NAnt.Compression.Tasks

NAnt SDK Documentation - v0.91

NAnt.Compression.Tasks Namespace

Namespace hierarchy

Classes

Class | Description
ExpandBaseTask | Summary description for ExpandTask.
GUnzip | Expands a file packed using GZip compression.
TarTask | Creates a tar file from the specified filesets.
UnTarTask | Extracts files from a tar archive.
UnZipTask | Extracts files from a zip archive.
ZipTask | Creates a zip file from the specified filesets.

Copyright (C) 2001-2011 Gerry Shaw


ExpandBaseTask Class

Summary description for ExpandTask.

For a list of all members of this type, see ExpandBaseTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Compression.Tasks.ExpandBaseTask
NAnt.Compression.Tasks.UnTarTask
NAnt.Compression.Tasks.UnZipTask

[Visual Basic]
MustInherit Public Class ExpandBaseTask
Inherits Task
[C#]
public abstract class ExpandBaseTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Compression.Tasks

Assembly: NAnt.CompressionTasks (in NAnt.CompressionTasks.dll)

See Also

ExpandBaseTask Members | NAnt.Compression.Tasks Namespace


ExpandBaseTask Members

ExpandBaseTask overview

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Overwrite | Overwrite files, even if they are newer than the corresponding entries in the archive. The default is true.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ExpandBaseTask Constructor Initializes a new instance of the ExpandBaseTask class.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask (inherited from Task) | Executes the task.
ExtractDirectory | Extracts a directory entry from the specified stream.
ExtractFile | Extracts a file entry from the specified stream.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpandBaseTask Class | NAnt.Compression.Tasks Namespace


ExpandBaseTask Constructor

Initializes a new instance of the ExpandBaseTask class.

[Visual Basic]
Protected Sub New()
[C#]
protected ExpandBaseTask();

See Also

ExpandBaseTask Class | NAnt.Compression.Tasks Namespace


ExpandBaseTask Properties

The properties of the ExpandBaseTask class are listed below. For a complete list of ExpandBaseTask class members, see the ExpandBaseTask Members topic.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Overwrite | Overwrite files, even if they are newer than the corresponding entries in the archive. The default is true.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

ExpandBaseTask Class | NAnt.Compression.Tasks Namespace


Overwrite Property

NAnt SDK Documentation - v0.91

ExpandBaseTask.Overwrite Property

Overwrite files, even if they are newer than the corresponding entries in the archive. The default is true.

[Visual Basic]
<TaskAttribute(Name:="overwrite", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property Overwrite As Boolean
[C#]
[TaskAttribute(Name="overwrite", Required=False, ExpandProperties=True, ProcessXml=True)]
public virtual bool Overwrite {get; set;}

See Also

ExpandBaseTask Class | NAnt.Compression.Tasks Namespace


ExpandBaseTask Methods

The methods of the ExpandBaseTask class are listed below. For a complete list of ExpandBaseTask class members, see the ExpandBaseTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask (inherited from Task) | Executes the task.
ExtractDirectory | Extracts a directory entry from the specified stream.
ExtractFile | Extracts a file entry from the specified stream.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpandBaseTask Class | NAnt.Compression.Tasks Namespace


ExpandBaseTask.ExtractDirectory Method

Extracts a directory entry from the specified stream.

[Visual Basic]
Protected Sub ExtractDirectory( _
ByVal inputStream As Stream, _
ByVal destDirectory As String, _
ByVal entryName As String, _
ByVal entryDate As Date _
)
[C#]
protected void ExtractDirectory(
Stream inputStream,
string destDirectory,
string entryName,
DateTime entryDate
);

Parameters

inputStream
The Stream containing the directory entry.
destDirectory
The directory where to create the subdirectory.
entryName
The name of the directory entry.
entryDate
The date of the entry.

Exceptions

Exception Type | Condition
BuildException | The destination directory for the entry could not be created.

See Also

ExpandBaseTask Class | NAnt.Compression.Tasks Namespace


ExpandBaseTask.ExtractFile Method

Extracts a file entry from the specified stream.

[Visual Basic]
Protected Sub ExtractFile( _
ByVal inputStream As Stream, _
ByVal destDirectory As String, _
ByVal entryName As String, _
ByVal entryDate As Date, _
ByVal entrySize As Long _
)
[C#]
protected void ExtractFile(
Stream inputStream,
string destDirectory,
string entryName,
DateTime entryDate,
long entrySize
);

Parameters

inputStream
The Stream containing the compressed entry.
destDirectory
The directory where to store the expanded file.
entryName
The name of the entry including directory information.
entryDate
The date of the entry.
entrySize
The uncompressed size of the entry.

Remarks

We cannot rely on the fact that the directory entry of a given file is created before the file is extracted, so we should create the directory if it doesn't yet exist.

Exceptions

Exception Type | Condition
BuildException | The destination directory for the entry could not be created. -or- The entry could not be extracted.

See Also

ExpandBaseTask Class | NAnt.Compression.Tasks Namespace


GUnzip Class

Expands a file packed using GZip compression.

For a list of all members of this type, see GUnzip Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Compression.Tasks.GUnzip

[Visual Basic]
<TaskName(Name:="gunzip")>
Public Class GUnzip
Inherits Task
[C#]
[TaskName(Name="gunzip")]
public class GUnzip : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Expands "test.tar.gz" to "test2.tar".

            <gunzip src="test.tar.gz" dest="test.tar" />

Requirements

Namespace: NAnt.Compression.Tasks

Assembly: NAnt.CompressionTasks (in NAnt.CompressionTasks.dll)

See Also

GUnzip Members | NAnt.Compression.Tasks Namespace


GUnzip Members

GUnzip overview

Public Instance Constructors

GUnzip Constructor Initializes a new instance of the GUnzip class.

Public Instance Properties

DestFile | The destination file.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
SrcFile | The file to expand.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Extracts the file from the gzip archive.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GUnzip Class | NAnt.Compression.Tasks Namespace


GUnzip Constructor

Initializes a new instance of the GUnzip class.

[Visual Basic]
Public Sub New()
[C#]
public GUnzip();

See Also

GUnzip Class | NAnt.Compression.Tasks Namespace


GUnzip Properties

The properties of the GUnzip class are listed below. For a complete list of GUnzip class members, see the GUnzip Members topic.

Public Instance Properties

DestFile | The destination file.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
SrcFile | The file to expand.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

GUnzip Class | NAnt.Compression.Tasks Namespace


DestFile Property

NAnt SDK Documentation - v0.91

GUnzip.DestFile Property

The destination file.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="dest", ExpandProperties:=True, ProcessXml:=True)>
Public Property DestFile As FileInfo
[C#]
[TaskAttribute(Required=True, Name="dest", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo DestFile {get; set;}

See Also

GUnzip Class | NAnt.Compression.Tasks Namespace


SrcFile Property

NAnt SDK Documentation - v0.91

GUnzip.SrcFile Property

The file to expand.

[Visual Basic]
<TaskAttribute(Name:="src", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property SrcFile As FileInfo
[C#]
[TaskAttribute(Name="src", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo SrcFile {get; set;}

See Also

GUnzip Class | NAnt.Compression.Tasks Namespace


GUnzip Methods

The methods of the GUnzip class are listed below. For a complete list of GUnzip class members, see the GUnzip Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Extracts the file from the gzip archive.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GUnzip Class | NAnt.Compression.Tasks Namespace


GUnzip.ExecuteTask Method

Extracts the file from the gzip archive.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

GUnzip Class | NAnt.Compression.Tasks Namespace


TarTask Class

Creates a tar file from the specified filesets.

For a list of all members of this type, see TarTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Compression.Tasks.TarTask

[Visual Basic]
<TaskName(Name:="tar")>
Public Class TarTask
Inherits Task
[C#]
[TaskName(Name="tar")]
public class TarTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Uses #ziplib (SharpZipLib), an open source Tar/Zip/GZip library written entirely in C#.

Example

Tar all files in ${build.dir} and ${doc.dir} into a file called "backup.tar.gz", and apply gzip compression to it.

            <tar destfile="backup.tar.gz" compression="GZip">
                <fileset basedir="${bin.dir}" prefix="bin">
                    <include name="**/*" />
                </fileset>
                <fileset basedir="${doc.dir}" prefix="doc">
                    <include name="**/*" />
                </fileset>
            </tar>

Requirements

Namespace: NAnt.Compression.Tasks

Assembly: NAnt.CompressionTasks (in NAnt.CompressionTasks.dll)

See Also

TarTask Members | NAnt.Compression.Tasks Namespace


TarTask Members

TarTask overview

Public Instance Constructors

TarTask Constructor Initializes a new instance of the TarTask class.

Public Instance Properties

CompressionMethod | The compression method. The default is None.
DestFile | The tar file to create.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IncludeEmptyDirs | Include empty directories in the generated tar file. The default is false.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
TarFileSets | The set of files to be included in the archive.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Creates the tar file.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TarTask Class | NAnt.Compression.Tasks Namespace


TarTask Constructor

Initializes a new instance of the TarTask class.

[Visual Basic]
Public Sub New()
[C#]
public TarTask();

See Also

TarTask Class | NAnt.Compression.Tasks Namespace


TarTask Properties

The properties of the TarTask class are listed below. For a complete list of TarTask class members, see the TarTask Members topic.

Public Instance Properties

CompressionMethod | The compression method. The default is None.
DestFile | The tar file to create.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IncludeEmptyDirs | Include empty directories in the generated tar file. The default is false.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
TarFileSets | The set of files to be included in the archive.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

TarTask Class | NAnt.Compression.Tasks Namespace


CompressionMethod Property

NAnt SDK Documentation - v0.91

TarTask.CompressionMethod Property

The compression method. The default is None.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="compression", ExpandProperties:=True, ProcessXml:=True)>
Public Property CompressionMethod As TarCompressionMethod
[C#]
[TaskAttribute(Required=False, Name="compression", ExpandProperties=True, ProcessXml=True)]
public NAnt.Compression.Types.TarCompressionMethod CompressionMethod {get; set;}

See Also

TarTask Class | NAnt.Compression.Tasks Namespace


DestFile Property

NAnt SDK Documentation - v0.91

TarTask.DestFile Property

The tar file to create.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="destfile", ExpandProperties:=True, ProcessXml:=True)>
Public Property DestFile As FileInfo
[C#]
[TaskAttribute(Required=True, Name="destfile", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo DestFile {get; set;}

See Also

TarTask Class | NAnt.Compression.Tasks Namespace


IncludeEmptyDirs Property

NAnt SDK Documentation - v0.91

TarTask.IncludeEmptyDirs Property

Include empty directories in the generated tar file. The default is false.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="includeemptydirs", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property IncludeEmptyDirs As Boolean
[C#]
[TaskAttribute(Required=False, Name="includeemptydirs", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool IncludeEmptyDirs {get; set;}

See Also

TarTask Class | NAnt.Compression.Tasks Namespace


TarFileSets Property

NAnt SDK Documentation - v0.91

TarTask.TarFileSets Property

The set of files to be included in the archive.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="fileset", Required:=False, ProcessXml:=True)>
Public ReadOnly Property TarFileSets As TarFileSetCollection
[C#]
[BuildElementArray(ElementType=null, Name="fileset", Required=False, ProcessXml=True)]
public NAnt.Compression.Types.TarFileSetCollection TarFileSets {get;}

See Also

TarTask Class | NAnt.Compression.Tasks Namespace


TarTask Methods

The methods of the TarTask class are listed below. For a complete list of TarTask class members, see the TarTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Creates the tar file.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TarTask Class | NAnt.Compression.Tasks Namespace


TarTask.ExecuteTask Method

Creates the tar file.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

TarTask Class | NAnt.Compression.Tasks Namespace


UnTarTask Class

Extracts files from a tar archive.

For a list of all members of this type, see UnTarTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Compression.Tasks.ExpandBaseTask
NAnt.Compression.Tasks.UnTarTask

[Visual Basic]
<TaskName(Name:="untar")>
Public Class UnTarTask
Inherits ExpandBaseTask
[C#]
[TaskName(Name="untar")]
public class UnTarTask : ExpandBaseTask

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Uses #ziplib (SharpZipLib), an open source Zip/GZip library written entirely in C#.

Example

Extracts all files from a gzipped tar, preserving the directory structure.

            <untar src="nant-bin.tar.gz" dest="bin" compression="gzip" />

Requirements

Namespace: NAnt.Compression.Tasks

Assembly: NAnt.CompressionTasks (in NAnt.CompressionTasks.dll)

See Also

UnTarTask Members | NAnt.Compression.Tasks Namespace


UnTarTask Members

UnTarTask overview

Public Instance Constructors

UnTarTask Constructor Initializes a new instance of the UnTarTask class.

Public Instance Properties

CompressionMethod | The compression method. The default is None.
DestinationDirectory | The directory where to store the expanded file(s). The default is the project base directory.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Overwrite (inherited from ExpandBaseTask) | Overwrite files, even if they are newer than the corresponding entries in the archive. The default is true.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
SrcFile | The archive file to expand.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Extracts the files from the archive.
ExtractDirectory (inherited from ExpandBaseTask) | Extracts a directory entry from the specified stream.
ExtractFile (inherited from ExpandBaseTask) | Extracts a file entry from the specified stream.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnTarTask Class | NAnt.Compression.Tasks Namespace


UnTarTask Constructor

Initializes a new instance of the UnTarTask class.

[Visual Basic]
Public Sub New()
[C#]
public UnTarTask();

See Also

UnTarTask Class | NAnt.Compression.Tasks Namespace


UnTarTask Properties

The properties of the UnTarTask class are listed below. For a complete list of UnTarTask class members, see the UnTarTask Members topic.

Public Instance Properties

CompressionMethod | The compression method. The default is None.
DestinationDirectory | The directory where to store the expanded file(s). The default is the project base directory.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Overwrite (inherited from ExpandBaseTask) | Overwrite files, even if they are newer than the corresponding entries in the archive. The default is true.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
SrcFile | The archive file to expand.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

UnTarTask Class | NAnt.Compression.Tasks Namespace


CompressionMethod Property

NAnt SDK Documentation - v0.91

UnTarTask.CompressionMethod Property

The compression method. The default is None.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="compression", ExpandProperties:=True, ProcessXml:=True)>
Public Property CompressionMethod As TarCompressionMethod
[C#]
[TaskAttribute(Required=False, Name="compression", ExpandProperties=True, ProcessXml=True)]
public NAnt.Compression.Types.TarCompressionMethod CompressionMethod {get; set;}

See Also

UnTarTask Class | NAnt.Compression.Tasks Namespace


DestinationDirectory Property

NAnt SDK Documentation - v0.91

UnTarTask.DestinationDirectory Property

The directory where to store the expanded file(s). The default is the project base directory.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="dest", ExpandProperties:=True, ProcessXml:=True)>
Public Property DestinationDirectory As DirectoryInfo
[C#]
[TaskAttribute(Required=False, Name="dest", ExpandProperties=True, ProcessXml=True)]
public System.IO.DirectoryInfo DestinationDirectory {get; set;}

See Also

UnTarTask Class | NAnt.Compression.Tasks Namespace


SrcFile Property

NAnt SDK Documentation - v0.91

UnTarTask.SrcFile Property

The archive file to expand.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="src", ExpandProperties:=True, ProcessXml:=True)>
Public Property SrcFile As FileInfo
[C#]
[TaskAttribute(Required=True, Name="src", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo SrcFile {get; set;}

See Also

UnTarTask Class | NAnt.Compression.Tasks Namespace


UnTarTask Methods

The methods of the UnTarTask class are listed below. For a complete list of UnTarTask class members, see the UnTarTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Extracts the files from the archive.
ExtractDirectory (inherited from ExpandBaseTask) | Extracts a directory entry from the specified stream.
ExtractFile (inherited from ExpandBaseTask) | Extracts a file entry from the specified stream.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnTarTask Class | NAnt.Compression.Tasks Namespace


UnTarTask.ExecuteTask Method

Extracts the files from the archive.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

UnTarTask Class | NAnt.Compression.Tasks Namespace


UnZipTask Class

Extracts files from a zip archive.

For a list of all members of this type, see UnZipTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Compression.Tasks.ExpandBaseTask
NAnt.Compression.Tasks.UnZipTask

[Visual Basic]
<TaskName(Name:="unzip")>
Public Class UnZipTask
Inherits ExpandBaseTask
[C#]
[TaskName(Name="unzip")]
public class UnZipTask : ExpandBaseTask

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Uses #ziplib (SharpZipLib), an open source Zip/GZip library written entirely in C#.

Example

Extracts all the file from the zip, preserving the directory structure.

            <unzip zipfile="backup.zip"/>

Requirements

Namespace: NAnt.Compression.Tasks

Assembly: NAnt.CompressionTasks (in NAnt.CompressionTasks.dll)

See Also

UnZipTask Members | NAnt.Compression.Tasks Namespace


UnZipTask Members

UnZipTask overview

Public Instance Constructors

UnZipTask Constructor Initializes a new instance of the UnZipTask class.

Public Instance Properties

Encoding | The character encoding that has been used for filenames inside the zip file. The default is the system's OEM code page.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Overwrite (inherited from ExpandBaseTask) | Overwrite files, even if they are newer than the corresponding entries in the archive. The default is true.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
ToDirectory | The directory where the expanded files should be stored. The default is the project base directory.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
ZipFile | The archive file to expand.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Extracts the files from the zip file.
ExtractDirectory (inherited from ExpandBaseTask) | Extracts a directory entry from the specified stream.
ExtractFile (inherited from ExpandBaseTask) | Extracts a file entry from the specified stream.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnZipTask Class | NAnt.Compression.Tasks Namespace


UnZipTask Constructor

Initializes a new instance of the UnZipTask class.

[Visual Basic]
Public Sub New()
[C#]
public UnZipTask();

See Also

UnZipTask Class | NAnt.Compression.Tasks Namespace


UnZipTask Properties

The properties of the UnZipTask class are listed below. For a complete list of UnZipTask class members, see the UnZipTask Members topic.

Public Instance Properties

Encoding | The character encoding that has been used for filenames inside the zip file. The default is the system's OEM code page.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Overwrite (inherited from ExpandBaseTask) | Overwrite files, even if they are newer than the corresponding entries in the archive. The default is true.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
ToDirectory | The directory where the expanded files should be stored. The default is the project base directory.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
ZipFile | The archive file to expand.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

UnZipTask Class | NAnt.Compression.Tasks Namespace


Encoding Property

NAnt SDK Documentation - v0.91

UnZipTask.Encoding Property

The character encoding that has been used for filenames inside the zip file. The default is the system's OEM code page.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="encoding", ExpandProperties:=True, ProcessXml:=True)>
Public Property Encoding As Encoding
[C#]
[TaskAttribute(Required=False, Name="encoding", ExpandProperties=True, ProcessXml=True)]
public System.Text.Encoding Encoding {get; set;}

See Also

UnZipTask Class | NAnt.Compression.Tasks Namespace


ToDirectory Property

NAnt SDK Documentation - v0.91

UnZipTask.ToDirectory Property

The directory where the expanded files should be stored. The default is the project base directory.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="todir", ExpandProperties:=True, ProcessXml:=True)>
Public Property ToDirectory As DirectoryInfo
[C#]
[TaskAttribute(Required=False, Name="todir", ExpandProperties=True, ProcessXml=True)]
public System.IO.DirectoryInfo ToDirectory {get; set;}

See Also

UnZipTask Class | NAnt.Compression.Tasks Namespace


ZipFile Property

NAnt SDK Documentation - v0.91

UnZipTask.ZipFile Property

The archive file to expand.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="zipfile", ExpandProperties:=True, ProcessXml:=True)>
Public Property ZipFile As FileInfo
[C#]
[TaskAttribute(Required=True, Name="zipfile", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo ZipFile {get; set;}

See Also

UnZipTask Class | NAnt.Compression.Tasks Namespace


UnZipTask Methods

The methods of the UnZipTask class are listed below. For a complete list of UnZipTask class members, see the UnZipTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Extracts the files from the zip file.
ExtractDirectory (inherited from ExpandBaseTask) | Extracts a directory entry from the specified stream.
ExtractFile (inherited from ExpandBaseTask) | Extracts a file entry from the specified stream.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnZipTask Class | NAnt.Compression.Tasks Namespace


UnZipTask.ExecuteTask Method

Extracts the files from the zip file.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

UnZipTask Class | NAnt.Compression.Tasks Namespace


ZipTask Class

Creates a zip file from the specified filesets.

For a list of all members of this type, see ZipTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Compression.Tasks.ZipTask

[Visual Basic]
<TaskName(Name:="zip")>
Public Class ZipTask
Inherits Task
[C#]
[TaskName(Name="zip")]
public class ZipTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Uses #ziplib (SharpZipLib), an open source Tar/Zip/GZip library written entirely in C#.

Example

Zip all files in ${build.dir} and ${doc.dir} into a file called "backup.zip".

            <zip zipfile="backup.zip">
                <fileset basedir="${bin.dir}" prefix="bin">
                    <include name="**/*" />
                </fileset>
                <fileset basedir="${doc.dir}" prefix="doc">
                    <include name="**/*" />
                </fileset>
            </zip>

Requirements

Namespace: NAnt.Compression.Tasks

Assembly: NAnt.CompressionTasks (in NAnt.CompressionTasks.dll)

See Also

ZipTask Members | NAnt.Compression.Tasks Namespace


ZipTask Members

ZipTask overview

Public Instance Constructors

ZipTask Constructor Initializes a new instance of the ZipTask class.

Public Instance Properties

Comment | The comment for the file.
DuplicateHandling | Specifies the behaviour when a duplicate file is found. The default is Add.
Encoding | The character encoding to use for filenames and comment inside the zip file. The default is the system's OEM code page.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IncludeEmptyDirs | Include empty directories in the generated zip file. The default is false.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Stamp | Date/time stamp for the files in the format MM/DD/YYYY HH:MM:SS.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
ZipFile | The zip file to create.
ZipFileSets | The set of files to be included in the archive.
ZipLevel | Desired level of compression. Possible values are 0 (STORE only) to 9 (highest). The default is 6.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Creates the zip file.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ZipTask Class | NAnt.Compression.Tasks Namespace


ZipTask Constructor

Initializes a new instance of the ZipTask class.

[Visual Basic]
Public Sub New()
[C#]
public ZipTask();

See Also

ZipTask Class | NAnt.Compression.Tasks Namespace


ZipTask Properties

The properties of the ZipTask class are listed below. For a complete list of ZipTask class members, see the ZipTask Members topic.

Public Instance Properties

Comment | The comment for the file.
DuplicateHandling | Specifies the behaviour when a duplicate file is found. The default is Add.
Encoding | The character encoding to use for filenames and comment inside the zip file. The default is the system's OEM code page.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IncludeEmptyDirs | Include empty directories in the generated zip file. The default is false.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Stamp | Date/time stamp for the files in the format MM/DD/YYYY HH:MM:SS.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
ZipFile | The zip file to create.
ZipFileSets | The set of files to be included in the archive.
ZipLevel | Desired level of compression. Possible values are 0 (STORE only) to 9 (highest). The default is 6.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

ZipTask Class | NAnt.Compression.Tasks Namespace


Comment Property

NAnt SDK Documentation - v0.91

ZipTask.Comment Property

The comment for the file.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="comment", ExpandProperties:=True, ProcessXml:=True)>
Public Property Comment As String
[C#]
[TaskAttribute(Required=False, Name="comment", ExpandProperties=True, ProcessXml=True)]
public string Comment {get; set;}

See Also

ZipTask Class | NAnt.Compression.Tasks Namespace


DuplicateHandling Property

NAnt SDK Documentation - v0.91

ZipTask.DuplicateHandling Property

Specifies the behaviour when a duplicate file is found. The default is Add.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="duplicate", ExpandProperties:=True, ProcessXml:=True)>
Public Property DuplicateHandling As DuplicateHandling
[C#]
[TaskAttribute(Required=False, Name="duplicate", ExpandProperties=True, ProcessXml=True)]
public NAnt.Compression.Types.DuplicateHandling DuplicateHandling {get; set;}

See Also

ZipTask Class | NAnt.Compression.Tasks Namespace


Encoding Property

NAnt SDK Documentation - v0.91

ZipTask.Encoding Property

The character encoding to use for filenames and comment inside the zip file. The default is the system's OEM code page.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="encoding", ExpandProperties:=True, ProcessXml:=True)>
Public Property Encoding As Encoding
[C#]
[TaskAttribute(Required=False, Name="encoding", ExpandProperties=True, ProcessXml=True)]
public System.Text.Encoding Encoding {get; set;}

See Also

ZipTask Class | NAnt.Compression.Tasks Namespace


IncludeEmptyDirs Property

NAnt SDK Documentation - v0.91

ZipTask.IncludeEmptyDirs Property

Include empty directories in the generated zip file. The default is false.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="includeemptydirs", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property IncludeEmptyDirs As Boolean
[C#]
[TaskAttribute(Required=False, Name="includeemptydirs", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool IncludeEmptyDirs {get; set;}

See Also

ZipTask Class | NAnt.Compression.Tasks Namespace


Stamp Property

NAnt SDK Documentation - v0.91

ZipTask.Stamp Property

Date/time stamp for the files in the format MM/DD/YYYY HH:MM:SS.

[Visual Basic]
<DateTimeValidator, _ TaskAttribute(Required:=False, Name:="stampdatetime", ExpandProperties:=True, ProcessXml:=True)>
Public Property Stamp As Date
[C#]
[DateTimeValidator]
[TaskAttribute(Required=False, Name="stampdatetime", ExpandProperties=True, ProcessXml=True)]
public System.DateTime Stamp {get; set;}

See Also

ZipTask Class | NAnt.Compression.Tasks Namespace


ZipFile Property

NAnt SDK Documentation - v0.91

ZipTask.ZipFile Property

The zip file to create.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="zipfile", ExpandProperties:=True, ProcessXml:=True)>
Public Property ZipFile As FileInfo
[C#]
[TaskAttribute(Required=True, Name="zipfile", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo ZipFile {get; set;}

See Also

ZipTask Class | NAnt.Compression.Tasks Namespace


ZipFileSets Property

NAnt SDK Documentation - v0.91

ZipTask.ZipFileSets Property

The set of files to be included in the archive.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="fileset", Required:=False, ProcessXml:=True)>
Public Property ZipFileSets As ZipFileSetCollection
[C#]
[BuildElementArray(ElementType=null, Name="fileset", Required=False, ProcessXml=True)]
public NAnt.Compression.Types.ZipFileSetCollection ZipFileSets {get; set;}

See Also

ZipTask Class | NAnt.Compression.Tasks Namespace


ZipLevel Property

NAnt SDK Documentation - v0.91

ZipTask.ZipLevel Property

Desired level of compression. Possible values are 0 (STORE only) to 9 (highest). The default is 6.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="ziplevel", ExpandProperties:=True, ProcessXml:=True), _ Int32Validator(MinValue:=0, MaxValue:=9, Base:=10)>
Public Property ZipLevel As Integer
[C#]
[TaskAttribute(Required=False, Name="ziplevel", ExpandProperties=True, ProcessXml=True)]
[Int32Validator(MinValue=0, MaxValue=9, Base=10)]
public int ZipLevel {get; set;}

See Also

ZipTask Class | NAnt.Compression.Tasks Namespace


ZipTask Methods

The methods of the ZipTask class are listed below. For a complete list of ZipTask class members, see the ZipTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Creates the zip file.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ZipTask Class | NAnt.Compression.Tasks Namespace


ZipTask.ExecuteTask Method

Creates the zip file.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

ZipTask Class | NAnt.Compression.Tasks Namespace


NAnt.Compression.Types

NAnt SDK Documentation - v0.91

NAnt.Compression.Types Namespace

Namespace hierarchy

Classes

Class | Description
TarFileSet | A TarFileSet is a FileSet with extra attributes useful in the context of the TarTask.
TarFileSetCollection | Contains a collection of TarFileSet elements.
TarFileSetEnumerator | Enumerates the TarFileSet elements of a TarFileSetCollection.
ZipFileSet | A ZipFileSet is a FileSet with extra attributes useful in the context of the ZipTask.
ZipFileSetCollection | Contains a collection of ZipFileSet elements.
ZipFileSetEnumerator | Enumerates the ZipFileSet elements of a ZipFileSetCollection.

Enumerations

Enumeration | Description
DuplicateHandling | Specifies how entries with the same name should be processed.
TarCompressionMethod | Specifies the compression methods supported by TarTask and UnTarTask.


DuplicateHandling Enumeration

Specifies how entries with the same name should be processed.

[Visual Basic]
<Serializable, _ TypeConverter(ConverterTypeName:="NAnt.Compression.Types.DuplicateHandlingConverter, NAnt.CompressionTasks, Version=0.91.4312.0, Culture=neutral, PublicKeyToken=null")>
Public Enum DuplicateHandling
[C#]
[Serializable]
[TypeConverter(ConverterTypeName="NAnt.Compression.Types.DuplicateHandlingConverter, NAnt.CompressionTasks, Version=0.91.4312.0, Culture=neutral, PublicKeyToken=null")]
public enum DuplicateHandling

Members

Member Name | Description
Add | Overwrite existing entry with same name.
Preserve | Preserve existing entry with the same name.
Fail | Report failure when two entries have the same name.

Requirements

Namespace: NAnt.Compression.Types

Assembly: NAnt.CompressionTasks (in NAnt.CompressionTasks.dll)

See Also

NAnt.Compression.Types Namespace


TarCompressionMethod Enumeration

Specifies the compression methods supported by TarTask and UnTarTask.

[Visual Basic]
<Serializable, _ TypeConverter(ConverterTypeName:="NAnt.Compression.Types.TarCompressionMethodConverter, NAnt.CompressionTasks, Version=0.91.4312.0, Culture=neutral, PublicKeyToken=null")>
Public Enum TarCompressionMethod
[C#]
[Serializable]
[TypeConverter(ConverterTypeName="NAnt.Compression.Types.TarCompressionMethodConverter, NAnt.CompressionTasks, Version=0.91.4312.0, Culture=neutral, PublicKeyToken=null")]
public enum TarCompressionMethod

Members

Member Name | Description
None | No compression.
GZip | GZIP compression.
BZip2 | BZIP2 compression.

Requirements

Namespace: NAnt.Compression.Types

Assembly: NAnt.CompressionTasks (in NAnt.CompressionTasks.dll)

See Also

NAnt.Compression.Types Namespace


TarFileSet Class

A TarFileSet is a FileSet with extra attributes useful in the context of the TarTask.

For a list of all members of this type, see TarFileSet Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.Core.Types.FileSet
NAnt.Compression.Types.TarFileSet

[Visual Basic]
<ElementName(Name:="tarfileset")>
Public Class TarFileSet
Inherits FileSet
[C#]
[ElementName(Name="tarfileset")]
public class TarFileSet : FileSet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Compression.Types

Assembly: NAnt.CompressionTasks (in NAnt.CompressionTasks.dll)

See Also

TarFileSet Members | NAnt.Compression.Types Namespace


TarFileSet Members

TarFileSet overview

Public Instance Constructors

TarFileSet Constructor Initializes a new instance of the TarFileSet class.

Public Instance Properties

AsIs (inherited from FileSet) | Gets the collection of files that will be added to the FileSet without pattern matching or checking if the file exists.
BaseDirectory (inherited from FileSet) | The base of the directory of this fileset. The default is the project base directory.
CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
CaseSensitive (inherited from FileSet) | Indicates whether include and exclude patterns must be treated in a case-sensitive way. The default is true on Unix; otherwise, false.
DefaultExcludes (inherited from FileSet) | Indicates whether default excludes should be used or not. The default is true.
DirectoryNames (inherited from FileSet) | Gets the collection of directory names that match the fileset.
DirMode | A 3 digit octal string, specify the user, group and other modes in the standard Unix fashion. Only applies to directories. The default is 755.
ExcludeElements (inherited from FileSet) | The items to exclude from the fileset.
Excludes (inherited from FileSet) | Gets the collection of exclude patterns.
ExcludesFiles (inherited from FileSet) | The files from which a list of patterns or files to exclude should be obtained.
FailOnEmpty (inherited from FileSet) | When set to true, causes the fileset element to throw a ValidationException when no files match the includes and excludes criteria. The default is false.
FileMode | A 3 digit octal string, specify the user, group and other modes in the standard Unix fashion. Only applies to plain files. The default is 644.
FileNames (inherited from FileSet) | Gets the collection of file names that match the fileset.
Gid | The group identifier (GID) for the tar entry.
GroupName | The groupname for the tar entry.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IncludeElements (inherited from FileSet) | The items to include in the fileset.
Includes (inherited from FileSet) | Gets the collection of include patterns.
IncludesFiles (inherited from FileSet) | The files from which a list of patterns or files to include should be obtained.
MostRecentLastWriteTimeFile (inherited from FileSet) | Determines the most recently modified file in the fileset (by LastWriteTime of the FileInfo).
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PathFiles (inherited from FileSet) |
Prefix | The top level directory prefix. If set, all file and directory paths in the fileset will have this value prepended. Can either be a single directory name or a "/" separated path.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.
ScannedDirectories (inherited from FileSet) | Gets the collection of directory names that were scanned for files.
SetExcludes (inherited from FileSet) | Obsolete. The items to exclude from the fileset.
SetIncludes (inherited from FileSet) | Obsolete. The items to include in the fileset.
SetIncludesList (inherited from FileSet) | Obsolete. The files from which a list of patterns or files to include should be obtained.
Uid | The user identifier (UID) for the tar entry.
UserName | The username for the tar entry.

Public Instance Methods

AddPatternSet (inherited from FileSet) | Adds a nested set of patterns, or references a standalone patternset.
Clone (inherited from FileSet) | Creates a shallow copy of the FileSet.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from FileSet) |
Scan (inherited from FileSet) |
ToString (inherited from FileSet) |

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from FileSet) | Overloaded. Copies all instance data of the FileSet to a given FileSet.
CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from FileSet) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TarFileSet Class | NAnt.Compression.Types Namespace


TarFileSet Constructor

Initializes a new instance of the TarFileSet class.

[Visual Basic]
Public Sub New()
[C#]
public TarFileSet();

See Also

TarFileSet Class | NAnt.Compression.Types Namespace


TarFileSet Properties

The properties of the TarFileSet class are listed below. For a complete list of TarFileSet class members, see the TarFileSet Members topic.

Public Instance Properties

AsIs (inherited from FileSet) | Gets the collection of files that will be added to the FileSet without pattern matching or checking if the file exists.
BaseDirectory (inherited from FileSet) | The base of the directory of this fileset. The default is the project base directory.
CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
CaseSensitive (inherited from FileSet) | Indicates whether include and exclude patterns must be treated in a case-sensitive way. The default is true on Unix; otherwise, false.
DefaultExcludes (inherited from FileSet) | Indicates whether default excludes should be used or not. The default is true.
DirectoryNames (inherited from FileSet) | Gets the collection of directory names that match the fileset.
DirMode | A 3 digit octal string, specify the user, group and other modes in the standard Unix fashion. Only applies to directories. The default is 755.
ExcludeElements (inherited from FileSet) | The items to exclude from the fileset.
Excludes (inherited from FileSet) | Gets the collection of exclude patterns.
ExcludesFiles (inherited from FileSet) | The files from which a list of patterns or files to exclude should be obtained.
FailOnEmpty (inherited from FileSet) | When set to true, causes the fileset element to throw a ValidationException when no files match the includes and excludes criteria. The default is false.
FileMode | A 3 digit octal string, specify the user, group and other modes in the standard Unix fashion. Only applies to plain files. The default is 644.
FileNames (inherited from FileSet) | Gets the collection of file names that match the fileset.
Gid | The group identifier (GID) for the tar entry.
GroupName | The groupname for the tar entry.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IncludeElements (inherited from FileSet) | The items to include in the fileset.
Includes (inherited from FileSet) | Gets the collection of include patterns.
IncludesFiles (inherited from FileSet) | The files from which a list of patterns or files to include should be obtained.
MostRecentLastWriteTimeFile (inherited from FileSet) | Determines the most recently modified file in the fileset (by LastWriteTime of the FileInfo).
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PathFiles (inherited from FileSet) |
Prefix | The top level directory prefix. If set, all file and directory paths in the fileset will have this value prepended. Can either be a single directory name or a "/" separated path.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.
ScannedDirectories (inherited from FileSet) | Gets the collection of directory names that were scanned for files.
SetExcludes (inherited from FileSet) | Obsolete. The items to exclude from the fileset.
SetIncludes (inherited from FileSet) | Obsolete. The items to include in the fileset.
SetIncludesList (inherited from FileSet) | Obsolete. The files from which a list of patterns or files to include should be obtained.
Uid | The user identifier (UID) for the tar entry.
UserName | The username for the tar entry.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

TarFileSet Class | NAnt.Compression.Types Namespace


DirMode Property

NAnt SDK Documentation - v0.91

TarFileSet.DirMode Property

A 3 digit octal string, specify the user, group and other modes in the standard Unix fashion. Only applies to directories. The default is 755.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="dirmode", ExpandProperties:=True, ProcessXml:=True)>
Public Property DirMode As Integer
[C#]
[TaskAttribute(Required=False, Name="dirmode", ExpandProperties=True, ProcessXml=True)]
public int DirMode {get; set;}

See Also

TarFileSet Class | NAnt.Compression.Types Namespace


FileMode Property

NAnt SDK Documentation - v0.91

TarFileSet.FileMode Property

A 3 digit octal string, specify the user, group and other modes in the standard Unix fashion. Only applies to plain files. The default is 644.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="filemode", ExpandProperties:=True, ProcessXml:=True)>
Public Property FileMode As Integer
[C#]
[TaskAttribute(Required=False, Name="filemode", ExpandProperties=True, ProcessXml=True)]
public int FileMode {get; set;}

See Also

TarFileSet Class | NAnt.Compression.Types Namespace


Gid Property

NAnt SDK Documentation - v0.91

TarFileSet.Gid Property

The group identifier (GID) for the tar entry.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="gid", ExpandProperties:=True, ProcessXml:=True)>
Public Property Gid As Integer
[C#]
[TaskAttribute(Required=False, Name="gid", ExpandProperties=True, ProcessXml=True)]
public int Gid {get; set;}

See Also

TarFileSet Class | NAnt.Compression.Types Namespace


GroupName Property

NAnt SDK Documentation - v0.91

TarFileSet.GroupName Property

The groupname for the tar entry.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="groupname", ExpandProperties:=True, ProcessXml:=True)>
Public Property GroupName As String
[C#]
[TaskAttribute(Required=False, Name="groupname", ExpandProperties=True, ProcessXml=True)]
public string GroupName {get; set;}

See Also

TarFileSet Class | NAnt.Compression.Types Namespace


Prefix Property

NAnt SDK Documentation - v0.91

TarFileSet.Prefix Property

The top level directory prefix. If set, all file and directory paths in the fileset will have this value prepended. Can either be a single directory name or a "/" separated path.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="prefix", ExpandProperties:=True, ProcessXml:=True)>
Public Property Prefix As String
[C#]
[TaskAttribute(Required=False, Name="prefix", ExpandProperties=True, ProcessXml=True)]
public string Prefix {get; set;}

See Also

TarFileSet Class | NAnt.Compression.Types Namespace


Uid Property

NAnt SDK Documentation - v0.91

TarFileSet.Uid Property

The user identifier (UID) for the tar entry.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="uid", ExpandProperties:=True, ProcessXml:=True)>
Public Property Uid As Integer
[C#]
[TaskAttribute(Required=False, Name="uid", ExpandProperties=True, ProcessXml=True)]
public int Uid {get; set;}

See Also

TarFileSet Class | NAnt.Compression.Types Namespace


UserName Property

NAnt SDK Documentation - v0.91

TarFileSet.UserName Property

The username for the tar entry.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="username", ExpandProperties:=True, ProcessXml:=True)>
Public Property UserName As String
[C#]
[TaskAttribute(Required=False, Name="username", ExpandProperties=True, ProcessXml=True)]
public string UserName {get; set;}

See Also

TarFileSet Class | NAnt.Compression.Types Namespace


TarFileSetCollection Class

Contains a collection of TarFileSet elements.

For a list of all members of this type, see TarFileSetCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.Compression.Types.TarFileSetCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class TarFileSetCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class TarFileSetCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Compression.Types

Assembly: NAnt.CompressionTasks (in NAnt.CompressionTasks.dll)

See Also

TarFileSetCollection Members | NAnt.Compression.Types Namespace


TarFileSetCollection Members

TarFileSetCollection overview

Public Instance Constructors

TarFileSetCollection Overloaded. Initializes a new instance of the TarFileSetCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
FileCount | Get the total number of files that are represented by the filesets in this collection.
Item | Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a TarFileSet to the end of the collection.
AddRange | Overloaded. Adds the elements of a TarFileSet array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a TarFileSet is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified TarFileSet object in the collection.
Insert | Inserts a TarFileSet into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

TarFileSetCollection Class | NAnt.Compression.Types Namespace


TarFileSetCollection Constructor

Initializes a new instance of the TarFileSetCollection class.

Overload List

Initializes a new instance of the TarFileSetCollection class.

public TarFileSetCollection();

Initializes a new instance of the TarFileSetCollection class with the specified array of TarFileSet instances.

public TarFileSetCollection(TarFileSet[]);

Initializes a new instance of the TarFileSetCollection class with the specified TarFileSetCollection instance.

public TarFileSetCollection(TarFileSetCollection);

See Also

TarFileSetCollection Class | NAnt.Compression.Types Namespace


TarFileSetCollection Constructor ()

Initializes a new instance of the TarFileSetCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public TarFileSetCollection();

See Also

TarFileSetCollection Class | NAnt.Compression.Types Namespace | TarFileSetCollection Constructor Overload List


TarFileSetCollection Constructor (TarFileSetCollection)

Initializes a new instance of the TarFileSetCollection class with the specified TarFileSetCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As TarFileSetCollection _
)
[C#]
public TarFileSetCollection(
TarFileSetCollection value
);

See Also

TarFileSetCollection Class | NAnt.Compression.Types Namespace | TarFileSetCollection Constructor Overload List


TarFileSetCollection Constructor (TarFileSet[])

Initializes a new instance of the TarFileSetCollection class with the specified array of TarFileSet instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As TarFileSet() _
)
[C#]
public TarFileSetCollection(
TarFileSet[] value
);

See Also

TarFileSetCollection Class | NAnt.Compression.Types Namespace | TarFileSetCollection Constructor Overload List


TarFileSetCollection Properties

The properties of the TarFileSetCollection class are listed below. For a complete list of TarFileSetCollection class members, see the TarFileSetCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
FileCount | Get the total number of files that are represented by the filesets in this collection.
Item | Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

TarFileSetCollection Class | NAnt.Compression.Types Namespace


FileCount Property

NAnt SDK Documentation - v0.91

TarFileSetCollection.FileCount Property

Get the total number of files that are represented by the filesets in this collection.

[Visual Basic]
Public ReadOnly Property FileCount As Integer
[C#]
public int FileCount {get;}

See Also

TarFileSetCollection Class | NAnt.Compression.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

TarFileSetCollection.Item Property

Gets or sets the element at the specified index.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As TarFileSet
[C#]
public TarFileSet this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

TarFileSetCollection Class | NAnt.Compression.Types Namespace


TarFileSetCollection Methods

The methods of the TarFileSetCollection class are listed below. For a complete list of TarFileSetCollection class members, see the TarFileSetCollection Members topic.

Public Instance Methods

Add | Adds a TarFileSet to the end of the collection.
AddRange | Overloaded. Adds the elements of a TarFileSet array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a TarFileSet is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified TarFileSet object in the collection.
Insert | Inserts a TarFileSet into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

TarFileSetCollection Class | NAnt.Compression.Types Namespace


TarFileSetCollection.Add Method

Adds a TarFileSet to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As TarFileSet _
) As Integer
[C#]
public int Add(
TarFileSet item
);

Parameters

item
The TarFileSet to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

TarFileSetCollection Class | NAnt.Compression.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

TarFileSetCollection.AddRange Method

Adds the elements of a TarFileSet array to the end of the collection.

Overload List

Adds the elements of a TarFileSet array to the end of the collection.

public void AddRange(TarFileSet[]);

Adds the elements of a TarFileSetCollection to the end of the collection.

public void AddRange(TarFileSetCollection);

See Also

TarFileSetCollection Class | NAnt.Compression.Types Namespace


TarFileSetCollection.AddRange Method (TarFileSet[])

Adds the elements of a TarFileSet array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As TarFileSet() _
)
[C#]
public void AddRange(
TarFileSet[] items
);

Parameters

items
The array of TarFileSet elements to be added to the end of the collection.

See Also

TarFileSetCollection Class | NAnt.Compression.Types Namespace | TarFileSetCollection.AddRange Overload List


TarFileSetCollection.AddRange Method (TarFileSetCollection)

Adds the elements of a TarFileSetCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As TarFileSetCollection _
)
[C#]
public void AddRange(
TarFileSetCollection items
);

Parameters

items
The TarFileSetCollection to be added to the end of the collection.

See Also

TarFileSetCollection Class | NAnt.Compression.Types Namespace | TarFileSetCollection.AddRange Overload List


TarFileSetCollection.Contains Method

Determines whether a TarFileSet is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal item As TarFileSet _
) As Boolean
[C#]
public bool Contains(
TarFileSet item
);

Parameters

item
The TarFileSet to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

TarFileSetCollection Class | NAnt.Compression.Types Namespace


TarFileSetCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As TarFileSet(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
TarFileSet[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

TarFileSetCollection Class | NAnt.Compression.Types Namespace


TarFileSetCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As TarFileSetEnumerator
[C#]
new public TarFileSetEnumerator GetEnumerator();

Return Value

A TarFileSetEnumerator for the entire collection.

See Also

TarFileSetCollection Class | NAnt.Compression.Types Namespace


TarFileSetCollection.IndexOf Method

Retrieves the index of a specified TarFileSet object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As TarFileSet _
) As Integer
[C#]
public int IndexOf(
TarFileSet item
);

Parameters

item
The TarFileSet object for which the index is returned.

Return Value

The index of the specified TarFileSet. If the TarFileSet is not currently a member of the collection, it returns -1.

See Also

TarFileSetCollection Class | NAnt.Compression.Types Namespace


TarFileSetCollection.Insert Method

Inserts a TarFileSet into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As TarFileSet _
)
[C#]
public void Insert(
int index,
TarFileSet item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The TarFileSet to insert.

See Also

TarFileSetCollection Class | NAnt.Compression.Types Namespace


TarFileSetCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As TarFileSet _
)
[C#]
public void Remove(
TarFileSet item
);

Parameters

item
The TarFileSet to remove from the collection.

See Also

TarFileSetCollection Class | NAnt.Compression.Types Namespace


TarFileSetEnumerator Class

Enumerates the TarFileSet elements of a TarFileSetCollection.

For a list of all members of this type, see TarFileSetEnumerator Members.

System.Object
NAnt.Compression.Types.TarFileSetEnumerator

[Visual Basic]
Public Class TarFileSetEnumerator
Implements IEnumerator
[C#]
public class TarFileSetEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Compression.Types

Assembly: NAnt.CompressionTasks (in NAnt.CompressionTasks.dll)

See Also

TarFileSetEnumerator Members | NAnt.Compression.Types Namespace


TarFileSetEnumerator Members

TarFileSetEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TarFileSetEnumerator Class | NAnt.Compression.Types Namespace


TarFileSetEnumerator Properties

The properties of the TarFileSetEnumerator class are listed below. For a complete list of TarFileSetEnumerator class members, see the TarFileSetEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

TarFileSetEnumerator Class | NAnt.Compression.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

TarFileSetEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As TarFileSet
[C#]
public TarFileSet Current {get;}

See Also

TarFileSetEnumerator Class | NAnt.Compression.Types Namespace


TarFileSetEnumerator Methods

The methods of the TarFileSetEnumerator class are listed below. For a complete list of TarFileSetEnumerator class members, see the TarFileSetEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TarFileSetEnumerator Class | NAnt.Compression.Types Namespace


TarFileSetEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

TarFileSetEnumerator Class | NAnt.Compression.Types Namespace


TarFileSetEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

TarFileSetEnumerator Class | NAnt.Compression.Types Namespace


ZipFileSet Class

A ZipFileSet is a FileSet with extra attributes useful in the context of the ZipTask.

For a list of all members of this type, see ZipFileSet Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.Core.Types.FileSet
NAnt.Compression.Types.ZipFileSet

[Visual Basic]
<ElementName(Name:="zipfileset")>
Public Class ZipFileSet
Inherits FileSet
[C#]
[ElementName(Name="zipfileset")]
public class ZipFileSet : FileSet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Compression.Types

Assembly: NAnt.CompressionTasks (in NAnt.CompressionTasks.dll)

See Also

ZipFileSet Members | NAnt.Compression.Types Namespace


ZipFileSet Members

ZipFileSet overview

Public Instance Constructors

ZipFileSet Constructor Initializes a new instance of the ZipFileSet class.

Public Instance Properties

AsIs (inherited from FileSet) | Gets the collection of files that will be added to the FileSet without pattern matching or checking if the file exists.
BaseDirectory (inherited from FileSet) | The base of the directory of this fileset. The default is the project base directory.
CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
CaseSensitive (inherited from FileSet) | Indicates whether include and exclude patterns must be treated in a case-sensitive way. The default is true on Unix; otherwise, false.
DefaultExcludes (inherited from FileSet) | Indicates whether default excludes should be used or not. The default is true.
DirectoryNames (inherited from FileSet) | Gets the collection of directory names that match the fileset.
ExcludeElements (inherited from FileSet) | The items to exclude from the fileset.
Excludes (inherited from FileSet) | Gets the collection of exclude patterns.
ExcludesFiles (inherited from FileSet) | The files from which a list of patterns or files to exclude should be obtained.
FailOnEmpty (inherited from FileSet) | When set to true, causes the fileset element to throw a ValidationException when no files match the includes and excludes criteria. The default is false.
FileNames (inherited from FileSet) | Gets the collection of file names that match the fileset.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IncludeElements (inherited from FileSet) | The items to include in the fileset.
Includes (inherited from FileSet) | Gets the collection of include patterns.
IncludesFiles (inherited from FileSet) | The files from which a list of patterns or files to include should be obtained.
MostRecentLastWriteTimeFile (inherited from FileSet) | Determines the most recently modified file in the fileset (by LastWriteTime of the FileInfo).
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PathFiles (inherited from FileSet) |
Prefix | The top level directory prefix. If set, all file and directory paths in the fileset will have this value prepended. Can either be a single directory name or a "/" separated path.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.
ScannedDirectories (inherited from FileSet) | Gets the collection of directory names that were scanned for files.
SetExcludes (inherited from FileSet) | Obsolete. The items to exclude from the fileset.
SetIncludes (inherited from FileSet) | Obsolete. The items to include in the fileset.
SetIncludesList (inherited from FileSet) | Obsolete. The files from which a list of patterns or files to include should be obtained.

Public Instance Methods

AddPatternSet (inherited from FileSet) | Adds a nested set of patterns, or references a standalone patternset.
Clone (inherited from FileSet) | Creates a shallow copy of the FileSet.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from FileSet) |
Scan (inherited from FileSet) |
ToString (inherited from FileSet) |

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from FileSet) | Overloaded. Copies all instance data of the FileSet to a given FileSet.
CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from FileSet) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ZipFileSet Class | NAnt.Compression.Types Namespace


ZipFileSet Constructor

Initializes a new instance of the ZipFileSet class.

[Visual Basic]
Public Sub New()
[C#]
public ZipFileSet();

See Also

ZipFileSet Class | NAnt.Compression.Types Namespace


ZipFileSet Properties

The properties of the ZipFileSet class are listed below. For a complete list of ZipFileSet class members, see the ZipFileSet Members topic.

Public Instance Properties

AsIs (inherited from FileSet) | Gets the collection of files that will be added to the FileSet without pattern matching or checking if the file exists.
BaseDirectory (inherited from FileSet) | The base of the directory of this fileset. The default is the project base directory.
CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
CaseSensitive (inherited from FileSet) | Indicates whether include and exclude patterns must be treated in a case-sensitive way. The default is true on Unix; otherwise, false.
DefaultExcludes (inherited from FileSet) | Indicates whether default excludes should be used or not. The default is true.
DirectoryNames (inherited from FileSet) | Gets the collection of directory names that match the fileset.
ExcludeElements (inherited from FileSet) | The items to exclude from the fileset.
Excludes (inherited from FileSet) | Gets the collection of exclude patterns.
ExcludesFiles (inherited from FileSet) | The files from which a list of patterns or files to exclude should be obtained.
FailOnEmpty (inherited from FileSet) | When set to true, causes the fileset element to throw a ValidationException when no files match the includes and excludes criteria. The default is false.
FileNames (inherited from FileSet) | Gets the collection of file names that match the fileset.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IncludeElements (inherited from FileSet) | The items to include in the fileset.
Includes (inherited from FileSet) | Gets the collection of include patterns.
IncludesFiles (inherited from FileSet) | The files from which a list of patterns or files to include should be obtained.
MostRecentLastWriteTimeFile (inherited from FileSet) | Determines the most recently modified file in the fileset (by LastWriteTime of the FileInfo).
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PathFiles (inherited from FileSet) |
Prefix | The top level directory prefix. If set, all file and directory paths in the fileset will have this value prepended. Can either be a single directory name or a "/" separated path.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.
ScannedDirectories (inherited from FileSet) | Gets the collection of directory names that were scanned for files.
SetExcludes (inherited from FileSet) | Obsolete. The items to exclude from the fileset.
SetIncludes (inherited from FileSet) | Obsolete. The items to include in the fileset.
SetIncludesList (inherited from FileSet) | Obsolete. The files from which a list of patterns or files to include should be obtained.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

ZipFileSet Class | NAnt.Compression.Types Namespace


Prefix Property

NAnt SDK Documentation - v0.91

ZipFileSet.Prefix Property

The top level directory prefix. If set, all file and directory paths in the fileset will have this value prepended. Can either be a single directory name or a "/" separated path.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="prefix", ExpandProperties:=True, ProcessXml:=True)>
Public Property Prefix As String
[C#]
[TaskAttribute(Required=False, Name="prefix", ExpandProperties=True, ProcessXml=True)]
public string Prefix {get; set;}

See Also

ZipFileSet Class | NAnt.Compression.Types Namespace


ZipFileSetCollection Class

Contains a collection of ZipFileSet elements.

For a list of all members of this type, see ZipFileSetCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.Compression.Types.ZipFileSetCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class ZipFileSetCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class ZipFileSetCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Compression.Types

Assembly: NAnt.CompressionTasks (in NAnt.CompressionTasks.dll)

See Also

ZipFileSetCollection Members | NAnt.Compression.Types Namespace


ZipFileSetCollection Members

ZipFileSetCollection overview

Public Instance Constructors

ZipFileSetCollection Overloaded. Initializes a new instance of the ZipFileSetCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
FileCount | Get the total number of files that are represented by the filesets in this collection.
Item | Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a ZipFileSet to the end of the collection.
AddRange | Overloaded. Adds the elements of a ZipFileSet array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a ZipFileSet is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified ZipFileSet object in the collection.
Insert | Inserts a ZipFileSet into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

ZipFileSetCollection Class | NAnt.Compression.Types Namespace


ZipFileSetCollection Constructor

Initializes a new instance of the ZipFileSetCollection class.

Overload List

Initializes a new instance of the ZipFileSetCollection class.

public ZipFileSetCollection();

Initializes a new instance of the ZipFileSetCollection class with the specified array of ZipFileSet instances.

public ZipFileSetCollection(ZipFileSet[]);

Initializes a new instance of the ZipFileSetCollection class with the specified ZipFileSetCollection instance.

public ZipFileSetCollection(ZipFileSetCollection);

See Also

ZipFileSetCollection Class | NAnt.Compression.Types Namespace


ZipFileSetCollection Constructor ()

Initializes a new instance of the ZipFileSetCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ZipFileSetCollection();

See Also

ZipFileSetCollection Class | NAnt.Compression.Types Namespace | ZipFileSetCollection Constructor Overload List


ZipFileSetCollection Constructor (ZipFileSetCollection)

Initializes a new instance of the ZipFileSetCollection class with the specified ZipFileSetCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As ZipFileSetCollection _
)
[C#]
public ZipFileSetCollection(
ZipFileSetCollection value
);

See Also

ZipFileSetCollection Class | NAnt.Compression.Types Namespace | ZipFileSetCollection Constructor Overload List


ZipFileSetCollection Constructor (ZipFileSet[])

Initializes a new instance of the ZipFileSetCollection class with the specified array of ZipFileSet instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As ZipFileSet() _
)
[C#]
public ZipFileSetCollection(
ZipFileSet[] value
);

See Also

ZipFileSetCollection Class | NAnt.Compression.Types Namespace | ZipFileSetCollection Constructor Overload List


ZipFileSetCollection Properties

The properties of the ZipFileSetCollection class are listed below. For a complete list of ZipFileSetCollection class members, see the ZipFileSetCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
FileCount | Get the total number of files that are represented by the filesets in this collection.
Item | Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

ZipFileSetCollection Class | NAnt.Compression.Types Namespace


FileCount Property

NAnt SDK Documentation - v0.91

ZipFileSetCollection.FileCount Property

Get the total number of files that are represented by the filesets in this collection.

[Visual Basic]
Public ReadOnly Property FileCount As Integer
[C#]
public int FileCount {get;}

See Also

ZipFileSetCollection Class | NAnt.Compression.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

ZipFileSetCollection.Item Property

Gets or sets the element at the specified index.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As ZipFileSet
[C#]
public ZipFileSet this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

ZipFileSetCollection Class | NAnt.Compression.Types Namespace


ZipFileSetCollection Methods

The methods of the ZipFileSetCollection class are listed below. For a complete list of ZipFileSetCollection class members, see the ZipFileSetCollection Members topic.

Public Instance Methods

Add | Adds a ZipFileSet to the end of the collection.
AddRange | Overloaded. Adds the elements of a ZipFileSet array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a ZipFileSet is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified ZipFileSet object in the collection.
Insert | Inserts a ZipFileSet into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

ZipFileSetCollection Class | NAnt.Compression.Types Namespace


ZipFileSetCollection.Add Method

Adds a ZipFileSet to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As ZipFileSet _
) As Integer
[C#]
public int Add(
ZipFileSet item
);

Parameters

item
The ZipFileSet to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

ZipFileSetCollection Class | NAnt.Compression.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

ZipFileSetCollection.AddRange Method

Adds the elements of a ZipFileSet array to the end of the collection.

Overload List

Adds the elements of a ZipFileSet array to the end of the collection.

public void AddRange(ZipFileSet[]);

Adds the elements of a ZipFileSetCollection to the end of the collection.

public void AddRange(ZipFileSetCollection);

See Also

ZipFileSetCollection Class | NAnt.Compression.Types Namespace


ZipFileSetCollection.AddRange Method (ZipFileSet[])

Adds the elements of a ZipFileSet array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As ZipFileSet() _
)
[C#]
public void AddRange(
ZipFileSet[] items
);

Parameters

items
The array of ZipFileSet elements to be added to the end of the collection.

See Also

ZipFileSetCollection Class | NAnt.Compression.Types Namespace | ZipFileSetCollection.AddRange Overload List


ZipFileSetCollection.AddRange Method (ZipFileSetCollection)

Adds the elements of a ZipFileSetCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As ZipFileSetCollection _
)
[C#]
public void AddRange(
ZipFileSetCollection items
);

Parameters

items
The ZipFileSetCollection to be added to the end of the collection.

See Also

ZipFileSetCollection Class | NAnt.Compression.Types Namespace | ZipFileSetCollection.AddRange Overload List


ZipFileSetCollection.Contains Method

Determines whether a ZipFileSet is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal item As ZipFileSet _
) As Boolean
[C#]
public bool Contains(
ZipFileSet item
);

Parameters

item
The ZipFileSet to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

ZipFileSetCollection Class | NAnt.Compression.Types Namespace


ZipFileSetCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As ZipFileSet(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
ZipFileSet[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

ZipFileSetCollection Class | NAnt.Compression.Types Namespace


ZipFileSetCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As ZipFileSetEnumerator
[C#]
new public ZipFileSetEnumerator GetEnumerator();

Return Value

A ZipFileSetEnumerator for the entire collection.

See Also

ZipFileSetCollection Class | NAnt.Compression.Types Namespace


ZipFileSetCollection.IndexOf Method

Retrieves the index of a specified ZipFileSet object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As ZipFileSet _
) As Integer
[C#]
public int IndexOf(
ZipFileSet item
);

Parameters

item
The ZipFileSet object for which the index is returned.

Return Value

The index of the specified ZipFileSet. If the ZipFileSet is not currently a member of the collection, it returns -1.

See Also

ZipFileSetCollection Class | NAnt.Compression.Types Namespace


ZipFileSetCollection.Insert Method

Inserts a ZipFileSet into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As ZipFileSet _
)
[C#]
public void Insert(
int index,
ZipFileSet item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The ZipFileSet to insert.

See Also

ZipFileSetCollection Class | NAnt.Compression.Types Namespace


ZipFileSetCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As ZipFileSet _
)
[C#]
public void Remove(
ZipFileSet item
);

Parameters

item
The ZipFileSet to remove from the collection.

See Also

ZipFileSetCollection Class | NAnt.Compression.Types Namespace


ZipFileSetEnumerator Class

Enumerates the ZipFileSet elements of a ZipFileSetCollection.

For a list of all members of this type, see ZipFileSetEnumerator Members.

System.Object
NAnt.Compression.Types.ZipFileSetEnumerator

[Visual Basic]
Public Class ZipFileSetEnumerator
Implements IEnumerator
[C#]
public class ZipFileSetEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Compression.Types

Assembly: NAnt.CompressionTasks (in NAnt.CompressionTasks.dll)

See Also

ZipFileSetEnumerator Members | NAnt.Compression.Types Namespace


ZipFileSetEnumerator Members

ZipFileSetEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ZipFileSetEnumerator Class | NAnt.Compression.Types Namespace


ZipFileSetEnumerator Properties

The properties of the ZipFileSetEnumerator class are listed below. For a complete list of ZipFileSetEnumerator class members, see the ZipFileSetEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

ZipFileSetEnumerator Class | NAnt.Compression.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

ZipFileSetEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As ZipFileSet
[C#]
public ZipFileSet Current {get;}

See Also

ZipFileSetEnumerator Class | NAnt.Compression.Types Namespace


ZipFileSetEnumerator Methods

The methods of the ZipFileSetEnumerator class are listed below. For a complete list of ZipFileSetEnumerator class members, see the ZipFileSetEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ZipFileSetEnumerator Class | NAnt.Compression.Types Namespace


ZipFileSetEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

ZipFileSetEnumerator Class | NAnt.Compression.Types Namespace


ZipFileSetEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

ZipFileSetEnumerator Class | NAnt.Compression.Types Namespace


NAnt.Core

NAnt SDK Documentation - v0.91

NAnt.Core Namespace

Namespace hierarchy

Classes

Class | Description
BuildEventArgs | Class representing an event occurring during a build.
BuildException | Thrown whenever an error occurs during the build.
BuildListenerCollection | Contains a strongly typed collection of IBuildListener objects.
BuildListenerEnumerator | Enumerates the IBuildListener elements of a BuildListenerCollection.
BuildReport | Used to store information about a build, to allow better reporting to the user.
CommandLineOptions | Represents the set of command-line options supported by NAnt.
ConfigurationSection | Custom configuration section handler for the element.
ConsoleDriver | Main entry point to NAnt that is called by the ConsoleStub.
DataTypeBase | Provides the abstract base class for types.
DataTypeBaseBuilder |
DataTypeBaseBuilderCollection | Contains a strongly typed collection of DataTypeBaseBuilder objects.
DataTypeBaseBuilderEnumerator | Enumerates the DataTypeBaseBuilder elements of a DataTypeBaseBuilderCollection.
DataTypeBaseDictionary |
DataTypeBaseDictionaryEnumerator |
DefaultLogger |
DirectoryScanner | Used for searching filesystem based on given include/exclude rules.
Element | Models a NAnt XML element in the build file.
Element.AttributeConfigurator | Configures an Element using meta-data provided by assigned attributes.
ExpressionEvalBase |
ExpressionEvaluator |
ExpressionParseException |
ExpressionTokenizer | Splits an input string into a sequence of tokens used during parsing.
FrameworkInfo | Encalsulates information about installed frameworks incuding version information and directory locations for finding tools.
FrameworkInfoDictionary |
FrameworkInfoDictionaryEnumerator |
FunctionSetBase |
Location | Stores the file name, line number and column number to record a position in a text file.
LogWriter | Implements a TextWriter for writing information to the NAnt logging infrastructure.
MailLogger | Buffers log messages from DefaultLogger, and sends an e-mail with the results.
PathScanner | Used to search for files on the PATH.
PlatformHelper |
Project | Central representation of a NAnt project.
PropertyDictionary |
Target |
TargetCollection |
Task | Provides the abstract base class for tasks.
TaskBuilder |
TaskBuilderCollection | Contains a strongly typed collection of TaskBuilder objects.
TaskBuilderEnumerator | Enumerates the TaskBuilder elements of a TaskBuilderCollection.
TaskContainer | Executes embedded tasks in the order in which they are defined.
TypeFactory | Comprises all of the loaded, and available, tasks. Use these static methods to register, initialize and create a task.
ValidationException |
XmlLogger | Used to wrap log messages in xml <message/> elements.

Interfaces

Interface | Description
IBuildListener | Instances of classes that implement this interface can register to be notified when things happen during a build.
IBuildLogger | Interface used by NAnt to log the build output.

Structures

Structure | Description
ExpressionTokenizer.Position |

Delegates

Delegate | Description
BuildEventHandler | Represents the method that handles the build events.

Enumerations

Enumeration | Description
ClrType |
ExpressionTokenizer.TokenType | Available tokens
FrameworkTypes | Defines the types of frameworks.
Level | Defines the set of levels recognised by the NAnt logging system.
VendorType |


BuildEventArgs Class

Class representing an event occurring during a build.

For a list of all members of this type, see BuildEventArgs Members.

System.Object
System.EventArgs
NAnt.Core.BuildEventArgs

[Visual Basic]
Public Class BuildEventArgs
Inherits EventArgs
[C#]
public class BuildEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

An event is built by specifying either a project, a task or a target.

A Project level event will only have a Project reference.

A Target level event will have Project and Target references.

A Task level event will have Project, Target and Task references.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

BuildEventArgs Members | NAnt.Core Namespace


BuildEventArgs Members

BuildEventArgs overview

Public Instance Constructors

BuildEventArgs Overloaded. Initializes a new instance of the BuildEventArgs class.

Public Instance Properties

Exception | Gets or sets the Exception associated with this event.
Message | Gets or sets the message associated with this event.
MessageLevel | Gets or sets the priority level associated with this event.
Project | Gets the Project that fired this event.
Target | Gets the Target that fired this event.
Task | Gets the Task that fired this event.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BuildEventArgs Class | NAnt.Core Namespace


BuildEventArgs Constructor

Initializes a new instance of the BuildEventArgs class.

Overload List

Initializes a new instance of the BuildEventArgs class.

public BuildEventArgs();

Initializes a new instance of the BuildEventArgs class for a Project level event.

public BuildEventArgs(Project);

Initializes a new instance of the BuildEventArgs class for a Target level event.

public BuildEventArgs(Target);

Initializes a new instance of the BuildEventArgs class for a Task level event.

public BuildEventArgs(Task);

See Also

BuildEventArgs Class | NAnt.Core Namespace


BuildEventArgs Constructor ()

Initializes a new instance of the BuildEventArgs class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public BuildEventArgs();

See Also

BuildEventArgs Class | NAnt.Core Namespace | BuildEventArgs Constructor Overload List


BuildEventArgs Constructor (Project)

Initializes a new instance of the BuildEventArgs class for a Project level event.

[Visual Basic]
Overloads Public Sub New( _
ByVal project As Project _
)
[C#]
public BuildEventArgs(
Project project
);

Parameters

project
The Project that emitted the event.

See Also

BuildEventArgs Class | NAnt.Core Namespace | BuildEventArgs Constructor Overload List


BuildEventArgs Constructor (Target)

Initializes a new instance of the BuildEventArgs class for a Target level event.

[Visual Basic]
Overloads Public Sub New( _
ByVal target As Target _
)
[C#]
public BuildEventArgs(
Target target
);

Parameters

target
The Target that emitted the event.

See Also

BuildEventArgs Class | NAnt.Core Namespace | BuildEventArgs Constructor Overload List


BuildEventArgs Constructor (Task)

Initializes a new instance of the BuildEventArgs class for a Task level event.

[Visual Basic]
Overloads Public Sub New( _
ByVal task As Task _
)
[C#]
public BuildEventArgs(
Task task
);

Parameters

task
The Task that emitted the event.

See Also

BuildEventArgs Class | NAnt.Core Namespace | BuildEventArgs Constructor Overload List


BuildEventArgs Properties

The properties of the BuildEventArgs class are listed below. For a complete list of BuildEventArgs class members, see the BuildEventArgs Members topic.

Public Instance Properties

Exception | Gets or sets the Exception associated with this event.
Message | Gets or sets the message associated with this event.
MessageLevel | Gets or sets the priority level associated with this event.
Project | Gets the Project that fired this event.
Target | Gets the Target that fired this event.
Task | Gets the Task that fired this event.

See Also

BuildEventArgs Class | NAnt.Core Namespace


Exception Property

NAnt SDK Documentation - v0.91

BuildEventArgs.Exception Property

Gets or sets the Exception associated with this event.

[Visual Basic]
Public Property Exception As Exception
[C#]
public System.Exception Exception {get; set;}

Property Value

The Exception associated with this event.

See Also

BuildEventArgs Class | NAnt.Core Namespace


Message Property

NAnt SDK Documentation - v0.91

BuildEventArgs.Message Property

Gets or sets the message associated with this event.

[Visual Basic]
Public Property Message As String
[C#]
public string Message {get; set;}

Property Value

The message associated with this event.

See Also

BuildEventArgs Class | NAnt.Core Namespace


MessageLevel Property

NAnt SDK Documentation - v0.91

BuildEventArgs.MessageLevel Property

Gets or sets the priority level associated with this event.

[Visual Basic]
Public Property MessageLevel As Level
[C#]
public Level MessageLevel {get; set;}

Property Value

The priority level associated with this event.

See Also

BuildEventArgs Class | NAnt.Core Namespace


Project Property

NAnt SDK Documentation - v0.91

BuildEventArgs.Project Property

Gets the Project that fired this event.

[Visual Basic]
Public ReadOnly Property Project As Project
[C#]
public Project Project {get;}

Property Value

The Project that fired this event.

See Also

BuildEventArgs Class | NAnt.Core Namespace


Target Property

NAnt SDK Documentation - v0.91

BuildEventArgs.Target Property

Gets the Target that fired this event.

[Visual Basic]
Public ReadOnly Property Target As Target
[C#]
public Target Target {get;}

Property Value

The Target that fired this event, or a null reference if this is a Project level event.

See Also

BuildEventArgs Class | NAnt.Core Namespace


Task Property

NAnt SDK Documentation - v0.91

BuildEventArgs.Task Property

Gets the Task that fired this event.

[Visual Basic]
Public ReadOnly Property Task As Task
[C#]
public Task Task {get;}

Property Value

The Task that fired this event, or a null reference (Nothing in Visual Basic) if this is a Project or Target level event.

See Also

BuildEventArgs Class | NAnt.Core Namespace


BuildEventHandler Delegate

Represents the method that handles the build events.

[Visual Basic]
<Serializable>
Public Delegate Sub BuildEventHandler( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
)
[C#]
[Serializable]
public delegate void BuildEventHandler(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs that contains the event data.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

NAnt.Core Namespace


BuildException Class

Thrown whenever an error occurs during the build.

For a list of all members of this type, see BuildException Members.

System.Object
System.Exception
System.ApplicationException
NAnt.Core.BuildException
NAnt.Core.ValidationException

[Visual Basic]
<Serializable, _ Serializable>
Public Class BuildException
Inherits ApplicationException
[C#]
[Serializable]
[Serializable]
public class BuildException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

BuildException Members | NAnt.Core Namespace


BuildException Members

BuildException overview

Public Instance Constructors

BuildException Overloaded. Initializes a new instance of the BuildException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Location | Gets the location in the build file of the element from which the exception originated.
Message | Gets a message that describes the current exception.
RawMessage | Gets the raw message as specified when the exception was constructed.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetObjectData | Serializes this object into the SerializationInfo provided.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Creates and returns a string representation of the current exception.

Protected Instance Constructors

BuildException Overloaded. Initializes a new instance of the BuildException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Instance Events

SerializeObjectState (inherited from Exception)

See Also

BuildException Class | NAnt.Core Namespace


BuildException Constructor

Initializes a new instance of the BuildException class.

Overload List

Initializes a new instance of the BuildException class.

public BuildException();

Initializes a new instance of the BuildException class with serialized data.

protected BuildException(SerializationInfo,StreamingContext);

Initializes a new instance of the BuildException class with a descriptive message.

public BuildException(string);

Initializes a new instance of the BuildException class with a descriptive message and the location in the build file that caused the exception.

public BuildException(string,Location);

Initializes a new instance of the BuildException class with a descriptive message, the location in the build file and an instance of the exception that is the cause of the current exception.

public BuildException(string,Location,Exception);

Initializes a new instance of the BuildException class with the specified descriptive message and inner exception.

public BuildException(string,Exception);

See Also

BuildException Class | NAnt.Core Namespace


BuildException Constructor ()

Initializes a new instance of the BuildException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public BuildException();

See Also

BuildException Class | NAnt.Core Namespace | BuildException Constructor Overload List


BuildException Constructor (String)

Initializes a new instance of the BuildException class with a descriptive message.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public BuildException(
string message
);

Parameters

message
A descriptive message to include with the exception.

See Also

BuildException Class | NAnt.Core Namespace | BuildException Constructor Overload List


BuildException Constructor (String, Exception)

Initializes a new instance of the BuildException class with the specified descriptive message and inner exception.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
[C#]
public BuildException(
string message,
Exception innerException
);

Parameters

message
A descriptive message to include with the exception.
innerException
A nested exception that is the cause of the current exception.

See Also

BuildException Class | NAnt.Core Namespace | BuildException Constructor Overload List


BuildException Constructor (String, Location)

Initializes a new instance of the BuildException class with a descriptive message and the location in the build file that caused the exception.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal location As Location _
)
[C#]
public BuildException(
string message,
Location location
);

Parameters

message
A descriptive message to include with the exception.
location
The location in the build file where the exception occured.

See Also

BuildException Class | NAnt.Core Namespace | BuildException Constructor Overload List


BuildException Constructor (String, Location, Exception)

Initializes a new instance of the BuildException class with a descriptive message, the location in the build file and an instance of the exception that is the cause of the current exception.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal location As Location, _
ByVal innerException As Exception _
)
[C#]
public BuildException(
string message,
Location location,
Exception innerException
);

Parameters

message
A descriptive message to include with the exception.
location
The location in the build file where the exception occured.
innerException
A nested exception that is the cause of the current exception.

See Also

BuildException Class | NAnt.Core Namespace | BuildException Constructor Overload List


BuildException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the BuildException class with serialized data.

[Visual Basic]
Overloads Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
protected BuildException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

See Also

BuildException Class | NAnt.Core Namespace | BuildException Constructor Overload List


BuildException Properties

The properties of the BuildException class are listed below. For a complete list of BuildException class members, see the BuildException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Location | Gets the location in the build file of the element from which the exception originated.
Message | Gets a message that describes the current exception.
RawMessage | Gets the raw message as specified when the exception was constructed.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

BuildException Class | NAnt.Core Namespace


Location Property

NAnt SDK Documentation - v0.91

BuildException.Location Property

Gets the location in the build file of the element from which the exception originated.

[Visual Basic]
Public ReadOnly Property Location As Location
[C#]
public Location Location {get;}

Property Value

The location in the build file of the element from which the exception originated.

See Also

BuildException Class | NAnt.Core Namespace


Message Property

NAnt SDK Documentation - v0.91

BuildException.Message Property

Gets a message that describes the current exception.

[Visual Basic]
Overrides Public ReadOnly Property Message As String
[C#]
public override string Message {get;}

Property Value

The error message that explains the reason for the exception.

Remarks

Adds location information to the message, if available.

See Also

BuildException Class | NAnt.Core Namespace


RawMessage Property

NAnt SDK Documentation - v0.91

BuildException.RawMessage Property

Gets the raw message as specified when the exception was constructed.

[Visual Basic]
Public ReadOnly Property RawMessage As String
[C#]
public string RawMessage {get;}

Property Value

The raw message as specified when the exception was constructed.

See Also

BuildException Class | NAnt.Core Namespace


BuildException Methods

The methods of the BuildException class are listed below. For a complete list of BuildException class members, see the BuildException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetObjectData | Serializes this object into the SerializationInfo provided.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BuildException Class | NAnt.Core Namespace


BuildException.GetObjectData Method

Serializes this object into the SerializationInfo provided.

[Visual Basic]
Overrides Public Sub GetObjectData( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
) _
Implements ISerializable.GetObjectData
[C#]
public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo to populate with data.
context
The destination for this serialization.

Implements

ISerializable.GetObjectData

See Also

BuildException Class | NAnt.Core Namespace


BuildException.ToString Method

Creates and returns a string representation of the current exception.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

A string representation of the current exception.

See Also

BuildException Class | NAnt.Core Namespace


BuildListenerCollection Class

Contains a strongly typed collection of IBuildListener objects.

For a list of all members of this type, see BuildListenerCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.Core.BuildListenerCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class BuildListenerCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class BuildListenerCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

BuildListenerCollection Members | NAnt.Core Namespace


BuildListenerCollection Members

BuildListenerCollection overview

Public Instance Constructors

BuildListenerCollection Overloaded. Initializes a new instance of the BuildListenerCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a IBuildListener to the end of the collection.
AddRange | Overloaded. Adds the elements of a IBuildListener array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a IBuildListener is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified IBuildListener object in the collection.
Insert | Inserts a IBuildListener into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

BuildListenerCollection Class | NAnt.Core Namespace


BuildListenerCollection Constructor

Initializes a new instance of the BuildListenerCollection class.

Overload List

Initializes a new instance of the BuildListenerCollection class.

public BuildListenerCollection();

Initializes a new instance of the BuildListenerCollection class with the specified BuildListenerCollection instance.

public BuildListenerCollection(BuildListenerCollection);

Initializes a new instance of the BuildListenerCollection class with the specified array of IBuildListener instances.

public BuildListenerCollection(IBuildListener[]);

See Also

BuildListenerCollection Class | NAnt.Core Namespace


BuildListenerCollection Constructor ()

Initializes a new instance of the BuildListenerCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public BuildListenerCollection();

See Also

BuildListenerCollection Class | NAnt.Core Namespace | BuildListenerCollection Constructor Overload List


BuildListenerCollection Constructor (BuildListenerCollection)

Initializes a new instance of the BuildListenerCollection class with the specified BuildListenerCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As BuildListenerCollection _
)
[C#]
public BuildListenerCollection(
BuildListenerCollection value
);

See Also

BuildListenerCollection Class | NAnt.Core Namespace | BuildListenerCollection Constructor Overload List


BuildListenerCollection Constructor (IBuildListener[])

Initializes a new instance of the BuildListenerCollection class with the specified array of IBuildListener instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As IBuildListener() _
)
[C#]
public BuildListenerCollection(
IBuildListener[] value
);

See Also

BuildListenerCollection Class | NAnt.Core Namespace | BuildListenerCollection Constructor Overload List


BuildListenerCollection Properties

The properties of the BuildListenerCollection class are listed below. For a complete list of BuildListenerCollection class members, see the BuildListenerCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

BuildListenerCollection Class | NAnt.Core Namespace


Item Property

NAnt SDK Documentation - v0.91

BuildListenerCollection.Item Property

Gets or sets the element at the specified index.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As IBuildListener
[C#]
public IBuildListener this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

BuildListenerCollection Class | NAnt.Core Namespace


BuildListenerCollection Methods

The methods of the BuildListenerCollection class are listed below. For a complete list of BuildListenerCollection class members, see the BuildListenerCollection Members topic.

Public Instance Methods

Add | Adds a IBuildListener to the end of the collection.
AddRange | Overloaded. Adds the elements of a IBuildListener array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a IBuildListener is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified IBuildListener object in the collection.
Insert | Inserts a IBuildListener into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

BuildListenerCollection Class | NAnt.Core Namespace


BuildListenerCollection.Add Method

Adds a IBuildListener to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As IBuildListener _
) As Integer
[C#]
public int Add(
IBuildListener item
);

Parameters

item
The IBuildListener to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

BuildListenerCollection Class | NAnt.Core Namespace


AddRange Method

NAnt SDK Documentation - v0.91

BuildListenerCollection.AddRange Method

Adds the elements of a BuildListenerCollection to the end of the collection.

Overload List

Adds the elements of a BuildListenerCollection to the end of the collection.

public void AddRange(BuildListenerCollection);

Adds the elements of a IBuildListener array to the end of the collection.

public void AddRange(IBuildListener[]);

See Also

BuildListenerCollection Class | NAnt.Core Namespace


BuildListenerCollection.AddRange Method (BuildListenerCollection)

Adds the elements of a BuildListenerCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As BuildListenerCollection _
)
[C#]
public void AddRange(
BuildListenerCollection items
);

Parameters

items
The BuildListenerCollection to be added to the end of the collection.

See Also

BuildListenerCollection Class | NAnt.Core Namespace | BuildListenerCollection.AddRange Overload List


BuildListenerCollection.AddRange Method (IBuildListener[])

Adds the elements of a IBuildListener array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As IBuildListener() _
)
[C#]
public void AddRange(
IBuildListener[] items
);

Parameters

items
The array of IBuildListener elements to be added to the end of the collection.

See Also

BuildListenerCollection Class | NAnt.Core Namespace | BuildListenerCollection.AddRange Overload List


BuildListenerCollection.Contains Method

Determines whether a IBuildListener is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal item As IBuildListener _
) As Boolean
[C#]
public bool Contains(
IBuildListener item
);

Parameters

item
The IBuildListener to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

BuildListenerCollection Class | NAnt.Core Namespace


BuildListenerCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As IBuildListener(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
IBuildListener[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

BuildListenerCollection Class | NAnt.Core Namespace


BuildListenerCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As BuildListenerEnumerator
[C#]
new public BuildListenerEnumerator GetEnumerator();

Return Value

A BuildListenerEnumerator for the entire collection.

See Also

BuildListenerCollection Class | NAnt.Core Namespace


BuildListenerCollection.IndexOf Method

Retrieves the index of a specified IBuildListener object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As IBuildListener _
) As Integer
[C#]
public int IndexOf(
IBuildListener item
);

Parameters

item
The IBuildListener object for which the index is returned.

Return Value

The index of the specified IBuildListener. If the IBuildListener is not currently a member of the collection, it returns -1.

See Also

BuildListenerCollection Class | NAnt.Core Namespace


BuildListenerCollection.Insert Method

Inserts a IBuildListener into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As IBuildListener _
)
[C#]
public void Insert(
int index,
IBuildListener item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The IBuildListener to insert.

See Also

BuildListenerCollection Class | NAnt.Core Namespace


BuildListenerCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As IBuildListener _
)
[C#]
public void Remove(
IBuildListener item
);

Parameters

item
The IBuildListener to remove from the collection.

See Also

BuildListenerCollection Class | NAnt.Core Namespace


BuildListenerEnumerator Class

Enumerates the IBuildListener elements of a BuildListenerCollection.

For a list of all members of this type, see BuildListenerEnumerator Members.

System.Object
NAnt.Core.BuildListenerEnumerator

[Visual Basic]
Public Class BuildListenerEnumerator
Implements IEnumerator
[C#]
public class BuildListenerEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

BuildListenerEnumerator Members | NAnt.Core Namespace


BuildListenerEnumerator Members

BuildListenerEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BuildListenerEnumerator Class | NAnt.Core Namespace


BuildListenerEnumerator Properties

The properties of the BuildListenerEnumerator class are listed below. For a complete list of BuildListenerEnumerator class members, see the BuildListenerEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

BuildListenerEnumerator Class | NAnt.Core Namespace


Current Property

NAnt SDK Documentation - v0.91

BuildListenerEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As IBuildListener
[C#]
public IBuildListener Current {get;}

See Also

BuildListenerEnumerator Class | NAnt.Core Namespace


BuildListenerEnumerator Methods

The methods of the BuildListenerEnumerator class are listed below. For a complete list of BuildListenerEnumerator class members, see the BuildListenerEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BuildListenerEnumerator Class | NAnt.Core Namespace


BuildListenerEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

BuildListenerEnumerator Class | NAnt.Core Namespace


BuildListenerEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

BuildListenerEnumerator Class | NAnt.Core Namespace


BuildReport Class

Used to store information about a build, to allow better reporting to the user.

For a list of all members of this type, see BuildReport Members.

System.Object
NAnt.Core.BuildReport

[Visual Basic]
<Serializable, _ Serializable>
Public Class BuildReport
[C#]
[Serializable]
[Serializable]
public class BuildReport

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

BuildReport Members | NAnt.Core Namespace


BuildReport Members

BuildReport overview

Public Instance Constructors

BuildReport Constructor

Public Instance Fields

Errors | Errors encountered so far.
StartTime | The start time of the build process.
Warnings | Warnings encountered so far.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BuildReport Class | NAnt.Core Namespace


BuildReport Constructor

[Visual Basic]
Public Sub New( _
ByVal startTime As Date _
)
[C#]
public BuildReport(
DateTime startTime
);

See Also

BuildReport Class | NAnt.Core Namespace


BuildReport Fields

The fields of the BuildReport class are listed below. For a complete list of BuildReport class members, see the BuildReport Members topic.

Public Instance Fields

Errors | Errors encountered so far.
StartTime | The start time of the build process.
Warnings | Warnings encountered so far.

See Also

BuildReport Class | NAnt.Core Namespace


BuildReport.Errors Field

Errors encountered so far.

[Visual Basic]
Public Errors As Integer
[C#]
public int Errors;

See Also

BuildReport Class | NAnt.Core Namespace


BuildReport.StartTime Field

The start time of the build process.

[Visual Basic]
Public ReadOnly StartTime As Date
[C#]
public readonly DateTime StartTime;

See Also

BuildReport Class | NAnt.Core Namespace


BuildReport.Warnings Field

Warnings encountered so far.

[Visual Basic]
Public Warnings As Integer
[C#]
public int Warnings;

See Also

BuildReport Class | NAnt.Core Namespace


ClrType Enumeration

[Visual Basic]
<Serializable>
Public Enum ClrType
[C#]
[Serializable]
public enum ClrType

Members

Member Name | Description
Desktop |
Compact |
Browser |

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

NAnt.Core Namespace


CommandLineOptions Class

Represents the set of command-line options supported by NAnt.

For a list of all members of this type, see CommandLineOptions Members.

System.Object
NAnt.Core.CommandLineOptions

[Visual Basic]
Public Class CommandLineOptions
[C#]
public class CommandLineOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

CommandLineOptions Members | NAnt.Core Namespace


CommandLineOptions Members

CommandLineOptions overview

Public Instance Constructors

CommandLineOptions Constructor Initializes a new instance of the CommandLineOptions class.

Public Instance Properties

BuildFile | Gets or sets the buildfile that should be executed.
Debug | Gets or sets a value indicating whether debug information should be displayed during the build process.
DefaultFramework | Obsolete. Gets or sets the target framework to use (overrides NAnt.exe.config settings)
EmacsMode | Gets or sets a value indicating whether to produce emacs (and other editor) friendly output.
ExtensionAssemblies | Gets a collection of assemblies to load extensions from.
FindInParent | Gets a value indicating whether parent directories should be searched for a buildfile.
IndentationLevel | Gets or sets the indentation level of the build output.
Listeners | Gets a collection containing fully qualified type names of classes implementating IBuildListener that should be added to the project as listeners.
LogFile | Gets or sets the name of the file to log output to.
LoggerType | Gets or sets the Type of logger to add to the list of listeners.
NoLogo | Gets or sets a value indicating whether the logo banner should be printed.
Properties | Gets or sets the list of properties that should be set.
Quiet | Gets or sets a value indicating whether only error and debug debug messages should be displayed during the build process.
ShowHelp | Gets or sets a value indicating whether the NAnt help should be printed.
ShowProjectHelp | Gets or sets a value indicating whether Project help should be printed.
TargetFramework | Gets or sets the target framework to use (overrides NAnt.exe.config settings)
Targets | Gets a collection containing the targets that should be executed.
Verbose | Gets or sets a value indicating whether more information should be displayed during the build process.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandLineOptions Class | NAnt.Core Namespace


CommandLineOptions Constructor

Initializes a new instance of the CommandLineOptions class.

[Visual Basic]
Public Sub New()
[C#]
public CommandLineOptions();

See Also

CommandLineOptions Class | NAnt.Core Namespace


CommandLineOptions Properties

The properties of the CommandLineOptions class are listed below. For a complete list of CommandLineOptions class members, see the CommandLineOptions Members topic.

Public Instance Properties

BuildFile | Gets or sets the buildfile that should be executed.
Debug | Gets or sets a value indicating whether debug information should be displayed during the build process.
DefaultFramework | Obsolete. Gets or sets the target framework to use (overrides NAnt.exe.config settings)
EmacsMode | Gets or sets a value indicating whether to produce emacs (and other editor) friendly output.
ExtensionAssemblies | Gets a collection of assemblies to load extensions from.
FindInParent | Gets a value indicating whether parent directories should be searched for a buildfile.
IndentationLevel | Gets or sets the indentation level of the build output.
Listeners | Gets a collection containing fully qualified type names of classes implementating IBuildListener that should be added to the project as listeners.
LogFile | Gets or sets the name of the file to log output to.
LoggerType | Gets or sets the Type of logger to add to the list of listeners.
NoLogo | Gets or sets a value indicating whether the logo banner should be printed.
Properties | Gets or sets the list of properties that should be set.
Quiet | Gets or sets a value indicating whether only error and debug debug messages should be displayed during the build process.
ShowHelp | Gets or sets a value indicating whether the NAnt help should be printed.
ShowProjectHelp | Gets or sets a value indicating whether Project help should be printed.
TargetFramework | Gets or sets the target framework to use (overrides NAnt.exe.config settings)
Targets | Gets a collection containing the targets that should be executed.
Verbose | Gets or sets a value indicating whether more information should be displayed during the build process.

See Also

CommandLineOptions Class | NAnt.Core Namespace


BuildFile Property

NAnt SDK Documentation - v0.91

CommandLineOptions.BuildFile Property

Gets or sets the buildfile that should be executed.

[Visual Basic]
<CommandLineArgument(Name:="buildfile", ShortName:="f", Description:="Use given buildfile", Type:=CommandLineArgumentTypes.AtMostOnce)>
Public Property BuildFile As String
[C#]
[CommandLineArgument(Name="buildfile", ShortName="f", Description="Use given buildfile", Type=CommandLineArgumentTypes.AtMostOnce)]
public string BuildFile {get; set;}

Property Value

The buildfile that should be executed.

Remarks

Can be both a file or an URI.

See Also

CommandLineOptions Class | NAnt.Core Namespace


Debug Property

NAnt SDK Documentation - v0.91

CommandLineOptions.Debug Property

Gets or sets a value indicating whether debug information should be displayed during the build process.

[Visual Basic]
<CommandLineArgument(Name:="debug", ShortName:="null", Description:="Displays debug information during build process", Type:=CommandLineArgumentTypes.AtMostOnce)>
Public Property Debug As Boolean
[C#]
[CommandLineArgument(Name="debug", ShortName="null", Description="Displays debug information during build process", Type=CommandLineArgumentTypes.AtMostOnce)]
public bool Debug {get; set;}

Property Value

true if debug information should be displayed; otherwise, false. The default is false.

See Also

CommandLineOptions Class | NAnt.Core Namespace


DefaultFramework Property

NAnt SDK Documentation - v0.91

CommandLineOptions.DefaultFramework Property

NOTE: This property is now obsolete.

Use the -[t]argetframework option instead.

Gets or sets the target framework to use (overrides NAnt.exe.config settings)

[Visual Basic]
<Obsolete(Message:="Use the -[t]argetframework option instead.", IsError:=False), _ CommandLineArgument(Name:="defaultframework", ShortName:="k", Description:="Specifies the framework to target", Type:=CommandLineArgumentTypes.AtMostOnce)>
Public Property DefaultFramework As String
[C#]
[Obsolete(Message="Use the -[t]argetframework option instead.", IsError=False)]
[CommandLineArgument(Name="defaultframework", ShortName="k", Description="Specifies the framework to target", Type=CommandLineArgumentTypes.AtMostOnce)]
public string DefaultFramework {get; set;}

Property Value

The framework that should be used.

Remarks

For a list of possible frameworks, see NAnt.exe.config, possible values include "net-1.0", "net-1.1", etc.

See Also

CommandLineOptions Class | NAnt.Core Namespace


EmacsMode Property

NAnt SDK Documentation - v0.91

CommandLineOptions.EmacsMode Property

Gets or sets a value indicating whether to produce emacs (and other editor) friendly output.

[Visual Basic]
<CommandLineArgument(Name:="emacs", ShortName:="e", Description:="Produce logging information without adornments", Type:=CommandLineArgumentTypes.AtMostOnce)>
Public Property EmacsMode As Boolean
[C#]
[CommandLineArgument(Name="emacs", ShortName="e", Description="Produce logging information without adornments", Type=CommandLineArgumentTypes.AtMostOnce)]
public bool EmacsMode {get; set;}

Property Value

true if output is to be unadorned so that emacs and other editors can parse files names, etc. The default is false.

See Also

CommandLineOptions Class | NAnt.Core Namespace


ExtensionAssemblies Property

NAnt SDK Documentation - v0.91

CommandLineOptions.ExtensionAssemblies Property

Gets a collection of assemblies to load extensions from.

[Visual Basic]
<CommandLineArgument(Name:="extension", ShortName:="ext", Description:="Load NAnt extensions from the specified assembly", Type:=CommandLineArgumentTypes.MultipleUnique)>
Public ReadOnly Property ExtensionAssemblies As StringCollection
[C#]
[CommandLineArgument(Name="extension", ShortName="ext", Description="Load NAnt extensions from the specified assembly", Type=CommandLineArgumentTypes.MultipleUnique)]
public System.Collections.Specialized.StringCollection ExtensionAssemblies {get;}

Property Value

A collection of assemblies to load extensions from.

See Also

CommandLineOptions Class | NAnt.Core Namespace


FindInParent Property

NAnt SDK Documentation - v0.91

CommandLineOptions.FindInParent Property

Gets a value indicating whether parent directories should be searched for a buildfile.

[Visual Basic]
<CommandLineArgument(Name:="find", ShortName:="null", Description:="Search parent directories for build file", Type:=CommandLineArgumentTypes.AtMostOnce)>
Public Property FindInParent As Boolean
[C#]
[CommandLineArgument(Name="find", ShortName="null", Description="Search parent directories for build file", Type=CommandLineArgumentTypes.AtMostOnce)]
public bool FindInParent {get; set;}

Property Value

true if parent directories should be searched for a build file; otherwise, false. The default is false.

See Also

CommandLineOptions Class | NAnt.Core Namespace


IndentationLevel Property

NAnt SDK Documentation - v0.91

CommandLineOptions.IndentationLevel Property

Gets or sets the indentation level of the build output.

[Visual Basic]
<CommandLineArgument(Name:="indent", ShortName:="null", Description:="Indentation level of build output", Type:=CommandLineArgumentTypes.AtMostOnce)>
Public Property IndentationLevel As Integer
[C#]
[CommandLineArgument(Name="indent", ShortName="null", Description="Indentation level of build output", Type=CommandLineArgumentTypes.AtMostOnce)]
public int IndentationLevel {get; set;}

Property Value

The indentation level of the build output. The default is 0.

See Also

CommandLineOptions Class | NAnt.Core Namespace


Listeners Property

NAnt SDK Documentation - v0.91

CommandLineOptions.Listeners Property

Gets a collection containing fully qualified type names of classes implementating IBuildListener that should be added to the project as listeners.

[Visual Basic]
<CommandLineArgument(Name:="listener", ShortName:="null", Description:="Add an instance of class as a project listener", Type:=CommandLineArgumentTypes.MultipleUnique)>
Public ReadOnly Property Listeners As StringCollection
[C#]
[CommandLineArgument(Name="listener", ShortName="null", Description="Add an instance of class as a project listener", Type=CommandLineArgumentTypes.MultipleUnique)]
public System.Collections.Specialized.StringCollection Listeners {get;}

Property Value

A collection of fully qualified type names that should be added as listeners to the Project.

See Also

CommandLineOptions Class | NAnt.Core Namespace


LogFile Property

NAnt SDK Documentation - v0.91

CommandLineOptions.LogFile Property

Gets or sets the name of the file to log output to.

[Visual Basic]
<CommandLineArgument(Name:="logfile", ShortName:="l", Description:="Use value as name of log output file", Type:=CommandLineArgumentTypes.AtMostOnce)>
Public Property LogFile As FileInfo
[C#]
[CommandLineArgument(Name="logfile", ShortName="l", Description="Use value as name of log output file", Type=CommandLineArgumentTypes.AtMostOnce)]
public System.IO.FileInfo LogFile {get; set;}

Property Value

The name of the file to log output to.

See Also

CommandLineOptions Class | NAnt.Core Namespace


LoggerType Property

NAnt SDK Documentation - v0.91

CommandLineOptions.LoggerType Property

Gets or sets the Type of logger to add to the list of listeners.

[Visual Basic]
<CommandLineArgument(Name:="logger", ShortName:="null", Description:="Use given type as logger", Type:=CommandLineArgumentTypes.AtMostOnce)>
Public Property LoggerType As String
[C#]
[CommandLineArgument(Name="logger", ShortName="null", Description="Use given type as logger", Type=CommandLineArgumentTypes.AtMostOnce)]
public string LoggerType {get; set;}

Property Value

The Type of logger to add to the list of listeners.

Remarks

The LoggerType should derive from IBuildLogger.

See Also

CommandLineOptions Class | NAnt.Core Namespace


NoLogo Property

NAnt SDK Documentation - v0.91

CommandLineOptions.NoLogo Property

Gets or sets a value indicating whether the logo banner should be printed.

[Visual Basic]
<CommandLineArgument(Name:="nologo", ShortName:="null", Description:="Suppresses display of the logo banner", Type:=CommandLineArgumentTypes.AtMostOnce)>
Public Property NoLogo As Boolean
[C#]
[CommandLineArgument(Name="nologo", ShortName="null", Description="Suppresses display of the logo banner", Type=CommandLineArgumentTypes.AtMostOnce)]
public bool NoLogo {get; set;}

Property Value

true if the logo banner should be printed; otherwise, false. The default is false.

See Also

CommandLineOptions Class | NAnt.Core Namespace


Properties Property

NAnt SDK Documentation - v0.91

CommandLineOptions.Properties Property

Gets or sets the list of properties that should be set.

[Visual Basic]
<CommandLineArgument(Name:="D", ShortName:="null", Description:="Use value for given property", Type:=CommandLineArgumentTypes.MultipleUnique)>
Public ReadOnly Property Properties As NameValueCollection
[C#]
[CommandLineArgument(Name="D", ShortName="null", Description="Use value for given property", Type=CommandLineArgumentTypes.MultipleUnique)]
public System.Collections.Specialized.NameValueCollection Properties {get;}

Property Value

The list of properties that should be set.

See Also

CommandLineOptions Class | NAnt.Core Namespace


Quiet Property

NAnt SDK Documentation - v0.91

CommandLineOptions.Quiet Property

Gets or sets a value indicating whether only error and debug debug messages should be displayed during the build process.

[Visual Basic]
<CommandLineArgument(Name:="quiet", ShortName:="q", Description:="Displays only error or warning messages during build process", Type:=CommandLineArgumentTypes.AtMostOnce)>
Public Property Quiet As Boolean
[C#]
[CommandLineArgument(Name="quiet", ShortName="q", Description="Displays only error or warning messages during build process", Type=CommandLineArgumentTypes.AtMostOnce)]
public bool Quiet {get; set;}

Property Value

true if only error or warning messages should be displayed; otherwise, false. The default is false.

See Also

CommandLineOptions Class | NAnt.Core Namespace


ShowHelp Property

NAnt SDK Documentation - v0.91

CommandLineOptions.ShowHelp Property

Gets or sets a value indicating whether the NAnt help should be printed.

[Visual Basic]
<CommandLineArgument(Name:="help", ShortName:="h", Description:="Prints this message", Type:=CommandLineArgumentTypes.Exclusive)>
Public Property ShowHelp As Boolean
[C#]
[CommandLineArgument(Name="help", ShortName="h", Description="Prints this message", Type=CommandLineArgumentTypes.Exclusive)]
public bool ShowHelp {get; set;}

Property Value

true if NAnt help should be printed; otherwise, false. The default is false.

See Also

CommandLineOptions Class | NAnt.Core Namespace


ShowProjectHelp Property

NAnt SDK Documentation - v0.91

CommandLineOptions.ShowProjectHelp Property

Gets or sets a value indicating whether Project help should be printed.

[Visual Basic]
<CommandLineArgument(Name:="projecthelp", ShortName:="null", Description:="Prints project help information", Type:=CommandLineArgumentTypes.AtMostOnce)>
Public Property ShowProjectHelp As Boolean
[C#]
[CommandLineArgument(Name="projecthelp", ShortName="null", Description="Prints project help information", Type=CommandLineArgumentTypes.AtMostOnce)]
public bool ShowProjectHelp {get; set;}

Property Value

true if Project help should be printed; otherwise, false. The default is false.

See Also

CommandLineOptions Class | NAnt.Core Namespace


TargetFramework Property

NAnt SDK Documentation - v0.91

CommandLineOptions.TargetFramework Property

Gets or sets the target framework to use (overrides NAnt.exe.config settings)

[Visual Basic]
<CommandLineArgument(Type:=CommandLineArgumentTypes.AtMostOnce, Name:="targetframework", ShortName:="t", Description:="Specifies the framework to target")>
Public Property TargetFramework As String
[C#]
[CommandLineArgument(Type=CommandLineArgumentTypes.AtMostOnce, Name="targetframework", ShortName="t", Description="Specifies the framework to target")]
public string TargetFramework {get; set;}

Property Value

The framework that should be used.

Remarks

For a list of possible frameworks, see NAnt.exe.config, possible values include "net-1.0", "net-1.1", etc.

See Also

CommandLineOptions Class | NAnt.Core Namespace


Targets Property

NAnt SDK Documentation - v0.91

CommandLineOptions.Targets Property

Gets a collection containing the targets that should be executed.

[Visual Basic]
<DefaultCommandLineArgument(Type:=CommandLineArgumentTypes.MultipleUnique, Name:="target", ShortName:="null", Description:="null")>
Public ReadOnly Property Targets As StringCollection
[C#]
[DefaultCommandLineArgument(Type=CommandLineArgumentTypes.MultipleUnique, Name="target", ShortName="null", Description="null")]
public System.Collections.Specialized.StringCollection Targets {get;}

Property Value

A collection that contains the targets that should be executed.

See Also

CommandLineOptions Class | NAnt.Core Namespace


Verbose Property

NAnt SDK Documentation - v0.91

CommandLineOptions.Verbose Property

Gets or sets a value indicating whether more information should be displayed during the build process.

[Visual Basic]
<CommandLineArgument(Name:="verbose", ShortName:="v", Description:="Displays more information during build process", Type:=CommandLineArgumentTypes.AtMostOnce)>
Public Property Verbose As Boolean
[C#]
[CommandLineArgument(Name="verbose", ShortName="v", Description="Displays more information during build process", Type=CommandLineArgumentTypes.AtMostOnce)]
public bool Verbose {get; set;}

Property Value

true if more information should be displayed; otherwise, false. The default is false.

See Also

CommandLineOptions Class | NAnt.Core Namespace


ConfigurationSection Class

Custom configuration section handler for the element.

For a list of all members of this type, see ConfigurationSection Members.

System.Object
NAnt.Core.ConfigurationSection

[Visual Basic]
Public Class ConfigurationSection
Implements IConfigurationSectionHandler
[C#]
public class ConfigurationSection : IConfigurationSectionHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ConfigurationSection Members | NAnt.Core Namespace


ConfigurationSection Members

ConfigurationSection overview

Public Instance Constructors

ConfigurationSection Constructor Initializes a new instance of the ConfigurationSection class.

Public Instance Methods

Create | This just passed things through. Return the node read from the config file.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConfigurationSection Class | NAnt.Core Namespace


ConfigurationSection Constructor

Initializes a new instance of the ConfigurationSection class.

[Visual Basic]
Public Sub New()
[C#]
public ConfigurationSection();

See Also

ConfigurationSection Class | NAnt.Core Namespace


ConfigurationSection Methods

The methods of the ConfigurationSection class are listed below. For a complete list of ConfigurationSection class members, see the ConfigurationSection Members topic.

Public Instance Methods

Create | This just passed things through. Return the node read from the config file.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConfigurationSection Class | NAnt.Core Namespace


ConfigurationSection.Create Method

This just passed things through. Return the node read from the config file.

[Visual Basic]
NotOverridable Public Function Create( _
ByVal parent As Object, _
ByVal configContext As Object, _
ByVal node As XmlNode _
) As Object _
Implements IConfigurationSectionHandler.Create
[C#]
public object Create(
object parent,
object configContext,
XmlNode node
);

Implements

IConfigurationSectionHandler.Create

See Also

ConfigurationSection Class | NAnt.Core Namespace


ConsoleDriver Class

Main entry point to NAnt that is called by the ConsoleStub.

For a list of all members of this type, see ConsoleDriver Members.

System.Object
NAnt.Core.ConsoleDriver

[Visual Basic]
Public Class ConsoleDriver
[C#]
public class ConsoleDriver

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ConsoleDriver Members | NAnt.Core Namespace


ConsoleDriver Members

ConsoleDriver overview

Public Static (Shared) Methods

CreateListener | Dynamically constructs an IBuildListener instance of the class specified.
CreateLogger | Dynamically constructs an IBuildLogger instance of the class specified.
GetBuildFileName | Gets the file name for the build file in the specified directory.
Main | Starts NAnt. This is the Main entry point.
ShowProjectHelp | Prints the projecthelp to the console.

Public Instance Constructors

ConsoleDriver Constructor Initializes a new instance of the ConsoleDriver class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConsoleDriver Class | NAnt.Core Namespace


ConsoleDriver Constructor

Initializes a new instance of the ConsoleDriver class.

[Visual Basic]
Public Sub New()
[C#]
public ConsoleDriver();

See Also

ConsoleDriver Class | NAnt.Core Namespace


ConsoleDriver Methods

The methods of the ConsoleDriver class are listed below. For a complete list of ConsoleDriver class members, see the ConsoleDriver Members topic.

Public Static (Shared) Methods

CreateListener | Dynamically constructs an IBuildListener instance of the class specified.
CreateLogger | Dynamically constructs an IBuildLogger instance of the class specified.
GetBuildFileName | Gets the file name for the build file in the specified directory.
Main | Starts NAnt. This is the Main entry point.
ShowProjectHelp | Prints the projecthelp to the console.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConsoleDriver Class | NAnt.Core Namespace


ConsoleDriver.CreateListener Method

Dynamically constructs an IBuildListener instance of the class specified.

[Visual Basic]
Public Shared Function CreateListener( _
ByVal typeName As String _
) As IBuildListener
[C#]
public static IBuildListener CreateListener(
string typeName
);

Parameters

typeName
The fully qualified name of the listener that should be instantiated.

Remarks

At this point, only looks in the assembly where IBuildListener is defined.

Exceptions

Exception Type | Condition
TypeLoadException | Type typeName could not be loaded.
ArgumentException | typeName does not implement IBuildListener.

See Also

ConsoleDriver Class | NAnt.Core Namespace


ConsoleDriver.CreateLogger Method

Dynamically constructs an IBuildLogger instance of the class specified.

[Visual Basic]
Public Shared Function CreateLogger( _
ByVal typeName As String _
) As IBuildLogger
[C#]
public static IBuildLogger CreateLogger(
string typeName
);

Parameters

typeName
The fully qualified name of the logger that should be instantiated.

Remarks

At this point, only looks in the assembly where IBuildLogger is defined.

Exceptions

Exception Type | Condition
TypeLoadException | Type typeName could not be loaded.
ArgumentException | typeName does not implement IBuildLogger.

See Also

ConsoleDriver Class | NAnt.Core Namespace


ConsoleDriver.GetBuildFileName Method

Gets the file name for the build file in the specified directory.

[Visual Basic]
Public Shared Function GetBuildFileName( _
ByVal directory As String, _
ByVal searchPattern As String, _
ByVal findInParent As Boolean _
) As String
[C#]
public static string GetBuildFileName(
string directory,
string searchPattern,
bool findInParent
);

Parameters

directory
The directory to look for a build file. When in doubt use Environment.CurrentDirectory for directory.
searchPattern
Look for a build file with this pattern or name. If null look for a file that matches the default build pattern (*.build).
findInParent
Whether or not to search the parent directories for a build file.

Return Value

The path to the build file or null if no build file could be found.

See Also

ConsoleDriver Class | NAnt.Core Namespace


ConsoleDriver.Main Method

Starts NAnt. This is the Main entry point.

[Visual Basic]
Public Shared Function Main( _
ByVal args As String() _
) As Integer
[C#]
public static int Main(
string[] args
);

Parameters

args
Command Line args, or whatever you want to pass it. They will treated as Command Line args.

Return Value

The exit code.

See Also

ConsoleDriver Class | NAnt.Core Namespace


ConsoleDriver.ShowProjectHelp Method

Prints the projecthelp to the console.

[Visual Basic]
Public Shared Sub ShowProjectHelp( _
ByVal buildDoc As XmlDocument _
)
[C#]
public static void ShowProjectHelp(
XmlDocument buildDoc
);

Parameters

buildDoc
The build file to show help for.

Remarks

buildDoc is loaded and transformed with ProjectHelp.xslt, which is an embedded resource.

See Also

ConsoleDriver Class | NAnt.Core Namespace


DataTypeBase Class

Provides the abstract base class for types.

For a list of all members of this type, see DataTypeBase Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
Derived types

[Visual Basic]
<Serializable, _ Serializable>
MustInherit Public Class DataTypeBase
Inherits Element
[C#]
[Serializable]
[Serializable]
public abstract class DataTypeBase : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

DataTypeBase Members | NAnt.Core Namespace


DataTypeBase Members

DataTypeBase overview

Public Instance Properties

CanBeReferenced | Gets a value indicating whether a reference to the type can be defined.
ID | The ID used to be referenced later.
Name | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID | The ID to use as the reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

DataTypeBase Constructor Initializes a new instance of the DataTypeBase class.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataTypeBase Class | NAnt.Core Namespace


DataTypeBase Constructor

Initializes a new instance of the DataTypeBase class.

[Visual Basic]
Protected Sub New()
[C#]
protected DataTypeBase();

See Also

DataTypeBase Class | NAnt.Core Namespace


DataTypeBase Properties

The properties of the DataTypeBase class are listed below. For a complete list of DataTypeBase class members, see the DataTypeBase Members topic.

Public Instance Properties

CanBeReferenced | Gets a value indicating whether a reference to the type can be defined.
ID | The ID used to be referenced later.
Name | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID | The ID to use as the reference.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

DataTypeBase Class | NAnt.Core Namespace


CanBeReferenced Property

NAnt SDK Documentation - v0.91

DataTypeBase.CanBeReferenced Property

Gets a value indicating whether a reference to the type can be defined.

[Visual Basic]
Public ReadOnly Property CanBeReferenced As Boolean
[C#]
public bool CanBeReferenced {get;}

Remarks

Only types with an ElementNameAttribute assigned to it, can be referenced.

See Also

DataTypeBase Class | NAnt.Core Namespace


ID Property

NAnt SDK Documentation - v0.91

DataTypeBase.ID Property

The ID used to be referenced later.

[Visual Basic]
<TaskAttribute(Name:="id", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property ID As String
[C#]
[TaskAttribute(Name="id", Required=False, ExpandProperties=True, ProcessXml=True)]
public string ID {get; set;}

See Also

DataTypeBase Class | NAnt.Core Namespace


Name Property

NAnt SDK Documentation - v0.91

DataTypeBase.Name Property

Gets the name of the datatype.

[Visual Basic]
Overrides Public ReadOnly Property Name As String
[C#]
public override string Name {get;}

Property Value

The name of the datatype.

See Also

DataTypeBase Class | NAnt.Core Namespace


RefID Property

NAnt SDK Documentation - v0.91

DataTypeBase.RefID Property

The ID to use as the reference.

[Visual Basic]
<TaskAttribute(Name:="refid", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property RefID As String
[C#]
[TaskAttribute(Name="refid", Required=False, ExpandProperties=True, ProcessXml=True)]
public string RefID {get; set;}

See Also

DataTypeBase Class | NAnt.Core Namespace


DataTypeBase Methods

The methods of the DataTypeBase class are listed below. For a complete list of DataTypeBase class members, see the DataTypeBase Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataTypeBase Class | NAnt.Core Namespace


CopyTo Method

NAnt SDK Documentation - v0.91

DataTypeBase.CopyTo Method

Copies all instance data of the DataTypeBase to a given DataTypeBase.

Overload List

Copies all instance data of the DataTypeBase to a given DataTypeBase.

protected void CopyTo(DataTypeBase);

Inherited from Element.

protected void CopyTo(Element);

See Also

DataTypeBase Class | NAnt.Core Namespace


DataTypeBase.CopyTo Method (DataTypeBase)

Copies all instance data of the DataTypeBase to a given DataTypeBase.

[Visual Basic]
Overloads Protected Sub CopyTo( _
ByVal clone As DataTypeBase _
)
[C#]
protected void CopyTo(
DataTypeBase clone
);

See Also

DataTypeBase Class | NAnt.Core Namespace | DataTypeBase.CopyTo Overload List


Initialize Method

NAnt SDK Documentation - v0.91

DataTypeBase.Initialize Method

Overload List

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

DataTypeBase Class | NAnt.Core Namespace


DataTypeBase.Initialize Method ()

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

DataTypeBase Class | NAnt.Core Namespace | DataTypeBase.Initialize Overload List


DataTypeBase.Reset Method

Should be overridden by derived classes. clones the referenced types data into the current instance.

[Visual Basic]
Overridable Public Sub Reset()
[C#]
public virtual void Reset();

See Also

DataTypeBase Class | NAnt.Core Namespace


DataTypeBaseBuilder Class

For a list of all members of this type, see DataTypeBaseBuilder Members.

System.Object
NAnt.Core.Extensibility.ExtensionBuilder
NAnt.Core.DataTypeBaseBuilder

[Visual Basic]
Public Class DataTypeBaseBuilder
Inherits ExtensionBuilder
[C#]
public class DataTypeBaseBuilder : ExtensionBuilder

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

DataTypeBaseBuilder Members | NAnt.Core Namespace


DataTypeBaseBuilder Members

DataTypeBaseBuilder overview

Public Instance Constructors

DataTypeBaseBuilder Constructor Creates a new instance of the DataTypeBaseBuilder class for the specified DataTypeBase class in the specified Assembly.

Public Instance Properties

ClassName | Gets the name of the DataTypeBase class that can be created using this DataTypeBaseBuilder.
DataTypeName | Gets the name of the data type which the DataTypeBaseBuilder can create.

Public Instance Methods

CreateDataTypeBase |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Properties

Assembly (inherited from ExtensionBuilder) Gets the Assembly from which the extension will be created.

See Also

DataTypeBaseBuilder Class | NAnt.Core Namespace


DataTypeBaseBuilder Constructor

Creates a new instance of the DataTypeBaseBuilder class for the specified DataTypeBase class in the specified Assembly.

[Visual Basic]
Overloads Public Sub New( _
ByVal assembly As Assembly, _
ByVal className As String _
)
[C#]
public DataTypeBaseBuilder(
Assembly assembly,
string className
);

Parameters

assembly
The Assembly containing the DataTypeBase.
className
The class representing the DataTypeBase.

Remarks

An ExtensionAssembly for the specified Assembly is cached for future use.

See Also

DataTypeBaseBuilder Class | NAnt.Core Namespace


DataTypeBaseBuilder Properties

The properties of the DataTypeBaseBuilder class are listed below. For a complete list of DataTypeBaseBuilder class members, see the DataTypeBaseBuilder Members topic.

Public Instance Properties

ClassName | Gets the name of the DataTypeBase class that can be created using this DataTypeBaseBuilder.
DataTypeName | Gets the name of the data type which the DataTypeBaseBuilder can create.

Protected Internal Instance Properties

Assembly (inherited from ExtensionBuilder) Gets the Assembly from which the extension will be created.

See Also

DataTypeBaseBuilder Class | NAnt.Core Namespace


ClassName Property

NAnt SDK Documentation - v0.91

DataTypeBaseBuilder.ClassName Property

Gets the name of the DataTypeBase class that can be created using this DataTypeBaseBuilder.

[Visual Basic]
Public ReadOnly Property ClassName As String
[C#]
public string ClassName {get;}

Property Value

The name of the DataTypeBase class that can be created using this DataTypeBaseBuilder.

See Also

DataTypeBaseBuilder Class | NAnt.Core Namespace


DataTypeName Property

NAnt SDK Documentation - v0.91

DataTypeBaseBuilder.DataTypeName Property

Gets the name of the data type which the DataTypeBaseBuilder can create.

[Visual Basic]
Public ReadOnly Property DataTypeName As String
[C#]
public string DataTypeName {get;}

Property Value

The name of the data type which the DataTypeBaseBuilder can create.

See Also

DataTypeBaseBuilder Class | NAnt.Core Namespace


DataTypeBaseBuilder Methods

The methods of the DataTypeBaseBuilder class are listed below. For a complete list of DataTypeBaseBuilder class members, see the DataTypeBaseBuilder Members topic.

Public Instance Methods

CreateDataTypeBase |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataTypeBaseBuilder Class | NAnt.Core Namespace


DataTypeBaseBuilder.CreateDataTypeBase Method

[Visual Basic]
Public Function CreateDataTypeBase() As DataTypeBase
[C#]
public DataTypeBase CreateDataTypeBase();

See Also

DataTypeBaseBuilder Class | NAnt.Core Namespace


DataTypeBaseBuilderCollection Class

Contains a strongly typed collection of DataTypeBaseBuilder objects.

For a list of all members of this type, see DataTypeBaseBuilderCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.Core.DataTypeBaseBuilderCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class DataTypeBaseBuilderCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class DataTypeBaseBuilderCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

DataTypeBaseBuilderCollection Members | NAnt.Core Namespace


DataTypeBaseBuilderCollection Members

DataTypeBaseBuilderCollection overview

Public Instance Constructors

DataTypeBaseBuilderCollection Overloaded. Initializes a new instance of the DataTypeBaseBuilderCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a DataTypeBaseBuilder to the end of the collection.
AddRange | Overloaded. Adds the elements of a DataTypeBaseBuilder array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a DataTypeBaseBuilder is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified DataTypeBaseBuilder object in the collection.
Insert | Inserts a DataTypeBaseBuilder into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace


DataTypeBaseBuilderCollection Constructor

Initializes a new instance of the DataTypeBaseBuilderCollection class.

Overload List

Initializes a new instance of the DataTypeBaseBuilderCollection class.

public DataTypeBaseBuilderCollection();

Initializes a new instance of the DataTypeBaseBuilderCollection class with the specified array of DataTypeBaseBuilder instances.

public DataTypeBaseBuilderCollection(DataTypeBaseBuilder[]);

Initializes a new instance of the DataTypeBaseBuilderCollection class with the specified DataTypeBaseBuilderCollection instance.

public DataTypeBaseBuilderCollection(DataTypeBaseBuilderCollection);

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace


DataTypeBaseBuilderCollection Constructor ()

Initializes a new instance of the DataTypeBaseBuilderCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DataTypeBaseBuilderCollection();

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace | DataTypeBaseBuilderCollection Constructor Overload List


DataTypeBaseBuilderCollection Constructor (DataTypeBaseBuilderCollection)

Initializes a new instance of the DataTypeBaseBuilderCollection class with the specified DataTypeBaseBuilderCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As DataTypeBaseBuilderCollection _
)
[C#]
public DataTypeBaseBuilderCollection(
DataTypeBaseBuilderCollection value
);

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace | DataTypeBaseBuilderCollection Constructor Overload List


DataTypeBaseBuilderCollection Constructor (DataTypeBaseBuilder[])

Initializes a new instance of the DataTypeBaseBuilderCollection class with the specified array of DataTypeBaseBuilder instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As DataTypeBaseBuilder() _
)
[C#]
public DataTypeBaseBuilderCollection(
DataTypeBaseBuilder[] value
);

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace | DataTypeBaseBuilderCollection Constructor Overload List


DataTypeBaseBuilderCollection Properties

The properties of the DataTypeBaseBuilderCollection class are listed below. For a complete list of DataTypeBaseBuilderCollection class members, see the DataTypeBaseBuilderCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace


Item Property

NAnt SDK Documentation - v0.91

DataTypeBaseBuilderCollection.Item Property

Gets or sets the element at the specified index.

Overload List

Gets or sets the element at the specified index.

public DataTypeBaseBuilder this[int] {get; set;}

Gets the DataTypeBaseBuilder for the specified task.

public DataTypeBaseBuilder this[string] {get;}

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace


Item Property (Int32)

NAnt SDK Documentation - v0.91

DataTypeBaseBuilderCollection.Item Property (Int32)

Gets or sets the element at the specified index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As DataTypeBaseBuilder
[C#]
public DataTypeBaseBuilder this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace | DataTypeBaseBuilderCollection.Item Overload List


Item Property (String)

NAnt SDK Documentation - v0.91

DataTypeBaseBuilderCollection.Item Property (String)

Gets the DataTypeBaseBuilder for the specified task.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal dataTypeName As String _
) As DataTypeBaseBuilder
[C#]
public DataTypeBaseBuilder this[
string dataTypeName
] {get;}

Parameters

dataTypeName
The name of task for which the DataTypeBaseBuilder should be located in the collection.

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace | DataTypeBaseBuilderCollection.Item Overload List


DataTypeBaseBuilderCollection Methods

The methods of the DataTypeBaseBuilderCollection class are listed below. For a complete list of DataTypeBaseBuilderCollection class members, see the DataTypeBaseBuilderCollection Members topic.

Public Instance Methods

Add | Adds a DataTypeBaseBuilder to the end of the collection.
AddRange | Overloaded. Adds the elements of a DataTypeBaseBuilder array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a DataTypeBaseBuilder is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified DataTypeBaseBuilder object in the collection.
Insert | Inserts a DataTypeBaseBuilder into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace


DataTypeBaseBuilderCollection.Add Method

Adds a DataTypeBaseBuilder to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As DataTypeBaseBuilder _
) As Integer
[C#]
public int Add(
DataTypeBaseBuilder item
);

Parameters

item
The DataTypeBaseBuilder to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace


AddRange Method

NAnt SDK Documentation - v0.91

DataTypeBaseBuilderCollection.AddRange Method

Adds the elements of a DataTypeBaseBuilder array to the end of the collection.

Overload List

Adds the elements of a DataTypeBaseBuilder array to the end of the collection.

public void AddRange(DataTypeBaseBuilder[]);

Adds the elements of a DataTypeBaseBuilderCollection to the end of the collection.

public void AddRange(DataTypeBaseBuilderCollection);

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace


DataTypeBaseBuilderCollection.AddRange Method (DataTypeBaseBuilder[])

Adds the elements of a DataTypeBaseBuilder array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As DataTypeBaseBuilder() _
)
[C#]
public void AddRange(
DataTypeBaseBuilder[] items
);

Parameters

items
The array of DataTypeBaseBuilder elements to be added to the end of the collection.

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace | DataTypeBaseBuilderCollection.AddRange Overload List


DataTypeBaseBuilderCollection.AddRange Method (DataTypeBaseBuilderCollection)

Adds the elements of a DataTypeBaseBuilderCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As DataTypeBaseBuilderCollection _
)
[C#]
public void AddRange(
DataTypeBaseBuilderCollection items
);

Parameters

items
The DataTypeBaseBuilderCollection to be added to the end of the collection.

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace | DataTypeBaseBuilderCollection.AddRange Overload List


Contains Method

NAnt SDK Documentation - v0.91

DataTypeBaseBuilderCollection.Contains Method

Determines whether a DataTypeBaseBuilder is in the collection.

Overload List

Determines whether a DataTypeBaseBuilder is in the collection.

public bool Contains(DataTypeBaseBuilder);

Determines whether a DataTypeBaseBuilder for the specified task is in the collection.

public bool Contains(string);

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace


DataTypeBaseBuilderCollection.Contains Method (DataTypeBaseBuilder)

Determines whether a DataTypeBaseBuilder is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal item As DataTypeBaseBuilder _
) As Boolean
[C#]
public bool Contains(
DataTypeBaseBuilder item
);

Parameters

item
The DataTypeBaseBuilder to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace | DataTypeBaseBuilderCollection.Contains Overload List


DataTypeBaseBuilderCollection.Contains Method (String)

Determines whether a DataTypeBaseBuilder for the specified task is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal taskName As String _
) As Boolean
[C#]
public bool Contains(
string taskName
);

Parameters

taskName
The name of task for which the DataTypeBaseBuilder should be located in the collection.

Return Value

true if a DataTypeBaseBuilder for the specified task is found in the collection; otherwise, false.

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace | DataTypeBaseBuilderCollection.Contains Overload List


DataTypeBaseBuilderCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As DataTypeBaseBuilder(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
DataTypeBaseBuilder[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace


DataTypeBaseBuilderCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As DataTypeBaseBuilderEnumerator
[C#]
new public DataTypeBaseBuilderEnumerator GetEnumerator();

Return Value

A DataTypeBaseBuilderEnumerator for the entire collection.

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace


DataTypeBaseBuilderCollection.IndexOf Method

Retrieves the index of a specified DataTypeBaseBuilder object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As DataTypeBaseBuilder _
) As Integer
[C#]
public int IndexOf(
DataTypeBaseBuilder item
);

Parameters

item
The DataTypeBaseBuilder object for which the index is returned.

Return Value

The index of the specified DataTypeBaseBuilder. If the DataTypeBaseBuilder is not currently a member of the collection, it returns -1.

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace


DataTypeBaseBuilderCollection.Insert Method

Inserts a DataTypeBaseBuilder into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As DataTypeBaseBuilder _
)
[C#]
public void Insert(
int index,
DataTypeBaseBuilder item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The DataTypeBaseBuilder to insert.

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace


DataTypeBaseBuilderCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As DataTypeBaseBuilder _
)
[C#]
public void Remove(
DataTypeBaseBuilder item
);

Parameters

item
The DataTypeBaseBuilder to remove from the collection.

See Also

DataTypeBaseBuilderCollection Class | NAnt.Core Namespace


DataTypeBaseBuilderEnumerator Class

Enumerates the DataTypeBaseBuilder elements of a DataTypeBaseBuilderCollection.

For a list of all members of this type, see DataTypeBaseBuilderEnumerator Members.

System.Object
NAnt.Core.DataTypeBaseBuilderEnumerator

[Visual Basic]
Public Class DataTypeBaseBuilderEnumerator
Implements IEnumerator
[C#]
public class DataTypeBaseBuilderEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

DataTypeBaseBuilderEnumerator Members | NAnt.Core Namespace


DataTypeBaseBuilderEnumerator Members

DataTypeBaseBuilderEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataTypeBaseBuilderEnumerator Class | NAnt.Core Namespace


DataTypeBaseBuilderEnumerator Properties

The properties of the DataTypeBaseBuilderEnumerator class are listed below. For a complete list of DataTypeBaseBuilderEnumerator class members, see the DataTypeBaseBuilderEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

DataTypeBaseBuilderEnumerator Class | NAnt.Core Namespace


Current Property

NAnt SDK Documentation - v0.91

DataTypeBaseBuilderEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As DataTypeBaseBuilder
[C#]
public DataTypeBaseBuilder Current {get;}

See Also

DataTypeBaseBuilderEnumerator Class | NAnt.Core Namespace


DataTypeBaseBuilderEnumerator Methods

The methods of the DataTypeBaseBuilderEnumerator class are listed below. For a complete list of DataTypeBaseBuilderEnumerator class members, see the DataTypeBaseBuilderEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataTypeBaseBuilderEnumerator Class | NAnt.Core Namespace


DataTypeBaseBuilderEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

DataTypeBaseBuilderEnumerator Class | NAnt.Core Namespace


DataTypeBaseBuilderEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

DataTypeBaseBuilderEnumerator Class | NAnt.Core Namespace


DataTypeBaseDictionary Class

For a list of all members of this type, see DataTypeBaseDictionary Members.

System.Object
NAnt.Core.DataTypeBaseDictionary

[Visual Basic]
<DefaultMember(MemberName:="Item")>
Public Class DataTypeBaseDictionary
Implements IDictionary, ICollection, IEnumerable, ICloneable
[C#]
[DefaultMember(MemberName="Item")]
public class DataTypeBaseDictionary : IDictionary, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

DataTypeBaseDictionary Members | NAnt.Core Namespace


DataTypeBaseDictionary Members

DataTypeBaseDictionary overview

Public Static (Shared) Methods

Synchronized

Public Instance Constructors

DataTypeBaseDictionary Overloaded. Initializes a new instance of the DataTypeBaseDictionary class.

Public Instance Properties

Count
IsFixedSize
IsReadOnly
IsSynchronized
Item
Keys
SyncRoot
Values

Public Instance Methods

Add |
Clear |
Clone |
Contains |
ContainsKey |
ContainsValue |
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Inherit | Inherits Properties from an existing property dictionary Instance
Remove |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


DataTypeBaseDictionary Constructor

Initializes a new instance of the DataTypeBaseDictionary class.

Overload List

Initializes a new instance of the DataTypeBaseDictionary class.

public DataTypeBaseDictionary();

public DataTypeBaseDictionary(DataTypeBaseDictionary);

public DataTypeBaseDictionary(IDictionary);

public DataTypeBaseDictionary(IDictionary,IHashCodeProvider,IComparer);

public DataTypeBaseDictionary(IDictionary,float);

public DataTypeBaseDictionary(IDictionary,float,IHashCodeProvider,IComparer);

public DataTypeBaseDictionary(IHashCodeProvider,IComparer);

Initializes a new instance of the DataTypeBaseDictionary class with the specified capacity.

public DataTypeBaseDictionary(int);

public DataTypeBaseDictionary(int,IHashCodeProvider,IComparer);

public DataTypeBaseDictionary(int,int);

public DataTypeBaseDictionary(int,float,IHashCodeProvider,IComparer);

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


DataTypeBaseDictionary Constructor ()

Initializes a new instance of the DataTypeBaseDictionary class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DataTypeBaseDictionary();

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace | DataTypeBaseDictionary Constructor Overload List


DataTypeBaseDictionary Constructor (DataTypeBaseDictionary)

[Visual Basic]
Overloads Public Sub New( _
ByVal original As DataTypeBaseDictionary _
)
[C#]
public DataTypeBaseDictionary(
DataTypeBaseDictionary original
);

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace | DataTypeBaseDictionary Constructor Overload List


DataTypeBaseDictionary Constructor (IDictionary)

[Visual Basic]
Overloads Public Sub New( _
ByVal dictionary As IDictionary _
)
[C#]
public DataTypeBaseDictionary(
IDictionary dictionary
);

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace | DataTypeBaseDictionary Constructor Overload List


DataTypeBaseDictionary Constructor (Int32)

Initializes a new instance of the DataTypeBaseDictionary class with the specified capacity.

[Visual Basic]
Overloads Public Sub New( _
ByVal capacity As Integer _
)
[C#]
public DataTypeBaseDictionary(
int capacity
);

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace | DataTypeBaseDictionary Constructor Overload List


DataTypeBaseDictionary Constructor (IDictionary, Single)

[Visual Basic]
Overloads Public Sub New( _
ByVal dictionary As IDictionary, _
ByVal loadFactor As Single _
)
[C#]
public DataTypeBaseDictionary(
IDictionary dictionary,
float loadFactor
);

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace | DataTypeBaseDictionary Constructor Overload List


DataTypeBaseDictionary Constructor (IHashCodeProvider, IComparer)

[Visual Basic]
Overloads Public Sub New( _
ByVal codeProvider As IHashCodeProvider, _
ByVal comparer As IComparer _
)
[C#]
public DataTypeBaseDictionary(
IHashCodeProvider codeProvider,
IComparer comparer
);

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace | DataTypeBaseDictionary Constructor Overload List


DataTypeBaseDictionary Constructor (Int32, Int32)

[Visual Basic]
Overloads Public Sub New( _
ByVal capacity As Integer, _
ByVal loadFactor As Integer _
)
[C#]
public DataTypeBaseDictionary(
int capacity,
int loadFactor
);

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace | DataTypeBaseDictionary Constructor Overload List


DataTypeBaseDictionary Constructor (IDictionary, IHashCodeProvider, IComparer)

[Visual Basic]
Overloads Public Sub New( _
ByVal dictionary As IDictionary, _
ByVal codeProvider As IHashCodeProvider, _
ByVal comparer As IComparer _
)
[C#]
public DataTypeBaseDictionary(
IDictionary dictionary,
IHashCodeProvider codeProvider,
IComparer comparer
);

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace | DataTypeBaseDictionary Constructor Overload List


DataTypeBaseDictionary Constructor (Int32, IHashCodeProvider, IComparer)

[Visual Basic]
Overloads Public Sub New( _
ByVal capacity As Integer, _
ByVal codeProvider As IHashCodeProvider, _
ByVal comparer As IComparer _
)
[C#]
public DataTypeBaseDictionary(
int capacity,
IHashCodeProvider codeProvider,
IComparer comparer
);

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace | DataTypeBaseDictionary Constructor Overload List


DataTypeBaseDictionary Constructor (IDictionary, Single, IHashCodeProvider, IComparer)

[Visual Basic]
Overloads Public Sub New( _
ByVal dictionary As IDictionary, _
ByVal loadFactor As Single, _
ByVal codeProvider As IHashCodeProvider, _
ByVal comparer As IComparer _
)
[C#]
public DataTypeBaseDictionary(
IDictionary dictionary,
float loadFactor,
IHashCodeProvider codeProvider,
IComparer comparer
);

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace | DataTypeBaseDictionary Constructor Overload List


DataTypeBaseDictionary Constructor (Int32, Single, IHashCodeProvider, IComparer)

[Visual Basic]
Overloads Public Sub New( _
ByVal capacity As Integer, _
ByVal loadFactor As Single, _
ByVal codeProvider As IHashCodeProvider, _
ByVal comparer As IComparer _
)
[C#]
public DataTypeBaseDictionary(
int capacity,
float loadFactor,
IHashCodeProvider codeProvider,
IComparer comparer
);

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace | DataTypeBaseDictionary Constructor Overload List


DataTypeBaseDictionary Properties

The properties of the DataTypeBaseDictionary class are listed below. For a complete list of DataTypeBaseDictionary class members, see the DataTypeBaseDictionary Members topic.

Public Instance Properties

Count
IsFixedSize
IsReadOnly
IsSynchronized
Item
Keys
SyncRoot
Values

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


Count Property

NAnt SDK Documentation - v0.91

DataTypeBaseDictionary.Count Property

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


IsFixedSize Property

NAnt SDK Documentation - v0.91

DataTypeBaseDictionary.IsFixedSize Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsFixedSize As Boolean _
Implements IDictionary.IsFixedSize
[C#]
public bool IsFixedSize {get;}

Implements

IDictionary.IsFixedSize

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


IsReadOnly Property

NAnt SDK Documentation - v0.91

DataTypeBaseDictionary.IsReadOnly Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsReadOnly As Boolean _
Implements IDictionary.IsReadOnly
[C#]
public bool IsReadOnly {get;}

Implements

IDictionary.IsReadOnly

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


IsSynchronized Property

NAnt SDK Documentation - v0.91

DataTypeBaseDictionary.IsSynchronized Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


Item Property

NAnt SDK Documentation - v0.91

DataTypeBaseDictionary.Item Property

[Visual Basic]
Public Default Property Item( _
ByVal key As String _
) As DataTypeBase
[C#]
public DataTypeBase this[
string key
] {get; set;}

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


Keys Property

NAnt SDK Documentation - v0.91

DataTypeBaseDictionary.Keys Property

[Visual Basic]
NotOverridable Public ReadOnly Property Keys As ICollection _
Implements IDictionary.Keys
[C#]
public System.Collections.ICollection Keys {get;}

Implements

IDictionary.Keys

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


SyncRoot Property

NAnt SDK Documentation - v0.91

DataTypeBaseDictionary.SyncRoot Property

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


Values Property

NAnt SDK Documentation - v0.91

DataTypeBaseDictionary.Values Property

[Visual Basic]
NotOverridable Public ReadOnly Property Values As ICollection _
Implements IDictionary.Values
[C#]
public System.Collections.ICollection Values {get;}

Implements

IDictionary.Values

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


DataTypeBaseDictionary Methods

The methods of the DataTypeBaseDictionary class are listed below. For a complete list of DataTypeBaseDictionary class members, see the DataTypeBaseDictionary Members topic.

Public Static (Shared) Methods

Synchronized

Public Instance Methods

Add |
Clear |
Clone |
Contains |
ContainsKey |
ContainsValue |
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Inherit | Inherits Properties from an existing property dictionary Instance
Remove |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


DataTypeBaseDictionary.Add Method

[Visual Basic]
Public Sub Add( _
ByVal key As String, _
ByVal value As DataTypeBase _
)
[C#]
public void Add(
string key,
DataTypeBase value
);

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


DataTypeBaseDictionary.Clear Method

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements IDictionary.Clear
[C#]
public void Clear();

Implements

IDictionary.Clear

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


DataTypeBaseDictionary.Clone Method

[Visual Basic]
Public Function Clone() As DataTypeBaseDictionary
[C#]
public DataTypeBaseDictionary Clone();

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


DataTypeBaseDictionary.Contains Method

[Visual Basic]
Public Function Contains( _
ByVal key As String _
) As Boolean
[C#]
public bool Contains(
string key
);

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


DataTypeBaseDictionary.ContainsKey Method

[Visual Basic]
Public Function ContainsKey( _
ByVal key As String _
) As Boolean
[C#]
public bool ContainsKey(
string key
);

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


DataTypeBaseDictionary.ContainsValue Method

[Visual Basic]
Public Function ContainsValue( _
ByVal value As DataTypeBase _
) As Boolean
[C#]
public bool ContainsValue(
DataTypeBase value
);

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


DataTypeBaseDictionary.CopyTo Method

[Visual Basic]
Public Sub CopyTo( _
ByVal array As DataTypeBase(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
DataTypeBase[] array,
int index
);

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


DataTypeBaseDictionary.GetEnumerator Method

[Visual Basic]
Public Function GetEnumerator() As DataTypeBaseDictionaryEnumerator
[C#]
public DataTypeBaseDictionaryEnumerator GetEnumerator();

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


DataTypeBaseDictionary.Inherit Method

Inherits Properties from an existing property dictionary Instance

[Visual Basic]
Overridable Public Sub Inherit( _
ByVal source As DataTypeBaseDictionary _
)
[C#]
public virtual void Inherit(
DataTypeBaseDictionary source
);

Parameters

source
DataType list to inherit

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


DataTypeBaseDictionary.Remove Method

[Visual Basic]
Public Sub Remove( _
ByVal key As String _
)
[C#]
public void Remove(
string key
);

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


DataTypeBaseDictionary.Synchronized Method

[Visual Basic]
Public Shared Function Synchronized( _
ByVal nonSync As DataTypeBaseDictionary _
) As DataTypeBaseDictionary
[C#]
public static DataTypeBaseDictionary Synchronized(
DataTypeBaseDictionary nonSync
);

See Also

DataTypeBaseDictionary Class | NAnt.Core Namespace


DataTypeBaseDictionaryEnumerator Class

For a list of all members of this type, see DataTypeBaseDictionaryEnumerator Members.

System.Object
NAnt.Core.DataTypeBaseDictionaryEnumerator

[Visual Basic]
Public Class DataTypeBaseDictionaryEnumerator
Implements IDictionaryEnumerator, IEnumerator
[C#]
public class DataTypeBaseDictionaryEnumerator : IDictionaryEnumerator, IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

DataTypeBaseDictionaryEnumerator Members | NAnt.Core Namespace


DataTypeBaseDictionaryEnumerator Members

DataTypeBaseDictionaryEnumerator overview

Public Instance Properties

Current
Entry
Key
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataTypeBaseDictionaryEnumerator Class | NAnt.Core Namespace


DataTypeBaseDictionaryEnumerator Properties

The properties of the DataTypeBaseDictionaryEnumerator class are listed below. For a complete list of DataTypeBaseDictionaryEnumerator class members, see the DataTypeBaseDictionaryEnumerator Members topic.

Public Instance Properties

Current
Entry
Key
Value

See Also

DataTypeBaseDictionaryEnumerator Class | NAnt.Core Namespace


Current Property

NAnt SDK Documentation - v0.91

DataTypeBaseDictionaryEnumerator.Current Property

[Visual Basic]
Public ReadOnly Property Current As DataTypeBase
[C#]
public DataTypeBase Current {get;}

See Also

DataTypeBaseDictionaryEnumerator Class | NAnt.Core Namespace


Entry Property

NAnt SDK Documentation - v0.91

DataTypeBaseDictionaryEnumerator.Entry Property

[Visual Basic]
NotOverridable Public ReadOnly Property Entry As DictionaryEntry _
Implements IDictionaryEnumerator.Entry
[C#]
public System.Collections.DictionaryEntry Entry {get;}

Implements

IDictionaryEnumerator.Entry

See Also

DataTypeBaseDictionaryEnumerator Class | NAnt.Core Namespace


Key Property

NAnt SDK Documentation - v0.91

DataTypeBaseDictionaryEnumerator.Key Property

[Visual Basic]
Public ReadOnly Property Key As String
[C#]
public string Key {get;}

See Also

DataTypeBaseDictionaryEnumerator Class | NAnt.Core Namespace


Value Property

NAnt SDK Documentation - v0.91

DataTypeBaseDictionaryEnumerator.Value Property

[Visual Basic]
Public ReadOnly Property Value As DataTypeBase
[C#]
public DataTypeBase Value {get;}

See Also

DataTypeBaseDictionaryEnumerator Class | NAnt.Core Namespace


DataTypeBaseDictionaryEnumerator Methods

The methods of the DataTypeBaseDictionaryEnumerator class are listed below. For a complete list of DataTypeBaseDictionaryEnumerator class members, see the DataTypeBaseDictionaryEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataTypeBaseDictionaryEnumerator Class | NAnt.Core Namespace


DataTypeBaseDictionaryEnumerator.MoveNext Method

[Visual Basic]
NotOverridable Public Function MoveNext() As Boolean _
Implements IEnumerator.MoveNext
[C#]
public bool MoveNext();

Implements

IEnumerator.MoveNext

See Also

DataTypeBaseDictionaryEnumerator Class | NAnt.Core Namespace


DataTypeBaseDictionaryEnumerator.Reset Method

[Visual Basic]
NotOverridable Public Sub Reset() _
Implements IEnumerator.Reset
[C#]
public void Reset();

Implements

IEnumerator.Reset

See Also

DataTypeBaseDictionaryEnumerator Class | NAnt.Core Namespace


DefaultLogger Class

For a list of all members of this type, see DefaultLogger Members.

System.Object
NAnt.Core.DefaultLogger
NAnt.Core.MailLogger

[Visual Basic]
<Serializable, _ Serializable>
Public Class DefaultLogger
Implements IBuildLogger, IBuildListener
[C#]
[Serializable]
[Serializable]
public class DefaultLogger : IBuildLogger, IBuildListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

DefaultLogger Members | NAnt.Core Namespace


DefaultLogger Members

DefaultLogger overview

Public Instance Constructors

DefaultLogger Constructor Initializes a new instance of the DefaultLogger class.

Public Instance Properties

EmacsMode | Gets or sets a value indicating whether to produce emacs (and other editor) friendly output.
OutputWriter | Gets or sets the TextWriter to which the logger is to send its output.
Threshold | Gets or sets the highest level of message this logger should respond to.

Public Instance Methods

BuildFinished | Signals that the last target has finished.
BuildStarted | Signals that a build has started.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush | Flushes buffered build events or messages to the underlying storage.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MessageLogged | Signals that a message has been logged.
TargetFinished | Signals that a task has finished.
TargetStarted | Signals that a target has started.
TaskFinished | Signals that a task has finished.
TaskStarted | Signals that a task has started.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
Log | Empty implementation which allows derived classes to receive the output that is generated in this logger.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultLogger Class | NAnt.Core Namespace


DefaultLogger Constructor

Initializes a new instance of the DefaultLogger class.

[Visual Basic]
Public Sub New()
[C#]
public DefaultLogger();

See Also

DefaultLogger Class | NAnt.Core Namespace


DefaultLogger Properties

The properties of the DefaultLogger class are listed below. For a complete list of DefaultLogger class members, see the DefaultLogger Members topic.

Public Instance Properties

EmacsMode | Gets or sets a value indicating whether to produce emacs (and other editor) friendly output.
OutputWriter | Gets or sets the TextWriter to which the logger is to send its output.
Threshold | Gets or sets the highest level of message this logger should respond to.

See Also

DefaultLogger Class | NAnt.Core Namespace


EmacsMode Property

NAnt SDK Documentation - v0.91

DefaultLogger.EmacsMode Property

Gets or sets a value indicating whether to produce emacs (and other editor) friendly output.

[Visual Basic]
Overridable Public Property EmacsMode As Boolean _
Implements IBuildLogger.EmacsMode
[C#]
public virtual bool EmacsMode {get; set;}

Property Value

true if output is to be unadorned so that emacs and other editors can parse files names, etc. The default is false.

Implements

IBuildLogger.EmacsMode

See Also

DefaultLogger Class | NAnt.Core Namespace


OutputWriter Property

NAnt SDK Documentation - v0.91

DefaultLogger.OutputWriter Property

Gets or sets the TextWriter to which the logger is to send its output.

[Visual Basic]
Overridable Public Property OutputWriter As TextWriter _
Implements IBuildLogger.OutputWriter
[C#]
public virtual System.IO.TextWriter OutputWriter {get; set;}

Property Value

The TextWriter to which the logger sends its output.

Implements

IBuildLogger.OutputWriter

See Also

DefaultLogger Class | NAnt.Core Namespace


Threshold Property

NAnt SDK Documentation - v0.91

DefaultLogger.Threshold Property

Gets or sets the highest level of message this logger should respond to.

[Visual Basic]
Overridable Public Property Threshold As Level _
Implements IBuildLogger.Threshold
[C#]
public virtual Level Threshold {get; set;}

Property Value

The highest level of message this logger should respond to.

Implements

IBuildLogger.Threshold

Remarks

Only messages with a message level higher than or equal to the given level should be written to the log.

See Also

DefaultLogger Class | NAnt.Core Namespace


DefaultLogger Methods

The methods of the DefaultLogger class are listed below. For a complete list of DefaultLogger class members, see the DefaultLogger Members topic.

Public Instance Methods

BuildFinished | Signals that the last target has finished.
BuildStarted | Signals that a build has started.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush | Flushes buffered build events or messages to the underlying storage.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MessageLogged | Signals that a message has been logged.
TargetFinished | Signals that a task has finished.
TargetStarted | Signals that a target has started.
TaskFinished | Signals that a task has finished.
TaskStarted | Signals that a task has started.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
Log | Empty implementation which allows derived classes to receive the output that is generated in this logger.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultLogger Class | NAnt.Core Namespace


DefaultLogger.BuildFinished Method

Signals that the last target has finished.

[Visual Basic]
Overridable Public Sub BuildFinished( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
) _
Implements IBuildListener.BuildFinished
[C#]
public virtual void BuildFinished(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Implements

IBuildListener.BuildFinished

Remarks

This event will still be fired if an error occurred during the build.

See Also

DefaultLogger Class | NAnt.Core Namespace


DefaultLogger.BuildStarted Method

Signals that a build has started.

[Visual Basic]
Overridable Public Sub BuildStarted( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
) _
Implements IBuildListener.BuildStarted
[C#]
public virtual void BuildStarted(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Implements

IBuildListener.BuildStarted

Remarks

This event is fired before any targets have started.

See Also

DefaultLogger Class | NAnt.Core Namespace


DefaultLogger.Flush Method

Flushes buffered build events or messages to the underlying storage.

[Visual Basic]
Overridable Public Sub Flush() _
Implements IBuildLogger.Flush
[C#]
public virtual void Flush();

Implements

IBuildLogger.Flush

See Also

DefaultLogger Class | NAnt.Core Namespace


DefaultLogger.Log Method

Empty implementation which allows derived classes to receive the output that is generated in this logger.

[Visual Basic]
Overridable Protected Sub Log( _
ByVal message As String _
)
[C#]
protected virtual void Log(
string message
);

Parameters

message
The message being logged.

See Also

DefaultLogger Class | NAnt.Core Namespace


DefaultLogger.MessageLogged Method

Signals that a message has been logged.

[Visual Basic]
Overridable Public Sub MessageLogged( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
) _
Implements IBuildListener.MessageLogged
[C#]
public virtual void MessageLogged(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Implements

IBuildListener.MessageLogged

Remarks

Only messages with a priority higher or equal to the threshold of the logger will actually be output in the build log.

See Also

DefaultLogger Class | NAnt.Core Namespace


DefaultLogger.TargetFinished Method

Signals that a task has finished.

[Visual Basic]
Overridable Public Sub TargetFinished( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
) _
Implements IBuildListener.TargetFinished
[C#]
public virtual void TargetFinished(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Implements

IBuildListener.TargetFinished

Remarks

This event will still be fired if an error occurred during the build.

See Also

DefaultLogger Class | NAnt.Core Namespace


DefaultLogger.TargetStarted Method

Signals that a target has started.

[Visual Basic]
Overridable Public Sub TargetStarted( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
) _
Implements IBuildListener.TargetStarted
[C#]
public virtual void TargetStarted(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Implements

IBuildListener.TargetStarted

See Also

DefaultLogger Class | NAnt.Core Namespace


DefaultLogger.TaskFinished Method

Signals that a task has finished.

[Visual Basic]
Overridable Public Sub TaskFinished( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
) _
Implements IBuildListener.TaskFinished
[C#]
public virtual void TaskFinished(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Implements

IBuildListener.TaskFinished

Remarks

This event will still be fired if an error occurred during the build.

See Also

DefaultLogger Class | NAnt.Core Namespace


DefaultLogger.TaskStarted Method

Signals that a task has started.

[Visual Basic]
Overridable Public Sub TaskStarted( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
) _
Implements IBuildListener.TaskStarted
[C#]
public virtual void TaskStarted(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Implements

IBuildListener.TaskStarted

See Also

DefaultLogger Class | NAnt.Core Namespace


DirectoryScanner Class

Used for searching filesystem based on given include/exclude rules.

For a list of all members of this type, see DirectoryScanner Members.

System.Object
NAnt.Core.DirectoryScanner

[Visual Basic]
<Serializable, _ Serializable>
Public Class DirectoryScanner
Implements ICloneable
[C#]
[Serializable]
[Serializable]
public class DirectoryScanner : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Simple client code for testing the class.

                    while (true) {
                        DirectoryScanner scanner = new DirectoryScanner();
                                    Console.Write("Scan Basedirectory : ");
                        string s = Console.ReadLine();
                        if (s.Length == 0) break;
                        scanner.BaseDirectory = s;
                                    while(true) {
                            Console.Write("Include pattern : ");
                            s = Console.ReadLine();
                            if (s.Length == 0) break;
                            scanner.Includes.Add(s);
                        }
                                    while(true) {
                            Console.Write("Exclude pattern : ");
                            s = Console.ReadLine();
                            if (s.Length == 0) break;
                            scanner.Excludes.Add(s);
                        }
                                    foreach (string name in scanner.FileNames)
                            Console.WriteLine("file:" + name);
                        foreach (string name in scanner.DirectoryNames)
                            Console.WriteLine("dir :" + name);
                                    Console.WriteLine("");
                    }

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

DirectoryScanner Members | NAnt.Core Namespace


DirectoryScanner Members

DirectoryScanner overview

Public Instance Constructors

DirectoryScanner Overloaded. Initializes a new instance of the DirectoryScanner class.

Public Instance Properties

BaseDirectory | The base directory to scan. The default is the current directory.
CaseSensitive | Gets or set a value indicating whether or not to use case-sensitive pattern matching.
DirectoryNames | Gets the list of directories that match the given patterns.
Excludes | Gets the collection of exclude patterns.
FileNames | Gets the list of files that match the given patterns.
Includes | Gets the collection of include patterns.
ScannedDirectories | Gets the list of directories that were scanned for files.

Public Instance Methods

Clone | Creates a shallow copy of the DirectoryScanner.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Scan | Uses Includes and Excludes search criteria (relative to BaseDirectory or absolute), to search for filesystem objects.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryScanner Class | NAnt.Core Namespace


DirectoryScanner Constructor

Initializes a new instance of the DirectoryScanner.

Overload List

Initializes a new instance of the DirectoryScanner.

public DirectoryScanner();

Initializes a new instance of the DirectoryScanner specifying whether patterns are to be match case-sensitively.

public DirectoryScanner(bool);

See Also

DirectoryScanner Class | NAnt.Core Namespace


DirectoryScanner Constructor ()

Initializes a new instance of the DirectoryScanner.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DirectoryScanner();

Remarks

On unix, patterns are matching case-sensitively; otherwise, they are matched case-insensitively.

See Also

DirectoryScanner Class | NAnt.Core Namespace | DirectoryScanner Constructor Overload List


DirectoryScanner Constructor (Boolean)

Initializes a new instance of the DirectoryScanner specifying whether patterns are to be match case-sensitively.

[Visual Basic]
Overloads Public Sub New( _
ByVal caseSensitive As Boolean _
)
[C#]
public DirectoryScanner(
bool caseSensitive
);

Parameters

caseSensitive
Specifies whether patterns are to be matched case-sensititely.

See Also

DirectoryScanner Class | NAnt.Core Namespace | DirectoryScanner Constructor Overload List


DirectoryScanner Properties

The properties of the DirectoryScanner class are listed below. For a complete list of DirectoryScanner class members, see the DirectoryScanner Members topic.

Public Instance Properties

BaseDirectory | The base directory to scan. The default is the current directory.
CaseSensitive | Gets or set a value indicating whether or not to use case-sensitive pattern matching.
DirectoryNames | Gets the list of directories that match the given patterns.
Excludes | Gets the collection of exclude patterns.
FileNames | Gets the list of files that match the given patterns.
Includes | Gets the collection of include patterns.
ScannedDirectories | Gets the list of directories that were scanned for files.

See Also

DirectoryScanner Class | NAnt.Core Namespace


BaseDirectory Property

NAnt SDK Documentation - v0.91

DirectoryScanner.BaseDirectory Property

The base directory to scan. The default is the current directory.

[Visual Basic]
Public Property BaseDirectory As DirectoryInfo
[C#]
public System.IO.DirectoryInfo BaseDirectory {get; set;}

See Also

DirectoryScanner Class | NAnt.Core Namespace


CaseSensitive Property

NAnt SDK Documentation - v0.91

DirectoryScanner.CaseSensitive Property

Gets or set a value indicating whether or not to use case-sensitive pattern matching.

[Visual Basic]
Public Property CaseSensitive As Boolean
[C#]
public bool CaseSensitive {get; set;}

See Also

DirectoryScanner Class | NAnt.Core Namespace


DirectoryNames Property

NAnt SDK Documentation - v0.91

DirectoryScanner.DirectoryNames Property

Gets the list of directories that match the given patterns.

[Visual Basic]
Public ReadOnly Property DirectoryNames As StringCollection
[C#]
public System.Collections.Specialized.StringCollection DirectoryNames {get;}

See Also

DirectoryScanner Class | NAnt.Core Namespace


Excludes Property

NAnt SDK Documentation - v0.91

DirectoryScanner.Excludes Property

Gets the collection of exclude patterns.

[Visual Basic]
Public ReadOnly Property Excludes As StringCollection
[C#]
public System.Collections.Specialized.StringCollection Excludes {get;}

See Also

DirectoryScanner Class | NAnt.Core Namespace


FileNames Property

NAnt SDK Documentation - v0.91

DirectoryScanner.FileNames Property

Gets the list of files that match the given patterns.

[Visual Basic]
Public ReadOnly Property FileNames As StringCollection
[C#]
public System.Collections.Specialized.StringCollection FileNames {get;}

See Also

DirectoryScanner Class | NAnt.Core Namespace


Includes Property

NAnt SDK Documentation - v0.91

DirectoryScanner.Includes Property

Gets the collection of include patterns.

[Visual Basic]
Public ReadOnly Property Includes As StringCollection
[C#]
public System.Collections.Specialized.StringCollection Includes {get;}

See Also

DirectoryScanner Class | NAnt.Core Namespace


ScannedDirectories Property

NAnt SDK Documentation - v0.91

DirectoryScanner.ScannedDirectories Property

Gets the list of directories that were scanned for files.

[Visual Basic]
Public ReadOnly Property ScannedDirectories As StringCollection
[C#]
public System.Collections.Specialized.StringCollection ScannedDirectories {get;}

See Also

DirectoryScanner Class | NAnt.Core Namespace


DirectoryScanner Methods

The methods of the DirectoryScanner class are listed below. For a complete list of DirectoryScanner class members, see the DirectoryScanner Members topic.

Public Instance Methods

Clone | Creates a shallow copy of the DirectoryScanner.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Scan | Uses Includes and Excludes search criteria (relative to BaseDirectory or absolute), to search for filesystem objects.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryScanner Class | NAnt.Core Namespace


DirectoryScanner.Clone Method

Creates a shallow copy of the DirectoryScanner.

[Visual Basic]
NotOverridable Public Function Clone() As Object _
Implements ICloneable.Clone
[C#]
public object Clone();

Return Value

A shallow copy of the DirectoryScanner.

Implements

ICloneable.Clone

See Also

DirectoryScanner Class | NAnt.Core Namespace


DirectoryScanner.Scan Method

Uses Includes and Excludes search criteria (relative to BaseDirectory or absolute), to search for filesystem objects.

[Visual Basic]
Public Sub Scan()
[C#]
public void Scan();

See Also

DirectoryScanner Class | NAnt.Core Namespace


Element Class

Models a NAnt XML element in the build file.

For a list of all members of this type, see Element Members.

System.Object
NAnt.Core.Element
Derived types

[Visual Basic]
<Serializable, _ Serializable>
MustInherit Public Class Element
[C#]
[Serializable]
[Serializable]
public abstract class Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Automatically validates attributes in the element based on attributes applied to members in derived classes.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

Element Members | NAnt.Core Namespace


Element Members

Element overview

Public Static (Shared) Methods

InitializeBuildElement

Public Instance Properties

Name | Gets the name of the XML element used to initialize this element.
NamespaceManager | Gets or sets the XmlNamespaceManager.
Parent | Gets or sets the parent of the element.
Project | Gets or sets the Project to which this element belongs.
Properties | Gets the properties local to this Element and the Project.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Overloaded. Performs default initialization.
Log | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Element Overloaded. Initializes a new instance of the Element class.

Protected Instance Properties

CustomXmlProcessing | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location | Gets or sets the location in the build file where the element is defined.
XmlNode | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeElement | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Element Class | NAnt.Core Namespace


Element Constructor

Initializes a new instance of the Element class.

Overload List

Initializes a new instance of the Element class.

protected Element();

Initializes a new instance of the Element class from the specified element.

protected Element(Element);

See Also

Element Class | NAnt.Core Namespace


Element Constructor ()

Initializes a new instance of the Element class.

[Visual Basic]
Overloads Protected Sub New()
[C#]
protected Element();

See Also

Element Class | NAnt.Core Namespace | Element Constructor Overload List


Element Constructor (Element)

Initializes a new instance of the Element class from the specified element.

[Visual Basic]
Overloads Protected Sub New( _
ByVal e As Element _
)
[C#]
protected Element(
Element e
);

Parameters

e
The element that should be used to create a new instance of the Element class.

See Also

Element Class | NAnt.Core Namespace | Element Constructor Overload List


Element Properties

The properties of the Element class are listed below. For a complete list of Element class members, see the Element Members topic.

Public Instance Properties

Name | Gets the name of the XML element used to initialize this element.
NamespaceManager | Gets or sets the XmlNamespaceManager.
Parent | Gets or sets the parent of the element.
Project | Gets or sets the Project to which this element belongs.
Properties | Gets the properties local to this Element and the Project.

Protected Instance Properties

CustomXmlProcessing | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location | Gets or sets the location in the build file where the element is defined.
XmlNode | Gets or sets the XML node of the element.

See Also

Element Class | NAnt.Core Namespace


CustomXmlProcessing Property

NAnt SDK Documentation - v0.91

Element.CustomXmlProcessing Property

Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.

[Visual Basic]
Overridable Protected ReadOnly Property CustomXmlProcessing As Boolean
[C#]
protected virtual bool CustomXmlProcessing {get;}

Property Value

false.

Remarks

Elements that need to perform additional processing of the XmlNode that was used to initialize the element, should override this property and return true.

When true, no build errors will be reported for unknown nested build elements.

See Also

Element Class | NAnt.Core Namespace


Location Property

NAnt SDK Documentation - v0.91

Element.Location Property

Gets or sets the location in the build file where the element is defined.

[Visual Basic]
Overridable Protected Property Location As Location
[C#]
protected virtual Location Location {get; set;}

Property Value

The location in the build file where the element is defined.

See Also

Element Class | NAnt.Core Namespace


Name Property

NAnt SDK Documentation - v0.91

Element.Name Property

Gets the name of the XML element used to initialize this element.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public virtual string Name {get;}

Property Value

The name of the XML element used to initialize this element.

See Also

Element Class | NAnt.Core Namespace


NamespaceManager Property

NAnt SDK Documentation - v0.91

Element.NamespaceManager Property

Gets or sets the XmlNamespaceManager.

[Visual Basic]
Public Property NamespaceManager As XmlNamespaceManager
[C#]
public System.Xml.XmlNamespaceManager NamespaceManager {get; set;}

Property Value

The XmlNamespaceManager.

Remarks

The NamespaceManager defines the current namespace scope and provides methods for looking up namespace information.

See Also

Element Class | NAnt.Core Namespace


Parent Property

NAnt SDK Documentation - v0.91

Element.Parent Property

Gets or sets the parent of the element.

[Visual Basic]
Public Property Parent As Object
[C#]
public object Parent {get; set;}

Property Value

The parent of the element.

Remarks

This will be the parent Task, Target, or Project depending on where the element is defined.

See Also

Element Class | NAnt.Core Namespace


Project Property

NAnt SDK Documentation - v0.91

Element.Project Property

Gets or sets the Project to which this element belongs.

[Visual Basic]
Overridable Public Property Project As Project
[C#]
public virtual Project Project {get; set;}

Property Value

The Project to which this element belongs.

See Also

Element Class | NAnt.Core Namespace


Properties Property

NAnt SDK Documentation - v0.91

Element.Properties Property

Gets the properties local to this Element and the Project.

[Visual Basic]
Overridable Public ReadOnly Property Properties As PropertyDictionary
[C#]
public virtual PropertyDictionary Properties {get;}

Property Value

The properties local to this Element and the Project.

See Also

Element Class | NAnt.Core Namespace


XmlNode Property

NAnt SDK Documentation - v0.91

Element.XmlNode Property

Gets or sets the XML node of the element.

[Visual Basic]
Overridable Protected Property XmlNode As XmlNode
[C#]
protected virtual System.Xml.XmlNode XmlNode {get; set;}

Property Value

The XML node of the element.

See Also

Element Class | NAnt.Core Namespace


Element Methods

The methods of the Element class are listed below. For a complete list of Element class members, see the Element Members topic.

Public Static (Shared) Methods

InitializeBuildElement

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Overloaded. Performs default initialization.
Log | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeElement | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Element Class | NAnt.Core Namespace


Element.CopyTo Method

Copies all instance data of the Element to a given Element.

[Visual Basic]
Protected Sub CopyTo( _
ByVal clone As Element _
)
[C#]
protected void CopyTo(
Element clone
);

See Also

Element Class | NAnt.Core Namespace


GetAttributeConfigurationNode Method

NAnt SDK Documentation - v0.91

Element.GetAttributeConfigurationNode Method

Locates the XML node for the specified attribute in the project configuration node.

Overload List

Locates the XML node for the specified attribute in the project configuration node.

protected virtual XmlNode GetAttributeConfigurationNode(FrameworkInfo,string);

protected XmlNode GetAttributeConfigurationNode(XmlNode,FrameworkInfo,string);

See Also

Element Class | NAnt.Core Namespace


Element.GetAttributeConfigurationNode Method (FrameworkInfo, String)

Locates the XML node for the specified attribute in the project configuration node.

[Visual Basic]
Overridable Overloads Protected Function GetAttributeConfigurationNode( _
ByVal framework As FrameworkInfo, _
ByVal attributeName As String _
) As XmlNode
[C#]
protected virtual XmlNode GetAttributeConfigurationNode(
FrameworkInfo framework,
string attributeName
);

Parameters

framework
The framework to use to obtain framework specific information, or a null reference (Nothing in Visual Basic) if no framework specific information should be used.
attributeName
The name of attribute for which the XML configuration node should be located.

Return Value

The XML configuration node for the specified attribute, or a null reference (Nothing in Visual Basic) if no corresponding XML node could be located.

Remarks

If there's a valid current framework, the configuration section for that framework will first be searched. If no corresponding configuration node can be located in that section, the framework-neutral section of the project configuration node will be searched.

See Also

Element Class | NAnt.Core Namespace | Element.GetAttributeConfigurationNode Overload List


Element.GetAttributeConfigurationNode Method (XmlNode, FrameworkInfo, String)

[Visual Basic]
Overloads Protected Function GetAttributeConfigurationNode( _
ByVal configSection As XmlNode, _
ByVal framework As FrameworkInfo, _
ByVal attributeName As String _
) As XmlNode
[C#]
protected XmlNode GetAttributeConfigurationNode(
XmlNode configSection,
FrameworkInfo framework,
string attributeName
);

See Also

Element Class | NAnt.Core Namespace | Element.GetAttributeConfigurationNode Overload List


Element.GetLocation Method

Retrieves the location in the build file where the element is defined.

[Visual Basic]
Public Function GetLocation() As Location
[C#]
public Location GetLocation();

Return Value

The element's build file location

See Also

Element Class | NAnt.Core Namespace


Initialize Method

NAnt SDK Documentation - v0.91

Element.Initialize Method

Derived classes should override to this method to provide extra initialization and validation not covered by the base class.

Overload List

Derived classes should override to this method to provide extra initialization and validation not covered by the base class.

protected virtual void Initialize();

Performs default initialization.

public void Initialize(XmlNode);

See Also

Element Class | NAnt.Core Namespace


Element.Initialize Method ()

Derived classes should override to this method to provide extra initialization and validation not covered by the base class.

[Visual Basic]
Overridable Overloads Protected Sub Initialize()
[C#]
protected virtual void Initialize();

Remarks

Access to the XmlNode that was used to initialize this Element is available through XmlNode.

See Also

Element Class | NAnt.Core Namespace | Element.Initialize Overload List


Element.Initialize Method (XmlNode)

Performs default initialization.

[Visual Basic]
Overloads Public Sub Initialize( _
ByVal elementNode As XmlNode _
)
[C#]
public void Initialize(
XmlNode elementNode
);

Remarks

Derived classes that wish to add custom initialization should override the Initialize method.

See Also

Element Class | NAnt.Core Namespace | Element.Initialize Overload List


Element.InitializeBuildElement Method

[Visual Basic]
Public Shared Function InitializeBuildElement( _
ByVal parent As Element, _
ByVal childNode As XmlNode, _
ByVal buildElement As Element, _
ByVal elementType As Type _
) As Element
[C#]
public static Element InitializeBuildElement(
Element parent,
XmlNode childNode,
Element buildElement,
Type elementType
);

See Also

Element Class | NAnt.Core Namespace


Element.InitializeElement Method

NOTE: This method is now obsolete.

Deprecated. Use Initialize() instead

Derived classes should override to this method to provide extra initialization and validation not covered by the base class.

[Visual Basic]
<Obsolete(Message:="Deprecated. Use Initialize() instead", IsError:=False)>
Overridable Protected Sub InitializeElement( _
ByVal elementNode As XmlNode _
)
[C#]
[Obsolete(Message="Deprecated. Use Initialize() instead", IsError=False)]
protected virtual void InitializeElement(
XmlNode elementNode
);

Parameters

elementNode
The XML node of the element to use for initialization.

See Also

Element Class | NAnt.Core Namespace


Element.InitializeXml Method

Initializes all build attributes and child elements.

[Visual Basic]
Overridable Protected Sub InitializeXml( _
ByVal elementNode As XmlNode, _
ByVal properties As PropertyDictionary, _
ByVal framework As FrameworkInfo _
)
[C#]
protected virtual void InitializeXml(
XmlNode elementNode,
PropertyDictionary properties,
FrameworkInfo framework
);

See Also

Element Class | NAnt.Core Namespace


Log Method

NAnt SDK Documentation - v0.91

Element.Log Method

Logs a message with the given priority.

Overload List

Logs a message with the given priority.

public virtual void Log(Level,string);

Logs a message with the given priority.

public virtual void Log(Level,string,params object[]);

See Also

Element Class | NAnt.Core Namespace


Element.Log Method (Level, String)

Logs a message with the given priority.

[Visual Basic]
Overridable Overloads Public Sub Log( _
ByVal messageLevel As Level, _
ByVal message As String _
)
[C#]
public virtual void Log(
Level messageLevel,
string message
);

Parameters

messageLevel
The message priority at which the specified message is to be logged.
message
The message to be logged.

Remarks

The actual logging is delegated to the project.

See Also

Element Class | NAnt.Core Namespace | Element.Log Overload List


Element.Log Method (Level, String, Object[])

Logs a message with the given priority.

[Visual Basic]
Overridable Overloads Public Sub Log( _
ByVal messageLevel As Level, _
ByVal message As String, _
ParamArray args As Object() _
)
[C#]
public virtual void Log(
Level messageLevel,
string message,
params object[] args
);

Parameters

messageLevel
The message priority at which the specified message is to be logged.
message
The message to log, containing zero or more format items.
args
An Object array containing zero or more objects to format.

Remarks

The actual logging is delegated to the project.

See Also

Element Class | NAnt.Core Namespace | Element.Log Overload List


Element.AttributeConfigurator Class

Configures an Element using meta-data provided by assigned attributes.

For a list of all members of this type, see Element.AttributeConfigurator Members.

System.Object
NAnt.Core.Element.AttributeConfigurator
NAnt.Core.Filters.FilterChain.FilterChainConfigurator

[Visual Basic]
Public Class Element.AttributeConfigurator
[C#]
public class Element.AttributeConfigurator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

Element.AttributeConfigurator Members | NAnt.Core Namespace


Element.AttributeConfigurator Members

Element.AttributeConfigurator overview

Public Instance Constructors

Element.AttributeConfigurator Constructor Initializes a new instance of the Element.AttributeConfigurator class for the given Element.

Public Instance Properties

Element |
ElementXml |
Location |
Name |
NamespaceManager | Gets the XmlNamespaceManager.
Project |
Properties |
TargetFramework |
UnprocessedAttributes |
UnprocessedChildNodes |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InitializeAttribute |
InitializeBuildElement |
InitializeBuildElementCollection |
InitializeChildElement |
InitializeOrderedChildElements |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


Element.AttributeConfigurator Constructor

Initializes a new instance of the Element.AttributeConfigurator class for the given Element.

[Visual Basic]
Public Sub New( _
ByVal element As Element, _
ByVal elementNode As XmlNode, _
ByVal properties As PropertyDictionary, _
ByVal targetFramework As FrameworkInfo _
)
[C#]
public Element.AttributeConfigurator(
Element element,
XmlNode elementNode,
PropertyDictionary properties,
FrameworkInfo targetFramework
);

Parameters

element
The Element for which an Element.AttributeConfigurator should be created.
elementNode
The XmlNode to initialize the Element with.
properties
The PropertyDictionary to use for property expansion.
targetFramework
The framework that the Element should target.

Exceptions

Exception Type | Condition
ArgumentNullException | element is a null reference (Nothing in Visual Basic). -or- elementNode is a null reference (Nothing in Visual Basic). -or- properties is a null reference (Nothing in Visual Basic).

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


Element.AttributeConfigurator Properties

The properties of the Element.AttributeConfigurator class are listed below. For a complete list of Element.AttributeConfigurator class members, see the Element.AttributeConfigurator Members topic.

Public Instance Properties

Element |
ElementXml |
Location |
Name |
NamespaceManager | Gets the XmlNamespaceManager.
Project |
Properties |
TargetFramework |
UnprocessedAttributes |
UnprocessedChildNodes |

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


Element Property

NAnt SDK Documentation - v0.91

Element.AttributeConfigurator.Element Property

[Visual Basic]
Public ReadOnly Property Element As Element
[C#]
public Element Element {get;}

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


ElementXml Property

NAnt SDK Documentation - v0.91

Element.AttributeConfigurator.ElementXml Property

[Visual Basic]
Public ReadOnly Property ElementXml As XmlNode
[C#]
public System.Xml.XmlNode ElementXml {get;}

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


Location Property

NAnt SDK Documentation - v0.91

Element.AttributeConfigurator.Location Property

[Visual Basic]
Public ReadOnly Property Location As Location
[C#]
public Location Location {get;}

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


Name Property

NAnt SDK Documentation - v0.91

Element.AttributeConfigurator.Name Property

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


NamespaceManager Property

NAnt SDK Documentation - v0.91

Element.AttributeConfigurator.NamespaceManager Property

Gets the XmlNamespaceManager.

[Visual Basic]
Public ReadOnly Property NamespaceManager As XmlNamespaceManager
[C#]
public System.Xml.XmlNamespaceManager NamespaceManager {get;}

Property Value

The XmlNamespaceManager.

Remarks

The NamespaceManager defines the current namespace scope and provides methods for looking up namespace information.

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


Project Property

NAnt SDK Documentation - v0.91

Element.AttributeConfigurator.Project Property

[Visual Basic]
Public ReadOnly Property Project As Project
[C#]
public Project Project {get;}

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


Properties Property

NAnt SDK Documentation - v0.91

Element.AttributeConfigurator.Properties Property

[Visual Basic]
Public ReadOnly Property Properties As PropertyDictionary
[C#]
public PropertyDictionary Properties {get;}

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


TargetFramework Property

NAnt SDK Documentation - v0.91

Element.AttributeConfigurator.TargetFramework Property

[Visual Basic]
Public ReadOnly Property TargetFramework As FrameworkInfo
[C#]
public FrameworkInfo TargetFramework {get;}

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


UnprocessedAttributes Property

NAnt SDK Documentation - v0.91

Element.AttributeConfigurator.UnprocessedAttributes Property

[Visual Basic]
Public ReadOnly Property UnprocessedAttributes As StringCollection
[C#]
public System.Collections.Specialized.StringCollection UnprocessedAttributes {get;}

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


UnprocessedChildNodes Property

NAnt SDK Documentation - v0.91

Element.AttributeConfigurator.UnprocessedChildNodes Property

[Visual Basic]
Public ReadOnly Property UnprocessedChildNodes As StringCollection
[C#]
public System.Collections.Specialized.StringCollection UnprocessedChildNodes {get;}

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


Element.AttributeConfigurator Methods

The methods of the Element.AttributeConfigurator class are listed below. For a complete list of Element.AttributeConfigurator class members, see the Element.AttributeConfigurator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InitializeAttribute |
InitializeBuildElement |
InitializeBuildElementCollection |
InitializeChildElement |
InitializeOrderedChildElements |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


Element.AttributeConfigurator.Initialize Method

[Visual Basic]
Public Sub Initialize()
[C#]
public void Initialize();

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


Element.AttributeConfigurator.InitializeAttribute Method

[Visual Basic]
Overridable Protected Function InitializeAttribute( _
ByVal propertyInfo As PropertyInfo _
) As Boolean
[C#]
protected virtual bool InitializeAttribute(
PropertyInfo propertyInfo
);

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


Element.AttributeConfigurator.InitializeBuildElement Method

[Visual Basic]
Overridable Protected Function InitializeBuildElement( _
ByVal childNode As XmlNode, _
ByVal elementType As Type _
) As Element
[C#]
protected virtual Element InitializeBuildElement(
XmlNode childNode,
Type elementType
);

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


Element.AttributeConfigurator.InitializeBuildElementCollection Method

[Visual Basic]
Overridable Protected Function InitializeBuildElementCollection( _
ByVal propertyInfo As PropertyInfo _
) As Boolean
[C#]
protected virtual bool InitializeBuildElementCollection(
PropertyInfo propertyInfo
);

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


Element.AttributeConfigurator.InitializeChildElement Method

[Visual Basic]
Overridable Protected Function InitializeChildElement( _
ByVal propertyInfo As PropertyInfo, _
ByVal getter As MethodInfo, _
ByVal setter As MethodInfo _
) As Boolean
[C#]
protected virtual bool InitializeChildElement(
PropertyInfo propertyInfo,
MethodInfo getter,
MethodInfo setter
);

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


Element.AttributeConfigurator.InitializeOrderedChildElements Method

[Visual Basic]
Overridable Protected Sub InitializeOrderedChildElements()
[C#]
protected virtual void InitializeOrderedChildElements();

See Also

Element.AttributeConfigurator Class | NAnt.Core Namespace


ExpressionEvalBase Class

For a list of all members of this type, see ExpressionEvalBase Members.

System.Object
NAnt.Core.ExpressionEvalBase
NAnt.Core.ExpressionEvaluator

[Visual Basic]
MustInherit Public Class ExpressionEvalBase
[C#]
public abstract class ExpressionEvalBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ExpressionEvalBase Members | NAnt.Core Namespace


ExpressionEvalBase Members

ExpressionEvalBase overview

Public Instance Constructors

ExpressionEvalBase Constructor

Public Instance Properties

Project

Public Instance Methods

CheckSyntax |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Evaluate | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BuildParseError | Overloaded.
EvaluateFunction |
EvaluateProperty |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetSimpleTypeName |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SafeConvert |
UnexpectedToken |

See Also

ExpressionEvalBase Class | NAnt.Core Namespace


ExpressionEvalBase Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project _
)
[C#]
public ExpressionEvalBase(
Project project
);

See Also

ExpressionEvalBase Class | NAnt.Core Namespace


ExpressionEvalBase Properties

The properties of the ExpressionEvalBase class are listed below. For a complete list of ExpressionEvalBase class members, see the ExpressionEvalBase Members topic.

Public Instance Properties

Project

See Also

ExpressionEvalBase Class | NAnt.Core Namespace


Project Property

NAnt SDK Documentation - v0.91

ExpressionEvalBase.Project Property

[Visual Basic]
Public ReadOnly Property Project As Project
[C#]
public Project Project {get;}

See Also

ExpressionEvalBase Class | NAnt.Core Namespace


ExpressionEvalBase Methods

The methods of the ExpressionEvalBase class are listed below. For a complete list of ExpressionEvalBase class members, see the ExpressionEvalBase Members topic.

Public Instance Methods

CheckSyntax |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Evaluate | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BuildParseError | Overloaded.
EvaluateFunction |
EvaluateProperty |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetSimpleTypeName |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SafeConvert |
UnexpectedToken |

See Also

ExpressionEvalBase Class | NAnt.Core Namespace


BuildParseError Method

NAnt SDK Documentation - v0.91

ExpressionEvalBase.BuildParseError Method

Overload List

protected ExpressionParseException BuildParseError(string,Position);

protected ExpressionParseException BuildParseError(string,Position,Position);

protected ExpressionParseException BuildParseError(string,Position,Position,Exception);

See Also

ExpressionEvalBase Class | NAnt.Core Namespace


ExpressionEvalBase.BuildParseError Method (String, Position)

[Visual Basic]
Overloads Protected Function BuildParseError( _
ByVal desc As String, _
ByVal p0 As Position _
) As ExpressionParseException
[C#]
protected ExpressionParseException BuildParseError(
string desc,
Position p0
);

See Also

ExpressionEvalBase Class | NAnt.Core Namespace | ExpressionEvalBase.BuildParseError Overload List


ExpressionEvalBase.BuildParseError Method (String, Position, Position)

[Visual Basic]
Overloads Protected Function BuildParseError( _
ByVal desc As String, _
ByVal p0 As Position, _
ByVal p1 As Position _
) As ExpressionParseException
[C#]
protected ExpressionParseException BuildParseError(
string desc,
Position p0,
Position p1
);

See Also

ExpressionEvalBase Class | NAnt.Core Namespace | ExpressionEvalBase.BuildParseError Overload List


ExpressionEvalBase.BuildParseError Method (String, Position, Position, Exception)

[Visual Basic]
Overloads Protected Function BuildParseError( _
ByVal desc As String, _
ByVal p0 As Position, _
ByVal p1 As Position, _
ByVal ex As Exception _
) As ExpressionParseException
[C#]
protected ExpressionParseException BuildParseError(
string desc,
Position p0,
Position p1,
Exception ex
);

See Also

ExpressionEvalBase Class | NAnt.Core Namespace | ExpressionEvalBase.BuildParseError Overload List


ExpressionEvalBase.CheckSyntax Method

[Visual Basic]
Public Sub CheckSyntax( _
ByVal s As String _
)
[C#]
public void CheckSyntax(
string s
);

See Also

ExpressionEvalBase Class | NAnt.Core Namespace


Evaluate Method

NAnt SDK Documentation - v0.91

ExpressionEvalBase.Evaluate Method

Overload List

public object Evaluate(ExpressionTokenizer);

public object Evaluate(string);

See Also

ExpressionEvalBase Class | NAnt.Core Namespace


ExpressionEvalBase.Evaluate Method (ExpressionTokenizer)

[Visual Basic]
Overloads Public Function Evaluate( _
ByVal tokenizer As ExpressionTokenizer _
) As Object
[C#]
public object Evaluate(
ExpressionTokenizer tokenizer
);

See Also

ExpressionEvalBase Class | NAnt.Core Namespace | ExpressionEvalBase.Evaluate Overload List


ExpressionEvalBase.Evaluate Method (String)

[Visual Basic]
Overloads Public Function Evaluate( _
ByVal s As String _
) As Object
[C#]
public object Evaluate(
string s
);

See Also

ExpressionEvalBase Class | NAnt.Core Namespace | ExpressionEvalBase.Evaluate Overload List


ExpressionEvalBase.EvaluateFunction Method

[Visual Basic]
MustOverride Protected Function EvaluateFunction( _
ByVal method As MethodInfo, _
ByVal args As Object() _
) As Object
[C#]
protected abstract object EvaluateFunction(
MethodInfo method,
object[] args
);

See Also

ExpressionEvalBase Class | NAnt.Core Namespace


ExpressionEvalBase.EvaluateProperty Method

[Visual Basic]
MustOverride Protected Function EvaluateProperty( _
ByVal propertyName As String _
) As Object
[C#]
protected abstract object EvaluateProperty(
string propertyName
);

See Also

ExpressionEvalBase Class | NAnt.Core Namespace


ExpressionEvalBase.GetSimpleTypeName Method

[Visual Basic]
Protected Function GetSimpleTypeName( _
ByVal t As Type _
) As String
[C#]
protected string GetSimpleTypeName(
Type t
);

See Also

ExpressionEvalBase Class | NAnt.Core Namespace


ExpressionEvalBase.SafeConvert Method

[Visual Basic]
Protected Function SafeConvert( _
ByVal returnType As Type, _
ByVal source As Object, _
ByVal description As String, _
ByVal p0 As Position, _
ByVal p1 As Position _
) As Object
[C#]
protected object SafeConvert(
Type returnType,
object source,
string description,
Position p0,
Position p1
);

See Also

ExpressionEvalBase Class | NAnt.Core Namespace


ExpressionEvalBase.UnexpectedToken Method

[Visual Basic]
Overridable Protected Function UnexpectedToken() As Object
[C#]
protected virtual object UnexpectedToken();

See Also

ExpressionEvalBase Class | NAnt.Core Namespace


ExpressionEvaluator Class

For a list of all members of this type, see ExpressionEvaluator Members.

System.Object
NAnt.Core.ExpressionEvalBase
NAnt.Core.ExpressionEvaluator

[Visual Basic]
<FunctionSet(Category:="NAnt", Prefix:="property")>
Public Class ExpressionEvaluator
Inherits ExpressionEvalBase
[C#]
[FunctionSet(Category="NAnt", Prefix="property")]
public class ExpressionEvaluator : ExpressionEvalBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ExpressionEvaluator Members | NAnt.Core Namespace


ExpressionEvaluator Members

ExpressionEvaluator overview

Public Instance Constructors

ExpressionEvaluator Constructor

Public Instance Properties

Project (inherited from ExpressionEvalBase)

Public Instance Methods

CheckSyntax (inherited from ExpressionEvalBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Evaluate (inherited from ExpressionEvalBase) | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPropertyValue | Gets the value of the specified property.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BuildParseError (inherited from ExpressionEvalBase) | Overloaded.
EvaluateFunction |
EvaluateProperty |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetSimpleTypeName (inherited from ExpressionEvalBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SafeConvert (inherited from ExpressionEvalBase) |
UnexpectedToken (inherited from ExpressionEvalBase) |

See Also

ExpressionEvaluator Class | NAnt.Core Namespace


ExpressionEvaluator Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary, _
ByVal state As Hashtable, _
ByVal visiting As Stack _
)
[C#]
public ExpressionEvaluator(
Project project,
PropertyDictionary properties,
Hashtable state,
Stack visiting
);

See Also

ExpressionEvaluator Class | NAnt.Core Namespace


ExpressionEvaluator Methods

The methods of the ExpressionEvaluator class are listed below. For a complete list of ExpressionEvaluator class members, see the ExpressionEvaluator Members topic.

Public Instance Methods

CheckSyntax (inherited from ExpressionEvalBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Evaluate (inherited from ExpressionEvalBase) | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPropertyValue | Gets the value of the specified property.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BuildParseError (inherited from ExpressionEvalBase) | Overloaded.
EvaluateFunction |
EvaluateProperty |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetSimpleTypeName (inherited from ExpressionEvalBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SafeConvert (inherited from ExpressionEvalBase) |
UnexpectedToken (inherited from ExpressionEvalBase) |

See Also

ExpressionEvaluator Class | NAnt.Core Namespace


ExpressionEvaluator.EvaluateFunction Method

[Visual Basic]
Overrides Protected Function EvaluateFunction( _
ByVal methodInfo As MethodInfo, _
ByVal args As Object() _
) As Object
[C#]
protected override object EvaluateFunction(
MethodInfo methodInfo,
object[] args
);

See Also

ExpressionEvaluator Class | NAnt.Core Namespace


ExpressionEvaluator.EvaluateProperty Method

[Visual Basic]
Overrides Protected Function EvaluateProperty( _
ByVal propertyName As String _
) As Object
[C#]
protected override object EvaluateProperty(
string propertyName
);

See Also

ExpressionEvaluator Class | NAnt.Core Namespace


ExpressionEvaluator.GetPropertyValue Method

Gets the value of the specified property.

[Visual Basic]
<Function(Name:="get-value")>
Public Function GetPropertyValue( _
ByVal propertyName As String _
) As String
[C#]
[Function(Name="get-value")]
public string GetPropertyValue(
string propertyName
);

Parameters

propertyName
The name of the property to get the value of.

Return Value

The value of the specified property.

See Also

ExpressionEvaluator Class | NAnt.Core Namespace


ExpressionParseException Class

For a list of all members of this type, see ExpressionParseException Members.

System.Object
System.Exception
NAnt.Core.ExpressionParseException

[Visual Basic]
<Serializable, _ Serializable>
Public Class ExpressionParseException
Inherits Exception
[C#]
[Serializable]
[Serializable]
public class ExpressionParseException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ExpressionParseException Members | NAnt.Core Namespace


ExpressionParseException Members

ExpressionParseException overview

Public Instance Constructors

ExpressionParseException Overloaded. Initializes a new instance of the ExpressionParseException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional user-defined information about the exception.
EndPos |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
StartPos |
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

ExpressionParseException Overloaded. Initializes a new instance of the ExpressionParseException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Instance Events

SerializeObjectState (inherited from Exception)

See Also

ExpressionParseException Class | NAnt.Core Namespace


ExpressionParseException Constructor

Initializes a new instance of the ExpressionParseException class.

Overload List

Initializes a new instance of the ExpressionParseException class.

public ExpressionParseException();

protected ExpressionParseException(SerializationInfo,StreamingContext);

public ExpressionParseException(string);

public ExpressionParseException(string,Exception);

public ExpressionParseException(string,int);

public ExpressionParseException(string,int,int);

public ExpressionParseException(string,int,int,Exception);

See Also

ExpressionParseException Class | NAnt.Core Namespace


ExpressionParseException Constructor ()

Initializes a new instance of the ExpressionParseException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ExpressionParseException();

See Also

ExpressionParseException Class | NAnt.Core Namespace | ExpressionParseException Constructor Overload List


ExpressionParseException Constructor (String)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public ExpressionParseException(
string message
);

See Also

ExpressionParseException Class | NAnt.Core Namespace | ExpressionParseException Constructor Overload List


ExpressionParseException Constructor (String, Exception)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
[C#]
public ExpressionParseException(
string message,
Exception inner
);

See Also

ExpressionParseException Class | NAnt.Core Namespace | ExpressionParseException Constructor Overload List


ExpressionParseException Constructor (SerializationInfo, StreamingContext)

[Visual Basic]
Overloads Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
protected ExpressionParseException(
SerializationInfo info,
StreamingContext context
);

See Also

ExpressionParseException Class | NAnt.Core Namespace | ExpressionParseException Constructor Overload List


ExpressionParseException Constructor (String, Int32)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal pos As Integer _
)
[C#]
public ExpressionParseException(
string message,
int pos
);

See Also

ExpressionParseException Class | NAnt.Core Namespace | ExpressionParseException Constructor Overload List


ExpressionParseException Constructor (String, Int32, Int32)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal startPos As Integer, _
ByVal endPos As Integer _
)
[C#]
public ExpressionParseException(
string message,
int startPos,
int endPos
);

See Also

ExpressionParseException Class | NAnt.Core Namespace | ExpressionParseException Constructor Overload List


ExpressionParseException Constructor (String, Int32, Int32, Exception)

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal startPos As Integer, _
ByVal endPos As Integer, _
ByVal inner As Exception _
)
[C#]
public ExpressionParseException(
string message,
int startPos,
int endPos,
Exception inner
);

See Also

ExpressionParseException Class | NAnt.Core Namespace | ExpressionParseException Constructor Overload List


ExpressionParseException Properties

The properties of the ExpressionParseException class are listed below. For a complete list of ExpressionParseException class members, see the ExpressionParseException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional user-defined information about the exception.
EndPos |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
StartPos |
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

ExpressionParseException Class | NAnt.Core Namespace


EndPos Property

NAnt SDK Documentation - v0.91

ExpressionParseException.EndPos Property

[Visual Basic]
Public ReadOnly Property EndPos As Integer
[C#]
public int EndPos {get;}

See Also

ExpressionParseException Class | NAnt.Core Namespace


StartPos Property

NAnt SDK Documentation - v0.91

ExpressionParseException.StartPos Property

[Visual Basic]
Public ReadOnly Property StartPos As Integer
[C#]
public int StartPos {get;}

See Also

ExpressionParseException Class | NAnt.Core Namespace


ExpressionParseException Methods

The methods of the ExpressionParseException class are listed below. For a complete list of ExpressionParseException class members, see the ExpressionParseException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpressionParseException Class | NAnt.Core Namespace


ExpressionParseException.GetObjectData Method

[Visual Basic]
Overrides Public Sub GetObjectData( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
) _
Implements ISerializable.GetObjectData
[C#]
public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.GetObjectData

See Also

ExpressionParseException Class | NAnt.Core Namespace


ExpressionTokenizer Class

Splits an input string into a sequence of tokens used during parsing.

For a list of all members of this type, see ExpressionTokenizer Members.

System.Object
NAnt.Core.ExpressionTokenizer

[Visual Basic]
Public Class ExpressionTokenizer
[C#]
public class ExpressionTokenizer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ExpressionTokenizer Members | NAnt.Core Namespace


ExpressionTokenizer Members

ExpressionTokenizer overview

Public Instance Constructors

ExpressionTokenizer Constructor Initializes a new instance of the ExpressionTokenizer class.

Public Instance Properties

CurrentPosition
CurrentToken
IgnoreWhitespace
SingleCharacterMode
TokenText

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetNextToken |
GetType (inherited from Object) | Gets the Type of the current instance.
InitTokenizer |
IsKeyword |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpressionTokenizer Class | NAnt.Core Namespace


ExpressionTokenizer Constructor

Initializes a new instance of the ExpressionTokenizer class.

[Visual Basic]
Public Sub New()
[C#]
public ExpressionTokenizer();

See Also

ExpressionTokenizer Class | NAnt.Core Namespace


ExpressionTokenizer Properties

The properties of the ExpressionTokenizer class are listed below. For a complete list of ExpressionTokenizer class members, see the ExpressionTokenizer Members topic.

Public Instance Properties

CurrentPosition
CurrentToken
IgnoreWhitespace
SingleCharacterMode
TokenText

See Also

ExpressionTokenizer Class | NAnt.Core Namespace


CurrentPosition Property

NAnt SDK Documentation - v0.91

ExpressionTokenizer.CurrentPosition Property

[Visual Basic]
Public ReadOnly Property CurrentPosition As Position
[C#]
public ExpressionTokenizer.Position CurrentPosition {get;}

See Also

ExpressionTokenizer Class | NAnt.Core Namespace


CurrentToken Property

NAnt SDK Documentation - v0.91

ExpressionTokenizer.CurrentToken Property

[Visual Basic]
Public ReadOnly Property CurrentToken As TokenType
[C#]
public ExpressionTokenizer.TokenType CurrentToken {get;}

See Also

ExpressionTokenizer Class | NAnt.Core Namespace


IgnoreWhitespace Property

NAnt SDK Documentation - v0.91

ExpressionTokenizer.IgnoreWhitespace Property

[Visual Basic]
Public Property IgnoreWhitespace As Boolean
[C#]
public bool IgnoreWhitespace {get; set;}

See Also

ExpressionTokenizer Class | NAnt.Core Namespace


SingleCharacterMode Property

NAnt SDK Documentation - v0.91

ExpressionTokenizer.SingleCharacterMode Property

[Visual Basic]
Public Property SingleCharacterMode As Boolean
[C#]
public bool SingleCharacterMode {get; set;}

See Also

ExpressionTokenizer Class | NAnt.Core Namespace


TokenText Property

NAnt SDK Documentation - v0.91

ExpressionTokenizer.TokenText Property

[Visual Basic]
Public ReadOnly Property TokenText As String
[C#]
public string TokenText {get;}

See Also

ExpressionTokenizer Class | NAnt.Core Namespace


ExpressionTokenizer Methods

The methods of the ExpressionTokenizer class are listed below. For a complete list of ExpressionTokenizer class members, see the ExpressionTokenizer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetNextToken |
GetType (inherited from Object) | Gets the Type of the current instance.
InitTokenizer |
IsKeyword |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpressionTokenizer Class | NAnt.Core Namespace


ExpressionTokenizer.GetNextToken Method

[Visual Basic]
Public Sub GetNextToken()
[C#]
public void GetNextToken();

See Also

ExpressionTokenizer Class | NAnt.Core Namespace


ExpressionTokenizer.InitTokenizer Method

[Visual Basic]
Public Sub InitTokenizer( _
ByVal s As String _
)
[C#]
public void InitTokenizer(
string s
);

See Also

ExpressionTokenizer Class | NAnt.Core Namespace


ExpressionTokenizer.IsKeyword Method

[Visual Basic]
Public Function IsKeyword( _
ByVal k As String _
) As Boolean
[C#]
public bool IsKeyword(
string k
);

See Also

ExpressionTokenizer Class | NAnt.Core Namespace


ExpressionTokenizer.Position Structure

For a list of all members of this type, see ExpressionTokenizer.Position Members.

System.Object
System.ValueType
NAnt.Core.ExpressionTokenizer.Position

[Visual Basic]
Public Structure ExpressionTokenizer.Position
[C#]
public struct ExpressionTokenizer.Position

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ExpressionTokenizer.Position Members | NAnt.Core Namespace


ExpressionTokenizer.Position Members

ExpressionTokenizer.Position overview

Public Instance Constructors

ExpressionTokenizer.Position Constructor

Public Instance Properties

CharIndex

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ExpressionTokenizer.Position Class | NAnt.Core Namespace


ExpressionTokenizer.Position Constructor

[Visual Basic]
Public Sub New( _
ByVal charIndex As Integer _
)
[C#]
public ExpressionTokenizer.Position(
int charIndex
);

See Also

ExpressionTokenizer.Position Class | NAnt.Core Namespace


ExpressionTokenizer.Position Properties

The properties of the ExpressionTokenizer.Position structure are listed below. For a complete list of ExpressionTokenizer.Position structure members, see the ExpressionTokenizer.Position Members topic.

Public Instance Properties

CharIndex

See Also

ExpressionTokenizer.Position Class | NAnt.Core Namespace


CharIndex Property

NAnt SDK Documentation - v0.91

ExpressionTokenizer.Position.CharIndex Property

[Visual Basic]
Public ReadOnly Property CharIndex As Integer
[C#]
public int CharIndex {get;}

See Also

ExpressionTokenizer.Position Class | NAnt.Core Namespace


ExpressionTokenizer.TokenType Enumeration

Available tokens

[Visual Basic]
<Serializable>
Public Enum ExpressionTokenizer.TokenType
[C#]
[Serializable]
public enum ExpressionTokenizer.TokenType

Members

Member Name | Description
BOF |
EOF |
Number |
String |
Keyword |
EQ |
NE |
LT |
GT |
LE |
GE |
Plus |
Minus |
Mul |
Div |
Mod |
LeftParen |
RightParen |
LeftCurlyBrace |
RightCurlyBrace |
Not |
Punctuation |
Whitespace |
Dollar |
Comma |
Dot |
DoubleColon |

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

NAnt.Core Namespace


FrameworkInfo Class

Encalsulates information about installed frameworks incuding version information and directory locations for finding tools.

For a list of all members of this type, see FrameworkInfo Members.

System.Object
NAnt.Core.FrameworkInfo

[Visual Basic]
<Serializable, _ Serializable>
Public Class FrameworkInfo
Implements ISerializable
[C#]
[Serializable]
[Serializable]
public class FrameworkInfo : ISerializable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FrameworkInfo Members | NAnt.Core Namespace


FrameworkInfo Members

FrameworkInfo overview

Public Instance Properties

ClrType | Gets the CLR type of the framework.
ClrVersion | Gets the Common Language Runtime version of the framework.
Description | Gets the description of the framework.
Family | Gets the family of the framework.
FrameworkAssemblyDirectory | Gets the directory where the system assemblies for the framework are located.
FrameworkDirectory | Gets the base directory of the framework tools for the framework.
IsValid | Returns a value indicating whether the current framework is valid.
Name | Gets the name of the framework.
Project | Gets the Project used to initialize this framework.
SdkDirectory | Gets the directory containing the SDK tools for the framework.
TaskAssemblies | Gets the set of assemblies and directories that should scanned for NAnt tasks, types or functions.
Version | Gets the version of the framework.
VisualStudioVersion | Gets the Visual Studio version that corresponds with this framework.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ResolveAssembly | Resolves the specified assembly to a full path by matching it against the reference assemblies.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

FrameworkInfo Constructor

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FrameworkInfo Class | NAnt.Core Namespace


FrameworkInfo Constructor

[Visual Basic]
Overloads Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
protected FrameworkInfo(
SerializationInfo info,
StreamingContext context
);

See Also

FrameworkInfo Class | NAnt.Core Namespace


FrameworkInfo Properties

The properties of the FrameworkInfo class are listed below. For a complete list of FrameworkInfo class members, see the FrameworkInfo Members topic.

Public Instance Properties

ClrType | Gets the CLR type of the framework.
ClrVersion | Gets the Common Language Runtime version of the framework.
Description | Gets the description of the framework.
Family | Gets the family of the framework.
FrameworkAssemblyDirectory | Gets the directory where the system assemblies for the framework are located.
FrameworkDirectory | Gets the base directory of the framework tools for the framework.
IsValid | Returns a value indicating whether the current framework is valid.
Name | Gets the name of the framework.
Project | Gets the Project used to initialize this framework.
SdkDirectory | Gets the directory containing the SDK tools for the framework.
TaskAssemblies | Gets the set of assemblies and directories that should scanned for NAnt tasks, types or functions.
Version | Gets the version of the framework.
VisualStudioVersion | Gets the Visual Studio version that corresponds with this framework.

See Also

FrameworkInfo Class | NAnt.Core Namespace


ClrType Property

NAnt SDK Documentation - v0.91

FrameworkInfo.ClrType Property

Gets the CLR type of the framework.

[Visual Basic]
Public ReadOnly Property ClrType As ClrType
[C#]
public ClrType ClrType {get;}

Property Value

The CLR type of the framework.

Exceptions

Exception Type | Condition
ArgumentException | The framework is not valid.

See Also

FrameworkInfo Class | NAnt.Core Namespace


ClrVersion Property

NAnt SDK Documentation - v0.91

FrameworkInfo.ClrVersion Property

Gets the Common Language Runtime version of the framework.

[Visual Basic]
Public ReadOnly Property ClrVersion As Version
[C#]
public System.Version ClrVersion {get;}

Property Value

The Common Language Runtime version of the framework.

Remarks

When ClrVersion is a null reference (Nothing in Visual Basic), the framework is not considered valid.

Exceptions

Exception Type | Condition
ArgumentException | The framework is not valid.

See Also

FrameworkInfo Class | NAnt.Core Namespace


Description Property

NAnt SDK Documentation - v0.91

FrameworkInfo.Description Property

Gets the description of the framework.

[Visual Basic]
Public ReadOnly Property Description As String
[C#]
public string Description {get;}

Property Value

The description of the framework.

See Also

FrameworkInfo Class | NAnt.Core Namespace


Family Property

NAnt SDK Documentation - v0.91

FrameworkInfo.Family Property

Gets the family of the framework.

[Visual Basic]
Public ReadOnly Property Family As String
[C#]
public string Family {get;}

Property Value

The family of the framework.

See Also

FrameworkInfo Class | NAnt.Core Namespace


FrameworkAssemblyDirectory Property

NAnt SDK Documentation - v0.91

FrameworkInfo.FrameworkAssemblyDirectory Property

Gets the directory where the system assemblies for the framework are located.

[Visual Basic]
Public ReadOnly Property FrameworkAssemblyDirectory As DirectoryInfo
[C#]
public System.IO.DirectoryInfo FrameworkAssemblyDirectory {get;}

Property Value

The directory where the system assemblies for the framework are located.

Exceptions

Exception Type | Condition
ArgumentException | The framework is not valid.

See Also

FrameworkInfo Class | NAnt.Core Namespace


FrameworkDirectory Property

NAnt SDK Documentation - v0.91

FrameworkInfo.FrameworkDirectory Property

Gets the base directory of the framework tools for the framework.

[Visual Basic]
Public ReadOnly Property FrameworkDirectory As DirectoryInfo
[C#]
public System.IO.DirectoryInfo FrameworkDirectory {get;}

Property Value

The base directory of the framework tools for the framework.

Exceptions

Exception Type | Condition
ArgumentException | The framework is not valid.

See Also

FrameworkInfo Class | NAnt.Core Namespace


IsValid Property

NAnt SDK Documentation - v0.91

FrameworkInfo.IsValid Property

Returns a value indicating whether the current framework is valid.

[Visual Basic]
Public ReadOnly Property IsValid As Boolean
[C#]
public bool IsValid {get;}

Property Value

true if the framework is installed and correctly configured; otherwise, false.

See Also

FrameworkInfo Class | NAnt.Core Namespace


Name Property

NAnt SDK Documentation - v0.91

FrameworkInfo.Name Property

Gets the name of the framework.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}

Property Value

The name of the framework.

See Also

FrameworkInfo Class | NAnt.Core Namespace


Project Property

NAnt SDK Documentation - v0.91

FrameworkInfo.Project Property

Gets the Project used to initialize this framework.

[Visual Basic]
Public ReadOnly Property Project As Project
[C#]
public Project Project {get;}

Property Value

The Project used to initialize this framework.

Exceptions

Exception Type | Condition
ArgumentException | The framework is not valid.

See Also

FrameworkInfo Class | NAnt.Core Namespace


SdkDirectory Property

NAnt SDK Documentation - v0.91

FrameworkInfo.SdkDirectory Property

Gets the directory containing the SDK tools for the framework.

[Visual Basic]
Public ReadOnly Property SdkDirectory As DirectoryInfo
[C#]
public System.IO.DirectoryInfo SdkDirectory {get;}

Property Value

The directory containing the SDK tools for the framework or a null reference if the configured sdk directory does not exist, or is not valid.

Exceptions

Exception Type | Condition
ArgumentException | The framework is not valid.

See Also

FrameworkInfo Class | NAnt.Core Namespace


TaskAssemblies Property

NAnt SDK Documentation - v0.91

FrameworkInfo.TaskAssemblies Property

Gets the set of assemblies and directories that should scanned for NAnt tasks, types or functions.

[Visual Basic]
Public ReadOnly Property TaskAssemblies As FileSet
[C#]
public Types.FileSet TaskAssemblies {get;}

Property Value

The set of assemblies and directories that should be scanned for NAnt tasks, types or functions.

Exceptions

Exception Type | Condition
ArgumentException | The framework is not valid.

See Also

FrameworkInfo Class | NAnt.Core Namespace


Version Property

NAnt SDK Documentation - v0.91

FrameworkInfo.Version Property

Gets the version of the framework.

[Visual Basic]
Public ReadOnly Property Version As Version
[C#]
public System.Version Version {get;}

Property Value

The version of the framework.

Remarks

When Version is not configured, the framework is not considered valid.

Exceptions

Exception Type | Condition
ArgumentException | The framework is not valid.

See Also

FrameworkInfo Class | NAnt.Core Namespace


VisualStudioVersion Property

NAnt SDK Documentation - v0.91

FrameworkInfo.VisualStudioVersion Property

Gets the Visual Studio version that corresponds with this framework.

[Visual Basic]
Public ReadOnly Property VisualStudioVersion As Version
[C#]
public System.Version VisualStudioVersion {get;}

Property Value

The Visual Studio version that corresponds with this framework.

Exceptions

Exception Type | Condition
ArgumentException | The framework is not valid.
BuildException | There is no version of Visual Studio that corresponds with this framework.

See Also

FrameworkInfo Class | NAnt.Core Namespace


FrameworkInfo Methods

The methods of the FrameworkInfo class are listed below. For a complete list of FrameworkInfo class members, see the FrameworkInfo Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ResolveAssembly | Resolves the specified assembly to a full path by matching it against the reference assemblies.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FrameworkInfo Class | NAnt.Core Namespace


FrameworkInfo.ResolveAssembly Method

Resolves the specified assembly to a full path by matching it against the reference assemblies.

[Visual Basic]
Public Function ResolveAssembly( _
ByVal fileName As String _
) As String
[C#]
public string ResolveAssembly(
string fileName
);

Parameters

fileName
The file name of the assembly to resolve (without path information).

Return Value

An absolute path to the assembly, or a null reference (Nothing in Visual Basic) if the assembly could not be found or no reference assemblies are configured for the current framework.

Remarks

Whether the file name is matched case-sensitively depends on the operating system.

See Also

FrameworkInfo Class | NAnt.Core Namespace


FrameworkInfoDictionary Class

For a list of all members of this type, see FrameworkInfoDictionary Members.

System.Object
NAnt.Core.FrameworkInfoDictionary

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
NotInheritable Public Class FrameworkInfoDictionary
Implements IDictionary, ICollection, IEnumerable, ICloneable
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public sealed class FrameworkInfoDictionary : IDictionary, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FrameworkInfoDictionary Members | NAnt.Core Namespace


FrameworkInfoDictionary Members

FrameworkInfoDictionary overview

Public Static (Shared) Methods

Synchronized

Public Instance Constructors

FrameworkInfoDictionary Overloaded. Initializes a new instance of the FrameworkInfoDictionary class.

Public Instance Properties

Count
IsFixedSize
IsReadOnly
IsSynchronized
Item
Keys
SyncRoot
Values

Public Instance Methods

Add |
Clear |
Clone |
Contains |
ContainsKey |
ContainsValue |
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


FrameworkInfoDictionary Constructor

Initializes a new instance of the FrameworkInfoDictionary class.

Overload List

Initializes a new instance of the FrameworkInfoDictionary class.

public FrameworkInfoDictionary();

public FrameworkInfoDictionary(FrameworkInfoDictionary);

public FrameworkInfoDictionary(IDictionary);

public FrameworkInfoDictionary(IDictionary,IHashCodeProvider,IComparer);

public FrameworkInfoDictionary(IDictionary,float);

public FrameworkInfoDictionary(IDictionary,float,IHashCodeProvider,IComparer);

public FrameworkInfoDictionary(IHashCodeProvider,IComparer);

Initializes a new instance of the FrameworkInfoDictionary class with the specified capacity.

public FrameworkInfoDictionary(int);

public FrameworkInfoDictionary(int,IHashCodeProvider,IComparer);

public FrameworkInfoDictionary(int,int);

public FrameworkInfoDictionary(int,float,IHashCodeProvider,IComparer);

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


FrameworkInfoDictionary Constructor ()

Initializes a new instance of the FrameworkInfoDictionary class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FrameworkInfoDictionary();

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace | FrameworkInfoDictionary Constructor Overload List


FrameworkInfoDictionary Constructor (FrameworkInfoDictionary)

[Visual Basic]
Overloads Public Sub New( _
ByVal original As FrameworkInfoDictionary _
)
[C#]
public FrameworkInfoDictionary(
FrameworkInfoDictionary original
);

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace | FrameworkInfoDictionary Constructor Overload List


FrameworkInfoDictionary Constructor (IDictionary)

[Visual Basic]
Overloads Public Sub New( _
ByVal dictionary As IDictionary _
)
[C#]
public FrameworkInfoDictionary(
IDictionary dictionary
);

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace | FrameworkInfoDictionary Constructor Overload List


FrameworkInfoDictionary Constructor (Int32)

Initializes a new instance of the FrameworkInfoDictionary class with the specified capacity.

[Visual Basic]
Overloads Public Sub New( _
ByVal capacity As Integer _
)
[C#]
public FrameworkInfoDictionary(
int capacity
);

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace | FrameworkInfoDictionary Constructor Overload List


FrameworkInfoDictionary Constructor (IDictionary, Single)

[Visual Basic]
Overloads Public Sub New( _
ByVal dictionary As IDictionary, _
ByVal loadFactor As Single _
)
[C#]
public FrameworkInfoDictionary(
IDictionary dictionary,
float loadFactor
);

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace | FrameworkInfoDictionary Constructor Overload List


FrameworkInfoDictionary Constructor (IHashCodeProvider, IComparer)

[Visual Basic]
Overloads Public Sub New( _
ByVal codeProvider As IHashCodeProvider, _
ByVal comparer As IComparer _
)
[C#]
public FrameworkInfoDictionary(
IHashCodeProvider codeProvider,
IComparer comparer
);

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace | FrameworkInfoDictionary Constructor Overload List


FrameworkInfoDictionary Constructor (Int32, Int32)

[Visual Basic]
Overloads Public Sub New( _
ByVal capacity As Integer, _
ByVal loadFactor As Integer _
)
[C#]
public FrameworkInfoDictionary(
int capacity,
int loadFactor
);

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace | FrameworkInfoDictionary Constructor Overload List


FrameworkInfoDictionary Constructor (IDictionary, IHashCodeProvider, IComparer)

[Visual Basic]
Overloads Public Sub New( _
ByVal dictionary As IDictionary, _
ByVal codeProvider As IHashCodeProvider, _
ByVal comparer As IComparer _
)
[C#]
public FrameworkInfoDictionary(
IDictionary dictionary,
IHashCodeProvider codeProvider,
IComparer comparer
);

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace | FrameworkInfoDictionary Constructor Overload List


FrameworkInfoDictionary Constructor (Int32, IHashCodeProvider, IComparer)

[Visual Basic]
Overloads Public Sub New( _
ByVal capacity As Integer, _
ByVal codeProvider As IHashCodeProvider, _
ByVal comparer As IComparer _
)
[C#]
public FrameworkInfoDictionary(
int capacity,
IHashCodeProvider codeProvider,
IComparer comparer
);

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace | FrameworkInfoDictionary Constructor Overload List


FrameworkInfoDictionary Constructor (IDictionary, Single, IHashCodeProvider, IComparer)

[Visual Basic]
Overloads Public Sub New( _
ByVal dictionary As IDictionary, _
ByVal loadFactor As Single, _
ByVal codeProvider As IHashCodeProvider, _
ByVal comparer As IComparer _
)
[C#]
public FrameworkInfoDictionary(
IDictionary dictionary,
float loadFactor,
IHashCodeProvider codeProvider,
IComparer comparer
);

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace | FrameworkInfoDictionary Constructor Overload List


FrameworkInfoDictionary Constructor (Int32, Single, IHashCodeProvider, IComparer)

[Visual Basic]
Overloads Public Sub New( _
ByVal capacity As Integer, _
ByVal loadFactor As Single, _
ByVal codeProvider As IHashCodeProvider, _
ByVal comparer As IComparer _
)
[C#]
public FrameworkInfoDictionary(
int capacity,
float loadFactor,
IHashCodeProvider codeProvider,
IComparer comparer
);

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace | FrameworkInfoDictionary Constructor Overload List


FrameworkInfoDictionary Properties

The properties of the FrameworkInfoDictionary class are listed below. For a complete list of FrameworkInfoDictionary class members, see the FrameworkInfoDictionary Members topic.

Public Instance Properties

Count
IsFixedSize
IsReadOnly
IsSynchronized
Item
Keys
SyncRoot
Values

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


Count Property

NAnt SDK Documentation - v0.91

FrameworkInfoDictionary.Count Property

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


IsFixedSize Property

NAnt SDK Documentation - v0.91

FrameworkInfoDictionary.IsFixedSize Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsFixedSize As Boolean _
Implements IDictionary.IsFixedSize
[C#]
public bool IsFixedSize {get;}

Implements

IDictionary.IsFixedSize

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


IsReadOnly Property

NAnt SDK Documentation - v0.91

FrameworkInfoDictionary.IsReadOnly Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsReadOnly As Boolean _
Implements IDictionary.IsReadOnly
[C#]
public bool IsReadOnly {get;}

Implements

IDictionary.IsReadOnly

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


IsSynchronized Property

NAnt SDK Documentation - v0.91

FrameworkInfoDictionary.IsSynchronized Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


Item Property

NAnt SDK Documentation - v0.91

FrameworkInfoDictionary.Item Property

[Visual Basic]
Public Default Property Item( _
ByVal key As String _
) As FrameworkInfo
[C#]
public FrameworkInfo this[
string key
] {get; set;}

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


Keys Property

NAnt SDK Documentation - v0.91

FrameworkInfoDictionary.Keys Property

[Visual Basic]
NotOverridable Public ReadOnly Property Keys As ICollection _
Implements IDictionary.Keys
[C#]
public System.Collections.ICollection Keys {get;}

Implements

IDictionary.Keys

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


SyncRoot Property

NAnt SDK Documentation - v0.91

FrameworkInfoDictionary.SyncRoot Property

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


Values Property

NAnt SDK Documentation - v0.91

FrameworkInfoDictionary.Values Property

[Visual Basic]
NotOverridable Public ReadOnly Property Values As ICollection _
Implements IDictionary.Values
[C#]
public System.Collections.ICollection Values {get;}

Implements

IDictionary.Values

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


FrameworkInfoDictionary Methods

The methods of the FrameworkInfoDictionary class are listed below. For a complete list of FrameworkInfoDictionary class members, see the FrameworkInfoDictionary Members topic.

Public Static (Shared) Methods

Synchronized

Public Instance Methods

Add |
Clear |
Clone |
Contains |
ContainsKey |
ContainsValue |
CopyTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


FrameworkInfoDictionary.Add Method

[Visual Basic]
Public Sub Add( _
ByVal key As String, _
ByVal value As FrameworkInfo _
)
[C#]
public void Add(
string key,
FrameworkInfo value
);

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


FrameworkInfoDictionary.Clear Method

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements IDictionary.Clear
[C#]
public void Clear();

Implements

IDictionary.Clear

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


FrameworkInfoDictionary.Clone Method

[Visual Basic]
Public Function Clone() As FrameworkInfoDictionary
[C#]
public FrameworkInfoDictionary Clone();

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


FrameworkInfoDictionary.Contains Method

[Visual Basic]
Public Function Contains( _
ByVal key As String _
) As Boolean
[C#]
public bool Contains(
string key
);

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


FrameworkInfoDictionary.ContainsKey Method

[Visual Basic]
Public Function ContainsKey( _
ByVal key As String _
) As Boolean
[C#]
public bool ContainsKey(
string key
);

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


FrameworkInfoDictionary.ContainsValue Method

[Visual Basic]
Public Function ContainsValue( _
ByVal value As FrameworkInfo _
) As Boolean
[C#]
public bool ContainsValue(
FrameworkInfo value
);

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


FrameworkInfoDictionary.CopyTo Method

[Visual Basic]
Public Sub CopyTo( _
ByVal array As FrameworkInfo(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
FrameworkInfo[] array,
int index
);

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


FrameworkInfoDictionary.GetEnumerator Method

[Visual Basic]
Public Function GetEnumerator() As FrameworkInfoDictionaryEnumerator
[C#]
public FrameworkInfoDictionaryEnumerator GetEnumerator();

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


FrameworkInfoDictionary.Remove Method

[Visual Basic]
Public Sub Remove( _
ByVal key As String _
)
[C#]
public void Remove(
string key
);

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


FrameworkInfoDictionary.Synchronized Method

[Visual Basic]
Public Shared Function Synchronized( _
ByVal nonSync As FrameworkInfoDictionary _
) As FrameworkInfoDictionary
[C#]
public static FrameworkInfoDictionary Synchronized(
FrameworkInfoDictionary nonSync
);

See Also

FrameworkInfoDictionary Class | NAnt.Core Namespace


FrameworkInfoDictionaryEnumerator Class

For a list of all members of this type, see FrameworkInfoDictionaryEnumerator Members.

System.Object
NAnt.Core.FrameworkInfoDictionaryEnumerator

[Visual Basic]
Public Class FrameworkInfoDictionaryEnumerator
Implements IDictionaryEnumerator, IEnumerator
[C#]
public class FrameworkInfoDictionaryEnumerator : IDictionaryEnumerator, IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FrameworkInfoDictionaryEnumerator Members | NAnt.Core Namespace


FrameworkInfoDictionaryEnumerator Members

FrameworkInfoDictionaryEnumerator overview

Public Instance Properties

Current
Entry
Key
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FrameworkInfoDictionaryEnumerator Class | NAnt.Core Namespace


FrameworkInfoDictionaryEnumerator Properties

The properties of the FrameworkInfoDictionaryEnumerator class are listed below. For a complete list of FrameworkInfoDictionaryEnumerator class members, see the FrameworkInfoDictionaryEnumerator Members topic.

Public Instance Properties

Current
Entry
Key
Value

See Also

FrameworkInfoDictionaryEnumerator Class | NAnt.Core Namespace


Current Property

NAnt SDK Documentation - v0.91

FrameworkInfoDictionaryEnumerator.Current Property

[Visual Basic]
Public ReadOnly Property Current As FrameworkInfo
[C#]
public FrameworkInfo Current {get;}

See Also

FrameworkInfoDictionaryEnumerator Class | NAnt.Core Namespace


Entry Property

NAnt SDK Documentation - v0.91

FrameworkInfoDictionaryEnumerator.Entry Property

[Visual Basic]
NotOverridable Public ReadOnly Property Entry As DictionaryEntry _
Implements IDictionaryEnumerator.Entry
[C#]
public System.Collections.DictionaryEntry Entry {get;}

Implements

IDictionaryEnumerator.Entry

See Also

FrameworkInfoDictionaryEnumerator Class | NAnt.Core Namespace


Key Property

NAnt SDK Documentation - v0.91

FrameworkInfoDictionaryEnumerator.Key Property

[Visual Basic]
Public ReadOnly Property Key As String
[C#]
public string Key {get;}

See Also

FrameworkInfoDictionaryEnumerator Class | NAnt.Core Namespace


Value Property

NAnt SDK Documentation - v0.91

FrameworkInfoDictionaryEnumerator.Value Property

[Visual Basic]
Public ReadOnly Property Value As FrameworkInfo
[C#]
public FrameworkInfo Value {get;}

See Also

FrameworkInfoDictionaryEnumerator Class | NAnt.Core Namespace


FrameworkInfoDictionaryEnumerator Methods

The methods of the FrameworkInfoDictionaryEnumerator class are listed below. For a complete list of FrameworkInfoDictionaryEnumerator class members, see the FrameworkInfoDictionaryEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FrameworkInfoDictionaryEnumerator Class | NAnt.Core Namespace


FrameworkInfoDictionaryEnumerator.MoveNext Method

[Visual Basic]
NotOverridable Public Function MoveNext() As Boolean _
Implements IEnumerator.MoveNext
[C#]
public bool MoveNext();

Implements

IEnumerator.MoveNext

See Also

FrameworkInfoDictionaryEnumerator Class | NAnt.Core Namespace


FrameworkInfoDictionaryEnumerator.Reset Method

[Visual Basic]
NotOverridable Public Sub Reset() _
Implements IEnumerator.Reset
[C#]
public void Reset();

Implements

IEnumerator.Reset

See Also

FrameworkInfoDictionaryEnumerator Class | NAnt.Core Namespace


FrameworkTypes Enumeration

Defines the types of frameworks.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Serializable, _ Flags>
Public Enum FrameworkTypes
[C#]
[Serializable]
[Flags]
public enum FrameworkTypes

Members

Member Name | Description | Value
NotInstalled | Frameworks that are supported on the current platform, but are not installed. | 1
Installed | Frameworks that are installed on the current system. | 2
InstallStateMask | Retrieves installation state attributes. | 3
Desktop | Frameworks that typically target full desktop devices. | 4
Compact | Frameworks that target compact devices. | 8
Browser | Frameworks that run in a browser. | 16
DeviceMask | Retrieves device attributes. | 28
Mono | Frameworks released as part of the open-source Mono project. | 32
MS | Frameworks released by Microsoft. | 64
VendorMask | Retrieves vendor attributes. | 96
All | All frameworks supported on the current platform, regarless of their installation state, target device or vendor. | 3

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

NAnt.Core Namespace


FunctionSetBase Class

For a list of all members of this type, see FunctionSetBase Members.

System.Object
NAnt.Core.FunctionSetBase
Derived types

[Visual Basic]
MustInherit Public Class FunctionSetBase
[C#]
public abstract class FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FunctionSetBase Members | NAnt.Core Namespace


FunctionSetBase Members

FunctionSetBase overview

Public Instance Properties

Project Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

FunctionSetBase Constructor

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FunctionSetBase Class | NAnt.Core Namespace


FunctionSetBase Constructor

[Visual Basic]
Protected Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
protected FunctionSetBase(
Project project,
PropertyDictionary properties
);

See Also

FunctionSetBase Class | NAnt.Core Namespace


FunctionSetBase Properties

The properties of the FunctionSetBase class are listed below. For a complete list of FunctionSetBase class members, see the FunctionSetBase Members topic.

Public Instance Properties

Project Gets or sets the Project that this functionset will reference.

See Also

FunctionSetBase Class | NAnt.Core Namespace


Project Property

NAnt SDK Documentation - v0.91

FunctionSetBase.Project Property

Gets or sets the Project that this functionset will reference.

[Visual Basic]
Overridable Public Property Project As Project
[C#]
public virtual Project Project {get; set;}

Property Value

The Project that this functionset will reference.

See Also

FunctionSetBase Class | NAnt.Core Namespace


IBuildListener Interface

Instances of classes that implement this interface can register to be notified when things happen during a build.

For a list of all members of this type, see IBuildListener Members.

NAnt.Core.IBuildListener
NAnt.Core.IBuildLogger

[Visual Basic]
Public Interface IBuildListener
[C#]
public interface IBuildListener

Types that implement IBuildListener

Type | Description
DefaultLogger |
MailLogger | Buffers log messages from DefaultLogger, and sends an e-mail with the results.
XmlLogger | Used to wrap log messages in xml <message/> elements.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

IBuildListener Members | NAnt.Core Namespace


IBuildListener Members

IBuildListener overview

Public Instance Methods

BuildFinished | Signals that the last target has finished.
BuildStarted | Signals that a build has started.
MessageLogged | Signals that a message has been logged.
TargetFinished | Signals that a target has finished.
TargetStarted | Signals that a target has started.
TaskFinished | Signals that a task has finished.
TaskStarted | Signals that a task has started.

See Also

IBuildListener Interface | NAnt.Core Namespace


IBuildListener Methods

The methods of the IBuildListener interface are listed below. For a complete list of IBuildListener interface members, see the IBuildListener Members topic.

Public Instance Methods

BuildFinished | Signals that the last target has finished.
BuildStarted | Signals that a build has started.
MessageLogged | Signals that a message has been logged.
TargetFinished | Signals that a target has finished.
TargetStarted | Signals that a target has started.
TaskFinished | Signals that a task has finished.
TaskStarted | Signals that a task has started.

See Also

IBuildListener Interface | NAnt.Core Namespace


IBuildListener.BuildFinished Method

Signals that the last target has finished.

[Visual Basic]
Sub BuildFinished( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
)
[C#]
void BuildFinished(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Remarks

This event will still be fired if an error occurred during the build.

See Also

IBuildListener Interface | NAnt.Core Namespace


IBuildListener.BuildStarted Method

Signals that a build has started.

[Visual Basic]
Sub BuildStarted( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
)
[C#]
void BuildStarted(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Remarks

This event is fired before any targets have started.

See Also

IBuildListener Interface | NAnt.Core Namespace


IBuildListener.MessageLogged Method

Signals that a message has been logged.

[Visual Basic]
Sub MessageLogged( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
)
[C#]
void MessageLogged(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

See Also

IBuildListener Interface | NAnt.Core Namespace


IBuildListener.TargetFinished Method

Signals that a target has finished.

[Visual Basic]
Sub TargetFinished( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
)
[C#]
void TargetFinished(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Remarks

This event will still be fired if an error occurred during the build.

See Also

IBuildListener Interface | NAnt.Core Namespace


IBuildListener.TargetStarted Method

Signals that a target has started.

[Visual Basic]
Sub TargetStarted( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
)
[C#]
void TargetStarted(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

See Also

IBuildListener Interface | NAnt.Core Namespace


IBuildListener.TaskFinished Method

Signals that a task has finished.

[Visual Basic]
Sub TaskFinished( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
)
[C#]
void TaskFinished(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Remarks

This event will still be fired if an error occurred during the build.

See Also

IBuildListener Interface | NAnt.Core Namespace


IBuildListener.TaskStarted Method

Signals that a task has started.

[Visual Basic]
Sub TaskStarted( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
)
[C#]
void TaskStarted(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

See Also

IBuildListener Interface | NAnt.Core Namespace


IBuildLogger Interface

Interface used by NAnt to log the build output.

For a list of all members of this type, see IBuildLogger Members.

[Visual Basic]
Public Interface IBuildLogger
Implements IBuildListener
[C#]
public interface IBuildLogger : IBuildListener

Types that implement IBuildLogger

Type | Description
DefaultLogger |
MailLogger | Buffers log messages from DefaultLogger, and sends an e-mail with the results.
XmlLogger | Used to wrap log messages in xml <message/> elements.

Remarks

Depending on the supplied command-line arguments, NAnt will set the OutputWriter to Out or a StreamWriter with a file as backend store.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

IBuildLogger Members | NAnt.Core Namespace


IBuildLogger Members

IBuildLogger overview

Public Instance Properties

EmacsMode | Gets or sets a value indicating whether to produce emacs (and other editor) friendly output.
OutputWriter | Gets or sets the TextWriter to which the logger is to send its output.
Threshold | Gets or sets the highest level of message this logger should respond to.

Public Instance Methods

Flush Flushes buffered build events or messages to the underlying storage.

See Also

IBuildLogger Interface | NAnt.Core Namespace


IBuildLogger Properties

The properties of the IBuildLogger interface are listed below. For a complete list of IBuildLogger interface members, see the IBuildLogger Members topic.

Public Instance Properties

EmacsMode | Gets or sets a value indicating whether to produce emacs (and other editor) friendly output.
OutputWriter | Gets or sets the TextWriter to which the logger is to send its output.
Threshold | Gets or sets the highest level of message this logger should respond to.

See Also

IBuildLogger Interface | NAnt.Core Namespace


EmacsMode Property

NAnt SDK Documentation - v0.91

IBuildLogger.EmacsMode Property

Gets or sets a value indicating whether to produce emacs (and other editor) friendly output.

[Visual Basic]
Property EmacsMode As Boolean
[C#]
bool EmacsMode {get; set;}

Property Value

true if output is to be unadorned so that emacs and other editors can parse files names, etc.

See Also

IBuildLogger Interface | NAnt.Core Namespace


OutputWriter Property

NAnt SDK Documentation - v0.91

IBuildLogger.OutputWriter Property

Gets or sets the TextWriter to which the logger is to send its output.

[Visual Basic]
Property OutputWriter As TextWriter
[C#]
System.IO.TextWriter OutputWriter {get; set;}

See Also

IBuildLogger Interface | NAnt.Core Namespace


Threshold Property

NAnt SDK Documentation - v0.91

IBuildLogger.Threshold Property

Gets or sets the highest level of message this logger should respond to.

[Visual Basic]
Property Threshold As Level
[C#]
Level Threshold {get; set;}

Property Value

The highest level of message this logger should respond to.

Remarks

Only messages with a message level higher than or equal to the given level should actually be written to the log.

See Also

IBuildLogger Interface | NAnt.Core Namespace


IBuildLogger Methods

The methods of the IBuildLogger interface are listed below. For a complete list of IBuildLogger interface members, see the IBuildLogger Members topic.

Public Instance Methods

Flush Flushes buffered build events or messages to the underlying storage.

See Also

IBuildLogger Interface | NAnt.Core Namespace


IBuildLogger.Flush Method

Flushes buffered build events or messages to the underlying storage.

[Visual Basic]
Sub Flush()
[C#]
void Flush();

See Also

IBuildLogger Interface | NAnt.Core Namespace


Level Enumeration

Defines the set of levels recognised by the NAnt logging system.

[Visual Basic]
<Serializable, _ TypeConverter(ConverterTypeName:="NAnt.Core.LevelConverter, NAnt.Core, Version=0.91.4312.0, Culture=neutral, PublicKeyToken=null")>
Public Enum Level
[C#]
[Serializable]
[TypeConverter(ConverterTypeName="NAnt.Core.LevelConverter, NAnt.Core, Version=0.91.4312.0, Culture=neutral, PublicKeyToken=null")]
public enum Level

Members

Member Name | Description
Debug | Designates fine-grained informational events that are most useful to debug a build process.
Verbose | Designates events that offer a more detailed view of the build process.
Info | Designates informational events that are useful for getting a high-level view of the build process.
Warning | Designates potentionally harmful events.
Error | Designates error events.
None | Can be used to suppress all messages.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

NAnt.Core Namespace


Location Class

Stores the file name, line number and column number to record a position in a text file.

For a list of all members of this type, see Location Members.

System.Object
NAnt.Core.Location

[Visual Basic]
<Serializable, _ Serializable>
Public Class Location
[C#]
[Serializable]
[Serializable]
public class Location

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

Location Members | NAnt.Core Namespace


Location Members

Location overview

Public Static (Shared) Fields

UnknownLocation

Public Instance Constructors

Location Overloaded. Initializes a new instance of the Location class.

Public Instance Properties

ColumnNumber | Gets the column number for the location.
FileName | Gets a string containing the file name for the location.
LineNumber | Gets the line number for the location.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns the file name, line number and a trailing space. An error message can be appended easily. For unknown locations, returns an empty string.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Location Class | NAnt.Core Namespace


Location Constructor

Creates a location consisting of a file name, line number and column number.

Overload List

Creates a location consisting of a file name.

public Location(string);

Creates a location consisting of a file name, line number and column number.

public Location(string,int,int);

See Also

Location Class | NAnt.Core Namespace


Location Constructor (String, Int32, Int32)

Creates a location consisting of a file name, line number and column number.

[Visual Basic]
Overloads Public Sub New( _
ByVal fileName As String, _
ByVal lineNumber As Integer, _
ByVal columnNumber As Integer _
)
[C#]
public Location(
string fileName,
int lineNumber,
int columnNumber
);

Remarks

fileName can be a local URI resource, e.g., file:///C:/WINDOWS/setuplog.txt.

See Also

Location Class | NAnt.Core Namespace | Location Constructor Overload List


Location Constructor (String)

Creates a location consisting of a file name.

[Visual Basic]
Overloads Public Sub New( _
ByVal fileName As String _
)
[C#]
public Location(
string fileName
);

Remarks

fileName can be a local URI resource, e.g., file:///C:/WINDOWS/setuplog.txt.

See Also

Location Class | NAnt.Core Namespace | Location Constructor Overload List


Location Fields

The fields of the Location class are listed below. For a complete list of Location class members, see the Location Members topic.

Public Static (Shared) Fields

UnknownLocation

See Also

Location Class | NAnt.Core Namespace


Location.UnknownLocation Field

[Visual Basic]
Public Shared ReadOnly UnknownLocation As Location
[C#]
public static readonly Location UnknownLocation;

See Also

Location Class | NAnt.Core Namespace


Location Properties

The properties of the Location class are listed below. For a complete list of Location class members, see the Location Members topic.

Public Instance Properties

ColumnNumber | Gets the column number for the location.
FileName | Gets a string containing the file name for the location.
LineNumber | Gets the line number for the location.

See Also

Location Class | NAnt.Core Namespace


ColumnNumber Property

NAnt SDK Documentation - v0.91

Location.ColumnNumber Property

Gets the column number for the location.

[Visual Basic]
Public ReadOnly Property ColumnNumber As Integer
[C#]
public int ColumnNumber {get;}

Remarks

Columns start a 1. Will be zero if not specified.

See Also

Location Class | NAnt.Core Namespace


FileName Property

NAnt SDK Documentation - v0.91

Location.FileName Property

Gets a string containing the file name for the location.

[Visual Basic]
Public ReadOnly Property FileName As String
[C#]
public string FileName {get;}

Remarks

The file name includes both the file path and the extension.

See Also

Location Class | NAnt.Core Namespace


LineNumber Property

NAnt SDK Documentation - v0.91

Location.LineNumber Property

Gets the line number for the location.

[Visual Basic]
Public ReadOnly Property LineNumber As Integer
[C#]
public int LineNumber {get;}

Remarks

Lines start at 1. Will be zero if not specified.

See Also

Location Class | NAnt.Core Namespace


Location Methods

The methods of the Location class are listed below. For a complete list of Location class members, see the Location Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns the file name, line number and a trailing space. An error message can be appended easily. For unknown locations, returns an empty string.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Location Class | NAnt.Core Namespace


Location.ToString Method

Returns the file name, line number and a trailing space. An error message can be appended easily. For unknown locations, returns an empty string.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

Location Class | NAnt.Core Namespace


LogWriter Class

Implements a TextWriter for writing information to the NAnt logging infrastructure.

For a list of all members of this type, see LogWriter Members.

System.Object
System.MarshalByRefObject
System.IO.TextWriter
NAnt.Core.LogWriter

[Visual Basic]
Public Class LogWriter
Inherits TextWriter
[C#]
public class LogWriter : TextWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

LogWriter Members | NAnt.Core Namespace


LogWriter Members

LogWriter overview

Public Instance Constructors

LogWriter Constructor Initializes a new instance of the LogWriter class for the specified Task with the specified output level and format provider.

Public Instance Properties

Encoding | Gets the Encoding in which the output is written.
FormatProvider (inherited from TextWriter) | Gets an object that controls formatting.
NewLine (inherited from TextWriter) | Gets or sets the line terminator string used by the current TextWriter.

Public Instance Methods

Close | Closes the current writer and releases any system resources associated with the writer.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from TextWriter) | Overloaded. Releases all resources used by the TextWriter object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush | Causes any buffered data to be written to the logging infrastructure.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes a character array to the buffer.
Write (inherited from TextWriter) | Overloaded. Writes a character to the text stream.
WriteLine | Overloaded. Writes an empty string to the logging infrastructure.
WriteLine (inherited from TextWriter) | Overloaded. Writes a character followed by a line terminator to the text stream.

Protected Instance Fields

CoreNewLine (inherited from TextWriter) Stores the new line characters used for this TextWriter.

Protected Instance Properties

OutputLevel Gets the Level with which messages will be output to the build log.

Protected Instance Methods

Dispose (inherited from TextWriter) | Overloaded. Releases the unmanaged resources used by the TextWriter and optionally releases the managed resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.

See Also

LogWriter Class | NAnt.Core Namespace


LogWriter Constructor

Initializes a new instance of the LogWriter class for the specified Task with the specified output level and format provider.

[Visual Basic]
Public Sub New( _
ByVal task As Task, _
ByVal outputLevel As Level, _
ByVal formatProvider As IFormatProvider _
)
[C#]
public LogWriter(
Task task,
Level outputLevel,
IFormatProvider formatProvider
);

Parameters

task
Determines the indentation level.
outputLevel
The Level with which messages will be output to the build log.
formatProvider
An IFormatProvider object that controls formatting.

See Also

LogWriter Class | NAnt.Core Namespace


LogWriter Properties

The properties of the LogWriter class are listed below. For a complete list of LogWriter class members, see the LogWriter Members topic.

Public Instance Properties

Encoding | Gets the Encoding in which the output is written.
FormatProvider (inherited from TextWriter) | Gets an object that controls formatting.
NewLine (inherited from TextWriter) | Gets or sets the line terminator string used by the current TextWriter.

Protected Instance Properties

OutputLevel Gets the Level with which messages will be output to the build log.

See Also

LogWriter Class | NAnt.Core Namespace


Encoding Property

NAnt SDK Documentation - v0.91

LogWriter.Encoding Property

Gets the Encoding in which the output is written.

[Visual Basic]
Overrides Public ReadOnly Property Encoding As Encoding
[C#]
public override System.Text.Encoding Encoding {get;}

Property Value

The LogWriter always writes output in UTF8 encoding.

See Also

LogWriter Class | NAnt.Core Namespace


OutputLevel Property

NAnt SDK Documentation - v0.91

LogWriter.OutputLevel Property

Gets the Level with which messages will be output to the build log.

[Visual Basic]
Protected ReadOnly Property OutputLevel As Level
[C#]
protected Level OutputLevel {get;}

See Also

LogWriter Class | NAnt.Core Namespace


LogWriter Methods

The methods of the LogWriter class are listed below. For a complete list of LogWriter class members, see the LogWriter Members topic.

Public Instance Methods

Close | Closes the current writer and releases any system resources associated with the writer.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from TextWriter) | Overloaded. Releases all resources used by the TextWriter object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush | Causes any buffered data to be written to the logging infrastructure.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes a character array to the buffer.
Write (inherited from TextWriter) | Overloaded. Writes a character to the text stream.
WriteLine | Overloaded. Writes an empty string to the logging infrastructure.
WriteLine (inherited from TextWriter) | Overloaded. Writes a character followed by a line terminator to the text stream.

Protected Instance Methods

Dispose (inherited from TextWriter) | Overloaded. Releases the unmanaged resources used by the TextWriter and optionally releases the managed resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.

See Also

LogWriter Class | NAnt.Core Namespace


LogWriter.Close Method

Closes the current writer and releases any system resources associated with the writer.

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();

See Also

LogWriter Class | NAnt.Core Namespace


LogWriter.Flush Method

Causes any buffered data to be written to the logging infrastructure.

[Visual Basic]
Overrides Public Sub Flush()
[C#]
public override void Flush();

See Also

LogWriter Class | NAnt.Core Namespace


LogWriter.InitializeLifetimeService Method

Obtains a lifetime service object to control the lifetime policy for this instance.

[Visual Basic]
Overrides Public Function InitializeLifetimeService() As Object
[C#]
public override object InitializeLifetimeService();

Return Value

An object of type ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized with a lease that will never time out.

See Also

LogWriter Class | NAnt.Core Namespace


Write Method

NAnt SDK Documentation - v0.91

LogWriter.Write Method

Writes a character array to the buffer.

Overload List

Inherited from TextWriter.

public virtual void Write(bool);

Inherited from TextWriter.

public virtual void Write(char);

Writes a character array to the buffer.

public override void Write(char[]);

Inherited from TextWriter.

public virtual void Write(char[],int,int);

Inherited from TextWriter.

public virtual void Write(decimal);

Inherited from TextWriter.

public virtual void Write(double);

Inherited from TextWriter.

public virtual void Write(int);

Inherited from TextWriter.

public virtual void Write(long);

Inherited from TextWriter.

public virtual void Write(object);

Inherited from TextWriter.

public virtual void Write(float);

Writes a string to the buffer.

public override void Write(string);

Inherited from TextWriter.

public virtual void Write(string,object);

Inherited from TextWriter.

public virtual void Write(string,object,object);

Inherited from TextWriter.

public virtual void Write(string,object,object,object);

Inherited from TextWriter.

public virtual void Write(string,params object[]);

Inherited from TextWriter.

public virtual void Write(uint);

Inherited from TextWriter.

public virtual void Write(ulong);

See Also

LogWriter Class | NAnt.Core Namespace


LogWriter.Write Method (Char[])

Writes a character array to the buffer.

[Visual Basic]
Overrides Overloads Public Sub Write( _
ByVal chars As Char() _
)
[C#]
public override void Write(
char[] chars
);

Parameters

chars
The character array to write to the text stream.

See Also

LogWriter Class | NAnt.Core Namespace | LogWriter.Write Overload List


LogWriter.Write Method (String)

Writes a string to the buffer.

[Visual Basic]
Overrides Overloads Public Sub Write( _
ByVal value As String _
)
[C#]
public override void Write(
string value
);

Parameters

value

See Also

LogWriter Class | NAnt.Core Namespace | LogWriter.Write Overload List


WriteLine Method

NAnt SDK Documentation - v0.91

LogWriter.WriteLine Method

Writes an empty string to the logging infrastructure.

Overload List

Writes an empty string to the logging infrastructure.

public override void WriteLine();

Inherited from TextWriter.

public virtual void WriteLine(bool);

Inherited from TextWriter.

public virtual void WriteLine(char);

Inherited from TextWriter.

public virtual void WriteLine(char[]);

Inherited from TextWriter.

public virtual void WriteLine(char[],int,int);

Inherited from TextWriter.

public virtual void WriteLine(decimal);

Inherited from TextWriter.

public virtual void WriteLine(double);

Inherited from TextWriter.

public virtual void WriteLine(int);

Inherited from TextWriter.

public virtual void WriteLine(long);

Inherited from TextWriter.

public virtual void WriteLine(object);

Inherited from TextWriter.

public virtual void WriteLine(float);

Writes a string to the logging infrastructure.

public override void WriteLine(string);

Inherited from TextWriter.

public virtual void WriteLine(string,object);

Inherited from TextWriter.

public virtual void WriteLine(string,object,object);

Inherited from TextWriter.

public virtual void WriteLine(string,object,object,object);

Writes out a formatted string using the same semantics as Format.

public override void WriteLine(string,params object[]);

Inherited from TextWriter.

public virtual void WriteLine(uint);

Inherited from TextWriter.

public virtual void WriteLine(ulong);

See Also

LogWriter Class | NAnt.Core Namespace


LogWriter.WriteLine Method ()

Writes an empty string to the logging infrastructure.

[Visual Basic]
Overrides Overloads Public Sub WriteLine()
[C#]
public override void WriteLine();

See Also

LogWriter Class | NAnt.Core Namespace | LogWriter.WriteLine Overload List


LogWriter.WriteLine Method (String)

Writes a string to the logging infrastructure.

[Visual Basic]
Overrides Overloads Public Sub WriteLine( _
ByVal value As String _
)
[C#]
public override void WriteLine(
string value
);

Parameters

value
The string to write. If value is a null reference, only the line termination characters are written.

See Also

LogWriter Class | NAnt.Core Namespace | LogWriter.WriteLine Overload List


LogWriter.WriteLine Method (String, Object[])

Writes out a formatted string using the same semantics as Format.

[Visual Basic]
Overrides Overloads Public Sub WriteLine( _
ByVal line As String, _
ParamArray args As Object() _
)
[C#]
public override void WriteLine(
string line,
params object[] args
);

Parameters

line
The formatting string.
args
The object array to write into format string.

See Also

LogWriter Class | NAnt.Core Namespace | LogWriter.WriteLine Overload List


MailLogger Class

Buffers log messages from DefaultLogger, and sends an e-mail with the results.

For a list of all members of this type, see MailLogger Members.

System.Object
NAnt.Core.DefaultLogger
NAnt.Core.MailLogger

[Visual Basic]
<Serializable, _ Serializable>
Public Class MailLogger
Inherits DefaultLogger
[C#]
[Serializable]
[Serializable]
public class MailLogger : DefaultLogger

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The following properties are used to send the mail :

Property | Description
MailLogger.mailhost | Mail server to use. [default: localhost]
MailLogger.from | The address of the e-mail sender.
MailLogger.failure.notify | Send build failure e-mails ? [default: true]
MailLogger.success.notify | Send build success e-mails ? [default: true]
MailLogger.failure.to | The address to send build failure messages to.
MailLogger.success.to | The address to send build success messages to.
MailLogger.failure.subject | The subject of build failure messages. [default: "Build Failure"]
MailLogger.success.subject | The subject of build success messages. [default: "Build Success"]
MailLogger.success.attachments | The ID of a fileset holdng set of files to attach when the build is successful.
MailLogger.failure.attachments | The ID of a fileset holdng set of files to attach when the build fails.
MailLogger.body.encoding | The encoding type of the body of the e-mail message. [default: system's ANSI code page]
MailLogger.smtp.username | The name of the user to login to the SMTP server.
MailLogger.smtp.password | The password of the specified user.
MailLogger.smtp.enablessl | Specifies whether to use SSL to encrypt the connection. [default: false]
MailLogger.smtp.port | The SMTP server port to connect to. [default: 25]

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

MailLogger Members | NAnt.Core Namespace


MailLogger Members

MailLogger overview

Public Instance Constructors

MailLogger Constructor Initializes a new instance of the MailLogger class.

Public Instance Properties

EmacsMode (inherited from DefaultLogger) | Gets or sets a value indicating whether to produce emacs (and other editor) friendly output.
OutputWriter (inherited from DefaultLogger) | Gets or sets the TextWriter to which the logger is to send its output.
Threshold (inherited from DefaultLogger) | Gets or sets the highest level of message this logger should respond to.

Public Instance Methods

BuildFinished | Signals that the last target has finished, and send an e-mail with the build results.
BuildStarted | Signals that a build has started.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from DefaultLogger) | Flushes buffered build events or messages to the underlying storage.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MessageLogged (inherited from DefaultLogger) | Signals that a message has been logged.
TargetFinished (inherited from DefaultLogger) | Signals that a task has finished.
TargetStarted (inherited from DefaultLogger) | Signals that a target has started.
TaskFinished (inherited from DefaultLogger) | Signals that a task has finished.
TaskStarted (inherited from DefaultLogger) | Signals that a task has started.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
Log | Receives and buffers log messages.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailLogger Class | NAnt.Core Namespace


MailLogger Constructor

Initializes a new instance of the MailLogger class.

[Visual Basic]
Public Sub New()
[C#]
public MailLogger();

See Also

MailLogger Class | NAnt.Core Namespace


MailLogger Methods

The methods of the MailLogger class are listed below. For a complete list of MailLogger class members, see the MailLogger Members topic.

Public Instance Methods

BuildFinished | Signals that the last target has finished, and send an e-mail with the build results.
BuildStarted | Signals that a build has started.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush (inherited from DefaultLogger) | Flushes buffered build events or messages to the underlying storage.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MessageLogged (inherited from DefaultLogger) | Signals that a message has been logged.
TargetFinished (inherited from DefaultLogger) | Signals that a task has finished.
TargetStarted (inherited from DefaultLogger) | Signals that a target has started.
TaskFinished (inherited from DefaultLogger) | Signals that a task has finished.
TaskStarted (inherited from DefaultLogger) | Signals that a task has started.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
Log | Receives and buffers log messages.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailLogger Class | NAnt.Core Namespace


MailLogger.BuildFinished Method

Signals that the last target has finished, and send an e-mail with the build results.

[Visual Basic]
Overrides Public Sub BuildFinished( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
) _
Implements IBuildListener.BuildFinished
[C#]
public override void BuildFinished(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Implements

IBuildListener.BuildFinished

See Also

MailLogger Class | NAnt.Core Namespace


MailLogger.BuildStarted Method

Signals that a build has started.

[Visual Basic]
Overrides Public Sub BuildStarted( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
) _
Implements IBuildListener.BuildStarted
[C#]
public override void BuildStarted(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Implements

IBuildListener.BuildStarted

Remarks

This event is fired before any targets have started.

See Also

MailLogger Class | NAnt.Core Namespace


MailLogger.Log Method

Receives and buffers log messages.

[Visual Basic]
Overrides Protected Sub Log( _
ByVal message As String _
)
[C#]
protected override void Log(
string message
);

Parameters

message
The message being logged.

See Also

MailLogger Class | NAnt.Core Namespace


PathScanner Class

Used to search for files on the PATH.

For a list of all members of this type, see PathScanner Members.

System.Object
NAnt.Core.PathScanner

[Visual Basic]
<Serializable, _ Serializable>
NotInheritable Public Class PathScanner
Implements ICloneable
[C#]
[Serializable]
[Serializable]
public sealed class PathScanner : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The local directory is not searched (since this would already be covered by normal use of the includes element).

Also, advanced pattern matching isn't supported: you need to know the exact name of the file.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

PathScanner Members | NAnt.Core Namespace


PathScanner Members

PathScanner overview

Public Instance Constructors

PathScanner Constructor Initializes a new instance of the PathScanner class.

Public Instance Methods

Add | Adds a file to the list of files to be scanned for.
Clear |
Clone | Creates a shallow copy of the PathScanner.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Scan | Overloaded. Scans all direcetories in the PATH environment variable for files.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PathScanner Class | NAnt.Core Namespace


PathScanner Constructor

Initializes a new instance of the PathScanner class.

[Visual Basic]
Public Sub New()
[C#]
public PathScanner();

See Also

PathScanner Class | NAnt.Core Namespace


PathScanner Methods

The methods of the PathScanner class are listed below. For a complete list of PathScanner class members, see the PathScanner Members topic.

Public Instance Methods

Add | Adds a file to the list of files to be scanned for.
Clear |
Clone | Creates a shallow copy of the PathScanner.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Scan | Overloaded. Scans all direcetories in the PATH environment variable for files.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PathScanner Class | NAnt.Core Namespace


PathScanner.Add Method

Adds a file to the list of files to be scanned for.

[Visual Basic]
Public Sub Add( _
ByVal fileName As String _
)
[C#]
public void Add(
string fileName
);

Parameters

fileName
The filename or search pattern to add to the list.

See Also

PathScanner Class | NAnt.Core Namespace


PathScanner.Clear Method

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();

See Also

PathScanner Class | NAnt.Core Namespace


PathScanner.Clone Method

Creates a shallow copy of the PathScanner.

[Visual Basic]
Public Function Clone() As PathScanner
[C#]
public PathScanner Clone();

Return Value

A shallow copy of the PathScanner.

See Also

PathScanner Class | NAnt.Core Namespace


Scan Method

NAnt SDK Documentation - v0.91

PathScanner.Scan Method

Scans all direcetories in the PATH environment variable for files.

Overload List

Scans all direcetories in the PATH environment variable for files.

public StringCollection Scan();

Scans all directories in the given environment variable for files.

public StringCollection Scan(string);

See Also

PathScanner Class | NAnt.Core Namespace


PathScanner.Scan Method ()

Scans all direcetories in the PATH environment variable for files.

[Visual Basic]
Overloads Public Function Scan() As StringCollection
[C#]
public StringCollection Scan();

Return Value

List of matching files found in the PATH.

See Also

PathScanner Class | NAnt.Core Namespace | PathScanner.Scan Overload List


PathScanner.Scan Method (String)

Scans all directories in the given environment variable for files.

[Visual Basic]
Overloads Public Function Scan( _
ByVal name As String _
) As StringCollection
[C#]
public StringCollection Scan(
string name
);

Parameters

name
The environment variable of which the directories should be scanned.

Return Value

List of matching files found in the directory of the given environment variable.

See Also

PathScanner Class | NAnt.Core Namespace | PathScanner.Scan Overload List


PlatformHelper Class

For a list of all members of this type, see PlatformHelper Members.

System.Object
NAnt.Core.PlatformHelper

[Visual Basic]
<Serializable, _ Serializable>
Public Class PlatformHelper
[C#]
[Serializable]
[Serializable]
public class PlatformHelper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

PlatformHelper Members | NAnt.Core Namespace


PlatformHelper Members

PlatformHelper overview

Public Static (Shared) Fields

IsMono |
IsUnix |
IsWin32 | Obsolete.

Public Static (Shared) Properties

IsWindows Returns a value indicating whether NAnt is running on Windows.

Public Static (Shared) Methods

IsVolumeCaseSensitive

Public Instance Constructors

PlatformHelper Constructor Initializes a new instance of the PlatformHelper class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PlatformHelper Class | NAnt.Core Namespace


PlatformHelper Constructor

Initializes a new instance of the PlatformHelper class.

[Visual Basic]
Public Sub New()
[C#]
public PlatformHelper();

See Also

PlatformHelper Class | NAnt.Core Namespace


PlatformHelper Fields

The fields of the PlatformHelper class are listed below. For a complete list of PlatformHelper class members, see the PlatformHelper Members topic.

Public Static (Shared) Fields

IsMono |
IsUnix |
IsWin32 | Obsolete.

See Also

PlatformHelper Class | NAnt.Core Namespace


PlatformHelper.IsMono Field

[Visual Basic]
Public Shared ReadOnly IsMono As Boolean
[C#]
public static readonly bool IsMono;

See Also

PlatformHelper Class | NAnt.Core Namespace


PlatformHelper.IsUnix Field

[Visual Basic]
Public Shared ReadOnly IsUnix As Boolean
[C#]
public static readonly bool IsUnix;

See Also

PlatformHelper Class | NAnt.Core Namespace


PlatformHelper.IsWin32 Field

NOTE: This field is now obsolete.

Use IsWindows instead.

[Visual Basic]
<Obsolete(Message:="Use IsWindows instead.", IsError:=False)>
Public Shared ReadOnly IsWin32 As Boolean
[C#]
[Obsolete(Message="Use IsWindows instead.", IsError=False)]
public static readonly bool IsWin32;

See Also

PlatformHelper Class | NAnt.Core Namespace


PlatformHelper Properties

The properties of the PlatformHelper class are listed below. For a complete list of PlatformHelper class members, see the PlatformHelper Members topic.

Public Static (Shared) Properties

IsWindows Returns a value indicating whether NAnt is running on Windows.

See Also

PlatformHelper Class | NAnt.Core Namespace


IsWindows Property

NAnt SDK Documentation - v0.91

PlatformHelper.IsWindows Property

Returns a value indicating whether NAnt is running on Windows.

[Visual Basic]
Public Shared ReadOnly Property IsWindows As Boolean
[C#]
public static bool IsWindows {get;}

Property Value

true if NAnt is running on Windows; otherwise, false.

See Also

PlatformHelper Class | NAnt.Core Namespace


PlatformHelper Methods

The methods of the PlatformHelper class are listed below. For a complete list of PlatformHelper class members, see the PlatformHelper Members topic.

Public Static (Shared) Methods

IsVolumeCaseSensitive

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PlatformHelper Class | NAnt.Core Namespace


PlatformHelper.IsVolumeCaseSensitive Method

[Visual Basic]
Public Shared Function IsVolumeCaseSensitive( _
ByVal path As String _
) As Boolean
[C#]
public static bool IsVolumeCaseSensitive(
string path
);

See Also

PlatformHelper Class | NAnt.Core Namespace


Project Class

Central representation of a NAnt project.

For a list of all members of this type, see Project Members.

System.Object
NAnt.Core.Project

[Visual Basic]
<Serializable, _ Serializable>
Public Class Project
[C#]
[Serializable]
[Serializable]
public class Project

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

The Run method will initialize the project with the build file specified in the constructor and execute the default target.

Project p = new Project("foo.build", Level.Info);
p.Run();

If no target is given, the default target will be executed if specified in the project.

Project p = new Project("foo.build", Level.Info);
p.Execute("build");

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

Project Members | NAnt.Core Namespace


Project Members

Project overview

Public Instance Constructors

Project Overloaded. Initializes a new instance of the Project class.

Public Instance Properties

BaseDirectory | Gets or sets the base directory used for relative references.
BuildFileLocalName | Gets the path to the build file.
BuildFileUri | Gets the Uri form of the current project definition.
BuildListeners | Gets the build listeners for this project.
BuildTargets | The list of targets to build.
ConfigurationNode | Gets the XmlNode NAnt should use to initialize configuration settings.
CurrentTarget | Gets the current target.
DataTypeReferences | Gets the DataTypeBase instances defined in this project.
DefaultTargetName |
Document | Gets the active Project definition.
FrameworkNeutralProperties | Gets the framework-neutral properties defined in the NAnt configuration file.
Frameworks | Gets a collection of available .NET frameworks.
IndentationLevel | Gets or sets the indendation level of the build output.
IndentationSize | Gets or sets the indentation size of the build output.
NamespaceManager | Gets the XmlNamespaceManager.
PlatformName | Gets the name of the platform on which NAnt is currently running.
ProjectName | Gets the name of the Project.
Properties | Gets the properties defined in this project.
RuntimeFramework | Gets the framework in which NAnt is currently running.
TargetFramework | Gets or sets the framework to use for compilation.
Targets | Gets the targets defined in this project.
Threshold | Gets or sets the default threshold level for build loggers.
Verbose | Gets a value indicating whether tasks should output more build log messages.

Public Instance Methods

AttachBuildListeners | Attaches the specified build listeners to the Project.
CreateDataTypeBase |
CreateDefaultLogger | Creates the default IBuildLogger and attaches it to the Project.
CreateTask | Overloaded. Creates a new from the given XmlNode.
DetachBuildListeners | Detaches the currently attached IBuildListener instances from the Project.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Overloaded. Executes the default target.
ExpandProperties | Expands a String from known properties.
GetFullPath | Combines the specified path with the BaseDirectory of the Project to form a full path to file or directory.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation | Returns the Location of the given node in an XML file loaded by NAnt.
GetType (inherited from Object) | Gets the Type of the current instance.
Indent | Increases the IndentationLevel of the Project.
Log | Overloaded. Writes a Project level message to the build log with the given Level.
OnBuildFinished | Dispatches a BuildFinished event to the build listeners for this Project.
OnBuildStarted | Dispatches a BuildStarted event to the build listeners for this Project.
OnMessageLogged | Dispatches a MessageLogged event to the build listeners for this Project.
OnTargetFinished | Dispatches a TargetFinished event to the build listeners for this Project.
OnTargetStarted | Dispatches a TargetStarted event to the build listeners for this Project.
OnTaskFinished | Dispatches the TaskFinished event to the build listeners for this Project.
OnTaskStarted | Dispatches a TaskStarted event to the build listeners for this Project.
Run | Executes the default target and wraps in error handling and time stamping.
TopologicalTargetSort | Topologically sorts a set of targets.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unindent | Decreases the IndentationLevel of the Project.

Public Instance Events

BuildFinished
BuildStarted
MessageLogged
TargetFinished
TargetStarted
TaskFinished
TaskStarted

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Project Class | NAnt.Core Namespace


Project Constructor

Initializes a new Project class with the given document, message threshold and indentation level.

Overload List

Initializes a new Project class with the given source, message threshold and indentation level.

public Project(string,Level,int);

Initializes a new Project class with the given source, message threshold and indentation level, and using the specified XmlNode to load internal configuration settings.

public Project(string,Level,int,XmlNode);

Initializes a new Project class with the given document, message threshold and indentation level.

public Project(XmlDocument,Level,int);

Initializes a new Project class with the given document, message threshold and indentation level, and using the specified XmlNode to load internal configuration settings.

public Project(XmlDocument,Level,int,XmlNode);

See Also

Project Class | NAnt.Core Namespace


Project Constructor (XmlDocument, Level, Int32)

Initializes a new Project class with the given document, message threshold and indentation level.

[Visual Basic]
Overloads Public Sub New( _
ByVal doc As XmlDocument, _
ByVal threshold As Level, _
ByVal indentLevel As Integer _
)
[C#]
public Project(
XmlDocument doc,
Level threshold,
int indentLevel
);

Parameters

doc
Any valid build format will do.
threshold
The message threshold.
indentLevel
The project indentation level.

See Also

Project Class | NAnt.Core Namespace | Project Constructor Overload List


Project Constructor (XmlDocument, Level, Int32, XmlNode)

Initializes a new Project class with the given document, message threshold and indentation level, and using the specified XmlNode to load internal configuration settings.

[Visual Basic]
Overloads Public Sub New( _
ByVal doc As XmlDocument, _
ByVal threshold As Level, _
ByVal indentLevel As Integer, _
ByVal configurationNode As XmlNode _
)
[C#]
public Project(
XmlDocument doc,
Level threshold,
int indentLevel,
XmlNode configurationNode
);

Parameters

doc
Any valid build format will do.
threshold
The message threshold.
indentLevel
The project indentation level.
configurationNode
The XmlNode NAnt should use to initialize configuration settings.

Remarks

This constructor is useful for developers using NAnt as a class library.

See Also

Project Class | NAnt.Core Namespace | Project Constructor Overload List


Project Constructor (String, Level, Int32)

Initializes a new Project class with the given source, message threshold and indentation level.

[Visual Basic]
Overloads Public Sub New( _
ByVal uriOrFilePath As String, _
ByVal threshold As Level, _
ByVal indentLevel As Integer _
)
[C#]
public Project(
string uriOrFilePath,
Level threshold,
int indentLevel
);

Parameters

uriOrFilePath

The full path to the build file.

This can be of any form that Load accepts.

threshold
The message threshold.
indentLevel
The project indentation level.

Remarks

If the source is a uri of form 'file:///path' then use the path part.

See Also

Project Class | NAnt.Core Namespace | Project Constructor Overload List


Project Constructor (String, Level, Int32, XmlNode)

Initializes a new Project class with the given source, message threshold and indentation level, and using the specified XmlNode to load internal configuration settings.

[Visual Basic]
Overloads Public Sub New( _
ByVal uriOrFilePath As String, _
ByVal threshold As Level, _
ByVal indentLevel As Integer, _
ByVal configurationNode As XmlNode _
)
[C#]
public Project(
string uriOrFilePath,
Level threshold,
int indentLevel,
XmlNode configurationNode
);

Parameters

uriOrFilePath

The full path to the build file.

This can be of any form that Load accepts.

threshold
The message threshold.
indentLevel
The project indentation level.
configurationNode
The XmlNode NAnt should use to initialize configuration settings.

Remarks

If the source is a uri of form 'file:///path' then use the path part.

Exceptions

Exception Type | Condition
ArgumentNullException | configurationNode is a null reference (Nothing in Visual Basic).

See Also

Project Class | NAnt.Core Namespace | Project Constructor Overload List


Project Properties

The properties of the Project class are listed below. For a complete list of Project class members, see the Project Members topic.

Public Instance Properties

BaseDirectory | Gets or sets the base directory used for relative references.
BuildFileLocalName | Gets the path to the build file.
BuildFileUri | Gets the Uri form of the current project definition.
BuildListeners | Gets the build listeners for this project.
BuildTargets | The list of targets to build.
ConfigurationNode | Gets the XmlNode NAnt should use to initialize configuration settings.
CurrentTarget | Gets the current target.
DataTypeReferences | Gets the DataTypeBase instances defined in this project.
DefaultTargetName |
Document | Gets the active Project definition.
FrameworkNeutralProperties | Gets the framework-neutral properties defined in the NAnt configuration file.
Frameworks | Gets a collection of available .NET frameworks.
IndentationLevel | Gets or sets the indendation level of the build output.
IndentationSize | Gets or sets the indentation size of the build output.
NamespaceManager | Gets the XmlNamespaceManager.
PlatformName | Gets the name of the platform on which NAnt is currently running.
ProjectName | Gets the name of the Project.
Properties | Gets the properties defined in this project.
RuntimeFramework | Gets the framework in which NAnt is currently running.
TargetFramework | Gets or sets the framework to use for compilation.
Targets | Gets the targets defined in this project.
Threshold | Gets or sets the default threshold level for build loggers.
Verbose | Gets a value indicating whether tasks should output more build log messages.

See Also

Project Class | NAnt.Core Namespace


BaseDirectory Property

NAnt SDK Documentation - v0.91

Project.BaseDirectory Property

Gets or sets the base directory used for relative references.

[Visual Basic]
Public Property BaseDirectory As String
[C#]
public string BaseDirectory {get; set;}

Property Value

The base directory used for relative references.

Remarks

The BaseDirectory gets and sets the built-in property named "nant.project.basedir".

Exceptions

Exception Type | Condition
BuildException | The directory is not rooted.

See Also

Project Class | NAnt.Core Namespace


BuildFileLocalName Property

NAnt SDK Documentation - v0.91

Project.BuildFileLocalName Property

Gets the path to the build file.

[Visual Basic]
Public ReadOnly Property BuildFileLocalName As String
[C#]
public string BuildFileLocalName {get;}

Property Value

The path to the build file, or a null reference (Nothing in Visual Basic) if the build document is not file backed.

See Also

Project Class | NAnt.Core Namespace


BuildFileUri Property

NAnt SDK Documentation - v0.91

Project.BuildFileUri Property

Gets the Uri form of the current project definition.

[Visual Basic]
Public ReadOnly Property BuildFileUri As Uri
[C#]
public System.Uri BuildFileUri {get;}

Property Value

The Uri form of the current project definition.

See Also

Project Class | NAnt.Core Namespace


BuildListeners Property

NAnt SDK Documentation - v0.91

Project.BuildListeners Property

Gets the build listeners for this project.

[Visual Basic]
Public ReadOnly Property BuildListeners As BuildListenerCollection
[C#]
public BuildListenerCollection BuildListeners {get;}

Property Value

The build listeners for this project.

See Also

Project Class | NAnt.Core Namespace


BuildTargets Property

NAnt SDK Documentation - v0.91

Project.BuildTargets Property

The list of targets to build.

[Visual Basic]
Public ReadOnly Property BuildTargets As StringCollection
[C#]
public System.Collections.Specialized.StringCollection BuildTargets {get;}

Remarks

Targets are built in the order they appear in the collection. If the collection is empty the default target will be built.

See Also

Project Class | NAnt.Core Namespace


ConfigurationNode Property

NAnt SDK Documentation - v0.91

Project.ConfigurationNode Property

Gets the XmlNode NAnt should use to initialize configuration settings.

[Visual Basic]
Public ReadOnly Property ConfigurationNode As XmlNode
[C#]
public System.Xml.XmlNode ConfigurationNode {get;}

Property Value

The XmlNode NAnt should use to initialize configuration settings.

See Also

Project Class | NAnt.Core Namespace


CurrentTarget Property

NAnt SDK Documentation - v0.91

Project.CurrentTarget Property

Gets the current target.

[Visual Basic]
Public ReadOnly Property CurrentTarget As Target
[C#]
public Target CurrentTarget {get;}

Property Value

The current target, or a null reference (Nothing in Visual Basic) if no target is executing.

See Also

Project Class | NAnt.Core Namespace


DataTypeReferences Property

NAnt SDK Documentation - v0.91

Project.DataTypeReferences Property

Gets the DataTypeBase instances defined in this project.

[Visual Basic]
Public ReadOnly Property DataTypeReferences As DataTypeBaseDictionary
[C#]
public DataTypeBaseDictionary DataTypeReferences {get;}

Property Value

The DataTypeBase instances defined in this project.

Remarks

This is the collection of DataTypeBase instances that are defined by DataTypeBase (eg fileset) declarations.

See Also

Project Class | NAnt.Core Namespace


DefaultTargetName Property

NAnt SDK Documentation - v0.91

Project.DefaultTargetName Property

[Visual Basic]
Public ReadOnly Property DefaultTargetName As String
[C#]
public string DefaultTargetName {get;}

Property Value

The name of the target that will be executed when no other build targets are specified, or a null reference (Nothing in Visual Basic) if no default target is specified in the build file.

Remarks

Gets the name of the target that will be executed when no other build targets are specified.

See Also

Project Class | NAnt.Core Namespace


Document Property

NAnt SDK Documentation - v0.91

Project.Document Property

Gets the active Project definition.

[Visual Basic]
Public ReadOnly Property Document As XmlDocument
[C#]
public System.Xml.XmlDocument Document {get;}

Property Value

The active Project definition.

See Also

Project Class | NAnt.Core Namespace


FrameworkNeutralProperties Property

NAnt SDK Documentation - v0.91

Project.FrameworkNeutralProperties Property

Gets the framework-neutral properties defined in the NAnt configuration file.

[Visual Basic]
Public ReadOnly Property FrameworkNeutralProperties As PropertyDictionary
[C#]
public PropertyDictionary FrameworkNeutralProperties {get;}

Property Value

The framework-neutral properties defined in the NAnt configuration file.

Remarks

This is the collection of read-only properties that are defined in the NAnt configuration file.

These properties can only be used for expansion in framework-specific and framework-neutral configuration settings. These properties are not available for expansion in the build file.

See Also

Project Class | NAnt.Core Namespace


Frameworks Property

NAnt SDK Documentation - v0.91

Project.Frameworks Property

Gets a collection of available .NET frameworks.

[Visual Basic]
Public ReadOnly Property Frameworks As FrameworkInfoDictionary
[C#]
public FrameworkInfoDictionary Frameworks {get;}

Property Value

A collection of available .NET frameworks.

See Also

Project Class | NAnt.Core Namespace


IndentationLevel Property

NAnt SDK Documentation - v0.91

Project.IndentationLevel Property

Gets or sets the indendation level of the build output.

[Visual Basic]
Public ReadOnly Property IndentationLevel As Integer
[C#]
public int IndentationLevel {get;}

Property Value

The indentation level of the build output.

Remarks

To change the IndentationLevel, the Indent and Unindent methods should be used.

See Also

Project Class | NAnt.Core Namespace


IndentationSize Property

NAnt SDK Documentation - v0.91

Project.IndentationSize Property

Gets or sets the indentation size of the build output.

[Visual Basic]
Public ReadOnly Property IndentationSize As Integer
[C#]
public int IndentationSize {get;}

Property Value

The indendation size of the build output.

See Also

Project Class | NAnt.Core Namespace


NamespaceManager Property

NAnt SDK Documentation - v0.91

Project.NamespaceManager Property

Gets the XmlNamespaceManager.

[Visual Basic]
Public ReadOnly Property NamespaceManager As XmlNamespaceManager
[C#]
public System.Xml.XmlNamespaceManager NamespaceManager {get;}

Property Value

The XmlNamespaceManager.

Remarks

The NamespaceManager defines the current namespace scope and provides methods for looking up namespace information.

See Also

Project Class | NAnt.Core Namespace


PlatformName Property

NAnt SDK Documentation - v0.91

Project.PlatformName Property

Gets the name of the platform on which NAnt is currently running.

[Visual Basic]
Public ReadOnly Property PlatformName As String
[C#]
public string PlatformName {get;}

Property Value

The name of the platform on which NAnt is currently running.

Remarks

Possible values are:

  • win32
  • unix

Exceptions

Exception Type | Condition
BuildException | NAnt does not support the current platform.

See Also

Project Class | NAnt.Core Namespace


ProjectName Property

NAnt SDK Documentation - v0.91

Project.ProjectName Property

Gets the name of the Project.

[Visual Basic]
Public ReadOnly Property ProjectName As String
[C#]
public string ProjectName {get;}

Property Value

The name of the Project or an empty String if no name is specified.

See Also

Project Class | NAnt.Core Namespace


Properties Property

NAnt SDK Documentation - v0.91

Project.Properties Property

Gets the properties defined in this project.

[Visual Basic]
Public ReadOnly Property Properties As PropertyDictionary
[C#]
public PropertyDictionary Properties {get;}

Property Value

The properties defined in this project.

Remarks

This is the collection of properties that are defined by the system and property task statements.

These properties can be used in expansion.

See Also

Project Class | NAnt.Core Namespace


RuntimeFramework Property

NAnt SDK Documentation - v0.91

Project.RuntimeFramework Property

Gets the framework in which NAnt is currently running.

[Visual Basic]
Public Property RuntimeFramework As FrameworkInfo
[C#]
public FrameworkInfo RuntimeFramework {get; set;}

Property Value

The framework in which NAnt is currently running.

See Also

Project Class | NAnt.Core Namespace


TargetFramework Property

NAnt SDK Documentation - v0.91

Project.TargetFramework Property

Gets or sets the framework to use for compilation.

[Visual Basic]
Public Property TargetFramework As FrameworkInfo
[C#]
public FrameworkInfo TargetFramework {get; set;}

Property Value

The framework to use for compilation.

Remarks

We will use compiler tools and system assemblies for this framework in framework-related tasks.

Exceptions

Exception Type | Condition
ArgumentNullException | The value specified is a null reference (Nothing in Visual Basic).
BuildException | The specified framework is not installed, or not configured correctly.

See Also

Project Class | NAnt.Core Namespace


Targets Property

NAnt SDK Documentation - v0.91

Project.Targets Property

Gets the targets defined in this project.

[Visual Basic]
Public ReadOnly Property Targets As TargetCollection
[C#]
public TargetCollection Targets {get;}

Property Value

The targets defined in this project.

See Also

Project Class | NAnt.Core Namespace


Threshold Property

NAnt SDK Documentation - v0.91

Project.Threshold Property

Gets or sets the default threshold level for build loggers.

[Visual Basic]
Public Property Threshold As Level
[C#]
public Level Threshold {get; set;}

Property Value

The default threshold level for build loggers.

See Also

Project Class | NAnt.Core Namespace


Verbose Property

NAnt SDK Documentation - v0.91

Project.Verbose Property

Gets a value indicating whether tasks should output more build log messages.

[Visual Basic]
Public ReadOnly Property Verbose As Boolean
[C#]
public bool Verbose {get;}

Property Value

true if tasks should output more build log message; otherwise, false.

See Also

Project Class | NAnt.Core Namespace


Project Methods

The methods of the Project class are listed below. For a complete list of Project class members, see the Project Members topic.

Public Instance Methods

AttachBuildListeners | Attaches the specified build listeners to the Project.
CreateDataTypeBase |
CreateDefaultLogger | Creates the default IBuildLogger and attaches it to the Project.
CreateTask | Overloaded. Creates a new from the given XmlNode.
DetachBuildListeners | Detaches the currently attached IBuildListener instances from the Project.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Overloaded. Executes the default target.
ExpandProperties | Expands a String from known properties.
GetFullPath | Combines the specified path with the BaseDirectory of the Project to form a full path to file or directory.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation | Returns the Location of the given node in an XML file loaded by NAnt.
GetType (inherited from Object) | Gets the Type of the current instance.
Indent | Increases the IndentationLevel of the Project.
Log | Overloaded. Writes a Project level message to the build log with the given Level.
OnBuildFinished | Dispatches a BuildFinished event to the build listeners for this Project.
OnBuildStarted | Dispatches a BuildStarted event to the build listeners for this Project.
OnMessageLogged | Dispatches a MessageLogged event to the build listeners for this Project.
OnTargetFinished | Dispatches a TargetFinished event to the build listeners for this Project.
OnTargetStarted | Dispatches a TargetStarted event to the build listeners for this Project.
OnTaskFinished | Dispatches the TaskFinished event to the build listeners for this Project.
OnTaskStarted | Dispatches a TaskStarted event to the build listeners for this Project.
Run | Executes the default target and wraps in error handling and time stamping.
TopologicalTargetSort | Topologically sorts a set of targets.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unindent | Decreases the IndentationLevel of the Project.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Project Class | NAnt.Core Namespace


Project.AttachBuildListeners Method

Attaches the specified build listeners to the Project.

[Visual Basic]
Public Sub AttachBuildListeners( _
ByVal listeners As BuildListenerCollection _
)
[C#]
public void AttachBuildListeners(
BuildListenerCollection listeners
);

Parameters

listeners
The IBuildListener instances to attach to the Project.

Remarks

The currently attached IBuildListener instances will be detached before the new IBuildListener instances are attached.

See Also

Project Class | NAnt.Core Namespace


Project.CreateDataTypeBase Method

[Visual Basic]
Public Function CreateDataTypeBase( _
ByVal elementNode As XmlNode _
) As DataTypeBase
[C#]
public DataTypeBase CreateDataTypeBase(
XmlNode elementNode
);

See Also

Project Class | NAnt.Core Namespace


Project.CreateDefaultLogger Method

Creates the default IBuildLogger and attaches it to the Project.

[Visual Basic]
Public Sub CreateDefaultLogger()
[C#]
public void CreateDefaultLogger();

See Also

Project Class | NAnt.Core Namespace


CreateTask Method

NAnt SDK Documentation - v0.91

Project.CreateTask Method

Creates a new from the given XmlNode.

Overload List

Creates a new from the given XmlNode.

public Task CreateTask(XmlNode);

Creates a new Task from the given XmlNode within a Target.

public Task CreateTask(XmlNode,Target);

See Also

Project Class | NAnt.Core Namespace


Project.CreateTask Method (XmlNode)

Creates a new from the given XmlNode.

[Visual Basic]
Overloads Public Function CreateTask( _
ByVal taskNode As XmlNode _
) As Task
[C#]
public Task CreateTask(
XmlNode taskNode
);

Parameters

taskNode
The Task definition.

Return Value

The new Task instance.

See Also

Project Class | NAnt.Core Namespace | Project.CreateTask Overload List


Project.CreateTask Method (XmlNode, Target)

Creates a new Task from the given XmlNode within a Target.

[Visual Basic]
Overloads Public Function CreateTask( _
ByVal taskNode As XmlNode, _
ByVal target As Target _
) As Task
[C#]
public Task CreateTask(
XmlNode taskNode,
Target target
);

Parameters

taskNode
The Task definition.
target
The owner Target.

Return Value

The new Task instance.

See Also

Project Class | NAnt.Core Namespace | Project.CreateTask Overload List


Project.DetachBuildListeners Method

Detaches the currently attached IBuildListener instances from the Project.

[Visual Basic]
Public Sub DetachBuildListeners()
[C#]
public void DetachBuildListeners();

See Also

Project Class | NAnt.Core Namespace


Execute Method

NAnt SDK Documentation - v0.91

Project.Execute Method

Executes the default target.

Overload List

Executes the default target.

public virtual void Execute();

Executes a specific target, and its dependencies.

public void Execute(string);

Executes a specific target.

public void Execute(string,bool);

See Also

Project Class | NAnt.Core Namespace


Project.Execute Method ()

Executes the default target.

[Visual Basic]
Overridable Overloads Public Sub Execute()
[C#]
public virtual void Execute();

Remarks

No top level error handling is done. Any BuildException will be passed onto the caller.

See Also

Project Class | NAnt.Core Namespace | Project.Execute Overload List


Project.Execute Method (String)

Executes a specific target, and its dependencies.

[Visual Basic]
Overloads Public Sub Execute( _
ByVal targetName As String _
)
[C#]
public void Execute(
string targetName
);

Parameters

targetName
The name of the target to execute.

Remarks

Global tasks are not executed.

See Also

Project Class | NAnt.Core Namespace | Project.Execute Overload List


Project.Execute Method (String, Boolean)

Executes a specific target.

[Visual Basic]
Overloads Public Sub Execute( _
ByVal targetName As String, _
ByVal forceDependencies As Boolean _
)
[C#]
public void Execute(
string targetName,
bool forceDependencies
);

Parameters

targetName
The name of the target to execute.
forceDependencies
Whether dependencies should be forced to execute

Remarks

Global tasks are not executed.

See Also

Project Class | NAnt.Core Namespace | Project.Execute Overload List


Project.ExpandProperties Method

Expands a String from known properties.

[Visual Basic]
Public Function ExpandProperties( _
ByVal input As String, _
ByVal location As Location _
) As String
[C#]
public string ExpandProperties(
string input,
Location location
);

Parameters

input
The String with replacement tokens.
location
The location in the build file. Used to throw more accurate exceptions.

Return Value

The expanded and replaced String.

See Also

Project Class | NAnt.Core Namespace


Project.GetFullPath Method

Combines the specified path with the BaseDirectory of the Project to form a full path to file or directory.

[Visual Basic]
Public Function GetFullPath( _
ByVal path As String _
) As String
[C#]
public string GetFullPath(
string path
);

Parameters

path
The relative or absolute path.

Return Value

A rooted path, or the BaseDirectory of the Project if the path parameter is a null reference.

See Also

Project Class | NAnt.Core Namespace


Project.GetLocation Method

Returns the Location of the given node in an XML file loaded by NAnt.

[Visual Basic]
Public Function GetLocation( _
ByVal node As XmlNode _
) As Location
[C#]
public Location GetLocation(
XmlNode node
);

Parameters

node
The XmlNode to get the Location for.

Return Value

Location of the given node in an XML file loaded by NAnt, or UnknownLocation if the node was not loaded from an XML file.

Remarks

The node must be from an XmlDocument that has been loaded by NAnt.

NAnt also does not process any of the following node types:

  • Whitespace
  • EndElement
  • ProcessingInstruction
  • XmlDeclaration
  • DocumentType

As a result, no location information is available for these nodes.

Exceptions

Exception Type | Condition
ArgumentException | node is from an XML file that was not loaded by NAnt. -or node was not processed by NAnt (eg. an XML declaration).

See Also

Project Class | NAnt.Core Namespace


Project.Indent Method

Increases the IndentationLevel of the Project.

[Visual Basic]
Public Sub Indent()
[C#]
public void Indent();

See Also

Project Class | NAnt.Core Namespace


Log Method

NAnt SDK Documentation - v0.91

Project.Log Method

Writes a Project level message to the build log with the given Level.

Overload List

Writes a Project level message to the build log with the given Level.

public void Log(Level,string);

Writes a Project level formatted message to the build log with the given Level.

public void Log(Level,string,params object[]);

Writes a Target level message to the build log with the given Level.

public void Log(Target,Level,string);

Writes a Task task level message to the build log with the given Level.

public void Log(Task,Level,string);

See Also

Project Class | NAnt.Core Namespace


Project.Log Method (Level, String)

Writes a Project level message to the build log with the given Level.

[Visual Basic]
Overloads Public Sub Log( _
ByVal messageLevel As Level, _
ByVal message As String _
)
[C#]
public void Log(
Level messageLevel,
string message
);

Parameters

messageLevel
The Level to log at.
message
The message to log.

See Also

Project Class | NAnt.Core Namespace | Project.Log Overload List


Project.Log Method (Level, String, Object[])

Writes a Project level formatted message to the build log with the given Level.

[Visual Basic]
Overloads Public Sub Log( _
ByVal messageLevel As Level, _
ByVal message As String, _
ParamArray args As Object() _
)
[C#]
public void Log(
Level messageLevel,
string message,
params object[] args
);

Parameters

messageLevel
The Level to log at.
message
The message to log, containing zero or more format items.
args
An Object array containing zero or more objects to format.

See Also

Project Class | NAnt.Core Namespace | Project.Log Overload List


Project.Log Method (Target, Level, String)

Writes a Target level message to the build log with the given Level.

[Visual Basic]
Overloads Public Sub Log( _
ByVal target As Target, _
ByVal messageLevel As Level, _
ByVal message As String _
)
[C#]
public void Log(
Target target,
Level messageLevel,
string message
);

Parameters

target
The Target from which the message orignated.
messageLevel
The level to log at.
message
The message to log.

See Also

Project Class | NAnt.Core Namespace | Project.Log Overload List


Project.Log Method (Task, Level, String)

Writes a Task task level message to the build log with the given Level.

[Visual Basic]
Overloads Public Sub Log( _
ByVal task As Task, _
ByVal messageLevel As Level, _
ByVal message As String _
)
[C#]
public void Log(
Task task,
Level messageLevel,
string message
);

Parameters

task
The Task from which the message originated.
messageLevel
The Level to log at.
message
The message to log.

See Also

Project Class | NAnt.Core Namespace | Project.Log Overload List


Project.OnBuildFinished Method

Dispatches a BuildFinished event to the build listeners for this Project.

[Visual Basic]
Public Sub OnBuildFinished( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
)
[C#]
public void OnBuildFinished(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs that contains the event data.

See Also

Project Class | NAnt.Core Namespace


Project.OnBuildStarted Method

Dispatches a BuildStarted event to the build listeners for this Project.

[Visual Basic]
Public Sub OnBuildStarted( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
)
[C#]
public void OnBuildStarted(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs that contains the event data.

See Also

Project Class | NAnt.Core Namespace


Project.OnMessageLogged Method

Dispatches a MessageLogged event to the build listeners for this Project.

[Visual Basic]
Public Sub OnMessageLogged( _
ByVal e As BuildEventArgs _
)
[C#]
public void OnMessageLogged(
BuildEventArgs e
);

Parameters

e
A BuildEventArgs that contains the event data.

See Also

Project Class | NAnt.Core Namespace


Project.OnTargetFinished Method

Dispatches a TargetFinished event to the build listeners for this Project.

[Visual Basic]
Public Sub OnTargetFinished( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
)
[C#]
public void OnTargetFinished(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs that contains the event data.

See Also

Project Class | NAnt.Core Namespace


Project.OnTargetStarted Method

Dispatches a TargetStarted event to the build listeners for this Project.

[Visual Basic]
Public Sub OnTargetStarted( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
)
[C#]
public void OnTargetStarted(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs that contains the event data.

See Also

Project Class | NAnt.Core Namespace


Project.OnTaskFinished Method

Dispatches the TaskFinished event to the build listeners for this Project.

[Visual Basic]
Public Sub OnTaskFinished( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
)
[C#]
public void OnTaskFinished(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs that contains the event data.

See Also

Project Class | NAnt.Core Namespace


Project.OnTaskStarted Method

Dispatches a TaskStarted event to the build listeners for this Project.

[Visual Basic]
Public Sub OnTaskStarted( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
)
[C#]
public void OnTaskStarted(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs that contains the event data.

See Also

Project Class | NAnt.Core Namespace


Project.Run Method

Executes the default target and wraps in error handling and time stamping.

[Visual Basic]
Public Function Run() As Boolean
[C#]
public bool Run();

Return Value

true if the build was successful; otherwise, false.

See Also

Project Class | NAnt.Core Namespace


Project.TopologicalTargetSort Method

Topologically sorts a set of targets.

[Visual Basic]
Public Function TopologicalTargetSort( _
ByVal root As String, _
ByVal targets As TargetCollection _
) As TargetCollection
[C#]
public TargetCollection TopologicalTargetSort(
string root,
TargetCollection targets
);

Parameters

root
The name of the root target. The sort is created in such a way that the sequence of targets up to the root target is the minimum possible such sequence. Must not be a null reference (Nothing in Visual Basic).
targets
A collection of Target instances.

Return Value

A collection of Target instances in sorted order.

Exceptions

Exception Type | Condition
BuildException | There is a cyclic dependecy among the targets, or a named target does not exist.

See Also

Project Class | NAnt.Core Namespace


Project.Unindent Method

Decreases the IndentationLevel of the Project.

[Visual Basic]
Public Sub Unindent()
[C#]
public void Unindent();

See Also

Project Class | NAnt.Core Namespace


Project Events

The events of the Project class are listed below. For a complete list of Project class members, see the Project Members topic.

Public Instance Events

BuildFinished
BuildStarted
MessageLogged
TargetFinished
TargetStarted
TaskFinished
TaskStarted

See Also

Project Class | NAnt.Core Namespace


Project.BuildFinished Event

[Visual Basic]
Public Event BuildFinished As BuildEventHandler
[C#]
public event BuildEventHandler BuildFinished;

Event Data

The event handler receives an argument of type BuildEventArgs containing data related to this event. The following BuildEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets or sets the Exception associated with this event.
Message | Gets or sets the message associated with this event.
MessageLevel | Gets or sets the priority level associated with this event.
Project | Gets the Project that fired this event.
Target | Gets the Target that fired this event.
Task | Gets the Task that fired this event.

See Also

Project Class | NAnt.Core Namespace


Project.BuildStarted Event

[Visual Basic]
Public Event BuildStarted As BuildEventHandler
[C#]
public event BuildEventHandler BuildStarted;

Event Data

The event handler receives an argument of type BuildEventArgs containing data related to this event. The following BuildEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets or sets the Exception associated with this event.
Message | Gets or sets the message associated with this event.
MessageLevel | Gets or sets the priority level associated with this event.
Project | Gets the Project that fired this event.
Target | Gets the Target that fired this event.
Task | Gets the Task that fired this event.

See Also

Project Class | NAnt.Core Namespace


Project.MessageLogged Event

[Visual Basic]
Public Event MessageLogged As BuildEventHandler
[C#]
public event BuildEventHandler MessageLogged;

Event Data

The event handler receives an argument of type BuildEventArgs containing data related to this event. The following BuildEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets or sets the Exception associated with this event.
Message | Gets or sets the message associated with this event.
MessageLevel | Gets or sets the priority level associated with this event.
Project | Gets the Project that fired this event.
Target | Gets the Target that fired this event.
Task | Gets the Task that fired this event.

See Also

Project Class | NAnt.Core Namespace


Project.TargetFinished Event

[Visual Basic]
Public Event TargetFinished As BuildEventHandler
[C#]
public event BuildEventHandler TargetFinished;

Event Data

The event handler receives an argument of type BuildEventArgs containing data related to this event. The following BuildEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets or sets the Exception associated with this event.
Message | Gets or sets the message associated with this event.
MessageLevel | Gets or sets the priority level associated with this event.
Project | Gets the Project that fired this event.
Target | Gets the Target that fired this event.
Task | Gets the Task that fired this event.

See Also

Project Class | NAnt.Core Namespace


Project.TargetStarted Event

[Visual Basic]
Public Event TargetStarted As BuildEventHandler
[C#]
public event BuildEventHandler TargetStarted;

Event Data

The event handler receives an argument of type BuildEventArgs containing data related to this event. The following BuildEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets or sets the Exception associated with this event.
Message | Gets or sets the message associated with this event.
MessageLevel | Gets or sets the priority level associated with this event.
Project | Gets the Project that fired this event.
Target | Gets the Target that fired this event.
Task | Gets the Task that fired this event.

See Also

Project Class | NAnt.Core Namespace


Project.TaskFinished Event

[Visual Basic]
Public Event TaskFinished As BuildEventHandler
[C#]
public event BuildEventHandler TaskFinished;

Event Data

The event handler receives an argument of type BuildEventArgs containing data related to this event. The following BuildEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets or sets the Exception associated with this event.
Message | Gets or sets the message associated with this event.
MessageLevel | Gets or sets the priority level associated with this event.
Project | Gets the Project that fired this event.
Target | Gets the Target that fired this event.
Task | Gets the Task that fired this event.

See Also

Project Class | NAnt.Core Namespace


Project.TaskStarted Event

[Visual Basic]
Public Event TaskStarted As BuildEventHandler
[C#]
public event BuildEventHandler TaskStarted;

Event Data

The event handler receives an argument of type BuildEventArgs containing data related to this event. The following BuildEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets or sets the Exception associated with this event.
Message | Gets or sets the message associated with this event.
MessageLevel | Gets or sets the priority level associated with this event.
Project | Gets the Project that fired this event.
Target | Gets the Target that fired this event.
Task | Gets the Task that fired this event.

See Also

Project Class | NAnt.Core Namespace


PropertyDictionary Class

For a list of all members of this type, see PropertyDictionary Members.

System.Object
System.Collections.DictionaryBase
NAnt.Core.PropertyDictionary

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class PropertyDictionary
Inherits DictionaryBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class PropertyDictionary : DictionaryBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

PropertyDictionary Members | NAnt.Core Namespace


PropertyDictionary Members

PropertyDictionary overview

Public Instance Constructors

PropertyDictionary Constructor Initializes a new instance of the PropertyDictionary class holding properties for the given Project instance.

Public Instance Properties

Count (inherited from DictionaryBase) | Gets the number of elements contained in the DictionaryBase instance.
Item | Indexer property.
Project | Gets the project for which the dictionary holds properties.

Public Instance Methods

Add | Adds a property to the collection.
AddReadOnly | Adds a property that cannot be changed.
Clear (inherited from DictionaryBase) | Clears the contents of the DictionaryBase instance.
Contains | Determines whether a property already exists.
CopyTo (inherited from DictionaryBase) | Copies the DictionaryBase elements to a one-dimensional Array at the specified index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandProperties | Expands a String from known properties.
GetEnumerator (inherited from DictionaryBase) | Returns an IDictionaryEnumerator that iterates through the DictionaryBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Inherit | Inherits properties from an existing property dictionary Instance.
IsDynamicProperty | Determines whether the specified property is listed as dynamic.
IsReadOnlyProperty | Determines whether the specified property is listed as read-only.
MarkDynamic | Marks a property as a property of which the value is expanded at execution time.
Remove | Removes the property with the specified name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Dictionary (inherited from DictionaryBase) | Gets the list of elements contained in the DictionaryBase instance.
InnerHashtable (inherited from DictionaryBase) | Gets the list of elements contained in the DictionaryBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear |
OnClearComplete (inherited from DictionaryBase) | Performs additional custom processes after clearing the contents of the DictionaryBase instance.
OnGet (inherited from DictionaryBase) | Gets the element with the specified key and value in the DictionaryBase instance.
OnInsert | Performs additional custom processes before inserting a new element into the DictionaryBase instance.
OnInsertComplete (inherited from DictionaryBase) | Performs additional custom processes after inserting a new element into the DictionaryBase instance.
OnRemove | Performs additional custom processes before removing an element from the DictionaryBase instance.
OnRemoveComplete (inherited from DictionaryBase) | Performs additional custom processes after removing an element from the DictionaryBase instance.
OnSet |
OnSetComplete (inherited from DictionaryBase) | Performs additional custom processes after setting a value in the DictionaryBase instance.
OnValidate | Performs additional custom processes when validating the element with the specified key and value.

See Also

PropertyDictionary Class | NAnt.Core Namespace


PropertyDictionary Constructor

Initializes a new instance of the PropertyDictionary class holding properties for the given Project instance.

[Visual Basic]
Public Sub New( _
ByVal project As Project _
)
[C#]
public PropertyDictionary(
Project project
);

Parameters

project
The project for which the dictionary will hold properties.

See Also

PropertyDictionary Class | NAnt.Core Namespace


PropertyDictionary Properties

The properties of the PropertyDictionary class are listed below. For a complete list of PropertyDictionary class members, see the PropertyDictionary Members topic.

Public Instance Properties

Count (inherited from DictionaryBase) | Gets the number of elements contained in the DictionaryBase instance.
Item | Indexer property.
Project | Gets the project for which the dictionary holds properties.

Protected Instance Properties

Dictionary (inherited from DictionaryBase) | Gets the list of elements contained in the DictionaryBase instance.
InnerHashtable (inherited from DictionaryBase) | Gets the list of elements contained in the DictionaryBase instance.

See Also

PropertyDictionary Class | NAnt.Core Namespace


Item Property

NAnt SDK Documentation - v0.91

PropertyDictionary.Item Property

Indexer property.

[Visual Basic]
Overridable Public Default Property Item( _
ByVal name As String _
) As String
[C#]
public virtual string this[
string name
] {get; set;}

See Also

PropertyDictionary Class | NAnt.Core Namespace


Project Property

NAnt SDK Documentation - v0.91

PropertyDictionary.Project Property

Gets the project for which the dictionary holds properties.

[Visual Basic]
Public ReadOnly Property Project As Project
[C#]
public Project Project {get;}

Property Value

The project for which the dictionary holds properties.

See Also

PropertyDictionary Class | NAnt.Core Namespace


PropertyDictionary Methods

The methods of the PropertyDictionary class are listed below. For a complete list of PropertyDictionary class members, see the PropertyDictionary Members topic.

Public Instance Methods

Add | Adds a property to the collection.
AddReadOnly | Adds a property that cannot be changed.
Clear (inherited from DictionaryBase) | Clears the contents of the DictionaryBase instance.
Contains | Determines whether a property already exists.
CopyTo (inherited from DictionaryBase) | Copies the DictionaryBase elements to a one-dimensional Array at the specified index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandProperties | Expands a String from known properties.
GetEnumerator (inherited from DictionaryBase) | Returns an IDictionaryEnumerator that iterates through the DictionaryBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Inherit | Inherits properties from an existing property dictionary Instance.
IsDynamicProperty | Determines whether the specified property is listed as dynamic.
IsReadOnlyProperty | Determines whether the specified property is listed as read-only.
MarkDynamic | Marks a property as a property of which the value is expanded at execution time.
Remove | Removes the property with the specified name.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear |
OnClearComplete (inherited from DictionaryBase) | Performs additional custom processes after clearing the contents of the DictionaryBase instance.
OnGet (inherited from DictionaryBase) | Gets the element with the specified key and value in the DictionaryBase instance.
OnInsert | Performs additional custom processes before inserting a new element into the DictionaryBase instance.
OnInsertComplete (inherited from DictionaryBase) | Performs additional custom processes after inserting a new element into the DictionaryBase instance.
OnRemove | Performs additional custom processes before removing an element from the DictionaryBase instance.
OnRemoveComplete (inherited from DictionaryBase) | Performs additional custom processes after removing an element from the DictionaryBase instance.
OnSet |
OnSetComplete (inherited from DictionaryBase) | Performs additional custom processes after setting a value in the DictionaryBase instance.
OnValidate | Performs additional custom processes when validating the element with the specified key and value.

See Also

PropertyDictionary Class | NAnt.Core Namespace


PropertyDictionary.Add Method

Adds a property to the collection.

[Visual Basic]
Overridable Public Sub Add( _
ByVal name As String, _
ByVal value As String _
)
[C#]
public virtual void Add(
string name,
string value
);

Parameters

name
The name of the property.
value
The value to assign to the property.

See Also

PropertyDictionary Class | NAnt.Core Namespace


PropertyDictionary.AddReadOnly Method

Adds a property that cannot be changed.

[Visual Basic]
Overridable Public Sub AddReadOnly( _
ByVal name As String, _
ByVal value As String _
)
[C#]
public virtual void AddReadOnly(
string name,
string value
);

Parameters

name
The name of the property.
value
The value to assign to the property.

Remarks

Properties added with this method can never be changed. Note that they are removed if the Clear method is called.

See Also

PropertyDictionary Class | NAnt.Core Namespace


PropertyDictionary.Contains Method

Determines whether a property already exists.

[Visual Basic]
Public Function Contains( _
ByVal name As String _
) As Boolean
[C#]
public bool Contains(
string name
);

Parameters

name
The name of the property to check.

Return Value

true if the specified property already exists; otherwise, false.

See Also

PropertyDictionary Class | NAnt.Core Namespace


PropertyDictionary.ExpandProperties Method

Expands a String from known properties.

[Visual Basic]
Public Function ExpandProperties( _
ByVal input As String, _
ByVal location As Location _
) As String
[C#]
public string ExpandProperties(
string input,
Location location
);

Parameters

input
The replacement tokens.
location
The Location to pass through for any exceptions.

Return Value

The expanded and replaced string.

See Also

PropertyDictionary Class | NAnt.Core Namespace


PropertyDictionary.Inherit Method

Inherits properties from an existing property dictionary Instance.

[Visual Basic]
Overridable Public Sub Inherit( _
ByVal source As PropertyDictionary, _
ByVal excludes As StringCollection _
)
[C#]
public virtual void Inherit(
PropertyDictionary source,
StringCollection excludes
);

Parameters

source
Property list to inherit.
excludes
The list of properties to exclude during inheritance.

See Also

PropertyDictionary Class | NAnt.Core Namespace


PropertyDictionary.IsDynamicProperty Method

Determines whether the specified property is listed as dynamic.

[Visual Basic]
Overridable Public Function IsDynamicProperty( _
ByVal name As String _
) As Boolean
[C#]
public virtual bool IsDynamicProperty(
string name
);

Parameters

name
The name of the property to check.

Return Value

true if the property is listed as dynamic; otherwise, false.

See Also

PropertyDictionary Class | NAnt.Core Namespace


PropertyDictionary.IsReadOnlyProperty Method

Determines whether the specified property is listed as read-only.

[Visual Basic]
Overridable Public Function IsReadOnlyProperty( _
ByVal name As String _
) As Boolean
[C#]
public virtual bool IsReadOnlyProperty(
string name
);

Parameters

name
The name of the property to check.

Return Value

true if the property is listed as read-only; otherwise, false.

See Also

PropertyDictionary Class | NAnt.Core Namespace


PropertyDictionary.MarkDynamic Method

Marks a property as a property of which the value is expanded at execution time.

[Visual Basic]
Overridable Public Sub MarkDynamic( _
ByVal name As String _
)
[C#]
public virtual void MarkDynamic(
string name
);

Parameters

name
The name of the property to mark as dynamic.

See Also

PropertyDictionary Class | NAnt.Core Namespace


PropertyDictionary.OnClear Method

[Visual Basic]
Overrides Protected Sub OnClear()
[C#]
protected override void OnClear();

See Also

PropertyDictionary Class | NAnt.Core Namespace


PropertyDictionary.OnInsert Method

Performs additional custom processes before inserting a new element into the DictionaryBase instance.

[Visual Basic]
Overrides Protected Sub OnInsert( _
ByVal key As Object, _
ByVal value As Object _
)
[C#]
protected override void OnInsert(
object key,
object value
);

Parameters

key
The key of the element to insert.
value
The value of the element to insert.

See Also

PropertyDictionary Class | NAnt.Core Namespace


PropertyDictionary.OnRemove Method

Performs additional custom processes before removing an element from the DictionaryBase instance.

[Visual Basic]
Overrides Protected Sub OnRemove( _
ByVal key As Object, _
ByVal value As Object _
)
[C#]
protected override void OnRemove(
object key,
object value
);

Parameters

key
The key of the element to remove.
value
The value of the element to remove.

See Also

PropertyDictionary Class | NAnt.Core Namespace


PropertyDictionary.OnSet Method

[Visual Basic]
Overrides Protected Sub OnSet( _
ByVal key As Object, _
ByVal oldValue As Object, _
ByVal newValue As Object _
)
[C#]
protected override void OnSet(
object key,
object oldValue,
object newValue
);

See Also

PropertyDictionary Class | NAnt.Core Namespace


PropertyDictionary.OnValidate Method

Performs additional custom processes when validating the element with the specified key and value.

[Visual Basic]
Overrides Protected Sub OnValidate( _
ByVal key As Object, _
ByVal value As Object _
)
[C#]
protected override void OnValidate(
object key,
object value
);

Parameters

key
The key of the element to validate.
value
The value of the element to validate.

See Also

PropertyDictionary Class | NAnt.Core Namespace


PropertyDictionary.Remove Method

Removes the property with the specified name.

[Visual Basic]
Public Sub Remove( _
ByVal name As String _
)
[C#]
public void Remove(
string name
);

Parameters

name
The name of the property to remove.

See Also

PropertyDictionary Class | NAnt.Core Namespace


Target Class

For a list of all members of this type, see Target Members.

System.Object
NAnt.Core.Element
NAnt.Core.Target

[Visual Basic]
<Serializable, _ Serializable>
NotInheritable Public Class Target
Inherits Element
Implements ICloneable
[C#]
[Serializable]
[Serializable]
public sealed class Target : Element, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

Target Members | NAnt.Core Namespace


Target Members

Target overview

Public Instance Constructors

Target Constructor Initializes a new instance of the Target class.

Public Instance Properties

Dependencies | A collection of target names that must be executed before this target.
DependsListString | Space separated list of targets that this target depends on.
Description | The description of the target.
Executed | This indicates whether the target has already executed.
IfCondition | If true then the target will be executed; otherwise, skipped. The default is true.
IfDefined | Gets a value indicating whether the target should be executed.
Name | The name of the target.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessCondition | Opposite of IfDefined. If false then the target will be executed; otherwise, skipped. The default is false.
UnlessDefined | Gets a value indicating whether the target should NOT be executed.

Public Instance Methods

Clone | Creates a shallow copy of the Target.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Executes dependent targets first, then the target.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Target Class | NAnt.Core Namespace


Target Constructor

Initializes a new instance of the Target class.

[Visual Basic]
Public Sub New()
[C#]
public Target();

See Also

Target Class | NAnt.Core Namespace


Target Properties

The properties of the Target class are listed below. For a complete list of Target class members, see the Target Members topic.

Public Instance Properties

Dependencies | A collection of target names that must be executed before this target.
DependsListString | Space separated list of targets that this target depends on.
Description | The description of the target.
Executed | This indicates whether the target has already executed.
IfCondition | If true then the target will be executed; otherwise, skipped. The default is true.
IfDefined | Gets a value indicating whether the target should be executed.
Name | The name of the target.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessCondition | Opposite of IfDefined. If false then the target will be executed; otherwise, skipped. The default is false.
UnlessDefined | Gets a value indicating whether the target should NOT be executed.

See Also

Target Class | NAnt.Core Namespace


Dependencies Property

NAnt SDK Documentation - v0.91

Target.Dependencies Property

A collection of target names that must be executed before this target.

[Visual Basic]
Public ReadOnly Property Dependencies As StringCollection
[C#]
public System.Collections.Specialized.StringCollection Dependencies {get;}

See Also

Target Class | NAnt.Core Namespace


DependsListString Property

NAnt SDK Documentation - v0.91

Target.DependsListString Property

Space separated list of targets that this target depends on.

[Visual Basic]
<TaskAttribute(Required:=False, ExpandProperties:=True, Name:="depends", ProcessXml:=True)>
Public WriteOnly Property DependsListString As String
[C#]
[TaskAttribute(Required=False, ExpandProperties=True, Name="depends", ProcessXml=True)]
public string DependsListString {set;}

See Also

Target Class | NAnt.Core Namespace


Description Property

NAnt SDK Documentation - v0.91

Target.Description Property

The description of the target.

[Visual Basic]
<TaskAttribute(Required:=False, ExpandProperties:=True, Name:="description", ProcessXml:=True)>
Public Property Description As String
[C#]
[TaskAttribute(Required=False, ExpandProperties=True, Name="description", ProcessXml=True)]
public string Description {get; set;}

See Also

Target Class | NAnt.Core Namespace


Executed Property

NAnt SDK Documentation - v0.91

Target.Executed Property

This indicates whether the target has already executed.

[Visual Basic]
Public ReadOnly Property Executed As Boolean
[C#]
public bool Executed {get;}

See Also

Target Class | NAnt.Core Namespace


IfCondition Property

NAnt SDK Documentation - v0.91

Target.IfCondition Property

If true then the target will be executed; otherwise, skipped. The default is true.

[Visual Basic]
<TaskAttribute(Required:=False, ExpandProperties:=False, Name:="if", ProcessXml:=True)>
Public Property IfCondition As String
[C#]
[TaskAttribute(Required=False, ExpandProperties=False, Name="if", ProcessXml=True)]
public string IfCondition {get; set;}

See Also

Target Class | NAnt.Core Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

Target.IfDefined Property

Gets a value indicating whether the target should be executed.

[Visual Basic]
Public ReadOnly Property IfDefined As Boolean
[C#]
public bool IfDefined {get;}

Property Value

true if the target should be executed; otherwise, false.

See Also

Target Class | NAnt.Core Namespace


Name Property

NAnt SDK Documentation - v0.91

Target.Name Property

The name of the target.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="name", Required:=True, ExpandProperties:=False, ProcessXml:=True)>
Public Property Name As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="name", Required=True, ExpandProperties=False, ProcessXml=True)]
new public string Name {get; set;}

Remarks

Hides Name to have Target return the name of target, not the name of XML element - which would always be target.

Note: Properties are not allowed in the name.

See Also

Target Class | NAnt.Core Namespace


UnlessCondition Property

NAnt SDK Documentation - v0.91

Target.UnlessCondition Property

Opposite of IfDefined. If false then the target will be executed; otherwise, skipped. The default is false.

[Visual Basic]
<TaskAttribute(Required:=False, ExpandProperties:=False, Name:="unless", ProcessXml:=True)>
Public Property UnlessCondition As String
[C#]
[TaskAttribute(Required=False, ExpandProperties=False, Name="unless", ProcessXml=True)]
public string UnlessCondition {get; set;}

See Also

Target Class | NAnt.Core Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

Target.UnlessDefined Property

Gets a value indicating whether the target should NOT be executed.

[Visual Basic]
Public ReadOnly Property UnlessDefined As Boolean
[C#]
public bool UnlessDefined {get;}

Property Value

true if the target should NOT be executed; otherwise, false.

See Also

Target Class | NAnt.Core Namespace


Target Methods

The methods of the Target class are listed below. For a complete list of Target class members, see the Target Members topic.

Public Instance Methods

Clone | Creates a shallow copy of the Target.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Executes dependent targets first, then the target.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Target Class | NAnt.Core Namespace


Target.Clone Method

Creates a shallow copy of the Target.

[Visual Basic]
Public Function Clone() As Target
[C#]
public Target Clone();

Return Value

A shallow copy of the Target.

See Also

Target Class | NAnt.Core Namespace


Target.Execute Method

Executes dependent targets first, then the target.

[Visual Basic]
Public Sub Execute()
[C#]
public void Execute();

See Also

Target Class | NAnt.Core Namespace


TargetCollection Class

For a list of all members of this type, see TargetCollection Members.

System.Object
System.Collections.ArrayList
NAnt.Core.TargetCollection

[Visual Basic]
<Serializable, _
 Serializable, _
 DefaultMember(MemberName:="Item"), _
 DebuggerTypeProxy(ProxyTypeName:="System.Collections.ArrayList+ArrayListDebugView, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", Target:=null, TargetTypeName:="null"), _
 DebuggerDisplay(Value:="Count = {Count}", Target:=null, TargetTypeName:="null")>
Public Class TargetCollection
Inherits ArrayList
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
[DebuggerTypeProxy(ProxyTypeName="System.Collections.ArrayList+ArrayListDebugView, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", Target=null, TargetTypeName="null")]
[DebuggerDisplay(Value="Count = {Count}", Target=null, TargetTypeName="null")]
public class TargetCollection : ArrayList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

TargetCollection Members | NAnt.Core Namespace


TargetCollection Members

TargetCollection overview

Public Instance Constructors

TargetCollection Constructor Initializes a new instance of the TargetCollection class.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread safe).
Item (inherited from ArrayList) | Gets or sets the element at the specified index.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

Public Instance Methods

Add | Overloaded.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches a range of elements in the sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the beginning of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Find | Finds a target by name.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the entire ArrayList.
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the entire ArrayList.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in the entire ArrayList using the IComparable implementation of each element.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new Object array.
ToString | Overloaded. Gets the names of the targets in the TargetCollection combined into one list separated by the given String.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TargetCollection Class | NAnt.Core Namespace


TargetCollection Constructor

Initializes a new instance of the TargetCollection class.

[Visual Basic]
Public Sub New()
[C#]
public TargetCollection();

See Also

TargetCollection Class | NAnt.Core Namespace


TargetCollection Methods

The methods of the TargetCollection class are listed below. For a complete list of TargetCollection class members, see the TargetCollection Members topic.

Public Instance Methods

Add | Overloaded.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches a range of elements in the sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the beginning of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Find | Finds a target by name.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the entire ArrayList.
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the entire ArrayList.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in the entire ArrayList using the IComparable implementation of each element.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new Object array.
ToString | Overloaded. Gets the names of the targets in the TargetCollection combined into one list separated by the given String.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TargetCollection Class | NAnt.Core Namespace


Add Method

NAnt SDK Documentation - v0.91

TargetCollection.Add Method

Overload List

public virtual int Add(Target);

public override int Add(object);

See Also

TargetCollection Class | NAnt.Core Namespace


TargetCollection.Add Method (Target)

[Visual Basic]
Overridable Overloads Public Function Add( _
ByVal t As Target _
) As Integer
[C#]
public virtual int Add(
Target t
);

See Also

TargetCollection Class | NAnt.Core Namespace | TargetCollection.Add Overload List


TargetCollection.Add Method (Object)

[Visual Basic]
Overrides Overloads Public Function Add( _
ByVal value As Object _
) As Integer _
Implements IList.Add
[C#]
public override int Add(
object value
);

Implements

IList.Add

See Also

TargetCollection Class | NAnt.Core Namespace | TargetCollection.Add Overload List


TargetCollection.Find Method

Finds a target by name.

[Visual Basic]
Public Function Find( _
ByVal targetName As String _
) As Target
[C#]
public Target Find(
string targetName
);

Parameters

targetName
The name of the target to find.

Return Value

The Target with the specified name, or a null reference (Nothing in Visual Basic) if no Target exists with the given name.

See Also

TargetCollection Class | NAnt.Core Namespace


ToString Method

NAnt SDK Documentation - v0.91

TargetCollection.ToString Method

Gets the names of the targets in the TargetCollection combined into one comma-separated list.

Overload List

Gets the names of the targets in the TargetCollection combined into one comma-separated list.

public override string ToString();

Gets the names of the targets in the TargetCollection combined into one list separated by the given String.

public string ToString(string);

See Also

TargetCollection Class | NAnt.Core Namespace


TargetCollection.ToString Method ()

Gets the names of the targets in the TargetCollection combined into one comma-separated list.

[Visual Basic]
Overrides Overloads Public Function ToString() As String
[C#]
public override string ToString();

Return Value

A String that contains a comma-separated list of the names of the targets in the TargetCollection.

See Also

TargetCollection Class | NAnt.Core Namespace | TargetCollection.ToString Overload List


TargetCollection.ToString Method (String)

Gets the names of the targets in the TargetCollection combined into one list separated by the given String.

[Visual Basic]
Overloads Public Function ToString( _
ByVal separator As String _
) As String
[C#]
public string ToString(
string separator
);

Return Value

A String that contains a list of the names of the targets in the TargetCollection, separated by the specified separator.

See Also

TargetCollection Class | NAnt.Core Namespace | TargetCollection.ToString Overload List


Task Class

Provides the abstract base class for tasks.

For a list of all members of this type, see Task Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
Derived types

[Visual Basic]
<Serializable, _ Serializable>
MustInherit Public Class Task
Inherits Element
[C#]
[Serializable]
[Serializable]
public abstract class Task : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

A task is a piece of code that can be executed.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

Task Members | NAnt.Core Namespace


Task Members

Task overview

Public Instance Properties

FailOnError | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix | Obsolete. The prefix used when sending messages to the log.
Name | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor | Determines whether build output is enabled for the given Level.
Log | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Task Constructor Initializes a new instance of the Task class.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Executes the task.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Task Class | NAnt.Core Namespace


Task Constructor

Initializes a new instance of the Task class.

[Visual Basic]
Protected Sub New()
[C#]
protected Task();

See Also

Task Class | NAnt.Core Namespace


Task Properties

The properties of the Task class are listed below. For a complete list of Task class members, see the Task Members topic.

Public Instance Properties

FailOnError | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix | Obsolete. The prefix used when sending messages to the log.
Name | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

Task Class | NAnt.Core Namespace


FailOnError Property

NAnt SDK Documentation - v0.91

Task.FailOnError Property

Determines if task failure stops the build, or is just reported. The default is true.

[Visual Basic]
<TaskAttribute(Name:="failonerror", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property FailOnError As Boolean
[C#]
[TaskAttribute(Name="failonerror", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool FailOnError {get; set;}

See Also

Task Class | NAnt.Core Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

Task.IfDefined Property

If true then the task will be executed; otherwise, skipped. The default is true.

[Visual Basic]
<TaskAttribute(Name:="if", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property IfDefined As Boolean
[C#]
[TaskAttribute(Name="if", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool IfDefined {get; set;}

See Also

Task Class | NAnt.Core Namespace


LogPrefix Property

NAnt SDK Documentation - v0.91

Task.LogPrefix Property

NOTE: This property is now obsolete.

Will be removed soon

The prefix used when sending messages to the log.

[Visual Basic]
<Obsolete(Message:="Will be removed soon", IsError:=False)>
Public ReadOnly Property LogPrefix As String
[C#]
[Obsolete(Message="Will be removed soon", IsError=False)]
public string LogPrefix {get;}

See Also

Task Class | NAnt.Core Namespace


Name Property

NAnt SDK Documentation - v0.91

Task.Name Property

The name of the task.

[Visual Basic]
Overrides Public ReadOnly Property Name As String
[C#]
public override string Name {get;}

See Also

Task Class | NAnt.Core Namespace


Threshold Property

NAnt SDK Documentation - v0.91

Task.Threshold Property

Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.

[Visual Basic]
Public Property Threshold As Level
[C#]
public Level Threshold {get; set;}

Property Value

The log threshold level for this Task.

Remarks

When the threshold of a Task is higher than the threshold of the Project, then all messages will still be delivered to the build listeners.

See Also

Task Class | NAnt.Core Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

Task.UnlessDefined Property

Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="unless", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property UnlessDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="unless", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool UnlessDefined {get; set;}

See Also

Task Class | NAnt.Core Namespace


Verbose Property

NAnt SDK Documentation - v0.91

Task.Verbose Property

Determines whether the task should report detailed build log messages. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="verbose", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property Verbose As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="verbose", Required=False, ExpandProperties=True, ProcessXml=True)]
public virtual bool Verbose {get; set;}

See Also

Task Class | NAnt.Core Namespace


Task Methods

The methods of the Task class are listed below. For a complete list of Task class members, see the Task Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor | Determines whether build output is enabled for the given Level.
Log | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Executes the task.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Task Class | NAnt.Core Namespace


Task.Execute Method

Executes the task unless it is skipped.

[Visual Basic]
Public Sub Execute()
[C#]
public void Execute();

See Also

Task Class | NAnt.Core Namespace


Task.ExecuteTask Method

Executes the task.

[Visual Basic]
MustOverride Protected Sub ExecuteTask()
[C#]
protected abstract void ExecuteTask();

See Also

Task Class | NAnt.Core Namespace


GetAttributeConfigurationNode Method

NAnt SDK Documentation - v0.91

Task.GetAttributeConfigurationNode Method

Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.

Overload List

Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.

protected override XmlNode GetAttributeConfigurationNode(FrameworkInfo,string);

Inherited from Element.

protected XmlNode GetAttributeConfigurationNode(XmlNode,FrameworkInfo,string);

See Also

Task Class | NAnt.Core Namespace


Task.GetAttributeConfigurationNode Method (FrameworkInfo, String)

Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.

[Visual Basic]
Overrides Overloads Protected Function GetAttributeConfigurationNode( _
ByVal framework As FrameworkInfo, _
ByVal attributeName As String _
) As XmlNode
[C#]
protected override XmlNode GetAttributeConfigurationNode(
FrameworkInfo framework,
string attributeName
);

Parameters

framework
The framework to use to obtain framework specific information, or a null reference (Nothing in Visual Basic) if no framework specific information should be used.
attributeName
The name of attribute for which the XML configuration node should be located.

Return Value

The XML configuration node for the specified attribute, or a null reference (Nothing in Visual Basic) if no corresponding XML node could be located.

Remarks

If there's a valid current framework, the configuration section for that framework will first be searched. If no corresponding configuration node can be located in that section, the framework-neutral section of the project configuration node will be searched.

See Also

Task Class | NAnt.Core Namespace | Task.GetAttributeConfigurationNode Overload List


Initialize Method

NAnt SDK Documentation - v0.91

Task.Initialize Method

Initializes the task.

Overload List

Initializes the task.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

Task Class | NAnt.Core Namespace


Task.Initialize Method ()

Initializes the task.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

Task Class | NAnt.Core Namespace | Task.Initialize Overload List


Task.InitializeTask Method

NOTE: This method is now obsolete.

Deprecated. Use Initialize() instead

Initializes the task.

[Visual Basic]
<Obsolete(Message:="Deprecated. Use Initialize() instead", IsError:=False)>
Overridable Protected Sub InitializeTask( _
ByVal taskNode As XmlNode _
)
[C#]
[Obsolete(Message="Deprecated. Use Initialize() instead", IsError=False)]
protected virtual void InitializeTask(
XmlNode taskNode
);

See Also

Task Class | NAnt.Core Namespace


Task.InitializeTaskConfiguration Method

Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.

[Visual Basic]
Public Sub InitializeTaskConfiguration()
[C#]
public void InitializeTaskConfiguration();

Remarks

TO-DO : Remove this temporary hack when a permanent solution is available for loading the default values from the configuration file if a build element is constructed from code.

See Also

Task Class | NAnt.Core Namespace


Task.IsLogEnabledFor Method

Determines whether build output is enabled for the given Level.

[Visual Basic]
Public Function IsLogEnabledFor( _
ByVal messageLevel As Level _
) As Boolean
[C#]
public bool IsLogEnabledFor(
Level messageLevel
);

Parameters

messageLevel
The Level to check.

Return Value

true if messages with the given Level should be passed on to the logging infrastructure; otherwise, false.

Remarks

The threshold of the project is not taken into account to determine whether a message should be passed to the logging infrastructure, as build listeners might be interested in receiving all messages.

See Also

Task Class | NAnt.Core Namespace


Log Method

NAnt SDK Documentation - v0.91

Task.Log Method

Logs a message with the given priority.

Overload List

Logs a message with the given priority.

public override void Log(Level,string);

Logs a formatted message with the given priority.

public override void Log(Level,string,params object[]);

See Also

Task Class | NAnt.Core Namespace


Task.Log Method (Level, String)

Logs a message with the given priority.

[Visual Basic]
Overrides Overloads Public Sub Log( _
ByVal messageLevel As Level, _
ByVal message As String _
)
[C#]
public override void Log(
Level messageLevel,
string message
);

Parameters

messageLevel
The message priority at which the specified message is to be logged.
message
The message to be logged.

Remarks

The actual logging is delegated to the project.

If the Verbose attribute is set on the task and a message is logged with level Verbose, the priority of the message will be increased to Info when the threshold of the build log is Info.

This will allow individual tasks to run in verbose mode while the build log itself is still configured with threshold Info.

The threshold of the project is not taken into account to determine whether a message should be passed to the logging infrastructure, as build listeners might be interested in receiving all messages.

See Also

Task Class | NAnt.Core Namespace | Task.Log Overload List


Task.Log Method (Level, String, Object[])

Logs a formatted message with the given priority.

[Visual Basic]
Overrides Overloads Public Sub Log( _
ByVal messageLevel As Level, _
ByVal message As String, _
ParamArray args As Object() _
)
[C#]
public override void Log(
Level messageLevel,
string message,
params object[] args
);

Parameters

messageLevel
The message priority at which the specified message is to be logged.
message
The message to log, containing zero or more format items.
args
An Object array containing zero or more objects to format.

Remarks

The actual logging is delegated to the project.

If the Verbose attribute is set on the task and a message is logged with level Verbose, the priority of the message will be increased to Info. when the threshold of the build log is Info.

This will allow individual tasks to run in verbose mode while the build log itself is still configured with threshold Info.

See Also

Task Class | NAnt.Core Namespace | Task.Log Overload List


TaskBuilder Class

For a list of all members of this type, see TaskBuilder Members.

System.Object
NAnt.Core.Extensibility.ExtensionBuilder
NAnt.Core.TaskBuilder

[Visual Basic]
Public Class TaskBuilder
Inherits ExtensionBuilder
[C#]
public class TaskBuilder : ExtensionBuilder

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

TaskBuilder Members | NAnt.Core Namespace


TaskBuilder Members

TaskBuilder overview

Public Instance Constructors

TaskBuilder Constructor Creates a new instance of the TaskBuilder class for the specified Task class in the specified Assembly.

Public Instance Properties

ClassName | Gets the name of the Task class that can be created using this TaskBuilder.
TaskName | Gets the name of the task which the TaskBuilder can create.

Public Instance Methods

CreateTask |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Properties

Assembly (inherited from ExtensionBuilder) Gets the Assembly from which the extension will be created.

See Also

TaskBuilder Class | NAnt.Core Namespace


TaskBuilder Constructor

Creates a new instance of the TaskBuilder class for the specified Task class in the specified Assembly.

[Visual Basic]
Overloads Public Sub New( _
ByVal assembly As Assembly, _
ByVal className As String _
)
[C#]
public TaskBuilder(
Assembly assembly,
string className
);

Parameters

assembly
The Assembly containing the Task.
className
The class representing the Task.

Remarks

An ExtensionAssembly for the specified Assembly is cached for future use.

See Also

TaskBuilder Class | NAnt.Core Namespace


TaskBuilder Properties

The properties of the TaskBuilder class are listed below. For a complete list of TaskBuilder class members, see the TaskBuilder Members topic.

Public Instance Properties

ClassName | Gets the name of the Task class that can be created using this TaskBuilder.
TaskName | Gets the name of the task which the TaskBuilder can create.

Protected Internal Instance Properties

Assembly (inherited from ExtensionBuilder) Gets the Assembly from which the extension will be created.

See Also

TaskBuilder Class | NAnt.Core Namespace


ClassName Property

NAnt SDK Documentation - v0.91

TaskBuilder.ClassName Property

Gets the name of the Task class that can be created using this TaskBuilder.

[Visual Basic]
Public ReadOnly Property ClassName As String
[C#]
public string ClassName {get;}

Property Value

The name of the Task class that can be created using this TaskBuilder.

See Also

TaskBuilder Class | NAnt.Core Namespace


TaskName Property

NAnt SDK Documentation - v0.91

TaskBuilder.TaskName Property

Gets the name of the task which the TaskBuilder can create.

[Visual Basic]
Public ReadOnly Property TaskName As String
[C#]
public string TaskName {get;}

Property Value

The name of the task which the TaskBuilder can create.

See Also

TaskBuilder Class | NAnt.Core Namespace


TaskBuilder Methods

The methods of the TaskBuilder class are listed below. For a complete list of TaskBuilder class members, see the TaskBuilder Members topic.

Public Instance Methods

CreateTask |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaskBuilder Class | NAnt.Core Namespace


TaskBuilder.CreateTask Method

[Visual Basic]
Public Function CreateTask() As Task
[C#]
public Task CreateTask();

See Also

TaskBuilder Class | NAnt.Core Namespace


TaskBuilderCollection Class

Contains a strongly typed collection of TaskBuilder objects.

For a list of all members of this type, see TaskBuilderCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.Core.TaskBuilderCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class TaskBuilderCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class TaskBuilderCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

TaskBuilderCollection Members | NAnt.Core Namespace


TaskBuilderCollection Members

TaskBuilderCollection overview

Public Instance Constructors

TaskBuilderCollection Overloaded. Initializes a new instance of the TaskBuilderCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a TaskBuilder to the end of the collection.
AddRange | Overloaded. Adds the elements of a TaskBuilder array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a TaskBuilder is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified TaskBuilder object in the collection.
Insert | Inserts a TaskBuilder into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

TaskBuilderCollection Class | NAnt.Core Namespace


TaskBuilderCollection Constructor

Initializes a new instance of the TaskBuilderCollection class.

Overload List

Initializes a new instance of the TaskBuilderCollection class.

public TaskBuilderCollection();

Initializes a new instance of the TaskBuilderCollection class with the specified array of TaskBuilder instances.

public TaskBuilderCollection(TaskBuilder[]);

Initializes a new instance of the TaskBuilderCollection class with the specified TaskBuilderCollection instance.

public TaskBuilderCollection(TaskBuilderCollection);

See Also

TaskBuilderCollection Class | NAnt.Core Namespace


TaskBuilderCollection Constructor ()

Initializes a new instance of the TaskBuilderCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public TaskBuilderCollection();

See Also

TaskBuilderCollection Class | NAnt.Core Namespace | TaskBuilderCollection Constructor Overload List


TaskBuilderCollection Constructor (TaskBuilderCollection)

Initializes a new instance of the TaskBuilderCollection class with the specified TaskBuilderCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As TaskBuilderCollection _
)
[C#]
public TaskBuilderCollection(
TaskBuilderCollection value
);

See Also

TaskBuilderCollection Class | NAnt.Core Namespace | TaskBuilderCollection Constructor Overload List


TaskBuilderCollection Constructor (TaskBuilder[])

Initializes a new instance of the TaskBuilderCollection class with the specified array of TaskBuilder instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As TaskBuilder() _
)
[C#]
public TaskBuilderCollection(
TaskBuilder[] value
);

See Also

TaskBuilderCollection Class | NAnt.Core Namespace | TaskBuilderCollection Constructor Overload List


TaskBuilderCollection Properties

The properties of the TaskBuilderCollection class are listed below. For a complete list of TaskBuilderCollection class members, see the TaskBuilderCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

TaskBuilderCollection Class | NAnt.Core Namespace


Item Property

NAnt SDK Documentation - v0.91

TaskBuilderCollection.Item Property

Gets or sets the element at the specified index.

Overload List

Gets or sets the element at the specified index.

public TaskBuilder this[int] {get; set;}

Gets the TaskBuilder for the specified task.

public TaskBuilder this[string] {get;}

See Also

TaskBuilderCollection Class | NAnt.Core Namespace


Item Property (Int32)

NAnt SDK Documentation - v0.91

TaskBuilderCollection.Item Property (Int32)

Gets or sets the element at the specified index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As TaskBuilder
[C#]
public TaskBuilder this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

TaskBuilderCollection Class | NAnt.Core Namespace | TaskBuilderCollection.Item Overload List


Item Property (String)

NAnt SDK Documentation - v0.91

TaskBuilderCollection.Item Property (String)

Gets the TaskBuilder for the specified task.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal taskName As String _
) As TaskBuilder
[C#]
public TaskBuilder this[
string taskName
] {get;}

Parameters

taskName
The name of task for which the TaskBuilder should be located in the collection.

See Also

TaskBuilderCollection Class | NAnt.Core Namespace | TaskBuilderCollection.Item Overload List


TaskBuilderCollection Methods

The methods of the TaskBuilderCollection class are listed below. For a complete list of TaskBuilderCollection class members, see the TaskBuilderCollection Members topic.

Public Instance Methods

Add | Adds a TaskBuilder to the end of the collection.
AddRange | Overloaded. Adds the elements of a TaskBuilder array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a TaskBuilder is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified TaskBuilder object in the collection.
Insert | Inserts a TaskBuilder into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

TaskBuilderCollection Class | NAnt.Core Namespace


TaskBuilderCollection.Add Method

Adds a TaskBuilder to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As TaskBuilder _
) As Integer
[C#]
public int Add(
TaskBuilder item
);

Parameters

item
The TaskBuilder to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

TaskBuilderCollection Class | NAnt.Core Namespace


AddRange Method

NAnt SDK Documentation - v0.91

TaskBuilderCollection.AddRange Method

Adds the elements of a TaskBuilder array to the end of the collection.

Overload List

Adds the elements of a TaskBuilder array to the end of the collection.

public void AddRange(TaskBuilder[]);

Adds the elements of a TaskBuilderCollection to the end of the collection.

public void AddRange(TaskBuilderCollection);

See Also

TaskBuilderCollection Class | NAnt.Core Namespace


TaskBuilderCollection.AddRange Method (TaskBuilder[])

Adds the elements of a TaskBuilder array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As TaskBuilder() _
)
[C#]
public void AddRange(
TaskBuilder[] items
);

Parameters

items
The array of TaskBuilder elements to be added to the end of the collection.

See Also

TaskBuilderCollection Class | NAnt.Core Namespace | TaskBuilderCollection.AddRange Overload List


TaskBuilderCollection.AddRange Method (TaskBuilderCollection)

Adds the elements of a TaskBuilderCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As TaskBuilderCollection _
)
[C#]
public void AddRange(
TaskBuilderCollection items
);

Parameters

items
The TaskBuilderCollection to be added to the end of the collection.

See Also

TaskBuilderCollection Class | NAnt.Core Namespace | TaskBuilderCollection.AddRange Overload List


Contains Method

NAnt SDK Documentation - v0.91

TaskBuilderCollection.Contains Method

Determines whether a TaskBuilder is in the collection.

Overload List

Determines whether a TaskBuilder is in the collection.

public bool Contains(TaskBuilder);

Determines whether a TaskBuilder for the specified task is in the collection.

public bool Contains(string);

See Also

TaskBuilderCollection Class | NAnt.Core Namespace


TaskBuilderCollection.Contains Method (TaskBuilder)

Determines whether a TaskBuilder is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal item As TaskBuilder _
) As Boolean
[C#]
public bool Contains(
TaskBuilder item
);

Parameters

item
The TaskBuilder to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

TaskBuilderCollection Class | NAnt.Core Namespace | TaskBuilderCollection.Contains Overload List


TaskBuilderCollection.Contains Method (String)

Determines whether a TaskBuilder for the specified task is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal taskName As String _
) As Boolean
[C#]
public bool Contains(
string taskName
);

Parameters

taskName
The name of task for which the TaskBuilder should be located in the collection.

Return Value

true if a TaskBuilder for the specified task is found in the collection; otherwise, false.

See Also

TaskBuilderCollection Class | NAnt.Core Namespace | TaskBuilderCollection.Contains Overload List


TaskBuilderCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As TaskBuilder(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
TaskBuilder[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

TaskBuilderCollection Class | NAnt.Core Namespace


TaskBuilderCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As TaskBuilderEnumerator
[C#]
new public TaskBuilderEnumerator GetEnumerator();

Return Value

A TaskBuilderEnumerator for the entire collection.

See Also

TaskBuilderCollection Class | NAnt.Core Namespace


TaskBuilderCollection.IndexOf Method

Retrieves the index of a specified TaskBuilder object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As TaskBuilder _
) As Integer
[C#]
public int IndexOf(
TaskBuilder item
);

Parameters

item
The TaskBuilder object for which the index is returned.

Return Value

The index of the specified TaskBuilder. If the TaskBuilder is not currently a member of the collection, it returns -1.

See Also

TaskBuilderCollection Class | NAnt.Core Namespace


TaskBuilderCollection.Insert Method

Inserts a TaskBuilder into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As TaskBuilder _
)
[C#]
public void Insert(
int index,
TaskBuilder item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The TaskBuilder to insert.

See Also

TaskBuilderCollection Class | NAnt.Core Namespace


TaskBuilderCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As TaskBuilder _
)
[C#]
public void Remove(
TaskBuilder item
);

Parameters

item
The TaskBuilder to remove from the collection.

See Also

TaskBuilderCollection Class | NAnt.Core Namespace


TaskBuilderEnumerator Class

Enumerates the TaskBuilder elements of a TaskBuilderCollection.

For a list of all members of this type, see TaskBuilderEnumerator Members.

System.Object
NAnt.Core.TaskBuilderEnumerator

[Visual Basic]
Public Class TaskBuilderEnumerator
Implements IEnumerator
[C#]
public class TaskBuilderEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

TaskBuilderEnumerator Members | NAnt.Core Namespace


TaskBuilderEnumerator Members

TaskBuilderEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaskBuilderEnumerator Class | NAnt.Core Namespace


TaskBuilderEnumerator Properties

The properties of the TaskBuilderEnumerator class are listed below. For a complete list of TaskBuilderEnumerator class members, see the TaskBuilderEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

TaskBuilderEnumerator Class | NAnt.Core Namespace


Current Property

NAnt SDK Documentation - v0.91

TaskBuilderEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As TaskBuilder
[C#]
public TaskBuilder Current {get;}

See Also

TaskBuilderEnumerator Class | NAnt.Core Namespace


TaskBuilderEnumerator Methods

The methods of the TaskBuilderEnumerator class are listed below. For a complete list of TaskBuilderEnumerator class members, see the TaskBuilderEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaskBuilderEnumerator Class | NAnt.Core Namespace


TaskBuilderEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

TaskBuilderEnumerator Class | NAnt.Core Namespace


TaskBuilderEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

TaskBuilderEnumerator Class | NAnt.Core Namespace


TaskContainer Class

Executes embedded tasks in the order in which they are defined.

For a list of all members of this type, see TaskContainer Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.TaskContainer
NAnt.Core.Tasks.IfTask
NAnt.Core.Tasks.LoopTask

[Visual Basic]
Public Class TaskContainer
Inherits Task
[C#]
public class TaskContainer : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

TaskContainer Members | NAnt.Core Namespace


TaskContainer Members

TaskContainer overview

Public Instance Constructors

TaskContainer Constructor Initializes a new instance of the TaskContainer class.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing | Gets a value indicating whether the element is performing additional processing using the XmlNode that was use to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

AddPrivateXmlElementName |
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
CreateChildDataTypeBase |
CreateChildTask |
ExecuteChildTasks | Creates and executes the embedded (child XML nodes) elements.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Automatically exclude build elements that are defined on the task from things that get executed, as they are evaluated normally during XML task initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
IsPrivateXmlElement |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaskContainer Class | NAnt.Core Namespace


TaskContainer Constructor

Initializes a new instance of the TaskContainer class.

[Visual Basic]
Public Sub New()
[C#]
public TaskContainer();

See Also

TaskContainer Class | NAnt.Core Namespace


TaskContainer Properties

The properties of the TaskContainer class are listed below. For a complete list of TaskContainer class members, see the TaskContainer Members topic.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing | Gets a value indicating whether the element is performing additional processing using the XmlNode that was use to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

TaskContainer Class | NAnt.Core Namespace


CustomXmlProcessing Property

NAnt SDK Documentation - v0.91

TaskContainer.CustomXmlProcessing Property

Gets a value indicating whether the element is performing additional processing using the XmlNode that was use to initialize the element.

[Visual Basic]
Overrides Protected ReadOnly Property CustomXmlProcessing As Boolean
[C#]
protected override bool CustomXmlProcessing {get;}

Property Value

true, as a TaskContainer is responsable for creating tasks from the nested build elements.

See Also

TaskContainer Class | NAnt.Core Namespace


TaskContainer Methods

The methods of the TaskContainer class are listed below. For a complete list of TaskContainer class members, see the TaskContainer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddPrivateXmlElementName |
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
CreateChildDataTypeBase |
CreateChildTask |
ExecuteChildTasks | Creates and executes the embedded (child XML nodes) elements.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Automatically exclude build elements that are defined on the task from things that get executed, as they are evaluated normally during XML task initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
IsPrivateXmlElement |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaskContainer Class | NAnt.Core Namespace


TaskContainer.AddPrivateXmlElementName Method

[Visual Basic]
Overridable Protected Sub AddPrivateXmlElementName( _
ByVal name As String _
)
[C#]
protected virtual void AddPrivateXmlElementName(
string name
);

See Also

TaskContainer Class | NAnt.Core Namespace


TaskContainer.CreateChildDataTypeBase Method

[Visual Basic]
Overridable Protected Function CreateChildDataTypeBase( _
ByVal node As XmlNode _
) As DataTypeBase
[C#]
protected virtual DataTypeBase CreateChildDataTypeBase(
XmlNode node
);

See Also

TaskContainer Class | NAnt.Core Namespace


TaskContainer.CreateChildTask Method

[Visual Basic]
Overridable Protected Function CreateChildTask( _
ByVal node As XmlNode _
) As Task
[C#]
protected virtual Task CreateChildTask(
XmlNode node
);

See Also

TaskContainer Class | NAnt.Core Namespace


TaskContainer.ExecuteChildTasks Method

Creates and executes the embedded (child XML nodes) elements.

[Visual Basic]
Overridable Protected Sub ExecuteChildTasks()
[C#]
protected virtual void ExecuteChildTasks();

Remarks

Skips any element defined by the host Task that has a BuildElementAttribute defined.

See Also

TaskContainer Class | NAnt.Core Namespace


TaskContainer.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

TaskContainer Class | NAnt.Core Namespace


Initialize Method

NAnt SDK Documentation - v0.91

TaskContainer.Initialize Method

Automatically exclude build elements that are defined on the task from things that get executed, as they are evaluated normally during XML task initialization.

Overload List

Automatically exclude build elements that are defined on the task from things that get executed, as they are evaluated normally during XML task initialization.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

TaskContainer Class | NAnt.Core Namespace


TaskContainer.Initialize Method ()

Automatically exclude build elements that are defined on the task from things that get executed, as they are evaluated normally during XML task initialization.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

TaskContainer Class | NAnt.Core Namespace | TaskContainer.Initialize Overload List


TaskContainer.IsPrivateXmlElement Method

[Visual Basic]
Overridable Protected Function IsPrivateXmlElement( _
ByVal node As XmlNode _
) As Boolean
[C#]
protected virtual bool IsPrivateXmlElement(
XmlNode node
);

See Also

TaskContainer Class | NAnt.Core Namespace


TypeFactory Class

Comprises all of the loaded, and available, tasks. Use these static methods to register, initialize and create a task.

For a list of all members of this type, see TypeFactory Members.

System.Object
NAnt.Core.TypeFactory

[Visual Basic]
NotInheritable Public Class TypeFactory
[C#]
public sealed class TypeFactory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

TypeFactory Members | NAnt.Core Namespace


TypeFactory Members

TypeFactory overview

Public Static (Shared) Properties

DataTypeBuilders | Gets the list of loaded DataTypeBaseBuilder instances.
FilterBuilders | Gets the list of loaded FilterBuilder instances.
TaskBuilders | Gets the list of loaded TaskBuilder instances.

Public Static (Shared) Methods

CreateDataType |
CreateFilter |
CreateTask | Creates a new Task instance for the given XML and Project.
ScanAssembly | Overloaded. Scans the given assembly for tasks, types, functions and filters.
ScanDir | Scans the path for any task assemblies and adds them.

Public Instance Constructors

TypeFactory Constructor Initializes a new instance of the TypeFactory class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TypeFactory Class | NAnt.Core Namespace


TypeFactory Constructor

Initializes a new instance of the TypeFactory class.

[Visual Basic]
Public Sub New()
[C#]
public TypeFactory();

See Also

TypeFactory Class | NAnt.Core Namespace


TypeFactory Properties

The properties of the TypeFactory class are listed below. For a complete list of TypeFactory class members, see the TypeFactory Members topic.

Public Static (Shared) Properties

DataTypeBuilders | Gets the list of loaded DataTypeBaseBuilder instances.
FilterBuilders | Gets the list of loaded FilterBuilder instances.
TaskBuilders | Gets the list of loaded TaskBuilder instances.

See Also

TypeFactory Class | NAnt.Core Namespace


DataTypeBuilders Property

NAnt SDK Documentation - v0.91

TypeFactory.DataTypeBuilders Property

Gets the list of loaded DataTypeBaseBuilder instances.

[Visual Basic]
Public Shared ReadOnly Property DataTypeBuilders As DataTypeBaseBuilderCollection
[C#]
public static DataTypeBaseBuilderCollection DataTypeBuilders {get;}

Property Value

List of loaded DataTypeBaseBuilder instances.

See Also

TypeFactory Class | NAnt.Core Namespace


FilterBuilders Property

NAnt SDK Documentation - v0.91

TypeFactory.FilterBuilders Property

Gets the list of loaded FilterBuilder instances.

[Visual Basic]
Public Shared ReadOnly Property FilterBuilders As FilterBuilderCollection
[C#]
public static Filters.FilterBuilderCollection FilterBuilders {get;}

Property Value

List of loaded FilterBuilder instances.

See Also

TypeFactory Class | NAnt.Core Namespace


TaskBuilders Property

NAnt SDK Documentation - v0.91

TypeFactory.TaskBuilders Property

Gets the list of loaded TaskBuilder instances.

[Visual Basic]
Public Shared ReadOnly Property TaskBuilders As TaskBuilderCollection
[C#]
public static TaskBuilderCollection TaskBuilders {get;}

Property Value

List of loaded TaskBuilder instances.

See Also

TypeFactory Class | NAnt.Core Namespace


TypeFactory Methods

The methods of the TypeFactory class are listed below. For a complete list of TypeFactory class members, see the TypeFactory Members topic.

Public Static (Shared) Methods

CreateDataType |
CreateFilter |
CreateTask | Creates a new Task instance for the given XML and Project.
ScanAssembly | Overloaded. Scans the given assembly for tasks, types, functions and filters.
ScanDir | Scans the path for any task assemblies and adds them.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TypeFactory Class | NAnt.Core Namespace


TypeFactory.CreateDataType Method

[Visual Basic]
Public Shared Function CreateDataType( _
ByVal elementNode As XmlNode, _
ByVal proj As Project _
) As DataTypeBase
[C#]
public static DataTypeBase CreateDataType(
XmlNode elementNode,
Project proj
);

See Also

TypeFactory Class | NAnt.Core Namespace


TypeFactory.CreateFilter Method

[Visual Basic]
Public Shared Function CreateFilter( _
ByVal elementNode As XmlNode, _
ByVal parent As Element _
) As Filter
[C#]
public static Filter CreateFilter(
XmlNode elementNode,
Element parent
);

See Also

TypeFactory Class | NAnt.Core Namespace


TypeFactory.CreateTask Method

Creates a new Task instance for the given XML and Project.

[Visual Basic]
Public Shared Function CreateTask( _
ByVal taskNode As XmlNode, _
ByVal proj As Project _
) As Task
[C#]
public static Task CreateTask(
XmlNode taskNode,
Project proj
);

Parameters

taskNode
The XML to initialize the task with.
proj
The Project that the Task belongs to.

Return Value

The new Task instance.

See Also

TypeFactory Class | NAnt.Core Namespace


ScanAssembly Method

NAnt SDK Documentation - v0.91

TypeFactory.ScanAssembly Method

Scans the given assembly for tasks, types, functions and filters.

Overload List

Scans the given assembly for tasks, types, functions and filters.

public static bool ScanAssembly(Assembly,Task);

Scans the given assembly for tasks, types, functions and filters.

public static bool ScanAssembly(string,Task);

See Also

TypeFactory Class | NAnt.Core Namespace


TypeFactory.ScanAssembly Method (Assembly, Task)

Scans the given assembly for tasks, types, functions and filters.

[Visual Basic]
Overloads Public Shared Function ScanAssembly( _
ByVal assembly As Assembly, _
ByVal task As Task _
) As Boolean
[C#]
public static bool ScanAssembly(
Assembly assembly,
Task task
);

Parameters

assembly
The assembly to scan for tasks, types, functions and filters.
task
The Task which will be used to output messages to the build log.

Return Value

true if assembly contains at least one "extension"; otherwise, false.

See Also

TypeFactory Class | NAnt.Core Namespace | TypeFactory.ScanAssembly Overload List


TypeFactory.ScanAssembly Method (String, Task)

Scans the given assembly for tasks, types, functions and filters.

[Visual Basic]
Overloads Public Shared Function ScanAssembly( _
ByVal assemblyFile As String, _
ByVal task As Task _
) As Boolean
[C#]
public static bool ScanAssembly(
string assemblyFile,
Task task
);

Parameters

assemblyFile
The assembly to scan for tasks, types, functions and filters.
task
The Task which will be used to output messages to the build log.

See Also

TypeFactory Class | NAnt.Core Namespace | TypeFactory.ScanAssembly Overload List


TypeFactory.ScanDir Method

Scans the path for any task assemblies and adds them.

[Visual Basic]
Public Shared Sub ScanDir( _
ByVal path As String, _
ByVal task As Task, _
ByVal failOnError As Boolean _
)
[C#]
public static void ScanDir(
string path,
Task task,
bool failOnError
);

Parameters

path
The directory to scan in.
task
The Task which will be used to output messages to the build log.
failOnError
Boolean indicating whether scanning of the directory should halt on first error.

See Also

TypeFactory Class | NAnt.Core Namespace


ValidationException Class

For a list of all members of this type, see ValidationException Members.

System.Object
System.Exception
System.ApplicationException
NAnt.Core.BuildException
NAnt.Core.ValidationException

[Visual Basic]
<Serializable, _ Serializable>
Public Class ValidationException
Inherits BuildException
[C#]
[Serializable]
[Serializable]
public class ValidationException : BuildException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ValidationException Members | NAnt.Core Namespace


ValidationException Members

ValidationException overview

Public Instance Constructors

ValidationException Overloaded. Initializes a new instance of the ValidationException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Location (inherited from BuildException) | Gets the location in the build file of the element from which the exception originated.
Message (inherited from BuildException) | Gets a message that describes the current exception.
RawMessage (inherited from BuildException) | Gets the raw message as specified when the exception was constructed.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetObjectData (inherited from BuildException) | Serializes this object into the SerializationInfo provided.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from BuildException) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

ValidationException Overloaded. Initializes a new instance of the ValidationException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Instance Events

SerializeObjectState (inherited from Exception)

See Also

ValidationException Class | NAnt.Core Namespace


ValidationException Constructor

Initializes a new instance of the ValidationException class.

Overload List

Initializes a new instance of the ValidationException class.

public ValidationException();

Initializes a new instance of the ValidationException class with serialized data.

protected ValidationException(SerializationInfo,StreamingContext);

Initializes a new instance of the ValidationException class with a descriptive message.

public ValidationException(string);

Initializes a new instance of the ValidationException class with a descriptive message and the location in the build file that caused the exception.

public ValidationException(string,Location);

Initializes a new instance of the ValidationException class with a descriptive message, the location in the build file and an instance of the exception that is the cause of the current exception.

public ValidationException(string,Location,Exception);

Initializes a new instance of the ValidationException class with the specified descriptive message and inner exception.

public ValidationException(string,Exception);

See Also

ValidationException Class | NAnt.Core Namespace


ValidationException Constructor ()

Initializes a new instance of the ValidationException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ValidationException();

See Also

ValidationException Class | NAnt.Core Namespace | ValidationException Constructor Overload List


ValidationException Constructor (String)

Initializes a new instance of the ValidationException class with a descriptive message.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public ValidationException(
string message
);

Parameters

message
A descriptive message to include with the exception.

See Also

ValidationException Class | NAnt.Core Namespace | ValidationException Constructor Overload List


ValidationException Constructor (String, Exception)

Initializes a new instance of the ValidationException class with the specified descriptive message and inner exception.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
[C#]
public ValidationException(
string message,
Exception innerException
);

Parameters

message
A descriptive message to include with the exception.
innerException
A nested exception that is the cause of the current exception.

See Also

ValidationException Class | NAnt.Core Namespace | ValidationException Constructor Overload List


ValidationException Constructor (String, Location)

Initializes a new instance of the ValidationException class with a descriptive message and the location in the build file that caused the exception.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal location As Location _
)
[C#]
public ValidationException(
string message,
Location location
);

Parameters

message
A descriptive message to include with the exception.
location
The location in the build file where the exception occured.

See Also

ValidationException Class | NAnt.Core Namespace | ValidationException Constructor Overload List


ValidationException Constructor (String, Location, Exception)

Initializes a new instance of the ValidationException class with a descriptive message, the location in the build file and an instance of the exception that is the cause of the current exception.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal location As Location, _
ByVal innerException As Exception _
)
[C#]
public ValidationException(
string message,
Location location,
Exception innerException
);

Parameters

message
A descriptive message to include with the exception.
location
The location in the build file where the exception occured.
innerException
A nested exception that is the cause of the current exception.

See Also

ValidationException Class | NAnt.Core Namespace | ValidationException Constructor Overload List


ValidationException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ValidationException class with serialized data.

[Visual Basic]
Overloads Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
protected ValidationException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

See Also

ValidationException Class | NAnt.Core Namespace | ValidationException Constructor Overload List


VendorType Enumeration

[Visual Basic]
<Serializable>
Public Enum VendorType
[C#]
[Serializable]
public enum VendorType

Members

Member Name | Description
Microsoft |
Mono |

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

NAnt.Core Namespace


XmlLogger Class

Used to wrap log messages in xml <message/> elements.

For a list of all members of this type, see XmlLogger Members.

System.Object
NAnt.Core.XmlLogger

[Visual Basic]
<Serializable, _ Serializable>
Public Class XmlLogger
Implements IBuildLogger, IBuildListener, ISerializable
[C#]
[Serializable]
[Serializable]
public class XmlLogger : IBuildLogger, IBuildListener, ISerializable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

XmlLogger Members | NAnt.Core Namespace


XmlLogger Members

XmlLogger overview

Public Instance Constructors

XmlLogger Overloaded. Initializes a new instance of the XmlLogger class.

Public Instance Properties

EmacsMode | Gets or sets a value indicating whether to produce emacs (and other editor) friendly output.
OutputWriter | Gets or sets the TextWriter to which the logger is to send its output.
Threshold | Gets or sets the highest level of message this logger should respond to.

Public Instance Methods

BuildFinished | Signals that the last target has finished.
BuildStarted | Signals that a build has started.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush | Flushes buffered build events or messages to the underlying storage.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetObjectData | Populates info with the data needed to serialize the XmlLogger instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsJustWhiteSpace |
MessageLogged | Signals that a message has been logged.
StripFormatting |
TargetFinished | Signals that a target has finished.
TargetStarted | Signals that a target has started.
TaskFinished | Signals that a task has finished.
TaskStarted | Signals that a task has started.
ToString | Returns the contents of log captured.

Protected Instance Constructors

XmlLogger Overloaded. Initializes a new instance of the XmlLogger class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlLogger Class | NAnt.Core Namespace


XmlLogger Constructor

Initializes a new instance of the XmlLogger class.

Overload List

Initializes a new instance of the XmlLogger class.

public XmlLogger();

public XmlLogger(StopWatchStack);

Initializes a new instance of the XmlLogger class with serialized data.

protected XmlLogger(SerializationInfo,StreamingContext);

See Also

XmlLogger Class | NAnt.Core Namespace


XmlLogger Constructor ()

Initializes a new instance of the XmlLogger class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public XmlLogger();

See Also

XmlLogger Class | NAnt.Core Namespace | XmlLogger Constructor Overload List


XmlLogger Constructor (StopWatchStack)

[Visual Basic]
Overloads Public Sub New( _
ByVal stopWatchStack As StopWatchStack _
)
[C#]
public XmlLogger(
StopWatchStack stopWatchStack
);

See Also

XmlLogger Class | NAnt.Core Namespace | XmlLogger Constructor Overload List


XmlLogger Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the XmlLogger class with serialized data.

[Visual Basic]
Overloads Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
protected XmlLogger(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data.
context
The StreamingContext that contains contextual information about the source or destination.

See Also

XmlLogger Class | NAnt.Core Namespace | XmlLogger Constructor Overload List


XmlLogger Properties

The properties of the XmlLogger class are listed below. For a complete list of XmlLogger class members, see the XmlLogger Members topic.

Public Instance Properties

EmacsMode | Gets or sets a value indicating whether to produce emacs (and other editor) friendly output.
OutputWriter | Gets or sets the TextWriter to which the logger is to send its output.
Threshold | Gets or sets the highest level of message this logger should respond to.

See Also

XmlLogger Class | NAnt.Core Namespace


EmacsMode Property

NAnt SDK Documentation - v0.91

XmlLogger.EmacsMode Property

Gets or sets a value indicating whether to produce emacs (and other editor) friendly output.

[Visual Basic]
Overridable Public Property EmacsMode As Boolean _
Implements IBuildLogger.EmacsMode
[C#]
public virtual bool EmacsMode {get; set;}

Property Value

false as it has no meaning in XML format.

Implements

IBuildLogger.EmacsMode

See Also

XmlLogger Class | NAnt.Core Namespace


OutputWriter Property

NAnt SDK Documentation - v0.91

XmlLogger.OutputWriter Property

Gets or sets the TextWriter to which the logger is to send its output.

[Visual Basic]
NotOverridable Public Property OutputWriter As TextWriter _
Implements IBuildLogger.OutputWriter
[C#]
public System.IO.TextWriter OutputWriter {get; set;}

Implements

IBuildLogger.OutputWriter

See Also

XmlLogger Class | NAnt.Core Namespace


Threshold Property

NAnt SDK Documentation - v0.91

XmlLogger.Threshold Property

Gets or sets the highest level of message this logger should respond to.

[Visual Basic]
NotOverridable Public Property Threshold As Level _
Implements IBuildLogger.Threshold
[C#]
public Level Threshold {get; set;}

Property Value

The highest level of message this logger should respond to.

Implements

IBuildLogger.Threshold

Remarks

Only messages with a message level higher than or equal to the given level should be written to the log.

See Also

XmlLogger Class | NAnt.Core Namespace


XmlLogger Methods

The methods of the XmlLogger class are listed below. For a complete list of XmlLogger class members, see the XmlLogger Members topic.

Public Instance Methods

BuildFinished | Signals that the last target has finished.
BuildStarted | Signals that a build has started.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Flush | Flushes buffered build events or messages to the underlying storage.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetObjectData | Populates info with the data needed to serialize the XmlLogger instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsJustWhiteSpace |
MessageLogged | Signals that a message has been logged.
StripFormatting |
TargetFinished | Signals that a target has finished.
TargetStarted | Signals that a target has started.
TaskFinished | Signals that a task has finished.
TaskStarted | Signals that a task has started.
ToString | Returns the contents of log captured.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlLogger Class | NAnt.Core Namespace


XmlLogger.BuildFinished Method

Signals that the last target has finished.

[Visual Basic]
NotOverridable Public Sub BuildFinished( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
) _
Implements IBuildListener.BuildFinished
[C#]
public void BuildFinished(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Implements

IBuildListener.BuildFinished

Remarks

This event will still be fired if an error occurred during the build.

See Also

XmlLogger Class | NAnt.Core Namespace


XmlLogger.BuildStarted Method

Signals that a build has started.

[Visual Basic]
NotOverridable Public Sub BuildStarted( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
) _
Implements IBuildListener.BuildStarted
[C#]
public void BuildStarted(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Implements

IBuildListener.BuildStarted

Remarks

This event is fired before any targets have started.

See Also

XmlLogger Class | NAnt.Core Namespace


XmlLogger.Flush Method

Flushes buffered build events or messages to the underlying storage.

[Visual Basic]
NotOverridable Public Sub Flush() _
Implements IBuildLogger.Flush
[C#]
public void Flush();

Implements

IBuildLogger.Flush

See Also

XmlLogger Class | NAnt.Core Namespace


XmlLogger.GetObjectData Method

Populates info with the data needed to serialize the XmlLogger instance.

[Visual Basic]
NotOverridable Public Sub GetObjectData( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
) _
Implements ISerializable.GetObjectData
[C#]
public void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo to populate with data.
context
The destination for this serialization.

Implements

ISerializable.GetObjectData

See Also

XmlLogger Class | NAnt.Core Namespace


XmlLogger.IsJustWhiteSpace Method

[Visual Basic]
Public Function IsJustWhiteSpace( _
ByVal message As String _
) As Boolean
[C#]
public bool IsJustWhiteSpace(
string message
);

See Also

XmlLogger Class | NAnt.Core Namespace


XmlLogger.MessageLogged Method

Signals that a message has been logged.

[Visual Basic]
NotOverridable Public Sub MessageLogged( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
) _
Implements IBuildListener.MessageLogged
[C#]
public void MessageLogged(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Implements

IBuildListener.MessageLogged

Remarks

Only messages with a priority higher or equal to the threshold of the logger will actually be output in the build log.

See Also

XmlLogger Class | NAnt.Core Namespace


XmlLogger.StripFormatting Method

[Visual Basic]
Public Function StripFormatting( _
ByVal message As String _
) As String
[C#]
public string StripFormatting(
string message
);

See Also

XmlLogger Class | NAnt.Core Namespace


XmlLogger.TargetFinished Method

Signals that a target has finished.

[Visual Basic]
NotOverridable Public Sub TargetFinished( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
) _
Implements IBuildListener.TargetFinished
[C#]
public void TargetFinished(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Implements

IBuildListener.TargetFinished

Remarks

This event will still be fired if an error occurred during the build.

See Also

XmlLogger Class | NAnt.Core Namespace


XmlLogger.TargetStarted Method

Signals that a target has started.

[Visual Basic]
NotOverridable Public Sub TargetStarted( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
) _
Implements IBuildListener.TargetStarted
[C#]
public void TargetStarted(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Implements

IBuildListener.TargetStarted

See Also

XmlLogger Class | NAnt.Core Namespace


XmlLogger.TaskFinished Method

Signals that a task has finished.

[Visual Basic]
NotOverridable Public Sub TaskFinished( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
) _
Implements IBuildListener.TaskFinished
[C#]
public void TaskFinished(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Implements

IBuildListener.TaskFinished

Remarks

This event will still be fired if an error occurred during the build.

See Also

XmlLogger Class | NAnt.Core Namespace


XmlLogger.TaskStarted Method

Signals that a task has started.

[Visual Basic]
NotOverridable Public Sub TaskStarted( _
ByVal sender As Object, _
ByVal e As BuildEventArgs _
) _
Implements IBuildListener.TaskStarted
[C#]
public void TaskStarted(
object sender,
BuildEventArgs e
);

Parameters

sender
The source of the event.
e
A BuildEventArgs object that contains the event data.

Implements

IBuildListener.TaskStarted

See Also

XmlLogger Class | NAnt.Core Namespace


XmlLogger.ToString Method

Returns the contents of log captured.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

XmlLogger Class | NAnt.Core Namespace


NAnt.Core.Attributes

NAnt SDK Documentation - v0.91

NAnt.Core.Attributes Namespace

Namespace hierarchy

Classes

Class | Description
BooleanValidatorAttribute | Used to indicate that a property should be able to be converted into a Boolean.
BuildAttributeAttribute | Indicates that property should be treated as a XML attribute for the task.
BuildElementArrayAttribute | Indicates that property should be treated as a XML arrayList
BuildElementAttribute | Indicates that the property should be treated as an XML element and further processing should be done.
BuildElementCollectionAttribute | Indicates that the property should be treated as a container for a collection of build elements.
DateTimeValidatorAttribute | Used to indicate that a property should be able to be converted into a DateTime.
ElementNameAttribute | Indicates that class should be treated as a NAnt element.
FileSetAttribute | Obsolete. Indicates that a property should be treated as a XML file set for the task.
FrameworkConfigurableAttribute | Indicates that the value of the property to which the attribute is assigned, can be configured on the framework-level in the NAnt application configuration file.
FunctionAttribute | Indicates that the method should be exposed as a function in NAnt build files.
FunctionSetAttribute | Indicates that class should be treated as a set of functions.
Int32ValidatorAttribute | Indicates that property should be able to be converted into a Int32 within the given range.
ProgramLocationAttribute | Indicates the location that a task executable can be located in.
StringValidatorAttribute | Used to indicate whether a String property should allow an empty string value or not.
TaskAttributeAttribute | Indicates that property should be treated as a XML attribute for the task.
TaskNameAttribute | Indicates that class should be treated as a task.
ValidatorAttribute | Base class for all validator attributes.

Enumerations

Enumeration | Description
LocationType | Defines possible locations in which a task executable can be located.


BooleanValidatorAttribute Class

Used to indicate that a property should be able to be converted into a Boolean.

For a list of all members of this type, see BooleanValidatorAttribute Members.

System.Object
System.Attribute
NAnt.Core.Attributes.ValidatorAttribute
NAnt.Core.Attributes.BooleanValidatorAttribute

[Visual Basic]
<AttributeUsage(Inherited:=True, ValidOn:=AttributeTargets.Property, AllowMultiple:=False)>
NotInheritable Public Class BooleanValidatorAttribute
Inherits ValidatorAttribute
[C#]
[AttributeUsage(Inherited=True, ValidOn=AttributeTargets.Property, AllowMultiple=False)]
public sealed class BooleanValidatorAttribute : ValidatorAttribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Attributes

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

BooleanValidatorAttribute Members | NAnt.Core.Attributes Namespace


BooleanValidatorAttribute Members

BooleanValidatorAttribute overview

Public Instance Constructors

BooleanValidatorAttribute Constructor Initializes a new instance of the BooleanValidatorAttribute class.

Public Instance Properties

TypeId (inherited from Attribute) When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Checks if the specified value can be converted to a Boolean.

See Also

BooleanValidatorAttribute Class | NAnt.Core.Attributes Namespace


BooleanValidatorAttribute Constructor

Initializes a new instance of the BooleanValidatorAttribute class.

[Visual Basic]
Public Sub New()
[C#]
public BooleanValidatorAttribute();

See Also

BooleanValidatorAttribute Class | NAnt.Core.Attributes Namespace


BooleanValidatorAttribute Methods

The methods of the BooleanValidatorAttribute class are listed below. For a complete list of BooleanValidatorAttribute class members, see the BooleanValidatorAttribute Members topic.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Checks if the specified value can be converted to a Boolean.

See Also

BooleanValidatorAttribute Class | NAnt.Core.Attributes Namespace


BooleanValidatorAttribute.Validate Method

Checks if the specified value can be converted to a Boolean.

[Visual Basic]
Overrides Public Sub Validate( _
ByVal value As Object _
)
[C#]
public override void Validate(
object value
);

Parameters

value
The value to be checked.

Exceptions

Exception Type | Condition
ValidationException | value cannot be converted to a Boolean.

See Also

BooleanValidatorAttribute Class | NAnt.Core.Attributes Namespace


BuildAttributeAttribute Class

Indicates that property should be treated as a XML attribute for the task.

For a list of all members of this type, see BuildAttributeAttribute Members.

System.Object
System.Attribute
NAnt.Core.Attributes.BuildAttributeAttribute
NAnt.Core.Attributes.TaskAttributeAttribute

[Visual Basic]
<AttributeUsage(Inherited:=True, ValidOn:=AttributeTargets.Property, AllowMultiple:=False)>
MustInherit Public Class BuildAttributeAttribute
Inherits Attribute
[C#]
[AttributeUsage(Inherited=True, ValidOn=AttributeTargets.Property, AllowMultiple=False)]
public abstract class BuildAttributeAttribute : Attribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Examples of how to specify task attributes

            #region Public Instance Properties

            [BuildAttribute("out", Required=true)]
            public string Output {
                get { return _out; }
                set { _out = value; }
            }
                        [BuildAttribute("optimize")]
            [BooleanValidator()]
            public bool Optimize {
                get { return _optimize; }
                set { _optimize = value; }
            }
                        [BuildAttribute("warnlevel")]
            [Int32Validator(0,4)] // limit values to 0-4
            public int WarnLevel {
                get { return _warnLevel; }
                set { _warnLevel = value; }
            }
                        [BuildElement("sources")]
            public FileSet Sources {
                get { return _sources; }
                set { _sources = value; }
            }

            #endregion Public Instance Properties

            #region Private Instance Fields

            private string _out = null;
            private bool _optimize = false;
            private int _warnLevel = 4;
            private FileSet _sources = new FileSet();

            #endregion Private Instance Fields

Requirements

Namespace: NAnt.Core.Attributes

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

BuildAttributeAttribute Members | NAnt.Core.Attributes Namespace


BuildAttributeAttribute Members

BuildAttributeAttribute overview

Public Instance Properties

ExpandProperties | Gets or sets a value indicating whether property references should be expanded.
Name | Gets or sets the name of the XML attribute.
ProcessXml | Used to specify how this attribute will be handled as the XML is parsed and given to the element.
Required | Gets or sets a value indicating whether the attribute is required.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BuildAttributeAttribute Constructor Initializes a new instance of the BuildAttributeAttribute with the specified name.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BuildAttributeAttribute Class | NAnt.Core.Attributes Namespace


BuildAttributeAttribute Constructor

Initializes a new instance of the BuildAttributeAttribute with the specified name.

[Visual Basic]
Protected Sub New( _
ByVal name As String _
)
[C#]
protected BuildAttributeAttribute(
string name
);

Parameters

name
The name of the attribute.

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing in Visual Basic).
ArgumentOutOfRangeException | name is a zero-length String.

See Also

BuildAttributeAttribute Class | NAnt.Core.Attributes Namespace


BuildAttributeAttribute Properties

The properties of the BuildAttributeAttribute class are listed below. For a complete list of BuildAttributeAttribute class members, see the BuildAttributeAttribute Members topic.

Public Instance Properties

ExpandProperties | Gets or sets a value indicating whether property references should be expanded.
Name | Gets or sets the name of the XML attribute.
ProcessXml | Used to specify how this attribute will be handled as the XML is parsed and given to the element.
Required | Gets or sets a value indicating whether the attribute is required.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

BuildAttributeAttribute Class | NAnt.Core.Attributes Namespace


ExpandProperties Property

NAnt SDK Documentation - v0.91

BuildAttributeAttribute.ExpandProperties Property

Gets or sets a value indicating whether property references should be expanded.

[Visual Basic]
Public Property ExpandProperties As Boolean
[C#]
public bool ExpandProperties {get; set;}

Property Value

true if properties should be expanded; otherwise false. The default is true.

See Also

BuildAttributeAttribute Class | NAnt.Core.Attributes Namespace


Name Property

NAnt SDK Documentation - v0.91

BuildAttributeAttribute.Name Property

Gets or sets the name of the XML attribute.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}

Property Value

The name of the XML attribute.

See Also

BuildAttributeAttribute Class | NAnt.Core.Attributes Namespace


ProcessXml Property

NAnt SDK Documentation - v0.91

BuildAttributeAttribute.ProcessXml Property

Used to specify how this attribute will be handled as the XML is parsed and given to the element.

[Visual Basic]
Public Property ProcessXml As Boolean
[C#]
public bool ProcessXml {get; set;}

Property Value

true if XML should be processed; otherwise false. The default is true.

See Also

BuildAttributeAttribute Class | NAnt.Core.Attributes Namespace


Required Property

NAnt SDK Documentation - v0.91

BuildAttributeAttribute.Required Property

Gets or sets a value indicating whether the attribute is required.

[Visual Basic]
Public Property Required As Boolean
[C#]
public bool Required {get; set;}

Property Value

true if the attribute is required; otherwise, false. The default is false.

See Also

BuildAttributeAttribute Class | NAnt.Core.Attributes Namespace


BuildElementArrayAttribute Class

Indicates that property should be treated as a XML arrayList

For a list of all members of this type, see BuildElementArrayAttribute Members.

System.Object
System.Attribute
NAnt.Core.Attributes.BuildElementAttribute
NAnt.Core.Attributes.BuildElementArrayAttribute
NAnt.Core.Attributes.BuildElementCollectionAttribute

[Visual Basic]
<AttributeUsage(Inherited:=True, ValidOn:=AttributeTargets.Property, AllowMultiple:=False)>
Public Class BuildElementArrayAttribute
Inherits BuildElementAttribute
[C#]
[AttributeUsage(Inherited=True, ValidOn=AttributeTargets.Property, AllowMultiple=False)]
public class BuildElementArrayAttribute : BuildElementAttribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Should only be applied to properties exposing strongly typed arrays or strongly typed collections.

The XML format is like this:

            <task>
                <elementName ... />
                <elementName ... />
                <elementName ... />
                <elementName ... />
            </task>

Requirements

Namespace: NAnt.Core.Attributes

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

BuildElementArrayAttribute Members | NAnt.Core.Attributes Namespace


BuildElementArrayAttribute Members

BuildElementArrayAttribute overview

Public Instance Constructors

BuildElementArrayAttribute Constructor Initializes a new instance of the BuildElementArrayAttribute with the specified name.

Public Instance Properties

ElementType | Gets or sets the type of objects that this container holds.
Name (inherited from BuildElementAttribute) | Gets or sets the name of the attribute.
ProcessXml (inherited from BuildElementAttribute) | Used to specify how this element will be handled as the XML is parsed and given to the element.
Required (inherited from BuildElementAttribute) | Gets or sets a value indicating whether the attribute is required.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BuildElementArrayAttribute Class | NAnt.Core.Attributes Namespace


BuildElementArrayAttribute Constructor

Initializes a new instance of the BuildElementArrayAttribute with the specified name.

[Visual Basic]
Public Sub New( _
ByVal name As String _
)
[C#]
public BuildElementArrayAttribute(
string name
);

Parameters

name
The name of the attribute.

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing in Visual Basic).
ArgumentOutOfRangeException | name is a zero-length String.

See Also

BuildElementArrayAttribute Class | NAnt.Core.Attributes Namespace


BuildElementArrayAttribute Properties

The properties of the BuildElementArrayAttribute class are listed below. For a complete list of BuildElementArrayAttribute class members, see the BuildElementArrayAttribute Members topic.

Public Instance Properties

ElementType | Gets or sets the type of objects that this container holds.
Name (inherited from BuildElementAttribute) | Gets or sets the name of the attribute.
ProcessXml (inherited from BuildElementAttribute) | Used to specify how this element will be handled as the XML is parsed and given to the element.
Required (inherited from BuildElementAttribute) | Gets or sets a value indicating whether the attribute is required.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

BuildElementArrayAttribute Class | NAnt.Core.Attributes Namespace


ElementType Property

NAnt SDK Documentation - v0.91

BuildElementArrayAttribute.ElementType Property

Gets or sets the type of objects that this container holds.

[Visual Basic]
Public Property ElementType As Type
[C#]
public System.Type ElementType {get; set;}

Property Value

The type of the elements that this container holds.

Remarks

This can be used for validation and schema generation.

If not specified, the type of the elements will be determined using reflection.

Exceptions

Exception Type | Condition
ArgumentNullException | value is a null reference (Nothing in Visual Basic).

See Also

BuildElementArrayAttribute Class | NAnt.Core.Attributes Namespace


BuildElementAttribute Class

Indicates that the property should be treated as an XML element and further processing should be done.

For a list of all members of this type, see BuildElementAttribute Members.

System.Object
System.Attribute
NAnt.Core.Attributes.BuildElementAttribute
NAnt.Core.Attributes.BuildElementArrayAttribute
NAnt.Core.Attributes.FileSetAttribute

[Visual Basic]
<AttributeUsage(Inherited:=True, ValidOn:=(AttributeTargets.Method Or AttributeTargets.Property), AllowMultiple:=False)>
Public Class BuildElementAttribute
Inherits Attribute
[C#]
[AttributeUsage(Inherited=True, ValidOn=(AttributeTargets.Method|AttributeTargets.Property), AllowMultiple=False)]
public class BuildElementAttribute : Attribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The XML format is like this:

            <task>
                <elementName ...>
                    <morestuff />
                </elementName>
            </task>

Requirements

Namespace: NAnt.Core.Attributes

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

BuildElementAttribute Members | NAnt.Core.Attributes Namespace


BuildElementAttribute Members

BuildElementAttribute overview

Public Instance Constructors

BuildElementAttribute Constructor Initializes a new instance of the BuildElementAttribute with the specified name.

Public Instance Properties

Name | Gets or sets the name of the attribute.
ProcessXml | Used to specify how this element will be handled as the XML is parsed and given to the element.
Required | Gets or sets a value indicating whether the attribute is required.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BuildElementAttribute Class | NAnt.Core.Attributes Namespace


BuildElementAttribute Constructor

Initializes a new instance of the BuildElementAttribute with the specified name.

[Visual Basic]
Public Sub New( _
ByVal name As String _
)
[C#]
public BuildElementAttribute(
string name
);

Parameters

name
The name of the attribute.

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing in Visual Basic).
ArgumentOutOfRangeException | name is a zero-length String.

See Also

BuildElementAttribute Class | NAnt.Core.Attributes Namespace


BuildElementAttribute Properties

The properties of the BuildElementAttribute class are listed below. For a complete list of BuildElementAttribute class members, see the BuildElementAttribute Members topic.

Public Instance Properties

Name | Gets or sets the name of the attribute.
ProcessXml | Used to specify how this element will be handled as the XML is parsed and given to the element.
Required | Gets or sets a value indicating whether the attribute is required.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

BuildElementAttribute Class | NAnt.Core.Attributes Namespace


Name Property

NAnt SDK Documentation - v0.91

BuildElementAttribute.Name Property

Gets or sets the name of the attribute.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}

Property Value

The name of the attribute.

See Also

BuildElementAttribute Class | NAnt.Core.Attributes Namespace


ProcessXml Property

NAnt SDK Documentation - v0.91

BuildElementAttribute.ProcessXml Property

Used to specify how this element will be handled as the XML is parsed and given to the element.

[Visual Basic]
Public Property ProcessXml As Boolean
[C#]
public bool ProcessXml {get; set;}

Property Value

true if XML should be processed; otherwise false. The default is true.

See Also

BuildElementAttribute Class | NAnt.Core.Attributes Namespace


Required Property

NAnt SDK Documentation - v0.91

BuildElementAttribute.Required Property

Gets or sets a value indicating whether the attribute is required.

[Visual Basic]
Public Property Required As Boolean
[C#]
public bool Required {get; set;}

Property Value

true if the attribute is required; otherwise, false. The default is false.

See Also

BuildElementAttribute Class | NAnt.Core.Attributes Namespace


BuildElementCollectionAttribute Class

Indicates that the property should be treated as a container for a collection of build elements.

For a list of all members of this type, see BuildElementCollectionAttribute Members.

System.Object
System.Attribute
NAnt.Core.Attributes.BuildElementAttribute
NAnt.Core.Attributes.BuildElementArrayAttribute
NAnt.Core.Attributes.BuildElementCollectionAttribute

[Visual Basic]
<AttributeUsage(Inherited:=True, ValidOn:=AttributeTargets.Property, AllowMultiple:=False)>
NotInheritable Public Class BuildElementCollectionAttribute
Inherits BuildElementArrayAttribute
[C#]
[AttributeUsage(Inherited=True, ValidOn=AttributeTargets.Property, AllowMultiple=False)]
public sealed class BuildElementCollectionAttribute : BuildElementArrayAttribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Should only be applied to properties exposing strongly typed arrays or strongly typed collections.

The XML format is like this:

            <task>
                <collectionName>
                    <elementName ... />
                    <elementName ... />
                    <elementName ... />
                    <elementName ... />
                </collectionName>
            </task>

Requirements

Namespace: NAnt.Core.Attributes

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

BuildElementCollectionAttribute Members | NAnt.Core.Attributes Namespace


BuildElementCollectionAttribute Members

BuildElementCollectionAttribute overview

Public Instance Constructors

BuildElementCollectionAttribute Constructor Initializes a new instance of the BuildElementCollectionAttribute with the specified name and child element name.

Public Instance Properties

ChildElementName | The name of the child element within the collection.
ElementType (inherited from BuildElementArrayAttribute) | Gets or sets the type of objects that this container holds.
Name (inherited from BuildElementAttribute) | Gets or sets the name of the attribute.
ProcessXml (inherited from BuildElementAttribute) | Used to specify how this element will be handled as the XML is parsed and given to the element.
Required (inherited from BuildElementAttribute) | Gets or sets a value indicating whether the attribute is required.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BuildElementCollectionAttribute Class | NAnt.Core.Attributes Namespace


BuildElementCollectionAttribute Constructor

Initializes a new instance of the BuildElementCollectionAttribute with the specified name and child element name.

[Visual Basic]
Public Sub New( _
ByVal collectionName As String, _
ByVal childName As String _
)
[C#]
public BuildElementCollectionAttribute(
string collectionName,
string childName
);

Parameters

collectionName
The name of the collection.
childName
The name of the child elements in the collection

Exceptions

Exception Type | Condition
ArgumentNullException | childName is a null reference (Nothing in Visual Basic).
ArgumentOutOfRangeException | childName is a zero-length String.

See Also

BuildElementCollectionAttribute Class | NAnt.Core.Attributes Namespace


BuildElementCollectionAttribute Properties

The properties of the BuildElementCollectionAttribute class are listed below. For a complete list of BuildElementCollectionAttribute class members, see the BuildElementCollectionAttribute Members topic.

Public Instance Properties

ChildElementName | The name of the child element within the collection.
ElementType (inherited from BuildElementArrayAttribute) | Gets or sets the type of objects that this container holds.
Name (inherited from BuildElementAttribute) | Gets or sets the name of the attribute.
ProcessXml (inherited from BuildElementAttribute) | Used to specify how this element will be handled as the XML is parsed and given to the element.
Required (inherited from BuildElementAttribute) | Gets or sets a value indicating whether the attribute is required.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

BuildElementCollectionAttribute Class | NAnt.Core.Attributes Namespace


ChildElementName Property

NAnt SDK Documentation - v0.91

BuildElementCollectionAttribute.ChildElementName Property

The name of the child element within the collection.

[Visual Basic]
Public ReadOnly Property ChildElementName As String
[C#]
public string ChildElementName {get;}

Property Value

The name to check for in the XML of the elements in the collection.

Remarks

This can be used for validation and schema generation.

See Also

BuildElementCollectionAttribute Class | NAnt.Core.Attributes Namespace


DateTimeValidatorAttribute Class

Used to indicate that a property should be able to be converted into a DateTime.

For a list of all members of this type, see DateTimeValidatorAttribute Members.

System.Object
System.Attribute
NAnt.Core.Attributes.ValidatorAttribute
NAnt.Core.Attributes.DateTimeValidatorAttribute

[Visual Basic]
<AttributeUsage(Inherited:=True, ValidOn:=AttributeTargets.Property, AllowMultiple:=False)>
NotInheritable Public Class DateTimeValidatorAttribute
Inherits ValidatorAttribute
[C#]
[AttributeUsage(Inherited=True, ValidOn=AttributeTargets.Property, AllowMultiple=False)]
public sealed class DateTimeValidatorAttribute : ValidatorAttribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Attributes

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

DateTimeValidatorAttribute Members | NAnt.Core.Attributes Namespace


DateTimeValidatorAttribute Members

DateTimeValidatorAttribute overview

Public Instance Constructors

DateTimeValidatorAttribute Constructor Initializes a new instance of the DateTimeValidatorAttribute class.

Public Instance Properties

TypeId (inherited from Attribute) When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Checks if the specified value can be converted to a DateTime.

See Also

DateTimeValidatorAttribute Class | NAnt.Core.Attributes Namespace


DateTimeValidatorAttribute Constructor

Initializes a new instance of the DateTimeValidatorAttribute class.

[Visual Basic]
Public Sub New()
[C#]
public DateTimeValidatorAttribute();

See Also

DateTimeValidatorAttribute Class | NAnt.Core.Attributes Namespace


DateTimeValidatorAttribute Methods

The methods of the DateTimeValidatorAttribute class are listed below. For a complete list of DateTimeValidatorAttribute class members, see the DateTimeValidatorAttribute Members topic.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Checks if the specified value can be converted to a DateTime.

See Also

DateTimeValidatorAttribute Class | NAnt.Core.Attributes Namespace


DateTimeValidatorAttribute.Validate Method

Checks if the specified value can be converted to a DateTime.

[Visual Basic]
Overrides Public Sub Validate( _
ByVal value As Object _
)
[C#]
public override void Validate(
object value
);

Parameters

value
The value to be checked.

Exceptions

Exception Type | Condition
ValidationException | value cannot be converted to a DateTime.

See Also

DateTimeValidatorAttribute Class | NAnt.Core.Attributes Namespace


ElementNameAttribute Class

Indicates that class should be treated as a NAnt element.

For a list of all members of this type, see ElementNameAttribute Members.

System.Object
System.Attribute
NAnt.Core.Attributes.ElementNameAttribute
NAnt.Core.Attributes.TaskNameAttribute

[Visual Basic]
<AttributeUsage(Inherited:=False, ValidOn:=AttributeTargets.Class, AllowMultiple:=False)>
Public Class ElementNameAttribute
Inherits Attribute
[C#]
[AttributeUsage(Inherited=False, ValidOn=AttributeTargets.Class, AllowMultiple=False)]
public class ElementNameAttribute : Attribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Attach this attribute to a subclass of Element to have NAnt be able to recognize it. The name should be short but must not confict with any other element already in use.

Requirements

Namespace: NAnt.Core.Attributes

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ElementNameAttribute Members | NAnt.Core.Attributes Namespace


ElementNameAttribute Members

ElementNameAttribute overview

Public Instance Constructors

ElementNameAttribute Constructor Initializes a new instance of the with the specified name.

Public Instance Properties

Name | Gets or sets the name of the element.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ElementNameAttribute Class | NAnt.Core.Attributes Namespace


ElementNameAttribute Constructor

Initializes a new instance of the with the specified name.

[Visual Basic]
Public Sub New( _
ByVal name As String _
)
[C#]
public ElementNameAttribute(
string name
);

Parameters

name
The name of the element.

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing in Visual Basic).
ArgumentOutOfRangeException | name is a zero-length String.

See Also

ElementNameAttribute Class | NAnt.Core.Attributes Namespace


ElementNameAttribute Properties

The properties of the ElementNameAttribute class are listed below. For a complete list of ElementNameAttribute class members, see the ElementNameAttribute Members topic.

Public Instance Properties

Name | Gets or sets the name of the element.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

ElementNameAttribute Class | NAnt.Core.Attributes Namespace


Name Property

NAnt SDK Documentation - v0.91

ElementNameAttribute.Name Property

Gets or sets the name of the element.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}

Property Value

The name of the element.

See Also

ElementNameAttribute Class | NAnt.Core.Attributes Namespace


FileSetAttribute Class

NOTE: This class is now obsolete.

Please use a BuildElement attribute instead. This class will be removed soon.

Indicates that a property should be treated as a XML file set for the task.

For a list of all members of this type, see FileSetAttribute Members.

System.Object
System.Attribute
NAnt.Core.Attributes.BuildElementAttribute
NAnt.Core.Attributes.FileSetAttribute

[Visual Basic]
<Obsolete(Message:="Please use a BuildElement attribute instead. This class will be removed soon.", IsError:=True), _ AttributeUsage(Inherited:=True, ValidOn:=AttributeTargets.Property, AllowMultiple:=False)>
NotInheritable Public Class FileSetAttribute
Inherits BuildElementAttribute
[C#]
[Obsolete(Message="Please use a BuildElement attribute instead. This class will be removed soon.", IsError=True)]
[AttributeUsage(Inherited=True, ValidOn=AttributeTargets.Property, AllowMultiple=False)]
public sealed class FileSetAttribute : BuildElementAttribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Attributes

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FileSetAttribute Members | NAnt.Core.Attributes Namespace


FileSetAttribute Members

FileSetAttribute overview

Public Instance Constructors

FileSetAttribute Constructor Initializes a new instance of the FileSetAttribute with the specified name.

Public Instance Properties

Name (inherited from BuildElementAttribute) | Gets or sets the name of the attribute.
ProcessXml (inherited from BuildElementAttribute) | Used to specify how this element will be handled as the XML is parsed and given to the element.
Required (inherited from BuildElementAttribute) | Gets or sets a value indicating whether the attribute is required.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileSetAttribute Class | NAnt.Core.Attributes Namespace


FileSetAttribute Constructor

Initializes a new instance of the FileSetAttribute with the specified name.

[Visual Basic]
Public Sub New( _
ByVal name As String _
)
[C#]
public FileSetAttribute(
string name
);

Parameters

name
The name of the attribute.

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing in Visual Basic).
ArgumentOutOfRangeException | name is a zero-length String.

See Also

FileSetAttribute Class | NAnt.Core.Attributes Namespace


FrameworkConfigurableAttribute Class

Indicates that the value of the property to which the attribute is assigned, can be configured on the framework-level in the NAnt application configuration file.

For a list of all members of this type, see FrameworkConfigurableAttribute Members.

System.Object
System.Attribute
NAnt.Core.Attributes.FrameworkConfigurableAttribute

[Visual Basic]
<AttributeUsage(Inherited:=True, ValidOn:=AttributeTargets.Property, AllowMultiple:=False)>
NotInheritable Public Class FrameworkConfigurableAttribute
Inherits Attribute
[C#]
[AttributeUsage(Inherited=True, ValidOn=AttributeTargets.Property, AllowMultiple=False)]
public sealed class FrameworkConfigurableAttribute : Attribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

The following example shows a property of which the value can be configured for a specific framework in the NAnt configuration file.

[C#]

            [FrameworkConfigurable("exename", Required=true)]
            public virtual string ExeName {
                get { return _exeName; }
                set { _exeName = value; }
            }

Requirements

Namespace: NAnt.Core.Attributes

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FrameworkConfigurableAttribute Members | NAnt.Core.Attributes Namespace


FrameworkConfigurableAttribute Members

FrameworkConfigurableAttribute overview

Public Instance Constructors

FrameworkConfigurableAttribute Constructor Initializes a new instance of the FrameworkConfigurableAttribute with the specified attribute name.

Public Instance Properties

ExpandProperties | Gets or sets a value indicating whether property references should be expanded.
Name | Gets or sets the name of the framework configuration attribute.
Required | Gets or sets a value indicating whether the configuration attribute is required.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FrameworkConfigurableAttribute Class | NAnt.Core.Attributes Namespace


FrameworkConfigurableAttribute Constructor

Initializes a new instance of the FrameworkConfigurableAttribute with the specified attribute name.

[Visual Basic]
Public Sub New( _
ByVal name As String _
)
[C#]
public FrameworkConfigurableAttribute(
string name
);

Parameters

name
The name of the framework configuration attribute.

Exceptions

Exception Type | Condition
ArgumentNullException | name is a a null reference (Nothing in Visual Basic).
ArgumentOutOfRangeException | name is a zero-length String.

See Also

FrameworkConfigurableAttribute Class | NAnt.Core.Attributes Namespace


FrameworkConfigurableAttribute Properties

The properties of the FrameworkConfigurableAttribute class are listed below. For a complete list of FrameworkConfigurableAttribute class members, see the FrameworkConfigurableAttribute Members topic.

Public Instance Properties

ExpandProperties | Gets or sets a value indicating whether property references should be expanded.
Name | Gets or sets the name of the framework configuration attribute.
Required | Gets or sets a value indicating whether the configuration attribute is required.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

FrameworkConfigurableAttribute Class | NAnt.Core.Attributes Namespace


ExpandProperties Property

NAnt SDK Documentation - v0.91

FrameworkConfigurableAttribute.ExpandProperties Property

Gets or sets a value indicating whether property references should be expanded.

[Visual Basic]
Public Property ExpandProperties As Boolean
[C#]
public bool ExpandProperties {get; set;}

Property Value

true if properties should be expanded; otherwise false. The default is true.

See Also

FrameworkConfigurableAttribute Class | NAnt.Core.Attributes Namespace


Name Property

NAnt SDK Documentation - v0.91

FrameworkConfigurableAttribute.Name Property

Gets or sets the name of the framework configuration attribute.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}

Property Value

The name of the framework configuration attribute.

See Also

FrameworkConfigurableAttribute Class | NAnt.Core.Attributes Namespace


Required Property

NAnt SDK Documentation - v0.91

FrameworkConfigurableAttribute.Required Property

Gets or sets a value indicating whether the configuration attribute is required.

[Visual Basic]
Public Property Required As Boolean
[C#]
public bool Required {get; set;}

Property Value

true if the configuration attribute is required; otherwise, true. The default is false.

See Also

FrameworkConfigurableAttribute Class | NAnt.Core.Attributes Namespace


FunctionAttribute Class

Indicates that the method should be exposed as a function in NAnt build files.

For a list of all members of this type, see FunctionAttribute Members.

System.Object
System.Attribute
NAnt.Core.Attributes.FunctionAttribute

[Visual Basic]
<AttributeUsage(Inherited:=False, ValidOn:=AttributeTargets.Method, AllowMultiple:=False)>
NotInheritable Public Class FunctionAttribute
Inherits Attribute
[C#]
[AttributeUsage(Inherited=False, ValidOn=AttributeTargets.Method, AllowMultiple=False)]
public sealed class FunctionAttribute : Attribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Attach this attribute to a method of a class that derives from FunctionSetBase to have NAnt be able to recognize it.

Requirements

Namespace: NAnt.Core.Attributes

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FunctionAttribute Members | NAnt.Core.Attributes Namespace


FunctionAttribute Members

FunctionAttribute overview

Public Instance Constructors

FunctionAttribute Constructor Initializes a new instance of the FunctionAttribute class with the specified name.

Public Instance Properties

Name | Gets or sets the name of the function.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FunctionAttribute Class | NAnt.Core.Attributes Namespace


FunctionAttribute Constructor

Initializes a new instance of the FunctionAttribute class with the specified name.

[Visual Basic]
Public Sub New( _
ByVal name As String _
)
[C#]
public FunctionAttribute(
string name
);

Parameters

name
The name of the function.

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing in Visual Basic).
ArgumentOutOfRangeException | name is a zero-length String.

See Also

FunctionAttribute Class | NAnt.Core.Attributes Namespace


FunctionAttribute Properties

The properties of the FunctionAttribute class are listed below. For a complete list of FunctionAttribute class members, see the FunctionAttribute Members topic.

Public Instance Properties

Name | Gets or sets the name of the function.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

FunctionAttribute Class | NAnt.Core.Attributes Namespace


Name Property

NAnt SDK Documentation - v0.91

FunctionAttribute.Name Property

Gets or sets the name of the function.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}

Property Value

The name of the function.

See Also

FunctionAttribute Class | NAnt.Core.Attributes Namespace


FunctionSetAttribute Class

Indicates that class should be treated as a set of functions.

For a list of all members of this type, see FunctionSetAttribute Members.

System.Object
System.Attribute
NAnt.Core.Attributes.FunctionSetAttribute

[Visual Basic]
<AttributeUsage(Inherited:=False, ValidOn:=AttributeTargets.Class, AllowMultiple:=False)>
NotInheritable Public Class FunctionSetAttribute
Inherits Attribute
[C#]
[AttributeUsage(Inherited=False, ValidOn=AttributeTargets.Class, AllowMultiple=False)]
public sealed class FunctionSetAttribute : Attribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Attach this attribute to a class that derives from FunctionSetBase to have NAnt be able to recognize it as containing custom functions.

Requirements

Namespace: NAnt.Core.Attributes

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FunctionSetAttribute Members | NAnt.Core.Attributes Namespace


FunctionSetAttribute Members

FunctionSetAttribute overview

Public Instance Constructors

FunctionSetAttribute Constructor Initializes a new instance of the FunctionSetAttribute class with the specified name.

Public Instance Properties

Category | Gets or sets the category of the function set.
Prefix | Gets or sets the prefix of all functions in this function set.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FunctionSetAttribute Class | NAnt.Core.Attributes Namespace


FunctionSetAttribute Constructor

Initializes a new instance of the FunctionSetAttribute class with the specified name.

[Visual Basic]
Public Sub New( _
ByVal prefix As String, _
ByVal category As String _
)
[C#]
public FunctionSetAttribute(
string prefix,
string category
);

Parameters

prefix
The prefix used to distinguish the functions.
category
The category of the functions.

Exceptions

Exception Type | Condition
ArgumentNullException | prefix is a null reference (Nothing in Visual Basic). -or- category is a null reference (Nothing in Visual Basic).
ArgumentOutOfRangeException | prefix is a zero-length String. -or- category is a zero-length String.

See Also

FunctionSetAttribute Class | NAnt.Core.Attributes Namespace


FunctionSetAttribute Properties

The properties of the FunctionSetAttribute class are listed below. For a complete list of FunctionSetAttribute class members, see the FunctionSetAttribute Members topic.

Public Instance Properties

Category | Gets or sets the category of the function set.
Prefix | Gets or sets the prefix of all functions in this function set.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

FunctionSetAttribute Class | NAnt.Core.Attributes Namespace


Category Property

NAnt SDK Documentation - v0.91

FunctionSetAttribute.Category Property

Gets or sets the category of the function set.

[Visual Basic]
Public Property Category As String
[C#]
public string Category {get; set;}

Property Value

The name of the category of the function set.

Remarks

This will be displayed in the user docs.

See Also

FunctionSetAttribute Class | NAnt.Core.Attributes Namespace


Prefix Property

NAnt SDK Documentation - v0.91

FunctionSetAttribute.Prefix Property

Gets or sets the prefix of all functions in this function set.

[Visual Basic]
Public Property Prefix As String
[C#]
public string Prefix {get; set;}

Property Value

The prefix of the functions in this function set.

See Also

FunctionSetAttribute Class | NAnt.Core.Attributes Namespace


Int32ValidatorAttribute Class

Indicates that property should be able to be converted into a Int32 within the given range.

For a list of all members of this type, see Int32ValidatorAttribute Members.

System.Object
System.Attribute
NAnt.Core.Attributes.ValidatorAttribute
NAnt.Core.Attributes.Int32ValidatorAttribute

[Visual Basic]
<AttributeUsage(Inherited:=True, ValidOn:=AttributeTargets.Property, AllowMultiple:=False)>
NotInheritable Public Class Int32ValidatorAttribute
Inherits ValidatorAttribute
[C#]
[AttributeUsage(Inherited=True, ValidOn=AttributeTargets.Property, AllowMultiple=False)]
public sealed class Int32ValidatorAttribute : ValidatorAttribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Attributes

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

Int32ValidatorAttribute Members | NAnt.Core.Attributes Namespace


Int32ValidatorAttribute Members

Int32ValidatorAttribute overview

Public Instance Constructors

Int32ValidatorAttribute Overloaded. Initializes a new instance of the Int32ValidatorAttribute class.

Public Instance Properties

Base | The base of the number to validate, which must be 2, 8, 10, or 16.
MaxValue | Gets or sets the maximum value.
MinValue | Gets or sets the minimum value.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Checks whether the specified value can be converted to an Int32 and whether the value lies within the range defined by the MinValue and MaxValue properties.

See Also

Int32ValidatorAttribute Class | NAnt.Core.Attributes Namespace


Int32ValidatorAttribute Constructor

Initializes a new instance of the Int32ValidatorAttribute class.

Overload List

Initializes a new instance of the Int32ValidatorAttribute class.

public Int32ValidatorAttribute();

Initializes a new instance of the Int32ValidatorAttribute class with the specied minimum and maximum values.

public Int32ValidatorAttribute(int,int);

See Also

Int32ValidatorAttribute Class | NAnt.Core.Attributes Namespace


Int32ValidatorAttribute Constructor ()

Initializes a new instance of the Int32ValidatorAttribute class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Int32ValidatorAttribute();

See Also

Int32ValidatorAttribute Class | NAnt.Core.Attributes Namespace | Int32ValidatorAttribute Constructor Overload List


Int32ValidatorAttribute Constructor (Int32, Int32)

Initializes a new instance of the Int32ValidatorAttribute class with the specied minimum and maximum values.

[Visual Basic]
Overloads Public Sub New( _
ByVal minValue As Integer, _
ByVal maxValue As Integer _
)
[C#]
public Int32ValidatorAttribute(
int minValue,
int maxValue
);

Parameters

minValue
The minimum value.
maxValue
The maximum value.

See Also

Int32ValidatorAttribute Class | NAnt.Core.Attributes Namespace | Int32ValidatorAttribute Constructor Overload List


Int32ValidatorAttribute Properties

The properties of the Int32ValidatorAttribute class are listed below. For a complete list of Int32ValidatorAttribute class members, see the Int32ValidatorAttribute Members topic.

Public Instance Properties

Base | The base of the number to validate, which must be 2, 8, 10, or 16.
MaxValue | Gets or sets the maximum value.
MinValue | Gets or sets the minimum value.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

Int32ValidatorAttribute Class | NAnt.Core.Attributes Namespace


Base Property

NAnt SDK Documentation - v0.91

Int32ValidatorAttribute.Base Property

The base of the number to validate, which must be 2, 8, 10, or 16.

[Visual Basic]
Public Property Base As Integer
[C#]
public int Base {get; set;}

Property Value

The base of the number to validate.

Remarks

The default is 10.

See Also

Int32ValidatorAttribute Class | NAnt.Core.Attributes Namespace


MaxValue Property

NAnt SDK Documentation - v0.91

Int32ValidatorAttribute.MaxValue Property

Gets or sets the maximum value.

[Visual Basic]
Public Property MaxValue As Integer
[C#]
public int MaxValue {get; set;}

Property Value

The maximum value. The default is MaxValue.

See Also

Int32ValidatorAttribute Class | NAnt.Core.Attributes Namespace


MinValue Property

NAnt SDK Documentation - v0.91

Int32ValidatorAttribute.MinValue Property

Gets or sets the minimum value.

[Visual Basic]
Public Property MinValue As Integer
[C#]
public int MinValue {get; set;}

Property Value

The minimum value. The default is MinValue.

See Also

Int32ValidatorAttribute Class | NAnt.Core.Attributes Namespace


Int32ValidatorAttribute Methods

The methods of the Int32ValidatorAttribute class are listed below. For a complete list of Int32ValidatorAttribute class members, see the Int32ValidatorAttribute Members topic.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Checks whether the specified value can be converted to an Int32 and whether the value lies within the range defined by the MinValue and MaxValue properties.

See Also

Int32ValidatorAttribute Class | NAnt.Core.Attributes Namespace


Int32ValidatorAttribute.Validate Method

Checks whether the specified value can be converted to an Int32 and whether the value lies within the range defined by the MinValue and MaxValue properties.

[Visual Basic]
Overrides Public Sub Validate( _
ByVal value As Object _
)
[C#]
public override void Validate(
object value
);

Parameters

value
The value to be checked.

Exceptions

Exception Type | Condition
ValidationException | value cannot be converted to an Int32. -or- value is not in the range defined by MinValue and MaxValue.

See Also

Int32ValidatorAttribute Class | NAnt.Core.Attributes Namespace


LocationType Enumeration

Defines possible locations in which a task executable can be located.

[Visual Basic]
<Serializable>
Public Enum LocationType
[C#]
[Serializable]
public enum LocationType

Members

Member Name | Description
FrameworkDir | Locates the task executable in the current Framework directory.
FrameworkSdkDir | Locates the task executable in the current Framework SDK directory.

Requirements

Namespace: NAnt.Core.Attributes

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

NAnt.Core.Attributes Namespace


ProgramLocationAttribute Class

Indicates the location that a task executable can be located in.

For a list of all members of this type, see ProgramLocationAttribute Members.

System.Object
System.Attribute
NAnt.Core.Attributes.ProgramLocationAttribute

[Visual Basic]
<AttributeUsage(Inherited:=False, ValidOn:=AttributeTargets.Class, AllowMultiple:=False)>
Public Class ProgramLocationAttribute
Inherits Attribute
[C#]
[AttributeUsage(Inherited=False, ValidOn=AttributeTargets.Class, AllowMultiple=False)]
public class ProgramLocationAttribute : Attribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

When applied to a task deriving from ExternalProgramBase, the program to execute will first be searched for in the designated location.

If the program does not exist in that location, and the file name is not an absolute path then the list of tool paths of the current target framework will be searched (in the order in which they are defined in the NAnt configuration file).

Requirements

Namespace: NAnt.Core.Attributes

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ProgramLocationAttribute Members | NAnt.Core.Attributes Namespace


ProgramLocationAttribute Members

ProgramLocationAttribute overview

Public Instance Constructors

ProgramLocationAttribute Constructor Initializes a new instance of the ProgramLocationAttribute with the specified location.

Public Instance Properties

LocationType | Gets or sets the LocationType of the task.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProgramLocationAttribute Class | NAnt.Core.Attributes Namespace


ProgramLocationAttribute Constructor

Initializes a new instance of the ProgramLocationAttribute with the specified location.

[Visual Basic]
Public Sub New( _
ByVal type As LocationType _
)
[C#]
public ProgramLocationAttribute(
LocationType type
);

Parameters

type

See Also

ProgramLocationAttribute Class | NAnt.Core.Attributes Namespace


ProgramLocationAttribute Properties

The properties of the ProgramLocationAttribute class are listed below. For a complete list of ProgramLocationAttribute class members, see the ProgramLocationAttribute Members topic.

Public Instance Properties

LocationType | Gets or sets the LocationType of the task.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

ProgramLocationAttribute Class | NAnt.Core.Attributes Namespace


LocationType Property

NAnt SDK Documentation - v0.91

ProgramLocationAttribute.LocationType Property

Gets or sets the LocationType of the task.

[Visual Basic]
Public Property LocationType As LocationType
[C#]
public LocationType LocationType {get; set;}

Property Value

The location type of the task to which the attribute is assigned.

See Also

ProgramLocationAttribute Class | NAnt.Core.Attributes Namespace


StringValidatorAttribute Class

Used to indicate whether a String property should allow an empty string value or not.

For a list of all members of this type, see StringValidatorAttribute Members.

System.Object
System.Attribute
NAnt.Core.Attributes.ValidatorAttribute
NAnt.Core.Attributes.StringValidatorAttribute

[Visual Basic]
<AttributeUsage(Inherited:=True, ValidOn:=AttributeTargets.Property, AllowMultiple:=False)>
NotInheritable Public Class StringValidatorAttribute
Inherits ValidatorAttribute
[C#]
[AttributeUsage(Inherited=True, ValidOn=AttributeTargets.Property, AllowMultiple=False)]
public sealed class StringValidatorAttribute : ValidatorAttribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Attributes

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

StringValidatorAttribute Members | NAnt.Core.Attributes Namespace


StringValidatorAttribute Members

StringValidatorAttribute overview

Public Instance Constructors

StringValidatorAttribute Constructor Initializes a new instance of the StringValidatorAttribute class.

Public Instance Properties

AllowEmpty | Gets or sets a value indicating whether an empty string or a null reference (Nothing in Visual Basic) should be a considered a valid value.
Expression | Gets or sets a regular expression. The string will be validated to determine if it matches the expression.
ExpressionErrorMessage | An optional error message that can be used to better describe the regular expression error.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Checks if the specified value adheres to the rules defined by the properties of the StringValidatorAttribute.

See Also

StringValidatorAttribute Class | NAnt.Core.Attributes Namespace


StringValidatorAttribute Constructor

Initializes a new instance of the StringValidatorAttribute class.

[Visual Basic]
Public Sub New()
[C#]
public StringValidatorAttribute();

See Also

StringValidatorAttribute Class | NAnt.Core.Attributes Namespace


StringValidatorAttribute Properties

The properties of the StringValidatorAttribute class are listed below. For a complete list of StringValidatorAttribute class members, see the StringValidatorAttribute Members topic.

Public Instance Properties

AllowEmpty | Gets or sets a value indicating whether an empty string or a null reference (Nothing in Visual Basic) should be a considered a valid value.
Expression | Gets or sets a regular expression. The string will be validated to determine if it matches the expression.
ExpressionErrorMessage | An optional error message that can be used to better describe the regular expression error.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

StringValidatorAttribute Class | NAnt.Core.Attributes Namespace


AllowEmpty Property

NAnt SDK Documentation - v0.91

StringValidatorAttribute.AllowEmpty Property

Gets or sets a value indicating whether an empty string or a null reference (Nothing in Visual Basic) should be a considered a valid value.

[Visual Basic]
Public Property AllowEmpty As Boolean
[C#]
public bool AllowEmpty {get; set;}

Property Value

true if an empty string or a null reference (Nothing in Visual Basic) should be considered a valid value; otherwise, false. The default is true.

See Also

StringValidatorAttribute Class | NAnt.Core.Attributes Namespace


Expression Property

NAnt SDK Documentation - v0.91

StringValidatorAttribute.Expression Property

Gets or sets a regular expression. The string will be validated to determine if it matches the expression.

[Visual Basic]
Public Property Expression As String
[C#]
public string Expression {get; set;}

Property Value

RegularExpressions

See Also

StringValidatorAttribute Class | NAnt.Core.Attributes Namespace


ExpressionErrorMessage Property

NAnt SDK Documentation - v0.91

StringValidatorAttribute.ExpressionErrorMessage Property

An optional error message that can be used to better describe the regular expression error.

[Visual Basic]
Public Property ExpressionErrorMessage As String
[C#]
public string ExpressionErrorMessage {get; set;}

See Also

StringValidatorAttribute Class | NAnt.Core.Attributes Namespace


StringValidatorAttribute Methods

The methods of the StringValidatorAttribute class are listed below. For a complete list of StringValidatorAttribute class members, see the StringValidatorAttribute Members topic.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Checks if the specified value adheres to the rules defined by the properties of the StringValidatorAttribute.

See Also

StringValidatorAttribute Class | NAnt.Core.Attributes Namespace


StringValidatorAttribute.Validate Method

Checks if the specified value adheres to the rules defined by the properties of the StringValidatorAttribute.

[Visual Basic]
Overrides Public Sub Validate( _
ByVal value As Object _
)
[C#]
public override void Validate(
object value
);

Parameters

value
The value to be checked.

Exceptions

Exception Type | Condition
ValidationException | value is an empty string value and AllowEmpty is set to false.

See Also

StringValidatorAttribute Class | NAnt.Core.Attributes Namespace


TaskAttributeAttribute Class

Indicates that property should be treated as a XML attribute for the task.

For a list of all members of this type, see TaskAttributeAttribute Members.

System.Object
System.Attribute
NAnt.Core.Attributes.BuildAttributeAttribute
NAnt.Core.Attributes.TaskAttributeAttribute

[Visual Basic]
<AttributeUsage(Inherited:=True, ValidOn:=AttributeTargets.Property, AllowMultiple:=False)>
NotInheritable Public Class TaskAttributeAttribute
Inherits BuildAttributeAttribute
[C#]
[AttributeUsage(Inherited=True, ValidOn=AttributeTargets.Property, AllowMultiple=False)]
public sealed class TaskAttributeAttribute : BuildAttributeAttribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Examples of how to specify task attributes

            // task XmlType default is string
            [TaskAttribute("out", Required=true)]
            string _out = null; // assign default value here
                        [TaskAttribute("optimize")]
            [BooleanValidator()]
            // during ExecuteTask you can safely use Convert.ToBoolean(_optimize)
            string _optimize = Boolean.FalseString;
                        [TaskAttribute("warnlevel")]
            [Int32Validator(0,4)] // limit values to 0-4
            // during ExecuteTask you can safely use Convert.ToInt32(_optimize)
            string _warnlevel = "0";
                        [BuildElement("sources")]
            FileSet _sources = new FileSet();
NOTE: Attribute values must be of type of string if you want to be able to have macros. The field stores the exact value during Initialize. Just before ExecuteTask is called NAnt will expand all the macros with the current values.

Requirements

Namespace: NAnt.Core.Attributes

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

TaskAttributeAttribute Members | NAnt.Core.Attributes Namespace


TaskAttributeAttribute Members

TaskAttributeAttribute overview

Public Instance Constructors

TaskAttributeAttribute Constructor Initializes a new instance of the TaskAttributeAttribute with the specified attribute name.

Public Instance Properties

ExpandProperties (inherited from BuildAttributeAttribute) | Gets or sets a value indicating whether property references should be expanded.
Name (inherited from BuildAttributeAttribute) | Gets or sets the name of the XML attribute.
ProcessXml (inherited from BuildAttributeAttribute) | Used to specify how this attribute will be handled as the XML is parsed and given to the element.
Required (inherited from BuildAttributeAttribute) | Gets or sets a value indicating whether the attribute is required.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TaskAttributeAttribute Class | NAnt.Core.Attributes Namespace


TaskAttributeAttribute Constructor

Initializes a new instance of the TaskAttributeAttribute with the specified attribute name.

[Visual Basic]
Public Sub New( _
ByVal name As String _
)
[C#]
public TaskAttributeAttribute(
string name
);

Parameters

name
The name of the task attribute.

Exceptions

Exception Type | Condition
ArgumentNullException | name is a a null reference (Nothing in Visual Basic).
ArgumentOutOfRangeException | name is a zero-length String.

See Also

TaskAttributeAttribute Class | NAnt.Core.Attributes Namespace


TaskNameAttribute Class

Indicates that class should be treated as a task.

For a list of all members of this type, see TaskNameAttribute Members.

System.Object
System.Attribute
NAnt.Core.Attributes.ElementNameAttribute
NAnt.Core.Attributes.TaskNameAttribute

[Visual Basic]
<AttributeUsage(Inherited:=False, ValidOn:=AttributeTargets.Class, AllowMultiple:=False)>
NotInheritable Public Class TaskNameAttribute
Inherits ElementNameAttribute
[C#]
[AttributeUsage(Inherited=False, ValidOn=AttributeTargets.Class, AllowMultiple=False)]
public sealed class TaskNameAttribute : ElementNameAttribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Attach this attribute to a subclass of Task to have NAnt be able to recognize it. The name should be short but must not confict with any other task already in use.

Requirements

Namespace: NAnt.Core.Attributes

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

TaskNameAttribute Members | NAnt.Core.Attributes Namespace


TaskNameAttribute Members

TaskNameAttribute overview

Public Instance Constructors

TaskNameAttribute Constructor Initializes a new instance of the TaskNameAttribute with the specified name.

Public Instance Properties

Name (inherited from ElementNameAttribute) | Gets or sets the name of the element.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TaskNameAttribute Class | NAnt.Core.Attributes Namespace


TaskNameAttribute Constructor

Initializes a new instance of the TaskNameAttribute with the specified name.

[Visual Basic]
Public Sub New( _
ByVal name As String _
)
[C#]
public TaskNameAttribute(
string name
);

Parameters

name
The name of the task.

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing in Visual Basic).
ArgumentOutOfRangeException | name is a zero-length String.

See Also

TaskNameAttribute Class | NAnt.Core.Attributes Namespace


ValidatorAttribute Class

Base class for all validator attributes.

For a list of all members of this type, see ValidatorAttribute Members.

System.Object
System.Attribute
NAnt.Core.Attributes.ValidatorAttribute
NAnt.Core.Attributes.BooleanValidatorAttribute
NAnt.Core.Attributes.DateTimeValidatorAttribute
NAnt.Core.Attributes.Int32ValidatorAttribute
NAnt.Core.Attributes.StringValidatorAttribute

[Visual Basic]
<AttributeUsage(ValidOn:=AttributeTargets.Property, AllowMultiple:=False, Inherited:=True)>
MustInherit Public Class ValidatorAttribute
Inherits Attribute
[C#]
[AttributeUsage(ValidOn=AttributeTargets.Property, AllowMultiple=False, Inherited=True)]
public abstract class ValidatorAttribute : Attribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Attributes

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ValidatorAttribute Members | NAnt.Core.Attributes Namespace


ValidatorAttribute Members

ValidatorAttribute overview

Public Instance Properties

TypeId (inherited from Attribute) When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Validates the specified value.

Protected Instance Constructors

ValidatorAttribute Constructor Initializes a new instance of the ValidatorAttribute class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValidatorAttribute Class | NAnt.Core.Attributes Namespace


ValidatorAttribute Constructor

Initializes a new instance of the ValidatorAttribute class.

[Visual Basic]
Protected Sub New()
[C#]
protected ValidatorAttribute();

See Also

ValidatorAttribute Class | NAnt.Core.Attributes Namespace


ValidatorAttribute Methods

The methods of the ValidatorAttribute class are listed below. For a complete list of ValidatorAttribute class members, see the ValidatorAttribute Members topic.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Validates the specified value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValidatorAttribute Class | NAnt.Core.Attributes Namespace


ValidatorAttribute.Validate Method

Validates the specified value.

[Visual Basic]
MustOverride Public Sub Validate( _
ByVal value As Object _
)
[C#]
public abstract void Validate(
object value
);

Parameters

value
The value to be validated.

Exceptions

Exception Type | Condition
ValidationException | The validation fails.

See Also

ValidatorAttribute Class | NAnt.Core.Attributes Namespace


NAnt.Core.Extensibility

NAnt SDK Documentation - v0.91

NAnt.Core.Extensibility Namespace

Namespace hierarchy

Classes

Class | Description
ExtensionBuilder |
PluginConsumerAttribute |

Interfaces

Interface | Description
IPlugin |
IPluginConsumer |


ExtensionBuilder Class

For a list of all members of this type, see ExtensionBuilder Members.

System.Object
NAnt.Core.Extensibility.ExtensionBuilder
NAnt.Core.DataTypeBaseBuilder
NAnt.Core.Filters.FilterBuilder
NAnt.Core.TaskBuilder

[Visual Basic]
MustInherit Public Class ExtensionBuilder
[C#]
public abstract class ExtensionBuilder

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Extensibility

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ExtensionBuilder Members | NAnt.Core.Extensibility Namespace


ExtensionBuilder Members

ExtensionBuilder overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ExtensionBuilder Constructor Initializes a instance of the ExtensionBuilder class for an extension in a given Assembly.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Properties

Assembly Gets the Assembly from which the extension will be created.

See Also

ExtensionBuilder Class | NAnt.Core.Extensibility Namespace


ExtensionBuilder Constructor

Initializes a instance of the ExtensionBuilder class for an extension in a given Assembly.

[Visual Basic]
Overloads Protected Sub New( _
ByVal assembly As Assembly _
)
[C#]
protected ExtensionBuilder(
Assembly assembly
);

Parameters

assembly
The Assembly in which the extension is found.

Exceptions

Exception Type | Condition
ArgumentNullException | assembly is a null reference (Nothing in Visual Basic).

See Also

ExtensionBuilder Class | NAnt.Core.Extensibility Namespace


ExtensionBuilder Properties

The properties of the ExtensionBuilder class are listed below. For a complete list of ExtensionBuilder class members, see the ExtensionBuilder Members topic.

Protected Internal Instance Properties

Assembly Gets the Assembly from which the extension will be created.

See Also

ExtensionBuilder Class | NAnt.Core.Extensibility Namespace


Assembly Property

NAnt SDK Documentation - v0.91

ExtensionBuilder.Assembly Property

Gets the Assembly from which the extension will be created.

[Visual Basic]
Protected Friend ReadOnly Property Assembly As Assembly
[C#]
protected internal System.Reflection.Assembly Assembly {get;}

Property Value

The Assembly containing the extension.

See Also

ExtensionBuilder Class | NAnt.Core.Extensibility Namespace


IPlugin Interface

NAnt.Core.Extensibility.IPlugin
NAnt.VSNet.Extensibility.IProjectBuildProvider
NAnt.VSNet.Extensibility.ISolutionBuildProvider

[Visual Basic]
Public Interface IPlugin
[C#]
public interface IPlugin

Requirements

Namespace: NAnt.Core.Extensibility

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

NAnt.Core.Extensibility Namespace


IPluginConsumer Interface

For a list of all members of this type, see IPluginConsumer Members.

[Visual Basic]
Public Interface IPluginConsumer
[C#]
public interface IPluginConsumer

Types that implement IPluginConsumer

Type | Description
SolutionTask | Compiles VS.NET solutions (or sets of projects), automatically determining project dependencies from inter-project references.

Requirements

Namespace: NAnt.Core.Extensibility

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

IPluginConsumer Members | NAnt.Core.Extensibility Namespace


IPluginConsumer Members

IPluginConsumer overview

Public Instance Methods

ConsumePlugin

See Also

IPluginConsumer Interface | NAnt.Core.Extensibility Namespace


IPluginConsumer Methods

The methods of the IPluginConsumer interface are listed below. For a complete list of IPluginConsumer interface members, see the IPluginConsumer Members topic.

Public Instance Methods

ConsumePlugin

See Also

IPluginConsumer Interface | NAnt.Core.Extensibility Namespace


IPluginConsumer.ConsumePlugin Method

[Visual Basic]
Sub ConsumePlugin( _
ByVal type As IPlugin _
)
[C#]
void ConsumePlugin(
IPlugin type
);

See Also

IPluginConsumer Interface | NAnt.Core.Extensibility Namespace


PluginConsumerAttribute Class

For a list of all members of this type, see PluginConsumerAttribute Members.

System.Object
System.Attribute
NAnt.Core.Extensibility.PluginConsumerAttribute

[Visual Basic]
<AttributeUsage(ValidOn:=AttributeTargets.Class, AllowMultiple:=True, Inherited:=False)>
NotInheritable Public Class PluginConsumerAttribute
Inherits Attribute
[C#]
[AttributeUsage(ValidOn=AttributeTargets.Class, AllowMultiple=True, Inherited=False)]
public sealed class PluginConsumerAttribute : Attribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Extensibility

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

PluginConsumerAttribute Members | NAnt.Core.Extensibility Namespace


PluginConsumerAttribute Members

PluginConsumerAttribute overview

Public Instance Constructors

PluginConsumerAttribute Constructor Initializes a new instance of the PluginConsumerAttribute with the specified type.

Public Instance Properties

PluginType |
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PluginConsumerAttribute Class | NAnt.Core.Extensibility Namespace


PluginConsumerAttribute Constructor

Initializes a new instance of the PluginConsumerAttribute with the specified type.

[Visual Basic]
Public Sub New( _
ByVal type As Type _
)
[C#]
public PluginConsumerAttribute(
Type type
);

Parameters

type
The type of the IPlugin to consume.

Exceptions

Exception Type | Condition
ArgumentNullException | type is a null reference (Nothing in Visual Basic).

See Also

PluginConsumerAttribute Class | NAnt.Core.Extensibility Namespace


PluginConsumerAttribute Properties

The properties of the PluginConsumerAttribute class are listed below. For a complete list of PluginConsumerAttribute class members, see the PluginConsumerAttribute Members topic.

Public Instance Properties

PluginType |
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

PluginConsumerAttribute Class | NAnt.Core.Extensibility Namespace


PluginType Property

NAnt SDK Documentation - v0.91

PluginConsumerAttribute.PluginType Property

[Visual Basic]
Public ReadOnly Property PluginType As Type
[C#]
public System.Type PluginType {get;}

See Also

PluginConsumerAttribute Class | NAnt.Core.Extensibility Namespace


NAnt.Core.Filters

NAnt SDK Documentation - v0.91

NAnt.Core.Filters Namespace

Namespace hierarchy

Classes

Class | Description
ChainableReader | Functions as a chainable TextReader
ExpandProperties | Parses NAnt properties and expressions
Filter | Allows a file's content to be modified while performing an operation.
FilterBuilder |
FilterBuilderCollection | Contains a strongly typed collection of FilterBuilder objects.
FilterBuilderEnumerator | Enumerates the FilterBuilder elements of a FilterBuilderCollection.
FilterChain | Represent a chain of NAnt filters that can be applied to a Task.
FilterChain.FilterChainConfigurator | Configurator that initializes filters in the order in which they've been specified in the build file.
FilterCollection | Contains a collection of Filter elements.
FilterEnumerator | Enumerates the Filter elements of a FilterCollection.
ReplaceString | Replaces all occurrences of a given string in the original input with user-supplied replacement string.
ReplaceTokens | Replaces tokens in the original input with user-supplied values.
TabsToSpaces | Converts tabs to spaces.


ChainableReader Class

Functions as a chainable TextReader

For a list of all members of this type, see ChainableReader Members.

System.Object
NAnt.Core.Element
NAnt.Core.Filters.ChainableReader
NAnt.Core.Filters.Filter

[Visual Basic]
MustInherit Public Class ChainableReader
Inherits Element
Implements IDisposable
[C#]
public abstract class ChainableReader : Element, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Implements a abstraction over a TextReader that allows the class to represent either a TextReader or another ChainableReader to which it is chained. By passing a ChainableReader as a constructor paramater it is possiable to chain many ChainableReaders together. The last ChainableReader in the chain must be based on a TextReader.

Requirements

Namespace: NAnt.Core.Filters

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ChainableReader Members | NAnt.Core.Filters Namespace


ChainableReader Members

ChainableReader overview

Public Instance Properties

Base | Gets a value indicating if the reader is backed by a stream in the chain.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.

Public Instance Methods

Chain | Overloaded. Makes it so all calls to Read and Peek are passed the ChainableReader passed as a parameter.
Close | Closes the reader.
Dispose | Calls close and supresses the finalizer for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Peek | Forwards Peek calls to the TextReader or ChainableReader passed in the corresponding constructor.
Read | Forwards Read calls to the TextReader or ChainableReader passed in the corresponding constructor.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ChainableReader Constructor Initializes a new instance of the ChainableReader class.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChainableReader Class | NAnt.Core.Filters Namespace


ChainableReader Constructor

Initializes a new instance of the ChainableReader class.

[Visual Basic]
Protected Sub New()
[C#]
protected ChainableReader();

See Also

ChainableReader Class | NAnt.Core.Filters Namespace


ChainableReader Properties

The properties of the ChainableReader class are listed below. For a complete list of ChainableReader class members, see the ChainableReader Members topic.

Public Instance Properties

Base | Gets a value indicating if the reader is backed by a stream in the chain.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

ChainableReader Class | NAnt.Core.Filters Namespace


Base Property

NAnt SDK Documentation - v0.91

ChainableReader.Base Property

Gets a value indicating if the reader is backed by a stream in the chain.

[Visual Basic]
Public ReadOnly Property Base As Boolean
[C#]
public bool Base {get;}

Property Value

true if the reader is backed by a stream; otherwise, false.

See Also

ChainableReader Class | NAnt.Core.Filters Namespace


ChainableReader Methods

The methods of the ChainableReader class are listed below. For a complete list of ChainableReader class members, see the ChainableReader Members topic.

Public Instance Methods

Chain | Overloaded. Makes it so all calls to Read and Peek are passed the ChainableReader passed as a parameter.
Close | Closes the reader.
Dispose | Calls close and supresses the finalizer for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Peek | Forwards Peek calls to the TextReader or ChainableReader passed in the corresponding constructor.
Read | Forwards Read calls to the TextReader or ChainableReader passed in the corresponding constructor.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChainableReader Class | NAnt.Core.Filters Namespace


Chain Method

NAnt SDK Documentation - v0.91

ChainableReader.Chain Method

Makes it so all calls to Read and Peek are passed the ChainableReader passed as a parameter.

Overload List

Makes it so all calls to Read and Peek are passed the ChainableReader passed as a parameter.

public virtual void Chain(ChainableReader);

Makes it so all calls to Read and Peek are passed the TextReader passed as a parameter.

public virtual void Chain(TextReader);

See Also

ChainableReader Class | NAnt.Core.Filters Namespace


ChainableReader.Chain Method (ChainableReader)

Makes it so all calls to Read and Peek are passed the ChainableReader passed as a parameter.

[Visual Basic]
Overridable Overloads Public Sub Chain( _
ByVal parentChainedReader As ChainableReader _
)
[C#]
public virtual void Chain(
ChainableReader parentChainedReader
);

Parameters

parentChainedReader
ChainableReader to forward calls to

See Also

ChainableReader Class | NAnt.Core.Filters Namespace | ChainableReader.Chain Overload List


ChainableReader.Chain Method (TextReader)

Makes it so all calls to Read and Peek are passed the TextReader passed as a parameter.

[Visual Basic]
Overridable Overloads Public Sub Chain( _
ByVal baseReader As TextReader _
)
[C#]
public virtual void Chain(
TextReader baseReader
);

Parameters

baseReader
TextReader to forward calls to

See Also

ChainableReader Class | NAnt.Core.Filters Namespace | ChainableReader.Chain Overload List


ChainableReader.Close Method

Closes the reader.

[Visual Basic]
Overridable Public Sub Close()
[C#]
public virtual void Close();

See Also

ChainableReader Class | NAnt.Core.Filters Namespace


ChainableReader.Dispose Method

Calls close and supresses the finalizer for the object.

[Visual Basic]
NotOverridable Public Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

ChainableReader Class | NAnt.Core.Filters Namespace


ChainableReader.Peek Method

Forwards Peek calls to the TextReader or ChainableReader passed in the corresponding constructor.

[Visual Basic]
Overridable Public Function Peek() As Integer
[C#]
public virtual int Peek();

Return Value

Character or -1 if end of stream

See Also

ChainableReader Class | NAnt.Core.Filters Namespace


ChainableReader.Read Method

Forwards Read calls to the TextReader or ChainableReader passed in the corresponding constructor.

[Visual Basic]
Overridable Public Function Read() As Integer
[C#]
public virtual int Read();

Return Value

Character or -1 if end of stream.

See Also

ChainableReader Class | NAnt.Core.Filters Namespace


ExpandProperties Class

Parses NAnt properties and expressions

For a list of all members of this type, see ExpandProperties Members.

System.Object
NAnt.Core.Element
NAnt.Core.Filters.ChainableReader
NAnt.Core.Filters.Filter
NAnt.Core.Filters.ExpandProperties

[Visual Basic]
<ElementName(Name:="expandproperties")>
Public Class ExpandProperties
Inherits Filter
[C#]
[ElementName(Name="expandproperties")]
public class ExpandProperties : Filter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This filter parses any NAnt properties or expressions found in its input, inlining their values in its output.

Note: Due to limitations on buffering, expressions longer than 2048 characters are not guaranteed to be expanded.

Filters are intended to be used as a element of a FilterChain.

Example

Replace all properties with their corresponding values.

<expandproperties />

Requirements

Namespace: NAnt.Core.Filters

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ExpandProperties Members | NAnt.Core.Filters Namespace


ExpandProperties Members

ExpandProperties overview

Public Instance Constructors

ExpandProperties Constructor Initializes a new instance of the ExpandProperties class.

Public Instance Properties

Base (inherited from ChainableReader) | Gets a value indicating if the reader is backed by a stream in the chain.
IfDefined (inherited from Filter) | If true then the filter will be used; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined (inherited from Filter) | Opposite of IfDefined. If false then the filter will be executed; otherwise, skipped. The default is false.

Public Instance Methods

Chain (inherited from ChainableReader) | Overloaded. Makes it so all calls to Read and Peek are passed the ChainableReader passed as a parameter.
Close (inherited from ChainableReader) | Closes the reader.
Dispose (inherited from ChainableReader) | Calls close and supresses the finalizer for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeFilter | Called after construction and after properties are set. Allows for filter initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Peek | Reads the next character applying the filter logic without advancing the current position in the stream.
Read | Reads the next character applying the filter logic.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpandProperties Class | NAnt.Core.Filters Namespace


ExpandProperties Constructor

Initializes a new instance of the ExpandProperties class.

[Visual Basic]
Public Sub New()
[C#]
public ExpandProperties();

See Also

ExpandProperties Class | NAnt.Core.Filters Namespace


ExpandProperties Methods

The methods of the ExpandProperties class are listed below. For a complete list of ExpandProperties class members, see the ExpandProperties Members topic.

Public Instance Methods

Chain (inherited from ChainableReader) | Overloaded. Makes it so all calls to Read and Peek are passed the ChainableReader passed as a parameter.
Close (inherited from ChainableReader) | Closes the reader.
Dispose (inherited from ChainableReader) | Calls close and supresses the finalizer for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeFilter | Called after construction and after properties are set. Allows for filter initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Peek | Reads the next character applying the filter logic without advancing the current position in the stream.
Read | Reads the next character applying the filter logic.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpandProperties Class | NAnt.Core.Filters Namespace


ExpandProperties.InitializeFilter Method

Called after construction and after properties are set. Allows for filter initialization.

[Visual Basic]
Overrides Public Sub InitializeFilter()
[C#]
public override void InitializeFilter();

See Also

ExpandProperties Class | NAnt.Core.Filters Namespace


ExpandProperties.Peek Method

Reads the next character applying the filter logic without advancing the current position in the stream.

[Visual Basic]
Overrides Public Function Peek() As Integer
[C#]
public override int Peek();

Return Value

Char as an int or -1 if at the end of the stream

See Also

ExpandProperties Class | NAnt.Core.Filters Namespace


ExpandProperties.Read Method

Reads the next character applying the filter logic.

[Visual Basic]
Overrides Public Function Read() As Integer
[C#]
public override int Read();

Return Value

Char as an int or -1 if at the end of the stream

See Also

ExpandProperties Class | NAnt.Core.Filters Namespace


Filter Class

Allows a file's content to be modified while performing an operation.

For a list of all members of this type, see Filter Members.

System.Object
NAnt.Core.Element
NAnt.Core.Filters.ChainableReader
NAnt.Core.Filters.Filter
NAnt.Core.Filters.ExpandProperties
NAnt.Core.Filters.ReplaceString
NAnt.Core.Filters.ReplaceTokens
NAnt.Core.Filters.TabsToSpaces

[Visual Basic]
MustInherit Public Class Filter
Inherits ChainableReader
[C#]
public abstract class Filter : ChainableReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Filters

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

Filter Members | NAnt.Core.Filters Namespace


Filter Members

Filter overview

Public Instance Properties

Base (inherited from ChainableReader) | Gets a value indicating if the reader is backed by a stream in the chain.
IfDefined | If true then the filter will be used; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Opposite of IfDefined. If false then the filter will be executed; otherwise, skipped. The default is false.

Public Instance Methods

Chain (inherited from ChainableReader) | Overloaded. Makes it so all calls to Read and Peek are passed the ChainableReader passed as a parameter.
Close (inherited from ChainableReader) | Closes the reader.
Dispose (inherited from ChainableReader) | Calls close and supresses the finalizer for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeFilter | Called after construction and after properties are set. Allows for filter initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Peek (inherited from ChainableReader) | Forwards Peek calls to the TextReader or ChainableReader passed in the corresponding constructor.
Read (inherited from ChainableReader) | Forwards Read calls to the TextReader or ChainableReader passed in the corresponding constructor.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Filter Constructor Initializes a new instance of the Filter class.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Filter Class | NAnt.Core.Filters Namespace


Filter Constructor

Initializes a new instance of the Filter class.

[Visual Basic]
Protected Sub New()
[C#]
protected Filter();

See Also

Filter Class | NAnt.Core.Filters Namespace


Filter Properties

The properties of the Filter class are listed below. For a complete list of Filter class members, see the Filter Members topic.

Public Instance Properties

Base (inherited from ChainableReader) | Gets a value indicating if the reader is backed by a stream in the chain.
IfDefined | If true then the filter will be used; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Opposite of IfDefined. If false then the filter will be executed; otherwise, skipped. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

Filter Class | NAnt.Core.Filters Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

Filter.IfDefined Property

If true then the filter will be used; otherwise, skipped. The default is true.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, ExpandProperties:=True, Name:="if", ProcessXml:=True)>
Public Property IfDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, ExpandProperties=True, Name="if", ProcessXml=True)]
public bool IfDefined {get; set;}

See Also

Filter Class | NAnt.Core.Filters Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

Filter.UnlessDefined Property

Opposite of IfDefined. If false then the filter will be executed; otherwise, skipped. The default is false.

[Visual Basic]
<TaskAttribute(Required:=False, ExpandProperties:=True, Name:="unless", ProcessXml:=True), _ BooleanValidator>
Public Property UnlessDefined As Boolean
[C#]
[TaskAttribute(Required=False, ExpandProperties=True, Name="unless", ProcessXml=True)]
[BooleanValidator]
public bool UnlessDefined {get; set;}

See Also

Filter Class | NAnt.Core.Filters Namespace


Filter Methods

The methods of the Filter class are listed below. For a complete list of Filter class members, see the Filter Members topic.

Public Instance Methods

Chain (inherited from ChainableReader) | Overloaded. Makes it so all calls to Read and Peek are passed the ChainableReader passed as a parameter.
Close (inherited from ChainableReader) | Closes the reader.
Dispose (inherited from ChainableReader) | Calls close and supresses the finalizer for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeFilter | Called after construction and after properties are set. Allows for filter initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Peek (inherited from ChainableReader) | Forwards Peek calls to the TextReader or ChainableReader passed in the corresponding constructor.
Read (inherited from ChainableReader) | Forwards Read calls to the TextReader or ChainableReader passed in the corresponding constructor.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Filter Class | NAnt.Core.Filters Namespace


Filter.InitializeFilter Method

Called after construction and after properties are set. Allows for filter initialization.

[Visual Basic]
Overridable Public Sub InitializeFilter()
[C#]
public virtual void InitializeFilter();

See Also

Filter Class | NAnt.Core.Filters Namespace


FilterBuilder Class

For a list of all members of this type, see FilterBuilder Members.

System.Object
NAnt.Core.Extensibility.ExtensionBuilder
NAnt.Core.Filters.FilterBuilder

[Visual Basic]
Public Class FilterBuilder
Inherits ExtensionBuilder
[C#]
public class FilterBuilder : ExtensionBuilder

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Filters

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FilterBuilder Members | NAnt.Core.Filters Namespace


FilterBuilder Members

FilterBuilder overview

Public Instance Constructors

FilterBuilder Constructor Creates a new instance of the FilterBuilder class for the specified Filter class in the specified Assembly.

Public Instance Properties

ClassName | Gets the name of the Filter class that can be created using this FilterBuilder.
FilterName | Gets the name of the filter which the FilterBuilder can create.

Public Instance Methods

CreateFilter |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Properties

Assembly (inherited from ExtensionBuilder) Gets the Assembly from which the extension will be created.

See Also

FilterBuilder Class | NAnt.Core.Filters Namespace


FilterBuilder Constructor

Creates a new instance of the FilterBuilder class for the specified Filter class in the specified Assembly.

[Visual Basic]
Overloads Public Sub New( _
ByVal assembly As Assembly, _
ByVal className As String _
)
[C#]
public FilterBuilder(
Assembly assembly,
string className
);

Parameters

assembly
The Assembly containing the Filter.
className
The class representing the Filter.

Remarks

An ExtensionAssembly for the specified Assembly is cached for future use.

See Also

FilterBuilder Class | NAnt.Core.Filters Namespace


FilterBuilder Properties

The properties of the FilterBuilder class are listed below. For a complete list of FilterBuilder class members, see the FilterBuilder Members topic.

Public Instance Properties

ClassName | Gets the name of the Filter class that can be created using this FilterBuilder.
FilterName | Gets the name of the filter which the FilterBuilder can create.

Protected Internal Instance Properties

Assembly (inherited from ExtensionBuilder) Gets the Assembly from which the extension will be created.

See Also

FilterBuilder Class | NAnt.Core.Filters Namespace


ClassName Property

NAnt SDK Documentation - v0.91

FilterBuilder.ClassName Property

Gets the name of the Filter class that can be created using this FilterBuilder.

[Visual Basic]
Public ReadOnly Property ClassName As String
[C#]
public string ClassName {get;}

Property Value

The name of the Filter class that can be created using this FilterBuilder.

See Also

FilterBuilder Class | NAnt.Core.Filters Namespace


FilterName Property

NAnt SDK Documentation - v0.91

FilterBuilder.FilterName Property

Gets the name of the filter which the FilterBuilder can create.

[Visual Basic]
Public ReadOnly Property FilterName As String
[C#]
public string FilterName {get;}

Property Value

The name of the task which the TaskBuilder can create.

See Also

FilterBuilder Class | NAnt.Core.Filters Namespace


FilterBuilder Methods

The methods of the FilterBuilder class are listed below. For a complete list of FilterBuilder class members, see the FilterBuilder Members topic.

Public Instance Methods

CreateFilter |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterBuilder Class | NAnt.Core.Filters Namespace


FilterBuilder.CreateFilter Method

[Visual Basic]
Public Function CreateFilter() As Filter
[C#]
public Filter CreateFilter();

See Also

FilterBuilder Class | NAnt.Core.Filters Namespace


FilterBuilderCollection Class

Contains a strongly typed collection of FilterBuilder objects.

For a list of all members of this type, see FilterBuilderCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.Core.Filters.FilterBuilderCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class FilterBuilderCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class FilterBuilderCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Filters

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FilterBuilderCollection Members | NAnt.Core.Filters Namespace


FilterBuilderCollection Members

FilterBuilderCollection overview

Public Instance Constructors

FilterBuilderCollection Overloaded. Initializes a new instance of the FilterBuilderCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a FilterBuilder to the end of the collection.
AddRange | Overloaded. Adds the elements of a FilterBuilder array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a FilterBuilder is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified FilterBuilder object in the collection.
Insert | Inserts a FilterBuilder into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace


FilterBuilderCollection Constructor

Initializes a new instance of the FilterBuilderCollection class.

Overload List

Initializes a new instance of the FilterBuilderCollection class.

public FilterBuilderCollection();

Initializes a new instance of the FilterBuilderCollection class with the specified array of FilterBuilder instances.

public FilterBuilderCollection(FilterBuilder[]);

Initializes a new instance of the FilterBuilderCollection class with the specified FilterBuilderCollection instance.

public FilterBuilderCollection(FilterBuilderCollection);

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace


FilterBuilderCollection Constructor ()

Initializes a new instance of the FilterBuilderCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FilterBuilderCollection();

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace | FilterBuilderCollection Constructor Overload List


FilterBuilderCollection Constructor (FilterBuilderCollection)

Initializes a new instance of the FilterBuilderCollection class with the specified FilterBuilderCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As FilterBuilderCollection _
)
[C#]
public FilterBuilderCollection(
FilterBuilderCollection value
);

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace | FilterBuilderCollection Constructor Overload List


FilterBuilderCollection Constructor (FilterBuilder[])

Initializes a new instance of the FilterBuilderCollection class with the specified array of FilterBuilder instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As FilterBuilder() _
)
[C#]
public FilterBuilderCollection(
FilterBuilder[] value
);

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace | FilterBuilderCollection Constructor Overload List


FilterBuilderCollection Properties

The properties of the FilterBuilderCollection class are listed below. For a complete list of FilterBuilderCollection class members, see the FilterBuilderCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace


Item Property

NAnt SDK Documentation - v0.91

FilterBuilderCollection.Item Property

Gets or sets the element at the specified index.

Overload List

Gets or sets the element at the specified index.

public FilterBuilder this[int] {get; set;}

Gets the FilterBuilder for the specified task.

public FilterBuilder this[string] {get;}

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace


Item Property (Int32)

NAnt SDK Documentation - v0.91

FilterBuilderCollection.Item Property (Int32)

Gets or sets the element at the specified index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As FilterBuilder
[C#]
public FilterBuilder this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace | FilterBuilderCollection.Item Overload List


Item Property (String)

NAnt SDK Documentation - v0.91

FilterBuilderCollection.Item Property (String)

Gets the FilterBuilder for the specified task.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal filterName As String _
) As FilterBuilder
[C#]
public FilterBuilder this[
string filterName
] {get;}

Parameters

filterName
The name of the filter for which the FilterBuilder should be located in the collection.

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace | FilterBuilderCollection.Item Overload List


FilterBuilderCollection Methods

The methods of the FilterBuilderCollection class are listed below. For a complete list of FilterBuilderCollection class members, see the FilterBuilderCollection Members topic.

Public Instance Methods

Add | Adds a FilterBuilder to the end of the collection.
AddRange | Overloaded. Adds the elements of a FilterBuilder array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a FilterBuilder is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified FilterBuilder object in the collection.
Insert | Inserts a FilterBuilder into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace


FilterBuilderCollection.Add Method

Adds a FilterBuilder to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As FilterBuilder _
) As Integer
[C#]
public int Add(
FilterBuilder item
);

Parameters

item
The FilterBuilder to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace


AddRange Method

NAnt SDK Documentation - v0.91

FilterBuilderCollection.AddRange Method

Adds the elements of a FilterBuilder array to the end of the collection.

Overload List

Adds the elements of a FilterBuilder array to the end of the collection.

public void AddRange(FilterBuilder[]);

Adds the elements of a FilterBuilderCollection to the end of the collection.

public void AddRange(FilterBuilderCollection);

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace


FilterBuilderCollection.AddRange Method (FilterBuilder[])

Adds the elements of a FilterBuilder array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As FilterBuilder() _
)
[C#]
public void AddRange(
FilterBuilder[] items
);

Parameters

items
The array of FilterBuilder elements to be added to the end of the collection.

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace | FilterBuilderCollection.AddRange Overload List


FilterBuilderCollection.AddRange Method (FilterBuilderCollection)

Adds the elements of a FilterBuilderCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As FilterBuilderCollection _
)
[C#]
public void AddRange(
FilterBuilderCollection items
);

Parameters

items
The FilterBuilderCollection to be added to the end of the collection.

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace | FilterBuilderCollection.AddRange Overload List


Contains Method

NAnt SDK Documentation - v0.91

FilterBuilderCollection.Contains Method

Determines whether a FilterBuilder is in the collection.

Overload List

Determines whether a FilterBuilder is in the collection.

public bool Contains(FilterBuilder);

Determines whether a FilterBuilder for the specified task is in the collection.

public bool Contains(string);

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace


FilterBuilderCollection.Contains Method (FilterBuilder)

Determines whether a FilterBuilder is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal item As FilterBuilder _
) As Boolean
[C#]
public bool Contains(
FilterBuilder item
);

Parameters

item
The FilterBuilder to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace | FilterBuilderCollection.Contains Overload List


FilterBuilderCollection.Contains Method (String)

Determines whether a FilterBuilder for the specified task is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal taskName As String _
) As Boolean
[C#]
public bool Contains(
string taskName
);

Parameters

taskName
The name of task for which the FilterBuilder should be located in the collection.

Return Value

true if a FilterBuilder for the specified task is found in the collection; otherwise, false.

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace | FilterBuilderCollection.Contains Overload List


FilterBuilderCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As FilterBuilder(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
FilterBuilder[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace


FilterBuilderCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As FilterBuilderEnumerator
[C#]
new public FilterBuilderEnumerator GetEnumerator();

Return Value

A FilterBuilderEnumerator for the entire collection.

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace


FilterBuilderCollection.IndexOf Method

Retrieves the index of a specified FilterBuilder object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As FilterBuilder _
) As Integer
[C#]
public int IndexOf(
FilterBuilder item
);

Parameters

item
The FilterBuilder object for which the index is returned.

Return Value

The index of the specified FilterBuilder. If the FilterBuilder is not currently a member of the collection, it returns -1.

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace


FilterBuilderCollection.Insert Method

Inserts a FilterBuilder into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As FilterBuilder _
)
[C#]
public void Insert(
int index,
FilterBuilder item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The FilterBuilder to insert.

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace


FilterBuilderCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As FilterBuilder _
)
[C#]
public void Remove(
FilterBuilder item
);

Parameters

item
The FilterBuilder to remove from the collection.

See Also

FilterBuilderCollection Class | NAnt.Core.Filters Namespace


FilterBuilderEnumerator Class

Enumerates the FilterBuilder elements of a FilterBuilderCollection.

For a list of all members of this type, see FilterBuilderEnumerator Members.

System.Object
NAnt.Core.Filters.FilterBuilderEnumerator

[Visual Basic]
Public Class FilterBuilderEnumerator
Implements IEnumerator
[C#]
public class FilterBuilderEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Filters

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FilterBuilderEnumerator Members | NAnt.Core.Filters Namespace


FilterBuilderEnumerator Members

FilterBuilderEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterBuilderEnumerator Class | NAnt.Core.Filters Namespace


FilterBuilderEnumerator Properties

The properties of the FilterBuilderEnumerator class are listed below. For a complete list of FilterBuilderEnumerator class members, see the FilterBuilderEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

FilterBuilderEnumerator Class | NAnt.Core.Filters Namespace


Current Property

NAnt SDK Documentation - v0.91

FilterBuilderEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As FilterBuilder
[C#]
public FilterBuilder Current {get;}

See Also

FilterBuilderEnumerator Class | NAnt.Core.Filters Namespace


FilterBuilderEnumerator Methods

The methods of the FilterBuilderEnumerator class are listed below. For a complete list of FilterBuilderEnumerator class members, see the FilterBuilderEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterBuilderEnumerator Class | NAnt.Core.Filters Namespace


FilterBuilderEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

FilterBuilderEnumerator Class | NAnt.Core.Filters Namespace


FilterBuilderEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

FilterBuilderEnumerator Class | NAnt.Core.Filters Namespace


FilterChain Class

Represent a chain of NAnt filters that can be applied to a Task.

For a list of all members of this type, see FilterChain Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.Core.Filters.FilterChain

[Visual Basic]
<Serializable, _ Serializable, _ ElementName(Name:="filterchain")>
Public Class FilterChain
Inherits DataTypeBase
[C#]
[Serializable]
[Serializable]
[ElementName(Name="filterchain")]
public class FilterChain : DataTypeBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

A FilterChain represents a collection of one or more filters that can be appled to a Task such as the CopyTask. In the case of the CopyTask, the contents of the copied files are filtered through each filter specified in the filter chain. Filtering occurs in the order the filters are specified with filtered output of one filter feeding into another.

:--------:--->:----------:--->:----------: ... :----------:--->:--------:
:.Source.:--->:.Filter 1.:--->:.Filter 2.: ... :.Filter n.:--->:.target.:
:--------:--->:----------:--->:----------: ... :----------:--->:--------:

A list of all filters that come with NAnt is available here.

The following tasks support filtering with a FilterChain:

  • CopyTask
  • MoveTask

Example

Replace all occurrences of @NOW@ with the current date/time and replace tabs with spaces in all copied files.

<property name="NOW" value="${datetime::now()}" />
<copy todir="out">
    <fileset basedir="in">
        <include name="**/*" />
    </fileset>
    <filterchain>
        <replacetokens>
            <token key="NOW" value="${TODAY}" />
        </replacetokens>
        <tabstospaces />
    </filterchain>
</copy>

Requirements

Namespace: NAnt.Core.Filters

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FilterChain Members | NAnt.Core.Filters Namespace


FilterChain Members

FilterChain overview

Public Instance Constructors

FilterChain Constructor Initializes a new instance of the FilterChain class.

Public Instance Properties

CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Filters | The filters to apply.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
InputEncoding | Obsolete. The encoding to assume when filter-copying files. The default is system's current ANSI code page.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from DataTypeBase) | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from DataTypeBase) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterChain Class | NAnt.Core.Filters Namespace


FilterChain Constructor

Initializes a new instance of the FilterChain class.

[Visual Basic]
Public Sub New()
[C#]
public FilterChain();

See Also

FilterChain Class | NAnt.Core.Filters Namespace


FilterChain Properties

The properties of the FilterChain class are listed below. For a complete list of FilterChain class members, see the FilterChain Members topic.

Public Instance Properties

CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Filters | The filters to apply.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
InputEncoding | Obsolete. The encoding to assume when filter-copying files. The default is system's current ANSI code page.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

FilterChain Class | NAnt.Core.Filters Namespace


Filters Property

NAnt SDK Documentation - v0.91

FilterChain.Filters Property

The filters to apply.

[Visual Basic]
<BuildElementArray(ElementType:=NAnt.Core.Filters.Filter, Name:="filter", Required:=False, ProcessXml:=True)>
Public ReadOnly Property Filters As FilterCollection
[C#]
[BuildElementArray(ElementType=NAnt.Core.Filters.Filter, Name="filter", Required=False, ProcessXml=True)]
public FilterCollection Filters {get;}

See Also

FilterChain Class | NAnt.Core.Filters Namespace


InputEncoding Property

NAnt SDK Documentation - v0.91

FilterChain.InputEncoding Property

NOTE: This property is now obsolete.

The input encoding should now be specified on the task.

The encoding to assume when filter-copying files. The default is system's current ANSI code page.

[Visual Basic]
<Obsolete(Message:="The input encoding should now be specified on the task.", IsError:=True), _ TaskAttribute(Name:="encoding", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property InputEncoding As Encoding
[C#]
[Obsolete(Message="The input encoding should now be specified on the task.", IsError=True)]
[TaskAttribute(Name="encoding", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.Text.Encoding InputEncoding {get; set;}

See Also

FilterChain Class | NAnt.Core.Filters Namespace


FilterChain Methods

The methods of the FilterChain class are listed below. For a complete list of FilterChain class members, see the FilterChain Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from DataTypeBase) | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from DataTypeBase) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterChain Class | NAnt.Core.Filters Namespace


FilterChain.InitializeXml Method

Initializes all build attributes and child elements.

[Visual Basic]
Overrides Protected Sub InitializeXml( _
ByVal elementNode As XmlNode, _
ByVal properties As PropertyDictionary, _
ByVal framework As FrameworkInfo _
)
[C#]
protected override void InitializeXml(
XmlNode elementNode,
PropertyDictionary properties,
FrameworkInfo framework
);

Remarks

FilterChain needs to maintain the order in which the filters are specified in the build file.

See Also

FilterChain Class | NAnt.Core.Filters Namespace


FilterChain.FilterChainConfigurator Class

Configurator that initializes filters in the order in which they've been specified in the build file.

For a list of all members of this type, see FilterChain.FilterChainConfigurator Members.

System.Object
NAnt.Core.Element.AttributeConfigurator
NAnt.Core.Filters.FilterChain.FilterChainConfigurator

[Visual Basic]
Public Class FilterChain.FilterChainConfigurator
Inherits AttributeConfigurator
[C#]
public class FilterChain.FilterChainConfigurator : AttributeConfigurator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Filters

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FilterChain.FilterChainConfigurator Members | NAnt.Core.Filters Namespace


FilterChain.FilterChainConfigurator Members

FilterChain.FilterChainConfigurator overview

Public Instance Constructors

FilterChain.FilterChainConfigurator Constructor

Public Instance Properties

Element (inherited from AttributeConfigurator) |
ElementXml (inherited from AttributeConfigurator) |
Location (inherited from AttributeConfigurator) |
Name (inherited from AttributeConfigurator) |
NamespaceManager (inherited from AttributeConfigurator) | Gets the XmlNamespaceManager.
Project (inherited from AttributeConfigurator) |
Properties (inherited from AttributeConfigurator) |
TargetFramework (inherited from AttributeConfigurator) |
UnprocessedAttributes (inherited from AttributeConfigurator) |
UnprocessedChildNodes (inherited from AttributeConfigurator) |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from AttributeConfigurator) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InitializeAttribute (inherited from AttributeConfigurator) |
InitializeBuildElement (inherited from AttributeConfigurator) |
InitializeBuildElementCollection |
InitializeChildElement (inherited from AttributeConfigurator) |
InitializeOrderedChildElements (inherited from AttributeConfigurator) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterChain.FilterChainConfigurator Class | NAnt.Core.Filters Namespace


FilterChain.FilterChainConfigurator Constructor

[Visual Basic]
Public Sub New( _
ByVal element As Element, _
ByVal elementNode As XmlNode, _
ByVal properties As PropertyDictionary, _
ByVal targetFramework As FrameworkInfo _
)
[C#]
public FilterChain.FilterChainConfigurator(
Element element,
XmlNode elementNode,
PropertyDictionary properties,
FrameworkInfo targetFramework
);

See Also

FilterChain.FilterChainConfigurator Class | NAnt.Core.Filters Namespace


FilterChain.FilterChainConfigurator Methods

The methods of the FilterChain.FilterChainConfigurator class are listed below. For a complete list of FilterChain.FilterChainConfigurator class members, see the FilterChain.FilterChainConfigurator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from AttributeConfigurator) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InitializeAttribute (inherited from AttributeConfigurator) |
InitializeBuildElement (inherited from AttributeConfigurator) |
InitializeBuildElementCollection |
InitializeChildElement (inherited from AttributeConfigurator) |
InitializeOrderedChildElements (inherited from AttributeConfigurator) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterChain.FilterChainConfigurator Class | NAnt.Core.Filters Namespace


FilterChain.FilterChainConfigurator.InitializeBuildElementCollection Method

[Visual Basic]
Overrides Protected Function InitializeBuildElementCollection( _
ByVal propertyInfo As PropertyInfo _
) As Boolean
[C#]
protected override bool InitializeBuildElementCollection(
PropertyInfo propertyInfo
);

See Also

FilterChain.FilterChainConfigurator Class | NAnt.Core.Filters Namespace


FilterCollection Class

Contains a collection of Filter elements.

For a list of all members of this type, see FilterCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.Core.Filters.FilterCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class FilterCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class FilterCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Filters

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FilterCollection Members | NAnt.Core.Filters Namespace


FilterCollection Members

FilterCollection overview

Public Instance Constructors

FilterCollection Overloaded. Initializes a new instance of the FilterCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a Filter to the end of the collection.
AddRange | Overloaded. Adds the elements of a Filter array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a Filter is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified Filter object in the collection.
Insert | Inserts a Filter into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

FilterCollection Class | NAnt.Core.Filters Namespace


FilterCollection Constructor

Initializes a new instance of the FilterCollection class.

Overload List

Initializes a new instance of the FilterCollection class.

public FilterCollection();

Initializes a new instance of the FilterCollection class with the specified array of Filter instances.

public FilterCollection(Filter[]);

Initializes a new instance of the FilterCollection class with the specified FilterCollection instance.

public FilterCollection(FilterCollection);

See Also

FilterCollection Class | NAnt.Core.Filters Namespace


FilterCollection Constructor ()

Initializes a new instance of the FilterCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FilterCollection();

See Also

FilterCollection Class | NAnt.Core.Filters Namespace | FilterCollection Constructor Overload List


FilterCollection Constructor (FilterCollection)

Initializes a new instance of the FilterCollection class with the specified FilterCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As FilterCollection _
)
[C#]
public FilterCollection(
FilterCollection value
);

See Also

FilterCollection Class | NAnt.Core.Filters Namespace | FilterCollection Constructor Overload List


FilterCollection Constructor (Filter[])

Initializes a new instance of the FilterCollection class with the specified array of Filter instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As Filter() _
)
[C#]
public FilterCollection(
Filter[] value
);

See Also

FilterCollection Class | NAnt.Core.Filters Namespace | FilterCollection Constructor Overload List


FilterCollection Properties

The properties of the FilterCollection class are listed below. For a complete list of FilterCollection class members, see the FilterCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

FilterCollection Class | NAnt.Core.Filters Namespace


Item Property

NAnt SDK Documentation - v0.91

FilterCollection.Item Property

Gets or sets the element at the specified index.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As Filter
[C#]
public Filter this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

FilterCollection Class | NAnt.Core.Filters Namespace


FilterCollection Methods

The methods of the FilterCollection class are listed below. For a complete list of FilterCollection class members, see the FilterCollection Members topic.

Public Instance Methods

Add | Adds a Filter to the end of the collection.
AddRange | Overloaded. Adds the elements of a Filter array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a Filter is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified Filter object in the collection.
Insert | Inserts a Filter into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

FilterCollection Class | NAnt.Core.Filters Namespace


FilterCollection.Add Method

Adds a Filter to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As Filter _
) As Integer
[C#]
public int Add(
Filter item
);

Parameters

item
The Filter to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

FilterCollection Class | NAnt.Core.Filters Namespace


AddRange Method

NAnt SDK Documentation - v0.91

FilterCollection.AddRange Method

Adds the elements of a Filter array to the end of the collection.

Overload List

Adds the elements of a Filter array to the end of the collection.

public void AddRange(Filter[]);

Adds the elements of a FilterCollection to the end of the collection.

public void AddRange(FilterCollection);

See Also

FilterCollection Class | NAnt.Core.Filters Namespace


FilterCollection.AddRange Method (Filter[])

Adds the elements of a Filter array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As Filter() _
)
[C#]
public void AddRange(
Filter[] items
);

Parameters

items
The array of Filter elements to be added to the end of the collection.

See Also

FilterCollection Class | NAnt.Core.Filters Namespace | FilterCollection.AddRange Overload List


FilterCollection.AddRange Method (FilterCollection)

Adds the elements of a FilterCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As FilterCollection _
)
[C#]
public void AddRange(
FilterCollection items
);

Parameters

items
The FilterCollection to be added to the end of the collection.

See Also

FilterCollection Class | NAnt.Core.Filters Namespace | FilterCollection.AddRange Overload List


FilterCollection.Contains Method

Determines whether a Filter is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal item As Filter _
) As Boolean
[C#]
public bool Contains(
Filter item
);

Parameters

item
The Filter to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

FilterCollection Class | NAnt.Core.Filters Namespace


FilterCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As Filter(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
Filter[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

FilterCollection Class | NAnt.Core.Filters Namespace


FilterCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As FilterEnumerator
[C#]
new public FilterEnumerator GetEnumerator();

Return Value

A FilterEnumerator for the entire collection.

See Also

FilterCollection Class | NAnt.Core.Filters Namespace


FilterCollection.IndexOf Method

Retrieves the index of a specified Filter object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As Filter _
) As Integer
[C#]
public int IndexOf(
Filter item
);

Parameters

item
The Filter object for which the index is returned.

Return Value

The index of the specified Filter. If the Filter is not currently a member of the collection, it returns -1.

See Also

FilterCollection Class | NAnt.Core.Filters Namespace


FilterCollection.Insert Method

Inserts a Filter into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As Filter _
)
[C#]
public void Insert(
int index,
Filter item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The Filter to insert.

See Also

FilterCollection Class | NAnt.Core.Filters Namespace


FilterCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As Filter _
)
[C#]
public void Remove(
Filter item
);

Parameters

item
The Filter to remove from the collection.

See Also

FilterCollection Class | NAnt.Core.Filters Namespace


FilterEnumerator Class

Enumerates the Filter elements of a FilterCollection.

For a list of all members of this type, see FilterEnumerator Members.

System.Object
NAnt.Core.Filters.FilterEnumerator

[Visual Basic]
Public Class FilterEnumerator
Implements IEnumerator
[C#]
public class FilterEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Filters

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FilterEnumerator Members | NAnt.Core.Filters Namespace


FilterEnumerator Members

FilterEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterEnumerator Class | NAnt.Core.Filters Namespace


FilterEnumerator Properties

The properties of the FilterEnumerator class are listed below. For a complete list of FilterEnumerator class members, see the FilterEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

FilterEnumerator Class | NAnt.Core.Filters Namespace


Current Property

NAnt SDK Documentation - v0.91

FilterEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As Filter
[C#]
public Filter Current {get;}

See Also

FilterEnumerator Class | NAnt.Core.Filters Namespace


FilterEnumerator Methods

The methods of the FilterEnumerator class are listed below. For a complete list of FilterEnumerator class members, see the FilterEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterEnumerator Class | NAnt.Core.Filters Namespace


FilterEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

FilterEnumerator Class | NAnt.Core.Filters Namespace


FilterEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

FilterEnumerator Class | NAnt.Core.Filters Namespace


ReplaceString Class

Replaces all occurrences of a given string in the original input with user-supplied replacement string.

For a list of all members of this type, see ReplaceString Members.

System.Object
NAnt.Core.Element
NAnt.Core.Filters.ChainableReader
NAnt.Core.Filters.Filter
NAnt.Core.Filters.ReplaceString

[Visual Basic]
<ElementName(Name:="replacestring")>
Public Class ReplaceString
Inherits Filter
[C#]
[ElementName(Name="replacestring")]
public class ReplaceString : Filter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This filter replaces all occurrences of a given string in the original input stream with a user-supplied replacement string. By default string comparisons are case sensitive but this can be changed by setting the optional IgnoreCase attribute to true.

To use this filter specify the string to be replaced with the From attribute and the string to replace it with using the To attribute.

Filters are intended to be used as a element of a FilterChain.

Example

Replace all occurrences of "3.14" with "PI".

<replacestring from="3.14" to="PI" />

Replace all occurrences of "string", "String", etc. with "System.String".

<replacestring from="String" to="System.String" ignorecase="true" />

Requirements

Namespace: NAnt.Core.Filters

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ReplaceString Members | NAnt.Core.Filters Namespace


ReplaceString Members

ReplaceString overview

Public Instance Constructors

ReplaceString Constructor Initializes a new instance of the ReplaceString class.

Public Instance Properties

Base (inherited from ChainableReader) | Gets a value indicating if the reader is backed by a stream in the chain.
From | The string to be replaced.
IfDefined (inherited from Filter) | If true then the filter will be used; otherwise, skipped. The default is true.
IgnoreCase | Determines if case will be ignored. The default is false.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
To | The new value for the replaced string. Am empty string is permissible.
UnlessDefined (inherited from Filter) | Opposite of IfDefined. If false then the filter will be executed; otherwise, skipped. The default is false.

Public Instance Methods

Chain | Overloaded. Construct that allows this filter to be chained to the one in the parameter chainedReader.
Chain (inherited from ChainableReader) | Overloaded. Makes it so all calls to Read and Peek are passed the ChainableReader passed as a parameter.
Close (inherited from ChainableReader) | Closes the reader.
Dispose (inherited from ChainableReader) | Calls close and supresses the finalizer for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeFilter (inherited from Filter) | Called after construction and after properties are set. Allows for filter initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Peek | Reads the next character applying the filter logic without advancing the current position in the stream. Peek currently is not supported.
Read | Reads the next character applying the filter logic.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReplaceString Class | NAnt.Core.Filters Namespace


ReplaceString Constructor

Initializes a new instance of the ReplaceString class.

[Visual Basic]
Public Sub New()
[C#]
public ReplaceString();

See Also

ReplaceString Class | NAnt.Core.Filters Namespace


ReplaceString Properties

The properties of the ReplaceString class are listed below. For a complete list of ReplaceString class members, see the ReplaceString Members topic.

Public Instance Properties

Base (inherited from ChainableReader) | Gets a value indicating if the reader is backed by a stream in the chain.
From | The string to be replaced.
IfDefined (inherited from Filter) | If true then the filter will be used; otherwise, skipped. The default is true.
IgnoreCase | Determines if case will be ignored. The default is false.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
To | The new value for the replaced string. Am empty string is permissible.
UnlessDefined (inherited from Filter) | Opposite of IfDefined. If false then the filter will be executed; otherwise, skipped. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

ReplaceString Class | NAnt.Core.Filters Namespace


From Property

NAnt SDK Documentation - v0.91

ReplaceString.From Property

The string to be replaced.

[Visual Basic]
<TaskAttribute(Name:="from", Required:=True, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property From As String
[C#]
[TaskAttribute(Name="from", Required=True, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string From {get; set;}

See Also

ReplaceString Class | NAnt.Core.Filters Namespace


IgnoreCase Property

NAnt SDK Documentation - v0.91

ReplaceString.IgnoreCase Property

Determines if case will be ignored. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="ignorecase", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property IgnoreCase As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="ignorecase", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool IgnoreCase {get; set;}

See Also

ReplaceString Class | NAnt.Core.Filters Namespace


To Property

NAnt SDK Documentation - v0.91

ReplaceString.To Property

The new value for the replaced string. Am empty string is permissible.

[Visual Basic]
<TaskAttribute(Name:="to", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=True, Expression:="null", ExpressionErrorMessage:="null")>
Public Property To As String
[C#]
[TaskAttribute(Name="to", Required=False, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=True, Expression="null", ExpressionErrorMessage="null")]
public string To {get; set;}

See Also

ReplaceString Class | NAnt.Core.Filters Namespace


ReplaceString Methods

The methods of the ReplaceString class are listed below. For a complete list of ReplaceString class members, see the ReplaceString Members topic.

Public Instance Methods

Chain | Overloaded. Construct that allows this filter to be chained to the one in the parameter chainedReader.
Chain (inherited from ChainableReader) | Overloaded. Makes it so all calls to Read and Peek are passed the ChainableReader passed as a parameter.
Close (inherited from ChainableReader) | Closes the reader.
Dispose (inherited from ChainableReader) | Calls close and supresses the finalizer for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeFilter (inherited from Filter) | Called after construction and after properties are set. Allows for filter initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Peek | Reads the next character applying the filter logic without advancing the current position in the stream. Peek currently is not supported.
Read | Reads the next character applying the filter logic.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReplaceString Class | NAnt.Core.Filters Namespace


Chain Method

NAnt SDK Documentation - v0.91

ReplaceString.Chain Method

Construct that allows this filter to be chained to the one in the parameter chainedReader.

Overload List

Construct that allows this filter to be chained to the one in the parameter chainedReader.

public override void Chain(ChainableReader);

Inherited from ChainableReader.

public virtual void Chain(TextReader);

See Also

ReplaceString Class | NAnt.Core.Filters Namespace


ReplaceString.Chain Method (ChainableReader)

Construct that allows this filter to be chained to the one in the parameter chainedReader.

[Visual Basic]
Overrides Overloads Public Sub Chain( _
ByVal chainedReader As ChainableReader _
)
[C#]
public override void Chain(
ChainableReader chainedReader
);

Parameters

chainedReader
Filter that the filter will be chained to

See Also

ReplaceString Class | NAnt.Core.Filters Namespace | ReplaceString.Chain Overload List


ReplaceString.Peek Method

Reads the next character applying the filter logic without advancing the current position in the stream. Peek currently is not supported.

[Visual Basic]
Overrides Public Function Peek() As Integer
[C#]
public override int Peek();

Return Value

Char as an int or -1 if at the end of the stream.

See Also

ReplaceString Class | NAnt.Core.Filters Namespace


ReplaceString.Read Method

Reads the next character applying the filter logic.

[Visual Basic]
Overrides Public Function Read() As Integer
[C#]
public override int Read();

Return Value

Char as an int or -1 if at the end of the stream

See Also

ReplaceString Class | NAnt.Core.Filters Namespace


ReplaceTokens Class

Replaces tokens in the original input with user-supplied values.

For a list of all members of this type, see ReplaceTokens Members.

System.Object
NAnt.Core.Element
NAnt.Core.Filters.ChainableReader
NAnt.Core.Filters.Filter
NAnt.Core.Filters.ReplaceTokens

[Visual Basic]
<ElementName(Name:="replacetokens")>
Public Class ReplaceTokens
Inherits Filter
[C#]
[ElementName(Name="replacetokens")]
public class ReplaceTokens : Filter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This filter replaces all token surrounded by a beginning and ending token. The default beginning and ending tokens both default to '@'. The optional BeginToken and EndToken attributes can be specified to change either token. By default string comparisons are case sensitive but this can be changed by setting the optional IgnoreCase attribute to true.

Tokens are specified by using the Token element. It is possible to specify from 1 to n tokens and replacement values. Values can be any valid NAnt expression.

Filters are intended to be used as a element of a FilterChain.

Example

Replace all occurrences of the string @DATE@ with the value of property "TODAY".

<replacetokens>
    <token key="DATE" value="${TODAY}" />
</replacetokens>

Replace all occurrences of the string <DATE> with the value of property "TODAY".

<replacetokens begintoken="&lt;" endtoken="&gt;">
    <token key="DATE" value="${TODAY}" />
</replacetokens>

Requirements

Namespace: NAnt.Core.Filters

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ReplaceTokens Members | NAnt.Core.Filters Namespace


ReplaceTokens Members

ReplaceTokens overview

Public Instance Constructors

ReplaceTokens Constructor Initializes a new instance of the ReplaceTokens class.

Public Instance Properties

Base (inherited from ChainableReader) | Gets a value indicating if the reader is backed by a stream in the chain.
BeginToken | Marks the beginning of a token. The default is "@".
EndToken | Marks the end of a token. The default is "@".
IfDefined (inherited from Filter) | If true then the filter will be used; otherwise, skipped. The default is true.
IgnoreCase | Determines if case will be ignored. The default is false.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Tokens | Tokens and replacement values.
UnlessDefined (inherited from Filter) | Opposite of IfDefined. If false then the filter will be executed; otherwise, skipped. The default is false.

Public Instance Methods

Chain | Overloaded. Construct that allows this filter to be chained to the one in the parameter chainedReader.
Chain (inherited from ChainableReader) | Overloaded. Makes it so all calls to Read and Peek are passed the ChainableReader passed as a parameter.
Close (inherited from ChainableReader) | Closes the reader.
Dispose (inherited from ChainableReader) | Calls close and supresses the finalizer for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeFilter (inherited from Filter) | Called after construction and after properties are set. Allows for filter initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Peek | Reads the next character applying the filter logic without advancing the current position in the stream. Peek currently is not supported.
Read | Reads the next character applying the filter logic.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Initialize the filter by setting its parameters.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReplaceTokens Class | NAnt.Core.Filters Namespace


ReplaceTokens Constructor

Initializes a new instance of the ReplaceTokens class.

[Visual Basic]
Public Sub New()
[C#]
public ReplaceTokens();

See Also

ReplaceTokens Class | NAnt.Core.Filters Namespace


ReplaceTokens Properties

The properties of the ReplaceTokens class are listed below. For a complete list of ReplaceTokens class members, see the ReplaceTokens Members topic.

Public Instance Properties

Base (inherited from ChainableReader) | Gets a value indicating if the reader is backed by a stream in the chain.
BeginToken | Marks the beginning of a token. The default is "@".
EndToken | Marks the end of a token. The default is "@".
IfDefined (inherited from Filter) | If true then the filter will be used; otherwise, skipped. The default is true.
IgnoreCase | Determines if case will be ignored. The default is false.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Tokens | Tokens and replacement values.
UnlessDefined (inherited from Filter) | Opposite of IfDefined. If false then the filter will be executed; otherwise, skipped. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

ReplaceTokens Class | NAnt.Core.Filters Namespace


BeginToken Property

NAnt SDK Documentation - v0.91

ReplaceTokens.BeginToken Property

Marks the beginning of a token. The default is "@".

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="begintoken", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property BeginToken As Char
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="begintoken", Required=False, ExpandProperties=True, ProcessXml=True)]
public char BeginToken {get; set;}

See Also

ReplaceTokens Class | NAnt.Core.Filters Namespace


EndToken Property

NAnt SDK Documentation - v0.91

ReplaceTokens.EndToken Property

Marks the end of a token. The default is "@".

[Visual Basic]
<TaskAttribute(Name:="endtoken", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property EndToken As Char
[C#]
[TaskAttribute(Name="endtoken", Required=False, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public char EndToken {get; set;}

See Also

ReplaceTokens Class | NAnt.Core.Filters Namespace


IgnoreCase Property

NAnt SDK Documentation - v0.91

ReplaceTokens.IgnoreCase Property

Determines if case will be ignored. The default is false.

[Visual Basic]
<TaskAttribute(Name:="ignorecase", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property IgnoreCase As Boolean
[C#]
[TaskAttribute(Name="ignorecase", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool IgnoreCase {get; set;}

See Also

ReplaceTokens Class | NAnt.Core.Filters Namespace


Tokens Property

NAnt SDK Documentation - v0.91

ReplaceTokens.Tokens Property

Tokens and replacement values.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="token", Required:=False, ProcessXml:=True)>
Public Property Tokens As Token()
[C#]
[BuildElementArray(ElementType=null, Name="token", Required=False, ProcessXml=True)]
public NAnt.Core.Types.Token[] Tokens {get; set;}

See Also

ReplaceTokens Class | NAnt.Core.Filters Namespace


ReplaceTokens Methods

The methods of the ReplaceTokens class are listed below. For a complete list of ReplaceTokens class members, see the ReplaceTokens Members topic.

Public Instance Methods

Chain | Overloaded. Construct that allows this filter to be chained to the one in the parameter chainedReader.
Chain (inherited from ChainableReader) | Overloaded. Makes it so all calls to Read and Peek are passed the ChainableReader passed as a parameter.
Close (inherited from ChainableReader) | Closes the reader.
Dispose (inherited from ChainableReader) | Calls close and supresses the finalizer for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeFilter (inherited from Filter) | Called after construction and after properties are set. Allows for filter initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Peek | Reads the next character applying the filter logic without advancing the current position in the stream. Peek currently is not supported.
Read | Reads the next character applying the filter logic.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Initialize the filter by setting its parameters.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReplaceTokens Class | NAnt.Core.Filters Namespace


Chain Method

NAnt SDK Documentation - v0.91

ReplaceTokens.Chain Method

Construct that allows this filter to be chained to the one in the parameter chainedReader.

Overload List

Construct that allows this filter to be chained to the one in the parameter chainedReader.

public override void Chain(ChainableReader);

Inherited from ChainableReader.

public virtual void Chain(TextReader);

See Also

ReplaceTokens Class | NAnt.Core.Filters Namespace


ReplaceTokens.Chain Method (ChainableReader)

Construct that allows this filter to be chained to the one in the parameter chainedReader.

[Visual Basic]
Overrides Overloads Public Sub Chain( _
ByVal chainedReader As ChainableReader _
)
[C#]
public override void Chain(
ChainableReader chainedReader
);

Parameters

chainedReader
Filter that the filter will be chained to

See Also

ReplaceTokens Class | NAnt.Core.Filters Namespace | ReplaceTokens.Chain Overload List


Initialize Method

NAnt SDK Documentation - v0.91

ReplaceTokens.Initialize Method

Initialize the filter by setting its parameters.

Overload List

Initialize the filter by setting its parameters.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

ReplaceTokens Class | NAnt.Core.Filters Namespace


ReplaceTokens.Initialize Method ()

Initialize the filter by setting its parameters.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

ReplaceTokens Class | NAnt.Core.Filters Namespace | ReplaceTokens.Initialize Overload List


ReplaceTokens.Peek Method

Reads the next character applying the filter logic without advancing the current position in the stream. Peek currently is not supported.

[Visual Basic]
Overrides Public Function Peek() As Integer
[C#]
public override int Peek();

Return Value

Char as an int or -1 if at the end of the stream.

See Also

ReplaceTokens Class | NAnt.Core.Filters Namespace


ReplaceTokens.Read Method

Reads the next character applying the filter logic.

[Visual Basic]
Overrides Public Function Read() As Integer
[C#]
public override int Read();

Return Value

Char as an int or -1 if at the end of the stream

See Also

ReplaceTokens Class | NAnt.Core.Filters Namespace


TabsToSpaces Class

Converts tabs to spaces.

For a list of all members of this type, see TabsToSpaces Members.

System.Object
NAnt.Core.Element
NAnt.Core.Filters.ChainableReader
NAnt.Core.Filters.Filter
NAnt.Core.Filters.TabsToSpaces

[Visual Basic]
<ElementName(Name:="tabstospaces")>
Public Class TabsToSpaces
Inherits Filter
[C#]
[ElementName(Name="tabstospaces")]
public class TabsToSpaces : Filter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The TabsToSpaces filter replaces tabs in a text file with spaces.

Filters are intended to be used as a element of a FilterChain.

Example

Replace all tabs with four spaces.

<tabtospaces tablength="4" />

Requirements

Namespace: NAnt.Core.Filters

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

TabsToSpaces Members | NAnt.Core.Filters Namespace


TabsToSpaces Members

TabsToSpaces overview

Public Instance Constructors

TabsToSpaces Constructor Initializes a new instance of the TabsToSpaces class.

Public Instance Properties

Base (inherited from ChainableReader) | Gets a value indicating if the reader is backed by a stream in the chain.
IfDefined (inherited from Filter) | If true then the filter will be used; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
TabLength | The number of spaces used when converting a tab. The default is "8".
UnlessDefined (inherited from Filter) | Opposite of IfDefined. If false then the filter will be executed; otherwise, skipped. The default is false.

Public Instance Methods

Chain | Overloaded. Construct that allows this filter to be chained to the one in the parameter chainedReader.
Chain (inherited from ChainableReader) | Overloaded. Makes it so all calls to Read and Peek are passed the ChainableReader passed as a parameter.
Close (inherited from ChainableReader) | Closes the reader.
Dispose (inherited from ChainableReader) | Calls close and supresses the finalizer for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeFilter (inherited from Filter) | Called after construction and after properties are set. Allows for filter initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Peek Retrieves the next character with moving the position in the stream.
Note This method is not implemented
Read | Retrieves the next character in the stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TabsToSpaces Class | NAnt.Core.Filters Namespace


TabsToSpaces Constructor

Initializes a new instance of the TabsToSpaces class.

[Visual Basic]
Public Sub New()
[C#]
public TabsToSpaces();

See Also

TabsToSpaces Class | NAnt.Core.Filters Namespace


TabsToSpaces Properties

The properties of the TabsToSpaces class are listed below. For a complete list of TabsToSpaces class members, see the TabsToSpaces Members topic.

Public Instance Properties

Base (inherited from ChainableReader) | Gets a value indicating if the reader is backed by a stream in the chain.
IfDefined (inherited from Filter) | If true then the filter will be used; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
TabLength | The number of spaces used when converting a tab. The default is "8".
UnlessDefined (inherited from Filter) | Opposite of IfDefined. If false then the filter will be executed; otherwise, skipped. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

TabsToSpaces Class | NAnt.Core.Filters Namespace


TabLength Property

NAnt SDK Documentation - v0.91

TabsToSpaces.TabLength Property

The number of spaces used when converting a tab. The default is "8".

[Visual Basic]
<TaskAttribute(Name:="tablength", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ Int32Validator(MinValue:=1, MaxValue:=100, Base:=10)>
Public Property TabLength As Integer
[C#]
[TaskAttribute(Name="tablength", Required=False, ExpandProperties=True, ProcessXml=True)]
[Int32Validator(MinValue=1, MaxValue=100, Base=10)]
public int TabLength {get; set;}

See Also

TabsToSpaces Class | NAnt.Core.Filters Namespace


TabsToSpaces Methods

The methods of the TabsToSpaces class are listed below. For a complete list of TabsToSpaces class members, see the TabsToSpaces Members topic.

Public Instance Methods

Chain | Overloaded. Construct that allows this filter to be chained to the one in the parameter chainedReader.
Chain (inherited from ChainableReader) | Overloaded. Makes it so all calls to Read and Peek are passed the ChainableReader passed as a parameter.
Close (inherited from ChainableReader) | Closes the reader.
Dispose (inherited from ChainableReader) | Calls close and supresses the finalizer for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeFilter (inherited from Filter) | Called after construction and after properties are set. Allows for filter initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Peek Retrieves the next character with moving the position in the stream.
Note This method is not implemented
Read | Retrieves the next character in the stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TabsToSpaces Class | NAnt.Core.Filters Namespace


Chain Method

NAnt SDK Documentation - v0.91

TabsToSpaces.Chain Method

Construct that allows this filter to be chained to the one in the parameter chainedReader.

Overload List

Construct that allows this filter to be chained to the one in the parameter chainedReader.

public override void Chain(ChainableReader);

Inherited from ChainableReader.

public virtual void Chain(TextReader);

See Also

TabsToSpaces Class | NAnt.Core.Filters Namespace


TabsToSpaces.Chain Method (ChainableReader)

Construct that allows this filter to be chained to the one in the parameter chainedReader.

[Visual Basic]
Overrides Overloads Public Sub Chain( _
ByVal chainedReader As ChainableReader _
)
[C#]
public override void Chain(
ChainableReader chainedReader
);

Parameters

chainedReader
Filter that the filter will be chained to

See Also

TabsToSpaces Class | NAnt.Core.Filters Namespace | TabsToSpaces.Chain Overload List


TabsToSpaces.Peek Method

Retrieves the next character with moving the position in the stream.

Note This method is not implemented
[Visual Basic]
Overrides Public Function Peek() As Integer
[C#]
public override int Peek();

Return Value

-1 if end of stream otherwise a character

See Also

TabsToSpaces Class | NAnt.Core.Filters Namespace


TabsToSpaces.Read Method

Retrieves the next character in the stream.

[Visual Basic]
Overrides Public Function Read() As Integer
[C#]
public override int Read();

Return Value

-1 if end of stream otherwise a character

See Also

TabsToSpaces Class | NAnt.Core.Filters Namespace


NAnt.Core.Functions

NAnt SDK Documentation - v0.91

NAnt.Core.Functions Namespace

Namespace hierarchy

Classes

Class | Description
AssemblyFunctions | Functions to return information for a given assembly.
AssemblyNameFunctions | Functions that return information about an assembly's identity.
BooleanConversionFunctions |
ConversionFunctions |
DateTimeConversionFunctions |
DateTimeFunctions |
DirectoryFunctions | Groups a set of functions for dealing with directories.
DnsFunctions | Functions for requesting information from DNS.
DoubleConversionFunctions |
EnvironmentFunctions | Provide information about the current environment and platform.
FileFunctions | Groups a set of functions for dealing with files.
FileVersionInfoFunctions | Functions that provide version information for a physical file on disk.
FrameworkFunctions |
Int32ConversionFunctions |
Int64ConversionFunctions |
MathFunctions |
NAntFunctions |
OperatingSystemFunctions | Functions that return information about an operating system.
PathFunctions |
PkgConfigFunctions |
PlatformFunctions |
ProjectFunctions |
PropertyFunctions |
StringFunctions |
TargetFunctions |
TaskFunctions |
TimeSpanConversionFunctions |
TimeSpanFunctions |
VersionConversionFunctions |
VersionFunctions |


AssemblyFunctions Class

Functions to return information for a given assembly.

For a list of all members of this type, see AssemblyFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.AssemblyFunctions

[Visual Basic]
<FunctionSet(Category:="Assembly", Prefix:="assembly")>
Public Class AssemblyFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Assembly", Prefix="assembly")]
public class AssemblyFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

AssemblyFunctions Members | NAnt.Core.Functions Namespace


AssemblyFunctions Members

AssemblyFunctions overview

Public Static (Shared) Methods

GetFullName | Gets the full name of the assembly, also known as the display name.
GetLocation | Gets the physical location, in codebase format, of the loaded file that contains the manifest.
GetName | Gets an AssemblyName for the specified assembly.

Public Instance Constructors

AssemblyFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Load | Loads an assembly given the long form of its name.
LoadFromFile | Loads an assembly given its file name or path.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyFunctions Class | NAnt.Core.Functions Namespace


AssemblyFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public AssemblyFunctions(
Project project,
PropertyDictionary properties
);

See Also

AssemblyFunctions Class | NAnt.Core.Functions Namespace


AssemblyFunctions Methods

The methods of the AssemblyFunctions class are listed below. For a complete list of AssemblyFunctions class members, see the AssemblyFunctions Members topic.

Public Static (Shared) Methods

GetFullName | Gets the full name of the assembly, also known as the display name.
GetLocation | Gets the physical location, in codebase format, of the loaded file that contains the manifest.
GetName | Gets an AssemblyName for the specified assembly.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Load | Loads an assembly given the long form of its name.
LoadFromFile | Loads an assembly given its file name or path.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyFunctions Class | NAnt.Core.Functions Namespace


AssemblyFunctions.GetFullName Method

Gets the full name of the assembly, also known as the display name.

[Visual Basic]
<Function(Name:="get-full-name")>
Public Shared Function GetFullName( _
ByVal assembly As Assembly _
) As String
[C#]
[Function(Name="get-full-name")]
public static string GetFullName(
Assembly assembly
);

Parameters

assembly
The assembly to get the full name for.

Return Value

The full name of the assembly, also known as the display name.

See Also

AssemblyFunctions Class | NAnt.Core.Functions Namespace


AssemblyFunctions.GetLocation Method

Gets the physical location, in codebase format, of the loaded file that contains the manifest.

[Visual Basic]
<Function(Name:="get-location")>
Public Shared Function GetLocation( _
ByVal assembly As Assembly _
) As String
[C#]
[Function(Name="get-location")]
public static string GetLocation(
Assembly assembly
);

Parameters

assembly
The assembly to get the location for.

Return Value

The location of the specified assembly.

See Also

AssemblyFunctions Class | NAnt.Core.Functions Namespace


AssemblyFunctions.GetName Method

Gets an AssemblyName for the specified assembly.

[Visual Basic]
<Function(Name:="get-name")>
Public Shared Function GetName( _
ByVal assembly As Assembly _
) As AssemblyName
[C#]
[Function(Name="get-name")]
public static AssemblyName GetName(
Assembly assembly
);

Parameters

assembly
The assembly to get an AssemblyName for.

Return Value

An AssemblyName for the specified assembly.

See Also

AssemblyFunctions Class | NAnt.Core.Functions Namespace | AssemblyNameFunctions


AssemblyFunctions.Load Method

Loads an assembly given the long form of its name.

[Visual Basic]
<Function(Name:="load")>
Public Function Load( _
ByVal assemblyString As String _
) As Assembly
[C#]
[Function(Name="load")]
public Assembly Load(
string assemblyString
);

Parameters

assemblyString
The long form of the assembly name.

Return Value

The loaded assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | assemblyString is a a null reference (Nothing in Visual Basic).
FileNotFoundException | assemblyString is not found.

Example

Determine the location of the Microsoft Access 11 Primary Interop Assembly by loading it using its fully qualified name, and copy it to the build directory.

<property name="access.pia.path" value="${assembly::get-location(assembly::load('Microsoft.Office.Interop.Access, Version=11.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c'))}" />
<copy file="${access.pia.path}" todir="${build.dir}" />

See Also

AssemblyFunctions Class | NAnt.Core.Functions Namespace


AssemblyFunctions.LoadFromFile Method

Loads an assembly given its file name or path.

[Visual Basic]
<Function(Name:="load-from-file")>
Public Function LoadFromFile( _
ByVal assemblyFile As String _
) As Assembly
[C#]
[Function(Name="load-from-file")]
public Assembly LoadFromFile(
string assemblyFile
);

Parameters

assemblyFile
The name or path of the file that contains the manifest of the assembly.

Return Value

The loaded assembly.

Exceptions

Exception Type | Condition
ArgumentException | assemblyFile is an empty String.
FileNotFoundException | assemblyFile is not found, or the module you are trying to load does not specify a filename extension.
BadImageFormatException | assemblyFile is not a valid assembly.
PathTooLongException | An assembly or module was loaded twice with two different evidences, or the assembly name is longer than MAX_PATH characters.

See Also

AssemblyFunctions Class | NAnt.Core.Functions Namespace


AssemblyNameFunctions Class

Functions that return information about an assembly's identity.

For a list of all members of this type, see AssemblyNameFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.AssemblyNameFunctions

[Visual Basic]
<FunctionSet(Category:="Assembly", Prefix:="assemblyname")>
Public Class AssemblyNameFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Assembly", Prefix="assemblyname")]
public class AssemblyNameFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

AssemblyNameFunctions Members | NAnt.Core.Functions Namespace


AssemblyNameFunctions Members

AssemblyNameFunctions overview

Public Static (Shared) Methods

GetCodeBase | Gets the location of the assembly as a URL.
GetEscapedCodeBase | Gets the URI, including escape characters, that represents the codebase.
GetFullName | Gets the full name of the assembly, also known as the display name.
GetName | Gets the simple, unencrypted name of the assembly.
GetVersion | Gets the version of the assembly.

Public Instance Constructors

AssemblyNameFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyName | Gets the AssemblyName for a given file.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyNameFunctions Class | NAnt.Core.Functions Namespace


AssemblyNameFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public AssemblyNameFunctions(
Project project,
PropertyDictionary properties
);

See Also

AssemblyNameFunctions Class | NAnt.Core.Functions Namespace


AssemblyNameFunctions Methods

The methods of the AssemblyNameFunctions class are listed below. For a complete list of AssemblyNameFunctions class members, see the AssemblyNameFunctions Members topic.

Public Static (Shared) Methods

GetCodeBase | Gets the location of the assembly as a URL.
GetEscapedCodeBase | Gets the URI, including escape characters, that represents the codebase.
GetFullName | Gets the full name of the assembly, also known as the display name.
GetName | Gets the simple, unencrypted name of the assembly.
GetVersion | Gets the version of the assembly.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyName | Gets the AssemblyName for a given file.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyNameFunctions Class | NAnt.Core.Functions Namespace


AssemblyNameFunctions.GetAssemblyName Method

Gets the AssemblyName for a given file.

[Visual Basic]
<Function(Name:="get-assembly-name")>
Public Function GetAssemblyName( _
ByVal assemblyFile As String _
) As AssemblyName
[C#]
[Function(Name="get-assembly-name")]
public AssemblyName GetAssemblyName(
string assemblyFile
);

Parameters

assemblyFile
The assembly file for which to get the AssemblyName.

Return Value

An AssemblyName object representing the given file.

Remarks

The assembly is not added to this domain.

Exceptions

Exception Type | Condition
ArgumentException | assemblyFile is an empty String.
FileNotFoundException | assemblyFile does not exist.
BadImageFormatException | assemblyFile is not a valid assembly.

Example

Output the full name of the nunit.framework assembly to the build log.

<echo message="${assemblyname::get-full-name(assemblyname::get-assembly-name('nunit.framework.dll'))}" />

See Also

AssemblyNameFunctions Class | NAnt.Core.Functions Namespace


AssemblyNameFunctions.GetCodeBase Method

Gets the location of the assembly as a URL.

[Visual Basic]
<Function(Name:="get-codebase")>
Public Shared Function GetCodeBase( _
ByVal assemblyName As AssemblyName _
) As String
[C#]
[Function(Name="get-codebase")]
public static string GetCodeBase(
AssemblyName assemblyName
);

Parameters

assemblyName
The AssemblyName of the assembly.

Return Value

The location of the assembly as a URL.

See Also

AssemblyNameFunctions Class | NAnt.Core.Functions Namespace | GetName


AssemblyNameFunctions.GetEscapedCodeBase Method

Gets the URI, including escape characters, that represents the codebase.

[Visual Basic]
<Function(Name:="get-escaped-codebase")>
Public Shared Function GetEscapedCodeBase( _
ByVal assemblyName As AssemblyName _
) As String
[C#]
[Function(Name="get-escaped-codebase")]
public static string GetEscapedCodeBase(
AssemblyName assemblyName
);

Parameters

assemblyName
The AssemblyName of the assembly.

Return Value

The URI, including escape characters, that represents the codebase.

See Also

AssemblyNameFunctions Class | NAnt.Core.Functions Namespace | GetName


AssemblyNameFunctions.GetFullName Method

Gets the full name of the assembly, also known as the display name.

[Visual Basic]
<Function(Name:="get-full-name")>
Public Shared Function GetFullName( _
ByVal assemblyName As AssemblyName _
) As String
[C#]
[Function(Name="get-full-name")]
public static string GetFullName(
AssemblyName assemblyName
);

Parameters

assemblyName
The AssemblyName of the assembly.

Return Value

The full name of the assembly, also known as the display name.

Example

Output the full name of the nunit.framework assembly to the build log.

<echo message="${assemblyname::get-full-name(assemblyname::get-assembly-name('nunit.framework.dll'))}" />

See Also

AssemblyNameFunctions Class | NAnt.Core.Functions Namespace | GetName


AssemblyNameFunctions.GetName Method

Gets the simple, unencrypted name of the assembly.

[Visual Basic]
<Function(Name:="get-name")>
Public Shared Function GetName( _
ByVal assemblyName As AssemblyName _
) As String
[C#]
[Function(Name="get-name")]
public static string GetName(
AssemblyName assemblyName
);

Parameters

assemblyName
The AssemblyName of the assembly.

Return Value

The simple, unencrypted name of the assembly.

Example

Output the simple name of the nunit.framework assembly to the build log.

<echo message="${assemblyname::get-name(assemblyname::get-assembly-name('nunit.framework.dll'))}" />

See Also

AssemblyNameFunctions Class | NAnt.Core.Functions Namespace | GetName


AssemblyNameFunctions.GetVersion Method

Gets the version of the assembly.

[Visual Basic]
<Function(Name:="get-version")>
Public Shared Function GetVersion( _
ByVal assemblyName As AssemblyName _
) As Version
[C#]
[Function(Name="get-version")]
public static Version GetVersion(
AssemblyName assemblyName
);

Parameters

assemblyName
The AssemblyName of the assembly.

Return Value

The version of the assembly.

Example

Output the major version of the nunit.framework assembly to the build log.

<echo message="${version::get-major-version(assemblyname::get-version(assemblyname::get-assembly-name('nunit.framework.dll')))}" />

See Also

AssemblyNameFunctions Class | NAnt.Core.Functions Namespace | GetName | VersionFunctions


BooleanConversionFunctions Class

For a list of all members of this type, see BooleanConversionFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.BooleanConversionFunctions

[Visual Basic]
<FunctionSet(Category:="Conversion", Prefix:="bool")>
Public Class BooleanConversionFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Conversion", Prefix="bool")]
public class BooleanConversionFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

BooleanConversionFunctions Members | NAnt.Core.Functions Namespace


BooleanConversionFunctions Members

BooleanConversionFunctions overview

Public Static (Shared) Methods

Parse | Converts the specified string representation of a logical value to its Boolean equivalent.
ToString | Overloaded. Converts the specified Boolean to its equivalent string representation.

Public Instance Constructors

BooleanConversionFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BooleanConversionFunctions Class | NAnt.Core.Functions Namespace


BooleanConversionFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public BooleanConversionFunctions(
Project project,
PropertyDictionary properties
);

See Also

BooleanConversionFunctions Class | NAnt.Core.Functions Namespace


BooleanConversionFunctions Methods

The methods of the BooleanConversionFunctions class are listed below. For a complete list of BooleanConversionFunctions class members, see the BooleanConversionFunctions Members topic.

Public Static (Shared) Methods

Parse | Converts the specified string representation of a logical value to its Boolean equivalent.
ToString | Overloaded. Converts the specified Boolean to its equivalent string representation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BooleanConversionFunctions Class | NAnt.Core.Functions Namespace


BooleanConversionFunctions.Parse Method

Converts the specified string representation of a logical value to its Boolean equivalent.

[Visual Basic]
<Function(Name:="parse")>
Public Shared Function Parse( _
ByVal s As String _
) As Boolean
[C#]
[Function(Name="parse")]
public static bool Parse(
string s
);

Parameters

s
A string containing the value to convert.

Return Value

true if s is equivalent to "True"; otherwise, false.

Exceptions

Exception Type | Condition
FormatException | s is not equivalent to TrueString or FalseString.

See Also

BooleanConversionFunctions Class | NAnt.Core.Functions Namespace


ToString Method

NAnt SDK Documentation - v0.91

BooleanConversionFunctions.ToString Method

Converts the specified Boolean to its equivalent string representation.

Overload List

Inherited from Object.

public virtual string ToString();

Converts the specified Boolean to its equivalent string representation.

public static string ToString(bool);

See Also

BooleanConversionFunctions Class | NAnt.Core.Functions Namespace


BooleanConversionFunctions.ToString Method (Boolean)

Converts the specified Boolean to its equivalent string representation.

[Visual Basic]
<Function(Name:="to-string")>
Overloads Public Shared Function ToString( _
ByVal value As Boolean _
) As String
[C#]
[Function(Name="to-string")]
public static string ToString(
bool value
);

Parameters

value
A Boolean to convert.

Return Value

"True" if value is true, or "False" if value is false.

See Also

BooleanConversionFunctions Class | NAnt.Core.Functions Namespace | BooleanConversionFunctions.ToString Overload List


ConversionFunctions Class

For a list of all members of this type, see ConversionFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.ConversionFunctions

[Visual Basic]
<FunctionSet(Category:="Conversion", Prefix:="convert")>
Public Class ConversionFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Conversion", Prefix="convert")]
public class ConversionFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ConversionFunctions Members | NAnt.Core.Functions Namespace


ConversionFunctions Members

ConversionFunctions overview

Public Static (Shared) Methods

ConvertToString | Obsolete. Converts the argument to a string.
ToBoolean | Obsolete. Converts the argument to a boolean
ToDateTime | Obsolete. Converts the argument to a datetime.
ToDouble | Obsolete. Converts the argument to double
ToInt | Obsolete. Converts the argument to an integer.

Public Instance Constructors

ConversionFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConversionFunctions Class | NAnt.Core.Functions Namespace


ConversionFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal propDict As PropertyDictionary _
)
[C#]
public ConversionFunctions(
Project project,
PropertyDictionary propDict
);

See Also

ConversionFunctions Class | NAnt.Core.Functions Namespace


ConversionFunctions Methods

The methods of the ConversionFunctions class are listed below. For a complete list of ConversionFunctions class members, see the ConversionFunctions Members topic.

Public Static (Shared) Methods

ConvertToString | Obsolete. Converts the argument to a string.
ToBoolean | Obsolete. Converts the argument to a boolean
ToDateTime | Obsolete. Converts the argument to a datetime.
ToDouble | Obsolete. Converts the argument to double
ToInt | Obsolete. Converts the argument to an integer.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConversionFunctions Class | NAnt.Core.Functions Namespace


ConversionFunctions.ConvertToString Method

NOTE: This method is now obsolete.

Use type-specific conversion functions instead.

Converts the argument to a string.

[Visual Basic]
<Obsolete(Message:="Use type-specific conversion functions instead.", IsError:=False), _ Function(Name:="to-string")>
Public Shared Function ConvertToString( _
ByVal value As String _
) As String
[C#]
[Obsolete(Message="Use type-specific conversion functions instead.", IsError=False)]
[Function(Name="to-string")]
public static string ConvertToString(
string value
);

Parameters

value
The value to be converted.

Return Value

value converted to string. The function fails with an exception when the conversion is not possible.

Remarks

Named method ConvertToString as a static ToString method would break CLS compliance.

See Also

ConversionFunctions Class | NAnt.Core.Functions Namespace


ConversionFunctions.ToBoolean Method

NOTE: This method is now obsolete.

Use type-specific conversion functions instead.

Converts the argument to a boolean

[Visual Basic]
<Function(Name:="to-boolean"), _ Obsolete(Message:="Use type-specific conversion functions instead.", IsError:=False)>
Public Shared Function ToBoolean( _
ByVal value As Boolean _
) As Boolean
[C#]
[Function(Name="to-boolean")]
[Obsolete(Message="Use type-specific conversion functions instead.", IsError=False)]
public static bool ToBoolean(
bool value
);

Parameters

value
The string value to be converted to boolean. Must be 'true' or 'false'.

Return Value

value converted to boolean. The function fails with an exception when the conversion is not possible.

See Also

ConversionFunctions Class | NAnt.Core.Functions Namespace


ConversionFunctions.ToDateTime Method

NOTE: This method is now obsolete.

Use type-specific conversion functions instead.

Converts the argument to a datetime.

[Visual Basic]
<Function(Name:="to-datetime"), _ Obsolete(Message:="Use type-specific conversion functions instead.", IsError:=False)>
Public Shared Function ToDateTime( _
ByVal value As Date _
) As Date
[C#]
[Function(Name="to-datetime")]
[Obsolete(Message="Use type-specific conversion functions instead.", IsError=False)]
public static DateTime ToDateTime(
DateTime value
);

Parameters

value
value to be converted

Return Value

value converted to datetime. The function fails with an exception when the conversion is not possible.

See Also

ConversionFunctions Class | NAnt.Core.Functions Namespace


ConversionFunctions.ToDouble Method

NOTE: This method is now obsolete.

Use type-specific conversion functions instead.

Converts the argument to double

[Visual Basic]
<Obsolete(Message:="Use type-specific conversion functions instead.", IsError:=False), _ Function(Name:="to-double")>
Public Shared Function ToDouble( _
ByVal value As Double _
) As Double
[C#]
[Obsolete(Message="Use type-specific conversion functions instead.", IsError=False)]
[Function(Name="to-double")]
public static double ToDouble(
double value
);

Parameters

value
The value to be converted.

Return Value

value converted to double. The function fails with an exception when the conversion is not possible.

See Also

ConversionFunctions Class | NAnt.Core.Functions Namespace


ConversionFunctions.ToInt Method

NOTE: This method is now obsolete.

Use type-specific conversion functions instead.

Converts the argument to an integer.

[Visual Basic]
<Obsolete(Message:="Use type-specific conversion functions instead.", IsError:=False), _ Function(Name:="to-int")>
Public Shared Function ToInt( _
ByVal value As Integer _
) As Integer
[C#]
[Obsolete(Message="Use type-specific conversion functions instead.", IsError=False)]
[Function(Name="to-int")]
public static int ToInt(
int value
);

Parameters

value
value to be converted

Return Value

value converted to integer. The function fails with an exception when the conversion is not possible.

See Also

ConversionFunctions Class | NAnt.Core.Functions Namespace


DateTimeConversionFunctions Class

For a list of all members of this type, see DateTimeConversionFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.DateTimeConversionFunctions

[Visual Basic]
<FunctionSet(Category:="Conversion", Prefix:="datetime")>
Public Class DateTimeConversionFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Conversion", Prefix="datetime")]
public class DateTimeConversionFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

DateTimeConversionFunctions Members | NAnt.Core.Functions Namespace


DateTimeConversionFunctions Members

DateTimeConversionFunctions overview

Public Static (Shared) Methods

Parse | Converts the specified string representation of a date and time to its DateTime equivalent.
ToString | Overloaded. Converts the specified DateTime to its equivalent string representation.

Public Instance Constructors

DateTimeConversionFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateTimeConversionFunctions Class | NAnt.Core.Functions Namespace


DateTimeConversionFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public DateTimeConversionFunctions(
Project project,
PropertyDictionary properties
);

See Also

DateTimeConversionFunctions Class | NAnt.Core.Functions Namespace


DateTimeConversionFunctions Methods

The methods of the DateTimeConversionFunctions class are listed below. For a complete list of DateTimeConversionFunctions class members, see the DateTimeConversionFunctions Members topic.

Public Static (Shared) Methods

Parse | Converts the specified string representation of a date and time to its DateTime equivalent.
ToString | Overloaded. Converts the specified DateTime to its equivalent string representation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateTimeConversionFunctions Class | NAnt.Core.Functions Namespace


DateTimeConversionFunctions.Parse Method

Converts the specified string representation of a date and time to its DateTime equivalent.

[Visual Basic]
<Function(Name:="parse")>
Public Shared Function Parse( _
ByVal s As String _
) As Date
[C#]
[Function(Name="parse")]
public static DateTime Parse(
string s
);

Parameters

s
A string containing a date and time to convert.

Return Value

A DateTime equivalent to the date and time contained in s.

Remarks

The DateTimeFormatInfo for the invariant culture is used to supply formatting information about s.

Exceptions

Exception Type | Condition
FormatException | s does not contain a valid string representation of a date and time.

See Also

DateTimeConversionFunctions Class | NAnt.Core.Functions Namespace


ToString Method

NAnt SDK Documentation - v0.91

DateTimeConversionFunctions.ToString Method

Converts the specified DateTime to its equivalent string representation.

Overload List

Inherited from Object.

public virtual string ToString();

Converts the specified DateTime to its equivalent string representation.

public static string ToString(DateTime);

See Also

DateTimeConversionFunctions Class | NAnt.Core.Functions Namespace


DateTimeConversionFunctions.ToString Method (DateTime)

Converts the specified DateTime to its equivalent string representation.

[Visual Basic]
<Function(Name:="to-string")>
Overloads Public Shared Function ToString( _
ByVal value As Date _
) As String
[C#]
[Function(Name="to-string")]
public static string ToString(
DateTime value
);

Parameters

value
A DateTime to convert.

Return Value

A string representation of value formatted using the general format specifier ("G").

Remarks

value is formatted with the DateTimeFormatInfo for the invariant culture.

See Also

DateTimeConversionFunctions Class | NAnt.Core.Functions Namespace | DateTimeConversionFunctions.ToString Overload List


DateTimeFunctions Class

For a list of all members of this type, see DateTimeFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.DateTimeFunctions

[Visual Basic]
<FunctionSet(Category:="Date/Time", Prefix:="datetime")>
Public Class DateTimeFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Date/Time", Prefix="datetime")]
public class DateTimeFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

DateTimeFunctions Members | NAnt.Core.Functions Namespace


DateTimeFunctions Members

DateTimeFunctions overview

Public Static (Shared) Methods

GetDay | Gets the day of the month represented by the specified date.
GetDayOfWeek | Gets the day of the week represented by the specified date.
GetDayOfYear | Gets the day of the year represented by the specified date.
GetDaysInMonth | Returns the number of days in the specified month of the specified year.
GetHour | Gets the hour component of the specified date.
GetMillisecond | Gets the milliseconds component of the specified date.
GetMinute | Gets the minute component of the specified date.
GetMonth | Gets the month component of the specified date.
GetSecond | Gets the seconds component of the specified date.
GetTicks | Gets the number of ticks that represent the specified date.
GetYear | Gets the year component of the specified date.
IsLeapYear | Returns an indication whether the specified year is a leap year.
Now | Gets a DateTime that is the current local date and time on this computer.

Public Instance Constructors

DateTimeFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateTimeFunctions Class | NAnt.Core.Functions Namespace


DateTimeFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public DateTimeFunctions(
Project project,
PropertyDictionary properties
);

See Also

DateTimeFunctions Class | NAnt.Core.Functions Namespace


DateTimeFunctions Methods

The methods of the DateTimeFunctions class are listed below. For a complete list of DateTimeFunctions class members, see the DateTimeFunctions Members topic.

Public Static (Shared) Methods

GetDay | Gets the day of the month represented by the specified date.
GetDayOfWeek | Gets the day of the week represented by the specified date.
GetDayOfYear | Gets the day of the year represented by the specified date.
GetDaysInMonth | Returns the number of days in the specified month of the specified year.
GetHour | Gets the hour component of the specified date.
GetMillisecond | Gets the milliseconds component of the specified date.
GetMinute | Gets the minute component of the specified date.
GetMonth | Gets the month component of the specified date.
GetSecond | Gets the seconds component of the specified date.
GetTicks | Gets the number of ticks that represent the specified date.
GetYear | Gets the year component of the specified date.
IsLeapYear | Returns an indication whether the specified year is a leap year.
Now | Gets a DateTime that is the current local date and time on this computer.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateTimeFunctions Class | NAnt.Core.Functions Namespace


DateTimeFunctions.GetDay Method

Gets the day of the month represented by the specified date.

[Visual Basic]
<Function(Name:="get-day")>
Public Shared Function GetDay( _
ByVal date As Date _
) As Integer
[C#]
[Function(Name="get-day")]
public static int GetDay(
DateTime date
);

Parameters

date
The date of which to get the day of the month.

Return Value

The day value, between 1 and 31.

See Also

DateTimeFunctions Class | NAnt.Core.Functions Namespace


DateTimeFunctions.GetDayOfWeek Method

Gets the day of the week represented by the specified date.

[Visual Basic]
<Function(Name:="get-day-of-week")>
Public Shared Function GetDayOfWeek( _
ByVal date As Date _
) As Integer
[C#]
[Function(Name="get-day-of-week")]
public static int GetDayOfWeek(
DateTime date
);

Parameters

date
The date of which to get the day of the week.

Return Value

The day of the week, ranging from zero, indicating Sunday, to six, indicating Saturday.

See Also

DateTimeFunctions Class | NAnt.Core.Functions Namespace


DateTimeFunctions.GetDayOfYear Method

Gets the day of the year represented by the specified date.

[Visual Basic]
<Function(Name:="get-day-of-year")>
Public Shared Function GetDayOfYear( _
ByVal date As Date _
) As Integer
[C#]
[Function(Name="get-day-of-year")]
public static int GetDayOfYear(
DateTime date
);

Parameters

date
The date of which to get the day of the year.

Return Value

The day of the year, between 1 and 366.

See Also

DateTimeFunctions Class | NAnt.Core.Functions Namespace


DateTimeFunctions.GetDaysInMonth Method

Returns the number of days in the specified month of the specified year.

[Visual Basic]
<Function(Name:="get-days-in-month")>
Public Shared Function GetDaysInMonth( _
ByVal year As Integer, _
ByVal month As Integer _
) As Integer
[C#]
[Function(Name="get-days-in-month")]
public static int GetDaysInMonth(
int year,
int month
);

Parameters

year
The year.
month
The month (a number ranging from 1 to 12).

Return Value

The number of days in month for the specified year.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | month is less than 1 or greater than 12.

See Also

DateTimeFunctions Class | NAnt.Core.Functions Namespace


DateTimeFunctions.GetHour Method

Gets the hour component of the specified date.

[Visual Basic]
<Function(Name:="get-hour")>
Public Shared Function GetHour( _
ByVal date As Date _
) As Integer
[C#]
[Function(Name="get-hour")]
public static int GetHour(
DateTime date
);

Parameters

date
The date of which to get the hour component.

Return Value

The hour, between 0 and 23.

See Also

DateTimeFunctions Class | NAnt.Core.Functions Namespace


DateTimeFunctions.GetMillisecond Method

Gets the milliseconds component of the specified date.

[Visual Basic]
<Function(Name:="get-millisecond")>
Public Shared Function GetMillisecond( _
ByVal date As Date _
) As Integer
[C#]
[Function(Name="get-millisecond")]
public static int GetMillisecond(
DateTime date
);

Parameters

date
The date of which to get the milliseconds component.

Return Value

The millisecond, between 0 and 999.

See Also

DateTimeFunctions Class | NAnt.Core.Functions Namespace


DateTimeFunctions.GetMinute Method

Gets the minute component of the specified date.

[Visual Basic]
<Function(Name:="get-minute")>
Public Shared Function GetMinute( _
ByVal date As Date _
) As Integer
[C#]
[Function(Name="get-minute")]
public static int GetMinute(
DateTime date
);

Parameters

date
The date of which to get the minute component.

Return Value

The minute, between 0 and 59.

See Also

DateTimeFunctions Class | NAnt.Core.Functions Namespace


DateTimeFunctions.GetMonth Method

Gets the month component of the specified date.

[Visual Basic]
<Function(Name:="get-month")>
Public Shared Function GetMonth( _
ByVal date As Date _
) As Integer
[C#]
[Function(Name="get-month")]
public static int GetMonth(
DateTime date
);

Parameters

date
The date of which to get the month component.

Return Value

The month, between 1 and 12.

See Also

DateTimeFunctions Class | NAnt.Core.Functions Namespace


DateTimeFunctions.GetSecond Method

Gets the seconds component of the specified date.

[Visual Basic]
<Function(Name:="get-second")>
Public Shared Function GetSecond( _
ByVal date As Date _
) As Integer
[C#]
[Function(Name="get-second")]
public static int GetSecond(
DateTime date
);

Parameters

date
The date of which to get the seconds component.

Return Value

The seconds, between 0 and 59.

See Also

DateTimeFunctions Class | NAnt.Core.Functions Namespace


DateTimeFunctions.GetTicks Method

Gets the number of ticks that represent the specified date.

[Visual Basic]
<Function(Name:="get-ticks")>
Public Shared Function GetTicks( _
ByVal date As Date _
) As Long
[C#]
[Function(Name="get-ticks")]
public static long GetTicks(
DateTime date
);

Parameters

date
The date of which to get the number of ticks.

Return Value

The number of ticks that represent the date and time of the specified date.

See Also

DateTimeFunctions Class | NAnt.Core.Functions Namespace


DateTimeFunctions.GetYear Method

Gets the year component of the specified date.

[Visual Basic]
<Function(Name:="get-year")>
Public Shared Function GetYear( _
ByVal date As Date _
) As Integer
[C#]
[Function(Name="get-year")]
public static int GetYear(
DateTime date
);

Parameters

date
The date of which to get the year component.

Return Value

The year, between 1 and 9999.

See Also

DateTimeFunctions Class | NAnt.Core.Functions Namespace


DateTimeFunctions.IsLeapYear Method

Returns an indication whether the specified year is a leap year.

[Visual Basic]
<Function(Name:="is-leap-year")>
Public Shared Function IsLeapYear( _
ByVal year As Integer _
) As Boolean
[C#]
[Function(Name="is-leap-year")]
public static bool IsLeapYear(
int year
);

Parameters

year
A 4-digit year.

Return Value

true if year is a leap year; otherwise, false.

See Also

DateTimeFunctions Class | NAnt.Core.Functions Namespace


DateTimeFunctions.Now Method

Gets a DateTime that is the current local date and time on this computer.

[Visual Basic]
<Function(Name:="now")>
Public Shared Function Now() As Date
[C#]
[Function(Name="now")]
public static DateTime Now();

Return Value

A DateTime whose value is the current date and time.

See Also

DateTimeFunctions Class | NAnt.Core.Functions Namespace


DirectoryFunctions Class

Groups a set of functions for dealing with directories.

For a list of all members of this type, see DirectoryFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.DirectoryFunctions

[Visual Basic]
<FunctionSet(Category:="Directory", Prefix:="directory")>
Public Class DirectoryFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Directory", Prefix="directory")]
public class DirectoryFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

DirectoryFunctions Members | NAnt.Core.Functions Namespace


DirectoryFunctions Members

DirectoryFunctions overview

Public Static (Shared) Methods

GetCurrentDirectory Gets the current working directory.

Public Instance Constructors

DirectoryFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists | Determines whether the given path refers to an existing directory on disk.
GetCreationTime | Returns the creation date and time of the specified directory.
GetDirectoryRoot | Returns the volume information, root information, or both for the specified path.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLastAccessTime | Returns the date and time the specified directory was last accessed.
GetLastWriteTime | Returns the date and time the specified directory was last written to.
GetParentDirectory | Retrieves the parent directory of the specified path.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryFunctions Class | NAnt.Core.Functions Namespace


DirectoryFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public DirectoryFunctions(
Project project,
PropertyDictionary properties
);

See Also

DirectoryFunctions Class | NAnt.Core.Functions Namespace


DirectoryFunctions Methods

The methods of the DirectoryFunctions class are listed below. For a complete list of DirectoryFunctions class members, see the DirectoryFunctions Members topic.

Public Static (Shared) Methods

GetCurrentDirectory Gets the current working directory.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists | Determines whether the given path refers to an existing directory on disk.
GetCreationTime | Returns the creation date and time of the specified directory.
GetDirectoryRoot | Returns the volume information, root information, or both for the specified path.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLastAccessTime | Returns the date and time the specified directory was last accessed.
GetLastWriteTime | Returns the date and time the specified directory was last written to.
GetParentDirectory | Retrieves the parent directory of the specified path.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryFunctions Class | NAnt.Core.Functions Namespace


DirectoryFunctions.Exists Method

Determines whether the given path refers to an existing directory on disk.

[Visual Basic]
<Function(Name:="exists")>
Public Function Exists( _
ByVal path As String _
) As Boolean
[C#]
[Function(Name="exists")]
public bool Exists(
string path
);

Parameters

path
The path to test.

Return Value

true if path refers to an existing directory; otherwise, false.

Example

Remove directory "test", if it exists.

            <delete dir="test" if="${directory::exists('test')}" />

See Also

DirectoryFunctions Class | NAnt.Core.Functions Namespace


DirectoryFunctions.GetCreationTime Method

Returns the creation date and time of the specified directory.

[Visual Basic]
<Function(Name:="get-creation-time")>
Public Function GetCreationTime( _
ByVal path As String _
) As Date
[C#]
[Function(Name="get-creation-time")]
public DateTime GetCreationTime(
string path
);

Parameters

path
The directory for which to obtain creation date and time information.

Return Value

The creation date and time of the specified directory.

Exceptions

Exception Type | Condition
IOException | The specified directory does not exist.
ArgumentException | path is a zero-length string, contains only white space, or contains one or more invalid characters.
PathTooLongException | The specified path, file name, or both exceed the system-defined maximum length.

See Also

DirectoryFunctions Class | NAnt.Core.Functions Namespace


DirectoryFunctions.GetCurrentDirectory Method

Gets the current working directory.

[Visual Basic]
<Function(Name:="get-current-directory")>
Public Shared Function GetCurrentDirectory() As String
[C#]
[Function(Name="get-current-directory")]
public static string GetCurrentDirectory();

Return Value

A String containing the path of the current working directory.

See Also

DirectoryFunctions Class | NAnt.Core.Functions Namespace


DirectoryFunctions.GetDirectoryRoot Method

Returns the volume information, root information, or both for the specified path.

[Visual Basic]
<Function(Name:="get-directory-root")>
Public Function GetDirectoryRoot( _
ByVal path As String _
) As String
[C#]
[Function(Name="get-directory-root")]
public string GetDirectoryRoot(
string path
);

Parameters

path
The path for which to retrieve the parent directory.

Return Value

A string containing the volume information, root information, or both for the specified path.

Exceptions

Exception Type | Condition
ArgumentException | path is a zero-length string, contains only white space, or contains one or more invalid characters.
PathTooLongException | The specified path, file name, or both exceed the system-defined maximum length.

See Also

DirectoryFunctions Class | NAnt.Core.Functions Namespace


DirectoryFunctions.GetLastAccessTime Method

Returns the date and time the specified directory was last accessed.

[Visual Basic]
<Function(Name:="get-last-access-time")>
Public Function GetLastAccessTime( _
ByVal path As String _
) As Date
[C#]
[Function(Name="get-last-access-time")]
public DateTime GetLastAccessTime(
string path
);

Parameters

path
The directory for which to obtain access date and time information.

Return Value

The date and time the specified directory was last accessed.

Exceptions

Exception Type | Condition
IOException | The specified directory does not exist.
ArgumentException | path is a zero-length string, contains only white space, or contains one or more invalid characters.
PathTooLongException | The specified path, file name, or both exceed the system-defined maximum length.
NotSupportedException | The path parameter is in an invalid format.

See Also

DirectoryFunctions Class | NAnt.Core.Functions Namespace


DirectoryFunctions.GetLastWriteTime Method

Returns the date and time the specified directory was last written to.

[Visual Basic]
<Function(Name:="get-last-write-time")>
Public Function GetLastWriteTime( _
ByVal path As String _
) As Date
[C#]
[Function(Name="get-last-write-time")]
public DateTime GetLastWriteTime(
string path
);

Parameters

path
The directory for which to obtain write date and time information.

Return Value

The date and time the specified directory was last written to.

Exceptions

Exception Type | Condition
IOException | The specified directory does not exist.
ArgumentException | path is a zero-length string, contains only white space, or contains one or more invalid characters.
PathTooLongException | The specified path, file name, or both exceed the system-defined maximum length.

See Also

DirectoryFunctions Class | NAnt.Core.Functions Namespace


DirectoryFunctions.GetParentDirectory Method

Retrieves the parent directory of the specified path.

[Visual Basic]
<Function(Name:="get-parent-directory")>
Public Function GetParentDirectory( _
ByVal path As String _
) As String
[C#]
[Function(Name="get-parent-directory")]
public string GetParentDirectory(
string path
);

Parameters

path
The path for which to retrieve the parent directory.

Return Value

The parent directory, or an empty String if path is the root directory, including the root of a UNC server or share name.

Exceptions

Exception Type | Condition
IOException | The directory specified by path is read-only.
ArgumentException | path is a zero-length string, contains only white space, or contains one or more invalid characters.
PathTooLongException | The specified path, file name, or both exceed the system-defined maximum length.
DirectoryNotFoundException | The specified path was not found.

Example

Copy "readme.txt" from the current working directory to its parent directory.

<property name="current.dir" value="${directory::get-current-directory()}" />
<property name="current.dir.parent" value="${directory::get-parent-directory(current.dir)}" />
<copy file="${path::combine(current.dir, 'readme.txt')} todir="${current.dir.parent}" />

See Also

DirectoryFunctions Class | NAnt.Core.Functions Namespace


DnsFunctions Class

Functions for requesting information from DNS.

For a list of all members of this type, see DnsFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.DnsFunctions

[Visual Basic]
<FunctionSet(Category:="DNS", Prefix:="dns")>
Public Class DnsFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="DNS", Prefix="dns")]
public class DnsFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

DnsFunctions Members | NAnt.Core.Functions Namespace


DnsFunctions Members

DnsFunctions overview

Public Static (Shared) Methods

GetHostName Gets the host name of the local computer.

Public Instance Constructors

DnsFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DnsFunctions Class | NAnt.Core.Functions Namespace


DnsFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public DnsFunctions(
Project project,
PropertyDictionary properties
);

See Also

DnsFunctions Class | NAnt.Core.Functions Namespace


DnsFunctions Methods

The methods of the DnsFunctions class are listed below. For a complete list of DnsFunctions class members, see the DnsFunctions Members topic.

Public Static (Shared) Methods

GetHostName Gets the host name of the local computer.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DnsFunctions Class | NAnt.Core.Functions Namespace


DnsFunctions.GetHostName Method

Gets the host name of the local computer.

[Visual Basic]
<Function(Name:="get-host-name")>
Public Shared Function GetHostName() As String
[C#]
[Function(Name="get-host-name")]
public static string GetHostName();

Return Value

A string that contains the DNS host name of the local computer.

Exceptions

Exception Type | Condition
SocketException | An error is encountered when resolving the local host name.

See Also

DnsFunctions Class | NAnt.Core.Functions Namespace


DoubleConversionFunctions Class

For a list of all members of this type, see DoubleConversionFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.DoubleConversionFunctions

[Visual Basic]
<FunctionSet(Category:="Conversion", Prefix:="double")>
Public Class DoubleConversionFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Conversion", Prefix="double")]
public class DoubleConversionFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

DoubleConversionFunctions Members | NAnt.Core.Functions Namespace


DoubleConversionFunctions Members

DoubleConversionFunctions overview

Public Static (Shared) Methods

Parse | Converts the specified string representation of a number to its double-precision floating point number equivalent.
ToString | Overloaded. Converts the specified Double to its equivalent string representation.

Public Instance Constructors

DoubleConversionFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DoubleConversionFunctions Class | NAnt.Core.Functions Namespace


DoubleConversionFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public DoubleConversionFunctions(
Project project,
PropertyDictionary properties
);

See Also

DoubleConversionFunctions Class | NAnt.Core.Functions Namespace


DoubleConversionFunctions Methods

The methods of the DoubleConversionFunctions class are listed below. For a complete list of DoubleConversionFunctions class members, see the DoubleConversionFunctions Members topic.

Public Static (Shared) Methods

Parse | Converts the specified string representation of a number to its double-precision floating point number equivalent.
ToString | Overloaded. Converts the specified Double to its equivalent string representation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DoubleConversionFunctions Class | NAnt.Core.Functions Namespace


DoubleConversionFunctions.Parse Method

Converts the specified string representation of a number to its double-precision floating point number equivalent.

[Visual Basic]
<Function(Name:="parse")>
Public Shared Function Parse( _
ByVal s As String _
) As Double
[C#]
[Function(Name="parse")]
public static double Parse(
string s
);

Parameters

s
A string containing a number to convert.

Return Value

A double-precision floating point number equivalent to the numeric value or symbol specified in s.

Remarks

The NumberFormatInfo for the invariant culture is used to supply formatting information about s.

Exceptions

Exception Type | Condition
FormatException | s is not a number in a valid format.
OverflowException | s represents a number less than MinValue or greater than MaxValue.

See Also

DoubleConversionFunctions Class | NAnt.Core.Functions Namespace


ToString Method

NAnt SDK Documentation - v0.91

DoubleConversionFunctions.ToString Method

Converts the specified Double to its equivalent string representation.

Overload List

Inherited from Object.

public virtual string ToString();

Converts the specified Double to its equivalent string representation.

public static string ToString(double);

See Also

DoubleConversionFunctions Class | NAnt.Core.Functions Namespace


DoubleConversionFunctions.ToString Method (Double)

Converts the specified Double to its equivalent string representation.

[Visual Basic]
<Function(Name:="to-string")>
Overloads Public Shared Function ToString( _
ByVal value As Double _
) As String
[C#]
[Function(Name="to-string")]
public static string ToString(
double value
);

Parameters

value
A Double to convert.

Return Value

The string representation of value formatted using the general format specifier ("G").

Remarks

value is formatted with the NumberFormatInfo for the invariant culture.

See Also

DoubleConversionFunctions Class | NAnt.Core.Functions Namespace | DoubleConversionFunctions.ToString Overload List


EnvironmentFunctions Class

Provide information about the current environment and platform.

For a list of all members of this type, see EnvironmentFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.EnvironmentFunctions

[Visual Basic]
<FunctionSet(Category:="Environment", Prefix:="environment")>
Public Class EnvironmentFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Environment", Prefix="environment")]
public class EnvironmentFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

EnvironmentFunctions Members | NAnt.Core.Functions Namespace


EnvironmentFunctions Members

EnvironmentFunctions overview

Public Static (Shared) Methods

GetFolderPath | Gets the path to the system special folder identified by the specified enumeration.
GetMachineName | Gets the NetBIOS name of this local computer.
GetOperatingSystem | Gets an OperatingSystem object that represents the current operating system.
GetUserName | Gets the user name of the person who started the current thread.
GetVariable | Returns the value of the specified environment variable.
GetVersion | Gets a Version object that describes the major, minor, build, and revision numbers of the Common Language Runtime.
NewLine | Gets the newline string defined for this environment.
VariableExists | Gets a value indicating whether the specified environment variable exists.

Public Instance Constructors

EnvironmentFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EnvironmentFunctions Class | NAnt.Core.Functions Namespace


EnvironmentFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public EnvironmentFunctions(
Project project,
PropertyDictionary properties
);

See Also

EnvironmentFunctions Class | NAnt.Core.Functions Namespace


EnvironmentFunctions Methods

The methods of the EnvironmentFunctions class are listed below. For a complete list of EnvironmentFunctions class members, see the EnvironmentFunctions Members topic.

Public Static (Shared) Methods

GetFolderPath | Gets the path to the system special folder identified by the specified enumeration.
GetMachineName | Gets the NetBIOS name of this local computer.
GetOperatingSystem | Gets an OperatingSystem object that represents the current operating system.
GetUserName | Gets the user name of the person who started the current thread.
GetVariable | Returns the value of the specified environment variable.
GetVersion | Gets a Version object that describes the major, minor, build, and revision numbers of the Common Language Runtime.
NewLine | Gets the newline string defined for this environment.
VariableExists | Gets a value indicating whether the specified environment variable exists.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EnvironmentFunctions Class | NAnt.Core.Functions Namespace


EnvironmentFunctions.GetFolderPath Method

Gets the path to the system special folder identified by the specified enumeration.

[Visual Basic]
<Function(Name:="get-folder-path")>
Public Shared Function GetFolderPath( _
ByVal folder As SpecialFolder _
) As String
[C#]
[Function(Name="get-folder-path")]
public static string GetFolderPath(
SpecialFolder folder
);

Parameters

folder
An enumerated constant that identifies a system special folder.

Return Value

The path to the specified system special folder, if that folder physically exists on your computer; otherwise, the empty string ("").

Exceptions

Exception Type | Condition
ArgumentException | folder is not a member of SpecialFolder.

Example

Copy "out.log" from the project base directory to the program files directory.

<copy file="out.log" todir="${environment::get-folder-path('ProgramFiles')}" />

See Also

EnvironmentFunctions Class | NAnt.Core.Functions Namespace


EnvironmentFunctions.GetMachineName Method

Gets the NetBIOS name of this local computer.

[Visual Basic]
<Function(Name:="get-machine-name")>
Public Shared Function GetMachineName() As String
[C#]
[Function(Name="get-machine-name")]
public static string GetMachineName();

Return Value

The NetBIOS name of this local computer.

Exceptions

Exception Type | Condition
InvalidOperationException | The name of this computer cannot be obtained.

See Also

EnvironmentFunctions Class | NAnt.Core.Functions Namespace


EnvironmentFunctions.GetOperatingSystem Method

Gets an OperatingSystem object that represents the current operating system.

[Visual Basic]
<Function(Name:="get-operating-system")>
Public Shared Function GetOperatingSystem() As OperatingSystem
[C#]
[Function(Name="get-operating-system")]
public static OperatingSystem GetOperatingSystem();

Return Value

An OperatingSystem object that contains the current platform identifier and version number.

Example

Output string representation of the current operating system.

<echo message="OS=${operating-system::to-string(environment::get-operating-system())}" />

If the operating system is Windows 2000, the output is:

Microsoft Windows NT 5.0.2195.0

See Also

EnvironmentFunctions Class | NAnt.Core.Functions Namespace | OperatingSystemFunctions


EnvironmentFunctions.GetUserName Method

Gets the user name of the person who started the current thread.

[Visual Basic]
<Function(Name:="get-user-name")>
Public Shared Function GetUserName() As String
[C#]
[Function(Name="get-user-name")]
public static string GetUserName();

Return Value

The name of the person logged on to the system who started the current thread.

Example

Modify the home directory of the current user on unix-based systems.

            <exec program="usermod">
                <arg value="-d" />
                <arg value="/home/temp" />
                <arg value="${environment::get-user-name()}" />
            </exec>

See Also

EnvironmentFunctions Class | NAnt.Core.Functions Namespace


EnvironmentFunctions.GetVariable Method

Returns the value of the specified environment variable.

[Visual Basic]
<Function(Name:="get-variable")>
Public Shared Function GetVariable( _
ByVal name As String _
) As String
[C#]
[Function(Name="get-variable")]
public static string GetVariable(
string name
);

Parameters

name
The environment variable of which the value should be returned.

Return Value

The value of the specified environment variable.

Exceptions

Exception Type | Condition
ArgumentException | Environment variable name does not exist.

See Also

EnvironmentFunctions Class | NAnt.Core.Functions Namespace


EnvironmentFunctions.GetVersion Method

Gets a Version object that describes the major, minor, build, and revision numbers of the Common Language Runtime.

[Visual Basic]
<Function(Name:="get-version")>
Public Shared Function GetVersion() As Version
[C#]
[Function(Name="get-version")]
public static Version GetVersion();

Return Value

A Version object.

Example

Output the major version of the CLR.

<echo message="Major version=${version::get-major(environment::get-version())}" />

See Also

EnvironmentFunctions Class | NAnt.Core.Functions Namespace


EnvironmentFunctions.NewLine Method

Gets the newline string defined for this environment.

[Visual Basic]
<Function(Name:="newline")>
Public Shared Function NewLine() As String
[C#]
[Function(Name="newline")]
public static string NewLine();

Return Value

A string containing CRLF for non-Unix platforms, or LF for Unix platforms.

Example

Output two lines in a log file.

            <echo file="build.log" message="First line${environment::newline()}Second line" />

See Also

EnvironmentFunctions Class | NAnt.Core.Functions Namespace


EnvironmentFunctions.VariableExists Method

Gets a value indicating whether the specified environment variable exists.

[Visual Basic]
<Function(Name:="variable-exists")>
Public Shared Function VariableExists( _
ByVal name As String _
) As Boolean
[C#]
[Function(Name="variable-exists")]
public static bool VariableExists(
string name
);

Parameters

name
The environment variable that should be checked.

Return Value

true if the environment variable exists; otherwise, false.

Example

Execute a set of tasks only if the "BUILD_DEBUG" environment variable is set.

            <if test="${environment::variable-exists('BUILD_DEBUG')}">
                ...
            </if>

See Also

EnvironmentFunctions Class | NAnt.Core.Functions Namespace


FileFunctions Class

Groups a set of functions for dealing with files.

For a list of all members of this type, see FileFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.FileFunctions

[Visual Basic]
<FunctionSet(Category:="File", Prefix:="file")>
Public Class FileFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="File", Prefix="file")]
public class FileFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FileFunctions Members | NAnt.Core.Functions Namespace


FileFunctions Members

FileFunctions overview

Public Instance Constructors

FileFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists | Determines whether the specified file exists.
GetCreationTime | Returns the creation date and time of the specified file.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLastAccessTime | Returns the date and time the specified file was last accessed.
GetLastWriteTime | Returns the date and time the specified file was last written to.
GetLength | Gets the length of the file.
GetType (inherited from Object) | Gets the Type of the current instance.
IsAssembly | Checks if a given file is an assembly.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpToDate | Determines whether targetFile is more or equal up-to-date than srcFile.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileFunctions Class | NAnt.Core.Functions Namespace


FileFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public FileFunctions(
Project project,
PropertyDictionary properties
);

See Also

FileFunctions Class | NAnt.Core.Functions Namespace


FileFunctions Methods

The methods of the FileFunctions class are listed below. For a complete list of FileFunctions class members, see the FileFunctions Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists | Determines whether the specified file exists.
GetCreationTime | Returns the creation date and time of the specified file.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLastAccessTime | Returns the date and time the specified file was last accessed.
GetLastWriteTime | Returns the date and time the specified file was last written to.
GetLength | Gets the length of the file.
GetType (inherited from Object) | Gets the Type of the current instance.
IsAssembly | Checks if a given file is an assembly.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpToDate | Determines whether targetFile is more or equal up-to-date than srcFile.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileFunctions Class | NAnt.Core.Functions Namespace


FileFunctions.Exists Method

Determines whether the specified file exists.

[Visual Basic]
<Function(Name:="exists")>
Public Function Exists( _
ByVal file As String _
) As Boolean
[C#]
[Function(Name="exists")]
public bool Exists(
string file
);

Parameters

file
The file to check.

Return Value

true if file refers to an existing file; otherwise, false.

Example

Execute a set of tasks, if file "output.xml" does not exist.

            <if test="${not file::exists('output.xml')}">
                ...
            </if>

See Also

FileFunctions Class | NAnt.Core.Functions Namespace


FileFunctions.GetCreationTime Method

Returns the creation date and time of the specified file.

[Visual Basic]
<Function(Name:="get-creation-time")>
Public Function GetCreationTime( _
ByVal path As String _
) As Date
[C#]
[Function(Name="get-creation-time")]
public DateTime GetCreationTime(
string path
);

Parameters

path
The file for which to obtain creation date and time information.

Return Value

The creation date and time of the specified file.

Exceptions

Exception Type | Condition
IOException | The specified file does not exist.
ArgumentException | path is a zero-length string, contains only white space, or contains one or more invalid characters.
PathTooLongException | The specified path, file name, or both exceed the system-defined maximum length.
NotSupportedException | The path parameter is in an invalid format.

See Also

FileFunctions Class | NAnt.Core.Functions Namespace


FileFunctions.GetLastAccessTime Method

Returns the date and time the specified file was last accessed.

[Visual Basic]
<Function(Name:="get-last-access-time")>
Public Function GetLastAccessTime( _
ByVal path As String _
) As Date
[C#]
[Function(Name="get-last-access-time")]
public DateTime GetLastAccessTime(
string path
);

Parameters

path
The file for which to obtain access date and time information.

Return Value

The date and time the specified file was last accessed.

Exceptions

Exception Type | Condition
IOException | The specified file does not exist.
ArgumentException | path is a zero-length string, contains only white space, or contains one or more invalid characters.
PathTooLongException | The specified path, file name, or both exceed the system-defined maximum length.
NotSupportedException | The path parameter is in an invalid format.

See Also

FileFunctions Class | NAnt.Core.Functions Namespace


FileFunctions.GetLastWriteTime Method

Returns the date and time the specified file was last written to.

[Visual Basic]
<Function(Name:="get-last-write-time")>
Public Function GetLastWriteTime( _
ByVal path As String _
) As Date
[C#]
[Function(Name="get-last-write-time")]
public DateTime GetLastWriteTime(
string path
);

Parameters

path
The file for which to obtain write date and time information.

Return Value

The date and time the specified file was last written to.

Exceptions

Exception Type | Condition
IOException | The specified file does not exist.
ArgumentException | path is a zero-length string, contains only white space, or contains one or more invalid characters.
PathTooLongException | The specified path, file name, or both exceed the system-defined maximum length.

See Also

FileFunctions Class | NAnt.Core.Functions Namespace


FileFunctions.GetLength Method

Gets the length of the file.

[Visual Basic]
<Function(Name:="get-length")>
Public Function GetLength( _
ByVal file As String _
) As Long
[C#]
[Function(Name="get-length")]
public long GetLength(
string file
);

Parameters

file
filename

Return Value

Length in bytes, of the file named file.

Exceptions

Exception Type | Condition
FileNotFoundException | The file specified cannot be found.

See Also

FileFunctions Class | NAnt.Core.Functions Namespace


FileFunctions.IsAssembly Method

Checks if a given file is an assembly.

[Visual Basic]
<Function(Name:="is-assembly")>
Public Function IsAssembly( _
ByVal assemblyFile As String _
) As Boolean
[C#]
[Function(Name="is-assembly")]
public bool IsAssembly(
string assemblyFile
);

Parameters

assemblyFile
The name or path of the file to be checked.

Return Value

True if the file is a valid assembly, false if it's not or if the assembly seems corrupted (invalid headers or metadata).

Exceptions

Exception Type | Condition
ArgumentNullException | assemblyFile is a null String.
ArgumentException | assemblyFile is an empty String.
FileNotFoundException | assemblyFile is not found, or the file you are trying to check does not specify a filename extension.
SecurityException | The caller does not have path discovery permission.

See Also

FileFunctions Class | NAnt.Core.Functions Namespace


FileFunctions.UpToDate Method

Determines whether targetFile is more or equal up-to-date than srcFile.

[Visual Basic]
<Function(Name:="up-to-date")>
Public Function UpToDate( _
ByVal srcFile As String, _
ByVal targetFile As String _
) As Boolean
[C#]
[Function(Name="up-to-date")]
public bool UpToDate(
string srcFile,
string targetFile
);

Parameters

srcFile
The file to check against the target file.
targetFile
The file for which we want to determine the status.

Return Value

true if targetFile is more or equal up-to-date than srcFile; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentException | srcFile or targetFile is a zero-length string, contains only white space, or contains one or more invalid characters.
PathTooLongException | The specified path, file name, or both of either srcFile or targetFile exceed the system-defined maximum length.

See Also

FileFunctions Class | NAnt.Core.Functions Namespace


FileVersionInfoFunctions Class

Functions that provide version information for a physical file on disk.

For a list of all members of this type, see FileVersionInfoFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.FileVersionInfoFunctions

[Visual Basic]
<FunctionSet(Category:="Version", Prefix:="fileversioninfo")>
Public Class FileVersionInfoFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Version", Prefix="fileversioninfo")]
public class FileVersionInfoFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FileVersionInfoFunctions Members | NAnt.Core.Functions Namespace


FileVersionInfoFunctions Members

FileVersionInfoFunctions overview

Public Static (Shared) Methods

GetCompanyName | Gets the name of the company that produced the file.
GetFileVersion | Gets the file version of a file.
GetProductName | Gets the name of the product the file is distributed with.
GetProductVersion | Gets the product version of a file.

Public Instance Constructors

FileVersionInfoFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersionInfo | Returns a FileVersionInfo representing the version information associated with the specified file.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileVersionInfoFunctions Class | NAnt.Core.Functions Namespace


FileVersionInfoFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public FileVersionInfoFunctions(
Project project,
PropertyDictionary properties
);

See Also

FileVersionInfoFunctions Class | NAnt.Core.Functions Namespace


FileVersionInfoFunctions Methods

The methods of the FileVersionInfoFunctions class are listed below. For a complete list of FileVersionInfoFunctions class members, see the FileVersionInfoFunctions Members topic.

Public Static (Shared) Methods

GetCompanyName | Gets the name of the company that produced the file.
GetFileVersion | Gets the file version of a file.
GetProductName | Gets the name of the product the file is distributed with.
GetProductVersion | Gets the product version of a file.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersionInfo | Returns a FileVersionInfo representing the version information associated with the specified file.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileVersionInfoFunctions Class | NAnt.Core.Functions Namespace


FileVersionInfoFunctions.GetCompanyName Method

Gets the name of the company that produced the file.

[Visual Basic]
<Function(Name:="get-company-name")>
Public Shared Function GetCompanyName( _
ByVal fileVersionInfo As FileVersionInfo _
) As String
[C#]
[Function(Name="get-company-name")]
public static string GetCompanyName(
FileVersionInfo fileVersionInfo
);

Parameters

fileVersionInfo
A FileVersionInfo instance containing version information about a file.

Return Value

The name of the company that produced the file.

See Also

FileVersionInfoFunctions Class | NAnt.Core.Functions Namespace


FileVersionInfoFunctions.GetFileVersion Method

Gets the file version of a file.

[Visual Basic]
<Function(Name:="get-file-version")>
Public Shared Function GetFileVersion( _
ByVal fileVersionInfo As FileVersionInfo _
) As Version
[C#]
[Function(Name="get-file-version")]
public static Version GetFileVersion(
FileVersionInfo fileVersionInfo
);

Parameters

fileVersionInfo
A FileVersionInfo instance containing version information about a file.

Return Value

The file version of a file.

See Also

FileVersionInfoFunctions Class | NAnt.Core.Functions Namespace


FileVersionInfoFunctions.GetProductName Method

Gets the name of the product the file is distributed with.

[Visual Basic]
<Function(Name:="get-product-name")>
Public Shared Function GetProductName( _
ByVal fileVersionInfo As FileVersionInfo _
) As String
[C#]
[Function(Name="get-product-name")]
public static string GetProductName(
FileVersionInfo fileVersionInfo
);

Parameters

fileVersionInfo
A FileVersionInfo instance containing version information about a file.

Return Value

The name of the product the file is distributed with.

See Also

FileVersionInfoFunctions Class | NAnt.Core.Functions Namespace


FileVersionInfoFunctions.GetProductVersion Method

Gets the product version of a file.

[Visual Basic]
<Function(Name:="get-product-version")>
Public Shared Function GetProductVersion( _
ByVal fileVersionInfo As FileVersionInfo _
) As Version
[C#]
[Function(Name="get-product-version")]
public static Version GetProductVersion(
FileVersionInfo fileVersionInfo
);

Parameters

fileVersionInfo
A FileVersionInfo instance containing version information about a file.

Return Value

The product version of a file.

See Also

FileVersionInfoFunctions Class | NAnt.Core.Functions Namespace


FileVersionInfoFunctions.GetVersionInfo Method

Returns a FileVersionInfo representing the version information associated with the specified file.

[Visual Basic]
<Function(Name:="get-version-info")>
Public Function GetVersionInfo( _
ByVal fileName As String _
) As FileVersionInfo
[C#]
[Function(Name="get-version-info")]
public FileVersionInfo GetVersionInfo(
string fileName
);

Parameters

fileName
The file to retrieve the version information for.

Return Value

A FileVersionInfo containing information about the file.

Exceptions

Exception Type | Condition
FileNotFoundException | The file specified cannot be found.

See Also

FileVersionInfoFunctions Class | NAnt.Core.Functions Namespace


FrameworkFunctions Class

For a list of all members of this type, see FrameworkFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.FrameworkFunctions

[Visual Basic]
<FunctionSet(Category:="NAnt", Prefix:="framework")>
Public Class FrameworkFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="NAnt", Prefix="framework")]
public class FrameworkFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FrameworkFunctions Members | NAnt.Core.Functions Namespace


FrameworkFunctions Members

FrameworkFunctions overview

Public Instance Constructors

FrameworkFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists | Checks whether the specified framework exists, and is valid.
GetAssemblyDirectory | Gets the assembly directory of the specified framework.
GetClrVersion | Overloaded. Gets the Common Language Runtime version of the current target framework.
GetDescription | Overloaded. Gets the description of the current target framework.
GetFamily | Gets the family of the specified framework.
GetFrameworkDirectory | Gets the framework directory of the specified framework.
GetFrameworks | Gets a comma-separated list of frameworks filtered by the specified FrameworkTypes.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetRuntimeEngine | Gets the runtime engine of the specified framework.
GetRuntimeFramework | Gets the identifier of the runtime framework.
GetSdkDirectory | Gets the SDK directory of the specified framework.
GetTargetFramework | Gets the identifier of the current target framework.
GetToolPath | Gets the absolute path of the specified tool for the current target framework.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion | Overloaded. Gets the version of the current target framework.
SdkExists | Checks whether the SDK for the specified framework is installed.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace


FrameworkFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public FrameworkFunctions(
Project project,
PropertyDictionary properties
);

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace


FrameworkFunctions Methods

The methods of the FrameworkFunctions class are listed below. For a complete list of FrameworkFunctions class members, see the FrameworkFunctions Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists | Checks whether the specified framework exists, and is valid.
GetAssemblyDirectory | Gets the assembly directory of the specified framework.
GetClrVersion | Overloaded. Gets the Common Language Runtime version of the current target framework.
GetDescription | Overloaded. Gets the description of the current target framework.
GetFamily | Gets the family of the specified framework.
GetFrameworkDirectory | Gets the framework directory of the specified framework.
GetFrameworks | Gets a comma-separated list of frameworks filtered by the specified FrameworkTypes.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetRuntimeEngine | Gets the runtime engine of the specified framework.
GetRuntimeFramework | Gets the identifier of the runtime framework.
GetSdkDirectory | Gets the SDK directory of the specified framework.
GetTargetFramework | Gets the identifier of the current target framework.
GetToolPath | Gets the absolute path of the specified tool for the current target framework.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersion | Overloaded. Gets the version of the current target framework.
SdkExists | Checks whether the SDK for the specified framework is installed.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace


FrameworkFunctions.Exists Method

Checks whether the specified framework exists, and is valid.

[Visual Basic]
<Function(Name:="exists")>
Public Function Exists( _
ByVal framework As String _
) As Boolean
[C#]
[Function(Name="exists")]
public bool Exists(
string framework
);

Parameters

framework
The framework to test.

Return Value

true if the specified framework exists ; otherwise, false.

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace


FrameworkFunctions.GetAssemblyDirectory Method

Gets the assembly directory of the specified framework.

[Visual Basic]
<Function(Name:="get-assembly-directory")>
Public Function GetAssemblyDirectory( _
ByVal framework As String _
) As String
[C#]
[Function(Name="get-assembly-directory")]
public string GetAssemblyDirectory(
string framework
);

Parameters

framework
The framework of which the assembly directory should be returned.

Return Value

The assembly directory of the specified framework.

Exceptions

Exception Type | Condition
ArgumentException | framework is not a valid framework identifier.

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace | GetRuntimeFramework | GetTargetFramework


GetClrVersion Method

NAnt SDK Documentation - v0.91

FrameworkFunctions.GetClrVersion Method

Gets the Common Language Runtime version of the current target framework.

Overload List

Gets the Common Language Runtime version of the current target framework.

public Version GetClrVersion();

Gets the Common Language Runtime version of the specified framework.

public Version GetClrVersion(string);

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace | GetTargetFramework


FrameworkFunctions.GetClrVersion Method ()

Gets the Common Language Runtime version of the current target framework.

[Visual Basic]
<Function(Name:="get-clr-version")>
Overloads Public Function GetClrVersion() As Version
[C#]
[Function(Name="get-clr-version")]
public Version GetClrVersion();

Return Value

The Common Language Runtime version of the current target framework.

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace | FrameworkFunctions.GetClrVersion Overload List | GetTargetFramework


FrameworkFunctions.GetClrVersion Method (String)

Gets the Common Language Runtime version of the specified framework.

[Visual Basic]
<Function(Name:="get-clr-version")>
Overloads Public Function GetClrVersion( _
ByVal framework As String _
) As Version
[C#]
[Function(Name="get-clr-version")]
public Version GetClrVersion(
string framework
);

Parameters

framework
The framework of which the Common Language Runtime version should be returned.

Return Value

The Common Language Runtime version of the specified framework.

Exceptions

Exception Type | Condition
ArgumentException | framework is not a valid framework identifier.

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace | FrameworkFunctions.GetClrVersion Overload List | GetRuntimeFramework | GetTargetFramework


GetDescription Method

NAnt SDK Documentation - v0.91

FrameworkFunctions.GetDescription Method

Gets the description of the current target framework.

Overload List

Gets the description of the current target framework.

public string GetDescription();

Gets the description of the specified framework.

public string GetDescription(string);

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace | GetTargetFramework


FrameworkFunctions.GetDescription Method ()

Gets the description of the current target framework.

[Visual Basic]
<Function(Name:="get-description")>
Overloads Public Function GetDescription() As String
[C#]
[Function(Name="get-description")]
public string GetDescription();

Return Value

The description of the current target framework.

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace | FrameworkFunctions.GetDescription Overload List | GetTargetFramework


FrameworkFunctions.GetDescription Method (String)

Gets the description of the specified framework.

[Visual Basic]
<Function(Name:="get-description")>
Overloads Public Function GetDescription( _
ByVal framework As String _
) As String
[C#]
[Function(Name="get-description")]
public string GetDescription(
string framework
);

Parameters

framework
The framework of which the description should be returned.

Return Value

The description of the specified framework.

Exceptions

Exception Type | Condition
ArgumentException | framework is not a valid framework identifier.

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace | FrameworkFunctions.GetDescription Overload List | GetRuntimeFramework | GetTargetFramework


FrameworkFunctions.GetFamily Method

Gets the family of the specified framework.

[Visual Basic]
<Function(Name:="get-family")>
Public Function GetFamily( _
ByVal framework As String _
) As String
[C#]
[Function(Name="get-family")]
public string GetFamily(
string framework
);

Parameters

framework
The framework of which the family should be returned.

Return Value

The family of the specified framework.

Exceptions

Exception Type | Condition
ArgumentException | framework is not a valid framework identifier.

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace | GetRuntimeFramework | GetTargetFramework


FrameworkFunctions.GetFrameworkDirectory Method

Gets the framework directory of the specified framework.

[Visual Basic]
<Function(Name:="get-framework-directory")>
Public Function GetFrameworkDirectory( _
ByVal framework As String _
) As String
[C#]
[Function(Name="get-framework-directory")]
public string GetFrameworkDirectory(
string framework
);

Parameters

framework
The framework of which the framework directory should be returned.

Return Value

The framework directory of the specified framework.

Exceptions

Exception Type | Condition
ArgumentException | framework is not a valid framework identifier.

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace | GetRuntimeFramework | GetTargetFramework


FrameworkFunctions.GetFrameworks Method

Gets a comma-separated list of frameworks filtered by the specified FrameworkTypes.

[Visual Basic]
<Function(Name:="get-frameworks")>
Public Function GetFrameworks( _
ByVal types As FrameworkTypes _
) As String
[C#]
[Function(Name="get-frameworks")]
public string GetFrameworks(
FrameworkTypes types
);

Parameters

types
A bitwise combination of FrameworkTypes values that filter the frameworks to retrieve.

Return Value

A comma-separated list of frameworks filtered by the specified FrameworkTypes, sorted on name.

Example

Define a build-all target that executes the build target once for each installed framework targeting compact devices.

<target name="build-all">
    <foreach item="String" in="${framework::get-frameworks('installed compact')}" delim="," property="framework">
        <property name="nant.settings.currentframework" value="${framework}" />
        <call target="build" />
    </foreach>
</target>

<target name="build">
    ...
</target>

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace


FrameworkFunctions.GetRuntimeEngine Method

Gets the runtime engine of the specified framework.

[Visual Basic]
<Function(Name:="get-runtime-engine")>
Public Function GetRuntimeEngine( _
ByVal framework As String _
) As String
[C#]
[Function(Name="get-runtime-engine")]
public string GetRuntimeEngine(
string framework
);

Parameters

framework
The framework of which the runtime engine should be returned.

Return Value

The full path to the runtime engine of the specified framework, or an empty String if no runtime engine is defined for the specified framework.

Exceptions

Exception Type | Condition
ArgumentException | framework is not a valid framework identifier.

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace | GetRuntimeFramework | GetTargetFramework


FrameworkFunctions.GetRuntimeFramework Method

Gets the identifier of the runtime framework.

[Visual Basic]
<Function(Name:="get-runtime-framework")>
Public Function GetRuntimeFramework() As String
[C#]
[Function(Name="get-runtime-framework")]
public string GetRuntimeFramework();

Return Value

The identifier of the runtime framework.

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace


FrameworkFunctions.GetSdkDirectory Method

Gets the SDK directory of the specified framework.

[Visual Basic]
<Function(Name:="get-sdk-directory")>
Public Function GetSdkDirectory( _
ByVal framework As String _
) As String
[C#]
[Function(Name="get-sdk-directory")]
public string GetSdkDirectory(
string framework
);

Parameters

framework
The framework of which the SDK directory should be returned.

Return Value

The SDK directory of the specified framework, or an empty String if the SDK of the specified framework is not installed.

Exceptions

Exception Type | Condition
ArgumentException | framework is not a valid framework identifier.

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace | GetRuntimeFramework | GetTargetFramework


FrameworkFunctions.GetTargetFramework Method

Gets the identifier of the current target framework.

[Visual Basic]
<Function(Name:="get-target-framework")>
Public Function GetTargetFramework() As String
[C#]
[Function(Name="get-target-framework")]
public string GetTargetFramework();

Return Value

The identifier of the current target framework.

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace


FrameworkFunctions.GetToolPath Method

Gets the absolute path of the specified tool for the current target framework.

[Visual Basic]
<Function(Name:="get-tool-path")>
Public Function GetToolPath( _
ByVal tool As String _
) As String
[C#]
[Function(Name="get-tool-path")]
public string GetToolPath(
string tool
);

Parameters

tool
The file name of the tool to search for.

Return Value

The absolute path to tool if found in one of the configured tool paths; otherwise, an error is reported.

Remarks

The configured tool paths are scanned in the order in which they are defined in the framework configuration.

The file name of the tool to search should include the extension.

Exceptions

Exception Type | Condition
FileNotFoundException | tool could not be found in the configured tool paths.

Example

Use gacutil to install an assembly in the GAC.

<exec program="${framework::get-tool-path('gacutil.exe')}" managed="strict">
    <arg value="/i" />
    <arg file="Cegeka.HealthFramework.dll" />
</exec>

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace


GetVersion Method

NAnt SDK Documentation - v0.91

FrameworkFunctions.GetVersion Method

Gets the version of the current target framework.

Overload List

Gets the version of the current target framework.

public Version GetVersion();

Gets the version of the specified framework.

public Version GetVersion(string);

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace | GetTargetFramework


FrameworkFunctions.GetVersion Method ()

Gets the version of the current target framework.

[Visual Basic]
<Function(Name:="get-version")>
Overloads Public Function GetVersion() As Version
[C#]
[Function(Name="get-version")]
public Version GetVersion();

Return Value

The version of the current target framework.

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace | FrameworkFunctions.GetVersion Overload List | GetTargetFramework


FrameworkFunctions.GetVersion Method (String)

Gets the version of the specified framework.

[Visual Basic]
<Function(Name:="get-version")>
Overloads Public Function GetVersion( _
ByVal framework As String _
) As Version
[C#]
[Function(Name="get-version")]
public Version GetVersion(
string framework
);

Parameters

framework
The framework of which the version should be returned.

Return Value

The version of the specified framework.

Exceptions

Exception Type | Condition
ArgumentException | framework is not a valid framework identifier.

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace | FrameworkFunctions.GetVersion Overload List | GetRuntimeFramework | GetTargetFramework


FrameworkFunctions.SdkExists Method

Checks whether the SDK for the specified framework is installed.

[Visual Basic]
<Function(Name:="sdk-exists")>
Public Function SdkExists( _
ByVal framework As String _
) As Boolean
[C#]
[Function(Name="sdk-exists")]
public bool SdkExists(
string framework
);

Parameters

framework
The framework to test.

Return Value

true if the SDK for specified framework is installed; otherwise, false.

See Also

FrameworkFunctions Class | NAnt.Core.Functions Namespace | GetRuntimeFramework | GetTargetFramework


Int32ConversionFunctions Class

For a list of all members of this type, see Int32ConversionFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.Int32ConversionFunctions

[Visual Basic]
<FunctionSet(Category:="Conversion", Prefix:="int")>
Public Class Int32ConversionFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Conversion", Prefix="int")]
public class Int32ConversionFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

Int32ConversionFunctions Members | NAnt.Core.Functions Namespace


Int32ConversionFunctions Members

Int32ConversionFunctions overview

Public Static (Shared) Methods

Parse | Converts the specified string representation of a number to its 32-bit signed integer equivalent.
ToString | Overloaded. Converts the specified Int32 to its equivalent string representation.

Public Instance Constructors

Int32ConversionFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Int32ConversionFunctions Class | NAnt.Core.Functions Namespace


Int32ConversionFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public Int32ConversionFunctions(
Project project,
PropertyDictionary properties
);

See Also

Int32ConversionFunctions Class | NAnt.Core.Functions Namespace


Int32ConversionFunctions Methods

The methods of the Int32ConversionFunctions class are listed below. For a complete list of Int32ConversionFunctions class members, see the Int32ConversionFunctions Members topic.

Public Static (Shared) Methods

Parse | Converts the specified string representation of a number to its 32-bit signed integer equivalent.
ToString | Overloaded. Converts the specified Int32 to its equivalent string representation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Int32ConversionFunctions Class | NAnt.Core.Functions Namespace


Int32ConversionFunctions.Parse Method

Converts the specified string representation of a number to its 32-bit signed integer equivalent.

[Visual Basic]
<Function(Name:="parse")>
Public Shared Function Parse( _
ByVal s As String _
) As Integer
[C#]
[Function(Name="parse")]
public static int Parse(
string s
);

Parameters

s
A string containing a number to convert.

Return Value

A 32-bit signed integer equivalent to the number contained in s.

Remarks

The NumberFormatInfo for the invariant culture is used to supply formatting information about s.

Exceptions

Exception Type | Condition
FormatException | s is not of the correct format.
OverflowException | s represents a number less than MinValue or greater than MaxValue.

See Also

Int32ConversionFunctions Class | NAnt.Core.Functions Namespace


ToString Method

NAnt SDK Documentation - v0.91

Int32ConversionFunctions.ToString Method

Converts the specified Int32 to its equivalent string representation.

Overload List

Inherited from Object.

public virtual string ToString();

Converts the specified Int32 to its equivalent string representation.

public static string ToString(int);

See Also

Int32ConversionFunctions Class | NAnt.Core.Functions Namespace


Int32ConversionFunctions.ToString Method (Int32)

Converts the specified Int32 to its equivalent string representation.

[Visual Basic]
<Function(Name:="to-string")>
Overloads Public Shared Function ToString( _
ByVal value As Integer _
) As String
[C#]
[Function(Name="to-string")]
public static string ToString(
int value
);

Parameters

value
A Int32 to convert.

Return Value

The string representation of value, consisting of a negative sign if the value is negative, and a sequence of digits ranging from 0 to 9 with no leading zeroes.

Remarks

value is formatted with the NumberFormatInfo for the invariant culture.

See Also

Int32ConversionFunctions Class | NAnt.Core.Functions Namespace | Int32ConversionFunctions.ToString Overload List


Int64ConversionFunctions Class

For a list of all members of this type, see Int64ConversionFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.Int64ConversionFunctions

[Visual Basic]
<FunctionSet(Category:="Conversion", Prefix:="long")>
Public Class Int64ConversionFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Conversion", Prefix="long")]
public class Int64ConversionFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

Int64ConversionFunctions Members | NAnt.Core.Functions Namespace


Int64ConversionFunctions Members

Int64ConversionFunctions overview

Public Static (Shared) Methods

Parse | Converts the specified string representation of a number to its 64-bit signed integer equivalent.
ToString | Overloaded. Converts the specified Int64 to its equivalent string representation.

Public Instance Constructors

Int64ConversionFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Int64ConversionFunctions Class | NAnt.Core.Functions Namespace


Int64ConversionFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public Int64ConversionFunctions(
Project project,
PropertyDictionary properties
);

See Also

Int64ConversionFunctions Class | NAnt.Core.Functions Namespace


Int64ConversionFunctions Methods

The methods of the Int64ConversionFunctions class are listed below. For a complete list of Int64ConversionFunctions class members, see the Int64ConversionFunctions Members topic.

Public Static (Shared) Methods

Parse | Converts the specified string representation of a number to its 64-bit signed integer equivalent.
ToString | Overloaded. Converts the specified Int64 to its equivalent string representation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Int64ConversionFunctions Class | NAnt.Core.Functions Namespace


Int64ConversionFunctions.Parse Method

Converts the specified string representation of a number to its 64-bit signed integer equivalent.

[Visual Basic]
<Function(Name:="parse")>
Public Shared Function Parse( _
ByVal s As String _
) As Long
[C#]
[Function(Name="parse")]
public static long Parse(
string s
);

Parameters

s
A string containing a number to convert.

Return Value

A 64-bit signed integer equivalent to the number contained in s.

Remarks

The NumberFormatInfo for the invariant culture is used to supply formatting information about s.

Exceptions

Exception Type | Condition
FormatException | s is not of the correct format.
OverflowException | s represents a number less than MinValue or greater than MaxValue.

See Also

Int64ConversionFunctions Class | NAnt.Core.Functions Namespace


ToString Method

NAnt SDK Documentation - v0.91

Int64ConversionFunctions.ToString Method

Converts the specified Int64 to its equivalent string representation.

Overload List

Inherited from Object.

public virtual string ToString();

Converts the specified Int64 to its equivalent string representation.

public static string ToString(long);

See Also

Int64ConversionFunctions Class | NAnt.Core.Functions Namespace


Int64ConversionFunctions.ToString Method (Int64)

Converts the specified Int64 to its equivalent string representation.

[Visual Basic]
<Function(Name:="to-string")>
Overloads Public Shared Function ToString( _
ByVal value As Long _
) As String
[C#]
[Function(Name="to-string")]
public static string ToString(
long value
);

Parameters

value
A Int64 to convert.

Return Value

The string representation of value, consisting of a negative sign if the value is negative, and a sequence of digits ranging from 0 to 9 with no leading zeroes.

Remarks

value is formatted with the NumberFormatInfo for the invariant culture.

See Also

Int64ConversionFunctions Class | NAnt.Core.Functions Namespace | Int64ConversionFunctions.ToString Overload List


MathFunctions Class

For a list of all members of this type, see MathFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.MathFunctions

[Visual Basic]
<FunctionSet(Category:="Math", Prefix:="math")>
Public Class MathFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Math", Prefix="math")]
public class MathFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

MathFunctions Members | NAnt.Core.Functions Namespace


MathFunctions Members

MathFunctions overview

Public Static (Shared) Methods

Abs | Returns the absolute value of the specified number
Ceiling | Returns the smallest whole number greater than or equal to the specified number
Floor | Returns the largest whole number less than or equal to the specified number.
Round | Rounds the value to the nearest whole number

Public Instance Constructors

MathFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MathFunctions Class | NAnt.Core.Functions Namespace


MathFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public MathFunctions(
Project project,
PropertyDictionary properties
);

See Also

MathFunctions Class | NAnt.Core.Functions Namespace


MathFunctions Methods

The methods of the MathFunctions class are listed below. For a complete list of MathFunctions class members, see the MathFunctions Members topic.

Public Static (Shared) Methods

Abs | Returns the absolute value of the specified number
Ceiling | Returns the smallest whole number greater than or equal to the specified number
Floor | Returns the largest whole number less than or equal to the specified number.
Round | Rounds the value to the nearest whole number

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MathFunctions Class | NAnt.Core.Functions Namespace


MathFunctions.Abs Method

Returns the absolute value of the specified number

[Visual Basic]
<Function(Name:="abs")>
Public Shared Function Abs( _
ByVal value As Double _
) As Double
[C#]
[Function(Name="abs")]
public static double Abs(
double value
);

Parameters

value
value to take the absolute value from

Return Value

value when value is greater than or equal to zero; otherwise, -value.

See Also

MathFunctions Class | NAnt.Core.Functions Namespace


MathFunctions.Ceiling Method

Returns the smallest whole number greater than or equal to the specified number

[Visual Basic]
<Function(Name:="ceiling")>
Public Shared Function Ceiling( _
ByVal value As Double _
) As Double
[C#]
[Function(Name="ceiling")]
public static double Ceiling(
double value
);

Parameters

value
value

Return Value

The smallest whole number greater than or equal to the specified number.

See Also

MathFunctions Class | NAnt.Core.Functions Namespace


MathFunctions.Floor Method

Returns the largest whole number less than or equal to the specified number.

[Visual Basic]
<Function(Name:="floor")>
Public Shared Function Floor( _
ByVal value As Double _
) As Double
[C#]
[Function(Name="floor")]
public static double Floor(
double value
);

Parameters

value
value to be , can be anything convertible to a double

Return Value

The largest whole number less than or equal to the specified number.

See Also

MathFunctions Class | NAnt.Core.Functions Namespace


MathFunctions.Round Method

Rounds the value to the nearest whole number

[Visual Basic]
<Function(Name:="round")>
Public Shared Function Round( _
ByVal value As Double _
) As Double
[C#]
[Function(Name="round")]
public static double Round(
double value
);

Parameters

value
Number to be rounded, can be anything convertible to a double.

Return Value

Rounded value.

See Also

MathFunctions Class | NAnt.Core.Functions Namespace


NAntFunctions Class

For a list of all members of this type, see NAntFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.NAntFunctions

[Visual Basic]
<FunctionSet(Category:="NAnt", Prefix:="nant")>
Public Class NAntFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="NAnt", Prefix="nant")]
public class NAntFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

NAntFunctions Members | NAnt.Core.Functions Namespace


NAntFunctions Members

NAntFunctions overview

Public Instance Constructors

NAntFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssembly | Gets the NAnt assembly.
GetBaseDirectory | Gets the base directory of the appdomain in which NAnt is running.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ScanProbingPaths | Overloaded. Searches the probing paths of the current target framework for the specified file.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NAntFunctions Class | NAnt.Core.Functions Namespace


NAntFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public NAntFunctions(
Project project,
PropertyDictionary properties
);

See Also

NAntFunctions Class | NAnt.Core.Functions Namespace


NAntFunctions Methods

The methods of the NAntFunctions class are listed below. For a complete list of NAntFunctions class members, see the NAntFunctions Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssembly | Gets the NAnt assembly.
GetBaseDirectory | Gets the base directory of the appdomain in which NAnt is running.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ScanProbingPaths | Overloaded. Searches the probing paths of the current target framework for the specified file.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NAntFunctions Class | NAnt.Core.Functions Namespace


NAntFunctions.GetAssembly Method

Gets the NAnt assembly.

[Visual Basic]
<Function(Name:="get-assembly")>
Public Function GetAssembly() As Assembly
[C#]
[Function(Name="get-assembly")]
public Assembly GetAssembly();

Return Value

The NAnt assembly.

See Also

NAntFunctions Class | NAnt.Core.Functions Namespace


NAntFunctions.GetBaseDirectory Method

Gets the base directory of the appdomain in which NAnt is running.

[Visual Basic]
<Function(Name:="get-base-directory")>
Public Function GetBaseDirectory() As String
[C#]
[Function(Name="get-base-directory")]
public string GetBaseDirectory();

Return Value

The base directory of the appdomain in which NAnt is running.

See Also

NAntFunctions Class | NAnt.Core.Functions Namespace


ScanProbingPaths Method

NAnt SDK Documentation - v0.91

NAntFunctions.ScanProbingPaths Method

Searches the probing paths of the current target framework for the specified file.

Overload List

Searches the probing paths of the current target framework for the specified file.

public string ScanProbingPaths(string);

Searches the probing paths of the current target framework for the specified file.

public string ScanProbingPaths(string,string);

See Also

NAntFunctions Class | NAnt.Core.Functions Namespace


NAntFunctions.ScanProbingPaths Method (String)

Searches the probing paths of the current target framework for the specified file.

[Visual Basic]
<EditorBrowsable(State:=EditorBrowsableState.Never), _ Function(Name:="scan-probing-paths")>
Overloads Public Function ScanProbingPaths( _
ByVal fileName As String _
) As String
[C#]
[EditorBrowsable(State=EditorBrowsableState.Never)]
[Function(Name="scan-probing-paths")]
public string ScanProbingPaths(
string fileName
);

Parameters

fileName
The name of the file to search for.

Return Value

The absolute path to fileName if found in one of the configured probing; otherwise, an error is reported.

Remarks

The (relative) probing paths are resolved relative to the base directory of the appdomain in which NAnt is running.

The configured probing paths are scanned recursively in the order in which they are defined in the framework configuration.

The file name to search should include the extension.

Exceptions

Exception Type | Condition
FileNotFoundException | fileName could not be found in the configured probing paths.

Example

Compile an assembly referencing the nunit.framework assembly for the current target framework that is shipped as part of the NAnt distribution.

<csc target="library" output="NAnt.Core.Tests.dll">
    <sources basedir="NAnt.Core">
        <include name="**/*.cs" />
    </sources>
    <references>
        <include name="NAnt.Core.dll" />
        <include name="${framework::get-lib-path('nunit.framework.dll')}" />
    </references>
</csc>

See Also

NAntFunctions Class | NAnt.Core.Functions Namespace | NAntFunctions.ScanProbingPaths Overload List


NAntFunctions.ScanProbingPaths Method (String, String)

Searches the probing paths of the current target framework for the specified file.

[Visual Basic]
<Function(Name:="scan-probing-paths"), _ EditorBrowsable(State:=EditorBrowsableState.Never)>
Overloads Public Function ScanProbingPaths( _
ByVal baseDirectory As String, _
ByVal fileName As String _
) As String
[C#]
[Function(Name="scan-probing-paths")]
[EditorBrowsable(State=EditorBrowsableState.Never)]
public string ScanProbingPaths(
string baseDirectory,
string fileName
);

Parameters

baseDirectory
The directory to use a base directory for the probing paths.
fileName
The name of the file to search for.

Return Value

The absolute path to fileName if found in one of the configured probing; otherwise, an error is reported.

Remarks

The (relative) probing paths are resolved relative to the specified base directory.

The configured probing paths are scanned recursively in the order in which they are defined in the framework configuration.

The file name to search should include the extension.

Exceptions

Exception Type | Condition
FileNotFoundException | fileName could not be found in the configured probing paths.

Example

Compile an assembly referencing the nunit.framework assembly for the current target framework that is shipped as part of the NAnt distribution.

<csc target="library" output="NAnt.Core.Tests.dll">
    <sources basedir="NAnt.Core">
        <include name="**/*.cs" />
    </sources>
    <references>
        <include name="NAnt.Core.dll" />
        <include name="${framework::get-lib-path('nunit.framework.dll')}" />
    </references>
</csc>

See Also

NAntFunctions Class | NAnt.Core.Functions Namespace | NAntFunctions.ScanProbingPaths Overload List


OperatingSystemFunctions Class

Functions that return information about an operating system.

For a list of all members of this type, see OperatingSystemFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.OperatingSystemFunctions

[Visual Basic]
<FunctionSet(Category:="Operating System", Prefix:="operating-system")>
Public Class OperatingSystemFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Operating System", Prefix="operating-system")]
public class OperatingSystemFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

OperatingSystemFunctions Members | NAnt.Core.Functions Namespace


OperatingSystemFunctions Members

OperatingSystemFunctions overview

Public Static (Shared) Methods

GetPlatform | Gets a PlatformID value that identifies the operating system platform.
GetVersion | Gets a Version object that identifies this operating system.
ToString | Overloaded. Converts the value of the specified operating system to its equivalent String representation.

Public Instance Constructors

OperatingSystemFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OperatingSystemFunctions Class | NAnt.Core.Functions Namespace


OperatingSystemFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public OperatingSystemFunctions(
Project project,
PropertyDictionary properties
);

See Also

OperatingSystemFunctions Class | NAnt.Core.Functions Namespace


OperatingSystemFunctions Methods

The methods of the OperatingSystemFunctions class are listed below. For a complete list of OperatingSystemFunctions class members, see the OperatingSystemFunctions Members topic.

Public Static (Shared) Methods

GetPlatform | Gets a PlatformID value that identifies the operating system platform.
GetVersion | Gets a Version object that identifies this operating system.
ToString | Overloaded. Converts the value of the specified operating system to its equivalent String representation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OperatingSystemFunctions Class | NAnt.Core.Functions Namespace


OperatingSystemFunctions.GetPlatform Method

Gets a PlatformID value that identifies the operating system platform.

[Visual Basic]
<Function(Name:="get-platform")>
Public Shared Function GetPlatform( _
ByVal operatingSystem As OperatingSystem _
) As PlatformID
[C#]
[Function(Name="get-platform")]
public static PlatformID GetPlatform(
OperatingSystem operatingSystem
);

Parameters

operatingSystem
The operating system.

Return Value

PlatformID value that identifies the operating system platform.

See Also

OperatingSystemFunctions Class | NAnt.Core.Functions Namespace | GetOperatingSystem


OperatingSystemFunctions.GetVersion Method

Gets a Version object that identifies this operating system.

[Visual Basic]
<Function(Name:="get-version")>
Public Shared Function GetVersion( _
ByVal operatingSystem As OperatingSystem _
) As Version
[C#]
[Function(Name="get-version")]
public static Version GetVersion(
OperatingSystem operatingSystem
);

Parameters

operatingSystem
The operating system.

Return Value

A Version object that describes the major version, minor version, build, and revision of the operating system.

See Also

OperatingSystemFunctions Class | NAnt.Core.Functions Namespace | GetOperatingSystem


ToString Method

NAnt SDK Documentation - v0.91

OperatingSystemFunctions.ToString Method

Converts the value of the specified operating system to its equivalent String representation.

Overload List

Inherited from Object.

public virtual string ToString();

Converts the value of the specified operating system to its equivalent String representation.

public static string ToString(OperatingSystem);

See Also

OperatingSystemFunctions Class | NAnt.Core.Functions Namespace | GetOperatingSystem


OperatingSystemFunctions.ToString Method (OperatingSystem)

Converts the value of the specified operating system to its equivalent String representation.

[Visual Basic]
<Function(Name:="to-string")>
Overloads Public Shared Function ToString( _
ByVal operatingSystem As OperatingSystem _
) As String
[C#]
[Function(Name="to-string")]
public static string ToString(
OperatingSystem operatingSystem
);

Parameters

operatingSystem
The operating system.

Return Value

The String representation of operatingSystem.

Example

Output string representation of the current operating system.

<echo message="OS=${operating-system::to-string(environment::get-operating-system())}" />

If the operating system is Windows 2000, the output is:

Microsoft Windows NT 5.0.2195.0

See Also

OperatingSystemFunctions Class | NAnt.Core.Functions Namespace | OperatingSystemFunctions.ToString Overload List | GetOperatingSystem


PathFunctions Class

For a list of all members of this type, see PathFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.PathFunctions

[Visual Basic]
<FunctionSet(Category:="Path", Prefix:="path")>
Public Class PathFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Path", Prefix="path")]
public class PathFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

PathFunctions Members | NAnt.Core.Functions Namespace


PathFunctions Members

PathFunctions overview

Public Static (Shared) Methods

ChangeExtension | Changes the extension of the path string.
Combine | Combines two paths.
GetDirectoryName | Returns the directory information for the specified path string.
GetExtension | Returns the extension for the specified path string.
GetFileName | Returns the filename for the specified path string.
GetFileNameWithoutExtension | Returns the filename without extension for the specified path string.
GetPathRoot | Gets the root directory of the specified path.
GetTempFileName | Returns a uniquely named zero-byte temporary file on disk and returns the full path to that file.
GetTempPath | Gets the path to the temporary directory.
HasExtension | Determines whether a path string includes an extension.
IsPathRooted | Determines whether a path string is absolute.

Public Instance Constructors

PathFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFullPath | Returns the fully qualified path.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PathFunctions Class | NAnt.Core.Functions Namespace


PathFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public PathFunctions(
Project project,
PropertyDictionary properties
);

See Also

PathFunctions Class | NAnt.Core.Functions Namespace


PathFunctions Methods

The methods of the PathFunctions class are listed below. For a complete list of PathFunctions class members, see the PathFunctions Members topic.

Public Static (Shared) Methods

ChangeExtension | Changes the extension of the path string.
Combine | Combines two paths.
GetDirectoryName | Returns the directory information for the specified path string.
GetExtension | Returns the extension for the specified path string.
GetFileName | Returns the filename for the specified path string.
GetFileNameWithoutExtension | Returns the filename without extension for the specified path string.
GetPathRoot | Gets the root directory of the specified path.
GetTempFileName | Returns a uniquely named zero-byte temporary file on disk and returns the full path to that file.
GetTempPath | Gets the path to the temporary directory.
HasExtension | Determines whether a path string includes an extension.
IsPathRooted | Determines whether a path string is absolute.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFullPath | Returns the fully qualified path.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PathFunctions Class | NAnt.Core.Functions Namespace


PathFunctions.ChangeExtension Method

Changes the extension of the path string.

[Visual Basic]
<Function(Name:="change-extension")>
Public Shared Function ChangeExtension( _
ByVal path As String, _
ByVal extension As String _
) As String
[C#]
[Function(Name="change-extension")]
public static string ChangeExtension(
string path,
string extension
);

Parameters

path
The path information to modify. The path cannot contain any of the characters defined in InvalidPathCharsInvalidPathChars.
extension
The new extension (with a leading period). Specify a null reference to remove an existing extension from path.

Return Value

A string containing the modified path information.

On Windows-based desktop platforms, if path is an empty String, the path information is returned unmodified. If path has no extension, the returned path String contains extension appended to the end of path.

Remarks

For more information see the Path documentation.

Exceptions

Exception Type | Condition
ArgumentException | path contains one or more invalid characters.

See Also

PathFunctions Class | NAnt.Core.Functions Namespace


PathFunctions.Combine Method

Combines two paths.

[Visual Basic]
<Function(Name:="combine")>
Public Shared Function Combine( _
ByVal path1 As String, _
ByVal path2 As String _
) As String
[C#]
[Function(Name="combine")]
public static string Combine(
string path1,
string path2
);

Parameters

path1
first path
path2
second path

Return Value

A string containing the combined paths. If one of the specified paths is a zero-length string, this method returns the other path. If path2 contains an absolute path, this method returns path2.

Exceptions

Exception Type | Condition
ArgumentException | path1 or path2 contain one or more invalid characters.

See Also

PathFunctions Class | NAnt.Core.Functions Namespace


PathFunctions.GetDirectoryName Method

Returns the directory information for the specified path string.

[Visual Basic]
<Function(Name:="get-directory-name")>
Public Shared Function GetDirectoryName( _
ByVal path As String _
) As String
[C#]
[Function(Name="get-directory-name")]
public static string GetDirectoryName(
string path
);

Parameters

path
The path of a file or directory.

Return Value

A String containing directory information for path, or an empty String if path denotes a root directory, or does not contain directory information.

Exceptions

Exception Type | Condition
ArgumentException | path contains invalid characters, is empty, or contains only white spaces.

See Also

PathFunctions Class | NAnt.Core.Functions Namespace


PathFunctions.GetExtension Method

Returns the extension for the specified path string.

[Visual Basic]
<Function(Name:="get-extension")>
Public Shared Function GetExtension( _
ByVal path As String _
) As String
[C#]
[Function(Name="get-extension")]
public static string GetExtension(
string path
);

Parameters

path
The path string from which to get the extension.

Return Value

A String containing the extension of the specified path (including the "."), or an empty String if path does not have extension information.

Exceptions

Exception Type | Condition
ArgumentException | path contains one or more invalid characters.

See Also

PathFunctions Class | NAnt.Core.Functions Namespace


PathFunctions.GetFileName Method

Returns the filename for the specified path string.

[Visual Basic]
<Function(Name:="get-file-name")>
Public Shared Function GetFileName( _
ByVal path As String _
) As String
[C#]
[Function(Name="get-file-name")]
public static string GetFileName(
string path
);

Parameters

path
The path string from which to obtain the file name and extension.

Return Value

A String consisting of the characters after the last directory character in path.

If the last character of path is a directory or volume separator character, an empty String is returned.

Exceptions

Exception Type | Condition
ArgumentException | path contains one or more invalid characters.

See Also

PathFunctions Class | NAnt.Core.Functions Namespace


PathFunctions.GetFileNameWithoutExtension Method

Returns the filename without extension for the specified path string.

[Visual Basic]
<Function(Name:="get-file-name-without-extension")>
Public Shared Function GetFileNameWithoutExtension( _
ByVal path As String _
) As String
[C#]
[Function(Name="get-file-name-without-extension")]
public static string GetFileNameWithoutExtension(
string path
);

Parameters

path
The path of the file.

Return Value

A String containing the String returned by GetFileName, minus the last period (.) and all characters following it.

Exceptions

Exception Type | Condition
ArgumentException | path contains one or more invalid characters.

See Also

PathFunctions Class | NAnt.Core.Functions Namespace


PathFunctions.GetFullPath Method

Returns the fully qualified path.

[Visual Basic]
<Function(Name:="get-full-path")>
Public Function GetFullPath( _
ByVal path As String _
) As String
[C#]
[Function(Name="get-full-path")]
public string GetFullPath(
string path
);

Parameters

path
The file or directory for which to obtain absolute path information.

Return Value

A string containing the fully qualified location of path, such as "C:\MyFile.txt".

Exceptions

Exception Type | Condition
ArgumentException | path is a zero-length string, contains only white space, or contains one or more invalid characters.
NotSupportedException | path contains a colon (":").
PathTooLongException | The specified path, file name, or both exceed the system-defined maximum length.

See Also

PathFunctions Class | NAnt.Core.Functions Namespace


PathFunctions.GetPathRoot Method

Gets the root directory of the specified path.

[Visual Basic]
<Function(Name:="get-path-root")>
Public Shared Function GetPathRoot( _
ByVal path As String _
) As String
[C#]
[Function(Name="get-path-root")]
public static string GetPathRoot(
string path
);

Parameters

path
The path from which to obtain root directory information.

Return Value

A String containing the root directory of path, such as "C:\", or an empty String if path does not contain root directory information.

Exceptions

Exception Type | Condition
ArgumentException | path contains invalid characters, or is empty.

See Also

PathFunctions Class | NAnt.Core.Functions Namespace


PathFunctions.GetTempFileName Method

Returns a uniquely named zero-byte temporary file on disk and returns the full path to that file.

[Visual Basic]
<Function(Name:="get-temp-file-name")>
Public Shared Function GetTempFileName() As String
[C#]
[Function(Name="get-temp-file-name")]
public static string GetTempFileName();

Return Value

A String containing the name of the temporary file.

See Also

PathFunctions Class | NAnt.Core.Functions Namespace


PathFunctions.GetTempPath Method

Gets the path to the temporary directory.

[Visual Basic]
<Function(Name:="get-temp-path")>
Public Shared Function GetTempPath() As String
[C#]
[Function(Name="get-temp-path")]
public static string GetTempPath();

Return Value

A String containing the path information of a temporary directory.

See Also

PathFunctions Class | NAnt.Core.Functions Namespace


PathFunctions.HasExtension Method

Determines whether a path string includes an extension.

[Visual Basic]
<Function(Name:="has-extension")>
Public Shared Function HasExtension( _
ByVal path As String _
) As Boolean
[C#]
[Function(Name="has-extension")]
public static bool HasExtension(
string path
);

Parameters

path
The path to search for an extension.

Return Value

true. if the characters that follow the last directory separator or volume separator in the path include a period (.) followed by one or more characters; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentException | path contains one or more invalid characters.

See Also

PathFunctions Class | NAnt.Core.Functions Namespace


PathFunctions.IsPathRooted Method

Determines whether a path string is absolute.

[Visual Basic]
<Function(Name:="is-path-rooted")>
Public Shared Function IsPathRooted( _
ByVal path As String _
) As Boolean
[C#]
[Function(Name="is-path-rooted")]
public static bool IsPathRooted(
string path
);

Parameters

path
The path to test.

Return Value

true if path contains an absolute path; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentException | path contains one or more invalid characters.

See Also

PathFunctions Class | NAnt.Core.Functions Namespace


PkgConfigFunctions Class

For a list of all members of this type, see PkgConfigFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.PkgConfigFunctions

[Visual Basic]
<FunctionSet(Category:="Unix/Cygwin", Prefix:="pkg-config")>
Public Class PkgConfigFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Unix/Cygwin", Prefix="pkg-config")]
public class PkgConfigFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

PkgConfigFunctions Members | NAnt.Core.Functions Namespace


PkgConfigFunctions Members

PkgConfigFunctions overview

Public Instance Constructors

PkgConfigFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists | Determines whether the given package exists.
GetCompileFlags | Gets the compile flags required to compile the package, including all its dependencies.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLinkFlags | Gets the link flags required to compile the package, including all its dependencies.
GetModVersion | Determines the version of the given package.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVariable | Gets the value of a variable for the specified package.
IsAtLeastVersion | Determines whether the given package is at least version version.
IsBetweenVersion | Determines whether the given package is between two versions.
IsExactVersion | Determines whether the given package is exactly version version.
IsMaxVersion | Determines whether the given package is at no newer than version version.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PkgConfigFunctions Class | NAnt.Core.Functions Namespace


PkgConfigFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public PkgConfigFunctions(
Project project,
PropertyDictionary properties
);

See Also

PkgConfigFunctions Class | NAnt.Core.Functions Namespace


PkgConfigFunctions Methods

The methods of the PkgConfigFunctions class are listed below. For a complete list of PkgConfigFunctions class members, see the PkgConfigFunctions Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists | Determines whether the given package exists.
GetCompileFlags | Gets the compile flags required to compile the package, including all its dependencies.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLinkFlags | Gets the link flags required to compile the package, including all its dependencies.
GetModVersion | Determines the version of the given package.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVariable | Gets the value of a variable for the specified package.
IsAtLeastVersion | Determines whether the given package is at least version version.
IsBetweenVersion | Determines whether the given package is between two versions.
IsExactVersion | Determines whether the given package is exactly version version.
IsMaxVersion | Determines whether the given package is at no newer than version version.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PkgConfigFunctions Class | NAnt.Core.Functions Namespace


PkgConfigFunctions.Exists Method

Determines whether the given package exists.

[Visual Basic]
<Function(Name:="exists")>
Public Function Exists( _
ByVal package As String _
) As Boolean
[C#]
[Function(Name="exists")]
public bool Exists(
string package
);

Parameters

package
The package to check.

Return Value

true if the package exists; otherwise, false.

Exceptions

Exception Type | Condition
Win32Exception | pkg-config could not be started.

See Also

PkgConfigFunctions Class | NAnt.Core.Functions Namespace


PkgConfigFunctions.GetCompileFlags Method

Gets the compile flags required to compile the package, including all its dependencies.

[Visual Basic]
<Function(Name:="get-compile-flags")>
Public Function GetCompileFlags( _
ByVal package As String _
) As String
[C#]
[Function(Name="get-compile-flags")]
public string GetCompileFlags(
string package
);

Parameters

package
The package for which the compile flags should be retrieved.

Return Value

The pre-processor and compile flags required to compile the package.

Exceptions

Exception Type | Condition
Win32Exception | pkg-config could not be started.
ArgumentException | package does not exist.

See Also

PkgConfigFunctions Class | NAnt.Core.Functions Namespace


PkgConfigFunctions.GetLinkFlags Method

Gets the link flags required to compile the package, including all its dependencies.

[Visual Basic]
<Function(Name:="get-link-flags")>
Public Function GetLinkFlags( _
ByVal package As String _
) As String
[C#]
[Function(Name="get-link-flags")]
public string GetLinkFlags(
string package
);

Parameters

package
The package for which the link flags should be retrieved.

Return Value

The link flags required to compile the package.

Exceptions

Exception Type | Condition
Win32Exception | pkg-config could not be started.
ArgumentException | package does not exist.

See Also

PkgConfigFunctions Class | NAnt.Core.Functions Namespace


PkgConfigFunctions.GetModVersion Method

Determines the version of the given package.

[Visual Basic]
<Function(Name:="get-mod-version")>
Public Function GetModVersion( _
ByVal package As String _
) As String
[C#]
[Function(Name="get-mod-version")]
public string GetModVersion(
string package
);

Parameters

package
The package to get the version of.

Return Value

The version of the given package.

Exceptions

Exception Type | Condition
Win32Exception | pkg-config could not be started.
ArgumentException | package does not exist.

See Also

PkgConfigFunctions Class | NAnt.Core.Functions Namespace


PkgConfigFunctions.GetVariable Method

Gets the value of a variable for the specified package.

[Visual Basic]
<Function(Name:="get-variable")>
Public Function GetVariable( _
ByVal package As String, _
ByVal name As String _
) As String
[C#]
[Function(Name="get-variable")]
public string GetVariable(
string package,
string name
);

Parameters

package
The package for which the variable should be retrieved.
name
The name of the variable.

Return Value

The value of variable name for the specified package.

Exceptions

Exception Type | Condition
Win32Exception | pkg-config could not be started.
ArgumentException | package does not exist.

See Also

PkgConfigFunctions Class | NAnt.Core.Functions Namespace


PkgConfigFunctions.IsAtLeastVersion Method

Determines whether the given package is at least version version.

[Visual Basic]
<Function(Name:="is-atleast-version")>
Public Function IsAtLeastVersion( _
ByVal package As String, _
ByVal version As String _
) As Boolean
[C#]
[Function(Name="is-atleast-version")]
public bool IsAtLeastVersion(
string package,
string version
);

Parameters

package
The package to check.
version
The version the package should at least have.

Return Value

true if the given package is at least version version; otherwise, false.

Exceptions

Exception Type | Condition
Win32Exception | pkg-config could not be started.

See Also

PkgConfigFunctions Class | NAnt.Core.Functions Namespace


PkgConfigFunctions.IsBetweenVersion Method

Determines whether the given package is between two versions.

[Visual Basic]
<Function(Name:="is-between-version")>
Public Function IsBetweenVersion( _
ByVal package As String, _
ByVal minVersion As String, _
ByVal maxVersion As String _
) As Boolean
[C#]
[Function(Name="is-between-version")]
public bool IsBetweenVersion(
string package,
string minVersion,
string maxVersion
);

Parameters

package
The package to check.
minVersion
The version the package should at least have.
maxVersion
The version the package should maximum have.

Return Value

true if the given package is between minVersion and maxVersion; otherwise, false.

Exceptions

Exception Type | Condition
Win32Exception | pkg-config could not be started.

See Also

PkgConfigFunctions Class | NAnt.Core.Functions Namespace


PkgConfigFunctions.IsExactVersion Method

Determines whether the given package is exactly version version.

[Visual Basic]
<Function(Name:="is-exact-version")>
Public Function IsExactVersion( _
ByVal package As String, _
ByVal version As String _
) As Boolean
[C#]
[Function(Name="is-exact-version")]
public bool IsExactVersion(
string package,
string version
);

Parameters

package
The package to check.
version
The version the package should have.

Return Value

true if the given package is exactly version version; otherwise, false.

Exceptions

Exception Type | Condition
Win32Exception | pkg-config could not be started.

See Also

PkgConfigFunctions Class | NAnt.Core.Functions Namespace


PkgConfigFunctions.IsMaxVersion Method

Determines whether the given package is at no newer than version version.

[Visual Basic]
<Function(Name:="is-max-version")>
Public Function IsMaxVersion( _
ByVal package As String, _
ByVal version As String _
) As Boolean
[C#]
[Function(Name="is-max-version")]
public bool IsMaxVersion(
string package,
string version
);

Parameters

package
The package to check.
version
The version the package should maximum have.

Return Value

true if the given package is at no newer than version version; otherwise, false.

Exceptions

Exception Type | Condition
Win32Exception | pkg-config could not be started.

See Also

PkgConfigFunctions Class | NAnt.Core.Functions Namespace


PlatformFunctions Class

For a list of all members of this type, see PlatformFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.PlatformFunctions

[Visual Basic]
<FunctionSet(Category:="NAnt", Prefix:="platform")>
Public Class PlatformFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="NAnt", Prefix="platform")]
public class PlatformFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

PlatformFunctions Members | NAnt.Core.Functions Namespace


PlatformFunctions Members

PlatformFunctions overview

Public Static (Shared) Methods

IsUnix | Checks whether NAnt is running on Unix.
IsWin32 | Obsolete. Checks whether NAnt is running on Windows (and not just 32-bit Windows as the name may lead you to believe).
IsWindows | Checks whether NAnt is running on Windows.

Public Instance Constructors

PlatformFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetName | Gets the name of the platform on which NAnt is running.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PlatformFunctions Class | NAnt.Core.Functions Namespace


PlatformFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public PlatformFunctions(
Project project,
PropertyDictionary properties
);

See Also

PlatformFunctions Class | NAnt.Core.Functions Namespace


PlatformFunctions Methods

The methods of the PlatformFunctions class are listed below. For a complete list of PlatformFunctions class members, see the PlatformFunctions Members topic.

Public Static (Shared) Methods

IsUnix | Checks whether NAnt is running on Unix.
IsWin32 | Obsolete. Checks whether NAnt is running on Windows (and not just 32-bit Windows as the name may lead you to believe).
IsWindows | Checks whether NAnt is running on Windows.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetName | Gets the name of the platform on which NAnt is running.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PlatformFunctions Class | NAnt.Core.Functions Namespace


PlatformFunctions.GetName Method

Gets the name of the platform on which NAnt is running.

[Visual Basic]
<Function(Name:="get-name")>
Public Function GetName() As String
[C#]
[Function(Name="get-name")]
public string GetName();

Return Value

The name of the platform on which NAnt is running.

See Also

PlatformFunctions Class | NAnt.Core.Functions Namespace


PlatformFunctions.IsUnix Method

Checks whether NAnt is running on Unix.

[Visual Basic]
<Function(Name:="is-unix")>
Public Shared Function IsUnix() As Boolean
[C#]
[Function(Name="is-unix")]
public static bool IsUnix();

Return Value

true if NAnt is running on Unix; otherwise, false.

See Also

PlatformFunctions Class | NAnt.Core.Functions Namespace


PlatformFunctions.IsWin32 Method

NOTE: This method is now obsolete.

Use the is-windows function instead.

Checks whether NAnt is running on Windows (and not just 32-bit Windows as the name may lead you to believe).

[Visual Basic]
<Function(Name:="is-win32"), _ Obsolete(Message:="Use the is-windows function instead.", IsError:=False)>
Public Shared Function IsWin32() As Boolean
[C#]
[Function(Name="is-win32")]
[Obsolete(Message="Use the is-windows function instead.", IsError=False)]
public static bool IsWin32();

Return Value

true if NAnt is running on Windows; otherwise, false.

See Also

PlatformFunctions Class | NAnt.Core.Functions Namespace


PlatformFunctions.IsWindows Method

Checks whether NAnt is running on Windows.

[Visual Basic]
<Function(Name:="is-windows")>
Public Shared Function IsWindows() As Boolean
[C#]
[Function(Name="is-windows")]
public static bool IsWindows();

Return Value

true if NAnt is running on Windows; otherwise, false.

See Also

PlatformFunctions Class | NAnt.Core.Functions Namespace


ProjectFunctions Class

For a list of all members of this type, see ProjectFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.ProjectFunctions

[Visual Basic]
<FunctionSet(Category:="NAnt", Prefix:="project")>
Public Class ProjectFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="NAnt", Prefix="project")]
public class ProjectFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ProjectFunctions Members | NAnt.Core.Functions Namespace


ProjectFunctions Members

ProjectFunctions overview

Public Instance Constructors

ProjectFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseDirectory | Gets the base directory of the current project.
GetBuildFilePath | Gets the local path to the build file.
GetBuildFileUri | Gets the Uri form of the build file.
GetDefaultTarget | Gets the name of the target that will be executed when no other build targets are specified.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetName | Gets the name of the current project.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProjectFunctions Class | NAnt.Core.Functions Namespace


ProjectFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public ProjectFunctions(
Project project,
PropertyDictionary properties
);

See Also

ProjectFunctions Class | NAnt.Core.Functions Namespace


ProjectFunctions Methods

The methods of the ProjectFunctions class are listed below. For a complete list of ProjectFunctions class members, see the ProjectFunctions Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseDirectory | Gets the base directory of the current project.
GetBuildFilePath | Gets the local path to the build file.
GetBuildFileUri | Gets the Uri form of the build file.
GetDefaultTarget | Gets the name of the target that will be executed when no other build targets are specified.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetName | Gets the name of the current project.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProjectFunctions Class | NAnt.Core.Functions Namespace


ProjectFunctions.GetBaseDirectory Method

Gets the base directory of the current project.

[Visual Basic]
<Function(Name:="get-base-directory")>
Public Function GetBaseDirectory() As String
[C#]
[Function(Name="get-base-directory")]
public string GetBaseDirectory();

Return Value

The base directory of the current project.

See Also

ProjectFunctions Class | NAnt.Core.Functions Namespace


ProjectFunctions.GetBuildFilePath Method

Gets the local path to the build file.

[Visual Basic]
<Function(Name:="get-buildfile-path")>
Public Function GetBuildFilePath() As String
[C#]
[Function(Name="get-buildfile-path")]
public string GetBuildFilePath();

Return Value

The local path of the build file, or an empty String if the project is not file backed.

See Also

ProjectFunctions Class | NAnt.Core.Functions Namespace


ProjectFunctions.GetBuildFileUri Method

Gets the Uri form of the build file.

[Visual Basic]
<Function(Name:="get-buildfile-uri")>
Public Function GetBuildFileUri() As String
[C#]
[Function(Name="get-buildfile-uri")]
public string GetBuildFileUri();

Return Value

The Uri form of the build file, or an empty String if the project is not file backed.

See Also

ProjectFunctions Class | NAnt.Core.Functions Namespace


ProjectFunctions.GetDefaultTarget Method

Gets the name of the target that will be executed when no other build targets are specified.

[Visual Basic]
<Function(Name:="get-default-target")>
Public Function GetDefaultTarget() As String
[C#]
[Function(Name="get-default-target")]
public string GetDefaultTarget();

Return Value

The name of the target that will be executed when no other build targets are specified, or an empty String if no default target is defined for the project.

See Also

ProjectFunctions Class | NAnt.Core.Functions Namespace


ProjectFunctions.GetName Method

Gets the name of the current project.

[Visual Basic]
<Function(Name:="get-name")>
Public Function GetName() As String
[C#]
[Function(Name="get-name")]
public string GetName();

Return Value

The name of the current project, or an empty String if no name is specified in the build file.

See Also

ProjectFunctions Class | NAnt.Core.Functions Namespace


PropertyFunctions Class

For a list of all members of this type, see PropertyFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.PropertyFunctions

[Visual Basic]
<FunctionSet(Category:="NAnt", Prefix:="property")>
Public Class PropertyFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="NAnt", Prefix="property")]
public class PropertyFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

PropertyFunctions Members | NAnt.Core.Functions Namespace


PropertyFunctions Members

PropertyFunctions overview

Public Instance Constructors

PropertyFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists | Checks whether the specified property exists.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDynamic | Checks whether the specified property is a dynamic property.
IsReadOnly | Checks whether the specified property is read-only.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyFunctions Class | NAnt.Core.Functions Namespace


PropertyFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public PropertyFunctions(
Project project,
PropertyDictionary properties
);

See Also

PropertyFunctions Class | NAnt.Core.Functions Namespace


PropertyFunctions Methods

The methods of the PropertyFunctions class are listed below. For a complete list of PropertyFunctions class members, see the PropertyFunctions Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists | Checks whether the specified property exists.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDynamic | Checks whether the specified property is a dynamic property.
IsReadOnly | Checks whether the specified property is read-only.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyFunctions Class | NAnt.Core.Functions Namespace


PropertyFunctions.Exists Method

Checks whether the specified property exists.

[Visual Basic]
<Function(Name:="exists")>
Public Function Exists( _
ByVal name As String _
) As Boolean
[C#]
[Function(Name="exists")]
public bool Exists(
string name
);

Parameters

name
The property to test.

Return Value

true if the specified property exists; otherwise, false.

Example

Execute a set of tasks if the "build.debug" property exists.

            <if test="${property::exists('build.debug')}">
                <echo message="Starting debug build" />
                <call target="init-debug" />
                <call target="build" />
            </if>

See Also

PropertyFunctions Class | NAnt.Core.Functions Namespace


PropertyFunctions.IsDynamic Method

Checks whether the specified property is a dynamic property.

[Visual Basic]
<Function(Name:="is-dynamic")>
Public Function IsDynamic( _
ByVal name As String _
) As Boolean
[C#]
[Function(Name="is-dynamic")]
public bool IsDynamic(
string name
);

Parameters

name
The property to test.

Return Value

true if the specified property is a dynamic property; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentException | Property name has not been set.

Example

Check whether the "debug" property is a dynamic property.

property::is-dynamic('debug')

See Also

PropertyFunctions Class | NAnt.Core.Functions Namespace


PropertyFunctions.IsReadOnly Method

Checks whether the specified property is read-only.

[Visual Basic]
<Function(Name:="is-readonly")>
Public Function IsReadOnly( _
ByVal name As String _
) As Boolean
[C#]
[Function(Name="is-readonly")]
public bool IsReadOnly(
string name
);

Parameters

name
The property to test.

Return Value

true if the specified property is read-only; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentException | Property name has not been set.

Example

Check whether the "debug" property is read-only.

property::is-readonly('debug')

See Also

PropertyFunctions Class | NAnt.Core.Functions Namespace


StringFunctions Class

For a list of all members of this type, see StringFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.StringFunctions

[Visual Basic]
<FunctionSet(Category:="String", Prefix:="string")>
Public Class StringFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="String", Prefix="string")]
public class StringFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

StringFunctions Members | NAnt.Core.Functions Namespace


StringFunctions Members

StringFunctions overview

Public Static (Shared) Methods

Contains | Tests whether the specified string contains the given search string.
EndsWith | Tests whether the specified string ends with the specified suffix string.
GetLength | Returns the length of the specified string.
IndexOf | Returns the position of the first occurrence in the specified string of the given search string.
LastIndexOf | Returns the position of the last occurrence in the specified string of the given search string.
PadLeft | Returns the given string left-padded to the given length.
PadRight | Returns the given string right-padded to the given length.
Replace | Returns a string corresponding to the replacement of a given string with another in the specified string.
StartsWith | Tests whether the specified string starts with the specified prefix string.
Substring | Returns a substring of the specified string.
ToLower | Returns the specified string converted to lowercase.
ToUpper | Returns the specified string converted to uppercase.
Trim | Returns the given string trimmed of whitespace.
TrimEnd | Returns the given string trimmed of trailing whitespace.
TrimStart | Returns the given string trimmed of leading whitespace.

Public Instance Constructors

StringFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringFunctions Class | NAnt.Core.Functions Namespace


StringFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal propDict As PropertyDictionary _
)
[C#]
public StringFunctions(
Project project,
PropertyDictionary propDict
);

See Also

StringFunctions Class | NAnt.Core.Functions Namespace


StringFunctions Methods

The methods of the StringFunctions class are listed below. For a complete list of StringFunctions class members, see the StringFunctions Members topic.

Public Static (Shared) Methods

Contains | Tests whether the specified string contains the given search string.
EndsWith | Tests whether the specified string ends with the specified suffix string.
GetLength | Returns the length of the specified string.
IndexOf | Returns the position of the first occurrence in the specified string of the given search string.
LastIndexOf | Returns the position of the last occurrence in the specified string of the given search string.
PadLeft | Returns the given string left-padded to the given length.
PadRight | Returns the given string right-padded to the given length.
Replace | Returns a string corresponding to the replacement of a given string with another in the specified string.
StartsWith | Tests whether the specified string starts with the specified prefix string.
Substring | Returns a substring of the specified string.
ToLower | Returns the specified string converted to lowercase.
ToUpper | Returns the specified string converted to uppercase.
Trim | Returns the given string trimmed of whitespace.
TrimEnd | Returns the given string trimmed of trailing whitespace.
TrimStart | Returns the given string trimmed of leading whitespace.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringFunctions Class | NAnt.Core.Functions Namespace


StringFunctions.Contains Method

Tests whether the specified string contains the given search string.

[Visual Basic]
<Function(Name:="contains")>
Public Shared Function Contains( _
ByVal source As String, _
ByVal value As String _
) As Boolean
[C#]
[Function(Name="contains")]
public static bool Contains(
string source,
string value
);

Parameters

source
The string to search.
value
The string to locate within source.

Return Value

true if value is found in source; otherwise, false.

Remarks

This function performs a case-sensitive word search using the invariant culture.

Example

string::contains('testing string', 'test') ==> true
string::contains('testing string', '') ==> true
string::contains('testing string', 'Test') ==> false
string::contains('testing string', 'foo') ==> false

See Also

StringFunctions Class | NAnt.Core.Functions Namespace


StringFunctions.EndsWith Method

Tests whether the specified string ends with the specified suffix string.

[Visual Basic]
<Function(Name:="ends-with")>
Public Shared Function EndsWith( _
ByVal s1 As String, _
ByVal s2 As String _
) As Boolean
[C#]
[Function(Name="ends-with")]
public static bool EndsWith(
string s1,
string s2
);

Parameters

s1
test string
s2
suffix string

Return Value

true when s2 is a suffix for the string s1. Meaning, the characters at the end of s1 are identical to s2; otherwise, false.

Remarks

This function performs a case-sensitive word search using the invariant culture.

Example

string::ends-with('testing string', 'string') ==> true
string::ends-with('testing string', '') ==> true
string::ends-with('testing string', 'bring') ==> false
string::ends-with('string', 'testing string') ==> false

See Also

StringFunctions Class | NAnt.Core.Functions Namespace


StringFunctions.GetLength Method

Returns the length of the specified string.

[Visual Basic]
<Function(Name:="get-length")>
Public Shared Function GetLength( _
ByVal s As String _
) As Integer
[C#]
[Function(Name="get-length")]
public static int GetLength(
string s
);

Parameters

s
input string

Return Value

The string's length.

Example

string::get-length('foo') ==> 3
string::get-length('') ==> 0

See Also

StringFunctions Class | NAnt.Core.Functions Namespace


StringFunctions.IndexOf Method

Returns the position of the first occurrence in the specified string of the given search string.

[Visual Basic]
<Function(Name:="index-of")>
Public Shared Function IndexOf( _
ByVal source As String, _
ByVal value As String _
) As Integer
[C#]
[Function(Name="index-of")]
public static int IndexOf(
string source,
string value
);

Parameters

source
The string to search.
value
The string to locate within source.

Return Value

The lowest-index position of value in source if it is found, or -1 if source does not contain value.

If value is an empty string, the return value will always be 0.

Remarks

This function performs a case-sensitive word search using the invariant culture.

Example

string::index-of('testing string', 'test') ==> 0
string::index-of('testing string', '') ==> 0
string::index-of('testing string', 'Test') ==> -1
string::index-of('testing string', 'ing') ==> 4

See Also

StringFunctions Class | NAnt.Core.Functions Namespace


StringFunctions.LastIndexOf Method

Returns the position of the last occurrence in the specified string of the given search string.

[Visual Basic]
<Function(Name:="last-index-of")>
Public Shared Function LastIndexOf( _
ByVal source As String, _
ByVal value As String _
) As Integer
[C#]
[Function(Name="last-index-of")]
public static int LastIndexOf(
string source,
string value
);

Parameters

source
The string to search.
value
The string to locate within source.

Return Value

The highest-index position of value in source if it is found, or -1 if source does not contain value.

If value is an empty string, the return value is the last index position in source.

Remarks

This function performs a case-sensitive word search using the invariant culture.

Example

string::last-index-of('testing string', 'test') ==> 0
string::last-index-of('testing string', '') ==> 13
string::last-index-of('testing string', 'Test') ==> -1
string::last-index-of('testing string', 'ing') ==> 11

See Also

StringFunctions Class | NAnt.Core.Functions Namespace


StringFunctions.PadLeft Method

Returns the given string left-padded to the given length.

[Visual Basic]
<Function(Name:="pad-left")>
Public Shared Function PadLeft( _
ByVal s As String, _
ByVal totalWidth As Integer, _
ByVal paddingChar As String _
) As String
[C#]
[Function(Name="pad-left")]
public static string PadLeft(
string s,
int totalWidth,
string paddingChar
);

Parameters

s
The String that needs to be left-padded.
totalWidth
The number of characters in the resulting string, equal to the number of original characters plus any additional padding characters.
paddingChar
A Unicode padding character.

Return Value

If the length of s is at least totalWidth, then a new String identical to s is returned. Otherwise, s will be padded on the left with as many paddingChar characters as needed to create a length of totalWidth.

Remarks

Note that only the first character of paddingChar will be used when padding the result.

Exceptions

Exception Type | Condition
ArgumentException | totalWidth is less than zero.

Example

string::pad-left('test', 10, ' ') ==> '      test'
string::pad-left('test', 10, 'test') ==> 'tttttttest'
string::pad-left('test', 3, ' ') ==> 'test'
string::pad-left('test', -4, ' ') ==> ERROR

See Also

StringFunctions Class | NAnt.Core.Functions Namespace


StringFunctions.PadRight Method

Returns the given string right-padded to the given length.

[Visual Basic]
<Function(Name:="pad-right")>
Public Shared Function PadRight( _
ByVal s As String, _
ByVal totalWidth As Integer, _
ByVal paddingChar As String _
) As String
[C#]
[Function(Name="pad-right")]
public static string PadRight(
string s,
int totalWidth,
string paddingChar
);

Parameters

s
The String that needs to be right-padded.
totalWidth
The number of characters in the resulting string, equal to the number of original characters plus any additional padding characters.
paddingChar
A Unicode padding character.

Return Value

If the length of s is at least totalWidth, then a new String identical to s is returned. Otherwise, s will be padded on the right with as many paddingChar characters as needed to create a length of totalWidth.

Remarks

Note that only the first character of paddingChar will be used when padding the result.

Exceptions

Exception Type | Condition
ArgumentException | totalWidth is less than zero.

Example

string::pad-right('test', 10, ' ') ==> 'test      '
string::pad-right('test', 10, 'abcd') ==> 'testaaaaaa'
string::pad-right('test', 3, ' ') ==> 'test'
string::pad-right('test', -3, ' ') ==> ERROR

See Also

StringFunctions Class | NAnt.Core.Functions Namespace


StringFunctions.Replace Method

Returns a string corresponding to the replacement of a given string with another in the specified string.

[Visual Basic]
<Function(Name:="replace")>
Public Shared Function Replace( _
ByVal str As String, _
ByVal oldValue As String, _
ByVal newValue As String _
) As String
[C#]
[Function(Name="replace")]
public static string Replace(
string str,
string oldValue,
string newValue
);

Parameters

str
input string
oldValue
A String to be replaced.
newValue
A String to replace all occurrences of oldValue.

Return Value

A String equivalent to str but with all instances of oldValue replaced with newValue.

Remarks

This function performs a word (case-sensitive and culture-sensitive) search to find oldValue.

Exceptions

Exception Type | Condition
ArgumentException | oldValue is an empty string.

Example

string::replace('testing string', 'test', 'winn') ==> 'winning string'
string::replace('testing string', 'foo', 'winn') ==> 'testing string'
string::replace('testing string', 'ing', '') ==> 'test str'
string::replace('banana', 'ana', 'ana') ==> 'banana'

See Also

StringFunctions Class | NAnt.Core.Functions Namespace


StringFunctions.StartsWith Method

Tests whether the specified string starts with the specified prefix string.

[Visual Basic]
<Function(Name:="starts-with")>
Public Shared Function StartsWith( _
ByVal s1 As String, _
ByVal s2 As String _
) As Boolean
[C#]
[Function(Name="starts-with")]
public static bool StartsWith(
string s1,
string s2
);

Parameters

s1
test string
s2
prefix string

Return Value

true when s2 is a prefix for the string s1. Meaning, the characters at the beginning of s1 are identical to s2; otherwise, false.

Remarks

This function performs a case-sensitive word search using the invariant culture.

Example

string::starts-with('testing string', 'test') ==> true
string::starts-with('testing string', 'testing') ==> true
string::starts-with('testing string', 'string') ==> false
string::starts-with('test', 'testing string') ==> false

See Also

StringFunctions Class | NAnt.Core.Functions Namespace


StringFunctions.Substring Method

Returns a substring of the specified string.

[Visual Basic]
<Function(Name:="substring")>
Public Shared Function Substring( _
ByVal str As String, _
ByVal startIndex As Integer, _
ByVal length As Integer _
) As String
[C#]
[Function(Name="substring")]
public static string Substring(
string str,
int startIndex,
int length
);

Parameters

str
input string
startIndex
position of the start of the substring
length
the length of the substring

Return Value

If the length is greater than zero, the function returns a substring starting at character position startIndex with a length of length characters.

If the length is equal to zero, the function returns an empty string.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | startIndex or length is less than zero.
ArgumentOutOfRangeException | startIndex is greater than the length of str.
ArgumentOutOfRangeException | startIndex plus length indicates a position not within str.

Example

string::substring('testing string', 0, 4) ==> 'test'
string::substring('testing string', 8, 3) ==> 'str'
string::substring('testing string', 8, 0) ==> ''
string::substring('testing string', -1, 5) ==> ERROR
string::substring('testing string', 8, -1) ==> ERROR
string::substring('testing string', 5, 17) ==> ERROR

See Also

StringFunctions Class | NAnt.Core.Functions Namespace


StringFunctions.ToLower Method

Returns the specified string converted to lowercase.

[Visual Basic]
<Function(Name:="to-lower")>
Public Shared Function ToLower( _
ByVal s As String _
) As String
[C#]
[Function(Name="to-lower")]
public static string ToLower(
string s
);

Parameters

s
input string

Return Value

The string s in lowercase.

Remarks

The casing rules of the invariant culture are used to convert the s to lowercase.

Example

string::to-lower('testing string') ==> 'testing string'
string::to-lower('Testing String') ==> 'testing string'
string::to-lower('Test 123') ==> 'test 123'

See Also

StringFunctions Class | NAnt.Core.Functions Namespace


StringFunctions.ToUpper Method

Returns the specified string converted to uppercase.

[Visual Basic]
<Function(Name:="to-upper")>
Public Shared Function ToUpper( _
ByVal s As String _
) As String
[C#]
[Function(Name="to-upper")]
public static string ToUpper(
string s
);

Parameters

s
input string

Return Value

The string s in uppercase.

Remarks

The casing rules of the invariant culture are used to convert the s to uppercase.

Example

string::to-upper('testing string') ==> 'TESTING STRING'
string::to-upper('Testing String') ==> 'TESTING STRING'
string::to-upper('Test 123') ==> 'TEST 123'

See Also

StringFunctions Class | NAnt.Core.Functions Namespace


StringFunctions.Trim Method

Returns the given string trimmed of whitespace.

[Visual Basic]
<Function(Name:="trim")>
Public Shared Function Trim( _
ByVal s As String _
) As String
[C#]
[Function(Name="trim")]
public static string Trim(
string s
);

Parameters

s
input string

Return Value

The string s with any leading or trailing white space characters removed.

Example

string::trim('  test  ') ==> 'test'
string::trim('\t\tfoo  \r\n') ==> 'foo'

See Also

StringFunctions Class | NAnt.Core.Functions Namespace


StringFunctions.TrimEnd Method

Returns the given string trimmed of trailing whitespace.

[Visual Basic]
<Function(Name:="trim-end")>
Public Shared Function TrimEnd( _
ByVal s As String _
) As String
[C#]
[Function(Name="trim-end")]
public static string TrimEnd(
string s
);

Parameters

s
input string

Return Value

The string s with any trailing white space characters removed.

Example

string::trim-end('  test  ') ==> '  test'
string::trim-end('\t\tfoo  \r\n') ==> '\t\tfoo'

See Also

StringFunctions Class | NAnt.Core.Functions Namespace


StringFunctions.TrimStart Method

Returns the given string trimmed of leading whitespace.

[Visual Basic]
<Function(Name:="trim-start")>
Public Shared Function TrimStart( _
ByVal s As String _
) As String
[C#]
[Function(Name="trim-start")]
public static string TrimStart(
string s
);

Parameters

s
input string

Return Value

The string s with any leading whites pace characters removed.

Example

string::trim-start('  test  ') ==> 'test  '
string::trim-start('\t\tfoo  \r\n') ==> 'foo  \r\n'

See Also

StringFunctions Class | NAnt.Core.Functions Namespace


TargetFunctions Class

For a list of all members of this type, see TargetFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.TargetFunctions

[Visual Basic]
<FunctionSet(Category:="NAnt", Prefix:="target")>
Public Class TargetFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="NAnt", Prefix="target")]
public class TargetFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

TargetFunctions Members | NAnt.Core.Functions Namespace


TargetFunctions Members

TargetFunctions overview

Public Instance Constructors

TargetFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists | Checks whether the specified target exists.
GetCurrentTarget | Gets the name of the target being executed.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasExecuted | Checks whether the specified target has already been executed.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TargetFunctions Class | NAnt.Core.Functions Namespace


TargetFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public TargetFunctions(
Project project,
PropertyDictionary properties
);

See Also

TargetFunctions Class | NAnt.Core.Functions Namespace


TargetFunctions Methods

The methods of the TargetFunctions class are listed below. For a complete list of TargetFunctions class members, see the TargetFunctions Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists | Checks whether the specified target exists.
GetCurrentTarget | Gets the name of the target being executed.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasExecuted | Checks whether the specified target has already been executed.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TargetFunctions Class | NAnt.Core.Functions Namespace


TargetFunctions.Exists Method

Checks whether the specified target exists.

[Visual Basic]
<Function(Name:="exists")>
Public Function Exists( _
ByVal name As String _
) As Boolean
[C#]
[Function(Name="exists")]
public bool Exists(
string name
);

Parameters

name
The target to test.

Return Value

true if the specified target exists; otherwise, false.

Example

Execute target "clean", if it exists.

            <if test="${target::exists('clean')}">
                <call target="clean" />
            </if>

See Also

TargetFunctions Class | NAnt.Core.Functions Namespace


TargetFunctions.GetCurrentTarget Method

Gets the name of the target being executed.

[Visual Basic]
<Function(Name:="get-current-target")>
Public Function GetCurrentTarget() As String
[C#]
[Function(Name="get-current-target")]
public string GetCurrentTarget();

Return Value

A String that contains the name of the target being executed.

Exceptions

Exception Type | Condition
InvalidOperationException | No target is being executed.

See Also

TargetFunctions Class | NAnt.Core.Functions Namespace


TargetFunctions.HasExecuted Method

Checks whether the specified target has already been executed.

[Visual Basic]
<Function(Name:="has-executed")>
Public Function HasExecuted( _
ByVal name As String _
) As Boolean
[C#]
[Function(Name="has-executed")]
public bool HasExecuted(
string name
);

Parameters

name
The target to test.

Return Value

true if the specified target has already been executed; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentException | Target name does not exist.

See Also

TargetFunctions Class | NAnt.Core.Functions Namespace


TaskFunctions Class

For a list of all members of this type, see TaskFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.TaskFunctions

[Visual Basic]
<FunctionSet(Category:="NAnt", Prefix:="task")>
Public Class TaskFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="NAnt", Prefix="task")]
public class TaskFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

TaskFunctions Members | NAnt.Core.Functions Namespace


TaskFunctions Members

TaskFunctions overview

Public Instance Constructors

TaskFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists | Checks whether the specified task exists.
GetAssembly | Returns the Assembly from which the specified task was loaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaskFunctions Class | NAnt.Core.Functions Namespace


TaskFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public TaskFunctions(
Project project,
PropertyDictionary properties
);

See Also

TaskFunctions Class | NAnt.Core.Functions Namespace


TaskFunctions Methods

The methods of the TaskFunctions class are listed below. For a complete list of TaskFunctions class members, see the TaskFunctions Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists | Checks whether the specified task exists.
GetAssembly | Returns the Assembly from which the specified task was loaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaskFunctions Class | NAnt.Core.Functions Namespace


TaskFunctions.Exists Method

Checks whether the specified task exists.

[Visual Basic]
<Function(Name:="exists")>
Public Function Exists( _
ByVal name As String _
) As Boolean
[C#]
[Function(Name="exists")]
public bool Exists(
string name
);

Parameters

name
The task to test.

Return Value

true if the specified task exists; otherwise, false.

See Also

TaskFunctions Class | NAnt.Core.Functions Namespace


TaskFunctions.GetAssembly Method

Returns the Assembly from which the specified task was loaded.

[Visual Basic]
<Function(Name:="get-assembly")>
Public Function GetAssembly( _
ByVal name As String _
) As Assembly
[C#]
[Function(Name="get-assembly")]
public Assembly GetAssembly(
string name
);

Parameters

name
The name of the task to get the Assembly of.

Return Value

The Assembly from which the specified task was loaded.

Exceptions

Exception Type | Condition
ArgumentException | Task name is not available.

See Also

TaskFunctions Class | NAnt.Core.Functions Namespace


TimeSpanConversionFunctions Class

For a list of all members of this type, see TimeSpanConversionFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.TimeSpanConversionFunctions

[Visual Basic]
<FunctionSet(Category:="Conversion", Prefix:="timespan")>
Public Class TimeSpanConversionFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Conversion", Prefix="timespan")]
public class TimeSpanConversionFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

TimeSpanConversionFunctions Members | NAnt.Core.Functions Namespace


TimeSpanConversionFunctions Members

TimeSpanConversionFunctions overview

Public Static (Shared) Methods

Parse | Constructs a TimeSpan from a time indicated by a specified string.
ToString | Overloaded. Converts the specified TimeSpan to its equivalent string representation.

Public Instance Constructors

TimeSpanConversionFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeSpanConversionFunctions Class | NAnt.Core.Functions Namespace


TimeSpanConversionFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public TimeSpanConversionFunctions(
Project project,
PropertyDictionary properties
);

See Also

TimeSpanConversionFunctions Class | NAnt.Core.Functions Namespace


TimeSpanConversionFunctions Methods

The methods of the TimeSpanConversionFunctions class are listed below. For a complete list of TimeSpanConversionFunctions class members, see the TimeSpanConversionFunctions Members topic.

Public Static (Shared) Methods

Parse | Constructs a TimeSpan from a time indicated by a specified string.
ToString | Overloaded. Converts the specified TimeSpan to its equivalent string representation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeSpanConversionFunctions Class | NAnt.Core.Functions Namespace


TimeSpanConversionFunctions.Parse Method

Constructs a TimeSpan from a time indicated by a specified string.

[Visual Basic]
<Function(Name:="parse")>
Public Shared Function Parse( _
ByVal s As String _
) As TimeSpan
[C#]
[Function(Name="parse")]
public static TimeSpan Parse(
string s
);

Parameters

s
A string.

Return Value

A TimeSpan that corresponds to s.

Exceptions

Exception Type | Condition
FormatException | s has an invalid format.
OverflowException | At least one of the hours, minutes, or seconds components is outside its valid range.

See Also

TimeSpanConversionFunctions Class | NAnt.Core.Functions Namespace


ToString Method

NAnt SDK Documentation - v0.91

TimeSpanConversionFunctions.ToString Method

Converts the specified TimeSpan to its equivalent string representation.

Overload List

Inherited from Object.

public virtual string ToString();

Converts the specified TimeSpan to its equivalent string representation.

public static string ToString(TimeSpan);

See Also

TimeSpanConversionFunctions Class | NAnt.Core.Functions Namespace


TimeSpanConversionFunctions.ToString Method (TimeSpan)

Converts the specified TimeSpan to its equivalent string representation.

[Visual Basic]
<Function(Name:="to-string")>
Overloads Public Shared Function ToString( _
ByVal value As TimeSpan _
) As String
[C#]
[Function(Name="to-string")]
public static string ToString(
TimeSpan value
);

Parameters

value
A TimeSpan to convert.

Return Value

The string representation of value. The format of the return value is of the form: [-][d.]hh:mm:ss[.ff].

See Also

TimeSpanConversionFunctions Class | NAnt.Core.Functions Namespace | TimeSpanConversionFunctions.ToString Overload List


TimeSpanFunctions Class

For a list of all members of this type, see TimeSpanFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.TimeSpanFunctions

[Visual Basic]
<FunctionSet(Category:="Date/Time", Prefix:="timespan")>
Public Class TimeSpanFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Date/Time", Prefix="timespan")]
public class TimeSpanFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

TimeSpanFunctions Members | NAnt.Core.Functions Namespace


TimeSpanFunctions Members

TimeSpanFunctions overview

Public Static (Shared) Methods

FromDays | Returns a TimeSpan that represents a specified number of days, where the specification is accurate to the nearest millisecond.
FromHours | Returns a TimeSpan that represents a specified number of hours, where the specification is accurate to the nearest millisecond.
FromMilliseconds | Returns a TimeSpan that represents a specified number of milliseconds.
FromMinutes | Returns a TimeSpan that represents a specified number of minutes, where the specification is accurate to the nearest millisecond.
FromSeconds | Returns a TimeSpan that represents a specified number of seconds, where the specification is accurate to the nearest millisecond.
FromTicks | Returns a TimeSpan that represents a specified time, where the specification is in units of ticks.
GetDays | Returns the number of whole days represented by the specified TimeSpan.
GetHours | Returns the number of whole hours represented by the specified TimeSpan.
GetMilliseconds | Returns the number of whole milliseconds represented by the specified TimeSpan.
GetMinutes | Returns the number of whole minutes represented by the specified TimeSpan.
GetSeconds | Returns the number of whole seconds represented by the specified TimeSpan.
GetTicks | Returns the number of ticks contained in the specified TimeSpan.
GetTotalDays | Returns the total number of days represented by the specified TimeSpan, expressed in whole and fractional days.
GetTotalHours | Returns the total number of hours represented by the specified TimeSpan, expressed in whole and fractional hours.
GetTotalMilliseconds | Returns the total number of milliseconds represented by the specified TimeSpan, expressed in whole and fractional milliseconds.
GetTotalMinutes | Returns the total number of minutes represented by the specified TimeSpan, expressed in whole and fractional minutes.
GetTotalSeconds | Returns the total number of seconds represented by the specified TimeSpan, expressed in whole and fractional seconds.

Public Instance Constructors

TimeSpanFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


TimeSpanFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public TimeSpanFunctions(
Project project,
PropertyDictionary properties
);

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


TimeSpanFunctions Methods

The methods of the TimeSpanFunctions class are listed below. For a complete list of TimeSpanFunctions class members, see the TimeSpanFunctions Members topic.

Public Static (Shared) Methods

FromDays | Returns a TimeSpan that represents a specified number of days, where the specification is accurate to the nearest millisecond.
FromHours | Returns a TimeSpan that represents a specified number of hours, where the specification is accurate to the nearest millisecond.
FromMilliseconds | Returns a TimeSpan that represents a specified number of milliseconds.
FromMinutes | Returns a TimeSpan that represents a specified number of minutes, where the specification is accurate to the nearest millisecond.
FromSeconds | Returns a TimeSpan that represents a specified number of seconds, where the specification is accurate to the nearest millisecond.
FromTicks | Returns a TimeSpan that represents a specified time, where the specification is in units of ticks.
GetDays | Returns the number of whole days represented by the specified TimeSpan.
GetHours | Returns the number of whole hours represented by the specified TimeSpan.
GetMilliseconds | Returns the number of whole milliseconds represented by the specified TimeSpan.
GetMinutes | Returns the number of whole minutes represented by the specified TimeSpan.
GetSeconds | Returns the number of whole seconds represented by the specified TimeSpan.
GetTicks | Returns the number of ticks contained in the specified TimeSpan.
GetTotalDays | Returns the total number of days represented by the specified TimeSpan, expressed in whole and fractional days.
GetTotalHours | Returns the total number of hours represented by the specified TimeSpan, expressed in whole and fractional hours.
GetTotalMilliseconds | Returns the total number of milliseconds represented by the specified TimeSpan, expressed in whole and fractional milliseconds.
GetTotalMinutes | Returns the total number of minutes represented by the specified TimeSpan, expressed in whole and fractional minutes.
GetTotalSeconds | Returns the total number of seconds represented by the specified TimeSpan, expressed in whole and fractional seconds.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


TimeSpanFunctions.FromDays Method

Returns a TimeSpan that represents a specified number of days, where the specification is accurate to the nearest millisecond.

[Visual Basic]
<Function(Name:="from-days")>
Public Shared Function FromDays( _
ByVal value As Double _
) As TimeSpan
[C#]
[Function(Name="from-days")]
public static TimeSpan FromDays(
double value
);

Parameters

value
A number of days, accurate to the nearest millisecond.

Return Value

A TimeSpan that represents value.

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


TimeSpanFunctions.FromHours Method

Returns a TimeSpan that represents a specified number of hours, where the specification is accurate to the nearest millisecond.

[Visual Basic]
<Function(Name:="from-hours")>
Public Shared Function FromHours( _
ByVal value As Double _
) As TimeSpan
[C#]
[Function(Name="from-hours")]
public static TimeSpan FromHours(
double value
);

Parameters

value
A number of hours, accurate to the nearest millisecond.

Return Value

A TimeSpan that represents value.

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


TimeSpanFunctions.FromMilliseconds Method

Returns a TimeSpan that represents a specified number of milliseconds.

[Visual Basic]
<Function(Name:="from-milliseconds")>
Public Shared Function FromMilliseconds( _
ByVal value As Double _
) As TimeSpan
[C#]
[Function(Name="from-milliseconds")]
public static TimeSpan FromMilliseconds(
double value
);

Parameters

value
A number of milliseconds.

Return Value

A TimeSpan that represents value.

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


TimeSpanFunctions.FromMinutes Method

Returns a TimeSpan that represents a specified number of minutes, where the specification is accurate to the nearest millisecond.

[Visual Basic]
<Function(Name:="from-minutes")>
Public Shared Function FromMinutes( _
ByVal value As Double _
) As TimeSpan
[C#]
[Function(Name="from-minutes")]
public static TimeSpan FromMinutes(
double value
);

Parameters

value
A number of minutes, accurate to the nearest millisecond.

Return Value

A TimeSpan that represents value.

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


TimeSpanFunctions.FromSeconds Method

Returns a TimeSpan that represents a specified number of seconds, where the specification is accurate to the nearest millisecond.

[Visual Basic]
<Function(Name:="from-seconds")>
Public Shared Function FromSeconds( _
ByVal value As Double _
) As TimeSpan
[C#]
[Function(Name="from-seconds")]
public static TimeSpan FromSeconds(
double value
);

Parameters

value
A number of seconds, accurate to the nearest millisecond.

Return Value

A TimeSpan that represents value.

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


TimeSpanFunctions.FromTicks Method

Returns a TimeSpan that represents a specified time, where the specification is in units of ticks.

[Visual Basic]
<Function(Name:="from-ticks")>
Public Shared Function FromTicks( _
ByVal value As Long _
) As TimeSpan
[C#]
[Function(Name="from-ticks")]
public static TimeSpan FromTicks(
long value
);

Parameters

value
A number of ticks that represent a time.

Return Value

A TimeSpan that represents value.

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


TimeSpanFunctions.GetDays Method

Returns the number of whole days represented by the specified TimeSpan.

[Visual Basic]
<Function(Name:="get-days")>
Public Shared Function GetDays( _
ByVal value As TimeSpan _
) As Integer
[C#]
[Function(Name="get-days")]
public static int GetDays(
TimeSpan value
);

Parameters

value
A TimeSpan.

Return Value

The number of whole days represented by the given TimeSpan.

Example

Remove all files that have not been modified in the last 7 days from directory "binaries".

<foreach item="File" in="binaries" property="filename">
    <if test="${timespan::get-days(datetime::now() - file::get-last-write-time(filename)) >= 7}">
        <delete file="${filename}" />
    </if>
</foreach>

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


TimeSpanFunctions.GetHours Method

Returns the number of whole hours represented by the specified TimeSpan.

[Visual Basic]
<Function(Name:="get-hours")>
Public Shared Function GetHours( _
ByVal value As TimeSpan _
) As Integer
[C#]
[Function(Name="get-hours")]
public static int GetHours(
TimeSpan value
);

Parameters

value
A TimeSpan.

Return Value

The number of whole hours represented by the given TimeSpan.

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


TimeSpanFunctions.GetMilliseconds Method

Returns the number of whole milliseconds represented by the specified TimeSpan.

[Visual Basic]
<Function(Name:="get-milliseconds")>
Public Shared Function GetMilliseconds( _
ByVal value As TimeSpan _
) As Integer
[C#]
[Function(Name="get-milliseconds")]
public static int GetMilliseconds(
TimeSpan value
);

Parameters

value
A TimeSpan.

Return Value

The number of whole milliseconds represented by the given TimeSpan.

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


TimeSpanFunctions.GetMinutes Method

Returns the number of whole minutes represented by the specified TimeSpan.

[Visual Basic]
<Function(Name:="get-minutes")>
Public Shared Function GetMinutes( _
ByVal value As TimeSpan _
) As Integer
[C#]
[Function(Name="get-minutes")]
public static int GetMinutes(
TimeSpan value
);

Parameters

value
A TimeSpan.

Return Value

The number of whole minutes represented by the given TimeSpan.

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


TimeSpanFunctions.GetSeconds Method

Returns the number of whole seconds represented by the specified TimeSpan.

[Visual Basic]
<Function(Name:="get-seconds")>
Public Shared Function GetSeconds( _
ByVal value As TimeSpan _
) As Integer
[C#]
[Function(Name="get-seconds")]
public static int GetSeconds(
TimeSpan value
);

Parameters

value
A TimeSpan.

Return Value

The number of whole seconds represented by the given TimeSpan.

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


TimeSpanFunctions.GetTicks Method

Returns the number of ticks contained in the specified TimeSpan.

[Visual Basic]
<Function(Name:="get-ticks")>
Public Shared Function GetTicks( _
ByVal value As TimeSpan _
) As Long
[C#]
[Function(Name="get-ticks")]
public static long GetTicks(
TimeSpan value
);

Parameters

value
A TimeSpan.

Return Value

The number of ticks contained in the given TimeSpan.

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


TimeSpanFunctions.GetTotalDays Method

Returns the total number of days represented by the specified TimeSpan, expressed in whole and fractional days.

[Visual Basic]
<Function(Name:="get-total-days")>
Public Shared Function GetTotalDays( _
ByVal value As TimeSpan _
) As Double
[C#]
[Function(Name="get-total-days")]
public static double GetTotalDays(
TimeSpan value
);

Parameters

value
A TimeSpan.

Return Value

The total number of days represented by the given TimeSpan.

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


TimeSpanFunctions.GetTotalHours Method

Returns the total number of hours represented by the specified TimeSpan, expressed in whole and fractional hours.

[Visual Basic]
<Function(Name:="get-total-hours")>
Public Shared Function GetTotalHours( _
ByVal value As TimeSpan _
) As Double
[C#]
[Function(Name="get-total-hours")]
public static double GetTotalHours(
TimeSpan value
);

Parameters

value
A TimeSpan.

Return Value

The total number of hours represented by the given TimeSpan.

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


TimeSpanFunctions.GetTotalMilliseconds Method

Returns the total number of milliseconds represented by the specified TimeSpan, expressed in whole and fractional milliseconds.

[Visual Basic]
<Function(Name:="get-total-milliseconds")>
Public Shared Function GetTotalMilliseconds( _
ByVal value As TimeSpan _
) As Double
[C#]
[Function(Name="get-total-milliseconds")]
public static double GetTotalMilliseconds(
TimeSpan value
);

Parameters

value
A TimeSpan.

Return Value

The total number of milliseconds represented by the given TimeSpan.

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


TimeSpanFunctions.GetTotalMinutes Method

Returns the total number of minutes represented by the specified TimeSpan, expressed in whole and fractional minutes.

[Visual Basic]
<Function(Name:="get-total-minutes")>
Public Shared Function GetTotalMinutes( _
ByVal value As TimeSpan _
) As Double
[C#]
[Function(Name="get-total-minutes")]
public static double GetTotalMinutes(
TimeSpan value
);

Parameters

value
A TimeSpan.

Return Value

The total number of minutes represented by the given TimeSpan.

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


TimeSpanFunctions.GetTotalSeconds Method

Returns the total number of seconds represented by the specified TimeSpan, expressed in whole and fractional seconds.

[Visual Basic]
<Function(Name:="get-total-seconds")>
Public Shared Function GetTotalSeconds( _
ByVal value As TimeSpan _
) As Double
[C#]
[Function(Name="get-total-seconds")]
public static double GetTotalSeconds(
TimeSpan value
);

Parameters

value
A TimeSpan.

Return Value

The total number of seconds represented by the given TimeSpan.

See Also

TimeSpanFunctions Class | NAnt.Core.Functions Namespace


VersionConversionFunctions Class

For a list of all members of this type, see VersionConversionFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.VersionConversionFunctions

[Visual Basic]
<FunctionSet(Category:="Conversion", Prefix:="version")>
Public Class VersionConversionFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Conversion", Prefix="version")]
public class VersionConversionFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

VersionConversionFunctions Members | NAnt.Core.Functions Namespace


VersionConversionFunctions Members

VersionConversionFunctions overview

Public Static (Shared) Methods

Parse | Converts the specified string representation of a version to its Version equivalent.
ToString | Overloaded. Converts the specified Version to its equivalent string representation.

Public Instance Constructors

VersionConversionFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VersionConversionFunctions Class | NAnt.Core.Functions Namespace


VersionConversionFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public VersionConversionFunctions(
Project project,
PropertyDictionary properties
);

See Also

VersionConversionFunctions Class | NAnt.Core.Functions Namespace


VersionConversionFunctions Methods

The methods of the VersionConversionFunctions class are listed below. For a complete list of VersionConversionFunctions class members, see the VersionConversionFunctions Members topic.

Public Static (Shared) Methods

Parse | Converts the specified string representation of a version to its Version equivalent.
ToString | Overloaded. Converts the specified Version to its equivalent string representation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VersionConversionFunctions Class | NAnt.Core.Functions Namespace


VersionConversionFunctions.Parse Method

Converts the specified string representation of a version to its Version equivalent.

[Visual Basic]
<Function(Name:="parse")>
Public Shared Function Parse( _
ByVal version As String _
) As Version
[C#]
[Function(Name="parse")]
public static Version Parse(
string version
);

Parameters

version
A string containing the major, minor, build, and revision numbers, where each number is delimited with a period character ('.').

Return Value

A Version instance representing the specified String.

Exceptions

Exception Type | Condition
ArgumentException | version has fewer than two components or more than four components.
ArgumentOutOfRangeException | A major, minor, build, or revision component is less than zero.
FormatException | At least one component of version does not parse to a decimal integer.

See Also

VersionConversionFunctions Class | NAnt.Core.Functions Namespace


ToString Method

NAnt SDK Documentation - v0.91

VersionConversionFunctions.ToString Method

Converts the specified Version to its equivalent string representation.

Overload List

Inherited from Object.

public virtual string ToString();

Converts the specified Version to its equivalent string representation.

public static string ToString(Version);

See Also

VersionConversionFunctions Class | NAnt.Core.Functions Namespace | GetVersion | GetVersion | GetVersion


VersionConversionFunctions.ToString Method (Version)

Converts the specified Version to its equivalent string representation.

[Visual Basic]
<Function(Name:="to-string")>
Overloads Public Shared Function ToString( _
ByVal value As Version _
) As String
[C#]
[Function(Name="to-string")]
public static string ToString(
Version value
);

Parameters

value
A Version to convert.

Return Value

The string representation of the values of the major, minor, build, and revision components of the specified Version.

See Also

VersionConversionFunctions Class | NAnt.Core.Functions Namespace | VersionConversionFunctions.ToString Overload List | GetVersion | GetVersion | GetVersion


VersionFunctions Class

For a list of all members of this type, see VersionFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.VersionFunctions

[Visual Basic]
<FunctionSet(Category:="Version", Prefix:="version")>
Public Class VersionFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Version", Prefix="version")]
public class VersionFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Functions

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

VersionFunctions Members | NAnt.Core.Functions Namespace


VersionFunctions Members

VersionFunctions overview

Public Static (Shared) Methods

GetBuild | Gets the value of the build component of a given version.
GetMajor | Gets the value of the major component of a given version.
GetMinor | Gets the value of the minor component of a given version.
GetRevision | Gets the value of the revision component of a given version.

Public Instance Constructors

VersionFunctions Constructor

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VersionFunctions Class | NAnt.Core.Functions Namespace


VersionFunctions Constructor

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public VersionFunctions(
Project project,
PropertyDictionary properties
);

See Also

VersionFunctions Class | NAnt.Core.Functions Namespace


VersionFunctions Methods

The methods of the VersionFunctions class are listed below. For a complete list of VersionFunctions class members, see the VersionFunctions Members topic.

Public Static (Shared) Methods

GetBuild | Gets the value of the build component of a given version.
GetMajor | Gets the value of the major component of a given version.
GetMinor | Gets the value of the minor component of a given version.
GetRevision | Gets the value of the revision component of a given version.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VersionFunctions Class | NAnt.Core.Functions Namespace


VersionFunctions.GetBuild Method

Gets the value of the build component of a given version.

[Visual Basic]
<Function(Name:="get-build")>
Public Shared Function GetBuild( _
ByVal version As Version _
) As Integer
[C#]
[Function(Name="get-build")]
public static int GetBuild(
Version version
);

Parameters

version
A version.

Return Value

The build number, or -1 if the build number is undefined.

See Also

VersionFunctions Class | NAnt.Core.Functions Namespace | GetVersion | GetVersion | GetVersion


VersionFunctions.GetMajor Method

Gets the value of the major component of a given version.

[Visual Basic]
<Function(Name:="get-major")>
Public Shared Function GetMajor( _
ByVal version As Version _
) As Integer
[C#]
[Function(Name="get-major")]
public static int GetMajor(
Version version
);

Parameters

version
A version.

Return Value

The major version number.

See Also

VersionFunctions Class | NAnt.Core.Functions Namespace | GetVersion | GetVersion | GetVersion


VersionFunctions.GetMinor Method

Gets the value of the minor component of a given version.

[Visual Basic]
<Function(Name:="get-minor")>
Public Shared Function GetMinor( _
ByVal version As Version _
) As Integer
[C#]
[Function(Name="get-minor")]
public static int GetMinor(
Version version
);

Parameters

version
A version.

Return Value

The minor version number.

See Also

VersionFunctions Class | NAnt.Core.Functions Namespace | GetVersion | GetVersion | GetVersion


VersionFunctions.GetRevision Method

Gets the value of the revision component of a given version.

[Visual Basic]
<Function(Name:="get-revision")>
Public Shared Function GetRevision( _
ByVal version As Version _
) As Integer
[C#]
[Function(Name="get-revision")]
public static int GetRevision(
Version version
);

Parameters

version
A version.

Return Value

The revision number, or -1 if the revision number is undefined.

See Also

VersionFunctions Class | NAnt.Core.Functions Namespace | GetVersion | GetVersion | GetVersion


NAnt.Core.Tasks

NAnt SDK Documentation - v0.91

NAnt.Core.Tasks Namespace

Namespace hierarchy

Classes

Class | Description
AttribTask | Changes the file attributes of a file or set of files and directories.
AvailableTask | Obsolete. Checks if a resource is available at runtime.
CallTask | Calls a NAnt target in the current project.
CopyTask | Copies a file, a directory, or set of files to a new file or directory.
CopyTask.FileDateInfo | Holds the absolute paths and last write time of a given file.
DeleteTask | Deletes a file, fileset or directory.
DescriptionTask | An empty task that allows a build file to contain a description.
EchoTask | Writes a message to the build log or a specified file.
ExecTask | Executes a system command.
ExternalProgramBase | Provides the abstract base class for tasks that execute external applications.
FailTask | Exits the current build by throwing a BuildException, optionally printing additional information.
GetTask | Gets a particular file from a URL source.
IfNotTask | Obsolete. The opposite of the if task.
IfTask | Checks the conditional attributes and executes the children if true.
IncludeTask | Includes an external build file.
InElement |
LoadFileTask | Load a text file into a single property.
LoadTasksTask | Loads tasks form a given assembly or all assemblies in a given directory or FileSet.
LoopTask | Loops over a set of items.
MailTask | Sends an SMTP message.
MkDirTask | Creates a directory and any non-existent parent directory if necessary.
MoveTask | Moves a file, a directory, or set of files to a new file or directory.
NAntSchemaTask | Creates an XSD File for all available tasks.
NAntTask | Runs NAnt on a supplied build file, or a set of build files.
PropertyTask | Sets a property in the current project.
RegexTask | Sets project properties based on the evaluatuion of a regular expression.
SetEnvTask | Sets an environment variable or a whole collection of them. Use an empty LiteralValue attribute to clear a variable.
SleepTask | A task for sleeping a specified period of time, useful when a build or deployment process requires an interval between tasks.
StyleTask | Processes a document via XSLT.
SysInfoTask | Sets properties with system information.
TouchTask | Touches a file or set of files -- corresponds to the Unix touch command.
TStampTask | Sets properties with the current date and time.
UpToDateTask | Check modification dates on groups of files.
XmlPeekTask | Extracts text from an XML file at the location specified by an XPath expression.
XmlPokeTask | Replaces text in an XML file at the location specified by an XPath expression.

Enumerations

Enumeration | Description
AvailableTask.ResourceType | Defines the possible resource checks.
LoopTask.LoopItem |
LoopTask.LoopTrim |


AttribTask Class

Changes the file attributes of a file or set of files and directories.

For a list of all members of this type, see AttribTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.AttribTask

[Visual Basic]
<TaskName(Name:="attrib")>
Public Class AttribTask
Inherits Task
[C#]
[TaskName(Name="attrib")]
public class AttribTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

AttribTask does not have the concept of turning attributes off. Instead you specify all the attributes that you want turned on and the rest are turned off by default.

Refer to the FileAttributes enumeration in the .NET SDK for more information about file attributes.

Example

Set the read-only file attribute for the specified file in the project directory.

<attrib file="myfile.txt" readonly="true" />

Set the normal file attribute for the specified file.

<attrib file="myfile.txt" normal="true" />

Set the normal file attribute for all executable files in the current project directory and sub-directories.

<attrib normal="true">
    <fileset>
        <include name="**/*.exe" />
        <include name="bin" />
    </fileset>
</attrib>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

AttribTask Members | NAnt.Core.Tasks Namespace


AttribTask Members

AttribTask overview

Public Instance Constructors

AttribTask Constructor Initializes a new instance of the AttribTask class.

Public Instance Properties

ArchiveAttrib | Set the archive attribute. The default is false.
AttribFileSet | All the matching files and directories in this fileset will have their attributes set.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
File | The name of the file which will have its attributes set. This is provided as an alternate to using the task's fileset.
HiddenAttrib | Set the hidden attribute. The default is false.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NormalAttrib | Set the normal file attributes. This attribute is only valid if used alone. The default is false.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
ReadOnlyAttrib | Set the read-only attribute. The default is false.
SystemAttrib | Set the system attribute. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttribTask Class | NAnt.Core.Tasks Namespace


AttribTask Constructor

Initializes a new instance of the AttribTask class.

[Visual Basic]
Public Sub New()
[C#]
public AttribTask();

See Also

AttribTask Class | NAnt.Core.Tasks Namespace


AttribTask Properties

The properties of the AttribTask class are listed below. For a complete list of AttribTask class members, see the AttribTask Members topic.

Public Instance Properties

ArchiveAttrib | Set the archive attribute. The default is false.
AttribFileSet | All the matching files and directories in this fileset will have their attributes set.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
File | The name of the file which will have its attributes set. This is provided as an alternate to using the task's fileset.
HiddenAttrib | Set the hidden attribute. The default is false.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NormalAttrib | Set the normal file attributes. This attribute is only valid if used alone. The default is false.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
ReadOnlyAttrib | Set the read-only attribute. The default is false.
SystemAttrib | Set the system attribute. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

AttribTask Class | NAnt.Core.Tasks Namespace


ArchiveAttrib Property

NAnt SDK Documentation - v0.91

AttribTask.ArchiveAttrib Property

Set the archive attribute. The default is false.

[Visual Basic]
<TaskAttribute(Name:="archive", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property ArchiveAttrib As Boolean
[C#]
[TaskAttribute(Name="archive", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool ArchiveAttrib {get; set;}

See Also

AttribTask Class | NAnt.Core.Tasks Namespace


AttribFileSet Property

NAnt SDK Documentation - v0.91

AttribTask.AttribFileSet Property

All the matching files and directories in this fileset will have their attributes set.

[Visual Basic]
<BuildElement(Name:="fileset", Required:=False, ProcessXml:=True)>
Public Property AttribFileSet As FileSet
[C#]
[BuildElement(Name="fileset", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet AttribFileSet {get; set;}

See Also

AttribTask Class | NAnt.Core.Tasks Namespace


File Property

NAnt SDK Documentation - v0.91

AttribTask.File Property

The name of the file which will have its attributes set. This is provided as an alternate to using the task's fileset.

[Visual Basic]
<TaskAttribute(Name:="file", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property File As FileInfo
[C#]
[TaskAttribute(Name="file", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo File {get; set;}

See Also

AttribTask Class | NAnt.Core.Tasks Namespace


HiddenAttrib Property

NAnt SDK Documentation - v0.91

AttribTask.HiddenAttrib Property

Set the hidden attribute. The default is false.

[Visual Basic]
<TaskAttribute(Name:="hidden", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property HiddenAttrib As Boolean
[C#]
[TaskAttribute(Name="hidden", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool HiddenAttrib {get; set;}

See Also

AttribTask Class | NAnt.Core.Tasks Namespace


NormalAttrib Property

NAnt SDK Documentation - v0.91

AttribTask.NormalAttrib Property

Set the normal file attributes. This attribute is only valid if used alone. The default is false.

[Visual Basic]
<TaskAttribute(Name:="normal", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property NormalAttrib As Boolean
[C#]
[TaskAttribute(Name="normal", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool NormalAttrib {get; set;}

See Also

AttribTask Class | NAnt.Core.Tasks Namespace


ReadOnlyAttrib Property

NAnt SDK Documentation - v0.91

AttribTask.ReadOnlyAttrib Property

Set the read-only attribute. The default is false.

[Visual Basic]
<TaskAttribute(Name:="readonly", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property ReadOnlyAttrib As Boolean
[C#]
[TaskAttribute(Name="readonly", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool ReadOnlyAttrib {get; set;}

See Also

AttribTask Class | NAnt.Core.Tasks Namespace


SystemAttrib Property

NAnt SDK Documentation - v0.91

AttribTask.SystemAttrib Property

Set the system attribute. The default is false.

[Visual Basic]
<TaskAttribute(Name:="system", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property SystemAttrib As Boolean
[C#]
[TaskAttribute(Name="system", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool SystemAttrib {get; set;}

See Also

AttribTask Class | NAnt.Core.Tasks Namespace


AttribTask Methods

The methods of the AttribTask class are listed below. For a complete list of AttribTask class members, see the AttribTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttribTask Class | NAnt.Core.Tasks Namespace


AttribTask.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

AttribTask Class | NAnt.Core.Tasks Namespace


AvailableTask Class

NOTE: This class is now obsolete.

Use functions instead.

Checks if a resource is available at runtime.

For a list of all members of this type, see AvailableTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.AvailableTask

[Visual Basic]
<Obsolete(Message:="Use functions instead.", IsError:=False), _ TaskName(Name:="available")>
Public Class AvailableTask
Inherits Task
[C#]
[Obsolete(Message="Use functions instead.", IsError=False)]
[TaskName(Name="available")]
public class AvailableTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The specified property is set to true if the requested resource is available at runtime, and false if the resource is not available.

Note we advise you to use the following functions instead:
Function | Description
Exists | Determines whether the specified file exists.
Exists | Determines whether the given path refers to an existing directory on disk.
Exists | Checks whether the specified framework exists..
SdkExists | Checks whether the SDK for the specified framework is installed.

Example

Sets the myfile.present property to true if the file is available on the filesystem and false if the file is not available.

<available type="File" resource="myfile.txt" property="myfile.present" />

Sets the build.dir.present property to true if the directory is available on the filesystem and false if the directory is not available.

<available type="Directory" resource="build" property="build.dir.present" />

Sets the mono-0.21.framework.present property to true if the Mono 0.21 framework is available on the current system and false if the framework is not available.

<available type="Framework" resource="mono-0.21" property="mono-0.21.framework.present" />

Sets the net-1.1.frameworksdk.present property to true if the .NET 1.1 Framework SDK is available on the current system and false if the SDK is not available.

<available type="FrameworkSDK" resource="net-1.1" property="net-1.1.frameworksdk.present" />

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

AvailableTask Members | NAnt.Core.Tasks Namespace


AvailableTask Members

AvailableTask overview

Public Instance Constructors

AvailableTask Constructor Initializes a new instance of the AvailableTask class.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PropertyName | The property that must be set if the resource is available.
Resource | The resource which must be available.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
Type | The type of resource which must be present.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Evaluate | Evaluates the availability of a resource.
ExecuteTask | Executes the task.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AvailableTask Class | NAnt.Core.Tasks Namespace


AvailableTask Constructor

Initializes a new instance of the AvailableTask class.

[Visual Basic]
Public Sub New()
[C#]
public AvailableTask();

See Also

AvailableTask Class | NAnt.Core.Tasks Namespace


AvailableTask Properties

The properties of the AvailableTask class are listed below. For a complete list of AvailableTask class members, see the AvailableTask Members topic.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PropertyName | The property that must be set if the resource is available.
Resource | The resource which must be available.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
Type | The type of resource which must be present.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

AvailableTask Class | NAnt.Core.Tasks Namespace


PropertyName Property

NAnt SDK Documentation - v0.91

AvailableTask.PropertyName Property

The property that must be set if the resource is available.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="property", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property PropertyName As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="property", Required=True, ExpandProperties=True, ProcessXml=True)]
public string PropertyName {get; set;}

See Also

AvailableTask Class | NAnt.Core.Tasks Namespace


Resource Property

NAnt SDK Documentation - v0.91

AvailableTask.Resource Property

The resource which must be available.

[Visual Basic]
<TaskAttribute(Name:="resource", Required:=True, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property Resource As String
[C#]
[TaskAttribute(Name="resource", Required=True, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string Resource {get; set;}

See Also

AvailableTask Class | NAnt.Core.Tasks Namespace


Type Property

NAnt SDK Documentation - v0.91

AvailableTask.Type Property

The type of resource which must be present.

[Visual Basic]
<TaskAttribute(Name:="type", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property Type As ResourceType
[C#]
[TaskAttribute(Name="type", Required=True, ExpandProperties=True, ProcessXml=True)]
public AvailableTask.ResourceType Type {get; set;}

See Also

AvailableTask Class | NAnt.Core.Tasks Namespace


AvailableTask Methods

The methods of the AvailableTask class are listed below. For a complete list of AvailableTask class members, see the AvailableTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Evaluate | Evaluates the availability of a resource.
ExecuteTask | Executes the task.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AvailableTask Class | NAnt.Core.Tasks Namespace


AvailableTask.Evaluate Method

Evaluates the availability of a resource.

[Visual Basic]
Overridable Protected Function Evaluate() As Boolean
[C#]
protected virtual bool Evaluate();

Return Value

true if the resource is available; otherwise, false.

Exceptions

Exception Type | Condition
BuildException | The availability of the resource could not be evaluated.

See Also

AvailableTask Class | NAnt.Core.Tasks Namespace


AvailableTask.ExecuteTask Method

Executes the task.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

Remarks

Sets the property identified by PropertyName to true when the resource exists and to false when the resource doesn't exist.

Exceptions

Exception Type | Condition
BuildException | The availability of the resource could not be evaluated.

See Also

AvailableTask Class | NAnt.Core.Tasks Namespace


AvailableTask.ResourceType Enumeration

Defines the possible resource checks.

[Visual Basic]
<Serializable>
Public Enum AvailableTask.ResourceType
[C#]
[Serializable]
public enum AvailableTask.ResourceType

Members

Member Name | Description
File | Determines whether a given file exists.
Directory | Determines whether a given directory exists.
Framework | Determines whether a given framework is available.
FrameworkSDK | Determines whether a given SDK is available.

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

NAnt.Core.Tasks Namespace


CallTask Class

Calls a NAnt target in the current project.

For a list of all members of this type, see CallTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.CallTask

[Visual Basic]
<TaskName(Name:="call")>
Public Class CallTask
Inherits Task
[C#]
[TaskName(Name="call")]
public class CallTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

When the CallTask is used to execute a target, both that target and all its dependent targets will be re-executed.

To avoid dependent targets from being executed more than once, two options are available:

  • Add an "unless" attribute with value "${target::has-executed('<target name>')}" to the dependent targets.
  • Set the CascadeDependencies attribute on the CallTask to false (recommended).

Example

Call the target "build".

<call target="build" />

This shows how a project could 'compile' a debug and release build using a common compile target.

<project default="build">
    <property name="debug" value="false" />
    <target name="init">
        <echo message="initializing" />
    </target>
    <target name="compile" depends="init">
        <echo message="compiling with debug = ${debug}" />
    </target>
    <target name="build">
        <property name="debug" value="false" />
        <call target="compile" />
        <property name="debug" value="true" />
        <call target="compile" />
    </target>
</project>

The CascadeDependencies parameter of the CallTask defaults to true, causing the "init" target to be executed for both the "debug" and "release" build.

This results in the following build log:

build:

init:
                [echo] initializing

compile:

    [echo] compiling with debug = false

init:

    [echo] initializing

compile:

    [echo] compiling with debug = true

BUILD SUCCEEDED

If the "init" should only be executed once, set the CascadeDependencies attribute of the CallTask to false.

The build log would then look like this:

build:

init:
                [echo] initializing

compile:

    [echo] compiling with debug = false

compile:

    [echo] compiling with debug = true

BUILD SUCCEEDED

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

CallTask Members | NAnt.Core.Tasks Namespace


CallTask Members

CallTask overview

Public Instance Constructors

CallTask Constructor Initializes a new instance of the CallTask class.

Public Instance Properties

CascadeDependencies | Execute the specified targets dependencies -- even if they have been previously executed. The default is true.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForceExecute | Obsolete. Force an execute even if the target has already been executed. The default is false.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
TargetName | NAnt target to call.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Executes the specified target.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Makes sure the CallTask is not calling its own parent.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CallTask Class | NAnt.Core.Tasks Namespace


CallTask Constructor

Initializes a new instance of the CallTask class.

[Visual Basic]
Public Sub New()
[C#]
public CallTask();

See Also

CallTask Class | NAnt.Core.Tasks Namespace


CallTask Properties

The properties of the CallTask class are listed below. For a complete list of CallTask class members, see the CallTask Members topic.

Public Instance Properties

CascadeDependencies | Execute the specified targets dependencies -- even if they have been previously executed. The default is true.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForceExecute | Obsolete. Force an execute even if the target has already been executed. The default is false.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
TargetName | NAnt target to call.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

CallTask Class | NAnt.Core.Tasks Namespace


CascadeDependencies Property

NAnt SDK Documentation - v0.91

CallTask.CascadeDependencies Property

Execute the specified targets dependencies -- even if they have been previously executed. The default is true.

[Visual Basic]
<TaskAttribute(Name:="cascade", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property CascadeDependencies As Boolean
[C#]
[TaskAttribute(Name="cascade", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool CascadeDependencies {get; set;}

See Also

CallTask Class | NAnt.Core.Tasks Namespace


ForceExecute Property

NAnt SDK Documentation - v0.91

CallTask.ForceExecute Property

NOTE: This property is now obsolete.

Use the "cascase" attribute to control whether dependencies should be re-executed.

Force an execute even if the target has already been executed. The default is false.

[Visual Basic]
<TaskAttribute(Name:="force", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ Obsolete(Message:="Use the "cascase" attribute to control whether dependencies should be re-executed.", IsError:=False)>
Public Property ForceExecute As Boolean
[C#]
[TaskAttribute(Name="force", Required=False, ExpandProperties=True, ProcessXml=True)]
[Obsolete(Message="Use the "cascase" attribute to control whether dependencies should be re-executed.", IsError=False)]
public bool ForceExecute {get; set;}

See Also

CallTask Class | NAnt.Core.Tasks Namespace


TargetName Property

NAnt SDK Documentation - v0.91

CallTask.TargetName Property

NAnt target to call.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="target", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property TargetName As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="target", Required=True, ExpandProperties=True, ProcessXml=True)]
public string TargetName {get; set;}

See Also

CallTask Class | NAnt.Core.Tasks Namespace


CallTask Methods

The methods of the CallTask class are listed below. For a complete list of CallTask class members, see the CallTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Executes the specified target.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Makes sure the CallTask is not calling its own parent.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CallTask Class | NAnt.Core.Tasks Namespace


CallTask.ExecuteTask Method

Executes the specified target.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

CallTask Class | NAnt.Core.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

CallTask.Initialize Method

Makes sure the CallTask is not calling its own parent.

Overload List

Makes sure the CallTask is not calling its own parent.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

CallTask Class | NAnt.Core.Tasks Namespace


CallTask.Initialize Method ()

Makes sure the CallTask is not calling its own parent.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

CallTask Class | NAnt.Core.Tasks Namespace | CallTask.Initialize Overload List


CopyTask Class

Copies a file, a directory, or set of files to a new file or directory.

For a list of all members of this type, see CopyTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.CopyTask
NAnt.Core.Tasks.MoveTask

[Visual Basic]
<TaskName(Name:="copy")>
Public Class CopyTask
Inherits Task
[C#]
[TaskName(Name="copy")]
public class CopyTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Files are only copied if the source file is newer than the destination file, or if the destination file does not exist. However, you can explicitly overwrite files with the Overwrite attribute.

When a FileSet is used to select files to copy, the ToDirectory attribute must be set. Files that are located under the base directory of the FileSet will be copied to a directory under the destination directory matching the path relative to the base directory of the FileSet, unless the Flatten attribute is set to true.

Files that are not located under the the base directory of the FileSet will be copied directly under to the destination directory, regardless of the value of the Flatten attribute.

Encoding

Unless an encoding is specified, the encoding associated with the system's current ANSI code page is used.

An UTF-8, little-endian Unicode, and big-endian Unicode encoded text file is automatically recognized, if the file starts with the appropriate byte order marks.

Note If you employ filters in your copy operation, you should limit the copy to text files. Binary files will be corrupted by the copy operation.

Example

Copy a single file while changing its encoding from "latin1" to "utf-8".

<copy
    file="myfile.txt"
    tofile="mycopy.txt"
    inputencoding="latin1"
    outputencoding="utf-8" />

Copy a set of files to a new directory.

<copy todir="${build.dir}">
    <fileset basedir="bin">
        <include name="*.dll" />
    </fileset>
</copy>

Copy a set of files to a directory, replacing @TITLE@ with "Foo Bar" in all files.

<copy todir="../backup/dir">
    <fileset basedir="src_dir">
        <include name="**/*" />
    </fileset>
    <filterchain>
        <replacetokens>
            <token key="TITLE" value="Foo Bar" />
        </replacetokens>
    </filterchain>
</copy>

Copy an entire directory and its contents.

<copy tofile="target/dir">
  <fileset basedir="source/dir"/>
</copy>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

CopyTask Members | NAnt.Core.Tasks Namespace


CopyTask Members

CopyTask overview

Public Instance Constructors

CopyTask Constructor Initialize new instance of the CopyTask.

Public Instance Properties

CopyFileSet | Used to select the files to copy. To use a FileSet, the ToDirectory attribute must be set.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
Filters | Chain of filters used to alter the file's content as it is copied.
Flatten | Ignore directory structure of source directory, copy all files into a single directory, specified by the ToDirectory attribute. The default is false.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IncludeEmptyDirs | Copy any empty directories included in the FileSet. The default is true.
InputEncoding | The encoding to use when reading files. The default is the system's current ANSI code page.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OutputEncoding | The encoding to use when writing the files. The default is the encoding of the input file.
Overwrite | Overwrite existing files even if the destination files are newer. The default is false.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
SourceFile | The file to copy.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
ToDirectory | The directory to copy to.
ToFile | The file to copy to.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
FileCopyMap | The set of files to perform a file operation on.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
CreateSourceFileNotFoundException |
DoFileOperations | Actually does the file copies.
ExecuteTask | Executes the Copy task.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Checks whether the task is initialized with valid attributes.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CopyTask Class | NAnt.Core.Tasks Namespace


CopyTask Constructor

Initialize new instance of the CopyTask.

[Visual Basic]
Public Sub New()
[C#]
public CopyTask();

See Also

CopyTask Class | NAnt.Core.Tasks Namespace


CopyTask Properties

The properties of the CopyTask class are listed below. For a complete list of CopyTask class members, see the CopyTask Members topic.

Public Instance Properties

CopyFileSet | Used to select the files to copy. To use a FileSet, the ToDirectory attribute must be set.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
Filters | Chain of filters used to alter the file's content as it is copied.
Flatten | Ignore directory structure of source directory, copy all files into a single directory, specified by the ToDirectory attribute. The default is false.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IncludeEmptyDirs | Copy any empty directories included in the FileSet. The default is true.
InputEncoding | The encoding to use when reading files. The default is the system's current ANSI code page.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OutputEncoding | The encoding to use when writing the files. The default is the encoding of the input file.
Overwrite | Overwrite existing files even if the destination files are newer. The default is false.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
SourceFile | The file to copy.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
ToDirectory | The directory to copy to.
ToFile | The file to copy to.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
FileCopyMap | The set of files to perform a file operation on.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

CopyTask Class | NAnt.Core.Tasks Namespace


CopyFileSet Property

NAnt SDK Documentation - v0.91

CopyTask.CopyFileSet Property

Used to select the files to copy. To use a FileSet, the ToDirectory attribute must be set.

[Visual Basic]
<BuildElement(Name:="fileset", Required:=False, ProcessXml:=True)>
Overridable Public Property CopyFileSet As FileSet
[C#]
[BuildElement(Name="fileset", Required=False, ProcessXml=True)]
public virtual NAnt.Core.Types.FileSet CopyFileSet {get; set;}

See Also

CopyTask Class | NAnt.Core.Tasks Namespace


FileCopyMap Property

NAnt SDK Documentation - v0.91

CopyTask.FileCopyMap Property

The set of files to perform a file operation on.

[Visual Basic]
Protected ReadOnly Property FileCopyMap As Hashtable
[C#]
protected System.Collections.Hashtable FileCopyMap {get;}

Remarks

The key of the Hashtable is the absolute path of the destination file and the value is a CopyTask.FileDateInfo holding the path and last write time of the most recently updated source file that is selected to be copied or moved to the destination file.

On Windows, the Hashtable is case-insensitive.

See Also

CopyTask Class | NAnt.Core.Tasks Namespace


Filters Property

NAnt SDK Documentation - v0.91

CopyTask.Filters Property

Chain of filters used to alter the file's content as it is copied.

[Visual Basic]
<BuildElement(Name:="filterchain", Required:=False, ProcessXml:=True)>
Overridable Public Property Filters As FilterChain
[C#]
[BuildElement(Name="filterchain", Required=False, ProcessXml=True)]
public virtual NAnt.Core.Filters.FilterChain Filters {get; set;}

See Also

CopyTask Class | NAnt.Core.Tasks Namespace


Flatten Property

NAnt SDK Documentation - v0.91

CopyTask.Flatten Property

Ignore directory structure of source directory, copy all files into a single directory, specified by the ToDirectory attribute. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="flatten", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property Flatten As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="flatten", Required=False, ExpandProperties=True, ProcessXml=True)]
public virtual bool Flatten {get; set;}

See Also

CopyTask Class | NAnt.Core.Tasks Namespace


IncludeEmptyDirs Property

NAnt SDK Documentation - v0.91

CopyTask.IncludeEmptyDirs Property

Copy any empty directories included in the FileSet. The default is true.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="includeemptydirs", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property IncludeEmptyDirs As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="includeemptydirs", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool IncludeEmptyDirs {get; set;}

See Also

CopyTask Class | NAnt.Core.Tasks Namespace


InputEncoding Property

NAnt SDK Documentation - v0.91

CopyTask.InputEncoding Property

The encoding to use when reading files. The default is the system's current ANSI code page.

[Visual Basic]
<TaskAttribute(Name:="inputencoding", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property InputEncoding As Encoding
[C#]
[TaskAttribute(Name="inputencoding", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.Text.Encoding InputEncoding {get; set;}

See Also

CopyTask Class | NAnt.Core.Tasks Namespace


OutputEncoding Property

NAnt SDK Documentation - v0.91

CopyTask.OutputEncoding Property

The encoding to use when writing the files. The default is the encoding of the input file.

[Visual Basic]
<TaskAttribute(Name:="outputencoding", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property OutputEncoding As Encoding
[C#]
[TaskAttribute(Name="outputencoding", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.Text.Encoding OutputEncoding {get; set;}

See Also

CopyTask Class | NAnt.Core.Tasks Namespace


Overwrite Property

NAnt SDK Documentation - v0.91

CopyTask.Overwrite Property

Overwrite existing files even if the destination files are newer. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="overwrite", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Overwrite As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="overwrite", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool Overwrite {get; set;}

See Also

CopyTask Class | NAnt.Core.Tasks Namespace


SourceFile Property

NAnt SDK Documentation - v0.91

CopyTask.SourceFile Property

The file to copy.

[Visual Basic]
<TaskAttribute(Name:="file", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property SourceFile As FileInfo
[C#]
[TaskAttribute(Name="file", Required=False, ExpandProperties=True, ProcessXml=True)]
public virtual System.IO.FileInfo SourceFile {get; set;}

See Also

CopyTask Class | NAnt.Core.Tasks Namespace


ToDirectory Property

NAnt SDK Documentation - v0.91

CopyTask.ToDirectory Property

The directory to copy to.

[Visual Basic]
<TaskAttribute(Name:="todir", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property ToDirectory As DirectoryInfo
[C#]
[TaskAttribute(Name="todir", Required=False, ExpandProperties=True, ProcessXml=True)]
public virtual System.IO.DirectoryInfo ToDirectory {get; set;}

See Also

CopyTask Class | NAnt.Core.Tasks Namespace


ToFile Property

NAnt SDK Documentation - v0.91

CopyTask.ToFile Property

The file to copy to.

[Visual Basic]
<TaskAttribute(Name:="tofile", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property ToFile As FileInfo
[C#]
[TaskAttribute(Name="tofile", Required=False, ExpandProperties=True, ProcessXml=True)]
public virtual System.IO.FileInfo ToFile {get; set;}

See Also

CopyTask Class | NAnt.Core.Tasks Namespace


CopyTask Methods

The methods of the CopyTask class are listed below. For a complete list of CopyTask class members, see the CopyTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
CreateSourceFileNotFoundException |
DoFileOperations | Actually does the file copies.
ExecuteTask | Executes the Copy task.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Checks whether the task is initialized with valid attributes.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CopyTask Class | NAnt.Core.Tasks Namespace


CopyTask.CreateSourceFileNotFoundException Method

[Visual Basic]
Overridable Protected Function CreateSourceFileNotFoundException( _
ByVal sourceFile As String _
) As BuildException
[C#]
protected virtual BuildException CreateSourceFileNotFoundException(
string sourceFile
);

See Also

CopyTask Class | NAnt.Core.Tasks Namespace


CopyTask.DoFileOperations Method

Actually does the file copies.

[Visual Basic]
Overridable Protected Sub DoFileOperations()
[C#]
protected virtual void DoFileOperations();

See Also

CopyTask Class | NAnt.Core.Tasks Namespace


CopyTask.ExecuteTask Method

Executes the Copy task.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

Exceptions

Exception Type | Condition
BuildException | A file that has to be copied does not exist or could not be copied.

See Also

CopyTask Class | NAnt.Core.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

CopyTask.Initialize Method

Checks whether the task is initialized with valid attributes.

Overload List

Checks whether the task is initialized with valid attributes.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

CopyTask Class | NAnt.Core.Tasks Namespace


CopyTask.Initialize Method ()

Checks whether the task is initialized with valid attributes.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

CopyTask Class | NAnt.Core.Tasks Namespace | CopyTask.Initialize Overload List


CopyTask.FileDateInfo Class

Holds the absolute paths and last write time of a given file.

For a list of all members of this type, see CopyTask.FileDateInfo Members.

System.Object
NAnt.Core.Tasks.CopyTask.FileDateInfo

[Visual Basic]
Protected Class CopyTask.FileDateInfo
[C#]
protected class CopyTask.FileDateInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

CopyTask.FileDateInfo Members | NAnt.Core.Tasks Namespace


CopyTask.FileDateInfo Members

CopyTask.FileDateInfo overview

Public Instance Constructors

CopyTask.FileDateInfo Constructor Initializes a new instance of the CopyTask.FileDateInfo class for the specified file and last write time.

Public Instance Properties

LastWriteTime | Gets the time when the current file was last written to.
Path | Gets the absolute path of the current file.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CopyTask.FileDateInfo Class | NAnt.Core.Tasks Namespace


CopyTask.FileDateInfo Constructor

Initializes a new instance of the CopyTask.FileDateInfo class for the specified file and last write time.

[Visual Basic]
Public Sub New( _
ByVal path As String, _
ByVal lastWriteTime As Date _
)
[C#]
public CopyTask.FileDateInfo(
string path,
DateTime lastWriteTime
);

Parameters

path
The absolute path of the file.
lastWriteTime
The last write time of the file.

See Also

CopyTask.FileDateInfo Class | NAnt.Core.Tasks Namespace


CopyTask.FileDateInfo Properties

The properties of the CopyTask.FileDateInfo class are listed below. For a complete list of CopyTask.FileDateInfo class members, see the CopyTask.FileDateInfo Members topic.

Public Instance Properties

LastWriteTime | Gets the time when the current file was last written to.
Path | Gets the absolute path of the current file.

See Also

CopyTask.FileDateInfo Class | NAnt.Core.Tasks Namespace


LastWriteTime Property

NAnt SDK Documentation - v0.91

CopyTask.FileDateInfo.LastWriteTime Property

Gets the time when the current file was last written to.

[Visual Basic]
Public ReadOnly Property LastWriteTime As Date
[C#]
public System.DateTime LastWriteTime {get;}

Property Value

The time when the current file was last written to.

See Also

CopyTask.FileDateInfo Class | NAnt.Core.Tasks Namespace


Path Property

NAnt SDK Documentation - v0.91

CopyTask.FileDateInfo.Path Property

Gets the absolute path of the current file.

[Visual Basic]
Public ReadOnly Property Path As String
[C#]
public string Path {get;}

Property Value

The absolute path of the current file.

See Also

CopyTask.FileDateInfo Class | NAnt.Core.Tasks Namespace


DeleteTask Class

Deletes a file, fileset or directory.

For a list of all members of this type, see DeleteTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.DeleteTask

[Visual Basic]
<TaskName(Name:="delete")>
Public Class DeleteTask
Inherits Task
[C#]
[TaskName(Name="delete")]
public class DeleteTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Deletes either a single file, all files in a specified directory and its sub-directories, or a set of files specified by one or more filesets.

If the File or Directory attribute is set then the fileset contents will be ignored. To delete the files in the fileset ommit the File and Directory attributes in the <delete> element.

If the specified file or directory does not exist, no error is reported.

Note Read-only files cannot be deleted. Use the AttribTask first to remove the read-only attribute.

Example

Delete a single file.

<delete file="myfile.txt" />

Delete a directory and the contents within. If the directory does not exist, no error is reported.

<delete dir="${build.dir}" />

Delete a set of files.

<delete>
    <fileset>
        <include name="${basename}-??.exe" />
        <include name="${basename}-??.pdb" />
    </fileset>
</delete>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

DeleteTask Members | NAnt.Core.Tasks Namespace


DeleteTask Members

DeleteTask overview

Public Instance Constructors

DeleteTask Constructor Initializes a new instance of the DeleteTask class.

Public Instance Properties

DeleteFileSet | All the files in the file set will be deleted.
Directory | The directory to delete.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
File | The file to delete.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IncludeEmptyDirs | Remove any empty directories included in the FileSet. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose | Controls whether to show the name of each deleted file or directory. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Ensures the supplied attributes are valid.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteTask Class | NAnt.Core.Tasks Namespace


DeleteTask Constructor

Initializes a new instance of the DeleteTask class.

[Visual Basic]
Public Sub New()
[C#]
public DeleteTask();

See Also

DeleteTask Class | NAnt.Core.Tasks Namespace


DeleteTask Properties

The properties of the DeleteTask class are listed below. For a complete list of DeleteTask class members, see the DeleteTask Members topic.

Public Instance Properties

DeleteFileSet | All the files in the file set will be deleted.
Directory | The directory to delete.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
File | The file to delete.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IncludeEmptyDirs | Remove any empty directories included in the FileSet. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose | Controls whether to show the name of each deleted file or directory. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

DeleteTask Class | NAnt.Core.Tasks Namespace


DeleteFileSet Property

NAnt SDK Documentation - v0.91

DeleteTask.DeleteFileSet Property

All the files in the file set will be deleted.

[Visual Basic]
<BuildElement(Name:="fileset", Required:=False, ProcessXml:=True)>
Public Property DeleteFileSet As FileSet
[C#]
[BuildElement(Name="fileset", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet DeleteFileSet {get; set;}

See Also

DeleteTask Class | NAnt.Core.Tasks Namespace


Directory Property

NAnt SDK Documentation - v0.91

DeleteTask.Directory Property

The directory to delete.

[Visual Basic]
<TaskAttribute(Name:="dir", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Directory As DirectoryInfo
[C#]
[TaskAttribute(Name="dir", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.DirectoryInfo Directory {get; set;}

See Also

DeleteTask Class | NAnt.Core.Tasks Namespace


File Property

NAnt SDK Documentation - v0.91

DeleteTask.File Property

The file to delete.

[Visual Basic]
<TaskAttribute(Name:="file", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property File As FileInfo
[C#]
[TaskAttribute(Name="file", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo File {get; set;}

See Also

DeleteTask Class | NAnt.Core.Tasks Namespace


IncludeEmptyDirs Property

NAnt SDK Documentation - v0.91

DeleteTask.IncludeEmptyDirs Property

Remove any empty directories included in the FileSet. The default is true.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="includeemptydirs", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property IncludeEmptyDirs As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="includeemptydirs", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool IncludeEmptyDirs {get; set;}

See Also

DeleteTask Class | NAnt.Core.Tasks Namespace


Verbose Property

NAnt SDK Documentation - v0.91

DeleteTask.Verbose Property

Controls whether to show the name of each deleted file or directory. The default is false.

[Visual Basic]
<TaskAttribute(Name:="verbose", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Overrides Public Property Verbose As Boolean
[C#]
[TaskAttribute(Name="verbose", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public override bool Verbose {get; set;}

See Also

DeleteTask Class | NAnt.Core.Tasks Namespace


DeleteTask Methods

The methods of the DeleteTask class are listed below. For a complete list of DeleteTask class members, see the DeleteTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Ensures the supplied attributes are valid.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteTask Class | NAnt.Core.Tasks Namespace


DeleteTask.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

DeleteTask Class | NAnt.Core.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

DeleteTask.Initialize Method

Ensures the supplied attributes are valid.

Overload List

Ensures the supplied attributes are valid.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

DeleteTask Class | NAnt.Core.Tasks Namespace


DeleteTask.Initialize Method ()

Ensures the supplied attributes are valid.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

DeleteTask Class | NAnt.Core.Tasks Namespace | DeleteTask.Initialize Overload List


DescriptionTask Class

An empty task that allows a build file to contain a description.

For a list of all members of this type, see DescriptionTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.DescriptionTask

[Visual Basic]
<TaskName(Name:="description")>
Public Class DescriptionTask
Inherits Task
[C#]
[TaskName(Name="description")]
public class DescriptionTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Set a description.

            <description>This is a description.</description>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

DescriptionTask Members | NAnt.Core.Tasks Namespace


DescriptionTask Members

DescriptionTask overview

Public Instance Constructors

DescriptionTask Constructor Initializes a new instance of the DescriptionTask class.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DescriptionTask Class | NAnt.Core.Tasks Namespace


DescriptionTask Constructor

Initializes a new instance of the DescriptionTask class.

[Visual Basic]
Public Sub New()
[C#]
public DescriptionTask();

See Also

DescriptionTask Class | NAnt.Core.Tasks Namespace


DescriptionTask Methods

The methods of the DescriptionTask class are listed below. For a complete list of DescriptionTask class members, see the DescriptionTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DescriptionTask Class | NAnt.Core.Tasks Namespace


DescriptionTask.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

DescriptionTask Class | NAnt.Core.Tasks Namespace


EchoTask Class

Writes a message to the build log or a specified file.

For a list of all members of this type, see EchoTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.EchoTask

[Visual Basic]
<TaskName(Name:="echo")>
Public Class EchoTask
Inherits Task
[C#]
[TaskName(Name="echo")]
public class EchoTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The message can be specified using the Message attribute or as inline content. If neither is included - or the message contains only whitespace - then an empty message will be emitted in the output.

Macros in the message will be expanded.

When writing to a file, the MessageLevel attribute is ignored.

Note Since NAnt 0.86, a newline will no longer be implictly added when writing a message to a file.

Example

Writes a message with level Debug to the build log.

<echo message="Hello, World!" level="Debug" />

Writes a two-line message to the build log using inline content.

<echo>First line
Second line</echo>

Writes a two-line message to the build log using the Message attribute.

<echo message='First line
Second line</echo>

Writes a message with expanded macro to the build log.

<echo message="Base build directory = ${nant.project.basedir}" />

Functionally equivalent to the previous example.

<echo>Base build directory = ${nant.project.basedir}</echo>

Writes the previous message to a file in the project directory, overwriting the file if it exists.

<echo file="buildmessage.txt">Base build directory = ${nant.project.basedir}</echo>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

EchoTask Members | NAnt.Core.Tasks Namespace


EchoTask Members

EchoTask overview

Public Instance Constructors

EchoTask Constructor Initializes a new instance of the EchoTask class.

Public Instance Properties

Append | Determines whether the EchoTask should append to the file, or overwrite it. By default, the file will be overwritten.
Contents | Gets or sets the inline content that should be output.
Encoding | The encoding to use when writing message to a file. The default is UTF-8 encoding without a Byte Order Mark (BOM).
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
File | The file to write the message to.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Message | The message to output.
MessageLevel | The logging level with which the message should be output. The default is Info.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Outputs the message to the build log or the specified file.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EchoTask Class | NAnt.Core.Tasks Namespace


EchoTask Constructor

Initializes a new instance of the EchoTask class.

[Visual Basic]
Public Sub New()
[C#]
public EchoTask();

See Also

EchoTask Class | NAnt.Core.Tasks Namespace


EchoTask Properties

The properties of the EchoTask class are listed below. For a complete list of EchoTask class members, see the EchoTask Members topic.

Public Instance Properties

Append | Determines whether the EchoTask should append to the file, or overwrite it. By default, the file will be overwritten.
Contents | Gets or sets the inline content that should be output.
Encoding | The encoding to use when writing message to a file. The default is UTF-8 encoding without a Byte Order Mark (BOM).
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
File | The file to write the message to.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Message | The message to output.
MessageLevel | The logging level with which the message should be output. The default is Info.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

EchoTask Class | NAnt.Core.Tasks Namespace


Append Property

NAnt SDK Documentation - v0.91

EchoTask.Append Property

Determines whether the EchoTask should append to the file, or overwrite it. By default, the file will be overwritten.

[Visual Basic]
<TaskAttribute(Name:="append", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Append As Boolean
[C#]
[TaskAttribute(Name="append", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool Append {get; set;}

Property Value

true if output should be appended to the file; otherwise, false. The default is false.

See Also

EchoTask Class | NAnt.Core.Tasks Namespace


Contents Property

NAnt SDK Documentation - v0.91

EchoTask.Contents Property

Gets or sets the inline content that should be output.

[Visual Basic]
Public Property Contents As String
[C#]
public string Contents {get; set;}

Property Value

The inline content that should be output.

See Also

EchoTask Class | NAnt.Core.Tasks Namespace


Encoding Property

NAnt SDK Documentation - v0.91

EchoTask.Encoding Property

The encoding to use when writing message to a file. The default is UTF-8 encoding without a Byte Order Mark (BOM).

[Visual Basic]
<TaskAttribute(Name:="encoding", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Encoding As Encoding
[C#]
[TaskAttribute(Name="encoding", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.Text.Encoding Encoding {get; set;}

See Also

EchoTask Class | NAnt.Core.Tasks Namespace


File Property

NAnt SDK Documentation - v0.91

EchoTask.File Property

The file to write the message to.

[Visual Basic]
<TaskAttribute(Name:="file", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property File As FileInfo
[C#]
[TaskAttribute(Name="file", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo File {get; set;}

See Also

EchoTask Class | NAnt.Core.Tasks Namespace


Message Property

NAnt SDK Documentation - v0.91

EchoTask.Message Property

The message to output.

[Visual Basic]
<TaskAttribute(Name:="message", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Message As String
[C#]
[TaskAttribute(Name="message", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Message {get; set;}

See Also

EchoTask Class | NAnt.Core.Tasks Namespace


MessageLevel Property

NAnt SDK Documentation - v0.91

EchoTask.MessageLevel Property

The logging level with which the message should be output. The default is Info.

[Visual Basic]
<TaskAttribute(Name:="level", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property MessageLevel As Level
[C#]
[TaskAttribute(Name="level", Required=False, ExpandProperties=True, ProcessXml=True)]
public NAnt.Core.Level MessageLevel {get; set;}

See Also

EchoTask Class | NAnt.Core.Tasks Namespace


EchoTask Methods

The methods of the EchoTask class are listed below. For a complete list of EchoTask class members, see the EchoTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Outputs the message to the build log or the specified file.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EchoTask Class | NAnt.Core.Tasks Namespace


EchoTask.ExecuteTask Method

Outputs the message to the build log or the specified file.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

EchoTask Class | NAnt.Core.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

EchoTask.Initialize Method

Overload List

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

EchoTask Class | NAnt.Core.Tasks Namespace


EchoTask.Initialize Method ()

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

EchoTask Class | NAnt.Core.Tasks Namespace | EchoTask.Initialize Overload List


ExecTask Class

Executes a system command.

For a list of all members of this type, see ExecTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.Core.Tasks.ExecTask

[Visual Basic]
<TaskName(Name:="exec")>
Public Class ExecTask
Inherits ExternalProgramBase
[C#]
[TaskName(Name="exec")]
public class ExecTask : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Use of nested Arguments element(s) is advised over the CommandLineArguments parameter, as it supports automatic quoting and can resolve relative to absolute paths.

Example

Ping "nant.sourceforge.net".

<exec program="ping">
    <arg value="nant.sourceforge.net" />
</exec>

Execute a java application using IKVM.NET that requires the Apache FOP jars, and a set of custom jars.

      <path id="fop-classpath">
          <pathelement file="${fop.dist.dir}/build/fop.jar" />
          <pathelement file="${fop.dist.dir}/lib/xercesImpl-2.2.1.jar" />
          <pathelement file="${fop.dist.dir}/lib/avalon-framework-cvs-20020806.jar" />
          <pathelement file="${fop.dist.dir}/lib/batik.jar" />
      </path>
      <exec program="ikvm.exe" useruntimeengine="true">
          <arg value="-cp" />
          <arg>
              <path>
                  <pathelement dir="conf" />
                  <path refid="fop-classpath" />
                  <pathelement file="lib/mylib.jar" />
                  <pathelement file="lib/otherlib.zip" />
              </path>
          </arg>
          <arg value="org.me.MyProg" />
      </exec>

Assuming the base directory of the build file is "c:\ikvm-test" and the value of the "fop.dist.dir" property is "c:\fop", then the value of the -cp argument that is passed toikvm.exe is "c:\ikvm-test\conf;c:\fop\build\fop.jar;conf;c:\fop\lib\xercesImpl-2.2.1.jar;c:\fop\lib\avalon-framework-cvs-20020806.jar;c:\fop\lib\batik.jar;c:\ikvm-test\lib\mylib.jar;c:\ikvm-test\lib\otherlib.zip" on a DOS-based system.

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ExecTask Members | NAnt.Core.Tasks Namespace


ExecTask Members

ExecTask overview

Public Instance Constructors

ExecTask Constructor Initializes a new instance of the ExecTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory | The directory the program is in.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments | The command-line arguments for the program. These will be passed as is to the external program. When quoting is necessary, these must be explictly set as part of the value. Consider using nested Arguments elements instead.
EnvironmentSet | Environment variables to pass to the program.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
FileName | The program to execute without command arguments.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed | Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output | The file to which the standard output will be redirected.
OutputAppend | Gets or sets a value indicating whether output should be appended to the output file. The default is false.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProcessIdProperty | The name of a property in which the unique identifier of the spawned application should be stored. Only of interest if Spawn is true.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
ResultProperty | The name of a property in which the exit code of the program should be stored. Only of interest if FailOnError is false. If the exit code of the program is "-1000" then the program could not be started, or did not exit (in time).
Spawn | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine | Obsolete. Specifies whether the external program should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
WorkingDirectory | The directory in which the command will be executed.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Executes the external program.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Performs additional checks after the task has been initialized.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess |
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


ExecTask Constructor

Initializes a new instance of the ExecTask class.

[Visual Basic]
Public Sub New()
[C#]
public ExecTask();

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


ExecTask Properties

The properties of the ExecTask class are listed below. For a complete list of ExecTask class members, see the ExecTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory | The directory the program is in.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments | The command-line arguments for the program. These will be passed as is to the external program. When quoting is necessary, these must be explictly set as part of the value. Consider using nested Arguments elements instead.
EnvironmentSet | Environment variables to pass to the program.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
FileName | The program to execute without command arguments.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed | Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output | The file to which the standard output will be redirected.
OutputAppend | Gets or sets a value indicating whether output should be appended to the output file. The default is false.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProcessIdProperty | The name of a property in which the unique identifier of the spawned application should be stored. Only of interest if Spawn is true.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
ResultProperty | The name of a property in which the exit code of the program should be stored. Only of interest if FailOnError is false. If the exit code of the program is "-1000" then the program could not be started, or did not exit (in time).
Spawn | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine | Obsolete. Specifies whether the external program should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
WorkingDirectory | The directory in which the command will be executed.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


BaseDirectory Property

NAnt SDK Documentation - v0.91

ExecTask.BaseDirectory Property

The directory the program is in.

[Visual Basic]
<TaskAttribute(Name:="basedir", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overrides Public Property BaseDirectory As DirectoryInfo
[C#]
[TaskAttribute(Name="basedir", Required=False, ExpandProperties=True, ProcessXml=True)]
public override System.IO.DirectoryInfo BaseDirectory {get; set;}

Remarks

The directory the program is in. The default is the project's base directory.

The basedir will be evaluated relative to the project's base directory if it is relative.

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


CommandLineArguments Property

NAnt SDK Documentation - v0.91

ExecTask.CommandLineArguments Property

The command-line arguments for the program. These will be passed as is to the external program. When quoting is necessary, these must be explictly set as part of the value. Consider using nested Arguments elements instead.

[Visual Basic]
<TaskAttribute(Name:="commandline", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property CommandLineArguments As String
[C#]
[TaskAttribute(Name="commandline", Required=False, ExpandProperties=True, ProcessXml=True)]
public string CommandLineArguments {get; set;}

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


EnvironmentSet Property

NAnt SDK Documentation - v0.91

ExecTask.EnvironmentSet Property

Environment variables to pass to the program.

[Visual Basic]
<BuildElement(Name:="environment", Required:=False, ProcessXml:=True)>
Public ReadOnly Property EnvironmentSet As EnvironmentSet
[C#]
[BuildElement(Name="environment", Required=False, ProcessXml=True)]
public NAnt.Core.Types.EnvironmentSet EnvironmentSet {get;}

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


FileName Property

NAnt SDK Documentation - v0.91

ExecTask.FileName Property

The program to execute without command arguments.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="program", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property FileName As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="program", Required=True, ExpandProperties=True, ProcessXml=True)]
public string FileName {get; set;}

Remarks

The path will not be evaluated to a full path using the project base directory.

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


Managed Property

NAnt SDK Documentation - v0.91

ExecTask.Managed Property

Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.

[Visual Basic]
<TaskAttribute(Name:="managed", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overrides Public Property Managed As ManagedExecution
[C#]
[TaskAttribute(Name="managed", Required=False, ExpandProperties=True, ProcessXml=True)]
public override NAnt.Core.Types.ManagedExecution Managed {get; set;}

Property Value

true if the external program should be executed using a runtime engine; otherwise, false.

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


Output Property

NAnt SDK Documentation - v0.91

ExecTask.Output Property

The file to which the standard output will be redirected.

[Visual Basic]
<TaskAttribute(Name:="output", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overrides Public Property Output As FileInfo
[C#]
[TaskAttribute(Name="output", Required=False, ExpandProperties=True, ProcessXml=True)]
public override System.IO.FileInfo Output {get; set;}

Remarks

By default, the standard output is redirected to the console.

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


OutputAppend Property

NAnt SDK Documentation - v0.91

ExecTask.OutputAppend Property

Gets or sets a value indicating whether output should be appended to the output file. The default is false.

[Visual Basic]
<TaskAttribute(Name:="append", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overrides Public Property OutputAppend As Boolean
[C#]
[TaskAttribute(Name="append", Required=False, ExpandProperties=True, ProcessXml=True)]
public override bool OutputAppend {get; set;}

Property Value

true if output should be appended to the Output; otherwise, false.

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


ProcessIdProperty Property

NAnt SDK Documentation - v0.91

ExecTask.ProcessIdProperty Property

The name of a property in which the unique identifier of the spawned application should be stored. Only of interest if Spawn is true.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="pidproperty", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property ProcessIdProperty As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="pidproperty", Required=False, ExpandProperties=True, ProcessXml=True)]
public string ProcessIdProperty {get; set;}

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

ExecTask.ProgramArguments Property

Gets the command-line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

Property Value

The command-line arguments for the external program.

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


ProgramFileName Property

NAnt SDK Documentation - v0.91

ExecTask.ProgramFileName Property

Gets the filename of the external program to start.

[Visual Basic]
Overrides Public ReadOnly Property ProgramFileName As String
[C#]
public override string ProgramFileName {get;}

Property Value

The filename of the external program.

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


ResultProperty Property

NAnt SDK Documentation - v0.91

ExecTask.ResultProperty Property

The name of a property in which the exit code of the program should be stored. Only of interest if FailOnError is false.

If the exit code of the program is "-1000" then the program could not be started, or did not exit (in time).

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="resultproperty", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property ResultProperty As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="resultproperty", Required=False, ExpandProperties=True, ProcessXml=True)]
public string ResultProperty {get; set;}

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


Spawn Property

NAnt SDK Documentation - v0.91

ExecTask.Spawn Property

Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.

[Visual Basic]
<TaskAttribute(Name:="spawn", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overrides Public Property Spawn As Boolean
[C#]
[TaskAttribute(Name="spawn", Required=False, ExpandProperties=True, ProcessXml=True)]
public override bool Spawn {get; set;}

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


UseRuntimeEngine Property

NAnt SDK Documentation - v0.91

ExecTask.UseRuntimeEngine Property

NOTE: This property is now obsolete.

Use the managed attribute and Managed property instead.

Specifies whether the external program should be executed using a runtime engine, if configured. The default is false.

[Visual Basic]
<TaskAttribute(Name:="useruntimeengine", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ Obsolete(Message:="Use the managed attribute and Managed property instead.", IsError:=False)>
Overrides Public Property UseRuntimeEngine As Boolean
[C#]
[TaskAttribute(Name="useruntimeengine", Required=False, ExpandProperties=True, ProcessXml=True)]
[Obsolete(Message="Use the managed attribute and Managed property instead.", IsError=False)]
public override bool UseRuntimeEngine {get; set;}

Property Value

true if the external program should be executed using a runtime engine; otherwise, false.

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


WorkingDirectory Property

NAnt SDK Documentation - v0.91

ExecTask.WorkingDirectory Property

The directory in which the command will be executed.

[Visual Basic]
<TaskAttribute(Name:="workingdir", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property WorkingDirectory As DirectoryInfo
[C#]
[TaskAttribute(Name="workingdir", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.DirectoryInfo WorkingDirectory {get; set;}

Property Value

The directory in which the command will be executed. The default is the project's base directory.

Remarks

The working directory will be evaluated relative to the project's base directory if it is relative.

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


ExecTask Methods

The methods of the ExecTask class are listed below. For a complete list of ExecTask class members, see the ExecTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Executes the external program.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Performs additional checks after the task has been initialized.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess |
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


ExecTask.ExecuteTask Method

Executes the external program.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

ExecTask.Initialize Method

Performs additional checks after the task has been initialized.

Overload List

Performs additional checks after the task has been initialized.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


ExecTask.Initialize Method ()

Performs additional checks after the task has been initialized.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

Exceptions

Exception Type | Condition
BuildException | FileName does not hold a valid file name.

See Also

ExecTask Class | NAnt.Core.Tasks Namespace | ExecTask.Initialize Overload List


ExecTask.PrepareProcess Method

[Visual Basic]
Overrides Protected Sub PrepareProcess( _
ByVal process As Process _
)
[C#]
protected override void PrepareProcess(
Process process
);

See Also

ExecTask Class | NAnt.Core.Tasks Namespace


ExternalProgramBase Class

Provides the abstract base class for tasks that execute external applications.

For a list of all members of this type, see ExternalProgramBase Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
Derived types

[Visual Basic]
<Serializable, _ Serializable>
MustInherit Public Class ExternalProgramBase
Inherits Task
[C#]
[Serializable]
[Serializable]
public abstract class ExternalProgramBase : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

When a ProgramLocationAttribute is applied to the deriving class and ExeName does not return an absolute path, then the program to execute will first be searched for in the location specified by LocationType.

If the program does not exist in that location, then the list of tool paths of the current target framework will be scanned in the order in which they are defined in the NAnt configuration file.

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ExternalProgramBase Members | NAnt.Core.Tasks Namespace


ExternalProgramBase Members

ExternalProgramBase overview

Public Static (Shared) Fields

UnknownExitCode Defines the exit code that will be returned by ExitCode if the process could not be started, or did not exit (in time).

Public Instance Properties

Arguments | The command-line arguments for the external program.
BaseDirectory | Gets the working directory for the application.
CommandLine | Gets the command-line arguments, separated by spaces.
ErrorWriter | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName | The name of the executable that should be used to launch the external program.
ExitCode | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output | Gets the file to which the standard output should be redirected.
OutputAppend | Gets a value indicating whether output will be appended to the Output.
OutputWriter | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Spawn | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ExternalProgramBase Constructor Initializes a new instance of the ExternalProgramBase class.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Starts the external process and captures its output.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess | Updates the ProcessStartInfo of the specified Process.
StartProcess | Starts the process and handles errors.

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


ExternalProgramBase Constructor

Initializes a new instance of the ExternalProgramBase class.

[Visual Basic]
Protected Sub New()
[C#]
protected ExternalProgramBase();

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


ExternalProgramBase Fields

The fields of the ExternalProgramBase class are listed below. For a complete list of ExternalProgramBase class members, see the ExternalProgramBase Members topic.

Public Static (Shared) Fields

UnknownExitCode Defines the exit code that will be returned by ExitCode if the process could not be started, or did not exit (in time).

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


ExternalProgramBase.UnknownExitCode Field

Defines the exit code that will be returned by ExitCode if the process could not be started, or did not exit (in time).

[Visual Basic]
Public Const UnknownExitCode As Integer = -1000
[C#]
public const int UnknownExitCode = -1000;

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


ExternalProgramBase Properties

The properties of the ExternalProgramBase class are listed below. For a complete list of ExternalProgramBase class members, see the ExternalProgramBase Members topic.

Public Instance Properties

Arguments | The command-line arguments for the external program.
BaseDirectory | Gets the working directory for the application.
CommandLine | Gets the command-line arguments, separated by spaces.
ErrorWriter | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName | The name of the executable that should be used to launch the external program.
ExitCode | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output | Gets the file to which the standard output should be redirected.
OutputAppend | Gets a value indicating whether output will be appended to the Output.
OutputWriter | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Spawn | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


Arguments Property

NAnt SDK Documentation - v0.91

ExternalProgramBase.Arguments Property

The command-line arguments for the external program.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="arg", Required:=False, ProcessXml:=True)>
Overridable Public ReadOnly Property Arguments As ArgumentCollection
[C#]
[BuildElementArray(ElementType=null, Name="arg", Required=False, ProcessXml=True)]
public virtual NAnt.Core.Types.ArgumentCollection Arguments {get;}

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


BaseDirectory Property

NAnt SDK Documentation - v0.91

ExternalProgramBase.BaseDirectory Property

Gets the working directory for the application.

[Visual Basic]
Overridable Public Property BaseDirectory As DirectoryInfo
[C#]
public virtual System.IO.DirectoryInfo BaseDirectory {get; set;}

Property Value

The working directory for the application.

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


CommandLine Property

NAnt SDK Documentation - v0.91

ExternalProgramBase.CommandLine Property

Gets the command-line arguments, separated by spaces.

[Visual Basic]
Public ReadOnly Property CommandLine As String
[C#]
public string CommandLine {get;}

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


ErrorWriter Property

NAnt SDK Documentation - v0.91

ExternalProgramBase.ErrorWriter Property

Gets or sets the TextWriter to which error output of the external program will be written.

[Visual Basic]
Overridable Public Property ErrorWriter As TextWriter
[C#]
public virtual System.IO.TextWriter ErrorWriter {get; set;}

Property Value

The TextWriter to which error output of the external program will be written.

Remarks

By default, error output wil be written to the build log with level Warning.

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


ExeName Property

NAnt SDK Documentation - v0.91

ExternalProgramBase.ExeName Property

The name of the executable that should be used to launch the external program.

[Visual Basic]
<FrameworkConfigurable(Name:="exename", Required:=False, ExpandProperties:=True)>
Overridable Public Property ExeName As String
[C#]
[FrameworkConfigurable(Name="exename", Required=False, ExpandProperties=True)]
public virtual string ExeName {get; set;}

Property Value

The name of the executable that should be used to launch the external program, or a null reference (Nothing in Visual Basic) if no name is specified.

Remarks

If available, the configured value in the NAnt configuration file will be used if no name is specified.

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


ExitCode Property

NAnt SDK Documentation - v0.91

ExternalProgramBase.ExitCode Property

Gets the value that the process specified when it terminated.

[Visual Basic]
Public ReadOnly Property ExitCode As Integer
[C#]
public int ExitCode {get;}

Property Value

The code that the associated process specified when it terminated, or -1000 if the process could not be started or did not exit (in time).

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


Managed Property

NAnt SDK Documentation - v0.91

ExternalProgramBase.Managed Property

Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.

[Visual Basic]
<FrameworkConfigurable(Name:="managed", Required:=False, ExpandProperties:=True)>
Overridable Public Property Managed As ManagedExecution
[C#]
[FrameworkConfigurable(Name="managed", Required=False, ExpandProperties=True)]
public virtual NAnt.Core.Types.ManagedExecution Managed {get; set;}

Property Value

A ManagedExecution indicating how the program should be treated.

Remarks

If Managed is set to Default, which is the default value, and UseRuntimeEngine is true then Auto is returned.

When the changing Managed to Default, then UseRuntimeEngine is set to false; otherwise, it is changed to true.

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


Output Property

NAnt SDK Documentation - v0.91

ExternalProgramBase.Output Property

Gets the file to which the standard output should be redirected.

[Visual Basic]
Overridable Public Property Output As FileInfo
[C#]
public virtual System.IO.FileInfo Output {get; set;}

Property Value

The file to which the standard output should be redirected, or a null reference (Nothing in Visual Basic) if the standard output should not be redirected.

Remarks

The default implementation will never allow the standard output to be redirected to a file. Deriving classes should override this property to change this behaviour.

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


OutputAppend Property

NAnt SDK Documentation - v0.91

ExternalProgramBase.OutputAppend Property

Gets a value indicating whether output will be appended to the Output.

[Visual Basic]
Overridable Public Property OutputAppend As Boolean
[C#]
public virtual bool OutputAppend {get; set;}

Property Value

true if output should be appended to the Output; otherwise, false.

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


OutputWriter Property

NAnt SDK Documentation - v0.91

ExternalProgramBase.OutputWriter Property

Gets or sets the TextWriter to which standard output messages of the external program will be written.

[Visual Basic]
Overridable Public Property OutputWriter As TextWriter
[C#]
public virtual System.IO.TextWriter OutputWriter {get; set;}

Property Value

The TextWriter to which standard output messages of the external program will be written.

Remarks

By default, standard output messages wil be written to the build log with level Info.

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


ProcessId Property

NAnt SDK Documentation - v0.91

ExternalProgramBase.ProcessId Property

Gets the unique identifier for the spawned application.

[Visual Basic]
Protected ReadOnly Property ProcessId As Integer
[C#]
protected int ProcessId {get;}

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

ExternalProgramBase.ProgramArguments Property

Gets the command-line arguments for the external program.

[Visual Basic]
MustOverride Public ReadOnly Property ProgramArguments As String
[C#]
public abstract string ProgramArguments {get;}

Property Value

The command-line arguments for the external program.

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


ProgramFileName Property

NAnt SDK Documentation - v0.91

ExternalProgramBase.ProgramFileName Property

Gets the filename of the external program to start.

[Visual Basic]
Overridable Public ReadOnly Property ProgramFileName As String
[C#]
public virtual string ProgramFileName {get;}

Property Value

The filename of the external program.

Remarks

Override in derived classes to explicitly set the location of the external tool.

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


Spawn Property

NAnt SDK Documentation - v0.91

ExternalProgramBase.Spawn Property

Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.

[Visual Basic]
Overridable Public Property Spawn As Boolean
[C#]
public virtual bool Spawn {get; set;}

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


TimeOut Property

NAnt SDK Documentation - v0.91

ExternalProgramBase.TimeOut Property

The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.

[Visual Basic]
<TaskAttribute(Name:="timeout", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ Int32Validator(MinValue:=-2147483648, MaxValue:=2147483647, Base:=10)>
Public Property TimeOut As Integer
[C#]
[TaskAttribute(Name="timeout", Required=False, ExpandProperties=True, ProcessXml=True)]
[Int32Validator(MinValue=-2147483648, MaxValue=2147483647, Base=10)]
public int TimeOut {get; set;}

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


UseRuntimeEngine Property

NAnt SDK Documentation - v0.91

ExternalProgramBase.UseRuntimeEngine Property

NOTE: This property is now obsolete.

Use the managed attribute and Managed property instead.

Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.

[Visual Basic]
<FrameworkConfigurable(Name:="useruntimeengine", Required:=False, ExpandProperties:=True), _ Obsolete(Message:="Use the managed attribute and Managed property instead.", IsError:=False)>
Overridable Public Property UseRuntimeEngine As Boolean
[C#]
[FrameworkConfigurable(Name="useruntimeengine", Required=False, ExpandProperties=True)]
[Obsolete(Message="Use the managed attribute and Managed property instead.", IsError=False)]
public virtual bool UseRuntimeEngine {get; set;}

Property Value

true if the external program should be executed using a runtime engine; otherwise, false.

Remarks

The value of UseRuntimeEngine is only used from Managed, and then only if its value is set to Default. In which case Managed returns Auto if UseRuntimeEngine is true.

In all other cases, the value of UseRuntimeEngine is ignored.

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


ExternalProgramBase Methods

The methods of the ExternalProgramBase class are listed below. For a complete list of ExternalProgramBase class members, see the ExternalProgramBase Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Starts the external process and captures its output.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess | Updates the ProcessStartInfo of the specified Process.
StartProcess | Starts the process and handles errors.

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


ExternalProgramBase.ExecuteTask Method

Starts the external process and captures its output.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

Exceptions

Exception Type | Condition
BuildException | The external process did not finish within the configured timeout. -or- The exit code of the external process indicates a failure.

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


ExternalProgramBase.PrepareProcess Method

Updates the ProcessStartInfo of the specified Process.

[Visual Basic]
Overridable Protected Sub PrepareProcess( _
ByVal process As Process _
)
[C#]
protected virtual void PrepareProcess(
Process process
);

Parameters

process
The Process of which the ProcessStartInfo should be updated.

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


ExternalProgramBase.StartProcess Method

Starts the process and handles errors.

[Visual Basic]
Overridable Protected Function StartProcess() As Process
[C#]
protected virtual Process StartProcess();

Return Value

The Process that was started.

See Also

ExternalProgramBase Class | NAnt.Core.Tasks Namespace


FailTask Class

Exits the current build by throwing a BuildException, optionally printing additional information.

For a list of all members of this type, see FailTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.FailTask

[Visual Basic]
<TaskName(Name:="fail")>
Public Class FailTask
Inherits Task
[C#]
[TaskName(Name="fail")]
public class FailTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The cause of the build failure can be specified using the Message attribute or as inline content.

Macros in the message will be expanded.

Example

Exits the current build without giving further information.

<fail />

Exits the current build and writes a message to the build log.

<fail message="Something wrong here." />

Functionally equivalent to the previous example.

<fail>Something wrong here.</fail>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FailTask Members | NAnt.Core.Tasks Namespace


FailTask Members

FailTask overview

Public Instance Constructors

FailTask Constructor Initializes a new instance of the FailTask class.

Public Instance Properties

Contents | Gets or sets the inline content that should be output in the build log, giving further information on why the build exited.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Message | A message giving further information on why the build exited.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FailTask Class | NAnt.Core.Tasks Namespace


FailTask Constructor

Initializes a new instance of the FailTask class.

[Visual Basic]
Public Sub New()
[C#]
public FailTask();

See Also

FailTask Class | NAnt.Core.Tasks Namespace


FailTask Properties

The properties of the FailTask class are listed below. For a complete list of FailTask class members, see the FailTask Members topic.

Public Instance Properties

Contents | Gets or sets the inline content that should be output in the build log, giving further information on why the build exited.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Message | A message giving further information on why the build exited.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

FailTask Class | NAnt.Core.Tasks Namespace


Contents Property

NAnt SDK Documentation - v0.91

FailTask.Contents Property

Gets or sets the inline content that should be output in the build log, giving further information on why the build exited.

[Visual Basic]
Public Property Contents As String
[C#]
public string Contents {get; set;}

Property Value

The inline content that should be output in the build log.

Remarks

Inline content and Message are mutually exclusive.

See Also

FailTask Class | NAnt.Core.Tasks Namespace


Message Property

NAnt SDK Documentation - v0.91

FailTask.Message Property

A message giving further information on why the build exited.

[Visual Basic]
<TaskAttribute(Name:="message", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Message As String
[C#]
[TaskAttribute(Name="message", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Message {get; set;}

Remarks

Inline content and Message are mutually exclusive.

See Also

FailTask Class | NAnt.Core.Tasks Namespace


FailTask Methods

The methods of the FailTask class are listed below. For a complete list of FailTask class members, see the FailTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FailTask Class | NAnt.Core.Tasks Namespace


FailTask.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

FailTask Class | NAnt.Core.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

FailTask.Initialize Method

Overload List

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

FailTask Class | NAnt.Core.Tasks Namespace


FailTask.Initialize Method ()

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

FailTask Class | NAnt.Core.Tasks Namespace | FailTask.Initialize Overload List


GetTask Class

Gets a particular file from a URL source.

For a list of all members of this type, see GetTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.GetTask

[Visual Basic]
<TaskName(Name:="get")>
Public Class GetTask
Inherits Task
[C#]
[TaskName(Name="get")]
public class GetTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Options include verbose reporting and timestamp based fetches.

Currently, only HTTP and UNC protocols are supported. FTP support may be added when more pluggable protocols are added to the System.Net assembly.

The UseTimeStamp option enables you to control downloads so that the remote file is only fetched if newer than the local copy. If there is no local copy, the download always takes place. When a file is downloaded, the timestamp of the downloaded file is set to the remote timestamp.

Note This timestamp facility only works on downloads using the HTTP protocol.

Example

Gets the index page of the NAnt home page, and stores it in the file help/index.html relative to the project base directory.

<get src="http://nant.sourceforge.org/" dest="help/index.html" />

Gets the index page of a secured web site using the given credentials, while connecting using the specified password-protected proxy server.

<get src="http://password.protected.site/index.html" dest="secure/index.html">
    <credentials username="user" password="guess" domain="mydomain" />
    <proxy host="proxy.company.com" port="8080">
        <credentials username="proxyuser" password="dunno" />
    </proxy>
</get>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

GetTask Members | NAnt.Core.Tasks Namespace


GetTask Members

GetTask overview

Public Instance Constructors

GetTask Constructor Initializes a new instance of the GetTask class.

Public Instance Properties

Certificates | The security certificates to associate with the request.
Credentials | The network credentials used for authenticating the request with the Internet resource.
DestinationFile | The file where to store the retrieved file.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
HttpProxy | Obsolete. If inside a firewall, proxy server/port information Format: {proxy server name}:{port number} Example: proxy.mycompany.com:8080
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IgnoreErrors | Obsolete. Log errors but don't treat as fatal. The default is false.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Proxy | The network proxy to use to access the Internet resource.
Source | The URL from which to retrieve a file.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
Timeout | The length of time, in milliseconds, until the request times out. The default is 100000 milliseconds.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseTimeStamp | Conditionally download a file based on the timestamp of the local copy. HTTP only. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | This is where the work is done
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Initializes task and ensures the supplied attributes are valid.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
TouchFile | Sets the timestamp of a given file to a specified time.

See Also

GetTask Class | NAnt.Core.Tasks Namespace


GetTask Constructor

Initializes a new instance of the GetTask class.

[Visual Basic]
Public Sub New()
[C#]
public GetTask();

See Also

GetTask Class | NAnt.Core.Tasks Namespace


GetTask Properties

The properties of the GetTask class are listed below. For a complete list of GetTask class members, see the GetTask Members topic.

Public Instance Properties

Certificates | The security certificates to associate with the request.
Credentials | The network credentials used for authenticating the request with the Internet resource.
DestinationFile | The file where to store the retrieved file.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
HttpProxy | Obsolete. If inside a firewall, proxy server/port information Format: {proxy server name}:{port number} Example: proxy.mycompany.com:8080
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IgnoreErrors | Obsolete. Log errors but don't treat as fatal. The default is false.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Proxy | The network proxy to use to access the Internet resource.
Source | The URL from which to retrieve a file.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
Timeout | The length of time, in milliseconds, until the request times out. The default is 100000 milliseconds.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseTimeStamp | Conditionally download a file based on the timestamp of the local copy. HTTP only. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

GetTask Class | NAnt.Core.Tasks Namespace


Certificates Property

NAnt SDK Documentation - v0.91

GetTask.Certificates Property

The security certificates to associate with the request.

[Visual Basic]
<BuildElement(Name:="certificates", Required:=False, ProcessXml:=True)>
Public Property Certificates As FileSet
[C#]
[BuildElement(Name="certificates", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet Certificates {get; set;}

See Also

GetTask Class | NAnt.Core.Tasks Namespace


Credentials Property

NAnt SDK Documentation - v0.91

GetTask.Credentials Property

The network credentials used for authenticating the request with the Internet resource.

[Visual Basic]
<BuildElement(Name:="credentials", Required:=False, ProcessXml:=True)>
Public Property Credentials As Credential
[C#]
[BuildElement(Name="credentials", Required=False, ProcessXml=True)]
public NAnt.Core.Types.Credential Credentials {get; set;}

See Also

GetTask Class | NAnt.Core.Tasks Namespace


DestinationFile Property

NAnt SDK Documentation - v0.91

GetTask.DestinationFile Property

The file where to store the retrieved file.

[Visual Basic]
<TaskAttribute(Name:="dest", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property DestinationFile As FileInfo
[C#]
[TaskAttribute(Name="dest", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo DestinationFile {get; set;}

See Also

GetTask Class | NAnt.Core.Tasks Namespace


HttpProxy Property

NAnt SDK Documentation - v0.91

GetTask.HttpProxy Property

NOTE: This property is now obsolete.

Use the <proxy> child element instead.

If inside a firewall, proxy server/port information Format: {proxy server name}:{port number} Example: proxy.mycompany.com:8080

[Visual Basic]
<Obsolete(Message:="Use the <proxy> child element instead.", IsError:=False), _ TaskAttribute(Name:="httpproxy", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property HttpProxy As String
[C#]
[Obsolete(Message="Use the <proxy> child element instead.", IsError=False)]
[TaskAttribute(Name="httpproxy", Required=False, ExpandProperties=True, ProcessXml=True)]
public string HttpProxy {get; set;}

See Also

GetTask Class | NAnt.Core.Tasks Namespace


IgnoreErrors Property

NAnt SDK Documentation - v0.91

GetTask.IgnoreErrors Property

NOTE: This property is now obsolete.

Use the 'failonerror' attribute instead.

Log errors but don't treat as fatal. The default is false.

[Visual Basic]
<Obsolete(Message:="Use the 'failonerror' attribute instead.", IsError:=False), _ BooleanValidator, _ TaskAttribute(Name:="ignoreerrors", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property IgnoreErrors As Boolean
[C#]
[Obsolete(Message="Use the 'failonerror' attribute instead.", IsError=False)]
[BooleanValidator]
[TaskAttribute(Name="ignoreerrors", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool IgnoreErrors {get; set;}

See Also

GetTask Class | NAnt.Core.Tasks Namespace


Proxy Property

NAnt SDK Documentation - v0.91

GetTask.Proxy Property

The network proxy to use to access the Internet resource.

[Visual Basic]
<BuildElement(Name:="proxy", Required:=False, ProcessXml:=True)>
Public Property Proxy As Proxy
[C#]
[BuildElement(Name="proxy", Required=False, ProcessXml=True)]
public NAnt.Core.Types.Proxy Proxy {get; set;}

See Also

GetTask Class | NAnt.Core.Tasks Namespace


Source Property

NAnt SDK Documentation - v0.91

GetTask.Source Property

The URL from which to retrieve a file.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="src", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property Source As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="src", Required=True, ExpandProperties=True, ProcessXml=True)]
public string Source {get; set;}

See Also

GetTask Class | NAnt.Core.Tasks Namespace


Timeout Property

NAnt SDK Documentation - v0.91

GetTask.Timeout Property

The length of time, in milliseconds, until the request times out. The default is 100000 milliseconds.

[Visual Basic]
<Int32Validator(MinValue:=-2147483648, MaxValue:=2147483647, Base:=10), _ TaskAttribute(Name:="timeout", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Timeout As Integer
[C#]
[Int32Validator(MinValue=-2147483648, MaxValue=2147483647, Base=10)]
[TaskAttribute(Name="timeout", Required=False, ExpandProperties=True, ProcessXml=True)]
public int Timeout {get; set;}

See Also

GetTask Class | NAnt.Core.Tasks Namespace


UseTimeStamp Property

NAnt SDK Documentation - v0.91

GetTask.UseTimeStamp Property

Conditionally download a file based on the timestamp of the local copy. HTTP only. The default is false.

[Visual Basic]
<TaskAttribute(Name:="usetimestamp", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property UseTimeStamp As Boolean
[C#]
[TaskAttribute(Name="usetimestamp", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool UseTimeStamp {get; set;}

See Also

GetTask Class | NAnt.Core.Tasks Namespace


GetTask Methods

The methods of the GetTask class are listed below. For a complete list of GetTask class members, see the GetTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | This is where the work is done
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Initializes task and ensures the supplied attributes are valid.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
TouchFile | Sets the timestamp of a given file to a specified time.

See Also

GetTask Class | NAnt.Core.Tasks Namespace


GetTask.ExecuteTask Method

This is where the work is done

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

GetTask Class | NAnt.Core.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

GetTask.Initialize Method

Initializes task and ensures the supplied attributes are valid.

Overload List

Initializes task and ensures the supplied attributes are valid.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

GetTask Class | NAnt.Core.Tasks Namespace


GetTask.Initialize Method ()

Initializes task and ensures the supplied attributes are valid.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

GetTask Class | NAnt.Core.Tasks Namespace | GetTask.Initialize Overload List


GetTask.TouchFile Method

Sets the timestamp of a given file to a specified time.

[Visual Basic]
Protected Sub TouchFile( _
ByVal file As FileInfo, _
ByVal touchDateTime As Date _
)
[C#]
protected void TouchFile(
FileInfo file,
DateTime touchDateTime
);

See Also

GetTask Class | NAnt.Core.Tasks Namespace


IfNotTask Class

NOTE: This class is now obsolete.

Use the <if> task instead.

The opposite of the if task.

For a list of all members of this type, see IfNotTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.TaskContainer
NAnt.Core.Tasks.IfTask
NAnt.Core.Tasks.IfNotTask

[Visual Basic]
<TaskName(Name:="ifnot"), _ Obsolete(Message:="Use the <if> task instead.", IsError:=False)>
Public Class IfNotTask
Inherits IfTask
[C#]
[TaskName(Name="ifnot")]
[Obsolete(Message="Use the <if> task instead.", IsError=False)]
public class IfNotTask : IfTask

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Check that a property does not exist.

            <ifnot propertyexists="myProp">
                <echo message="myProp does not exist."/>
            </if>

Check that a property value is not true.

            <ifnot propertytrue="myProp">
                <echo message="myProp is not true."/>
            </if>

Check that a target does not exist.

            <ifnot targetexists="myTarget">
                <echo message="myTarget does not exist."/>
            </if>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

IfNotTask Members | NAnt.Core.Tasks Namespace


IfNotTask Members

IfNotTask overview

Public Instance Constructors

IfNotTask Constructor Initializes a new instance of the IfNotTask class.

Public Instance Properties

CompareFile (inherited from IfTask) | Obsolete. The file to check against for the uptodate file.
CompareFiles (inherited from IfTask) | Obsolete. The FileSet that contains the comparison files for the UpToDateFile(s) check.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PropertyNameExists (inherited from IfTask) | Obsolete. Used to test whether a property exists.
PropertyNameTrue (inherited from IfTask) | Obsolete. Used to test whether a property is true.
TargetNameExists (inherited from IfTask) | Obsolete. Used to test whether a target exists.
Test (inherited from IfTask) | Used to test arbitrary boolean expression.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UpToDateFile (inherited from IfTask) | Obsolete. The file to compare if uptodate.
UpToDateFiles (inherited from IfTask) | Obsolete. The FileSet that contains the uptodate files for the CompareFile(s) check.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

ConditionsTrue |
CustomXmlProcessing (inherited from TaskContainer) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was use to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

AddPrivateXmlElementName (inherited from TaskContainer) |
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
CreateChildDataTypeBase (inherited from TaskContainer) |
CreateChildTask (inherited from TaskContainer) |
ExecuteChildTasks (inherited from TaskContainer) | Creates and executes the embedded (child XML nodes) elements.
ExecuteTask (inherited from IfTask) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from IfTask) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
IsPrivateXmlElement (inherited from TaskContainer) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IfNotTask Class | NAnt.Core.Tasks Namespace


IfNotTask Constructor

Initializes a new instance of the IfNotTask class.

[Visual Basic]
Public Sub New()
[C#]
public IfNotTask();

See Also

IfNotTask Class | NAnt.Core.Tasks Namespace


IfNotTask Properties

The properties of the IfNotTask class are listed below. For a complete list of IfNotTask class members, see the IfNotTask Members topic.

Public Instance Properties

CompareFile (inherited from IfTask) | Obsolete. The file to check against for the uptodate file.
CompareFiles (inherited from IfTask) | Obsolete. The FileSet that contains the comparison files for the UpToDateFile(s) check.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PropertyNameExists (inherited from IfTask) | Obsolete. Used to test whether a property exists.
PropertyNameTrue (inherited from IfTask) | Obsolete. Used to test whether a property is true.
TargetNameExists (inherited from IfTask) | Obsolete. Used to test whether a target exists.
Test (inherited from IfTask) | Used to test arbitrary boolean expression.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UpToDateFile (inherited from IfTask) | Obsolete. The file to compare if uptodate.
UpToDateFiles (inherited from IfTask) | Obsolete. The FileSet that contains the uptodate files for the CompareFile(s) check.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

ConditionsTrue |
CustomXmlProcessing (inherited from TaskContainer) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was use to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

IfNotTask Class | NAnt.Core.Tasks Namespace


ConditionsTrue Property

NAnt SDK Documentation - v0.91

IfNotTask.ConditionsTrue Property

[Visual Basic]
Overrides Protected ReadOnly Property ConditionsTrue As Boolean
[C#]
protected override bool ConditionsTrue {get;}

See Also

IfNotTask Class | NAnt.Core.Tasks Namespace


IfTask Class

Checks the conditional attributes and executes the children if true.

For a list of all members of this type, see IfTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.TaskContainer
NAnt.Core.Tasks.IfTask
NAnt.Core.Tasks.IfNotTask

[Visual Basic]
<TaskName(Name:="if")>
Public Class IfTask
Inherits TaskContainer
[C#]
[TaskName(Name="if")]
public class IfTask : TaskContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

If no conditions are checked, all child tasks are executed.

If more than one attribute is used, they are &&'d. The first to fail stops the check.

The order of condition evaluation is, TargetNameExists, PropertyNameExists, PropertyNameTrue, UpToDateFile.

Note instead of using the deprecated attributes, we advise you to use the following functions in combination with the Test attribute:
Function | Description
Exists | Checks whether the specified property exists.
Exists | Checks whether the specified target exists.

Example

Tests the value of a property using expressions.

<if test="${build.configuration=='release'}">
    <echo>Build release configuration</echo>
</if>

Tests the the output of a function.

<if test="${not file::exists(filename) or file::get-length(filename) = 0}">
    <echo message="The version file ${filename} doesn't exist or is empty!" />
</if>

(Deprecated) Check that a target exists.

<target name="myTarget" />
<if targetexists="myTarget">
    <echo message="myTarget exists" />
</if>

(Deprecated) Check existence of a property.

<if propertyexists="myProp">
    <echo message="myProp Exists. Value='${myProp}'" />
</if>

(Deprecated) Check that a property value is true.

<if propertytrue="myProp">
    <echo message="myProp is true. Value='${myProp}'" />
</if>

(Deprecated) Check that a property exists and is true (uses multiple conditions).

<if propertyexists="myProp" propertytrue="myProp">
    <echo message="myProp is '${myProp}'" />
</if>

which is the same as

<if propertyexists="myProp">
    <if propertytrue="myProp">
        <echo message="myProp is '${myProp}'" />
    </if>
</if>

(Deprecated) Check file dates. If myfile.dll is uptodate, then do stuff.

<if uptodatefile="myfile.dll" comparefile="myfile.cs">
    <echo message="myfile.dll is newer/same-date as myfile.cs" />
</if>

or

<if uptodatefile="myfile.dll">
    <comparefiles>
        <include name="*.cs" />
    </comparefiles>
    <echo message="myfile.dll is newer/same-date as myfile.cs" />
</if>

or

<if>
    <uptodatefiles>
        <include name="myfile.dll" />
    </uptodatefiles>
    <comparefiles>
        <include name="*.cs" />
    </comparefiles>
    <echo message="myfile.dll is newer/same-date as myfile.cs" />
</if>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

IfTask Members | NAnt.Core.Tasks Namespace


IfTask Members

IfTask overview

Public Instance Constructors

IfTask Constructor Initializes a new instance of the IfTask class.

Public Instance Properties

CompareFile | Obsolete. The file to check against for the uptodate file.
CompareFiles | Obsolete. The FileSet that contains the comparison files for the UpToDateFile(s) check.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PropertyNameExists | Obsolete. Used to test whether a property exists.
PropertyNameTrue | Obsolete. Used to test whether a property is true.
TargetNameExists | Obsolete. Used to test whether a target exists.
Test | Used to test arbitrary boolean expression.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UpToDateFile | Obsolete. The file to compare if uptodate.
UpToDateFiles | Obsolete. The FileSet that contains the uptodate files for the CompareFile(s) check.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

ConditionsTrue |
CustomXmlProcessing (inherited from TaskContainer) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was use to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

AddPrivateXmlElementName (inherited from TaskContainer) |
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
CreateChildDataTypeBase (inherited from TaskContainer) |
CreateChildTask (inherited from TaskContainer) |
ExecuteChildTasks (inherited from TaskContainer) | Creates and executes the embedded (child XML nodes) elements.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
IsPrivateXmlElement (inherited from TaskContainer) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IfTask Class | NAnt.Core.Tasks Namespace


IfTask Constructor

Initializes a new instance of the IfTask class.

[Visual Basic]
Public Sub New()
[C#]
public IfTask();

See Also

IfTask Class | NAnt.Core.Tasks Namespace


IfTask Properties

The properties of the IfTask class are listed below. For a complete list of IfTask class members, see the IfTask Members topic.

Public Instance Properties

CompareFile | Obsolete. The file to check against for the uptodate file.
CompareFiles | Obsolete. The FileSet that contains the comparison files for the UpToDateFile(s) check.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PropertyNameExists | Obsolete. Used to test whether a property exists.
PropertyNameTrue | Obsolete. Used to test whether a property is true.
TargetNameExists | Obsolete. Used to test whether a target exists.
Test | Used to test arbitrary boolean expression.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UpToDateFile | Obsolete. The file to compare if uptodate.
UpToDateFiles | Obsolete. The FileSet that contains the uptodate files for the CompareFile(s) check.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

ConditionsTrue |
CustomXmlProcessing (inherited from TaskContainer) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was use to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

IfTask Class | NAnt.Core.Tasks Namespace


CompareFile Property

NAnt SDK Documentation - v0.91

IfTask.CompareFile Property

NOTE: This property is now obsolete.

Use <if test="${file::up-to-date(comparefile, uptodatefile)}"> instead.

The file to check against for the uptodate file.

[Visual Basic]
<Obsolete(Message:="Use <if test="${file::up-to-date(comparefile, uptodatefile)}"> instead.", IsError:=False), _ TaskAttribute(Name:="comparefile", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public WriteOnly Property CompareFile As String
[C#]
[Obsolete(Message="Use <if test="${file::up-to-date(comparefile, uptodatefile)}"> instead.", IsError=False)]
[TaskAttribute(Name="comparefile", Required=False, ExpandProperties=True, ProcessXml=True)]
public string CompareFile {set;}

See Also

IfTask Class | NAnt.Core.Tasks Namespace


CompareFiles Property

NAnt SDK Documentation - v0.91

IfTask.CompareFiles Property

NOTE: This property is now obsolete.

Use <uptodate /> task instead.

The FileSet that contains the comparison files for the UpToDateFile(s) check.

[Visual Basic]
<BuildElement(Name:="comparefiles", Required:=False, ProcessXml:=True), _ Obsolete(Message:="Use <uptodate /> task instead.", IsError:=False)>
Public Property CompareFiles As FileSet
[C#]
[BuildElement(Name="comparefiles", Required=False, ProcessXml=True)]
[Obsolete(Message="Use <uptodate /> task instead.", IsError=False)]
public NAnt.Core.Types.FileSet CompareFiles {get; set;}

See Also

IfTask Class | NAnt.Core.Tasks Namespace


ConditionsTrue Property

NAnt SDK Documentation - v0.91

IfTask.ConditionsTrue Property

[Visual Basic]
Overridable Protected ReadOnly Property ConditionsTrue As Boolean
[C#]
protected virtual bool ConditionsTrue {get;}

See Also

IfTask Class | NAnt.Core.Tasks Namespace


PropertyNameExists Property

NAnt SDK Documentation - v0.91

IfTask.PropertyNameExists Property

NOTE: This property is now obsolete.

Use <if test="${property::exists('propertyname')}"> instead.

Used to test whether a property exists.

[Visual Basic]
<TaskAttribute(Name:="propertyexists", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ Obsolete(Message:="Use <if test="${property::exists('propertyname')}"> instead.", IsError:=False)>
Public Property PropertyNameExists As String
[C#]
[TaskAttribute(Name="propertyexists", Required=False, ExpandProperties=True, ProcessXml=True)]
[Obsolete(Message="Use <if test="${property::exists('propertyname')}"> instead.", IsError=False)]
public string PropertyNameExists {get; set;}

See Also

IfTask Class | NAnt.Core.Tasks Namespace


PropertyNameTrue Property

NAnt SDK Documentation - v0.91

IfTask.PropertyNameTrue Property

NOTE: This property is now obsolete.

Use <if test="${propertyname}"> instead.

Used to test whether a property is true.

[Visual Basic]
<Obsolete(Message:="Use <if test="${propertyname}"> instead.", IsError:=False), _ TaskAttribute(Name:="propertytrue", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property PropertyNameTrue As String
[C#]
[Obsolete(Message="Use <if test="${propertyname}"> instead.", IsError=False)]
[TaskAttribute(Name="propertytrue", Required=False, ExpandProperties=True, ProcessXml=True)]
public string PropertyNameTrue {get; set;}

See Also

IfTask Class | NAnt.Core.Tasks Namespace


TargetNameExists Property

NAnt SDK Documentation - v0.91

IfTask.TargetNameExists Property

NOTE: This property is now obsolete.

Use <if test="${target::exists('targetname')}"> instead.

Used to test whether a target exists.

[Visual Basic]
<TaskAttribute(Name:="targetexists", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ Obsolete(Message:="Use <if test="${target::exists('targetname')}"> instead.", IsError:=False)>
Public Property TargetNameExists As String
[C#]
[TaskAttribute(Name="targetexists", Required=False, ExpandProperties=True, ProcessXml=True)]
[Obsolete(Message="Use <if test="${target::exists('targetname')}"> instead.", IsError=False)]
public string TargetNameExists {get; set;}

See Also

IfTask Class | NAnt.Core.Tasks Namespace


Test Property

NAnt SDK Documentation - v0.91

IfTask.Test Property

Used to test arbitrary boolean expression.

[Visual Basic]
<TaskAttribute(Name:="test", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property Test As String
[C#]
[TaskAttribute(Name="test", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public string Test {get; set;}

See Also

IfTask Class | NAnt.Core.Tasks Namespace


UpToDateFile Property

NAnt SDK Documentation - v0.91

IfTask.UpToDateFile Property

NOTE: This property is now obsolete.

Use <if test="${file::up-to-date(comparefile, uptodatefile)}"> instead.

The file to compare if uptodate.

[Visual Basic]
<Obsolete(Message:="Use <if test="${file::up-to-date(comparefile, uptodatefile)}"> instead.", IsError:=False), _ TaskAttribute(Name:="uptodatefile", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public WriteOnly Property UpToDateFile As String
[C#]
[Obsolete(Message="Use <if test="${file::up-to-date(comparefile, uptodatefile)}"> instead.", IsError=False)]
[TaskAttribute(Name="uptodatefile", Required=False, ExpandProperties=True, ProcessXml=True)]
public string UpToDateFile {set;}

See Also

IfTask Class | NAnt.Core.Tasks Namespace


UpToDateFiles Property

NAnt SDK Documentation - v0.91

IfTask.UpToDateFiles Property

NOTE: This property is now obsolete.

Use <uptodate /> task instead.

The FileSet that contains the uptodate files for the CompareFile(s) check.

[Visual Basic]
<BuildElement(Name:="uptodatefiles", Required:=False, ProcessXml:=True), _ Obsolete(Message:="Use <uptodate /> task instead.", IsError:=False)>
Public Property UpToDateFiles As FileSet
[C#]
[BuildElement(Name="uptodatefiles", Required=False, ProcessXml=True)]
[Obsolete(Message="Use <uptodate /> task instead.", IsError=False)]
public NAnt.Core.Types.FileSet UpToDateFiles {get; set;}

See Also

IfTask Class | NAnt.Core.Tasks Namespace


IfTask Methods

The methods of the IfTask class are listed below. For a complete list of IfTask class members, see the IfTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddPrivateXmlElementName (inherited from TaskContainer) |
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
CreateChildDataTypeBase (inherited from TaskContainer) |
CreateChildTask (inherited from TaskContainer) |
ExecuteChildTasks (inherited from TaskContainer) | Creates and executes the embedded (child XML nodes) elements.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
IsPrivateXmlElement (inherited from TaskContainer) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IfTask Class | NAnt.Core.Tasks Namespace


IfTask.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

IfTask Class | NAnt.Core.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

IfTask.Initialize Method

Overload List

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

IfTask Class | NAnt.Core.Tasks Namespace


IfTask.Initialize Method ()

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

IfTask Class | NAnt.Core.Tasks Namespace | IfTask.Initialize Overload List


IncludeTask Class

Includes an external build file.

For a list of all members of this type, see IncludeTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.IncludeTask

[Visual Basic]
<TaskName(Name:="include")>
Public Class IncludeTask
Inherits Task
[C#]
[TaskName(Name="include")]
public class IncludeTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This task is used to break your build file into smaller chunks. You can load a partial build file and have it included into the build file.

Note Any global (project level) tasks in the included build file are executed when this task is executed. Tasks in target elements are only executed if that target is executed.
Note The project element attributes are ignored.
Note This task can only be in the global (project level) section of the build file.
Note This task can only include files from the file system.

Example

Include a task that fetches the project version from the GetProjectVersion.include build file.

            <include buildfile="GetProjectVersion.include" />

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

IncludeTask Members | NAnt.Core.Tasks Namespace


IncludeTask Members

IncludeTask overview

Public Instance Constructors

IncludeTask Constructor Initializes a new instance of the IncludeTask class.

Public Instance Properties

BuildFileName | Build file to include.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Verifies parameters.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IncludeTask Class | NAnt.Core.Tasks Namespace


IncludeTask Constructor

Initializes a new instance of the IncludeTask class.

[Visual Basic]
Public Sub New()
[C#]
public IncludeTask();

See Also

IncludeTask Class | NAnt.Core.Tasks Namespace


IncludeTask Properties

The properties of the IncludeTask class are listed below. For a complete list of IncludeTask class members, see the IncludeTask Members topic.

Public Instance Properties

BuildFileName | Build file to include.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

IncludeTask Class | NAnt.Core.Tasks Namespace


BuildFileName Property

NAnt SDK Documentation - v0.91

IncludeTask.BuildFileName Property

Build file to include.

[Visual Basic]
<TaskAttribute(Name:="buildfile", Required:=True, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property BuildFileName As String
[C#]
[TaskAttribute(Name="buildfile", Required=True, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string BuildFileName {get; set;}

See Also

IncludeTask Class | NAnt.Core.Tasks Namespace


IncludeTask Methods

The methods of the IncludeTask class are listed below. For a complete list of IncludeTask class members, see the IncludeTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Verifies parameters.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IncludeTask Class | NAnt.Core.Tasks Namespace


IncludeTask.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

IncludeTask Class | NAnt.Core.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

IncludeTask.Initialize Method

Verifies parameters.

Overload List

Verifies parameters.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

IncludeTask Class | NAnt.Core.Tasks Namespace


IncludeTask.Initialize Method ()

Verifies parameters.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

IncludeTask Class | NAnt.Core.Tasks Namespace | IncludeTask.Initialize Overload List


InElement Class

For a list of all members of this type, see InElement Members.

System.Object
NAnt.Core.Element
NAnt.Core.Tasks.InElement

[Visual Basic]
Public Class InElement
Inherits Element
[C#]
public class InElement : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

InElement Members | NAnt.Core.Tasks Namespace


InElement Members

InElement overview

Public Instance Constructors

InElement Constructor Initializes a new instance of the InElement class.

Public Instance Properties

Items |
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InElement Class | NAnt.Core.Tasks Namespace


InElement Constructor

Initializes a new instance of the InElement class.

[Visual Basic]
Public Sub New()
[C#]
public InElement();

See Also

InElement Class | NAnt.Core.Tasks Namespace


InElement Properties

The properties of the InElement class are listed below. For a complete list of InElement class members, see the InElement Members topic.

Public Instance Properties

Items |
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

InElement Class | NAnt.Core.Tasks Namespace


Items Property

NAnt SDK Documentation - v0.91

InElement.Items Property

[Visual Basic]
<BuildElement(Name:="items", Required:=False, ProcessXml:=True)>
Public Property Items As FileSet
[C#]
[BuildElement(Name="items", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet Items {get; set;}

See Also

InElement Class | NAnt.Core.Tasks Namespace


LoadFileTask Class

Load a text file into a single property.

For a list of all members of this type, see LoadFileTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.LoadFileTask

[Visual Basic]
<TaskName(Name:="loadfile")>
Public Class LoadFileTask
Inherits Task
[C#]
[TaskName(Name="loadfile")]
public class LoadFileTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Unless an encoding is specified, the encoding associated with the system's current ANSI code page is used.

An UTF-8, little-endian Unicode, and big-endian Unicode encoded text file is automatically recognized, if the file starts with the appropriate byte order marks.

Example

Load file message.txt into property "message".

            <loadfile
                file="message.txt"
                property="message" />

Load a file using the "latin-1" encoding.

            <loadfile
                file="loadfile.xml"
                property="encoded-file"
                encoding="iso-8859-1" />

Load a file, replacing all @NOW@ tokens with the current date/time.

            <loadfile file="token.txt" property="token-file">
                <filterchain>
                    <replacetokens>
                        <token key="NOW" value="${datetime::now()}" />
                    </replacetokens>
                </filterchain>
            </loadfile>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

LoadFileTask Members | NAnt.Core.Tasks Namespace


LoadFileTask Members

LoadFileTask overview

Public Instance Constructors

LoadFileTask Constructor Initializes a new instance of the LoadFileTask class.

Public Instance Properties

Encoding | The encoding to use when loading the file. The default is the encoding associated with the system's current ANSI code page.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
File | The file to load.
FilterChain | The filterchain definition to use.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Property | The name of the property to save the content to.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LoadFileTask Class | NAnt.Core.Tasks Namespace


LoadFileTask Constructor

Initializes a new instance of the LoadFileTask class.

[Visual Basic]
Public Sub New()
[C#]
public LoadFileTask();

See Also

LoadFileTask Class | NAnt.Core.Tasks Namespace


LoadFileTask Properties

The properties of the LoadFileTask class are listed below. For a complete list of LoadFileTask class members, see the LoadFileTask Members topic.

Public Instance Properties

Encoding | The encoding to use when loading the file. The default is the encoding associated with the system's current ANSI code page.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
File | The file to load.
FilterChain | The filterchain definition to use.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Property | The name of the property to save the content to.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

LoadFileTask Class | NAnt.Core.Tasks Namespace


Encoding Property

NAnt SDK Documentation - v0.91

LoadFileTask.Encoding Property

The encoding to use when loading the file. The default is the encoding associated with the system's current ANSI code page.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="encoding", ExpandProperties:=True, ProcessXml:=True)>
Public Property Encoding As Encoding
[C#]
[TaskAttribute(Required=False, Name="encoding", ExpandProperties=True, ProcessXml=True)]
public System.Text.Encoding Encoding {get; set;}

See Also

LoadFileTask Class | NAnt.Core.Tasks Namespace


File Property

NAnt SDK Documentation - v0.91

LoadFileTask.File Property

The file to load.

[Visual Basic]
<TaskAttribute(Name:="file", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property File As FileInfo
[C#]
[TaskAttribute(Name="file", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo File {get; set;}

See Also

LoadFileTask Class | NAnt.Core.Tasks Namespace


FilterChain Property

NAnt SDK Documentation - v0.91

LoadFileTask.FilterChain Property

The filterchain definition to use.

[Visual Basic]
<BuildElement(Name:="filterchain", Required:=False, ProcessXml:=True)>
Public Property FilterChain As FilterChain
[C#]
[BuildElement(Name="filterchain", Required=False, ProcessXml=True)]
public NAnt.Core.Filters.FilterChain FilterChain {get; set;}

See Also

LoadFileTask Class | NAnt.Core.Tasks Namespace


Property Property

NAnt SDK Documentation - v0.91

LoadFileTask.Property Property

The name of the property to save the content to.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="property", ExpandProperties:=True, ProcessXml:=True)>
Public Property Property As String
[C#]
[TaskAttribute(Required=True, Name="property", ExpandProperties=True, ProcessXml=True)]
public string Property {get; set;}

See Also

LoadFileTask Class | NAnt.Core.Tasks Namespace


LoadFileTask Methods

The methods of the LoadFileTask class are listed below. For a complete list of LoadFileTask class members, see the LoadFileTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LoadFileTask Class | NAnt.Core.Tasks Namespace


LoadFileTask.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

LoadFileTask Class | NAnt.Core.Tasks Namespace


LoadTasksTask Class

Loads tasks form a given assembly or all assemblies in a given directory or FileSet.

For a list of all members of this type, see LoadTasksTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.LoadTasksTask

[Visual Basic]
<TaskName(Name:="loadtasks")>
Public Class LoadTasksTask
Inherits Task
[C#]
[TaskName(Name="loadtasks")]
public class LoadTasksTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Load tasks from a single assembly.

<loadtasks assembly="c:foo\NAnt.Contrib.Tasks.dll" />

Scan a single directory for task assemblies.

<loadtasks path="c:\foo" />

Use a TaskFileSet containing both a directory and an assembly.

 <loadtasks>
    <fileset>
        <include name="C:\cvs\NAntContrib\build" />
        <include name="C:\cvs\NAntContrib\build\NAnt.Contrib.Tasks.dll" />
    </fileset>
</loadtasks>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

LoadTasksTask Members | NAnt.Core.Tasks Namespace


LoadTasksTask Members

LoadTasksTask overview

Public Instance Constructors

LoadTasksTask Constructor Initializes a new instance of the LoadTasksTask class.

Public Instance Properties

AssemblyPath | An assembly to load tasks from.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Path | A directory to scan for task assemblies.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
TaskFileSet | Used to select which directories or individual assemblies to scan.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Executes the Load Tasks task.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Validates the attributes.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LoadTasksTask Class | NAnt.Core.Tasks Namespace


LoadTasksTask Constructor

Initializes a new instance of the LoadTasksTask class.

[Visual Basic]
Public Sub New()
[C#]
public LoadTasksTask();

See Also

LoadTasksTask Class | NAnt.Core.Tasks Namespace


LoadTasksTask Properties

The properties of the LoadTasksTask class are listed below. For a complete list of LoadTasksTask class members, see the LoadTasksTask Members topic.

Public Instance Properties

AssemblyPath | An assembly to load tasks from.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Path | A directory to scan for task assemblies.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
TaskFileSet | Used to select which directories or individual assemblies to scan.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

LoadTasksTask Class | NAnt.Core.Tasks Namespace


AssemblyPath Property

NAnt SDK Documentation - v0.91

LoadTasksTask.AssemblyPath Property

An assembly to load tasks from.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="assembly", ExpandProperties:=True, ProcessXml:=True)>
Public Property AssemblyPath As FileInfo
[C#]
[TaskAttribute(Required=False, Name="assembly", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo AssemblyPath {get; set;}

See Also

LoadTasksTask Class | NAnt.Core.Tasks Namespace


Path Property

NAnt SDK Documentation - v0.91

LoadTasksTask.Path Property

A directory to scan for task assemblies.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="path", ExpandProperties:=True, ProcessXml:=True)>
Public Property Path As DirectoryInfo
[C#]
[TaskAttribute(Required=False, Name="path", ExpandProperties=True, ProcessXml=True)]
public System.IO.DirectoryInfo Path {get; set;}

See Also

LoadTasksTask Class | NAnt.Core.Tasks Namespace


TaskFileSet Property

NAnt SDK Documentation - v0.91

LoadTasksTask.TaskFileSet Property

Used to select which directories or individual assemblies to scan.

[Visual Basic]
<BuildElement(Name:="fileset", Required:=False, ProcessXml:=True)>
Public Property TaskFileSet As FileSet
[C#]
[BuildElement(Name="fileset", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet TaskFileSet {get; set;}

See Also

LoadTasksTask Class | NAnt.Core.Tasks Namespace


LoadTasksTask Methods

The methods of the LoadTasksTask class are listed below. For a complete list of LoadTasksTask class members, see the LoadTasksTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Executes the Load Tasks task.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Validates the attributes.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LoadTasksTask Class | NAnt.Core.Tasks Namespace


LoadTasksTask.ExecuteTask Method

Executes the Load Tasks task.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

Exceptions

Exception Type | Condition
BuildException | Specified assembly or path does not exist.

See Also

LoadTasksTask Class | NAnt.Core.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

LoadTasksTask.Initialize Method

Validates the attributes.

Overload List

Validates the attributes.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

LoadTasksTask Class | NAnt.Core.Tasks Namespace


LoadTasksTask.Initialize Method ()

Validates the attributes.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

Exceptions

Exception Type | Condition
BuildException | Both AssemblyPath and Path are set.

See Also

LoadTasksTask Class | NAnt.Core.Tasks Namespace | LoadTasksTask.Initialize Overload List


LoopTask Class

Loops over a set of items.

For a list of all members of this type, see LoopTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.TaskContainer
NAnt.Core.Tasks.LoopTask

[Visual Basic]
<TaskName(Name:="foreach")>
Public Class LoopTask
Inherits TaskContainer
[C#]
[TaskName(Name="foreach")]
public class LoopTask : TaskContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Can loop over files in directory, lines in a file, etc.

The property value is stored before the loop is done, and restored when the loop is finished.

The property is returned to its normal value once it is used. Read-only parameters cannot be overridden in this loop.

Example

Loops over the files in c:\.

            <foreach item="File" in="c:\" property="filename">
                <echo message="${filename}" />
            </foreach>

Loops over all files in the project directory.

            <foreach item="File" property="filename">
                <in>
                    <items>
                        <include name="**" />
                    </items>
                </in>
                <do>
                    <echo message="${filename}" />
                </do>
            </foreach>

Loops over the folders in c:\.

            <foreach item="Folder" in="c:\" property="foldername">
                <echo message="${foldername}" />
            </foreach>

Loops over all folders in the project directory.

            <foreach item="Folder" property="foldername">
                <in>
                    <items>
                        <include name="**" />
                    </items>
                </in>
                <do>
                    <echo message="${foldername}" />
                </do>
            </foreach>

Loops over a list.

            <foreach item="String" in="1 2,3" delim=" ," property="count">
                <echo message="${count}" />
            </foreach>

Loops over lines in the file properties.csv, where each line is of the format name,value.

            <foreach item="Line" in="properties.csv" delim="," property="x,y">
                <echo message="Read pair ${x}=${y}" />
            </foreach>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

LoopTask Members | NAnt.Core.Tasks Namespace


LoopTask Members

LoopTask overview

Public Instance Constructors

LoopTask Constructor Initializes a new instance of the LoopTask class.

Public Instance Properties

Delimiter | The deliminator char.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
InElement Stuff to operate in. Just like the Source attribute, but supports more complicated things like a FileSet and such.
Note Please remove the Source attribute if you are using this element.
ItemType | The type of iteration that should be done.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Property | The NAnt property name(s) that should be used for the current iterated item.
Source | The source of the iteration.
StuffToDo | Tasks to execute for each matching item.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TrimType | The type of whitespace trimming that should be done. The default is None.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from TaskContainer) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was use to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

AddPrivateXmlElementName (inherited from TaskContainer) |
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
CreateChildDataTypeBase (inherited from TaskContainer) |
CreateChildTask (inherited from TaskContainer) |
DoWork |
ExecuteChildTasks |
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from TaskContainer) | Overloaded. Automatically exclude build elements that are defined on the task from things that get executed, as they are evaluated normally during XML task initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
IsPrivateXmlElement (inherited from TaskContainer) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LoopTask Class | NAnt.Core.Tasks Namespace


LoopTask Constructor

Initializes a new instance of the LoopTask class.

[Visual Basic]
Public Sub New()
[C#]
public LoopTask();

See Also

LoopTask Class | NAnt.Core.Tasks Namespace


LoopTask Properties

The properties of the LoopTask class are listed below. For a complete list of LoopTask class members, see the LoopTask Members topic.

Public Instance Properties

Delimiter | The deliminator char.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
InElement Stuff to operate in. Just like the Source attribute, but supports more complicated things like a FileSet and such.
Note Please remove the Source attribute if you are using this element.
ItemType | The type of iteration that should be done.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Property | The NAnt property name(s) that should be used for the current iterated item.
Source | The source of the iteration.
StuffToDo | Tasks to execute for each matching item.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TrimType | The type of whitespace trimming that should be done. The default is None.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from TaskContainer) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was use to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

LoopTask Class | NAnt.Core.Tasks Namespace


Delimiter Property

NAnt SDK Documentation - v0.91

LoopTask.Delimiter Property

The deliminator char.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="delim", ExpandProperties:=True, ProcessXml:=True)>
Public Property Delimiter As String
[C#]
[TaskAttribute(Required=False, Name="delim", ExpandProperties=True, ProcessXml=True)]
public string Delimiter {get; set;}

See Also

LoopTask Class | NAnt.Core.Tasks Namespace


InElement Property

NAnt SDK Documentation - v0.91

LoopTask.InElement Property

Stuff to operate in. Just like the Source attribute, but supports more complicated things like a FileSet and such.

Note Please remove the Source attribute if you are using this element.

[Visual Basic]
<BuildElement(Name:="in", Required:=False, ProcessXml:=True)>
Public Property InElement As InElement
[C#]
[BuildElement(Name="in", Required=False, ProcessXml=True)]
public InElement InElement {get; set;}

See Also

LoopTask Class | NAnt.Core.Tasks Namespace


ItemType Property

NAnt SDK Documentation - v0.91

LoopTask.ItemType Property

The type of iteration that should be done.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="item", ExpandProperties:=True, ProcessXml:=True)>
Public Property ItemType As LoopItem
[C#]
[TaskAttribute(Required=True, Name="item", ExpandProperties=True, ProcessXml=True)]
public LoopTask.LoopItem ItemType {get; set;}

See Also

LoopTask Class | NAnt.Core.Tasks Namespace


Property Property

NAnt SDK Documentation - v0.91

LoopTask.Property Property

The NAnt property name(s) that should be used for the current iterated item.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Required:=True, Name:="property", ExpandProperties:=True, ProcessXml:=True)>
Public Property Property As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Required=True, Name="property", ExpandProperties=True, ProcessXml=True)]
public string Property {get; set;}

Remarks

If specifying multiple properties, separate them with a comma.

See Also

LoopTask Class | NAnt.Core.Tasks Namespace


Source Property

NAnt SDK Documentation - v0.91

LoopTask.Source Property

The source of the iteration.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="in", ExpandProperties:=True, ProcessXml:=True)>
Public Property Source As String
[C#]
[TaskAttribute(Required=False, Name="in", ExpandProperties=True, ProcessXml=True)]
public string Source {get; set;}

See Also

LoopTask Class | NAnt.Core.Tasks Namespace


StuffToDo Property

NAnt SDK Documentation - v0.91

LoopTask.StuffToDo Property

Tasks to execute for each matching item.

[Visual Basic]
<BuildElement(Name:="do", Required:=False, ProcessXml:=True)>
Public Property StuffToDo As TaskContainer
[C#]
[BuildElement(Name="do", Required=False, ProcessXml=True)]
public NAnt.Core.TaskContainer StuffToDo {get; set;}

See Also

LoopTask Class | NAnt.Core.Tasks Namespace


TrimType Property

NAnt SDK Documentation - v0.91

LoopTask.TrimType Property

The type of whitespace trimming that should be done. The default is None.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="trim", ExpandProperties:=True, ProcessXml:=True)>
Public Property TrimType As LoopTrim
[C#]
[TaskAttribute(Required=False, Name="trim", ExpandProperties=True, ProcessXml=True)]
public LoopTask.LoopTrim TrimType {get; set;}

See Also

LoopTask Class | NAnt.Core.Tasks Namespace


LoopTask Methods

The methods of the LoopTask class are listed below. For a complete list of LoopTask class members, see the LoopTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddPrivateXmlElementName (inherited from TaskContainer) |
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
CreateChildDataTypeBase (inherited from TaskContainer) |
CreateChildTask (inherited from TaskContainer) |
DoWork |
ExecuteChildTasks |
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from TaskContainer) | Overloaded. Automatically exclude build elements that are defined on the task from things that get executed, as they are evaluated normally during XML task initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
IsPrivateXmlElement (inherited from TaskContainer) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LoopTask Class | NAnt.Core.Tasks Namespace


LoopTask.DoWork Method

[Visual Basic]
Overridable Protected Sub DoWork( _
ParamArray propVals As String() _
)
[C#]
protected virtual void DoWork(
params string[] propVals
);

See Also

LoopTask Class | NAnt.Core.Tasks Namespace


LoopTask.ExecuteChildTasks Method

[Visual Basic]
Overrides Protected Sub ExecuteChildTasks()
[C#]
protected override void ExecuteChildTasks();

See Also

LoopTask Class | NAnt.Core.Tasks Namespace


LoopTask.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

LoopTask Class | NAnt.Core.Tasks Namespace


LoopTask.LoopItem Enumeration

[Visual Basic]
<Serializable>
Public Enum LoopTask.LoopItem
[C#]
[Serializable]
public enum LoopTask.LoopItem

Members

Member Name | Description
File |
Folder |
String |
Line |

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

NAnt.Core.Tasks Namespace


LoopTask.LoopTrim Enumeration

[Visual Basic]
<Serializable>
Public Enum LoopTask.LoopTrim
[C#]
[Serializable]
public enum LoopTask.LoopTrim

Members

Member Name | Description
None | Do not remove any white space characters.
End | Remove all white space characters from the end of the current item.
Start | Remove all white space characters from the beginning of the current item.
Both | Remove all white space characters from the beginning and end of the current item.

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

NAnt.Core.Tasks Namespace


MailTask Class

Sends an SMTP message.

For a list of all members of this type, see MailTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.MailTask

[Visual Basic]
<TaskName(Name:="mail")>
Public Class MailTask
Inherits Task
[C#]
[TaskName(Name="mail")]
public class MailTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Text and text files to include in the message body may be specified as well as binary attachments.

Example

Sends an email from nant@sourceforge.net to three recipients with a subject about the attachments. The body of the message will be the combined contents of all .txt files in the base directory. All zip files in the base directory will be included as attachments. The message will be sent using the smtpserver.anywhere.com SMTP server.

            <mail
                from="nant@sourceforge.net"
                tolist="recipient1@sourceforge.net"
                cclist="recipient2@sourceforge.net"
                bcclist="recipient3@sourceforge.net"
                subject="Msg 7: With attachments"
                mailhost="smtpserver.anywhere.com">
                <files>
                    <include name="*.txt" />
                </files>
                <attachments>
                    <include name="*.zip" />
                </attachments>
            </mail>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

MailTask Members | NAnt.Core.Tasks Namespace


MailTask Members

MailTask overview

Public Instance Constructors

MailTask Constructor Initializes a new instance of the MailTask class.

Public Instance Properties

Attachments | Attachments that are transmitted with the message.
BccList | Semicolon-separated list of BCC: recipient email addresses.
CcList | Semicolon-separated list of CC: recipient email addresses.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
Files | Files that are transmitted as part of the body of the email message.
Format | Format of the message. The default is Text.
From | Email address of sender.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Mailhost | Host name of mail server. The default is localhost.
Message | Text to send in body of email message.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Subject | Text to send in subject line of email message.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
ToList | Semicolon-separated list of recipient email addresses.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | This is where the work is done.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Initializes task and ensures the supplied attributes are valid.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailTask Class | NAnt.Core.Tasks Namespace


MailTask Constructor

Initializes a new instance of the MailTask class.

[Visual Basic]
Public Sub New()
[C#]
public MailTask();

See Also

MailTask Class | NAnt.Core.Tasks Namespace


MailTask Properties

The properties of the MailTask class are listed below. For a complete list of MailTask class members, see the MailTask Members topic.

Public Instance Properties

Attachments | Attachments that are transmitted with the message.
BccList | Semicolon-separated list of BCC: recipient email addresses.
CcList | Semicolon-separated list of CC: recipient email addresses.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
Files | Files that are transmitted as part of the body of the email message.
Format | Format of the message. The default is Text.
From | Email address of sender.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Mailhost | Host name of mail server. The default is localhost.
Message | Text to send in body of email message.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Subject | Text to send in subject line of email message.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
ToList | Semicolon-separated list of recipient email addresses.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

MailTask Class | NAnt.Core.Tasks Namespace


Attachments Property

NAnt SDK Documentation - v0.91

MailTask.Attachments Property

Attachments that are transmitted with the message.

[Visual Basic]
<BuildElement(Name:="attachments", Required:=False, ProcessXml:=True)>
Public Property Attachments As FileSet
[C#]
[BuildElement(Name="attachments", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet Attachments {get; set;}

See Also

MailTask Class | NAnt.Core.Tasks Namespace


BccList Property

NAnt SDK Documentation - v0.91

MailTask.BccList Property

Semicolon-separated list of BCC: recipient email addresses.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="bcclist", ExpandProperties:=True, ProcessXml:=True)>
Public Property BccList As String
[C#]
[TaskAttribute(Required=False, Name="bcclist", ExpandProperties=True, ProcessXml=True)]
public string BccList {get; set;}

See Also

MailTask Class | NAnt.Core.Tasks Namespace


CcList Property

NAnt SDK Documentation - v0.91

MailTask.CcList Property

Semicolon-separated list of CC: recipient email addresses.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="cclist", ExpandProperties:=True, ProcessXml:=True)>
Public Property CcList As String
[C#]
[TaskAttribute(Required=False, Name="cclist", ExpandProperties=True, ProcessXml=True)]
public string CcList {get; set;}

See Also

MailTask Class | NAnt.Core.Tasks Namespace


Files Property

NAnt SDK Documentation - v0.91

MailTask.Files Property

Files that are transmitted as part of the body of the email message.

[Visual Basic]
<BuildElement(Name:="files", Required:=False, ProcessXml:=True)>
Public Property Files As FileSet
[C#]
[BuildElement(Name="files", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet Files {get; set;}

See Also

MailTask Class | NAnt.Core.Tasks Namespace


Format Property

NAnt SDK Documentation - v0.91

MailTask.Format Property

Format of the message. The default is Text.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="format", ExpandProperties:=True, ProcessXml:=True)>
Public Property Format As MailFormat
[C#]
[TaskAttribute(Required=False, Name="format", ExpandProperties=True, ProcessXml=True)]
public System.Web.Mail.MailFormat Format {get; set;}

See Also

MailTask Class | NAnt.Core.Tasks Namespace


From Property

NAnt SDK Documentation - v0.91

MailTask.From Property

Email address of sender.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Required:=True, Name:="from", ExpandProperties:=True, ProcessXml:=True)>
Public Property From As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Required=True, Name="from", ExpandProperties=True, ProcessXml=True)]
public string From {get; set;}

See Also

MailTask Class | NAnt.Core.Tasks Namespace


Mailhost Property

NAnt SDK Documentation - v0.91

MailTask.Mailhost Property

Host name of mail server. The default is localhost.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="mailhost", ExpandProperties:=True, ProcessXml:=True)>
Public Property Mailhost As String
[C#]
[TaskAttribute(Required=False, Name="mailhost", ExpandProperties=True, ProcessXml=True)]
public string Mailhost {get; set;}

See Also

MailTask Class | NAnt.Core.Tasks Namespace


Message Property

NAnt SDK Documentation - v0.91

MailTask.Message Property

Text to send in body of email message.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="message", ExpandProperties:=True, ProcessXml:=True)>
Public Property Message As String
[C#]
[TaskAttribute(Required=False, Name="message", ExpandProperties=True, ProcessXml=True)]
public string Message {get; set;}

See Also

MailTask Class | NAnt.Core.Tasks Namespace


Subject Property

NAnt SDK Documentation - v0.91

MailTask.Subject Property

Text to send in subject line of email message.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="subject", ExpandProperties:=True, ProcessXml:=True)>
Public Property Subject As String
[C#]
[TaskAttribute(Required=False, Name="subject", ExpandProperties=True, ProcessXml=True)]
public string Subject {get; set;}

See Also

MailTask Class | NAnt.Core.Tasks Namespace


ToList Property

NAnt SDK Documentation - v0.91

MailTask.ToList Property

Semicolon-separated list of recipient email addresses.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="tolist", ExpandProperties:=True, ProcessXml:=True)>
Public Property ToList As String
[C#]
[TaskAttribute(Required=False, Name="tolist", ExpandProperties=True, ProcessXml=True)]
public string ToList {get; set;}

See Also

MailTask Class | NAnt.Core.Tasks Namespace


MailTask Methods

The methods of the MailTask class are listed below. For a complete list of MailTask class members, see the MailTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | This is where the work is done.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Initializes task and ensures the supplied attributes are valid.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailTask Class | NAnt.Core.Tasks Namespace


MailTask.ExecuteTask Method

This is where the work is done.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

MailTask Class | NAnt.Core.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

MailTask.Initialize Method

Initializes task and ensures the supplied attributes are valid.

Overload List

Initializes task and ensures the supplied attributes are valid.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

MailTask Class | NAnt.Core.Tasks Namespace


MailTask.Initialize Method ()

Initializes task and ensures the supplied attributes are valid.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

MailTask Class | NAnt.Core.Tasks Namespace | MailTask.Initialize Overload List


MkDirTask Class

Creates a directory and any non-existent parent directory if necessary.

For a list of all members of this type, see MkDirTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.MkDirTask

[Visual Basic]
<TaskName(Name:="mkdir")>
Public Class MkDirTask
Inherits Task
[C#]
[TaskName(Name="mkdir")]
public class MkDirTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Create the directory build.

            <mkdir dir="build" />

Create the directory tree one/two/three.

            <mkdir dir="one/two/three" />

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

MkDirTask Members | NAnt.Core.Tasks Namespace


MkDirTask Members

MkDirTask overview

Public Instance Constructors

MkDirTask Constructor Initializes a new instance of the MkDirTask class.

Public Instance Properties

Dir | The directory to create.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Creates the directory specified by the Dir property.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MkDirTask Class | NAnt.Core.Tasks Namespace


MkDirTask Constructor

Initializes a new instance of the MkDirTask class.

[Visual Basic]
Public Sub New()
[C#]
public MkDirTask();

See Also

MkDirTask Class | NAnt.Core.Tasks Namespace


MkDirTask Properties

The properties of the MkDirTask class are listed below. For a complete list of MkDirTask class members, see the MkDirTask Members topic.

Public Instance Properties

Dir | The directory to create.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

MkDirTask Class | NAnt.Core.Tasks Namespace


Dir Property

NAnt SDK Documentation - v0.91

MkDirTask.Dir Property

The directory to create.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="dir", ExpandProperties:=True, ProcessXml:=True)>
Public Property Dir As DirectoryInfo
[C#]
[TaskAttribute(Required=True, Name="dir", ExpandProperties=True, ProcessXml=True)]
public System.IO.DirectoryInfo Dir {get; set;}

See Also

MkDirTask Class | NAnt.Core.Tasks Namespace


MkDirTask Methods

The methods of the MkDirTask class are listed below. For a complete list of MkDirTask class members, see the MkDirTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Creates the directory specified by the Dir property.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MkDirTask Class | NAnt.Core.Tasks Namespace


MkDirTask.ExecuteTask Method

Creates the directory specified by the Dir property.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

Exceptions

Exception Type | Condition
BuildException | The directory could not be created.

See Also

MkDirTask Class | NAnt.Core.Tasks Namespace


MoveTask Class

Moves a file, a directory, or set of files to a new file or directory.

For a list of all members of this type, see MoveTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.CopyTask
NAnt.Core.Tasks.MoveTask

[Visual Basic]
<TaskName(Name:="move")>
Public Class MoveTask
Inherits CopyTask
[C#]
[TaskName(Name="move")]
public class MoveTask : CopyTask

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Files are only moved if the source file is newer than the destination file, or if the destination file does not exist. However, you can explicitly overwrite files with the Overwrite attribute.

A FileSet can be used to select files to move. To use a FileSet, the ToDirectory attribute must be set.

Encoding

Unless an encoding is specified, the encoding associated with the system's current ANSI code page is used.

An UTF-8, little-endian Unicode, and big-endian Unicode encoded text file is automatically recognized, if the file starts with the appropriate byte order marks.

Note If you employ filters in your move operation, you should limit the move to text files. Binary files will be corrupted by the move operation.

Example

Move a single file while changing its encoding from "latin1" to "utf-8".

<move
    file="myfile.txt"
    tofile="mycopy.txt"
    inputencoding="latin1"
    outputencoding="utf-8" />

Move a set of files.

<move todir="${build.dir}">
    <fileset basedir="bin">
        <include name="*.dll" />
    </fileset>
</move>

Move a set of files to a directory, replacing @TITLE@ with "Foo Bar" in all files.

<move todir="../backup/dir">
    <fileset basedir="src_dir">
        <include name="**/*" />
    </fileset>
    <filterchain>
        <replacetokens>
            <token key="TITLE" value="Foo Bar" />
        </replacetokens>
    </filterchain>
</move>

Move an entire directory and its contents.

<move tofile="target/dir">
  <fileset basedir="source/dir"/>
</move>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

MoveTask Members | NAnt.Core.Tasks Namespace


MoveTask Members

MoveTask overview

Public Instance Constructors

MoveTask Constructor Initializes a new instance of the MoveTask class.

Public Instance Properties

CopyFileSet | Used to select the files to move. To use a FileSet, the ToDirectory attribute must be set.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
Filters | Chain of filters used to alter the file's content as it is moved.
Flatten | Ignore directory structure of source directory, move all files into a single directory, specified by the ToDirectory attribute. The default is false.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IncludeEmptyDirs (inherited from CopyTask) | Copy any empty directories included in the FileSet. The default is true.
InputEncoding (inherited from CopyTask) | The encoding to use when reading files. The default is the system's current ANSI code page.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OutputEncoding (inherited from CopyTask) | The encoding to use when writing the files. The default is the encoding of the input file.
Overwrite (inherited from CopyTask) | Overwrite existing files even if the destination files are newer. The default is false.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
SourceFile | The file to move.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
ToDirectory | The directory to move to.
ToFile | The file to move to.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
FileCopyMap (inherited from CopyTask) | The set of files to perform a file operation on.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
CreateSourceFileNotFoundException |
DoFileOperations | Actually does the file moves.
ExecuteTask (inherited from CopyTask) | Executes the Copy task.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from CopyTask) | Overloaded. Checks whether the task is initialized with valid attributes.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MoveTask Class | NAnt.Core.Tasks Namespace


MoveTask Constructor

Initializes a new instance of the MoveTask class.

[Visual Basic]
Public Sub New()
[C#]
public MoveTask();

See Also

MoveTask Class | NAnt.Core.Tasks Namespace


MoveTask Properties

The properties of the MoveTask class are listed below. For a complete list of MoveTask class members, see the MoveTask Members topic.

Public Instance Properties

CopyFileSet | Used to select the files to move. To use a FileSet, the ToDirectory attribute must be set.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
Filters | Chain of filters used to alter the file's content as it is moved.
Flatten | Ignore directory structure of source directory, move all files into a single directory, specified by the ToDirectory attribute. The default is false.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IncludeEmptyDirs (inherited from CopyTask) | Copy any empty directories included in the FileSet. The default is true.
InputEncoding (inherited from CopyTask) | The encoding to use when reading files. The default is the system's current ANSI code page.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OutputEncoding (inherited from CopyTask) | The encoding to use when writing the files. The default is the encoding of the input file.
Overwrite (inherited from CopyTask) | Overwrite existing files even if the destination files are newer. The default is false.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
SourceFile | The file to move.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
ToDirectory | The directory to move to.
ToFile | The file to move to.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
FileCopyMap (inherited from CopyTask) | The set of files to perform a file operation on.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

MoveTask Class | NAnt.Core.Tasks Namespace


CopyFileSet Property

NAnt SDK Documentation - v0.91

MoveTask.CopyFileSet Property

Used to select the files to move. To use a FileSet, the ToDirectory attribute must be set.

[Visual Basic]
<BuildElement(Name:="fileset", Required:=False, ProcessXml:=True)>
Overrides Public Property CopyFileSet As FileSet
[C#]
[BuildElement(Name="fileset", Required=False, ProcessXml=True)]
public override NAnt.Core.Types.FileSet CopyFileSet {get; set;}

See Also

MoveTask Class | NAnt.Core.Tasks Namespace


Filters Property

NAnt SDK Documentation - v0.91

MoveTask.Filters Property

Chain of filters used to alter the file's content as it is moved.

[Visual Basic]
<BuildElement(Name:="filterchain", Required:=False, ProcessXml:=True)>
Overrides Public Property Filters As FilterChain
[C#]
[BuildElement(Name="filterchain", Required=False, ProcessXml=True)]
public override NAnt.Core.Filters.FilterChain Filters {get; set;}

See Also

MoveTask Class | NAnt.Core.Tasks Namespace


Flatten Property

NAnt SDK Documentation - v0.91

MoveTask.Flatten Property

Ignore directory structure of source directory, move all files into a single directory, specified by the ToDirectory attribute. The default is false.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="flatten", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Overrides Public Property Flatten As Boolean
[C#]
[TaskAttribute(Required=False, Name="flatten", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public override bool Flatten {get; set;}

See Also

MoveTask Class | NAnt.Core.Tasks Namespace


SourceFile Property

NAnt SDK Documentation - v0.91

MoveTask.SourceFile Property

The file to move.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="file", ExpandProperties:=True, ProcessXml:=True)>
Overrides Public Property SourceFile As FileInfo
[C#]
[TaskAttribute(Required=False, Name="file", ExpandProperties=True, ProcessXml=True)]
public override System.IO.FileInfo SourceFile {get; set;}

See Also

MoveTask Class | NAnt.Core.Tasks Namespace


ToDirectory Property

NAnt SDK Documentation - v0.91

MoveTask.ToDirectory Property

The directory to move to.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="todir", ExpandProperties:=True, ProcessXml:=True)>
Overrides Public Property ToDirectory As DirectoryInfo
[C#]
[TaskAttribute(Required=False, Name="todir", ExpandProperties=True, ProcessXml=True)]
public override System.IO.DirectoryInfo ToDirectory {get; set;}

See Also

MoveTask Class | NAnt.Core.Tasks Namespace


ToFile Property

NAnt SDK Documentation - v0.91

MoveTask.ToFile Property

The file to move to.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="tofile", ExpandProperties:=True, ProcessXml:=True)>
Overrides Public Property ToFile As FileInfo
[C#]
[TaskAttribute(Required=False, Name="tofile", ExpandProperties=True, ProcessXml=True)]
public override System.IO.FileInfo ToFile {get; set;}

See Also

MoveTask Class | NAnt.Core.Tasks Namespace


MoveTask Methods

The methods of the MoveTask class are listed below. For a complete list of MoveTask class members, see the MoveTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
CreateSourceFileNotFoundException |
DoFileOperations | Actually does the file moves.
ExecuteTask (inherited from CopyTask) | Executes the Copy task.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from CopyTask) | Overloaded. Checks whether the task is initialized with valid attributes.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MoveTask Class | NAnt.Core.Tasks Namespace


MoveTask.CreateSourceFileNotFoundException Method

[Visual Basic]
Overrides Protected Function CreateSourceFileNotFoundException( _
ByVal sourceFile As String _
) As BuildException
[C#]
protected override BuildException CreateSourceFileNotFoundException(
string sourceFile
);

See Also

MoveTask Class | NAnt.Core.Tasks Namespace


MoveTask.DoFileOperations Method

Actually does the file moves.

[Visual Basic]
Overrides Protected Sub DoFileOperations()
[C#]
protected override void DoFileOperations();

See Also

MoveTask Class | NAnt.Core.Tasks Namespace


NAntSchemaTask Class

Creates an XSD File for all available tasks.

For a list of all members of this type, see NAntSchemaTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.NAntSchemaTask

[Visual Basic]
<TaskName(Name:="nantschema")>
Public Class NAntSchemaTask
Inherits Task
[C#]
[TaskName(Name="nantschema")]
public class NAntSchemaTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This can be used in conjuntion with the command-line option to do XSD Schema validation on the build file.

Example

Creates a NAnt.xsd file in the current project directory.

            <nantschema output="NAnt.xsd" />

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

NAntSchemaTask Members | NAnt.Core.Tasks Namespace


NAntSchemaTask Members

NAntSchemaTask overview

Public Static (Shared) Methods

WriteSchema Creates a NAnt Schema for given types

Protected Static (Shared) Methods

CreateXsdAttribute | Creates a new XmlSchemaAttribute instance.
CreateXsdSequence | Creates a new XmlSchemaSequence instance.
GenerateIDFromType |
TextToNodeArray |

Public Instance Constructors

NAntSchemaTask Constructor Initializes a new instance of the NAntSchemaTask class.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForType | The Type for which an XSD should be created. If not specified, an XSD will be created for all available tasks.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OutputFile | The name of the output file to which the XSD should be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
TargetNamespace | The target namespace for the output. Defaults to "http://tempuri.org/nant-donotuse.xsd"
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NAntSchemaTask Class | NAnt.Core.Tasks Namespace


NAntSchemaTask Constructor

Initializes a new instance of the NAntSchemaTask class.

[Visual Basic]
Public Sub New()
[C#]
public NAntSchemaTask();

See Also

NAntSchemaTask Class | NAnt.Core.Tasks Namespace


NAntSchemaTask Properties

The properties of the NAntSchemaTask class are listed below. For a complete list of NAntSchemaTask class members, see the NAntSchemaTask Members topic.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForType | The Type for which an XSD should be created. If not specified, an XSD will be created for all available tasks.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OutputFile | The name of the output file to which the XSD should be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
TargetNamespace | The target namespace for the output. Defaults to "http://tempuri.org/nant-donotuse.xsd"
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

NAntSchemaTask Class | NAnt.Core.Tasks Namespace


ForType Property

NAnt SDK Documentation - v0.91

NAntSchemaTask.ForType Property

The Type for which an XSD should be created. If not specified, an XSD will be created for all available tasks.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="class", ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property ForType As String
[C#]
[TaskAttribute(Required=False, Name="class", ExpandProperties=True, ProcessXml=True)]
public virtual string ForType {get; set;}

See Also

NAntSchemaTask Class | NAnt.Core.Tasks Namespace


OutputFile Property

NAnt SDK Documentation - v0.91

NAntSchemaTask.OutputFile Property

The name of the output file to which the XSD should be written.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="output", ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property OutputFile As FileInfo
[C#]
[TaskAttribute(Required=True, Name="output", ExpandProperties=True, ProcessXml=True)]
public virtual System.IO.FileInfo OutputFile {get; set;}

See Also

NAntSchemaTask Class | NAnt.Core.Tasks Namespace


TargetNamespace Property

NAnt SDK Documentation - v0.91

NAntSchemaTask.TargetNamespace Property

The target namespace for the output. Defaults to "http://tempuri.org/nant-donotuse.xsd"

[Visual Basic]
<TaskAttribute(Required:=False, Name:="target-ns", ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property TargetNamespace As String
[C#]
[TaskAttribute(Required=False, Name="target-ns", ExpandProperties=True, ProcessXml=True)]
public virtual string TargetNamespace {get; set;}

See Also

NAntSchemaTask Class | NAnt.Core.Tasks Namespace


NAntSchemaTask Methods

The methods of the NAntSchemaTask class are listed below. For a complete list of NAntSchemaTask class members, see the NAntSchemaTask Members topic.

Public Static (Shared) Methods

WriteSchema Creates a NAnt Schema for given types

Protected Static (Shared) Methods

CreateXsdAttribute | Creates a new XmlSchemaAttribute instance.
CreateXsdSequence | Creates a new XmlSchemaSequence instance.
GenerateIDFromType |
TextToNodeArray |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NAntSchemaTask Class | NAnt.Core.Tasks Namespace


NAntSchemaTask.CreateXsdAttribute Method

Creates a new XmlSchemaAttribute instance.

[Visual Basic]
Protected Shared Function CreateXsdAttribute( _
ByVal name As String, _
ByVal required As Boolean _
) As XmlSchemaAttribute
[C#]
protected static XmlSchemaAttribute CreateXsdAttribute(
string name,
bool required
);

Parameters

name
The name of the attribute.
required
Value indicating whether the attribute should be required.

Return Value

The new XmlSchemaAttribute instance.

See Also

NAntSchemaTask Class | NAnt.Core.Tasks Namespace


NAntSchemaTask.CreateXsdSequence Method

Creates a new XmlSchemaSequence instance.

[Visual Basic]
Protected Shared Function CreateXsdSequence( _
ByVal min As Decimal, _
ByVal max As Decimal _
) As XmlSchemaSequence
[C#]
protected static XmlSchemaSequence CreateXsdSequence(
decimal min,
decimal max
);

Parameters

min
The minimum value to allow for this choice
max
The maximum value to allow, Decimal.MaxValue sets it to 'unbound'

Return Value

The new XmlSchemaSequence instance.

See Also

NAntSchemaTask Class | NAnt.Core.Tasks Namespace


NAntSchemaTask.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

NAntSchemaTask Class | NAnt.Core.Tasks Namespace


NAntSchemaTask.GenerateIDFromType Method

[Visual Basic]
Protected Shared Function GenerateIDFromType( _
ByVal type As Type _
) As String
[C#]
protected static string GenerateIDFromType(
Type type
);

See Also

NAntSchemaTask Class | NAnt.Core.Tasks Namespace


NAntSchemaTask.TextToNodeArray Method

[Visual Basic]
Protected Shared Function TextToNodeArray( _
ByVal text As String _
) As XmlNode()
[C#]
protected static XmlNode[] TextToNodeArray(
string text
);

See Also

NAntSchemaTask Class | NAnt.Core.Tasks Namespace


NAntSchemaTask.WriteSchema Method

Creates a NAnt Schema for given types

[Visual Basic]
Public Shared Function WriteSchema( _
ByVal stream As Stream, _
ByVal tasks As Type(), _
ByVal dataTypes As Type(), _
ByVal targetNS As String _
) As XmlSchema
[C#]
public static XmlSchema WriteSchema(
Stream stream,
Type[] tasks,
Type[] dataTypes,
string targetNS
);

Parameters

stream
The output stream to save the schema to. If a null reference (Nothing in Visual Basic), writing is ignored, no exception generated.
tasks
The list of tasks to generate XML Schema for.
dataTypes
The list of datatypes to generate XML Schema for.
targetNS
The target namespace to output.

Return Value

The new NAnt Schema.

See Also

NAntSchemaTask Class | NAnt.Core.Tasks Namespace


NAntTask Class

Runs NAnt on a supplied build file, or a set of build files.

For a list of all members of this type, see NAntTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.NAntTask

[Visual Basic]
<TaskName(Name:="nant")>
Public Class NAntTask
Inherits Task
[C#]
[TaskName(Name="nant")]
public class NAntTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

By default, all the properties of the current project will be available in the new project. Alternatively, you can set InheritAll to false to not copy any properties to the new project.

You can also set properties in the new project from the old project by using nested property tags. These properties are always passed to the new project regardless of the setting of InheritAll. This allows you to parameterize your subprojects.

References to data types can also be passed to the new project, but by default they are not. If you set the InheritRefs to true, all references will be copied.

Example

Build a project located in a different directory if the debug property is not true.

<nant buildfile="${src.dir}/Extras/BuildServer/BuildServer.build" unless="${debug}" />

Build a project while adding a set of properties to that project.

<nant buildfile="${src.dir}/Extras/BuildServer/BuildServer.build">
    <properties>
        <property name="build.dir" value="c:/buildserver" />
        <property name="build.debug" value="false" />
        <property name="lib.dir" value="c:/shared/lib" readonly="true" />
    </properties>
</nant>

Build all projects named default.build located anywhere under the project base directory.

<nant>
    <buildfiles>
        <include name="**/default.build" />
        <!-- avoid recursive execution of current build file -->
        <exclude name="${project::get-buildfile-path()}" />
    </buildfiles>
</nant>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

NAntTask Members | NAnt.Core.Tasks Namespace


NAntTask Members

NAntTask overview

Public Instance Constructors

NAntTask Constructor Initializes a new instance of the NAntTask class.

Public Instance Properties

BuildFile | The build file to build.
BuildFiles | Used to specify a set of build files to process.
DefaultTarget | The target to execute. To specify more than one target seperate targets with a space. Targets are executed in order if possible. The default is to use target specified in the project's default attribute.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
InheritAll | Specifies whether current property values should be inherited by the executed project. The default is true.
InheritRefs | Specifies whether all references will be copied to the new project. The default is false.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OverrideProperties | Specifies a collection of properties that should be created in the executed project. Note, existing properties with identical names that are not read-only will be overwritten.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Validates the NAntTask element.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NAntTask Class | NAnt.Core.Tasks Namespace


NAntTask Constructor

Initializes a new instance of the NAntTask class.

[Visual Basic]
Public Sub New()
[C#]
public NAntTask();

See Also

NAntTask Class | NAnt.Core.Tasks Namespace


NAntTask Properties

The properties of the NAntTask class are listed below. For a complete list of NAntTask class members, see the NAntTask Members topic.

Public Instance Properties

BuildFile | The build file to build.
BuildFiles | Used to specify a set of build files to process.
DefaultTarget | The target to execute. To specify more than one target seperate targets with a space. Targets are executed in order if possible. The default is to use target specified in the project's default attribute.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
InheritAll | Specifies whether current property values should be inherited by the executed project. The default is true.
InheritRefs | Specifies whether all references will be copied to the new project. The default is false.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OverrideProperties | Specifies a collection of properties that should be created in the executed project. Note, existing properties with identical names that are not read-only will be overwritten.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

NAntTask Class | NAnt.Core.Tasks Namespace


BuildFile Property

NAnt SDK Documentation - v0.91

NAntTask.BuildFile Property

The build file to build.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="buildfile", ExpandProperties:=True, ProcessXml:=True)>
Public Property BuildFile As FileInfo
[C#]
[TaskAttribute(Required=False, Name="buildfile", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo BuildFile {get; set;}

See Also

NAntTask Class | NAnt.Core.Tasks Namespace


BuildFiles Property

NAnt SDK Documentation - v0.91

NAntTask.BuildFiles Property

Used to specify a set of build files to process.

[Visual Basic]
<BuildElement(Name:="buildfiles", Required:=False, ProcessXml:=True)>
Overridable Public Property BuildFiles As FileSet
[C#]
[BuildElement(Name="buildfiles", Required=False, ProcessXml=True)]
public virtual NAnt.Core.Types.FileSet BuildFiles {get; set;}

See Also

NAntTask Class | NAnt.Core.Tasks Namespace


DefaultTarget Property

NAnt SDK Documentation - v0.91

NAntTask.DefaultTarget Property

The target to execute. To specify more than one target seperate targets with a space. Targets are executed in order if possible. The default is to use target specified in the project's default attribute.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="target", ExpandProperties:=True, ProcessXml:=True)>
Public Property DefaultTarget As String
[C#]
[TaskAttribute(Required=False, Name="target", ExpandProperties=True, ProcessXml=True)]
public string DefaultTarget {get; set;}

See Also

NAntTask Class | NAnt.Core.Tasks Namespace


InheritAll Property

NAnt SDK Documentation - v0.91

NAntTask.InheritAll Property

Specifies whether current property values should be inherited by the executed project. The default is true.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="inheritall", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property InheritAll As Boolean
[C#]
[TaskAttribute(Required=False, Name="inheritall", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool InheritAll {get; set;}

See Also

NAntTask Class | NAnt.Core.Tasks Namespace


InheritRefs Property

NAnt SDK Documentation - v0.91

NAntTask.InheritRefs Property

Specifies whether all references will be copied to the new project. The default is false.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="inheritrefs", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property InheritRefs As Boolean
[C#]
[TaskAttribute(Required=False, Name="inheritrefs", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool InheritRefs {get; set;}

See Also

NAntTask Class | NAnt.Core.Tasks Namespace


OverrideProperties Property

NAnt SDK Documentation - v0.91

NAntTask.OverrideProperties Property

Specifies a collection of properties that should be created in the executed project. Note, existing properties with identical names that are not read-only will be overwritten.

[Visual Basic]
<BuildElementCollection(ChildElementName:="property", ElementType:=NAnt.Core.Tasks.PropertyTask, Name:="properties", Required:=False, ProcessXml:=True)>
Public ReadOnly Property OverrideProperties As ArrayList
[C#]
[BuildElementCollection(ChildElementName="property", ElementType=NAnt.Core.Tasks.PropertyTask, Name="properties", Required=False, ProcessXml=True)]
public System.Collections.ArrayList OverrideProperties {get;}

See Also

NAntTask Class | NAnt.Core.Tasks Namespace


NAntTask Methods

The methods of the NAntTask class are listed below. For a complete list of NAntTask class members, see the NAntTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Validates the NAntTask element.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NAntTask Class | NAnt.Core.Tasks Namespace


NAntTask.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

NAntTask Class | NAnt.Core.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

NAntTask.Initialize Method

Validates the NAntTask element.

Overload List

Validates the NAntTask element.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

NAntTask Class | NAnt.Core.Tasks Namespace


NAntTask.Initialize Method ()

Validates the NAntTask element.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

NAntTask Class | NAnt.Core.Tasks Namespace | NAntTask.Initialize Overload List


PropertyTask Class

Sets a property in the current project.

For a list of all members of this type, see PropertyTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.PropertyTask

[Visual Basic]
<TaskName(Name:="property")>
Public Class PropertyTask
Inherits Task
[C#]
[TaskName(Name="property")]
public class PropertyTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Note NAnt uses a number of predefined properties.

Example

Define a debug property with value true.

            <property name="debug" value="true" />

Use the user-defined debug property.

            <property name="trace" value="${debug}" />

Define a read-only property. This is just like passing in the param on the command line.

            <property name="do_not_touch_ME" value="hammer" readonly="true" />

Define a property, but do not overwrite the value if the property already exists (eg. it was specified on the command line).

            <project name="property-example">
              <property name="debug" value="true" overwrite="false" />
              <echo message="debug: ${debug}" />
            </project>

Executing this build file with the command line option -D:debug=false, would cause the value specified on the command line to remain unaltered.

            [echo] debug: false

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

PropertyTask Members | NAnt.Core.Tasks Namespace


PropertyTask Members

PropertyTask overview

Public Instance Constructors

PropertyTask Constructor Initializes a new instance of the PropertyTask class.

Public Instance Properties

Dynamic | Specifies whether references to other properties should not be expanded when the value of the property is set, but expanded when the property is actually used. By default, properties will be expanded when set.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Overwrite | Specifies whether the value of a property should be overwritten if the property already exists (unless the property is read-only). The default is true.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PropertyName | The name of the NAnt property to set.
ReadOnly | Specifies whether the property is read-only or not. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Value | The value to assign to the NAnt property.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyTask Class | NAnt.Core.Tasks Namespace


PropertyTask Constructor

Initializes a new instance of the PropertyTask class.

[Visual Basic]
Public Sub New()
[C#]
public PropertyTask();

See Also

PropertyTask Class | NAnt.Core.Tasks Namespace


PropertyTask Properties

The properties of the PropertyTask class are listed below. For a complete list of PropertyTask class members, see the PropertyTask Members topic.

Public Instance Properties

Dynamic | Specifies whether references to other properties should not be expanded when the value of the property is set, but expanded when the property is actually used. By default, properties will be expanded when set.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Overwrite | Specifies whether the value of a property should be overwritten if the property already exists (unless the property is read-only). The default is true.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PropertyName | The name of the NAnt property to set.
ReadOnly | Specifies whether the property is read-only or not. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Value | The value to assign to the NAnt property.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

PropertyTask Class | NAnt.Core.Tasks Namespace


Dynamic Property

NAnt SDK Documentation - v0.91

PropertyTask.Dynamic Property

Specifies whether references to other properties should not be expanded when the value of the property is set, but expanded when the property is actually used. By default, properties will be expanded when set.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="dynamic", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property Dynamic As Boolean
[C#]
[TaskAttribute(Required=False, Name="dynamic", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool Dynamic {get; set;}

See Also

PropertyTask Class | NAnt.Core.Tasks Namespace


Overwrite Property

NAnt SDK Documentation - v0.91

PropertyTask.Overwrite Property

Specifies whether the value of a property should be overwritten if the property already exists (unless the property is read-only). The default is true.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="overwrite", ExpandProperties:=True, ProcessXml:=True)>
Public Property Overwrite As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="overwrite", ExpandProperties=True, ProcessXml=True)]
public bool Overwrite {get; set;}

See Also

PropertyTask Class | NAnt.Core.Tasks Namespace


PropertyName Property

NAnt SDK Documentation - v0.91

PropertyTask.PropertyName Property

The name of the NAnt property to set.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Required:=True, Name:="name", ExpandProperties:=True, ProcessXml:=True)>
Public Property PropertyName As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Required=True, Name="name", ExpandProperties=True, ProcessXml=True)]
public string PropertyName {get; set;}

See Also

PropertyTask Class | NAnt.Core.Tasks Namespace


ReadOnly Property

NAnt SDK Documentation - v0.91

PropertyTask.ReadOnly Property

Specifies whether the property is read-only or not. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="readonly", ExpandProperties:=True, ProcessXml:=True)>
Public Property ReadOnly As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="readonly", ExpandProperties=True, ProcessXml=True)]
public bool ReadOnly {get; set;}

See Also

PropertyTask Class | NAnt.Core.Tasks Namespace


Value Property

NAnt SDK Documentation - v0.91

PropertyTask.Value Property

The value to assign to the NAnt property.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="value", ExpandProperties:=False, ProcessXml:=True), _ StringValidator(AllowEmpty:=True, Expression:="null", ExpressionErrorMessage:="null")>
Public Property Value As String
[C#]
[TaskAttribute(Required=True, Name="value", ExpandProperties=False, ProcessXml=True)]
[StringValidator(AllowEmpty=True, Expression="null", ExpressionErrorMessage="null")]
public string Value {get; set;}

See Also

PropertyTask Class | NAnt.Core.Tasks Namespace


PropertyTask Methods

The methods of the PropertyTask class are listed below. For a complete list of PropertyTask class members, see the PropertyTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyTask Class | NAnt.Core.Tasks Namespace


PropertyTask.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

PropertyTask Class | NAnt.Core.Tasks Namespace


RegexTask Class

Sets project properties based on the evaluatuion of a regular expression.

For a list of all members of this type, see RegexTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.RegexTask

[Visual Basic]
<TaskName(Name:="regex")>
Public Class RegexTask
Inherits Task
[C#]
[TaskName(Name="regex")]
public class RegexTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The Pattern attribute must contain one or more named grouping constructs, which represents the names of the properties to be set. These named grouping constructs can be enclosed by angle brackets (?<name>) or single quotes (?'name').

Note In the build file, use the XML element &lt; to specify <, and &gt; to specify >.
Note The named grouping construct must not contain any punctuation and it cannot begin with a number.

Example

Find the last word in the given string and stores it in the property lastword.

<regex pattern="(?'lastword'\w+)$" input="This is a test sentence" />
<echo message="${lastword}" />

Split the full filename and extension of a filename.

<regex pattern="^(?'filename'.*)\.(?'extension'\w+)$" input="d:\Temp\SomeDir\SomeDir\bla.xml" />

Split the path and the filename. (This checks for / or \ as the path separator).

<regex pattern="^(?'path'.*(\\|/)|(/|\\))(?'file'.*)$" input="d:\Temp\SomeDir\SomeDir\bla.xml" />

Results in path=d:\Temp\SomeDir\SomeDir\ and file=bla.xml.

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

RegexTask Members | NAnt.Core.Tasks Namespace


RegexTask Members

RegexTask overview

Public Instance Constructors

RegexTask Constructor Initializes a new instance of the RegexTask class.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
Input | Represents the input for the regular expression.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Options | A comma separated list of options to pass to the regex engine. The default is None.
Parent (inherited from Element) | Gets or sets the parent of the element.
Pattern | Represents the regular expression to be evalued.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Executes the task.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RegexTask Class | NAnt.Core.Tasks Namespace


RegexTask Constructor

Initializes a new instance of the RegexTask class.

[Visual Basic]
Public Sub New()
[C#]
public RegexTask();

See Also

RegexTask Class | NAnt.Core.Tasks Namespace


RegexTask Properties

The properties of the RegexTask class are listed below. For a complete list of RegexTask class members, see the RegexTask Members topic.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
Input | Represents the input for the regular expression.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Options | A comma separated list of options to pass to the regex engine. The default is None.
Parent (inherited from Element) | Gets or sets the parent of the element.
Pattern | Represents the regular expression to be evalued.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

RegexTask Class | NAnt.Core.Tasks Namespace


Input Property

NAnt SDK Documentation - v0.91

RegexTask.Input Property

Represents the input for the regular expression.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="input", ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=True, Expression:="null", ExpressionErrorMessage:="null")>
Public Property Input As String
[C#]
[TaskAttribute(Required=True, Name="input", ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=True, Expression="null", ExpressionErrorMessage="null")]
public string Input {get; set;}

Property Value

The input for the regular expression.

See Also

RegexTask Class | NAnt.Core.Tasks Namespace


Options Property

NAnt SDK Documentation - v0.91

RegexTask.Options Property

A comma separated list of options to pass to the regex engine. The default is None.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="options", ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=True, Expression:="null", ExpressionErrorMessage:="null")>
Public Property Options As RegexOptions
[C#]
[TaskAttribute(Required=False, Name="options", ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=True, Expression="null", ExpressionErrorMessage="null")]
public System.Text.RegularExpressions.RegexOptions Options {get; set;}

See Also

RegexTask Class | NAnt.Core.Tasks Namespace


Pattern Property

NAnt SDK Documentation - v0.91

RegexTask.Pattern Property

Represents the regular expression to be evalued.

[Visual Basic]
<TaskAttribute(Name:="pattern", Required:=True, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property Pattern As String
[C#]
[TaskAttribute(Name="pattern", Required=True, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string Pattern {get; set;}

Property Value

The regular expression to be evalued.

Remarks

The pattern must contain one or more named constructs, which may not contain any punctuation and cannot begin with a number.

See Also

RegexTask Class | NAnt.Core.Tasks Namespace


RegexTask Methods

The methods of the RegexTask class are listed below. For a complete list of RegexTask class members, see the RegexTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Executes the task.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RegexTask Class | NAnt.Core.Tasks Namespace


RegexTask.ExecuteTask Method

Executes the task.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

RegexTask Class | NAnt.Core.Tasks Namespace


SetEnvTask Class

Sets an environment variable or a whole collection of them. Use an empty LiteralValue attribute to clear a variable.

For a list of all members of this type, see SetEnvTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.SetEnvTask

[Visual Basic]
<TaskName(Name:="setenv")>
Public Class SetEnvTask
Inherits Task
[C#]
[TaskName(Name="setenv")]
public class SetEnvTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Note Variables will be set for the current NAnt process and all child processes that NAnt spawns (compilers, shell tools, etc). If the intention is to only set a variable for a single child process, then using the ExecTask and its nested EnvironmentSet element might be a better option.
Note Expansion of inline environment variables is performed using the syntax of the current platform. So on Windows platforms using the string %PATH% in the LiteralValue attribute will result in the value of the PATH variable being expanded in place before the variable is set.

Example

Set the MONO_PATH environment variable on a *nix platform.

  <setenv name=="MONO_PATH" value="/home/jimbob/dev/foo:%MONO_PATH%"/>

Set a collection of environment variables. Note the nested variable used to set var3.

  <setenv>
          <variable name="var1" value="value2" />
          <variable name="var2" value="value2" />
          <variable name="var3" value="value3:%var2%" />
  </setenv>

Set environment variables using nested path elements.

  <path id="build.path">
         <pathelement dir="c:/windows" />
         <pathelement dir="c:/cygwin/usr/local/bin" />
     </path>
  <setenv>
          <variable name="build_path" >
                 <path refid="build.path" />
          </variable>
          <variable name="path2">
             <path>
                 <pathelement dir="c:/windows" />
                 <pathelement dir="c:/cygwin/usr/local/bin" />
             </path>
          </variable>
  </setenv>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

SetEnvTask Members | NAnt.Core.Tasks Namespace


SetEnvTask Members

SetEnvTask overview

Public Instance Constructors

SetEnvTask Constructor Initializes a new instance of the SetEnvTask class.

Public Instance Properties

Directory | The value for a directory-based environment variable. NAnt will convert it to an absolute path.
EnvironmentVariables |
EnvName | The name of a single Environment variable to set
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
File | The value for a file-based environment variable. NAnt will convert it to an absolute filename.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LiteralValue | The literal value for the environment variable.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Path | The value for a PATH like environment variable. You can use : or ; as path separators and NAnt will convert it to the platform's local conventions.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Set the environment variables
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Checks whether the task is initialized with valid attributes.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetEnvTask Class | NAnt.Core.Tasks Namespace


SetEnvTask Constructor

Initializes a new instance of the SetEnvTask class.

[Visual Basic]
Public Sub New()
[C#]
public SetEnvTask();

See Also

SetEnvTask Class | NAnt.Core.Tasks Namespace


SetEnvTask Properties

The properties of the SetEnvTask class are listed below. For a complete list of SetEnvTask class members, see the SetEnvTask Members topic.

Public Instance Properties

Directory | The value for a directory-based environment variable. NAnt will convert it to an absolute path.
EnvironmentVariables |
EnvName | The name of a single Environment variable to set
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
File | The value for a file-based environment variable. NAnt will convert it to an absolute filename.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LiteralValue | The literal value for the environment variable.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Path | The value for a PATH like environment variable. You can use : or ; as path separators and NAnt will convert it to the platform's local conventions.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

SetEnvTask Class | NAnt.Core.Tasks Namespace


Directory Property

NAnt SDK Documentation - v0.91

SetEnvTask.Directory Property

The value for a directory-based environment variable. NAnt will convert it to an absolute path.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="dir", ExpandProperties:=True, ProcessXml:=True)>
Public Property Directory As DirectoryInfo
[C#]
[TaskAttribute(Required=False, Name="dir", ExpandProperties=True, ProcessXml=True)]
public System.IO.DirectoryInfo Directory {get; set;}

See Also

SetEnvTask Class | NAnt.Core.Tasks Namespace


EnvironmentVariables Property

NAnt SDK Documentation - v0.91

SetEnvTask.EnvironmentVariables Property

[Visual Basic]
<BuildElementArray(ElementType:=NAnt.Core.Types.EnvironmentVariable, Name:="variable", Required:=False, ProcessXml:=True)>
Public Property EnvironmentVariables As EnvironmentVariableCollection
[C#]
[BuildElementArray(ElementType=NAnt.Core.Types.EnvironmentVariable, Name="variable", Required=False, ProcessXml=True)]
public NAnt.Core.Types.EnvironmentVariableCollection EnvironmentVariables {get; set;}

See Also

SetEnvTask Class | NAnt.Core.Tasks Namespace


EnvName Property

NAnt SDK Documentation - v0.91

SetEnvTask.EnvName Property

The name of a single Environment variable to set

[Visual Basic]
<TaskAttribute(Required:=False, Name:="name", ExpandProperties:=True, ProcessXml:=True)>
Public Property EnvName As String
[C#]
[TaskAttribute(Required=False, Name="name", ExpandProperties=True, ProcessXml=True)]
public string EnvName {get; set;}

See Also

SetEnvTask Class | NAnt.Core.Tasks Namespace


File Property

NAnt SDK Documentation - v0.91

SetEnvTask.File Property

The value for a file-based environment variable. NAnt will convert it to an absolute filename.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="file", ExpandProperties:=True, ProcessXml:=True)>
Public Property File As FileInfo
[C#]
[TaskAttribute(Required=False, Name="file", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo File {get; set;}

See Also

SetEnvTask Class | NAnt.Core.Tasks Namespace


LiteralValue Property

NAnt SDK Documentation - v0.91

SetEnvTask.LiteralValue Property

The literal value for the environment variable.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="value", ExpandProperties:=True, ProcessXml:=True)>
Public Property LiteralValue As String
[C#]
[TaskAttribute(Required=False, Name="value", ExpandProperties=True, ProcessXml=True)]
public string LiteralValue {get; set;}

See Also

SetEnvTask Class | NAnt.Core.Tasks Namespace


Path Property

NAnt SDK Documentation - v0.91

SetEnvTask.Path Property

The value for a PATH like environment variable. You can use : or ; as path separators and NAnt will convert it to the platform's local conventions.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="path", ExpandProperties:=True, ProcessXml:=True)>
Public Property Path As PathSet
[C#]
[TaskAttribute(Required=False, Name="path", ExpandProperties=True, ProcessXml=True)]
public NAnt.Core.Types.PathSet Path {get; set;}

See Also

SetEnvTask Class | NAnt.Core.Tasks Namespace


SetEnvTask Methods

The methods of the SetEnvTask class are listed below. For a complete list of SetEnvTask class members, see the SetEnvTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Set the environment variables
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Checks whether the task is initialized with valid attributes.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetEnvTask Class | NAnt.Core.Tasks Namespace


SetEnvTask.ExecuteTask Method

Set the environment variables

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

SetEnvTask Class | NAnt.Core.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

SetEnvTask.Initialize Method

Checks whether the task is initialized with valid attributes.

Overload List

Checks whether the task is initialized with valid attributes.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

SetEnvTask Class | NAnt.Core.Tasks Namespace


SetEnvTask.Initialize Method ()

Checks whether the task is initialized with valid attributes.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

SetEnvTask Class | NAnt.Core.Tasks Namespace | SetEnvTask.Initialize Overload List


SleepTask Class

A task for sleeping a specified period of time, useful when a build or deployment process requires an interval between tasks.

For a list of all members of this type, see SleepTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.SleepTask

[Visual Basic]
<TaskName(Name:="sleep")>
Public Class SleepTask
Inherits Task
[C#]
[TaskName(Name="sleep")]
public class SleepTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Sleep 1 hour, 2 minutes, 3 seconds and 4 milliseconds.

            <sleep hours="1" minutes="2" seconds="3" milliseconds="4" />

Sleep 123 milliseconds.

            <sleep milliseconds="123" />

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

SleepTask Members | NAnt.Core.Tasks Namespace


SleepTask Members

SleepTask overview

Public Instance Constructors

SleepTask Constructor Initializes a new instance of the SleepTask class.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
Hours | Hours to add to the sleep time.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Milliseconds | Milliseconds to add to the sleep time.
Minutes | Minutes to add to the sleep time.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Seconds | Seconds to add to the sleep time.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Verify parameters.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SleepTask Class | NAnt.Core.Tasks Namespace


SleepTask Constructor

Initializes a new instance of the SleepTask class.

[Visual Basic]
Public Sub New()
[C#]
public SleepTask();

See Also

SleepTask Class | NAnt.Core.Tasks Namespace


SleepTask Properties

The properties of the SleepTask class are listed below. For a complete list of SleepTask class members, see the SleepTask Members topic.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
Hours | Hours to add to the sleep time.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Milliseconds | Milliseconds to add to the sleep time.
Minutes | Minutes to add to the sleep time.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Seconds | Seconds to add to the sleep time.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

SleepTask Class | NAnt.Core.Tasks Namespace


Hours Property

NAnt SDK Documentation - v0.91

SleepTask.Hours Property

Hours to add to the sleep time.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="hours", ExpandProperties:=True, ProcessXml:=True), _ Int32Validator(MinValue:=0, MaxValue:=2147483647, Base:=10)>
Public Property Hours As Integer
[C#]
[TaskAttribute(Required=False, Name="hours", ExpandProperties=True, ProcessXml=True)]
[Int32Validator(MinValue=0, MaxValue=2147483647, Base=10)]
public int Hours {get; set;}

See Also

SleepTask Class | NAnt.Core.Tasks Namespace


Milliseconds Property

NAnt SDK Documentation - v0.91

SleepTask.Milliseconds Property

Milliseconds to add to the sleep time.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="milliseconds", ExpandProperties:=True, ProcessXml:=True), _ Int32Validator(MinValue:=0, MaxValue:=2147483647, Base:=10)>
Public Property Milliseconds As Integer
[C#]
[TaskAttribute(Required=False, Name="milliseconds", ExpandProperties=True, ProcessXml=True)]
[Int32Validator(MinValue=0, MaxValue=2147483647, Base=10)]
public int Milliseconds {get; set;}

See Also

SleepTask Class | NAnt.Core.Tasks Namespace


Minutes Property

NAnt SDK Documentation - v0.91

SleepTask.Minutes Property

Minutes to add to the sleep time.

[Visual Basic]
<Int32Validator(MinValue:=0, MaxValue:=2147483647, Base:=10), _ TaskAttribute(Required:=False, Name:="minutes", ExpandProperties:=True, ProcessXml:=True)>
Public Property Minutes As Integer
[C#]
[Int32Validator(MinValue=0, MaxValue=2147483647, Base=10)]
[TaskAttribute(Required=False, Name="minutes", ExpandProperties=True, ProcessXml=True)]
public int Minutes {get; set;}

See Also

SleepTask Class | NAnt.Core.Tasks Namespace


Seconds Property

NAnt SDK Documentation - v0.91

SleepTask.Seconds Property

Seconds to add to the sleep time.

[Visual Basic]
<Int32Validator(MinValue:=0, MaxValue:=2147483647, Base:=10), _ TaskAttribute(Required:=False, Name:="seconds", ExpandProperties:=True, ProcessXml:=True)>
Public Property Seconds As Integer
[C#]
[Int32Validator(MinValue=0, MaxValue=2147483647, Base=10)]
[TaskAttribute(Required=False, Name="seconds", ExpandProperties=True, ProcessXml=True)]
public int Seconds {get; set;}

See Also

SleepTask Class | NAnt.Core.Tasks Namespace


SleepTask Methods

The methods of the SleepTask class are listed below. For a complete list of SleepTask class members, see the SleepTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Verify parameters.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SleepTask Class | NAnt.Core.Tasks Namespace


SleepTask.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

SleepTask Class | NAnt.Core.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

SleepTask.Initialize Method

Verify parameters.

Overload List

Verify parameters.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

SleepTask Class | NAnt.Core.Tasks Namespace


SleepTask.Initialize Method ()

Verify parameters.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

SleepTask Class | NAnt.Core.Tasks Namespace | SleepTask.Initialize Overload List


StyleTask Class

Processes a document via XSLT.

For a list of all members of this type, see StyleTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.StyleTask

[Visual Basic]
<TaskName(Name:="style")>
Public Class StyleTask
Inherits Task
[C#]
[TaskName(Name="style")]
public class StyleTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Create a report in HTML.

            <style style="report.xsl" in="data.xml" out="report.html" />

Create a report in HTML, with a param.

            <style style="report.xsl" in="data.xml" out="report.html">
                <parameters>
                    <parameter name="reportType" namespaceuri="" value="Plain" />
                </parameters>
            </style>

Create a report in HTML, with a expanded param.

            <style style="report.xsl" in="data.xml" out="report.html">
                <parameters>
                    <parameter name="reportType" namespaceuri="" value="${report.type}" />
                </parameters>
            </style>

Create some code based on a directory of templates.

            <style style="CodeGenerator.xsl" extension="java">
                <infiles>
                    <include name="*.xml" />
                </infiles>
                <parameters>
                    <parameter name="reportType" namespaceuri="" value="Plain" if="${report.plain}" />
                </parameters>
            <style>

Create a report in HTML, with an extension object.

            <style style="report.xsl" in="data.xml" out="report.html">
                <extensionobjects>
                    <extensionobject namespaceuri="urn:Formatter" typename="XsltExtensionObjects.Formatter" assembly="XsltExtensionObjects.dll" />
                </extensionobjects>
            </style>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

StyleTask Members | NAnt.Core.Tasks Namespace


StyleTask Members

StyleTask overview

Public Instance Constructors

StyleTask Constructor Initializes a new instance of the StyleTask class.

Public Instance Properties

DestDir | Directory in which to store the results. The default is the project base directory.
Extension | Desired file extension to be used for the targets. The default is html.
ExtensionObjects | XSLT extension objects to be passed to the XSLT transformation.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
InFiles | Specifies a group of input files to which to apply the stylesheet.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OutputFile | Specifies the output name for the styled result from the SrcFile attribute.
Parameters | XSLT parameters to be passed to the XSLT transformation.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Proxy | The network proxy to use to access the Internet resource.
SrcFile | Specifies a single XML document to be styled. Should be used with the OutputFile attribute.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
XsltFile | URI or path that points to the stylesheet to use. If given as path, it can be relative to the project's basedir or absolute.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
CreateWriter |
CreateXmlReader |
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StyleTask Class | NAnt.Core.Tasks Namespace


StyleTask Constructor

Initializes a new instance of the StyleTask class.

[Visual Basic]
Public Sub New()
[C#]
public StyleTask();

See Also

StyleTask Class | NAnt.Core.Tasks Namespace


StyleTask Properties

The properties of the StyleTask class are listed below. For a complete list of StyleTask class members, see the StyleTask Members topic.

Public Instance Properties

DestDir | Directory in which to store the results. The default is the project base directory.
Extension | Desired file extension to be used for the targets. The default is html.
ExtensionObjects | XSLT extension objects to be passed to the XSLT transformation.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
InFiles | Specifies a group of input files to which to apply the stylesheet.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OutputFile | Specifies the output name for the styled result from the SrcFile attribute.
Parameters | XSLT parameters to be passed to the XSLT transformation.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Proxy | The network proxy to use to access the Internet resource.
SrcFile | Specifies a single XML document to be styled. Should be used with the OutputFile attribute.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
XsltFile | URI or path that points to the stylesheet to use. If given as path, it can be relative to the project's basedir or absolute.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

StyleTask Class | NAnt.Core.Tasks Namespace


DestDir Property

NAnt SDK Documentation - v0.91

StyleTask.DestDir Property

Directory in which to store the results. The default is the project base directory.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="destdir", ExpandProperties:=True, ProcessXml:=True)>
Public Property DestDir As DirectoryInfo
[C#]
[TaskAttribute(Required=False, Name="destdir", ExpandProperties=True, ProcessXml=True)]
public System.IO.DirectoryInfo DestDir {get; set;}

See Also

StyleTask Class | NAnt.Core.Tasks Namespace


Extension Property

NAnt SDK Documentation - v0.91

StyleTask.Extension Property

Desired file extension to be used for the targets. The default is html.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="extension", ExpandProperties:=True, ProcessXml:=True)>
Public Property Extension As String
[C#]
[TaskAttribute(Required=False, Name="extension", ExpandProperties=True, ProcessXml=True)]
public string Extension {get; set;}

See Also

StyleTask Class | NAnt.Core.Tasks Namespace


ExtensionObjects Property

NAnt SDK Documentation - v0.91

StyleTask.ExtensionObjects Property

XSLT extension objects to be passed to the XSLT transformation.

[Visual Basic]
<BuildElementCollection(ChildElementName:="extensionobject", ElementType:=null, Name:="extensionobjects", Required:=False, ProcessXml:=True)>
Public ReadOnly Property ExtensionObjects As XsltExtensionObjectCollection
[C#]
[BuildElementCollection(ChildElementName="extensionobject", ElementType=null, Name="extensionobjects", Required=False, ProcessXml=True)]
public NAnt.Core.Types.XsltExtensionObjectCollection ExtensionObjects {get;}

See Also

StyleTask Class | NAnt.Core.Tasks Namespace


InFiles Property

NAnt SDK Documentation - v0.91

StyleTask.InFiles Property

Specifies a group of input files to which to apply the stylesheet.

[Visual Basic]
<BuildElement(Name:="infiles", Required:=False, ProcessXml:=True)>
Public Property InFiles As FileSet
[C#]
[BuildElement(Name="infiles", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet InFiles {get; set;}

See Also

StyleTask Class | NAnt.Core.Tasks Namespace


OutputFile Property

NAnt SDK Documentation - v0.91

StyleTask.OutputFile Property

Specifies the output name for the styled result from the SrcFile attribute.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="out", ExpandProperties:=True, ProcessXml:=True)>
Public Property OutputFile As FileInfo
[C#]
[TaskAttribute(Required=False, Name="out", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo OutputFile {get; set;}

See Also

StyleTask Class | NAnt.Core.Tasks Namespace


Parameters Property

NAnt SDK Documentation - v0.91

StyleTask.Parameters Property

XSLT parameters to be passed to the XSLT transformation.

[Visual Basic]
<BuildElementCollection(ChildElementName:="parameter", ElementType:=null, Name:="parameters", Required:=False, ProcessXml:=True)>
Public ReadOnly Property Parameters As XsltParameterCollection
[C#]
[BuildElementCollection(ChildElementName="parameter", ElementType=null, Name="parameters", Required=False, ProcessXml=True)]
public NAnt.Core.Types.XsltParameterCollection Parameters {get;}

See Also

StyleTask Class | NAnt.Core.Tasks Namespace


Proxy Property

NAnt SDK Documentation - v0.91

StyleTask.Proxy Property

The network proxy to use to access the Internet resource.

[Visual Basic]
<BuildElement(Name:="proxy", Required:=False, ProcessXml:=True)>
Public Property Proxy As Proxy
[C#]
[BuildElement(Name="proxy", Required=False, ProcessXml=True)]
public NAnt.Core.Types.Proxy Proxy {get; set;}

See Also

StyleTask Class | NAnt.Core.Tasks Namespace


SrcFile Property

NAnt SDK Documentation - v0.91

StyleTask.SrcFile Property

Specifies a single XML document to be styled. Should be used with the OutputFile attribute.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="in", ExpandProperties:=True, ProcessXml:=True)>
Public Property SrcFile As FileInfo
[C#]
[TaskAttribute(Required=False, Name="in", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo SrcFile {get; set;}

See Also

StyleTask Class | NAnt.Core.Tasks Namespace


XsltFile Property

NAnt SDK Documentation - v0.91

StyleTask.XsltFile Property

URI or path that points to the stylesheet to use. If given as path, it can be relative to the project's basedir or absolute.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="style", ExpandProperties:=True, ProcessXml:=True)>
Public Property XsltFile As Uri
[C#]
[TaskAttribute(Required=True, Name="style", ExpandProperties=True, ProcessXml=True)]
public System.Uri XsltFile {get; set;}

See Also

StyleTask Class | NAnt.Core.Tasks Namespace


StyleTask Methods

The methods of the StyleTask class are listed below. For a complete list of StyleTask class members, see the StyleTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
CreateWriter |
CreateXmlReader |
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StyleTask Class | NAnt.Core.Tasks Namespace


StyleTask.CreateWriter Method

[Visual Basic]
Overridable Protected Function CreateWriter( _
ByVal filepath As String _
) As TextWriter
[C#]
protected virtual TextWriter CreateWriter(
string filepath
);

See Also

StyleTask Class | NAnt.Core.Tasks Namespace


StyleTask.CreateXmlReader Method

[Visual Basic]
Overridable Protected Function CreateXmlReader( _
ByVal uri As Uri _
) As XmlReader
[C#]
protected virtual XmlReader CreateXmlReader(
Uri uri
);

See Also

StyleTask Class | NAnt.Core.Tasks Namespace


StyleTask.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

StyleTask Class | NAnt.Core.Tasks Namespace


SysInfoTask Class

Sets properties with system information.

For a list of all members of this type, see SysInfoTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.SysInfoTask

[Visual Basic]
<TaskName(Name:="sysinfo")>
Public Class SysInfoTask
Inherits Task
[C#]
[TaskName(Name="sysinfo")]
public class SysInfoTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Sets a number of properties with information about the system environment. The intent of this task is for nightly build logs to have a record of system information so that the build was performed on.

Property | Value
<Prefix>.clr.version | Common Language Runtime version number.
<Prefix>.env.* | Environment variables (e.g., <Prefix>.env.PATH).
<Prefix>.os.platform | Operating system platform ID.
<Prefix>.os.version | Operating system version.
<Prefix>.os | Operating system version string.
<Prefix>.os.folder.applicationdata | The directory that serves as a common repository for application-specific data for the current roaming user.
<Prefix>.os.folder.commonapplicationdata | The directory that serves as a common repository for application-specific data that is used by all users.
<Prefix>.os.folder.commonprogramfiles | The directory for components that are shared across applications.
<Prefix>.os.folder.desktopdirectory | The directory used to physically store file objects on the desktop. Do not confuse this directory with the desktop folder itself, which is a virtual folder.
<Prefix>.os.folder.programfiles | The Program Files directory.
<Prefix>.os.folder.system | The System directory.
<Prefix>.os.folder.temp | The temporary directory.

When the name of an environment variable is not a valid property name, the task will fail. In that case, set FailOnError to true to allow that environment variable to be skipped.

Note we advise you to use the following functions instead:
Function | Description
GetOperatingSystem | Gets a OperatingSystem object that identifies this operating system.
GetFolderPath | Gets the path to a system special folder.
GetVariable | Returns the value of a environment variable.
GetTempPath | Gets the path to the temporary directory.
GetVersion | Gets the Common Language Runtime version.

Example

Register the properties with the default property prefix.

<sysinfo />

Register the properties without a prefix.

<sysinfo prefix="" />

Register properties and display a summary.

<sysinfo verbose="true" />

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

SysInfoTask Members | NAnt.Core.Tasks Namespace


SysInfoTask Members

SysInfoTask overview

Public Instance Constructors

SysInfoTask Constructor Initializes a new instance of the SysInfoTask class.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Prefix | The string to prefix the property names with. The default is "sys.".
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SysInfoTask Class | NAnt.Core.Tasks Namespace


SysInfoTask Constructor

Initializes a new instance of the SysInfoTask class.

[Visual Basic]
Public Sub New()
[C#]
public SysInfoTask();

See Also

SysInfoTask Class | NAnt.Core.Tasks Namespace


SysInfoTask Properties

The properties of the SysInfoTask class are listed below. For a complete list of SysInfoTask class members, see the SysInfoTask Members topic.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Prefix | The string to prefix the property names with. The default is "sys.".
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

SysInfoTask Class | NAnt.Core.Tasks Namespace


Prefix Property

NAnt SDK Documentation - v0.91

SysInfoTask.Prefix Property

The string to prefix the property names with. The default is "sys.".

[Visual Basic]
<TaskAttribute(Required:=False, Name:="prefix", ExpandProperties:=True, ProcessXml:=True)>
Public Property Prefix As String
[C#]
[TaskAttribute(Required=False, Name="prefix", ExpandProperties=True, ProcessXml=True)]
public string Prefix {get; set;}

See Also

SysInfoTask Class | NAnt.Core.Tasks Namespace


SysInfoTask Methods

The methods of the SysInfoTask class are listed below. For a complete list of SysInfoTask class members, see the SysInfoTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SysInfoTask Class | NAnt.Core.Tasks Namespace


SysInfoTask.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

SysInfoTask Class | NAnt.Core.Tasks Namespace


TouchTask Class

Touches a file or set of files -- corresponds to the Unix touch command.

For a list of all members of this type, see TouchTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.TouchTask

[Visual Basic]
<TaskName(Name:="touch")>
Public Class TouchTask
Inherits Task
[C#]
[TaskName(Name="touch")]
public class TouchTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

If the file specified does not exist, the task will create it.

Example

Touch the Main.cs file. The current time is used.

            <touch file="Main.cs" />

Touch all executable files in the project base directory and its subdirectories.

            <touch>
                <fileset>
                    <include name="**/*.exe" />
                    <include name="**/*.dll" />
                </fileset>
            </touch>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

TouchTask Members | NAnt.Core.Tasks Namespace


TouchTask Members

TouchTask overview

Public Instance Constructors

TouchTask Constructor Initializes a new instance of the TouchTask class.

Public Instance Properties

Datetime | Specifies the new modification time of the file in the format MM/DD/YYYY HH:MM:SS.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
File | The file to touch.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Millis | Specifies the new modification time of the file(s) in milliseconds since midnight Jan 1 1970.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TouchFileSet | Used to select files that should be touched.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Ensures the supplied attributes are valid.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TouchTask Class | NAnt.Core.Tasks Namespace


TouchTask Constructor

Initializes a new instance of the TouchTask class.

[Visual Basic]
Public Sub New()
[C#]
public TouchTask();

See Also

TouchTask Class | NAnt.Core.Tasks Namespace


TouchTask Properties

The properties of the TouchTask class are listed below. For a complete list of TouchTask class members, see the TouchTask Members topic.

Public Instance Properties

Datetime | Specifies the new modification time of the file in the format MM/DD/YYYY HH:MM:SS.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
File | The file to touch.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Millis | Specifies the new modification time of the file(s) in milliseconds since midnight Jan 1 1970.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TouchFileSet | Used to select files that should be touched.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

TouchTask Class | NAnt.Core.Tasks Namespace


Datetime Property

NAnt SDK Documentation - v0.91

TouchTask.Datetime Property

Specifies the new modification time of the file in the format MM/DD/YYYY HH:MM:SS.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="datetime", ExpandProperties:=True, ProcessXml:=True), _ DateTimeValidator>
Public Property Datetime As Date
[C#]
[TaskAttribute(Required=False, Name="datetime", ExpandProperties=True, ProcessXml=True)]
[DateTimeValidator]
public System.DateTime Datetime {get; set;}

See Also

TouchTask Class | NAnt.Core.Tasks Namespace


File Property

NAnt SDK Documentation - v0.91

TouchTask.File Property

The file to touch.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="file", ExpandProperties:=True, ProcessXml:=True)>
Public Property File As FileInfo
[C#]
[TaskAttribute(Required=False, Name="file", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo File {get; set;}

See Also

TouchTask Class | NAnt.Core.Tasks Namespace


Millis Property

NAnt SDK Documentation - v0.91

TouchTask.Millis Property

Specifies the new modification time of the file(s) in milliseconds since midnight Jan 1 1970.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="millis", ExpandProperties:=True, ProcessXml:=True)>
Public Property Millis As Long
[C#]
[TaskAttribute(Required=False, Name="millis", ExpandProperties=True, ProcessXml=True)]
public long Millis {get; set;}

See Also

TouchTask Class | NAnt.Core.Tasks Namespace


TouchFileSet Property

NAnt SDK Documentation - v0.91

TouchTask.TouchFileSet Property

Used to select files that should be touched.

[Visual Basic]
<BuildElement(Name:="fileset", Required:=False, ProcessXml:=True)>
Public Property TouchFileSet As FileSet
[C#]
[BuildElement(Name="fileset", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet TouchFileSet {get; set;}

See Also

TouchTask Class | NAnt.Core.Tasks Namespace


TouchTask Methods

The methods of the TouchTask class are listed below. For a complete list of TouchTask class members, see the TouchTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Ensures the supplied attributes are valid.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TouchTask Class | NAnt.Core.Tasks Namespace


TouchTask.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

TouchTask Class | NAnt.Core.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

TouchTask.Initialize Method

Ensures the supplied attributes are valid.

Overload List

Ensures the supplied attributes are valid.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

TouchTask Class | NAnt.Core.Tasks Namespace


TouchTask.Initialize Method ()

Ensures the supplied attributes are valid.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

TouchTask Class | NAnt.Core.Tasks Namespace | TouchTask.Initialize Overload List


TStampTask Class

Sets properties with the current date and time.

For a list of all members of this type, see TStampTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.TStampTask

[Visual Basic]
<TaskName(Name:="tstamp")>
Public Class TStampTask
Inherits Task
[C#]
[TaskName(Name="tstamp")]
public class TStampTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

By default the TStampTask displays the current date and time and sets the following properties:

  • tstamp.date to yyyyMMdd
  • tstamp.time to HHmm
  • tstamp.now using the default DateTime.ToString() method

To set an additional property with a custom date/time use the Property and Pattern attributes. To set a number of additional properties with the exact same date and time use the Formatters nested element (see example).

The date and time string displayed by the TStampTask uses the computer's default long date and time string format. You might consider setting these to the ISO 8601 standard for date and time notation.

Example

Set the build.date property.

<tstamp property="build.date" pattern="yyyyMMdd" verbose="true" />

Set a number of properties for Ant like compatibility.

<tstamp verbose="true">
    <formatter property="TODAY" pattern="dd MMM yyyy"/>
    <formatter property="DSTAMP" pattern="yyyyMMdd" unless="${date.not.needed}" />
    <formatter property="TSTAMP" pattern="HHmm" if="${need.hours}" />
</tstamp>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

TStampTask Members | NAnt.Core.Tasks Namespace


TStampTask Members

TStampTask overview

Public Instance Constructors

TStampTask Constructor Initializes a new instance of the TStampTask class.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
Formatters |
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Pattern | The date/time pattern to be used.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Property | The property to receive the date/time string in the given pattern.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TStampTask Class | NAnt.Core.Tasks Namespace


TStampTask Constructor

Initializes a new instance of the TStampTask class.

[Visual Basic]
Public Sub New()
[C#]
public TStampTask();

See Also

TStampTask Class | NAnt.Core.Tasks Namespace


TStampTask Properties

The properties of the TStampTask class are listed below. For a complete list of TStampTask class members, see the TStampTask Members topic.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
Formatters |
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Pattern | The date/time pattern to be used.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Property | The property to receive the date/time string in the given pattern.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

TStampTask Class | NAnt.Core.Tasks Namespace


Formatters Property

NAnt SDK Documentation - v0.91

TStampTask.Formatters Property

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="formatter", Required:=False, ProcessXml:=True)>
Public ReadOnly Property Formatters As FormatterCollection
[C#]
[BuildElementArray(ElementType=null, Name="formatter", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FormatterCollection Formatters {get;}

See Also

TStampTask Class | NAnt.Core.Tasks Namespace


Pattern Property

NAnt SDK Documentation - v0.91

TStampTask.Pattern Property

The date/time pattern to be used.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="pattern", ExpandProperties:=True, ProcessXml:=True)>
Public Property Pattern As String
[C#]
[TaskAttribute(Required=False, Name="pattern", ExpandProperties=True, ProcessXml=True)]
public string Pattern {get; set;}

Remarks

The following table lists the standard format characters for each standard pattern. The format characters are case-sensitive; for example, 'g' and 'G' represent slightly different patterns.

Format Character | Description Example Format Pattern (en-US)
d | MM/dd/yyyy
D | dddd, dd MMMM yyyy
f | dddd, dd MMMM yyyy HH:mm
F | dddd, dd MMMM yyyy HH:mm:ss
g | MM/dd/yyyy HH:mm
G | MM/dd/yyyy HH:mm:ss
m, M | MMMM dd
r, R | ddd, dd MMM yyyy HH':'mm':'ss 'GMT'
s | yyyy'-'MM'-'dd'T'HH':'mm':'ss
t | HH:mm
T | HH:mm:ss
u | yyyy'-'MM'-'dd HH':'mm':'ss'Z'
U | dddd, dd MMMM yyyy HH:mm:ss
y, Y | yyyy MMMM

The following table lists the patterns that can be combined to construct custom patterns. The patterns are case-sensitive; for example, "MM" is recognized, but "mm" is not. If the custom pattern contains white-space characters or characters enclosed in single quotation marks, the output string will also contain those characters. Characters not defined as part of a format pattern or as format characters are reproduced literally.

Format | Pattern Description
d | The day of the month. Single-digit days will not have a leading zero.
dd | The day of the month. Single-digit days will have a leading zero.
ddd | The abbreviated name of the day of the week.
dddd | The full name of the day of the week.
M | The numeric month. Single-digit months will not have a leading zero.
MM | The numeric month. Single-digit months will have a leading zero.
MMM | The abbreviated name of the month.
MMMM | The full name of the month.
y | The year without the century. If the year without the century is less than 10, the year is displayed with no leading zero.
yy | The year without the century. If the year without the century is less than 10, the year is displayed with a leading zero.
yyyy | The year in four digits, including the century.
gg | The period or era. This pattern is ignored if the date to be formatted does not have an associated period or era string.
h | The hour in a 12-hour clock. Single-digit hours will not have a leading zero.
hh | The hour in a 12-hour clock. Single-digit hours will have a leading zero.
H | The hour in a 24-hour clock. Single-digit hours will not have a leading zero.
HH | The hour in a 24-hour clock. Single-digit hours will have a leading zero.
m | The minute. Single-digit minutes will not have a leading zero.
mm | The minute. Single-digit minutes will have a leading zero.
s | The second. Single-digit seconds will not have a leading zero.
ss | The second. Single-digit seconds will have a leading zero.
f | The fraction of a second in single-digit precision. The remaining digits are truncated.
ff | The fraction of a second in double-digit precision. The remaining digits are truncated.
fff | The fraction of a second in three-digit precision. The remaining digits are truncated.
ffff | The fraction of a second in four-digit precision. The remaining digits are truncated.
fffff | The fraction of a second in five-digit precision. The remaining digits are truncated.
ffffff | The fraction of a second in six-digit precision. The remaining digits are truncated.
fffffff | The fraction of a second in seven-digit precision. The remaining digits are truncated.
t | The first character in the AM/PM designator.
tt | The AM/PM designator.
z | The time zone offset ("+" or "-" followed by the hour only). Single-digit hours will not have a leading zero. For example, Pacific Standard Time is "-8".
zz | The time zone offset ("+" or "-" followed by the hour only). Single-digit hours will have a leading zero. For example, Pacific Standard Time is "-08".
zzz | The full time zone offset ("+" or "-" followed by the hour and minutes). Single-digit hours and minutes will have leading zeros. For example, Pacific Standard Time is "-08:00".
: | The default time separator.
/ | The default date separator.
\ c | Pattern Where c is any character. Displays the character literally. To display the backslash character, use "\\".

See Also

TStampTask Class | NAnt.Core.Tasks Namespace


Property Property

NAnt SDK Documentation - v0.91

TStampTask.Property Property

The property to receive the date/time string in the given pattern.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="property", ExpandProperties:=True, ProcessXml:=True)>
Public Property Property As String
[C#]
[TaskAttribute(Required=False, Name="property", ExpandProperties=True, ProcessXml=True)]
public string Property {get; set;}

See Also

TStampTask Class | NAnt.Core.Tasks Namespace


TStampTask Methods

The methods of the TStampTask class are listed below. For a complete list of TStampTask class members, see the TStampTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TStampTask Class | NAnt.Core.Tasks Namespace


TStampTask.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

TStampTask Class | NAnt.Core.Tasks Namespace


UpToDateTask Class

Check modification dates on groups of files.

For a list of all members of this type, see UpToDateTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.UpToDateTask

[Visual Basic]
<TaskName(Name:="uptodate")>
Public Class UpToDateTask
Inherits Task
[C#]
[TaskName(Name="uptodate")]
public class UpToDateTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

If all TargetFiles are same or newer than all SourceFiles, the specified property is set to true, otherwise it is set to false.

Example

Check file dates. If myfile.dll is same or newer than myfile.cs, then set myfile.dll.uptodate property to either true or false.

<uptodate property="myfile.dll.uptodate">
    <sourcefiles>
        <include name="myfile.cs" />
    </sourcefiles>
    <targetfiles>
        <include name="myfile.dll" />
    </targetfiles>
</uptodate>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

UpToDateTask Members | NAnt.Core.Tasks Namespace


UpToDateTask Members

UpToDateTask overview

Public Instance Constructors

UpToDateTask Constructor Initializes a new instance of the UpToDateTask class.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PropertyName | Property that will be set to true or false depending on the result of the date check.
SourceFiles | The FileSet that contains list of source files.
TargetFiles | The FileSet that contains list of target files.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpToDateTask Class | NAnt.Core.Tasks Namespace


UpToDateTask Constructor

Initializes a new instance of the UpToDateTask class.

[Visual Basic]
Public Sub New()
[C#]
public UpToDateTask();

See Also

UpToDateTask Class | NAnt.Core.Tasks Namespace


UpToDateTask Properties

The properties of the UpToDateTask class are listed below. For a complete list of UpToDateTask class members, see the UpToDateTask Members topic.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PropertyName | Property that will be set to true or false depending on the result of the date check.
SourceFiles | The FileSet that contains list of source files.
TargetFiles | The FileSet that contains list of target files.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

UpToDateTask Class | NAnt.Core.Tasks Namespace


PropertyName Property

NAnt SDK Documentation - v0.91

UpToDateTask.PropertyName Property

Property that will be set to true or false depending on the result of the date check.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="property", ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property PropertyName As String
[C#]
[TaskAttribute(Required=True, Name="property", ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string PropertyName {get; set;}

See Also

UpToDateTask Class | NAnt.Core.Tasks Namespace


SourceFiles Property

NAnt SDK Documentation - v0.91

UpToDateTask.SourceFiles Property

The FileSet that contains list of source files.

[Visual Basic]
<BuildElement(Name:="sourcefiles", Required:=False, ProcessXml:=True)>
Public Property SourceFiles As FileSet
[C#]
[BuildElement(Name="sourcefiles", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet SourceFiles {get; set;}

See Also

UpToDateTask Class | NAnt.Core.Tasks Namespace


TargetFiles Property

NAnt SDK Documentation - v0.91

UpToDateTask.TargetFiles Property

The FileSet that contains list of target files.

[Visual Basic]
<BuildElement(Name:="targetfiles", Required:=False, ProcessXml:=True)>
Public Property TargetFiles As FileSet
[C#]
[BuildElement(Name="targetfiles", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet TargetFiles {get; set;}

See Also

UpToDateTask Class | NAnt.Core.Tasks Namespace


UpToDateTask Methods

The methods of the UpToDateTask class are listed below. For a complete list of UpToDateTask class members, see the UpToDateTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpToDateTask Class | NAnt.Core.Tasks Namespace


UpToDateTask.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

UpToDateTask Class | NAnt.Core.Tasks Namespace


XmlPeekTask Class

Extracts text from an XML file at the location specified by an XPath expression.

For a list of all members of this type, see XmlPeekTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.XmlPeekTask

[Visual Basic]
<TaskName(Name:="xmlpeek")>
Public Class XmlPeekTask
Inherits Task
[C#]
[TaskName(Name="xmlpeek")]
public class XmlPeekTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

If the XPath expression specifies multiple nodes the node index is used to determine which of the nodes' text is returned.

Example

The example provided assumes that the following XML file (App.config) exists in the current build directory.

            <?xml version="1.0" encoding="utf-8" ?>
            <configuration xmlns="http://www.gordic.cz/shared/project-config/v_1.0.0.0">
                <appSettings>
                    <add key="server" value="testhost.somecompany.com" />
                </appSettings>
            </configuration>

The example will read the server value from the above configuration file.

            <xmlpeek
                file="App.config"
                xpath="/x:configuration/x:appSettings/x:add[@key = 'server']/@value"
                property="configuration.server">
                <namespaces>
                    <namespace prefix="x" uri="http://www.gordic.cz/shared/project-config/v_1.0.0.0" />
                </namespaces>
            </xmlpeek>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

XmlPeekTask Members | NAnt.Core.Tasks Namespace


XmlPeekTask Members

XmlPeekTask overview

Public Instance Constructors

XmlPeekTask Constructor Initializes a new instance of the XmlPeekTask class.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Namespaces | Namespace definitions to resolve prefixes in the XPath expression.
NodeIndex | The index of the node that gets its text returned when the query returns multiple nodes.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Property | The property that receives the text representation of the XML inside the node returned from the XPath expression.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
XmlFile | The name of the file that contains the XML document that is going to be peeked at.
XPath | The XPath expression used to select which node to read.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Executes the XML peek task.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlPeekTask Class | NAnt.Core.Tasks Namespace


XmlPeekTask Constructor

Initializes a new instance of the XmlPeekTask class.

[Visual Basic]
Public Sub New()
[C#]
public XmlPeekTask();

See Also

XmlPeekTask Class | NAnt.Core.Tasks Namespace


XmlPeekTask Properties

The properties of the XmlPeekTask class are listed below. For a complete list of XmlPeekTask class members, see the XmlPeekTask Members topic.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Namespaces | Namespace definitions to resolve prefixes in the XPath expression.
NodeIndex | The index of the node that gets its text returned when the query returns multiple nodes.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Property | The property that receives the text representation of the XML inside the node returned from the XPath expression.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
XmlFile | The name of the file that contains the XML document that is going to be peeked at.
XPath | The XPath expression used to select which node to read.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

XmlPeekTask Class | NAnt.Core.Tasks Namespace


Namespaces Property

NAnt SDK Documentation - v0.91

XmlPeekTask.Namespaces Property

Namespace definitions to resolve prefixes in the XPath expression.

[Visual Basic]
<BuildElementCollection(ChildElementName:="namespace", ElementType:=null, Name:="namespaces", Required:=False, ProcessXml:=True)>
Public Property Namespaces As XmlNamespaceCollection
[C#]
[BuildElementCollection(ChildElementName="namespace", ElementType=null, Name="namespaces", Required=False, ProcessXml=True)]
public NAnt.Core.Types.XmlNamespaceCollection Namespaces {get; set;}

See Also

XmlPeekTask Class | NAnt.Core.Tasks Namespace


NodeIndex Property

NAnt SDK Documentation - v0.91

XmlPeekTask.NodeIndex Property

The index of the node that gets its text returned when the query returns multiple nodes.

[Visual Basic]
<Int32Validator(MinValue:=0, MaxValue:=2147483647, Base:=10), _ TaskAttribute(Required:=False, Name:="nodeindex", ExpandProperties:=True, ProcessXml:=True)>
Public Property NodeIndex As Integer
[C#]
[Int32Validator(MinValue=0, MaxValue=2147483647, Base=10)]
[TaskAttribute(Required=False, Name="nodeindex", ExpandProperties=True, ProcessXml=True)]
public int NodeIndex {get; set;}

See Also

XmlPeekTask Class | NAnt.Core.Tasks Namespace


Property Property

NAnt SDK Documentation - v0.91

XmlPeekTask.Property Property

The property that receives the text representation of the XML inside the node returned from the XPath expression.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Required:=True, Name:="property", ExpandProperties:=True, ProcessXml:=True)>
Public Property Property As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Required=True, Name="property", ExpandProperties=True, ProcessXml=True)]
public string Property {get; set;}

See Also

XmlPeekTask Class | NAnt.Core.Tasks Namespace


XmlFile Property

NAnt SDK Documentation - v0.91

XmlPeekTask.XmlFile Property

The name of the file that contains the XML document that is going to be peeked at.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="file", ExpandProperties:=True, ProcessXml:=True)>
Public Property XmlFile As FileInfo
[C#]
[TaskAttribute(Required=True, Name="file", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo XmlFile {get; set;}

See Also

XmlPeekTask Class | NAnt.Core.Tasks Namespace


XPath Property

NAnt SDK Documentation - v0.91

XmlPeekTask.XPath Property

The XPath expression used to select which node to read.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="xpath", ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property XPath As String
[C#]
[TaskAttribute(Required=True, Name="xpath", ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string XPath {get; set;}

See Also

XmlPeekTask Class | NAnt.Core.Tasks Namespace


XmlPeekTask Methods

The methods of the XmlPeekTask class are listed below. For a complete list of XmlPeekTask class members, see the XmlPeekTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Executes the XML peek task.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlPeekTask Class | NAnt.Core.Tasks Namespace


XmlPeekTask.ExecuteTask Method

Executes the XML peek task.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

XmlPeekTask Class | NAnt.Core.Tasks Namespace


XmlPokeTask Class

Replaces text in an XML file at the location specified by an XPath expression.

For a list of all members of this type, see XmlPokeTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.XmlPokeTask

[Visual Basic]
<TaskName(Name:="xmlpoke")>
Public Class XmlPokeTask
Inherits Task
[C#]
[TaskName(Name="xmlpoke")]
public class XmlPokeTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The location specified by the XPath expression must exist, it will not create the parent elements for you. However, provided you have a root element you could use a series of the tasks to build the XML file up if necessary.

Example

Change the server setting in the configuration from testhost.somecompany.com to productionhost.somecompany.com.

XML file:

            <?xml version="1.0" encoding="utf-8" ?>
            <configuration>
                <appSettings>
                    <add key="server" value="testhost.somecompany.com" />
                </appSettings>
            </configuration>

Build fragment:

            <xmlpoke
                file="App.config"
                xpath="/configuration/appSettings/add[@key = 'server']/@value"
                value="productionhost.somecompany.com" />

Modify the noNamespaceSchemaLocation in an XML file.

XML file:

            <?xml version="1.0" encoding="utf-8" ?>
            <Commands xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="Path Value">
            </Commands>

Build fragment:

            <xmlpoke file="test.xml" xpath="/Commands/@xsi:noNamespaceSchemaLocation" value="d:\Commands.xsd">
                <namespaces>
                    <namespace prefix="xsi" uri="http://www.w3.org/2001/XMLSchema-instance" />
                </namespaces>
            </xmlpoke>

Requirements

Namespace: NAnt.Core.Tasks

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

XmlPokeTask Members | NAnt.Core.Tasks Namespace


XmlPokeTask Members

XmlPokeTask overview

Public Instance Constructors

XmlPokeTask Constructor Initializes a new instance of the XmlPokeTask class.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Namespaces | Namespace definitions to resolve prefixes in the XPath expression.
Parent (inherited from Element) | Gets or sets the parent of the element.
PreserveWhitespace | Namespace definitions to resolve prefixes in the XPath expression.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Value | The value that replaces the contents of the selected nodes.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
XmlFile | The name of the file that contains the XML document that is going to be poked.
XPath | The XPath expression used to select which nodes are to be modified.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Executes the XML poke task.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlPokeTask Class | NAnt.Core.Tasks Namespace


XmlPokeTask Constructor

Initializes a new instance of the XmlPokeTask class.

[Visual Basic]
Public Sub New()
[C#]
public XmlPokeTask();

See Also

XmlPokeTask Class | NAnt.Core.Tasks Namespace


XmlPokeTask Properties

The properties of the XmlPokeTask class are listed below. For a complete list of XmlPokeTask class members, see the XmlPokeTask Members topic.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Namespaces | Namespace definitions to resolve prefixes in the XPath expression.
Parent (inherited from Element) | Gets or sets the parent of the element.
PreserveWhitespace | Namespace definitions to resolve prefixes in the XPath expression.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Value | The value that replaces the contents of the selected nodes.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
XmlFile | The name of the file that contains the XML document that is going to be poked.
XPath | The XPath expression used to select which nodes are to be modified.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

XmlPokeTask Class | NAnt.Core.Tasks Namespace


Namespaces Property

NAnt SDK Documentation - v0.91

XmlPokeTask.Namespaces Property

Namespace definitions to resolve prefixes in the XPath expression.

[Visual Basic]
<BuildElementCollection(ChildElementName:="namespace", ElementType:=null, Name:="namespaces", Required:=False, ProcessXml:=True)>
Public Property Namespaces As XmlNamespaceCollection
[C#]
[BuildElementCollection(ChildElementName="namespace", ElementType=null, Name="namespaces", Required=False, ProcessXml=True)]
public NAnt.Core.Types.XmlNamespaceCollection Namespaces {get; set;}

See Also

XmlPokeTask Class | NAnt.Core.Tasks Namespace


PreserveWhitespace Property

NAnt SDK Documentation - v0.91

XmlPokeTask.PreserveWhitespace Property

Namespace definitions to resolve prefixes in the XPath expression.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Required:=False, Name:="preserveWhitespace", ExpandProperties:=True, ProcessXml:=True)>
Public Property PreserveWhitespace As Boolean
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Required=False, Name="preserveWhitespace", ExpandProperties=True, ProcessXml=True)]
public bool PreserveWhitespace {get; set;}

See Also

XmlPokeTask Class | NAnt.Core.Tasks Namespace


Value Property

NAnt SDK Documentation - v0.91

XmlPokeTask.Value Property

The value that replaces the contents of the selected nodes.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="value", ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=True, Expression:="null", ExpressionErrorMessage:="null")>
Public Property Value As String
[C#]
[TaskAttribute(Required=True, Name="value", ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=True, Expression="null", ExpressionErrorMessage="null")]
public string Value {get; set;}

See Also

XmlPokeTask Class | NAnt.Core.Tasks Namespace


XmlFile Property

NAnt SDK Documentation - v0.91

XmlPokeTask.XmlFile Property

The name of the file that contains the XML document that is going to be poked.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="file", ExpandProperties:=True, ProcessXml:=True)>
Public Property XmlFile As FileInfo
[C#]
[TaskAttribute(Required=True, Name="file", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo XmlFile {get; set;}

See Also

XmlPokeTask Class | NAnt.Core.Tasks Namespace


XPath Property

NAnt SDK Documentation - v0.91

XmlPokeTask.XPath Property

The XPath expression used to select which nodes are to be modified.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Required:=True, Name:="xpath", ExpandProperties:=True, ProcessXml:=True)>
Public Property XPath As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Required=True, Name="xpath", ExpandProperties=True, ProcessXml=True)]
public string XPath {get; set;}

See Also

XmlPokeTask Class | NAnt.Core.Tasks Namespace


XmlPokeTask Methods

The methods of the XmlPokeTask class are listed below. For a complete list of XmlPokeTask class members, see the XmlPokeTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Executes the XML poke task.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlPokeTask Class | NAnt.Core.Tasks Namespace


XmlPokeTask.ExecuteTask Method

Executes the XML poke task.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

XmlPokeTask Class | NAnt.Core.Tasks Namespace


NAnt.Core.Types

NAnt SDK Documentation - v0.91

NAnt.Core.Types Namespace

Namespace hierarchy

Classes

Class | Description
Argument | Represents a command-line argument.
ArgumentCollection | Contains a collection of Argument elements.
ArgumentEnumerator | Enumerates the Argument elements of a ArgumentCollection.
Credential | Provides credentials for password-based authentication schemes.
DirSet | A specialized FileSet used for specifying a set of directories.
EnvironmentSet | A set of environment variables.
EnvironmentVariable | Represents an environment variable.
EnvironmentVariableCollection | Contains a collection of EnvironmentVariable elements.
EnvironmentVariableEnumerator | Enumerates the EnvironmentVariable elements of a EnvironmentVariableCollection.
FileSet | Filesets are groups of files. These files can be found in a directory tree starting in a base directory and are matched by patterns taken from a number of patterns. Filesets can appear inside tasks that support this feature or at the project level, i.e., as children of <project>.
FileSet.Exclude |
FileSet.ExcludesFile |
FileSet.Include |
FileSet.IncludesFile |
Formatter |
FormatterCollection | Contains a collection of Formatter elements.
FormatterEnumerator | Enumerates the Formatter elements of a FormatterCollection.
ManagedExecutionConverter | Specialized EnumConverter that also supports case-insensitive conversion of "true" to Auto and "false" to Default.
Option | Represents an option.
OptionCollection | Contains a collection of Option elements.
OptionEnumerator | Enumerates the Option elements of a OptionCollection.
PathElement | Represents a nested path element.
PathSet | Paths are groups of files and/or directories that need to be passed as a single unit. The order in which parts of the path are specified in the build file is retained, and duplicate parts are automatically suppressed.
Pattern |
PatternCollection | Contains a collection of Pattern elements.
PatternEnumerator | Enumerates the Pattern elements of a PatternCollection.
PatternSet | A set of patterns, mostly used to include or exclude certain files.
Proxy | Contains HTTP proxy settings used to process requests to Internet resources.
RawXml | Represents an element of which the XML is processed by its parent task or type.
Token | ReplaceTokens filter token.
XmlNamespace | Represents an XML namespace.
XmlNamespaceCollection | Contains a collection of XmlNamespace elements.
XmlNamespaceEnumerator | Enumerates the XmlNamespace elements of a XmlNamespaceCollection.
XsltExtensionObject | Represents an XSLT extension object. The object should have a default parameterless constructor and the return value should be one of the four basic XPath data types of number, string, Boolean or node set.
XsltExtensionObjectCollection | Contains a collection of XsltExtensionObject elements.
XsltExtensionObjectEnumerator | Enumerates the XsltExtensionObject elements of a XsltExtensionObjectCollection.
XsltParameter | Represents an XSLT parameter.
XsltParameterCollection | Contains a collection of XsltParameter elements.
XsltParameterEnumerator | Enumerates the XsltParameter elements of a XsltParameterCollection.

Enumerations

Enumeration | Description
ManagedExecution | Specifies the execution mode for managed applications.


Argument Class

Represents a command-line argument.

For a list of all members of this type, see Argument Members.

System.Object
NAnt.Core.Element
NAnt.Core.Types.Argument

[Visual Basic]
<Serializable, _ Serializable, _ ElementName(Name:="arg")>
Public Class Argument
Inherits Element
[C#]
[Serializable]
[Serializable]
[ElementName(Name="arg")]
public class Argument : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

When passed to an external application, the argument will be quoted when appropriate. This does not apply to the Line parameter, which is always passed as is.

Example

A single command-line argument containing a space character.

<arg value="-l -a" />

Two separate command-line arguments.

<arg line="-l -a" />

A single command-line argument with the value \dir;\dir2;\dir3 on DOS-based systems and /dir:/dir2:/dir3 on Unix-like systems.

<arg path="/dir;/dir2:\dir3" />

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

Argument Members | NAnt.Core.Types Namespace


Argument Members

Argument overview

Public Instance Constructors

Argument Overloaded. Initializes a new instance of the Argument class.

Public Instance Properties

Directory | The value for a directory-based command-line argument; will be replaced with the absolute path of the directory.
File | The name of a file as a single command-line argument; will be replaced with the absolute filename of the file.
IfDefined | Indicates if the argument should be passed to the external program. If true then the argument will be passed; otherwise, skipped. The default is true.
Line | List of command-line arguments; will be passed to the executable as is.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Path | The value for a PATH-like command-line argument; you can use : or ; as path separators and NAnt will convert it to the platform's local conventions, while resolving references to environment variables.
PathSet | Sets a single command-line argument and treats it like a PATH - ensures the right separator for the local platform is used.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Indicates if the argument should not be passed to the external program. If false then the argument will be passed; otherwise, skipped. The default is false.
Value | A single command-line argument; can contain space characters.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString | Returns the argument as a String.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Argument Class | NAnt.Core.Types Namespace


Argument Constructor

Initializes a new instance of the Argument class.

Overload List

Initializes a new instance of the Argument class.

public Argument();

Initializes a new instance of the Argument class with the given path.

public Argument(PathSet);

Initializes a new instance of the Argument class with the given file.

public Argument(FileInfo);

Initializes a new instance of the Argument class with the specified command-line argument.

public Argument(string);

See Also

Argument Class | NAnt.Core.Types Namespace


Argument Constructor ()

Initializes a new instance of the Argument class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Argument();

See Also

Argument Class | NAnt.Core.Types Namespace | Argument Constructor Overload List


Argument Constructor (String)

Initializes a new instance of the Argument class with the specified command-line argument.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As String _
)
[C#]
public Argument(
string value
);

See Also

Argument Class | NAnt.Core.Types Namespace | Argument Constructor Overload List


Argument Constructor (FileInfo)

Initializes a new instance of the Argument class with the given file.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As FileInfo _
)
[C#]
public Argument(
FileInfo value
);

See Also

Argument Class | NAnt.Core.Types Namespace | Argument Constructor Overload List


Argument Constructor (PathSet)

Initializes a new instance of the Argument class with the given path.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As PathSet _
)
[C#]
public Argument(
PathSet value
);

See Also

Argument Class | NAnt.Core.Types Namespace | Argument Constructor Overload List


Argument Properties

The properties of the Argument class are listed below. For a complete list of Argument class members, see the Argument Members topic.

Public Instance Properties

Directory | The value for a directory-based command-line argument; will be replaced with the absolute path of the directory.
File | The name of a file as a single command-line argument; will be replaced with the absolute filename of the file.
IfDefined | Indicates if the argument should be passed to the external program. If true then the argument will be passed; otherwise, skipped. The default is true.
Line | List of command-line arguments; will be passed to the executable as is.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Path | The value for a PATH-like command-line argument; you can use : or ; as path separators and NAnt will convert it to the platform's local conventions, while resolving references to environment variables.
PathSet | Sets a single command-line argument and treats it like a PATH - ensures the right separator for the local platform is used.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Indicates if the argument should not be passed to the external program. If false then the argument will be passed; otherwise, skipped. The default is false.
Value | A single command-line argument; can contain space characters.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

Argument Class | NAnt.Core.Types Namespace


Directory Property

NAnt SDK Documentation - v0.91

Argument.Directory Property

The value for a directory-based command-line argument; will be replaced with the absolute path of the directory.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="dir", ExpandProperties:=True, ProcessXml:=True)>
Public Property Directory As DirectoryInfo
[C#]
[TaskAttribute(Required=False, Name="dir", ExpandProperties=True, ProcessXml=True)]
public System.IO.DirectoryInfo Directory {get; set;}

See Also

Argument Class | NAnt.Core.Types Namespace


File Property

NAnt SDK Documentation - v0.91

Argument.File Property

The name of a file as a single command-line argument; will be replaced with the absolute filename of the file.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="file", ExpandProperties:=True, ProcessXml:=True)>
Public Property File As FileInfo
[C#]
[TaskAttribute(Required=False, Name="file", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo File {get; set;}

See Also

Argument Class | NAnt.Core.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

Argument.IfDefined Property

Indicates if the argument should be passed to the external program. If true then the argument will be passed; otherwise, skipped. The default is true.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="if", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property IfDefined As Boolean
[C#]
[TaskAttribute(Required=False, Name="if", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool IfDefined {get; set;}

See Also

Argument Class | NAnt.Core.Types Namespace


Line Property

NAnt SDK Documentation - v0.91

Argument.Line Property

List of command-line arguments; will be passed to the executable as is.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="line", ExpandProperties:=True, ProcessXml:=True)>
Public Property Line As String
[C#]
[TaskAttribute(Required=False, Name="line", ExpandProperties=True, ProcessXml=True)]
public string Line {get; set;}

See Also

Argument Class | NAnt.Core.Types Namespace


Path Property

NAnt SDK Documentation - v0.91

Argument.Path Property

The value for a PATH-like command-line argument; you can use : or ; as path separators and NAnt will convert it to the platform's local conventions, while resolving references to environment variables.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="path", ExpandProperties:=True, ProcessXml:=True)>
Public Property Path As PathSet
[C#]
[TaskAttribute(Required=False, Name="path", ExpandProperties=True, ProcessXml=True)]
public PathSet Path {get; set;}

Remarks

Individual parts will be replaced with the absolute path, resolved relative to the project base directory.

See Also

Argument Class | NAnt.Core.Types Namespace


PathSet Property

NAnt SDK Documentation - v0.91

Argument.PathSet Property

Sets a single command-line argument and treats it like a PATH - ensures the right separator for the local platform is used.

[Visual Basic]
<BuildElement(Name:="path", Required:=False, ProcessXml:=True)>
Public Property PathSet As PathSet
[C#]
[BuildElement(Name="path", Required=False, ProcessXml=True)]
public PathSet PathSet {get; set;}

See Also

Argument Class | NAnt.Core.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

Argument.UnlessDefined Property

Indicates if the argument should not be passed to the external program. If false then the argument will be passed; otherwise, skipped. The default is false.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="unless", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property UnlessDefined As Boolean
[C#]
[TaskAttribute(Required=False, Name="unless", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool UnlessDefined {get; set;}

See Also

Argument Class | NAnt.Core.Types Namespace


Value Property

NAnt SDK Documentation - v0.91

Argument.Value Property

A single command-line argument; can contain space characters.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="value", ExpandProperties:=True, ProcessXml:=True)>
Public Property Value As String
[C#]
[TaskAttribute(Required=False, Name="value", ExpandProperties=True, ProcessXml=True)]
public string Value {get; set;}

See Also

Argument Class | NAnt.Core.Types Namespace


Argument Methods

The methods of the Argument class are listed below. For a complete list of Argument class members, see the Argument Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString | Returns the argument as a String.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Argument Class | NAnt.Core.Types Namespace


Argument.ToString Method

Returns the argument as a String.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The argument as a String.

Remarks

File and individual path elements will be quoted if necessary.

See Also

Argument Class | NAnt.Core.Types Namespace


ArgumentCollection Class

Contains a collection of Argument elements.

For a list of all members of this type, see ArgumentCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.Core.Types.ArgumentCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class ArgumentCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class ArgumentCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ArgumentCollection Members | NAnt.Core.Types Namespace


ArgumentCollection Members

ArgumentCollection overview

Public Instance Constructors

ArgumentCollection Overloaded. Initializes a new instance of the ArgumentCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a Argument to the end of the collection.
AddRange | Overloaded. Adds the elements of a Argument array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a Argument is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified Argument object in the collection.
Insert | Inserts a Argument into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString |

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace


ArgumentCollection Constructor

Initializes a new instance of the ArgumentCollection class.

Overload List

Initializes a new instance of the ArgumentCollection class.

public ArgumentCollection();

Initializes a new instance of the ArgumentCollection class with the specified array of Argument instances.

public ArgumentCollection(Argument[]);

Initializes a new instance of the ArgumentCollection class with the specified ArgumentCollection instance.

public ArgumentCollection(ArgumentCollection);

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace


ArgumentCollection Constructor ()

Initializes a new instance of the ArgumentCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ArgumentCollection();

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace | ArgumentCollection Constructor Overload List


ArgumentCollection Constructor (ArgumentCollection)

Initializes a new instance of the ArgumentCollection class with the specified ArgumentCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As ArgumentCollection _
)
[C#]
public ArgumentCollection(
ArgumentCollection value
);

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace | ArgumentCollection Constructor Overload List


ArgumentCollection Constructor (Argument[])

Initializes a new instance of the ArgumentCollection class with the specified array of Argument instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As Argument() _
)
[C#]
public ArgumentCollection(
Argument[] value
);

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace | ArgumentCollection Constructor Overload List


ArgumentCollection Properties

The properties of the ArgumentCollection class are listed below. For a complete list of ArgumentCollection class members, see the ArgumentCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

ArgumentCollection.Item Property

Gets or sets the element at the specified index.

Overload List

Gets or sets the element at the specified index.

public Argument this[int] {get; set;}

Gets the Argument with the specified value.

public Argument this[string] {get;}

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace


Item Property (Int32)

NAnt SDK Documentation - v0.91

ArgumentCollection.Item Property (Int32)

Gets or sets the element at the specified index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As Argument
[C#]
public Argument this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace | ArgumentCollection.Item Overload List


Item Property (String)

NAnt SDK Documentation - v0.91

ArgumentCollection.Item Property (String)

Gets the Argument with the specified value.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal value As String _
) As Argument
[C#]
public Argument this[
string value
] {get;}

Parameters

value
The value of the Argument to get.

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace | ArgumentCollection.Item Overload List


ArgumentCollection Methods

The methods of the ArgumentCollection class are listed below. For a complete list of ArgumentCollection class members, see the ArgumentCollection Members topic.

Public Instance Methods

Add | Adds a Argument to the end of the collection.
AddRange | Overloaded. Adds the elements of a Argument array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a Argument is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified Argument object in the collection.
Insert | Inserts a Argument into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace


ArgumentCollection.Add Method

Adds a Argument to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As Argument _
) As Integer
[C#]
public int Add(
Argument item
);

Parameters

item
The Argument to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

ArgumentCollection.AddRange Method

Adds the elements of a Argument array to the end of the collection.

Overload List

Adds the elements of a Argument array to the end of the collection.

public void AddRange(Argument[]);

Adds the elements of a ArgumentCollection to the end of the collection.

public void AddRange(ArgumentCollection);

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace


ArgumentCollection.AddRange Method (Argument[])

Adds the elements of a Argument array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As Argument() _
)
[C#]
public void AddRange(
Argument[] items
);

Parameters

items
The array of Argument elements to be added to the end of the collection.

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace | ArgumentCollection.AddRange Overload List


ArgumentCollection.AddRange Method (ArgumentCollection)

Adds the elements of a ArgumentCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As ArgumentCollection _
)
[C#]
public void AddRange(
ArgumentCollection items
);

Parameters

items
The ArgumentCollection to be added to the end of the collection.

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace | ArgumentCollection.AddRange Overload List


Contains Method

NAnt SDK Documentation - v0.91

ArgumentCollection.Contains Method

Determines whether a Argument is in the collection.

Overload List

Determines whether a Argument is in the collection.

public bool Contains(Argument);

Determines whether a Argument with the specified value is in the collection.

public bool Contains(string);

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace


ArgumentCollection.Contains Method (Argument)

Determines whether a Argument is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal item As Argument _
) As Boolean
[C#]
public bool Contains(
Argument item
);

Parameters

item
The Argument to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace | ArgumentCollection.Contains Overload List


ArgumentCollection.Contains Method (String)

Determines whether a Argument with the specified value is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal value As String _
) As Boolean
[C#]
public bool Contains(
string value
);

Parameters

value
The argument value to locate in the collection.

Return Value

true if a Argument with value value is found in the collection; otherwise, false.

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace | ArgumentCollection.Contains Overload List


ArgumentCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As Argument(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
Argument[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace


ArgumentCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As ArgumentEnumerator
[C#]
new public ArgumentEnumerator GetEnumerator();

Return Value

A ArgumentEnumerator for the entire collection.

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace


ArgumentCollection.IndexOf Method

Retrieves the index of a specified Argument object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As Argument _
) As Integer
[C#]
public int IndexOf(
Argument item
);

Parameters

item
The Argument object for which the index is returned.

Return Value

The index of the specified Argument. If the Argument is not currently a member of the collection, it returns -1.

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace


ArgumentCollection.Insert Method

Inserts a Argument into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As Argument _
)
[C#]
public void Insert(
int index,
Argument item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The Argument to insert.

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace


ArgumentCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As Argument _
)
[C#]
public void Remove(
Argument item
);

Parameters

item
The Argument to remove from the collection.

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace


ArgumentCollection.ToString Method

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

ArgumentCollection Class | NAnt.Core.Types Namespace


ArgumentEnumerator Class

Enumerates the Argument elements of a ArgumentCollection.

For a list of all members of this type, see ArgumentEnumerator Members.

System.Object
NAnt.Core.Types.ArgumentEnumerator

[Visual Basic]
Public Class ArgumentEnumerator
Implements IEnumerator
[C#]
public class ArgumentEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ArgumentEnumerator Members | NAnt.Core.Types Namespace


ArgumentEnumerator Members

ArgumentEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArgumentEnumerator Class | NAnt.Core.Types Namespace


ArgumentEnumerator Properties

The properties of the ArgumentEnumerator class are listed below. For a complete list of ArgumentEnumerator class members, see the ArgumentEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

ArgumentEnumerator Class | NAnt.Core.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

ArgumentEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As Argument
[C#]
public Argument Current {get;}

See Also

ArgumentEnumerator Class | NAnt.Core.Types Namespace


ArgumentEnumerator Methods

The methods of the ArgumentEnumerator class are listed below. For a complete list of ArgumentEnumerator class members, see the ArgumentEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArgumentEnumerator Class | NAnt.Core.Types Namespace


ArgumentEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

ArgumentEnumerator Class | NAnt.Core.Types Namespace


ArgumentEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

ArgumentEnumerator Class | NAnt.Core.Types Namespace


Credential Class

Provides credentials for password-based authentication schemes.

For a list of all members of this type, see Credential Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.Core.Types.Credential

[Visual Basic]
<ElementName(Name:="credential")>
Public Class Credential
Inherits DataTypeBase
[C#]
[ElementName(Name="credential")]
public class Credential : DataTypeBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

Credential Members | NAnt.Core.Types Namespace


Credential Members

Credential overview

Public Instance Constructors

Credential Constructor Initializes a new instance of the Credential class.

Public Instance Properties

CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Domain | The domain or computer name that verifies the credentials.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IfDefined | Indicates if the credentials should be used to provide authentication information to the external resource. If true then the credentials will be passed; otherwise, not. The default is true.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Password | The password for the user name associated with the credentials.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.
UnlessDefined | Indicates if the credentials should not be used to provide authentication information to the external resource. If false then the credentials will be passed; otherwise, not. The default is false.
UserName | The user name associated with the credentials.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCredential | Returns a NetworkCredential instance representing the current Credential.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from DataTypeBase) | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from DataTypeBase) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Credential Class | NAnt.Core.Types Namespace


Credential Constructor

Initializes a new instance of the Credential class.

[Visual Basic]
Public Sub New()
[C#]
public Credential();

See Also

Credential Class | NAnt.Core.Types Namespace


Credential Properties

The properties of the Credential class are listed below. For a complete list of Credential class members, see the Credential Members topic.

Public Instance Properties

CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Domain | The domain or computer name that verifies the credentials.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IfDefined | Indicates if the credentials should be used to provide authentication information to the external resource. If true then the credentials will be passed; otherwise, not. The default is true.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Password | The password for the user name associated with the credentials.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.
UnlessDefined | Indicates if the credentials should not be used to provide authentication information to the external resource. If false then the credentials will be passed; otherwise, not. The default is false.
UserName | The user name associated with the credentials.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

Credential Class | NAnt.Core.Types Namespace


Domain Property

NAnt SDK Documentation - v0.91

Credential.Domain Property

The domain or computer name that verifies the credentials.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="domain", ExpandProperties:=True, ProcessXml:=True)>
Public Property Domain As String
[C#]
[TaskAttribute(Required=False, Name="domain", ExpandProperties=True, ProcessXml=True)]
public string Domain {get; set;}

See Also

Credential Class | NAnt.Core.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

Credential.IfDefined Property

Indicates if the credentials should be used to provide authentication information to the external resource. If true then the credentials will be passed; otherwise, not. The default is true.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="if", ExpandProperties:=True, ProcessXml:=True)>
Public Property IfDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="if", ExpandProperties=True, ProcessXml=True)]
public bool IfDefined {get; set;}

See Also

Credential Class | NAnt.Core.Types Namespace


Password Property

NAnt SDK Documentation - v0.91

Credential.Password Property

The password for the user name associated with the credentials.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="password", ExpandProperties:=True, ProcessXml:=True)>
Public Property Password As String
[C#]
[TaskAttribute(Required=False, Name="password", ExpandProperties=True, ProcessXml=True)]
public string Password {get; set;}

See Also

Credential Class | NAnt.Core.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

Credential.UnlessDefined Property

Indicates if the credentials should not be used to provide authentication information to the external resource. If false then the credentials will be passed; otherwise, not. The default is false.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="unless", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property UnlessDefined As Boolean
[C#]
[TaskAttribute(Required=False, Name="unless", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool UnlessDefined {get; set;}

See Also

Credential Class | NAnt.Core.Types Namespace


UserName Property

NAnt SDK Documentation - v0.91

Credential.UserName Property

The user name associated with the credentials.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="username", ExpandProperties:=True, ProcessXml:=True)>
Public Property UserName As String
[C#]
[TaskAttribute(Required=False, Name="username", ExpandProperties=True, ProcessXml=True)]
public string UserName {get; set;}

See Also

Credential Class | NAnt.Core.Types Namespace


Credential Methods

The methods of the Credential class are listed below. For a complete list of Credential class members, see the Credential Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCredential | Returns a NetworkCredential instance representing the current Credential.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from DataTypeBase) | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from DataTypeBase) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Credential Class | NAnt.Core.Types Namespace


Credential.GetCredential Method

Returns a NetworkCredential instance representing the current Credential.

[Visual Basic]
Public Function GetCredential() As ICredentials
[C#]
public ICredentials GetCredential();

Return Value

A NetworkCredential instance representing the current Credential, or a null reference (Nothing in Visual Basic) if the credentials should not be used to provide authentication information to the external resource.

See Also

Credential Class | NAnt.Core.Types Namespace


DirSet Class

A specialized FileSet used for specifying a set of directories.

For a list of all members of this type, see DirSet Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.Core.Types.FileSet
NAnt.Core.Types.DirSet

[Visual Basic]
<ElementName(Name:="dirset")>
Public Class DirSet
Inherits FileSet
Implements ICloneable
[C#]
[ElementName(Name="dirset")]
public class DirSet : FileSet, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Hint for supporting tasks that the included directories instead of files should be used.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

DirSet Members | NAnt.Core.Types Namespace


DirSet Members

DirSet overview

Public Instance Constructors

DirSet Overloaded. Initializes a new instance of the DirSet class.

Public Instance Properties

AsIs (inherited from FileSet) | Gets the collection of files that will be added to the FileSet without pattern matching or checking if the file exists.
BaseDirectory (inherited from FileSet) | The base of the directory of this fileset. The default is the project base directory.
CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
CaseSensitive (inherited from FileSet) | Indicates whether include and exclude patterns must be treated in a case-sensitive way. The default is true on Unix; otherwise, false.
DefaultExcludes (inherited from FileSet) | Indicates whether default excludes should be used or not. The default is true.
DirectoryNames (inherited from FileSet) | Gets the collection of directory names that match the fileset.
ExcludeElements (inherited from FileSet) | The items to exclude from the fileset.
Excludes (inherited from FileSet) | Gets the collection of exclude patterns.
ExcludesFiles (inherited from FileSet) | The files from which a list of patterns or files to exclude should be obtained.
FailOnEmpty (inherited from FileSet) | When set to true, causes the fileset element to throw a ValidationException when no files match the includes and excludes criteria. The default is false.
FileNames (inherited from FileSet) | Gets the collection of file names that match the fileset.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IncludeElements (inherited from FileSet) | The items to include in the fileset.
Includes (inherited from FileSet) | Gets the collection of include patterns.
IncludesFiles (inherited from FileSet) | The files from which a list of patterns or files to include should be obtained.
MostRecentLastWriteTimeFile (inherited from FileSet) | Determines the most recently modified file in the fileset (by LastWriteTime of the FileInfo).
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PathFiles (inherited from FileSet) |
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.
ScannedDirectories (inherited from FileSet) | Gets the collection of directory names that were scanned for files.
SetExcludes (inherited from FileSet) | Obsolete. The items to exclude from the fileset.
SetIncludes (inherited from FileSet) | Obsolete. The items to include in the fileset.
SetIncludesList (inherited from FileSet) | Obsolete. The files from which a list of patterns or files to include should be obtained.

Public Instance Methods

AddPatternSet (inherited from FileSet) | Adds a nested set of patterns, or references a standalone patternset.
Clone (inherited from FileSet) | Creates a shallow copy of the FileSet.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from FileSet) |
Scan (inherited from FileSet) |
ToString (inherited from FileSet) |

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from FileSet) | Overloaded. Copies all instance data of the FileSet to a given FileSet.
CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from FileSet) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirSet Class | NAnt.Core.Types Namespace


DirSet Constructor

Initializes a new instance of the DirSet class.

Overload List

Initializes a new instance of the DirSet class.

public DirSet();

Copy constructor for FileSet. Required in order to assign references of FileSet type where DirSet is used.

public DirSet(FileSet);

See Also

DirSet Class | NAnt.Core.Types Namespace


DirSet Constructor ()

Initializes a new instance of the DirSet class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DirSet();

See Also

DirSet Class | NAnt.Core.Types Namespace | DirSet Constructor Overload List


DirSet Constructor (FileSet)

Copy constructor for FileSet. Required in order to assign references of FileSet type where DirSet is used.

[Visual Basic]
Overloads Public Sub New( _
ByVal fs As FileSet _
)
[C#]
public DirSet(
FileSet fs
);

Parameters

fs
A FileSet instance to create a DirSet from.

See Also

DirSet Class | NAnt.Core.Types Namespace | DirSet Constructor Overload List


EnvironmentSet Class

A set of environment variables.

For a list of all members of this type, see EnvironmentSet Members.

System.Object
NAnt.Core.Element
NAnt.Core.Types.EnvironmentSet

[Visual Basic]
<Serializable, _ Serializable, _ ElementName(Name:="environment")>
Public Class EnvironmentSet
Inherits Element
[C#]
[Serializable]
[Serializable]
[ElementName(Name="environment")]
public class EnvironmentSet : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

EnvironmentSet Members | NAnt.Core.Types Namespace


EnvironmentSet Members

EnvironmentSet overview

Public Instance Constructors

EnvironmentSet Constructor Initializes a new instance of the EnvironmentSet class.

Public Instance Properties

EnvironmentVariables | Environment variable to pass to a program.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Options | Obsolete. Environment variable to pass to a program.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EnvironmentSet Class | NAnt.Core.Types Namespace


EnvironmentSet Constructor

Initializes a new instance of the EnvironmentSet class.

[Visual Basic]
Public Sub New()
[C#]
public EnvironmentSet();

See Also

EnvironmentSet Class | NAnt.Core.Types Namespace


EnvironmentSet Properties

The properties of the EnvironmentSet class are listed below. For a complete list of EnvironmentSet class members, see the EnvironmentSet Members topic.

Public Instance Properties

EnvironmentVariables | Environment variable to pass to a program.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Options | Obsolete. Environment variable to pass to a program.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

EnvironmentSet Class | NAnt.Core.Types Namespace


EnvironmentVariables Property

NAnt SDK Documentation - v0.91

EnvironmentSet.EnvironmentVariables Property

Environment variable to pass to a program.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="variable", Required:=False, ProcessXml:=True)>
Public Property EnvironmentVariables As EnvironmentVariableCollection
[C#]
[BuildElementArray(ElementType=null, Name="variable", Required=False, ProcessXml=True)]
public EnvironmentVariableCollection EnvironmentVariables {get; set;}

See Also

EnvironmentSet Class | NAnt.Core.Types Namespace


Options Property

NAnt SDK Documentation - v0.91

EnvironmentSet.Options Property

NOTE: This property is now obsolete.

Use <variable> element instead.

Environment variable to pass to a program.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="option", Required:=False, ProcessXml:=True), _ Obsolete(Message:="Use <variable> element instead.", IsError:=False)>
Public Property Options As OptionCollection
[C#]
[BuildElementArray(ElementType=null, Name="option", Required=False, ProcessXml=True)]
[Obsolete(Message="Use <variable> element instead.", IsError=False)]
public OptionCollection Options {get; set;}

See Also

EnvironmentSet Class | NAnt.Core.Types Namespace


EnvironmentVariable Class

Represents an environment variable.

For a list of all members of this type, see EnvironmentVariable Members.

System.Object
NAnt.Core.Element
NAnt.Core.Types.EnvironmentVariable

[Visual Basic]
<Serializable, _ Serializable, _ ElementName(Name:="env")>
Public Class EnvironmentVariable
Inherits Element
[C#]
[Serializable]
[Serializable]
[ElementName(Name="env")]
public class EnvironmentVariable : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

EnvironmentVariable Members | NAnt.Core.Types Namespace


EnvironmentVariable Members

EnvironmentVariable overview

Public Instance Constructors

EnvironmentVariable Overloaded. Initializes a new instance of the EnvironmentVariable class.

Public Instance Properties

Directory | The value for a directory-based environment variable. NAnt will convert it to an absolute path.
File | The value for a file-based environment variable. NAnt will convert it to an absolute filename.
IfDefined | Indicates if the environment variable should be passed to the external program. If true then the environment variable will be passed; otherwise, skipped. The default is true.
LiteralValue | The literal value for the environment variable.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Path | The value for a PATH like environment variable. You can use : or ; as path separators and NAnt will convert it to the platform's local conventions.
PathSet | Sets a single environment variable and treats it like a PATH - ensures the right separator for the local platform is used.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Indicates if the environment variable should not be passed to the external program. If false then the environment variable will be passed; otherwise, skipped. The default is false.
Value | Gets the value of the environment variable.
VariableName | The name of the environment variable.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EnvironmentVariable Class | NAnt.Core.Types Namespace


EnvironmentVariable Constructor

Initializes a EnvironmentVariable instance with the specified name and value.

Overload List

Initializes a EnvironmentVariable instance.

public EnvironmentVariable();

Initializes a EnvironmentVariable instance with the specified name and value.

public EnvironmentVariable(string,string);

See Also

EnvironmentVariable Class | NAnt.Core.Types Namespace


EnvironmentVariable Constructor (String, String)

Initializes a EnvironmentVariable instance with the specified name and value.

[Visual Basic]
Overloads Public Sub New( _
ByVal name As String, _
ByVal value As String _
)
[C#]
public EnvironmentVariable(
string name,
string value
);

Parameters

name
The name of the environment variable.
value
The value of the environment variable.

See Also

EnvironmentVariable Class | NAnt.Core.Types Namespace | EnvironmentVariable Constructor Overload List


EnvironmentVariable Constructor ()

Initializes a EnvironmentVariable instance.

[Visual Basic]
Overloads Public Sub New()
[C#]
public EnvironmentVariable();

See Also

EnvironmentVariable Class | NAnt.Core.Types Namespace | EnvironmentVariable Constructor Overload List


EnvironmentVariable Properties

The properties of the EnvironmentVariable class are listed below. For a complete list of EnvironmentVariable class members, see the EnvironmentVariable Members topic.

Public Instance Properties

Directory | The value for a directory-based environment variable. NAnt will convert it to an absolute path.
File | The value for a file-based environment variable. NAnt will convert it to an absolute filename.
IfDefined | Indicates if the environment variable should be passed to the external program. If true then the environment variable will be passed; otherwise, skipped. The default is true.
LiteralValue | The literal value for the environment variable.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Path | The value for a PATH like environment variable. You can use : or ; as path separators and NAnt will convert it to the platform's local conventions.
PathSet | Sets a single environment variable and treats it like a PATH - ensures the right separator for the local platform is used.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Indicates if the environment variable should not be passed to the external program. If false then the environment variable will be passed; otherwise, skipped. The default is false.
Value | Gets the value of the environment variable.
VariableName | The name of the environment variable.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

EnvironmentVariable Class | NAnt.Core.Types Namespace


Directory Property

NAnt SDK Documentation - v0.91

EnvironmentVariable.Directory Property

The value for a directory-based environment variable. NAnt will convert it to an absolute path.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="dir", ExpandProperties:=True, ProcessXml:=True)>
Public Property Directory As DirectoryInfo
[C#]
[TaskAttribute(Required=False, Name="dir", ExpandProperties=True, ProcessXml=True)]
public System.IO.DirectoryInfo Directory {get; set;}

See Also

EnvironmentVariable Class | NAnt.Core.Types Namespace


File Property

NAnt SDK Documentation - v0.91

EnvironmentVariable.File Property

The value for a file-based environment variable. NAnt will convert it to an absolute filename.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="file", ExpandProperties:=True, ProcessXml:=True)>
Public Property File As FileInfo
[C#]
[TaskAttribute(Required=False, Name="file", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo File {get; set;}

See Also

EnvironmentVariable Class | NAnt.Core.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

EnvironmentVariable.IfDefined Property

Indicates if the environment variable should be passed to the external program. If true then the environment variable will be passed; otherwise, skipped. The default is true.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="if", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property IfDefined As Boolean
[C#]
[TaskAttribute(Required=False, Name="if", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool IfDefined {get; set;}

See Also

EnvironmentVariable Class | NAnt.Core.Types Namespace


LiteralValue Property

NAnt SDK Documentation - v0.91

EnvironmentVariable.LiteralValue Property

The literal value for the environment variable.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="value", ExpandProperties:=True, ProcessXml:=True)>
Public Property LiteralValue As String
[C#]
[TaskAttribute(Required=False, Name="value", ExpandProperties=True, ProcessXml=True)]
public string LiteralValue {get; set;}

See Also

EnvironmentVariable Class | NAnt.Core.Types Namespace


Path Property

NAnt SDK Documentation - v0.91

EnvironmentVariable.Path Property

The value for a PATH like environment variable. You can use : or ; as path separators and NAnt will convert it to the platform's local conventions.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="path", ExpandProperties:=True, ProcessXml:=True)>
Public Property Path As PathSet
[C#]
[TaskAttribute(Required=False, Name="path", ExpandProperties=True, ProcessXml=True)]
public PathSet Path {get; set;}

See Also

EnvironmentVariable Class | NAnt.Core.Types Namespace


PathSet Property

NAnt SDK Documentation - v0.91

EnvironmentVariable.PathSet Property

Sets a single environment variable and treats it like a PATH - ensures the right separator for the local platform is used.

[Visual Basic]
<BuildElement(Name:="path", Required:=False, ProcessXml:=True)>
Public Property PathSet As PathSet
[C#]
[BuildElement(Name="path", Required=False, ProcessXml=True)]
public PathSet PathSet {get; set;}

See Also

EnvironmentVariable Class | NAnt.Core.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

EnvironmentVariable.UnlessDefined Property

Indicates if the environment variable should not be passed to the external program. If false then the environment variable will be passed; otherwise, skipped. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="unless", ExpandProperties:=True, ProcessXml:=True)>
Public Property UnlessDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="unless", ExpandProperties=True, ProcessXml=True)]
public bool UnlessDefined {get; set;}

See Also

EnvironmentVariable Class | NAnt.Core.Types Namespace


Value Property

NAnt SDK Documentation - v0.91

EnvironmentVariable.Value Property

Gets the value of the environment variable.

[Visual Basic]
Public ReadOnly Property Value As String
[C#]
public string Value {get;}

See Also

EnvironmentVariable Class | NAnt.Core.Types Namespace


VariableName Property

NAnt SDK Documentation - v0.91

EnvironmentVariable.VariableName Property

The name of the environment variable.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="name", ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property VariableName As String
[C#]
[TaskAttribute(Required=True, Name="name", ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string VariableName {get; set;}

See Also

EnvironmentVariable Class | NAnt.Core.Types Namespace


EnvironmentVariableCollection Class

Contains a collection of EnvironmentVariable elements.

For a list of all members of this type, see EnvironmentVariableCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.Core.Types.EnvironmentVariableCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class EnvironmentVariableCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class EnvironmentVariableCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

EnvironmentVariableCollection Members | NAnt.Core.Types Namespace


EnvironmentVariableCollection Members

EnvironmentVariableCollection overview

Public Instance Constructors

EnvironmentVariableCollection Overloaded. Initializes a new instance of the EnvironmentVariableCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a EnvironmentVariable to the end of the collection.
AddRange | Overloaded. Adds the elements of a EnvironmentVariable array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a EnvironmentVariable is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified EnvironmentVariable object in the collection.
Insert | Inserts a EnvironmentVariable into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace


EnvironmentVariableCollection Constructor

Initializes a new instance of the EnvironmentVariableCollection class.

Overload List

Initializes a new instance of the EnvironmentVariableCollection class.

public EnvironmentVariableCollection();

Initializes a new instance of the EnvironmentVariableCollection class with the specified array of EnvironmentVariable instances.

public EnvironmentVariableCollection(EnvironmentVariable[]);

Initializes a new instance of the EnvironmentVariableCollection class with the specified EnvironmentVariableCollection instance.

public EnvironmentVariableCollection(EnvironmentVariableCollection);

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace


EnvironmentVariableCollection Constructor ()

Initializes a new instance of the EnvironmentVariableCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public EnvironmentVariableCollection();

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace | EnvironmentVariableCollection Constructor Overload List


EnvironmentVariableCollection Constructor (EnvironmentVariableCollection)

Initializes a new instance of the EnvironmentVariableCollection class with the specified EnvironmentVariableCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As EnvironmentVariableCollection _
)
[C#]
public EnvironmentVariableCollection(
EnvironmentVariableCollection value
);

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace | EnvironmentVariableCollection Constructor Overload List


EnvironmentVariableCollection Constructor (EnvironmentVariable[])

Initializes a new instance of the EnvironmentVariableCollection class with the specified array of EnvironmentVariable instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As EnvironmentVariable() _
)
[C#]
public EnvironmentVariableCollection(
EnvironmentVariable[] value
);

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace | EnvironmentVariableCollection Constructor Overload List


EnvironmentVariableCollection Properties

The properties of the EnvironmentVariableCollection class are listed below. For a complete list of EnvironmentVariableCollection class members, see the EnvironmentVariableCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

EnvironmentVariableCollection.Item Property

Gets or sets the element at the specified index.

Overload List

Gets or sets the element at the specified index.

public EnvironmentVariable this[int] {get; set;}

Gets the EnvironmentVariable with the specified name.

public EnvironmentVariable this[string] {get;}

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace


Item Property (Int32)

NAnt SDK Documentation - v0.91

EnvironmentVariableCollection.Item Property (Int32)

Gets or sets the element at the specified index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As EnvironmentVariable
[C#]
public EnvironmentVariable this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace | EnvironmentVariableCollection.Item Overload List


Item Property (String)

NAnt SDK Documentation - v0.91

EnvironmentVariableCollection.Item Property (String)

Gets the EnvironmentVariable with the specified name.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal name As String _
) As EnvironmentVariable
[C#]
public EnvironmentVariable this[
string name
] {get;}

Parameters

name
The name of the EnvironmentVariable to get.

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace | EnvironmentVariableCollection.Item Overload List


EnvironmentVariableCollection Methods

The methods of the EnvironmentVariableCollection class are listed below. For a complete list of EnvironmentVariableCollection class members, see the EnvironmentVariableCollection Members topic.

Public Instance Methods

Add | Adds a EnvironmentVariable to the end of the collection.
AddRange | Overloaded. Adds the elements of a EnvironmentVariable array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a EnvironmentVariable is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified EnvironmentVariable object in the collection.
Insert | Inserts a EnvironmentVariable into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace


EnvironmentVariableCollection.Add Method

Adds a EnvironmentVariable to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As EnvironmentVariable _
) As Integer
[C#]
public int Add(
EnvironmentVariable item
);

Parameters

item
The EnvironmentVariable to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

EnvironmentVariableCollection.AddRange Method

Adds the elements of a EnvironmentVariable array to the end of the collection.

Overload List

Adds the elements of a EnvironmentVariable array to the end of the collection.

public void AddRange(EnvironmentVariable[]);

Adds the elements of a EnvironmentVariableCollection to the end of the collection.

public void AddRange(EnvironmentVariableCollection);

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace


EnvironmentVariableCollection.AddRange Method (EnvironmentVariable[])

Adds the elements of a EnvironmentVariable array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As EnvironmentVariable() _
)
[C#]
public void AddRange(
EnvironmentVariable[] items
);

Parameters

items
The array of EnvironmentVariable elements to be added to the end of the collection.

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace | EnvironmentVariableCollection.AddRange Overload List


EnvironmentVariableCollection.AddRange Method (EnvironmentVariableCollection)

Adds the elements of a EnvironmentVariableCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As EnvironmentVariableCollection _
)
[C#]
public void AddRange(
EnvironmentVariableCollection items
);

Parameters

items
The EnvironmentVariableCollection to be added to the end of the collection.

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace | EnvironmentVariableCollection.AddRange Overload List


Contains Method

NAnt SDK Documentation - v0.91

EnvironmentVariableCollection.Contains Method

Determines whether a EnvironmentVariable is in the collection.

Overload List

Determines whether a EnvironmentVariable is in the collection.

public bool Contains(EnvironmentVariable);

Determines whether a EnvironmentVariable with the specified value is in the collection.

public bool Contains(string);

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace


EnvironmentVariableCollection.Contains Method (EnvironmentVariable)

Determines whether a EnvironmentVariable is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal item As EnvironmentVariable _
) As Boolean
[C#]
public bool Contains(
EnvironmentVariable item
);

Parameters

item
The EnvironmentVariable to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace | EnvironmentVariableCollection.Contains Overload List


EnvironmentVariableCollection.Contains Method (String)

Determines whether a EnvironmentVariable with the specified value is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal value As String _
) As Boolean
[C#]
public bool Contains(
string value
);

Parameters

value
The argument value to locate in the collection.

Return Value

true if a EnvironmentVariable with value value is found in the collection; otherwise, false.

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace | EnvironmentVariableCollection.Contains Overload List


EnvironmentVariableCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As EnvironmentVariable(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
EnvironmentVariable[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace


EnvironmentVariableCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As EnvironmentVariableEnumerator
[C#]
new public EnvironmentVariableEnumerator GetEnumerator();

Return Value

A EnvironmentVariableEnumerator for the entire collection.

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace


EnvironmentVariableCollection.IndexOf Method

Retrieves the index of a specified EnvironmentVariable object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As EnvironmentVariable _
) As Integer
[C#]
public int IndexOf(
EnvironmentVariable item
);

Parameters

item
The EnvironmentVariable object for which the index is returned.

Return Value

The index of the specified EnvironmentVariable. If the EnvironmentVariable is not currently a member of the collection, it returns -1.

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace


EnvironmentVariableCollection.Insert Method

Inserts a EnvironmentVariable into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As EnvironmentVariable _
)
[C#]
public void Insert(
int index,
EnvironmentVariable item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The EnvironmentVariable to insert.

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace


EnvironmentVariableCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As EnvironmentVariable _
)
[C#]
public void Remove(
EnvironmentVariable item
);

Parameters

item
The EnvironmentVariable to remove from the collection.

See Also

EnvironmentVariableCollection Class | NAnt.Core.Types Namespace


EnvironmentVariableEnumerator Class

Enumerates the EnvironmentVariable elements of a EnvironmentVariableCollection.

For a list of all members of this type, see EnvironmentVariableEnumerator Members.

System.Object
NAnt.Core.Types.EnvironmentVariableEnumerator

[Visual Basic]
Public Class EnvironmentVariableEnumerator
Implements IEnumerator
[C#]
public class EnvironmentVariableEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

EnvironmentVariableEnumerator Members | NAnt.Core.Types Namespace


EnvironmentVariableEnumerator Members

EnvironmentVariableEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EnvironmentVariableEnumerator Class | NAnt.Core.Types Namespace


EnvironmentVariableEnumerator Properties

The properties of the EnvironmentVariableEnumerator class are listed below. For a complete list of EnvironmentVariableEnumerator class members, see the EnvironmentVariableEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

EnvironmentVariableEnumerator Class | NAnt.Core.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

EnvironmentVariableEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As EnvironmentVariable
[C#]
public EnvironmentVariable Current {get;}

See Also

EnvironmentVariableEnumerator Class | NAnt.Core.Types Namespace


EnvironmentVariableEnumerator Methods

The methods of the EnvironmentVariableEnumerator class are listed below. For a complete list of EnvironmentVariableEnumerator class members, see the EnvironmentVariableEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EnvironmentVariableEnumerator Class | NAnt.Core.Types Namespace


EnvironmentVariableEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

EnvironmentVariableEnumerator Class | NAnt.Core.Types Namespace


EnvironmentVariableEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

EnvironmentVariableEnumerator Class | NAnt.Core.Types Namespace


FileSet Class

Filesets are groups of files. These files can be found in a directory tree starting in a base directory and are matched by patterns taken from a number of patterns. Filesets can appear inside tasks that support this feature or at the project level, i.e., as children of <project>.

For a list of all members of this type, see FileSet Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.Core.Types.FileSet
Derived types

[Visual Basic]
<Serializable, _ Serializable, _ ElementName(Name:="fileset")>
Public Class FileSet
Inherits DataTypeBase
[C#]
[Serializable]
[Serializable]
[ElementName(Name="fileset")]
public class FileSet : DataTypeBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Patterns

As described earlier, patterns are used for the inclusion and exclusion. These patterns look very much like the patterns used in DOS and UNIX:

  • '*' matches zero or more characters

    For example:

    *.cs matches .cs, x.cs and FooBar.cs, but not FooBar.xml (does not end with .cs).

  • '?' matches one character

    For example:

    ?.cs matches x.cs, A.cs, but not .cs or xyz.cs (both don't have one character before .cs).

Combinations of *'s and ?'s are allowed.

Matching is done per-directory. This means that first the first directory in the pattern is matched against the first directory in the path to match. Then the second directory is matched, and so on. For example, when we have the pattern /?abc/*/*.cs and the path /xabc/foobar/test.cs, the first ?abc is matched with xabc, then * is matched with foobar, and finally *.cs is matched with test.cs. They all match, so the path matches the pattern.

To make things a bit more flexible, we added one extra feature, which makes it possible to match multiple directory levels. This can be used to match a complete directory tree, or a file anywhere in the directory tree. To do this, ** must be used as the name of a directory. When ** is used as the name of a directory in the pattern, it matches zero or more directories. For example: /test/** matches all files/directories under /test/, such as /test/x.cs, or /test/foo/bar/xyz.html, but not /xyz.xml.

There is one "shorthand" - if a pattern ends with / or \, then ** is appended. For example, mypackage/test/ is interpreted as if it were mypackage/test/**.

Case-Sensitivity

By default, pattern matching is case-sensitive on Unix and case-insensitive on other platforms. The CaseSensitive parameter can be used to override this.

Default Excludes

There are a set of definitions that are excluded by default from all tasks that use filesets. They are:

  • **/.svn
  • **/.svn/**
  • **/_svn
  • **/_svn/**
  • **/.git
  • **/.git/**
  • **/.git* (eg. .gitignore)
  • **/.hg
  • **/.hg/**
  • **/.hg* (eg. .hgignore)
  • **/SCCS
  • **/SCCS/**
  • **/vssver.scc
  • **/vssver2.scc
  • **/_vti_cnf/**
  • **/*~
  • **/#*#
  • **/.#*
  • **/%*%
  • **/CVS
  • **/CVS/**
  • **/.cvsignore

If you do not want these default excludes applied, you may disable them by setting DefaultExcludes to false.

Example

Pattern Match
**/CVS/*

Matches all files in CVS directories that can be located anywhere in the directory tree.

Matches:

  • CVS/Repository
  • org/apache/CVS/Entries
  • org/apache/jakarta/tools/ant/CVS/Entries

But not:

  • org/apache/CVS/foo/bar/Entries (foo/bar/ part does not match)
org/apache/jakarta/**

Matches all files in the org/apache/jakarta directory tree.

Matches:

  • org/apache/jakarta/tools/ant/docs/index.html
  • org/apache/jakarta/test.xml

But not:

  • org/apache/xyz.java (jakarta/ part is missing)
org/apache/**/CVS/*

Matches all files in CVS directories that are located anywhere in the directory tree under org/apache.

Matches:

  • org/apache/CVS/Entries
  • org/apache/jakarta/tools/ant/CVS/Entries

But not:

  • org/apache/CVS/foo/bar/Entries (foo/bar/ part does not match)
**/test/**

Matches all files that have a test element in their path, including test as a filename.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FileSet Members | NAnt.Core.Types Namespace | PatternSet


FileSet Members

FileSet overview

Public Static (Shared) Methods

FindMoreRecentLastWriteTime Overloaded. Determines if a file has a more recent last write time than the given time, or no longer exists.

Public Instance Constructors

FileSet Overloaded. Initializes a new instance of the FileSet class.

Public Instance Properties

AsIs | Gets the collection of files that will be added to the FileSet without pattern matching or checking if the file exists.
BaseDirectory | The base of the directory of this fileset. The default is the project base directory.
CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
CaseSensitive | Indicates whether include and exclude patterns must be treated in a case-sensitive way. The default is true on Unix; otherwise, false.
DefaultExcludes | Indicates whether default excludes should be used or not. The default is true.
DirectoryNames | Gets the collection of directory names that match the fileset.
ExcludeElements | The items to exclude from the fileset.
Excludes | Gets the collection of exclude patterns.
ExcludesFiles | The files from which a list of patterns or files to exclude should be obtained.
FailOnEmpty | When set to true, causes the fileset element to throw a ValidationException when no files match the includes and excludes criteria. The default is false.
FileNames | Gets the collection of file names that match the fileset.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IncludeElements | The items to include in the fileset.
Includes | Gets the collection of include patterns.
IncludesFiles | The files from which a list of patterns or files to include should be obtained.
MostRecentLastWriteTimeFile | Determines the most recently modified file in the fileset (by LastWriteTime of the FileInfo).
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PathFiles |
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.
ScannedDirectories | Gets the collection of directory names that were scanned for files.
SetExcludes | Obsolete. The items to exclude from the fileset.
SetIncludes | Obsolete. The items to include in the fileset.
SetIncludesList | Obsolete. The files from which a list of patterns or files to include should be obtained.

Public Instance Methods

AddPatternSet | Adds a nested set of patterns, or references a standalone patternset.
Clone | Creates a shallow copy of the FileSet.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset |
Scan |
ToString |

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo | Overloaded. Copies all instance data of the FileSet to a given FileSet.
CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileSet Class | NAnt.Core.Types Namespace | PatternSet


FileSet Constructor

Initializes a new instance of the FileSet class.

Overload List

Initializes a new instance of the FileSet class.

public FileSet();

copy constructor

public FileSet(FileSet);

See Also

FileSet Class | NAnt.Core.Types Namespace


FileSet Constructor ()

Initializes a new instance of the FileSet class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FileSet();

See Also

FileSet Class | NAnt.Core.Types Namespace | FileSet Constructor Overload List


FileSet Constructor (FileSet)

copy constructor

[Visual Basic]
Overloads Public Sub New( _
ByVal fs As FileSet _
)
[C#]
public FileSet(
FileSet fs
);

Parameters

fs

See Also

FileSet Class | NAnt.Core.Types Namespace | FileSet Constructor Overload List


FileSet Properties

The properties of the FileSet class are listed below. For a complete list of FileSet class members, see the FileSet Members topic.

Public Instance Properties

AsIs | Gets the collection of files that will be added to the FileSet without pattern matching or checking if the file exists.
BaseDirectory | The base of the directory of this fileset. The default is the project base directory.
CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
CaseSensitive | Indicates whether include and exclude patterns must be treated in a case-sensitive way. The default is true on Unix; otherwise, false.
DefaultExcludes | Indicates whether default excludes should be used or not. The default is true.
DirectoryNames | Gets the collection of directory names that match the fileset.
ExcludeElements | The items to exclude from the fileset.
Excludes | Gets the collection of exclude patterns.
ExcludesFiles | The files from which a list of patterns or files to exclude should be obtained.
FailOnEmpty | When set to true, causes the fileset element to throw a ValidationException when no files match the includes and excludes criteria. The default is false.
FileNames | Gets the collection of file names that match the fileset.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IncludeElements | The items to include in the fileset.
Includes | Gets the collection of include patterns.
IncludesFiles | The files from which a list of patterns or files to include should be obtained.
MostRecentLastWriteTimeFile | Determines the most recently modified file in the fileset (by LastWriteTime of the FileInfo).
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PathFiles |
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.
ScannedDirectories | Gets the collection of directory names that were scanned for files.
SetExcludes | Obsolete. The items to exclude from the fileset.
SetIncludes | Obsolete. The items to include in the fileset.
SetIncludesList | Obsolete. The files from which a list of patterns or files to include should be obtained.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

FileSet Class | NAnt.Core.Types Namespace | PatternSet


AsIs Property

NAnt SDK Documentation - v0.91

FileSet.AsIs Property

Gets the collection of files that will be added to the FileSet without pattern matching or checking if the file exists.

[Visual Basic]
Public ReadOnly Property AsIs As StringCollection
[C#]
public System.Collections.Specialized.StringCollection AsIs {get;}

See Also

FileSet Class | NAnt.Core.Types Namespace


BaseDirectory Property

NAnt SDK Documentation - v0.91

FileSet.BaseDirectory Property

The base of the directory of this fileset. The default is the project base directory.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="basedir", ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property BaseDirectory As DirectoryInfo
[C#]
[TaskAttribute(Required=False, Name="basedir", ExpandProperties=True, ProcessXml=True)]
public virtual System.IO.DirectoryInfo BaseDirectory {get; set;}

See Also

FileSet Class | NAnt.Core.Types Namespace


CaseSensitive Property

NAnt SDK Documentation - v0.91

FileSet.CaseSensitive Property

Indicates whether include and exclude patterns must be treated in a case-sensitive way. The default is true on Unix; otherwise, false.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="casesensitive", ExpandProperties:=True, ProcessXml:=True)>
Public Property CaseSensitive As Boolean
[C#]
[TaskAttribute(Required=False, Name="casesensitive", ExpandProperties=True, ProcessXml=True)]
public bool CaseSensitive {get; set;}

See Also

FileSet Class | NAnt.Core.Types Namespace


DefaultExcludes Property

NAnt SDK Documentation - v0.91

FileSet.DefaultExcludes Property

Indicates whether default excludes should be used or not. The default is true.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="defaultexcludes", ExpandProperties:=True, ProcessXml:=True)>
Public Property DefaultExcludes As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="defaultexcludes", ExpandProperties=True, ProcessXml=True)]
public bool DefaultExcludes {get; set;}

See Also

FileSet Class | NAnt.Core.Types Namespace


DirectoryNames Property

NAnt SDK Documentation - v0.91

FileSet.DirectoryNames Property

Gets the collection of directory names that match the fileset.

[Visual Basic]
Public ReadOnly Property DirectoryNames As StringCollection
[C#]
public System.Collections.Specialized.StringCollection DirectoryNames {get;}

Property Value

A collection that contains the directory names that match the FileSet.

See Also

FileSet Class | NAnt.Core.Types Namespace


ExcludeElements Property

NAnt SDK Documentation - v0.91

FileSet.ExcludeElements Property

The items to exclude from the fileset.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="exclude", Required:=False, ProcessXml:=True)>
Public WriteOnly Property ExcludeElements As Exclude()
[C#]
[BuildElementArray(ElementType=null, Name="exclude", Required=False, ProcessXml=True)]
public FileSet.Exclude[] ExcludeElements {set;}

See Also

FileSet Class | NAnt.Core.Types Namespace


Excludes Property

NAnt SDK Documentation - v0.91

FileSet.Excludes Property

Gets the collection of exclude patterns.

[Visual Basic]
Public ReadOnly Property Excludes As StringCollection
[C#]
public System.Collections.Specialized.StringCollection Excludes {get;}

See Also

FileSet Class | NAnt.Core.Types Namespace


ExcludesFiles Property

NAnt SDK Documentation - v0.91

FileSet.ExcludesFiles Property

The files from which a list of patterns or files to exclude should be obtained.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="excludesfile", Required:=False, ProcessXml:=True)>
Public WriteOnly Property ExcludesFiles As ExcludesFile()
[C#]
[BuildElementArray(ElementType=null, Name="excludesfile", Required=False, ProcessXml=True)]
public FileSet.ExcludesFile[] ExcludesFiles {set;}

See Also

FileSet Class | NAnt.Core.Types Namespace


FailOnEmpty Property

NAnt SDK Documentation - v0.91

FileSet.FailOnEmpty Property

When set to true, causes the fileset element to throw a ValidationException when no files match the includes and excludes criteria. The default is false.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="failonempty", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property FailOnEmpty As Boolean
[C#]
[TaskAttribute(Required=False, Name="failonempty", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool FailOnEmpty {get; set;}

See Also

FileSet Class | NAnt.Core.Types Namespace


FileNames Property

NAnt SDK Documentation - v0.91

FileSet.FileNames Property

Gets the collection of file names that match the fileset.

[Visual Basic]
Public ReadOnly Property FileNames As StringCollection
[C#]
public System.Collections.Specialized.StringCollection FileNames {get;}

Property Value

A collection that contains the file names that match the FileSet.

See Also

FileSet Class | NAnt.Core.Types Namespace


IncludeElements Property

NAnt SDK Documentation - v0.91

FileSet.IncludeElements Property

The items to include in the fileset.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="include", Required:=False, ProcessXml:=True)>
Public WriteOnly Property IncludeElements As Include()
[C#]
[BuildElementArray(ElementType=null, Name="include", Required=False, ProcessXml=True)]
public FileSet.Include[] IncludeElements {set;}

See Also

FileSet Class | NAnt.Core.Types Namespace


Includes Property

NAnt SDK Documentation - v0.91

FileSet.Includes Property

Gets the collection of include patterns.

[Visual Basic]
Public ReadOnly Property Includes As StringCollection
[C#]
public System.Collections.Specialized.StringCollection Includes {get;}

See Also

FileSet Class | NAnt.Core.Types Namespace


IncludesFiles Property

NAnt SDK Documentation - v0.91

FileSet.IncludesFiles Property

The files from which a list of patterns or files to include should be obtained.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="includesfile", Required:=False, ProcessXml:=True)>
Public WriteOnly Property IncludesFiles As IncludesFile()
[C#]
[BuildElementArray(ElementType=null, Name="includesfile", Required=False, ProcessXml=True)]
public FileSet.IncludesFile[] IncludesFiles {set;}

See Also

FileSet Class | NAnt.Core.Types Namespace


MostRecentLastWriteTimeFile Property

NAnt SDK Documentation - v0.91

FileSet.MostRecentLastWriteTimeFile Property

Determines the most recently modified file in the fileset (by LastWriteTime of the FileInfo).

[Visual Basic]
Public ReadOnly Property MostRecentLastWriteTimeFile As FileInfo
[C#]
public System.IO.FileInfo MostRecentLastWriteTimeFile {get;}

See Also

FileSet Class | NAnt.Core.Types Namespace


PathFiles Property

NAnt SDK Documentation - v0.91

FileSet.PathFiles Property

[Visual Basic]
Public ReadOnly Property PathFiles As PathScanner
[C#]
public NAnt.Core.PathScanner PathFiles {get;}

See Also

FileSet Class | NAnt.Core.Types Namespace


ScannedDirectories Property

NAnt SDK Documentation - v0.91

FileSet.ScannedDirectories Property

Gets the collection of directory names that were scanned for files.

[Visual Basic]
Public ReadOnly Property ScannedDirectories As StringCollection
[C#]
public System.Collections.Specialized.StringCollection ScannedDirectories {get;}

Property Value

A collection that contains the directory names that were scanned for files.

See Also

FileSet Class | NAnt.Core.Types Namespace


SetExcludes Property

NAnt SDK Documentation - v0.91

FileSet.SetExcludes Property

NOTE: This property is now obsolete.

Use <exclude> element instead.

The items to exclude from the fileset.

[Visual Basic]
<Obsolete(Message:="Use <exclude> element instead.", IsError:=False), _ BuildElementArray(ElementType:=null, Name:="excludes", Required:=False, ProcessXml:=True)>
Public WriteOnly Property SetExcludes As Exclude()
[C#]
[Obsolete(Message="Use <exclude> element instead.", IsError=False)]
[BuildElementArray(ElementType=null, Name="excludes", Required=False, ProcessXml=True)]
public FileSet.Exclude[] SetExcludes {set;}

See Also

FileSet Class | NAnt.Core.Types Namespace


SetIncludes Property

NAnt SDK Documentation - v0.91

FileSet.SetIncludes Property

NOTE: This property is now obsolete.

Use <include> element instead.

The items to include in the fileset.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="includes", Required:=False, ProcessXml:=True), _ Obsolete(Message:="Use <include> element instead.", IsError:=False)>
Public WriteOnly Property SetIncludes As Include()
[C#]
[BuildElementArray(ElementType=null, Name="includes", Required=False, ProcessXml=True)]
[Obsolete(Message="Use <include> element instead.", IsError=False)]
public FileSet.Include[] SetIncludes {set;}

See Also

FileSet Class | NAnt.Core.Types Namespace


SetIncludesList Property

NAnt SDK Documentation - v0.91

FileSet.SetIncludesList Property

NOTE: This property is now obsolete.

Use <includesfile> instead.

The files from which a list of patterns or files to include should be obtained.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="includesList", Required:=False, ProcessXml:=True), _ Obsolete(Message:="Use <includesfile> instead.", IsError:=False)>
Public WriteOnly Property SetIncludesList As IncludesFile()
[C#]
[BuildElementArray(ElementType=null, Name="includesList", Required=False, ProcessXml=True)]
[Obsolete(Message="Use <includesfile> instead.", IsError=False)]
public FileSet.IncludesFile[] SetIncludesList {set;}

See Also

FileSet Class | NAnt.Core.Types Namespace


FileSet Methods

The methods of the FileSet class are listed below. For a complete list of FileSet class members, see the FileSet Members topic.

Public Static (Shared) Methods

FindMoreRecentLastWriteTime Overloaded. Determines if a file has a more recent last write time than the given time, or no longer exists.

Public Instance Methods

AddPatternSet | Adds a nested set of patterns, or references a standalone patternset.
Clone | Creates a shallow copy of the FileSet.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset |
Scan |
ToString |

Protected Instance Methods

CopyTo | Overloaded. Copies all instance data of the FileSet to a given FileSet.
CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileSet Class | NAnt.Core.Types Namespace | PatternSet


FileSet.AddPatternSet Method

Adds a nested set of patterns, or references a standalone patternset.

[Visual Basic]
<BuildElement(Name:="patternset", Required:=False, ProcessXml:=True)>
Public Sub AddPatternSet( _
ByVal patternSet As PatternSet _
)
[C#]
[BuildElement(Name="patternset", Required=False, ProcessXml=True)]
public void AddPatternSet(
PatternSet patternSet
);

See Also

FileSet Class | NAnt.Core.Types Namespace


FileSet.Clone Method

Creates a shallow copy of the FileSet.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();

Return Value

A shallow copy of the FileSet.

See Also

FileSet Class | NAnt.Core.Types Namespace


CopyTo Method

NAnt SDK Documentation - v0.91

FileSet.CopyTo Method

Copies all instance data of the FileSet to a given FileSet.

Overload List

Inherited from DataTypeBase.

protected void CopyTo(DataTypeBase);

Inherited from Element.

protected void CopyTo(Element);

Copies all instance data of the FileSet to a given FileSet.

protected void CopyTo(FileSet);

See Also

FileSet Class | NAnt.Core.Types Namespace


FileSet.CopyTo Method (FileSet)

Copies all instance data of the FileSet to a given FileSet.

[Visual Basic]
Overloads Protected Sub CopyTo( _
ByVal clone As FileSet _
)
[C#]
protected void CopyTo(
FileSet clone
);

See Also

FileSet Class | NAnt.Core.Types Namespace | FileSet.CopyTo Overload List


FindMoreRecentLastWriteTime Method

NAnt SDK Documentation - v0.91

FileSet.FindMoreRecentLastWriteTime Method

Determines if one of the given files has a more recent last write time than the given time. If one of the given files no longer exists, the target will be considered out-of-date.

Overload List

Determines if one of the given files has a more recent last write time than the given time. If one of the given files no longer exists, the target will be considered out-of-date.

public static string FindMoreRecentLastWriteTime(StringCollection,DateTime);

Determines if a file has a more recent last write time than the given time, or no longer exists.

public static string FindMoreRecentLastWriteTime(string,DateTime);

See Also

FileSet Class | NAnt.Core.Types Namespace


FileSet.FindMoreRecentLastWriteTime Method (StringCollection, DateTime)

Determines if one of the given files has a more recent last write time than the given time. If one of the given files no longer exists, the target will be considered out-of-date.

[Visual Basic]
Overloads Public Shared Function FindMoreRecentLastWriteTime( _
ByVal fileNames As StringCollection, _
ByVal targetLastWriteTime As Date _
) As String
[C#]
public static string FindMoreRecentLastWriteTime(
StringCollection fileNames,
DateTime targetLastWriteTime
);

Parameters

fileNames
A collection of filenames to check the last write time against.
targetLastWriteTime
The datetime to compare against.

Return Value

The name of the first file that has a last write time greater than targetLastWriteTime; otherwise, null.

See Also

FileSet Class | NAnt.Core.Types Namespace | FileSet.FindMoreRecentLastWriteTime Overload List


FileSet.FindMoreRecentLastWriteTime Method (String, DateTime)

Determines if a file has a more recent last write time than the given time, or no longer exists.

[Visual Basic]
Overloads Public Shared Function FindMoreRecentLastWriteTime( _
ByVal fileName As String, _
ByVal targetLastWriteTime As Date _
) As String
[C#]
public static string FindMoreRecentLastWriteTime(
string fileName,
DateTime targetLastWriteTime
);

Parameters

fileName
A file to check the last write time against.
targetLastWriteTime
The datetime to compare against.

Return Value

The name of the file that has a last write time greater than targetLastWriteTime or that no longer exists; otherwise, a null reference (Nothing in Visual Basic).

See Also

FileSet Class | NAnt.Core.Types Namespace | FileSet.FindMoreRecentLastWriteTime Overload List


Initialize Method

NAnt SDK Documentation - v0.91

FileSet.Initialize Method

Overload List

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

FileSet Class | NAnt.Core.Types Namespace


FileSet.Initialize Method ()

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

FileSet Class | NAnt.Core.Types Namespace | FileSet.Initialize Overload List


FileSet.Reset Method

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();

See Also

FileSet Class | NAnt.Core.Types Namespace


FileSet.Scan Method

[Visual Basic]
Overridable Public Sub Scan()
[C#]
public virtual void Scan();

See Also

FileSet Class | NAnt.Core.Types Namespace


FileSet.ToString Method

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

FileSet Class | NAnt.Core.Types Namespace


FileSet.Exclude Class

For a list of all members of this type, see FileSet.Exclude Members.

System.Object
NAnt.Core.Element
NAnt.Core.Types.FileSet.Exclude
NAnt.Core.Types.FileSet.Include

[Visual Basic]
Public Class FileSet.Exclude
Inherits Element
[C#]
public class FileSet.Exclude : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FileSet.Exclude Members | NAnt.Core.Types Namespace


FileSet.Exclude Members

FileSet.Exclude overview

Public Instance Constructors

FileSet.Exclude Constructor Initializes a new instance of the FileSet.Exclude class.

Public Instance Properties

IfDefined | If true then the pattern will be excluded; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Pattern | The pattern or file name to exclude.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Opposite of IfDefined. If false then the pattern will be excluded; otherwise, skipped. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileSet.Exclude Class | NAnt.Core.Types Namespace


FileSet.Exclude Constructor

Initializes a new instance of the FileSet.Exclude class.

[Visual Basic]
Public Sub New()
[C#]
public FileSet.Exclude();

See Also

FileSet.Exclude Class | NAnt.Core.Types Namespace


FileSet.Exclude Properties

The properties of the FileSet.Exclude class are listed below. For a complete list of FileSet.Exclude class members, see the FileSet.Exclude Members topic.

Public Instance Properties

IfDefined | If true then the pattern will be excluded; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Pattern | The pattern or file name to exclude.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Opposite of IfDefined. If false then the pattern will be excluded; otherwise, skipped. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

FileSet.Exclude Class | NAnt.Core.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

FileSet.Exclude.IfDefined Property

If true then the pattern will be excluded; otherwise, skipped. The default is true.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="if", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Overridable Public Property IfDefined As Boolean
[C#]
[TaskAttribute(Required=False, Name="if", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public virtual bool IfDefined {get; set;}

See Also

FileSet.Exclude Class | NAnt.Core.Types Namespace


Pattern Property

NAnt SDK Documentation - v0.91

FileSet.Exclude.Pattern Property

The pattern or file name to exclude.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Required:=True, Name:="name", ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property Pattern As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Required=True, Name="name", ExpandProperties=True, ProcessXml=True)]
public virtual string Pattern {get; set;}

See Also

FileSet.Exclude Class | NAnt.Core.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

FileSet.Exclude.UnlessDefined Property

Opposite of IfDefined. If false then the pattern will be excluded; otherwise, skipped. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="unless", ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property UnlessDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="unless", ExpandProperties=True, ProcessXml=True)]
public virtual bool UnlessDefined {get; set;}

See Also

FileSet.Exclude Class | NAnt.Core.Types Namespace


FileSet.ExcludesFile Class

For a list of all members of this type, see FileSet.ExcludesFile Members.

System.Object
NAnt.Core.Element
NAnt.Core.Types.FileSet.ExcludesFile
NAnt.Core.Types.FileSet.IncludesFile

[Visual Basic]
Public Class FileSet.ExcludesFile
Inherits Element
[C#]
public class FileSet.ExcludesFile : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FileSet.ExcludesFile Members | NAnt.Core.Types Namespace


FileSet.ExcludesFile Members

FileSet.ExcludesFile overview

Public Instance Constructors

FileSet.ExcludesFile Constructor Initializes a new instance of the FileSet.ExcludesFile class.

Public Instance Properties

IfDefined | If true then the patterns will be excluded; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PatternFile | The name of a file; each line of this file is taken to be a pattern.
Patterns | Gets the list of patterns in PatternFile.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Opposite of IfDefined. If false then the patterns will be excluded; otherwise, skipped. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileSet.ExcludesFile Class | NAnt.Core.Types Namespace


FileSet.ExcludesFile Constructor

Initializes a new instance of the FileSet.ExcludesFile class.

[Visual Basic]
Public Sub New()
[C#]
public FileSet.ExcludesFile();

See Also

FileSet.ExcludesFile Class | NAnt.Core.Types Namespace


FileSet.ExcludesFile Properties

The properties of the FileSet.ExcludesFile class are listed below. For a complete list of FileSet.ExcludesFile class members, see the FileSet.ExcludesFile Members topic.

Public Instance Properties

IfDefined | If true then the patterns will be excluded; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PatternFile | The name of a file; each line of this file is taken to be a pattern.
Patterns | Gets the list of patterns in PatternFile.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Opposite of IfDefined. If false then the patterns will be excluded; otherwise, skipped. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

FileSet.ExcludesFile Class | NAnt.Core.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

FileSet.ExcludesFile.IfDefined Property

If true then the patterns will be excluded; otherwise, skipped. The default is true.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="if", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Overridable Public Property IfDefined As Boolean
[C#]
[TaskAttribute(Required=False, Name="if", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public virtual bool IfDefined {get; set;}

See Also

FileSet.ExcludesFile Class | NAnt.Core.Types Namespace


PatternFile Property

NAnt SDK Documentation - v0.91

FileSet.ExcludesFile.PatternFile Property

The name of a file; each line of this file is taken to be a pattern.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="name", ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property PatternFile As FileInfo
[C#]
[TaskAttribute(Required=True, Name="name", ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public System.IO.FileInfo PatternFile {get; set;}

See Also

FileSet.ExcludesFile Class | NAnt.Core.Types Namespace


Patterns Property

NAnt SDK Documentation - v0.91

FileSet.ExcludesFile.Patterns Property

Gets the list of patterns in PatternFile.

[Visual Basic]
Public ReadOnly Property Patterns As StringCollection
[C#]
public System.Collections.Specialized.StringCollection Patterns {get;}

See Also

FileSet.ExcludesFile Class | NAnt.Core.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

FileSet.ExcludesFile.UnlessDefined Property

Opposite of IfDefined. If false then the patterns will be excluded; otherwise, skipped. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="unless", ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property UnlessDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="unless", ExpandProperties=True, ProcessXml=True)]
public virtual bool UnlessDefined {get; set;}

See Also

FileSet.ExcludesFile Class | NAnt.Core.Types Namespace


FileSet.Include Class

For a list of all members of this type, see FileSet.Include Members.

System.Object
NAnt.Core.Element
NAnt.Core.Types.FileSet.Exclude
NAnt.Core.Types.FileSet.Include

[Visual Basic]
Public Class FileSet.Include
Inherits Exclude
[C#]
public class FileSet.Include : Exclude

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FileSet.Include Members | NAnt.Core.Types Namespace


FileSet.Include Members

FileSet.Include overview

Public Instance Constructors

FileSet.Include Constructor Initializes a new instance of the FileSet.Include class.

Public Instance Properties

AsIs | If true then the file name will be added to the FileSet without pattern matching or checking if the file exists. The default is false.
FromPath | If true then the file will be searched for on the path. The default is false.
IfDefined | If true then the pattern will be included; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Pattern | The pattern or file name to include.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Opposite of IfDefined. If false then the pattern will be included; otherwise, skipped. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileSet.Include Class | NAnt.Core.Types Namespace


FileSet.Include Constructor

Initializes a new instance of the FileSet.Include class.

[Visual Basic]
Public Sub New()
[C#]
public FileSet.Include();

See Also

FileSet.Include Class | NAnt.Core.Types Namespace


FileSet.Include Properties

The properties of the FileSet.Include class are listed below. For a complete list of FileSet.Include class members, see the FileSet.Include Members topic.

Public Instance Properties

AsIs | If true then the file name will be added to the FileSet without pattern matching or checking if the file exists. The default is false.
FromPath | If true then the file will be searched for on the path. The default is false.
IfDefined | If true then the pattern will be included; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Pattern | The pattern or file name to include.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Opposite of IfDefined. If false then the pattern will be included; otherwise, skipped. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

FileSet.Include Class | NAnt.Core.Types Namespace


AsIs Property

NAnt SDK Documentation - v0.91

FileSet.Include.AsIs Property

If true then the file name will be added to the FileSet without pattern matching or checking if the file exists. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="asis", ExpandProperties:=True, ProcessXml:=True)>
Public Property AsIs As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="asis", ExpandProperties=True, ProcessXml=True)]
public bool AsIs {get; set;}

See Also

FileSet.Include Class | NAnt.Core.Types Namespace


FromPath Property

NAnt SDK Documentation - v0.91

FileSet.Include.FromPath Property

If true then the file will be searched for on the path. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="frompath", ExpandProperties:=True, ProcessXml:=True)>
Public Property FromPath As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="frompath", ExpandProperties=True, ProcessXml=True)]
public bool FromPath {get; set;}

See Also

FileSet.Include Class | NAnt.Core.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

FileSet.Include.IfDefined Property

If true then the pattern will be included; otherwise, skipped. The default is true.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="if", ExpandProperties:=True, ProcessXml:=True)>
Overrides Public Property IfDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="if", ExpandProperties=True, ProcessXml=True)]
public override bool IfDefined {get; set;}

See Also

FileSet.Include Class | NAnt.Core.Types Namespace


Pattern Property

NAnt SDK Documentation - v0.91

FileSet.Include.Pattern Property

The pattern or file name to include.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="name", ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Overrides Public Property Pattern As String
[C#]
[TaskAttribute(Required=True, Name="name", ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public override string Pattern {get; set;}

See Also

FileSet.Include Class | NAnt.Core.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

FileSet.Include.UnlessDefined Property

Opposite of IfDefined. If false then the pattern will be included; otherwise, skipped. The default is false.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="unless", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Overrides Public Property UnlessDefined As Boolean
[C#]
[TaskAttribute(Required=False, Name="unless", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public override bool UnlessDefined {get; set;}

See Also

FileSet.Include Class | NAnt.Core.Types Namespace


FileSet.IncludesFile Class

For a list of all members of this type, see FileSet.IncludesFile Members.

System.Object
NAnt.Core.Element
NAnt.Core.Types.FileSet.ExcludesFile
NAnt.Core.Types.FileSet.IncludesFile

[Visual Basic]
Public Class FileSet.IncludesFile
Inherits ExcludesFile
[C#]
public class FileSet.IncludesFile : ExcludesFile

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FileSet.IncludesFile Members | NAnt.Core.Types Namespace


FileSet.IncludesFile Members

FileSet.IncludesFile overview

Public Instance Constructors

FileSet.IncludesFile Constructor Initializes a new instance of the FileSet.IncludesFile class.

Public Instance Properties

AsIs | If true then the patterns in the include file will be added to the FileSet without pattern matching or checking if the file exists. The default is false.
FromPath | If true then the patterns in the include file will be searched for on the path. The default is false.
IfDefined | If true then the patterns will be included; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PatternFile (inherited from ExcludesFile) | The name of a file; each line of this file is taken to be a pattern.
Patterns (inherited from ExcludesFile) | Gets the list of patterns in PatternFile.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Opposite of IfDefined. If false then the patterns will be included; otherwise, skipped. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileSet.IncludesFile Class | NAnt.Core.Types Namespace


FileSet.IncludesFile Constructor

Initializes a new instance of the FileSet.IncludesFile class.

[Visual Basic]
Public Sub New()
[C#]
public FileSet.IncludesFile();

See Also

FileSet.IncludesFile Class | NAnt.Core.Types Namespace


FileSet.IncludesFile Properties

The properties of the FileSet.IncludesFile class are listed below. For a complete list of FileSet.IncludesFile class members, see the FileSet.IncludesFile Members topic.

Public Instance Properties

AsIs | If true then the patterns in the include file will be added to the FileSet without pattern matching or checking if the file exists. The default is false.
FromPath | If true then the patterns in the include file will be searched for on the path. The default is false.
IfDefined | If true then the patterns will be included; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PatternFile (inherited from ExcludesFile) | The name of a file; each line of this file is taken to be a pattern.
Patterns (inherited from ExcludesFile) | Gets the list of patterns in PatternFile.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Opposite of IfDefined. If false then the patterns will be included; otherwise, skipped. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

FileSet.IncludesFile Class | NAnt.Core.Types Namespace


AsIs Property

NAnt SDK Documentation - v0.91

FileSet.IncludesFile.AsIs Property

If true then the patterns in the include file will be added to the FileSet without pattern matching or checking if the file exists. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="asis", ExpandProperties:=True, ProcessXml:=True)>
Public Property AsIs As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="asis", ExpandProperties=True, ProcessXml=True)]
public bool AsIs {get; set;}

See Also

FileSet.IncludesFile Class | NAnt.Core.Types Namespace


FromPath Property

NAnt SDK Documentation - v0.91

FileSet.IncludesFile.FromPath Property

If true then the patterns in the include file will be searched for on the path. The default is false.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="frompath", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property FromPath As Boolean
[C#]
[TaskAttribute(Required=False, Name="frompath", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool FromPath {get; set;}

See Also

FileSet.IncludesFile Class | NAnt.Core.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

FileSet.IncludesFile.IfDefined Property

If true then the patterns will be included; otherwise, skipped. The default is true.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="if", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Overrides Public Property IfDefined As Boolean
[C#]
[TaskAttribute(Required=False, Name="if", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public override bool IfDefined {get; set;}

See Also

FileSet.IncludesFile Class | NAnt.Core.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

FileSet.IncludesFile.UnlessDefined Property

Opposite of IfDefined. If false then the patterns will be included; otherwise, skipped. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="unless", ExpandProperties:=True, ProcessXml:=True)>
Overrides Public Property UnlessDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="unless", ExpandProperties=True, ProcessXml=True)]
public override bool UnlessDefined {get; set;}

See Also

FileSet.IncludesFile Class | NAnt.Core.Types Namespace


Formatter Class

For a list of all members of this type, see Formatter Members.

System.Object
NAnt.Core.Element
NAnt.Core.Types.Formatter

[Visual Basic]
<ElementName(Name:="formatter")>
Public Class Formatter
Inherits Element
[C#]
[ElementName(Name="formatter")]
public class Formatter : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

Formatter Members | NAnt.Core.Types Namespace


Formatter Members

Formatter overview

Public Instance Constructors

Formatter Constructor Initializes a new instance of the Formatter class.

Public Instance Properties

IfDefined | Indicates if the formatter should be used to format the timestamp. If true then the formatter will be used; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Pattern | The string pattern to use to format the property.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Property | The name of the NAnt property to set.
UnlessDefined | Indicates if the formatter should be not used to format the timestamp. If false then the formatter will be used; otherwise, skipped. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Formatter Class | NAnt.Core.Types Namespace


Formatter Constructor

Initializes a new instance of the Formatter class.

[Visual Basic]
Public Sub New()
[C#]
public Formatter();

See Also

Formatter Class | NAnt.Core.Types Namespace


Formatter Properties

The properties of the Formatter class are listed below. For a complete list of Formatter class members, see the Formatter Members topic.

Public Instance Properties

IfDefined | Indicates if the formatter should be used to format the timestamp. If true then the formatter will be used; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Pattern | The string pattern to use to format the property.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Property | The name of the NAnt property to set.
UnlessDefined | Indicates if the formatter should be not used to format the timestamp. If false then the formatter will be used; otherwise, skipped. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

Formatter Class | NAnt.Core.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

Formatter.IfDefined Property

Indicates if the formatter should be used to format the timestamp. If true then the formatter will be used; otherwise, skipped. The default is true.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="if", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property IfDefined As Boolean
[C#]
[TaskAttribute(Required=False, Name="if", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool IfDefined {get; set;}

See Also

Formatter Class | NAnt.Core.Types Namespace


Pattern Property

NAnt SDK Documentation - v0.91

Formatter.Pattern Property

The string pattern to use to format the property.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="pattern", ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property Pattern As String
[C#]
[TaskAttribute(Required=True, Name="pattern", ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string Pattern {get; set;}

See Also

Formatter Class | NAnt.Core.Types Namespace


Property Property

NAnt SDK Documentation - v0.91

Formatter.Property Property

The name of the NAnt property to set.

[Visual Basic]
<TaskAttribute(Name:="property", Required:=True, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property Property As String
[C#]
[TaskAttribute(Name="property", Required=True, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string Property {get; set;}

See Also

Formatter Class | NAnt.Core.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

Formatter.UnlessDefined Property

Indicates if the formatter should be not used to format the timestamp. If false then the formatter will be used; otherwise, skipped. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="unless", ExpandProperties:=True, ProcessXml:=True)>
Public Property UnlessDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="unless", ExpandProperties=True, ProcessXml=True)]
public bool UnlessDefined {get; set;}

See Also

Formatter Class | NAnt.Core.Types Namespace


FormatterCollection Class

Contains a collection of Formatter elements.

For a list of all members of this type, see FormatterCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.Core.Types.FormatterCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class FormatterCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class FormatterCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FormatterCollection Members | NAnt.Core.Types Namespace


FormatterCollection Members

FormatterCollection overview

Public Instance Constructors

FormatterCollection Overloaded. Initializes a new instance of the FormatterCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a Formatter to the end of the collection.
AddRange | Overloaded. Adds the elements of a Formatter array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a Formatter is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified Formatter object in the collection.
Insert | Inserts a Formatter into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

FormatterCollection Class | NAnt.Core.Types Namespace


FormatterCollection Constructor

Initializes a new instance of the FormatterCollection class.

Overload List

Initializes a new instance of the FormatterCollection class.

public FormatterCollection();

Initializes a new instance of the FormatterCollection class with the specified array of Formatter instances.

public FormatterCollection(Formatter[]);

Initializes a new instance of the FormatterCollection class with the specified FormatterCollection instance.

public FormatterCollection(FormatterCollection);

See Also

FormatterCollection Class | NAnt.Core.Types Namespace


FormatterCollection Constructor ()

Initializes a new instance of the FormatterCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FormatterCollection();

See Also

FormatterCollection Class | NAnt.Core.Types Namespace | FormatterCollection Constructor Overload List


FormatterCollection Constructor (FormatterCollection)

Initializes a new instance of the FormatterCollection class with the specified FormatterCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As FormatterCollection _
)
[C#]
public FormatterCollection(
FormatterCollection value
);

See Also

FormatterCollection Class | NAnt.Core.Types Namespace | FormatterCollection Constructor Overload List


FormatterCollection Constructor (Formatter[])

Initializes a new instance of the FormatterCollection class with the specified array of Formatter instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As Formatter() _
)
[C#]
public FormatterCollection(
Formatter[] value
);

See Also

FormatterCollection Class | NAnt.Core.Types Namespace | FormatterCollection Constructor Overload List


FormatterCollection Properties

The properties of the FormatterCollection class are listed below. For a complete list of FormatterCollection class members, see the FormatterCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

FormatterCollection Class | NAnt.Core.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

FormatterCollection.Item Property

Gets or sets the element at the specified index.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As Formatter
[C#]
public Formatter this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

FormatterCollection Class | NAnt.Core.Types Namespace


FormatterCollection Methods

The methods of the FormatterCollection class are listed below. For a complete list of FormatterCollection class members, see the FormatterCollection Members topic.

Public Instance Methods

Add | Adds a Formatter to the end of the collection.
AddRange | Overloaded. Adds the elements of a Formatter array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a Formatter is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified Formatter object in the collection.
Insert | Inserts a Formatter into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

FormatterCollection Class | NAnt.Core.Types Namespace


FormatterCollection.Add Method

Adds a Formatter to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As Formatter _
) As Integer
[C#]
public int Add(
Formatter item
);

Parameters

item
The Formatter to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

FormatterCollection Class | NAnt.Core.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

FormatterCollection.AddRange Method

Adds the elements of a Formatter array to the end of the collection.

Overload List

Adds the elements of a Formatter array to the end of the collection.

public void AddRange(Formatter[]);

Adds the elements of a FormatterCollection to the end of the collection.

public void AddRange(FormatterCollection);

See Also

FormatterCollection Class | NAnt.Core.Types Namespace


FormatterCollection.AddRange Method (Formatter[])

Adds the elements of a Formatter array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As Formatter() _
)
[C#]
public void AddRange(
Formatter[] items
);

Parameters

items
The array of Formatter elements to be added to the end of the collection.

See Also

FormatterCollection Class | NAnt.Core.Types Namespace | FormatterCollection.AddRange Overload List


FormatterCollection.AddRange Method (FormatterCollection)

Adds the elements of a FormatterCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As FormatterCollection _
)
[C#]
public void AddRange(
FormatterCollection items
);

Parameters

items
The FormatterCollection to be added to the end of the collection.

See Also

FormatterCollection Class | NAnt.Core.Types Namespace | FormatterCollection.AddRange Overload List


FormatterCollection.Contains Method

Determines whether a Formatter is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal item As Formatter _
) As Boolean
[C#]
public bool Contains(
Formatter item
);

Parameters

item
The Formatter to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

FormatterCollection Class | NAnt.Core.Types Namespace


FormatterCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As Formatter(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
Formatter[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

FormatterCollection Class | NAnt.Core.Types Namespace


FormatterCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As FormatterEnumerator
[C#]
new public FormatterEnumerator GetEnumerator();

Return Value

A FormatterEnumerator for the entire collection.

See Also

FormatterCollection Class | NAnt.Core.Types Namespace


FormatterCollection.IndexOf Method

Retrieves the index of a specified Formatter object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As Formatter _
) As Integer
[C#]
public int IndexOf(
Formatter item
);

Parameters

item
The Formatter object for which the index is returned.

Return Value

The index of the specified Formatter. If the Formatter is not currently a member of the collection, it returns -1.

See Also

FormatterCollection Class | NAnt.Core.Types Namespace


FormatterCollection.Insert Method

Inserts a Formatter into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As Formatter _
)
[C#]
public void Insert(
int index,
Formatter item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The Formatter to insert.

See Also

FormatterCollection Class | NAnt.Core.Types Namespace


FormatterCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As Formatter _
)
[C#]
public void Remove(
Formatter item
);

Parameters

item
The Formatter to remove from the collection.

See Also

FormatterCollection Class | NAnt.Core.Types Namespace


FormatterEnumerator Class

Enumerates the Formatter elements of a FormatterCollection.

For a list of all members of this type, see FormatterEnumerator Members.

System.Object
NAnt.Core.Types.FormatterEnumerator

[Visual Basic]
Public Class FormatterEnumerator
Implements IEnumerator
[C#]
public class FormatterEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FormatterEnumerator Members | NAnt.Core.Types Namespace


FormatterEnumerator Members

FormatterEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FormatterEnumerator Class | NAnt.Core.Types Namespace


FormatterEnumerator Properties

The properties of the FormatterEnumerator class are listed below. For a complete list of FormatterEnumerator class members, see the FormatterEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

FormatterEnumerator Class | NAnt.Core.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

FormatterEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As Formatter
[C#]
public Formatter Current {get;}

See Also

FormatterEnumerator Class | NAnt.Core.Types Namespace


FormatterEnumerator Methods

The methods of the FormatterEnumerator class are listed below. For a complete list of FormatterEnumerator class members, see the FormatterEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FormatterEnumerator Class | NAnt.Core.Types Namespace


FormatterEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

FormatterEnumerator Class | NAnt.Core.Types Namespace


FormatterEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

FormatterEnumerator Class | NAnt.Core.Types Namespace


ManagedExecution Enumeration

Specifies the execution mode for managed applications.

[Visual Basic]
<Serializable, _ TypeConverter(ConverterTypeName:="NAnt.Core.Types.ManagedExecutionConverter, NAnt.Core, Version=0.91.4312.0, Culture=neutral, PublicKeyToken=null")>
Public Enum ManagedExecution
[C#]
[Serializable]
[TypeConverter(ConverterTypeName="NAnt.Core.Types.ManagedExecutionConverter, NAnt.Core, Version=0.91.4312.0, Culture=neutral, PublicKeyToken=null")]
public enum ManagedExecution

Remarks

For backward compatibility, the following string values can also be used in build files:

Value | Corresponding field
"true" | Auto
"false" | Default

Even if set to Default, the operating system can still run the program as a managed application.

On Linux this can be done through binfmt_misc, while on Windows installing the .NET Framework redistributable caused managed applications to run on the MS CLR by default.

Members

Member Name | Description
Default | Do not threat the program as a managed application.
Auto | Leave it up to the CLR to determine which specific version of the CLR will be used to run the application.
Strict | Forces an application to run against the currently targeted version of a given CLR.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

NAnt.Core.Types Namespace


ManagedExecutionConverter Class

Specialized EnumConverter that also supports case-insensitive conversion of "true" to Auto and "false" to Default.

For a list of all members of this type, see ManagedExecutionConverter Members.

System.Object
System.ComponentModel.TypeConverter
System.ComponentModel.EnumConverter
NAnt.Core.Types.ManagedExecutionConverter

[Visual Basic]
Public Class ManagedExecutionConverter
Inherits EnumConverter
[C#]
public class ManagedExecutionConverter : EnumConverter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ManagedExecutionConverter Members | NAnt.Core.Types Namespace


ManagedExecutionConverter Members

ManagedExecutionConverter overview

Public Instance Constructors

ManagedExecutionConverter Constructor Initializes a new instance of the ManagedExecutionConverter class.

Public Instance Methods

CanConvertFrom (inherited from EnumConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to an enumeration object using the specified context.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from EnumConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type using the context.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type.
ConvertFrom | Overloaded. Converts the given object to the type of this converter, using the specified context and culture information.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from EnumConverter) | Overloaded. Converts the given value object to the specified destination type.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the arguments.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Re-creates an Object given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties.
GetStandardValues (inherited from EnumConverter) | Overloaded. Gets a collection of standard values for the data type this validator is designed for.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from EnumConverter) | Overloaded. Gets a value indicating whether the list of standard values returned from GetStandardValues is an exclusive list using the specified context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from EnumConverter) | Overloaded. Gets a value indicating whether this object supports a standard set of values that can be picked from a list using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from EnumConverter) | Overloaded. Gets a value indicating whether the given object value is valid for this type.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Comparer (inherited from EnumConverter) | Gets an IComparer that can be used to sort the values of the enumeration.
EnumType (inherited from EnumConverter) | Specifies the type of the enumerator this converter is associated with.
Values (inherited from EnumConverter) | Gets or sets a StandardValuesCollection that specifies the possible values for the enumeration.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

ManagedExecutionConverter Class | NAnt.Core.Types Namespace


ManagedExecutionConverter Constructor

Initializes a new instance of the ManagedExecutionConverter class.

[Visual Basic]
Public Sub New()
[C#]
public ManagedExecutionConverter();

See Also

ManagedExecutionConverter Class | NAnt.Core.Types Namespace


ManagedExecutionConverter Methods

The methods of the ManagedExecutionConverter class are listed below. For a complete list of ManagedExecutionConverter class members, see the ManagedExecutionConverter Members topic.

Public Instance Methods

CanConvertFrom (inherited from EnumConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to an enumeration object using the specified context.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from EnumConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type using the context.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type.
ConvertFrom | Overloaded. Converts the given object to the type of this converter, using the specified context and culture information.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from EnumConverter) | Overloaded. Converts the given value object to the specified destination type.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the arguments.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Re-creates an Object given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties.
GetStandardValues (inherited from EnumConverter) | Overloaded. Gets a collection of standard values for the data type this validator is designed for.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from EnumConverter) | Overloaded. Gets a value indicating whether the list of standard values returned from GetStandardValues is an exclusive list using the specified context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from EnumConverter) | Overloaded. Gets a value indicating whether this object supports a standard set of values that can be picked from a list using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from EnumConverter) | Overloaded. Gets a value indicating whether the given object value is valid for this type.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

ManagedExecutionConverter Class | NAnt.Core.Types Namespace


ConvertFrom Method

NAnt SDK Documentation - v0.91

ManagedExecutionConverter.ConvertFrom Method

Converts the given object to the type of this converter, using the specified context and culture information.

Overload List

Converts the given object to the type of this converter, using the specified context and culture information.

public override object ConvertFrom(ITypeDescriptorContext,CultureInfo,object);

Inherited from TypeConverter.

public object ConvertFrom(object);

See Also

ManagedExecutionConverter Class | NAnt.Core.Types Namespace


ManagedExecutionConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts the given object to the type of this converter, using the specified context and culture information.

[Visual Basic]
Overrides Overloads Public Function ConvertFrom( _
ByVal context As ITypeDescriptorContext, _
ByVal culture As CultureInfo, _
ByVal value As Object _
) As Object
[C#]
public override object ConvertFrom(
ITypeDescriptorContext context,
CultureInfo culture,
object value
);

Parameters

context
An ITypeDescriptorContext that provides a format context.
culture
A CultureInfo object. If a a null reference (Nothing in Visual Basic) is passed, the current culture is assumed.
value
The Object to convert.

Return Value

An Object that represents the converted value.

See Also

ManagedExecutionConverter Class | NAnt.Core.Types Namespace | ManagedExecutionConverter.ConvertFrom Overload List


Option Class

Represents an option.

For a list of all members of this type, see Option Members.

System.Object
NAnt.Core.Element
NAnt.Core.Types.Option

[Visual Basic]
<ElementName(Name:="option")>
Public Class Option
Inherits Element
[C#]
[ElementName(Name="option")]
public class Option : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

Option Members | NAnt.Core.Types Namespace


Option Members

Option overview

Public Instance Constructors

Option Overloaded. Initializes a new instance of the Option class.

Public Instance Properties

IfDefined | Indicates if the option should be passed to the task. If true then the option will be passed; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OptionName | Name of the option.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Indicates if the option should not be passed to the task. If false then the option will be passed; otherwise, skipped. The default is false.
Value | Value of the option. The default is a null reference (Nothing in Visual Basic).

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Option Class | NAnt.Core.Types Namespace


Option Constructor

name, value constructor

Overload List

Default constructor

public Option();

name, value constructor

public Option(string,string);

See Also

Option Class | NAnt.Core.Types Namespace


Option Constructor (String, String)

name, value constructor

[Visual Basic]
Overloads Public Sub New( _
ByVal name As String, _
ByVal value As String _
)
[C#]
public Option(
string name,
string value
);

Parameters

name
value

See Also

Option Class | NAnt.Core.Types Namespace | Option Constructor Overload List


Option Constructor ()

Default constructor

[Visual Basic]
Overloads Public Sub New()
[C#]
public Option();

See Also

Option Class | NAnt.Core.Types Namespace | Option Constructor Overload List


Option Properties

The properties of the Option class are listed below. For a complete list of Option class members, see the Option Members topic.

Public Instance Properties

IfDefined | Indicates if the option should be passed to the task. If true then the option will be passed; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OptionName | Name of the option.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Indicates if the option should not be passed to the task. If false then the option will be passed; otherwise, skipped. The default is false.
Value | Value of the option. The default is a null reference (Nothing in Visual Basic).

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

Option Class | NAnt.Core.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

Option.IfDefined Property

Indicates if the option should be passed to the task. If true then the option will be passed; otherwise, skipped. The default is true.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="if", ExpandProperties:=True, ProcessXml:=True)>
Public Property IfDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="if", ExpandProperties=True, ProcessXml=True)]
public bool IfDefined {get; set;}

See Also

Option Class | NAnt.Core.Types Namespace


OptionName Property

NAnt SDK Documentation - v0.91

Option.OptionName Property

Name of the option.

[Visual Basic]
<TaskAttribute(Name:="name", Required:=True, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property OptionName As String
[C#]
[TaskAttribute(Name="name", Required=True, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string OptionName {get; set;}

See Also

Option Class | NAnt.Core.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

Option.UnlessDefined Property

Indicates if the option should not be passed to the task. If false then the option will be passed; otherwise, skipped. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="unless", ExpandProperties:=True, ProcessXml:=True)>
Public Property UnlessDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="unless", ExpandProperties=True, ProcessXml=True)]
public bool UnlessDefined {get; set;}

See Also

Option Class | NAnt.Core.Types Namespace


Value Property

NAnt SDK Documentation - v0.91

Option.Value Property

Value of the option. The default is a null reference (Nothing in Visual Basic).

[Visual Basic]
<TaskAttribute(Required:=False, Name:="value", ExpandProperties:=True, ProcessXml:=True)>
Public Property Value As String
[C#]
[TaskAttribute(Required=False, Name="value", ExpandProperties=True, ProcessXml=True)]
public string Value {get; set;}

See Also

Option Class | NAnt.Core.Types Namespace


OptionCollection Class

Contains a collection of Option elements.

For a list of all members of this type, see OptionCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.Core.Types.OptionCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class OptionCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class OptionCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

OptionCollection Members | NAnt.Core.Types Namespace


OptionCollection Members

OptionCollection overview

Public Instance Constructors

OptionCollection Overloaded. Initializes a new instance of the OptionCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a Option to the end of the collection.
AddRange | Overloaded. Adds the elements of a Option array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a Option is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified Option object in the collection.
Insert | Inserts a Option into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

OptionCollection Class | NAnt.Core.Types Namespace


OptionCollection Constructor

Initializes a new instance of the OptionCollection class.

Overload List

Initializes a new instance of the OptionCollection class.

public OptionCollection();

Initializes a new instance of the OptionCollection class with the specified array of Option instances.

public OptionCollection(Option[]);

Initializes a new instance of the OptionCollection class with the specified OptionCollection instance.

public OptionCollection(OptionCollection);

See Also

OptionCollection Class | NAnt.Core.Types Namespace


OptionCollection Constructor ()

Initializes a new instance of the OptionCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public OptionCollection();

See Also

OptionCollection Class | NAnt.Core.Types Namespace | OptionCollection Constructor Overload List


OptionCollection Constructor (OptionCollection)

Initializes a new instance of the OptionCollection class with the specified OptionCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As OptionCollection _
)
[C#]
public OptionCollection(
OptionCollection value
);

See Also

OptionCollection Class | NAnt.Core.Types Namespace | OptionCollection Constructor Overload List


OptionCollection Constructor (Option[])

Initializes a new instance of the OptionCollection class with the specified array of Option instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As Option() _
)
[C#]
public OptionCollection(
Option[] value
);

See Also

OptionCollection Class | NAnt.Core.Types Namespace | OptionCollection Constructor Overload List


OptionCollection Properties

The properties of the OptionCollection class are listed below. For a complete list of OptionCollection class members, see the OptionCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

OptionCollection Class | NAnt.Core.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

OptionCollection.Item Property

Gets or sets the element at the specified index.

Overload List

Gets or sets the element at the specified index.

public Option this[int] {get; set;}

Gets the Option with the specified name.

public Option this[string] {get;}

See Also

OptionCollection Class | NAnt.Core.Types Namespace


Item Property (Int32)

NAnt SDK Documentation - v0.91

OptionCollection.Item Property (Int32)

Gets or sets the element at the specified index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As Option
[C#]
public Option this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

OptionCollection Class | NAnt.Core.Types Namespace | OptionCollection.Item Overload List


Item Property (String)

NAnt SDK Documentation - v0.91

OptionCollection.Item Property (String)

Gets the Option with the specified name.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal name As String _
) As Option
[C#]
public Option this[
string name
] {get;}

Parameters

name
The name of the option that should be located in the collection.

See Also

OptionCollection Class | NAnt.Core.Types Namespace | OptionCollection.Item Overload List


OptionCollection Methods

The methods of the OptionCollection class are listed below. For a complete list of OptionCollection class members, see the OptionCollection Members topic.

Public Instance Methods

Add | Adds a Option to the end of the collection.
AddRange | Overloaded. Adds the elements of a Option array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a Option is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified Option object in the collection.
Insert | Inserts a Option into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

OptionCollection Class | NAnt.Core.Types Namespace


OptionCollection.Add Method

Adds a Option to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As Option _
) As Integer
[C#]
public int Add(
Option item
);

Parameters

item
The Option to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

OptionCollection Class | NAnt.Core.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

OptionCollection.AddRange Method

Adds the elements of a Option array to the end of the collection.

Overload List

Adds the elements of a Option array to the end of the collection.

public void AddRange(Option[]);

Adds the elements of a OptionCollection to the end of the collection.

public void AddRange(OptionCollection);

See Also

OptionCollection Class | NAnt.Core.Types Namespace


OptionCollection.AddRange Method (Option[])

Adds the elements of a Option array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As Option() _
)
[C#]
public void AddRange(
Option[] items
);

Parameters

items
The array of Option elements to be added to the end of the collection.

See Also

OptionCollection Class | NAnt.Core.Types Namespace | OptionCollection.AddRange Overload List


OptionCollection.AddRange Method (OptionCollection)

Adds the elements of a OptionCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As OptionCollection _
)
[C#]
public void AddRange(
OptionCollection items
);

Parameters

items
The OptionCollection to be added to the end of the collection.

See Also

OptionCollection Class | NAnt.Core.Types Namespace | OptionCollection.AddRange Overload List


Contains Method

NAnt SDK Documentation - v0.91

OptionCollection.Contains Method

Determines whether a Option is in the collection.

Overload List

Determines whether a Option is in the collection.

public bool Contains(Option);

Determines whether a Option for the specified task is in the collection.

public bool Contains(string);

See Also

OptionCollection Class | NAnt.Core.Types Namespace


OptionCollection.Contains Method (Option)

Determines whether a Option is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal item As Option _
) As Boolean
[C#]
public bool Contains(
Option item
);

Parameters

item
The Option to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

OptionCollection Class | NAnt.Core.Types Namespace | OptionCollection.Contains Overload List


OptionCollection.Contains Method (String)

Determines whether a Option for the specified task is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal taskName As String _
) As Boolean
[C#]
public bool Contains(
string taskName
);

Parameters

taskName
The name of task for which the Option should be located in the collection.

Return Value

true if a Option for the specified task is found in the collection; otherwise, false.

See Also

OptionCollection Class | NAnt.Core.Types Namespace | OptionCollection.Contains Overload List


OptionCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As Option(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
Option[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

OptionCollection Class | NAnt.Core.Types Namespace


OptionCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As OptionEnumerator
[C#]
new public OptionEnumerator GetEnumerator();

Return Value

A OptionEnumerator for the entire collection.

See Also

OptionCollection Class | NAnt.Core.Types Namespace


OptionCollection.IndexOf Method

Retrieves the index of a specified Option object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As Option _
) As Integer
[C#]
public int IndexOf(
Option item
);

Parameters

item
The Option object for which the index is returned.

Return Value

The index of the specified Option. If the Option is not currently a member of the collection, it returns -1.

See Also

OptionCollection Class | NAnt.Core.Types Namespace


OptionCollection.Insert Method

Inserts a Option into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As Option _
)
[C#]
public void Insert(
int index,
Option item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The Option to insert.

See Also

OptionCollection Class | NAnt.Core.Types Namespace


OptionCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As Option _
)
[C#]
public void Remove(
Option item
);

Parameters

item
The Option to remove from the collection.

See Also

OptionCollection Class | NAnt.Core.Types Namespace


OptionEnumerator Class

Enumerates the Option elements of a OptionCollection.

For a list of all members of this type, see OptionEnumerator Members.

System.Object
NAnt.Core.Types.OptionEnumerator

[Visual Basic]
Public Class OptionEnumerator
Implements IEnumerator
[C#]
public class OptionEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

OptionEnumerator Members | NAnt.Core.Types Namespace


OptionEnumerator Members

OptionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OptionEnumerator Class | NAnt.Core.Types Namespace


OptionEnumerator Properties

The properties of the OptionEnumerator class are listed below. For a complete list of OptionEnumerator class members, see the OptionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

OptionEnumerator Class | NAnt.Core.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

OptionEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As Option
[C#]
public Option Current {get;}

See Also

OptionEnumerator Class | NAnt.Core.Types Namespace


OptionEnumerator Methods

The methods of the OptionEnumerator class are listed below. For a complete list of OptionEnumerator class members, see the OptionEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OptionEnumerator Class | NAnt.Core.Types Namespace


OptionEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

OptionEnumerator Class | NAnt.Core.Types Namespace


OptionEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

OptionEnumerator Class | NAnt.Core.Types Namespace


PathElement Class

Represents a nested path element.

For a list of all members of this type, see PathElement Members.

System.Object
NAnt.Core.Element
NAnt.Core.Types.PathElement

[Visual Basic]
<Serializable, _ Serializable, _ ElementName(Name:="pathelement")>
Public Class PathElement
Inherits Element
[C#]
[Serializable]
[Serializable]
[ElementName(Name="pathelement")]
public class PathElement : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

PathElement Members | NAnt.Core.Types Namespace


PathElement Members

PathElement overview

Public Instance Constructors

PathElement Constructor Initializes a new instance of the PathElement class.

Public Instance Properties

Directory | The name of a directory to add to the path. Will be replaced with the absolute path of the directory.
File | The name of a file to add to the path. Will be replaced with the absolute path of the file.
IfDefined | If true then the entry will be added to the path; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Parts | Gets the parts of a path represented by this element.
Path | A string that will be treated as a path-like string. You can use : or ; as path separators and NAnt will convert it to the platform's local conventions, while resolving references to environment variables.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Opposite of IfDefined. If false then the entry will be added to the path; otherwise, skipped. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PathElement Class | NAnt.Core.Types Namespace


PathElement Constructor

Initializes a new instance of the PathElement class.

[Visual Basic]
Public Sub New()
[C#]
public PathElement();

See Also

PathElement Class | NAnt.Core.Types Namespace


PathElement Properties

The properties of the PathElement class are listed below. For a complete list of PathElement class members, see the PathElement Members topic.

Public Instance Properties

Directory | The name of a directory to add to the path. Will be replaced with the absolute path of the directory.
File | The name of a file to add to the path. Will be replaced with the absolute path of the file.
IfDefined | If true then the entry will be added to the path; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Parts | Gets the parts of a path represented by this element.
Path | A string that will be treated as a path-like string. You can use : or ; as path separators and NAnt will convert it to the platform's local conventions, while resolving references to environment variables.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Opposite of IfDefined. If false then the entry will be added to the path; otherwise, skipped. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

PathElement Class | NAnt.Core.Types Namespace


Directory Property

NAnt SDK Documentation - v0.91

PathElement.Directory Property

The name of a directory to add to the path. Will be replaced with the absolute path of the directory.

[Visual Basic]
<TaskAttribute(Name:="dir", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Directory As DirectoryInfo
[C#]
[TaskAttribute(Name="dir", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.DirectoryInfo Directory {get; set;}

See Also

PathElement Class | NAnt.Core.Types Namespace


File Property

NAnt SDK Documentation - v0.91

PathElement.File Property

The name of a file to add to the path. Will be replaced with the absolute path of the file.

[Visual Basic]
<TaskAttribute(Name:="file", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property File As FileInfo
[C#]
[TaskAttribute(Name="file", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo File {get; set;}

See Also

PathElement Class | NAnt.Core.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

PathElement.IfDefined Property

If true then the entry will be added to the path; otherwise, skipped. The default is true.

[Visual Basic]
<TaskAttribute(Name:="if", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property IfDefined As Boolean
[C#]
[TaskAttribute(Name="if", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool IfDefined {get; set;}

See Also

PathElement Class | NAnt.Core.Types Namespace


Parts Property

NAnt SDK Documentation - v0.91

PathElement.Parts Property

Gets the parts of a path represented by this element.

[Visual Basic]
Public ReadOnly Property Parts As StringCollection
[C#]
public System.Collections.Specialized.StringCollection Parts {get;}

Property Value

A StringCollection containing the parts of a path represented by this element.

See Also

PathElement Class | NAnt.Core.Types Namespace


Path Property

NAnt SDK Documentation - v0.91

PathElement.Path Property

A string that will be treated as a path-like string. You can use : or ; as path separators and NAnt will convert it to the platform's local conventions, while resolving references to environment variables.

[Visual Basic]
<TaskAttribute(Name:="path", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Path As PathSet
[C#]
[TaskAttribute(Name="path", Required=False, ExpandProperties=True, ProcessXml=True)]
public PathSet Path {get; set;}

See Also

PathElement Class | NAnt.Core.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

PathElement.UnlessDefined Property

Opposite of IfDefined. If false then the entry will be added to the path; otherwise, skipped. The default is false.

[Visual Basic]
<TaskAttribute(Name:="unless", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property UnlessDefined As Boolean
[C#]
[TaskAttribute(Name="unless", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool UnlessDefined {get; set;}

See Also

PathElement Class | NAnt.Core.Types Namespace


PathElement Methods

The methods of the PathElement class are listed below. For a complete list of PathElement class members, see the PathElement Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PathElement Class | NAnt.Core.Types Namespace


Initialize Method

NAnt SDK Documentation - v0.91

PathElement.Initialize Method

Overload List

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

PathElement Class | NAnt.Core.Types Namespace


PathElement.Initialize Method ()

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

PathElement Class | NAnt.Core.Types Namespace | PathElement.Initialize Overload List


PathSet Class

Paths are groups of files and/or directories that need to be passed as a single unit. The order in which parts of the path are specified in the build file is retained, and duplicate parts are automatically suppressed.

For a list of all members of this type, see PathSet Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.Core.Types.PathSet

[Visual Basic]
<Serializable, _ Serializable, _ ElementName(Name:="path")>
Public Class PathSet
Inherits DataTypeBase
[C#]
[Serializable]
[Serializable]
[ElementName(Name="path")]
public class PathSet : DataTypeBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Define a global <path> that can be referenced by other tasks or types.

                    <path id="includes-path">
                        <pathelement path="%INCLUDE%" />
                        <pathelement dir="${build.dir}/include" />
                    </path>

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

PathSet Members | NAnt.Core.Types Namespace


PathSet Members

PathSet overview

Public Static (Shared) Methods

TranslatePath Splits a PATH (with ; or : as separators) into its parts, while resolving references to environment variables.

Public Instance Constructors

PathSet Overloaded. Initializes a new instance of the PathSet class.

Public Instance Properties

CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.

Public Instance Methods

AddPath | Defines a set of path elements to add to the current path.
AddPathElement | Defines a path element to add to the current path.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetElements | Returns all path elements defined by this path object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from DataTypeBase) | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString | Returns a textual representation of the path, which can be used as PATH environment variable definition.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from DataTypeBase) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PathSet Class | NAnt.Core.Types Namespace


PathSet Constructor

Initializes a new instance of the PathSet class.

Overload List

Initializes a new instance of the PathSet class.

public PathSet();

Invoked by Element.AttributeConfigurator for build attributes with an underlying PathSet type.

public PathSet(Project,string);

See Also

PathSet Class | NAnt.Core.Types Namespace


PathSet Constructor ()

Initializes a new instance of the PathSet class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PathSet();

See Also

PathSet Class | NAnt.Core.Types Namespace | PathSet Constructor Overload List


PathSet Constructor (Project, String)

Invoked by Element.AttributeConfigurator for build attributes with an underlying PathSet type.

[Visual Basic]
Overloads Public Sub New( _
ByVal project As Project, _
ByVal path As String _
)
[C#]
public PathSet(
Project project,
string path
);

Parameters

project
The Project to be used to resolve relative paths.
path
The string representing a path.

See Also

PathSet Class | NAnt.Core.Types Namespace | PathSet Constructor Overload List


PathSet Methods

The methods of the PathSet class are listed below. For a complete list of PathSet class members, see the PathSet Members topic.

Public Static (Shared) Methods

TranslatePath Splits a PATH (with ; or : as separators) into its parts, while resolving references to environment variables.

Public Instance Methods

AddPath | Defines a set of path elements to add to the current path.
AddPathElement | Defines a path element to add to the current path.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetElements | Returns all path elements defined by this path object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from DataTypeBase) | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString | Returns a textual representation of the path, which can be used as PATH environment variable definition.

Protected Instance Methods

CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from DataTypeBase) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PathSet Class | NAnt.Core.Types Namespace


PathSet.AddPath Method

Defines a set of path elements to add to the current path.

[Visual Basic]
<BuildElement(Name:="path", Required:=False, ProcessXml:=True)>
Public Sub AddPath( _
ByVal path As PathSet _
)
[C#]
[BuildElement(Name="path", Required=False, ProcessXml=True)]
public void AddPath(
PathSet path
);

Parameters

path
The PathSet to add.

See Also

PathSet Class | NAnt.Core.Types Namespace


PathSet.AddPathElement Method

Defines a path element to add to the current path.

[Visual Basic]
<BuildElement(Name:="pathelement", Required:=False, ProcessXml:=True)>
Public Sub AddPathElement( _
ByVal pathElement As PathElement _
)
[C#]
[BuildElement(Name="pathelement", Required=False, ProcessXml=True)]
public void AddPathElement(
PathElement pathElement
);

Parameters

pathElement
The PathElement to add.

See Also

PathSet Class | NAnt.Core.Types Namespace


PathSet.GetElements Method

Returns all path elements defined by this path object.

[Visual Basic]
Public Function GetElements() As StringCollection
[C#]
public StringCollection GetElements();

Return Value

A list of path elements.

See Also

PathSet Class | NAnt.Core.Types Namespace


PathSet.ToString Method

Returns a textual representation of the path, which can be used as PATH environment variable definition.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

A textual representation of the path.

See Also

PathSet Class | NAnt.Core.Types Namespace


PathSet.TranslatePath Method

Splits a PATH (with ; or : as separators) into its parts, while resolving references to environment variables.

[Visual Basic]
Public Shared Function TranslatePath( _
ByVal project As Project, _
ByVal source As String _
) As StringCollection
[C#]
public static StringCollection TranslatePath(
Project project,
string source
);

Parameters

project
The Project to be used to resolve relative paths.
source
The path to translate.

Return Value

A PATH split up its parts, with references to environment variables resolved and duplicate entries removed.

See Also

PathSet Class | NAnt.Core.Types Namespace


Pattern Class

For a list of all members of this type, see Pattern Members.

System.Object
NAnt.Core.Element
NAnt.Core.Types.Pattern

[Visual Basic]
Public Class Pattern
Inherits Element
[C#]
public class Pattern : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

Pattern Members | NAnt.Core.Types Namespace


Pattern Members

Pattern overview

Public Instance Constructors

Pattern Constructor Initializes a new instance of the Pattern class.

Public Instance Properties

IfDefined | If true then the pattern will be used; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PatternName | The name pattern to include/exclude.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | If false then the pattern will be used; otherwise, skipped. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Pattern Class | NAnt.Core.Types Namespace


Pattern Constructor

Initializes a new instance of the Pattern class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Pattern();

See Also

Pattern Class | NAnt.Core.Types Namespace


Pattern Properties

The properties of the Pattern class are listed below. For a complete list of Pattern class members, see the Pattern Members topic.

Public Instance Properties

IfDefined | If true then the pattern will be used; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PatternName | The name pattern to include/exclude.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | If false then the pattern will be used; otherwise, skipped. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

Pattern Class | NAnt.Core.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

Pattern.IfDefined Property

If true then the pattern will be used; otherwise, skipped. The default is true.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="if", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property IfDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="if", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool IfDefined {get; set;}

See Also

Pattern Class | NAnt.Core.Types Namespace


PatternName Property

NAnt SDK Documentation - v0.91

Pattern.PatternName Property

The name pattern to include/exclude.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="name", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property PatternName As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="name", Required=True, ExpandProperties=True, ProcessXml=True)]
public virtual string PatternName {get; set;}

See Also

Pattern Class | NAnt.Core.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

Pattern.UnlessDefined Property

If false then the pattern will be used; otherwise, skipped. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="unless", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property UnlessDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="unless", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool UnlessDefined {get; set;}

See Also

Pattern Class | NAnt.Core.Types Namespace


PatternCollection Class

Contains a collection of Pattern elements.

For a list of all members of this type, see PatternCollection Members.

System.Object
NAnt.Core.Types.PatternCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class PatternCollection
Implements IList, ICollection, IEnumerable
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class PatternCollection : IList, ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

PatternCollection Members | NAnt.Core.Types Namespace


PatternCollection Members

PatternCollection overview

Public Instance Constructors

PatternCollection Constructor Initializes a new instance of the PatternCollection class.

Public Instance Properties

Count |
Item | Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a Pattern to the end of the collection.
AddRange | Overloaded. Adds the elements of a Pattern array to the end of the collection.
Clear | Removes all items from the PatternCollection.
Contains | Determines whether a Pattern is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified Pattern object in the collection.
Insert | Inserts a Pattern into the collection at the specified index.
Remove | Removes a member from the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PatternCollection Class | NAnt.Core.Types Namespace


PatternCollection Constructor

Initializes a new instance of the PatternCollection class.

[Visual Basic]
Public Sub New()
[C#]
public PatternCollection();

See Also

PatternCollection Class | NAnt.Core.Types Namespace


PatternCollection Properties

The properties of the PatternCollection class are listed below. For a complete list of PatternCollection class members, see the PatternCollection Members topic.

Public Instance Properties

Count |
Item | Gets or sets the element at the specified index.

See Also

PatternCollection Class | NAnt.Core.Types Namespace


Count Property

NAnt SDK Documentation - v0.91

PatternCollection.Count Property

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

PatternCollection Class | NAnt.Core.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

PatternCollection.Item Property

Gets or sets the element at the specified index.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As Pattern
[C#]
public Pattern this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

PatternCollection Class | NAnt.Core.Types Namespace


PatternCollection Methods

The methods of the PatternCollection class are listed below. For a complete list of PatternCollection class members, see the PatternCollection Members topic.

Public Instance Methods

Add | Adds a Pattern to the end of the collection.
AddRange | Overloaded. Adds the elements of a Pattern array to the end of the collection.
Clear | Removes all items from the PatternCollection.
Contains | Determines whether a Pattern is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified Pattern object in the collection.
Insert | Inserts a Pattern into the collection at the specified index.
Remove | Removes a member from the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PatternCollection Class | NAnt.Core.Types Namespace


PatternCollection.Add Method

Adds a Pattern to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As Pattern _
) As Integer
[C#]
public int Add(
Pattern item
);

Parameters

item
The Pattern to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

PatternCollection Class | NAnt.Core.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

PatternCollection.AddRange Method

Adds the elements of a Pattern array to the end of the collection.

Overload List

Adds the elements of a Pattern array to the end of the collection.

public void AddRange(Pattern[]);

Adds the elements of a PatternCollection to the end of the collection.

public void AddRange(PatternCollection);

See Also

PatternCollection Class | NAnt.Core.Types Namespace


PatternCollection.AddRange Method (Pattern[])

Adds the elements of a Pattern array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As Pattern() _
)
[C#]
public void AddRange(
Pattern[] items
);

Parameters

items
The array of Pattern elements to be added to the end of the collection.

See Also

PatternCollection Class | NAnt.Core.Types Namespace | PatternCollection.AddRange Overload List


PatternCollection.AddRange Method (PatternCollection)

Adds the elements of a PatternCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As PatternCollection _
)
[C#]
public void AddRange(
PatternCollection items
);

Parameters

items
The PatternCollection to be added to the end of the collection.

See Also

PatternCollection Class | NAnt.Core.Types Namespace | PatternCollection.AddRange Overload List


PatternCollection.Clear Method

Removes all items from the PatternCollection.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements IList.Clear
[C#]
public void Clear();

Implements

IList.Clear

See Also

PatternCollection Class | NAnt.Core.Types Namespace


PatternCollection.Contains Method

Determines whether a Pattern is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal item As Pattern _
) As Boolean
[C#]
public bool Contains(
Pattern item
);

Parameters

item
The Pattern to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

PatternCollection Class | NAnt.Core.Types Namespace


PatternCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As Pattern(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
Pattern[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

PatternCollection Class | NAnt.Core.Types Namespace


PatternCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As PatternEnumerator
[C#]
public PatternEnumerator GetEnumerator();

Return Value

A PatternEnumerator for the entire collection.

See Also

PatternCollection Class | NAnt.Core.Types Namespace


PatternCollection.IndexOf Method

Retrieves the index of a specified Pattern object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As Pattern _
) As Integer
[C#]
public int IndexOf(
Pattern item
);

Parameters

item
The Pattern object for which the index is returned.

Return Value

The index of the specified Pattern. If the Pattern is not currently a member of the collection, it returns -1.

See Also

PatternCollection Class | NAnt.Core.Types Namespace


PatternCollection.Insert Method

Inserts a Pattern into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As Pattern _
)
[C#]
public void Insert(
int index,
Pattern item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The Pattern to insert.

See Also

PatternCollection Class | NAnt.Core.Types Namespace


PatternCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As Pattern _
)
[C#]
public void Remove(
Pattern item
);

Parameters

item
The Pattern to remove from the collection.

See Also

PatternCollection Class | NAnt.Core.Types Namespace


PatternEnumerator Class

Enumerates the Pattern elements of a PatternCollection.

For a list of all members of this type, see PatternEnumerator Members.

System.Object
NAnt.Core.Types.PatternEnumerator

[Visual Basic]
Public Class PatternEnumerator
Implements IEnumerator
[C#]
public class PatternEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

PatternEnumerator Members | NAnt.Core.Types Namespace


PatternEnumerator Members

PatternEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PatternEnumerator Class | NAnt.Core.Types Namespace


PatternEnumerator Properties

The properties of the PatternEnumerator class are listed below. For a complete list of PatternEnumerator class members, see the PatternEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

PatternEnumerator Class | NAnt.Core.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

PatternEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As Pattern
[C#]
public Pattern Current {get;}

See Also

PatternEnumerator Class | NAnt.Core.Types Namespace


PatternEnumerator Methods

The methods of the PatternEnumerator class are listed below. For a complete list of PatternEnumerator class members, see the PatternEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PatternEnumerator Class | NAnt.Core.Types Namespace


PatternEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
NotOverridable Public Function MoveNext() As Boolean _
Implements IEnumerator.MoveNext
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Implements

IEnumerator.MoveNext

See Also

PatternEnumerator Class | NAnt.Core.Types Namespace


PatternEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
NotOverridable Public Sub Reset() _
Implements IEnumerator.Reset
[C#]
public void Reset();

Implements

IEnumerator.Reset

See Also

PatternEnumerator Class | NAnt.Core.Types Namespace


PatternSet Class

A set of patterns, mostly used to include or exclude certain files.

For a list of all members of this type, see PatternSet Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.Core.Types.PatternSet

[Visual Basic]
<ElementName(Name:="patternset")>
Public Class PatternSet
Inherits DataTypeBase
[C#]
[ElementName(Name="patternset")]
public class PatternSet : DataTypeBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The individual patterns support if and unless attributes to specify that the element should only be used if or unless a given condition is met.

The IncludesFile and ExcludesFile elements load patterns from a file. When the file is a relative path, it will be resolved relative to the project base directory in which the patternset is defined. Each line of this file is taken to be a pattern.

The number sign (#) as the first non-blank character in a line denotes that all text following it is a comment:

     EventLog.cs
     # requires Mono.Posix
     SysLogEventLogImpl.cs
     # uses the win32 eventlog API
     Win32EventLogImpl.cs

Patterns can be grouped to sets, and later be referenced by their ID.

When used as a standalone element (global type), any properties that are referenced will be resolved when the definition is processed, not when it actually used. Passing a reference to a nested build file will not cause the properties to be re-evaluated.

To improve reuse of globally defined patternsets, avoid referencing any properties altogether.

Example

Define a set of patterns that matches all .cs files that do not contain the text Test in their name.

      <patternset id="non.test.sources">
          <include name="**/*.cs" />
          <exclude name="**/*Test*" />
      </patternset>

Define two sets. One holding C# sources, and one holding VB sources. Both sets only include test sources when the test property is set. A third set combines both C# and VB sources.

      <patternset id="cs.sources">
          <include name="src/**/*.cs" />
          <include name="test/**/*.cs" if=${property::exist('test')}" />
      </patternset>

      <patternset id="vb.sources">
          <include name="src/**/*.vb" />
          <include name="test/**/*.vb" if=${property::exist('test')}" />
      </patternset>

      <patternset id="all.sources">
          <patternset refid="cs.sources" />
          <patternset refid="vb.sources" />
      </patternset>

Define a set from patterns in a file.

      <patternset id="sources">
          <includesfile name="test.sources" />
          <includesfile name="non.test.sources" />
      </patternset>

Defines a patternset with patterns that are loaded from an external file, and shows the behavior when that patternset is passed as a reference to a nested build script.

External file "c:\foo\build\service.lst" holding patterns of source files to include for the Foo.Service assembly:

    AssemblyInfo.cs
    *Channel.cs
    ServiceFactory.cs

Main build script located in "c:\foo\default.build":

    <project name="main" default="build">
        <property name="build.debug" value="true" />

        <patternset id="service.sources">
            <include name="TraceListener.cs" if="${build.debug}" />
            <includesfile name="build/service.lst" />
        </patternset>

        <property name="build.debug" value="false" />

        <target name="build">
            <nant buildfile="service/default.build" inheritrefs="true" />
        </target>
    </project>

Nested build script located in "c:\foo\services\default.build" which uses the patternset to feed sources files to the C# compiler:

    <project name="service" default="build">
        <target name="build">
            <csc output="../bin/Foo.Service.dll" target="library">
                <fileset basedir="src">
                    <patternset refid="service.sources" />
                </fileset>
            </csc>
        </target>
    </project>

At the time when the patternset is used in the "service" build script, the following source files in "c:\foo\services\src" match the defined patterns:

    AssemblyInfo.cs
    MsmqChannel.cs
    SmtpChannel.cs
    ServiceFactory.cs
    TraceListener.cs

You should have observed that:

  • although the patternset is used from the "service" build script, the path to the external file is resolved relative to the base directory of the "main" build script in which the patternset is defined.
  • the "TraceListener.cs" file is included, even though the "build.debug" property was changed to false after the patternset was defined (but before it was passed to the nested build, and used).

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

PatternSet Members | NAnt.Core.Types Namespace | FileSet


PatternSet Members

PatternSet overview

Public Instance Constructors

PatternSet Constructor Initializes a new instance of the PatternSet class.

Public Instance Properties

CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Exclude | Defines a single pattern for files to exclude.
ExcludesFile | Loads multiple patterns of files to exclude from a given file, set using the PatternName parameter.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
Include | Defines a single pattern for files to include.
IncludesFile | Loads multiple patterns of files to include from a given file, set using the PatternName parameter.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.

Public Instance Methods

Append | Adds a nested set of patterns, or references other standalone patternset.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetExcludePatterns |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetIncludePatterns |
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from DataTypeBase) | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from DataTypeBase) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PatternSet Class | NAnt.Core.Types Namespace | FileSet


PatternSet Constructor

Initializes a new instance of the PatternSet class.

[Visual Basic]
Public Sub New()
[C#]
public PatternSet();

See Also

PatternSet Class | NAnt.Core.Types Namespace


PatternSet Properties

The properties of the PatternSet class are listed below. For a complete list of PatternSet class members, see the PatternSet Members topic.

Public Instance Properties

CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Exclude | Defines a single pattern for files to exclude.
ExcludesFile | Loads multiple patterns of files to exclude from a given file, set using the PatternName parameter.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
Include | Defines a single pattern for files to include.
IncludesFile | Loads multiple patterns of files to include from a given file, set using the PatternName parameter.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

PatternSet Class | NAnt.Core.Types Namespace | FileSet


Exclude Property

NAnt SDK Documentation - v0.91

PatternSet.Exclude Property

Defines a single pattern for files to exclude.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="exclude", Required:=False, ProcessXml:=True)>
Public ReadOnly Property Exclude As PatternCollection
[C#]
[BuildElementArray(ElementType=null, Name="exclude", Required=False, ProcessXml=True)]
public PatternCollection Exclude {get;}

See Also

PatternSet Class | NAnt.Core.Types Namespace


ExcludesFile Property

NAnt SDK Documentation - v0.91

PatternSet.ExcludesFile Property

Loads multiple patterns of files to exclude from a given file, set using the PatternName parameter.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="excludesfile", Required:=False, ProcessXml:=True)>
Public ReadOnly Property ExcludesFile As PatternCollection
[C#]
[BuildElementArray(ElementType=null, Name="excludesfile", Required=False, ProcessXml=True)]
public PatternCollection ExcludesFile {get;}

See Also

PatternSet Class | NAnt.Core.Types Namespace


Include Property

NAnt SDK Documentation - v0.91

PatternSet.Include Property

Defines a single pattern for files to include.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="include", Required:=False, ProcessXml:=True)>
Public ReadOnly Property Include As PatternCollection
[C#]
[BuildElementArray(ElementType=null, Name="include", Required=False, ProcessXml=True)]
public PatternCollection Include {get;}

See Also

PatternSet Class | NAnt.Core.Types Namespace


IncludesFile Property

NAnt SDK Documentation - v0.91

PatternSet.IncludesFile Property

Loads multiple patterns of files to include from a given file, set using the PatternName parameter.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="includesfile", Required:=False, ProcessXml:=True)>
Public ReadOnly Property IncludesFile As PatternCollection
[C#]
[BuildElementArray(ElementType=null, Name="includesfile", Required=False, ProcessXml=True)]
public PatternCollection IncludesFile {get;}

See Also

PatternSet Class | NAnt.Core.Types Namespace


PatternSet Methods

The methods of the PatternSet class are listed below. For a complete list of PatternSet class members, see the PatternSet Members topic.

Public Instance Methods

Append | Adds a nested set of patterns, or references other standalone patternset.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetExcludePatterns |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetIncludePatterns |
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from DataTypeBase) | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from DataTypeBase) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PatternSet Class | NAnt.Core.Types Namespace | FileSet


PatternSet.Append Method

Adds a nested set of patterns, or references other standalone patternset.

[Visual Basic]
<BuildElement(Name:="patternset", Required:=False, ProcessXml:=True)>
Public Sub Append( _
ByVal patternSet As PatternSet _
)
[C#]
[BuildElement(Name="patternset", Required=False, ProcessXml=True)]
public void Append(
PatternSet patternSet
);

Parameters

patternSet
The PatternSet to add.

See Also

PatternSet Class | NAnt.Core.Types Namespace


PatternSet.GetExcludePatterns Method

[Visual Basic]
Public Function GetExcludePatterns() As String()
[C#]
public string[] GetExcludePatterns();

See Also

PatternSet Class | NAnt.Core.Types Namespace


PatternSet.GetIncludePatterns Method

[Visual Basic]
Public Function GetIncludePatterns() As String()
[C#]
public string[] GetIncludePatterns();

See Also

PatternSet Class | NAnt.Core.Types Namespace


Proxy Class

Contains HTTP proxy settings used to process requests to Internet resources.

For a list of all members of this type, see Proxy Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.Core.Types.Proxy

[Visual Basic]
<ElementName(Name:="proxy")>
Public Class Proxy
Inherits DataTypeBase
[C#]
[ElementName(Name="proxy")]
public class Proxy : DataTypeBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

Proxy Members | NAnt.Core.Types Namespace


Proxy Members

Proxy overview

Public Instance Constructors

Proxy Constructor Initializes a new instance of the Proxy class.

Public Instance Properties

BypassOnLocal | Specifies whether to bypass the proxy server for local addresses. The default is false.
CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Credentials | The credentials to submit to the proxy server for authentication.
Host | The name of the proxy host.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IfDefined | Indicates if the proxy should be used to connect to the external resource. If true then the proxy will be used; otherwise, not. The default is true.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Port | The port number on Host to use.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.
UnlessDefined | Indicates if the proxy should not be used to connect to the external resource. If false then the proxy will be used; otherwise, not. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
GetWebProxy | Gets a WebProxy instance representing the current Proxy.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from DataTypeBase) | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from DataTypeBase) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Proxy Class | NAnt.Core.Types Namespace


Proxy Constructor

Initializes a new instance of the Proxy class.

[Visual Basic]
Public Sub New()
[C#]
public Proxy();

See Also

Proxy Class | NAnt.Core.Types Namespace


Proxy Properties

The properties of the Proxy class are listed below. For a complete list of Proxy class members, see the Proxy Members topic.

Public Instance Properties

BypassOnLocal | Specifies whether to bypass the proxy server for local addresses. The default is false.
CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Credentials | The credentials to submit to the proxy server for authentication.
Host | The name of the proxy host.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IfDefined | Indicates if the proxy should be used to connect to the external resource. If true then the proxy will be used; otherwise, not. The default is true.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Port | The port number on Host to use.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.
UnlessDefined | Indicates if the proxy should not be used to connect to the external resource. If false then the proxy will be used; otherwise, not. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

Proxy Class | NAnt.Core.Types Namespace


BypassOnLocal Property

NAnt SDK Documentation - v0.91

Proxy.BypassOnLocal Property

Specifies whether to bypass the proxy server for local addresses. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="bypassonlocal", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property BypassOnLocal As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="bypassonlocal", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool BypassOnLocal {get; set;}

See Also

Proxy Class | NAnt.Core.Types Namespace


Credentials Property

NAnt SDK Documentation - v0.91

Proxy.Credentials Property

The credentials to submit to the proxy server for authentication.

[Visual Basic]
<BuildElement(Name:="credentials", Required:=False, ProcessXml:=True)>
Public Property Credentials As Credential
[C#]
[BuildElement(Name="credentials", Required=False, ProcessXml=True)]
public Credential Credentials {get; set;}

See Also

Proxy Class | NAnt.Core.Types Namespace


Host Property

NAnt SDK Documentation - v0.91

Proxy.Host Property

The name of the proxy host.

[Visual Basic]
<TaskAttribute(Name:="host", Required:=True, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property Host As String
[C#]
[TaskAttribute(Name="host", Required=True, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string Host {get; set;}

See Also

Proxy Class | NAnt.Core.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

Proxy.IfDefined Property

Indicates if the proxy should be used to connect to the external resource. If true then the proxy will be used; otherwise, not. The default is true.

[Visual Basic]
<TaskAttribute(Name:="if", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property IfDefined As Boolean
[C#]
[TaskAttribute(Name="if", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool IfDefined {get; set;}

See Also

Proxy Class | NAnt.Core.Types Namespace


Port Property

NAnt SDK Documentation - v0.91

Proxy.Port Property

The port number on Host to use.

[Visual Basic]
<Int32Validator(MinValue:=-2147483648, MaxValue:=2147483647, Base:=10), _ TaskAttribute(Name:="port", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property Port As Integer
[C#]
[Int32Validator(MinValue=-2147483648, MaxValue=2147483647, Base=10)]
[TaskAttribute(Name="port", Required=True, ExpandProperties=True, ProcessXml=True)]
public int Port {get; set;}

See Also

Proxy Class | NAnt.Core.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

Proxy.UnlessDefined Property

Indicates if the proxy should not be used to connect to the external resource. If false then the proxy will be used; otherwise, not. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="unless", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property UnlessDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="unless", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool UnlessDefined {get; set;}

See Also

Proxy Class | NAnt.Core.Types Namespace


Proxy Methods

The methods of the Proxy class are listed below. For a complete list of Proxy class members, see the Proxy Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
GetWebProxy | Gets a WebProxy instance representing the current Proxy.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from DataTypeBase) | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from DataTypeBase) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Proxy Class | NAnt.Core.Types Namespace


Proxy.GetWebProxy Method

Gets a WebProxy instance representing the current Proxy.

[Visual Basic]
Public Function GetWebProxy() As IWebProxy
[C#]
public IWebProxy GetWebProxy();

Return Value

A WebProxy instance representing the current Proxy, or GlobalProxySelection.Select if this proxy should not be used to connect to the external resource.

See Also

Proxy Class | NAnt.Core.Types Namespace


RawXml Class

Represents an element of which the XML is processed by its parent task or type.

For a list of all members of this type, see RawXml Members.

System.Object
NAnt.Core.Element
NAnt.Core.Types.RawXml

[Visual Basic]
Public Class RawXml
Inherits Element
[C#]
public class RawXml : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

RawXml Members | NAnt.Core.Types Namespace


RawXml Members

RawXml overview

Public Instance Constructors

RawXml Constructor Initializes a new instance of the RawXml class.

Public Instance Properties

Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Xml | Gets the XML that this element represents.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing | Gets a value indicating whether the element is performing additional processing using the XmlNode that was use to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RawXml Class | NAnt.Core.Types Namespace


RawXml Constructor

Initializes a new instance of the RawXml class.

[Visual Basic]
Public Sub New()
[C#]
public RawXml();

See Also

RawXml Class | NAnt.Core.Types Namespace


RawXml Properties

The properties of the RawXml class are listed below. For a complete list of RawXml class members, see the RawXml Members topic.

Public Instance Properties

Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Xml | Gets the XML that this element represents.

Protected Instance Properties

CustomXmlProcessing | Gets a value indicating whether the element is performing additional processing using the XmlNode that was use to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

RawXml Class | NAnt.Core.Types Namespace


CustomXmlProcessing Property

NAnt SDK Documentation - v0.91

RawXml.CustomXmlProcessing Property

Gets a value indicating whether the element is performing additional processing using the XmlNode that was use to initialize the element.

[Visual Basic]
Overrides Protected ReadOnly Property CustomXmlProcessing As Boolean
[C#]
protected override bool CustomXmlProcessing {get;}

Property Value

true, as the XML that represents this build element is processed by the containing task or type.

See Also

RawXml Class | NAnt.Core.Types Namespace


Xml Property

NAnt SDK Documentation - v0.91

RawXml.Xml Property

Gets the XML that this element represents.

[Visual Basic]
Public ReadOnly Property Xml As XmlNode
[C#]
public System.Xml.XmlNode Xml {get;}

See Also

RawXml Class | NAnt.Core.Types Namespace


Token Class

ReplaceTokens filter token.

For a list of all members of this type, see Token Members.

System.Object
NAnt.Core.Element
NAnt.Core.Types.Token

[Visual Basic]
<ElementName(Name:="token")>
Public Class Token
Inherits Element
[C#]
[ElementName(Name="token")]
public class Token : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

Token Members | NAnt.Core.Types Namespace


Token Members

Token overview

Public Instance Constructors

Token Constructor Initializes a new instance of the Token class.

Public Instance Properties

IfDefined | Indicates if the token should be used to replace values. If true then the token will be used; otherwise, not. The default is true.
Key | Token to be replaced.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Indicates if the token should not be used to replace values. If false then the token will be used; otherwise, not. The default is false.
Value | New value of token.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Token Class | NAnt.Core.Types Namespace


Token Constructor

Initializes a new instance of the Token class.

[Visual Basic]
Public Sub New()
[C#]
public Token();

See Also

Token Class | NAnt.Core.Types Namespace


Token Properties

The properties of the Token class are listed below. For a complete list of Token class members, see the Token Members topic.

Public Instance Properties

IfDefined | Indicates if the token should be used to replace values. If true then the token will be used; otherwise, not. The default is true.
Key | Token to be replaced.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Indicates if the token should not be used to replace values. If false then the token will be used; otherwise, not. The default is false.
Value | New value of token.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

Token Class | NAnt.Core.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

Token.IfDefined Property

Indicates if the token should be used to replace values. If true then the token will be used; otherwise, not. The default is true.

[Visual Basic]
<TaskAttribute(Name:="if", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property IfDefined As Boolean
[C#]
[TaskAttribute(Name="if", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool IfDefined {get; set;}

See Also

Token Class | NAnt.Core.Types Namespace


Key Property

NAnt SDK Documentation - v0.91

Token.Key Property

Token to be replaced.

[Visual Basic]
<TaskAttribute(Name:="key", Required:=True, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property Key As String
[C#]
[TaskAttribute(Name="key", Required=True, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string Key {get; set;}

See Also

Token Class | NAnt.Core.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

Token.UnlessDefined Property

Indicates if the token should not be used to replace values. If false then the token will be used; otherwise, not. The default is false.

[Visual Basic]
<TaskAttribute(Name:="unless", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property UnlessDefined As Boolean
[C#]
[TaskAttribute(Name="unless", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool UnlessDefined {get; set;}

See Also

Token Class | NAnt.Core.Types Namespace


Value Property

NAnt SDK Documentation - v0.91

Token.Value Property

New value of token.

[Visual Basic]
<TaskAttribute(Name:="value", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property Value As String
[C#]
[TaskAttribute(Name="value", Required=True, ExpandProperties=True, ProcessXml=True)]
public string Value {get; set;}

See Also

Token Class | NAnt.Core.Types Namespace


XmlNamespace Class

Represents an XML namespace.

For a list of all members of this type, see XmlNamespace Members.

System.Object
NAnt.Core.Element
NAnt.Core.Types.XmlNamespace

[Visual Basic]
<ElementName(Name:="namespace")>
Public Class XmlNamespace
Inherits Element
[C#]
[ElementName(Name="namespace")]
public class XmlNamespace : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

XmlNamespace Members | NAnt.Core.Types Namespace


XmlNamespace Members

XmlNamespace overview

Public Instance Constructors

XmlNamespace Constructor Initializes a new instance of the XmlNamespace class.

Public Instance Properties

IfDefined | Indicates if the namespace should be added to the XmlNamespaceManager. If true then the namespace will be added; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Prefix | The prefix to associate with the namespace.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Indicates if the namespace should not be added to the XmlNamespaceManager. list. If false then the parameter will be added; otherwise, skipped. The default is false.
Uri | The associated XML namespace URI.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlNamespace Class | NAnt.Core.Types Namespace


XmlNamespace Constructor

Initializes a new instance of the XmlNamespace class.

[Visual Basic]
Public Sub New()
[C#]
public XmlNamespace();

See Also

XmlNamespace Class | NAnt.Core.Types Namespace


XmlNamespace Properties

The properties of the XmlNamespace class are listed below. For a complete list of XmlNamespace class members, see the XmlNamespace Members topic.

Public Instance Properties

IfDefined | Indicates if the namespace should be added to the XmlNamespaceManager. If true then the namespace will be added; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Prefix | The prefix to associate with the namespace.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Indicates if the namespace should not be added to the XmlNamespaceManager. list. If false then the parameter will be added; otherwise, skipped. The default is false.
Uri | The associated XML namespace URI.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

XmlNamespace Class | NAnt.Core.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

XmlNamespace.IfDefined Property

Indicates if the namespace should be added to the XmlNamespaceManager. If true then the namespace will be added; otherwise, skipped. The default is true.

[Visual Basic]
<TaskAttribute(Name:="if", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property IfDefined As Boolean
[C#]
[TaskAttribute(Name="if", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool IfDefined {get; set;}

See Also

XmlNamespace Class | NAnt.Core.Types Namespace


Prefix Property

NAnt SDK Documentation - v0.91

XmlNamespace.Prefix Property

The prefix to associate with the namespace.

[Visual Basic]
<StringValidator(AllowEmpty:=True, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="prefix", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property Prefix As String
[C#]
[StringValidator(AllowEmpty=True, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="prefix", Required=True, ExpandProperties=True, ProcessXml=True)]
public string Prefix {get; set;}

See Also

XmlNamespace Class | NAnt.Core.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

XmlNamespace.UnlessDefined Property

Indicates if the namespace should not be added to the XmlNamespaceManager. list. If false then the parameter will be added; otherwise, skipped. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="unless", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property UnlessDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="unless", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool UnlessDefined {get; set;}

See Also

XmlNamespace Class | NAnt.Core.Types Namespace


Uri Property

NAnt SDK Documentation - v0.91

XmlNamespace.Uri Property

The associated XML namespace URI.

[Visual Basic]
<StringValidator(AllowEmpty:=True, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="uri", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property Uri As String
[C#]
[StringValidator(AllowEmpty=True, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="uri", Required=True, ExpandProperties=True, ProcessXml=True)]
public string Uri {get; set;}

See Also

XmlNamespace Class | NAnt.Core.Types Namespace


XmlNamespaceCollection Class

Contains a collection of XmlNamespace elements.

For a list of all members of this type, see XmlNamespaceCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.Core.Types.XmlNamespaceCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class XmlNamespaceCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class XmlNamespaceCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

XmlNamespaceCollection Members | NAnt.Core.Types Namespace


XmlNamespaceCollection Members

XmlNamespaceCollection overview

Public Instance Constructors

XmlNamespaceCollection Overloaded. Initializes a new instance of the XmlNamespaceCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a XmlNamespace to the end of the collection.
AddRange | Overloaded. Adds the elements of a XmlNamespace array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a XmlNamespace is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified XmlNamespace object in the collection.
Insert | Inserts a XmlNamespace into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace


XmlNamespaceCollection Constructor

Initializes a new instance of the XmlNamespaceCollection class.

Overload List

Initializes a new instance of the XmlNamespaceCollection class.

public XmlNamespaceCollection();

Initializes a new instance of the XmlNamespaceCollection class with the specified array of XmlNamespace instances.

public XmlNamespaceCollection(XmlNamespace[]);

Initializes a new instance of the XmlNamespaceCollection class with the specified XmlNamespaceCollection instance.

public XmlNamespaceCollection(XmlNamespaceCollection);

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace


XmlNamespaceCollection Constructor ()

Initializes a new instance of the XmlNamespaceCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public XmlNamespaceCollection();

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace | XmlNamespaceCollection Constructor Overload List


XmlNamespaceCollection Constructor (XmlNamespaceCollection)

Initializes a new instance of the XmlNamespaceCollection class with the specified XmlNamespaceCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As XmlNamespaceCollection _
)
[C#]
public XmlNamespaceCollection(
XmlNamespaceCollection value
);

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace | XmlNamespaceCollection Constructor Overload List


XmlNamespaceCollection Constructor (XmlNamespace[])

Initializes a new instance of the XmlNamespaceCollection class with the specified array of XmlNamespace instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As XmlNamespace() _
)
[C#]
public XmlNamespaceCollection(
XmlNamespace[] value
);

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace | XmlNamespaceCollection Constructor Overload List


XmlNamespaceCollection Properties

The properties of the XmlNamespaceCollection class are listed below. For a complete list of XmlNamespaceCollection class members, see the XmlNamespaceCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

XmlNamespaceCollection.Item Property

Gets or sets the element at the specified index.

Overload List

Gets or sets the element at the specified index.

public XmlNamespace this[int] {get; set;}

Gets the XmlNamespace with the specified prefix.

public XmlNamespace this[string] {get;}

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace


Item Property (Int32)

NAnt SDK Documentation - v0.91

XmlNamespaceCollection.Item Property (Int32)

Gets or sets the element at the specified index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As XmlNamespace
[C#]
public XmlNamespace this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace | XmlNamespaceCollection.Item Overload List


Item Property (String)

NAnt SDK Documentation - v0.91

XmlNamespaceCollection.Item Property (String)

Gets the XmlNamespace with the specified prefix.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal value As String _
) As XmlNamespace
[C#]
public XmlNamespace this[
string value
] {get;}

Parameters

value
The prefix of the XmlNamespace to get.

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace | XmlNamespaceCollection.Item Overload List


XmlNamespaceCollection Methods

The methods of the XmlNamespaceCollection class are listed below. For a complete list of XmlNamespaceCollection class members, see the XmlNamespaceCollection Members topic.

Public Instance Methods

Add | Adds a XmlNamespace to the end of the collection.
AddRange | Overloaded. Adds the elements of a XmlNamespace array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a XmlNamespace is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified XmlNamespace object in the collection.
Insert | Inserts a XmlNamespace into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace


XmlNamespaceCollection.Add Method

Adds a XmlNamespace to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As XmlNamespace _
) As Integer
[C#]
public int Add(
XmlNamespace item
);

Parameters

item
The XmlNamespace to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

XmlNamespaceCollection.AddRange Method

Adds the elements of a XmlNamespace array to the end of the collection.

Overload List

Adds the elements of a XmlNamespace array to the end of the collection.

public void AddRange(XmlNamespace[]);

Adds the elements of a XmlNamespaceCollection to the end of the collection.

public void AddRange(XmlNamespaceCollection);

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace


XmlNamespaceCollection.AddRange Method (XmlNamespace[])

Adds the elements of a XmlNamespace array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As XmlNamespace() _
)
[C#]
public void AddRange(
XmlNamespace[] items
);

Parameters

items
The array of XmlNamespace elements to be added to the end of the collection.

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace | XmlNamespaceCollection.AddRange Overload List


XmlNamespaceCollection.AddRange Method (XmlNamespaceCollection)

Adds the elements of a XmlNamespaceCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As XmlNamespaceCollection _
)
[C#]
public void AddRange(
XmlNamespaceCollection items
);

Parameters

items
The XmlNamespaceCollection to be added to the end of the collection.

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace | XmlNamespaceCollection.AddRange Overload List


Contains Method

NAnt SDK Documentation - v0.91

XmlNamespaceCollection.Contains Method

Determines whether a XmlNamespace is in the collection.

Overload List

Determines whether a XmlNamespace is in the collection.

public bool Contains(XmlNamespace);

Determines whether a XmlNamespace with the specified value is in the collection.

public bool Contains(string);

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace


XmlNamespaceCollection.Contains Method (XmlNamespace)

Determines whether a XmlNamespace is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal item As XmlNamespace _
) As Boolean
[C#]
public bool Contains(
XmlNamespace item
);

Parameters

item
The XmlNamespace to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace | XmlNamespaceCollection.Contains Overload List


XmlNamespaceCollection.Contains Method (String)

Determines whether a XmlNamespace with the specified value is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal value As String _
) As Boolean
[C#]
public bool Contains(
string value
);

Parameters

value
The argument value to locate in the collection.

Return Value

true if a XmlNamespace with value value is found in the collection; otherwise, false.

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace | XmlNamespaceCollection.Contains Overload List


XmlNamespaceCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As XmlNamespace(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
XmlNamespace[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace


XmlNamespaceCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As XmlNamespaceEnumerator
[C#]
new public XmlNamespaceEnumerator GetEnumerator();

Return Value

A XmlNamespaceEnumerator for the entire collection.

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace


XmlNamespaceCollection.IndexOf Method

Retrieves the index of a specified XmlNamespace object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As XmlNamespace _
) As Integer
[C#]
public int IndexOf(
XmlNamespace item
);

Parameters

item
The XmlNamespace object for which the index is returned.

Return Value

The index of the specified XmlNamespace. If the XmlNamespace is not currently a member of the collection, it returns -1.

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace


XmlNamespaceCollection.Insert Method

Inserts a XmlNamespace into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As XmlNamespace _
)
[C#]
public void Insert(
int index,
XmlNamespace item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The XmlNamespace to insert.

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace


XmlNamespaceCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As XmlNamespace _
)
[C#]
public void Remove(
XmlNamespace item
);

Parameters

item
The XmlNamespace to remove from the collection.

See Also

XmlNamespaceCollection Class | NAnt.Core.Types Namespace


XmlNamespaceEnumerator Class

Enumerates the XmlNamespace elements of a XmlNamespaceCollection.

For a list of all members of this type, see XmlNamespaceEnumerator Members.

System.Object
NAnt.Core.Types.XmlNamespaceEnumerator

[Visual Basic]
Public Class XmlNamespaceEnumerator
Implements IEnumerator
[C#]
public class XmlNamespaceEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

XmlNamespaceEnumerator Members | NAnt.Core.Types Namespace


XmlNamespaceEnumerator Members

XmlNamespaceEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlNamespaceEnumerator Class | NAnt.Core.Types Namespace


XmlNamespaceEnumerator Properties

The properties of the XmlNamespaceEnumerator class are listed below. For a complete list of XmlNamespaceEnumerator class members, see the XmlNamespaceEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

XmlNamespaceEnumerator Class | NAnt.Core.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

XmlNamespaceEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As XmlNamespace
[C#]
public XmlNamespace Current {get;}

See Also

XmlNamespaceEnumerator Class | NAnt.Core.Types Namespace


XmlNamespaceEnumerator Methods

The methods of the XmlNamespaceEnumerator class are listed below. For a complete list of XmlNamespaceEnumerator class members, see the XmlNamespaceEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlNamespaceEnumerator Class | NAnt.Core.Types Namespace


XmlNamespaceEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

XmlNamespaceEnumerator Class | NAnt.Core.Types Namespace


XmlNamespaceEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

XmlNamespaceEnumerator Class | NAnt.Core.Types Namespace


XsltExtensionObject Class

Represents an XSLT extension object. The object should have a default parameterless constructor and the return value should be one of the four basic XPath data types of number, string, Boolean or node set.

For a list of all members of this type, see XsltExtensionObject Members.

System.Object
NAnt.Core.Element
NAnt.Core.Types.XsltExtensionObject

[Visual Basic]
<ElementName(Name:="xsltextensionobject")>
Public Class XsltExtensionObject
Inherits Element
[C#]
[ElementName(Name="xsltextensionobject")]
public class XsltExtensionObject : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

XsltExtensionObject Members | NAnt.Core.Types Namespace


XsltExtensionObject Members

XsltExtensionObject overview

Public Instance Constructors

XsltExtensionObject Constructor Initializes a new instance of the XsltExtensionObject class.

Public Instance Properties

AssemblyPath | The assembly which contains the XSLT extension object.
IfDefined | Indicates if the extension object should be added to the XSLT argument list. If true then the extension object will be added; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NamespaceUri | The namespace URI to associate with the extension object.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
TypeName | The full type name of the XSLT extension object.
UnlessDefined | Indicates if the extension object should not be added to the XSLT argument list. If false then the extension object will be added; otherwise, skipped. The default is false.

Public Instance Methods

CreateInstance |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XsltExtensionObject Class | NAnt.Core.Types Namespace


XsltExtensionObject Constructor

Initializes a new instance of the XsltExtensionObject class.

[Visual Basic]
Public Sub New()
[C#]
public XsltExtensionObject();

See Also

XsltExtensionObject Class | NAnt.Core.Types Namespace


XsltExtensionObject Properties

The properties of the XsltExtensionObject class are listed below. For a complete list of XsltExtensionObject class members, see the XsltExtensionObject Members topic.

Public Instance Properties

AssemblyPath | The assembly which contains the XSLT extension object.
IfDefined | Indicates if the extension object should be added to the XSLT argument list. If true then the extension object will be added; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NamespaceUri | The namespace URI to associate with the extension object.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
TypeName | The full type name of the XSLT extension object.
UnlessDefined | Indicates if the extension object should not be added to the XSLT argument list. If false then the extension object will be added; otherwise, skipped. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

XsltExtensionObject Class | NAnt.Core.Types Namespace


AssemblyPath Property

NAnt SDK Documentation - v0.91

XsltExtensionObject.AssemblyPath Property

The assembly which contains the XSLT extension object.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="assembly", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property AssemblyPath As FileInfo
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="assembly", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo AssemblyPath {get; set;}

See Also

XsltExtensionObject Class | NAnt.Core.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

XsltExtensionObject.IfDefined Property

Indicates if the extension object should be added to the XSLT argument list. If true then the extension object will be added; otherwise, skipped. The default is true.

[Visual Basic]
<TaskAttribute(Name:="if", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property IfDefined As Boolean
[C#]
[TaskAttribute(Name="if", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool IfDefined {get; set;}

See Also

XsltExtensionObject Class | NAnt.Core.Types Namespace


NamespaceUri Property

NAnt SDK Documentation - v0.91

XsltExtensionObject.NamespaceUri Property

The namespace URI to associate with the extension object.

[Visual Basic]
<TaskAttribute(Name:="namespaceuri", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property NamespaceUri As String
[C#]
[TaskAttribute(Name="namespaceuri", Required=False, ExpandProperties=True, ProcessXml=True)]
public string NamespaceUri {get; set;}

Property Value

The namespace URI to associate with the extension object, or Empty if not set.

See Also

XsltExtensionObject Class | NAnt.Core.Types Namespace


TypeName Property

NAnt SDK Documentation - v0.91

XsltExtensionObject.TypeName Property

The full type name of the XSLT extension object.

[Visual Basic]
<TaskAttribute(Name:="typename", Required:=True, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property TypeName As String
[C#]
[TaskAttribute(Name="typename", Required=True, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string TypeName {get; set;}

See Also

XsltExtensionObject Class | NAnt.Core.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

XsltExtensionObject.UnlessDefined Property

Indicates if the extension object should not be added to the XSLT argument list. If false then the extension object will be added; otherwise, skipped. The default is false.

[Visual Basic]
<TaskAttribute(Name:="unless", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property UnlessDefined As Boolean
[C#]
[TaskAttribute(Name="unless", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool UnlessDefined {get; set;}

See Also

XsltExtensionObject Class | NAnt.Core.Types Namespace


XsltExtensionObject Methods

The methods of the XsltExtensionObject class are listed below. For a complete list of XsltExtensionObject class members, see the XsltExtensionObject Members topic.

Public Instance Methods

CreateInstance |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XsltExtensionObject Class | NAnt.Core.Types Namespace


XsltExtensionObject.CreateInstance Method

[Visual Basic]
Public Function CreateInstance() As Object
[C#]
public object CreateInstance();

See Also

XsltExtensionObject Class | NAnt.Core.Types Namespace


XsltExtensionObjectCollection Class

Contains a collection of XsltExtensionObject elements.

For a list of all members of this type, see XsltExtensionObjectCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.Core.Types.XsltExtensionObjectCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class XsltExtensionObjectCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class XsltExtensionObjectCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

XsltExtensionObjectCollection Members | NAnt.Core.Types Namespace


XsltExtensionObjectCollection Members

XsltExtensionObjectCollection overview

Public Instance Constructors

XsltExtensionObjectCollection Overloaded. Initializes a new instance of the XsltExtensionObjectCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a XsltExtensionObject to the end of the collection.
AddRange | Overloaded. Adds the elements of a XsltExtensionObject array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a XsltExtensionObject is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified XsltExtensionObject object in the collection.
Insert | Inserts a XsltExtensionObject into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace


XsltExtensionObjectCollection Constructor

Initializes a new instance of the XsltExtensionObjectCollection class.

Overload List

Initializes a new instance of the XsltExtensionObjectCollection class.

public XsltExtensionObjectCollection();

Initializes a new instance of the XsltExtensionObjectCollection class with the specified array of XsltExtensionObject instances.

public XsltExtensionObjectCollection(XsltExtensionObject[]);

Initializes a new instance of the XsltExtensionObjectCollection class with the specified XsltExtensionObjectCollection instance.

public XsltExtensionObjectCollection(XsltExtensionObjectCollection);

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace


XsltExtensionObjectCollection Constructor ()

Initializes a new instance of the XsltExtensionObjectCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public XsltExtensionObjectCollection();

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace | XsltExtensionObjectCollection Constructor Overload List


XsltExtensionObjectCollection Constructor (XsltExtensionObjectCollection)

Initializes a new instance of the XsltExtensionObjectCollection class with the specified XsltExtensionObjectCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As XsltExtensionObjectCollection _
)
[C#]
public XsltExtensionObjectCollection(
XsltExtensionObjectCollection value
);

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace | XsltExtensionObjectCollection Constructor Overload List


XsltExtensionObjectCollection Constructor (XsltExtensionObject[])

Initializes a new instance of the XsltExtensionObjectCollection class with the specified array of XsltExtensionObject instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As XsltExtensionObject() _
)
[C#]
public XsltExtensionObjectCollection(
XsltExtensionObject[] value
);

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace | XsltExtensionObjectCollection Constructor Overload List


XsltExtensionObjectCollection Properties

The properties of the XsltExtensionObjectCollection class are listed below. For a complete list of XsltExtensionObjectCollection class members, see the XsltExtensionObjectCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

XsltExtensionObjectCollection.Item Property

Gets or sets the element at the specified index.

Overload List

Gets or sets the element at the specified index.

public XsltExtensionObject this[int] {get; set;}

Gets the XsltExtensionObject with the specified name.

public XsltExtensionObject this[string] {get;}

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace


Item Property (Int32)

NAnt SDK Documentation - v0.91

XsltExtensionObjectCollection.Item Property (Int32)

Gets or sets the element at the specified index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As XsltExtensionObject
[C#]
public XsltExtensionObject this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace | XsltExtensionObjectCollection.Item Overload List


Item Property (String)

NAnt SDK Documentation - v0.91

XsltExtensionObjectCollection.Item Property (String)

Gets the XsltExtensionObject with the specified name.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal value As String _
) As XsltExtensionObject
[C#]
public XsltExtensionObject this[
string value
] {get;}

Parameters

value
The name of the XsltExtensionObject to get.

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace | XsltExtensionObjectCollection.Item Overload List


XsltExtensionObjectCollection Methods

The methods of the XsltExtensionObjectCollection class are listed below. For a complete list of XsltExtensionObjectCollection class members, see the XsltExtensionObjectCollection Members topic.

Public Instance Methods

Add | Adds a XsltExtensionObject to the end of the collection.
AddRange | Overloaded. Adds the elements of a XsltExtensionObject array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a XsltExtensionObject is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified XsltExtensionObject object in the collection.
Insert | Inserts a XsltExtensionObject into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace


XsltExtensionObjectCollection.Add Method

Adds a XsltExtensionObject to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As XsltExtensionObject _
) As Integer
[C#]
public int Add(
XsltExtensionObject item
);

Parameters

item
The XsltExtensionObject to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

XsltExtensionObjectCollection.AddRange Method

Adds the elements of a XsltExtensionObject array to the end of the collection.

Overload List

Adds the elements of a XsltExtensionObject array to the end of the collection.

public void AddRange(XsltExtensionObject[]);

Adds the elements of a XsltExtensionObjectCollection to the end of the collection.

public void AddRange(XsltExtensionObjectCollection);

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace


XsltExtensionObjectCollection.AddRange Method (XsltExtensionObject[])

Adds the elements of a XsltExtensionObject array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As XsltExtensionObject() _
)
[C#]
public void AddRange(
XsltExtensionObject[] items
);

Parameters

items
The array of XsltExtensionObject elements to be added to the end of the collection.

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace | XsltExtensionObjectCollection.AddRange Overload List


XsltExtensionObjectCollection.AddRange Method (XsltExtensionObjectCollection)

Adds the elements of a XsltExtensionObjectCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As XsltExtensionObjectCollection _
)
[C#]
public void AddRange(
XsltExtensionObjectCollection items
);

Parameters

items
The XsltExtensionObjectCollection to be added to the end of the collection.

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace | XsltExtensionObjectCollection.AddRange Overload List


Contains Method

NAnt SDK Documentation - v0.91

XsltExtensionObjectCollection.Contains Method

Determines whether a XsltExtensionObject is in the collection.

Overload List

Determines whether a XsltExtensionObject is in the collection.

public bool Contains(XsltExtensionObject);

Determines whether a XsltExtensionObject with the specified value is in the collection.

public bool Contains(string);

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace


XsltExtensionObjectCollection.Contains Method (XsltExtensionObject)

Determines whether a XsltExtensionObject is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal item As XsltExtensionObject _
) As Boolean
[C#]
public bool Contains(
XsltExtensionObject item
);

Parameters

item
The XsltExtensionObject to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace | XsltExtensionObjectCollection.Contains Overload List


XsltExtensionObjectCollection.Contains Method (String)

Determines whether a XsltExtensionObject with the specified value is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal value As String _
) As Boolean
[C#]
public bool Contains(
string value
);

Parameters

value
The argument value to locate in the collection.

Return Value

true if a XsltExtensionObject with value value is found in the collection; otherwise, false.

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace | XsltExtensionObjectCollection.Contains Overload List


XsltExtensionObjectCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As XsltExtensionObject(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
XsltExtensionObject[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace


XsltExtensionObjectCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As XsltExtensionObjectEnumerator
[C#]
new public XsltExtensionObjectEnumerator GetEnumerator();

Return Value

A XsltExtensionObjectEnumerator for the entire collection.

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace


XsltExtensionObjectCollection.IndexOf Method

Retrieves the index of a specified XsltExtensionObject object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As XsltExtensionObject _
) As Integer
[C#]
public int IndexOf(
XsltExtensionObject item
);

Parameters

item
The XsltExtensionObject object for which the index is returned.

Return Value

The index of the specified XsltExtensionObject. If the XsltExtensionObject is not currently a member of the collection, it returns -1.

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace


XsltExtensionObjectCollection.Insert Method

Inserts a XsltExtensionObject into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As XsltExtensionObject _
)
[C#]
public void Insert(
int index,
XsltExtensionObject item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The XsltExtensionObject to insert.

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace


XsltExtensionObjectCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As XsltExtensionObject _
)
[C#]
public void Remove(
XsltExtensionObject item
);

Parameters

item
The XsltExtensionObject to remove from the collection.

See Also

XsltExtensionObjectCollection Class | NAnt.Core.Types Namespace


XsltExtensionObjectEnumerator Class

Enumerates the XsltExtensionObject elements of a XsltExtensionObjectCollection.

For a list of all members of this type, see XsltExtensionObjectEnumerator Members.

System.Object
NAnt.Core.Types.XsltExtensionObjectEnumerator

[Visual Basic]
Public Class XsltExtensionObjectEnumerator
Implements IEnumerator
[C#]
public class XsltExtensionObjectEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

XsltExtensionObjectEnumerator Members | NAnt.Core.Types Namespace


XsltExtensionObjectEnumerator Members

XsltExtensionObjectEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XsltExtensionObjectEnumerator Class | NAnt.Core.Types Namespace


XsltExtensionObjectEnumerator Properties

The properties of the XsltExtensionObjectEnumerator class are listed below. For a complete list of XsltExtensionObjectEnumerator class members, see the XsltExtensionObjectEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

XsltExtensionObjectEnumerator Class | NAnt.Core.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

XsltExtensionObjectEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As XsltExtensionObject
[C#]
public XsltExtensionObject Current {get;}

See Also

XsltExtensionObjectEnumerator Class | NAnt.Core.Types Namespace


XsltExtensionObjectEnumerator Methods

The methods of the XsltExtensionObjectEnumerator class are listed below. For a complete list of XsltExtensionObjectEnumerator class members, see the XsltExtensionObjectEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XsltExtensionObjectEnumerator Class | NAnt.Core.Types Namespace


XsltExtensionObjectEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

XsltExtensionObjectEnumerator Class | NAnt.Core.Types Namespace


XsltExtensionObjectEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

XsltExtensionObjectEnumerator Class | NAnt.Core.Types Namespace


XsltParameter Class

Represents an XSLT parameter.

For a list of all members of this type, see XsltParameter Members.

System.Object
NAnt.Core.Element
NAnt.Core.Types.XsltParameter

[Visual Basic]
<ElementName(Name:="xsltparameter")>
Public Class XsltParameter
Inherits Element
[C#]
[ElementName(Name="xsltparameter")]
public class XsltParameter : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

XsltParameter Members | NAnt.Core.Types Namespace


XsltParameter Members

XsltParameter overview

Public Instance Constructors

XsltParameter Constructor Initializes a new instance of the XsltParameter class.

Public Instance Properties

IfDefined | Indicates if the parameter should be added to the XSLT argument list. If true then the parameter will be added; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NamespaceUri | The namespace URI to associate with the parameter.
ParameterName | The name of the XSLT parameter.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Indicates if the parameter should not be added to the XSLT argument list. If false then the parameter will be added; otherwise, skipped. The default is false.
Value | The value of the XSLT parameter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XsltParameter Class | NAnt.Core.Types Namespace


XsltParameter Constructor

Initializes a new instance of the XsltParameter class.

[Visual Basic]
Public Sub New()
[C#]
public XsltParameter();

See Also

XsltParameter Class | NAnt.Core.Types Namespace


XsltParameter Properties

The properties of the XsltParameter class are listed below. For a complete list of XsltParameter class members, see the XsltParameter Members topic.

Public Instance Properties

IfDefined | Indicates if the parameter should be added to the XSLT argument list. If true then the parameter will be added; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NamespaceUri | The namespace URI to associate with the parameter.
ParameterName | The name of the XSLT parameter.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Indicates if the parameter should not be added to the XSLT argument list. If false then the parameter will be added; otherwise, skipped. The default is false.
Value | The value of the XSLT parameter.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

XsltParameter Class | NAnt.Core.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

XsltParameter.IfDefined Property

Indicates if the parameter should be added to the XSLT argument list. If true then the parameter will be added; otherwise, skipped. The default is true.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="if", ExpandProperties:=True, ProcessXml:=True)>
Public Property IfDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="if", ExpandProperties=True, ProcessXml=True)]
public bool IfDefined {get; set;}

See Also

XsltParameter Class | NAnt.Core.Types Namespace


NamespaceUri Property

NAnt SDK Documentation - v0.91

XsltParameter.NamespaceUri Property

The namespace URI to associate with the parameter.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="namespaceuri", ExpandProperties:=True, ProcessXml:=True)>
Public Property NamespaceUri As String
[C#]
[TaskAttribute(Required=False, Name="namespaceuri", ExpandProperties=True, ProcessXml=True)]
public string NamespaceUri {get; set;}

Property Value

The namespace URI to associate with the parameter, or Empty if not set.

See Also

XsltParameter Class | NAnt.Core.Types Namespace


ParameterName Property

NAnt SDK Documentation - v0.91

XsltParameter.ParameterName Property

The name of the XSLT parameter.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="name", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property ParameterName As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="name", Required=True, ExpandProperties=True, ProcessXml=True)]
public string ParameterName {get; set;}

Property Value

The name of the XSLT parameter, or Empty if not set.

See Also

XsltParameter Class | NAnt.Core.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

XsltParameter.UnlessDefined Property

Indicates if the parameter should not be added to the XSLT argument list. If false then the parameter will be added; otherwise, skipped. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="unless", ExpandProperties:=True, ProcessXml:=True)>
Public Property UnlessDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="unless", ExpandProperties=True, ProcessXml=True)]
public bool UnlessDefined {get; set;}

See Also

XsltParameter Class | NAnt.Core.Types Namespace


Value Property

NAnt SDK Documentation - v0.91

XsltParameter.Value Property

The value of the XSLT parameter.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="value", ExpandProperties:=True, ProcessXml:=True)>
Public Property Value As String
[C#]
[TaskAttribute(Required=True, Name="value", ExpandProperties=True, ProcessXml=True)]
public string Value {get; set;}

Property Value

The value of the XSLT parameter, or Empty if not set.

See Also

XsltParameter Class | NAnt.Core.Types Namespace


XsltParameterCollection Class

Contains a collection of XsltParameter elements.

For a list of all members of this type, see XsltParameterCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.Core.Types.XsltParameterCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class XsltParameterCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class XsltParameterCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

XsltParameterCollection Members | NAnt.Core.Types Namespace


XsltParameterCollection Members

XsltParameterCollection overview

Public Instance Constructors

XsltParameterCollection Overloaded. Initializes a new instance of the XsltParameterCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a XsltParameter to the end of the collection.
AddRange | Overloaded. Adds the elements of a XsltParameter array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a XsltParameter is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified XsltParameter object in the collection.
Insert | Inserts a XsltParameter into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace


XsltParameterCollection Constructor

Initializes a new instance of the XsltParameterCollection class.

Overload List

Initializes a new instance of the XsltParameterCollection class.

public XsltParameterCollection();

Initializes a new instance of the XsltParameterCollection class with the specified array of XsltParameter instances.

public XsltParameterCollection(XsltParameter[]);

Initializes a new instance of the XsltParameterCollection class with the specified XsltParameterCollection instance.

public XsltParameterCollection(XsltParameterCollection);

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace


XsltParameterCollection Constructor ()

Initializes a new instance of the XsltParameterCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public XsltParameterCollection();

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace | XsltParameterCollection Constructor Overload List


XsltParameterCollection Constructor (XsltParameterCollection)

Initializes a new instance of the XsltParameterCollection class with the specified XsltParameterCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As XsltParameterCollection _
)
[C#]
public XsltParameterCollection(
XsltParameterCollection value
);

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace | XsltParameterCollection Constructor Overload List


XsltParameterCollection Constructor (XsltParameter[])

Initializes a new instance of the XsltParameterCollection class with the specified array of XsltParameter instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As XsltParameter() _
)
[C#]
public XsltParameterCollection(
XsltParameter[] value
);

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace | XsltParameterCollection Constructor Overload List


XsltParameterCollection Properties

The properties of the XsltParameterCollection class are listed below. For a complete list of XsltParameterCollection class members, see the XsltParameterCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

XsltParameterCollection.Item Property

Gets or sets the element at the specified index.

Overload List

Gets or sets the element at the specified index.

public XsltParameter this[int] {get; set;}

Gets the XsltParameter with the specified name.

public XsltParameter this[string] {get;}

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace


Item Property (Int32)

NAnt SDK Documentation - v0.91

XsltParameterCollection.Item Property (Int32)

Gets or sets the element at the specified index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As XsltParameter
[C#]
public XsltParameter this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace | XsltParameterCollection.Item Overload List


Item Property (String)

NAnt SDK Documentation - v0.91

XsltParameterCollection.Item Property (String)

Gets the XsltParameter with the specified name.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal value As String _
) As XsltParameter
[C#]
public XsltParameter this[
string value
] {get;}

Parameters

value
The name of the XsltParameter to get.

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace | XsltParameterCollection.Item Overload List


XsltParameterCollection Methods

The methods of the XsltParameterCollection class are listed below. For a complete list of XsltParameterCollection class members, see the XsltParameterCollection Members topic.

Public Instance Methods

Add | Adds a XsltParameter to the end of the collection.
AddRange | Overloaded. Adds the elements of a XsltParameter array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a XsltParameter is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified XsltParameter object in the collection.
Insert | Inserts a XsltParameter into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace


XsltParameterCollection.Add Method

Adds a XsltParameter to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As XsltParameter _
) As Integer
[C#]
public int Add(
XsltParameter item
);

Parameters

item
The XsltParameter to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

XsltParameterCollection.AddRange Method

Adds the elements of a XsltParameter array to the end of the collection.

Overload List

Adds the elements of a XsltParameter array to the end of the collection.

public void AddRange(XsltParameter[]);

Adds the elements of a XsltParameterCollection to the end of the collection.

public void AddRange(XsltParameterCollection);

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace


XsltParameterCollection.AddRange Method (XsltParameter[])

Adds the elements of a XsltParameter array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As XsltParameter() _
)
[C#]
public void AddRange(
XsltParameter[] items
);

Parameters

items
The array of XsltParameter elements to be added to the end of the collection.

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace | XsltParameterCollection.AddRange Overload List


XsltParameterCollection.AddRange Method (XsltParameterCollection)

Adds the elements of a XsltParameterCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As XsltParameterCollection _
)
[C#]
public void AddRange(
XsltParameterCollection items
);

Parameters

items
The XsltParameterCollection to be added to the end of the collection.

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace | XsltParameterCollection.AddRange Overload List


Contains Method

NAnt SDK Documentation - v0.91

XsltParameterCollection.Contains Method

Determines whether a XsltParameter is in the collection.

Overload List

Determines whether a XsltParameter is in the collection.

public bool Contains(XsltParameter);

Determines whether a XsltParameter with the specified value is in the collection.

public bool Contains(string);

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace


XsltParameterCollection.Contains Method (XsltParameter)

Determines whether a XsltParameter is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal item As XsltParameter _
) As Boolean
[C#]
public bool Contains(
XsltParameter item
);

Parameters

item
The XsltParameter to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace | XsltParameterCollection.Contains Overload List


XsltParameterCollection.Contains Method (String)

Determines whether a XsltParameter with the specified value is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal value As String _
) As Boolean
[C#]
public bool Contains(
string value
);

Parameters

value
The argument value to locate in the collection.

Return Value

true if a XsltParameter with value value is found in the collection; otherwise, false.

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace | XsltParameterCollection.Contains Overload List


XsltParameterCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As XsltParameter(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
XsltParameter[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace


XsltParameterCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As XsltParameterEnumerator
[C#]
new public XsltParameterEnumerator GetEnumerator();

Return Value

A XsltParameterEnumerator for the entire collection.

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace


XsltParameterCollection.IndexOf Method

Retrieves the index of a specified XsltParameter object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As XsltParameter _
) As Integer
[C#]
public int IndexOf(
XsltParameter item
);

Parameters

item
The XsltParameter object for which the index is returned.

Return Value

The index of the specified XsltParameter. If the XsltParameter is not currently a member of the collection, it returns -1.

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace


XsltParameterCollection.Insert Method

Inserts a XsltParameter into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As XsltParameter _
)
[C#]
public void Insert(
int index,
XsltParameter item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The XsltParameter to insert.

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace


XsltParameterCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As XsltParameter _
)
[C#]
public void Remove(
XsltParameter item
);

Parameters

item
The XsltParameter to remove from the collection.

See Also

XsltParameterCollection Class | NAnt.Core.Types Namespace


XsltParameterEnumerator Class

Enumerates the XsltParameter elements of a XsltParameterCollection.

For a list of all members of this type, see XsltParameterEnumerator Members.

System.Object
NAnt.Core.Types.XsltParameterEnumerator

[Visual Basic]
Public Class XsltParameterEnumerator
Implements IEnumerator
[C#]
public class XsltParameterEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Types

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

XsltParameterEnumerator Members | NAnt.Core.Types Namespace


XsltParameterEnumerator Members

XsltParameterEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XsltParameterEnumerator Class | NAnt.Core.Types Namespace


XsltParameterEnumerator Properties

The properties of the XsltParameterEnumerator class are listed below. For a complete list of XsltParameterEnumerator class members, see the XsltParameterEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

XsltParameterEnumerator Class | NAnt.Core.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

XsltParameterEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As XsltParameter
[C#]
public XsltParameter Current {get;}

See Also

XsltParameterEnumerator Class | NAnt.Core.Types Namespace


XsltParameterEnumerator Methods

The methods of the XsltParameterEnumerator class are listed below. For a complete list of XsltParameterEnumerator class members, see the XsltParameterEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XsltParameterEnumerator Class | NAnt.Core.Types Namespace


XsltParameterEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

XsltParameterEnumerator Class | NAnt.Core.Types Namespace


XsltParameterEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

XsltParameterEnumerator Class | NAnt.Core.Types Namespace


NAnt.Core.Util

NAnt SDK Documentation - v0.91

NAnt.Core.Util Namespace

Namespace hierarchy

Classes

Class | Description
AssemblyResolver | Resolves assemblies by caching assemblies that were loaded.
CommandLineArgument | Represents a valid command-line argument.
CommandLineArgumentAttribute | Allows control of command line parsing.
CommandLineArgumentCollection | Contains a strongly typed collection of CommandLineArgument objects.
CommandLineArgumentEnumerator | Enumerates the CommandLineArgument elements of a CommandLineArgumentCollection.
CommandLineArgumentException | The exception that is thrown when one of the command-line arguments provided is not valid.
CommandLineParser | Commandline parser.
DateTimeProvider |
DefaultCommandLineArgumentAttribute | Marks a command-line option as being the default option. When the name of a command-line argument is not specified, this option will be assumed.
FileUtils | Provides modified version for Copy and Move from the File class that allow for filter chain processing.
GacCache | Helper class for determining whether assemblies are located in the Global Assembly Cache.
ReflectionUtils | Provides a set of helper methods related to reflection.
ResourceUtils | Provides resource support to NAnt assemblies. This class cannot be inherited from.
StopWatchStack |
StringUtils | Groups a set of useful String manipulation and validation methods.

Enumerations

Enumeration | Description
CommandLineArgumentTypes | Used to control parsing of command-line arguments.


AssemblyResolver Class

Resolves assemblies by caching assemblies that were loaded.

For a list of all members of this type, see AssemblyResolver Members.

System.Object
NAnt.Core.Util.AssemblyResolver

[Visual Basic]
<Serializable, _ Serializable>
NotInheritable Public Class AssemblyResolver
[C#]
[Serializable]
[Serializable]
public sealed class AssemblyResolver

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Util

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

AssemblyResolver Members | NAnt.Core.Util Namespace


AssemblyResolver Members

AssemblyResolver overview

Public Instance Constructors

AssemblyResolver Overloaded. Initializes a new instance of the AssemblyResolver class.

Public Instance Methods

Attach | Installs the assembly resolver by hooking up to the AssemblyResolve event.
Detach | Uninstalls the assembly resolver.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AssemblyResolver Class | NAnt.Core.Util Namespace


AssemblyResolver Constructor

Initializes an instanse of the AssemblyResolver class.

Overload List

Initializes an instanse of the AssemblyResolver class.

public AssemblyResolver();

Initializes an instanse of the AssemblyResolver class in the context of the given Task.

public AssemblyResolver(Task);

See Also

AssemblyResolver Class | NAnt.Core.Util Namespace


AssemblyResolver Constructor ()

Initializes an instanse of the AssemblyResolver class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public AssemblyResolver();

See Also

AssemblyResolver Class | NAnt.Core.Util Namespace | AssemblyResolver Constructor Overload List


AssemblyResolver Constructor (Task)

Initializes an instanse of the AssemblyResolver class in the context of the given Task.

[Visual Basic]
Overloads Public Sub New( _
ByVal task As Task _
)
[C#]
public AssemblyResolver(
Task task
);

See Also

AssemblyResolver Class | NAnt.Core.Util Namespace | AssemblyResolver Constructor Overload List


AssemblyResolver Methods

The methods of the AssemblyResolver class are listed below. For a complete list of AssemblyResolver class members, see the AssemblyResolver Members topic.

Public Instance Methods

Attach | Installs the assembly resolver by hooking up to the AssemblyResolve event.
Detach | Uninstalls the assembly resolver.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AssemblyResolver Class | NAnt.Core.Util Namespace


AssemblyResolver.Attach Method

Installs the assembly resolver by hooking up to the AssemblyResolve event.

[Visual Basic]
Public Sub Attach()
[C#]
public void Attach();

See Also

AssemblyResolver Class | NAnt.Core.Util Namespace


AssemblyResolver.Detach Method

Uninstalls the assembly resolver.

[Visual Basic]
Public Sub Detach()
[C#]
public void Detach();

See Also

AssemblyResolver Class | NAnt.Core.Util Namespace


CommandLineArgument Class

Represents a valid command-line argument.

For a list of all members of this type, see CommandLineArgument Members.

System.Object
NAnt.Core.Util.CommandLineArgument

[Visual Basic]
Public Class CommandLineArgument
[C#]
public class CommandLineArgument

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Util

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

CommandLineArgument Members | NAnt.Core.Util Namespace


CommandLineArgument Members

CommandLineArgument overview

Public Instance Constructors

CommandLineArgument Constructor

Public Instance Properties

AllowMultiple | Gets a value indicating whether the argument can be specified multiple times.
Description | Gets the description of the argument.
IsArray | Gets a value indicating whether the argument is array-based.
IsCollection | Gets a value indicating whether the argument is collection-based.
IsDefault | Gets a value indicating whether the argument is the default argument.
IsExclusive | Gets a value indicating whether the argument cannot be combined with other arguments.
IsNameValueCollection | Gets a value indicating whether the argument is a set of name/value pairs.
IsRequired | Gets a value indicating whether the argument is required.
LongName | Gets the long name of the argument.
Property | Gets the property that backs the argument.
SeenValue | Gets a value indicating whether a mathing command-line argument was already found.
ShortName | Gets the short name of the argument.
Type | Gets the Type of the property to which the argument is applied.
Unique | Gets a value indicating whether the argument can only be specified once with a certain value.
ValueType | Gets the underlying Type of the argument.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Finish | Sets the value of the argument on the specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
SetValue | Assigns the specified value to the argument.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


CommandLineArgument Constructor

[Visual Basic]
Public Sub New( _
ByVal attribute As CommandLineArgumentAttribute, _
ByVal propertyInfo As PropertyInfo _
)
[C#]
public CommandLineArgument(
CommandLineArgumentAttribute attribute,
PropertyInfo propertyInfo
);

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


CommandLineArgument Properties

The properties of the CommandLineArgument class are listed below. For a complete list of CommandLineArgument class members, see the CommandLineArgument Members topic.

Public Instance Properties

AllowMultiple | Gets a value indicating whether the argument can be specified multiple times.
Description | Gets the description of the argument.
IsArray | Gets a value indicating whether the argument is array-based.
IsCollection | Gets a value indicating whether the argument is collection-based.
IsDefault | Gets a value indicating whether the argument is the default argument.
IsExclusive | Gets a value indicating whether the argument cannot be combined with other arguments.
IsNameValueCollection | Gets a value indicating whether the argument is a set of name/value pairs.
IsRequired | Gets a value indicating whether the argument is required.
LongName | Gets the long name of the argument.
Property | Gets the property that backs the argument.
SeenValue | Gets a value indicating whether a mathing command-line argument was already found.
ShortName | Gets the short name of the argument.
Type | Gets the Type of the property to which the argument is applied.
Unique | Gets a value indicating whether the argument can only be specified once with a certain value.
ValueType | Gets the underlying Type of the argument.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


AllowMultiple Property

NAnt SDK Documentation - v0.91

CommandLineArgument.AllowMultiple Property

Gets a value indicating whether the argument can be specified multiple times.

[Visual Basic]
Public ReadOnly Property AllowMultiple As Boolean
[C#]
public bool AllowMultiple {get;}

Property Value

true if the argument may be specified multiple times; otherwise, false.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


Description Property

NAnt SDK Documentation - v0.91

CommandLineArgument.Description Property

Gets the description of the argument.

[Visual Basic]
Public ReadOnly Property Description As String
[C#]
public string Description {get;}

Property Value

The description of the argument.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


IsArray Property

NAnt SDK Documentation - v0.91

CommandLineArgument.IsArray Property

Gets a value indicating whether the argument is array-based.

[Visual Basic]
Public ReadOnly Property IsArray As Boolean
[C#]
public bool IsArray {get;}

Property Value

true if the argument is backed by an array; otherwise, false.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


IsCollection Property

NAnt SDK Documentation - v0.91

CommandLineArgument.IsCollection Property

Gets a value indicating whether the argument is collection-based.

[Visual Basic]
Public ReadOnly Property IsCollection As Boolean
[C#]
public bool IsCollection {get;}

Property Value

true if the argument is backed by a Type that can be assigned to ICollection and is not backed by a Type that can be assigned to NameValueCollection; otherwise, false.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


IsDefault Property

NAnt SDK Documentation - v0.91

CommandLineArgument.IsDefault Property

Gets a value indicating whether the argument is the default argument.

[Visual Basic]
Public ReadOnly Property IsDefault As Boolean
[C#]
public bool IsDefault {get;}

Property Value

true if the argument is the default argument; otherwise, false.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


IsExclusive Property

NAnt SDK Documentation - v0.91

CommandLineArgument.IsExclusive Property

Gets a value indicating whether the argument cannot be combined with other arguments.

[Visual Basic]
Public ReadOnly Property IsExclusive As Boolean
[C#]
public bool IsExclusive {get;}

Property Value

true if the argument cannot be combined with other arguments; otherwise, false.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


IsNameValueCollection Property

NAnt SDK Documentation - v0.91

CommandLineArgument.IsNameValueCollection Property

Gets a value indicating whether the argument is a set of name/value pairs.

[Visual Basic]
Public ReadOnly Property IsNameValueCollection As Boolean
[C#]
public bool IsNameValueCollection {get;}

Property Value

true if the argument is backed by a Type that can be assigned to NameValueCollection; otherwise, false.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


IsRequired Property

NAnt SDK Documentation - v0.91

CommandLineArgument.IsRequired Property

Gets a value indicating whether the argument is required.

[Visual Basic]
Public ReadOnly Property IsRequired As Boolean
[C#]
public bool IsRequired {get;}

Property Value

true if the argument is required; otherwise, false.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


LongName Property

NAnt SDK Documentation - v0.91

CommandLineArgument.LongName Property

Gets the long name of the argument.

[Visual Basic]
Public ReadOnly Property LongName As String
[C#]
public string LongName {get;}

Property Value

The long name of the argument.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


Property Property

NAnt SDK Documentation - v0.91

CommandLineArgument.Property Property

Gets the property that backs the argument.

[Visual Basic]
Public ReadOnly Property Property As PropertyInfo
[C#]
public System.Reflection.PropertyInfo Property {get;}

Property Value

The property that backs the arguments.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


SeenValue Property

NAnt SDK Documentation - v0.91

CommandLineArgument.SeenValue Property

Gets a value indicating whether a mathing command-line argument was already found.

[Visual Basic]
Public ReadOnly Property SeenValue As Boolean
[C#]
public bool SeenValue {get;}

Property Value

true if a matching command-line argument was already found; otherwise, false.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


ShortName Property

NAnt SDK Documentation - v0.91

CommandLineArgument.ShortName Property

Gets the short name of the argument.

[Visual Basic]
Public ReadOnly Property ShortName As String
[C#]
public string ShortName {get;}

Property Value

The short name of the argument.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


Type Property

NAnt SDK Documentation - v0.91

CommandLineArgument.Type Property

Gets the Type of the property to which the argument is applied.

[Visual Basic]
Public ReadOnly Property Type As Type
[C#]
public System.Type Type {get;}

Property Value

The Type of the property to which the argument is applied.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


Unique Property

NAnt SDK Documentation - v0.91

CommandLineArgument.Unique Property

Gets a value indicating whether the argument can only be specified once with a certain value.

[Visual Basic]
Public ReadOnly Property Unique As Boolean
[C#]
public bool Unique {get;}

Property Value

true if the argument should always have a unique value; otherwise, false.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


ValueType Property

NAnt SDK Documentation - v0.91

CommandLineArgument.ValueType Property

Gets the underlying Type of the argument.

[Visual Basic]
Public ReadOnly Property ValueType As Type
[C#]
public System.Type ValueType {get;}

Property Value

The underlying Type of the argument.

Remarks

If the Type of the argument is a collection type, this property will returns the underlying type of that collection.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


CommandLineArgument Methods

The methods of the CommandLineArgument class are listed below. For a complete list of CommandLineArgument class members, see the CommandLineArgument Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Finish | Sets the value of the argument on the specified object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
SetValue | Assigns the specified value to the argument.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


CommandLineArgument.Finish Method

Sets the value of the argument on the specified object.

[Visual Basic]
Public Sub Finish( _
ByVal destination As Object _
)
[C#]
public void Finish(
object destination
);

Parameters

destination
The object on which the value of the argument should be set.

Exceptions

Exception Type | Condition
CommandLineArgumentException | The argument is required and no value was specified.
NotSupportedException | The matching property is collection-based, but is not initialized and cannot be written to. -or- The matching property is collection-based, but has no strongly-typed Add method. -or- The matching property is collection-based, but the signature of the Add method is not supported.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


CommandLineArgument.SetValue Method

Assigns the specified value to the argument.

[Visual Basic]
Public Sub SetValue( _
ByVal value As String _
)
[C#]
public void SetValue(
string value
);

Parameters

value
The value that should be assigned to the argument.

Exceptions

Exception Type | Condition
CommandLineArgumentException | Duplicate argument. -or- Invalid value.

See Also

CommandLineArgument Class | NAnt.Core.Util Namespace


CommandLineArgumentAttribute Class

Allows control of command line parsing.

For a list of all members of this type, see CommandLineArgumentAttribute Members.

System.Object
System.Attribute
NAnt.Core.Util.CommandLineArgumentAttribute
NAnt.Core.Util.DefaultCommandLineArgumentAttribute

[Visual Basic]
<AttributeUsage(ValidOn:=AttributeTargets.Property, AllowMultiple:=False, Inherited:=True)>
Public Class CommandLineArgumentAttribute
Inherits Attribute
[C#]
[AttributeUsage(ValidOn=AttributeTargets.Property, AllowMultiple=False, Inherited=True)]
public class CommandLineArgumentAttribute : Attribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Util

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

CommandLineArgumentAttribute Members | NAnt.Core.Util Namespace


CommandLineArgumentAttribute Members

CommandLineArgumentAttribute overview

Public Instance Constructors

CommandLineArgumentAttribute Constructor Initializes a new instance of the CommandLineArgumentAttribute class with the specified argument type.

Public Instance Properties

Description | Gets or sets the description of the argument.
Name | Gets or sets the long name of the argument.
ShortName | Gets or sets the short name of the argument.
Type | Gets or sets the checking to be done on the argument.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandLineArgumentAttribute Class | NAnt.Core.Util Namespace


CommandLineArgumentAttribute Constructor

Initializes a new instance of the CommandLineArgumentAttribute class with the specified argument type.

[Visual Basic]
Public Sub New( _
ByVal argumentType As CommandLineArgumentTypes _
)
[C#]
public CommandLineArgumentAttribute(
CommandLineArgumentTypes argumentType
);

Parameters

argumentType
Specifies the checking to be done on the argument.

See Also

CommandLineArgumentAttribute Class | NAnt.Core.Util Namespace


CommandLineArgumentAttribute Properties

The properties of the CommandLineArgumentAttribute class are listed below. For a complete list of CommandLineArgumentAttribute class members, see the CommandLineArgumentAttribute Members topic.

Public Instance Properties

Description | Gets or sets the description of the argument.
Name | Gets or sets the long name of the argument.
ShortName | Gets or sets the short name of the argument.
Type | Gets or sets the checking to be done on the argument.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

CommandLineArgumentAttribute Class | NAnt.Core.Util Namespace


Description Property

NAnt SDK Documentation - v0.91

CommandLineArgumentAttribute.Description Property

Gets or sets the description of the argument.

[Visual Basic]
Public Property Description As String
[C#]
public string Description {get; set;}

Property Value

The description of the argument.

See Also

CommandLineArgumentAttribute Class | NAnt.Core.Util Namespace


Name Property

NAnt SDK Documentation - v0.91

CommandLineArgumentAttribute.Name Property

Gets or sets the long name of the argument.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}

Property Value

The long name of the argument.

See Also

CommandLineArgumentAttribute Class | NAnt.Core.Util Namespace


ShortName Property

NAnt SDK Documentation - v0.91

CommandLineArgumentAttribute.ShortName Property

Gets or sets the short name of the argument.

[Visual Basic]
Public Property ShortName As String
[C#]
public string ShortName {get; set;}

Property Value

The short name of the argument.

See Also

CommandLineArgumentAttribute Class | NAnt.Core.Util Namespace


Type Property

NAnt SDK Documentation - v0.91

CommandLineArgumentAttribute.Type Property

Gets or sets the checking to be done on the argument.

[Visual Basic]
Public ReadOnly Property Type As CommandLineArgumentTypes
[C#]
public CommandLineArgumentTypes Type {get;}

Property Value

The checking that should be done on the argument.

See Also

CommandLineArgumentAttribute Class | NAnt.Core.Util Namespace


CommandLineArgumentCollection Class

Contains a strongly typed collection of CommandLineArgument objects.

For a list of all members of this type, see CommandLineArgumentCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.Core.Util.CommandLineArgumentCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class CommandLineArgumentCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class CommandLineArgumentCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Util

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

CommandLineArgumentCollection Members | NAnt.Core.Util Namespace


CommandLineArgumentCollection Members

CommandLineArgumentCollection overview

Public Instance Constructors

CommandLineArgumentCollection Overloaded. Initializes a new instance of the CommandLineArgumentCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a CommandLineArgument to the end of the collection.
AddRange | Overloaded. Adds the elements of a CommandLineArgument array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a CommandLineArgument is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified CommandLineArgument object in the collection.
Insert | Inserts a CommandLineArgument into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace


CommandLineArgumentCollection Constructor

Initializes a new instance of the CommandLineArgumentCollection class.

Overload List

Initializes a new instance of the CommandLineArgumentCollection class.

public CommandLineArgumentCollection();

Initializes a new instance of the CommandLineArgumentCollection class with the specified array of CommandLineArgument instances.

public CommandLineArgumentCollection(CommandLineArgument[]);

Initializes a new instance of the CommandLineArgumentCollection class with the specified CommandLineArgumentCollection instance.

public CommandLineArgumentCollection(CommandLineArgumentCollection);

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace


CommandLineArgumentCollection Constructor ()

Initializes a new instance of the CommandLineArgumentCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CommandLineArgumentCollection();

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace | CommandLineArgumentCollection Constructor Overload List


CommandLineArgumentCollection Constructor (CommandLineArgumentCollection)

Initializes a new instance of the CommandLineArgumentCollection class with the specified CommandLineArgumentCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As CommandLineArgumentCollection _
)
[C#]
public CommandLineArgumentCollection(
CommandLineArgumentCollection value
);

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace | CommandLineArgumentCollection Constructor Overload List


CommandLineArgumentCollection Constructor (CommandLineArgument[])

Initializes a new instance of the CommandLineArgumentCollection class with the specified array of CommandLineArgument instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As CommandLineArgument() _
)
[C#]
public CommandLineArgumentCollection(
CommandLineArgument[] value
);

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace | CommandLineArgumentCollection Constructor Overload List


CommandLineArgumentCollection Properties

The properties of the CommandLineArgumentCollection class are listed below. For a complete list of CommandLineArgumentCollection class members, see the CommandLineArgumentCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace


Item Property

NAnt SDK Documentation - v0.91

CommandLineArgumentCollection.Item Property

Gets or sets the element at the specified index.

Overload List

Gets or sets the element at the specified index.

public CommandLineArgument this[int] {get; set;}

Gets the CommandLineArgument with the specified name.

public CommandLineArgument this[string] {get;}

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace


Item Property (Int32)

NAnt SDK Documentation - v0.91

CommandLineArgumentCollection.Item Property (Int32)

Gets or sets the element at the specified index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As CommandLineArgument
[C#]
public CommandLineArgument this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace | CommandLineArgumentCollection.Item Overload List


Item Property (String)

NAnt SDK Documentation - v0.91

CommandLineArgumentCollection.Item Property (String)

Gets the CommandLineArgument with the specified name.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal name As String _
) As CommandLineArgument
[C#]
public CommandLineArgument this[
string name
] {get;}

Parameters

name
The name of the CommandLineArgument to get.

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace | CommandLineArgumentCollection.Item Overload List


CommandLineArgumentCollection Methods

The methods of the CommandLineArgumentCollection class are listed below. For a complete list of CommandLineArgumentCollection class members, see the CommandLineArgumentCollection Members topic.

Public Instance Methods

Add | Adds a CommandLineArgument to the end of the collection.
AddRange | Overloaded. Adds the elements of a CommandLineArgument array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a CommandLineArgument is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified CommandLineArgument object in the collection.
Insert | Inserts a CommandLineArgument into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace


CommandLineArgumentCollection.Add Method

Adds a CommandLineArgument to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As CommandLineArgument _
) As Integer
[C#]
public int Add(
CommandLineArgument item
);

Parameters

item
The CommandLineArgument to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace


AddRange Method

NAnt SDK Documentation - v0.91

CommandLineArgumentCollection.AddRange Method

Adds the elements of a CommandLineArgument array to the end of the collection.

Overload List

Adds the elements of a CommandLineArgument array to the end of the collection.

public void AddRange(CommandLineArgument[]);

Adds the elements of a CommandLineArgumentCollection to the end of the collection.

public void AddRange(CommandLineArgumentCollection);

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace


CommandLineArgumentCollection.AddRange Method (CommandLineArgument[])

Adds the elements of a CommandLineArgument array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As CommandLineArgument() _
)
[C#]
public void AddRange(
CommandLineArgument[] items
);

Parameters

items
The array of CommandLineArgument elements to be added to the end of the collection.

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace | CommandLineArgumentCollection.AddRange Overload List


CommandLineArgumentCollection.AddRange Method (CommandLineArgumentCollection)

Adds the elements of a CommandLineArgumentCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As CommandLineArgumentCollection _
)
[C#]
public void AddRange(
CommandLineArgumentCollection items
);

Parameters

items
The CommandLineArgumentCollection to be added to the end of the collection.

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace | CommandLineArgumentCollection.AddRange Overload List


CommandLineArgumentCollection.Contains Method

Determines whether a CommandLineArgument is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal item As CommandLineArgument _
) As Boolean
[C#]
public bool Contains(
CommandLineArgument item
);

Parameters

item
The CommandLineArgument to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace


CommandLineArgumentCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As CommandLineArgument(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
CommandLineArgument[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace


CommandLineArgumentCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As CommandLineArgumentEnumerator
[C#]
new public CommandLineArgumentEnumerator GetEnumerator();

Return Value

A CommandLineArgumentEnumerator for the entire collection.

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace


CommandLineArgumentCollection.IndexOf Method

Retrieves the index of a specified CommandLineArgument object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As CommandLineArgument _
) As Integer
[C#]
public int IndexOf(
CommandLineArgument item
);

Parameters

item
The CommandLineArgument object for which the index is returned.

Return Value

The index of the specified CommandLineArgument. If the CommandLineArgument is not currently a member of the collection, it returns -1.

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace


CommandLineArgumentCollection.Insert Method

Inserts a CommandLineArgument into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As CommandLineArgument _
)
[C#]
public void Insert(
int index,
CommandLineArgument item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The CommandLineArgument to insert.

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace


CommandLineArgumentCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As CommandLineArgument _
)
[C#]
public void Remove(
CommandLineArgument item
);

Parameters

item
The CommandLineArgument to remove from the collection.

See Also

CommandLineArgumentCollection Class | NAnt.Core.Util Namespace


CommandLineArgumentEnumerator Class

Enumerates the CommandLineArgument elements of a CommandLineArgumentCollection.

For a list of all members of this type, see CommandLineArgumentEnumerator Members.

System.Object
NAnt.Core.Util.CommandLineArgumentEnumerator

[Visual Basic]
Public Class CommandLineArgumentEnumerator
Implements IEnumerator
[C#]
public class CommandLineArgumentEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Util

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

CommandLineArgumentEnumerator Members | NAnt.Core.Util Namespace


CommandLineArgumentEnumerator Members

CommandLineArgumentEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandLineArgumentEnumerator Class | NAnt.Core.Util Namespace


CommandLineArgumentEnumerator Properties

The properties of the CommandLineArgumentEnumerator class are listed below. For a complete list of CommandLineArgumentEnumerator class members, see the CommandLineArgumentEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

CommandLineArgumentEnumerator Class | NAnt.Core.Util Namespace


Current Property

NAnt SDK Documentation - v0.91

CommandLineArgumentEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As CommandLineArgument
[C#]
public CommandLineArgument Current {get;}

See Also

CommandLineArgumentEnumerator Class | NAnt.Core.Util Namespace


CommandLineArgumentEnumerator Methods

The methods of the CommandLineArgumentEnumerator class are listed below. For a complete list of CommandLineArgumentEnumerator class members, see the CommandLineArgumentEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandLineArgumentEnumerator Class | NAnt.Core.Util Namespace


CommandLineArgumentEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

CommandLineArgumentEnumerator Class | NAnt.Core.Util Namespace


CommandLineArgumentEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

CommandLineArgumentEnumerator Class | NAnt.Core.Util Namespace


CommandLineArgumentException Class

The exception that is thrown when one of the command-line arguments provided is not valid.

For a list of all members of this type, see CommandLineArgumentException Members.

System.Object
System.Exception
System.SystemException
System.ArgumentException
NAnt.Core.Util.CommandLineArgumentException

[Visual Basic]
<Serializable, _ Serializable>
NotInheritable Public Class CommandLineArgumentException
Inherits ArgumentException
[C#]
[Serializable]
[Serializable]
public sealed class CommandLineArgumentException : ArgumentException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Util

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

CommandLineArgumentException Members | NAnt.Core.Util Namespace


CommandLineArgumentException Members

CommandLineArgumentException overview

Public Instance Constructors

CommandLineArgumentException Overloaded. Initializes a new instance of the CommandLineArgumentException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from ArgumentException) | Gets the error message and the parameter name, or only the error message if no parameter name is set.
ParamName (inherited from ArgumentException) | Gets the name of the parameter that causes this exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetObjectData (inherited from ArgumentException) | Sets the SerializationInfo object with the parameter name and additional exception information.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

See Also

CommandLineArgumentException Class | NAnt.Core.Util Namespace


CommandLineArgumentException Constructor

Initializes a new instance of the CommandLineArgumentException class.

Overload List

Initializes a new instance of the CommandLineArgumentException class.

public CommandLineArgumentException();

Initializes a new instance of the CommandLineArgumentException class with a descriptive message.

public CommandLineArgumentException(string);

Initializes a new instance of the CommandLineArgumentException class with a descriptive message and an inner exception.

public CommandLineArgumentException(string,Exception);

See Also

CommandLineArgumentException Class | NAnt.Core.Util Namespace


CommandLineArgumentException Constructor ()

Initializes a new instance of the CommandLineArgumentException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CommandLineArgumentException();

See Also

CommandLineArgumentException Class | NAnt.Core.Util Namespace | CommandLineArgumentException Constructor Overload List


CommandLineArgumentException Constructor (String)

Initializes a new instance of the CommandLineArgumentException class with a descriptive message.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public CommandLineArgumentException(
string message
);

Parameters

message
A descriptive message to include with the exception.

See Also

CommandLineArgumentException Class | NAnt.Core.Util Namespace | CommandLineArgumentException Constructor Overload List


CommandLineArgumentException Constructor (String, Exception)

Initializes a new instance of the CommandLineArgumentException class with a descriptive message and an inner exception.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
[C#]
public CommandLineArgumentException(
string message,
Exception innerException
);

Parameters

message
A descriptive message to include with the exception.
innerException
A nested exception that is the cause of the current exception.

See Also

CommandLineArgumentException Class | NAnt.Core.Util Namespace | CommandLineArgumentException Constructor Overload List


CommandLineArgumentTypes Enumeration

Used to control parsing of command-line arguments.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Serializable, _ Flags>
Public Enum CommandLineArgumentTypes
[C#]
[Serializable]
[Flags]
public enum CommandLineArgumentTypes

Members

Member Name | Description | Value
Required | Indicates that this field is required. An error will be displayed if it is not present when parsing arguments. | 1
Unique | Only valid in conjunction with Multiple. Duplicate values will result in an error. | 2
Multiple | Inidicates that the argument may be specified more than once. Only valid if the argument is a collection | 4
Exclusive | Inidicates that if this argument is specified, no other arguments may be specified. | 8
AtMostOnce | The default type for non-collection arguments. The argument is not required, but an error will be reported if it is specified more than once. | 0
MultipleUnique | The default type for collection arguments. The argument is permitted to occur multiple times, but duplicate values will cause an error to be reported. | 6

Requirements

Namespace: NAnt.Core.Util

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

NAnt.Core.Util Namespace


CommandLineParser Class

Commandline parser.

For a list of all members of this type, see CommandLineParser Members.

System.Object
NAnt.Core.Util.CommandLineParser

[Visual Basic]
Public Class CommandLineParser
[C#]
public class CommandLineParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Util

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

CommandLineParser Members | NAnt.Core.Util Namespace


CommandLineParser Members

CommandLineParser overview

Public Instance Constructors

CommandLineParser Constructor Initializes a new instance of the CommandLineParser class using possible arguments deducted from the specific Type.

Public Instance Properties

LogoBanner | Gets a logo banner using version and copyright attributes defined on the GetEntryAssembly or the GetCallingAssembly.
NoArgs | Gets a value indicating whether no arguments were specified on the command line.
Usage | Gets the usage instructions.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Parse | Parses an argument list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandLineParser Class | NAnt.Core.Util Namespace


CommandLineParser Constructor

Initializes a new instance of the CommandLineParser class using possible arguments deducted from the specific Type.

[Visual Basic]
Public Sub New( _
ByVal argumentSpecification As Type, _
ByVal supportsResponseFile As Boolean _
)
[C#]
public CommandLineParser(
Type argumentSpecification,
bool supportsResponseFile
);

Parameters

argumentSpecification
The Type from which the possible command-line arguments should be retrieved.
supportsResponseFile
A Boolean value indicating whether or not a response file is able to be used.

Exceptions

Exception Type | Condition
ArgumentNullException | argumentSpecification is a null reference.

See Also

CommandLineParser Class | NAnt.Core.Util Namespace


CommandLineParser Properties

The properties of the CommandLineParser class are listed below. For a complete list of CommandLineParser class members, see the CommandLineParser Members topic.

Public Instance Properties

LogoBanner | Gets a logo banner using version and copyright attributes defined on the GetEntryAssembly or the GetCallingAssembly.
NoArgs | Gets a value indicating whether no arguments were specified on the command line.
Usage | Gets the usage instructions.

See Also

CommandLineParser Class | NAnt.Core.Util Namespace


LogoBanner Property

NAnt SDK Documentation - v0.91

CommandLineParser.LogoBanner Property

Gets a logo banner using version and copyright attributes defined on the GetEntryAssembly or the GetCallingAssembly.

[Visual Basic]
Overridable Public ReadOnly Property LogoBanner As String
[C#]
public virtual string LogoBanner {get;}

Property Value

A logo banner.

See Also

CommandLineParser Class | NAnt.Core.Util Namespace


NoArgs Property

NAnt SDK Documentation - v0.91

CommandLineParser.NoArgs Property

Gets a value indicating whether no arguments were specified on the command line.

[Visual Basic]
Public ReadOnly Property NoArgs As Boolean
[C#]
public bool NoArgs {get;}

See Also

CommandLineParser Class | NAnt.Core.Util Namespace


Usage Property

NAnt SDK Documentation - v0.91

CommandLineParser.Usage Property

Gets the usage instructions.

[Visual Basic]
Overridable Public ReadOnly Property Usage As String
[C#]
public virtual string Usage {get;}

Property Value

The usage instructions.

See Also

CommandLineParser Class | NAnt.Core.Util Namespace


CommandLineParser Methods

The methods of the CommandLineParser class are listed below. For a complete list of CommandLineParser class members, see the CommandLineParser Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Parse | Parses an argument list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandLineParser Class | NAnt.Core.Util Namespace


CommandLineParser.Parse Method

Parses an argument list.

[Visual Basic]
Public Sub Parse( _
ByVal args As String(), _
ByVal destination As Object _
)
[C#]
public void Parse(
string[] args,
object destination
);

Parameters

args
The arguments to parse.
destination
The destination object on which properties will be set corresponding to the specified arguments.

Exceptions

Exception Type | Condition
ArgumentNullException | destination is a null reference.
ArgumentException | The Type of destination does not match the argument specification that was used to initialize the parser.

See Also

CommandLineParser Class | NAnt.Core.Util Namespace


DateTimeProvider Class

For a list of all members of this type, see DateTimeProvider Members.

System.Object
NAnt.Core.Util.DateTimeProvider

[Visual Basic]
Public Class DateTimeProvider
[C#]
public class DateTimeProvider

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Util

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

DateTimeProvider Members | NAnt.Core.Util Namespace


DateTimeProvider Members

DateTimeProvider overview

Public Instance Constructors

DateTimeProvider Constructor Initializes a new instance of the DateTimeProvider class.

Public Instance Properties

Now

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateTimeProvider Class | NAnt.Core.Util Namespace


DateTimeProvider Constructor

Initializes a new instance of the DateTimeProvider class.

[Visual Basic]
Public Sub New()
[C#]
public DateTimeProvider();

See Also

DateTimeProvider Class | NAnt.Core.Util Namespace


DateTimeProvider Properties

The properties of the DateTimeProvider class are listed below. For a complete list of DateTimeProvider class members, see the DateTimeProvider Members topic.

Public Instance Properties

Now

See Also

DateTimeProvider Class | NAnt.Core.Util Namespace


Now Property

NAnt SDK Documentation - v0.91

DateTimeProvider.Now Property

[Visual Basic]
Overridable Public ReadOnly Property Now As Date
[C#]
public virtual System.DateTime Now {get;}

See Also

DateTimeProvider Class | NAnt.Core.Util Namespace


DefaultCommandLineArgumentAttribute Class

Marks a command-line option as being the default option. When the name of a command-line argument is not specified, this option will be assumed.

For a list of all members of this type, see DefaultCommandLineArgumentAttribute Members.

System.Object
System.Attribute
NAnt.Core.Util.CommandLineArgumentAttribute
NAnt.Core.Util.DefaultCommandLineArgumentAttribute

[Visual Basic]
<AttributeUsage(AllowMultiple:=False, Inherited:=True, ValidOn:=AttributeTargets.Property)>
NotInheritable Public Class DefaultCommandLineArgumentAttribute
Inherits CommandLineArgumentAttribute
[C#]
[AttributeUsage(AllowMultiple=False, Inherited=True, ValidOn=AttributeTargets.Property)]
public sealed class DefaultCommandLineArgumentAttribute : CommandLineArgumentAttribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Util

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

DefaultCommandLineArgumentAttribute Members | NAnt.Core.Util Namespace


DefaultCommandLineArgumentAttribute Members

DefaultCommandLineArgumentAttribute overview

Public Instance Constructors

DefaultCommandLineArgumentAttribute Constructor Initializes a new instance of the CommandLineArgumentAttribute class with the specified argument type.

Public Instance Properties

Description (inherited from CommandLineArgumentAttribute) | Gets or sets the description of the argument.
Name (inherited from CommandLineArgumentAttribute) | Gets or sets the long name of the argument.
ShortName (inherited from CommandLineArgumentAttribute) | Gets or sets the short name of the argument.
Type (inherited from CommandLineArgumentAttribute) | Gets or sets the checking to be done on the argument.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DefaultCommandLineArgumentAttribute Class | NAnt.Core.Util Namespace


DefaultCommandLineArgumentAttribute Constructor

Initializes a new instance of the CommandLineArgumentAttribute class with the specified argument type.

[Visual Basic]
Public Sub New( _
ByVal argumentType As CommandLineArgumentTypes _
)
[C#]
public DefaultCommandLineArgumentAttribute(
CommandLineArgumentTypes argumentType
);

Parameters

argumentType
Specifies the checking to be done on the argument.

See Also

DefaultCommandLineArgumentAttribute Class | NAnt.Core.Util Namespace


FileUtils Class

Provides modified version for Copy and Move from the File class that allow for filter chain processing.

For a list of all members of this type, see FileUtils Members.

System.Object
NAnt.Core.Util.FileUtils

[Visual Basic]
NotInheritable Public Class FileUtils
[C#]
public sealed class FileUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Util

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

FileUtils Members | NAnt.Core.Util Namespace


FileUtils Members

FileUtils overview

Public Static (Shared) Methods

CombinePaths | Combines two path strings.
CopyFile | Copies a file filtering its content through the filter chain.
GetFullPath | Returns Absolute Path (Fix for 260 Char Limit of Path.GetFullPath(...))
GetHomeDirectory | Returns the home directory of the current user.
GetTempDirectory | Returns a uniquely named empty temporary directory on disk.
MoveFile | Moves a file filtering its content through the filter chain.
ReadFile | Reads a file filtering its content through the filter chain.
ResolveFile | Scans a list of directories for the specified filename.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileUtils Class | NAnt.Core.Util Namespace


FileUtils Methods

The methods of the FileUtils class are listed below. For a complete list of FileUtils class members, see the FileUtils Members topic.

Public Static (Shared) Methods

CombinePaths | Combines two path strings.
CopyFile | Copies a file filtering its content through the filter chain.
GetFullPath | Returns Absolute Path (Fix for 260 Char Limit of Path.GetFullPath(...))
GetHomeDirectory | Returns the home directory of the current user.
GetTempDirectory | Returns a uniquely named empty temporary directory on disk.
MoveFile | Moves a file filtering its content through the filter chain.
ReadFile | Reads a file filtering its content through the filter chain.
ResolveFile | Scans a list of directories for the specified filename.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileUtils Class | NAnt.Core.Util Namespace


FileUtils.CombinePaths Method

Combines two path strings.

[Visual Basic]
Public Shared Function CombinePaths( _
ByVal path1 As String, _
ByVal path2 As String _
) As String
[C#]
public static string CombinePaths(
string path1,
string path2
);

Parameters

path1
The first path.
path2
The second path.

Return Value

A string containing the combined paths. If one of the specified paths is a zero-length string, this method returns the other path. If path2 contains an absolute path, this method returns path2.

Remarks

On *nix, processing is delegated to Combine.

On Windows, this method normalized the paths to avoid running into the 260 character limit of a path and converts forward slashes in both path1 and path2 to the platform's directory separator character.

See Also

FileUtils Class | NAnt.Core.Util Namespace


FileUtils.CopyFile Method

Copies a file filtering its content through the filter chain.

[Visual Basic]
Public Shared Sub CopyFile( _
ByVal sourceFileName As String, _
ByVal destFileName As String, _
ByVal filterChain As FilterChain, _
ByVal inputEncoding As Encoding, _
ByVal outputEncoding As Encoding _
)
[C#]
public static void CopyFile(
string sourceFileName,
string destFileName,
FilterChain filterChain,
Encoding inputEncoding,
Encoding outputEncoding
);

Parameters

sourceFileName
The file to copy
destFileName
The file to copy to
filterChain
Chain of filters to apply when copying, or a null reference (Nothing in Visual Basic) is no filters should be applied.
inputEncoding
The encoding used to read the soure file.
outputEncoding
The encoding used to write the destination file.

See Also

FileUtils Class | NAnt.Core.Util Namespace


FileUtils.GetFullPath Method

Returns Absolute Path (Fix for 260 Char Limit of Path.GetFullPath(...))

[Visual Basic]
Public Shared Function GetFullPath( _
ByVal path As String _
) As String
[C#]
public static string GetFullPath(
string path
);

Parameters

path
The file or directory for which to obtain absolute path information.

Return Value

Path Resolved

Exceptions

Exception Type | Condition
ArgumentException | path is a zero-length string, contains only white space or contains one or more invalid characters as defined by InvalidPathChars.
ArgumentNullException | path is a null reference (Nothing in Visual Basic).

See Also

FileUtils Class | NAnt.Core.Util Namespace


FileUtils.GetHomeDirectory Method

Returns the home directory of the current user.

[Visual Basic]
Public Shared Function GetHomeDirectory() As String
[C#]
public static string GetHomeDirectory();

Return Value

The home directory of the current user.

See Also

FileUtils Class | NAnt.Core.Util Namespace


FileUtils.GetTempDirectory Method

Returns a uniquely named empty temporary directory on disk.

[Visual Basic]
Public Shared Function GetTempDirectory() As DirectoryInfo
[C#]
public static DirectoryInfo GetTempDirectory();

See Also

FileUtils Class | NAnt.Core.Util Namespace


FileUtils.MoveFile Method

Moves a file filtering its content through the filter chain.

[Visual Basic]
Public Shared Sub MoveFile( _
ByVal sourceFileName As String, _
ByVal destFileName As String, _
ByVal filterChain As FilterChain, _
ByVal inputEncoding As Encoding, _
ByVal outputEncoding As Encoding _
)
[C#]
public static void MoveFile(
string sourceFileName,
string destFileName,
FilterChain filterChain,
Encoding inputEncoding,
Encoding outputEncoding
);

Parameters

sourceFileName
The file to move.
destFileName
The file to move move to.
filterChain
Chain of filters to apply when moving, or a null reference (Nothing in Visual Basic) is no filters should be applied.
inputEncoding
The encoding used to read the soure file.
outputEncoding
The encoding used to write the destination file.

See Also

FileUtils Class | NAnt.Core.Util Namespace


FileUtils.ReadFile Method

Reads a file filtering its content through the filter chain.

[Visual Basic]
Public Shared Function ReadFile( _
ByVal fileName As String, _
ByVal filterChain As FilterChain, _
ByVal inputEncoding As Encoding _
) As String
[C#]
public static string ReadFile(
string fileName,
FilterChain filterChain,
Encoding inputEncoding
);

Parameters

fileName
The file to read.
filterChain
Chain of filters to apply when reading, or a null reference (Nothing in Visual Basic) is no filters should be applied.
inputEncoding
The encoding used to read the file.

Remarks

If inputEncoding is a null reference (Nothing in Visual Basic), then the system's ANSI code page will be used to read the file.

See Also

FileUtils Class | NAnt.Core.Util Namespace


FileUtils.ResolveFile Method

Scans a list of directories for the specified filename.

[Visual Basic]
Public Shared Function ResolveFile( _
ByVal directories As String(), _
ByVal fileName As String, _
ByVal recursive As Boolean _
) As String
[C#]
public static string ResolveFile(
string[] directories,
string fileName,
bool recursive
);

Parameters

directories
The list of directories to search.
fileName
The name of the file to look for.
recursive
Specifies whether the directory should be searched recursively.

Return Value

The absolute path to the specified file, or null if the file was not found.

Remarks

The directories are scanned in the order in which they are defined.

See Also

FileUtils Class | NAnt.Core.Util Namespace


GacCache Class

Helper class for determining whether assemblies are located in the Global Assembly Cache.

For a list of all members of this type, see GacCache Members.

System.Object
NAnt.Core.Util.GacCache

[Visual Basic]
NotInheritable Public Class GacCache
Implements IDisposable
[C#]
public sealed class GacCache : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Util

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

GacCache Members | NAnt.Core.Util Namespace


GacCache Members

GacCache overview

Public Instance Constructors

GacCache Constructor Initializes a new instance of the GacCache class in the context of the given Project.

Public Instance Properties

Project Gets the Project context of the GacCache.

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IsAssemblyInGac | Determines whether an assembly is installed in the Global Assembly Cache given its file name or path.
RecreateDomain |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GacCache Class | NAnt.Core.Util Namespace


GacCache Constructor

Initializes a new instance of the GacCache class in the context of the given Project.

[Visual Basic]
Public Sub New( _
ByVal project As Project _
)
[C#]
public GacCache(
Project project
);

See Also

GacCache Class | NAnt.Core.Util Namespace


GacCache Properties

The properties of the GacCache class are listed below. For a complete list of GacCache class members, see the GacCache Members topic.

Public Instance Properties

Project Gets the Project context of the GacCache.

See Also

GacCache Class | NAnt.Core.Util Namespace


Project Property

NAnt SDK Documentation - v0.91

GacCache.Project Property

Gets the Project context of the GacCache.

[Visual Basic]
Public ReadOnly Property Project As Project
[C#]
public NAnt.Core.Project Project {get;}

Property Value

The Project context of the GacCache.

See Also

GacCache Class | NAnt.Core.Util Namespace


GacCache Methods

The methods of the GacCache class are listed below. For a complete list of GacCache class members, see the GacCache Members topic.

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IsAssemblyInGac | Determines whether an assembly is installed in the Global Assembly Cache given its file name or path.
RecreateDomain |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GacCache Class | NAnt.Core.Util Namespace


GacCache.Dispose Method

[Visual Basic]
NotOverridable Public Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

GacCache Class | NAnt.Core.Util Namespace


GacCache.IsAssemblyInGac Method

Determines whether an assembly is installed in the Global Assembly Cache given its file name or path.

[Visual Basic]
Public Function IsAssemblyInGac( _
ByVal assemblyFile As String _
) As Boolean
[C#]
public bool IsAssemblyInGac(
string assemblyFile
);

Parameters

assemblyFile
The name or path of the file that contains the manifest of the assembly.

Return Value

true if assemblyFile is installed in the Global Assembly Cache; otherwise, false.

Remarks

To determine whether the specified assembly is installed in the Global Assembly Cache, the assembly is loaded into a separate AppDomain.

If the family of the current runtime framework does not match the family of the current target framework, this method will return false for all assemblies as there's no way to determine whether a given assembly is in the Global Assembly Cache for another framework family than the family of the current runtime framework.

See Also

GacCache Class | NAnt.Core.Util Namespace


GacCache.RecreateDomain Method

[Visual Basic]
Public Sub RecreateDomain()
[C#]
public void RecreateDomain();

See Also

GacCache Class | NAnt.Core.Util Namespace


ReflectionUtils Class

Provides a set of helper methods related to reflection.

For a list of all members of this type, see ReflectionUtils Members.

System.Object
NAnt.Core.Util.ReflectionUtils

[Visual Basic]
NotInheritable Public Class ReflectionUtils
[C#]
public sealed class ReflectionUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Util

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ReflectionUtils Members | NAnt.Core.Util Namespace


ReflectionUtils Members

ReflectionUtils overview

Public Static (Shared) Methods

GetTypeFromString Loads the type specified in the type string with assembly qualified name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ReflectionUtils Class | NAnt.Core.Util Namespace


ReflectionUtils Methods

The methods of the ReflectionUtils class are listed below. For a complete list of ReflectionUtils class members, see the ReflectionUtils Members topic.

Public Static (Shared) Methods

GetTypeFromString Loads the type specified in the type string with assembly qualified name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ReflectionUtils Class | NAnt.Core.Util Namespace


ReflectionUtils.GetTypeFromString Method

Loads the type specified in the type string with assembly qualified name.

[Visual Basic]
Public Shared Function GetTypeFromString( _
ByVal typeName As String, _
ByVal throwOnError As Boolean _
) As Type
[C#]
public static Type GetTypeFromString(
string typeName,
bool throwOnError
);

Parameters

typeName
The assembly qualified name of the type to load.
throwOnError
Flag set to true to throw an exception if the type cannot be loaded.

Return Value

The type loaded or a null reference (Nothing in Visual Basic) if it could not be loaded.

Remarks

If the Type cannot be instantiated from the assembly qualified type name, then we'll try to instantiate the type using its simple type name from an already loaded assembly with an assembly name mathing the assembly in the assembly qualified type name.

Exceptions

Exception Type | Condition
TypeLoadException | throwOnError is true and an error is encountered while loading the Type, or typeName is not an assembly qualified name.

See Also

ReflectionUtils Class | NAnt.Core.Util Namespace


ResourceUtils Class

Provides resource support to NAnt assemblies. This class cannot be inherited from.

For a list of all members of this type, see ResourceUtils Members.

System.Object
NAnt.Core.Util.ResourceUtils

[Visual Basic]
NotInheritable Public Class ResourceUtils
[C#]
public sealed class ResourceUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Util

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

ResourceUtils Members | NAnt.Core.Util Namespace


ResourceUtils Members

ResourceUtils overview

Public Static (Shared) Methods

GetString | Overloaded. Returns the value of the specified string resource.
RegisterSharedAssembly | Registers the assembly to be used as the fallback if resources aren't found in the local satellite assembly.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ResourceUtils Class | NAnt.Core.Util Namespace


ResourceUtils Methods

The methods of the ResourceUtils class are listed below. For a complete list of ResourceUtils class members, see the ResourceUtils Members topic.

Public Static (Shared) Methods

GetString | Overloaded. Returns the value of the specified string resource.
RegisterSharedAssembly | Registers the assembly to be used as the fallback if resources aren't found in the local satellite assembly.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ResourceUtils Class | NAnt.Core.Util Namespace


GetString Method

NAnt SDK Documentation - v0.91

ResourceUtils.GetString Method

Returns the value of the specified string resource.

Overload List

Returns the value of the specified string resource.

public static string GetString(string);

Returns the value of the specified string resource localized for the specified culture.

public static string GetString(string,CultureInfo);

Returns the value of the specified string resource localized for the specified culture for the specified assembly.

public static string GetString(string,CultureInfo,Assembly);

See Also

ResourceUtils Class | NAnt.Core.Util Namespace


ResourceUtils.GetString Method (String)

Returns the value of the specified string resource.

[Visual Basic]
Overloads Public Shared Function GetString( _
ByVal name As String _
) As String
[C#]
public static string GetString(
string name
);

Parameters

name
A String that contains the name of the resource to get.

Return Value

A String that contains the value of the resource localized for the current culture.

Remarks

The returned resource is localized for the cultural settings of the current Thread.

Note The GetString method is thread-safe.

Example

The following example demonstrates the GetString method using the cultural settings of the current Thread.

            string localizedString = ResourceUtils.GetString("String_HelloWorld");

See Also

ResourceUtils Class | NAnt.Core.Util Namespace | ResourceUtils.GetString Overload List


ResourceUtils.GetString Method (String, CultureInfo)

Returns the value of the specified string resource localized for the specified culture.

[Visual Basic]
Overloads Public Shared Function GetString( _
ByVal name As String, _
ByVal culture As CultureInfo _
) As String
[C#]
public static string GetString(
string name,
CultureInfo culture
);

Parameters

name
culture

Return Value

A String that contains the value of the resource localized for the specified culture.

Remarks

Note The GetString method is thread-safe.

Example

The following example demonstrates the GetString method using a specific culture.

             CultureInfo culture = CultureInfo.CreateSpecificCulture("en-US");
             string localizedString = ResourceUtils.GetString("String_HelloWorld", culture);

See Also

ResourceUtils Class | NAnt.Core.Util Namespace | ResourceUtils.GetString Overload List


ResourceUtils.GetString Method (String, CultureInfo, Assembly)

Returns the value of the specified string resource localized for the specified culture for the specified assembly.

[Visual Basic]
Overloads Public Shared Function GetString( _
ByVal name As String, _
ByVal culture As CultureInfo, _
ByVal assembly As Assembly _
) As String
[C#]
public static string GetString(
string name,
CultureInfo culture,
Assembly assembly
);

Parameters

name
A String that contains the name of the resource to get.
culture
A CultureInfo that represents the culture for which the resource is localized.
assembly
A Assembly

Return Value

A String that contains the value of the resource localized for the specified culture.

Remarks

Note The GetString method is thread-safe.

Example

The following example demonstrates the GetString method using specific culture and assembly.

            CultureInfo culture = CultureInfo.CreateSpecificCulture("en-US");
            Assembly assembly = Assembly.GetCallingAssembly();
            string localizedString = ResourceUtils.GetString("String_HelloWorld", culture, assembly);

See Also

ResourceUtils Class | NAnt.Core.Util Namespace | ResourceUtils.GetString Overload List


ResourceUtils.RegisterSharedAssembly Method

Registers the assembly to be used as the fallback if resources aren't found in the local satellite assembly.

[Visual Basic]
Public Shared Sub RegisterSharedAssembly( _
ByVal assembly As Assembly _
)
[C#]
public static void RegisterSharedAssembly(
Assembly assembly
);

Parameters

assembly
A Assembly that represents the assembly to register.

Example

The following example shows how to register a shared satellite assembly.

            Assembly sharedAssembly = Assembly.Load("MyResources.dll");
            ResourceUtils.RegisterSharedAssembly(sharedAssembly);

See Also

ResourceUtils Class | NAnt.Core.Util Namespace


StopWatchStack Class

For a list of all members of this type, see StopWatchStack Members.

System.Object
NAnt.Core.Util.StopWatchStack

[Visual Basic]
Public Class StopWatchStack
[C#]
public class StopWatchStack

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Util

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

StopWatchStack Members | NAnt.Core.Util Namespace


StopWatchStack Members

StopWatchStack overview

Public Instance Constructors

StopWatchStack Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
PopStop |
PushStart |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StopWatchStack Class | NAnt.Core.Util Namespace


StopWatchStack Constructor

[Visual Basic]
Public Sub New( _
ByVal dtProvider As DateTimeProvider _
)
[C#]
public StopWatchStack(
DateTimeProvider dtProvider
);

See Also

StopWatchStack Class | NAnt.Core.Util Namespace


StopWatchStack Methods

The methods of the StopWatchStack class are listed below. For a complete list of StopWatchStack class members, see the StopWatchStack Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
PopStop |
PushStart |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StopWatchStack Class | NAnt.Core.Util Namespace


StopWatchStack.PopStop Method

[Visual Basic]
Public Function PopStop() As TimeSpan
[C#]
public TimeSpan PopStop();

See Also

StopWatchStack Class | NAnt.Core.Util Namespace


StopWatchStack.PushStart Method

[Visual Basic]
Public Sub PushStart()
[C#]
public void PushStart();

See Also

StopWatchStack Class | NAnt.Core.Util Namespace


StringUtils Class

Groups a set of useful String manipulation and validation methods.

For a list of all members of this type, see StringUtils Members.

System.Object
NAnt.Core.Util.StringUtils

[Visual Basic]
NotInheritable Public Class StringUtils
[C#]
public sealed class StringUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.Core.Util

Assembly: NAnt.Core (in NAnt.Core.dll)

See Also

StringUtils Members | NAnt.Core.Util Namespace


StringUtils Members

StringUtils overview

Public Static (Shared) Methods

Clone | Creates a shallow copy of the specified StringCollection.
ConvertEmptyToNull | Converts an empty string ("") to a null reference (Nothing in Visual Basic).
ConvertNullToEmpty | Converts a null reference (Nothing in Visual Basic) to an empty string.
EndsWith | Determines whether the last character of the given String matches the specified character.
IsNullOrEmpty | Indicates whether or not the specified String is a null reference (Nothing in Visual Basic) or an Empty string.
Join | Concatenates a specified separator String between each element of a specified StringCollection, yielding a single concatenated string.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StringUtils Class | NAnt.Core.Util Namespace


StringUtils Methods

The methods of the StringUtils class are listed below. For a complete list of StringUtils class members, see the StringUtils Members topic.

Public Static (Shared) Methods

Clone | Creates a shallow copy of the specified StringCollection.
ConvertEmptyToNull | Converts an empty string ("") to a null reference (Nothing in Visual Basic).
ConvertNullToEmpty | Converts a null reference (Nothing in Visual Basic) to an empty string.
EndsWith | Determines whether the last character of the given String matches the specified character.
IsNullOrEmpty | Indicates whether or not the specified String is a null reference (Nothing in Visual Basic) or an Empty string.
Join | Concatenates a specified separator String between each element of a specified StringCollection, yielding a single concatenated string.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StringUtils Class | NAnt.Core.Util Namespace


StringUtils.Clone Method

Creates a shallow copy of the specified StringCollection.

[Visual Basic]
Public Shared Function Clone( _
ByVal stringCollection As StringCollection _
) As StringCollection
[C#]
public static StringCollection Clone(
StringCollection stringCollection
);

Parameters

stringCollection
The StringCollection that should be copied.

Return Value

A shallow copy of the specified StringCollection.

See Also

StringUtils Class | NAnt.Core.Util Namespace


StringUtils.ConvertEmptyToNull Method

Converts an empty string ("") to a null reference (Nothing in Visual Basic).

[Visual Basic]
Public Shared Function ConvertEmptyToNull( _
ByVal value As String _
) As String
[C#]
public static string ConvertEmptyToNull(
string value
);

Parameters

value
The value to convert.

Return Value

a null reference (Nothing in Visual Basic) if value is an empty string ("") or a null reference (Nothing in Visual Basic); otherwise, value.

See Also

StringUtils Class | NAnt.Core.Util Namespace


StringUtils.ConvertNullToEmpty Method

Converts a null reference (Nothing in Visual Basic) to an empty string.

[Visual Basic]
Public Shared Function ConvertNullToEmpty( _
ByVal value As String _
) As String
[C#]
public static string ConvertNullToEmpty(
string value
);

Parameters

value
The value to convert.

Return Value

An empty string if value is a null reference (Nothing in Visual Basic); otherwise, value.

See Also

StringUtils Class | NAnt.Core.Util Namespace


StringUtils.EndsWith Method

Determines whether the last character of the given String matches the specified character.

[Visual Basic]
Public Shared Function EndsWith( _
ByVal value As String, _
ByVal c As Char _
) As Boolean
[C#]
public static bool EndsWith(
string value,
char c
);

Parameters

value
The string.
c
The character.

Return Value

true if the last character of value matches c; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | value is a null reference (Nothing in Visual Basic).

See Also

StringUtils Class | NAnt.Core.Util Namespace


StringUtils.IsNullOrEmpty Method

Indicates whether or not the specified String is a null reference (Nothing in Visual Basic) or an Empty string.

[Visual Basic]
Public Shared Function IsNullOrEmpty( _
ByVal value As String _
) As Boolean
[C#]
public static bool IsNullOrEmpty(
string value
);

Parameters

value
The value to check.

Return Value

true if value is a null reference (Nothing in Visual Basic) or an empty string (""); otherwise, false.

See Also

StringUtils Class | NAnt.Core.Util Namespace


StringUtils.Join Method

Concatenates a specified separator String between each element of a specified StringCollection, yielding a single concatenated string.

[Visual Basic]
Public Shared Function Join( _
ByVal separator As String, _
ByVal value As StringCollection _
) As String
[C#]
public static string Join(
string separator,
StringCollection value
);

Parameters

separator
A String.
value
A StringCollection.

Return Value

A String consisting of the elements of value interspersed with the separator string.

Remarks

For example if separator is ", " and the elements of value are "apple", "orange", "grape", and "pear", Join returns "apple, orange, grape, pear".

If separator is a null reference (Nothing in Visual Basic), an empty string (Empty) is used instead.

See Also

StringUtils Class | NAnt.Core.Util Namespace


NAnt.DotNet.Tasks

NAnt SDK Documentation - v0.91

NAnt.DotNet.Tasks Namespace

Namespace hierarchy

Classes

Class | Description
AssemblyInfoTask | Generates an AssemblyInfo file using the attributes given.
AssemblyLinkerTask | Wraps al.exe, the assembly linker for the .NET Framework.
CompilerBase | Provides the abstract base class for compiler tasks.
CompilerBase.ResourceLinkage | Holds class and namespace information for resource (*.resx) linkage.
CscTask | Compiles C# programs.
DelaySignTask | Signs delay-signed .NET Assemblies, or re-signs existing assemblies.
IlasmTask | Compiles ILASM programs.
JscTask | Compiles JScript.NET programs.
LicenseTask | Generates a .licence file from a .licx file.
NDocTask | Runs NDoc V1.3.1 to create documentation.
QualifiedResource | For internal use only !
RegsvcsTask | Installs or removes .NET Services.
ResGenTask | Converts files from one resource format to another.
ScriptTask | Executes the code contained within the task.
VbcTask | Compiles Visual Basic.NET programs.
VjcTask | Compiles Visual J# programs using vjc, Microsoft's J# compiler.

Enumerations

Enumeration | Description
AssemblyInfoTask.CodeLanguage | Defines the supported code languages for generating an AssemblyInfo file.
RegsvcsTask.ActionType | Defines the possible actions for a .NET Service.


AssemblyInfoTask Class

Generates an AssemblyInfo file using the attributes given.

For a list of all members of this type, see AssemblyInfoTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.DotNet.Tasks.AssemblyInfoTask

[Visual Basic]
<Serializable, _ Serializable, _ TaskName(Name:="asminfo")>
Public Class AssemblyInfoTask
Inherits Task
[C#]
[Serializable]
[Serializable]
[TaskName(Name="asminfo")]
public class AssemblyInfoTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Create a C# AssemblyInfo file containing the specified assembly-level attributes.

<asminfo output="AssemblyInfo.cs" language="CSharp">
    <imports>
        <import namespace="System" />
        <import namespace="System.Reflection" />
        <import namespace="System.EnterpriseServices" />
        <import namespace="System.Runtime.InteropServices" />
    </imports>
    <attributes>
        <attribute type="ComVisibleAttribute" value="false" />
        <attribute type="CLSCompliantAttribute" value="true" />
        <attribute type="AssemblyVersionAttribute" value="1.0.0.0" />
        <attribute type="AssemblyTitleAttribute" value="My fun assembly" />
        <attribute type="AssemblyDescriptionAttribute" value="More fun than a barrel of monkeys" />
        <attribute type="AssemblyCopyrightAttribute" value="Copyright (c) 2002, Monkeyboy, Inc." />
        <attribute type="ApplicationNameAttribute" value="FunAssembly" />
    </attributes>
    <references>
        <include name="System.EnterpriseServices.dll" />
    </references>
</asminfo>

Create a C# AssemblyInfo file containing an attribute with multiple named properties by setting the AsIs attribute on the AssemblyAttribute element to true.

<asminfo output="AssemblyInfo.cs" language="CSharp">
    <imports>
        <import namespace="log4net.Config" />
    </imports>
    <attributes>
        <attribute type="DOMConfiguratorAttribute" value="ConfigFile=&quot;config.log4net&quot;,Watch=true" asis="true" />
    </attributes>
    <references>
        <include name="log4net.dll" />
    </references>
</asminfo>

Requirements

Namespace: NAnt.DotNet.Tasks

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

AssemblyInfoTask Members | NAnt.DotNet.Tasks Namespace


AssemblyInfoTask Members

AssemblyInfoTask overview

Public Instance Constructors

AssemblyInfoTask Constructor Initializes a new instance of the AssemblyInfoTask class.

Public Instance Properties

AssemblyAttributes | The assembly-level attributes to generate.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
Imports | The namespaces to import.
Language | The code language in which the AssemblyInfo file should be generated.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output | Name of the AssemblyInfo file to generate.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
References | Assembly files used to locate the types of the specified attributes.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Generates an AssemblyInfo file.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyInfoTask Class | NAnt.DotNet.Tasks Namespace


AssemblyInfoTask Constructor

Initializes a new instance of the AssemblyInfoTask class.

[Visual Basic]
Public Sub New()
[C#]
public AssemblyInfoTask();

See Also

AssemblyInfoTask Class | NAnt.DotNet.Tasks Namespace


AssemblyInfoTask Properties

The properties of the AssemblyInfoTask class are listed below. For a complete list of AssemblyInfoTask class members, see the AssemblyInfoTask Members topic.

Public Instance Properties

AssemblyAttributes | The assembly-level attributes to generate.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
Imports | The namespaces to import.
Language | The code language in which the AssemblyInfo file should be generated.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output | Name of the AssemblyInfo file to generate.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
References | Assembly files used to locate the types of the specified attributes.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

AssemblyInfoTask Class | NAnt.DotNet.Tasks Namespace


AssemblyAttributes Property

NAnt SDK Documentation - v0.91

AssemblyInfoTask.AssemblyAttributes Property

The assembly-level attributes to generate.

[Visual Basic]
<BuildElementCollection(ChildElementName:="attribute", ElementType:=null, Name:="attributes", Required:=False, ProcessXml:=True)>
Public ReadOnly Property AssemblyAttributes As AssemblyAttributeCollection
[C#]
[BuildElementCollection(ChildElementName="attribute", ElementType=null, Name="attributes", Required=False, ProcessXml=True)]
public NAnt.DotNet.Types.AssemblyAttributeCollection AssemblyAttributes {get;}

Property Value

The assembly-level attributes to generate.

See Also

AssemblyInfoTask Class | NAnt.DotNet.Tasks Namespace


Imports Property

NAnt SDK Documentation - v0.91

AssemblyInfoTask.Imports Property

The namespaces to import.

[Visual Basic]
<BuildElement(Name:="imports", Required:=False, ProcessXml:=True)>
Public Property Imports As NamespaceImportCollection
[C#]
[BuildElement(Name="imports", Required=False, ProcessXml=True)]
public NAnt.DotNet.Types.NamespaceImportCollection Imports {get; set;}

Property Value

The namespaces to import.

See Also

AssemblyInfoTask Class | NAnt.DotNet.Tasks Namespace


Language Property

NAnt SDK Documentation - v0.91

AssemblyInfoTask.Language Property

The code language in which the AssemblyInfo file should be generated.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Required:=True, Name:="language", ExpandProperties:=True, ProcessXml:=True)>
Public Property Language As CodeLanguage
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Required=True, Name="language", ExpandProperties=True, ProcessXml=True)]
public AssemblyInfoTask.CodeLanguage Language {get; set;}

See Also

AssemblyInfoTask Class | NAnt.DotNet.Tasks Namespace


Output Property

NAnt SDK Documentation - v0.91

AssemblyInfoTask.Output Property

Name of the AssemblyInfo file to generate.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="output", ExpandProperties:=True, ProcessXml:=True)>
Public Property Output As FileInfo
[C#]
[TaskAttribute(Required=True, Name="output", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo Output {get; set;}

Property Value

The name of the AssemblyInfo file to generate.

See Also

AssemblyInfoTask Class | NAnt.DotNet.Tasks Namespace


References Property

NAnt SDK Documentation - v0.91

AssemblyInfoTask.References Property

Assembly files used to locate the types of the specified attributes.

[Visual Basic]
<BuildElement(Name:="references", Required:=False, ProcessXml:=True)>
Public Property References As AssemblyFileSet
[C#]
[BuildElement(Name="references", Required=False, ProcessXml=True)]
public NAnt.DotNet.Types.AssemblyFileSet References {get; set;}

See Also

AssemblyInfoTask Class | NAnt.DotNet.Tasks Namespace


AssemblyInfoTask Methods

The methods of the AssemblyInfoTask class are listed below. For a complete list of AssemblyInfoTask class members, see the AssemblyInfoTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Generates an AssemblyInfo file.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyInfoTask Class | NAnt.DotNet.Tasks Namespace


AssemblyInfoTask.ExecuteTask Method

Generates an AssemblyInfo file.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

AssemblyInfoTask Class | NAnt.DotNet.Tasks Namespace


AssemblyInfoTask.CodeLanguage Enumeration

Defines the supported code languages for generating an AssemblyInfo file.

[Visual Basic]
<Serializable>
Public Enum AssemblyInfoTask.CodeLanguage
[C#]
[Serializable]
public enum AssemblyInfoTask.CodeLanguage

Members

Member Name | Description
CSharp | A value for generating C# code.
JScript | A value for generating JScript code.
VB | A value for generating Visual Basic code.

Requirements

Namespace: NAnt.DotNet.Tasks

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

NAnt.DotNet.Tasks Namespace


AssemblyLinkerTask Class

Wraps al.exe, the assembly linker for the .NET Framework.

For a list of all members of this type, see AssemblyLinkerTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.DotNet.Tasks.AssemblyLinkerTask

[Visual Basic]
<TaskName(Name:="al"), _ ProgramLocation(LocationType:=LocationType.FrameworkDir)>
Public Class AssemblyLinkerTask
Inherits ExternalProgramBase
[C#]
[TaskName(Name="al")]
[ProgramLocation(LocationType=LocationType.FrameworkDir)]
public class AssemblyLinkerTask : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

All specified sources will be embedded using the /embed flag. Other source types are not supported.

Example

Create a library containing all icon files in the current directory.

            <al output="MyIcons.dll" target="lib">
                <sources>
                    <include name="*.ico" />
                </sources>
            </al>

Create an executable assembly manifest from modules.

            <al output="Client.exe" target="exe" main="Program.Main">
                <modules>
                    <include name="Client.netmodule" />
                    <include name="Common.netmodule" />
                </modules>
            </al>

Requirements

Namespace: NAnt.DotNet.Tasks

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

AssemblyLinkerTask Members | NAnt.DotNet.Tasks Namespace


AssemblyLinkerTask Members

AssemblyLinkerTask overview

Public Instance Constructors

AssemblyLinkerTask Constructor Initializes a new instance of the AssemblyLinkerTask class.

Public Instance Properties

AlgorithmID | Specifies an algorithm (in hexadecimal) to hash all files in a multifile assembly except the file that contains the assembly manifest. The default algorithm is CALG_SHA1.
Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Company | Specifies a string for the Company field in the assembly.
Configuration | Specifies a string for the Configuration field in the assembly.
Copyright | Specifies a string for the Copyright field in the assembly.
Culture | The culture string associated with the output assembly. The string must be in RFC 1766 format, such as "en-US".
DelaySign | Specifies whether the assembly should be partially signed. The default is NAnt.DotNet.Types.DelaySign.NotSet.
Description | Specifies a string for the Description field in the assembly.
EmbeddedResources | The set of compiled resources to embed.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
EvidenceFile | Security evidence file to embed.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
FileVersion | Specifies a string for the File Version field in the assembly.
Flags | Specifies a value (in hexadecimal) for the Flags field in the assembly.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
KeyContainer | Specifies a container that holds a key pair.
KeyFile | Specifies a file (filename) that contains a key pair or just a public key to sign an assembly.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
MainMethod | Specifies the fully-qualified name (class.method) of the method to use as an entry point when converting a module to an executable file.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
ModuleSet | One or more modules to be compiled into an assembly.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | The name of the output file for the assembly manifest.
OutputTarget | The target type (one of lib, exe, or winexe).
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
Product | Specifies a string for the Product field in the assembly.
ProductVersion | Specifies a string for the Product Version field in the assembly.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Resources | The set of resources to embed.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
SupportsTemplate | Indicates whether the assembly linker for a given target framework supports the "template" option, which takes an assembly from which to get all options except the culture field. The default is true.
TemplateFile | Specifies an assembly from which to get all options except the culture field.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
Title | Specifies a string for the Title field in the assembly.
Trademark | Specifies a string for the Trademark field in the assembly.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
Version | Specifies version information for the assembly. The format of the version string is major.minor.build.revision.
Win32Icon | Icon to associate with the assembly.
Win32Res | Inserts a Win32 resource (.res file) in the output file.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Generates an assembly manifest.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines whether the assembly manifest needs compiling or is uptodate.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


AssemblyLinkerTask Constructor

Initializes a new instance of the AssemblyLinkerTask class.

[Visual Basic]
Public Sub New()
[C#]
public AssemblyLinkerTask();

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


AssemblyLinkerTask Properties

The properties of the AssemblyLinkerTask class are listed below. For a complete list of AssemblyLinkerTask class members, see the AssemblyLinkerTask Members topic.

Public Instance Properties

AlgorithmID | Specifies an algorithm (in hexadecimal) to hash all files in a multifile assembly except the file that contains the assembly manifest. The default algorithm is CALG_SHA1.
Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Company | Specifies a string for the Company field in the assembly.
Configuration | Specifies a string for the Configuration field in the assembly.
Copyright | Specifies a string for the Copyright field in the assembly.
Culture | The culture string associated with the output assembly. The string must be in RFC 1766 format, such as "en-US".
DelaySign | Specifies whether the assembly should be partially signed. The default is NAnt.DotNet.Types.DelaySign.NotSet.
Description | Specifies a string for the Description field in the assembly.
EmbeddedResources | The set of compiled resources to embed.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
EvidenceFile | Security evidence file to embed.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
FileVersion | Specifies a string for the File Version field in the assembly.
Flags | Specifies a value (in hexadecimal) for the Flags field in the assembly.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
KeyContainer | Specifies a container that holds a key pair.
KeyFile | Specifies a file (filename) that contains a key pair or just a public key to sign an assembly.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
MainMethod | Specifies the fully-qualified name (class.method) of the method to use as an entry point when converting a module to an executable file.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
ModuleSet | One or more modules to be compiled into an assembly.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | The name of the output file for the assembly manifest.
OutputTarget | The target type (one of lib, exe, or winexe).
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
Product | Specifies a string for the Product field in the assembly.
ProductVersion | Specifies a string for the Product Version field in the assembly.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Resources | The set of resources to embed.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
SupportsTemplate | Indicates whether the assembly linker for a given target framework supports the "template" option, which takes an assembly from which to get all options except the culture field. The default is true.
TemplateFile | Specifies an assembly from which to get all options except the culture field.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
Title | Specifies a string for the Title field in the assembly.
Trademark | Specifies a string for the Trademark field in the assembly.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
Version | Specifies version information for the assembly. The format of the version string is major.minor.build.revision.
Win32Icon | Icon to associate with the assembly.
Win32Res | Inserts a Win32 resource (.res file) in the output file.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


AlgorithmID Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.AlgorithmID Property

Specifies an algorithm (in hexadecimal) to hash all files in a multifile assembly except the file that contains the assembly manifest. The default algorithm is CALG_SHA1.

[Visual Basic]
<Int32Validator(MinValue:=-2147483648, MaxValue:=2147483647, Base:=16), _ TaskAttribute(Required:=False, Name:="algid", ExpandProperties:=True, ProcessXml:=True)>
Public Property AlgorithmID As String
[C#]
[Int32Validator(MinValue=-2147483648, MaxValue=2147483647, Base=16)]
[TaskAttribute(Required=False, Name="algid", ExpandProperties=True, ProcessXml=True)]
public string AlgorithmID {get; set;}

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


Company Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.Company Property

Specifies a string for the Company field in the assembly.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="company", ExpandProperties:=True, ProcessXml:=True)>
Public Property Company As String
[C#]
[TaskAttribute(Required=False, Name="company", ExpandProperties=True, ProcessXml=True)]
public string Company {get; set;}

Property Value

A string for the Company field in the assembly.

Remarks

If Company is an empty string (""), the Win32 Company resource appears as a single space.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


Configuration Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.Configuration Property

Specifies a string for the Configuration field in the assembly.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="configuration", ExpandProperties:=True, ProcessXml:=True)>
Public Property Configuration As String
[C#]
[TaskAttribute(Required=False, Name="configuration", ExpandProperties=True, ProcessXml=True)]
public string Configuration {get; set;}

Property Value

A string for the Configuration field in the assembly.

Remarks

If Configuration is an empty string (""), the Win32 Configuration resource appears as a single space.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


Copyright Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.Copyright Property

Specifies a string for the Copyright field in the assembly.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="copyright", ExpandProperties:=True, ProcessXml:=True)>
Public Property Copyright As String
[C#]
[TaskAttribute(Required=False, Name="copyright", ExpandProperties=True, ProcessXml=True)]
public string Copyright {get; set;}

Property Value

A string for the Copyright field in the assembly.

Remarks

If Copyright is an empty string (""), the Win32 Copyright resource appears as a single space.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


Culture Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.Culture Property

The culture string associated with the output assembly. The string must be in RFC 1766 format, such as "en-US".

[Visual Basic]
<TaskAttribute(Required:=False, Name:="culture", ExpandProperties:=True, ProcessXml:=True)>
Public Property Culture As String
[C#]
[TaskAttribute(Required=False, Name="culture", ExpandProperties=True, ProcessXml=True)]
public string Culture {get; set;}

Remarks

Corresponds with the /c[ulture]: flag.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


DelaySign Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.DelaySign Property

Specifies whether the assembly should be partially signed. The default is NAnt.DotNet.Types.DelaySign.NotSet.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="delaysign", ExpandProperties:=True, ProcessXml:=True)>
Public Property DelaySign As DelaySign
[C#]
[TaskAttribute(Required=False, Name="delaysign", ExpandProperties=True, ProcessXml=True)]
public NAnt.DotNet.Types.DelaySign DelaySign {get; set;}

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


Description Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.Description Property

Specifies a string for the Description field in the assembly.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="description", ExpandProperties:=True, ProcessXml:=True)>
Public Property Description As String
[C#]
[TaskAttribute(Required=False, Name="description", ExpandProperties=True, ProcessXml=True)]
public string Description {get; set;}

Property Value

A string for the Description field in the assembly.

Remarks

If Description is an empty string (""), the Win32 Description resource appears as a single space.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


EmbeddedResources Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.EmbeddedResources Property

The set of compiled resources to embed.

[Visual Basic]
Public Property EmbeddedResources As EmbeddedResourceCollection
[C#]
public NAnt.DotNet.Types.EmbeddedResourceCollection EmbeddedResources {get; set;}

Remarks

Do not yet expose this to build authors.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


EvidenceFile Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.EvidenceFile Property

Security evidence file to embed.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="evidence", ExpandProperties:=True, ProcessXml:=True)>
Public Property EvidenceFile As FileInfo
[C#]
[TaskAttribute(Required=False, Name="evidence", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo EvidenceFile {get; set;}

Property Value

The security evidence file to embed.

Remarks

Corresponds with the /e[vidence] flag.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


FileVersion Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.FileVersion Property

Specifies a string for the File Version field in the assembly.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="fileversion", ExpandProperties:=True, ProcessXml:=True)>
Public Property FileVersion As String
[C#]
[TaskAttribute(Required=False, Name="fileversion", ExpandProperties=True, ProcessXml=True)]
public string FileVersion {get; set;}

Property Value

A string for the File Version field in the assembly.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


Flags Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.Flags Property

Specifies a value (in hexadecimal) for the Flags field in the assembly.

[Visual Basic]
<Int32Validator(Base:=16, MinValue:=-2147483648, MaxValue:=2147483647), _ TaskAttribute(Required:=False, Name:="flags", ExpandProperties:=True, ProcessXml:=True)>
Public Property Flags As String
[C#]
[Int32Validator(Base=16, MinValue=-2147483648, MaxValue=2147483647)]
[TaskAttribute(Required=False, Name="flags", ExpandProperties=True, ProcessXml=True)]
public string Flags {get; set;}

Property Value

A value (in hexadecimal) for the Flags field in the assembly.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


KeyContainer Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.KeyContainer Property

Specifies a container that holds a key pair.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="keycontainer", ExpandProperties:=True, ProcessXml:=True)>
Public Property KeyContainer As String
[C#]
[TaskAttribute(Required=False, Name="keycontainer", ExpandProperties=True, ProcessXml=True)]
public string KeyContainer {get; set;}

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


KeyFile Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.KeyFile Property

Specifies a file (filename) that contains a key pair or just a public key to sign an assembly.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="keyfile", ExpandProperties:=True, ProcessXml:=True)>
Public Property KeyFile As FileInfo
[C#]
[TaskAttribute(Required=False, Name="keyfile", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo KeyFile {get; set;}

Property Value

The complete path to the key file.

Remarks

Corresponds with the /keyf[ile]: flag.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


MainMethod Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.MainMethod Property

Specifies the fully-qualified name (class.method) of the method to use as an entry point when converting a module to an executable file.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="main", ExpandProperties:=True, ProcessXml:=True)>
Public Property MainMethod As String
[C#]
[TaskAttribute(Required=False, Name="main", ExpandProperties=True, ProcessXml=True)]
public string MainMethod {get; set;}

Property Value

The fully-qualified name (class.method) of the method to use as an entry point when converting a module to an executable file.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


ModuleSet Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.ModuleSet Property

One or more modules to be compiled into an assembly.

[Visual Basic]
<BuildElement(Name:="modules", Required:=False, ProcessXml:=True)>
Public Property ModuleSet As ModuleSet
[C#]
[BuildElement(Name="modules", Required=False, ProcessXml=True)]
public NAnt.DotNet.Types.ModuleSet ModuleSet {get; set;}

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


OutputFile Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.OutputFile Property

The name of the output file for the assembly manifest.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="output", ExpandProperties:=True, ProcessXml:=True)>
Public Property OutputFile As FileInfo
[C#]
[TaskAttribute(Required=True, Name="output", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo OutputFile {get; set;}

Property Value

The complete output path for the assembly manifest.

Remarks

Corresponds with the /out flag.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


OutputTarget Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.OutputTarget Property

The target type (one of lib, exe, or winexe).

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Required:=True, Name:="target", ExpandProperties:=True, ProcessXml:=True)>
Public Property OutputTarget As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Required=True, Name="target", ExpandProperties=True, ProcessXml=True)]
public string OutputTarget {get; set;}

Remarks

Corresponds with the /t[arget]: flag.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


Product Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.Product Property

Specifies a string for the Product field in the assembly.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="product", ExpandProperties:=True, ProcessXml:=True)>
Public Property Product As String
[C#]
[TaskAttribute(Required=False, Name="product", ExpandProperties=True, ProcessXml=True)]
public string Product {get; set;}

Property Value

A string for the Product field in the assembly.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


ProductVersion Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.ProductVersion Property

Specifies a string for the Product Version field in the assembly.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="productversion", ExpandProperties:=True, ProcessXml:=True)>
Public Property ProductVersion As String
[C#]
[TaskAttribute(Required=False, Name="productversion", ExpandProperties=True, ProcessXml=True)]
public string ProductVersion {get; set;}

Property Value

A string for the Product Version field in the assembly.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.ProgramArguments Property

Gets the command-line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

Property Value

The command-line arguments for the external program or a null reference (Nothing in Visual Basic) if the task is not being executed.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


Resources Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.Resources Property

The set of resources to embed.

[Visual Basic]
<BuildElement(Name:="sources", Required:=False, ProcessXml:=True)>
Public Property Resources As FileSet
[C#]
[BuildElement(Name="sources", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet Resources {get; set;}

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


SupportsTemplate Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.SupportsTemplate Property

Indicates whether the assembly linker for a given target framework supports the "template" option, which takes an assembly from which to get all options except the culture field. The default is true.

[Visual Basic]
<FrameworkConfigurable(Name:="supportstemplate", Required:=False, ExpandProperties:=True)>
Public Property SupportsTemplate As Boolean
[C#]
[FrameworkConfigurable(Name="supportstemplate", Required=False, ExpandProperties=True)]
public bool SupportsTemplate {get; set;}

Remarks

TODO: remove this once Mono bug #74814 is fixed.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


TemplateFile Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.TemplateFile Property

Specifies an assembly from which to get all options except the culture field.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="template", ExpandProperties:=True, ProcessXml:=True)>
Public Property TemplateFile As FileInfo
[C#]
[TaskAttribute(Required=False, Name="template", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo TemplateFile {get; set;}

Property Value

The complete path to the assembly template.

Remarks

Corresponds with the /template: flag.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


Title Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.Title Property

Specifies a string for the Title field in the assembly.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="title", ExpandProperties:=True, ProcessXml:=True)>
Public Property Title As String
[C#]
[TaskAttribute(Required=False, Name="title", ExpandProperties=True, ProcessXml=True)]
public string Title {get; set;}

Property Value

A string for the Title field in the assembly.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


Trademark Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.Trademark Property

Specifies a string for the Trademark field in the assembly.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="trademark", ExpandProperties:=True, ProcessXml:=True)>
Public Property Trademark As String
[C#]
[TaskAttribute(Required=False, Name="trademark", ExpandProperties=True, ProcessXml=True)]
public string Trademark {get; set;}

Property Value

A string for the Trademark field in the assembly.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


Version Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.Version Property

Specifies version information for the assembly. The format of the version string is major.minor.build.revision.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="version", ExpandProperties:=True, ProcessXml:=True)>
Public Property Version As String
[C#]
[TaskAttribute(Required=False, Name="version", ExpandProperties=True, ProcessXml=True)]
public string Version {get; set;}

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


Win32Icon Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.Win32Icon Property

Icon to associate with the assembly.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="win32icon", ExpandProperties:=True, ProcessXml:=True)>
Public Property Win32Icon As FileInfo
[C#]
[TaskAttribute(Required=False, Name="win32icon", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo Win32Icon {get; set;}

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


Win32Res Property

NAnt SDK Documentation - v0.91

AssemblyLinkerTask.Win32Res Property

Inserts a Win32 resource (.res file) in the output file.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="win32res", ExpandProperties:=True, ProcessXml:=True)>
Public Property Win32Res As FileInfo
[C#]
[TaskAttribute(Required=False, Name="win32res", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo Win32Res {get; set;}

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


AssemblyLinkerTask Methods

The methods of the AssemblyLinkerTask class are listed below. For a complete list of AssemblyLinkerTask class members, see the AssemblyLinkerTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Generates an assembly manifest.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines whether the assembly manifest needs compiling or is uptodate.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


AssemblyLinkerTask.ExecuteTask Method

Generates an assembly manifest.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


AssemblyLinkerTask.NeedsCompiling Method

Determines whether the assembly manifest needs compiling or is uptodate.

[Visual Basic]
Overridable Protected Function NeedsCompiling() As Boolean
[C#]
protected virtual bool NeedsCompiling();

Return Value

true if the assembly manifest needs compiling; otherwise, false.

See Also

AssemblyLinkerTask Class | NAnt.DotNet.Tasks Namespace


CompilerBase Class

Provides the abstract base class for compiler tasks.

For a list of all members of this type, see CompilerBase Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.DotNet.Tasks.CompilerBase
NAnt.DotNet.Tasks.CscTask
NAnt.DotNet.Tasks.JscTask
NAnt.DotNet.Tasks.VbcTask
NAnt.DotNet.Tasks.VjcTask

[Visual Basic]
MustInherit Public Class CompilerBase
Inherits ExternalProgramBase
[C#]
public abstract class CompilerBase : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Tasks

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

CompilerBase Members | NAnt.DotNet.Tasks Namespace


CompilerBase Members

CompilerBase overview

Public Static (Shared) Methods

GetResourceCulture Determines the culture associated with a given resource file by scanning the filename for valid culture names.

Protected Static (Shared) Fields

CodebehindExtensions | Contains a list of extensions for all file types that should be treated as 'code-behind' when looking for resources. Ultimately this will determine if we use the "namespace+filename" or "namespace+classname" algorithm, since code-behind will use the "namespace+classname" algorithm.
CultureNames | Case-insensitive list of valid culture names for this platform.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Debug | Generate debug output. The default is false.
Define | Define conditional compilation symbol(s).
DelaySign | Specifies whether to delay sign the assembly using only the public portion of the strong name key. The default is NotSet.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
Extension | Gets the file extension required by the current compiler.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForceRebuild | Instructs NAnt to recompile the output file regardless of the file timestamps.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
KeyContainer | Specifies the key pair container used to strongname the assembly.
KeyFile | Specifies a strong name key file.
Lib | Obsolete. Additional directories to search in for assembly references.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
MainType | Specifies which type contains the Main method that you want to use as the entry point into the program.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Modules | Link the specified modules into this assembly.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NoWarn | Obsolete. Specifies a comma-separated list of warnings that should be suppressed by the compiler.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | The output file created by the compiler.
OutputTarget | Output type. Possible values are exe, winexe, library or module.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Packages | Specifies list of packages to reference.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
References | Reference metadata from the specified assembly files.
ResourcesList | Resources to embed.
Sources | The set of source files for compilation.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
SupportsDelaySign | Indicates whether the compiler for a given target framework supports the "delaysign" option. The default is false.
SupportsKeyContainer | Indicates whether the compiler for a given target framework supports the "keycontainer" option. The default is false.
SupportsKeyFile | Indicates whether the compiler for a given target framework supports the "keyfile" option. The default is false.
SupportsNoWarnList | Indicates whether the compiler for a given target framework supports a command line option that allows a list of warnings to be suppressed. The default is false.
SupportsPackageReferences | Indicates whether package references are supported by compiler for a given target framework. The default is false.
SupportsWarnAsErrorList | Indicates whether the compiler for a given target framework supports the "warnaserror" option that takes a list of warnings. The default is false.
SuppressWarnings | Specifies a list of warnings that you want the compiler to suppress.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
WarnAsError | Instructs the compiler to treat all warnings as errors. The default is false.
WarningAsError | Controls which warnings should be reported as errors.
Win32Icon | Icon to associate with the application.
Win32Res | Specifies a Win32 resource file (.res).

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetManifestResourceName | Overloaded. Determines the manifest resource name of the given resource file.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
PerformSearchForResourceLinkage | Extracts the associated namespace/classname linkage found in the given stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

CompilerBase Constructor Initializes a new instance of the CompilerBase class.

Protected Instance Properties

ClassNameRegex | Gets the class name regular expression for the language of the current compiler.
CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
NamespaceRegex | Gets the namespace regular expression for the language of the current compiler.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CompileResxResources | Compiles a set of resx files to a .resources files.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Compiles the sources and resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
GetResourceLinkage | Finds the correct namespace/classname for a resource file from the given dependent source file.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
LinkResourceAssembly | Link a list of files into a resource assembly.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines whether compilation is needed.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
WriteConditionalCompilationConstants | Writes conditional compilation constants to the specified TextWriter.
WriteModuleReferences | Writes module references to the specified TextWriter.
WriteNoWarnList | Writes list of warnings to suppress to the specified TextWriter.
WriteOption | Overloaded. Writes an option using the default output format.
WriteOptions | Allows derived classes to provide compiler-specific options.
WritePackageReferences | Writes package references to the specified TextWriter.
WriteWarningsAsError | Writes list of warnings to (not) treat as errors to the specified TextWriter.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase Constructor

Initializes a new instance of the CompilerBase class.

[Visual Basic]
Protected Sub New()
[C#]
protected CompilerBase();

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase Fields

The fields of the CompilerBase class are listed below. For a complete list of CompilerBase class members, see the CompilerBase Members topic.

Protected Static (Shared) Fields

CodebehindExtensions | Contains a list of extensions for all file types that should be treated as 'code-behind' when looking for resources. Ultimately this will determine if we use the "namespace+filename" or "namespace+classname" algorithm, since code-behind will use the "namespace+classname" algorithm.
CultureNames | Case-insensitive list of valid culture names for this platform.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase.CodebehindExtensions Field

Contains a list of extensions for all file types that should be treated as 'code-behind' when looking for resources. Ultimately this will determine if we use the "namespace+filename" or "namespace+classname" algorithm, since code-behind will use the "namespace+classname" algorithm.

[Visual Basic]
Protected Shared CodebehindExtensions As String()
[C#]
protected static string[] CodebehindExtensions;

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase.CultureNames Field

Case-insensitive list of valid culture names for this platform.

[Visual Basic]
Protected Shared ReadOnly CultureNames As Hashtable
[C#]
protected static readonly Hashtable CultureNames;

Remarks

The key of the Hashtable is the culture name and the value is a null reference (Nothing in Visual Basic).

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase Properties

The properties of the CompilerBase class are listed below. For a complete list of CompilerBase class members, see the CompilerBase Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Debug | Generate debug output. The default is false.
Define | Define conditional compilation symbol(s).
DelaySign | Specifies whether to delay sign the assembly using only the public portion of the strong name key. The default is NotSet.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
Extension | Gets the file extension required by the current compiler.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForceRebuild | Instructs NAnt to recompile the output file regardless of the file timestamps.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
KeyContainer | Specifies the key pair container used to strongname the assembly.
KeyFile | Specifies a strong name key file.
Lib | Obsolete. Additional directories to search in for assembly references.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
MainType | Specifies which type contains the Main method that you want to use as the entry point into the program.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Modules | Link the specified modules into this assembly.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NoWarn | Obsolete. Specifies a comma-separated list of warnings that should be suppressed by the compiler.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | The output file created by the compiler.
OutputTarget | Output type. Possible values are exe, winexe, library or module.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Packages | Specifies list of packages to reference.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
References | Reference metadata from the specified assembly files.
ResourcesList | Resources to embed.
Sources | The set of source files for compilation.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
SupportsDelaySign | Indicates whether the compiler for a given target framework supports the "delaysign" option. The default is false.
SupportsKeyContainer | Indicates whether the compiler for a given target framework supports the "keycontainer" option. The default is false.
SupportsKeyFile | Indicates whether the compiler for a given target framework supports the "keyfile" option. The default is false.
SupportsNoWarnList | Indicates whether the compiler for a given target framework supports a command line option that allows a list of warnings to be suppressed. The default is false.
SupportsPackageReferences | Indicates whether package references are supported by compiler for a given target framework. The default is false.
SupportsWarnAsErrorList | Indicates whether the compiler for a given target framework supports the "warnaserror" option that takes a list of warnings. The default is false.
SuppressWarnings | Specifies a list of warnings that you want the compiler to suppress.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
WarnAsError | Instructs the compiler to treat all warnings as errors. The default is false.
WarningAsError | Controls which warnings should be reported as errors.
Win32Icon | Icon to associate with the application.
Win32Res | Specifies a Win32 resource file (.res).

Protected Instance Properties

ClassNameRegex | Gets the class name regular expression for the language of the current compiler.
CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
NamespaceRegex | Gets the namespace regular expression for the language of the current compiler.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


ClassNameRegex Property

NAnt SDK Documentation - v0.91

CompilerBase.ClassNameRegex Property

Gets the class name regular expression for the language of the current compiler.

[Visual Basic]
MustOverride Protected ReadOnly Property ClassNameRegex As Regex
[C#]
protected abstract System.Text.RegularExpressions.Regex ClassNameRegex {get;}

Property Value

class name regular expression for the language of the current compiler

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


Debug Property

NAnt SDK Documentation - v0.91

CompilerBase.Debug Property

Generate debug output. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="debug", ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property Debug As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="debug", ExpandProperties=True, ProcessXml=True)]
public virtual bool Debug {get; set;}

Remarks

Only used for <jsc> tasks, but retained for backward compatibility (Clover.NET).

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


Define Property

NAnt SDK Documentation - v0.91

CompilerBase.Define Property

Define conditional compilation symbol(s).

[Visual Basic]
<TaskAttribute(Required:=False, Name:="define", ExpandProperties:=True, ProcessXml:=True)>
Public Property Define As String
[C#]
[TaskAttribute(Required=False, Name="define", ExpandProperties=True, ProcessXml=True)]
public string Define {get; set;}

Remarks

Corresponds to /d[efine]: flag.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


DelaySign Property

NAnt SDK Documentation - v0.91

CompilerBase.DelaySign Property

Specifies whether to delay sign the assembly using only the public portion of the strong name key. The default is NotSet.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="delaysign", ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property DelaySign As DelaySign
[C#]
[TaskAttribute(Required=False, Name="delaysign", ExpandProperties=True, ProcessXml=True)]
public virtual NAnt.DotNet.Types.DelaySign DelaySign {get; set;}

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


Extension Property

NAnt SDK Documentation - v0.91

CompilerBase.Extension Property

Gets the file extension required by the current compiler.

[Visual Basic]
MustOverride Public ReadOnly Property Extension As String
[C#]
public abstract string Extension {get;}

Property Value

The file extension required by the current compiler.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


ForceRebuild Property

NAnt SDK Documentation - v0.91

CompilerBase.ForceRebuild Property

Instructs NAnt to recompile the output file regardless of the file timestamps.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="rebuild", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property ForceRebuild As Boolean
[C#]
[TaskAttribute(Required=False, Name="rebuild", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool ForceRebuild {get; set;}

Remarks

When this parameter is to true, NAnt will always run the compiler to rebuild the output file, regardless of the file timestamps.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


KeyContainer Property

NAnt SDK Documentation - v0.91

CompilerBase.KeyContainer Property

Specifies the key pair container used to strongname the assembly.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="keycontainer", ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property KeyContainer As String
[C#]
[TaskAttribute(Required=False, Name="keycontainer", ExpandProperties=True, ProcessXml=True)]
public virtual string KeyContainer {get; set;}

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


KeyFile Property

NAnt SDK Documentation - v0.91

CompilerBase.KeyFile Property

Specifies a strong name key file.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="keyfile", ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property KeyFile As FileInfo
[C#]
[TaskAttribute(Required=False, Name="keyfile", ExpandProperties=True, ProcessXml=True)]
public virtual System.IO.FileInfo KeyFile {get; set;}

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


Lib Property

NAnt SDK Documentation - v0.91

CompilerBase.Lib Property

NOTE: This property is now obsolete.

Use the <lib> element in <references> and <modules> instead.

Additional directories to search in for assembly references.

[Visual Basic]
<BuildElement(Name:="lib", Required:=False, ProcessXml:=True), _ Obsolete(Message:="Use the <lib> element in <references> and <modules> instead.", IsError:=False)>
Public Property Lib As FileSet
[C#]
[BuildElement(Name="lib", Required=False, ProcessXml=True)]
[Obsolete(Message="Use the <lib> element in <references> and <modules> instead.", IsError=False)]
public NAnt.Core.Types.FileSet Lib {get; set;}

Remarks

Corresponds with the /lib[path]: flag.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


MainType Property

NAnt SDK Documentation - v0.91

CompilerBase.MainType Property

Specifies which type contains the Main method that you want to use as the entry point into the program.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="main", ExpandProperties:=True, ProcessXml:=True)>
Public Property MainType As String
[C#]
[TaskAttribute(Required=False, Name="main", ExpandProperties=True, ProcessXml=True)]
public string MainType {get; set;}

Remarks

Corresponds to the /m[ain]: flag of the compiler.

Use this property when creating an executable file. If this property is not set, the compiler searches for a valid Main method in all public classes.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


Modules Property

NAnt SDK Documentation - v0.91

CompilerBase.Modules Property

Link the specified modules into this assembly.

[Visual Basic]
<BuildElement(Name:="modules", Required:=False, ProcessXml:=True)>
Overridable Public Property Modules As AssemblyFileSet
[C#]
[BuildElement(Name="modules", Required=False, ProcessXml=True)]
public virtual NAnt.DotNet.Types.AssemblyFileSet Modules {get; set;}

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


NamespaceRegex Property

NAnt SDK Documentation - v0.91

CompilerBase.NamespaceRegex Property

Gets the namespace regular expression for the language of the current compiler.

[Visual Basic]
MustOverride Protected ReadOnly Property NamespaceRegex As Regex
[C#]
protected abstract System.Text.RegularExpressions.Regex NamespaceRegex {get;}

Property Value

namespace regular expression for the language of the current compiler

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


NoWarn Property

NAnt SDK Documentation - v0.91

CompilerBase.NoWarn Property

NOTE: This property is now obsolete.

Use the <nowarn> element instead.

Specifies a comma-separated list of warnings that should be suppressed by the compiler.

[Visual Basic]
<Obsolete(Message:="Use the <nowarn> element instead.", IsError:=False), _ TaskAttribute(Required:=False, Name:="nowarn", ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property NoWarn As String
[C#]
[Obsolete(Message="Use the <nowarn> element instead.", IsError=False)]
[TaskAttribute(Required=False, Name="nowarn", ExpandProperties=True, ProcessXml=True)]
public virtual string NoWarn {get; set;}

Property Value

Comma-separated list of warnings that should be suppressed by the compiler.

Remarks

Corresponds with the /nowarn flag.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


OutputFile Property

NAnt SDK Documentation - v0.91

CompilerBase.OutputFile Property

The output file created by the compiler.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="output", ExpandProperties:=True, ProcessXml:=True)>
Public Property OutputFile As FileInfo
[C#]
[TaskAttribute(Required=True, Name="output", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo OutputFile {get; set;}

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


OutputTarget Property

NAnt SDK Documentation - v0.91

CompilerBase.OutputTarget Property

Output type. Possible values are exe, winexe, library or module.

[Visual Basic]
<TaskAttribute(Required:=True, Name:="target", ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property OutputTarget As String
[C#]
[TaskAttribute(Required=True, Name="target", ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string OutputTarget {get; set;}

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


Packages Property

NAnt SDK Documentation - v0.91

CompilerBase.Packages Property

Specifies list of packages to reference.

[Visual Basic]
<BuildElementCollection(ChildElementName:="package", ElementType:=null, Name:="pkg-references", Required:=False, ProcessXml:=True)>
Overridable Public Property Packages As PackageCollection
[C#]
[BuildElementCollection(ChildElementName="package", ElementType=null, Name="pkg-references", Required=False, ProcessXml=True)]
public virtual NAnt.DotNet.Types.PackageCollection Packages {get; set;}

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

CompilerBase.ProgramArguments Property

Gets the command-line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

Property Value

The command-line arguments for the external program.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


References Property

NAnt SDK Documentation - v0.91

CompilerBase.References Property

Reference metadata from the specified assembly files.

[Visual Basic]
<BuildElement(Name:="references", Required:=False, ProcessXml:=True)>
Public Property References As AssemblyFileSet
[C#]
[BuildElement(Name="references", Required=False, ProcessXml=True)]
public NAnt.DotNet.Types.AssemblyFileSet References {get; set;}

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


ResourcesList Property

NAnt SDK Documentation - v0.91

CompilerBase.ResourcesList Property

Resources to embed.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="resources", Required:=False, ProcessXml:=True)>
Public ReadOnly Property ResourcesList As ResourceFileSetCollection
[C#]
[BuildElementArray(ElementType=null, Name="resources", Required=False, ProcessXml=True)]
public NAnt.DotNet.Types.ResourceFileSetCollection ResourcesList {get;}

Remarks

This can be a combination of resx files and file resources.

.resx files will be compiled by ResGenTask and then embedded into the resulting executable.

The Prefix property is used to make up the resource name added to the assembly manifest for non-resx files.

For .resx files the namespace from the matching source file is used as prefix. This matches the behaviour of Visual Studio.

Multiple resources tags with different namespace prefixes may be specified.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


Sources Property

NAnt SDK Documentation - v0.91

CompilerBase.Sources Property

The set of source files for compilation.

[Visual Basic]
<BuildElement(Name:="sources", Required:=True, ProcessXml:=True)>
Public Property Sources As FileSet
[C#]
[BuildElement(Name="sources", Required=True, ProcessXml=True)]
public NAnt.Core.Types.FileSet Sources {get; set;}

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


SupportsDelaySign Property

NAnt SDK Documentation - v0.91

CompilerBase.SupportsDelaySign Property

Indicates whether the compiler for a given target framework supports the "delaysign" option. The default is false.

[Visual Basic]
<FrameworkConfigurable(Name:="supportsdelaysign", Required:=False, ExpandProperties:=True)>
Overridable Public Property SupportsDelaySign As Boolean
[C#]
[FrameworkConfigurable(Name="supportsdelaysign", Required=False, ExpandProperties=True)]
public virtual bool SupportsDelaySign {get; set;}

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


SupportsKeyContainer Property

NAnt SDK Documentation - v0.91

CompilerBase.SupportsKeyContainer Property

Indicates whether the compiler for a given target framework supports the "keycontainer" option. The default is false.

[Visual Basic]
<FrameworkConfigurable(Name:="supportskeycontainer", Required:=False, ExpandProperties:=True)>
Overridable Public Property SupportsKeyContainer As Boolean
[C#]
[FrameworkConfigurable(Name="supportskeycontainer", Required=False, ExpandProperties=True)]
public virtual bool SupportsKeyContainer {get; set;}

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


SupportsKeyFile Property

NAnt SDK Documentation - v0.91

CompilerBase.SupportsKeyFile Property

Indicates whether the compiler for a given target framework supports the "keyfile" option. The default is false.

[Visual Basic]
<FrameworkConfigurable(Name:="supportskeyfile", Required:=False, ExpandProperties:=True)>
Overridable Public Property SupportsKeyFile As Boolean
[C#]
[FrameworkConfigurable(Name="supportskeyfile", Required=False, ExpandProperties=True)]
public virtual bool SupportsKeyFile {get; set;}

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


SupportsNoWarnList Property

NAnt SDK Documentation - v0.91

CompilerBase.SupportsNoWarnList Property

Indicates whether the compiler for a given target framework supports a command line option that allows a list of warnings to be suppressed. The default is false.

[Visual Basic]
<FrameworkConfigurable(Name:="supportsnowarnlist", Required:=False, ExpandProperties:=True)>
Overridable Public Property SupportsNoWarnList As Boolean
[C#]
[FrameworkConfigurable(Name="supportsnowarnlist", Required=False, ExpandProperties=True)]
public virtual bool SupportsNoWarnList {get; set;}

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


SupportsPackageReferences Property

NAnt SDK Documentation - v0.91

CompilerBase.SupportsPackageReferences Property

Indicates whether package references are supported by compiler for a given target framework. The default is false.

[Visual Basic]
<FrameworkConfigurable(Name:="supportspackagereferences", Required:=False, ExpandProperties:=True)>
Overridable Public Property SupportsPackageReferences As Boolean
[C#]
[FrameworkConfigurable(Name="supportspackagereferences", Required=False, ExpandProperties=True)]
public virtual bool SupportsPackageReferences {get; set;}

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


SupportsWarnAsErrorList Property

NAnt SDK Documentation - v0.91

CompilerBase.SupportsWarnAsErrorList Property

Indicates whether the compiler for a given target framework supports the "warnaserror" option that takes a list of warnings. The default is false.

[Visual Basic]
<FrameworkConfigurable(Name:="supportswarnaserrorlist", Required:=False, ExpandProperties:=True)>
Overridable Public Property SupportsWarnAsErrorList As Boolean
[C#]
[FrameworkConfigurable(Name="supportswarnaserrorlist", Required=False, ExpandProperties=True)]
public virtual bool SupportsWarnAsErrorList {get; set;}

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


SuppressWarnings Property

NAnt SDK Documentation - v0.91

CompilerBase.SuppressWarnings Property

Specifies a list of warnings that you want the compiler to suppress.

[Visual Basic]
<BuildElementCollection(ChildElementName:="warning", ElementType:=null, Name:="nowarn", Required:=False, ProcessXml:=True)>
Overridable Public ReadOnly Property SuppressWarnings As CompilerWarningCollection
[C#]
[BuildElementCollection(ChildElementName="warning", ElementType=null, Name="nowarn", Required=False, ProcessXml=True)]
public virtual NAnt.DotNet.Types.CompilerWarningCollection SuppressWarnings {get;}

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


WarnAsError Property

NAnt SDK Documentation - v0.91

CompilerBase.WarnAsError Property

Instructs the compiler to treat all warnings as errors. The default is false.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="warnaserror", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property WarnAsError As Boolean
[C#]
[TaskAttribute(Required=False, Name="warnaserror", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool WarnAsError {get; set;}

Remarks

Corresponds to the /warnaserror[+|-] flag of the compiler.

When this property is set to true, any messages that would ordinarily be reported as warnings will instead be reported as errors.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


WarningAsError Property

NAnt SDK Documentation - v0.91

CompilerBase.WarningAsError Property

Controls which warnings should be reported as errors.

[Visual Basic]
<BuildElement(Name:="warnaserror", Required:=False, ProcessXml:=True)>
Overridable Public ReadOnly Property WarningAsError As WarningAsError
[C#]
[BuildElement(Name="warnaserror", Required=False, ProcessXml=True)]
public virtual NAnt.DotNet.Types.WarningAsError WarningAsError {get;}

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


Win32Icon Property

NAnt SDK Documentation - v0.91

CompilerBase.Win32Icon Property

Icon to associate with the application.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="win32icon", ExpandProperties:=True, ProcessXml:=True)>
Public Property Win32Icon As FileInfo
[C#]
[TaskAttribute(Required=False, Name="win32icon", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo Win32Icon {get; set;}

Remarks

Corresponds to /win32icon: flag.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


Win32Res Property

NAnt SDK Documentation - v0.91

CompilerBase.Win32Res Property

Specifies a Win32 resource file (.res).

[Visual Basic]
<TaskAttribute(Required:=False, Name:="win32res", ExpandProperties:=True, ProcessXml:=True)>
Public Property Win32Res As FileInfo
[C#]
[TaskAttribute(Required=False, Name="win32res", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo Win32Res {get; set;}

Remarks

Corresponds to /win32res[ource]: flag.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase Methods

The methods of the CompilerBase class are listed below. For a complete list of CompilerBase class members, see the CompilerBase Members topic.

Public Static (Shared) Methods

GetResourceCulture Determines the culture associated with a given resource file by scanning the filename for valid culture names.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetManifestResourceName | Overloaded. Determines the manifest resource name of the given resource file.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
PerformSearchForResourceLinkage | Extracts the associated namespace/classname linkage found in the given stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CompileResxResources | Compiles a set of resx files to a .resources files.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Compiles the sources and resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
GetResourceLinkage | Finds the correct namespace/classname for a resource file from the given dependent source file.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
LinkResourceAssembly | Link a list of files into a resource assembly.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines whether compilation is needed.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
WriteConditionalCompilationConstants | Writes conditional compilation constants to the specified TextWriter.
WriteModuleReferences | Writes module references to the specified TextWriter.
WriteNoWarnList | Writes list of warnings to suppress to the specified TextWriter.
WriteOption | Overloaded. Writes an option using the default output format.
WriteOptions | Allows derived classes to provide compiler-specific options.
WritePackageReferences | Writes package references to the specified TextWriter.
WriteWarningsAsError | Writes list of warnings to (not) treat as errors to the specified TextWriter.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase.CompileResxResources Method

Compiles a set of resx files to a .resources files.

[Visual Basic]
Protected Sub CompileResxResources( _
ByVal resxFiles As StringCollection _
)
[C#]
protected void CompileResxResources(
StringCollection resxFiles
);

Parameters

resxFiles
The set of resx files to compile.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase.ExecuteTask Method

Compiles the sources and resources.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


GetManifestResourceName Method

NAnt SDK Documentation - v0.91

CompilerBase.GetManifestResourceName Method

Determines the manifest resource name of the given resource file.

Overload List

Determines the manifest resource name of the given resource file.

public string GetManifestResourceName(ResourceFileSet,string);

Determines the manifest resource name of the given resource file.

public string GetManifestResourceName(ResourceFileSet,string,string,string);

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase.GetManifestResourceName Method (ResourceFileSet, String)

Determines the manifest resource name of the given resource file.

[Visual Basic]
Overloads Public Function GetManifestResourceName( _
ByVal resources As ResourceFileSet, _
ByVal resourceFile As String _
) As String
[C#]
public string GetManifestResourceName(
ResourceFileSet resources,
string resourceFile
);

Parameters

resources
The ResourceFileSet containing information that will used to assemble the manifest resource name.
resourceFile
The resource file of which the manifest resource name should be determined.

Return Value

The manifest resource name of the specified resource file.

Remarks

For .resx resources, the name of the dependent is determined by replacing the extension of the file with the extension of the source files for the compiler, and removing the culture name from the file name for localized resources.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace | CompilerBase.GetManifestResourceName Overload List


CompilerBase.GetManifestResourceName Method (ResourceFileSet, String, String, String)

Determines the manifest resource name of the given resource file.

[Visual Basic]
Overloads Public Function GetManifestResourceName( _
ByVal resources As ResourceFileSet, _
ByVal resourcePhysicalFile As String, _
ByVal resourceLogicalFile As String, _
ByVal dependentFile As String _
) As String
[C#]
public string GetManifestResourceName(
ResourceFileSet resources,
string resourcePhysicalFile,
string resourceLogicalFile,
string dependentFile
);

Parameters

resources
The ResourceFileSet containing information that will used to assemble the manifest resource name.
resourcePhysicalFile
The resource file of which the manifest resource name should be determined.
resourceLogicalFile
The logical location of the resource file.
dependentFile
The source file on which the resource file depends.

Return Value

The manifest resource name of the specified resource file.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace | CompilerBase.GetManifestResourceName Overload List


CompilerBase.GetResourceCulture Method

Determines the culture associated with a given resource file by scanning the filename for valid culture names.

[Visual Basic]
Public Shared Function GetResourceCulture( _
ByVal resourceFile As String, _
ByVal dependentFile As String _
) As CultureInfo
[C#]
public static CultureInfo GetResourceCulture(
string resourceFile,
string dependentFile
);

Parameters

resourceFile
The resource file path to check for culture info.
dependentFile
The file on which the resource file depends.

Return Value

A valid CultureInfo instance if the resource is associated with a specific culture; otherwise, a null reference (Nothing in Visual Basic).

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase.GetResourceLinkage Method

Finds the correct namespace/classname for a resource file from the given dependent source file.

[Visual Basic]
Overridable Protected Function GetResourceLinkage( _
ByVal dependentFile As String, _
ByVal resourceCulture As CultureInfo _
) As ResourceLinkage
[C#]
protected virtual ResourceLinkage GetResourceLinkage(
string dependentFile,
CultureInfo resourceCulture
);

Parameters

dependentFile
The file from which the resource linkage of the resource file should be determined.
resourceCulture
The culture of the resource file for which the resource linkage should be determined.

Return Value

The namespace/classname of the source file matching the resource or a null reference (Nothing in Visual Basic) if the dependent source file does not exist.

Remarks

This behaviour may be overidden by each particular compiler to support the namespace/classname syntax for that language.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase.LinkResourceAssembly Method

Link a list of files into a resource assembly.

[Visual Basic]
Protected Sub LinkResourceAssembly( _
ByVal resourceFiles As Hashtable, _
ByVal resourceAssemblyFile As FileInfo, _
ByVal culture As String _
)
[C#]
protected void LinkResourceAssembly(
Hashtable resourceFiles,
FileInfo resourceAssemblyFile,
string culture
);

Parameters

resourceFiles
The collection of resources.
resourceAssemblyFile
Resource assembly to generate
culture
Culture of the generated assembly.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase.NeedsCompiling Method

Determines whether compilation is needed.

[Visual Basic]
Overridable Protected Function NeedsCompiling() As Boolean
[C#]
protected virtual bool NeedsCompiling();

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase.PerformSearchForResourceLinkage Method

Extracts the associated namespace/classname linkage found in the given stream.

[Visual Basic]
Overridable Public Function PerformSearchForResourceLinkage( _
ByVal sr As TextReader _
) As ResourceLinkage
[C#]
public virtual ResourceLinkage PerformSearchForResourceLinkage(
TextReader sr
);

Parameters

sr
The read-only stream of the source file to search.

Return Value

The namespace/classname of the source file matching the resource.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase.WriteConditionalCompilationConstants Method

Writes conditional compilation constants to the specified TextWriter.

[Visual Basic]
Overridable Protected Sub WriteConditionalCompilationConstants( _
ByVal writer As TextWriter _
)
[C#]
protected virtual void WriteConditionalCompilationConstants(
TextWriter writer
);

Parameters

writer
The TextWriter to which the conditional compilation constants should be written.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase.WriteModuleReferences Method

Writes module references to the specified TextWriter.

[Visual Basic]
Overridable Protected Sub WriteModuleReferences( _
ByVal writer As TextWriter _
)
[C#]
protected virtual void WriteModuleReferences(
TextWriter writer
);

Parameters

writer
The TextWriter to which the module references should be written.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase.WriteNoWarnList Method

Writes list of warnings to suppress to the specified TextWriter.

[Visual Basic]
Overridable Protected Sub WriteNoWarnList( _
ByVal writer As TextWriter _
)
[C#]
protected virtual void WriteNoWarnList(
TextWriter writer
);

Parameters

writer
The TextWriter to which the list of warnings to suppress should be written.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


WriteOption Method

NAnt SDK Documentation - v0.91

CompilerBase.WriteOption Method

Writes an option using the default output format.

Overload List

Writes an option using the default output format.

protected virtual void WriteOption(TextWriter,string);

Writes an option and its value using the default output format.

protected virtual void WriteOption(TextWriter,string,string);

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase.WriteOption Method (TextWriter, String)

Writes an option using the default output format.

[Visual Basic]
Overridable Overloads Protected Sub WriteOption( _
ByVal writer As TextWriter, _
ByVal name As String _
)
[C#]
protected virtual void WriteOption(
TextWriter writer,
string name
);

Parameters

writer
The TextWriter to which the compiler options should be written.
name
The name of the option which should be passed to the compiler.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace | CompilerBase.WriteOption Overload List


CompilerBase.WriteOption Method (TextWriter, String, String)

Writes an option and its value using the default output format.

[Visual Basic]
Overridable Overloads Protected Sub WriteOption( _
ByVal writer As TextWriter, _
ByVal name As String, _
ByVal value As String _
)
[C#]
protected virtual void WriteOption(
TextWriter writer,
string name,
string value
);

Parameters

writer
The TextWriter to which the compiler options should be written.
name
The name of the option which should be passed to the compiler.
value
The value of the option which should be passed to the compiler.

Remarks

The combination of name and value (separated by a colon) is quoted unless value is already surrounded by quotes.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace | CompilerBase.WriteOption Overload List


CompilerBase.WriteOptions Method

Allows derived classes to provide compiler-specific options.

[Visual Basic]
Overridable Protected Sub WriteOptions( _
ByVal writer As TextWriter _
)
[C#]
protected virtual void WriteOptions(
TextWriter writer
);

Parameters

writer
The TextWriter to which the compiler options should be written.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase.WritePackageReferences Method

Writes package references to the specified TextWriter.

[Visual Basic]
Overridable Protected Sub WritePackageReferences( _
ByVal writer As TextWriter _
)
[C#]
protected virtual void WritePackageReferences(
TextWriter writer
);

Parameters

writer
The TextWriter to which the package references should be written.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase.WriteWarningsAsError Method

Writes list of warnings to (not) treat as errors to the specified TextWriter.

[Visual Basic]
Overridable Protected Sub WriteWarningsAsError( _
ByVal writer As TextWriter _
)
[C#]
protected virtual void WriteWarningsAsError(
TextWriter writer
);

Parameters

writer
The TextWriter to which the list of warnings should be written.

See Also

CompilerBase Class | NAnt.DotNet.Tasks Namespace


CompilerBase.ResourceLinkage Class

Holds class and namespace information for resource (*.resx) linkage.

For a list of all members of this type, see CompilerBase.ResourceLinkage Members.

System.Object
NAnt.DotNet.Tasks.CompilerBase.ResourceLinkage

[Visual Basic]
Public Class CompilerBase.ResourceLinkage
[C#]
public class CompilerBase.ResourceLinkage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Tasks

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

CompilerBase.ResourceLinkage Members | NAnt.DotNet.Tasks Namespace


CompilerBase.ResourceLinkage Members

CompilerBase.ResourceLinkage overview

Public Instance Constructors

CompilerBase.ResourceLinkage Constructor Initializes a new instance of the CompilerBase.ResourceLinkage class.

Public Instance Properties

ClassName | Gets the name of the class (most likely a form) that the resource is associated with.
Culture | Gets the culture that the resource is associated with.
HasClassName | Gets a value indicating whether a class name is available for this CompilerBase.ResourceLinkage instance.
HasNamespaceName | Gets a value indicating whether a namespace name is available for this CompilerBase.ResourceLinkage instance.
IsValid | Gets a value indicating whether the CompilerBase.ResourceLinkage instances contains valid data.
NamespaceName | Gets the name of namespace the resource is under.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns the resource linkage as a string.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompilerBase.ResourceLinkage Class | NAnt.DotNet.Tasks Namespace


CompilerBase.ResourceLinkage Constructor

Initializes a new instance of the CompilerBase.ResourceLinkage class.

[Visual Basic]
Public Sub New( _
ByVal namespaceName As String, _
ByVal className As String _
)
[C#]
public CompilerBase.ResourceLinkage(
string namespaceName,
string className
);

Parameters

namespaceName
The namespace the resource is under.
className
The class name the resource is associated with.

See Also

CompilerBase.ResourceLinkage Class | NAnt.DotNet.Tasks Namespace


CompilerBase.ResourceLinkage Properties

The properties of the CompilerBase.ResourceLinkage class are listed below. For a complete list of CompilerBase.ResourceLinkage class members, see the CompilerBase.ResourceLinkage Members topic.

Public Instance Properties

ClassName | Gets the name of the class (most likely a form) that the resource is associated with.
Culture | Gets the culture that the resource is associated with.
HasClassName | Gets a value indicating whether a class name is available for this CompilerBase.ResourceLinkage instance.
HasNamespaceName | Gets a value indicating whether a namespace name is available for this CompilerBase.ResourceLinkage instance.
IsValid | Gets a value indicating whether the CompilerBase.ResourceLinkage instances contains valid data.
NamespaceName | Gets the name of namespace the resource is under.

See Also

CompilerBase.ResourceLinkage Class | NAnt.DotNet.Tasks Namespace


ClassName Property

NAnt SDK Documentation - v0.91

CompilerBase.ResourceLinkage.ClassName Property

Gets the name of the class (most likely a form) that the resource is associated with.

[Visual Basic]
Public Property ClassName As String
[C#]
public string ClassName {get; set;}

Property Value

The name of the class the resource is associated with.

See Also

CompilerBase.ResourceLinkage Class | NAnt.DotNet.Tasks Namespace


Culture Property

NAnt SDK Documentation - v0.91

CompilerBase.ResourceLinkage.Culture Property

Gets the culture that the resource is associated with.

[Visual Basic]
Public Property Culture As CultureInfo
[C#]
public System.Globalization.CultureInfo Culture {get; set;}

Property Value

The culture that the resource is associated with.

See Also

CompilerBase.ResourceLinkage Class | NAnt.DotNet.Tasks Namespace


HasClassName Property

NAnt SDK Documentation - v0.91

CompilerBase.ResourceLinkage.HasClassName Property

Gets a value indicating whether a class name is available for this CompilerBase.ResourceLinkage instance.

[Visual Basic]
Public ReadOnly Property HasClassName As Boolean
[C#]
public bool HasClassName {get;}

Property Value

true if a class name is available for this CompilerBase.ResourceLinkage instance; otherwise, false.

See Also

CompilerBase.ResourceLinkage Class | NAnt.DotNet.Tasks Namespace


HasNamespaceName Property

NAnt SDK Documentation - v0.91

CompilerBase.ResourceLinkage.HasNamespaceName Property

Gets a value indicating whether a namespace name is available for this CompilerBase.ResourceLinkage instance.

[Visual Basic]
Public ReadOnly Property HasNamespaceName As Boolean
[C#]
public bool HasNamespaceName {get;}

Property Value

true if a namespace name is available for this CompilerBase.ResourceLinkage instance; otherwise, false.

See Also

CompilerBase.ResourceLinkage Class | NAnt.DotNet.Tasks Namespace


IsValid Property

NAnt SDK Documentation - v0.91

CompilerBase.ResourceLinkage.IsValid Property

Gets a value indicating whether the CompilerBase.ResourceLinkage instances contains valid data.

[Visual Basic]
Public ReadOnly Property IsValid As Boolean
[C#]
public bool IsValid {get;}

Property Value

true if the CompilerBase.ResourceLinkage instance contains valid data; otherwise, false.

See Also

CompilerBase.ResourceLinkage Class | NAnt.DotNet.Tasks Namespace


NamespaceName Property

NAnt SDK Documentation - v0.91

CompilerBase.ResourceLinkage.NamespaceName Property

Gets the name of namespace the resource is under.

[Visual Basic]
Public Property NamespaceName As String
[C#]
public string NamespaceName {get; set;}

Property Value

The name of namespace the resource is under.

See Also

CompilerBase.ResourceLinkage Class | NAnt.DotNet.Tasks Namespace


CompilerBase.ResourceLinkage Methods

The methods of the CompilerBase.ResourceLinkage class are listed below. For a complete list of CompilerBase.ResourceLinkage class members, see the CompilerBase.ResourceLinkage Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns the resource linkage as a string.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompilerBase.ResourceLinkage Class | NAnt.DotNet.Tasks Namespace


CompilerBase.ResourceLinkage.ToString Method

Returns the resource linkage as a string.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

A string representation of the resource linkage.

See Also

CompilerBase.ResourceLinkage Class | NAnt.DotNet.Tasks Namespace


CscTask Class

Compiles C# programs.

For a list of all members of this type, see CscTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.DotNet.Tasks.CompilerBase
NAnt.DotNet.Tasks.CscTask

[Visual Basic]
<TaskName(Name:="csc"), _ ProgramLocation(LocationType:=LocationType.FrameworkDir)>
Public Class CscTask
Inherits CompilerBase
[C#]
[TaskName(Name="csc")]
[ProgramLocation(LocationType=LocationType.FrameworkDir)]
public class CscTask : CompilerBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Note In order to have CscTask generate manifest resource names that match those generated by Microsoft Visual Studio.NET, the value of the Prefix attribute of the <ResourcesList> element should match the "Default Namespace" of the C# project, and the value of the DynamicPrefix attribute should be set to "true".

Example

Compile a "HelloWorld" application, including embedded resources.

<csc target="exe" output="HelloWorld.exe" debug="true">
    <nowarn>
        <!-- do not report warnings for missing XML comments -->
        <warning number="0519" />
    </nowarn>
    <sources>
        <include name="**/*.cs" />
    </sources>
    <resources dynamicprefix="true" prefix="HelloWorld">
        <include name="**/*.resx" />
    </resources>
    <references>
        <include name="System.dll" />
        <include name="System.Data.dll" />
    </references>
</csc>

Requirements

Namespace: NAnt.DotNet.Tasks

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

CscTask Members | NAnt.DotNet.Tasks Namespace


CscTask Members

CscTask overview

Public Instance Constructors

CscTask Constructor Initializes a new instance of the CscTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseAddress | The preferred base address at which to load a DLL. The default base address for a DLL is set by the .NET Framework common language runtime.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
Checked | Specifies whether an integer arithmetic statement that is not in the scope of the checked or unchecked keywords and that results in a value outside the range of the data type should cause a run-time exception. The default is false.
Codepage | Specifies the code page to use for all source code files in the compilation.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Debug | No longer expose this to build authors. Use DebugOutput instead.
DebugOutput | Specifies the type of debugging information generated by the compiler. The default is None.
Define (inherited from CompilerBase) | Define conditional compilation symbol(s).
DelaySign (inherited from CompilerBase) | Specifies whether to delay sign the assembly using only the public portion of the strong name key. The default is NotSet.
DocFile | The name of the XML documentation file to generate.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
Extension | Gets the file extension required by the current compiler.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
FileAlign | Specifies the size of sections in the output file. Valid values are 512, 1024, 2048, 4096, and 8192.
ForceRebuild (inherited from CompilerBase) | Instructs NAnt to recompile the output file regardless of the file timestamps.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
KeyContainer (inherited from CompilerBase) | Specifies the key pair container used to strongname the assembly.
KeyFile (inherited from CompilerBase) | Specifies a strong name key file.
LangVersion | Causes the compiler to only accept syntax that is included in a given specification.
Lib (inherited from CompilerBase) | Obsolete. Additional directories to search in for assembly references.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
MainType (inherited from CompilerBase) | Specifies which type contains the Main method that you want to use as the entry point into the program.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Modules (inherited from CompilerBase) | Link the specified modules into this assembly.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NoConfig | Instructs the compiler not to use implicit references to assemblies. The default is false.
NoStdLib | Instructs the compiler not to import mscorlib.dll. The default is false.
NoWarn (inherited from CompilerBase) | Obsolete. Specifies a comma-separated list of warnings that should be suppressed by the compiler.
Optimize | Specifies whether the compiler should perform optimizations to the make output files smaller, faster, and more effecient. The default is false.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile (inherited from CompilerBase) | The output file created by the compiler.
OutputTarget (inherited from CompilerBase) | Output type. Possible values are exe, winexe, library or module.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Packages (inherited from CompilerBase) | Specifies list of packages to reference.
Parent (inherited from Element) | Gets or sets the parent of the element.
Platform | Specifies which platform version of common language runtime (CLR) can run the output file.
ProgramArguments (inherited from CompilerBase) | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
References (inherited from CompilerBase) | Reference metadata from the specified assembly files.
ResourcesList (inherited from CompilerBase) | Resources to embed.
Sources (inherited from CompilerBase) | The set of source files for compilation.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
SupportsDelaySign (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "delaysign" option. The default is false.
SupportsDocGeneration | Specifies whether the compiler for the active target framework supports generation of XML Documentation file. The default is true.
SupportsKeyContainer (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "keycontainer" option. The default is false.
SupportsKeyFile (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "keyfile" option. The default is false.
SupportsLangVersion | Specifies whether the compiler for the active target framework supports accepting only a specific language syntax. The default is false.
SupportsNoWarnList (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports a command line option that allows a list of warnings to be suppressed. The default is false.
SupportsPackageReferences (inherited from CompilerBase) | Indicates whether package references are supported by compiler for a given target framework. The default is false.
SupportsPlatform | Specifies whether the compiler for the active target framework supports limiting the platform on which the compiled code can run. The default is false.
SupportsWarnAsErrorList (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "warnaserror" option that takes a list of warnings. The default is false.
SuppressWarnings (inherited from CompilerBase) | Specifies a list of warnings that you want the compiler to suppress.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Unsafe | Instructs the compiler to allow code that uses the unsafe keyword. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
WarnAsError (inherited from CompilerBase) | Instructs the compiler to treat all warnings as errors. The default is false.
WarningAsError (inherited from CompilerBase) | Controls which warnings should be reported as errors.
WarningLevel | Specifies the warning level for the compiler to display. Valid values are 0-4. The default is 4.
Win32Icon (inherited from CompilerBase) | Icon to associate with the application.
Win32Res (inherited from CompilerBase) | Specifies a Win32 resource file (.res).

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetManifestResourceName (inherited from CompilerBase) | Overloaded. Determines the manifest resource name of the given resource file.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
PerformSearchForResourceLinkage (inherited from CompilerBase) | Extracts the associated namespace/classname linkage found in the given stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

ClassNameRegex | Gets the class name regular expression for the language of the current compiler.
CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
NamespaceRegex | Gets the namespace regular expression for the language of the current compiler.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CompileResxResources (inherited from CompilerBase) | Compiles a set of resx files to a .resources files.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask (inherited from CompilerBase) | Compiles the sources and resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
GetResourceLinkage (inherited from CompilerBase) | Finds the correct namespace/classname for a resource file from the given dependent source file.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
LinkResourceAssembly (inherited from CompilerBase) | Link a list of files into a resource assembly.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines whether compilation is needed.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
WriteConditionalCompilationConstants (inherited from CompilerBase) | Writes conditional compilation constants to the specified TextWriter.
WriteModuleReferences (inherited from CompilerBase) | Writes module references to the specified TextWriter.
WriteNoWarnList (inherited from CompilerBase) | Writes list of warnings to suppress to the specified TextWriter.
WriteOption (inherited from CompilerBase) | Overloaded. Writes an option using the default output format.
WriteOptions | Writes the compiler options to the specified TextWriter.
WritePackageReferences (inherited from CompilerBase) | Writes package references to the specified TextWriter.
WriteWarningsAsError (inherited from CompilerBase) | Writes list of warnings to (not) treat as errors to the specified TextWriter.

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


CscTask Constructor

Initializes a new instance of the CscTask class.

[Visual Basic]
Public Sub New()
[C#]
public CscTask();

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


CscTask Properties

The properties of the CscTask class are listed below. For a complete list of CscTask class members, see the CscTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseAddress | The preferred base address at which to load a DLL. The default base address for a DLL is set by the .NET Framework common language runtime.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
Checked | Specifies whether an integer arithmetic statement that is not in the scope of the checked or unchecked keywords and that results in a value outside the range of the data type should cause a run-time exception. The default is false.
Codepage | Specifies the code page to use for all source code files in the compilation.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Debug | No longer expose this to build authors. Use DebugOutput instead.
DebugOutput | Specifies the type of debugging information generated by the compiler. The default is None.
Define (inherited from CompilerBase) | Define conditional compilation symbol(s).
DelaySign (inherited from CompilerBase) | Specifies whether to delay sign the assembly using only the public portion of the strong name key. The default is NotSet.
DocFile | The name of the XML documentation file to generate.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
Extension | Gets the file extension required by the current compiler.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
FileAlign | Specifies the size of sections in the output file. Valid values are 512, 1024, 2048, 4096, and 8192.
ForceRebuild (inherited from CompilerBase) | Instructs NAnt to recompile the output file regardless of the file timestamps.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
KeyContainer (inherited from CompilerBase) | Specifies the key pair container used to strongname the assembly.
KeyFile (inherited from CompilerBase) | Specifies a strong name key file.
LangVersion | Causes the compiler to only accept syntax that is included in a given specification.
Lib (inherited from CompilerBase) | Obsolete. Additional directories to search in for assembly references.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
MainType (inherited from CompilerBase) | Specifies which type contains the Main method that you want to use as the entry point into the program.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Modules (inherited from CompilerBase) | Link the specified modules into this assembly.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NoConfig | Instructs the compiler not to use implicit references to assemblies. The default is false.
NoStdLib | Instructs the compiler not to import mscorlib.dll. The default is false.
NoWarn (inherited from CompilerBase) | Obsolete. Specifies a comma-separated list of warnings that should be suppressed by the compiler.
Optimize | Specifies whether the compiler should perform optimizations to the make output files smaller, faster, and more effecient. The default is false.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile (inherited from CompilerBase) | The output file created by the compiler.
OutputTarget (inherited from CompilerBase) | Output type. Possible values are exe, winexe, library or module.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Packages (inherited from CompilerBase) | Specifies list of packages to reference.
Parent (inherited from Element) | Gets or sets the parent of the element.
Platform | Specifies which platform version of common language runtime (CLR) can run the output file.
ProgramArguments (inherited from CompilerBase) | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
References (inherited from CompilerBase) | Reference metadata from the specified assembly files.
ResourcesList (inherited from CompilerBase) | Resources to embed.
Sources (inherited from CompilerBase) | The set of source files for compilation.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
SupportsDelaySign (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "delaysign" option. The default is false.
SupportsDocGeneration | Specifies whether the compiler for the active target framework supports generation of XML Documentation file. The default is true.
SupportsKeyContainer (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "keycontainer" option. The default is false.
SupportsKeyFile (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "keyfile" option. The default is false.
SupportsLangVersion | Specifies whether the compiler for the active target framework supports accepting only a specific language syntax. The default is false.
SupportsNoWarnList (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports a command line option that allows a list of warnings to be suppressed. The default is false.
SupportsPackageReferences (inherited from CompilerBase) | Indicates whether package references are supported by compiler for a given target framework. The default is false.
SupportsPlatform | Specifies whether the compiler for the active target framework supports limiting the platform on which the compiled code can run. The default is false.
SupportsWarnAsErrorList (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "warnaserror" option that takes a list of warnings. The default is false.
SuppressWarnings (inherited from CompilerBase) | Specifies a list of warnings that you want the compiler to suppress.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Unsafe | Instructs the compiler to allow code that uses the unsafe keyword. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
WarnAsError (inherited from CompilerBase) | Instructs the compiler to treat all warnings as errors. The default is false.
WarningAsError (inherited from CompilerBase) | Controls which warnings should be reported as errors.
WarningLevel | Specifies the warning level for the compiler to display. Valid values are 0-4. The default is 4.
Win32Icon (inherited from CompilerBase) | Icon to associate with the application.
Win32Res (inherited from CompilerBase) | Specifies a Win32 resource file (.res).

Protected Instance Properties

ClassNameRegex | Gets the class name regular expression for the language of the current compiler.
CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
NamespaceRegex | Gets the namespace regular expression for the language of the current compiler.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


BaseAddress Property

NAnt SDK Documentation - v0.91

CscTask.BaseAddress Property

The preferred base address at which to load a DLL. The default base address for a DLL is set by the .NET Framework common language runtime.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="baseaddress", ExpandProperties:=True, ProcessXml:=True)>
Public Property BaseAddress As String
[C#]
[TaskAttribute(Required=False, Name="baseaddress", ExpandProperties=True, ProcessXml=True)]
public string BaseAddress {get; set;}

Property Value

The preferred base address at which to load a DLL.

Remarks

This address can be specified as a decimal, hexadecimal, or octal number.

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


Checked Property

NAnt SDK Documentation - v0.91

CscTask.Checked Property

Specifies whether an integer arithmetic statement that is not in the scope of the checked or unchecked keywords and that results in a value outside the range of the data type should cause a run-time exception. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="checked", ExpandProperties:=True, ProcessXml:=True)>
Public Property Checked As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="checked", ExpandProperties=True, ProcessXml=True)]
public bool Checked {get; set;}

Remarks

Corresponds with the /checked[+|-] flag.

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


ClassNameRegex Property

NAnt SDK Documentation - v0.91

CscTask.ClassNameRegex Property

Gets the class name regular expression for the language of the current compiler.

[Visual Basic]
Overrides Protected ReadOnly Property ClassNameRegex As Regex
[C#]
protected override System.Text.RegularExpressions.Regex ClassNameRegex {get;}

Property Value

Class name regular expression for the language of the current compiler.

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


Codepage Property

NAnt SDK Documentation - v0.91

CscTask.Codepage Property

Specifies the code page to use for all source code files in the compilation.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="codepage", ExpandProperties:=True, ProcessXml:=True)>
Public Property Codepage As String
[C#]
[TaskAttribute(Required=False, Name="codepage", ExpandProperties=True, ProcessXml=True)]
public string Codepage {get; set;}

Remarks

Corresponds with the /codepage flag.

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


Debug Property

NAnt SDK Documentation - v0.91

CscTask.Debug Property

No longer expose this to build authors. Use DebugOutput instead.

[Visual Basic]
Overrides Public Property Debug As Boolean
[C#]
public override bool Debug {get; set;}

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


DebugOutput Property

NAnt SDK Documentation - v0.91

CscTask.DebugOutput Property

Specifies the type of debugging information generated by the compiler. The default is None.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="debug", ExpandProperties:=True, ProcessXml:=True)>
Public Property DebugOutput As DebugOutput
[C#]
[TaskAttribute(Required=False, Name="debug", ExpandProperties=True, ProcessXml=True)]
public NAnt.DotNet.Types.DebugOutput DebugOutput {get; set;}

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


DocFile Property

NAnt SDK Documentation - v0.91

CscTask.DocFile Property

The name of the XML documentation file to generate.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="doc", ExpandProperties:=True, ProcessXml:=True)>
Public Property DocFile As FileInfo
[C#]
[TaskAttribute(Required=False, Name="doc", ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo DocFile {get; set;}

Remarks

Corresponds with the /doc: flag.

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


Extension Property

NAnt SDK Documentation - v0.91

CscTask.Extension Property

Gets the file extension required by the current compiler.

[Visual Basic]
Overrides Public ReadOnly Property Extension As String
[C#]
public override string Extension {get;}

Property Value

For the C# compiler, the file extension is always cs.

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


FileAlign Property

NAnt SDK Documentation - v0.91

CscTask.FileAlign Property

Specifies the size of sections in the output file. Valid values are 512, 1024, 2048, 4096, and 8192.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="filealign", ExpandProperties:=True, ProcessXml:=True), _ Int32Validator(Base:=10, MinValue:=512, MaxValue:=8192)>
Public Property FileAlign As Integer
[C#]
[TaskAttribute(Required=False, Name="filealign", ExpandProperties=True, ProcessXml=True)]
[Int32Validator(Base=10, MinValue=512, MaxValue=8192)]
public int FileAlign {get; set;}

Property Value

The size of sections in the output file.

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


LangVersion Property

NAnt SDK Documentation - v0.91

CscTask.LangVersion Property

Causes the compiler to only accept syntax that is included in a given specification.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="langversion", ExpandProperties:=True, ProcessXml:=True)>
Public Property LangVersion As String
[C#]
[TaskAttribute(Required=False, Name="langversion", ExpandProperties=True, ProcessXml=True)]
public string LangVersion {get; set;}

Remarks

Corresponds with the /langversion flag.

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


NamespaceRegex Property

NAnt SDK Documentation - v0.91

CscTask.NamespaceRegex Property

Gets the namespace regular expression for the language of the current compiler.

[Visual Basic]
Overrides Protected ReadOnly Property NamespaceRegex As Regex
[C#]
protected override System.Text.RegularExpressions.Regex NamespaceRegex {get;}

Property Value

Namespace regular expression for the language of the current compiler.

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


NoConfig Property

NAnt SDK Documentation - v0.91

CscTask.NoConfig Property

Instructs the compiler not to use implicit references to assemblies. The default is false.

[Visual Basic]
<FrameworkConfigurable(Name:="noconfig", Required:=False, ExpandProperties:=True), _ TaskAttribute(Required:=False, Name:="noconfig", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property NoConfig As Boolean
[C#]
[FrameworkConfigurable(Name="noconfig", Required=False, ExpandProperties=True)]
[TaskAttribute(Required=False, Name="noconfig", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool NoConfig {get; set;}

Remarks

Corresponds with the /noconfig flag.

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


NoStdLib Property

NAnt SDK Documentation - v0.91

CscTask.NoStdLib Property

Instructs the compiler not to import mscorlib.dll. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Required:=False, Name:="nostdlib", ExpandProperties:=True, ProcessXml:=True), _ FrameworkConfigurable(Name:="nostdlib", Required:=False, ExpandProperties:=True)>
Public Property NoStdLib As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Required=False, Name="nostdlib", ExpandProperties=True, ProcessXml=True)]
[FrameworkConfigurable(Name="nostdlib", Required=False, ExpandProperties=True)]
public bool NoStdLib {get; set;}

Remarks

Corresponds with the /nostdlib[+|-] flag.

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


Optimize Property

NAnt SDK Documentation - v0.91

CscTask.Optimize Property

Specifies whether the compiler should perform optimizations to the make output files smaller, faster, and more effecient. The default is false.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="optimize", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property Optimize As Boolean
[C#]
[TaskAttribute(Required=False, Name="optimize", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool Optimize {get; set;}

Property Value

true if the compiler should perform optimizations; otherwise, false.

Remarks

Corresponds with the /optimize[+|-] flag.

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


Platform Property

NAnt SDK Documentation - v0.91

CscTask.Platform Property

Specifies which platform version of common language runtime (CLR) can run the output file.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="platform", ExpandProperties:=True, ProcessXml:=True)>
Public Property Platform As String
[C#]
[TaskAttribute(Required=False, Name="platform", ExpandProperties=True, ProcessXml=True)]
public string Platform {get; set;}

Property Value

The platform version of common language runtime (CLR) that can run the output file.

Remarks

Corresponds with the /platform flag.

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


SupportsDocGeneration Property

NAnt SDK Documentation - v0.91

CscTask.SupportsDocGeneration Property

Specifies whether the compiler for the active target framework supports generation of XML Documentation file. The default is true.

[Visual Basic]
<FrameworkConfigurable(Name:="supportsdocgeneration", Required:=False, ExpandProperties:=True)>
Public Property SupportsDocGeneration As Boolean
[C#]
[FrameworkConfigurable(Name="supportsdocgeneration", Required=False, ExpandProperties=True)]
public bool SupportsDocGeneration {get; set;}

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


SupportsLangVersion Property

NAnt SDK Documentation - v0.91

CscTask.SupportsLangVersion Property

Specifies whether the compiler for the active target framework supports accepting only a specific language syntax. The default is false.

[Visual Basic]
<FrameworkConfigurable(Name:="supportslangversion", Required:=False, ExpandProperties:=True)>
Public Property SupportsLangVersion As Boolean
[C#]
[FrameworkConfigurable(Name="supportslangversion", Required=False, ExpandProperties=True)]
public bool SupportsLangVersion {get; set;}

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


SupportsPlatform Property

NAnt SDK Documentation - v0.91

CscTask.SupportsPlatform Property

Specifies whether the compiler for the active target framework supports limiting the platform on which the compiled code can run. The default is false.

[Visual Basic]
<FrameworkConfigurable(Name:="supportsplatform", Required:=False, ExpandProperties:=True)>
Public Property SupportsPlatform As Boolean
[C#]
[FrameworkConfigurable(Name="supportsplatform", Required=False, ExpandProperties=True)]
public bool SupportsPlatform {get; set;}

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


Unsafe Property

NAnt SDK Documentation - v0.91

CscTask.Unsafe Property

Instructs the compiler to allow code that uses the unsafe keyword. The default is false.

[Visual Basic]
<TaskAttribute(Required:=False, Name:="unsafe", ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property Unsafe As Boolean
[C#]
[TaskAttribute(Required=False, Name="unsafe", ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool Unsafe {get; set;}

Remarks

Corresponds with the /unsafe[+|-] flag.

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


WarningLevel Property

NAnt SDK Documentation - v0.91

CscTask.WarningLevel Property

Specifies the warning level for the compiler to display. Valid values are 0-4. The default is 4.

[Visual Basic]
<Int32Validator(Base:=10, MinValue:=0, MaxValue:=4), _ TaskAttribute(Required:=False, Name:="warninglevel", ExpandProperties:=True, ProcessXml:=True)>
Public Property WarningLevel As String
[C#]
[Int32Validator(Base=10, MinValue=0, MaxValue=4)]
[TaskAttribute(Required=False, Name="warninglevel", ExpandProperties=True, ProcessXml=True)]
public string WarningLevel {get; set;}

Property Value

The warning level for the compiler to display.

Remarks

Corresponds with the /warn flag.

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


CscTask Methods

The methods of the CscTask class are listed below. For a complete list of CscTask class members, see the CscTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetManifestResourceName (inherited from CompilerBase) | Overloaded. Determines the manifest resource name of the given resource file.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
PerformSearchForResourceLinkage (inherited from CompilerBase) | Extracts the associated namespace/classname linkage found in the given stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CompileResxResources (inherited from CompilerBase) | Compiles a set of resx files to a .resources files.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask (inherited from CompilerBase) | Compiles the sources and resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
GetResourceLinkage (inherited from CompilerBase) | Finds the correct namespace/classname for a resource file from the given dependent source file.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
LinkResourceAssembly (inherited from CompilerBase) | Link a list of files into a resource assembly.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines whether compilation is needed.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
WriteConditionalCompilationConstants (inherited from CompilerBase) | Writes conditional compilation constants to the specified TextWriter.
WriteModuleReferences (inherited from CompilerBase) | Writes module references to the specified TextWriter.
WriteNoWarnList (inherited from CompilerBase) | Writes list of warnings to suppress to the specified TextWriter.
WriteOption (inherited from CompilerBase) | Overloaded. Writes an option using the default output format.
WriteOptions | Writes the compiler options to the specified TextWriter.
WritePackageReferences (inherited from CompilerBase) | Writes package references to the specified TextWriter.
WriteWarningsAsError (inherited from CompilerBase) | Writes list of warnings to (not) treat as errors to the specified TextWriter.

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


CscTask.NeedsCompiling Method

Determines whether compilation is needed.

[Visual Basic]
Overrides Protected Function NeedsCompiling() As Boolean
[C#]
protected override bool NeedsCompiling();

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


CscTask.WriteOptions Method

Writes the compiler options to the specified TextWriter.

[Visual Basic]
Overrides Protected Sub WriteOptions( _
ByVal writer As TextWriter _
)
[C#]
protected override void WriteOptions(
TextWriter writer
);

Parameters

writer
TextWriter to which the compiler options should be written.

See Also

CscTask Class | NAnt.DotNet.Tasks Namespace


DelaySignTask Class

Signs delay-signed .NET Assemblies, or re-signs existing assemblies.

For a list of all members of this type, see DelaySignTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.DotNet.Tasks.DelaySignTask

[Visual Basic]
<ProgramLocation(LocationType:=LocationType.FrameworkSdkDir), _ TaskName(Name:="delay-sign")>
Public Class DelaySignTask
Inherits ExternalProgramBase
[C#]
[ProgramLocation(LocationType=LocationType.FrameworkSdkDir)]
[TaskName(Name="delay-sign")]
public class DelaySignTask : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The delay-signing mechanism takes a fileset (named targets) and either a KeyFile attribute for a file containing the public and private keys, or KeyContainer to name a key container.

Example

Sign partially-signed foo.dll with bar.snk.

<delay-sign keyfile="bar.snk" verbose="false">
    <targets>
        <include name="foo.dll" />
    </targets>
</delay-sign>

Requirements

Namespace: NAnt.DotNet.Tasks

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

DelaySignTask Members | NAnt.DotNet.Tasks Namespace


DelaySignTask Members

DelaySignTask overview

Public Instance Constructors

DelaySignTask Constructor Initializes a new instance of the DelaySignTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
KeyContainer | Specifies the key container.
KeyFile | Specifies the filesystem path to the signing key.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Targets | List of assemblies/executables to sign.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Converts a single file or group of files.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

DelaySignTask Class | NAnt.DotNet.Tasks Namespace


DelaySignTask Constructor

Initializes a new instance of the DelaySignTask class.

[Visual Basic]
Public Sub New()
[C#]
public DelaySignTask();

See Also

DelaySignTask Class | NAnt.DotNet.Tasks Namespace


DelaySignTask Properties

The properties of the DelaySignTask class are listed below. For a complete list of DelaySignTask class members, see the DelaySignTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
KeyContainer | Specifies the key container.
KeyFile | Specifies the filesystem path to the signing key.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Targets | List of assemblies/executables to sign.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

DelaySignTask Class | NAnt.DotNet.Tasks Namespace


KeyContainer Property

NAnt SDK Documentation - v0.91

DelaySignTask.KeyContainer Property

Specifies the key container.

[Visual Basic]
<TaskAttribute(Name:="keycontainer", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property KeyContainer As String
[C#]
[TaskAttribute(Name="keycontainer", Required=False, ExpandProperties=True, ProcessXml=True)]
public string KeyContainer {get; set;}

See Also

DelaySignTask Class | NAnt.DotNet.Tasks Namespace


KeyFile Property

NAnt SDK Documentation - v0.91

DelaySignTask.KeyFile Property

Specifies the filesystem path to the signing key.

[Visual Basic]
<TaskAttribute(Name:="keyfile", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property KeyFile As FileInfo
[C#]
[TaskAttribute(Name="keyfile", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo KeyFile {get; set;}

See Also

DelaySignTask Class | NAnt.DotNet.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

DelaySignTask.ProgramArguments Property

Gets the command line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

Property Value

The command line arguments for the external program.

See Also

DelaySignTask Class | NAnt.DotNet.Tasks Namespace


Targets Property

NAnt SDK Documentation - v0.91

DelaySignTask.Targets Property

List of assemblies/executables to sign.

[Visual Basic]
<BuildElement(Required:=False, Name:="targets", ProcessXml:=True)>
Public Property Targets As FileSet
[C#]
[BuildElement(Required=False, Name="targets", ProcessXml=True)]
public NAnt.Core.Types.FileSet Targets {get; set;}

See Also

DelaySignTask Class | NAnt.DotNet.Tasks Namespace


DelaySignTask Methods

The methods of the DelaySignTask class are listed below. For a complete list of DelaySignTask class members, see the DelaySignTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Converts a single file or group of files.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

DelaySignTask Class | NAnt.DotNet.Tasks Namespace


DelaySignTask.ExecuteTask Method

Converts a single file or group of files.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

DelaySignTask Class | NAnt.DotNet.Tasks Namespace


IlasmTask Class

Compiles ILASM programs.

For a list of all members of this type, see IlasmTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.DotNet.Tasks.IlasmTask

[Visual Basic]
<ProgramLocation(LocationType:=LocationType.FrameworkDir), _ TaskName(Name:="ilasm")>
Public Class IlasmTask
Inherits ExternalProgramBase
[C#]
[ProgramLocation(LocationType=LocationType.FrameworkDir)]
[TaskName(Name="ilasm")]
public class IlasmTask : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Compiles helloworld.il to helloworld.exe.

            <ilasm target="exe" output="helloworld.exe" debug="true">
                <sources>
                    <include name="helloworld.il" />
                </sources>
            </ilasm>

Requirements

Namespace: NAnt.DotNet.Tasks

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

IlasmTask Members | NAnt.DotNet.Tasks Namespace


IlasmTask Members

IlasmTask overview

Public Instance Constructors

IlasmTask Constructor Initializes a new instance of the IlasmTask class.

Public Instance Properties

Alignment | Instructs the compiler to set the FileAlignment value in the PE header.
Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
Base | Instructs the compiler to set the ImageBase value in the PE header.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
Clock | Specifies whether or not the compiler should measure and report the compilation times.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Debug | Specifies whether or not the compiler should generate debug information.
Error | Specifies whether or not the compiler should attempt to create a PE file even if compilation errors have been reported.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
Flags | Instructs the compiler to set the Flags value in the CLR header.
ForceRebuild | Instructs NAnt to recompile the output file regardless of the file timestamps.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
KeyFile | Instructs the compiler to generate a strong signature of the PE file.
KeySource | Instructs the compiler to generate a strong signature of the PE file.
Listing | Specifies whether or not the compiler should type a formatted listing of the compilation result.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | Specifies the name of the output file created by the compiler.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
ResourceFile | Instructs the compiler to link the specified unmanaged resource file into the resulting PE file.
Sources | Specifies the set of source files to compile.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Subsystem | Instructs the compiler to set the Subsystem value in the PE header.
Target | Specifies which output type should be generated.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Compiles the sources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


IlasmTask Constructor

Initializes a new instance of the IlasmTask class.

[Visual Basic]
Public Sub New()
[C#]
public IlasmTask();

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


IlasmTask Properties

The properties of the IlasmTask class are listed below. For a complete list of IlasmTask class members, see the IlasmTask Members topic.

Public Instance Properties

Alignment | Instructs the compiler to set the FileAlignment value in the PE header.
Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
Base | Instructs the compiler to set the ImageBase value in the PE header.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
Clock | Specifies whether or not the compiler should measure and report the compilation times.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Debug | Specifies whether or not the compiler should generate debug information.
Error | Specifies whether or not the compiler should attempt to create a PE file even if compilation errors have been reported.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
Flags | Instructs the compiler to set the Flags value in the CLR header.
ForceRebuild | Instructs NAnt to recompile the output file regardless of the file timestamps.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
KeyFile | Instructs the compiler to generate a strong signature of the PE file.
KeySource | Instructs the compiler to generate a strong signature of the PE file.
Listing | Specifies whether or not the compiler should type a formatted listing of the compilation result.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | Specifies the name of the output file created by the compiler.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
ResourceFile | Instructs the compiler to link the specified unmanaged resource file into the resulting PE file.
Sources | Specifies the set of source files to compile.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Subsystem | Instructs the compiler to set the Subsystem value in the PE header.
Target | Specifies which output type should be generated.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


Alignment Property

NAnt SDK Documentation - v0.91

IlasmTask.Alignment Property

Instructs the compiler to set the FileAlignment value in the PE header.

[Visual Basic]
<TaskAttribute(Name:="alignment", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ Int32Validator(MinValue:=-2147483648, MaxValue:=2147483647, Base:=10)>
Public Property Alignment As Integer
[C#]
[TaskAttribute(Name="alignment", Required=False, ExpandProperties=True, ProcessXml=True)]
[Int32Validator(MinValue=-2147483648, MaxValue=2147483647, Base=10)]
public int Alignment {get; set;}

Property Value

An Int32 that represents the FileAlignment value to set in the PE header. The value must be a power of 2, in range from 512 to 65536.

Remarks

Corresponds to the /ALIGNMENT flag.

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


Base Property

NAnt SDK Documentation - v0.91

IlasmTask.Base Property

Instructs the compiler to set the ImageBase value in the PE header.

[Visual Basic]
<Int32Validator(MinValue:=-2147483648, MaxValue:=2147483647, Base:=10), _ TaskAttribute(Name:="base", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Base As Integer
[C#]
[Int32Validator(MinValue=-2147483648, MaxValue=2147483647, Base=10)]
[TaskAttribute(Name="base", Required=False, ExpandProperties=True, ProcessXml=True)]
public int Base {get; set;}

Property Value

A Int32 that represents the ImageBase value to set in the PE header.

Remarks

Corresponds to the /BASE flag.

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


Clock Property

NAnt SDK Documentation - v0.91

IlasmTask.Clock Property

Specifies whether or not the compiler should measure and report the compilation times.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="clock", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Clock As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="clock", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool Clock {get; set;}

Property Value

true if the compilation times should be measured and reported; otherwise, false. The default is false.

Remarks

Corresponds to the /CLOCK flag.

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


Debug Property

NAnt SDK Documentation - v0.91

IlasmTask.Debug Property

Specifies whether or not the compiler should generate debug information.

[Visual Basic]
<TaskAttribute(Name:="debug", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property Debug As Boolean
[C#]
[TaskAttribute(Name="debug", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool Debug {get; set;}

Property Value

true if debug information should be generated; otherwise, false. The default is false.

Remarks

Corresponds to the /DEBUG flag.

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


Error Property

NAnt SDK Documentation - v0.91

IlasmTask.Error Property

Specifies whether or not the compiler should attempt to create a PE file even if compilation errors have been reported.

[Visual Basic]
<TaskAttribute(Name:="error", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property Error As Boolean
[C#]
[TaskAttribute(Name="error", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool Error {get; set;}

Property Value

true if a PE file has to be created even if compilation errors have been reported; otherwise, false. The default is false.

Remarks

Corresponds to the /ERROR flag.

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


Flags Property

NAnt SDK Documentation - v0.91

IlasmTask.Flags Property

Instructs the compiler to set the Flags value in the CLR header.

[Visual Basic]
<TaskAttribute(Name:="flags", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ Int32Validator(MinValue:=-2147483648, MaxValue:=2147483647, Base:=10)>
Public Property Flags As Integer
[C#]
[TaskAttribute(Name="flags", Required=False, ExpandProperties=True, ProcessXml=True)]
[Int32Validator(MinValue=-2147483648, MaxValue=2147483647, Base=10)]
public int Flags {get; set;}

Property Value

An Int32 that represents the Flags value to set in the CLR header. The most frequently value are 1 (pre-IL code) and 2 (mixed code). The third bit indicating that the PE file is strong signed, is ignored.

Remarks

Corresponds to the /FLAGS flag.

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


ForceRebuild Property

NAnt SDK Documentation - v0.91

IlasmTask.ForceRebuild Property

Instructs NAnt to recompile the output file regardless of the file timestamps.

[Visual Basic]
<TaskAttribute(Name:="rebuild", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property ForceRebuild As Boolean
[C#]
[TaskAttribute(Name="rebuild", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool ForceRebuild {get; set;}

Property Value

true if the output file should be recompiled regardless of its timestamps; otherwise false. The default is false.

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


KeyFile Property

NAnt SDK Documentation - v0.91

IlasmTask.KeyFile Property

Instructs the compiler to generate a strong signature of the PE file.

[Visual Basic]
<TaskAttribute(Name:="keyfile", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property KeyFile As FileInfo
[C#]
[TaskAttribute(Name="keyfile", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo KeyFile {get; set;}

Property Value

A FileInfo that represents the file containing the private encryption key.

Remarks

Corresponds to the /KEY=<keyfile> flag.

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


KeySource Property

NAnt SDK Documentation - v0.91

IlasmTask.KeySource Property

Instructs the compiler to generate a strong signature of the PE file.

[Visual Basic]
<TaskAttribute(Name:="keysource", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property KeySource As String
[C#]
[TaskAttribute(Name="keysource", Required=False, ExpandProperties=True, ProcessXml=True)]
public string KeySource {get; set;}

Property Value

A String that contains the private encryption key.

Remarks

Corresponds to the /KEY=@<keysource> flag.

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


Listing Property

NAnt SDK Documentation - v0.91

IlasmTask.Listing Property

Specifies whether or not the compiler should type a formatted listing of the compilation result.

[Visual Basic]
<TaskAttribute(Name:="listing", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property Listing As Boolean
[C#]
[TaskAttribute(Name="listing", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool Listing {get; set;}

Property Value

true if a formatted listing of the compilation result should be typed; otherwise, false. The default is false.

Remarks

Corresponds to the /LISTING flag.

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


OutputFile Property

NAnt SDK Documentation - v0.91

IlasmTask.OutputFile Property

Specifies the name of the output file created by the compiler.

[Visual Basic]
<TaskAttribute(Name:="output", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property OutputFile As FileInfo
[C#]
[TaskAttribute(Name="output", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo OutputFile {get; set;}

Property Value

A FileInfo that represents the name of the output file.

Remarks

Corresponds to the /OUTPUT flag.

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

IlasmTask.ProgramArguments Property

Gets the command-line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

Property Value

A String that contains the command-line arguments for the external program.

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


ResourceFile Property

NAnt SDK Documentation - v0.91

IlasmTask.ResourceFile Property

Instructs the compiler to link the specified unmanaged resource file into the resulting PE file.

[Visual Basic]
<TaskAttribute(Name:="resourcefile", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property ResourceFile As FileInfo
[C#]
[TaskAttribute(Name="resourcefile", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo ResourceFile {get; set;}

Property Value

A FileInfo that represents the unmanaged resource file to link.

Remarks

Corresponds to the /RESOURCE flag.

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


Sources Property

NAnt SDK Documentation - v0.91

IlasmTask.Sources Property

Specifies the set of source files to compile.

[Visual Basic]
<BuildElement(Required:=True, Name:="sources", ProcessXml:=True)>
Public Property Sources As FileSet
[C#]
[BuildElement(Required=True, Name="sources", ProcessXml=True)]
public NAnt.Core.Types.FileSet Sources {get; set;}

Property Value

A FileSet that represents the set of source files to compile.

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


Subsystem Property

NAnt SDK Documentation - v0.91

IlasmTask.Subsystem Property

Instructs the compiler to set the Subsystem value in the PE header.

[Visual Basic]
<TaskAttribute(Name:="subsystem", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ Int32Validator(MinValue:=-2147483648, MaxValue:=2147483647, Base:=10)>
Public Property Subsystem As Integer
[C#]
[TaskAttribute(Name="subsystem", Required=False, ExpandProperties=True, ProcessXml=True)]
[Int32Validator(MinValue=-2147483648, MaxValue=2147483647, Base=10)]
public int Subsystem {get; set;}

Property Value

An Int32 that represents the Subsystem value to set in the PE header. The most frequently value are 3 (console application) and 2 (GUI application).

Remarks

Corresponds to the /SUBSYSTEM flag.

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


Target Property

NAnt SDK Documentation - v0.91

IlasmTask.Target Property

Specifies which output type should be generated.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="target", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property Target As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="target", Required=True, ExpandProperties=True, ProcessXml=True)]
public string Target {get; set;}

Property Value

A String that contains the target type. Possible values are dll and exe.

Remarks

Corresponds to the /OUTPUT flag.

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


IlasmTask Methods

The methods of the IlasmTask class are listed below. For a complete list of IlasmTask class members, see the IlasmTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Compiles the sources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


IlasmTask.ExecuteTask Method

Compiles the sources.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

IlasmTask Class | NAnt.DotNet.Tasks Namespace


JscTask Class

Compiles JScript.NET programs.

For a list of all members of this type, see JscTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.DotNet.Tasks.CompilerBase
NAnt.DotNet.Tasks.JscTask

[Visual Basic]
<TaskName(Name:="jsc"), _ ProgramLocation(LocationType:=LocationType.FrameworkDir)>
Public Class JscTask
Inherits CompilerBase
[C#]
[TaskName(Name="jsc")]
[ProgramLocation(LocationType=LocationType.FrameworkDir)]
public class JscTask : CompilerBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Compile helloworld.js to helloworld.exe.

            <jsc target="exe" output="helloworld.exe" debug="true">
                <sources>
                    <include name="helloworld.js" />
                </sources>
            </jsc>

Requirements

Namespace: NAnt.DotNet.Tasks

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

JscTask Members | NAnt.DotNet.Tasks Namespace


JscTask Members

JscTask overview

Public Instance Constructors

JscTask Constructor Initializes a new instance of the JscTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
AutoRef | Automatically references assemblies if they have the same name as an imported namespace or as a type annotation when declaring a variable. The default is false.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
Codepage | Specifies the code page to use for all source code files in the compilation.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Debug (inherited from CompilerBase) | Generate debug output. The default is false.
Define (inherited from CompilerBase) | Define conditional compilation symbol(s).
DelaySign | Specifies whether to delay sign the assembly using only the public portion of the strong name key.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
Extension | Gets the file extension required by the current compiler.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForceRebuild (inherited from CompilerBase) | Instructs NAnt to recompile the output file regardless of the file timestamps.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
KeyContainer | Specifies the key pair container used to strongname the assembly.
KeyFile | Specifies a strong name key file.
Lib (inherited from CompilerBase) | Obsolete. Additional directories to search in for assembly references.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
MainType (inherited from CompilerBase) | Specifies which type contains the Main method that you want to use as the entry point into the program.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Modules | Link the specified modules into this assembly.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NoStdLib | Instructs the compiler not to import standard library, and changes AutoRef to false. The default is false.
NoWarn | Obsolete. Specifies a comma-separated list of warnings that should be suppressed by the compiler.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile (inherited from CompilerBase) | The output file created by the compiler.
OutputTarget (inherited from CompilerBase) | Output type. Possible values are exe, winexe, library or module.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Packages (inherited from CompilerBase) | Specifies list of packages to reference.
Parent (inherited from Element) | Gets or sets the parent of the element.
Platform | Specifies which platform version of common language runtime (CLR) can run the output file.
ProgramArguments (inherited from CompilerBase) | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
References (inherited from CompilerBase) | Reference metadata from the specified assembly files.
ResourcesList (inherited from CompilerBase) | Resources to embed.
Sources (inherited from CompilerBase) | The set of source files for compilation.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
SupportsDelaySign | Indicates whether the compiler for a given target framework supports the "delaysign" option. The default is false.
SupportsKeyContainer | Indicates whether the compiler for a given target framework supports the "keycontainer" option. The default is false.
SupportsKeyFile | Indicates whether the compiler for a given target framework supports the "keyfile" option. The default is false.
SupportsNoWarnList (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports a command line option that allows a list of warnings to be suppressed. The default is false.
SupportsPackageReferences (inherited from CompilerBase) | Indicates whether package references are supported by compiler for a given target framework. The default is false.
SupportsPlatform | Specifies whether the compiler for the active target framework supports limiting the platform on which the compiled code can run. The default is false.
SupportsWarnAsErrorList (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "warnaserror" option that takes a list of warnings. The default is false.
SuppressWarnings | Specifies a list of warnings that you want the compiler to suppress.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
VersionSafe | Causes the compiler to generate errors for implicit method overrides. The default is false.
WarnAsError (inherited from CompilerBase) | Instructs the compiler to treat all warnings as errors. The default is false.
WarningAsError | Controls which warnings should be reported as errors.
WarningLevel | Specifies the warning level for the compiler to display. Valid values are 0-4. The default is 4.
Win32Icon (inherited from CompilerBase) | Icon to associate with the application.
Win32Res (inherited from CompilerBase) | Specifies a Win32 resource file (.res).

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetManifestResourceName (inherited from CompilerBase) | Overloaded. Determines the manifest resource name of the given resource file.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
PerformSearchForResourceLinkage (inherited from CompilerBase) | Extracts the associated namespace/classname linkage found in the given stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

ClassNameRegex | Gets the class name regular expression for the language of the current compiler.
CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
NamespaceRegex | Gets the namespace regular expression for the language of the current compiler.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CompileResxResources (inherited from CompilerBase) | Compiles a set of resx files to a .resources files.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask (inherited from CompilerBase) | Compiles the sources and resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
GetResourceLinkage (inherited from CompilerBase) | Finds the correct namespace/classname for a resource file from the given dependent source file.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
LinkResourceAssembly (inherited from CompilerBase) | Link a list of files into a resource assembly.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling (inherited from CompilerBase) | Determines whether compilation is needed.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
WriteConditionalCompilationConstants (inherited from CompilerBase) | Writes conditional compilation constants to the specified TextWriter.
WriteModuleReferences | Writes module references to the specified TextWriter.
WriteNoWarnList (inherited from CompilerBase) | Writes list of warnings to suppress to the specified TextWriter.
WriteOption (inherited from CompilerBase) | Overloaded. Writes an option using the default output format.
WriteOptions | Writes the compiler options to the specified TextWriter.
WritePackageReferences (inherited from CompilerBase) | Writes package references to the specified TextWriter.
WriteWarningsAsError (inherited from CompilerBase) | Writes list of warnings to (not) treat as errors to the specified TextWriter.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


JscTask Constructor

Initializes a new instance of the JscTask class.

[Visual Basic]
Public Sub New()
[C#]
public JscTask();

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


JscTask Properties

The properties of the JscTask class are listed below. For a complete list of JscTask class members, see the JscTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
AutoRef | Automatically references assemblies if they have the same name as an imported namespace or as a type annotation when declaring a variable. The default is false.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
Codepage | Specifies the code page to use for all source code files in the compilation.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Debug (inherited from CompilerBase) | Generate debug output. The default is false.
Define (inherited from CompilerBase) | Define conditional compilation symbol(s).
DelaySign | Specifies whether to delay sign the assembly using only the public portion of the strong name key.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
Extension | Gets the file extension required by the current compiler.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForceRebuild (inherited from CompilerBase) | Instructs NAnt to recompile the output file regardless of the file timestamps.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
KeyContainer | Specifies the key pair container used to strongname the assembly.
KeyFile | Specifies a strong name key file.
Lib (inherited from CompilerBase) | Obsolete. Additional directories to search in for assembly references.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
MainType (inherited from CompilerBase) | Specifies which type contains the Main method that you want to use as the entry point into the program.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Modules | Link the specified modules into this assembly.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NoStdLib | Instructs the compiler not to import standard library, and changes AutoRef to false. The default is false.
NoWarn | Obsolete. Specifies a comma-separated list of warnings that should be suppressed by the compiler.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile (inherited from CompilerBase) | The output file created by the compiler.
OutputTarget (inherited from CompilerBase) | Output type. Possible values are exe, winexe, library or module.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Packages (inherited from CompilerBase) | Specifies list of packages to reference.
Parent (inherited from Element) | Gets or sets the parent of the element.
Platform | Specifies which platform version of common language runtime (CLR) can run the output file.
ProgramArguments (inherited from CompilerBase) | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
References (inherited from CompilerBase) | Reference metadata from the specified assembly files.
ResourcesList (inherited from CompilerBase) | Resources to embed.
Sources (inherited from CompilerBase) | The set of source files for compilation.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
SupportsDelaySign | Indicates whether the compiler for a given target framework supports the "delaysign" option. The default is false.
SupportsKeyContainer | Indicates whether the compiler for a given target framework supports the "keycontainer" option. The default is false.
SupportsKeyFile | Indicates whether the compiler for a given target framework supports the "keyfile" option. The default is false.
SupportsNoWarnList (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports a command line option that allows a list of warnings to be suppressed. The default is false.
SupportsPackageReferences (inherited from CompilerBase) | Indicates whether package references are supported by compiler for a given target framework. The default is false.
SupportsPlatform | Specifies whether the compiler for the active target framework supports limiting the platform on which the compiled code can run. The default is false.
SupportsWarnAsErrorList (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "warnaserror" option that takes a list of warnings. The default is false.
SuppressWarnings | Specifies a list of warnings that you want the compiler to suppress.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
VersionSafe | Causes the compiler to generate errors for implicit method overrides. The default is false.
WarnAsError (inherited from CompilerBase) | Instructs the compiler to treat all warnings as errors. The default is false.
WarningAsError | Controls which warnings should be reported as errors.
WarningLevel | Specifies the warning level for the compiler to display. Valid values are 0-4. The default is 4.
Win32Icon (inherited from CompilerBase) | Icon to associate with the application.
Win32Res (inherited from CompilerBase) | Specifies a Win32 resource file (.res).

Protected Instance Properties

ClassNameRegex | Gets the class name regular expression for the language of the current compiler.
CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
NamespaceRegex | Gets the namespace regular expression for the language of the current compiler.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


AutoRef Property

NAnt SDK Documentation - v0.91

JscTask.AutoRef Property

Automatically references assemblies if they have the same name as an imported namespace or as a type annotation when declaring a variable. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="autoref", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property AutoRef As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="autoref", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool AutoRef {get; set;}

Remarks

Corresponds with the /autoref flag.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


ClassNameRegex Property

NAnt SDK Documentation - v0.91

JscTask.ClassNameRegex Property

Gets the class name regular expression for the language of the current compiler.

[Visual Basic]
Overrides Protected ReadOnly Property ClassNameRegex As Regex
[C#]
protected override System.Text.RegularExpressions.Regex ClassNameRegex {get;}

Property Value

Class name regular expression for the language of the current compiler.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


Codepage Property

NAnt SDK Documentation - v0.91

JscTask.Codepage Property

Specifies the code page to use for all source code files in the compilation.

[Visual Basic]
<TaskAttribute(Name:="codepage", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Codepage As String
[C#]
[TaskAttribute(Name="codepage", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Codepage {get; set;}

Remarks

Corresponds with the /codepage flag.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


DelaySign Property

NAnt SDK Documentation - v0.91

JscTask.DelaySign Property

Specifies whether to delay sign the assembly using only the public portion of the strong name key.

[Visual Basic]
Overrides Public Property DelaySign As DelaySign
[C#]
public override NAnt.DotNet.Types.DelaySign DelaySign {get; set;}

Remarks

Override to avoid exposing this to build authors, as the JScript.NET does not support this.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


Extension Property

NAnt SDK Documentation - v0.91

JscTask.Extension Property

Gets the file extension required by the current compiler.

[Visual Basic]
Overrides Public ReadOnly Property Extension As String
[C#]
public override string Extension {get;}

Property Value

For the JScript.NET compiler, the file extension is always js.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


KeyContainer Property

NAnt SDK Documentation - v0.91

JscTask.KeyContainer Property

Specifies the key pair container used to strongname the assembly.

[Visual Basic]
Overrides Public Property KeyContainer As String
[C#]
public override string KeyContainer {get; set;}

Remarks

Override to avoid exposing this to build authors, as the JScript.NET does not support this.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


KeyFile Property

NAnt SDK Documentation - v0.91

JscTask.KeyFile Property

Specifies a strong name key file.

[Visual Basic]
Overrides Public Property KeyFile As FileInfo
[C#]
public override System.IO.FileInfo KeyFile {get; set;}

Remarks

Override to avoid exposing this to build authors, as the JScript.NET does not support this.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


Modules Property

NAnt SDK Documentation - v0.91

JscTask.Modules Property

Link the specified modules into this assembly.

[Visual Basic]
Overrides Public Property Modules As AssemblyFileSet
[C#]
public override NAnt.DotNet.Types.AssemblyFileSet Modules {get; set;}

Remarks

Override to avoid exposing this to build authors, as the JScript.NET compiler does not support linking modules.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


NamespaceRegex Property

NAnt SDK Documentation - v0.91

JscTask.NamespaceRegex Property

Gets the namespace regular expression for the language of the current compiler.

[Visual Basic]
Overrides Protected ReadOnly Property NamespaceRegex As Regex
[C#]
protected override System.Text.RegularExpressions.Regex NamespaceRegex {get;}

Property Value

Namespace regular expression for the language of the current compiler.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


NoStdLib Property

NAnt SDK Documentation - v0.91

JscTask.NoStdLib Property

Instructs the compiler not to import standard library, and changes AutoRef to false. The default is false.

[Visual Basic]
<TaskAttribute(Name:="nostdlib", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property NoStdLib As Boolean
[C#]
[TaskAttribute(Name="nostdlib", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool NoStdLib {get; set;}

Remarks

Corresponds with the /noconfig flag.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


NoWarn Property

NAnt SDK Documentation - v0.91

JscTask.NoWarn Property

NOTE: This property is now obsolete.

Use the <nowarn> element instead.

Specifies a comma-separated list of warnings that should be suppressed by the compiler.

[Visual Basic]
<Obsolete(Message:="Use the <nowarn> element instead.", IsError:=False)>
Overrides Public Property NoWarn As String
[C#]
[Obsolete(Message="Use the <nowarn> element instead.", IsError=False)]
public override string NoWarn {get; set;}

Remarks

Override to avoid exposing this to build authors, as the JScript.NET compiler does not support package references.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


Platform Property

NAnt SDK Documentation - v0.91

JscTask.Platform Property

Specifies which platform version of common language runtime (CLR) can run the output file.

[Visual Basic]
<TaskAttribute(Name:="platform", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Platform As String
[C#]
[TaskAttribute(Name="platform", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Platform {get; set;}

Property Value

The platform version of common language runtime (CLR) that can run the output file.

Remarks

Corresponds with the /platform flag.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


SupportsDelaySign Property

NAnt SDK Documentation - v0.91

JscTask.SupportsDelaySign Property

Indicates whether the compiler for a given target framework supports the "delaysign" option. The default is false.

[Visual Basic]
Overrides Public Property SupportsDelaySign As Boolean
[C#]
public override bool SupportsDelaySign {get; set;}

Property Value

false.

Remarks

Override to avoid exposing this to build authors, as the JScript.NET does not support this.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


SupportsKeyContainer Property

NAnt SDK Documentation - v0.91

JscTask.SupportsKeyContainer Property

Indicates whether the compiler for a given target framework supports the "keycontainer" option. The default is false.

[Visual Basic]
Overrides Public Property SupportsKeyContainer As Boolean
[C#]
public override bool SupportsKeyContainer {get; set;}

Property Value

false.

Remarks

Override to avoid exposing this to build authors, as the JScript.NET does not support this.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


SupportsKeyFile Property

NAnt SDK Documentation - v0.91

JscTask.SupportsKeyFile Property

Indicates whether the compiler for a given target framework supports the "keyfile" option. The default is false.

[Visual Basic]
Overrides Public Property SupportsKeyFile As Boolean
[C#]
public override bool SupportsKeyFile {get; set;}

Property Value

false.

Remarks

Override to avoid exposing this to build authors, as the JScript.NET does not support this.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


SupportsPlatform Property

NAnt SDK Documentation - v0.91

JscTask.SupportsPlatform Property

Specifies whether the compiler for the active target framework supports limiting the platform on which the compiled code can run. The default is false.

[Visual Basic]
<FrameworkConfigurable(Name:="supportsplatform", Required:=False, ExpandProperties:=True)>
Public Property SupportsPlatform As Boolean
[C#]
[FrameworkConfigurable(Name="supportsplatform", Required=False, ExpandProperties=True)]
public bool SupportsPlatform {get; set;}

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


SuppressWarnings Property

NAnt SDK Documentation - v0.91

JscTask.SuppressWarnings Property

Specifies a list of warnings that you want the compiler to suppress.

[Visual Basic]
Overrides Public ReadOnly Property SuppressWarnings As CompilerWarningCollection
[C#]
public override NAnt.DotNet.Types.CompilerWarningCollection SuppressWarnings {get;}

Remarks

Override to avoid exposing this to build authors, as the JScript.NET compiler does not support suppressing warnings.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


VersionSafe Property

NAnt SDK Documentation - v0.91

JscTask.VersionSafe Property

Causes the compiler to generate errors for implicit method overrides. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="versionsafe", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property VersionSafe As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="versionsafe", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool VersionSafe {get; set;}

Remarks

Corresponds with the /versionsafe flag.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


WarningAsError Property

NAnt SDK Documentation - v0.91

JscTask.WarningAsError Property

Controls which warnings should be reported as errors.

[Visual Basic]
Overrides Public ReadOnly Property WarningAsError As WarningAsError
[C#]
public override NAnt.DotNet.Types.WarningAsError WarningAsError {get;}

Remarks

Override to avoid exposing this to build authors, as the JScript.NET compiler does not allow control over which warnings should be reported as errors.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


WarningLevel Property

NAnt SDK Documentation - v0.91

JscTask.WarningLevel Property

Specifies the warning level for the compiler to display. Valid values are 0-4. The default is 4.

[Visual Basic]
<Int32Validator(MinValue:=0, MaxValue:=4, Base:=10), _ TaskAttribute(Name:="warninglevel", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property WarningLevel As String
[C#]
[Int32Validator(MinValue=0, MaxValue=4, Base=10)]
[TaskAttribute(Name="warninglevel", Required=False, ExpandProperties=True, ProcessXml=True)]
public string WarningLevel {get; set;}

Property Value

The warning level for the compiler to display.

Remarks

Corresponds with the /warn flag.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


JscTask Methods

The methods of the JscTask class are listed below. For a complete list of JscTask class members, see the JscTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetManifestResourceName (inherited from CompilerBase) | Overloaded. Determines the manifest resource name of the given resource file.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
PerformSearchForResourceLinkage (inherited from CompilerBase) | Extracts the associated namespace/classname linkage found in the given stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CompileResxResources (inherited from CompilerBase) | Compiles a set of resx files to a .resources files.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask (inherited from CompilerBase) | Compiles the sources and resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
GetResourceLinkage (inherited from CompilerBase) | Finds the correct namespace/classname for a resource file from the given dependent source file.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
LinkResourceAssembly (inherited from CompilerBase) | Link a list of files into a resource assembly.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling (inherited from CompilerBase) | Determines whether compilation is needed.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
WriteConditionalCompilationConstants (inherited from CompilerBase) | Writes conditional compilation constants to the specified TextWriter.
WriteModuleReferences | Writes module references to the specified TextWriter.
WriteNoWarnList (inherited from CompilerBase) | Writes list of warnings to suppress to the specified TextWriter.
WriteOption (inherited from CompilerBase) | Overloaded. Writes an option using the default output format.
WriteOptions | Writes the compiler options to the specified TextWriter.
WritePackageReferences (inherited from CompilerBase) | Writes package references to the specified TextWriter.
WriteWarningsAsError (inherited from CompilerBase) | Writes list of warnings to (not) treat as errors to the specified TextWriter.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


JscTask.WriteModuleReferences Method

Writes module references to the specified TextWriter.

[Visual Basic]
Overrides Protected Sub WriteModuleReferences( _
ByVal writer As TextWriter _
)
[C#]
protected override void WriteModuleReferences(
TextWriter writer
);

Parameters

writer
The TextWriter to which the module references should be written.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


JscTask.WriteOptions Method

Writes the compiler options to the specified TextWriter.

[Visual Basic]
Overrides Protected Sub WriteOptions( _
ByVal writer As TextWriter _
)
[C#]
protected override void WriteOptions(
TextWriter writer
);

Parameters

writer
TextWriter to which the compiler options should be written.

See Also

JscTask Class | NAnt.DotNet.Tasks Namespace


LicenseTask Class

Generates a .licence file from a .licx file.

For a list of all members of this type, see LicenseTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.DotNet.Tasks.LicenseTask

[Visual Basic]
<Serializable, _ Serializable, _ TaskName(Name:="license"), _ ProgramLocation(LocationType:=LocationType.FrameworkSdkDir)>
Public Class LicenseTask
Inherits ExternalProgramBase
[C#]
[Serializable]
[Serializable]
[TaskName(Name="license")]
[ProgramLocation(LocationType=LocationType.FrameworkSdkDir)]
public class LicenseTask : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

If no output file is specified, the default filename is the name of the target file with the extension .licenses appended.

Example

Generate the file component.exe.licenses file from component.licx.

            <license input="component.licx" licensetarget="component.exe" />

Requirements

Namespace: NAnt.DotNet.Tasks

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

LicenseTask Members | NAnt.DotNet.Tasks Namespace


LicenseTask Members

LicenseTask overview

Public Instance Constructors

LicenseTask Constructor Initializes a new instance of the LicenseTask class.

Public Instance Properties

Arguments | The command-line arguments for the external program.
Assemblies | Names of the references to scan for the licensed component.
BaseDirectory | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
HasCommandLineCompiler | Indicates whether the current target framework has a command line tool for compiling licenses files. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
InputFile | Input file to process.
LicenseTarget | Obsolete. Specifies the executable for which the .licenses file is generated.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | Name of the license file to output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
SupportsAssemblyReferences | Indicates whether assembly references are supported by the current target framework. The default is false.
Target | Specifies the executable for which the .licenses file is generated.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Generates the license file.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Initializes the LicenseTask class.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

LicenseTask Class | NAnt.DotNet.Tasks Namespace


LicenseTask Constructor

Initializes a new instance of the LicenseTask class.

[Visual Basic]
Public Sub New()
[C#]
public LicenseTask();

See Also

LicenseTask Class | NAnt.DotNet.Tasks Namespace


LicenseTask Properties

The properties of the LicenseTask class are listed below. For a complete list of LicenseTask class members, see the LicenseTask Members topic.

Public Instance Properties

Arguments | The command-line arguments for the external program.
Assemblies | Names of the references to scan for the licensed component.
BaseDirectory | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
HasCommandLineCompiler | Indicates whether the current target framework has a command line tool for compiling licenses files. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
InputFile | Input file to process.
LicenseTarget | Obsolete. Specifies the executable for which the .licenses file is generated.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | Name of the license file to output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
SupportsAssemblyReferences | Indicates whether assembly references are supported by the current target framework. The default is false.
Target | Specifies the executable for which the .licenses file is generated.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

LicenseTask Class | NAnt.DotNet.Tasks Namespace


Arguments Property

NAnt SDK Documentation - v0.91

LicenseTask.Arguments Property

The command-line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property Arguments As ArgumentCollection
[C#]
public override NAnt.Core.Types.ArgumentCollection Arguments {get;}

Remarks

Override to avoid exposing these elements in build file.

See Also

LicenseTask Class | NAnt.DotNet.Tasks Namespace


Assemblies Property

NAnt SDK Documentation - v0.91

LicenseTask.Assemblies Property

Names of the references to scan for the licensed component.

[Visual Basic]
<BuildElement(Required:=False, Name:="assemblies", ProcessXml:=True)>
Public Property Assemblies As AssemblyFileSet
[C#]
[BuildElement(Required=False, Name="assemblies", ProcessXml=True)]
public NAnt.DotNet.Types.AssemblyFileSet Assemblies {get; set;}

See Also

LicenseTask Class | NAnt.DotNet.Tasks Namespace


BaseDirectory Property

NAnt SDK Documentation - v0.91

LicenseTask.BaseDirectory Property

Gets the working directory for the application.

[Visual Basic]
Overrides Public Property BaseDirectory As DirectoryInfo
[C#]
public override System.IO.DirectoryInfo BaseDirectory {get; set;}

Property Value

The working directory for the application.

See Also

LicenseTask Class | NAnt.DotNet.Tasks Namespace


HasCommandLineCompiler Property

NAnt SDK Documentation - v0.91

LicenseTask.HasCommandLineCompiler Property

Indicates whether the current target framework has a command line tool for compiling licenses files. The default is true.

[Visual Basic]
<FrameworkConfigurable(Name:="hascommandlinecompiler", Required:=False, ExpandProperties:=True)>
Public Property HasCommandLineCompiler As Boolean
[C#]
[FrameworkConfigurable(Name="hascommandlinecompiler", Required=False, ExpandProperties=True)]
public bool HasCommandLineCompiler {get; set;}

See Also

LicenseTask Class | NAnt.DotNet.Tasks Namespace


InputFile Property

NAnt SDK Documentation - v0.91

LicenseTask.InputFile Property

Input file to process.

[Visual Basic]
<TaskAttribute(Name:="input", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property InputFile As FileInfo
[C#]
[TaskAttribute(Name="input", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo InputFile {get; set;}

See Also

LicenseTask Class | NAnt.DotNet.Tasks Namespace


LicenseTarget Property

NAnt SDK Documentation - v0.91

LicenseTask.LicenseTarget Property

NOTE: This property is now obsolete.

Use the "target" attribute instead.

Specifies the executable for which the .licenses file is generated.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _
 TaskAttribute(Name:="licensetarget", Required:=False, ExpandProperties:=True, ProcessXml:=True), _
 Obsolete(Message:="Use the "target" attribute instead.", IsError:=False)>
Public Property LicenseTarget As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="licensetarget", Required=False, ExpandProperties=True, ProcessXml=True)]
[Obsolete(Message="Use the "target" attribute instead.", IsError=False)]
public string LicenseTarget {get; set;}

See Also

LicenseTask Class | NAnt.DotNet.Tasks Namespace


OutputFile Property

NAnt SDK Documentation - v0.91

LicenseTask.OutputFile Property

Name of the license file to output.

[Visual Basic]
<TaskAttribute(Name:="output", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property OutputFile As FileInfo
[C#]
[TaskAttribute(Name="output", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo OutputFile {get; set;}

See Also

LicenseTask Class | NAnt.DotNet.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

LicenseTask.ProgramArguments Property

Gets the command-line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

Property Value

The command-line arguments for the external program.

See Also

LicenseTask Class | NAnt.DotNet.Tasks Namespace


ProgramFileName Property

NAnt SDK Documentation - v0.91

LicenseTask.ProgramFileName Property

Gets the filename of the external program to start.

[Visual Basic]
Overrides Public ReadOnly Property ProgramFileName As String
[C#]
public override string ProgramFileName {get;}

Property Value

The filename of the external program.

Remarks

Override in derived classes to explicitly set the location of the external tool.

See Also

LicenseTask Class | NAnt.DotNet.Tasks Namespace


SupportsAssemblyReferences Property

NAnt SDK Documentation - v0.91

LicenseTask.SupportsAssemblyReferences Property

Indicates whether assembly references are supported by the current target framework. The default is false.

[Visual Basic]
<FrameworkConfigurable(Name:="supportsassemblyreferences", Required:=False, ExpandProperties:=True)>
Public Property SupportsAssemblyReferences As Boolean
[C#]
[FrameworkConfigurable(Name="supportsassemblyreferences", Required=False, ExpandProperties=True)]
public bool SupportsAssemblyReferences {get; set;}

Remarks

Applies only to frameworks having a command line tool for compiling licenses files.

See Also

LicenseTask Class | NAnt.DotNet.Tasks Namespace


Target Property

NAnt SDK Documentation - v0.91

LicenseTask.Target Property

Specifies the executable for which the .licenses file is generated.

[Visual Basic]
<TaskAttribute(Name:="target", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property Target As String
[C#]
[TaskAttribute(Name="target", Required=False, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string Target {get; set;}

See Also

LicenseTask Class | NAnt.DotNet.Tasks Namespace


LicenseTask Methods

The methods of the LicenseTask class are listed below. For a complete list of LicenseTask class members, see the LicenseTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Generates the license file.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Initializes the LicenseTask class.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

LicenseTask Class | NAnt.DotNet.Tasks Namespace


LicenseTask.ExecuteTask Method

Generates the license file.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

LicenseTask Class | NAnt.DotNet.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

LicenseTask.Initialize Method

Initializes the LicenseTask class.

Overload List

Initializes the LicenseTask class.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

LicenseTask Class | NAnt.DotNet.Tasks Namespace


LicenseTask.Initialize Method ()

Initializes the LicenseTask class.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

LicenseTask Class | NAnt.DotNet.Tasks Namespace | LicenseTask.Initialize Overload List


LicenseTask.PrepareProcess Method

Updates the ProcessStartInfo of the specified Process.

[Visual Basic]
Overrides Protected Sub PrepareProcess( _
ByVal process As Process _
)
[C#]
protected override void PrepareProcess(
Process process
);

Parameters

process
The Process of which the ProcessStartInfo should be updated.

See Also

LicenseTask Class | NAnt.DotNet.Tasks Namespace


NDocTask Class

Runs NDoc V1.3.1 to create documentation.

For a list of all members of this type, see NDocTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.DotNet.Tasks.NDocTask

[Visual Basic]
<TaskName(Name:="ndoc")>
Public Class NDocTask
Inherits Task
[C#]
[TaskName(Name="ndoc")]
public class NDocTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

See the NDoc home page for more information.

Note By default, only the NDoc MSDN documenter ships as part of the NAnt distribution. To make another NDoc documenter from the NDoc V1.3.1 distribution available to the NDocTask, copy the documenter assembly (and possible dependencies) to the "lib" directory corresponding with the CLR you're running NAnt on (eg. <nant root>/bin/lib/net/1.1).

Example

Document two assemblies using the MSDN documenter. The namespaces are documented in NamespaceSummary.xml.

<ndoc>
    <assemblies basedir="${build.dir}">
        <include name="NAnt.exe" />
        <include name="NAnt.Core.dll" />
    </assemblies>
    <summaries basedir="${build.dir}">
        <include name="NamespaceSummary.xml" />
    </summaries>
    <documenters>
        <documenter name="MSDN">
            <property name="OutputDirectory" value="doc\MSDN" />
            <property name="HtmlHelpName" value="NAnt" />
            <property name="IncludeFavorites" value="False" />
            <property name="Title" value="An NDoc Documented Class Library" />
            <property name="SplitTOCs" value="False" />
            <property name="DefaulTOC" value="" />
            <property name="ShowVisualBasic" value="True" />
            <property name="ShowMissingSummaries" value="True" />
            <property name="ShowMissingRemarks" value="True" />
            <property name="ShowMissingParams" value="True" />
            <property name="ShowMissingReturns" value="True" />
            <property name="ShowMissingValues" value="True" />
            <property name="DocumentInternals" value="False" />
            <property name="DocumentProtected" value="True" />
            <property name="DocumentPrivates" value="False" />
            <property name="DocumentEmptyNamespaces" value="False" />
            <property name="IncludeAssemblyVersion" value="False" />
            <property name="CopyrightText" value="" />
            <property name="CopyrightHref" value="" />
         </documenter>
    </documenters>
</ndoc>

Content of NamespaceSummary.xml :

<namespaces>
    <namespace name="Foo.Bar">
        The <b>Foo.Bar</b> namespace reinvents the wheel.
    </namespace>
    <namespace name="Foo.Bar.Tests">
        The <b>Foo.Bar.Tests</b> namespace ensures that the Foo.Bar namespace reinvents the wheel correctly.
    </namespace>
</namespaces>

Requirements

Namespace: NAnt.DotNet.Tasks

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

NDocTask Members | NAnt.DotNet.Tasks Namespace


NDocTask Members

NDocTask overview

Public Instance Constructors

NDocTask Constructor Initializes a new instance of the NDocTask class.

Public Instance Properties

Assemblies | The set of assemblies to document.
Documenters | Specifies the formats in which the documentation should be generated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
ReferencePaths | Collection of additional directories to search for referenced assemblies.
Summaries | The set of namespace summary files.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Generates an NDoc project and builds the documentation.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Initializes the taks and verifies the parameters.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NDocTask Class | NAnt.DotNet.Tasks Namespace


NDocTask Constructor

Initializes a new instance of the NDocTask class.

[Visual Basic]
Public Sub New()
[C#]
public NDocTask();

See Also

NDocTask Class | NAnt.DotNet.Tasks Namespace


NDocTask Properties

The properties of the NDocTask class are listed below. For a complete list of NDocTask class members, see the NDocTask Members topic.

Public Instance Properties

Assemblies | The set of assemblies to document.
Documenters | Specifies the formats in which the documentation should be generated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
ReferencePaths | Collection of additional directories to search for referenced assemblies.
Summaries | The set of namespace summary files.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

NDocTask Class | NAnt.DotNet.Tasks Namespace


Assemblies Property

NAnt SDK Documentation - v0.91

NDocTask.Assemblies Property

The set of assemblies to document.

[Visual Basic]
<BuildElement(Required:=True, Name:="assemblies", ProcessXml:=True)>
Public Property Assemblies As AssemblyFileSet
[C#]
[BuildElement(Required=True, Name="assemblies", ProcessXml=True)]
public NAnt.DotNet.Types.AssemblyFileSet Assemblies {get; set;}

See Also

NDocTask Class | NAnt.DotNet.Tasks Namespace


Documenters Property

NAnt SDK Documentation - v0.91

NDocTask.Documenters Property

Specifies the formats in which the documentation should be generated.

[Visual Basic]
<BuildElement(Required:=True, Name:="documenters", ProcessXml:=True)>
Public Property Documenters As RawXml
[C#]
[BuildElement(Required=True, Name="documenters", ProcessXml=True)]
public NAnt.Core.Types.RawXml Documenters {get; set;}

See Also

NDocTask Class | NAnt.DotNet.Tasks Namespace


ReferencePaths Property

NAnt SDK Documentation - v0.91

NDocTask.ReferencePaths Property

Collection of additional directories to search for referenced assemblies.

[Visual Basic]
<BuildElement(Required:=False, Name:="referencepaths", ProcessXml:=True)>
Public Property ReferencePaths As DirSet
[C#]
[BuildElement(Required=False, Name="referencepaths", ProcessXml=True)]
public NAnt.Core.Types.DirSet ReferencePaths {get; set;}

See Also

NDocTask Class | NAnt.DotNet.Tasks Namespace


Summaries Property

NAnt SDK Documentation - v0.91

NDocTask.Summaries Property

The set of namespace summary files.

[Visual Basic]
<BuildElement(Required:=False, Name:="summaries", ProcessXml:=True)>
Public Property Summaries As FileSet
[C#]
[BuildElement(Required=False, Name="summaries", ProcessXml=True)]
public NAnt.Core.Types.FileSet Summaries {get; set;}

See Also

NDocTask Class | NAnt.DotNet.Tasks Namespace


NDocTask Methods

The methods of the NDocTask class are listed below. For a complete list of NDocTask class members, see the NDocTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Generates an NDoc project and builds the documentation.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Initializes the taks and verifies the parameters.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NDocTask Class | NAnt.DotNet.Tasks Namespace


NDocTask.ExecuteTask Method

Generates an NDoc project and builds the documentation.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

NDocTask Class | NAnt.DotNet.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

NDocTask.Initialize Method

Initializes the taks and verifies the parameters.

Overload List

Initializes the taks and verifies the parameters.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

NDocTask Class | NAnt.DotNet.Tasks Namespace


NDocTask.Initialize Method ()

Initializes the taks and verifies the parameters.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

NDocTask Class | NAnt.DotNet.Tasks Namespace | NDocTask.Initialize Overload List


QualifiedResource Class

For internal use only !

For a list of all members of this type, see QualifiedResource Members.

System.Object
NAnt.DotNet.Tasks.QualifiedResource

[Visual Basic]
Public Class QualifiedResource
[C#]
public class QualifiedResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Tasks

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

QualifiedResource Members | NAnt.DotNet.Tasks Namespace


QualifiedResource Members

QualifiedResource overview

Public Instance Constructors

QualifiedResource Constructor Initializes a new instance of the QualifiedResource class for a given input and output file.

Public Instance Properties

Input | Gets the resource file to compile.
Output | Gets the compiled resource file.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QualifiedResource Class | NAnt.DotNet.Tasks Namespace


QualifiedResource Constructor

Initializes a new instance of the QualifiedResource class for a given input and output file.

[Visual Basic]
Public Sub New( _
ByVal input As FileInfo, _
ByVal output As FileInfo _
)
[C#]
public QualifiedResource(
FileInfo input,
FileInfo output
);

Parameters

input
The resource to compile.
output
The compiled resource.

See Also

QualifiedResource Class | NAnt.DotNet.Tasks Namespace


QualifiedResource Properties

The properties of the QualifiedResource class are listed below. For a complete list of QualifiedResource class members, see the QualifiedResource Members topic.

Public Instance Properties

Input | Gets the resource file to compile.
Output | Gets the compiled resource file.

See Also

QualifiedResource Class | NAnt.DotNet.Tasks Namespace


Input Property

NAnt SDK Documentation - v0.91

QualifiedResource.Input Property

Gets the resource file to compile.

[Visual Basic]
Public ReadOnly Property Input As FileInfo
[C#]
public System.IO.FileInfo Input {get;}

Property Value

The resource file to compile.

See Also

QualifiedResource Class | NAnt.DotNet.Tasks Namespace


Output Property

NAnt SDK Documentation - v0.91

QualifiedResource.Output Property

Gets the compiled resource file.

[Visual Basic]
Public ReadOnly Property Output As FileInfo
[C#]
public System.IO.FileInfo Output {get;}

Property Value

The compiled resource file.

See Also

QualifiedResource Class | NAnt.DotNet.Tasks Namespace


RegsvcsTask Class

Installs or removes .NET Services.

For a list of all members of this type, see RegsvcsTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.DotNet.Tasks.RegsvcsTask

[Visual Basic]
<ProgramLocation(LocationType:=LocationType.FrameworkDir), _ TaskName(Name:="regsvcs")>
Public Class RegsvcsTask
Inherits ExternalProgramBase
[C#]
[ProgramLocation(LocationType=LocationType.FrameworkDir)]
[TaskName(Name="regsvcs")]
public class RegsvcsTask : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This tasks provides the same functionality as the regsvcs tool provided in the .NET SDK.

It performs the following actions:

  • Loads and registers an assembly.
  • Generates, registers, and installs a type library into a specified COM+ application.
  • Configures services that are added programmatically to your class.

Refer to the .NET Services Installation Tool (Regsvcs.exe) for more information.

Example

Adds all public classes contained in myTest.dll to a COM+ application and produces the myTest.tlb type library. If the application already exists, it is overwritten.

            <regsvcs action="FindOrCreate" assembly="myTest.dll" />

Adds all public classes contained in myTest.dll to myTargetApp and produces the myTest.tlb type library. If the application already exists, it is overwritten.

            <regsvcs action="FindOrCreate" assembly="myTest.dll" application="myTargetApp" />

Adds all public classes contained in myTest.dll to a COM+ application and produces the myTest.tlb type library. A new application is always created.

            <regsvcs action="Create" assembly="myTest.dll" />

Uninstalls the COM+ application contained in myTest.dll.

            <regsvcs action="Uninstall" assembly="myTest.dll" />

Requirements

Namespace: NAnt.DotNet.Tasks

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

RegsvcsTask Members | NAnt.DotNet.Tasks Namespace


RegsvcsTask Members

RegsvcsTask overview

Public Instance Constructors

RegsvcsTask Constructor Initializes a new instance of the RegsvcsTask class.

Public Instance Properties

Action | Defines the action to take with the assembly. The default is FindOrCreate.
ApplicationName | Specifies the name of the COM+ application to either find or create.
Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
AssemblyFile | The source assembly file.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
ComponentsOnly | Configures components only; ignores methods and interfaces. The default is false.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExistingApplication | Expect an existing application. The default is false.
ExistingTypeLibrary | Uses an existing type library. The default is false.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NoReconfig | Do not reconfigure an existing target application. The default is false.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
PartitionName | Specifies the name or id of the COM+ application to either find or create.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
TypeLibrary | Specifies the type library file to install.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Performs the specified action.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

RegsvcsTask Class | NAnt.DotNet.Tasks Namespace


RegsvcsTask Constructor

Initializes a new instance of the RegsvcsTask class.

[Visual Basic]
Public Sub New()
[C#]
public RegsvcsTask();

See Also

RegsvcsTask Class | NAnt.DotNet.Tasks Namespace


RegsvcsTask Properties

The properties of the RegsvcsTask class are listed below. For a complete list of RegsvcsTask class members, see the RegsvcsTask Members topic.

Public Instance Properties

Action | Defines the action to take with the assembly. The default is FindOrCreate.
ApplicationName | Specifies the name of the COM+ application to either find or create.
Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
AssemblyFile | The source assembly file.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
ComponentsOnly | Configures components only; ignores methods and interfaces. The default is false.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExistingApplication | Expect an existing application. The default is false.
ExistingTypeLibrary | Uses an existing type library. The default is false.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NoReconfig | Do not reconfigure an existing target application. The default is false.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
PartitionName | Specifies the name or id of the COM+ application to either find or create.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
TypeLibrary | Specifies the type library file to install.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

RegsvcsTask Class | NAnt.DotNet.Tasks Namespace


Action Property

NAnt SDK Documentation - v0.91

RegsvcsTask.Action Property

Defines the action to take with the assembly. The default is FindOrCreate.

[Visual Basic]
<TaskAttribute(Name:="action", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Action As ActionType
[C#]
[TaskAttribute(Name="action", Required=False, ExpandProperties=True, ProcessXml=True)]
public RegsvcsTask.ActionType Action {get; set;}

See Also

RegsvcsTask Class | NAnt.DotNet.Tasks Namespace


ApplicationName Property

NAnt SDK Documentation - v0.91

RegsvcsTask.ApplicationName Property

Specifies the name of the COM+ application to either find or create.

[Visual Basic]
<TaskAttribute(Name:="application", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property ApplicationName As String
[C#]
[TaskAttribute(Name="application", Required=False, ExpandProperties=True, ProcessXml=True)]
public string ApplicationName {get; set;}

See Also

RegsvcsTask Class | NAnt.DotNet.Tasks Namespace


AssemblyFile Property

NAnt SDK Documentation - v0.91

RegsvcsTask.AssemblyFile Property

The source assembly file.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="assembly", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property AssemblyFile As FileInfo
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="assembly", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo AssemblyFile {get; set;}

Remarks

The assembly must be signed with a strong name.

See Also

RegsvcsTask Class | NAnt.DotNet.Tasks Namespace


ComponentsOnly Property

NAnt SDK Documentation - v0.91

RegsvcsTask.ComponentsOnly Property

Configures components only; ignores methods and interfaces. The default is false.

[Visual Basic]
<TaskAttribute(Name:="componentsonly", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property ComponentsOnly As Boolean
[C#]
[TaskAttribute(Name="componentsonly", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool ComponentsOnly {get; set;}

See Also

RegsvcsTask Class | NAnt.DotNet.Tasks Namespace


ExistingApplication Property

NAnt SDK Documentation - v0.91

RegsvcsTask.ExistingApplication Property

Expect an existing application. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="existingapp", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property ExistingApplication As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="existingapp", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool ExistingApplication {get; set;}

See Also

RegsvcsTask Class | NAnt.DotNet.Tasks Namespace


ExistingTypeLibrary Property

NAnt SDK Documentation - v0.91

RegsvcsTask.ExistingTypeLibrary Property

Uses an existing type library. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="existingtlb", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property ExistingTypeLibrary As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="existingtlb", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool ExistingTypeLibrary {get; set;}

See Also

RegsvcsTask Class | NAnt.DotNet.Tasks Namespace


NoReconfig Property

NAnt SDK Documentation - v0.91

RegsvcsTask.NoReconfig Property

Do not reconfigure an existing target application. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="noreconfig", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property NoReconfig As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="noreconfig", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool NoReconfig {get; set;}

See Also

RegsvcsTask Class | NAnt.DotNet.Tasks Namespace


PartitionName Property

NAnt SDK Documentation - v0.91

RegsvcsTask.PartitionName Property

Specifies the name or id of the COM+ application to either find or create.

[Visual Basic]
<TaskAttribute(Name:="partition", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property PartitionName As String
[C#]
[TaskAttribute(Name="partition", Required=False, ExpandProperties=True, ProcessXml=True)]
public string PartitionName {get; set;}

See Also

RegsvcsTask Class | NAnt.DotNet.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

RegsvcsTask.ProgramArguments Property

Gets the command-line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

Property Value

The command-line arguments for the external program.

See Also

RegsvcsTask Class | NAnt.DotNet.Tasks Namespace


TypeLibrary Property

NAnt SDK Documentation - v0.91

RegsvcsTask.TypeLibrary Property

Specifies the type library file to install.

[Visual Basic]
<TaskAttribute(Name:="tlb", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property TypeLibrary As FileInfo
[C#]
[TaskAttribute(Name="tlb", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo TypeLibrary {get; set;}

See Also

RegsvcsTask Class | NAnt.DotNet.Tasks Namespace


RegsvcsTask Methods

The methods of the RegsvcsTask class are listed below. For a complete list of RegsvcsTask class members, see the RegsvcsTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Performs the specified action.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

RegsvcsTask Class | NAnt.DotNet.Tasks Namespace


RegsvcsTask.ExecuteTask Method

Performs the specified action.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

RegsvcsTask Class | NAnt.DotNet.Tasks Namespace


RegsvcsTask.ActionType Enumeration

Defines the possible actions for a .NET Service.

[Visual Basic]
<Serializable>
Public Enum RegsvcsTask.ActionType
[C#]
[Serializable]
public enum RegsvcsTask.ActionType

Members

Member Name | Description
FindOrCreate | Finds or creates the target application.
Create | Creates the target application.
Uninstall | Uninstalls the target application.

Requirements

Namespace: NAnt.DotNet.Tasks

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

NAnt.DotNet.Tasks Namespace


ResGenTask Class

Converts files from one resource format to another.

For a list of all members of this type, see ResGenTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.DotNet.Tasks.ResGenTask

[Visual Basic]
<ProgramLocation(LocationType:=LocationType.FrameworkSdkDir), _ TaskName(Name:="resgen")>
Public Class ResGenTask
Inherits ExternalProgramBase
[C#]
[ProgramLocation(LocationType=LocationType.FrameworkSdkDir)]
[TaskName(Name="resgen")]
public class ResGenTask : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Note If no ToDirectory is specified, the resource file will be created next to the input file.

Example

Convert a resource file from the .resx to the .resources format.

<resgen input="translations.resx" output="translations.resources" />

Convert a set of .resx files to the .resources format.

<resgen todir=".">
    <resources>
        <include name="*.resx" />
    </resources>
</resgen>

Requirements

Namespace: NAnt.DotNet.Tasks

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

ResGenTask Members | NAnt.DotNet.Tasks Namespace


ResGenTask Members

ResGenTask overview

Public Instance Constructors

ResGenTask Constructor Initializes a new instance of the ResGenTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
Assemblies | Reference metadata from the specified assembly files.
BaseDirectory | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
InputFile | Input file to process.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | The resource file to output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command line arguments for the external program.
ProgramFileName | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
QualifiedResources | For internal use only !
Resources | Takes a list of .resx or .txt files to convert to .resources files.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
SupportsAssemblyReferences | Indicates whether assembly references are supported by the resgen tool for the current target framework. The default is false.
SupportsExternalFileReferences | Indicates whether external file references are supported by the resgen tool for the current target framework. The default is false.
TargetExt | The target type. The default is resources.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
ToDirectory | The directory to which outputs will be stored.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
UseSourcePath | Use each source file's directory as the current directory for resolving relative file paths. The default is false. Only supported when targeting .NET 2.0 (or higher).
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
RemoveOutputs | Cleans up generated files.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Converts a single file or group of files.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines whether the specified input file needs to be compiled.
PrepareProcess | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


ResGenTask Constructor

Initializes a new instance of the ResGenTask class.

[Visual Basic]
Public Sub New()
[C#]
public ResGenTask();

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


ResGenTask Properties

The properties of the ResGenTask class are listed below. For a complete list of ResGenTask class members, see the ResGenTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
Assemblies | Reference metadata from the specified assembly files.
BaseDirectory | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
InputFile | Input file to process.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | The resource file to output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command line arguments for the external program.
ProgramFileName | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
QualifiedResources | For internal use only !
Resources | Takes a list of .resx or .txt files to convert to .resources files.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
SupportsAssemblyReferences | Indicates whether assembly references are supported by the resgen tool for the current target framework. The default is false.
SupportsExternalFileReferences | Indicates whether external file references are supported by the resgen tool for the current target framework. The default is false.
TargetExt | The target type. The default is resources.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
ToDirectory | The directory to which outputs will be stored.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
UseSourcePath | Use each source file's directory as the current directory for resolving relative file paths. The default is false. Only supported when targeting .NET 2.0 (or higher).
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


Assemblies Property

NAnt SDK Documentation - v0.91

ResGenTask.Assemblies Property

Reference metadata from the specified assembly files.

[Visual Basic]
<BuildElement(Name:="assemblies", Required:=False, ProcessXml:=True)>
Public Property Assemblies As AssemblyFileSet
[C#]
[BuildElement(Name="assemblies", Required=False, ProcessXml=True)]
public NAnt.DotNet.Types.AssemblyFileSet Assemblies {get; set;}

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


BaseDirectory Property

NAnt SDK Documentation - v0.91

ResGenTask.BaseDirectory Property

Gets the working directory for the application.

[Visual Basic]
Overrides Public Property BaseDirectory As DirectoryInfo
[C#]
public override System.IO.DirectoryInfo BaseDirectory {get; set;}

Property Value

The working directory for the application.

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


InputFile Property

NAnt SDK Documentation - v0.91

ResGenTask.InputFile Property

Input file to process.

[Visual Basic]
<TaskAttribute(Name:="input", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property InputFile As FileInfo
[C#]
[TaskAttribute(Name="input", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo InputFile {get; set;}

Property Value

The full path to the input file.

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


OutputFile Property

NAnt SDK Documentation - v0.91

ResGenTask.OutputFile Property

The resource file to output.

[Visual Basic]
<TaskAttribute(Name:="output", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property OutputFile As FileInfo
[C#]
[TaskAttribute(Name="output", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo OutputFile {get; set;}

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

ResGenTask.ProgramArguments Property

Gets the command line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

Property Value

The command line arguments for the external program.

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


ProgramFileName Property

NAnt SDK Documentation - v0.91

ResGenTask.ProgramFileName Property

Gets the filename of the external program to start.

[Visual Basic]
Overrides Public ReadOnly Property ProgramFileName As String
[C#]
public override string ProgramFileName {get;}

Property Value

The filename of the external program.

Remarks

Override in derived classes to explicitly set the location of the external tool.

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


QualifiedResources Property

NAnt SDK Documentation - v0.91

ResGenTask.QualifiedResources Property

For internal use only !

[Visual Basic]
Public ReadOnly Property QualifiedResources As ArrayList
[C#]
public System.Collections.ArrayList QualifiedResources {get;}

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


Resources Property

NAnt SDK Documentation - v0.91

ResGenTask.Resources Property

Takes a list of .resx or .txt files to convert to .resources files.

[Visual Basic]
<BuildElement(Name:="resources", Required:=False, ProcessXml:=True)>
Public Property Resources As ResourceFileSet
[C#]
[BuildElement(Name="resources", Required=False, ProcessXml=True)]
public NAnt.DotNet.Types.ResourceFileSet Resources {get; set;}

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


SupportsAssemblyReferences Property

NAnt SDK Documentation - v0.91

ResGenTask.SupportsAssemblyReferences Property

Indicates whether assembly references are supported by the resgen tool for the current target framework. The default is false.

[Visual Basic]
<FrameworkConfigurable(Name:="supportsassemblyreferences", Required:=False, ExpandProperties:=True)>
Public Property SupportsAssemblyReferences As Boolean
[C#]
[FrameworkConfigurable(Name="supportsassemblyreferences", Required=False, ExpandProperties=True)]
public bool SupportsAssemblyReferences {get; set;}

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


SupportsExternalFileReferences Property

NAnt SDK Documentation - v0.91

ResGenTask.SupportsExternalFileReferences Property

Indicates whether external file references are supported by the resgen tool for the current target framework. The default is false.

[Visual Basic]
<FrameworkConfigurable(Name:="supportsexternalfilereferences", Required:=False, ExpandProperties:=True)>
Public Property SupportsExternalFileReferences As Boolean
[C#]
[FrameworkConfigurable(Name="supportsexternalfilereferences", Required=False, ExpandProperties=True)]
public bool SupportsExternalFileReferences {get; set;}

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


TargetExt Property

NAnt SDK Documentation - v0.91

ResGenTask.TargetExt Property

The target type. The default is resources.

[Visual Basic]
<TaskAttribute(Name:="target", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property TargetExt As String
[C#]
[TaskAttribute(Name="target", Required=False, ExpandProperties=True, ProcessXml=True)]
public string TargetExt {get; set;}

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


ToDirectory Property

NAnt SDK Documentation - v0.91

ResGenTask.ToDirectory Property

The directory to which outputs will be stored.

[Visual Basic]
<TaskAttribute(Name:="todir", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property ToDirectory As DirectoryInfo
[C#]
[TaskAttribute(Name="todir", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.DirectoryInfo ToDirectory {get; set;}

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


UseSourcePath Property

NAnt SDK Documentation - v0.91

ResGenTask.UseSourcePath Property

Use each source file's directory as the current directory for resolving relative file paths. The default is false. Only supported when targeting .NET 2.0 (or higher).

[Visual Basic]
<TaskAttribute(Name:="usesourcepath", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property UseSourcePath As Boolean
[C#]
[TaskAttribute(Name="usesourcepath", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool UseSourcePath {get; set;}

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


ResGenTask Methods

The methods of the ResGenTask class are listed below. For a complete list of ResGenTask class members, see the ResGenTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
RemoveOutputs | Cleans up generated files.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Converts a single file or group of files.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines whether the specified input file needs to be compiled.
PrepareProcess | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


ResGenTask.ExecuteTask Method

Converts a single file or group of files.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


ResGenTask.NeedsCompiling Method

Determines whether the specified input file needs to be compiled.

[Visual Basic]
Overridable Protected Function NeedsCompiling( _
ByVal inputFile As FileInfo, _
ByVal outputFile As FileInfo _
) As Boolean
[C#]
protected virtual bool NeedsCompiling(
FileInfo inputFile,
FileInfo outputFile
);

Parameters

inputFile
The input file.
outputFile
The output file.

Return Value

true if the input file need to be compiled; otherwise false.

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


ResGenTask.PrepareProcess Method

Updates the ProcessStartInfo of the specified Process.

[Visual Basic]
Overrides Protected Sub PrepareProcess( _
ByVal process As Process _
)
[C#]
protected override void PrepareProcess(
Process process
);

Parameters

process
The Process of which the ProcessStartInfo should be updated.

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


ResGenTask.RemoveOutputs Method

Cleans up generated files.

[Visual Basic]
Public Sub RemoveOutputs()
[C#]
public void RemoveOutputs();

See Also

ResGenTask Class | NAnt.DotNet.Tasks Namespace


ScriptTask Class

Executes the code contained within the task.

For a list of all members of this type, see ScriptTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.DotNet.Tasks.ScriptTask

[Visual Basic]
<TaskName(Name:="script")>
Public Class ScriptTask
Inherits Task
[C#]
[TaskName(Name="script")]
public class ScriptTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Code

The ScriptTask must contain a single code element, which in turn contains the script code.

This code can include extensions such as functions, or tasks. Once the script task has executed those extensions will be available for use in the buildfile.

If no extensions have been defined, a static entry point named ScriptMain - which must have a single Project argument - is required.

Namespaces

The following namespaces are imported by default:

  • System
  • System.Collections
  • System.IO
  • System.Text
  • NAnt.Core
  • NAnt.Core.Attributes
Assembly References

The assembly references that are specified will be used to compile the script, and will be loaded into the NAnt appdomain.

By default, only the NAnt.Core and mscorlib assemblies are referenced.

Example

Run C# code that writes a message to the build log.

      <script language="C#">
          <code>
            <![CDATA[
              public static void ScriptMain(Project project) {
                  project.Log(Level.Info, "Hello World from a script task using C#");
              }
            ]]>
          </code>
      </script>

Define a custom function and call it using C#.

      <script language="C#" prefix="test" >
          <code>
            <![CDATA[
              [Function("test-func")]
              public static string Testfunc(  ) {
                  return "some result !!!!!!!!";
              }
            ]]>
          </code>
      </script>
      <echo message='${test::test-func()}'/>

Use a custom namespace in C# to create a database

      <script language="C#" >
          <references>
              <include name="System.Data.dll" />
          </references>
          <imports>
              <import namespace="System.Data.SqlClient" />
          </imports>
          <code>
            <![CDATA[
              public static void ScriptMain(Project project) {
                  string dbUserName = "nant";
                  string dbPassword = "nant";
                  string dbServer = "(local)";
                  string dbDatabaseName = "NAntSample";
                  string connectionString = String.Format("Server={0};uid={1};pwd={2};", dbServer, dbUserName, dbPassword);

                  SqlConnection connection = new SqlConnection(connectionString);
                  string createDbQuery = "CREATE DATABASE " + dbDatabaseName;
                  SqlCommand createDatabaseCommand = new SqlCommand(createDbQuery);
                  createDatabaseCommand.Connection = connection;

                  connection.Open();

                  try {
                      createDatabaseCommand.ExecuteNonQuery();
                      project.Log(Level.Info, "Database added successfully: " + dbDatabaseName);
                  } catch (Exception e) {
                      project.Log(Level.Error, e.ToString());
                  } finally {
                      connection.Close();
                  }
              }
            ]]>
          </code>
      </script>

Run Visual Basic.NET code that writes a message to the build log.

      <script language="VB">
          <code>
            <![CDATA[
              Public Shared Sub ScriptMain(project As Project)
                  project.Log(Level.Info, "Hello World from a script task using Visual Basic.NET")
              End Sub
            ]]>
          </code>
      </script>

Define a custom task and call it using C#.

      <script language="C#" prefix="test" >
          <code>
            <![CDATA[
              [TaskName("usertask")]
              public class TestTask : Task {
                #region Private Instance Fields
                            private string _message;
                            #endregion Private Instance Fields
                            #region Public Instance Properties
                            [TaskAttribute("message", Required=true)]
                public string FileName {
                    get { return _message; }
                    set { _message = value; }
                }
                            #endregion Public Instance Properties
                            #region Override implementation of Task
                            protected override void ExecuteTask() {
                    Log(Level.Info, _message.ToUpper());
                }
                #endregion Override implementation of Task
              }
            ]]>
          </code>
      </script>
      <usertask message='Hello from UserTask'/>

Define a custom function and call it using Boo.

      <script language="Boo.CodeDom.BooCodeProvider, Boo.CodeDom, Version=1.0.0.0, Culture=neutral, PublicKeyToken=32c39770e9a21a67"
          failonerror="true">
          <code>
            <![CDATA[

              [Function("test-func")]
              def MyFunc():
                  return "Hello from Boo !!!!!!"
            ]]>
          </code>
      </script>
      <echo message='${script::test-func()}'/>

Requirements

Namespace: NAnt.DotNet.Tasks

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

ScriptTask Members | NAnt.DotNet.Tasks Namespace


ScriptTask Members

ScriptTask overview

Public Instance Constructors

ScriptTask Constructor Initializes a new instance of the ScriptTask class.

Public Instance Properties

Code | The code to execute.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
Imports | The namespaces to import.
Language | The language of the script block. Possible values are "VB", "vb", "VISUALBASIC", "C#", "c#", "CSHARP". "JS", "js", "JSCRIPT" "VJS", "vjs", "JSHARP" or a fully-qualified name for a class implementing CodeDomProvider.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
MainClass | The name of the main class containing the static ScriptMain entry point.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Prefix | The namespace prefix for any custom functions defined in the script. If ommitted the prefix will default to 'script'
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
References | Any required references.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Executes the script block.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ScriptTask Class | NAnt.DotNet.Tasks Namespace


ScriptTask Constructor

Initializes a new instance of the ScriptTask class.

[Visual Basic]
Public Sub New()
[C#]
public ScriptTask();

See Also

ScriptTask Class | NAnt.DotNet.Tasks Namespace


ScriptTask Properties

The properties of the ScriptTask class are listed below. For a complete list of ScriptTask class members, see the ScriptTask Members topic.

Public Instance Properties

Code | The code to execute.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
Imports | The namespaces to import.
Language | The language of the script block. Possible values are "VB", "vb", "VISUALBASIC", "C#", "c#", "CSHARP". "JS", "js", "JSCRIPT" "VJS", "vjs", "JSHARP" or a fully-qualified name for a class implementing CodeDomProvider.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
MainClass | The name of the main class containing the static ScriptMain entry point.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Prefix | The namespace prefix for any custom functions defined in the script. If ommitted the prefix will default to 'script'
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
References | Any required references.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

ScriptTask Class | NAnt.DotNet.Tasks Namespace


Code Property

NAnt SDK Documentation - v0.91

ScriptTask.Code Property

The code to execute.

[Visual Basic]
<BuildElement(Name:="code", Required:=True, ProcessXml:=True)>
Public Property Code As RawXml
[C#]
[BuildElement(Name="code", Required=True, ProcessXml=True)]
public NAnt.Core.Types.RawXml Code {get; set;}

See Also

ScriptTask Class | NAnt.DotNet.Tasks Namespace


Imports Property

NAnt SDK Documentation - v0.91

ScriptTask.Imports Property

The namespaces to import.

[Visual Basic]
<BuildElement(Name:="imports", Required:=False, ProcessXml:=True)>
Public Property Imports As NamespaceImportCollection
[C#]
[BuildElement(Name="imports", Required=False, ProcessXml=True)]
public NAnt.DotNet.Types.NamespaceImportCollection Imports {get; set;}

See Also

ScriptTask Class | NAnt.DotNet.Tasks Namespace


Language Property

NAnt SDK Documentation - v0.91

ScriptTask.Language Property

The language of the script block. Possible values are "VB", "vb", "VISUALBASIC", "C#", "c#", "CSHARP". "JS", "js", "JSCRIPT" "VJS", "vjs", "JSHARP" or a fully-qualified name for a class implementing CodeDomProvider.

[Visual Basic]
<TaskAttribute(Name:="language", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property Language As String
[C#]
[TaskAttribute(Name="language", Required=True, ExpandProperties=True, ProcessXml=True)]
public string Language {get; set;}

See Also

ScriptTask Class | NAnt.DotNet.Tasks Namespace


MainClass Property

NAnt SDK Documentation - v0.91

ScriptTask.MainClass Property

The name of the main class containing the static ScriptMain entry point.

[Visual Basic]
<TaskAttribute(Name:="mainclass", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property MainClass As String
[C#]
[TaskAttribute(Name="mainclass", Required=False, ExpandProperties=True, ProcessXml=True)]
public string MainClass {get; set;}

See Also

ScriptTask Class | NAnt.DotNet.Tasks Namespace


Prefix Property

NAnt SDK Documentation - v0.91

ScriptTask.Prefix Property

The namespace prefix for any custom functions defined in the script. If ommitted the prefix will default to 'script'

[Visual Basic]
<TaskAttribute(Name:="prefix", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Prefix As String
[C#]
[TaskAttribute(Name="prefix", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Prefix {get; set;}

See Also

ScriptTask Class | NAnt.DotNet.Tasks Namespace


References Property

NAnt SDK Documentation - v0.91

ScriptTask.References Property

Any required references.

[Visual Basic]
<BuildElement(Name:="references", Required:=False, ProcessXml:=True)>
Public Property References As AssemblyFileSet
[C#]
[BuildElement(Name="references", Required=False, ProcessXml=True)]
public NAnt.DotNet.Types.AssemblyFileSet References {get; set;}

See Also

ScriptTask Class | NAnt.DotNet.Tasks Namespace


ScriptTask Methods

The methods of the ScriptTask class are listed below. For a complete list of ScriptTask class members, see the ScriptTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Executes the script block.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ScriptTask Class | NAnt.DotNet.Tasks Namespace


ScriptTask.ExecuteTask Method

Executes the script block.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

ScriptTask Class | NAnt.DotNet.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

ScriptTask.Initialize Method

Initializes the task.

Overload List

Initializes the task.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

ScriptTask Class | NAnt.DotNet.Tasks Namespace


ScriptTask.Initialize Method ()

Initializes the task.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

ScriptTask Class | NAnt.DotNet.Tasks Namespace | ScriptTask.Initialize Overload List


VbcTask Class

Compiles Visual Basic.NET programs.

For a list of all members of this type, see VbcTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.DotNet.Tasks.CompilerBase
NAnt.DotNet.Tasks.VbcTask

[Visual Basic]
<ProgramLocation(LocationType:=LocationType.FrameworkDir), _ TaskName(Name:="vbc")>
Public Class VbcTask
Inherits CompilerBase
[C#]
[ProgramLocation(LocationType=LocationType.FrameworkDir)]
[TaskName(Name="vbc")]
public class VbcTask : CompilerBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Note In order to have VbcTask generate manifest resource names that match those generated by Microsoft Visual Studio.NET, the value of the Prefix attribute of the <ResourcesList> element should match the "Root namespace" of the VB.NET project, and the value of the DynamicPrefix attribute should be set to "false".

Example

Example build file using this task.

<project name="Hello World" default="build" basedir=".">
  <property name="basename" value="HelloWorld" />
  <target name="clean">
     <delete file="${basename}-vb.exe" failonerror="false" />
     <delete file="${basename}-vb.pdb" failonerror="false" />
  </target>
  <target name="build">
     <vbc target="exe" output="${basename}-vb.exe" rootnamespace="${basename}">
        <imports>
            <import namespace="System" />
            <import namespace="System.Data" />
        </imports>
        <sources>
           <include name="${basename}.vb" />
        </sources>
        <resources prefix="${basename}" dynamicprefix="true">
            <include name="**/*.resx" />
        </resources>
        <references>
            <include name="System.dll" />
            <include name="System.Data.dll" />
        </references>
     </vbc>
  </target>
  <target name="rebuild" depends="clean, build" />
</project>

Requirements

Namespace: NAnt.DotNet.Tasks

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

VbcTask Members | NAnt.DotNet.Tasks Namespace


VbcTask Members

VbcTask overview

Public Instance Constructors

VbcTask Constructor Initializes a new instance of the VbcTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseAddress | The preferred base address at which to load a DLL. The default base address for a DLL is set by the .NET Framework common language runtime.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Debug | No longer expose this to build authors. Use DebugOutput instead.
DebugOutput | Specifies the type of debugging information generated by the compiler. The default is None.
Define (inherited from CompilerBase) | Define conditional compilation symbol(s).
DelaySign (inherited from CompilerBase) | Specifies whether to delay sign the assembly using only the public portion of the strong name key. The default is NotSet.
DocFile | The name of the XML documentation file to generate. Only supported when targeting .NET 2.0 (or higher).
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
Extension | Gets the file extension required by the current compiler.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForceRebuild (inherited from CompilerBase) | Instructs NAnt to recompile the output file regardless of the file timestamps.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
Imports | The namespaces to import.
ImportsString | Obsolete. Specifies whether the /imports option gets passed to the compiler.
KeyContainer (inherited from CompilerBase) | Specifies the key pair container used to strongname the assembly.
KeyFile (inherited from CompilerBase) | Specifies a strong name key file.
Lib (inherited from CompilerBase) | Obsolete. Additional directories to search in for assembly references.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
MainType (inherited from CompilerBase) | Specifies which type contains the Main method that you want to use as the entry point into the program.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Modules (inherited from CompilerBase) | Link the specified modules into this assembly.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NoStdLib | Instructs the compiler not to reference standard libraries (system.dll and VBC.RSP). The default is false. Only supported when targeting .NET 2.0 (or higher).
NoWarn (inherited from CompilerBase) | Obsolete. Specifies a comma-separated list of warnings that should be suppressed by the compiler.
OptionCompare | Specifies whether /optioncompare option gets passed to the compiler.
OptionExplicit | Specifies whether the /optionexplicit option gets passed to the compiler. The default is false.
OptionOptimize | Specifies whether the /optimize option gets passed to the compiler. The default is false.
OptionStrict | Specifies whether the /optionstrict option gets passed to the compiler. The default is false.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile (inherited from CompilerBase) | The output file created by the compiler.
OutputTarget (inherited from CompilerBase) | Output type. Possible values are exe, winexe, library or module.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Packages (inherited from CompilerBase) | Specifies list of packages to reference.
Parent (inherited from Element) | Gets or sets the parent of the element.
Platform | Specifies which platform version of common language runtime (CLR) can run the output file.
ProgramArguments (inherited from CompilerBase) | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
References (inherited from CompilerBase) | Reference metadata from the specified assembly files.
RemoveIntChecks | Specifies whether the /removeintchecks option gets passed to the compiler. The default is false.
ResourcesList (inherited from CompilerBase) | Resources to embed.
RootNamespace | Specifies whether the /rootnamespace option gets passed to the compiler.
Sources (inherited from CompilerBase) | The set of source files for compilation.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
SupportsDelaySign (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "delaysign" option. The default is false.
SupportsDocGeneration | Specifies whether the compiler for the active target framework supports generation of XML Documentation file. The default is false.
SupportsKeyContainer (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "keycontainer" option. The default is false.
SupportsKeyFile (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "keyfile" option. The default is false.
SupportsNoStdLib | Specifies whether the compiler for the active target framework supports NOT referencing standard libraries (system.dll and VBC.RSP). The default is false.
SupportsNoWarnList (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports a command line option that allows a list of warnings to be suppressed. The default is false.
SupportsPackageReferences (inherited from CompilerBase) | Indicates whether package references are supported by compiler for a given target framework. The default is false.
SupportsPlatform | Specifies whether the compiler for the active target framework supports limiting the platform on which the compiled code can run. The default is false.
SupportsWarnAsErrorList (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "warnaserror" option that takes a list of warnings. The default is false.
SuppressWarnings (inherited from CompilerBase) | Specifies a list of warnings that you want the compiler to suppress.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
WarnAsError (inherited from CompilerBase) | Instructs the compiler to treat all warnings as errors. The default is false.
WarningAsError (inherited from CompilerBase) | Controls which warnings should be reported as errors.
Win32Icon (inherited from CompilerBase) | Icon to associate with the application.
Win32Res (inherited from CompilerBase) | Specifies a Win32 resource file (.res).

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetManifestResourceName (inherited from CompilerBase) | Overloaded. Determines the manifest resource name of the given resource file.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
PerformSearchForResourceLinkage (inherited from CompilerBase) | Extracts the associated namespace/classname linkage found in the given stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

ClassNameRegex | Gets the class name regular expression for the language of the current compiler.
CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
NamespaceRegex | Gets the namespace regular expression for the language of the current compiler.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CompileResxResources (inherited from CompilerBase) | Compiles a set of resx files to a .resources files.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask (inherited from CompilerBase) | Compiles the sources and resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
GetResourceLinkage | Finds the correct namespace/classname for a resource file from the given dependent source file, and ensure the RootNamespace is prefixed.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
LinkResourceAssembly (inherited from CompilerBase) | Link a list of files into a resource assembly.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines whether compilation is needed.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
WriteConditionalCompilationConstants | Writes conditional compilation constants to the specified TextWriter.
WriteModuleReferences (inherited from CompilerBase) | Writes module references to the specified TextWriter.
WriteNoWarnList (inherited from CompilerBase) | Writes list of warnings to suppress to the specified TextWriter.
WriteOption (inherited from CompilerBase) | Overloaded. Writes an option using the default output format.
WriteOptions | Writes the compiler options to the specified TextWriter.
WritePackageReferences (inherited from CompilerBase) | Writes package references to the specified TextWriter.
WriteWarningsAsError (inherited from CompilerBase) | Writes list of warnings to (not) treat as errors to the specified TextWriter.

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


VbcTask Constructor

Initializes a new instance of the VbcTask class.

[Visual Basic]
Public Sub New()
[C#]
public VbcTask();

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


VbcTask Properties

The properties of the VbcTask class are listed below. For a complete list of VbcTask class members, see the VbcTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseAddress | The preferred base address at which to load a DLL. The default base address for a DLL is set by the .NET Framework common language runtime.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Debug | No longer expose this to build authors. Use DebugOutput instead.
DebugOutput | Specifies the type of debugging information generated by the compiler. The default is None.
Define (inherited from CompilerBase) | Define conditional compilation symbol(s).
DelaySign (inherited from CompilerBase) | Specifies whether to delay sign the assembly using only the public portion of the strong name key. The default is NotSet.
DocFile | The name of the XML documentation file to generate. Only supported when targeting .NET 2.0 (or higher).
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
Extension | Gets the file extension required by the current compiler.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForceRebuild (inherited from CompilerBase) | Instructs NAnt to recompile the output file regardless of the file timestamps.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
Imports | The namespaces to import.
ImportsString | Obsolete. Specifies whether the /imports option gets passed to the compiler.
KeyContainer (inherited from CompilerBase) | Specifies the key pair container used to strongname the assembly.
KeyFile (inherited from CompilerBase) | Specifies a strong name key file.
Lib (inherited from CompilerBase) | Obsolete. Additional directories to search in for assembly references.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
MainType (inherited from CompilerBase) | Specifies which type contains the Main method that you want to use as the entry point into the program.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Modules (inherited from CompilerBase) | Link the specified modules into this assembly.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NoStdLib | Instructs the compiler not to reference standard libraries (system.dll and VBC.RSP). The default is false. Only supported when targeting .NET 2.0 (or higher).
NoWarn (inherited from CompilerBase) | Obsolete. Specifies a comma-separated list of warnings that should be suppressed by the compiler.
OptionCompare | Specifies whether /optioncompare option gets passed to the compiler.
OptionExplicit | Specifies whether the /optionexplicit option gets passed to the compiler. The default is false.
OptionOptimize | Specifies whether the /optimize option gets passed to the compiler. The default is false.
OptionStrict | Specifies whether the /optionstrict option gets passed to the compiler. The default is false.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile (inherited from CompilerBase) | The output file created by the compiler.
OutputTarget (inherited from CompilerBase) | Output type. Possible values are exe, winexe, library or module.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Packages (inherited from CompilerBase) | Specifies list of packages to reference.
Parent (inherited from Element) | Gets or sets the parent of the element.
Platform | Specifies which platform version of common language runtime (CLR) can run the output file.
ProgramArguments (inherited from CompilerBase) | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
References (inherited from CompilerBase) | Reference metadata from the specified assembly files.
RemoveIntChecks | Specifies whether the /removeintchecks option gets passed to the compiler. The default is false.
ResourcesList (inherited from CompilerBase) | Resources to embed.
RootNamespace | Specifies whether the /rootnamespace option gets passed to the compiler.
Sources (inherited from CompilerBase) | The set of source files for compilation.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
SupportsDelaySign (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "delaysign" option. The default is false.
SupportsDocGeneration | Specifies whether the compiler for the active target framework supports generation of XML Documentation file. The default is false.
SupportsKeyContainer (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "keycontainer" option. The default is false.
SupportsKeyFile (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "keyfile" option. The default is false.
SupportsNoStdLib | Specifies whether the compiler for the active target framework supports NOT referencing standard libraries (system.dll and VBC.RSP). The default is false.
SupportsNoWarnList (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports a command line option that allows a list of warnings to be suppressed. The default is false.
SupportsPackageReferences (inherited from CompilerBase) | Indicates whether package references are supported by compiler for a given target framework. The default is false.
SupportsPlatform | Specifies whether the compiler for the active target framework supports limiting the platform on which the compiled code can run. The default is false.
SupportsWarnAsErrorList (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "warnaserror" option that takes a list of warnings. The default is false.
SuppressWarnings (inherited from CompilerBase) | Specifies a list of warnings that you want the compiler to suppress.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
WarnAsError (inherited from CompilerBase) | Instructs the compiler to treat all warnings as errors. The default is false.
WarningAsError (inherited from CompilerBase) | Controls which warnings should be reported as errors.
Win32Icon (inherited from CompilerBase) | Icon to associate with the application.
Win32Res (inherited from CompilerBase) | Specifies a Win32 resource file (.res).

Protected Instance Properties

ClassNameRegex | Gets the class name regular expression for the language of the current compiler.
CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
NamespaceRegex | Gets the namespace regular expression for the language of the current compiler.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


BaseAddress Property

NAnt SDK Documentation - v0.91

VbcTask.BaseAddress Property

The preferred base address at which to load a DLL. The default base address for a DLL is set by the .NET Framework common language runtime.

[Visual Basic]
<TaskAttribute(Name:="baseaddress", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property BaseAddress As String
[C#]
[TaskAttribute(Name="baseaddress", Required=False, ExpandProperties=True, ProcessXml=True)]
public string BaseAddress {get; set;}

Property Value

The preferred base address at which to load a DLL.

Remarks

This address must be specified as a hexadecimal number.

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


ClassNameRegex Property

NAnt SDK Documentation - v0.91

VbcTask.ClassNameRegex Property

Gets the class name regular expression for the language of the current compiler.

[Visual Basic]
Overrides Protected ReadOnly Property ClassNameRegex As Regex
[C#]
protected override System.Text.RegularExpressions.Regex ClassNameRegex {get;}

Property Value

Class name regular expression for the language of the current compiler.

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


Debug Property

NAnt SDK Documentation - v0.91

VbcTask.Debug Property

No longer expose this to build authors. Use DebugOutput instead.

[Visual Basic]
Overrides Public Property Debug As Boolean
[C#]
public override bool Debug {get; set;}

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


DebugOutput Property

NAnt SDK Documentation - v0.91

VbcTask.DebugOutput Property

Specifies the type of debugging information generated by the compiler. The default is None.

[Visual Basic]
<TaskAttribute(Name:="debug", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property DebugOutput As DebugOutput
[C#]
[TaskAttribute(Name="debug", Required=False, ExpandProperties=True, ProcessXml=True)]
public NAnt.DotNet.Types.DebugOutput DebugOutput {get; set;}

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


DocFile Property

NAnt SDK Documentation - v0.91

VbcTask.DocFile Property

The name of the XML documentation file to generate. Only supported when targeting .NET 2.0 (or higher).

[Visual Basic]
<TaskAttribute(Name:="doc", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property DocFile As FileInfo
[C#]
[TaskAttribute(Name="doc", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo DocFile {get; set;}

Remarks

Corresponds with the /doc: flag.

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


Extension Property

NAnt SDK Documentation - v0.91

VbcTask.Extension Property

Gets the file extension required by the current compiler.

[Visual Basic]
Overrides Public ReadOnly Property Extension As String
[C#]
public override string Extension {get;}

Property Value

For the VB.NET compiler, the file extension is always vb.

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


Imports Property

NAnt SDK Documentation - v0.91

VbcTask.Imports Property

The namespaces to import.

[Visual Basic]
<BuildElement(Name:="imports", Required:=False, ProcessXml:=True)>
Public Property Imports As NamespaceImportCollection
[C#]
[BuildElement(Name="imports", Required=False, ProcessXml=True)]
public NAnt.DotNet.Types.NamespaceImportCollection Imports {get; set;}

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


ImportsString Property

NAnt SDK Documentation - v0.91

VbcTask.ImportsString Property

NOTE: This property is now obsolete.

Use the <imports> element instead.

Specifies whether the /imports option gets passed to the compiler.

[Visual Basic]
<Obsolete(Message:="Use the <imports> element instead.", IsError:=False), _ TaskAttribute(Name:="imports", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public WriteOnly Property ImportsString As String
[C#]
[Obsolete(Message="Use the <imports> element instead.", IsError=False)]
[TaskAttribute(Name="imports", Required=False, ExpandProperties=True, ProcessXml=True)]
public string ImportsString {set;}

Property Value

The value of this attribute is a string that contains one or more namespaces separated by commas.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

Example

Example of an imports attribute

imports="Microsoft.VisualBasic, System, System.Collections, System.Data, System.Diagnostics"

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


NamespaceRegex Property

NAnt SDK Documentation - v0.91

VbcTask.NamespaceRegex Property

Gets the namespace regular expression for the language of the current compiler.

[Visual Basic]
Overrides Protected ReadOnly Property NamespaceRegex As Regex
[C#]
protected override System.Text.RegularExpressions.Regex NamespaceRegex {get;}

Property Value

Namespace regular expression for the language of the current compiler.

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


NoStdLib Property

NAnt SDK Documentation - v0.91

VbcTask.NoStdLib Property

Instructs the compiler not to reference standard libraries (system.dll and VBC.RSP). The default is false. Only supported when targeting .NET 2.0 (or higher).

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="nostdlib", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ FrameworkConfigurable(Name:="nostdlib", Required:=False, ExpandProperties:=True)>
Public Property NoStdLib As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="nostdlib", Required=False, ExpandProperties=True, ProcessXml=True)]
[FrameworkConfigurable(Name="nostdlib", Required=False, ExpandProperties=True)]
public bool NoStdLib {get; set;}

Remarks

Corresponds with the /nostdlib flag.

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


OptionCompare Property

NAnt SDK Documentation - v0.91

VbcTask.OptionCompare Property

Specifies whether /optioncompare option gets passed to the compiler.

[Visual Basic]
<TaskAttribute(Name:="optioncompare", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property OptionCompare As String
[C#]
[TaskAttribute(Name="optioncompare", Required=False, ExpandProperties=True, ProcessXml=True)]
public string OptionCompare {get; set;}

Property Value

text, binary, or an empty string. If the value is false or an empty string, the option will not be passed to the compiler.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


OptionExplicit Property

NAnt SDK Documentation - v0.91

VbcTask.OptionExplicit Property

Specifies whether the /optionexplicit option gets passed to the compiler. The default is false.

[Visual Basic]
<TaskAttribute(Name:="optionexplicit", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property OptionExplicit As Boolean
[C#]
[TaskAttribute(Name="optionexplicit", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool OptionExplicit {get; set;}

Property Value

true if the option should be passed to the compiler; otherwise, false.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


OptionOptimize Property

NAnt SDK Documentation - v0.91

VbcTask.OptionOptimize Property

Specifies whether the /optimize option gets passed to the compiler. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="optionoptimize", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property OptionOptimize As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="optionoptimize", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool OptionOptimize {get; set;}

Property Value

true if the option should be passed to the compiler; otherwise, false.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


OptionStrict Property

NAnt SDK Documentation - v0.91

VbcTask.OptionStrict Property

Specifies whether the /optionstrict option gets passed to the compiler. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="optionstrict", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property OptionStrict As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="optionstrict", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool OptionStrict {get; set;}

Property Value

true if the option should be passed to the compiler; otherwise, false.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


Platform Property

NAnt SDK Documentation - v0.91

VbcTask.Platform Property

Specifies which platform version of common language runtime (CLR) can run the output file.

[Visual Basic]
<TaskAttribute(Name:="platform", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Platform As String
[C#]
[TaskAttribute(Name="platform", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Platform {get; set;}

Property Value

The platform version of common language runtime (CLR) that can run the output file.

Remarks

Corresponds with the /platform flag.

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


RemoveIntChecks Property

NAnt SDK Documentation - v0.91

VbcTask.RemoveIntChecks Property

Specifies whether the /removeintchecks option gets passed to the compiler. The default is false.

[Visual Basic]
<TaskAttribute(Name:="removeintchecks", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property RemoveIntChecks As Boolean
[C#]
[TaskAttribute(Name="removeintchecks", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool RemoveIntChecks {get; set;}

Property Value

true if the option should be passed to the compiler; otherwise, false.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


RootNamespace Property

NAnt SDK Documentation - v0.91

VbcTask.RootNamespace Property

Specifies whether the /rootnamespace option gets passed to the compiler.

[Visual Basic]
<TaskAttribute(Name:="rootnamespace", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property RootNamespace As String
[C#]
[TaskAttribute(Name="rootnamespace", Required=False, ExpandProperties=True, ProcessXml=True)]
public string RootNamespace {get; set;}

Property Value

The value of this attribute is a string that contains the root namespace of the project.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


SupportsDocGeneration Property

NAnt SDK Documentation - v0.91

VbcTask.SupportsDocGeneration Property

Specifies whether the compiler for the active target framework supports generation of XML Documentation file. The default is false.

[Visual Basic]
<FrameworkConfigurable(Name:="supportsdocgeneration", Required:=False, ExpandProperties:=True)>
Public Property SupportsDocGeneration As Boolean
[C#]
[FrameworkConfigurable(Name="supportsdocgeneration", Required=False, ExpandProperties=True)]
public bool SupportsDocGeneration {get; set;}

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


SupportsNoStdLib Property

NAnt SDK Documentation - v0.91

VbcTask.SupportsNoStdLib Property

Specifies whether the compiler for the active target framework supports NOT referencing standard libraries (system.dll and VBC.RSP). The default is false.

[Visual Basic]
<FrameworkConfigurable(Name:="supportsnostdlib", Required:=False, ExpandProperties:=True)>
Public Property SupportsNoStdLib As Boolean
[C#]
[FrameworkConfigurable(Name="supportsnostdlib", Required=False, ExpandProperties=True)]
public bool SupportsNoStdLib {get; set;}

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


SupportsPlatform Property

NAnt SDK Documentation - v0.91

VbcTask.SupportsPlatform Property

Specifies whether the compiler for the active target framework supports limiting the platform on which the compiled code can run. The default is false.

[Visual Basic]
<FrameworkConfigurable(Name:="supportsplatform", Required:=False, ExpandProperties:=True)>
Public Property SupportsPlatform As Boolean
[C#]
[FrameworkConfigurable(Name="supportsplatform", Required=False, ExpandProperties=True)]
public bool SupportsPlatform {get; set;}

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


VbcTask Methods

The methods of the VbcTask class are listed below. For a complete list of VbcTask class members, see the VbcTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetManifestResourceName (inherited from CompilerBase) | Overloaded. Determines the manifest resource name of the given resource file.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
PerformSearchForResourceLinkage (inherited from CompilerBase) | Extracts the associated namespace/classname linkage found in the given stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CompileResxResources (inherited from CompilerBase) | Compiles a set of resx files to a .resources files.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask (inherited from CompilerBase) | Compiles the sources and resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
GetResourceLinkage | Finds the correct namespace/classname for a resource file from the given dependent source file, and ensure the RootNamespace is prefixed.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
LinkResourceAssembly (inherited from CompilerBase) | Link a list of files into a resource assembly.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines whether compilation is needed.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
WriteConditionalCompilationConstants | Writes conditional compilation constants to the specified TextWriter.
WriteModuleReferences (inherited from CompilerBase) | Writes module references to the specified TextWriter.
WriteNoWarnList (inherited from CompilerBase) | Writes list of warnings to suppress to the specified TextWriter.
WriteOption (inherited from CompilerBase) | Overloaded. Writes an option using the default output format.
WriteOptions | Writes the compiler options to the specified TextWriter.
WritePackageReferences (inherited from CompilerBase) | Writes package references to the specified TextWriter.
WriteWarningsAsError (inherited from CompilerBase) | Writes list of warnings to (not) treat as errors to the specified TextWriter.

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


VbcTask.GetResourceLinkage Method

Finds the correct namespace/classname for a resource file from the given dependent source file, and ensure the RootNamespace is prefixed.

[Visual Basic]
Overrides Protected Function GetResourceLinkage( _
ByVal dependentFile As String, _
ByVal resourceCulture As CultureInfo _
) As ResourceLinkage
[C#]
protected override ResourceLinkage GetResourceLinkage(
string dependentFile,
CultureInfo resourceCulture
);

Parameters

dependentFile
The file from which the resource linkage of the resource file should be determined.
resourceCulture
The culture of the resource file for which the resource linkage should be determined.

Return Value

The namespace/classname of the source file matching the resource or a null reference (Nothing in Visual Basic) if the dependent source file does not exist.

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


VbcTask.NeedsCompiling Method

Determines whether compilation is needed.

[Visual Basic]
Overrides Protected Function NeedsCompiling() As Boolean
[C#]
protected override bool NeedsCompiling();

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


VbcTask.WriteConditionalCompilationConstants Method

Writes conditional compilation constants to the specified TextWriter.

[Visual Basic]
Overrides Protected Sub WriteConditionalCompilationConstants( _
ByVal writer As TextWriter _
)
[C#]
protected override void WriteConditionalCompilationConstants(
TextWriter writer
);

Parameters

writer
The TextWriter to which the conditional compilation constants should be written.

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


VbcTask.WriteOptions Method

Writes the compiler options to the specified TextWriter.

[Visual Basic]
Overrides Protected Sub WriteOptions( _
ByVal writer As TextWriter _
)
[C#]
protected override void WriteOptions(
TextWriter writer
);

Parameters

writer
TextWriter to which the compiler options should be written.

See Also

VbcTask Class | NAnt.DotNet.Tasks Namespace


VjcTask Class

Compiles Visual J# programs using vjc, Microsoft's J# compiler.

For a list of all members of this type, see VjcTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.DotNet.Tasks.CompilerBase
NAnt.DotNet.Tasks.VjcTask

[Visual Basic]
<ProgramLocation(LocationType:=LocationType.FrameworkDir), _ TaskName(Name:="vjc")>
Public Class VjcTask
Inherits CompilerBase
[C#]
[ProgramLocation(LocationType=LocationType.FrameworkDir)]
[TaskName(Name="vjc")]
public class VjcTask : CompilerBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Note In order to have VjcTask generate manifest resource names that match those generated by Microsoft Visual Studio.NET, the value of the Prefix attribute of the <ResourcesList> element should match the "Default Package" of the J#.NET project, and the value of the DynamicPrefix attribute should be set to "true".

Example

Compile a "HelloWorld" application, including embedded resources.

<vjc target="exe" output="helloworld.exe" debug="true">
    <sources>
        <include name="helloworld.jsl" />
    </sources>
    <resources prefix="HelloWorld" dynamicprefix="true">
        <include name="**/*.resx" />
    </resources>
    <references>
        <include name="System.dll" />
        <include name="System.Data.dll" />
        <include name="System.Drawing.dll" />
        <include name="System.Windows.Forms.dll" />
        <include name="System.Xml.dll" />
    </references>
</vjc>

Requirements

Namespace: NAnt.DotNet.Tasks

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

VjcTask Members | NAnt.DotNet.Tasks Namespace


VjcTask Members

VjcTask overview

Public Instance Constructors

VjcTask Constructor Initializes a new instance of the VjcTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseAddress | The preferred base address at which to load a DLL. The default base address for a DLL is set by the .NET Framework common language runtime.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
Codepage | Specifies the code page to use for all source code files in the compilation.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Debug | No longer expose this to build authors. Use DebugOutput instead.
DebugOutput | Specifies the type of debugging information generated by the compiler. The default is None.
Define (inherited from CompilerBase) | Define conditional compilation symbol(s).
DelaySign (inherited from CompilerBase) | Specifies whether to delay sign the assembly using only the public portion of the strong name key. The default is NotSet.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
Extension | Gets the file extension required by the current compiler.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForceRebuild (inherited from CompilerBase) | Instructs NAnt to recompile the output file regardless of the file timestamps.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
Jcpa | Associate Java-language/COM package names.
KeyContainer (inherited from CompilerBase) | Specifies the key pair container used to strongname the assembly.
KeyFile (inherited from CompilerBase) | Specifies a strong name key file.
Lib (inherited from CompilerBase) | Obsolete. Additional directories to search in for assembly references.
LibPath | Specifies the location of assemblies referenced by way of the /reference flag.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
MainType (inherited from CompilerBase) | Specifies which type contains the Main method that you want to use as the entry point into the program.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Modules | Link the specified modules into this assembly.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NoWarn (inherited from CompilerBase) | Obsolete. Specifies a comma-separated list of warnings that should be suppressed by the compiler.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile (inherited from CompilerBase) | The output file created by the compiler.
OutputTarget (inherited from CompilerBase) | Output type. Possible values are exe, winexe, library or module.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Packages | Reference packages
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments (inherited from CompilerBase) | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
References (inherited from CompilerBase) | Reference metadata from the specified assembly files.
ResourcesList (inherited from CompilerBase) | Resources to embed.
SecureScoping | Specifies whether package-scoped members are accessible outside of the assembly. In other words, package scope is treated as assembly scope when emitting metadata. The default is false.
Sources (inherited from CompilerBase) | The set of source files for compilation.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
SupportsDelaySign (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "delaysign" option. The default is false.
SupportsKeyContainer (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "keycontainer" option. The default is false.
SupportsKeyFile (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "keyfile" option. The default is false.
SupportsNoWarnList (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports a command line option that allows a list of warnings to be suppressed. The default is false.
SupportsPackageReferences | Override to avoid exposing the configuration setting for this task as Visual J# will never support package references.
SupportsWarnAsErrorList (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "warnaserror" option that takes a list of warnings. The default is false.
SuppressWarnings (inherited from CompilerBase) | Specifies a list of warnings that you want the compiler to suppress.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
WarnAsError (inherited from CompilerBase) | Instructs the compiler to treat all warnings as errors. The default is false.
WarningAsError | Controls which warnings should be reported as errors.
WarningLevel | Specifies the warning level for the compiler to display. Valid values are 0-4. The default is 4.
Win32Icon (inherited from CompilerBase) | Icon to associate with the application.
Win32Res (inherited from CompilerBase) | Specifies a Win32 resource file (.res).
X | Specifies whether to disable language extensions.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetManifestResourceName (inherited from CompilerBase) | Overloaded. Determines the manifest resource name of the given resource file.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
PerformSearchForResourceLinkage (inherited from CompilerBase) | Extracts the associated namespace/classname linkage found in the given stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

ClassNameRegex | Gets the class name regular expression for the language of the current compiler.
CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
NamespaceRegex | Gets the namespace regular expression for the language of the current compiler.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CompileResxResources (inherited from CompilerBase) | Compiles a set of resx files to a .resources files.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask (inherited from CompilerBase) | Compiles the sources and resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
GetResourceLinkage (inherited from CompilerBase) | Finds the correct namespace/classname for a resource file from the given dependent source file.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
LinkResourceAssembly (inherited from CompilerBase) | Link a list of files into a resource assembly.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling (inherited from CompilerBase) | Determines whether compilation is needed.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
WriteConditionalCompilationConstants (inherited from CompilerBase) | Writes conditional compilation constants to the specified TextWriter.
WriteModuleReferences | Writes module references to the specified TextWriter.
WriteNoWarnList (inherited from CompilerBase) | Writes list of warnings to suppress to the specified TextWriter.
WriteOption (inherited from CompilerBase) | Overloaded. Writes an option using the default output format.
WriteOptions | Writes the compiler options to the specified TextWriter.
WritePackageReferences (inherited from CompilerBase) | Writes package references to the specified TextWriter.
WriteWarningsAsError (inherited from CompilerBase) | Writes list of warnings to (not) treat as errors to the specified TextWriter.

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


VjcTask Constructor

Initializes a new instance of the VjcTask class.

[Visual Basic]
Public Sub New()
[C#]
public VjcTask();

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


VjcTask Properties

The properties of the VjcTask class are listed below. For a complete list of VjcTask class members, see the VjcTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseAddress | The preferred base address at which to load a DLL. The default base address for a DLL is set by the .NET Framework common language runtime.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
Codepage | Specifies the code page to use for all source code files in the compilation.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Debug | No longer expose this to build authors. Use DebugOutput instead.
DebugOutput | Specifies the type of debugging information generated by the compiler. The default is None.
Define (inherited from CompilerBase) | Define conditional compilation symbol(s).
DelaySign (inherited from CompilerBase) | Specifies whether to delay sign the assembly using only the public portion of the strong name key. The default is NotSet.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
Extension | Gets the file extension required by the current compiler.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForceRebuild (inherited from CompilerBase) | Instructs NAnt to recompile the output file regardless of the file timestamps.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
Jcpa | Associate Java-language/COM package names.
KeyContainer (inherited from CompilerBase) | Specifies the key pair container used to strongname the assembly.
KeyFile (inherited from CompilerBase) | Specifies a strong name key file.
Lib (inherited from CompilerBase) | Obsolete. Additional directories to search in for assembly references.
LibPath | Specifies the location of assemblies referenced by way of the /reference flag.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
MainType (inherited from CompilerBase) | Specifies which type contains the Main method that you want to use as the entry point into the program.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Modules | Link the specified modules into this assembly.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NoWarn (inherited from CompilerBase) | Obsolete. Specifies a comma-separated list of warnings that should be suppressed by the compiler.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile (inherited from CompilerBase) | The output file created by the compiler.
OutputTarget (inherited from CompilerBase) | Output type. Possible values are exe, winexe, library or module.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Packages | Reference packages
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments (inherited from CompilerBase) | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
References (inherited from CompilerBase) | Reference metadata from the specified assembly files.
ResourcesList (inherited from CompilerBase) | Resources to embed.
SecureScoping | Specifies whether package-scoped members are accessible outside of the assembly. In other words, package scope is treated as assembly scope when emitting metadata. The default is false.
Sources (inherited from CompilerBase) | The set of source files for compilation.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
SupportsDelaySign (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "delaysign" option. The default is false.
SupportsKeyContainer (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "keycontainer" option. The default is false.
SupportsKeyFile (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "keyfile" option. The default is false.
SupportsNoWarnList (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports a command line option that allows a list of warnings to be suppressed. The default is false.
SupportsPackageReferences | Override to avoid exposing the configuration setting for this task as Visual J# will never support package references.
SupportsWarnAsErrorList (inherited from CompilerBase) | Indicates whether the compiler for a given target framework supports the "warnaserror" option that takes a list of warnings. The default is false.
SuppressWarnings (inherited from CompilerBase) | Specifies a list of warnings that you want the compiler to suppress.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
WarnAsError (inherited from CompilerBase) | Instructs the compiler to treat all warnings as errors. The default is false.
WarningAsError | Controls which warnings should be reported as errors.
WarningLevel | Specifies the warning level for the compiler to display. Valid values are 0-4. The default is 4.
Win32Icon (inherited from CompilerBase) | Icon to associate with the application.
Win32Res (inherited from CompilerBase) | Specifies a Win32 resource file (.res).
X | Specifies whether to disable language extensions.

Protected Instance Properties

ClassNameRegex | Gets the class name regular expression for the language of the current compiler.
CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
NamespaceRegex | Gets the namespace regular expression for the language of the current compiler.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


BaseAddress Property

NAnt SDK Documentation - v0.91

VjcTask.BaseAddress Property

The preferred base address at which to load a DLL. The default base address for a DLL is set by the .NET Framework common language runtime.

[Visual Basic]
Public Property BaseAddress As String
[C#]
public string BaseAddress {get; set;}

Property Value

The preferred base address at which to load a DLL.

Remarks

This address can be specified as a decimal, hexadecimal, or octal number.

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


ClassNameRegex Property

NAnt SDK Documentation - v0.91

VjcTask.ClassNameRegex Property

Gets the class name regular expression for the language of the current compiler.

[Visual Basic]
Overrides Protected ReadOnly Property ClassNameRegex As Regex
[C#]
protected override System.Text.RegularExpressions.Regex ClassNameRegex {get;}

Property Value

Class name regular expression for the language of the current compiler.

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


Codepage Property

NAnt SDK Documentation - v0.91

VjcTask.Codepage Property

Specifies the code page to use for all source code files in the compilation.

[Visual Basic]
<TaskAttribute(Name:="codepage", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Codepage As String
[C#]
[TaskAttribute(Name="codepage", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Codepage {get; set;}

Remarks

Corresponds with the /codepage flag.

See the Visual J# Reference for details.

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


Debug Property

NAnt SDK Documentation - v0.91

VjcTask.Debug Property

No longer expose this to build authors. Use DebugOutput instead.

[Visual Basic]
Overrides Public Property Debug As Boolean
[C#]
public override bool Debug {get; set;}

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


DebugOutput Property

NAnt SDK Documentation - v0.91

VjcTask.DebugOutput Property

Specifies the type of debugging information generated by the compiler. The default is None.

[Visual Basic]
<TaskAttribute(Name:="debug", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property DebugOutput As DebugOutput
[C#]
[TaskAttribute(Name="debug", Required=False, ExpandProperties=True, ProcessXml=True)]
public NAnt.DotNet.Types.DebugOutput DebugOutput {get; set;}

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


Extension Property

NAnt SDK Documentation - v0.91

VjcTask.Extension Property

Gets the file extension required by the current compiler.

[Visual Basic]
Overrides Public ReadOnly Property Extension As String
[C#]
public override string Extension {get;}

Property Value

For the J# compiler, the file extension is always jsl.

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


Jcpa Property

NAnt SDK Documentation - v0.91

VjcTask.Jcpa Property

Associate Java-language/COM package names.

[Visual Basic]
<TaskAttribute(Name:="jcpa", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Jcpa As String
[C#]
[TaskAttribute(Name="jcpa", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Jcpa {get; set;}

Property Value

The value of this propery. must be package=namespace, @filename, or an empty string.

Remarks

Corresponds to the /jcpa:package=namespace and /jcpa:@filename flags.

See the Visual J# Reference for details.

Example

Map package 'x' to namespace 'y': <vjc jcpa='x=y'/>

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


LibPath Property

NAnt SDK Documentation - v0.91

VjcTask.LibPath Property

Specifies the location of assemblies referenced by way of the /reference flag.

[Visual Basic]
<TaskAttribute(Name:="libpath", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property LibPath As String
[C#]
[TaskAttribute(Name="libpath", Required=False, ExpandProperties=True, ProcessXml=True)]
public string LibPath {get; set;}

Remarks

Corresponds to the /libpath:dir[;dir2] flag.

See the Visual J# Reference for details.

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


Modules Property

NAnt SDK Documentation - v0.91

VjcTask.Modules Property

Link the specified modules into this assembly.

[Visual Basic]
Overrides Public Property Modules As AssemblyFileSet
[C#]
public override NAnt.DotNet.Types.AssemblyFileSet Modules {get; set;}

Remarks

Override to avoid exposing this to build authors, as the Visual J# compiler does not support linking modules.

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


NamespaceRegex Property

NAnt SDK Documentation - v0.91

VjcTask.NamespaceRegex Property

Gets the namespace regular expression for the language of the current compiler.

[Visual Basic]
Overrides Protected ReadOnly Property NamespaceRegex As Regex
[C#]
protected override System.Text.RegularExpressions.Regex NamespaceRegex {get;}

Property Value

Namespace regular expression for the language of the current compiler.

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


Packages Property

NAnt SDK Documentation - v0.91

VjcTask.Packages Property

Reference packages

[Visual Basic]
Overrides Public Property Packages As PackageCollection
[C#]
public override NAnt.DotNet.Types.PackageCollection Packages {get; set;}

Remarks

Override to avoid exposing this to build authors, as the Visual J# compiler does not support package references.

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


SecureScoping Property

NAnt SDK Documentation - v0.91

VjcTask.SecureScoping Property

Specifies whether package-scoped members are accessible outside of the assembly. In other words, package scope is treated as assembly scope when emitting metadata. The default is false.

[Visual Basic]
<TaskAttribute(Name:="securescoping", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property SecureScoping As Boolean
[C#]
[TaskAttribute(Name="securescoping", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool SecureScoping {get; set;}

Property Value

true if the option should be passed to the compiler; otherwise, false.

Remarks

Corresponds to the /securescoping flag.

See the Visual J# Reference for details.

Example

<vjc securescoping='true'/>

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


SupportsPackageReferences Property

NAnt SDK Documentation - v0.91

VjcTask.SupportsPackageReferences Property

Override to avoid exposing the configuration setting for this task as Visual J# will never support package references.

[Visual Basic]
Overrides Public Property SupportsPackageReferences As Boolean
[C#]
public override bool SupportsPackageReferences {get; set;}

Property Value

false, as the Visual J# compiler will never support package references.

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


WarningAsError Property

NAnt SDK Documentation - v0.91

VjcTask.WarningAsError Property

Controls which warnings should be reported as errors.

[Visual Basic]
Overrides Public ReadOnly Property WarningAsError As WarningAsError
[C#]
public override NAnt.DotNet.Types.WarningAsError WarningAsError {get;}

Remarks

Override to avoid exposing this to build authors, as the Visual J# compiler does not allow control over which warnings should be reported as errors.

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


WarningLevel Property

NAnt SDK Documentation - v0.91

VjcTask.WarningLevel Property

Specifies the warning level for the compiler to display. Valid values are 0-4. The default is 4.

[Visual Basic]
<TaskAttribute(Name:="warninglevel", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ Int32Validator(MinValue:=0, MaxValue:=4, Base:=10)>
Public Property WarningLevel As String
[C#]
[TaskAttribute(Name="warninglevel", Required=False, ExpandProperties=True, ProcessXml=True)]
[Int32Validator(MinValue=0, MaxValue=4, Base=10)]
public string WarningLevel {get; set;}

Property Value

The warning level for the compiler to display.

Remarks

Corresponds with the /warn option.

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


X Property

NAnt SDK Documentation - v0.91

VjcTask.X Property

Specifies whether to disable language extensions.

[Visual Basic]
<TaskAttribute(Name:="x", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property X As String
[C#]
[TaskAttribute(Name="x", Required=False, ExpandProperties=True, ProcessXml=True)]
public string X {get; set;}

Property Value

The value of this property must be either all, net, or an empty string.

Remarks

Corresponds to the /x flag.

See the Visual J# Reference for details.

Example

To disable only the .NET Framework extensions: <vjc x='net'/>

To disable the .NET Framework extensions and the VJ++ 6.0 extensions: <vjc x='all'/>

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


VjcTask Methods

The methods of the VjcTask class are listed below. For a complete list of VjcTask class members, see the VjcTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetManifestResourceName (inherited from CompilerBase) | Overloaded. Determines the manifest resource name of the given resource file.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
PerformSearchForResourceLinkage (inherited from CompilerBase) | Extracts the associated namespace/classname linkage found in the given stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CompileResxResources (inherited from CompilerBase) | Compiles a set of resx files to a .resources files.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask (inherited from CompilerBase) | Compiles the sources and resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
GetResourceLinkage (inherited from CompilerBase) | Finds the correct namespace/classname for a resource file from the given dependent source file.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
LinkResourceAssembly (inherited from CompilerBase) | Link a list of files into a resource assembly.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling (inherited from CompilerBase) | Determines whether compilation is needed.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
WriteConditionalCompilationConstants (inherited from CompilerBase) | Writes conditional compilation constants to the specified TextWriter.
WriteModuleReferences | Writes module references to the specified TextWriter.
WriteNoWarnList (inherited from CompilerBase) | Writes list of warnings to suppress to the specified TextWriter.
WriteOption (inherited from CompilerBase) | Overloaded. Writes an option using the default output format.
WriteOptions | Writes the compiler options to the specified TextWriter.
WritePackageReferences (inherited from CompilerBase) | Writes package references to the specified TextWriter.
WriteWarningsAsError (inherited from CompilerBase) | Writes list of warnings to (not) treat as errors to the specified TextWriter.

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


VjcTask.WriteModuleReferences Method

Writes module references to the specified TextWriter.

[Visual Basic]
Overrides Protected Sub WriteModuleReferences( _
ByVal writer As TextWriter _
)
[C#]
protected override void WriteModuleReferences(
TextWriter writer
);

Parameters

writer
The TextWriter to which the module references should be written.

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


VjcTask.WriteOptions Method

Writes the compiler options to the specified TextWriter.

[Visual Basic]
Overrides Protected Sub WriteOptions( _
ByVal writer As TextWriter _
)
[C#]
protected override void WriteOptions(
TextWriter writer
);

Parameters

writer
TextWriter to which the compiler options should be written.

See Also

VjcTask Class | NAnt.DotNet.Tasks Namespace


NAnt.DotNet.Types

NAnt SDK Documentation - v0.91

NAnt.DotNet.Types Namespace

Namespace hierarchy

Classes

Class | Description
AssemblyAttribute | Represents an assembly-level attribute.
AssemblyAttributeCollection | Contains a strongly typed collection of AssemblyAttribute objects.
AssemblyAttributeEnumerator | Enumerates the AssemblyAttribute elements of a AssemblyAttributeCollection.
AssemblyFileSet | Specialized FileSet class for managing assembly files.
CompilerWarning | Represents a compiler warning.
CompilerWarningCollection | Contains a collection of CompilerWarning elements.
CompilerWarningEnumerator | Enumerates the CompilerWarning elements of a CompilerWarningCollection.
DataTypeCollectionBase | Base class for collections that needs to be globally referencable.
DebugOutputConverter | Specialized EnumConverter that also supports case-insensitive conversion of "true" to Enable and "false" to None.
DelaySignConverter | Specialized EnumConverter that also supports case-insensitive conversion of "true" to Yes and "false" to No.
EmbeddedResource | Represents an embedded resource.
EmbeddedResourceCollection | Contains a collection of EmbeddedResource items.
EmbeddedResourceEnumerator | Enumerates the EmbeddedResource items of a EmbeddedResourceCollection.
LibDirectorySet | A specialized FileSet used for setting the lib directories.
Module | Represents a metadata file without assembly manifest.
ModuleCollection | Contains a collection of Module items.
ModuleEnumerator | Enumerates the Module items of a ModuleCollection.
ModuleSet | One or more modules to compile into an assembly.
NamespaceImport | Represents a namespace to import.
NamespaceImportCollection | Contains a collection of NamespaceImport items.
NamespaceImportEnumerator | Enumerates the NamespaceImport items of a NamespaceImportCollection.
Package | Represents a package.
PackageCollection | Contains a strongly typed collection of Package objects.
PackageEnumerator | Enumerates the Package elements of a PackageCollection.
ResourceFileSet | Specialized FileSet class for managing resource files.
ResourceFileSetCollection | Contains a strongly typed collection of ResourceFileSet objects.
ResourceFileSetEnumerator | Enumerates the ResourceFileSet elements of a ResourceFileSetCollection.
WarningAsError | Controls the behaviour of a compiler with regards to the reporting of warnings.

Enumerations

Enumeration | Description
DebugOutput | Specifies the type of debugging information generated by the compiler.
DelaySign | Specifies whether the generated assembly is strongly named and will be signed later.


AssemblyAttribute Class

Represents an assembly-level attribute.

For a list of all members of this type, see AssemblyAttribute Members.

System.Object
NAnt.Core.Element
NAnt.DotNet.Types.AssemblyAttribute

[Visual Basic]
<Serializable, _ Serializable, _ ElementName(Name:="attribute")>
Public Class AssemblyAttribute
Inherits Element
[C#]
[Serializable]
[Serializable]
[ElementName(Name="attribute")]
public class AssemblyAttribute : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

AssemblyAttribute Members | NAnt.DotNet.Types Namespace


AssemblyAttribute Members

AssemblyAttribute overview

Public Instance Constructors

AssemblyAttribute Constructor Initializes a new instance of the AssemblyAttribute class.

Public Instance Properties

AsIs | If true then the value of the attribute will be set as is, without actually looking for a matching constructor or named properties. The default is false.
IfDefined | Indicates if the attribute should be generated.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
TypeName | Typename of the assembly-level attribute.
UnlessDefined | Indicates if the attribute should be not generated.
Value | Value of the attribute.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyAttribute Class | NAnt.DotNet.Types Namespace


AssemblyAttribute Constructor

Initializes a new instance of the AssemblyAttribute class.

[Visual Basic]
Public Sub New()
[C#]
public AssemblyAttribute();

See Also

AssemblyAttribute Class | NAnt.DotNet.Types Namespace


AssemblyAttribute Properties

The properties of the AssemblyAttribute class are listed below. For a complete list of AssemblyAttribute class members, see the AssemblyAttribute Members topic.

Public Instance Properties

AsIs | If true then the value of the attribute will be set as is, without actually looking for a matching constructor or named properties. The default is false.
IfDefined | Indicates if the attribute should be generated.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
TypeName | Typename of the assembly-level attribute.
UnlessDefined | Indicates if the attribute should be not generated.
Value | Value of the attribute.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

AssemblyAttribute Class | NAnt.DotNet.Types Namespace


AsIs Property

NAnt SDK Documentation - v0.91

AssemblyAttribute.AsIs Property

If true then the value of the attribute will be set as is, without actually looking for a matching constructor or named properties. The default is false.

[Visual Basic]
<TaskAttribute(Name:="asis", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property AsIs As Boolean
[C#]
[TaskAttribute(Name="asis", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool AsIs {get; set;}

Property Value

true if the value of the attribute should be set as is; otherwise, false.

See Also

AssemblyAttribute Class | NAnt.DotNet.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

AssemblyAttribute.IfDefined Property

Indicates if the attribute should be generated.

[Visual Basic]
<TaskAttribute(Name:="if", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property IfDefined As Boolean
[C#]
[TaskAttribute(Name="if", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool IfDefined {get; set;}

Property Value

true if the attribute should be generated; otherwise, false.

See Also

AssemblyAttribute Class | NAnt.DotNet.Types Namespace


TypeName Property

NAnt SDK Documentation - v0.91

AssemblyAttribute.TypeName Property

Typename of the assembly-level attribute.

[Visual Basic]
<TaskAttribute(Name:="type", Required:=True, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property TypeName As String
[C#]
[TaskAttribute(Name="type", Required=True, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string TypeName {get; set;}

See Also

AssemblyAttribute Class | NAnt.DotNet.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

AssemblyAttribute.UnlessDefined Property

Indicates if the attribute should be not generated.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="unless", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property UnlessDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="unless", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool UnlessDefined {get; set;}

Property Value

true if the attribute should be not generated; otherwise, false.

See Also

AssemblyAttribute Class | NAnt.DotNet.Types Namespace


Value Property

NAnt SDK Documentation - v0.91

AssemblyAttribute.Value Property

Value of the attribute.

[Visual Basic]
<TaskAttribute(Name:="value", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Value As String
[C#]
[TaskAttribute(Name="value", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Value {get; set;}

See Also

AssemblyAttribute Class | NAnt.DotNet.Types Namespace


AssemblyAttributeCollection Class

Contains a strongly typed collection of AssemblyAttribute objects.

For a list of all members of this type, see AssemblyAttributeCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.DotNet.Types.AssemblyAttributeCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class AssemblyAttributeCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class AssemblyAttributeCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

AssemblyAttributeCollection Members | NAnt.DotNet.Types Namespace


AssemblyAttributeCollection Members

AssemblyAttributeCollection overview

Public Instance Constructors

AssemblyAttributeCollection Overloaded. Initializes a new instance of the AssemblyAttributeCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a AssemblyAttribute to the end of the collection.
AddRange | Overloaded. Adds the elements of a AssemblyAttribute array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a AssemblyAttribute is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified AssemblyAttribute object in the collection.
Insert | Inserts a AssemblyAttribute into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace


AssemblyAttributeCollection Constructor

Initializes a new instance of the AssemblyAttributeCollection class.

Overload List

Initializes a new instance of the AssemblyAttributeCollection class.

public AssemblyAttributeCollection();

Initializes a new instance of the AssemblyAttributeCollection class with the specified array of AssemblyAttribute instances.

public AssemblyAttributeCollection(AssemblyAttribute[]);

Initializes a new instance of the AssemblyAttributeCollection class with the specified AssemblyAttributeCollection instance.

public AssemblyAttributeCollection(AssemblyAttributeCollection);

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace


AssemblyAttributeCollection Constructor ()

Initializes a new instance of the AssemblyAttributeCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public AssemblyAttributeCollection();

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace | AssemblyAttributeCollection Constructor Overload List


AssemblyAttributeCollection Constructor (AssemblyAttributeCollection)

Initializes a new instance of the AssemblyAttributeCollection class with the specified AssemblyAttributeCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As AssemblyAttributeCollection _
)
[C#]
public AssemblyAttributeCollection(
AssemblyAttributeCollection value
);

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace | AssemblyAttributeCollection Constructor Overload List


AssemblyAttributeCollection Constructor (AssemblyAttribute[])

Initializes a new instance of the AssemblyAttributeCollection class with the specified array of AssemblyAttribute instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As AssemblyAttribute() _
)
[C#]
public AssemblyAttributeCollection(
AssemblyAttribute[] value
);

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace | AssemblyAttributeCollection Constructor Overload List


AssemblyAttributeCollection Properties

The properties of the AssemblyAttributeCollection class are listed below. For a complete list of AssemblyAttributeCollection class members, see the AssemblyAttributeCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

AssemblyAttributeCollection.Item Property

Gets or sets the element at the specified index.

Overload List

Gets or sets the element at the specified index.

public AssemblyAttribute this[int] {get; set;}

Gets the AssemblyAttribute with the specified value.

public AssemblyAttribute this[string] {get;}

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace


Item Property (Int32)

NAnt SDK Documentation - v0.91

AssemblyAttributeCollection.Item Property (Int32)

Gets or sets the element at the specified index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As AssemblyAttribute
[C#]
public AssemblyAttribute this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace | AssemblyAttributeCollection.Item Overload List


Item Property (String)

NAnt SDK Documentation - v0.91

AssemblyAttributeCollection.Item Property (String)

Gets the AssemblyAttribute with the specified value.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal value As String _
) As AssemblyAttribute
[C#]
public AssemblyAttribute this[
string value
] {get;}

Parameters

value
The value of the AssemblyAttribute to get.

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace | AssemblyAttributeCollection.Item Overload List


AssemblyAttributeCollection Methods

The methods of the AssemblyAttributeCollection class are listed below. For a complete list of AssemblyAttributeCollection class members, see the AssemblyAttributeCollection Members topic.

Public Instance Methods

Add | Adds a AssemblyAttribute to the end of the collection.
AddRange | Overloaded. Adds the elements of a AssemblyAttribute array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a AssemblyAttribute is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified AssemblyAttribute object in the collection.
Insert | Inserts a AssemblyAttribute into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace


AssemblyAttributeCollection.Add Method

Adds a AssemblyAttribute to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As AssemblyAttribute _
) As Integer
[C#]
public int Add(
AssemblyAttribute item
);

Parameters

item
The AssemblyAttribute to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

AssemblyAttributeCollection.AddRange Method

Adds the elements of a AssemblyAttribute array to the end of the collection.

Overload List

Adds the elements of a AssemblyAttribute array to the end of the collection.

public void AddRange(AssemblyAttribute[]);

Adds the elements of a AssemblyAttributeCollection to the end of the collection.

public void AddRange(AssemblyAttributeCollection);

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace


AssemblyAttributeCollection.AddRange Method (AssemblyAttribute[])

Adds the elements of a AssemblyAttribute array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As AssemblyAttribute() _
)
[C#]
public void AddRange(
AssemblyAttribute[] items
);

Parameters

items
The array of AssemblyAttribute elements to be added to the end of the collection.

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace | AssemblyAttributeCollection.AddRange Overload List


AssemblyAttributeCollection.AddRange Method (AssemblyAttributeCollection)

Adds the elements of a AssemblyAttributeCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As AssemblyAttributeCollection _
)
[C#]
public void AddRange(
AssemblyAttributeCollection items
);

Parameters

items
The AssemblyAttributeCollection to be added to the end of the collection.

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace | AssemblyAttributeCollection.AddRange Overload List


Contains Method

NAnt SDK Documentation - v0.91

AssemblyAttributeCollection.Contains Method

Determines whether a AssemblyAttribute is in the collection.

Overload List

Determines whether a AssemblyAttribute is in the collection.

public bool Contains(AssemblyAttribute);

Determines whether a AssemblyAttribute with the specified value is in the collection.

public bool Contains(string);

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace


AssemblyAttributeCollection.Contains Method (AssemblyAttribute)

Determines whether a AssemblyAttribute is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal item As AssemblyAttribute _
) As Boolean
[C#]
public bool Contains(
AssemblyAttribute item
);

Parameters

item
The AssemblyAttribute to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace | AssemblyAttributeCollection.Contains Overload List


AssemblyAttributeCollection.Contains Method (String)

Determines whether a AssemblyAttribute with the specified value is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal value As String _
) As Boolean
[C#]
public bool Contains(
string value
);

Parameters

value
The argument value to locate in the collection.

Return Value

true if a AssemblyAttribute with value value is found in the collection; otherwise, false.

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace | AssemblyAttributeCollection.Contains Overload List


AssemblyAttributeCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As AssemblyAttribute(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
AssemblyAttribute[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace


AssemblyAttributeCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As AssemblyAttributeEnumerator
[C#]
new public AssemblyAttributeEnumerator GetEnumerator();

Return Value

A AssemblyAttributeEnumerator for the entire collection.

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace


AssemblyAttributeCollection.IndexOf Method

Retrieves the index of a specified AssemblyAttribute object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As AssemblyAttribute _
) As Integer
[C#]
public int IndexOf(
AssemblyAttribute item
);

Parameters

item
The AssemblyAttribute object for which the index is returned.

Return Value

The index of the specified AssemblyAttribute. If the AssemblyAttribute is not currently a member of the collection, it returns -1.

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace


AssemblyAttributeCollection.Insert Method

Inserts a AssemblyAttribute into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As AssemblyAttribute _
)
[C#]
public void Insert(
int index,
AssemblyAttribute item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The AssemblyAttribute to insert.

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace


AssemblyAttributeCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As AssemblyAttribute _
)
[C#]
public void Remove(
AssemblyAttribute item
);

Parameters

item
The AssemblyAttribute to remove from the collection.

See Also

AssemblyAttributeCollection Class | NAnt.DotNet.Types Namespace


AssemblyAttributeEnumerator Class

Enumerates the AssemblyAttribute elements of a AssemblyAttributeCollection.

For a list of all members of this type, see AssemblyAttributeEnumerator Members.

System.Object
NAnt.DotNet.Types.AssemblyAttributeEnumerator

[Visual Basic]
Public Class AssemblyAttributeEnumerator
Implements IEnumerator
[C#]
public class AssemblyAttributeEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

AssemblyAttributeEnumerator Members | NAnt.DotNet.Types Namespace


AssemblyAttributeEnumerator Members

AssemblyAttributeEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyAttributeEnumerator Class | NAnt.DotNet.Types Namespace


AssemblyAttributeEnumerator Properties

The properties of the AssemblyAttributeEnumerator class are listed below. For a complete list of AssemblyAttributeEnumerator class members, see the AssemblyAttributeEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

AssemblyAttributeEnumerator Class | NAnt.DotNet.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

AssemblyAttributeEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As AssemblyAttribute
[C#]
public AssemblyAttribute Current {get;}

See Also

AssemblyAttributeEnumerator Class | NAnt.DotNet.Types Namespace


AssemblyAttributeEnumerator Methods

The methods of the AssemblyAttributeEnumerator class are listed below. For a complete list of AssemblyAttributeEnumerator class members, see the AssemblyAttributeEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyAttributeEnumerator Class | NAnt.DotNet.Types Namespace


AssemblyAttributeEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

AssemblyAttributeEnumerator Class | NAnt.DotNet.Types Namespace


AssemblyAttributeEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

AssemblyAttributeEnumerator Class | NAnt.DotNet.Types Namespace


AssemblyFileSet Class

Specialized FileSet class for managing assembly files.

For a list of all members of this type, see AssemblyFileSet Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.Core.Types.FileSet
NAnt.DotNet.Types.AssemblyFileSet

[Visual Basic]
<Serializable, _ Serializable, _ ElementName(Name:="assemblyfileset")>
Public Class AssemblyFileSet
Inherits FileSet
Implements ICloneable
[C#]
[Serializable]
[Serializable]
[ElementName(Name="assemblyfileset")]
public class AssemblyFileSet : FileSet, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

If an include pattern does not contain any wildcard characters then the assembly will be searched for in following locations (in the order listed):

  • The base directory of the fileset.
  • The directories specified using the nested <lib> element.
  • The list of reference assemblies of the current target framework.

The reference assemblies of a given target framework are defined using <reference-assemblies> filesets in the <framework> node of the NAnt configuration file.

Example

Define a reference with name "sys.assemblies", holding a set of system assemblies.

<assemblyfileset id="sys.assemblies">
    <include name="System.dll" />
    <include name="System.Data.dll" />
    <include name="System.Xml.dll" />
</assemblyfileset>

Use the predefined set of assemblies to compile a C# assembly.

<csc target="exe" output="HelloWorld.exe">
    <sources>
        <include name="**/*.cs" />
    </sources>
    <references refid="sys.assemblies" />
</csc>

Compile a C# assembly using assembly references that are searched for in the "Third Party Assemblies" and "Company Assemblies" directories.

<csc target="exe" output="HelloWorld.exe">
    <sources>
        <include name="**/*.cs" />
    </sources>
    <references>
        <lib>
            <include name="Third Party Assemblies" />
            <include name="Company Assemblies" />
        </lib>
        <include name="log4net.dll" />
        <include name="Company.Business.dll" />
    </references>
</csc>

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

AssemblyFileSet Members | NAnt.DotNet.Types Namespace | FileSet


AssemblyFileSet Members

AssemblyFileSet overview

Public Instance Constructors

AssemblyFileSet Overloaded. Initializes a new instance of the AssemblyFileSet class.

Public Instance Properties

AsIs (inherited from FileSet) | Gets the collection of files that will be added to the FileSet without pattern matching or checking if the file exists.
BaseDirectory (inherited from FileSet) | The base of the directory of this fileset. The default is the project base directory.
CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
CaseSensitive (inherited from FileSet) | Indicates whether include and exclude patterns must be treated in a case-sensitive way. The default is true on Unix; otherwise, false.
DefaultExcludes (inherited from FileSet) | Indicates whether default excludes should be used or not. The default is true.
DirectoryNames (inherited from FileSet) | Gets the collection of directory names that match the fileset.
ExcludeElements (inherited from FileSet) | The items to exclude from the fileset.
Excludes (inherited from FileSet) | Gets the collection of exclude patterns.
ExcludesFiles (inherited from FileSet) | The files from which a list of patterns or files to exclude should be obtained.
FailOnEmpty (inherited from FileSet) | When set to true, causes the fileset element to throw a ValidationException when no files match the includes and excludes criteria. The default is false.
FileNames (inherited from FileSet) | Gets the collection of file names that match the fileset.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IncludeElements (inherited from FileSet) | The items to include in the fileset.
Includes (inherited from FileSet) | Gets the collection of include patterns.
IncludesFiles (inherited from FileSet) | The files from which a list of patterns or files to include should be obtained.
Lib | Additional directories to search in for assembly references.
MostRecentLastWriteTimeFile (inherited from FileSet) | Determines the most recently modified file in the fileset (by LastWriteTime of the FileInfo).
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PathFiles (inherited from FileSet) |
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.
ScannedDirectories (inherited from FileSet) | Gets the collection of directory names that were scanned for files.
SetExcludes (inherited from FileSet) | Obsolete. The items to exclude from the fileset.
SetIncludes (inherited from FileSet) | Obsolete. The items to include in the fileset.
SetIncludesList (inherited from FileSet) | Obsolete. The files from which a list of patterns or files to include should be obtained.

Public Instance Methods

AddPatternSet (inherited from FileSet) | Adds a nested set of patterns, or references a standalone patternset.
Clone (inherited from FileSet) | Creates a shallow copy of the FileSet.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from FileSet) |
Scan | Do a normal scan and then resolve assemblies.
ToString (inherited from FileSet) |

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from FileSet) | Overloaded. Copies all instance data of the FileSet to a given FileSet.
CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from FileSet) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ResolveReferences | Resolves references to system assemblies and assemblies that can be resolved using directories specified in Lib.

See Also

AssemblyFileSet Class | NAnt.DotNet.Types Namespace | FileSet


AssemblyFileSet Constructor

Initializes a new instance of the AssemblyFileSet class.

Overload List

Initializes a new instance of the AssemblyFileSet class.

public AssemblyFileSet();

copy constructor for FileSet. Required in order to assign references of FileSet type where AssemblyFileSets are used

public AssemblyFileSet(FileSet);

See Also

AssemblyFileSet Class | NAnt.DotNet.Types Namespace


AssemblyFileSet Constructor ()

Initializes a new instance of the AssemblyFileSet class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public AssemblyFileSet();

See Also

AssemblyFileSet Class | NAnt.DotNet.Types Namespace | AssemblyFileSet Constructor Overload List


AssemblyFileSet Constructor (FileSet)

copy constructor for FileSet. Required in order to assign references of FileSet type where AssemblyFileSets are used

[Visual Basic]
Overloads Public Sub New( _
ByVal fs As FileSet _
)
[C#]
public AssemblyFileSet(
FileSet fs
);

Parameters

fs

See Also

AssemblyFileSet Class | NAnt.DotNet.Types Namespace | AssemblyFileSet Constructor Overload List


AssemblyFileSet Properties

The properties of the AssemblyFileSet class are listed below. For a complete list of AssemblyFileSet class members, see the AssemblyFileSet Members topic.

Public Instance Properties

AsIs (inherited from FileSet) | Gets the collection of files that will be added to the FileSet without pattern matching or checking if the file exists.
BaseDirectory (inherited from FileSet) | The base of the directory of this fileset. The default is the project base directory.
CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
CaseSensitive (inherited from FileSet) | Indicates whether include and exclude patterns must be treated in a case-sensitive way. The default is true on Unix; otherwise, false.
DefaultExcludes (inherited from FileSet) | Indicates whether default excludes should be used or not. The default is true.
DirectoryNames (inherited from FileSet) | Gets the collection of directory names that match the fileset.
ExcludeElements (inherited from FileSet) | The items to exclude from the fileset.
Excludes (inherited from FileSet) | Gets the collection of exclude patterns.
ExcludesFiles (inherited from FileSet) | The files from which a list of patterns or files to exclude should be obtained.
FailOnEmpty (inherited from FileSet) | When set to true, causes the fileset element to throw a ValidationException when no files match the includes and excludes criteria. The default is false.
FileNames (inherited from FileSet) | Gets the collection of file names that match the fileset.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IncludeElements (inherited from FileSet) | The items to include in the fileset.
Includes (inherited from FileSet) | Gets the collection of include patterns.
IncludesFiles (inherited from FileSet) | The files from which a list of patterns or files to include should be obtained.
Lib | Additional directories to search in for assembly references.
MostRecentLastWriteTimeFile (inherited from FileSet) | Determines the most recently modified file in the fileset (by LastWriteTime of the FileInfo).
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PathFiles (inherited from FileSet) |
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.
ScannedDirectories (inherited from FileSet) | Gets the collection of directory names that were scanned for files.
SetExcludes (inherited from FileSet) | Obsolete. The items to exclude from the fileset.
SetIncludes (inherited from FileSet) | Obsolete. The items to include in the fileset.
SetIncludesList (inherited from FileSet) | Obsolete. The files from which a list of patterns or files to include should be obtained.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

AssemblyFileSet Class | NAnt.DotNet.Types Namespace | FileSet


Lib Property

NAnt SDK Documentation - v0.91

AssemblyFileSet.Lib Property

Additional directories to search in for assembly references.

[Visual Basic]
<BuildElement(Name:="lib", Required:=False, ProcessXml:=True)>
Public Property Lib As LibDirectorySet
[C#]
[BuildElement(Name="lib", Required=False, ProcessXml=True)]
public LibDirectorySet Lib {get; set;}

Remarks

loosely Corresponds with the /lib[path]: flag of the various compiler tasks.

See Also

AssemblyFileSet Class | NAnt.DotNet.Types Namespace


AssemblyFileSet Methods

The methods of the AssemblyFileSet class are listed below. For a complete list of AssemblyFileSet class members, see the AssemblyFileSet Members topic.

Public Instance Methods

AddPatternSet (inherited from FileSet) | Adds a nested set of patterns, or references a standalone patternset.
Clone (inherited from FileSet) | Creates a shallow copy of the FileSet.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from FileSet) |
Scan | Do a normal scan and then resolve assemblies.
ToString (inherited from FileSet) |

Protected Instance Methods

CopyTo (inherited from FileSet) | Overloaded. Copies all instance data of the FileSet to a given FileSet.
CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from FileSet) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ResolveReferences | Resolves references to system assemblies and assemblies that can be resolved using directories specified in Lib.

See Also

AssemblyFileSet Class | NAnt.DotNet.Types Namespace | FileSet


AssemblyFileSet.ResolveReferences Method

Resolves references to system assemblies and assemblies that can be resolved using directories specified in Lib.

[Visual Basic]
Protected Sub ResolveReferences()
[C#]
protected void ResolveReferences();

See Also

AssemblyFileSet Class | NAnt.DotNet.Types Namespace


AssemblyFileSet.Scan Method

Do a normal scan and then resolve assemblies.

[Visual Basic]
Overrides Public Sub Scan()
[C#]
public override void Scan();

See Also

AssemblyFileSet Class | NAnt.DotNet.Types Namespace


CompilerWarning Class

Represents a compiler warning.

For a list of all members of this type, see CompilerWarning Members.

System.Object
NAnt.Core.Element
NAnt.DotNet.Types.CompilerWarning

[Visual Basic]
Public Class CompilerWarning
Inherits Element
[C#]
public class CompilerWarning : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

CompilerWarning Members | NAnt.DotNet.Types Namespace


CompilerWarning Members

CompilerWarning overview

Public Instance Constructors

CompilerWarning Constructor Initializes a new instance of the CompilerWarning class.

Public Instance Properties

IfDefined | If true then the element will be processed; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Number | A warning number, or comma-separated list of warnings, that you want the compiler to suppress or report.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | If true then the element will be skipped; otherwise, processed. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompilerWarning Class | NAnt.DotNet.Types Namespace


CompilerWarning Constructor

Initializes a new instance of the CompilerWarning class.

[Visual Basic]
Public Sub New()
[C#]
public CompilerWarning();

See Also

CompilerWarning Class | NAnt.DotNet.Types Namespace


CompilerWarning Properties

The properties of the CompilerWarning class are listed below. For a complete list of CompilerWarning class members, see the CompilerWarning Members topic.

Public Instance Properties

IfDefined | If true then the element will be processed; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Number | A warning number, or comma-separated list of warnings, that you want the compiler to suppress or report.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | If true then the element will be skipped; otherwise, processed. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

CompilerWarning Class | NAnt.DotNet.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

CompilerWarning.IfDefined Property

If true then the element will be processed; otherwise, skipped. The default is true.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="if", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property IfDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="if", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool IfDefined {get; set;}

See Also

CompilerWarning Class | NAnt.DotNet.Types Namespace


Number Property

NAnt SDK Documentation - v0.91

CompilerWarning.Number Property

A warning number, or comma-separated list of warnings, that you want the compiler to suppress or report.

[Visual Basic]
<TaskAttribute(Name:="number", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property Number As String
[C#]
[TaskAttribute(Name="number", Required=True, ExpandProperties=True, ProcessXml=True)]
public string Number {get; set;}

See Also

CompilerWarning Class | NAnt.DotNet.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

CompilerWarning.UnlessDefined Property

If true then the element will be skipped; otherwise, processed. The default is false.

[Visual Basic]
<TaskAttribute(Name:="unless", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property UnlessDefined As Boolean
[C#]
[TaskAttribute(Name="unless", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool UnlessDefined {get; set;}

See Also

CompilerWarning Class | NAnt.DotNet.Types Namespace


CompilerWarningCollection Class

Contains a collection of CompilerWarning elements.

For a list of all members of this type, see CompilerWarningCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.DotNet.Types.CompilerWarningCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class CompilerWarningCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class CompilerWarningCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

CompilerWarningCollection Members | NAnt.DotNet.Types Namespace


CompilerWarningCollection Members

CompilerWarningCollection overview

Public Instance Constructors

CompilerWarningCollection Overloaded. Initializes a new instance of the CompilerWarningCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a CompilerWarning to the end of the collection.
AddRange | Overloaded. Adds the elements of a CompilerWarning array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a CompilerWarning is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified CompilerWarning object in the collection.
Insert | Inserts a CompilerWarning into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

CompilerWarningCollection Class | NAnt.DotNet.Types Namespace


CompilerWarningCollection Constructor

Initializes a new instance of the CompilerWarningCollection class.

Overload List

Initializes a new instance of the CompilerWarningCollection class.

public CompilerWarningCollection();

Initializes a new instance of the CompilerWarningCollection class with the specified array of CompilerWarning instances.

public CompilerWarningCollection(CompilerWarning[]);

Initializes a new instance of the CompilerWarningCollection class with the specified CompilerWarningCollection instance.

public CompilerWarningCollection(CompilerWarningCollection);

See Also

CompilerWarningCollection Class | NAnt.DotNet.Types Namespace


CompilerWarningCollection Constructor ()

Initializes a new instance of the CompilerWarningCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CompilerWarningCollection();

See Also

CompilerWarningCollection Class | NAnt.DotNet.Types Namespace | CompilerWarningCollection Constructor Overload List


CompilerWarningCollection Constructor (CompilerWarningCollection)

Initializes a new instance of the CompilerWarningCollection class with the specified CompilerWarningCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As CompilerWarningCollection _
)
[C#]
public CompilerWarningCollection(
CompilerWarningCollection value
);

See Also

CompilerWarningCollection Class | NAnt.DotNet.Types Namespace | CompilerWarningCollection Constructor Overload List


CompilerWarningCollection Constructor (CompilerWarning[])

Initializes a new instance of the CompilerWarningCollection class with the specified array of CompilerWarning instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As CompilerWarning() _
)
[C#]
public CompilerWarningCollection(
CompilerWarning[] value
);

See Also

CompilerWarningCollection Class | NAnt.DotNet.Types Namespace | CompilerWarningCollection Constructor Overload List


CompilerWarningCollection Properties

The properties of the CompilerWarningCollection class are listed below. For a complete list of CompilerWarningCollection class members, see the CompilerWarningCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

CompilerWarningCollection Class | NAnt.DotNet.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

CompilerWarningCollection.Item Property

Gets or sets the element at the specified index.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As CompilerWarning
[C#]
public CompilerWarning this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

CompilerWarningCollection Class | NAnt.DotNet.Types Namespace


CompilerWarningCollection Methods

The methods of the CompilerWarningCollection class are listed below. For a complete list of CompilerWarningCollection class members, see the CompilerWarningCollection Members topic.

Public Instance Methods

Add | Adds a CompilerWarning to the end of the collection.
AddRange | Overloaded. Adds the elements of a CompilerWarning array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a CompilerWarning is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified CompilerWarning object in the collection.
Insert | Inserts a CompilerWarning into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

CompilerWarningCollection Class | NAnt.DotNet.Types Namespace


CompilerWarningCollection.Add Method

Adds a CompilerWarning to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As CompilerWarning _
) As Integer
[C#]
public int Add(
CompilerWarning item
);

Parameters

item
The CompilerWarning to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

CompilerWarningCollection Class | NAnt.DotNet.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

CompilerWarningCollection.AddRange Method

Adds the elements of a CompilerWarning array to the end of the collection.

Overload List

Adds the elements of a CompilerWarning array to the end of the collection.

public void AddRange(CompilerWarning[]);

Adds the elements of a CompilerWarningCollection to the end of the collection.

public void AddRange(CompilerWarningCollection);

See Also

CompilerWarningCollection Class | NAnt.DotNet.Types Namespace


CompilerWarningCollection.AddRange Method (CompilerWarning[])

Adds the elements of a CompilerWarning array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As CompilerWarning() _
)
[C#]
public void AddRange(
CompilerWarning[] items
);

Parameters

items
The array of CompilerWarning elements to be added to the end of the collection.

See Also

CompilerWarningCollection Class | NAnt.DotNet.Types Namespace | CompilerWarningCollection.AddRange Overload List


CompilerWarningCollection.AddRange Method (CompilerWarningCollection)

Adds the elements of a CompilerWarningCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As CompilerWarningCollection _
)
[C#]
public void AddRange(
CompilerWarningCollection items
);

Parameters

items
The CompilerWarningCollection to be added to the end of the collection.

See Also

CompilerWarningCollection Class | NAnt.DotNet.Types Namespace | CompilerWarningCollection.AddRange Overload List


CompilerWarningCollection.Contains Method

Determines whether a CompilerWarning is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal item As CompilerWarning _
) As Boolean
[C#]
public bool Contains(
CompilerWarning item
);

Parameters

item
The CompilerWarning to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

CompilerWarningCollection Class | NAnt.DotNet.Types Namespace


CompilerWarningCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As CompilerWarning(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
CompilerWarning[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

CompilerWarningCollection Class | NAnt.DotNet.Types Namespace


CompilerWarningCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As CompilerWarningEnumerator
[C#]
new public CompilerWarningEnumerator GetEnumerator();

Return Value

A CompilerWarningEnumerator for the entire collection.

See Also

CompilerWarningCollection Class | NAnt.DotNet.Types Namespace


CompilerWarningCollection.IndexOf Method

Retrieves the index of a specified CompilerWarning object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As CompilerWarning _
) As Integer
[C#]
public int IndexOf(
CompilerWarning item
);

Parameters

item
The CompilerWarning object for which the index is returned.

Return Value

The index of the specified CompilerWarning. If the CompilerWarning is not currently a member of the collection, it returns -1.

See Also

CompilerWarningCollection Class | NAnt.DotNet.Types Namespace


CompilerWarningCollection.Insert Method

Inserts a CompilerWarning into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As CompilerWarning _
)
[C#]
public void Insert(
int index,
CompilerWarning item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The CompilerWarning to insert.

See Also

CompilerWarningCollection Class | NAnt.DotNet.Types Namespace


CompilerWarningCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As CompilerWarning _
)
[C#]
public void Remove(
CompilerWarning item
);

Parameters

item
The CompilerWarning to remove from the collection.

See Also

CompilerWarningCollection Class | NAnt.DotNet.Types Namespace


CompilerWarningEnumerator Class

Enumerates the CompilerWarning elements of a CompilerWarningCollection.

For a list of all members of this type, see CompilerWarningEnumerator Members.

System.Object
NAnt.DotNet.Types.CompilerWarningEnumerator

[Visual Basic]
Public Class CompilerWarningEnumerator
Implements IEnumerator
[C#]
public class CompilerWarningEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

CompilerWarningEnumerator Members | NAnt.DotNet.Types Namespace


CompilerWarningEnumerator Members

CompilerWarningEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompilerWarningEnumerator Class | NAnt.DotNet.Types Namespace


CompilerWarningEnumerator Properties

The properties of the CompilerWarningEnumerator class are listed below. For a complete list of CompilerWarningEnumerator class members, see the CompilerWarningEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

CompilerWarningEnumerator Class | NAnt.DotNet.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

CompilerWarningEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As CompilerWarning
[C#]
public CompilerWarning Current {get;}

See Also

CompilerWarningEnumerator Class | NAnt.DotNet.Types Namespace


CompilerWarningEnumerator Methods

The methods of the CompilerWarningEnumerator class are listed below. For a complete list of CompilerWarningEnumerator class members, see the CompilerWarningEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompilerWarningEnumerator Class | NAnt.DotNet.Types Namespace


CompilerWarningEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

CompilerWarningEnumerator Class | NAnt.DotNet.Types Namespace


CompilerWarningEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

CompilerWarningEnumerator Class | NAnt.DotNet.Types Namespace


DataTypeCollectionBase Class

Base class for collections that needs to be globally referencable.

For a list of all members of this type, see DataTypeCollectionBase Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.DotNet.Types.DataTypeCollectionBase
NAnt.DotNet.Types.EmbeddedResourceCollection
NAnt.DotNet.Types.NamespaceImportCollection

[Visual Basic]
MustInherit Public Class DataTypeCollectionBase
Inherits DataTypeBase
Implements ICollection, IEnumerable
[C#]
public abstract class DataTypeCollectionBase : DataTypeBase, ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

DataTypeCollectionBase Members | NAnt.DotNet.Types Namespace


DataTypeCollectionBase Members

DataTypeCollectionBase overview

Public Instance Properties

CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Count | Gets the number of items in the collection.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | Gets a value indicating whether the collection has a fixed size.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.

Public Instance Methods

Clear | Removes all items from the collection.
CopyTo | Overloaded. Copies the items of the collection to an Array, starting at a particular index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
RemoveAt | Removes an item at a specific index.
Reset (inherited from DataTypeBase) | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

DataTypeCollectionBase Constructor Initializes a new instance of the DataTypeCollectionBase class.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
ItemType | Gets the Type of the items in this collection.
List | Gets the list of elements contained in the DataTypeCollectionBase instance.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from DataTypeBase) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RangeCheck | Checks whether the specified index is within the range of this collection.
ValidateType | Used by methods that take Object instances as argument to verify whether the instance is valid for the collection class.

See Also

DataTypeCollectionBase Class | NAnt.DotNet.Types Namespace


DataTypeCollectionBase Constructor

Initializes a new instance of the DataTypeCollectionBase class.

[Visual Basic]
Protected Sub New()
[C#]
protected DataTypeCollectionBase();

See Also

DataTypeCollectionBase Class | NAnt.DotNet.Types Namespace


DataTypeCollectionBase Properties

The properties of the DataTypeCollectionBase class are listed below. For a complete list of DataTypeCollectionBase class members, see the DataTypeCollectionBase Members topic.

Public Instance Properties

CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Count | Gets the number of items in the collection.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | Gets a value indicating whether the collection has a fixed size.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
ItemType | Gets the Type of the items in this collection.
List | Gets the list of elements contained in the DataTypeCollectionBase instance.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

DataTypeCollectionBase Class | NAnt.DotNet.Types Namespace


Count Property

NAnt SDK Documentation - v0.91

DataTypeCollectionBase.Count Property

Gets the number of items in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Property Value

The number of items in the collection.

Implements

ICollection.Count

See Also

DataTypeCollectionBase Class | NAnt.DotNet.Types Namespace


IsFixedSize Property

NAnt SDK Documentation - v0.91

DataTypeCollectionBase.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

[Visual Basic]
NotOverridable Public ReadOnly Property IsFixedSize As Boolean
[C#]
public bool IsFixedSize {get;}

Property Value

false.

See Also

DataTypeCollectionBase Class | NAnt.DotNet.Types Namespace


IsReadOnly Property

NAnt SDK Documentation - v0.91

DataTypeCollectionBase.IsReadOnly Property

Gets a value indicating whether the collection has a fixed size.

[Visual Basic]
NotOverridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {get;}

Property Value

false.

See Also

DataTypeCollectionBase Class | NAnt.DotNet.Types Namespace


ItemType Property

NAnt SDK Documentation - v0.91

DataTypeCollectionBase.ItemType Property

Gets the Type of the items in this collection.

[Visual Basic]
MustOverride Protected ReadOnly Property ItemType As Type
[C#]
protected abstract System.Type ItemType {get;}

Property Value

The Type of the items in this collection.

See Also

DataTypeCollectionBase Class | NAnt.DotNet.Types Namespace


List Property

NAnt SDK Documentation - v0.91

DataTypeCollectionBase.List Property

Gets the list of elements contained in the DataTypeCollectionBase instance.

[Visual Basic]
Protected ReadOnly Property List As ArrayList
[C#]
protected System.Collections.ArrayList List {get;}

Property Value

An ArrayList containing the elements of the collection.

See Also

DataTypeCollectionBase Class | NAnt.DotNet.Types Namespace


DataTypeCollectionBase Methods

The methods of the DataTypeCollectionBase class are listed below. For a complete list of DataTypeCollectionBase class members, see the DataTypeCollectionBase Members topic.

Public Instance Methods

Clear | Removes all items from the collection.
CopyTo | Overloaded. Copies the items of the collection to an Array, starting at a particular index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
RemoveAt | Removes an item at a specific index.
Reset (inherited from DataTypeBase) | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from DataTypeBase) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RangeCheck | Checks whether the specified index is within the range of this collection.
ValidateType | Used by methods that take Object instances as argument to verify whether the instance is valid for the collection class.

See Also

DataTypeCollectionBase Class | NAnt.DotNet.Types Namespace


DataTypeCollectionBase.Clear Method

Removes all items from the collection.

[Visual Basic]
NotOverridable Public Sub Clear()
[C#]
public void Clear();

See Also

DataTypeCollectionBase Class | NAnt.DotNet.Types Namespace


CopyTo Method

NAnt SDK Documentation - v0.91

DataTypeCollectionBase.CopyTo Method

Copies the items of the collection to an Array, starting at a particular index.

Overload List

Inherited from DataTypeBase.

protected void CopyTo(DataTypeBase);

Inherited from Element.

protected void CopyTo(Element);

Copies the items of the collection to an Array, starting at a particular index.

public void CopyTo(Array,int);

See Also

DataTypeCollectionBase Class | NAnt.DotNet.Types Namespace


DataTypeCollectionBase.CopyTo Method (Array, Int32)

Copies the items of the collection to an Array, starting at a particular index.

[Visual Basic]
NotOverridable Overloads Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
The one-dimensional Array that is the destination of the items copied from the collection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Implements

ICollection.CopyTo

See Also

DataTypeCollectionBase Class | NAnt.DotNet.Types Namespace | DataTypeCollectionBase.CopyTo Overload List


DataTypeCollectionBase.RangeCheck Method

Checks whether the specified index is within the range of this collection.

[Visual Basic]
Protected Sub RangeCheck( _
ByVal index As Integer _
)
[C#]
protected void RangeCheck(
int index
);

Parameters

index
The index to check.

See Also

DataTypeCollectionBase Class | NAnt.DotNet.Types Namespace


DataTypeCollectionBase.RemoveAt Method

Removes an item at a specific index.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
public void RemoveAt(
int index
);

Parameters

index
The zero-based index of the item to remove.

See Also

DataTypeCollectionBase Class | NAnt.DotNet.Types Namespace


DataTypeCollectionBase.ValidateType Method

Used by methods that take Object instances as argument to verify whether the instance is valid for the collection class.

[Visual Basic]
Protected Sub ValidateType( _
ByVal value As Object _
)
[C#]
protected void ValidateType(
object value
);

Parameters

value
The instance to verify.

See Also

DataTypeCollectionBase Class | NAnt.DotNet.Types Namespace


DebugOutput Enumeration

Specifies the type of debugging information generated by the compiler.

[Visual Basic]
<Serializable, _ TypeConverter(ConverterTypeName:="NAnt.DotNet.Types.DebugOutputConverter, NAnt.DotNetTasks, Version=0.91.4312.0, Culture=neutral, PublicKeyToken=null")>
Public Enum DebugOutput
[C#]
[Serializable]
[TypeConverter(ConverterTypeName="NAnt.DotNet.Types.DebugOutputConverter, NAnt.DotNetTasks, Version=0.91.4312.0, Culture=neutral, PublicKeyToken=null")]
public enum DebugOutput

Remarks

For backward compatibility, the following string values can also be used in build files:

Value | Corresponding field
"true" | Enable
"false" | None

When set to Enabled then the following conditional compilation symbols will also be defined:

  • DEBUG
  • TRACE

Members

Member Name | Description
None | Create no debug information.
Enable | Enable attaching a debugger to the running program.
Full | Enable attaching a debugger to the running program.
PdbOnly | Only display assembler when the running program is attached to the debugger.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

NAnt.DotNet.Types Namespace


DebugOutputConverter Class

Specialized EnumConverter that also supports case-insensitive conversion of "true" to Enable and "false" to None.

For a list of all members of this type, see DebugOutputConverter Members.

System.Object
System.ComponentModel.TypeConverter
System.ComponentModel.EnumConverter
NAnt.DotNet.Types.DebugOutputConverter

[Visual Basic]
Public Class DebugOutputConverter
Inherits EnumConverter
[C#]
public class DebugOutputConverter : EnumConverter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

DebugOutputConverter Members | NAnt.DotNet.Types Namespace


DebugOutputConverter Members

DebugOutputConverter overview

Public Instance Constructors

DebugOutputConverter Constructor Initializes a new instance of the DebugOutputConverter class.

Public Instance Methods

CanConvertFrom (inherited from EnumConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to an enumeration object using the specified context.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from EnumConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type using the context.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type.
ConvertFrom | Overloaded. Converts the given object to the type of this converter, using the specified context and culture information.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from EnumConverter) | Overloaded. Converts the given value object to the specified destination type.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the arguments.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Re-creates an Object given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties.
GetStandardValues (inherited from EnumConverter) | Overloaded. Gets a collection of standard values for the data type this validator is designed for.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from EnumConverter) | Overloaded. Gets a value indicating whether the list of standard values returned from GetStandardValues is an exclusive list using the specified context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from EnumConverter) | Overloaded. Gets a value indicating whether this object supports a standard set of values that can be picked from a list using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from EnumConverter) | Overloaded. Gets a value indicating whether the given object value is valid for this type.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Comparer (inherited from EnumConverter) | Gets an IComparer that can be used to sort the values of the enumeration.
EnumType (inherited from EnumConverter) | Specifies the type of the enumerator this converter is associated with.
Values (inherited from EnumConverter) | Gets or sets a StandardValuesCollection that specifies the possible values for the enumeration.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

DebugOutputConverter Class | NAnt.DotNet.Types Namespace


DebugOutputConverter Constructor

Initializes a new instance of the DebugOutputConverter class.

[Visual Basic]
Public Sub New()
[C#]
public DebugOutputConverter();

See Also

DebugOutputConverter Class | NAnt.DotNet.Types Namespace


DebugOutputConverter Methods

The methods of the DebugOutputConverter class are listed below. For a complete list of DebugOutputConverter class members, see the DebugOutputConverter Members topic.

Public Instance Methods

CanConvertFrom (inherited from EnumConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to an enumeration object using the specified context.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from EnumConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type using the context.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type.
ConvertFrom | Overloaded. Converts the given object to the type of this converter, using the specified context and culture information.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from EnumConverter) | Overloaded. Converts the given value object to the specified destination type.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the arguments.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Re-creates an Object given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties.
GetStandardValues (inherited from EnumConverter) | Overloaded. Gets a collection of standard values for the data type this validator is designed for.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from EnumConverter) | Overloaded. Gets a value indicating whether the list of standard values returned from GetStandardValues is an exclusive list using the specified context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from EnumConverter) | Overloaded. Gets a value indicating whether this object supports a standard set of values that can be picked from a list using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from EnumConverter) | Overloaded. Gets a value indicating whether the given object value is valid for this type.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

DebugOutputConverter Class | NAnt.DotNet.Types Namespace


ConvertFrom Method

NAnt SDK Documentation - v0.91

DebugOutputConverter.ConvertFrom Method

Converts the given object to the type of this converter, using the specified context and culture information.

Overload List

Converts the given object to the type of this converter, using the specified context and culture information.

public override object ConvertFrom(ITypeDescriptorContext,CultureInfo,object);

Inherited from TypeConverter.

public object ConvertFrom(object);

See Also

DebugOutputConverter Class | NAnt.DotNet.Types Namespace


DebugOutputConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts the given object to the type of this converter, using the specified context and culture information.

[Visual Basic]
Overrides Overloads Public Function ConvertFrom( _
ByVal context As ITypeDescriptorContext, _
ByVal culture As CultureInfo, _
ByVal value As Object _
) As Object
[C#]
public override object ConvertFrom(
ITypeDescriptorContext context,
CultureInfo culture,
object value
);

Parameters

context
An ITypeDescriptorContext that provides a format context.
culture
A CultureInfo object. If a a null reference (Nothing in Visual Basic) is passed, the current culture is assumed.
value
The Object to convert.

Return Value

An Object that represents the converted value.

See Also

DebugOutputConverter Class | NAnt.DotNet.Types Namespace | DebugOutputConverter.ConvertFrom Overload List


DelaySign Enumeration

Specifies whether the generated assembly is strongly named and will be signed later.

[Visual Basic]
<Serializable, _ TypeConverter(ConverterTypeName:="NAnt.DotNet.Types.DelaySignConverter, NAnt.DotNetTasks, Version=0.91.4312.0, Culture=neutral, PublicKeyToken=null")>
Public Enum DelaySign
[C#]
[Serializable]
[TypeConverter(ConverterTypeName="NAnt.DotNet.Types.DelaySignConverter, NAnt.DotNetTasks, Version=0.91.4312.0, Culture=neutral, PublicKeyToken=null")]
public enum DelaySign

Remarks

For backward compatibility, the following string values can also be used in build files:

Value | Corresponding field
"true" | Yes
"false" | No

Members

Member Name | Description
NotSet | Not specified.
No | Fully sign the assembly.
Yes | Only place the public key in the assembly, allowing the signature to be added later.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

NAnt.DotNet.Types Namespace


DelaySignConverter Class

Specialized EnumConverter that also supports case-insensitive conversion of "true" to Yes and "false" to No.

For a list of all members of this type, see DelaySignConverter Members.

System.Object
System.ComponentModel.TypeConverter
System.ComponentModel.EnumConverter
NAnt.DotNet.Types.DelaySignConverter

[Visual Basic]
Public Class DelaySignConverter
Inherits EnumConverter
[C#]
public class DelaySignConverter : EnumConverter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

DelaySignConverter Members | NAnt.DotNet.Types Namespace


DelaySignConverter Members

DelaySignConverter overview

Public Instance Constructors

DelaySignConverter Constructor Initializes a new instance of the DelaySignConverter class.

Public Instance Methods

CanConvertFrom (inherited from EnumConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to an enumeration object using the specified context.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from EnumConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type using the context.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type.
ConvertFrom | Overloaded. Converts the given object to the type of this converter, using the specified context and culture information.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from EnumConverter) | Overloaded. Converts the given value object to the specified destination type.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the arguments.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Re-creates an Object given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties.
GetStandardValues (inherited from EnumConverter) | Overloaded. Gets a collection of standard values for the data type this validator is designed for.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from EnumConverter) | Overloaded. Gets a value indicating whether the list of standard values returned from GetStandardValues is an exclusive list using the specified context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from EnumConverter) | Overloaded. Gets a value indicating whether this object supports a standard set of values that can be picked from a list using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from EnumConverter) | Overloaded. Gets a value indicating whether the given object value is valid for this type.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Comparer (inherited from EnumConverter) | Gets an IComparer that can be used to sort the values of the enumeration.
EnumType (inherited from EnumConverter) | Specifies the type of the enumerator this converter is associated with.
Values (inherited from EnumConverter) | Gets or sets a StandardValuesCollection that specifies the possible values for the enumeration.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

DelaySignConverter Class | NAnt.DotNet.Types Namespace


DelaySignConverter Constructor

Initializes a new instance of the DelaySignConverter class.

[Visual Basic]
Public Sub New()
[C#]
public DelaySignConverter();

See Also

DelaySignConverter Class | NAnt.DotNet.Types Namespace


DelaySignConverter Methods

The methods of the DelaySignConverter class are listed below. For a complete list of DelaySignConverter class members, see the DelaySignConverter Members topic.

Public Instance Methods

CanConvertFrom (inherited from EnumConverter) | Overloaded. Gets a value indicating whether this converter can convert an object in the given source type to an enumeration object using the specified context.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from EnumConverter) | Overloaded. Gets a value indicating whether this converter can convert an object to the given destination type using the context.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type.
ConvertFrom | Overloaded. Converts the given object to the type of this converter, using the specified context and culture information.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from EnumConverter) | Overloaded. Converts the given value object to the specified destination type.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the arguments.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Re-creates an Object given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties.
GetStandardValues (inherited from EnumConverter) | Overloaded. Gets a collection of standard values for the data type this validator is designed for.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for.
GetStandardValuesExclusive (inherited from EnumConverter) | Overloaded. Gets a value indicating whether the list of standard values returned from GetStandardValues is an exclusive list using the specified context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list.
GetStandardValuesSupported (inherited from EnumConverter) | Overloaded. Gets a value indicating whether this object supports a standard set of values that can be picked from a list using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from EnumConverter) | Overloaded. Gets a value indicating whether the given object value is valid for this type.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

DelaySignConverter Class | NAnt.DotNet.Types Namespace


ConvertFrom Method

NAnt SDK Documentation - v0.91

DelaySignConverter.ConvertFrom Method

Converts the given object to the type of this converter, using the specified context and culture information.

Overload List

Converts the given object to the type of this converter, using the specified context and culture information.

public override object ConvertFrom(ITypeDescriptorContext,CultureInfo,object);

Inherited from TypeConverter.

public object ConvertFrom(object);

See Also

DelaySignConverter Class | NAnt.DotNet.Types Namespace


DelaySignConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts the given object to the type of this converter, using the specified context and culture information.

[Visual Basic]
Overrides Overloads Public Function ConvertFrom( _
ByVal context As ITypeDescriptorContext, _
ByVal culture As CultureInfo, _
ByVal value As Object _
) As Object
[C#]
public override object ConvertFrom(
ITypeDescriptorContext context,
CultureInfo culture,
object value
);

Parameters

context
An ITypeDescriptorContext that provides a format context.
culture
A CultureInfo object. If a a null reference (Nothing in Visual Basic) is passed, the current culture is assumed.
value
The Object to convert.

Return Value

An Object that represents the converted value.

See Also

DelaySignConverter Class | NAnt.DotNet.Types Namespace | DelaySignConverter.ConvertFrom Overload List


EmbeddedResource Class

Represents an embedded resource.

For a list of all members of this type, see EmbeddedResource Members.

System.Object
NAnt.DotNet.Types.EmbeddedResource

[Visual Basic]
Public Class EmbeddedResource
[C#]
public class EmbeddedResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Do not yet expose this to build authors.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

EmbeddedResource Members | NAnt.DotNet.Types Namespace


EmbeddedResource Members

EmbeddedResource overview

Public Instance Constructors

EmbeddedResource Constructor Initializes a new instance of the EmbeddedResource with the specified file name and manifest resource name.

Public Instance Properties

File | Gets the physical location of the resource to embed.
ManifestResourceName | Gets the manifest resource name to use when embedding the resource.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmbeddedResource Class | NAnt.DotNet.Types Namespace


EmbeddedResource Constructor

Initializes a new instance of the EmbeddedResource with the specified file name and manifest resource name.

[Visual Basic]
Public Sub New( _
ByVal file As String, _
ByVal manifestResourceName As String _
)
[C#]
public EmbeddedResource(
string file,
string manifestResourceName
);

Parameters

file
The path of the compiled resource.
manifestResourceName
The manifest resource name of the embedded resource.

See Also

EmbeddedResource Class | NAnt.DotNet.Types Namespace


EmbeddedResource Properties

The properties of the EmbeddedResource class are listed below. For a complete list of EmbeddedResource class members, see the EmbeddedResource Members topic.

Public Instance Properties

File | Gets the physical location of the resource to embed.
ManifestResourceName | Gets the manifest resource name to use when embedding the resource.

See Also

EmbeddedResource Class | NAnt.DotNet.Types Namespace


File Property

NAnt SDK Documentation - v0.91

EmbeddedResource.File Property

Gets the physical location of the resource to embed.

[Visual Basic]
Public ReadOnly Property File As String
[C#]
public string File {get;}

Property Value

The physical location of the resource to embed.

See Also

EmbeddedResource Class | NAnt.DotNet.Types Namespace


ManifestResourceName Property

NAnt SDK Documentation - v0.91

EmbeddedResource.ManifestResourceName Property

Gets the manifest resource name to use when embedding the resource.

[Visual Basic]
Public ReadOnly Property ManifestResourceName As String
[C#]
public string ManifestResourceName {get;}

Property Value

The manifest resource name to use when embedding the resource.

See Also

EmbeddedResource Class | NAnt.DotNet.Types Namespace


EmbeddedResourceCollection Class

Contains a collection of EmbeddedResource items.

For a list of all members of this type, see EmbeddedResourceCollection Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.DotNet.Types.DataTypeCollectionBase
NAnt.DotNet.Types.EmbeddedResourceCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class EmbeddedResourceCollection
Inherits DataTypeCollectionBase
Implements IList
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class EmbeddedResourceCollection : DataTypeCollectionBase, IList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Do not yet expose this to build authors.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

EmbeddedResourceCollection Members | NAnt.DotNet.Types Namespace


EmbeddedResourceCollection Members

EmbeddedResourceCollection overview

Public Instance Constructors

EmbeddedResourceCollection Constructor Initializes a new instance of the EmbeddedResourceCollection class.

Public Instance Properties

CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Count (inherited from DataTypeCollectionBase) | Gets the number of items in the collection.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IsFixedSize (inherited from DataTypeCollectionBase) | Gets a value indicating whether the collection has a fixed size.
IsReadOnly (inherited from DataTypeCollectionBase) | Gets a value indicating whether the collection has a fixed size.
Item | Overloaded. Gets or sets the item at the specified index.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.

Public Instance Methods

Add | Adds a EmbeddedResource to the end of the collection.
AddRange | Adds the items of a EmbeddedResourceCollection to the end of the collection.
Clear (inherited from DataTypeCollectionBase) | Removes all items from the collection.
Contains | Determines whether a EmbeddedResource is in the collection.
CopyTo (inherited from DataTypeCollectionBase) | Overloaded. Copies the items of the collection to an Array, starting at a particular index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the location of a EmbeddedResource in the collection.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Insert | Inserts a EmbeddedResource into the collection at the specified index.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Remove | Removes the specified EmbeddedResource from the collection.
RemoveAt (inherited from DataTypeCollectionBase) | Removes an item at a specific index.
Reset (inherited from DataTypeBase) | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
ItemType | Gets the Type of the items in this collection.
List (inherited from DataTypeCollectionBase) | Gets the list of elements contained in the DataTypeCollectionBase instance.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from DataTypeBase) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RangeCheck (inherited from DataTypeCollectionBase) | Checks whether the specified index is within the range of this collection.
ValidateType (inherited from DataTypeCollectionBase) | Used by methods that take Object instances as argument to verify whether the instance is valid for the collection class.

See Also

EmbeddedResourceCollection Class | NAnt.DotNet.Types Namespace


EmbeddedResourceCollection Constructor

Initializes a new instance of the EmbeddedResourceCollection class.

[Visual Basic]
Public Sub New()
[C#]
public EmbeddedResourceCollection();

See Also

EmbeddedResourceCollection Class | NAnt.DotNet.Types Namespace


EmbeddedResourceCollection Properties

The properties of the EmbeddedResourceCollection class are listed below. For a complete list of EmbeddedResourceCollection class members, see the EmbeddedResourceCollection Members topic.

Public Instance Properties

CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Count (inherited from DataTypeCollectionBase) | Gets the number of items in the collection.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IsFixedSize (inherited from DataTypeCollectionBase) | Gets a value indicating whether the collection has a fixed size.
IsReadOnly (inherited from DataTypeCollectionBase) | Gets a value indicating whether the collection has a fixed size.
Item | Overloaded. Gets or sets the item at the specified index.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
ItemType | Gets the Type of the items in this collection.
List (inherited from DataTypeCollectionBase) | Gets the list of elements contained in the DataTypeCollectionBase instance.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

EmbeddedResourceCollection Class | NAnt.DotNet.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

EmbeddedResourceCollection.Item Property

Gets or sets the item at the specified index.

Overload List

Gets or sets the item at the specified index.

public EmbeddedResource this[int] {get; set;}

Gets the EmbeddedResource with the specified manifest resource name.

public EmbeddedResource this[string] {get;}

See Also

EmbeddedResourceCollection Class | NAnt.DotNet.Types Namespace


Item Property (Int32)

NAnt SDK Documentation - v0.91

EmbeddedResourceCollection.Item Property (Int32)

Gets or sets the item at the specified index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As EmbeddedResource
[C#]
public EmbeddedResource this[
int index
] {get; set;}

Parameters

index
The zero-based index of the item to get or set.

See Also

EmbeddedResourceCollection Class | NAnt.DotNet.Types Namespace | EmbeddedResourceCollection.Item Overload List


Item Property (String)

NAnt SDK Documentation - v0.91

EmbeddedResourceCollection.Item Property (String)

Gets the EmbeddedResource with the specified manifest resource name.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal value As String _
) As EmbeddedResource
[C#]
public EmbeddedResource this[
string value
] {get;}

Parameters

value
The manifest resource name of the EmbeddedResource to get.

See Also

EmbeddedResourceCollection Class | NAnt.DotNet.Types Namespace | EmbeddedResourceCollection.Item Overload List


ItemType Property

NAnt SDK Documentation - v0.91

EmbeddedResourceCollection.ItemType Property

Gets the Type of the items in this collection.

[Visual Basic]
Overrides Protected ReadOnly Property ItemType As Type
[C#]
protected override System.Type ItemType {get;}

Property Value

The Type of the items in this collection.

See Also

EmbeddedResourceCollection Class | NAnt.DotNet.Types Namespace


EmbeddedResourceCollection Methods

The methods of the EmbeddedResourceCollection class are listed below. For a complete list of EmbeddedResourceCollection class members, see the EmbeddedResourceCollection Members topic.

Public Instance Methods

Add | Adds a EmbeddedResource to the end of the collection.
AddRange | Adds the items of a EmbeddedResourceCollection to the end of the collection.
Clear (inherited from DataTypeCollectionBase) | Removes all items from the collection.
Contains | Determines whether a EmbeddedResource is in the collection.
CopyTo (inherited from DataTypeCollectionBase) | Overloaded. Copies the items of the collection to an Array, starting at a particular index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the location of a EmbeddedResource in the collection.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Insert | Inserts a EmbeddedResource into the collection at the specified index.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Remove | Removes the specified EmbeddedResource from the collection.
RemoveAt (inherited from DataTypeCollectionBase) | Removes an item at a specific index.
Reset (inherited from DataTypeBase) | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from DataTypeBase) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RangeCheck (inherited from DataTypeCollectionBase) | Checks whether the specified index is within the range of this collection.
ValidateType (inherited from DataTypeCollectionBase) | Used by methods that take Object instances as argument to verify whether the instance is valid for the collection class.

See Also

EmbeddedResourceCollection Class | NAnt.DotNet.Types Namespace


EmbeddedResourceCollection.Add Method

Adds a EmbeddedResource to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal value As EmbeddedResource _
) As Integer
[C#]
public int Add(
EmbeddedResource value
);

Parameters

value
The EmbeddedResource to be added to the end of the collection.

Return Value

The position into which the new item was inserted.

See Also

EmbeddedResourceCollection Class | NAnt.DotNet.Types Namespace


EmbeddedResourceCollection.AddRange Method

Adds the items of a EmbeddedResourceCollection to the end of the collection.

[Visual Basic]
Public Sub AddRange( _
ByVal items As EmbeddedResourceCollection _
)
[C#]
public void AddRange(
EmbeddedResourceCollection items
);

Parameters

items
The EmbeddedResourceCollection to be added to the end of the collection.

See Also

EmbeddedResourceCollection Class | NAnt.DotNet.Types Namespace


EmbeddedResourceCollection.Contains Method

Determines whether a EmbeddedResource is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal value As EmbeddedResource _
) As Boolean
[C#]
public bool Contains(
EmbeddedResource value
);

Parameters

value
The EmbeddedResource to locate in the collection.

Return Value

true if value is found in the collection; otherwise, false.

See Also

EmbeddedResourceCollection Class | NAnt.DotNet.Types Namespace


EmbeddedResourceCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As EmbeddedResourceEnumerator
[C#]
public EmbeddedResourceEnumerator GetEnumerator();

Return Value

A EmbeddedResourceEnumerator for the entire collection.

See Also

EmbeddedResourceCollection Class | NAnt.DotNet.Types Namespace


EmbeddedResourceCollection.IndexOf Method

Gets the location of a EmbeddedResource in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal value As EmbeddedResource _
) As Integer
[C#]
public int IndexOf(
EmbeddedResource value
);

Parameters

value
The EmbeddedResource object to locate.

Return Value

The zero-based location of the EmbeddedResource in the collection.

Remarks

If the EmbeddedResource is not currently a member of the collection, -1 is returned.

See Also

EmbeddedResourceCollection Class | NAnt.DotNet.Types Namespace


EmbeddedResourceCollection.Insert Method

Inserts a EmbeddedResource into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal value As EmbeddedResource _
)
[C#]
public void Insert(
int index,
EmbeddedResource value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The EmbeddedResource to insert.

See Also

EmbeddedResourceCollection Class | NAnt.DotNet.Types Namespace


EmbeddedResourceCollection.Remove Method

Removes the specified EmbeddedResource from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal value As EmbeddedResource _
)
[C#]
public void Remove(
EmbeddedResource value
);

Parameters

value
The EmbeddedResource to remove from the collection.

See Also

EmbeddedResourceCollection Class | NAnt.DotNet.Types Namespace


EmbeddedResourceEnumerator Class

Enumerates the EmbeddedResource items of a EmbeddedResourceCollection.

For a list of all members of this type, see EmbeddedResourceEnumerator Members.

System.Object
NAnt.DotNet.Types.EmbeddedResourceEnumerator

[Visual Basic]
Public Class EmbeddedResourceEnumerator
Implements IEnumerator
[C#]
public class EmbeddedResourceEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

EmbeddedResourceEnumerator Members | NAnt.DotNet.Types Namespace


EmbeddedResourceEnumerator Members

EmbeddedResourceEnumerator overview

Public Instance Properties

Current Gets the current item in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next item of the collection.
Reset | Sets the enumerator to its initial position, which is before the first item in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmbeddedResourceEnumerator Class | NAnt.DotNet.Types Namespace


EmbeddedResourceEnumerator Properties

The properties of the EmbeddedResourceEnumerator class are listed below. For a complete list of EmbeddedResourceEnumerator class members, see the EmbeddedResourceEnumerator Members topic.

Public Instance Properties

Current Gets the current item in the collection.

See Also

EmbeddedResourceEnumerator Class | NAnt.DotNet.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

EmbeddedResourceEnumerator.Current Property

Gets the current item in the collection.

[Visual Basic]
Public ReadOnly Property Current As EmbeddedResource
[C#]
public EmbeddedResource Current {get;}

See Also

EmbeddedResourceEnumerator Class | NAnt.DotNet.Types Namespace


EmbeddedResourceEnumerator Methods

The methods of the EmbeddedResourceEnumerator class are listed below. For a complete list of EmbeddedResourceEnumerator class members, see the EmbeddedResourceEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next item of the collection.
Reset | Sets the enumerator to its initial position, which is before the first item in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmbeddedResourceEnumerator Class | NAnt.DotNet.Types Namespace


EmbeddedResourceEnumerator.MoveNext Method

Advances the enumerator to the next item of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next item; false if the enumerator has passed the end of the collection.

See Also

EmbeddedResourceEnumerator Class | NAnt.DotNet.Types Namespace


EmbeddedResourceEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first item in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

EmbeddedResourceEnumerator Class | NAnt.DotNet.Types Namespace


LibDirectorySet Class

A specialized FileSet used for setting the lib directories.

For a list of all members of this type, see LibDirectorySet Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.Core.Types.FileSet
NAnt.DotNet.Types.LibDirectorySet

[Visual Basic]
<Serializable, _ Serializable>
Public Class LibDirectorySet
Inherits FileSet
[C#]
[Serializable]
[Serializable]
public class LibDirectorySet : FileSet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The primary reason for this class is to allow the BaseDirectory to always be the same value as the parent AssemblyFileSet

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

LibDirectorySet Members | NAnt.DotNet.Types Namespace | FileSet


LibDirectorySet Members

LibDirectorySet overview

Public Instance Constructors

LibDirectorySet Constructor Initializes a new instance of the LibDirectorySet class.

Public Instance Properties

AsIs (inherited from FileSet) | Gets the collection of files that will be added to the FileSet without pattern matching or checking if the file exists.
BaseDirectory | override this. We will always use the base directory of the parent. overriding without the TaskAttribute attribute prevents it being set in the source xml
CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
CaseSensitive (inherited from FileSet) | Indicates whether include and exclude patterns must be treated in a case-sensitive way. The default is true on Unix; otherwise, false.
DefaultExcludes (inherited from FileSet) | Indicates whether default excludes should be used or not. The default is true.
DirectoryNames (inherited from FileSet) | Gets the collection of directory names that match the fileset.
ExcludeElements (inherited from FileSet) | The items to exclude from the fileset.
Excludes (inherited from FileSet) | Gets the collection of exclude patterns.
ExcludesFiles (inherited from FileSet) | The files from which a list of patterns or files to exclude should be obtained.
FailOnEmpty (inherited from FileSet) | When set to true, causes the fileset element to throw a ValidationException when no files match the includes and excludes criteria. The default is false.
FileNames (inherited from FileSet) | Gets the collection of file names that match the fileset.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IncludeElements (inherited from FileSet) | The items to include in the fileset.
Includes (inherited from FileSet) | Gets the collection of include patterns.
IncludesFiles (inherited from FileSet) | The files from which a list of patterns or files to include should be obtained.
MostRecentLastWriteTimeFile (inherited from FileSet) | Determines the most recently modified file in the fileset (by LastWriteTime of the FileInfo).
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PathFiles (inherited from FileSet) |
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.
ScannedDirectories (inherited from FileSet) | Gets the collection of directory names that were scanned for files.
SetExcludes (inherited from FileSet) | Obsolete. The items to exclude from the fileset.
SetIncludes (inherited from FileSet) | Obsolete. The items to include in the fileset.
SetIncludesList (inherited from FileSet) | Obsolete. The files from which a list of patterns or files to include should be obtained.

Public Instance Methods

AddPatternSet (inherited from FileSet) | Adds a nested set of patterns, or references a standalone patternset.
Clone (inherited from FileSet) | Creates a shallow copy of the FileSet.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from FileSet) |
Scan (inherited from FileSet) |
ToString (inherited from FileSet) |

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from FileSet) | Overloaded. Copies all instance data of the FileSet to a given FileSet.
CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from FileSet) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LibDirectorySet Class | NAnt.DotNet.Types Namespace | FileSet


LibDirectorySet Constructor

Initializes a new instance of the LibDirectorySet class.

[Visual Basic]
Public Sub New( _
ByVal parent As AssemblyFileSet _
)
[C#]
public LibDirectorySet(
AssemblyFileSet parent
);

Parameters

parent

See Also

LibDirectorySet Class | NAnt.DotNet.Types Namespace


LibDirectorySet Properties

The properties of the LibDirectorySet class are listed below. For a complete list of LibDirectorySet class members, see the LibDirectorySet Members topic.

Public Instance Properties

AsIs (inherited from FileSet) | Gets the collection of files that will be added to the FileSet without pattern matching or checking if the file exists.
BaseDirectory | override this. We will always use the base directory of the parent. overriding without the TaskAttribute attribute prevents it being set in the source xml
CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
CaseSensitive (inherited from FileSet) | Indicates whether include and exclude patterns must be treated in a case-sensitive way. The default is true on Unix; otherwise, false.
DefaultExcludes (inherited from FileSet) | Indicates whether default excludes should be used or not. The default is true.
DirectoryNames (inherited from FileSet) | Gets the collection of directory names that match the fileset.
ExcludeElements (inherited from FileSet) | The items to exclude from the fileset.
Excludes (inherited from FileSet) | Gets the collection of exclude patterns.
ExcludesFiles (inherited from FileSet) | The files from which a list of patterns or files to exclude should be obtained.
FailOnEmpty (inherited from FileSet) | When set to true, causes the fileset element to throw a ValidationException when no files match the includes and excludes criteria. The default is false.
FileNames (inherited from FileSet) | Gets the collection of file names that match the fileset.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IncludeElements (inherited from FileSet) | The items to include in the fileset.
Includes (inherited from FileSet) | Gets the collection of include patterns.
IncludesFiles (inherited from FileSet) | The files from which a list of patterns or files to include should be obtained.
MostRecentLastWriteTimeFile (inherited from FileSet) | Determines the most recently modified file in the fileset (by LastWriteTime of the FileInfo).
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PathFiles (inherited from FileSet) |
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.
ScannedDirectories (inherited from FileSet) | Gets the collection of directory names that were scanned for files.
SetExcludes (inherited from FileSet) | Obsolete. The items to exclude from the fileset.
SetIncludes (inherited from FileSet) | Obsolete. The items to include in the fileset.
SetIncludesList (inherited from FileSet) | Obsolete. The files from which a list of patterns or files to include should be obtained.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

LibDirectorySet Class | NAnt.DotNet.Types Namespace | FileSet


BaseDirectory Property

NAnt SDK Documentation - v0.91

LibDirectorySet.BaseDirectory Property

override this. We will always use the base directory of the parent. overriding without the TaskAttribute attribute prevents it being set in the source xml

[Visual Basic]
Overrides Public ReadOnly Property BaseDirectory As DirectoryInfo
[C#]
public override System.IO.DirectoryInfo BaseDirectory {get;}

See Also

LibDirectorySet Class | NAnt.DotNet.Types Namespace


Module Class

Represents a metadata file without assembly manifest.

For a list of all members of this type, see Module Members.

System.Object
NAnt.Core.Element
NAnt.DotNet.Types.Module

[Visual Basic]
<Serializable, _ Serializable>
Public Class Module
Inherits Element
[C#]
[Serializable]
[Serializable]
public class Module : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

Module Members | NAnt.DotNet.Types Namespace


Module Members

Module overview

Public Instance Constructors

Module Constructor Initializes a new instance of the Module class.

Public Instance Properties

File | The path of the module.
ModuleSet | Gets or sets the ModuleSet that contains the module.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Target | File name where the module should be copied to before it is compiled into an assembly.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString | Returns a textual representation of the module, which can be used as argument for command-line tools.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Module Class | NAnt.DotNet.Types Namespace


Module Constructor

Initializes a new instance of the Module class.

[Visual Basic]
Public Sub New()
[C#]
public Module();

See Also

Module Class | NAnt.DotNet.Types Namespace


Module Properties

The properties of the Module class are listed below. For a complete list of Module class members, see the Module Members topic.

Public Instance Properties

File | The path of the module.
ModuleSet | Gets or sets the ModuleSet that contains the module.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Target | File name where the module should be copied to before it is compiled into an assembly.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

Module Class | NAnt.DotNet.Types Namespace


File Property

NAnt SDK Documentation - v0.91

Module.File Property

The path of the module.

[Visual Basic]
<TaskAttribute(Name:="file", Required:=True, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property File As String
[C#]
[TaskAttribute(Name="file", Required=True, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string File {get; set;}

See Also

Module Class | NAnt.DotNet.Types Namespace


ModuleSet Property

NAnt SDK Documentation - v0.91

Module.ModuleSet Property

Gets or sets the ModuleSet that contains the module.

[Visual Basic]
Public Property ModuleSet As ModuleSet
[C#]
public ModuleSet ModuleSet {get; set;}

See Also

Module Class | NAnt.DotNet.Types Namespace


Target Property

NAnt SDK Documentation - v0.91

Module.Target Property

File name where the module should be copied to before it is compiled into an assembly.

[Visual Basic]
<TaskAttribute(Name:="target", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Target As String
[C#]
[TaskAttribute(Name="target", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Target {get; set;}

See Also

Module Class | NAnt.DotNet.Types Namespace


Module Methods

The methods of the Module class are listed below. For a complete list of Module class members, see the Module Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString | Returns a textual representation of the module, which can be used as argument for command-line tools.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Module Class | NAnt.DotNet.Types Namespace


Module.ToString Method

Returns a textual representation of the module, which can be used as argument for command-line tools.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

A textual representation of the path, file[,target].

See Also

Module Class | NAnt.DotNet.Types Namespace


ModuleCollection Class

Contains a collection of Module items.

For a list of all members of this type, see ModuleCollection Members.

System.Object
NAnt.DotNet.Types.ModuleCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class ModuleCollection
Implements IList, ICollection, IEnumerable
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class ModuleCollection : IList, ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Do not yet expose this to build authors.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

ModuleCollection Members | NAnt.DotNet.Types Namespace


ModuleCollection Members

ModuleCollection overview

Public Instance Constructors

ModuleCollection Constructor Initializes a new instance of the ModuleCollection for the specified ModuleSet.

Public Instance Properties

Count | Gets the number of items in the collection.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | Gets a value indicating whether the collection has a fixed size.
Item | Gets or sets the item at the specified index.

Public Instance Methods

Add | Adds a Module to the end of the collection.
AddRange | Adds the items of a ModuleCollection to the end of the collection.
Clear | Removes all items from the collection.
Contains | Determines whether a Module is in the collection.
CopyTo | Copies the items of the collection to an Array, starting at a particular index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the location of a Module in the collection.
Insert | Inserts a Module into the collection at the specified index.
Remove | Removes the specified Module from the collection.
RemoveAt | Removes an item at a specific index.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

List Gets the list of elements contained in the ModuleCollection instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ModuleCollection Class | NAnt.DotNet.Types Namespace


ModuleCollection Constructor

Initializes a new instance of the ModuleCollection for the specified ModuleSet.

[Visual Basic]
Public Sub New( _
ByVal moduleSet As ModuleSet _
)
[C#]
public ModuleCollection(
ModuleSet moduleSet
);

Parameters

moduleSet
The ModuleSet containing the collection.

Exceptions

Exception Type | Condition
ArgumentNullException | moduleSet is true.

See Also

ModuleCollection Class | NAnt.DotNet.Types Namespace


ModuleCollection Properties

The properties of the ModuleCollection class are listed below. For a complete list of ModuleCollection class members, see the ModuleCollection Members topic.

Public Instance Properties

Count | Gets the number of items in the collection.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | Gets a value indicating whether the collection has a fixed size.
Item | Gets or sets the item at the specified index.

Protected Instance Properties

List Gets the list of elements contained in the ModuleCollection instance.

See Also

ModuleCollection Class | NAnt.DotNet.Types Namespace


Count Property

NAnt SDK Documentation - v0.91

ModuleCollection.Count Property

Gets the number of items in the collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Property Value

The number of items in the collection.

Implements

ICollection.Count

See Also

ModuleCollection Class | NAnt.DotNet.Types Namespace


IsFixedSize Property

NAnt SDK Documentation - v0.91

ModuleCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

[Visual Basic]
NotOverridable Public ReadOnly Property IsFixedSize As Boolean _
Implements IList.IsFixedSize
[C#]
public bool IsFixedSize {get;}

Property Value

false.

Implements

IList.IsFixedSize

See Also

ModuleCollection Class | NAnt.DotNet.Types Namespace


IsReadOnly Property

NAnt SDK Documentation - v0.91

ModuleCollection.IsReadOnly Property

Gets a value indicating whether the collection has a fixed size.

[Visual Basic]
NotOverridable Public ReadOnly Property IsReadOnly As Boolean _
Implements IList.IsReadOnly
[C#]
public bool IsReadOnly {get;}

Property Value

false.

Implements

IList.IsReadOnly

See Also

ModuleCollection Class | NAnt.DotNet.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

ModuleCollection.Item Property

Gets or sets the item at the specified index.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As Module
[C#]
public Module this[
int index
] {get; set;}

Parameters

index
The zero-based index of the item to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | The index parameter is less than 0 or greater than or equal to the value of the Count property of the ModuleCollection.

See Also

ModuleCollection Class | NAnt.DotNet.Types Namespace


List Property

NAnt SDK Documentation - v0.91

ModuleCollection.List Property

Gets the list of elements contained in the ModuleCollection instance.

[Visual Basic]
Protected ReadOnly Property List As ArrayList
[C#]
protected System.Collections.ArrayList List {get;}

Property Value

An ArrayList containing the elements of the collection.

See Also

ModuleCollection Class | NAnt.DotNet.Types Namespace


ModuleCollection Methods

The methods of the ModuleCollection class are listed below. For a complete list of ModuleCollection class members, see the ModuleCollection Members topic.

Public Instance Methods

Add | Adds a Module to the end of the collection.
AddRange | Adds the items of a ModuleCollection to the end of the collection.
Clear | Removes all items from the collection.
Contains | Determines whether a Module is in the collection.
CopyTo | Copies the items of the collection to an Array, starting at a particular index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the location of a Module in the collection.
Insert | Inserts a Module into the collection at the specified index.
Remove | Removes the specified Module from the collection.
RemoveAt | Removes an item at a specific index.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ModuleCollection Class | NAnt.DotNet.Types Namespace


ModuleCollection.Add Method

Adds a Module to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal value As Module _
) As Integer
[C#]
public int Add(
Module value
);

Parameters

value
The Module to be added to the end of the collection.

Return Value

The position into which the new item was inserted.

See Also

ModuleCollection Class | NAnt.DotNet.Types Namespace


ModuleCollection.AddRange Method

Adds the items of a ModuleCollection to the end of the collection.

[Visual Basic]
Public Sub AddRange( _
ByVal items As ModuleCollection _
)
[C#]
public void AddRange(
ModuleCollection items
);

Parameters

items
The ModuleCollection to be added to the end of the collection.

See Also

ModuleCollection Class | NAnt.DotNet.Types Namespace


ModuleCollection.Clear Method

Removes all items from the collection.

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements IList.Clear
[C#]
public void Clear();

Implements

IList.Clear

See Also

ModuleCollection Class | NAnt.DotNet.Types Namespace


ModuleCollection.Contains Method

Determines whether a Module is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal value As Module _
) As Boolean
[C#]
public bool Contains(
Module value
);

Parameters

value
The Module to locate in the collection.

Return Value

true if value is found in the collection; otherwise, false.

See Also

ModuleCollection Class | NAnt.DotNet.Types Namespace


ModuleCollection.CopyTo Method

Copies the items of the collection to an Array, starting at a particular index.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);

Parameters

array
The one-dimensional Array that is the destination of the items copied from the collection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Implements

ICollection.CopyTo

See Also

ModuleCollection Class | NAnt.DotNet.Types Namespace


ModuleCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As ModuleEnumerator
[C#]
public ModuleEnumerator GetEnumerator();

Return Value

A ModuleEnumerator for the entire collection.

See Also

ModuleCollection Class | NAnt.DotNet.Types Namespace


ModuleCollection.IndexOf Method

Gets the location of a Module in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal value As Module _
) As Integer
[C#]
public int IndexOf(
Module value
);

Parameters

value
The Module object to locate.

Return Value

The zero-based location of the Module in the collection.

Remarks

If the Module is not currently a member of the collection, -1 is returned.

See Also

ModuleCollection Class | NAnt.DotNet.Types Namespace


ModuleCollection.Insert Method

Inserts a Module into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal value As Module _
)
[C#]
public void Insert(
int index,
Module value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The Module to insert.

See Also

ModuleCollection Class | NAnt.DotNet.Types Namespace


ModuleCollection.Remove Method

Removes the specified Module from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal value As Module _
)
[C#]
public void Remove(
Module value
);

Parameters

value
The Module to remove from the collection.

See Also

ModuleCollection Class | NAnt.DotNet.Types Namespace


ModuleCollection.RemoveAt Method

Removes an item at a specific index.

[Visual Basic]
NotOverridable Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements IList.RemoveAt
[C#]
public void RemoveAt(
int index
);

Parameters

index
The zero-based index of the item to remove.

Implements

IList.RemoveAt

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | The index parameter is less than 0 or greater than or equal to the value of the Count property of the ModuleCollection.

See Also

ModuleCollection Class | NAnt.DotNet.Types Namespace


ModuleEnumerator Class

Enumerates the Module items of a ModuleCollection.

For a list of all members of this type, see ModuleEnumerator Members.

System.Object
NAnt.DotNet.Types.ModuleEnumerator

[Visual Basic]
Public Class ModuleEnumerator
Implements IEnumerator
[C#]
public class ModuleEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

ModuleEnumerator Members | NAnt.DotNet.Types Namespace


ModuleEnumerator Members

ModuleEnumerator overview

Public Instance Properties

Current Gets the current item in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next item of the collection.
Reset | Sets the enumerator to its initial position, which is before the first item in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ModuleEnumerator Class | NAnt.DotNet.Types Namespace


ModuleEnumerator Properties

The properties of the ModuleEnumerator class are listed below. For a complete list of ModuleEnumerator class members, see the ModuleEnumerator Members topic.

Public Instance Properties

Current Gets the current item in the collection.

See Also

ModuleEnumerator Class | NAnt.DotNet.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

ModuleEnumerator.Current Property

Gets the current item in the collection.

[Visual Basic]
Public ReadOnly Property Current As Module
[C#]
public Module Current {get;}

See Also

ModuleEnumerator Class | NAnt.DotNet.Types Namespace


ModuleEnumerator Methods

The methods of the ModuleEnumerator class are listed below. For a complete list of ModuleEnumerator class members, see the ModuleEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next item of the collection.
Reset | Sets the enumerator to its initial position, which is before the first item in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ModuleEnumerator Class | NAnt.DotNet.Types Namespace


ModuleEnumerator.MoveNext Method

Advances the enumerator to the next item of the collection.

[Visual Basic]
NotOverridable Public Function MoveNext() As Boolean _
Implements IEnumerator.MoveNext
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next item; false if the enumerator has passed the end of the collection.

Implements

IEnumerator.MoveNext

See Also

ModuleEnumerator Class | NAnt.DotNet.Types Namespace


ModuleEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first item in the collection.

[Visual Basic]
NotOverridable Public Sub Reset() _
Implements IEnumerator.Reset
[C#]
public void Reset();

Implements

IEnumerator.Reset

See Also

ModuleEnumerator Class | NAnt.DotNet.Types Namespace


ModuleSet Class

One or more modules to compile into an assembly.

For a list of all members of this type, see ModuleSet Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.DotNet.Types.ModuleSet

[Visual Basic]
<Serializable, _ Serializable, _ ElementName(Name:="moduleset")>
Public Class ModuleSet
Inherits DataTypeBase
[C#]
[Serializable]
[Serializable]
[ElementName(Name="moduleset")]
public class ModuleSet : DataTypeBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Define a global <moduleset> that can be referenced by other tasks or types.

                    <moduleset id="client-modules" dir="${build}">
                        <module file="Client.netmodule" />
                        <module file="Common.netmodule" />
                    </moduleset>

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

ModuleSet Members | NAnt.DotNet.Types Namespace


ModuleSet Members

ModuleSet overview

Public Instance Constructors

ModuleSet Constructor Initializes a new instance of the ModuleSet class.

Public Instance Properties

CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Dir | The base of the directory of this ModuleSet. The default is the project base directory.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
Modules | The modules to add to this ModuleSet.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from DataTypeBase) | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from DataTypeBase) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ModuleSet Class | NAnt.DotNet.Types Namespace


ModuleSet Constructor

Initializes a new instance of the ModuleSet class.

[Visual Basic]
Public Sub New()
[C#]
public ModuleSet();

See Also

ModuleSet Class | NAnt.DotNet.Types Namespace


ModuleSet Properties

The properties of the ModuleSet class are listed below. For a complete list of ModuleSet class members, see the ModuleSet Members topic.

Public Instance Properties

CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Dir | The base of the directory of this ModuleSet. The default is the project base directory.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
Modules | The modules to add to this ModuleSet.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

ModuleSet Class | NAnt.DotNet.Types Namespace


Dir Property

NAnt SDK Documentation - v0.91

ModuleSet.Dir Property

The base of the directory of this ModuleSet. The default is the project base directory.

[Visual Basic]
<TaskAttribute(Name:="dir", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Dir As DirectoryInfo
[C#]
[TaskAttribute(Name="dir", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.DirectoryInfo Dir {get; set;}

See Also

ModuleSet Class | NAnt.DotNet.Types Namespace


Modules Property

NAnt SDK Documentation - v0.91

ModuleSet.Modules Property

The modules to add to this ModuleSet.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="module", Required:=False, ProcessXml:=True)>
Public ReadOnly Property Modules As ModuleCollection
[C#]
[BuildElementArray(ElementType=null, Name="module", Required=False, ProcessXml=True)]
public ModuleCollection Modules {get;}

See Also

ModuleSet Class | NAnt.DotNet.Types Namespace


NamespaceImport Class

Represents a namespace to import.

For a list of all members of this type, see NamespaceImport Members.

System.Object
NAnt.Core.Element
NAnt.DotNet.Types.NamespaceImport

[Visual Basic]
<Serializable, _ Serializable, _ ElementName(Name:="import")>
Public Class NamespaceImport
Inherits Element
[C#]
[Serializable]
[Serializable]
[ElementName(Name="import")]
public class NamespaceImport : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

NamespaceImport Members | NAnt.DotNet.Types Namespace


NamespaceImport Members

NamespaceImport overview

Public Instance Constructors

NamespaceImport Overloaded. Initializes a new instance of the NamespaceImport class.

Public Instance Properties

IfDefined | Indicates if the import should be generated.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
Namespace | The name of the namespace to import.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
TempName | Obsolete. The name of the namespace to import.
UnlessDefined | Indicates if the import should be not generated.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NamespaceImport Class | NAnt.DotNet.Types Namespace


NamespaceImport Constructor

Initializes a new instance of the NamespaceImport class.

Overload List

Initializes a new instance of the NamespaceImport class.

public NamespaceImport();

Initializes a new instance of the NamespaceImport class for the specified namespace.

public NamespaceImport(string);

See Also

NamespaceImport Class | NAnt.DotNet.Types Namespace


NamespaceImport Constructor ()

Initializes a new instance of the NamespaceImport class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public NamespaceImport();

See Also

NamespaceImport Class | NAnt.DotNet.Types Namespace | NamespaceImport Constructor Overload List


NamespaceImport Constructor (String)

Initializes a new instance of the NamespaceImport class for the specified namespace.

[Visual Basic]
Overloads Public Sub New( _
ByVal nameSpace As String _
)
[C#]
public NamespaceImport(
string nameSpace
);

Parameters

nameSpace
The namespace.

Exceptions

Exception Type | Condition
ArgumentNullException | nameSpace is a null reference (Nothing in Visual Basic).

See Also

NamespaceImport Class | NAnt.DotNet.Types Namespace | NamespaceImport Constructor Overload List


NamespaceImport Properties

The properties of the NamespaceImport class are listed below. For a complete list of NamespaceImport class members, see the NamespaceImport Members topic.

Public Instance Properties

IfDefined | Indicates if the import should be generated.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
Namespace | The name of the namespace to import.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
TempName | Obsolete. The name of the namespace to import.
UnlessDefined | Indicates if the import should be not generated.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

NamespaceImport Class | NAnt.DotNet.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

NamespaceImport.IfDefined Property

Indicates if the import should be generated.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="if", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property IfDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="if", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool IfDefined {get; set;}

Property Value

true if the import should be generated; otherwise, false.

See Also

NamespaceImport Class | NAnt.DotNet.Types Namespace


Namespace Property

NAnt SDK Documentation - v0.91

NamespaceImport.Namespace Property

The name of the namespace to import.

[Visual Basic]
<TaskAttribute(Name:="namespace", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property Namespace As String
[C#]
[TaskAttribute(Name="namespace", Required=False, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string Namespace {get; set;}

Property Value

The name of the namespace to import.

See Also

NamespaceImport Class | NAnt.DotNet.Types Namespace


TempName Property

NAnt SDK Documentation - v0.91

NamespaceImport.TempName Property

NOTE: This property is now obsolete.

Use "namespace" attribute instead.

The name of the namespace to import.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _
 Obsolete(Message:="Use "namespace" attribute instead.", IsError:=False), _
 TaskAttribute(Name:="name", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property TempName As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[Obsolete(Message="Use "namespace" attribute instead.", IsError=False)]
[TaskAttribute(Name="name", Required=False, ExpandProperties=True, ProcessXml=True)]
public string TempName {get; set;}

Property Value

The name of the namespace to import.

See Also

NamespaceImport Class | NAnt.DotNet.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

NamespaceImport.UnlessDefined Property

Indicates if the import should be not generated.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="unless", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property UnlessDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="unless", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool UnlessDefined {get; set;}

Property Value

true if the import should be not generated; otherwise, false.

See Also

NamespaceImport Class | NAnt.DotNet.Types Namespace


NamespaceImportCollection Class

Contains a collection of NamespaceImport items.

For a list of all members of this type, see NamespaceImportCollection Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.DotNet.Types.DataTypeCollectionBase
NAnt.DotNet.Types.NamespaceImportCollection

[Visual Basic]
<Serializable, _ Serializable, _ ElementName(Name:="namespaceimports"), _ DefaultMember(MemberName:="Item")>
Public Class NamespaceImportCollection
Inherits DataTypeCollectionBase
Implements IList
[C#]
[Serializable]
[Serializable]
[ElementName(Name="namespaceimports")]
[DefaultMember(MemberName="Item")]
public class NamespaceImportCollection : DataTypeCollectionBase, IList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Define a reference with name "system.imports".

<namespaceimports id="system.imports">
    <import namespace="System" />
    <import namespace="System.Data" />
</namespaceimports>

Use the predefined set of imports to compile a VB.NET assembly.

<vbc target="exe" output="HelloWorld.exe" rootnamespace="HelloWorld">
    <imports refid="system.imports" />
    <sources>
        <include name="**/*.vb" />
    </sources>
    <references>
        <include name="System.dll" />
        <include name="System.Data.dll" />
    </references>
</vbc>

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

NamespaceImportCollection Members | NAnt.DotNet.Types Namespace


NamespaceImportCollection Members

NamespaceImportCollection overview

Public Instance Constructors

NamespaceImportCollection Constructor Initializes a new instance of the NamespaceImportCollection class.

Public Instance Properties

CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Count (inherited from DataTypeCollectionBase) | Gets the number of items in the collection.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IsFixedSize (inherited from DataTypeCollectionBase) | Gets a value indicating whether the collection has a fixed size.
IsReadOnly (inherited from DataTypeCollectionBase) | Gets a value indicating whether the collection has a fixed size.
Item | Overloaded. Gets or sets the item at the specified index.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.

Public Instance Methods

Add | Adds a NamespaceImport to the end of the collection.
AddRange | Adds the items of a NamespaceImportCollection to the end of the collection.
Clear (inherited from DataTypeCollectionBase) | Removes all items from the collection.
Contains | Determines whether a NamespaceImport is in the collection.
CopyTo (inherited from DataTypeCollectionBase) | Overloaded. Copies the items of the collection to an Array, starting at a particular index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the location of a NamespaceImport in the collection.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Insert | Inserts a NamespaceImport into the collection at the specified index.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Remove | Removes the specified NamespaceImport from the collection.
RemoveAt (inherited from DataTypeCollectionBase) | Removes an item at a specific index.
Reset (inherited from DataTypeBase) | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString | Returns a comma-delimited list of namespace imports.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
ItemType | Gets the Type of the items in this collection.
List (inherited from DataTypeCollectionBase) | Gets the list of elements contained in the DataTypeCollectionBase instance.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from DataTypeBase) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RangeCheck (inherited from DataTypeCollectionBase) | Checks whether the specified index is within the range of this collection.
ValidateType (inherited from DataTypeCollectionBase) | Used by methods that take Object instances as argument to verify whether the instance is valid for the collection class.

See Also

NamespaceImportCollection Class | NAnt.DotNet.Types Namespace


NamespaceImportCollection Constructor

Initializes a new instance of the NamespaceImportCollection class.

[Visual Basic]
Public Sub New()
[C#]
public NamespaceImportCollection();

See Also

NamespaceImportCollection Class | NAnt.DotNet.Types Namespace


NamespaceImportCollection Properties

The properties of the NamespaceImportCollection class are listed below. For a complete list of NamespaceImportCollection class members, see the NamespaceImportCollection Members topic.

Public Instance Properties

CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Count (inherited from DataTypeCollectionBase) | Gets the number of items in the collection.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IsFixedSize (inherited from DataTypeCollectionBase) | Gets a value indicating whether the collection has a fixed size.
IsReadOnly (inherited from DataTypeCollectionBase) | Gets a value indicating whether the collection has a fixed size.
Item | Overloaded. Gets or sets the item at the specified index.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
ItemType | Gets the Type of the items in this collection.
List (inherited from DataTypeCollectionBase) | Gets the list of elements contained in the DataTypeCollectionBase instance.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

NamespaceImportCollection Class | NAnt.DotNet.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

NamespaceImportCollection.Item Property

Gets or sets the item at the specified index.

Overload List

Gets or sets the item at the specified index.

public NamespaceImport this[int] {get; set;}

Gets the NamespaceImport with the specified namespace.

public NamespaceImport this[string] {get;}

See Also

NamespaceImportCollection Class | NAnt.DotNet.Types Namespace


Item Property (Int32)

NAnt SDK Documentation - v0.91

NamespaceImportCollection.Item Property (Int32)

Gets or sets the item at the specified index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As NamespaceImport
[C#]
public NamespaceImport this[
int index
] {get; set;}

Parameters

index
The zero-based index of the item to get or set.

See Also

NamespaceImportCollection Class | NAnt.DotNet.Types Namespace | NamespaceImportCollection.Item Overload List


Item Property (String)

NAnt SDK Documentation - v0.91

NamespaceImportCollection.Item Property (String)

Gets the NamespaceImport with the specified namespace.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal value As String _
) As NamespaceImport
[C#]
public NamespaceImport this[
string value
] {get;}

Parameters

value
The namespace of the NamespaceImport to get.

See Also

NamespaceImportCollection Class | NAnt.DotNet.Types Namespace | NamespaceImportCollection.Item Overload List


ItemType Property

NAnt SDK Documentation - v0.91

NamespaceImportCollection.ItemType Property

Gets the Type of the items in this collection.

[Visual Basic]
Overrides Protected ReadOnly Property ItemType As Type
[C#]
protected override System.Type ItemType {get;}

Property Value

The Type of the items in this collection.

See Also

NamespaceImportCollection Class | NAnt.DotNet.Types Namespace


NamespaceImportCollection Methods

The methods of the NamespaceImportCollection class are listed below. For a complete list of NamespaceImportCollection class members, see the NamespaceImportCollection Members topic.

Public Instance Methods

Add | Adds a NamespaceImport to the end of the collection.
AddRange | Adds the items of a NamespaceImportCollection to the end of the collection.
Clear (inherited from DataTypeCollectionBase) | Removes all items from the collection.
Contains | Determines whether a NamespaceImport is in the collection.
CopyTo (inherited from DataTypeCollectionBase) | Overloaded. Copies the items of the collection to an Array, starting at a particular index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the location of a NamespaceImport in the collection.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Insert | Inserts a NamespaceImport into the collection at the specified index.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Remove | Removes the specified NamespaceImport from the collection.
RemoveAt (inherited from DataTypeCollectionBase) | Removes an item at a specific index.
Reset (inherited from DataTypeBase) | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString | Returns a comma-delimited list of namespace imports.

Protected Instance Methods

CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from DataTypeBase) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RangeCheck (inherited from DataTypeCollectionBase) | Checks whether the specified index is within the range of this collection.
ValidateType (inherited from DataTypeCollectionBase) | Used by methods that take Object instances as argument to verify whether the instance is valid for the collection class.

See Also

NamespaceImportCollection Class | NAnt.DotNet.Types Namespace


NamespaceImportCollection.Add Method

Adds a NamespaceImport to the end of the collection.

[Visual Basic]
<BuildElement(Name:="import", Required:=False, ProcessXml:=True)>
Public Function Add( _
ByVal value As NamespaceImport _
) As Integer
[C#]
[BuildElement(Name="import", Required=False, ProcessXml=True)]
public int Add(
NamespaceImport value
);

Parameters

value
The NamespaceImport to be added to the end of the collection.

Return Value

The position into which the new item was inserted.

See Also

NamespaceImportCollection Class | NAnt.DotNet.Types Namespace


NamespaceImportCollection.AddRange Method

Adds the items of a NamespaceImportCollection to the end of the collection.

[Visual Basic]
Public Sub AddRange( _
ByVal items As NamespaceImportCollection _
)
[C#]
public void AddRange(
NamespaceImportCollection items
);

Parameters

items
The NamespaceImportCollection to be added to the end of the collection.

See Also

NamespaceImportCollection Class | NAnt.DotNet.Types Namespace


NamespaceImportCollection.Contains Method

Determines whether a NamespaceImport is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal value As NamespaceImport _
) As Boolean
[C#]
public bool Contains(
NamespaceImport value
);

Parameters

value
The NamespaceImport to locate in the collection.

Return Value

true if value is found in the collection; otherwise, false.

See Also

NamespaceImportCollection Class | NAnt.DotNet.Types Namespace


NamespaceImportCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As NamespaceImportEnumerator
[C#]
public NamespaceImportEnumerator GetEnumerator();

Return Value

A NamespaceImportEnumerator for the entire collection.

See Also

NamespaceImportCollection Class | NAnt.DotNet.Types Namespace


NamespaceImportCollection.IndexOf Method

Gets the location of a NamespaceImport in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal value As NamespaceImport _
) As Integer
[C#]
public int IndexOf(
NamespaceImport value
);

Parameters

value
The NamespaceImport object to locate.

Return Value

The zero-based location of the NamespaceImport in the collection.

Remarks

If the NamespaceImport is not currently a member of the collection, -1 is returned.

See Also

NamespaceImportCollection Class | NAnt.DotNet.Types Namespace


NamespaceImportCollection.Insert Method

Inserts a NamespaceImport into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal value As NamespaceImport _
)
[C#]
public void Insert(
int index,
NamespaceImport value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The NamespaceImport to insert.

See Also

NamespaceImportCollection Class | NAnt.DotNet.Types Namespace


NamespaceImportCollection.Remove Method

Removes the specified NamespaceImport from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal value As NamespaceImport _
)
[C#]
public void Remove(
NamespaceImport value
);

Parameters

value
The NamespaceImport to remove from the collection.

See Also

NamespaceImportCollection Class | NAnt.DotNet.Types Namespace


NamespaceImportCollection.ToString Method

Returns a comma-delimited list of namespace imports.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

A comma-delimited list of namespace imports, or an empty String if there are no namespace imports.

Remarks

Each namespace import is quoted individually.

See Also

NamespaceImportCollection Class | NAnt.DotNet.Types Namespace


NamespaceImportEnumerator Class

Enumerates the NamespaceImport items of a NamespaceImportCollection.

For a list of all members of this type, see NamespaceImportEnumerator Members.

System.Object
NAnt.DotNet.Types.NamespaceImportEnumerator

[Visual Basic]
Public Class NamespaceImportEnumerator
Implements IEnumerator
[C#]
public class NamespaceImportEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

NamespaceImportEnumerator Members | NAnt.DotNet.Types Namespace


NamespaceImportEnumerator Members

NamespaceImportEnumerator overview

Public Instance Properties

Current Gets the current item in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next item of the collection.
Reset | Sets the enumerator to its initial position, which is before the first item in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NamespaceImportEnumerator Class | NAnt.DotNet.Types Namespace


NamespaceImportEnumerator Properties

The properties of the NamespaceImportEnumerator class are listed below. For a complete list of NamespaceImportEnumerator class members, see the NamespaceImportEnumerator Members topic.

Public Instance Properties

Current Gets the current item in the collection.

See Also

NamespaceImportEnumerator Class | NAnt.DotNet.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

NamespaceImportEnumerator.Current Property

Gets the current item in the collection.

[Visual Basic]
Public ReadOnly Property Current As NamespaceImport
[C#]
public NamespaceImport Current {get;}

See Also

NamespaceImportEnumerator Class | NAnt.DotNet.Types Namespace


NamespaceImportEnumerator Methods

The methods of the NamespaceImportEnumerator class are listed below. For a complete list of NamespaceImportEnumerator class members, see the NamespaceImportEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next item of the collection.
Reset | Sets the enumerator to its initial position, which is before the first item in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NamespaceImportEnumerator Class | NAnt.DotNet.Types Namespace


NamespaceImportEnumerator.MoveNext Method

Advances the enumerator to the next item of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next item; false if the enumerator has passed the end of the collection.

See Also

NamespaceImportEnumerator Class | NAnt.DotNet.Types Namespace


NamespaceImportEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first item in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

NamespaceImportEnumerator Class | NAnt.DotNet.Types Namespace


Package Class

Represents a package.

For a list of all members of this type, see Package Members.

System.Object
NAnt.Core.Element
NAnt.DotNet.Types.Package

[Visual Basic]
Public Class Package
Inherits Element
[C#]
public class Package : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

Package Members | NAnt.DotNet.Types Namespace


Package Members

Package overview

Public Instance Constructors

Package Constructor Initializes a new instance of the Package class.

Public Instance Properties

IfDefined | Indicates if the package should be passed to the task. If true then the package will be passed; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
PackageName | Name of the package to reference. Multiple package can be specified with a single element as a semi-colon separated list of package names.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Indicates if the package should not be passed to the task. If false then the package will be passed; otherwise, skipped. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Package Class | NAnt.DotNet.Types Namespace


Package Constructor

Initializes a new instance of the Package class.

[Visual Basic]
Public Sub New()
[C#]
public Package();

See Also

Package Class | NAnt.DotNet.Types Namespace


Package Properties

The properties of the Package class are listed below. For a complete list of Package class members, see the Package Members topic.

Public Instance Properties

IfDefined | Indicates if the package should be passed to the task. If true then the package will be passed; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
PackageName | Name of the package to reference. Multiple package can be specified with a single element as a semi-colon separated list of package names.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Indicates if the package should not be passed to the task. If false then the package will be passed; otherwise, skipped. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

Package Class | NAnt.DotNet.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

Package.IfDefined Property

Indicates if the package should be passed to the task. If true then the package will be passed; otherwise, skipped. The default is true.

[Visual Basic]
<TaskAttribute(Name:="if", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property IfDefined As Boolean
[C#]
[TaskAttribute(Name="if", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool IfDefined {get; set;}

See Also

Package Class | NAnt.DotNet.Types Namespace


PackageName Property

NAnt SDK Documentation - v0.91

Package.PackageName Property

Name of the package to reference. Multiple package can be specified with a single element as a semi-colon separated list of package names.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="name", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property PackageName As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="name", Required=True, ExpandProperties=True, ProcessXml=True)]
public string PackageName {get; set;}

See Also

Package Class | NAnt.DotNet.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

Package.UnlessDefined Property

Indicates if the package should not be passed to the task. If false then the package will be passed; otherwise, skipped. The default is false.

[Visual Basic]
<TaskAttribute(Name:="unless", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property UnlessDefined As Boolean
[C#]
[TaskAttribute(Name="unless", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool UnlessDefined {get; set;}

See Also

Package Class | NAnt.DotNet.Types Namespace


PackageCollection Class

Contains a strongly typed collection of Package objects.

For a list of all members of this type, see PackageCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.DotNet.Types.PackageCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class PackageCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class PackageCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

PackageCollection Members | NAnt.DotNet.Types Namespace


PackageCollection Members

PackageCollection overview

Public Instance Constructors

PackageCollection Overloaded. Initializes a new instance of the PackageCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a Package to the end of the collection.
AddRange | Overloaded. Adds the elements of a Package array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a Package is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified Package object in the collection.
Insert | Inserts a Package into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

PackageCollection Class | NAnt.DotNet.Types Namespace


PackageCollection Constructor

Initializes a new instance of the PackageCollection class.

Overload List

Initializes a new instance of the PackageCollection class.

public PackageCollection();

Initializes a new instance of the PackageCollection class with the specified array of Package instances.

public PackageCollection(Package[]);

Initializes a new instance of the PackageCollection class with the specified PackageCollection instance.

public PackageCollection(PackageCollection);

See Also

PackageCollection Class | NAnt.DotNet.Types Namespace


PackageCollection Constructor ()

Initializes a new instance of the PackageCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PackageCollection();

See Also

PackageCollection Class | NAnt.DotNet.Types Namespace | PackageCollection Constructor Overload List


PackageCollection Constructor (PackageCollection)

Initializes a new instance of the PackageCollection class with the specified PackageCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As PackageCollection _
)
[C#]
public PackageCollection(
PackageCollection value
);

See Also

PackageCollection Class | NAnt.DotNet.Types Namespace | PackageCollection Constructor Overload List


PackageCollection Constructor (Package[])

Initializes a new instance of the PackageCollection class with the specified array of Package instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As Package() _
)
[C#]
public PackageCollection(
Package[] value
);

See Also

PackageCollection Class | NAnt.DotNet.Types Namespace | PackageCollection Constructor Overload List


PackageCollection Properties

The properties of the PackageCollection class are listed below. For a complete list of PackageCollection class members, see the PackageCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

PackageCollection Class | NAnt.DotNet.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

PackageCollection.Item Property

Gets or sets the element at the specified index.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As Package
[C#]
public Package this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

PackageCollection Class | NAnt.DotNet.Types Namespace


PackageCollection Methods

The methods of the PackageCollection class are listed below. For a complete list of PackageCollection class members, see the PackageCollection Members topic.

Public Instance Methods

Add | Adds a Package to the end of the collection.
AddRange | Overloaded. Adds the elements of a Package array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a Package is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified Package object in the collection.
Insert | Inserts a Package into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

PackageCollection Class | NAnt.DotNet.Types Namespace


PackageCollection.Add Method

Adds a Package to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As Package _
) As Integer
[C#]
public int Add(
Package item
);

Parameters

item
The Package to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

PackageCollection Class | NAnt.DotNet.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

PackageCollection.AddRange Method

Adds the elements of a Package array to the end of the collection.

Overload List

Adds the elements of a Package array to the end of the collection.

public void AddRange(Package[]);

Adds the elements of a PackageCollection to the end of the collection.

public void AddRange(PackageCollection);

See Also

PackageCollection Class | NAnt.DotNet.Types Namespace


PackageCollection.AddRange Method (Package[])

Adds the elements of a Package array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As Package() _
)
[C#]
public void AddRange(
Package[] items
);

Parameters

items
The array of Package elements to be added to the end of the collection.

See Also

PackageCollection Class | NAnt.DotNet.Types Namespace | PackageCollection.AddRange Overload List


PackageCollection.AddRange Method (PackageCollection)

Adds the elements of a PackageCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As PackageCollection _
)
[C#]
public void AddRange(
PackageCollection items
);

Parameters

items
The PackageCollection to be added to the end of the collection.

See Also

PackageCollection Class | NAnt.DotNet.Types Namespace | PackageCollection.AddRange Overload List


PackageCollection.Contains Method

Determines whether a Package is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal item As Package _
) As Boolean
[C#]
public bool Contains(
Package item
);

Parameters

item
The Package to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

PackageCollection Class | NAnt.DotNet.Types Namespace


PackageCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As Package(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
Package[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

PackageCollection Class | NAnt.DotNet.Types Namespace


PackageCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As PackageEnumerator
[C#]
new public PackageEnumerator GetEnumerator();

Return Value

A PackageEnumerator for the entire collection.

See Also

PackageCollection Class | NAnt.DotNet.Types Namespace


PackageCollection.IndexOf Method

Retrieves the index of a specified Package object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As Package _
) As Integer
[C#]
public int IndexOf(
Package item
);

Parameters

item
The Package object for which the index is returned.

Return Value

The index of the specified Package. If the Package is not currently a member of the collection, it returns -1.

See Also

PackageCollection Class | NAnt.DotNet.Types Namespace


PackageCollection.Insert Method

Inserts a Package into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As Package _
)
[C#]
public void Insert(
int index,
Package item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The Package to insert.

See Also

PackageCollection Class | NAnt.DotNet.Types Namespace


PackageCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As Package _
)
[C#]
public void Remove(
Package item
);

Parameters

item
The Package to remove from the collection.

See Also

PackageCollection Class | NAnt.DotNet.Types Namespace


PackageEnumerator Class

Enumerates the Package elements of a PackageCollection.

For a list of all members of this type, see PackageEnumerator Members.

System.Object
NAnt.DotNet.Types.PackageEnumerator

[Visual Basic]
Public Class PackageEnumerator
Implements IEnumerator
[C#]
public class PackageEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

PackageEnumerator Members | NAnt.DotNet.Types Namespace


PackageEnumerator Members

PackageEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PackageEnumerator Class | NAnt.DotNet.Types Namespace


PackageEnumerator Properties

The properties of the PackageEnumerator class are listed below. For a complete list of PackageEnumerator class members, see the PackageEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

PackageEnumerator Class | NAnt.DotNet.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

PackageEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As Package
[C#]
public Package Current {get;}

See Also

PackageEnumerator Class | NAnt.DotNet.Types Namespace


PackageEnumerator Methods

The methods of the PackageEnumerator class are listed below. For a complete list of PackageEnumerator class members, see the PackageEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PackageEnumerator Class | NAnt.DotNet.Types Namespace


PackageEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

PackageEnumerator Class | NAnt.DotNet.Types Namespace


PackageEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

PackageEnumerator Class | NAnt.DotNet.Types Namespace


ResourceFileSet Class

Specialized FileSet class for managing resource files.

For a list of all members of this type, see ResourceFileSet Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.Core.Types.FileSet
NAnt.DotNet.Types.ResourceFileSet

[Visual Basic]
<ElementName(Name:="resourcefileset")>
Public Class ResourceFileSet
Inherits FileSet
Implements ICloneable
[C#]
[ElementName(Name="resourcefileset")]
public class ResourceFileSet : FileSet, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

ResourceFileSet Members | NAnt.DotNet.Types Namespace


ResourceFileSet Members

ResourceFileSet overview

Public Instance Constructors

ResourceFileSet Overloaded. Initializes a new instance of the ResourceFileSet class.

Public Instance Properties

AsIs (inherited from FileSet) | Gets the collection of files that will be added to the FileSet without pattern matching or checking if the file exists.
BaseDirectory (inherited from FileSet) | The base of the directory of this fileset. The default is the project base directory.
CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
CaseSensitive (inherited from FileSet) | Indicates whether include and exclude patterns must be treated in a case-sensitive way. The default is true on Unix; otherwise, false.
DefaultExcludes (inherited from FileSet) | Indicates whether default excludes should be used or not. The default is true.
DirectoryNames (inherited from FileSet) | Gets the collection of directory names that match the fileset.
DynamicPrefix | Indicates whether prefixes should be dynamically generated by taking the path of the resource relative to the basedir and appending it to the specified prefix. The default is false.
ExcludeElements (inherited from FileSet) | The items to exclude from the fileset.
Excludes (inherited from FileSet) | Gets the collection of exclude patterns.
ExcludesFiles (inherited from FileSet) | The files from which a list of patterns or files to exclude should be obtained.
FailOnEmpty (inherited from FileSet) | When set to true, causes the fileset element to throw a ValidationException when no files match the includes and excludes criteria. The default is false.
FileNames (inherited from FileSet) | Gets the collection of file names that match the fileset.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IncludeElements (inherited from FileSet) | The items to include in the fileset.
Includes (inherited from FileSet) | Gets the collection of include patterns.
IncludesFiles (inherited from FileSet) | The files from which a list of patterns or files to include should be obtained.
MostRecentLastWriteTimeFile (inherited from FileSet) | Determines the most recently modified file in the fileset (by LastWriteTime of the FileInfo).
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NonResxFiles | Gets a FileSet containing all matching non-resx files.
Parent (inherited from Element) | Gets or sets the parent of the element.
PathFiles (inherited from FileSet) |
Prefix | Indicates the prefix to prepend to the actual resource. This is usually the default namspace of the assembly.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.
ResxFiles | Gets a FileSet containing all matching resx files.
ScannedDirectories (inherited from FileSet) | Gets the collection of directory names that were scanned for files.
SetExcludes (inherited from FileSet) | Obsolete. The items to exclude from the fileset.
SetIncludes (inherited from FileSet) | Obsolete. The items to include in the fileset.
SetIncludesList (inherited from FileSet) | Obsolete. The files from which a list of patterns or files to include should be obtained.

Public Instance Methods

AddPatternSet (inherited from FileSet) | Adds a nested set of patterns, or references a standalone patternset.
Clone | Creates a shallow copy of the ResourceFileSet.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetManifestResourceName | Overloaded. Gets the manifest resource name for the specified resource file.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from FileSet) |
Scan (inherited from FileSet) |
ToString (inherited from FileSet) |

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from FileSet) | Overloaded. Copies all instance data of the FileSet to a given FileSet.
CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from FileSet) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResourceFileSet Class | NAnt.DotNet.Types Namespace


ResourceFileSet Constructor

Initializes a new instance of the ResourceFileSet class.

Overload List

Initializes a new instance of the ResourceFileSet class.

public ResourceFileSet();

copy constructor for FileSet. Required in order to assign references of FileSet type where ResourceFileSet are used

public ResourceFileSet(FileSet);

See Also

ResourceFileSet Class | NAnt.DotNet.Types Namespace


ResourceFileSet Constructor ()

Initializes a new instance of the ResourceFileSet class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ResourceFileSet();

See Also

ResourceFileSet Class | NAnt.DotNet.Types Namespace | ResourceFileSet Constructor Overload List


ResourceFileSet Constructor (FileSet)

copy constructor for FileSet. Required in order to assign references of FileSet type where ResourceFileSet are used

[Visual Basic]
Overloads Public Sub New( _
ByVal fs As FileSet _
)
[C#]
public ResourceFileSet(
FileSet fs
);

Parameters

fs

See Also

ResourceFileSet Class | NAnt.DotNet.Types Namespace | ResourceFileSet Constructor Overload List


ResourceFileSet Properties

The properties of the ResourceFileSet class are listed below. For a complete list of ResourceFileSet class members, see the ResourceFileSet Members topic.

Public Instance Properties

AsIs (inherited from FileSet) | Gets the collection of files that will be added to the FileSet without pattern matching or checking if the file exists.
BaseDirectory (inherited from FileSet) | The base of the directory of this fileset. The default is the project base directory.
CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
CaseSensitive (inherited from FileSet) | Indicates whether include and exclude patterns must be treated in a case-sensitive way. The default is true on Unix; otherwise, false.
DefaultExcludes (inherited from FileSet) | Indicates whether default excludes should be used or not. The default is true.
DirectoryNames (inherited from FileSet) | Gets the collection of directory names that match the fileset.
DynamicPrefix | Indicates whether prefixes should be dynamically generated by taking the path of the resource relative to the basedir and appending it to the specified prefix. The default is false.
ExcludeElements (inherited from FileSet) | The items to exclude from the fileset.
Excludes (inherited from FileSet) | Gets the collection of exclude patterns.
ExcludesFiles (inherited from FileSet) | The files from which a list of patterns or files to exclude should be obtained.
FailOnEmpty (inherited from FileSet) | When set to true, causes the fileset element to throw a ValidationException when no files match the includes and excludes criteria. The default is false.
FileNames (inherited from FileSet) | Gets the collection of file names that match the fileset.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IncludeElements (inherited from FileSet) | The items to include in the fileset.
Includes (inherited from FileSet) | Gets the collection of include patterns.
IncludesFiles (inherited from FileSet) | The files from which a list of patterns or files to include should be obtained.
MostRecentLastWriteTimeFile (inherited from FileSet) | Determines the most recently modified file in the fileset (by LastWriteTime of the FileInfo).
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NonResxFiles | Gets a FileSet containing all matching non-resx files.
Parent (inherited from Element) | Gets or sets the parent of the element.
PathFiles (inherited from FileSet) |
Prefix | Indicates the prefix to prepend to the actual resource. This is usually the default namspace of the assembly.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.
ResxFiles | Gets a FileSet containing all matching resx files.
ScannedDirectories (inherited from FileSet) | Gets the collection of directory names that were scanned for files.
SetExcludes (inherited from FileSet) | Obsolete. The items to exclude from the fileset.
SetIncludes (inherited from FileSet) | Obsolete. The items to include in the fileset.
SetIncludesList (inherited from FileSet) | Obsolete. The files from which a list of patterns or files to include should be obtained.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

ResourceFileSet Class | NAnt.DotNet.Types Namespace


DynamicPrefix Property

NAnt SDK Documentation - v0.91

ResourceFileSet.DynamicPrefix Property

Indicates whether prefixes should be dynamically generated by taking the path of the resource relative to the basedir and appending it to the specified prefix. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="dynamicprefix", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property DynamicPrefix As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="dynamicprefix", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool DynamicPrefix {get; set;}

See Also

ResourceFileSet Class | NAnt.DotNet.Types Namespace


NonResxFiles Property

NAnt SDK Documentation - v0.91

ResourceFileSet.NonResxFiles Property

Gets a FileSet containing all matching non-resx files.

[Visual Basic]
Public ReadOnly Property NonResxFiles As FileSet
[C#]
public NAnt.Core.Types.FileSet NonResxFiles {get;}

Property Value

A FileSet containing all matching non-resx files.

See Also

ResourceFileSet Class | NAnt.DotNet.Types Namespace


Prefix Property

NAnt SDK Documentation - v0.91

ResourceFileSet.Prefix Property

Indicates the prefix to prepend to the actual resource. This is usually the default namspace of the assembly.

[Visual Basic]
<TaskAttribute(Name:="prefix", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Prefix As String
[C#]
[TaskAttribute(Name="prefix", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Prefix {get; set;}

See Also

ResourceFileSet Class | NAnt.DotNet.Types Namespace


ResxFiles Property

NAnt SDK Documentation - v0.91

ResourceFileSet.ResxFiles Property

Gets a FileSet containing all matching resx files.

[Visual Basic]
Public ReadOnly Property ResxFiles As FileSet
[C#]
public NAnt.Core.Types.FileSet ResxFiles {get;}

Property Value

A FileSet containing all matching resx files.

See Also

ResourceFileSet Class | NAnt.DotNet.Types Namespace


ResourceFileSet Methods

The methods of the ResourceFileSet class are listed below. For a complete list of ResourceFileSet class members, see the ResourceFileSet Members topic.

Public Instance Methods

AddPatternSet (inherited from FileSet) | Adds a nested set of patterns, or references a standalone patternset.
Clone | Creates a shallow copy of the ResourceFileSet.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetManifestResourceName | Overloaded. Gets the manifest resource name for the specified resource file.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from FileSet) |
Scan (inherited from FileSet) |
ToString (inherited from FileSet) |

Protected Instance Methods

CopyTo (inherited from FileSet) | Overloaded. Copies all instance data of the FileSet to a given FileSet.
CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from FileSet) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResourceFileSet Class | NAnt.DotNet.Types Namespace


ResourceFileSet.Clone Method

Creates a shallow copy of the ResourceFileSet.

[Visual Basic]
Overrides Public Function Clone() As Object _
Implements ICloneable.Clone
[C#]
public override object Clone();

Return Value

A shallow copy of the ResourceFileSet.

Implements

ICloneable.Clone

See Also

ResourceFileSet Class | NAnt.DotNet.Types Namespace


GetManifestResourceName Method

NAnt SDK Documentation - v0.91

ResourceFileSet.GetManifestResourceName Method

Gets the manifest resource name for the specified resource file.

Overload List

Gets the manifest resource name for the specified resource file.

public string GetManifestResourceName(string);

Gets the manifest resource name for the file using both its physical and logical path.

public string GetManifestResourceName(string,string);

See Also

ResourceFileSet Class | NAnt.DotNet.Types Namespace


ResourceFileSet.GetManifestResourceName Method (String)

Gets the manifest resource name for the specified resource file.

[Visual Basic]
Overloads Public Function GetManifestResourceName( _
ByVal resourceFile As String _
) As String
[C#]
public string GetManifestResourceName(
string resourceFile
);

Parameters

resourceFile
The physical path of the resource file.

Return Value

The manifest resource name to be sent to the compiler.

See Also

ResourceFileSet Class | NAnt.DotNet.Types Namespace | ResourceFileSet.GetManifestResourceName Overload List


ResourceFileSet.GetManifestResourceName Method (String, String)

Gets the manifest resource name for the file using both its physical and logical path.

[Visual Basic]
Overloads Public Function GetManifestResourceName( _
ByVal physicalPath As String, _
ByVal logicalPath As String _
) As String
[C#]
public string GetManifestResourceName(
string physicalPath,
string logicalPath
);

Parameters

physicalPath
The physical path of the resource file.
logicalPath
The logical location of the resource file.

Return Value

The manifest resource name to be sent to the compiler.

Remarks

We use the relative path of the logical path, but the filename and and the extension of the physical path to match VS.NET

See Also

ResourceFileSet Class | NAnt.DotNet.Types Namespace | ResourceFileSet.GetManifestResourceName Overload List


ResourceFileSetCollection Class

Contains a strongly typed collection of ResourceFileSet objects.

For a list of all members of this type, see ResourceFileSetCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.DotNet.Types.ResourceFileSetCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class ResourceFileSetCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class ResourceFileSetCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

ResourceFileSetCollection Members | NAnt.DotNet.Types Namespace


ResourceFileSetCollection Members

ResourceFileSetCollection overview

Public Instance Constructors

ResourceFileSetCollection Overloaded. Initializes a new instance of the ResourceFileSetCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a ResourceFileSet to the end of the collection.
AddRange | Overloaded. Adds the elements of a ResourceFileSet array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a ResourceFileSet is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified ResourceFileSet object in the collection.
Insert | Inserts a ResourceFileSet into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

ResourceFileSetCollection Class | NAnt.DotNet.Types Namespace


ResourceFileSetCollection Constructor

Initializes a new instance of the ResourceFileSetCollection class.

Overload List

Initializes a new instance of the ResourceFileSetCollection class.

public ResourceFileSetCollection();

Initializes a new instance of the ResourceFileSetCollection class with the specified array of ResourceFileSet instances.

public ResourceFileSetCollection(ResourceFileSet[]);

Initializes a new instance of the ResourceFileSetCollection class with the specified ResourceFileSetCollection instance.

public ResourceFileSetCollection(ResourceFileSetCollection);

See Also

ResourceFileSetCollection Class | NAnt.DotNet.Types Namespace


ResourceFileSetCollection Constructor ()

Initializes a new instance of the ResourceFileSetCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ResourceFileSetCollection();

See Also

ResourceFileSetCollection Class | NAnt.DotNet.Types Namespace | ResourceFileSetCollection Constructor Overload List


ResourceFileSetCollection Constructor (ResourceFileSetCollection)

Initializes a new instance of the ResourceFileSetCollection class with the specified ResourceFileSetCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As ResourceFileSetCollection _
)
[C#]
public ResourceFileSetCollection(
ResourceFileSetCollection value
);

See Also

ResourceFileSetCollection Class | NAnt.DotNet.Types Namespace | ResourceFileSetCollection Constructor Overload List


ResourceFileSetCollection Constructor (ResourceFileSet[])

Initializes a new instance of the ResourceFileSetCollection class with the specified array of ResourceFileSet instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As ResourceFileSet() _
)
[C#]
public ResourceFileSetCollection(
ResourceFileSet[] value
);

See Also

ResourceFileSetCollection Class | NAnt.DotNet.Types Namespace | ResourceFileSetCollection Constructor Overload List


ResourceFileSetCollection Properties

The properties of the ResourceFileSetCollection class are listed below. For a complete list of ResourceFileSetCollection class members, see the ResourceFileSetCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

ResourceFileSetCollection Class | NAnt.DotNet.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

ResourceFileSetCollection.Item Property

Gets or sets the element at the specified index.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As ResourceFileSet
[C#]
public ResourceFileSet this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

ResourceFileSetCollection Class | NAnt.DotNet.Types Namespace


ResourceFileSetCollection Methods

The methods of the ResourceFileSetCollection class are listed below. For a complete list of ResourceFileSetCollection class members, see the ResourceFileSetCollection Members topic.

Public Instance Methods

Add | Adds a ResourceFileSet to the end of the collection.
AddRange | Overloaded. Adds the elements of a ResourceFileSet array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a ResourceFileSet is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified ResourceFileSet object in the collection.
Insert | Inserts a ResourceFileSet into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

ResourceFileSetCollection Class | NAnt.DotNet.Types Namespace


ResourceFileSetCollection.Add Method

Adds a ResourceFileSet to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As ResourceFileSet _
) As Integer
[C#]
public int Add(
ResourceFileSet item
);

Parameters

item
The ResourceFileSet to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

ResourceFileSetCollection Class | NAnt.DotNet.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

ResourceFileSetCollection.AddRange Method

Adds the elements of a ResourceFileSet array to the end of the collection.

Overload List

Adds the elements of a ResourceFileSet array to the end of the collection.

public void AddRange(ResourceFileSet[]);

Adds the elements of a ResourceFileSetCollection to the end of the collection.

public void AddRange(ResourceFileSetCollection);

See Also

ResourceFileSetCollection Class | NAnt.DotNet.Types Namespace


ResourceFileSetCollection.AddRange Method (ResourceFileSet[])

Adds the elements of a ResourceFileSet array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As ResourceFileSet() _
)
[C#]
public void AddRange(
ResourceFileSet[] items
);

Parameters

items
The array of ResourceFileSet elements to be added to the end of the collection.

See Also

ResourceFileSetCollection Class | NAnt.DotNet.Types Namespace | ResourceFileSetCollection.AddRange Overload List


ResourceFileSetCollection.AddRange Method (ResourceFileSetCollection)

Adds the elements of a ResourceFileSetCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As ResourceFileSetCollection _
)
[C#]
public void AddRange(
ResourceFileSetCollection items
);

Parameters

items
The ResourceFileSetCollection to be added to the end of the collection.

See Also

ResourceFileSetCollection Class | NAnt.DotNet.Types Namespace | ResourceFileSetCollection.AddRange Overload List


ResourceFileSetCollection.Contains Method

Determines whether a ResourceFileSet is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal item As ResourceFileSet _
) As Boolean
[C#]
public bool Contains(
ResourceFileSet item
);

Parameters

item
The ResourceFileSet to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

ResourceFileSetCollection Class | NAnt.DotNet.Types Namespace


ResourceFileSetCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As ResourceFileSet(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
ResourceFileSet[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

ResourceFileSetCollection Class | NAnt.DotNet.Types Namespace


ResourceFileSetCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As ResourceFileSetEnumerator
[C#]
new public ResourceFileSetEnumerator GetEnumerator();

Return Value

A ResourceFileSetEnumerator for the entire collection.

See Also

ResourceFileSetCollection Class | NAnt.DotNet.Types Namespace


ResourceFileSetCollection.IndexOf Method

Retrieves the index of a specified ResourceFileSet object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As ResourceFileSet _
) As Integer
[C#]
public int IndexOf(
ResourceFileSet item
);

Parameters

item
The ResourceFileSet object for which the index is returned.

Return Value

The index of the specified ResourceFileSet. If the ResourceFileSet is not currently a member of the collection, it returns -1.

See Also

ResourceFileSetCollection Class | NAnt.DotNet.Types Namespace


ResourceFileSetCollection.Insert Method

Inserts a ResourceFileSet into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As ResourceFileSet _
)
[C#]
public void Insert(
int index,
ResourceFileSet item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The ResourceFileSet to insert.

See Also

ResourceFileSetCollection Class | NAnt.DotNet.Types Namespace


ResourceFileSetCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As ResourceFileSet _
)
[C#]
public void Remove(
ResourceFileSet item
);

Parameters

item
The ResourceFileSet to remove from the collection.

See Also

ResourceFileSetCollection Class | NAnt.DotNet.Types Namespace


ResourceFileSetEnumerator Class

Enumerates the ResourceFileSet elements of a ResourceFileSetCollection.

For a list of all members of this type, see ResourceFileSetEnumerator Members.

System.Object
NAnt.DotNet.Types.ResourceFileSetEnumerator

[Visual Basic]
Public Class ResourceFileSetEnumerator
Implements IEnumerator
[C#]
public class ResourceFileSetEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

ResourceFileSetEnumerator Members | NAnt.DotNet.Types Namespace


ResourceFileSetEnumerator Members

ResourceFileSetEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResourceFileSetEnumerator Class | NAnt.DotNet.Types Namespace


ResourceFileSetEnumerator Properties

The properties of the ResourceFileSetEnumerator class are listed below. For a complete list of ResourceFileSetEnumerator class members, see the ResourceFileSetEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

ResourceFileSetEnumerator Class | NAnt.DotNet.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

ResourceFileSetEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As ResourceFileSet
[C#]
public ResourceFileSet Current {get;}

See Also

ResourceFileSetEnumerator Class | NAnt.DotNet.Types Namespace


ResourceFileSetEnumerator Methods

The methods of the ResourceFileSetEnumerator class are listed below. For a complete list of ResourceFileSetEnumerator class members, see the ResourceFileSetEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResourceFileSetEnumerator Class | NAnt.DotNet.Types Namespace


ResourceFileSetEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

ResourceFileSetEnumerator Class | NAnt.DotNet.Types Namespace


ResourceFileSetEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

ResourceFileSetEnumerator Class | NAnt.DotNet.Types Namespace


WarningAsError Class

Controls the behaviour of a compiler with regards to the reporting of warnings.

For a list of all members of this type, see WarningAsError Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.DotNet.Types.WarningAsError

[Visual Basic]
<ElementName(Name:="warnaserror")>
Public Class WarningAsError
Inherits DataTypeBase
[C#]
[ElementName(Name="warnaserror")]
public class WarningAsError : DataTypeBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Instruct a compiler to report warning 0519 as an error.

            <warnaserror>
                <include number="0519" />
            </warnaserror>

Instruct a compiler not to report warning 0519 as an error, if the release property is true.

            <warnaserror>
                <exclude number="0519" if="${release}" />
            </warnaserror>

Requirements

Namespace: NAnt.DotNet.Types

Assembly: NAnt.DotNetTasks (in NAnt.DotNetTasks.dll)

See Also

WarningAsError Members | NAnt.DotNet.Types Namespace


WarningAsError Members

WarningAsError overview

Public Instance Constructors

WarningAsError Constructor Initializes a new instance of the WarningAsError class.

Public Instance Properties

CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Excludes | Specifies a list of warnings that the compiler should NOT treat as errors. This is only useful if WarnAsError is true. Only supported when targeting .NET 2.0 or higher.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
Includes | Specifies a list of warnings that the compiler should treat as errors. This overrides the WarnAsError attribute. Only supported when targeting .NET 2.0 or higher.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from DataTypeBase) | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from DataTypeBase) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WarningAsError Class | NAnt.DotNet.Types Namespace


WarningAsError Constructor

Initializes a new instance of the WarningAsError class.

[Visual Basic]
Public Sub New()
[C#]
public WarningAsError();

See Also

WarningAsError Class | NAnt.DotNet.Types Namespace


WarningAsError Properties

The properties of the WarningAsError class are listed below. For a complete list of WarningAsError class members, see the WarningAsError Members topic.

Public Instance Properties

CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Excludes | Specifies a list of warnings that the compiler should NOT treat as errors. This is only useful if WarnAsError is true. Only supported when targeting .NET 2.0 or higher.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
Includes | Specifies a list of warnings that the compiler should treat as errors. This overrides the WarnAsError attribute. Only supported when targeting .NET 2.0 or higher.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

WarningAsError Class | NAnt.DotNet.Types Namespace


Excludes Property

NAnt SDK Documentation - v0.91

WarningAsError.Excludes Property

Specifies a list of warnings that the compiler should NOT treat as errors. This is only useful if WarnAsError is true. Only supported when targeting .NET 2.0 or higher.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="exclude", Required:=False, ProcessXml:=True)>
Public ReadOnly Property Excludes As CompilerWarningCollection
[C#]
[BuildElementArray(ElementType=null, Name="exclude", Required=False, ProcessXml=True)]
public CompilerWarningCollection Excludes {get;}

See Also

WarningAsError Class | NAnt.DotNet.Types Namespace


Includes Property

NAnt SDK Documentation - v0.91

WarningAsError.Includes Property

Specifies a list of warnings that the compiler should treat as errors. This overrides the WarnAsError attribute. Only supported when targeting .NET 2.0 or higher.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="include", Required:=False, ProcessXml:=True)>
Public ReadOnly Property Includes As CompilerWarningCollection
[C#]
[BuildElementArray(ElementType=null, Name="include", Required=False, ProcessXml=True)]
public CompilerWarningCollection Includes {get;}

See Also

WarningAsError Class | NAnt.DotNet.Types Namespace


NAnt.MSNet.Tasks

NAnt SDK Documentation - v0.91

NAnt.MSNet.Tasks Namespace

Namespace hierarchy

Classes

Class | Description
IldasmTask | Disassembles any portable executable (PE) file that contains intermediate language (IL) code.
ServiceControllerTask | Allows a Windows service to be controlled.

Enumerations

Enumeration | Description
ServiceControllerTask.ActionType | Defines the actions that can be performed on a service.


IldasmTask Class

Disassembles any portable executable (PE) file that contains intermediate language (IL) code.

For a list of all members of this type, see IldasmTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.MSNet.Tasks.IldasmTask

[Visual Basic]
<TaskName(Name:="ildasm"), _ ProgramLocation(LocationType:=LocationType.FrameworkSdkDir)>
Public Class IldasmTask
Inherits ExternalProgramBase
[C#]
[TaskName(Name="ildasm")]
[ProgramLocation(LocationType=LocationType.FrameworkSdkDir)]
public class IldasmTask : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Files are only disassembled if the input file is newer than the output file, or if the output file does not exist. However, you can explicitly force files to be disassembled with the ForceRebuild attribute.

A FileSet can be used to select files to disassemble. To use a FileSet, the ToDirectory attribute must be set. The file name of the output file will be equal to the file name of the input file, but with extension ".il".

Example

Disassembles helloworld.exe to helloworld.il.

<ildasm input="helloworld.exe" output="helloworld.il" />

Disassembles a set of PE files into the specified directory.

<ildasm todir=".">
    <assemblies>
        <include name="*.exe" />
        <include name="*.dll" />
    </assemblies>
</ildasm>

Requirements

Namespace: NAnt.MSNet.Tasks

Assembly: NAnt.MSNetTasks (in NAnt.MSNetTasks.dll)

See Also

IldasmTask Members | NAnt.MSNet.Tasks Namespace


IldasmTask Members

IldasmTask overview

Public Instance Constructors

IldasmTask Constructor Initializes a new instance of the IldasmTask class.

Public Instance Properties

All | Specifies whether or not the disassembler should combine the /HEADER, /BYTE, and /TOKENS options. The default is false.
Arguments | The command-line arguments for the external program.
Assemblies | Specifies a list of PE files to disassemble. To use a FileSet, the ToDirectory attribute must be specified.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
Bytes | Specifies whether or not the disassembler should generate the IL stream bytes (in hexadecimal notation) as instruction comments. The default is false.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForceRebuild | Instructs NAnt to rebuild the output file regardless of the file timestamps. The default is false.
Header | Specifies whether or not the disassembler should include PE header information and runtime header information in the output. The default is false.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
InputFile | Specifies the PE file to disassemble.
Item | Instructs the disassembler to disassemble the specified item only.
LineNumbers | Specifies whether or not the disassembler should include references to original source lines. The default is false.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NoIL | Specifies whether or not the disassembler should suppress ILASM code output. The default is false.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | Specifies the name of the output file created by the disassembler.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PublicOnly | Specifies whether or not the disassembler should disassemble public items only. This is a shortcut for Visibility="pub". The default is false.
QuoteAllNames | Specifies whether or not the disassembler should enclose all names in single quotation marks. By default, only names that don't match the ILASM definition of a simple name are quoted. The default is false.
RawExceptionHandling | Specifies whether or not the disassembler should generate structured exception handling clauses in canonical (label) form. The default is false.
Source | Specifies whether or not the disassembler should generate original source lines as comments. The default is false.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
ToDirectory | Specifies the directory to which outputs will be stored.
Tokens | Specifies whether or not the disassembler should generate metadata token values as comments. The default is false.
Unicode | Specifies whether or not the disassembler should use the UNICODE encoding when generating the output. The default is ANSI.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Utf8 | Specifies whether or not the disassembler should use the UTF-8 encoding when generating the output. The default is ANSI.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
Visibility | Instructs the disassembler to disassemble only the items with the specified visibility. Possible values are PUB, PRI, FAM, ASM, FAA, FOA, PSC, or any combination of them separated by +.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Disassembles the PE file(s).
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Checks whether the task is initialized with valid attributes.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


IldasmTask Constructor

Initializes a new instance of the IldasmTask class.

[Visual Basic]
Public Sub New()
[C#]
public IldasmTask();

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


IldasmTask Properties

The properties of the IldasmTask class are listed below. For a complete list of IldasmTask class members, see the IldasmTask Members topic.

Public Instance Properties

All | Specifies whether or not the disassembler should combine the /HEADER, /BYTE, and /TOKENS options. The default is false.
Arguments | The command-line arguments for the external program.
Assemblies | Specifies a list of PE files to disassemble. To use a FileSet, the ToDirectory attribute must be specified.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
Bytes | Specifies whether or not the disassembler should generate the IL stream bytes (in hexadecimal notation) as instruction comments. The default is false.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForceRebuild | Instructs NAnt to rebuild the output file regardless of the file timestamps. The default is false.
Header | Specifies whether or not the disassembler should include PE header information and runtime header information in the output. The default is false.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
InputFile | Specifies the PE file to disassemble.
Item | Instructs the disassembler to disassemble the specified item only.
LineNumbers | Specifies whether or not the disassembler should include references to original source lines. The default is false.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NoIL | Specifies whether or not the disassembler should suppress ILASM code output. The default is false.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | Specifies the name of the output file created by the disassembler.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PublicOnly | Specifies whether or not the disassembler should disassemble public items only. This is a shortcut for Visibility="pub". The default is false.
QuoteAllNames | Specifies whether or not the disassembler should enclose all names in single quotation marks. By default, only names that don't match the ILASM definition of a simple name are quoted. The default is false.
RawExceptionHandling | Specifies whether or not the disassembler should generate structured exception handling clauses in canonical (label) form. The default is false.
Source | Specifies whether or not the disassembler should generate original source lines as comments. The default is false.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
ToDirectory | Specifies the directory to which outputs will be stored.
Tokens | Specifies whether or not the disassembler should generate metadata token values as comments. The default is false.
Unicode | Specifies whether or not the disassembler should use the UNICODE encoding when generating the output. The default is ANSI.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Utf8 | Specifies whether or not the disassembler should use the UTF-8 encoding when generating the output. The default is ANSI.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
Visibility | Instructs the disassembler to disassemble only the items with the specified visibility. Possible values are PUB, PRI, FAM, ASM, FAA, FOA, PSC, or any combination of them separated by +.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


All Property

NAnt SDK Documentation - v0.91

IldasmTask.All Property

Specifies whether or not the disassembler should combine the /HEADER, /BYTE, and /TOKENS options. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="all", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property All As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="all", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool All {get; set;}

Property Value

true if the disassembler should combine the /HEADER, /BYTE, and /TOKENS options; otherwise, false. The default is false.

Remarks

Corresponds to the /ALL flag.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


Arguments Property

NAnt SDK Documentation - v0.91

IldasmTask.Arguments Property

The command-line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property Arguments As ArgumentCollection
[C#]
public override NAnt.Core.Types.ArgumentCollection Arguments {get;}

Remarks

Overridden to ensure the <arg> elements would not be exposed to build authors.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


Assemblies Property

NAnt SDK Documentation - v0.91

IldasmTask.Assemblies Property

Specifies a list of PE files to disassemble. To use a FileSet, the ToDirectory attribute must be specified.

[Visual Basic]
<BuildElement(Name:="assemblies", Required:=False, ProcessXml:=True)>
Public Property Assemblies As FileSet
[C#]
[BuildElement(Name="assemblies", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet Assemblies {get; set;}

Property Value

A FileSet that represents the set of PE files to disassemble.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


Bytes Property

NAnt SDK Documentation - v0.91

IldasmTask.Bytes Property

Specifies whether or not the disassembler should generate the IL stream bytes (in hexadecimal notation) as instruction comments. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="bytes", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Bytes As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="bytes", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool Bytes {get; set;}

Property Value

true if the IL stream bytes should be generated as instruction comments; otherwise, false. The default is false.

Remarks

Corresponds to the /BYTE flag.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


ForceRebuild Property

NAnt SDK Documentation - v0.91

IldasmTask.ForceRebuild Property

Instructs NAnt to rebuild the output file regardless of the file timestamps. The default is false.

[Visual Basic]
<TaskAttribute(Name:="rebuild", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property ForceRebuild As Boolean
[C#]
[TaskAttribute(Name="rebuild", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool ForceRebuild {get; set;}

Property Value

true if the output file should be rebuilt regardless of its timestamps; otherwise false. The default is false.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


Header Property

NAnt SDK Documentation - v0.91

IldasmTask.Header Property

Specifies whether or not the disassembler should include PE header information and runtime header information in the output. The default is false.

[Visual Basic]
<TaskAttribute(Name:="header", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property Header As Boolean
[C#]
[TaskAttribute(Name="header", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool Header {get; set;}

Property Value

true if PE header information and runtime header information should be included in the output; otherwise, false. The default is false.

Remarks

Corresponds to the /HEADER flag.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


InputFile Property

NAnt SDK Documentation - v0.91

IldasmTask.InputFile Property

Specifies the PE file to disassemble.

[Visual Basic]
<TaskAttribute(Name:="input", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property InputFile As FileInfo
[C#]
[TaskAttribute(Name="input", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo InputFile {get; set;}

Property Value

A FileInfo that represents the PE file to disassemble.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


Item Property

NAnt SDK Documentation - v0.91

IldasmTask.Item Property

Instructs the disassembler to disassemble the specified item only.

[Visual Basic]
<TaskAttribute(Name:="item", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property Item As String
[C#]
[TaskAttribute(Name="item", Required=False, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string Item {get; set;}

Property Value

A String that specifies the item to disassemble.

Remarks

Corresponds to the /ITEM flag.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


LineNumbers Property

NAnt SDK Documentation - v0.91

IldasmTask.LineNumbers Property

Specifies whether or not the disassembler should include references to original source lines. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="linenumbers", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property LineNumbers As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="linenumbers", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool LineNumbers {get; set;}

Property Value

true if references to original source lines should be included; otherwise, false. The default is false.

Remarks

Corresponds to the /LINENUM flag.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


NoIL Property

NAnt SDK Documentation - v0.91

IldasmTask.NoIL Property

Specifies whether or not the disassembler should suppress ILASM code output. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="noil", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property NoIL As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="noil", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool NoIL {get; set;}

Property Value

true if ILASM code output should be suppresses; otherwise, false. The default is false.

Remarks

Corresponds to the /NOIL flag.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


OutputFile Property

NAnt SDK Documentation - v0.91

IldasmTask.OutputFile Property

Specifies the name of the output file created by the disassembler.

[Visual Basic]
<TaskAttribute(Name:="output", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property OutputFile As FileInfo
[C#]
[TaskAttribute(Name="output", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo OutputFile {get; set;}

Property Value

A FileInfo that represents the name of the output file.

Remarks

Corresponds to the /OUT flag.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

IldasmTask.ProgramArguments Property

Gets the command-line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

Property Value

A String that contains the command-line arguments for the external program.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


PublicOnly Property

NAnt SDK Documentation - v0.91

IldasmTask.PublicOnly Property

Specifies whether or not the disassembler should disassemble public items only. This is a shortcut for Visibility="pub". The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="publiconly", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property PublicOnly As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="publiconly", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool PublicOnly {get; set;}

Property Value

true if only public items should be disassembled; otherwise, false. The default is false.

Remarks

Corresponds to the /PUBONLY flag.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


QuoteAllNames Property

NAnt SDK Documentation - v0.91

IldasmTask.QuoteAllNames Property

Specifies whether or not the disassembler should enclose all names in single quotation marks. By default, only names that don't match the ILASM definition of a simple name are quoted. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="quoteallnames", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property QuoteAllNames As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="quoteallnames", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool QuoteAllNames {get; set;}

Property Value

true if all names should be enclosed in single quotation marks; otherwise, false. The default is false.

Remarks

Corresponds to the /QUOTEALLNAMES flag.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


RawExceptionHandling Property

NAnt SDK Documentation - v0.91

IldasmTask.RawExceptionHandling Property

Specifies whether or not the disassembler should generate structured exception handling clauses in canonical (label) form. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="rawexceptionhandling", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property RawExceptionHandling As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="rawexceptionhandling", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool RawExceptionHandling {get; set;}

Property Value

true if structured exception handling clauses should be generated in canonical form; otherwise, false. The default is false.

Remarks

Corresponds to the /RAWEH flag.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


Source Property

NAnt SDK Documentation - v0.91

IldasmTask.Source Property

Specifies whether or not the disassembler should generate original source lines as comments. The default is false.

[Visual Basic]
<TaskAttribute(Name:="source", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property Source As Boolean
[C#]
[TaskAttribute(Name="source", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool Source {get; set;}

Property Value

true if original source lines should be generated as comments; otherwise, false. The default is false.

Remarks

Corresponds to the /SOURCE flag.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


ToDirectory Property

NAnt SDK Documentation - v0.91

IldasmTask.ToDirectory Property

Specifies the directory to which outputs will be stored.

[Visual Basic]
<TaskAttribute(Name:="todir", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property ToDirectory As DirectoryInfo
[C#]
[TaskAttribute(Name="todir", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.DirectoryInfo ToDirectory {get; set;}

Property Value

A DirectoryInfo that represents the directory to which outputs will be stored.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


Tokens Property

NAnt SDK Documentation - v0.91

IldasmTask.Tokens Property

Specifies whether or not the disassembler should generate metadata token values as comments. The default is false.

[Visual Basic]
<TaskAttribute(Name:="tokens", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property Tokens As Boolean
[C#]
[TaskAttribute(Name="tokens", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool Tokens {get; set;}

Property Value

true if metadata token values should be generated as comments; otherwise, false. The default is false.

Remarks

Corresponds to the /TOKENS flag.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


Unicode Property

NAnt SDK Documentation - v0.91

IldasmTask.Unicode Property

Specifies whether or not the disassembler should use the UNICODE encoding when generating the output. The default is ANSI.

[Visual Basic]
<TaskAttribute(Name:="unicode", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property Unicode As Boolean
[C#]
[TaskAttribute(Name="unicode", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool Unicode {get; set;}

Property Value

true if the output should be generated using the UNICODE encoding; otherwise, false. The default is false.

Remarks

Corresponds to the /UNICODE flag.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


Utf8 Property

NAnt SDK Documentation - v0.91

IldasmTask.Utf8 Property

Specifies whether or not the disassembler should use the UTF-8 encoding when generating the output. The default is ANSI.

[Visual Basic]
<TaskAttribute(Name:="utf8", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property Utf8 As Boolean
[C#]
[TaskAttribute(Name="utf8", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool Utf8 {get; set;}

Property Value

true if the output should be generated using the UTF-8 encoding; otherwise, false. The default is false.

Remarks

Corresponds to the /UTF8 flag.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


Visibility Property

NAnt SDK Documentation - v0.91

IldasmTask.Visibility Property

Instructs the disassembler to disassemble only the items with the specified visibility. Possible values are PUB, PRI, FAM, ASM, FAA, FOA, PSC, or any combination of them separated by +.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="visibility", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Visibility As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="visibility", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Visibility {get; set;}

Property Value

A String that contains the visibility suboptions.

Remarks

Corresponds to the /VISIBILITY flag.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


IldasmTask Methods

The methods of the IldasmTask class are listed below. For a complete list of IldasmTask class members, see the IldasmTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Disassembles the PE file(s).
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Checks whether the task is initialized with valid attributes.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


IldasmTask.ExecuteTask Method

Disassembles the PE file(s).

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

IldasmTask.Initialize Method

Checks whether the task is initialized with valid attributes.

Overload List

Checks whether the task is initialized with valid attributes.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace


IldasmTask.Initialize Method ()

Checks whether the task is initialized with valid attributes.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

IldasmTask Class | NAnt.MSNet.Tasks Namespace | IldasmTask.Initialize Overload List


ServiceControllerTask Class

Allows a Windows service to be controlled.

For a list of all members of this type, see ServiceControllerTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.MSNet.Tasks.ServiceControllerTask

[Visual Basic]
<TaskName(Name:="servicecontroller")>
Public Class ServiceControllerTask
Inherits Task
[C#]
[TaskName(Name="servicecontroller")]
public class ServiceControllerTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Starts the World Wide Web Publishing Service on the local computer.

            <servicecontroller action="Start" service="w3svc" />

Stops the Alerter service on computer 'MOTHER'.

            <servicecontroller action="Stop" service="Alerter" machine="MOTHER" />

Requirements

Namespace: NAnt.MSNet.Tasks

Assembly: NAnt.MSNetTasks (in NAnt.MSNetTasks.dll)

See Also

ServiceControllerTask Members | NAnt.MSNet.Tasks Namespace


ServiceControllerTask Members

ServiceControllerTask overview

Public Instance Constructors

ServiceControllerTask Constructor Initializes a new instance of the ServiceControllerTask class.

Public Instance Properties

Action | The action that should be performed on the service.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
MachineName | The name of the computer on which the service resides. The default is the local computer.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
ServiceName | The name of the service that should be controlled.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
Timeout | The time, in milliseconds, the task will wait for the service to reach the desired status. The default is 5000 milliseconds.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Peforms actions on the service in order to reach the desired status.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ServiceControllerTask Class | NAnt.MSNet.Tasks Namespace


ServiceControllerTask Constructor

Initializes a new instance of the ServiceControllerTask class.

[Visual Basic]
Public Sub New()
[C#]
public ServiceControllerTask();

See Also

ServiceControllerTask Class | NAnt.MSNet.Tasks Namespace


ServiceControllerTask Properties

The properties of the ServiceControllerTask class are listed below. For a complete list of ServiceControllerTask class members, see the ServiceControllerTask Members topic.

Public Instance Properties

Action | The action that should be performed on the service.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
MachineName | The name of the computer on which the service resides. The default is the local computer.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
ServiceName | The name of the service that should be controlled.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
Timeout | The time, in milliseconds, the task will wait for the service to reach the desired status. The default is 5000 milliseconds.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

ServiceControllerTask Class | NAnt.MSNet.Tasks Namespace


Action Property

NAnt SDK Documentation - v0.91

ServiceControllerTask.Action Property

The action that should be performed on the service.

[Visual Basic]
<TaskAttribute(Name:="action", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property Action As ActionType
[C#]
[TaskAttribute(Name="action", Required=True, ExpandProperties=True, ProcessXml=True)]
public ServiceControllerTask.ActionType Action {get; set;}

See Also

ServiceControllerTask Class | NAnt.MSNet.Tasks Namespace


MachineName Property

NAnt SDK Documentation - v0.91

ServiceControllerTask.MachineName Property

The name of the computer on which the service resides. The default is the local computer.

[Visual Basic]
<TaskAttribute(Name:="machine", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property MachineName As String
[C#]
[TaskAttribute(Name="machine", Required=False, ExpandProperties=True, ProcessXml=True)]
public string MachineName {get; set;}

See Also

ServiceControllerTask Class | NAnt.MSNet.Tasks Namespace


ServiceName Property

NAnt SDK Documentation - v0.91

ServiceControllerTask.ServiceName Property

The name of the service that should be controlled.

[Visual Basic]
<TaskAttribute(Name:="service", Required:=True, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property ServiceName As String
[C#]
[TaskAttribute(Name="service", Required=True, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string ServiceName {get; set;}

See Also

ServiceControllerTask Class | NAnt.MSNet.Tasks Namespace


Timeout Property

NAnt SDK Documentation - v0.91

ServiceControllerTask.Timeout Property

The time, in milliseconds, the task will wait for the service to reach the desired status. The default is 5000 milliseconds.

[Visual Basic]
<TaskAttribute(Name:="timeout", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Timeout As Double
[C#]
[TaskAttribute(Name="timeout", Required=False, ExpandProperties=True, ProcessXml=True)]
public double Timeout {get; set;}

See Also

ServiceControllerTask Class | NAnt.MSNet.Tasks Namespace


ServiceControllerTask Methods

The methods of the ServiceControllerTask class are listed below. For a complete list of ServiceControllerTask class members, see the ServiceControllerTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Peforms actions on the service in order to reach the desired status.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ServiceControllerTask Class | NAnt.MSNet.Tasks Namespace


ServiceControllerTask.ExecuteTask Method

Peforms actions on the service in order to reach the desired status.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

ServiceControllerTask Class | NAnt.MSNet.Tasks Namespace


ServiceControllerTask.ActionType Enumeration

Defines the actions that can be performed on a service.

[Visual Basic]
<Serializable>
Public Enum ServiceControllerTask.ActionType
[C#]
[Serializable]
public enum ServiceControllerTask.ActionType

Members

Member Name | Description
Start | Starts a service.
Stop | Stops a service.
Restart | Restarts a service.
Pause | Pauses a running service.
Continue | Continues a paused service.

Requirements

Namespace: NAnt.MSNet.Tasks

Assembly: NAnt.MSNetTasks (in NAnt.MSNetTasks.dll)

See Also

NAnt.MSNet.Tasks Namespace


NAnt.NUnit.Types

NAnt SDK Documentation - v0.91

NAnt.NUnit.Types Namespace

Namespace hierarchy

Classes

Class | Description
FormatterData | Carries data specified through the formatter element.
FormatterDataCollection | Contains a strongly typed collection of FormatterData objects.
FormatterDataEnumerator | Enumerates the FormatterData elements of a FormatterDataCollection.
FormatterElement | Represents the FormatterElement of the NUnit task.
FormatterElementCollection | Contains a strongly typed collection of FormatterElement objects.
FormatterElementEnumerator | Enumerates the FormatterElement elements of a FormatterElementCollection.

Enumerations

Enumeration | Description
FormatterType | The built-in formatter types.


FormatterData Class

Carries data specified through the formatter element.

For a list of all members of this type, see FormatterData Members.

System.Object
NAnt.NUnit.Types.FormatterData

[Visual Basic]
<Serializable, _ Serializable>
Public Class FormatterData
[C#]
[Serializable]
[Serializable]
public class FormatterData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit.Types

Assembly: NAnt.NUnit (in NAnt.NUnit.dll)

See Also

FormatterData Members | NAnt.NUnit.Types Namespace


FormatterData Members

FormatterData overview

Public Instance Constructors

FormatterData Constructor Initializes a new instance of the FormatterData class.

Public Instance Properties

Extension | Gets or sets the extension to append to the output filename.
OutputDirectory | Gets or sets the directory where the output file should be written to, if UseFile is true.
Type | Gets or sets the type of the formatter.
UseFile | Gets or sets a value indicating whether output should be persisted to a file.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FormatterData Class | NAnt.NUnit.Types Namespace


FormatterData Constructor

Initializes a new instance of the FormatterData class.

[Visual Basic]
Public Sub New()
[C#]
public FormatterData();

See Also

FormatterData Class | NAnt.NUnit.Types Namespace


FormatterData Properties

The properties of the FormatterData class are listed below. For a complete list of FormatterData class members, see the FormatterData Members topic.

Public Instance Properties

Extension | Gets or sets the extension to append to the output filename.
OutputDirectory | Gets or sets the directory where the output file should be written to, if UseFile is true.
Type | Gets or sets the type of the formatter.
UseFile | Gets or sets a value indicating whether output should be persisted to a file.

See Also

FormatterData Class | NAnt.NUnit.Types Namespace


Extension Property

NAnt SDK Documentation - v0.91

FormatterData.Extension Property

Gets or sets the extension to append to the output filename.

[Visual Basic]
Public Property Extension As String
[C#]
public string Extension {get; set;}

Property Value

The extension to append to the output filename.

See Also

FormatterData Class | NAnt.NUnit.Types Namespace


OutputDirectory Property

NAnt SDK Documentation - v0.91

FormatterData.OutputDirectory Property

Gets or sets the directory where the output file should be written to, if UseFile is true.

[Visual Basic]
Public Property OutputDirectory As DirectoryInfo
[C#]
public System.IO.DirectoryInfo OutputDirectory {get; set;}

Property Value

The directory where the output file should be written to.

See Also

FormatterData Class | NAnt.NUnit.Types Namespace


Type Property

NAnt SDK Documentation - v0.91

FormatterData.Type Property

Gets or sets the type of the formatter.

[Visual Basic]
Public Property Type As FormatterType
[C#]
public FormatterType Type {get; set;}

Property Value

The type of the formatter.

See Also

FormatterData Class | NAnt.NUnit.Types Namespace


UseFile Property

NAnt SDK Documentation - v0.91

FormatterData.UseFile Property

Gets or sets a value indicating whether output should be persisted to a file.

[Visual Basic]
Public Property UseFile As Boolean
[C#]
public bool UseFile {get; set;}

Property Value

true if output should be written to a file; otherwise, false. The default is false.

See Also

FormatterData Class | NAnt.NUnit.Types Namespace


FormatterDataCollection Class

Contains a strongly typed collection of FormatterData objects.

For a list of all members of this type, see FormatterDataCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.NUnit.Types.FormatterDataCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class FormatterDataCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class FormatterDataCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit.Types

Assembly: NAnt.NUnit (in NAnt.NUnit.dll)

See Also

FormatterDataCollection Members | NAnt.NUnit.Types Namespace


FormatterDataCollection Members

FormatterDataCollection overview

Public Instance Constructors

FormatterDataCollection Overloaded. Initializes a new instance of the FormatterDataCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a FormatterData to the end of the collection.
AddRange | Overloaded. Adds the elements of a FormatterData array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a FormatterData is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified FormatterData object in the collection.
Insert | Inserts a FormatterData into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

FormatterDataCollection Class | NAnt.NUnit.Types Namespace


FormatterDataCollection Constructor

Initializes a new instance of the FormatterDataCollection class.

Overload List

Initializes a new instance of the FormatterDataCollection class.

public FormatterDataCollection();

Initializes a new instance of the FormatterDataCollection class with the specified array of FormatterData instances.

public FormatterDataCollection(FormatterData[]);

Initializes a new instance of the FormatterDataCollection class with the specified FormatterDataCollection instance.

public FormatterDataCollection(FormatterDataCollection);

See Also

FormatterDataCollection Class | NAnt.NUnit.Types Namespace


FormatterDataCollection Constructor ()

Initializes a new instance of the FormatterDataCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FormatterDataCollection();

See Also

FormatterDataCollection Class | NAnt.NUnit.Types Namespace | FormatterDataCollection Constructor Overload List


FormatterDataCollection Constructor (FormatterDataCollection)

Initializes a new instance of the FormatterDataCollection class with the specified FormatterDataCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As FormatterDataCollection _
)
[C#]
public FormatterDataCollection(
FormatterDataCollection value
);

See Also

FormatterDataCollection Class | NAnt.NUnit.Types Namespace | FormatterDataCollection Constructor Overload List


FormatterDataCollection Constructor (FormatterData[])

Initializes a new instance of the FormatterDataCollection class with the specified array of FormatterData instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As FormatterData() _
)
[C#]
public FormatterDataCollection(
FormatterData[] value
);

See Also

FormatterDataCollection Class | NAnt.NUnit.Types Namespace | FormatterDataCollection Constructor Overload List


FormatterDataCollection Properties

The properties of the FormatterDataCollection class are listed below. For a complete list of FormatterDataCollection class members, see the FormatterDataCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

FormatterDataCollection Class | NAnt.NUnit.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

FormatterDataCollection.Item Property

Gets or sets the element at the specified index.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As FormatterData
[C#]
public FormatterData this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

FormatterDataCollection Class | NAnt.NUnit.Types Namespace


FormatterDataCollection Methods

The methods of the FormatterDataCollection class are listed below. For a complete list of FormatterDataCollection class members, see the FormatterDataCollection Members topic.

Public Instance Methods

Add | Adds a FormatterData to the end of the collection.
AddRange | Overloaded. Adds the elements of a FormatterData array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a FormatterData is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified FormatterData object in the collection.
Insert | Inserts a FormatterData into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

FormatterDataCollection Class | NAnt.NUnit.Types Namespace


FormatterDataCollection.Add Method

Adds a FormatterData to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As FormatterData _
) As Integer
[C#]
public int Add(
FormatterData item
);

Parameters

item
The FormatterData to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

FormatterDataCollection Class | NAnt.NUnit.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

FormatterDataCollection.AddRange Method

Adds the elements of a FormatterData array to the end of the collection.

Overload List

Adds the elements of a FormatterData array to the end of the collection.

public void AddRange(FormatterData[]);

Adds the elements of a FormatterDataCollection to the end of the collection.

public void AddRange(FormatterDataCollection);

See Also

FormatterDataCollection Class | NAnt.NUnit.Types Namespace


FormatterDataCollection.AddRange Method (FormatterData[])

Adds the elements of a FormatterData array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As FormatterData() _
)
[C#]
public void AddRange(
FormatterData[] items
);

Parameters

items
The array of FormatterData elements to be added to the end of the collection.

See Also

FormatterDataCollection Class | NAnt.NUnit.Types Namespace | FormatterDataCollection.AddRange Overload List


FormatterDataCollection.AddRange Method (FormatterDataCollection)

Adds the elements of a FormatterDataCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As FormatterDataCollection _
)
[C#]
public void AddRange(
FormatterDataCollection items
);

Parameters

items
The FormatterDataCollection to be added to the end of the collection.

See Also

FormatterDataCollection Class | NAnt.NUnit.Types Namespace | FormatterDataCollection.AddRange Overload List


FormatterDataCollection.Contains Method

Determines whether a FormatterData is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal item As FormatterData _
) As Boolean
[C#]
public bool Contains(
FormatterData item
);

Parameters

item
The FormatterData to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

FormatterDataCollection Class | NAnt.NUnit.Types Namespace


FormatterDataCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As FormatterData(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
FormatterData[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

FormatterDataCollection Class | NAnt.NUnit.Types Namespace


FormatterDataCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As FormatterDataEnumerator
[C#]
new public FormatterDataEnumerator GetEnumerator();

Return Value

A FormatterDataEnumerator for the entire collection.

See Also

FormatterDataCollection Class | NAnt.NUnit.Types Namespace


FormatterDataCollection.IndexOf Method

Retrieves the index of a specified FormatterData object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As FormatterData _
) As Integer
[C#]
public int IndexOf(
FormatterData item
);

Parameters

item
The FormatterData object for which the index is returned.

Return Value

The index of the specified FormatterData. If the FormatterData is not currently a member of the collection, it returns -1.

See Also

FormatterDataCollection Class | NAnt.NUnit.Types Namespace


FormatterDataCollection.Insert Method

Inserts a FormatterData into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As FormatterData _
)
[C#]
public void Insert(
int index,
FormatterData item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The FormatterData to insert.

See Also

FormatterDataCollection Class | NAnt.NUnit.Types Namespace


FormatterDataCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As FormatterData _
)
[C#]
public void Remove(
FormatterData item
);

Parameters

item
The FormatterData to remove from the collection.

See Also

FormatterDataCollection Class | NAnt.NUnit.Types Namespace


FormatterDataEnumerator Class

Enumerates the FormatterData elements of a FormatterDataCollection.

For a list of all members of this type, see FormatterDataEnumerator Members.

System.Object
NAnt.NUnit.Types.FormatterDataEnumerator

[Visual Basic]
Public Class FormatterDataEnumerator
Implements IEnumerator
[C#]
public class FormatterDataEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit.Types

Assembly: NAnt.NUnit (in NAnt.NUnit.dll)

See Also

FormatterDataEnumerator Members | NAnt.NUnit.Types Namespace


FormatterDataEnumerator Members

FormatterDataEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FormatterDataEnumerator Class | NAnt.NUnit.Types Namespace


FormatterDataEnumerator Properties

The properties of the FormatterDataEnumerator class are listed below. For a complete list of FormatterDataEnumerator class members, see the FormatterDataEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

FormatterDataEnumerator Class | NAnt.NUnit.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

FormatterDataEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As FormatterData
[C#]
public FormatterData Current {get;}

See Also

FormatterDataEnumerator Class | NAnt.NUnit.Types Namespace


FormatterDataEnumerator Methods

The methods of the FormatterDataEnumerator class are listed below. For a complete list of FormatterDataEnumerator class members, see the FormatterDataEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FormatterDataEnumerator Class | NAnt.NUnit.Types Namespace


FormatterDataEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

FormatterDataEnumerator Class | NAnt.NUnit.Types Namespace


FormatterDataEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

FormatterDataEnumerator Class | NAnt.NUnit.Types Namespace


FormatterElement Class

Represents the FormatterElement of the NUnit task.

For a list of all members of this type, see FormatterElement Members.

System.Object
NAnt.Core.Element
NAnt.NUnit.Types.FormatterElement

[Visual Basic]
<ElementName(Name:="formatter")>
Public Class FormatterElement
Inherits Element
[C#]
[ElementName(Name="formatter")]
public class FormatterElement : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit.Types

Assembly: NAnt.NUnit (in NAnt.NUnit.dll)

See Also

FormatterElement Members | NAnt.NUnit.Types Namespace


FormatterElement Members

FormatterElement overview

Public Instance Constructors

FormatterElement Constructor Initializes a new instance of the FormatterElement class.

Public Instance Properties

Data | Gets the underlying FormatterData for the element.
Extension | Extension to append to the output filename.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OutputDirectory | Specifies the directory where the output file should be written to, if UseFile is true. If not specified, the output file will be written to the directory where the test module is located.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Type | Type of formatter.
UseFile | Determines whether output should be persisted to a file. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FormatterElement Class | NAnt.NUnit.Types Namespace


FormatterElement Constructor

Initializes a new instance of the FormatterElement class.

[Visual Basic]
Public Sub New()
[C#]
public FormatterElement();

See Also

FormatterElement Class | NAnt.NUnit.Types Namespace


FormatterElement Properties

The properties of the FormatterElement class are listed below. For a complete list of FormatterElement class members, see the FormatterElement Members topic.

Public Instance Properties

Data | Gets the underlying FormatterData for the element.
Extension | Extension to append to the output filename.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OutputDirectory | Specifies the directory where the output file should be written to, if UseFile is true. If not specified, the output file will be written to the directory where the test module is located.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Type | Type of formatter.
UseFile | Determines whether output should be persisted to a file. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

FormatterElement Class | NAnt.NUnit.Types Namespace


Data Property

NAnt SDK Documentation - v0.91

FormatterElement.Data Property

Gets the underlying FormatterData for the element.

[Visual Basic]
Public ReadOnly Property Data As FormatterData
[C#]
public FormatterData Data {get;}

See Also

FormatterElement Class | NAnt.NUnit.Types Namespace


Extension Property

NAnt SDK Documentation - v0.91

FormatterElement.Extension Property

Extension to append to the output filename.

[Visual Basic]
<TaskAttribute(Name:="extension", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Extension As String
[C#]
[TaskAttribute(Name="extension", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Extension {get; set;}

See Also

FormatterElement Class | NAnt.NUnit.Types Namespace


OutputDirectory Property

NAnt SDK Documentation - v0.91

FormatterElement.OutputDirectory Property

Specifies the directory where the output file should be written to, if UseFile is true. If not specified, the output file will be written to the directory where the test module is located.

[Visual Basic]
<TaskAttribute(Name:="outputdir", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property OutputDirectory As DirectoryInfo
[C#]
[TaskAttribute(Name="outputdir", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.DirectoryInfo OutputDirectory {get; set;}

See Also

FormatterElement Class | NAnt.NUnit.Types Namespace


Type Property

NAnt SDK Documentation - v0.91

FormatterElement.Type Property

Type of formatter.

[Visual Basic]
<TaskAttribute(Name:="type", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property Type As FormatterType
[C#]
[TaskAttribute(Name="type", Required=True, ExpandProperties=True, ProcessXml=True)]
public FormatterType Type {get; set;}

See Also

FormatterElement Class | NAnt.NUnit.Types Namespace


UseFile Property

NAnt SDK Documentation - v0.91

FormatterElement.UseFile Property

Determines whether output should be persisted to a file. The default is false.

[Visual Basic]
<TaskAttribute(Name:="usefile", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property UseFile As Boolean
[C#]
[TaskAttribute(Name="usefile", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool UseFile {get; set;}

See Also

FormatterElement Class | NAnt.NUnit.Types Namespace


FormatterElementCollection Class

Contains a strongly typed collection of FormatterElement objects.

For a list of all members of this type, see FormatterElementCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.NUnit.Types.FormatterElementCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class FormatterElementCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class FormatterElementCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit.Types

Assembly: NAnt.NUnit (in NAnt.NUnit.dll)

See Also

FormatterElementCollection Members | NAnt.NUnit.Types Namespace


FormatterElementCollection Members

FormatterElementCollection overview

Public Instance Constructors

FormatterElementCollection Overloaded. Initializes a new instance of the FormatterElementCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a FormatterElement to the end of the collection.
AddRange | Overloaded. Adds the elements of a FormatterElement array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a FormatterElement is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified FormatterElement object in the collection.
Insert | Inserts a FormatterElement into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

FormatterElementCollection Class | NAnt.NUnit.Types Namespace


FormatterElementCollection Constructor

Initializes a new instance of the FormatterElementCollection class.

Overload List

Initializes a new instance of the FormatterElementCollection class.

public FormatterElementCollection();

Initializes a new instance of the FormatterElementCollection class with the specified array of FormatterElement instances.

public FormatterElementCollection(FormatterElement[]);

Initializes a new instance of the FormatterElementCollection class with the specified FormatterElementCollection instance.

public FormatterElementCollection(FormatterElementCollection);

See Also

FormatterElementCollection Class | NAnt.NUnit.Types Namespace


FormatterElementCollection Constructor ()

Initializes a new instance of the FormatterElementCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FormatterElementCollection();

See Also

FormatterElementCollection Class | NAnt.NUnit.Types Namespace | FormatterElementCollection Constructor Overload List


FormatterElementCollection Constructor (FormatterElementCollection)

Initializes a new instance of the FormatterElementCollection class with the specified FormatterElementCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As FormatterElementCollection _
)
[C#]
public FormatterElementCollection(
FormatterElementCollection value
);

See Also

FormatterElementCollection Class | NAnt.NUnit.Types Namespace | FormatterElementCollection Constructor Overload List


FormatterElementCollection Constructor (FormatterElement[])

Initializes a new instance of the FormatterElementCollection class with the specified array of FormatterElement instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As FormatterElement() _
)
[C#]
public FormatterElementCollection(
FormatterElement[] value
);

See Also

FormatterElementCollection Class | NAnt.NUnit.Types Namespace | FormatterElementCollection Constructor Overload List


FormatterElementCollection Properties

The properties of the FormatterElementCollection class are listed below. For a complete list of FormatterElementCollection class members, see the FormatterElementCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

FormatterElementCollection Class | NAnt.NUnit.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

FormatterElementCollection.Item Property

Gets or sets the element at the specified index.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As FormatterElement
[C#]
public FormatterElement this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

FormatterElementCollection Class | NAnt.NUnit.Types Namespace


FormatterElementCollection Methods

The methods of the FormatterElementCollection class are listed below. For a complete list of FormatterElementCollection class members, see the FormatterElementCollection Members topic.

Public Instance Methods

Add | Adds a FormatterElement to the end of the collection.
AddRange | Overloaded. Adds the elements of a FormatterElement array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a FormatterElement is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified FormatterElement object in the collection.
Insert | Inserts a FormatterElement into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

FormatterElementCollection Class | NAnt.NUnit.Types Namespace


FormatterElementCollection.Add Method

Adds a FormatterElement to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As FormatterElement _
) As Integer
[C#]
public int Add(
FormatterElement item
);

Parameters

item
The FormatterElement to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

FormatterElementCollection Class | NAnt.NUnit.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

FormatterElementCollection.AddRange Method

Adds the elements of a FormatterElement array to the end of the collection.

Overload List

Adds the elements of a FormatterElement array to the end of the collection.

public void AddRange(FormatterElement[]);

Adds the elements of a FormatterElementCollection to the end of the collection.

public void AddRange(FormatterElementCollection);

See Also

FormatterElementCollection Class | NAnt.NUnit.Types Namespace


FormatterElementCollection.AddRange Method (FormatterElement[])

Adds the elements of a FormatterElement array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As FormatterElement() _
)
[C#]
public void AddRange(
FormatterElement[] items
);

Parameters

items
The array of FormatterElement elements to be added to the end of the collection.

See Also

FormatterElementCollection Class | NAnt.NUnit.Types Namespace | FormatterElementCollection.AddRange Overload List


FormatterElementCollection.AddRange Method (FormatterElementCollection)

Adds the elements of a FormatterElementCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As FormatterElementCollection _
)
[C#]
public void AddRange(
FormatterElementCollection items
);

Parameters

items
The FormatterElementCollection to be added to the end of the collection.

See Also

FormatterElementCollection Class | NAnt.NUnit.Types Namespace | FormatterElementCollection.AddRange Overload List


FormatterElementCollection.Contains Method

Determines whether a FormatterElement is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal item As FormatterElement _
) As Boolean
[C#]
public bool Contains(
FormatterElement item
);

Parameters

item
The FormatterElement to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

FormatterElementCollection Class | NAnt.NUnit.Types Namespace


FormatterElementCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As FormatterElement(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
FormatterElement[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

FormatterElementCollection Class | NAnt.NUnit.Types Namespace


FormatterElementCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As FormatterElementEnumerator
[C#]
new public FormatterElementEnumerator GetEnumerator();

Return Value

A FormatterElementEnumerator for the entire collection.

See Also

FormatterElementCollection Class | NAnt.NUnit.Types Namespace


FormatterElementCollection.IndexOf Method

Retrieves the index of a specified FormatterElement object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As FormatterElement _
) As Integer
[C#]
public int IndexOf(
FormatterElement item
);

Parameters

item
The FormatterElement object for which the index is returned.

Return Value

The index of the specified FormatterElement. If the FormatterElement is not currently a member of the collection, it returns -1.

See Also

FormatterElementCollection Class | NAnt.NUnit.Types Namespace


FormatterElementCollection.Insert Method

Inserts a FormatterElement into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As FormatterElement _
)
[C#]
public void Insert(
int index,
FormatterElement item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The FormatterElement to insert.

See Also

FormatterElementCollection Class | NAnt.NUnit.Types Namespace


FormatterElementCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As FormatterElement _
)
[C#]
public void Remove(
FormatterElement item
);

Parameters

item
The FormatterElement to remove from the collection.

See Also

FormatterElementCollection Class | NAnt.NUnit.Types Namespace


FormatterElementEnumerator Class

Enumerates the FormatterElement elements of a FormatterElementCollection.

For a list of all members of this type, see FormatterElementEnumerator Members.

System.Object
NAnt.NUnit.Types.FormatterElementEnumerator

[Visual Basic]
Public Class FormatterElementEnumerator
Implements IEnumerator
[C#]
public class FormatterElementEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit.Types

Assembly: NAnt.NUnit (in NAnt.NUnit.dll)

See Also

FormatterElementEnumerator Members | NAnt.NUnit.Types Namespace


FormatterElementEnumerator Members

FormatterElementEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FormatterElementEnumerator Class | NAnt.NUnit.Types Namespace


FormatterElementEnumerator Properties

The properties of the FormatterElementEnumerator class are listed below. For a complete list of FormatterElementEnumerator class members, see the FormatterElementEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

FormatterElementEnumerator Class | NAnt.NUnit.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

FormatterElementEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As FormatterElement
[C#]
public FormatterElement Current {get;}

See Also

FormatterElementEnumerator Class | NAnt.NUnit.Types Namespace


FormatterElementEnumerator Methods

The methods of the FormatterElementEnumerator class are listed below. For a complete list of FormatterElementEnumerator class members, see the FormatterElementEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FormatterElementEnumerator Class | NAnt.NUnit.Types Namespace


FormatterElementEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

FormatterElementEnumerator Class | NAnt.NUnit.Types Namespace


FormatterElementEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

FormatterElementEnumerator Class | NAnt.NUnit.Types Namespace


FormatterType Enumeration

The built-in formatter types.

[Visual Basic]
<Serializable>
Public Enum FormatterType
[C#]
[Serializable]
public enum FormatterType

Members

Member Name | Description
Plain | A plaintext formatter.
Xml | An XML formatter.

Requirements

Namespace: NAnt.NUnit.Types

Assembly: NAnt.NUnit (in NAnt.NUnit.dll)

See Also

NAnt.NUnit.Types Namespace


NAnt.NUnit1.Tasks

NAnt SDK Documentation - v0.91

NAnt.NUnit1.Tasks Namespace

Namespace hierarchy

Classes

Class | Description
NUnitTask | Obsolete. Runs tests using the NUnit V1.0 framework.
NUnitTestRunner |
RemoteNUnitTestRunner |

Enumerations

Enumeration | Description
RunnerResult |


NUnitTask Class

NOTE: This class is now obsolete.

In a future release, this task will be moved to NAntContrib. However, we strongly advise you to upgrade to NUnit 2.x.

Runs tests using the NUnit V1.0 framework.

For a list of all members of this type, see NUnitTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.NUnit1.Tasks.NUnitTask

[Visual Basic]
<Obsolete(Message:="In a future release, this task will be moved to NAntContrib. However, we strongly advise you to upgrade to NUnit 2.x.", IsError:=False), _ TaskName(Name:="nunit")>
Public Class NUnitTask
Inherits Task
[C#]
[Obsolete(Message="In a future release, this task will be moved to NAntContrib. However, we strongly advise you to upgrade to NUnit 2.x.", IsError=False)]
[TaskName(Name="nunit")]
public class NUnitTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

See the NUnit home page for more information.

The HaltOnFailure or HaltOnError attributes are only used to stop more than one test suite to stop running. If any test suite fails a build error will be thrown. Set FailOnError to false to ignore test errors and continue build.

Example

Run tests in the MyProject.Tests.dll assembly.

The test results are logged in results.xml and results.txt using the Xml and Plain formatters, respectively.

<nunit basedir="build" verbose="false" haltonerror="true" haltonfailure="true">
    <formatter type="Xml" />
    <formatter type="Plain" />
    <test name="MyProject.Tests.AllTests" assembly="MyProject.Tests.dll" outfile="results"/>
</nunit>

Requirements

Namespace: NAnt.NUnit1.Tasks

Assembly: NAnt.NUnit1Tasks (in NAnt.NUnit1Tasks.dll)

See Also

NUnitTask Members | NAnt.NUnit1.Tasks Namespace


NUnitTask Members

NUnitTask overview

Public Instance Constructors

NUnitTask Constructor Initializes a new instance of the NUnitTask class.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
FormatterElements | Formatters to output results of unit tests.
HaltOnError | Stops running tests when a test causes an error. The default is false.
HaltOnFailure | Stops running tests if a test fails (errors are considered failures as well). The default is false.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Tests | Tests to run.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
Timeout | Cancel the individual tests if they do not finish in the specified time (measured in milliseconds). Ignored if fork is disabled.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NUnitTask Class | NAnt.NUnit1.Tasks Namespace


NUnitTask Constructor

Initializes a new instance of the NUnitTask class.

[Visual Basic]
Public Sub New()
[C#]
public NUnitTask();

See Also

NUnitTask Class | NAnt.NUnit1.Tasks Namespace


NUnitTask Properties

The properties of the NUnitTask class are listed below. For a complete list of NUnitTask class members, see the NUnitTask Members topic.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
FormatterElements | Formatters to output results of unit tests.
HaltOnError | Stops running tests when a test causes an error. The default is false.
HaltOnFailure | Stops running tests if a test fails (errors are considered failures as well). The default is false.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Tests | Tests to run.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
Timeout | Cancel the individual tests if they do not finish in the specified time (measured in milliseconds). Ignored if fork is disabled.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

NUnitTask Class | NAnt.NUnit1.Tasks Namespace


FormatterElements Property

NAnt SDK Documentation - v0.91

NUnitTask.FormatterElements Property

Formatters to output results of unit tests.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="formatter", Required:=False, ProcessXml:=True)>
Public ReadOnly Property FormatterElements As FormatterElementCollection
[C#]
[BuildElementArray(ElementType=null, Name="formatter", Required=False, ProcessXml=True)]
public NAnt.NUnit.Types.FormatterElementCollection FormatterElements {get;}

See Also

NUnitTask Class | NAnt.NUnit1.Tasks Namespace


HaltOnError Property

NAnt SDK Documentation - v0.91

NUnitTask.HaltOnError Property

Stops running tests when a test causes an error. The default is false.

[Visual Basic]
<TaskAttribute(Name:="haltonerror", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property HaltOnError As Boolean
[C#]
[TaskAttribute(Name="haltonerror", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool HaltOnError {get; set;}

Remarks

Implies haltonfailure.

See Also

NUnitTask Class | NAnt.NUnit1.Tasks Namespace


HaltOnFailure Property

NAnt SDK Documentation - v0.91

NUnitTask.HaltOnFailure Property

Stops running tests if a test fails (errors are considered failures as well). The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="haltonfailure", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property HaltOnFailure As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="haltonfailure", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool HaltOnFailure {get; set;}

See Also

NUnitTask Class | NAnt.NUnit1.Tasks Namespace


Tests Property

NAnt SDK Documentation - v0.91

NUnitTask.Tests Property

Tests to run.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="test", Required:=False, ProcessXml:=True)>
Public ReadOnly Property Tests As NUnitTestCollection
[C#]
[BuildElementArray(ElementType=null, Name="test", Required=False, ProcessXml=True)]
public NAnt.NUnit1.Types.NUnitTestCollection Tests {get;}

See Also

NUnitTask Class | NAnt.NUnit1.Tasks Namespace


Timeout Property

NAnt SDK Documentation - v0.91

NUnitTask.Timeout Property

Cancel the individual tests if they do not finish in the specified time (measured in milliseconds). Ignored if fork is disabled.

[Visual Basic]
<TaskAttribute(Name:="timeout", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Timeout As Integer
[C#]
[TaskAttribute(Name="timeout", Required=False, ExpandProperties=True, ProcessXml=True)]
public int Timeout {get; set;}

See Also

NUnitTask Class | NAnt.NUnit1.Tasks Namespace


NUnitTask Methods

The methods of the NUnitTask class are listed below. For a complete list of NUnitTask class members, see the NUnitTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NUnitTask Class | NAnt.NUnit1.Tasks Namespace


NUnitTask.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

NUnitTask Class | NAnt.NUnit1.Tasks Namespace


NUnitTestRunner Class

For a list of all members of this type, see NUnitTestRunner Members.

System.Object
System.MarshalByRefObject
NUnit.Runner.BaseTestRunner
NAnt.NUnit1.Tasks.NUnitTestRunner

[Visual Basic]
Public Class NUnitTestRunner
Inherits BaseTestRunner
[C#]
public class NUnitTestRunner : BaseTestRunner

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit1.Tasks

Assembly: NAnt.NUnit1Tasks (in NAnt.NUnit1Tasks.dll)

See Also

NUnitTestRunner Members | NAnt.NUnit1.Tasks Namespace


NUnitTestRunner Members

NUnitTestRunner overview

Public Instance Constructors

NUnitTestRunner Constructor

Public Instance Properties

Formatters | Gets the collection of registered formatters.
ResultCode | Gets the result of the test.

Public Instance Methods

AddError |
AddFailure |
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
EndTest |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetLoader (inherited from NUnit.Runner.BaseTestRunner) |
GetTest (inherited from NUnit.Runner.BaseTestRunner) |
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
NeedsRunning | Determines if the unit test needs running.
Run | Runs a Suite extracted from a TestCase subclass.
StartTest |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CreateFormatter |
CreateFormatters | Creates the formatters to be used when running this test.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOutput | Returns the output file or null if does not use a file.
LoadSuiteClass (inherited from NUnit.Runner.BaseTestRunner) |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
ProcessArguments (inherited from NUnit.Runner.BaseTestRunner) |
RunFailed |
SetLoading (inherited from NUnit.Runner.BaseTestRunner) |
UseReloadingTestSuiteLoader (inherited from NUnit.Runner.BaseTestRunner) |

See Also

NUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


NUnitTestRunner Constructor

[Visual Basic]
Public Sub New( _
ByVal testData As NUnitTestData _
)
[C#]
public NUnitTestRunner(
NUnitTestData testData
);

See Also

NUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


NUnitTestRunner Properties

The properties of the NUnitTestRunner class are listed below. For a complete list of NUnitTestRunner class members, see the NUnitTestRunner Members topic.

Public Instance Properties

Formatters | Gets the collection of registered formatters.
ResultCode | Gets the result of the test.

See Also

NUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


Formatters Property

NAnt SDK Documentation - v0.91

NUnitTestRunner.Formatters Property

Gets the collection of registered formatters.

[Visual Basic]
Public ReadOnly Property Formatters As IResultFormatterCollection
[C#]
public NAnt.NUnit1.Types.IResultFormatterCollection Formatters {get;}

Property Value

Collection of registered formatters.

See Also

NUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


ResultCode Property

NAnt SDK Documentation - v0.91

NUnitTestRunner.ResultCode Property

Gets the result of the test.

[Visual Basic]
Public ReadOnly Property ResultCode As RunnerResult
[C#]
public RunnerResult ResultCode {get;}

Property Value

The result of the test.

See Also

NUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


NUnitTestRunner Methods

The methods of the NUnitTestRunner class are listed below. For a complete list of NUnitTestRunner class members, see the NUnitTestRunner Members topic.

Public Instance Methods

AddError |
AddFailure |
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
EndTest |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetLoader (inherited from NUnit.Runner.BaseTestRunner) |
GetTest (inherited from NUnit.Runner.BaseTestRunner) |
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
NeedsRunning | Determines if the unit test needs running.
Run | Runs a Suite extracted from a TestCase subclass.
StartTest |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CreateFormatter |
CreateFormatters | Creates the formatters to be used when running this test.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOutput | Returns the output file or null if does not use a file.
LoadSuiteClass (inherited from NUnit.Runner.BaseTestRunner) |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
ProcessArguments (inherited from NUnit.Runner.BaseTestRunner) |
RunFailed |
SetLoading (inherited from NUnit.Runner.BaseTestRunner) |
UseReloadingTestSuiteLoader (inherited from NUnit.Runner.BaseTestRunner) |

See Also

NUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


NUnitTestRunner.AddError Method

[Visual Basic]
Overrides Public Sub AddError( _
ByVal test As ITest, _
ByVal t As Exception _
) _
Implements ITestListener.AddError
[C#]
public override void AddError(
ITest test,
Exception t
);

Implements

ITestListener.AddError

See Also

NUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


NUnitTestRunner.AddFailure Method

[Visual Basic]
Overrides Public Sub AddFailure( _
ByVal test As ITest, _
ByVal t As AssertionFailedError _
) _
Implements ITestListener.AddFailure
[C#]
public override void AddFailure(
ITest test,
AssertionFailedError t
);

Implements

ITestListener.AddFailure

See Also

NUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


NUnitTestRunner.CreateFormatter Method

[Visual Basic]
Protected Function CreateFormatter( _
ByVal type As FormatterType, _
ByVal outfile As FileInfo _
) As IResultFormatter
[C#]
protected IResultFormatter CreateFormatter(
FormatterType type,
FileInfo outfile
);

See Also

NUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


NUnitTestRunner.CreateFormatters Method

Creates the formatters to be used when running this test.

[Visual Basic]
Protected Sub CreateFormatters( _
ByVal testData As NUnitTestData, _
ByVal logPrefix As String, _
ByVal verbose As Boolean _
)
[C#]
protected void CreateFormatters(
NUnitTestData testData,
string logPrefix,
bool verbose
);

See Also

NUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


NUnitTestRunner.EndTest Method

[Visual Basic]
Overrides Public Sub EndTest( _
ByVal test As ITest _
) _
Implements ITestListener.EndTest
[C#]
public override void EndTest(
ITest test
);

Implements

ITestListener.EndTest

See Also

NUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


NUnitTestRunner.GetOutput Method

Returns the output file or null if does not use a file.

[Visual Basic]
Protected Function GetOutput( _
ByVal formatterData As FormatterData, _
ByVal test As NUnitTestData _
) As FileInfo
[C#]
protected FileInfo GetOutput(
FormatterData formatterData,
NUnitTestData test
);

See Also

NUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


NUnitTestRunner.NeedsRunning Method

Determines if the unit test needs running.

[Visual Basic]
Public Function NeedsRunning() As Boolean
[C#]
public bool NeedsRunning();

Return Value

true if unit test needs running, otherwise, false.

Remarks

Determines if the test needs running by looking at the date stamp of the test assembly and the test results log.

See Also

NUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


NUnitTestRunner.Run Method

Runs a Suite extracted from a TestCase subclass.

[Visual Basic]
Public Sub Run( _
ByVal logPrefix As String, _
ByVal verbose As Boolean _
)
[C#]
public void Run(
string logPrefix,
bool verbose
);

See Also

NUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


NUnitTestRunner.RunFailed Method

[Visual Basic]
Overrides Protected Sub RunFailed( _
ByVal message As String _
)
[C#]
protected override void RunFailed(
string message
);

See Also

NUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


NUnitTestRunner.StartTest Method

[Visual Basic]
Overrides Public Sub StartTest( _
ByVal test As ITest _
) _
Implements ITestListener.StartTest
[C#]
public override void StartTest(
ITest test
);

Implements

ITestListener.StartTest

See Also

NUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


RemoteNUnitTestRunner Class

For a list of all members of this type, see RemoteNUnitTestRunner Members.

System.Object
System.MarshalByRefObject
NAnt.NUnit1.Tasks.RemoteNUnitTestRunner

[Visual Basic]
Public Class RemoteNUnitTestRunner
Inherits MarshalByRefObject
[C#]
public class RemoteNUnitTestRunner : MarshalByRefObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit1.Tasks

Assembly: NAnt.NUnit1Tasks (in NAnt.NUnit1Tasks.dll)

See Also

RemoteNUnitTestRunner Members | NAnt.NUnit1.Tasks Namespace


RemoteNUnitTestRunner Members

RemoteNUnitTestRunner overview

Public Instance Constructors

RemoteNUnitTestRunner Constructor

Public Instance Properties

Formatters
ResultCode

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.

See Also

RemoteNUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


RemoteNUnitTestRunner Constructor

[Visual Basic]
Public Sub New( _
ByVal testData As NUnitTestData _
)
[C#]
public RemoteNUnitTestRunner(
NUnitTestData testData
);

See Also

RemoteNUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


RemoteNUnitTestRunner Properties

The properties of the RemoteNUnitTestRunner class are listed below. For a complete list of RemoteNUnitTestRunner class members, see the RemoteNUnitTestRunner Members topic.

Public Instance Properties

Formatters
ResultCode

See Also

RemoteNUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


Formatters Property

NAnt SDK Documentation - v0.91

RemoteNUnitTestRunner.Formatters Property

[Visual Basic]
Public ReadOnly Property Formatters As IResultFormatterCollection
[C#]
public NAnt.NUnit1.Types.IResultFormatterCollection Formatters {get;}

See Also

RemoteNUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


ResultCode Property

NAnt SDK Documentation - v0.91

RemoteNUnitTestRunner.ResultCode Property

[Visual Basic]
Public ReadOnly Property ResultCode As RunnerResult
[C#]
public RunnerResult ResultCode {get;}

See Also

RemoteNUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


RemoteNUnitTestRunner Methods

The methods of the RemoteNUnitTestRunner class are listed below. For a complete list of RemoteNUnitTestRunner class members, see the RemoteNUnitTestRunner Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.

See Also

RemoteNUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


RemoteNUnitTestRunner.Run Method

[Visual Basic]
Public Sub Run( _
ByVal logPrefix As String, _
ByVal verbose As Boolean _
)
[C#]
public void Run(
string logPrefix,
bool verbose
);

See Also

RemoteNUnitTestRunner Class | NAnt.NUnit1.Tasks Namespace


RunnerResult Enumeration

[Visual Basic]
<Serializable>
Public Enum RunnerResult
[C#]
[Serializable]
public enum RunnerResult

Members

Member Name | Description
Success |
Failures |
Errors |

Requirements

Namespace: NAnt.NUnit1.Tasks

Assembly: NAnt.NUnit1Tasks (in NAnt.NUnit1Tasks.dll)

See Also

NAnt.NUnit1.Tasks Namespace


NAnt.NUnit1.Types

NAnt SDK Documentation - v0.91

NAnt.NUnit1.Types Namespace

Namespace hierarchy

Classes

Class | Description
IResultFormatterCollection | Contains a strongly typed collection of IResultFormatter objects.
IResultFormatterEnumerator | Enumerates the IResultFormatter elements of a IResultFormatterCollection.
LogFormatter | Prints information about running tests directly to the build log.
NUnitTest | Represents a test element of an NUnitTask.
NUnitTestCollection | Contains a strongly typed collection of NUnitTest objects.
NUnitTestData | Carries data specified through the test element.
NUnitTestEnumerator | Enumerates the NUnitTest elements of a NUnitTestCollection.
PlainTextFormatter | Prints information about running tests in plain text.
TestResultExtra | Decorates NUnits TestResult with extra information such as run-time.
XmlResultFormatter | Prints detailed information about running tests in XML format.

Interfaces

Interface | Description
IResultFormatter |


IResultFormatter Interface

For a list of all members of this type, see IResultFormatter Members.

[Visual Basic]
Public Interface IResultFormatter
Implements ITestListener
[C#]
public interface IResultFormatter : ITestListener

Types that implement IResultFormatter

Type | Description
LogFormatter | Prints information about running tests directly to the build log.
PlainTextFormatter | Prints information about running tests in plain text.
XmlResultFormatter | Prints detailed information about running tests in XML format.

Requirements

Namespace: NAnt.NUnit1.Types

Assembly: NAnt.NUnit1Tasks (in NAnt.NUnit1Tasks.dll)

See Also

IResultFormatter Members | NAnt.NUnit1.Types Namespace


IResultFormatter Members

IResultFormatter overview

Public Instance Methods

EndTestSuite | The whole test suite ended.
SetOutput | Sets the TextWriter the formatter is supposed to write its results to.
StartTestSuite | The whole test suite started.

See Also

IResultFormatter Interface | NAnt.NUnit1.Types Namespace


IResultFormatter Methods

The methods of the IResultFormatter interface are listed below. For a complete list of IResultFormatter interface members, see the IResultFormatter Members topic.

Public Instance Methods

EndTestSuite | The whole test suite ended.
SetOutput | Sets the TextWriter the formatter is supposed to write its results to.
StartTestSuite | The whole test suite started.

See Also

IResultFormatter Interface | NAnt.NUnit1.Types Namespace


IResultFormatter.EndTestSuite Method

The whole test suite ended.

[Visual Basic]
Sub EndTestSuite( _
ByVal result As TestResultExtra _
)
[C#]
void EndTestSuite(
TestResultExtra result
);

See Also

IResultFormatter Interface | NAnt.NUnit1.Types Namespace


IResultFormatter.SetOutput Method

Sets the TextWriter the formatter is supposed to write its results to.

[Visual Basic]
Sub SetOutput( _
ByVal writer As TextWriter _
)
[C#]
void SetOutput(
TextWriter writer
);

See Also

IResultFormatter Interface | NAnt.NUnit1.Types Namespace


IResultFormatter.StartTestSuite Method

The whole test suite started.

[Visual Basic]
Sub StartTestSuite( _
ByVal suite As NUnitTestData _
)
[C#]
void StartTestSuite(
NUnitTestData suite
);

See Also

IResultFormatter Interface | NAnt.NUnit1.Types Namespace


IResultFormatterCollection Class

Contains a strongly typed collection of IResultFormatter objects.

For a list of all members of this type, see IResultFormatterCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.NUnit1.Types.IResultFormatterCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class IResultFormatterCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class IResultFormatterCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit1.Types

Assembly: NAnt.NUnit1Tasks (in NAnt.NUnit1Tasks.dll)

See Also

IResultFormatterCollection Members | NAnt.NUnit1.Types Namespace


IResultFormatterCollection Members

IResultFormatterCollection overview

Public Instance Constructors

IResultFormatterCollection Overloaded. Initializes a new instance of the IResultFormatterCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a IResultFormatter to the end of the collection.
AddRange | Overloaded. Adds the elements of a IResultFormatter array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a IResultFormatter is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified IResultFormatter object in the collection.
Insert | Inserts a IResultFormatter into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

IResultFormatterCollection Class | NAnt.NUnit1.Types Namespace


IResultFormatterCollection Constructor

Initializes a new instance of the IResultFormatterCollection class.

Overload List

Initializes a new instance of the IResultFormatterCollection class.

public IResultFormatterCollection();

Initializes a new instance of the IResultFormatterCollection class with the specified array of IResultFormatter instances.

public IResultFormatterCollection(IResultFormatter[]);

Initializes a new instance of the IResultFormatterCollection class with the specified IResultFormatterCollection instance.

public IResultFormatterCollection(IResultFormatterCollection);

See Also

IResultFormatterCollection Class | NAnt.NUnit1.Types Namespace


IResultFormatterCollection Constructor ()

Initializes a new instance of the IResultFormatterCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public IResultFormatterCollection();

See Also

IResultFormatterCollection Class | NAnt.NUnit1.Types Namespace | IResultFormatterCollection Constructor Overload List


IResultFormatterCollection Constructor (IResultFormatterCollection)

Initializes a new instance of the IResultFormatterCollection class with the specified IResultFormatterCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As IResultFormatterCollection _
)
[C#]
public IResultFormatterCollection(
IResultFormatterCollection value
);

See Also

IResultFormatterCollection Class | NAnt.NUnit1.Types Namespace | IResultFormatterCollection Constructor Overload List


IResultFormatterCollection Constructor (IResultFormatter[])

Initializes a new instance of the IResultFormatterCollection class with the specified array of IResultFormatter instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As IResultFormatter() _
)
[C#]
public IResultFormatterCollection(
IResultFormatter[] value
);

See Also

IResultFormatterCollection Class | NAnt.NUnit1.Types Namespace | IResultFormatterCollection Constructor Overload List


IResultFormatterCollection Properties

The properties of the IResultFormatterCollection class are listed below. For a complete list of IResultFormatterCollection class members, see the IResultFormatterCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

IResultFormatterCollection Class | NAnt.NUnit1.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

IResultFormatterCollection.Item Property

Gets or sets the element at the specified index.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As IResultFormatter
[C#]
public IResultFormatter this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

IResultFormatterCollection Class | NAnt.NUnit1.Types Namespace


IResultFormatterCollection Methods

The methods of the IResultFormatterCollection class are listed below. For a complete list of IResultFormatterCollection class members, see the IResultFormatterCollection Members topic.

Public Instance Methods

Add | Adds a IResultFormatter to the end of the collection.
AddRange | Overloaded. Adds the elements of a IResultFormatter array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a IResultFormatter is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified IResultFormatter object in the collection.
Insert | Inserts a IResultFormatter into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

IResultFormatterCollection Class | NAnt.NUnit1.Types Namespace


IResultFormatterCollection.Add Method

Adds a IResultFormatter to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As IResultFormatter _
) As Integer
[C#]
public int Add(
IResultFormatter item
);

Parameters

item
The IResultFormatter to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

IResultFormatterCollection Class | NAnt.NUnit1.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

IResultFormatterCollection.AddRange Method

Adds the elements of a IResultFormatter array to the end of the collection.

Overload List

Adds the elements of a IResultFormatter array to the end of the collection.

public void AddRange(IResultFormatter[]);

Adds the elements of a IResultFormatterCollection to the end of the collection.

public void AddRange(IResultFormatterCollection);

See Also

IResultFormatterCollection Class | NAnt.NUnit1.Types Namespace


IResultFormatterCollection.AddRange Method (IResultFormatter[])

Adds the elements of a IResultFormatter array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As IResultFormatter() _
)
[C#]
public void AddRange(
IResultFormatter[] items
);

Parameters

items
The array of IResultFormatter elements to be added to the end of the collection.

See Also

IResultFormatterCollection Class | NAnt.NUnit1.Types Namespace | IResultFormatterCollection.AddRange Overload List


IResultFormatterCollection.AddRange Method (IResultFormatterCollection)

Adds the elements of a IResultFormatterCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As IResultFormatterCollection _
)
[C#]
public void AddRange(
IResultFormatterCollection items
);

Parameters

items
The IResultFormatterCollection to be added to the end of the collection.

See Also

IResultFormatterCollection Class | NAnt.NUnit1.Types Namespace | IResultFormatterCollection.AddRange Overload List


IResultFormatterCollection.Contains Method

Determines whether a IResultFormatter is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal item As IResultFormatter _
) As Boolean
[C#]
public bool Contains(
IResultFormatter item
);

Parameters

item
The IResultFormatter to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

IResultFormatterCollection Class | NAnt.NUnit1.Types Namespace


IResultFormatterCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As IResultFormatter(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
IResultFormatter[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

IResultFormatterCollection Class | NAnt.NUnit1.Types Namespace


IResultFormatterCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As IResultFormatterEnumerator
[C#]
new public IResultFormatterEnumerator GetEnumerator();

Return Value

A IResultFormatterEnumerator for the entire collection.

See Also

IResultFormatterCollection Class | NAnt.NUnit1.Types Namespace


IResultFormatterCollection.IndexOf Method

Retrieves the index of a specified IResultFormatter object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As IResultFormatter _
) As Integer
[C#]
public int IndexOf(
IResultFormatter item
);

Parameters

item
The IResultFormatter object for which the index is returned.

Return Value

The index of the specified IResultFormatter. If the IResultFormatter is not currently a member of the collection, it returns -1.

See Also

IResultFormatterCollection Class | NAnt.NUnit1.Types Namespace


IResultFormatterCollection.Insert Method

Inserts a IResultFormatter into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As IResultFormatter _
)
[C#]
public void Insert(
int index,
IResultFormatter item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The IResultFormatter to insert.

See Also

IResultFormatterCollection Class | NAnt.NUnit1.Types Namespace


IResultFormatterCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As IResultFormatter _
)
[C#]
public void Remove(
IResultFormatter item
);

Parameters

item
The IResultFormatter to remove from the collection.

See Also

IResultFormatterCollection Class | NAnt.NUnit1.Types Namespace


IResultFormatterEnumerator Class

Enumerates the IResultFormatter elements of a IResultFormatterCollection.

For a list of all members of this type, see IResultFormatterEnumerator Members.

System.Object
NAnt.NUnit1.Types.IResultFormatterEnumerator

[Visual Basic]
Public Class IResultFormatterEnumerator
Implements IEnumerator
[C#]
public class IResultFormatterEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit1.Types

Assembly: NAnt.NUnit1Tasks (in NAnt.NUnit1Tasks.dll)

See Also

IResultFormatterEnumerator Members | NAnt.NUnit1.Types Namespace


IResultFormatterEnumerator Members

IResultFormatterEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IResultFormatterEnumerator Class | NAnt.NUnit1.Types Namespace


IResultFormatterEnumerator Properties

The properties of the IResultFormatterEnumerator class are listed below. For a complete list of IResultFormatterEnumerator class members, see the IResultFormatterEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

IResultFormatterEnumerator Class | NAnt.NUnit1.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

IResultFormatterEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As IResultFormatter
[C#]
public IResultFormatter Current {get;}

See Also

IResultFormatterEnumerator Class | NAnt.NUnit1.Types Namespace


IResultFormatterEnumerator Methods

The methods of the IResultFormatterEnumerator class are listed below. For a complete list of IResultFormatterEnumerator class members, see the IResultFormatterEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IResultFormatterEnumerator Class | NAnt.NUnit1.Types Namespace


IResultFormatterEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

IResultFormatterEnumerator Class | NAnt.NUnit1.Types Namespace


IResultFormatterEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

IResultFormatterEnumerator Class | NAnt.NUnit1.Types Namespace


LogFormatter Class

Prints information about running tests directly to the build log.

For a list of all members of this type, see LogFormatter Members.

System.Object
NAnt.NUnit1.Types.LogFormatter

[Visual Basic]
Public Class LogFormatter
Implements IResultFormatter, ITestListener
[C#]
public class LogFormatter : IResultFormatter, ITestListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit1.Types

Assembly: NAnt.NUnit1Tasks (in NAnt.NUnit1Tasks.dll)

See Also

LogFormatter Members | NAnt.NUnit1.Types Namespace


LogFormatter Members

LogFormatter overview

Public Instance Constructors

LogFormatter Constructor

Public Instance Methods

AddError |
AddFailure |
EndTest |
EndTestSuite | Called when the whole test suite has ended.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
SetOutput | Not used, all output goes to Log class.
StartTest |
StartTestSuite | Called when the whole test suite has started.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Prefix
Verbose

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LogFormatter Class | NAnt.NUnit1.Types Namespace


LogFormatter Constructor

[Visual Basic]
Public Sub New( _
ByVal prefix As String, _
ByVal verbose As Boolean _
)
[C#]
public LogFormatter(
string prefix,
bool verbose
);

See Also

LogFormatter Class | NAnt.NUnit1.Types Namespace


LogFormatter Properties

The properties of the LogFormatter class are listed below. For a complete list of LogFormatter class members, see the LogFormatter Members topic.

Protected Instance Properties

Prefix
Verbose

See Also

LogFormatter Class | NAnt.NUnit1.Types Namespace


Prefix Property

NAnt SDK Documentation - v0.91

LogFormatter.Prefix Property

[Visual Basic]
Protected ReadOnly Property Prefix As String
[C#]
protected string Prefix {get;}

See Also

LogFormatter Class | NAnt.NUnit1.Types Namespace


Verbose Property

NAnt SDK Documentation - v0.91

LogFormatter.Verbose Property

[Visual Basic]
Protected ReadOnly Property Verbose As Boolean
[C#]
protected bool Verbose {get;}

See Also

LogFormatter Class | NAnt.NUnit1.Types Namespace


LogFormatter Methods

The methods of the LogFormatter class are listed below. For a complete list of LogFormatter class members, see the LogFormatter Members topic.

Public Instance Methods

AddError |
AddFailure |
EndTest |
EndTestSuite | Called when the whole test suite has ended.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
SetOutput | Not used, all output goes to Log class.
StartTest |
StartTestSuite | Called when the whole test suite has started.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LogFormatter Class | NAnt.NUnit1.Types Namespace


LogFormatter.AddError Method

[Visual Basic]
NotOverridable Public Sub AddError( _
ByVal test As ITest, _
ByVal e As Exception _
) _
Implements ITestListener.AddError
[C#]
public void AddError(
ITest test,
Exception e
);

Implements

ITestListener.AddError

See Also

LogFormatter Class | NAnt.NUnit1.Types Namespace


LogFormatter.AddFailure Method

[Visual Basic]
NotOverridable Public Sub AddFailure( _
ByVal test As ITest, _
ByVal e As AssertionFailedError _
) _
Implements ITestListener.AddFailure
[C#]
public void AddFailure(
ITest test,
AssertionFailedError e
);

Implements

ITestListener.AddFailure

See Also

LogFormatter Class | NAnt.NUnit1.Types Namespace


LogFormatter.EndTest Method

[Visual Basic]
NotOverridable Public Sub EndTest( _
ByVal test As ITest _
) _
Implements ITestListener.EndTest
[C#]
public void EndTest(
ITest test
);

Implements

ITestListener.EndTest

See Also

LogFormatter Class | NAnt.NUnit1.Types Namespace


LogFormatter.EndTestSuite Method

Called when the whole test suite has ended.

[Visual Basic]
NotOverridable Public Sub EndTestSuite( _
ByVal result As TestResultExtra _
) _
Implements IResultFormatter.EndTestSuite
[C#]
public void EndTestSuite(
TestResultExtra result
);

Implements

IResultFormatter.EndTestSuite

See Also

LogFormatter Class | NAnt.NUnit1.Types Namespace


LogFormatter.SetOutput Method

Not used, all output goes to Log class.

[Visual Basic]
NotOverridable Public Sub SetOutput( _
ByVal writer As TextWriter _
) _
Implements IResultFormatter.SetOutput
[C#]
public void SetOutput(
TextWriter writer
);

Implements

IResultFormatter.SetOutput

See Also

LogFormatter Class | NAnt.NUnit1.Types Namespace


LogFormatter.StartTest Method

[Visual Basic]
NotOverridable Public Sub StartTest( _
ByVal test As ITest _
) _
Implements ITestListener.StartTest
[C#]
public void StartTest(
ITest test
);

Implements

ITestListener.StartTest

See Also

LogFormatter Class | NAnt.NUnit1.Types Namespace


LogFormatter.StartTestSuite Method

Called when the whole test suite has started.

[Visual Basic]
NotOverridable Public Sub StartTestSuite( _
ByVal suite As NUnitTestData _
) _
Implements IResultFormatter.StartTestSuite
[C#]
public void StartTestSuite(
NUnitTestData suite
);

Implements

IResultFormatter.StartTestSuite

See Also

LogFormatter Class | NAnt.NUnit1.Types Namespace


NUnitTest Class

Represents a test element of an NUnitTask.

For a list of all members of this type, see NUnitTest Members.

System.Object
NAnt.Core.Element
NAnt.NUnit1.Types.NUnitTest

[Visual Basic]
<ElementName(Name:="test")>
Public Class NUnitTest
Inherits Element
[C#]
[ElementName(Name="test")]
public class NUnitTest : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit1.Types

Assembly: NAnt.NUnit1Tasks (in NAnt.NUnit1Tasks.dll)

See Also

NUnitTest Members | NAnt.NUnit1.Types Namespace


NUnitTest Members

NUnitTest overview

Public Instance Constructors

NUnitTest Constructor Initializes a new instance of the NUnitTest class.

Public Instance Properties

AppConfigFile | The application configuration file to use for the NUnit test domain.
Assembly | Assembly to load the test from.
Class | Class name of the test.
Fork | Run the tests in a separate AppDomain.
HaltOnError | Stop the build process if an error occurs during the test run.
HaltOnFailure | Stop the build process if a test fails (errors are considered failures as well).
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OutFile | Base name of the test result. The full filename is determined by this attribute and the extension of formatter.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
ToDir | Directory to write the reports to.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NUnitTest Class | NAnt.NUnit1.Types Namespace


NUnitTest Constructor

Initializes a new instance of the NUnitTest class.

[Visual Basic]
Public Sub New()
[C#]
public NUnitTest();

See Also

NUnitTest Class | NAnt.NUnit1.Types Namespace


NUnitTest Properties

The properties of the NUnitTest class are listed below. For a complete list of NUnitTest class members, see the NUnitTest Members topic.

Public Instance Properties

AppConfigFile | The application configuration file to use for the NUnit test domain.
Assembly | Assembly to load the test from.
Class | Class name of the test.
Fork | Run the tests in a separate AppDomain.
HaltOnError | Stop the build process if an error occurs during the test run.
HaltOnFailure | Stop the build process if a test fails (errors are considered failures as well).
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OutFile | Base name of the test result. The full filename is determined by this attribute and the extension of formatter.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
ToDir | Directory to write the reports to.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

NUnitTest Class | NAnt.NUnit1.Types Namespace


AppConfigFile Property

NAnt SDK Documentation - v0.91

NUnitTest.AppConfigFile Property

The application configuration file to use for the NUnit test domain.

[Visual Basic]
<TaskAttribute(Name:="appconfig", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property AppConfigFile As String
[C#]
[TaskAttribute(Name="appconfig", Required=False, ExpandProperties=True, ProcessXml=True)]
public string AppConfigFile {get; set;}

See Also

NUnitTest Class | NAnt.NUnit1.Types Namespace


Assembly Property

NAnt SDK Documentation - v0.91

NUnitTest.Assembly Property

Assembly to load the test from.

[Visual Basic]
<TaskAttribute(Name:="assembly", Required:=True, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property Assembly As String
[C#]
[TaskAttribute(Name="assembly", Required=True, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string Assembly {get; set;}

See Also

NUnitTest Class | NAnt.NUnit1.Types Namespace


Class Property

NAnt SDK Documentation - v0.91

NUnitTest.Class Property

Class name of the test.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="class", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property Class As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="class", Required=True, ExpandProperties=True, ProcessXml=True)]
public string Class {get; set;}

See Also

NUnitTest Class | NAnt.NUnit1.Types Namespace


Fork Property

NAnt SDK Documentation - v0.91

NUnitTest.Fork Property

Run the tests in a separate AppDomain.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="fork", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Fork As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="fork", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool Fork {get; set;}

See Also

NUnitTest Class | NAnt.NUnit1.Types Namespace


HaltOnError Property

NAnt SDK Documentation - v0.91

NUnitTest.HaltOnError Property

Stop the build process if an error occurs during the test run.

[Visual Basic]
<TaskAttribute(Name:="haltonerror", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property HaltOnError As Boolean
[C#]
[TaskAttribute(Name="haltonerror", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool HaltOnError {get; set;}

See Also

NUnitTest Class | NAnt.NUnit1.Types Namespace


HaltOnFailure Property

NAnt SDK Documentation - v0.91

NUnitTest.HaltOnFailure Property

Stop the build process if a test fails (errors are considered failures as well).

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="haltonfailure", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property HaltOnFailure As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="haltonfailure", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool HaltOnFailure {get; set;}

See Also

NUnitTest Class | NAnt.NUnit1.Types Namespace


OutFile Property

NAnt SDK Documentation - v0.91

NUnitTest.OutFile Property

Base name of the test result. The full filename is determined by this attribute and the extension of formatter.

[Visual Basic]
<TaskAttribute(Name:="outfile", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property OutFile As String
[C#]
[TaskAttribute(Name="outfile", Required=False, ExpandProperties=True, ProcessXml=True)]
public string OutFile {get; set;}

See Also

NUnitTest Class | NAnt.NUnit1.Types Namespace


ToDir Property

NAnt SDK Documentation - v0.91

NUnitTest.ToDir Property

Directory to write the reports to.

[Visual Basic]
<TaskAttribute(Name:="todir", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property ToDir As String
[C#]
[TaskAttribute(Name="todir", Required=False, ExpandProperties=True, ProcessXml=True)]
public string ToDir {get; set;}

See Also

NUnitTest Class | NAnt.NUnit1.Types Namespace


NUnitTestCollection Class

Contains a strongly typed collection of NUnitTest objects.

For a list of all members of this type, see NUnitTestCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.NUnit1.Types.NUnitTestCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class NUnitTestCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class NUnitTestCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit1.Types

Assembly: NAnt.NUnit1Tasks (in NAnt.NUnit1Tasks.dll)

See Also

NUnitTestCollection Members | NAnt.NUnit1.Types Namespace


NUnitTestCollection Members

NUnitTestCollection overview

Public Instance Constructors

NUnitTestCollection Overloaded. Initializes a new instance of the NUnitTestCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a NUnitTest to the end of the collection.
AddRange | Overloaded. Adds the elements of a NUnitTest array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a NUnitTest is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified NUnitTest object in the collection.
Insert | Inserts a NUnitTest into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

NUnitTestCollection Class | NAnt.NUnit1.Types Namespace


NUnitTestCollection Constructor

Initializes a new instance of the NUnitTestCollection class.

Overload List

Initializes a new instance of the NUnitTestCollection class.

public NUnitTestCollection();

Initializes a new instance of the NUnitTestCollection class with the specified array of NUnitTest instances.

public NUnitTestCollection(NUnitTest[]);

Initializes a new instance of the NUnitTestCollection class with the specified NUnitTestCollection instance.

public NUnitTestCollection(NUnitTestCollection);

See Also

NUnitTestCollection Class | NAnt.NUnit1.Types Namespace


NUnitTestCollection Constructor ()

Initializes a new instance of the NUnitTestCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public NUnitTestCollection();

See Also

NUnitTestCollection Class | NAnt.NUnit1.Types Namespace | NUnitTestCollection Constructor Overload List


NUnitTestCollection Constructor (NUnitTestCollection)

Initializes a new instance of the NUnitTestCollection class with the specified NUnitTestCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As NUnitTestCollection _
)
[C#]
public NUnitTestCollection(
NUnitTestCollection value
);

See Also

NUnitTestCollection Class | NAnt.NUnit1.Types Namespace | NUnitTestCollection Constructor Overload List


NUnitTestCollection Constructor (NUnitTest[])

Initializes a new instance of the NUnitTestCollection class with the specified array of NUnitTest instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As NUnitTest() _
)
[C#]
public NUnitTestCollection(
NUnitTest[] value
);

See Also

NUnitTestCollection Class | NAnt.NUnit1.Types Namespace | NUnitTestCollection Constructor Overload List


NUnitTestCollection Properties

The properties of the NUnitTestCollection class are listed below. For a complete list of NUnitTestCollection class members, see the NUnitTestCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

NUnitTestCollection Class | NAnt.NUnit1.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

NUnitTestCollection.Item Property

Gets or sets the element at the specified index.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As NUnitTest
[C#]
public NUnitTest this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

NUnitTestCollection Class | NAnt.NUnit1.Types Namespace


NUnitTestCollection Methods

The methods of the NUnitTestCollection class are listed below. For a complete list of NUnitTestCollection class members, see the NUnitTestCollection Members topic.

Public Instance Methods

Add | Adds a NUnitTest to the end of the collection.
AddRange | Overloaded. Adds the elements of a NUnitTest array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a NUnitTest is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified NUnitTest object in the collection.
Insert | Inserts a NUnitTest into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

NUnitTestCollection Class | NAnt.NUnit1.Types Namespace


NUnitTestCollection.Add Method

Adds a NUnitTest to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As NUnitTest _
) As Integer
[C#]
public int Add(
NUnitTest item
);

Parameters

item
The NUnitTest to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

NUnitTestCollection Class | NAnt.NUnit1.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

NUnitTestCollection.AddRange Method

Adds the elements of a NUnitTest array to the end of the collection.

Overload List

Adds the elements of a NUnitTest array to the end of the collection.

public void AddRange(NUnitTest[]);

Adds the elements of a NUnitTestCollection to the end of the collection.

public void AddRange(NUnitTestCollection);

See Also

NUnitTestCollection Class | NAnt.NUnit1.Types Namespace


NUnitTestCollection.AddRange Method (NUnitTest[])

Adds the elements of a NUnitTest array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As NUnitTest() _
)
[C#]
public void AddRange(
NUnitTest[] items
);

Parameters

items
The array of NUnitTest elements to be added to the end of the collection.

See Also

NUnitTestCollection Class | NAnt.NUnit1.Types Namespace | NUnitTestCollection.AddRange Overload List


NUnitTestCollection.AddRange Method (NUnitTestCollection)

Adds the elements of a NUnitTestCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As NUnitTestCollection _
)
[C#]
public void AddRange(
NUnitTestCollection items
);

Parameters

items
The NUnitTestCollection to be added to the end of the collection.

See Also

NUnitTestCollection Class | NAnt.NUnit1.Types Namespace | NUnitTestCollection.AddRange Overload List


NUnitTestCollection.Contains Method

Determines whether a NUnitTest is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal item As NUnitTest _
) As Boolean
[C#]
public bool Contains(
NUnitTest item
);

Parameters

item
The NUnitTest to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

NUnitTestCollection Class | NAnt.NUnit1.Types Namespace


NUnitTestCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As NUnitTest(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
NUnitTest[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

NUnitTestCollection Class | NAnt.NUnit1.Types Namespace


NUnitTestCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As NUnitTestEnumerator
[C#]
new public NUnitTestEnumerator GetEnumerator();

Return Value

A NUnitTestEnumerator for the entire collection.

See Also

NUnitTestCollection Class | NAnt.NUnit1.Types Namespace


NUnitTestCollection.IndexOf Method

Retrieves the index of a specified NUnitTest object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As NUnitTest _
) As Integer
[C#]
public int IndexOf(
NUnitTest item
);

Parameters

item
The NUnitTest object for which the index is returned.

Return Value

The index of the specified NUnitTest. If the NUnitTest is not currently a member of the collection, it returns -1.

See Also

NUnitTestCollection Class | NAnt.NUnit1.Types Namespace


NUnitTestCollection.Insert Method

Inserts a NUnitTest into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As NUnitTest _
)
[C#]
public void Insert(
int index,
NUnitTest item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The NUnitTest to insert.

See Also

NUnitTestCollection Class | NAnt.NUnit1.Types Namespace


NUnitTestCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As NUnitTest _
)
[C#]
public void Remove(
NUnitTest item
);

Parameters

item
The NUnitTest to remove from the collection.

See Also

NUnitTestCollection Class | NAnt.NUnit1.Types Namespace


NUnitTestData Class

Carries data specified through the test element.

For a list of all members of this type, see NUnitTestData Members.

System.Object
NAnt.NUnit1.Types.NUnitTestData

[Visual Basic]
<Serializable, _ Serializable>
Public Class NUnitTestData
[C#]
[Serializable]
[Serializable]
public class NUnitTestData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit1.Types

Assembly: NAnt.NUnit1Tasks (in NAnt.NUnit1Tasks.dll)

See Also

NUnitTestData Members | NAnt.NUnit1.Types Namespace


NUnitTestData Members

NUnitTestData overview

Public Instance Constructors

NUnitTestData Constructor Initializes a new instance of the NUnitTestData class.

Public Instance Properties

AppConfigFile
Assembly
Class
Fork
Formatters
HaltOnError
HaltOnFailure
OutFile
Suite
ToDir

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NUnitTestData Class | NAnt.NUnit1.Types Namespace


NUnitTestData Constructor

Initializes a new instance of the NUnitTestData class.

[Visual Basic]
Public Sub New()
[C#]
public NUnitTestData();

See Also

NUnitTestData Class | NAnt.NUnit1.Types Namespace


NUnitTestData Properties

The properties of the NUnitTestData class are listed below. For a complete list of NUnitTestData class members, see the NUnitTestData Members topic.

Public Instance Properties

AppConfigFile
Assembly
Class
Fork
Formatters
HaltOnError
HaltOnFailure
OutFile
Suite
ToDir

See Also

NUnitTestData Class | NAnt.NUnit1.Types Namespace


AppConfigFile Property

NAnt SDK Documentation - v0.91

NUnitTestData.AppConfigFile Property

[Visual Basic]
Public Property AppConfigFile As String
[C#]
public string AppConfigFile {get; set;}

See Also

NUnitTestData Class | NAnt.NUnit1.Types Namespace


Assembly Property

NAnt SDK Documentation - v0.91

NUnitTestData.Assembly Property

[Visual Basic]
Public Property Assembly As String
[C#]
public string Assembly {get; set;}

See Also

NUnitTestData Class | NAnt.NUnit1.Types Namespace


Class Property

NAnt SDK Documentation - v0.91

NUnitTestData.Class Property

[Visual Basic]
Public Property Class As String
[C#]
public string Class {get; set;}

See Also

NUnitTestData Class | NAnt.NUnit1.Types Namespace


Fork Property

NAnt SDK Documentation - v0.91

NUnitTestData.Fork Property

[Visual Basic]
Public Property Fork As Boolean
[C#]
public bool Fork {get; set;}

See Also

NUnitTestData Class | NAnt.NUnit1.Types Namespace


Formatters Property

NAnt SDK Documentation - v0.91

NUnitTestData.Formatters Property

[Visual Basic]
Public ReadOnly Property Formatters As FormatterDataCollection
[C#]
public NAnt.NUnit.Types.FormatterDataCollection Formatters {get;}

See Also

NUnitTestData Class | NAnt.NUnit1.Types Namespace


HaltOnError Property

NAnt SDK Documentation - v0.91

NUnitTestData.HaltOnError Property

[Visual Basic]
Public Property HaltOnError As Boolean
[C#]
public bool HaltOnError {get; set;}

See Also

NUnitTestData Class | NAnt.NUnit1.Types Namespace


HaltOnFailure Property

NAnt SDK Documentation - v0.91

NUnitTestData.HaltOnFailure Property

[Visual Basic]
Public Property HaltOnFailure As Boolean
[C#]
public bool HaltOnFailure {get; set;}

See Also

NUnitTestData Class | NAnt.NUnit1.Types Namespace


OutFile Property

NAnt SDK Documentation - v0.91

NUnitTestData.OutFile Property

[Visual Basic]
Public Property OutFile As String
[C#]
public string OutFile {get; set;}

See Also

NUnitTestData Class | NAnt.NUnit1.Types Namespace


Suite Property

NAnt SDK Documentation - v0.91

NUnitTestData.Suite Property

[Visual Basic]
Public Property Suite As ITest
[C#]
public NUnit.Framework.ITest Suite {get; set;}

See Also

NUnitTestData Class | NAnt.NUnit1.Types Namespace


ToDir Property

NAnt SDK Documentation - v0.91

NUnitTestData.ToDir Property

[Visual Basic]
Public Property ToDir As String
[C#]
public string ToDir {get; set;}

See Also

NUnitTestData Class | NAnt.NUnit1.Types Namespace


NUnitTestEnumerator Class

Enumerates the NUnitTest elements of a NUnitTestCollection.

For a list of all members of this type, see NUnitTestEnumerator Members.

System.Object
NAnt.NUnit1.Types.NUnitTestEnumerator

[Visual Basic]
Public Class NUnitTestEnumerator
Implements IEnumerator
[C#]
public class NUnitTestEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit1.Types

Assembly: NAnt.NUnit1Tasks (in NAnt.NUnit1Tasks.dll)

See Also

NUnitTestEnumerator Members | NAnt.NUnit1.Types Namespace


NUnitTestEnumerator Members

NUnitTestEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NUnitTestEnumerator Class | NAnt.NUnit1.Types Namespace


NUnitTestEnumerator Properties

The properties of the NUnitTestEnumerator class are listed below. For a complete list of NUnitTestEnumerator class members, see the NUnitTestEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

NUnitTestEnumerator Class | NAnt.NUnit1.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

NUnitTestEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As NUnitTest
[C#]
public NUnitTest Current {get;}

See Also

NUnitTestEnumerator Class | NAnt.NUnit1.Types Namespace


NUnitTestEnumerator Methods

The methods of the NUnitTestEnumerator class are listed below. For a complete list of NUnitTestEnumerator class members, see the NUnitTestEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NUnitTestEnumerator Class | NAnt.NUnit1.Types Namespace


NUnitTestEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

NUnitTestEnumerator Class | NAnt.NUnit1.Types Namespace


NUnitTestEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

NUnitTestEnumerator Class | NAnt.NUnit1.Types Namespace


PlainTextFormatter Class

Prints information about running tests in plain text.

For a list of all members of this type, see PlainTextFormatter Members.

System.Object
NAnt.NUnit1.Types.PlainTextFormatter

[Visual Basic]
Public Class PlainTextFormatter
Implements IResultFormatter, ITestListener
[C#]
public class PlainTextFormatter : IResultFormatter, ITestListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit1.Types

Assembly: NAnt.NUnit1Tasks (in NAnt.NUnit1Tasks.dll)

See Also

PlainTextFormatter Members | NAnt.NUnit1.Types Namespace


PlainTextFormatter Members

PlainTextFormatter overview

Public Instance Constructors

PlainTextFormatter Constructor Initializes a new instance of the PlainTextFormatter class.

Public Instance Properties

Writer

Public Instance Methods

AddError |
AddFailure |
EndTest |
EndTestSuite | Called when the whole test suite has ended.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
SetOutput | Sets the Writer the formatter is supposed to write its results to.
StartTest |
StartTestSuite | Called when the whole test suite has started.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PlainTextFormatter Class | NAnt.NUnit1.Types Namespace


PlainTextFormatter Constructor

Initializes a new instance of the PlainTextFormatter class.

[Visual Basic]
Public Sub New()
[C#]
public PlainTextFormatter();

See Also

PlainTextFormatter Class | NAnt.NUnit1.Types Namespace


PlainTextFormatter Properties

The properties of the PlainTextFormatter class are listed below. For a complete list of PlainTextFormatter class members, see the PlainTextFormatter Members topic.

Public Instance Properties

Writer

See Also

PlainTextFormatter Class | NAnt.NUnit1.Types Namespace


Writer Property

NAnt SDK Documentation - v0.91

PlainTextFormatter.Writer Property

[Visual Basic]
Public Property Writer As TextWriter
[C#]
public System.IO.TextWriter Writer {get; set;}

See Also

PlainTextFormatter Class | NAnt.NUnit1.Types Namespace


PlainTextFormatter Methods

The methods of the PlainTextFormatter class are listed below. For a complete list of PlainTextFormatter class members, see the PlainTextFormatter Members topic.

Public Instance Methods

AddError |
AddFailure |
EndTest |
EndTestSuite | Called when the whole test suite has ended.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
SetOutput | Sets the Writer the formatter is supposed to write its results to.
StartTest |
StartTestSuite | Called when the whole test suite has started.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PlainTextFormatter Class | NAnt.NUnit1.Types Namespace


PlainTextFormatter.AddError Method

[Visual Basic]
NotOverridable Public Sub AddError( _
ByVal test As ITest, _
ByVal e As Exception _
) _
Implements ITestListener.AddError
[C#]
public void AddError(
ITest test,
Exception e
);

Implements

ITestListener.AddError

See Also

PlainTextFormatter Class | NAnt.NUnit1.Types Namespace


PlainTextFormatter.AddFailure Method

[Visual Basic]
NotOverridable Public Sub AddFailure( _
ByVal test As ITest, _
ByVal e As AssertionFailedError _
) _
Implements ITestListener.AddFailure
[C#]
public void AddFailure(
ITest test,
AssertionFailedError e
);

Implements

ITestListener.AddFailure

See Also

PlainTextFormatter Class | NAnt.NUnit1.Types Namespace


PlainTextFormatter.EndTest Method

[Visual Basic]
NotOverridable Public Sub EndTest( _
ByVal test As ITest _
) _
Implements ITestListener.EndTest
[C#]
public void EndTest(
ITest test
);

Implements

ITestListener.EndTest

See Also

PlainTextFormatter Class | NAnt.NUnit1.Types Namespace


PlainTextFormatter.EndTestSuite Method

Called when the whole test suite has ended.

[Visual Basic]
NotOverridable Public Sub EndTestSuite( _
ByVal result As TestResultExtra _
) _
Implements IResultFormatter.EndTestSuite
[C#]
public void EndTestSuite(
TestResultExtra result
);

Implements

IResultFormatter.EndTestSuite

See Also

PlainTextFormatter Class | NAnt.NUnit1.Types Namespace


PlainTextFormatter.SetOutput Method

Sets the Writer the formatter is supposed to write its results to.

[Visual Basic]
NotOverridable Public Sub SetOutput( _
ByVal writer As TextWriter _
) _
Implements IResultFormatter.SetOutput
[C#]
public void SetOutput(
TextWriter writer
);

Implements

IResultFormatter.SetOutput

See Also

PlainTextFormatter Class | NAnt.NUnit1.Types Namespace


PlainTextFormatter.StartTest Method

[Visual Basic]
NotOverridable Public Sub StartTest( _
ByVal test As ITest _
) _
Implements ITestListener.StartTest
[C#]
public void StartTest(
ITest test
);

Implements

ITestListener.StartTest

See Also

PlainTextFormatter Class | NAnt.NUnit1.Types Namespace


PlainTextFormatter.StartTestSuite Method

Called when the whole test suite has started.

[Visual Basic]
NotOverridable Public Sub StartTestSuite( _
ByVal suite As NUnitTestData _
) _
Implements IResultFormatter.StartTestSuite
[C#]
public void StartTestSuite(
NUnitTestData suite
);

Implements

IResultFormatter.StartTestSuite

See Also

PlainTextFormatter Class | NAnt.NUnit1.Types Namespace


TestResultExtra Class

Decorates NUnits TestResult with extra information such as run-time.

For a list of all members of this type, see TestResultExtra Members.

System.Object
System.MarshalByRefObject
NUnit.Framework.TestResult
NAnt.NUnit1.Types.TestResultExtra

[Visual Basic]
Public Class TestResultExtra
Inherits TestResult
[C#]
public class TestResultExtra : TestResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit1.Types

Assembly: NAnt.NUnit1Tasks (in NAnt.NUnit1Tasks.dll)

See Also

TestResultExtra Members | NAnt.NUnit1.Types Namespace


TestResultExtra Members

TestResultExtra overview

Public Instance Constructors

TestResultExtra Constructor Initializes a new instance of the TestResultExtra class.

Public Instance Properties

ErrorCount (inherited from NUnit.Framework.TestResult) |
Errors (inherited from NUnit.Framework.TestResult) |
FailureCount (inherited from NUnit.Framework.TestResult) |
Failures (inherited from NUnit.Framework.TestResult) |
RunCount (inherited from NUnit.Framework.TestResult) |
RunTime | Gets or sets the total run-time of a test.
ShouldStop (inherited from NUnit.Framework.TestResult) |
WasSuccessful (inherited from NUnit.Framework.TestResult) |

Public Instance Methods

AddError (inherited from NUnit.Framework.TestResult) |
AddFailure (inherited from NUnit.Framework.TestResult) |
AddListener (inherited from NUnit.Framework.TestResult) |
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
EndTest (inherited from NUnit.Framework.TestResult) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
RemoveListener (inherited from NUnit.Framework.TestResult) |
RunProtected (inherited from NUnit.Framework.TestResult) |
StartTest (inherited from NUnit.Framework.TestResult) |
Stop (inherited from NUnit.Framework.TestResult) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.

See Also

TestResultExtra Class | NAnt.NUnit1.Types Namespace


TestResultExtra Constructor

Initializes a new instance of the TestResultExtra class.

[Visual Basic]
Public Sub New()
[C#]
public TestResultExtra();

See Also

TestResultExtra Class | NAnt.NUnit1.Types Namespace


TestResultExtra Properties

The properties of the TestResultExtra class are listed below. For a complete list of TestResultExtra class members, see the TestResultExtra Members topic.

Public Instance Properties

ErrorCount (inherited from NUnit.Framework.TestResult) |
Errors (inherited from NUnit.Framework.TestResult) |
FailureCount (inherited from NUnit.Framework.TestResult) |
Failures (inherited from NUnit.Framework.TestResult) |
RunCount (inherited from NUnit.Framework.TestResult) |
RunTime | Gets or sets the total run-time of a test.
ShouldStop (inherited from NUnit.Framework.TestResult) |
WasSuccessful (inherited from NUnit.Framework.TestResult) |

See Also

TestResultExtra Class | NAnt.NUnit1.Types Namespace


RunTime Property

NAnt SDK Documentation - v0.91

TestResultExtra.RunTime Property

Gets or sets the total run-time of a test.

[Visual Basic]
Public Property RunTime As Long
[C#]
public long RunTime {get; set;}

Property Value

The total run-time of a test.

See Also

TestResultExtra Class | NAnt.NUnit1.Types Namespace


XmlResultFormatter Class

Prints detailed information about running tests in XML format.

For a list of all members of this type, see XmlResultFormatter Members.

System.Object
NAnt.NUnit1.Types.XmlResultFormatter

[Visual Basic]
Public Class XmlResultFormatter
Implements IResultFormatter, ITestListener
[C#]
public class XmlResultFormatter : IResultFormatter, ITestListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit1.Types

Assembly: NAnt.NUnit1Tasks (in NAnt.NUnit1Tasks.dll)

See Also

XmlResultFormatter Members | NAnt.NUnit1.Types Namespace


XmlResultFormatter Members

XmlResultFormatter overview

Public Instance Constructors

XmlResultFormatter Constructor Initializes a new instance of the XmlResultFormatter class.

Public Instance Properties

Writer

Public Instance Methods

AddError |
AddFailure |
EndTest |
EndTestSuite | Called when the whole test suite has ended.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
SetOutput | Sets the TextWriter the formatter is supposed to write its results to.
StartTest |
StartTestSuite | Called when the whole test suite has started.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlResultFormatter Class | NAnt.NUnit1.Types Namespace


XmlResultFormatter Constructor

Initializes a new instance of the XmlResultFormatter class.

[Visual Basic]
Public Sub New()
[C#]
public XmlResultFormatter();

See Also

XmlResultFormatter Class | NAnt.NUnit1.Types Namespace


XmlResultFormatter Properties

The properties of the XmlResultFormatter class are listed below. For a complete list of XmlResultFormatter class members, see the XmlResultFormatter Members topic.

Public Instance Properties

Writer

See Also

XmlResultFormatter Class | NAnt.NUnit1.Types Namespace


Writer Property

NAnt SDK Documentation - v0.91

XmlResultFormatter.Writer Property

[Visual Basic]
Public Property Writer As TextWriter
[C#]
public System.IO.TextWriter Writer {get; set;}

See Also

XmlResultFormatter Class | NAnt.NUnit1.Types Namespace


XmlResultFormatter Methods

The methods of the XmlResultFormatter class are listed below. For a complete list of XmlResultFormatter class members, see the XmlResultFormatter Members topic.

Public Instance Methods

AddError |
AddFailure |
EndTest |
EndTestSuite | Called when the whole test suite has ended.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
SetOutput | Sets the TextWriter the formatter is supposed to write its results to.
StartTest |
StartTestSuite | Called when the whole test suite has started.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlResultFormatter Class | NAnt.NUnit1.Types Namespace


XmlResultFormatter.AddError Method

[Visual Basic]
NotOverridable Public Sub AddError( _
ByVal test As ITest, _
ByVal t As Exception _
) _
Implements ITestListener.AddError
[C#]
public void AddError(
ITest test,
Exception t
);

Implements

ITestListener.AddError

See Also

XmlResultFormatter Class | NAnt.NUnit1.Types Namespace


XmlResultFormatter.AddFailure Method

[Visual Basic]
NotOverridable Public Sub AddFailure( _
ByVal test As ITest, _
ByVal t As AssertionFailedError _
) _
Implements ITestListener.AddFailure
[C#]
public void AddFailure(
ITest test,
AssertionFailedError t
);

Implements

ITestListener.AddFailure

See Also

XmlResultFormatter Class | NAnt.NUnit1.Types Namespace


XmlResultFormatter.EndTest Method

[Visual Basic]
NotOverridable Public Sub EndTest( _
ByVal test As ITest _
) _
Implements ITestListener.EndTest
[C#]
public void EndTest(
ITest test
);

Implements

ITestListener.EndTest

See Also

XmlResultFormatter Class | NAnt.NUnit1.Types Namespace


XmlResultFormatter.EndTestSuite Method

Called when the whole test suite has ended.

[Visual Basic]
NotOverridable Public Sub EndTestSuite( _
ByVal result As TestResultExtra _
) _
Implements IResultFormatter.EndTestSuite
[C#]
public void EndTestSuite(
TestResultExtra result
);

Implements

IResultFormatter.EndTestSuite

See Also

XmlResultFormatter Class | NAnt.NUnit1.Types Namespace


XmlResultFormatter.SetOutput Method

Sets the TextWriter the formatter is supposed to write its results to.

[Visual Basic]
NotOverridable Public Sub SetOutput( _
ByVal writer As TextWriter _
) _
Implements IResultFormatter.SetOutput
[C#]
public void SetOutput(
TextWriter writer
);

Implements

IResultFormatter.SetOutput

See Also

XmlResultFormatter Class | NAnt.NUnit1.Types Namespace


XmlResultFormatter.StartTest Method

[Visual Basic]
NotOverridable Public Sub StartTest( _
ByVal test As ITest _
) _
Implements ITestListener.StartTest
[C#]
public void StartTest(
ITest test
);

Implements

ITestListener.StartTest

See Also

XmlResultFormatter Class | NAnt.NUnit1.Types Namespace


XmlResultFormatter.StartTestSuite Method

Called when the whole test suite has started.

[Visual Basic]
NotOverridable Public Sub StartTestSuite( _
ByVal suite As NUnitTestData _
) _
Implements IResultFormatter.StartTestSuite
[C#]
public void StartTestSuite(
NUnitTestData suite
);

Implements

IResultFormatter.StartTestSuite

See Also

XmlResultFormatter Class | NAnt.NUnit1.Types Namespace


NAnt.NUnit2.Tasks

NAnt SDK Documentation - v0.91

NAnt.NUnit2.Tasks Namespace

Namespace hierarchy

Classes

Class | Description
NUnit2Task | Runs tests using the NUnit V2.2 framework.


NUnit2Task Class

Runs tests using the NUnit V2.2 framework.

For a list of all members of this type, see NUnit2Task Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.NUnit2.Tasks.NUnit2Task

[Visual Basic]
<TaskName(Name:="nunit2")>
Public Class NUnit2Task
Inherits Task
[C#]
[TaskName(Name="nunit2")]
public class NUnit2Task : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The HaltOnFailure attribute is only useful when more than one test suite is used, and you want to continue running other test suites although a test failed.

Set FailOnError to false to ignore any errors and continue the build.

In order to run a test assembly built with NUnit 2.0 or 2.1 using NUnit2Task, you must add the following node to your test config file :

<configuration>
    ...
    <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
            <dependentAssembly>
                <assemblyIdentity name="nunit.framework" publicKeyToken="96d09a1eb7f44a77" culture="Neutral" />
                <bindingRedirect oldVersion="2.0.6.0" newVersion="2.2.8.0" />
                <bindingRedirect oldVersion="2.1.4.0" newVersion="2.2.8.0" />
            </dependentAssembly>
        </assemblyBinding>
    </runtime>
    ...
</configuration>

See the NUnit home page for more information.

Example

Run tests in the MyProject.Tests.dll assembly.

<nunit2>
    <formatter type="Plain" />
    <test assemblyname="MyProject.Tests.dll" appconfig="MyProject.Tests.dll.config" />
</nunit2>

Only run tests that are not known to fail in files listed in the tests.txt file.

<nunit2>
    <formatter type="Xml" usefile="true" extension=".xml" outputdir="${build.dir}/results" />
    <test>
        <assemblies>
            <includesfile name="tests.txt" />
        </assemblies>
        <categories>
            <exclude name="NotWorking" />
        </categories>
        <references basedir="build">
            <include name="Cegeka.Income.Services.dll" />
            <include name="Cegeka.Util.dll" />
        </references>
    </test>
</nunit2>

Requirements

Namespace: NAnt.NUnit2.Tasks

Assembly: NAnt.NUnit2Tasks (in NAnt.NUnit2Tasks.dll)

See Also

NUnit2Task Members | NAnt.NUnit2.Tasks Namespace


NUnit2Task Members

NUnit2Task overview

Public Instance Constructors

NUnit2Task Constructor Initializes a new instance of the NUnit2Task class.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
FormatterElements | Formatters to output results of unit tests.
HaltOnFailure | Stop the test run if a test fails. The default is false.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Tests | Tests to run.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Runs the tests and sets up the formatters.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NUnit2Task Class | NAnt.NUnit2.Tasks Namespace


NUnit2Task Constructor

Initializes a new instance of the NUnit2Task class.

[Visual Basic]
Public Sub New()
[C#]
public NUnit2Task();

See Also

NUnit2Task Class | NAnt.NUnit2.Tasks Namespace


NUnit2Task Properties

The properties of the NUnit2Task class are listed below. For a complete list of NUnit2Task class members, see the NUnit2Task Members topic.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
FormatterElements | Formatters to output results of unit tests.
HaltOnFailure | Stop the test run if a test fails. The default is false.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Tests | Tests to run.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

NUnit2Task Class | NAnt.NUnit2.Tasks Namespace


FormatterElements Property

NAnt SDK Documentation - v0.91

NUnit2Task.FormatterElements Property

Formatters to output results of unit tests.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="formatter", Required:=False, ProcessXml:=True)>
Public ReadOnly Property FormatterElements As FormatterElementCollection
[C#]
[BuildElementArray(ElementType=null, Name="formatter", Required=False, ProcessXml=True)]
public NAnt.NUnit.Types.FormatterElementCollection FormatterElements {get;}

See Also

NUnit2Task Class | NAnt.NUnit2.Tasks Namespace


HaltOnFailure Property

NAnt SDK Documentation - v0.91

NUnit2Task.HaltOnFailure Property

Stop the test run if a test fails. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="haltonfailure", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property HaltOnFailure As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="haltonfailure", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool HaltOnFailure {get; set;}

See Also

NUnit2Task Class | NAnt.NUnit2.Tasks Namespace


Tests Property

NAnt SDK Documentation - v0.91

NUnit2Task.Tests Property

Tests to run.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="test", Required:=False, ProcessXml:=True)>
Public ReadOnly Property Tests As NUnit2TestCollection
[C#]
[BuildElementArray(ElementType=null, Name="test", Required=False, ProcessXml=True)]
public NAnt.NUnit2.Types.NUnit2TestCollection Tests {get;}

See Also

NUnit2Task Class | NAnt.NUnit2.Tasks Namespace


NUnit2Task Methods

The methods of the NUnit2Task class are listed below. For a complete list of NUnit2Task class members, see the NUnit2Task Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Runs the tests and sets up the formatters.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NUnit2Task Class | NAnt.NUnit2.Tasks Namespace


NUnit2Task.ExecuteTask Method

Runs the tests and sets up the formatters.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

NUnit2Task Class | NAnt.NUnit2.Tasks Namespace


NAnt.NUnit2.Types

NAnt SDK Documentation - v0.91

NAnt.NUnit2.Types Namespace

Namespace hierarchy

Classes

Class | Description
Categories | Controls the categories of tests to execute using the NUnit2Task.
Category | Represents a certain group of test cases or fixtures.
CategoryCollection | Contains a collection of Category elements.
CategoryEnumerator | Enumerates the Category elements of a CategoryCollection.
NUnit2Test | Represents a test element of an NUnit2Task.
NUnit2TestCollection | Contains a strongly typed collection of NUnit2Test objects.
NUnit2TestEnumerator | Enumerates the NUnit2Test elements of a NUnit2TestCollection.


Categories Class

Controls the categories of tests to execute using the NUnit2Task.

For a list of all members of this type, see Categories Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.NUnit2.Types.Categories

[Visual Basic]
<ElementName(Name:="categories")>
Public Class Categories
Inherits DataTypeBase
[C#]
[ElementName(Name="categories")]
public class Categories : DataTypeBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Only include test cases and fixtures that require no internet access.

<categories>
    <include name="NoInternetAccess" />
</categories>

Exclude test cases and fixtures that are known to fail.

<categories>
    <exclude name="NotWorking" />
</categories>

Requirements

Namespace: NAnt.NUnit2.Types

Assembly: NAnt.NUnit2Tasks (in NAnt.NUnit2Tasks.dll)

See Also

Categories Members | NAnt.NUnit2.Types Namespace


Categories Members

Categories overview

Public Instance Constructors

Categories Constructor Initializes a new instance of the Categories class.

Public Instance Properties

CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Excludes | Specifies a list of categories to exclude.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
Includes | Specifies a list of categories to include.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from DataTypeBase) | Should be overridden by derived classes. clones the referenced types data into the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from DataTypeBase) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Categories Class | NAnt.NUnit2.Types Namespace


Categories Constructor

Initializes a new instance of the Categories class.

[Visual Basic]
Public Sub New()
[C#]
public Categories();

See Also

Categories Class | NAnt.NUnit2.Types Namespace


Categories Properties

The properties of the Categories class are listed below. For a complete list of Categories class members, see the Categories Members topic.

Public Instance Properties

CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
Excludes | Specifies a list of categories to exclude.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
Includes | Specifies a list of categories to include.
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

Categories Class | NAnt.NUnit2.Types Namespace


Excludes Property

NAnt SDK Documentation - v0.91

Categories.Excludes Property

Specifies a list of categories to exclude.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="exclude", Required:=False, ProcessXml:=True)>
Public ReadOnly Property Excludes As CategoryCollection
[C#]
[BuildElementArray(ElementType=null, Name="exclude", Required=False, ProcessXml=True)]
public CategoryCollection Excludes {get;}

See Also

Categories Class | NAnt.NUnit2.Types Namespace


Includes Property

NAnt SDK Documentation - v0.91

Categories.Includes Property

Specifies a list of categories to include.

[Visual Basic]
<BuildElementArray(ElementType:=null, Name:="include", Required:=False, ProcessXml:=True)>
Public ReadOnly Property Includes As CategoryCollection
[C#]
[BuildElementArray(ElementType=null, Name="include", Required=False, ProcessXml=True)]
public CategoryCollection Includes {get;}

See Also

Categories Class | NAnt.NUnit2.Types Namespace


Category Class

Represents a certain group of test cases or fixtures.

For a list of all members of this type, see Category Members.

System.Object
NAnt.Core.Element
NAnt.NUnit2.Types.Category

[Visual Basic]
Public Class Category
Inherits Element
[C#]
public class Category : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit2.Types

Assembly: NAnt.NUnit2Tasks (in NAnt.NUnit2Tasks.dll)

See Also

Category Members | NAnt.NUnit2.Types Namespace


Category Members

Category overview

Public Instance Constructors

Category Constructor Initializes a new instance of the Category class.

Public Instance Properties

CategoryName | A name of a category, or comma-separated list of names.
IfDefined | If true then the category will be processed; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | If true then the category will be skipped; otherwise, processed. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Category Class | NAnt.NUnit2.Types Namespace


Category Constructor

Initializes a new instance of the Category class.

[Visual Basic]
Public Sub New()
[C#]
public Category();

See Also

Category Class | NAnt.NUnit2.Types Namespace


Category Properties

The properties of the Category class are listed below. For a complete list of Category class members, see the Category Members topic.

Public Instance Properties

CategoryName | A name of a category, or comma-separated list of names.
IfDefined | If true then the category will be processed; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | If true then the category will be skipped; otherwise, processed. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

Category Class | NAnt.NUnit2.Types Namespace


CategoryName Property

NAnt SDK Documentation - v0.91

Category.CategoryName Property

A name of a category, or comma-separated list of names.

[Visual Basic]
<TaskAttribute(Name:="name", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property CategoryName As String
[C#]
[TaskAttribute(Name="name", Required=True, ExpandProperties=True, ProcessXml=True)]
public string CategoryName {get; set;}

See Also

Category Class | NAnt.NUnit2.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

Category.IfDefined Property

If true then the category will be processed; otherwise, skipped. The default is true.

[Visual Basic]
<TaskAttribute(Name:="if", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property IfDefined As Boolean
[C#]
[TaskAttribute(Name="if", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool IfDefined {get; set;}

See Also

Category Class | NAnt.NUnit2.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

Category.UnlessDefined Property

If true then the category will be skipped; otherwise, processed. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="unless", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property UnlessDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="unless", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool UnlessDefined {get; set;}

See Also

Category Class | NAnt.NUnit2.Types Namespace


CategoryCollection Class

Contains a collection of Category elements.

For a list of all members of this type, see CategoryCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.NUnit2.Types.CategoryCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class CategoryCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class CategoryCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit2.Types

Assembly: NAnt.NUnit2Tasks (in NAnt.NUnit2Tasks.dll)

See Also

CategoryCollection Members | NAnt.NUnit2.Types Namespace


CategoryCollection Members

CategoryCollection overview

Public Instance Constructors

CategoryCollection Overloaded. Initializes a new instance of the CategoryCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a Category to the end of the collection.
AddRange | Overloaded. Adds the elements of a Category array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a Category is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified Category object in the collection.
Insert | Inserts a Category into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString | Returns a comma-delimited list of categories.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace


CategoryCollection Constructor

Initializes a new instance of the CategoryCollection class.

Overload List

Initializes a new instance of the CategoryCollection class.

public CategoryCollection();

Initializes a new instance of the CategoryCollection class with the specified array of Category instances.

public CategoryCollection(Category[]);

Initializes a new instance of the CategoryCollection class with the specified CategoryCollection instance.

public CategoryCollection(CategoryCollection);

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace


CategoryCollection Constructor ()

Initializes a new instance of the CategoryCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public CategoryCollection();

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace | CategoryCollection Constructor Overload List


CategoryCollection Constructor (CategoryCollection)

Initializes a new instance of the CategoryCollection class with the specified CategoryCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As CategoryCollection _
)
[C#]
public CategoryCollection(
CategoryCollection value
);

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace | CategoryCollection Constructor Overload List


CategoryCollection Constructor (Category[])

Initializes a new instance of the CategoryCollection class with the specified array of Category instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As Category() _
)
[C#]
public CategoryCollection(
Category[] value
);

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace | CategoryCollection Constructor Overload List


CategoryCollection Properties

The properties of the CategoryCollection class are listed below. For a complete list of CategoryCollection class members, see the CategoryCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

CategoryCollection.Item Property

Gets or sets the element at the specified index.

Overload List

Gets or sets the element at the specified index.

public Category this[int] {get; set;}

Gets the Category with the specified name.

public Category this[string] {get;}

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace


Item Property (Int32)

NAnt SDK Documentation - v0.91

CategoryCollection.Item Property (Int32)

Gets or sets the element at the specified index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As Category
[C#]
public Category this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace | CategoryCollection.Item Overload List


Item Property (String)

NAnt SDK Documentation - v0.91

CategoryCollection.Item Property (String)

Gets the Category with the specified name.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal value As String _
) As Category
[C#]
public Category this[
string value
] {get;}

Parameters

value
The name of the Category to get.

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace | CategoryCollection.Item Overload List


CategoryCollection Methods

The methods of the CategoryCollection class are listed below. For a complete list of CategoryCollection class members, see the CategoryCollection Members topic.

Public Instance Methods

Add | Adds a Category to the end of the collection.
AddRange | Overloaded. Adds the elements of a Category array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a Category is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified Category object in the collection.
Insert | Inserts a Category into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString | Returns a comma-delimited list of categories.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace


CategoryCollection.Add Method

Adds a Category to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As Category _
) As Integer
[C#]
public int Add(
Category item
);

Parameters

item
The Category to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

CategoryCollection.AddRange Method

Adds the elements of a Category array to the end of the collection.

Overload List

Adds the elements of a Category array to the end of the collection.

public void AddRange(Category[]);

Adds the elements of a CategoryCollection to the end of the collection.

public void AddRange(CategoryCollection);

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace


CategoryCollection.AddRange Method (Category[])

Adds the elements of a Category array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As Category() _
)
[C#]
public void AddRange(
Category[] items
);

Parameters

items
The array of Category elements to be added to the end of the collection.

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace | CategoryCollection.AddRange Overload List


CategoryCollection.AddRange Method (CategoryCollection)

Adds the elements of a CategoryCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As CategoryCollection _
)
[C#]
public void AddRange(
CategoryCollection items
);

Parameters

items
The CategoryCollection to be added to the end of the collection.

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace | CategoryCollection.AddRange Overload List


Contains Method

NAnt SDK Documentation - v0.91

CategoryCollection.Contains Method

Determines whether a Category is in the collection.

Overload List

Determines whether a Category is in the collection.

public bool Contains(Category);

Determines whether a Category with the specified value is in the collection.

public bool Contains(string);

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace


CategoryCollection.Contains Method (Category)

Determines whether a Category is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal item As Category _
) As Boolean
[C#]
public bool Contains(
Category item
);

Parameters

item
The Category to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace | CategoryCollection.Contains Overload List


CategoryCollection.Contains Method (String)

Determines whether a Category with the specified value is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal value As String _
) As Boolean
[C#]
public bool Contains(
string value
);

Parameters

value
The argument value to locate in the collection.

Return Value

true if a Category with value value is found in the collection; otherwise, false.

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace | CategoryCollection.Contains Overload List


CategoryCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As Category(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
Category[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace


CategoryCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As CategoryEnumerator
[C#]
new public CategoryEnumerator GetEnumerator();

Return Value

A CategoryEnumerator for the entire collection.

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace


CategoryCollection.IndexOf Method

Retrieves the index of a specified Category object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As Category _
) As Integer
[C#]
public int IndexOf(
Category item
);

Parameters

item
The Category object for which the index is returned.

Return Value

The index of the specified Category. If the Category is not currently a member of the collection, it returns -1.

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace


CategoryCollection.Insert Method

Inserts a Category into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As Category _
)
[C#]
public void Insert(
int index,
Category item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The Category to insert.

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace


CategoryCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As Category _
)
[C#]
public void Remove(
Category item
);

Parameters

item
The Category to remove from the collection.

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace


CategoryCollection.ToString Method

Returns a comma-delimited list of categories.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

A comma-delimited list of categories, or an empty String if there are no categories.

See Also

CategoryCollection Class | NAnt.NUnit2.Types Namespace


CategoryEnumerator Class

Enumerates the Category elements of a CategoryCollection.

For a list of all members of this type, see CategoryEnumerator Members.

System.Object
NAnt.NUnit2.Types.CategoryEnumerator

[Visual Basic]
Public Class CategoryEnumerator
Implements IEnumerator
[C#]
public class CategoryEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit2.Types

Assembly: NAnt.NUnit2Tasks (in NAnt.NUnit2Tasks.dll)

See Also

CategoryEnumerator Members | NAnt.NUnit2.Types Namespace


CategoryEnumerator Members

CategoryEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CategoryEnumerator Class | NAnt.NUnit2.Types Namespace


CategoryEnumerator Properties

The properties of the CategoryEnumerator class are listed below. For a complete list of CategoryEnumerator class members, see the CategoryEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

CategoryEnumerator Class | NAnt.NUnit2.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

CategoryEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As Category
[C#]
public Category Current {get;}

See Also

CategoryEnumerator Class | NAnt.NUnit2.Types Namespace


CategoryEnumerator Methods

The methods of the CategoryEnumerator class are listed below. For a complete list of CategoryEnumerator class members, see the CategoryEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CategoryEnumerator Class | NAnt.NUnit2.Types Namespace


CategoryEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

CategoryEnumerator Class | NAnt.NUnit2.Types Namespace


CategoryEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

CategoryEnumerator Class | NAnt.NUnit2.Types Namespace


NUnit2Test Class

Represents a test element of an NUnit2Task.

For a list of all members of this type, see NUnit2Test Members.

System.Object
NAnt.Core.Element
NAnt.NUnit2.Types.NUnit2Test

[Visual Basic]
<ElementName(Name:="test")>
Public Class NUnit2Test
Inherits Element
[C#]
[ElementName(Name="test")]
public class NUnit2Test : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit2.Types

Assembly: NAnt.NUnit2Tasks (in NAnt.NUnit2Tasks.dll)

See Also

NUnit2Test Members | NAnt.NUnit2.Types Namespace


NUnit2Test Members

NUnit2Test overview

Public Instance Constructors

NUnit2Test Constructor Initializes a new instance of the NUnit2Test class.

Public Instance Properties

AppConfigFile | The application configuration file to use for the NUnit test domain. If not specified, NAnt will try to use a configuration name matching the file name of the assembly with extension ".config".
Assemblies | Assemblies to include in test.
AssemblyFile | Name of the assembly to search for tests.
Categories | Categories of test cases to include or exclude.
HaltOnFailure | Build fails on failure. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
References | Assemblies to scan for missing assembly references.
TestAssemblies | Gets all assemblies specified for these tests.
TestName | Name of a specific testfixture to run. If not specified then all testfixtures are run.
XsltFile | XSLT transform file to use when using the Plain formatter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NUnit2Test Class | NAnt.NUnit2.Types Namespace


NUnit2Test Constructor

Initializes a new instance of the NUnit2Test class.

[Visual Basic]
Public Sub New()
[C#]
public NUnit2Test();

See Also

NUnit2Test Class | NAnt.NUnit2.Types Namespace


NUnit2Test Properties

The properties of the NUnit2Test class are listed below. For a complete list of NUnit2Test class members, see the NUnit2Test Members topic.

Public Instance Properties

AppConfigFile | The application configuration file to use for the NUnit test domain. If not specified, NAnt will try to use a configuration name matching the file name of the assembly with extension ".config".
Assemblies | Assemblies to include in test.
AssemblyFile | Name of the assembly to search for tests.
Categories | Categories of test cases to include or exclude.
HaltOnFailure | Build fails on failure. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
References | Assemblies to scan for missing assembly references.
TestAssemblies | Gets all assemblies specified for these tests.
TestName | Name of a specific testfixture to run. If not specified then all testfixtures are run.
XsltFile | XSLT transform file to use when using the Plain formatter.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

NUnit2Test Class | NAnt.NUnit2.Types Namespace


AppConfigFile Property

NAnt SDK Documentation - v0.91

NUnit2Test.AppConfigFile Property

The application configuration file to use for the NUnit test domain. If not specified, NAnt will try to use a configuration name matching the file name of the assembly with extension ".config".

[Visual Basic]
<TaskAttribute(Name:="appconfig", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property AppConfigFile As FileInfo
[C#]
[TaskAttribute(Name="appconfig", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo AppConfigFile {get; set;}

See Also

NUnit2Test Class | NAnt.NUnit2.Types Namespace


Assemblies Property

NAnt SDK Documentation - v0.91

NUnit2Test.Assemblies Property

Assemblies to include in test.

[Visual Basic]
<BuildElement(Name:="assemblies", Required:=False, ProcessXml:=True)>
Public Property Assemblies As AssemblyFileSet
[C#]
[BuildElement(Name="assemblies", Required=False, ProcessXml=True)]
public NAnt.DotNet.Types.AssemblyFileSet Assemblies {get; set;}

See Also

NUnit2Test Class | NAnt.NUnit2.Types Namespace


AssemblyFile Property

NAnt SDK Documentation - v0.91

NUnit2Test.AssemblyFile Property

Name of the assembly to search for tests.

[Visual Basic]
<TaskAttribute(Name:="assemblyname", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property AssemblyFile As FileInfo
[C#]
[TaskAttribute(Name="assemblyname", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo AssemblyFile {get; set;}

See Also

NUnit2Test Class | NAnt.NUnit2.Types Namespace


Categories Property

NAnt SDK Documentation - v0.91

NUnit2Test.Categories Property

Categories of test cases to include or exclude.

[Visual Basic]
<BuildElement(Name:="categories", Required:=False, ProcessXml:=True)>
Public Property Categories As Categories
[C#]
[BuildElement(Name="categories", Required=False, ProcessXml=True)]
public Categories Categories {get; set;}

See Also

NUnit2Test Class | NAnt.NUnit2.Types Namespace


HaltOnFailure Property

NAnt SDK Documentation - v0.91

NUnit2Test.HaltOnFailure Property

Build fails on failure. The default is true.

[Visual Basic]
<TaskAttribute(Name:="haltonfailure", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property HaltOnFailure As Boolean
[C#]
[TaskAttribute(Name="haltonfailure", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool HaltOnFailure {get; set;}

See Also

NUnit2Test Class | NAnt.NUnit2.Types Namespace


References Property

NAnt SDK Documentation - v0.91

NUnit2Test.References Property

Assemblies to scan for missing assembly references.

[Visual Basic]
<BuildElement(Name:="references", Required:=False, ProcessXml:=True)>
Public Property References As AssemblyFileSet
[C#]
[BuildElement(Name="references", Required=False, ProcessXml=True)]
public NAnt.DotNet.Types.AssemblyFileSet References {get; set;}

See Also

NUnit2Test Class | NAnt.NUnit2.Types Namespace


TestAssemblies Property

NAnt SDK Documentation - v0.91

NUnit2Test.TestAssemblies Property

Gets all assemblies specified for these tests.

[Visual Basic]
Public ReadOnly Property TestAssemblies As StringCollection
[C#]
public System.Collections.Specialized.StringCollection TestAssemblies {get;}

See Also

NUnit2Test Class | NAnt.NUnit2.Types Namespace


TestName Property

NAnt SDK Documentation - v0.91

NUnit2Test.TestName Property

Name of a specific testfixture to run. If not specified then all testfixtures are run.

[Visual Basic]
<TaskAttribute(Name:="testname", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property TestName As String
[C#]
[TaskAttribute(Name="testname", Required=False, ExpandProperties=True, ProcessXml=True)]
public string TestName {get; set;}

See Also

NUnit2Test Class | NAnt.NUnit2.Types Namespace


XsltFile Property

NAnt SDK Documentation - v0.91

NUnit2Test.XsltFile Property

XSLT transform file to use when using the Plain formatter.

[Visual Basic]
<TaskAttribute(Name:="transformfile", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property XsltFile As FileInfo
[C#]
[TaskAttribute(Name="transformfile", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo XsltFile {get; set;}

See Also

NUnit2Test Class | NAnt.NUnit2.Types Namespace


NUnit2TestCollection Class

Contains a strongly typed collection of NUnit2Test objects.

For a list of all members of this type, see NUnit2TestCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.NUnit2.Types.NUnit2TestCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class NUnit2TestCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class NUnit2TestCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit2.Types

Assembly: NAnt.NUnit2Tasks (in NAnt.NUnit2Tasks.dll)

See Also

NUnit2TestCollection Members | NAnt.NUnit2.Types Namespace


NUnit2TestCollection Members

NUnit2TestCollection overview

Public Instance Constructors

NUnit2TestCollection Overloaded. Initializes a new instance of the NUnit2TestCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a NUnit2Test to the end of the collection.
AddRange | Overloaded. Adds the elements of a NUnit2Test array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a NUnit2Test is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified NUnit2Test object in the collection.
Insert | Inserts a NUnit2Test into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

NUnit2TestCollection Class | NAnt.NUnit2.Types Namespace


NUnit2TestCollection Constructor

Initializes a new instance of the NUnit2TestCollection class.

Overload List

Initializes a new instance of the NUnit2TestCollection class.

public NUnit2TestCollection();

Initializes a new instance of the NUnit2TestCollection class with the specified array of NUnit2Test instances.

public NUnit2TestCollection(NUnit2Test[]);

Initializes a new instance of the NUnit2TestCollection class with the specified NUnit2TestCollection instance.

public NUnit2TestCollection(NUnit2TestCollection);

See Also

NUnit2TestCollection Class | NAnt.NUnit2.Types Namespace


NUnit2TestCollection Constructor ()

Initializes a new instance of the NUnit2TestCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public NUnit2TestCollection();

See Also

NUnit2TestCollection Class | NAnt.NUnit2.Types Namespace | NUnit2TestCollection Constructor Overload List


NUnit2TestCollection Constructor (NUnit2TestCollection)

Initializes a new instance of the NUnit2TestCollection class with the specified NUnit2TestCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As NUnit2TestCollection _
)
[C#]
public NUnit2TestCollection(
NUnit2TestCollection value
);

See Also

NUnit2TestCollection Class | NAnt.NUnit2.Types Namespace | NUnit2TestCollection Constructor Overload List


NUnit2TestCollection Constructor (NUnit2Test[])

Initializes a new instance of the NUnit2TestCollection class with the specified array of NUnit2Test instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As NUnit2Test() _
)
[C#]
public NUnit2TestCollection(
NUnit2Test[] value
);

See Also

NUnit2TestCollection Class | NAnt.NUnit2.Types Namespace | NUnit2TestCollection Constructor Overload List


NUnit2TestCollection Properties

The properties of the NUnit2TestCollection class are listed below. For a complete list of NUnit2TestCollection class members, see the NUnit2TestCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

NUnit2TestCollection Class | NAnt.NUnit2.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

NUnit2TestCollection.Item Property

Gets or sets the element at the specified index.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As NUnit2Test
[C#]
public NUnit2Test this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

NUnit2TestCollection Class | NAnt.NUnit2.Types Namespace


NUnit2TestCollection Methods

The methods of the NUnit2TestCollection class are listed below. For a complete list of NUnit2TestCollection class members, see the NUnit2TestCollection Members topic.

Public Instance Methods

Add | Adds a NUnit2Test to the end of the collection.
AddRange | Overloaded. Adds the elements of a NUnit2Test array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a NUnit2Test is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified NUnit2Test object in the collection.
Insert | Inserts a NUnit2Test into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

NUnit2TestCollection Class | NAnt.NUnit2.Types Namespace


NUnit2TestCollection.Add Method

Adds a NUnit2Test to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As NUnit2Test _
) As Integer
[C#]
public int Add(
NUnit2Test item
);

Parameters

item
The NUnit2Test to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

NUnit2TestCollection Class | NAnt.NUnit2.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

NUnit2TestCollection.AddRange Method

Adds the elements of a NUnit2Test array to the end of the collection.

Overload List

Adds the elements of a NUnit2Test array to the end of the collection.

public void AddRange(NUnit2Test[]);

Adds the elements of a NUnit2TestCollection to the end of the collection.

public void AddRange(NUnit2TestCollection);

See Also

NUnit2TestCollection Class | NAnt.NUnit2.Types Namespace


NUnit2TestCollection.AddRange Method (NUnit2Test[])

Adds the elements of a NUnit2Test array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As NUnit2Test() _
)
[C#]
public void AddRange(
NUnit2Test[] items
);

Parameters

items
The array of NUnit2Test elements to be added to the end of the collection.

See Also

NUnit2TestCollection Class | NAnt.NUnit2.Types Namespace | NUnit2TestCollection.AddRange Overload List


NUnit2TestCollection.AddRange Method (NUnit2TestCollection)

Adds the elements of a NUnit2TestCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As NUnit2TestCollection _
)
[C#]
public void AddRange(
NUnit2TestCollection items
);

Parameters

items
The NUnit2TestCollection to be added to the end of the collection.

See Also

NUnit2TestCollection Class | NAnt.NUnit2.Types Namespace | NUnit2TestCollection.AddRange Overload List


NUnit2TestCollection.Contains Method

Determines whether a NUnit2Test is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal item As NUnit2Test _
) As Boolean
[C#]
public bool Contains(
NUnit2Test item
);

Parameters

item
The NUnit2Test to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

NUnit2TestCollection Class | NAnt.NUnit2.Types Namespace


NUnit2TestCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As NUnit2Test(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
NUnit2Test[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

NUnit2TestCollection Class | NAnt.NUnit2.Types Namespace


NUnit2TestCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As NUnit2TestEnumerator
[C#]
new public NUnit2TestEnumerator GetEnumerator();

Return Value

A NUnit2TestEnumerator for the entire collection.

See Also

NUnit2TestCollection Class | NAnt.NUnit2.Types Namespace


NUnit2TestCollection.IndexOf Method

Retrieves the index of a specified NUnit2Test object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As NUnit2Test _
) As Integer
[C#]
public int IndexOf(
NUnit2Test item
);

Parameters

item
The NUnit2Test object for which the index is returned.

Return Value

The index of the specified NUnit2Test. If the NUnit2Test is not currently a member of the collection, it returns -1.

See Also

NUnit2TestCollection Class | NAnt.NUnit2.Types Namespace


NUnit2TestCollection.Insert Method

Inserts a NUnit2Test into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As NUnit2Test _
)
[C#]
public void Insert(
int index,
NUnit2Test item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The NUnit2Test to insert.

See Also

NUnit2TestCollection Class | NAnt.NUnit2.Types Namespace


NUnit2TestCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As NUnit2Test _
)
[C#]
public void Remove(
NUnit2Test item
);

Parameters

item
The NUnit2Test to remove from the collection.

See Also

NUnit2TestCollection Class | NAnt.NUnit2.Types Namespace


NUnit2TestEnumerator Class

Enumerates the NUnit2Test elements of a NUnit2TestCollection.

For a list of all members of this type, see NUnit2TestEnumerator Members.

System.Object
NAnt.NUnit2.Types.NUnit2TestEnumerator

[Visual Basic]
Public Class NUnit2TestEnumerator
Implements IEnumerator
[C#]
public class NUnit2TestEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.NUnit2.Types

Assembly: NAnt.NUnit2Tasks (in NAnt.NUnit2Tasks.dll)

See Also

NUnit2TestEnumerator Members | NAnt.NUnit2.Types Namespace


NUnit2TestEnumerator Members

NUnit2TestEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NUnit2TestEnumerator Class | NAnt.NUnit2.Types Namespace


NUnit2TestEnumerator Properties

The properties of the NUnit2TestEnumerator class are listed below. For a complete list of NUnit2TestEnumerator class members, see the NUnit2TestEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

NUnit2TestEnumerator Class | NAnt.NUnit2.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

NUnit2TestEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As NUnit2Test
[C#]
public NUnit2Test Current {get;}

See Also

NUnit2TestEnumerator Class | NAnt.NUnit2.Types Namespace


NUnit2TestEnumerator Methods

The methods of the NUnit2TestEnumerator class are listed below. For a complete list of NUnit2TestEnumerator class members, see the NUnit2TestEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NUnit2TestEnumerator Class | NAnt.NUnit2.Types Namespace


NUnit2TestEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

NUnit2TestEnumerator Class | NAnt.NUnit2.Types Namespace


NUnit2TestEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

NUnit2TestEnumerator Class | NAnt.NUnit2.Types Namespace


NAnt.SourceControl.Tasks

NAnt SDK Documentation - v0.91

NAnt.SourceControl.Tasks Namespace

Namespace hierarchy

Classes

Class | Description
AbstractCvsTask | A base class for creating tasks for executing CVS client commands on a CVS repository.
AbstractSourceControlTask | A base class for creating tasks for executing CVS client commands on a CVS repository.
ChangeLogTask | Produces an XML report that represents the cvs changes from the given start day, to a given end date.
CheckoutTask | Checks out a CVS module to the required directory.
CvsPass | Executes the cvs login command which appends or updates an entry to the specified .cvspass file.
CvsTask | Executes the cvs command specified by the command attribute.
ExportTask | Exports a cvs module in preperation for a release (i.e. the CVS version folders are not exported).
RTagTask | Tags all sources in the remote repository with a given tag.
TagTask | Tags all local sources with the specified tag.
UpdateTask | Updates a CVS module in a local working directory.


AbstractCvsTask Class

A base class for creating tasks for executing CVS client commands on a CVS repository.

For a list of all members of this type, see AbstractCvsTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.SourceControl.Tasks.AbstractSourceControlTask
NAnt.SourceControl.Tasks.AbstractCvsTask
Derived types

[Visual Basic]
MustInherit Public Class AbstractCvsTask
Inherits AbstractSourceControlTask
[C#]
public abstract class AbstractCvsTask : AbstractSourceControlTask

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.SourceControl.Tasks

Assembly: NAnt.SourceControlTasks (in NAnt.SourceControlTasks.dll)

See Also

AbstractCvsTask Members | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask Members

AbstractCvsTask overview

Protected Static (Shared) Fields

CvsExe | The name of the cvs executable.
CvsHome | An environment variable that holds path information about where cvs is located.
CvsPassfile | Name of the password file that cvs stores pserver cvsroot/ password pairings.
CvsRsh | Environment variable that holds the executable name that is used for ssh communication.
DefaultCompressionLevel | The default compression level to use for cvs commands.
DefaultQuiet | Default value for the quiet command.
DefaultReallyQuiet | Default value for the really quiet command.
DefaultRecursive | Default value for the recursive directive. The default is false.
DefaultUseSharpCvsLib | The default use of binaries, defaults to use sharpcvs.
SharpCvsExe | The temporary name of the sharpcvslib binary file, to avoid conflicts in the path variable.
UseSharpCvsLibProp | Property name used to specify on a project level whether sharpcvs is used or not.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments (inherited from AbstractSourceControlTask) | Command-line arguments for the program. The command line arguments are used to specify any cvs command options that are not available as attributes. These are appended after the command itself and are additive to whatever attributes are currently specified.
CommandName (inherited from AbstractSourceControlTask) | The name of the command that is going to be executed.
CommandOptions (inherited from AbstractSourceControlTask) | A collection of options that can be used to modify the default behavoir of the version control commands. See the sub-tasks for implementation specifics.
CompressionLevel Compression level to use for all net traffic. This should be a value from 1-9.

NOTE: This is not available on sharpcvslib.
CvsFileSet | Used to specify the version control system (VCS) files that are going to be acted on.
CvsFullPath | The full path to the cvs binary used. The cvs tasks will attempt to "guess" the location of your cvs binary based on your path. If the task is unable to resolve the location, or resolves it incorrectly this can be used to manually specify the path.
DestinationDirectory (inherited from AbstractSourceControlTask) | Destination directory for the local sandbox. If destination is not specified then the current directory is used.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName | The name of the cvs executable.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
GlobalOptions (inherited from AbstractSourceControlTask) | Holds a collection of globally available options.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Module | The module to perform an operation on.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile (inherited from AbstractSourceControlTask) | The full path to the cached password file. If not specified then the environment variables are used to try and locate the file.
Password (inherited from AbstractSourceControlTask) | Obsolete. The password for logging in to the repository.
ProgramArguments (inherited from AbstractSourceControlTask) | Get the command line arguments for the task.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Quiet | Indicates if the output from the cvs command should be supressed. The default is false.
ReadOnly | true if the sandbox files should be checked out in read only mode. The default is false.
ReadWrite | true if the sandbox files should be checked out in read/write mode. The default is true.
ReallyQuiet | Indicates if the output from the cvs command should be stopped. The default is false.
Root The cvs root variable has the following components:
[protocol]:[username]@[servername]:[server path]
  • protocol: ext, pserver, ssh (sharpcvslib); if you are not using sharpcvslib consult your cvs documentation.
  • username: [username]
  • servername: cvs.sourceforge.net
  • server path: /cvsroot/nant
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Ssh | The executable to use for ssh communication.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
UseSharpCvsLib | true if the SharpCvsLib binaries that come bundled with NAnt should be used to perform the cvs commands, false otherwise. You may also specify an override value for all cvs tasks instead of specifying a value for each. To do this set the property sourcecontrol.usesharpcvslib to false. If you choose not to use SharpCvsLib to checkout from cvs you will need to include a cvs.exe binary in your path.
VcsFileSet | Get the cvs file set.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

AbstractCvsTask Constructor Initializes a new instance of the AbstractCvsTask class.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
IsModuleNeeded | Specify if the module is needed for this cvs command. It is only needed if there is no module information on the local file system.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
PassFileName | The name of the pass file, or .cvspass at the time of this writing.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
SshEnv | The environment name for the ssh variable.
VcsExeName | The name of the cvs binary, or cvs.exe at the time this was written.
VcsHome (inherited from AbstractSourceControlTask) | The path to the specific home directory of the version control system, this can be where the binary files are kept, or other app information.
VcsHomeEnv | The name of the version control system specific home environment variable.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

AddArg | Add the given argument to the command line options. Note that are not explicitly quoted are split into seperate arguments. This is to resolve a recent issue with quoting command line arguments.
AppendFiles (inherited from AbstractSourceControlTask) | Append the files specified in the fileset to the command line argument. Files are changed to use a relative path from the working directory that the task is spawned in.
AppendSubCommandArgs | Override to append any commands before the modele and files.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
DeriveVcsFromEnvironment (inherited from AbstractSourceControlTask) Derive the location of the version control system from the environment variable
PATH
.
ExecuteTask (inherited from ExternalProgramBase) | Starts the external process and captures its output.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess | Build up the command line arguments, determine which executable is being used and find the path to that executable and set the working directory.
SetCommandOption (inherited from AbstractSourceControlTask) | Adds a new command option if none exists. If one does exist then the use switch is toggled on or of.
SetEnvironment (inherited from AbstractSourceControlTask) | Set up the environment variables for a process.
SetGlobalOption (inherited from AbstractSourceControlTask) | Adds a new global option if none exists. If one does exist then the use switch is toggled on or of.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
ToCvsDateTimeString | Converts a DateTime value to a String representation that can be interpreted by cvs.

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask Constructor

Initializes a new instance of the AbstractCvsTask class.

[Visual Basic]
Protected Sub New()
[C#]
protected AbstractCvsTask();

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask Fields

The fields of the AbstractCvsTask class are listed below. For a complete list of AbstractCvsTask class members, see the AbstractCvsTask Members topic.

Protected Static (Shared) Fields

CvsExe | The name of the cvs executable.
CvsHome | An environment variable that holds path information about where cvs is located.
CvsPassfile | Name of the password file that cvs stores pserver cvsroot/ password pairings.
CvsRsh | Environment variable that holds the executable name that is used for ssh communication.
DefaultCompressionLevel | The default compression level to use for cvs commands.
DefaultQuiet | Default value for the quiet command.
DefaultReallyQuiet | Default value for the really quiet command.
DefaultRecursive | Default value for the recursive directive. The default is false.
DefaultUseSharpCvsLib | The default use of binaries, defaults to use sharpcvs.
SharpCvsExe | The temporary name of the sharpcvslib binary file, to avoid conflicts in the path variable.
UseSharpCvsLibProp | Property name used to specify on a project level whether sharpcvs is used or not.

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask.CvsExe Field

The name of the cvs executable.

[Visual Basic]
Protected Const CvsExe As String = "cvs.exe"
[C#]
protected const string CvsExe = "cvs.exe";

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask.CvsHome Field

An environment variable that holds path information about where cvs is located.

[Visual Basic]
Protected Const CvsHome As String = "CVS_HOME"
[C#]
protected const string CvsHome = "CVS_HOME";

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask.CvsPassfile Field

Name of the password file that cvs stores pserver cvsroot/ password pairings.

[Visual Basic]
Protected Const CvsPassfile As String = ".cvspass"
[C#]
protected const string CvsPassfile = ".cvspass";

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask.CvsRsh Field

Environment variable that holds the executable name that is used for ssh communication.

[Visual Basic]
Protected Const CvsRsh As String = "CVS_RSH"
[C#]
protected const string CvsRsh = "CVS_RSH";

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask.DefaultCompressionLevel Field

The default compression level to use for cvs commands.

[Visual Basic]
Protected Const DefaultCompressionLevel As Integer = 3
[C#]
protected const int DefaultCompressionLevel = 3;

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask.DefaultQuiet Field

Default value for the quiet command.

[Visual Basic]
Protected Const DefaultQuiet As Boolean = False
[C#]
protected const bool DefaultQuiet = False;

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask.DefaultReallyQuiet Field

Default value for the really quiet command.

[Visual Basic]
Protected Const DefaultReallyQuiet As Boolean = False
[C#]
protected const bool DefaultReallyQuiet = False;

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask.DefaultRecursive Field

Default value for the recursive directive. The default is false.

[Visual Basic]
Protected Const DefaultRecursive As Boolean = False
[C#]
protected const bool DefaultRecursive = False;

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask.DefaultUseSharpCvsLib Field

The default use of binaries, defaults to use sharpcvs.

[Visual Basic]
Protected Const DefaultUseSharpCvsLib As Boolean = True
[C#]
protected const bool DefaultUseSharpCvsLib = True;

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask.SharpCvsExe Field

The temporary name of the sharpcvslib binary file, to avoid conflicts in the path variable.

[Visual Basic]
Protected Const SharpCvsExe As String = "scvs.exe"
[C#]
protected const string SharpCvsExe = "scvs.exe";

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask.UseSharpCvsLibProp Field

Property name used to specify on a project level whether sharpcvs is used or not.

[Visual Basic]
Protected Const UseSharpCvsLibProp As String = "sourcecontrol.usesharpcvslib"
[C#]
protected const string UseSharpCvsLibProp = "sourcecontrol.usesharpcvslib";

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask Properties

The properties of the AbstractCvsTask class are listed below. For a complete list of AbstractCvsTask class members, see the AbstractCvsTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments (inherited from AbstractSourceControlTask) | Command-line arguments for the program. The command line arguments are used to specify any cvs command options that are not available as attributes. These are appended after the command itself and are additive to whatever attributes are currently specified.
CommandName (inherited from AbstractSourceControlTask) | The name of the command that is going to be executed.
CommandOptions (inherited from AbstractSourceControlTask) | A collection of options that can be used to modify the default behavoir of the version control commands. See the sub-tasks for implementation specifics.
CompressionLevel Compression level to use for all net traffic. This should be a value from 1-9.

NOTE: This is not available on sharpcvslib.
CvsFileSet | Used to specify the version control system (VCS) files that are going to be acted on.
CvsFullPath | The full path to the cvs binary used. The cvs tasks will attempt to "guess" the location of your cvs binary based on your path. If the task is unable to resolve the location, or resolves it incorrectly this can be used to manually specify the path.
DestinationDirectory (inherited from AbstractSourceControlTask) | Destination directory for the local sandbox. If destination is not specified then the current directory is used.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName | The name of the cvs executable.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
GlobalOptions (inherited from AbstractSourceControlTask) | Holds a collection of globally available options.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Module | The module to perform an operation on.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile (inherited from AbstractSourceControlTask) | The full path to the cached password file. If not specified then the environment variables are used to try and locate the file.
Password (inherited from AbstractSourceControlTask) | Obsolete. The password for logging in to the repository.
ProgramArguments (inherited from AbstractSourceControlTask) | Get the command line arguments for the task.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Quiet | Indicates if the output from the cvs command should be supressed. The default is false.
ReadOnly | true if the sandbox files should be checked out in read only mode. The default is false.
ReadWrite | true if the sandbox files should be checked out in read/write mode. The default is true.
ReallyQuiet | Indicates if the output from the cvs command should be stopped. The default is false.
Root The cvs root variable has the following components:
[protocol]:[username]@[servername]:[server path]
  • protocol: ext, pserver, ssh (sharpcvslib); if you are not using sharpcvslib consult your cvs documentation.
  • username: [username]
  • servername: cvs.sourceforge.net
  • server path: /cvsroot/nant
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Ssh | The executable to use for ssh communication.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
UseSharpCvsLib | true if the SharpCvsLib binaries that come bundled with NAnt should be used to perform the cvs commands, false otherwise. You may also specify an override value for all cvs tasks instead of specifying a value for each. To do this set the property sourcecontrol.usesharpcvslib to false. If you choose not to use SharpCvsLib to checkout from cvs you will need to include a cvs.exe binary in your path.
VcsFileSet | Get the cvs file set.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
IsModuleNeeded | Specify if the module is needed for this cvs command. It is only needed if there is no module information on the local file system.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
PassFileName | The name of the pass file, or .cvspass at the time of this writing.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
SshEnv | The environment name for the ssh variable.
VcsExeName | The name of the cvs binary, or cvs.exe at the time this was written.
VcsHome (inherited from AbstractSourceControlTask) | The path to the specific home directory of the version control system, this can be where the binary files are kept, or other app information.
VcsHomeEnv | The name of the version control system specific home environment variable.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


CompressionLevel Property

NAnt SDK Documentation - v0.91

AbstractCvsTask.CompressionLevel Property

Compression level to use for all net traffic. This should be a value from 1-9.

NOTE: This is not available on sharpcvslib.

[Visual Basic]
<TaskAttribute(Name:="compressionlevel", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property CompressionLevel As Integer
[C#]
[TaskAttribute(Name="compressionlevel", Required=False, ExpandProperties=True, ProcessXml=True)]
public int CompressionLevel {get; set;}

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


CvsFileSet Property

NAnt SDK Documentation - v0.91

AbstractCvsTask.CvsFileSet Property

Used to specify the version control system (VCS) files that are going to be acted on.

[Visual Basic]
<BuildElement(Name:="fileset", Required:=False, ProcessXml:=True)>
Public Property CvsFileSet As CvsFileSet
[C#]
[BuildElement(Name="fileset", Required=False, ProcessXml=True)]
public NAnt.SourceControl.Types.CvsFileSet CvsFileSet {get; set;}

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


CvsFullPath Property

NAnt SDK Documentation - v0.91

AbstractCvsTask.CvsFullPath Property

The full path to the cvs binary used. The cvs tasks will attempt to "guess" the location of your cvs binary based on your path. If the task is unable to resolve the location, or resolves it incorrectly this can be used to manually specify the path.

[Visual Basic]
<TaskAttribute(Name:="cvsfullpath", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property CvsFullPath As FileInfo
[C#]
[TaskAttribute(Name="cvsfullpath", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo CvsFullPath {get; set;}

Property Value

A full path (i.e. including file name) of your cvs binary: On Windows: c:\vcs\cvs\cvs.exe On *nix: /usr/bin/cvs

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


ExeName Property

NAnt SDK Documentation - v0.91

AbstractCvsTask.ExeName Property

The name of the cvs executable.

[Visual Basic]
Overrides Public ReadOnly Property ExeName As String
[C#]
public override string ExeName {get;}

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


IsModuleNeeded Property

NAnt SDK Documentation - v0.91

AbstractCvsTask.IsModuleNeeded Property

Specify if the module is needed for this cvs command. It is only needed if there is no module information on the local file system.

[Visual Basic]
Overridable Protected ReadOnly Property IsModuleNeeded As Boolean
[C#]
protected virtual bool IsModuleNeeded {get;}

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


Module Property

NAnt SDK Documentation - v0.91

AbstractCvsTask.Module Property

The module to perform an operation on.

[Visual Basic]
<TaskAttribute(Name:="module", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=True, Expression:="null", ExpressionErrorMessage:="null")>
Overridable Public Property Module As String
[C#]
[TaskAttribute(Name="module", Required=False, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=True, Expression="null", ExpressionErrorMessage="null")]
public virtual string Module {get; set;}

Property Value

The module to perform an operation on. This is a normal file/folder name without path information.

Example

In NAnt the module name would be:

nant

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


PassFileName Property

NAnt SDK Documentation - v0.91

AbstractCvsTask.PassFileName Property

The name of the pass file, or .cvspass at the time of this writing.

[Visual Basic]
Overrides Protected ReadOnly Property PassFileName As String
[C#]
protected override string PassFileName {get;}

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


Quiet Property

NAnt SDK Documentation - v0.91

AbstractCvsTask.Quiet Property

Indicates if the output from the cvs command should be supressed. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="quiet", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Quiet As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="quiet", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool Quiet {get; set;}

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


ReadOnly Property

NAnt SDK Documentation - v0.91

AbstractCvsTask.ReadOnly Property

true if the sandbox files should be checked out in read only mode. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="readonly", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property ReadOnly As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="readonly", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool ReadOnly {get; set;}

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


ReadWrite Property

NAnt SDK Documentation - v0.91

AbstractCvsTask.ReadWrite Property

true if the sandbox files should be checked out in read/write mode. The default is true.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="readwrite", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property ReadWrite As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="readwrite", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool ReadWrite {get; set;}

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


ReallyQuiet Property

NAnt SDK Documentation - v0.91

AbstractCvsTask.ReallyQuiet Property

Indicates if the output from the cvs command should be stopped. The default is false.

[Visual Basic]
<TaskAttribute(Name:="reallyquiet", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property ReallyQuiet As Boolean
[C#]
[TaskAttribute(Name="reallyquiet", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool ReallyQuiet {get; set;}

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


Root Property

NAnt SDK Documentation - v0.91

AbstractCvsTask.Root Property

The cvs root variable has the following components:

[protocol]:[username]@[servername]:[server path]
  • protocol: ext, pserver, ssh (sharpcvslib); if you are not using sharpcvslib consult your cvs documentation.
  • username: [username]
  • servername: cvs.sourceforge.net
  • server path: /cvsroot/nant

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="cvsroot", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overrides Public Property Root As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="cvsroot", Required=False, ExpandProperties=True, ProcessXml=True)]
public override string Root {get; set;}

Example

NAnt anonymous cvsroot:

              :pserver:anonymous@cvs.sourceforge.net:/cvsroot/nant

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


Ssh Property

NAnt SDK Documentation - v0.91

AbstractCvsTask.Ssh Property

The executable to use for ssh communication.

[Visual Basic]
<TaskAttribute(Name:="cvsrsh", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overrides Public Property Ssh As FileInfo
[C#]
[TaskAttribute(Name="cvsrsh", Required=False, ExpandProperties=True, ProcessXml=True)]
public override System.IO.FileInfo Ssh {get; set;}

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


SshEnv Property

NAnt SDK Documentation - v0.91

AbstractCvsTask.SshEnv Property

The environment name for the ssh variable.

[Visual Basic]
Overrides Protected ReadOnly Property SshEnv As String
[C#]
protected override string SshEnv {get;}

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


UseSharpCvsLib Property

NAnt SDK Documentation - v0.91

AbstractCvsTask.UseSharpCvsLib Property

true if the SharpCvsLib binaries that come bundled with NAnt should be used to perform the cvs commands, false otherwise.

You may also specify an override value for all cvs tasks instead of specifying a value for each. To do this set the property sourcecontrol.usesharpcvslib to false.

If you choose not to use SharpCvsLib to checkout from cvs you will need to include a cvs.exe binary in your path.
[Visual Basic]
<TaskAttribute(Name:="usesharpcvslib", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property UseSharpCvsLib As Boolean
[C#]
[TaskAttribute(Name="usesharpcvslib", Required=False, ExpandProperties=True, ProcessXml=True)]
public virtual bool UseSharpCvsLib {get; set;}

Example

To use a cvs client in your path instead of sharpcvslib specify the property: >property name="sourcecontrol.usesharpcvslib" value="false"< The default settings is to use sharpcvslib and the setting closest to the task execution is used to determine which value is used to execute the process. For instance if the attribute usesharpcvslib was set to false and the global property was set to true, the usesharpcvslib is closes to the point of execution and would be used and is false. Therefore the sharpcvslib binary would NOT be used.

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


VcsExeName Property

NAnt SDK Documentation - v0.91

AbstractCvsTask.VcsExeName Property

The name of the cvs binary, or cvs.exe at the time this was written.

[Visual Basic]
Overrides Protected ReadOnly Property VcsExeName As String
[C#]
protected override string VcsExeName {get;}

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


VcsFileSet Property

NAnt SDK Documentation - v0.91

AbstractCvsTask.VcsFileSet Property

Get the cvs file set.

[Visual Basic]
Overrides Public ReadOnly Property VcsFileSet As FileSet
[C#]
public override NAnt.Core.Types.FileSet VcsFileSet {get;}

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


VcsHomeEnv Property

NAnt SDK Documentation - v0.91

AbstractCvsTask.VcsHomeEnv Property

The name of the version control system specific home environment variable.

[Visual Basic]
Overrides Protected ReadOnly Property VcsHomeEnv As String
[C#]
protected override string VcsHomeEnv {get;}

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask Methods

The methods of the AbstractCvsTask class are listed below. For a complete list of AbstractCvsTask class members, see the AbstractCvsTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddArg | Add the given argument to the command line options. Note that are not explicitly quoted are split into seperate arguments. This is to resolve a recent issue with quoting command line arguments.
AppendFiles (inherited from AbstractSourceControlTask) | Append the files specified in the fileset to the command line argument. Files are changed to use a relative path from the working directory that the task is spawned in.
AppendSubCommandArgs | Override to append any commands before the modele and files.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
DeriveVcsFromEnvironment (inherited from AbstractSourceControlTask) Derive the location of the version control system from the environment variable
PATH
.
ExecuteTask (inherited from ExternalProgramBase) | Starts the external process and captures its output.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess | Build up the command line arguments, determine which executable is being used and find the path to that executable and set the working directory.
SetCommandOption (inherited from AbstractSourceControlTask) | Adds a new command option if none exists. If one does exist then the use switch is toggled on or of.
SetEnvironment (inherited from AbstractSourceControlTask) | Set up the environment variables for a process.
SetGlobalOption (inherited from AbstractSourceControlTask) | Adds a new global option if none exists. If one does exist then the use switch is toggled on or of.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
ToCvsDateTimeString | Converts a DateTime value to a String representation that can be interpreted by cvs.

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask.AddArg Method

Add the given argument to the command line options. Note that are not explicitly quoted are split into seperate arguments. This is to resolve a recent issue with quoting command line arguments.

[Visual Basic]
Protected Sub AddArg( _
ByVal arg As String _
)
[C#]
protected void AddArg(
string arg
);

Parameters

arg

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask.AppendSubCommandArgs Method

Override to append any commands before the modele and files.

[Visual Basic]
Overridable Protected Sub AppendSubCommandArgs()
[C#]
protected virtual void AppendSubCommandArgs();

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask.PrepareProcess Method

Build up the command line arguments, determine which executable is being used and find the path to that executable and set the working directory.

[Visual Basic]
Overrides Protected Sub PrepareProcess( _
ByVal process As Process _
)
[C#]
protected override void PrepareProcess(
Process process
);

Parameters

process
The process to prepare.

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractCvsTask.ToCvsDateTimeString Method

Converts a DateTime value to a String representation that can be interpreted by cvs.

[Visual Basic]
Protected Function ToCvsDateTimeString( _
ByVal item As Date _
) As String
[C#]
protected string ToCvsDateTimeString(
DateTime item
);

Parameters

item
DateTime to convert.

Return Value

String interpretation of item.

See Also

AbstractCvsTask Class | NAnt.SourceControl.Tasks Namespace


AbstractSourceControlTask Class

A base class for creating tasks for executing CVS client commands on a CVS repository.

For a list of all members of this type, see AbstractSourceControlTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.SourceControl.Tasks.AbstractSourceControlTask
NAnt.SourceControl.Tasks.AbstractCvsTask

[Visual Basic]
MustInherit Public Class AbstractSourceControlTask
Inherits ExternalProgramBase
[C#]
public abstract class AbstractSourceControlTask : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.SourceControl.Tasks

Assembly: NAnt.SourceControlTasks (in NAnt.SourceControlTasks.dll)

See Also

AbstractSourceControlTask Members | NAnt.SourceControl.Tasks Namespace


AbstractSourceControlTask Members

AbstractSourceControlTask overview

Protected Static (Shared) Fields

AppData | Used on windows to specify the location of application data.
CvsPassFileVariable | The environment variable that holds the location of the .cvspass file.
EnvHome | Name of the environmental variable specifying a users' home in a *nix environment.
PathVariable | The environment variable that holds path information.
PropExeName | Property name used to specify the source control executable. This is used as a readonly property.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments | Command-line arguments for the program. The command line arguments are used to specify any cvs command options that are not available as attributes. These are appended after the command itself and are additive to whatever attributes are currently specified.
CommandName | The name of the command that is going to be executed.
CommandOptions | A collection of options that can be used to modify the default behavoir of the version control commands. See the sub-tasks for implementation specifics.
DestinationDirectory | Destination directory for the local sandbox. If destination is not specified then the current directory is used.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName | The name of the version control system executable.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
GlobalOptions | Holds a collection of globally available options.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile | The full path to the cached password file. If not specified then the environment variables are used to try and locate the file.
Password | Obsolete. The password for logging in to the repository.
ProgramArguments | Get the command line arguments for the task.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Root The root variable contains information on how to locate a repository. Although this information is in different formats it typically must define the following:
server locationprotocol used to communicate with the repositoryrepository location on the serverproject location in the repository
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Ssh | The executable to use for ssh communication.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
VcsFileSet | Used to specify the version control system (VCS) files that are going to be acted on.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

AbstractSourceControlTask Constructor Initializes a new instance of the AbstractCvsTask class.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
PassFileName | The name of the passfile, overriden for each version control system (VCS).
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
SshEnv | The environment name for the ssh variable.
VcsExeName | The name of the version control system (VCS) executable file.
VcsHome | The path to the specific home directory of the version control system, this can be where the binary files are kept, or other app information.
VcsHomeEnv | The environment variable that defines where the version control system (VCS) home variable is kept.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

AppendFiles | Append the files specified in the fileset to the command line argument. Files are changed to use a relative path from the working directory that the task is spawned in.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
DeriveVcsFromEnvironment Derive the location of the version control system from the environment variable
PATH
.
ExecuteTask (inherited from ExternalProgramBase) | Starts the external process and captures its output.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess | Build up the command line arguments, determine which executable is being used and find the path to that executable and set the working directory.
SetCommandOption | Adds a new command option if none exists. If one does exist then the use switch is toggled on or of.
SetEnvironment | Set up the environment variables for a process.
SetGlobalOption | Adds a new global option if none exists. If one does exist then the use switch is toggled on or of.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


AbstractSourceControlTask Constructor

Initializes a new instance of the AbstractCvsTask class.

[Visual Basic]
Protected Sub New()
[C#]
protected AbstractSourceControlTask();

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


AbstractSourceControlTask Fields

The fields of the AbstractSourceControlTask class are listed below. For a complete list of AbstractSourceControlTask class members, see the AbstractSourceControlTask Members topic.

Protected Static (Shared) Fields

AppData | Used on windows to specify the location of application data.
CvsPassFileVariable | The environment variable that holds the location of the .cvspass file.
EnvHome | Name of the environmental variable specifying a users' home in a *nix environment.
PathVariable | The environment variable that holds path information.
PropExeName | Property name used to specify the source control executable. This is used as a readonly property.

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


AbstractSourceControlTask.AppData Field

Used on windows to specify the location of application data.

[Visual Basic]
Protected Const AppData As String = "APPDATA"
[C#]
protected const string AppData = "APPDATA";

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


AbstractSourceControlTask.CvsPassFileVariable Field

The environment variable that holds the location of the .cvspass file.

[Visual Basic]
Protected Const CvsPassFileVariable As String = "CVS_PASSFILE"
[C#]
protected const string CvsPassFileVariable = "CVS_PASSFILE";

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


AbstractSourceControlTask.EnvHome Field

Name of the environmental variable specifying a users' home in a *nix environment.

[Visual Basic]
Protected Const EnvHome As String = "HOME"
[C#]
protected const string EnvHome = "HOME";

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


AbstractSourceControlTask.PathVariable Field

The environment variable that holds path information.

[Visual Basic]
Protected Const PathVariable As String = "PATH"
[C#]
protected const string PathVariable = "PATH";

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


AbstractSourceControlTask.PropExeName Field

Property name used to specify the source control executable. This is used as a readonly property.

[Visual Basic]
Protected Const PropExeName As String = "sourcecontrol.exename"
[C#]
protected const string PropExeName = "sourcecontrol.exename";

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


AbstractSourceControlTask Properties

The properties of the AbstractSourceControlTask class are listed below. For a complete list of AbstractSourceControlTask class members, see the AbstractSourceControlTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments | Command-line arguments for the program. The command line arguments are used to specify any cvs command options that are not available as attributes. These are appended after the command itself and are additive to whatever attributes are currently specified.
CommandName | The name of the command that is going to be executed.
CommandOptions | A collection of options that can be used to modify the default behavoir of the version control commands. See the sub-tasks for implementation specifics.
DestinationDirectory | Destination directory for the local sandbox. If destination is not specified then the current directory is used.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName | The name of the version control system executable.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
GlobalOptions | Holds a collection of globally available options.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile | The full path to the cached password file. If not specified then the environment variables are used to try and locate the file.
Password | Obsolete. The password for logging in to the repository.
ProgramArguments | Get the command line arguments for the task.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Root The root variable contains information on how to locate a repository. Although this information is in different formats it typically must define the following:
server locationprotocol used to communicate with the repositoryrepository location on the serverproject location in the repository
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Ssh | The executable to use for ssh communication.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
VcsFileSet | Used to specify the version control system (VCS) files that are going to be acted on.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
PassFileName | The name of the passfile, overriden for each version control system (VCS).
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
SshEnv | The environment name for the ssh variable.
VcsExeName | The name of the version control system (VCS) executable file.
VcsHome | The path to the specific home directory of the version control system, this can be where the binary files are kept, or other app information.
VcsHomeEnv | The environment variable that defines where the version control system (VCS) home variable is kept.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


CommandLineArguments Property

NAnt SDK Documentation - v0.91

AbstractSourceControlTask.CommandLineArguments Property

Command-line arguments for the program. The command line arguments are used to specify any cvs command options that are not available as attributes. These are appended after the command itself and are additive to whatever attributes are currently specified.

[Visual Basic]
<TaskAttribute(Name:="commandline", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property CommandLineArguments As String
[C#]
[TaskAttribute(Name="commandline", Required=False, ExpandProperties=True, ProcessXml=True)]
public string CommandLineArguments {get; set;}

Example

<cvs-checkout cvsroot=":pserver:anonymous@cvs.sourceforge.net:/cvsroot/nant" module="nant" destination="e:\test\merillcornish\working" readonly="true" quiet="true" commandline="-n" cvsfullpath="C:\Program Files\TortoiseCVS\cvs.exe" />
Produces the cvs command:

c:\Program Files\TortoiseCVS\cvs.exe -d:pserver:anonymous@cvs.sourceforge.net:/cvsroot/nant -q checkout -n nant

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


CommandName Property

NAnt SDK Documentation - v0.91

AbstractSourceControlTask.CommandName Property

The name of the command that is going to be executed.

[Visual Basic]
Overridable Public Property CommandName As String
[C#]
public virtual string CommandName {get; set;}

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


CommandOptions Property

NAnt SDK Documentation - v0.91

AbstractSourceControlTask.CommandOptions Property

A collection of options that can be used to modify the default behavoir of the version control commands. See the sub-tasks for implementation specifics.

[Visual Basic]
Public Property CommandOptions As Hashtable
[C#]
public System.Collections.Hashtable CommandOptions {get; set;}

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


DestinationDirectory Property

NAnt SDK Documentation - v0.91

AbstractSourceControlTask.DestinationDirectory Property

Destination directory for the local sandbox. If destination is not specified then the current directory is used.

[Visual Basic]
<TaskAttribute(Name:="destination", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property DestinationDirectory As DirectoryInfo
[C#]
[TaskAttribute(Name="destination", Required=False, ExpandProperties=True, ProcessXml=True)]
public virtual System.IO.DirectoryInfo DestinationDirectory {get; set;}

Property Value

Root path of the local sandbox.

Remarks

Root path of the local sandbox.

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


ExeName Property

NAnt SDK Documentation - v0.91

AbstractSourceControlTask.ExeName Property

The name of the version control system executable.

[Visual Basic]
Overrides Public Property ExeName As String
[C#]
public override string ExeName {get; set;}

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


GlobalOptions Property

NAnt SDK Documentation - v0.91

AbstractSourceControlTask.GlobalOptions Property

Holds a collection of globally available options.

[Visual Basic]
Public Property GlobalOptions As Hashtable
[C#]
public System.Collections.Hashtable GlobalOptions {get; set;}

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


PassFile Property

NAnt SDK Documentation - v0.91

AbstractSourceControlTask.PassFile Property

The full path to the cached password file. If not specified then the environment variables are used to try and locate the file.

[Visual Basic]
<TaskAttribute(Name:="passfile", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property PassFile As FileInfo
[C#]
[TaskAttribute(Name="passfile", Required=False, ExpandProperties=True, ProcessXml=True)]
public virtual System.IO.FileInfo PassFile {get; set;}

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


PassFileName Property

NAnt SDK Documentation - v0.91

AbstractSourceControlTask.PassFileName Property

The name of the passfile, overriden for each version control system (VCS).

[Visual Basic]
MustOverride Protected ReadOnly Property PassFileName As String
[C#]
protected abstract string PassFileName {get;}

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


Password Property

NAnt SDK Documentation - v0.91

AbstractSourceControlTask.Password Property

NOTE: This property is now obsolete.

Use <cvs-pass> task instead.

The password for logging in to the repository.

[Visual Basic]
<Obsolete(Message:="Use <cvs-pass> task instead.", IsError:=True), _ TaskAttribute(Name:="password", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property Password As String
[C#]
[Obsolete(Message="Use <cvs-pass> task instead.", IsError=True)]
[TaskAttribute(Name="password", Required=False, ExpandProperties=True, ProcessXml=True)]
public virtual string Password {get; set;}

Property Value

The password for logging in to the repository.

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

AbstractSourceControlTask.ProgramArguments Property

Get the command line arguments for the task.

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


Root Property

NAnt SDK Documentation - v0.91

AbstractSourceControlTask.Root Property

The root variable contains information on how to locate a repository. Although this information is in different formats it typically must define the following:

server locationprotocol used to communicate with the repositoryrepository location on the serverproject location in the repository

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Overridable Public Property Root As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public virtual string Root {get; set;}

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


Ssh Property

NAnt SDK Documentation - v0.91

AbstractSourceControlTask.Ssh Property

The executable to use for ssh communication.

[Visual Basic]
<TaskAttribute(Name:="ssh", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property Ssh As FileInfo
[C#]
[TaskAttribute(Name="ssh", Required=False, ExpandProperties=True, ProcessXml=True)]
public virtual System.IO.FileInfo Ssh {get; set;}

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


SshEnv Property

NAnt SDK Documentation - v0.91

AbstractSourceControlTask.SshEnv Property

The environment name for the ssh variable.

[Visual Basic]
MustOverride Protected ReadOnly Property SshEnv As String
[C#]
protected abstract string SshEnv {get;}

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


VcsExeName Property

NAnt SDK Documentation - v0.91

AbstractSourceControlTask.VcsExeName Property

The name of the version control system (VCS) executable file.

[Visual Basic]
MustOverride Protected ReadOnly Property VcsExeName As String
[C#]
protected abstract string VcsExeName {get;}

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


VcsFileSet Property

NAnt SDK Documentation - v0.91

AbstractSourceControlTask.VcsFileSet Property

Used to specify the version control system (VCS) files that are going to be acted on.

[Visual Basic]
<BuildElement(Name:="fileset", Required:=False, ProcessXml:=True)>
Overridable Public Property VcsFileSet As FileSet
[C#]
[BuildElement(Name="fileset", Required=False, ProcessXml=True)]
public virtual NAnt.Core.Types.FileSet VcsFileSet {get; set;}

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


VcsHome Property

NAnt SDK Documentation - v0.91

AbstractSourceControlTask.VcsHome Property

The path to the specific home directory of the version control system, this can be where the binary files are kept, or other app information.

[Visual Basic]
Protected ReadOnly Property VcsHome As DirectoryInfo
[C#]
protected System.IO.DirectoryInfo VcsHome {get;}

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


VcsHomeEnv Property

NAnt SDK Documentation - v0.91

AbstractSourceControlTask.VcsHomeEnv Property

The environment variable that defines where the version control system (VCS) home variable is kept.

[Visual Basic]
MustOverride Protected ReadOnly Property VcsHomeEnv As String
[C#]
protected abstract string VcsHomeEnv {get;}

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


AbstractSourceControlTask Methods

The methods of the AbstractSourceControlTask class are listed below. For a complete list of AbstractSourceControlTask class members, see the AbstractSourceControlTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AppendFiles | Append the files specified in the fileset to the command line argument. Files are changed to use a relative path from the working directory that the task is spawned in.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
DeriveVcsFromEnvironment Derive the location of the version control system from the environment variable
PATH
.
ExecuteTask (inherited from ExternalProgramBase) | Starts the external process and captures its output.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess | Build up the command line arguments, determine which executable is being used and find the path to that executable and set the working directory.
SetCommandOption | Adds a new command option if none exists. If one does exist then the use switch is toggled on or of.
SetEnvironment | Set up the environment variables for a process.
SetGlobalOption | Adds a new global option if none exists. If one does exist then the use switch is toggled on or of.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


AbstractSourceControlTask.AppendFiles Method

Append the files specified in the fileset to the command line argument. Files are changed to use a relative path from the working directory that the task is spawned in.

[Visual Basic]
Protected Sub AppendFiles()
[C#]
protected void AppendFiles();

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


AbstractSourceControlTask.DeriveVcsFromEnvironment Method

Derive the location of the version control system from the environment variable

PATH
.

[Visual Basic]
Protected Function DeriveVcsFromEnvironment() As FileInfo
[C#]
protected FileInfo DeriveVcsFromEnvironment();

Return Value

The file information of the version control system, or

null
if this cannot be found.

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


AbstractSourceControlTask.PrepareProcess Method

Build up the command line arguments, determine which executable is being used and find the path to that executable and set the working directory.

[Visual Basic]
Overrides Protected Sub PrepareProcess( _
ByVal process As Process _
)
[C#]
protected override void PrepareProcess(
Process process
);

Parameters

process
The process to prepare.

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


AbstractSourceControlTask.SetCommandOption Method

Adds a new command option if none exists. If one does exist then the use switch is toggled on or of.

[Visual Basic]
Protected Sub SetCommandOption( _
ByVal name As String, _
ByVal value As String, _
ByVal on As Boolean _
)
[C#]
protected void SetCommandOption(
string name,
string value,
bool on
);

Parameters

name
The common name of the option.
value
The option value or command line switch of the option.
on
true
if the option should be appended to the commandline, otherwise
false
.

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


AbstractSourceControlTask.SetEnvironment Method

Set up the environment variables for a process.

[Visual Basic]
Overridable Protected Sub SetEnvironment( _
ByVal process As Process _
)
[C#]
protected virtual void SetEnvironment(
Process process
);

Parameters

process
A process to setup.

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


AbstractSourceControlTask.SetGlobalOption Method

Adds a new global option if none exists. If one does exist then the use switch is toggled on or of.

[Visual Basic]
Protected Sub SetGlobalOption( _
ByVal name As String, _
ByVal value As String, _
ByVal on As Boolean _
)
[C#]
protected void SetGlobalOption(
string name,
string value,
bool on
);

Parameters

name
The common name of the option.
value
The option value or command line switch of the option.
on
true
if the option should be appended to the commandline, otherwise
false
.

See Also

AbstractSourceControlTask Class | NAnt.SourceControl.Tasks Namespace


ChangeLogTask Class

Produces an XML report that represents the cvs changes from the given start day, to a given end date.

For a list of all members of this type, see ChangeLogTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.SourceControl.Tasks.AbstractSourceControlTask
NAnt.SourceControl.Tasks.AbstractCvsTask
NAnt.SourceControl.Tasks.ChangeLogTask

[Visual Basic]
<TaskName(Name:="cvs-changelog")>
Public Class ChangeLogTask
Inherits AbstractCvsTask
[C#]
[TaskName(Name="cvs-changelog")]
public class ChangeLogTask : AbstractCvsTask

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Report changes in NAnt from 1st of June 2004 until 25th of July 2004.

            <cvs-changelog
                destination="e:/test/nant/sourcecontrol/"
                cvsroot=":pserver:anonymous@cvs.sourceforge.net:/cvsroot/nant"
                module="nant"
                start="2004/06/01"
                end="2004/07/25"
                xmlfile="e:/test/nant/sourcecontrol/changelog-nant.xml"
            />

Requirements

Namespace: NAnt.SourceControl.Tasks

Assembly: NAnt.SourceControlTasks (in NAnt.SourceControlTasks.dll)

See Also

ChangeLogTask Members | NAnt.SourceControl.Tasks Namespace


ChangeLogTask Members

ChangeLogTask overview

Public Instance Constructors

ChangeLogTask Constructor Initializes a new instance of the ChangeLogTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments (inherited from AbstractSourceControlTask) | Command-line arguments for the program. The command line arguments are used to specify any cvs command options that are not available as attributes. These are appended after the command itself and are additive to whatever attributes are currently specified.
CommandName | The cvs command to execute.
CommandOptions (inherited from AbstractSourceControlTask) | A collection of options that can be used to modify the default behavoir of the version control commands. See the sub-tasks for implementation specifics.
CompressionLevel (inherited from AbstractCvsTask) Compression level to use for all net traffic. This should be a value from 1-9.

NOTE: This is not available on sharpcvslib.
CvsFileSet (inherited from AbstractCvsTask) | Used to specify the version control system (VCS) files that are going to be acted on.
CvsFullPath (inherited from AbstractCvsTask) | The full path to the cvs binary used. The cvs tasks will attempt to "guess" the location of your cvs binary based on your path. If the task is unable to resolve the location, or resolves it incorrectly this can be used to manually specify the path.
DestFile | Name of the xml file that will contain the cvs log information.
DestinationDirectory (inherited from AbstractSourceControlTask) | Destination directory for the local sandbox. If destination is not specified then the current directory is used.
EndDate | The latest date to use in the cvs log command.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from AbstractCvsTask) | The name of the cvs executable.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
GlobalOptions (inherited from AbstractSourceControlTask) | Holds a collection of globally available options.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Module (inherited from AbstractCvsTask) | The module to perform an operation on.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile (inherited from AbstractSourceControlTask) | The full path to the cached password file. If not specified then the environment variables are used to try and locate the file.
Password (inherited from AbstractSourceControlTask) | Obsolete. The password for logging in to the repository.
ProgramArguments (inherited from AbstractSourceControlTask) | Get the command line arguments for the task.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Quiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be supressed. The default is false.
ReadOnly (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read only mode. The default is false.
ReadWrite (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read/write mode. The default is true.
ReallyQuiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be stopped. The default is false.
Root The cvs root variable has the following components:
[protocol]:[username]@[servername]:[server path]
  • protocol: ext, pserver, ssh (sharpcvslib); if you are not using sharpcvslib consult your cvs documentation.
  • username: [username]
  • servername: cvs.sourceforge.net
  • server path: /cvsroot/nant
If the cvsroot is not specified then the directory specified by the DestinationDirectory attribute is searched for CVS\Root.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Ssh (inherited from AbstractCvsTask) | The executable to use for ssh communication.
StartDate | The earliest change to use in the cvs log command.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
UseSharpCvsLib | Override use of sharpcvslib, needs to be true.
VcsFileSet (inherited from AbstractCvsTask) | Get the cvs file set.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
IsModuleNeeded (inherited from AbstractCvsTask) | Specify if the module is needed for this cvs command. It is only needed if there is no module information on the local file system.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
PassFileName (inherited from AbstractCvsTask) | The name of the pass file, or .cvspass at the time of this writing.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
SshEnv (inherited from AbstractCvsTask) | The environment name for the ssh variable.
VcsExeName (inherited from AbstractCvsTask) | The name of the cvs binary, or cvs.exe at the time this was written.
VcsHome (inherited from AbstractSourceControlTask) | The path to the specific home directory of the version control system, this can be where the binary files are kept, or other app information.
VcsHomeEnv (inherited from AbstractCvsTask) | The name of the version control system specific home environment variable.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

AddArg (inherited from AbstractCvsTask) | Add the given argument to the command line options. Note that are not explicitly quoted are split into seperate arguments. This is to resolve a recent issue with quoting command line arguments.
AppendFiles (inherited from AbstractSourceControlTask) | Append the files specified in the fileset to the command line argument. Files are changed to use a relative path from the working directory that the task is spawned in.
AppendSubCommandArgs (inherited from AbstractCvsTask) | Override to append any commands before the modele and files.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
DeriveVcsFromEnvironment (inherited from AbstractSourceControlTask) Derive the location of the version control system from the environment variable
PATH
.
ExecuteTask (inherited from ExternalProgramBase) | Starts the external process and captures its output.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from AbstractCvsTask) | Build up the command line arguments, determine which executable is being used and find the path to that executable and set the working directory.
SetCommandOption (inherited from AbstractSourceControlTask) | Adds a new command option if none exists. If one does exist then the use switch is toggled on or of.
SetEnvironment (inherited from AbstractSourceControlTask) | Set up the environment variables for a process.
SetGlobalOption (inherited from AbstractSourceControlTask) | Adds a new global option if none exists. If one does exist then the use switch is toggled on or of.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
ToCvsDateTimeString (inherited from AbstractCvsTask) | Converts a DateTime value to a String representation that can be interpreted by cvs.

See Also

ChangeLogTask Class | NAnt.SourceControl.Tasks Namespace


ChangeLogTask Constructor

Initializes a new instance of the ChangeLogTask class.

[Visual Basic]
Public Sub New()
[C#]
public ChangeLogTask();

See Also

ChangeLogTask Class | NAnt.SourceControl.Tasks Namespace


ChangeLogTask Properties

The properties of the ChangeLogTask class are listed below. For a complete list of ChangeLogTask class members, see the ChangeLogTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments (inherited from AbstractSourceControlTask) | Command-line arguments for the program. The command line arguments are used to specify any cvs command options that are not available as attributes. These are appended after the command itself and are additive to whatever attributes are currently specified.
CommandName | The cvs command to execute.
CommandOptions (inherited from AbstractSourceControlTask) | A collection of options that can be used to modify the default behavoir of the version control commands. See the sub-tasks for implementation specifics.
CompressionLevel (inherited from AbstractCvsTask) Compression level to use for all net traffic. This should be a value from 1-9.

NOTE: This is not available on sharpcvslib.
CvsFileSet (inherited from AbstractCvsTask) | Used to specify the version control system (VCS) files that are going to be acted on.
CvsFullPath (inherited from AbstractCvsTask) | The full path to the cvs binary used. The cvs tasks will attempt to "guess" the location of your cvs binary based on your path. If the task is unable to resolve the location, or resolves it incorrectly this can be used to manually specify the path.
DestFile | Name of the xml file that will contain the cvs log information.
DestinationDirectory (inherited from AbstractSourceControlTask) | Destination directory for the local sandbox. If destination is not specified then the current directory is used.
EndDate | The latest date to use in the cvs log command.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from AbstractCvsTask) | The name of the cvs executable.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
GlobalOptions (inherited from AbstractSourceControlTask) | Holds a collection of globally available options.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Module (inherited from AbstractCvsTask) | The module to perform an operation on.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile (inherited from AbstractSourceControlTask) | The full path to the cached password file. If not specified then the environment variables are used to try and locate the file.
Password (inherited from AbstractSourceControlTask) | Obsolete. The password for logging in to the repository.
ProgramArguments (inherited from AbstractSourceControlTask) | Get the command line arguments for the task.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Quiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be supressed. The default is false.
ReadOnly (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read only mode. The default is false.
ReadWrite (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read/write mode. The default is true.
ReallyQuiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be stopped. The default is false.
Root The cvs root variable has the following components:
[protocol]:[username]@[servername]:[server path]
  • protocol: ext, pserver, ssh (sharpcvslib); if you are not using sharpcvslib consult your cvs documentation.
  • username: [username]
  • servername: cvs.sourceforge.net
  • server path: /cvsroot/nant
If the cvsroot is not specified then the directory specified by the DestinationDirectory attribute is searched for CVS\Root.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Ssh (inherited from AbstractCvsTask) | The executable to use for ssh communication.
StartDate | The earliest change to use in the cvs log command.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
UseSharpCvsLib | Override use of sharpcvslib, needs to be true.
VcsFileSet (inherited from AbstractCvsTask) | Get the cvs file set.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
IsModuleNeeded (inherited from AbstractCvsTask) | Specify if the module is needed for this cvs command. It is only needed if there is no module information on the local file system.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
PassFileName (inherited from AbstractCvsTask) | The name of the pass file, or .cvspass at the time of this writing.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
SshEnv (inherited from AbstractCvsTask) | The environment name for the ssh variable.
VcsExeName (inherited from AbstractCvsTask) | The name of the cvs binary, or cvs.exe at the time this was written.
VcsHome (inherited from AbstractSourceControlTask) | The path to the specific home directory of the version control system, this can be where the binary files are kept, or other app information.
VcsHomeEnv (inherited from AbstractCvsTask) | The name of the version control system specific home environment variable.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

ChangeLogTask Class | NAnt.SourceControl.Tasks Namespace


CommandName Property

NAnt SDK Documentation - v0.91

ChangeLogTask.CommandName Property

The cvs command to execute.

[Visual Basic]
Overrides Public ReadOnly Property CommandName As String
[C#]
public override string CommandName {get;}

See Also

ChangeLogTask Class | NAnt.SourceControl.Tasks Namespace


DestFile Property

NAnt SDK Documentation - v0.91

ChangeLogTask.DestFile Property

Name of the xml file that will contain the cvs log information.

[Visual Basic]
<TaskAttribute(Name:="xmlfile", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property DestFile As FileInfo
[C#]
[TaskAttribute(Name="xmlfile", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo DestFile {get; set;}

See Also

ChangeLogTask Class | NAnt.SourceControl.Tasks Namespace


EndDate Property

NAnt SDK Documentation - v0.91

ChangeLogTask.EndDate Property

The latest date to use in the cvs log command.

[Visual Basic]
<TaskAttribute(Name:="end", Required:=True, ExpandProperties:=True, ProcessXml:=True), _ DateTimeValidator>
Public Property EndDate As Date
[C#]
[TaskAttribute(Name="end", Required=True, ExpandProperties=True, ProcessXml=True)]
[DateTimeValidator]
public System.DateTime EndDate {get; set;}

See Also

ChangeLogTask Class | NAnt.SourceControl.Tasks Namespace


Root Property

NAnt SDK Documentation - v0.91

ChangeLogTask.Root Property

The cvs root variable has the following components:

[protocol]:[username]@[servername]:[server path]
  • protocol: ext, pserver, ssh (sharpcvslib); if you are not using sharpcvslib consult your cvs documentation.
  • username: [username]
  • servername: cvs.sourceforge.net
  • server path: /cvsroot/nant

If the cvsroot is not specified then the directory specified by the DestinationDirectory attribute is searched for CVS\Root.

[Visual Basic]
<TaskAttribute(Name:="cvsroot", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overrides Public Property Root As String
[C#]
[TaskAttribute(Name="cvsroot", Required=False, ExpandProperties=True, ProcessXml=True)]
public override string Root {get; set;}

Example

NAnt anonymous cvsroot:

:pserver:anonymous@cvs.sourceforge.net:/cvsroot/nant

See Also

ChangeLogTask Class | NAnt.SourceControl.Tasks Namespace


StartDate Property

NAnt SDK Documentation - v0.91

ChangeLogTask.StartDate Property

The earliest change to use in the cvs log command.

[Visual Basic]
<DateTimeValidator, _ TaskAttribute(Name:="start", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property StartDate As Date
[C#]
[DateTimeValidator]
[TaskAttribute(Name="start", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.DateTime StartDate {get; set;}

See Also

ChangeLogTask Class | NAnt.SourceControl.Tasks Namespace


UseSharpCvsLib Property

NAnt SDK Documentation - v0.91

ChangeLogTask.UseSharpCvsLib Property

Override use of sharpcvslib, needs to be true.

[Visual Basic]
Overrides Public Property UseSharpCvsLib As Boolean
[C#]
public override bool UseSharpCvsLib {get; set;}

See Also

ChangeLogTask Class | NAnt.SourceControl.Tasks Namespace


CheckoutTask Class

Checks out a CVS module to the required directory.

For a list of all members of this type, see CheckoutTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.SourceControl.Tasks.AbstractSourceControlTask
NAnt.SourceControl.Tasks.AbstractCvsTask
NAnt.SourceControl.Tasks.CheckoutTask

[Visual Basic]
<TaskName(Name:="cvs-checkout")>
Public Class CheckoutTask
Inherits AbstractCvsTask
[C#]
[TaskName(Name="cvs-checkout")]
public class CheckoutTask : AbstractCvsTask

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Checkout NAnt.

            <cvs-checkout
                destination="c:\src\nant\"
                cvsroot=":pserver:anonymous@cvs.sourceforge.net:/cvsroot/nant"
                module="nant" />

Checkout NAnt revision named 0_85 to the folder c:\src\nant\v0.85.

            <cvs-checkout
                destination="c:\src\nant"
                cvsroot=":pserver:anonymous@cvs.sourceforge.net:/cvsroot/nant"
                module="nant"
                revision="0_85"
                overridedir="v0.85" />

So the nant module tagged with revision 0_85 will be checked out in the folder v0.85 under the working/ destination directory.
This could be used to work on different branches of a repository at the same time.

Checkout NAnt with specified revision date to the folder c:\src\nant\2003_08_16.

            <cvs-checkout
                destination="c:\src\nant\"
                cvsroot=":pserver:anonymous@cvs.sourceforge.net:/cvsroot/nant"
                module="nant"
                date="2003/08/16"
                overridedir="2003_08_16" />

Requirements

Namespace: NAnt.SourceControl.Tasks

Assembly: NAnt.SourceControlTasks (in NAnt.SourceControlTasks.dll)

See Also

CheckoutTask Members | NAnt.SourceControl.Tasks Namespace


CheckoutTask Members

CheckoutTask overview

Public Instance Constructors

CheckoutTask Constructor Initializes a new instance of the CheckoutTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments (inherited from AbstractSourceControlTask) | Command-line arguments for the program. The command line arguments are used to specify any cvs command options that are not available as attributes. These are appended after the command itself and are additive to whatever attributes are currently specified.
CommandName | The name of the cvs command that is going to be executed.
CommandOptions (inherited from AbstractSourceControlTask) | A collection of options that can be used to modify the default behavoir of the version control commands. See the sub-tasks for implementation specifics.
CompressionLevel (inherited from AbstractCvsTask) Compression level to use for all net traffic. This should be a value from 1-9.

NOTE: This is not available on sharpcvslib.
CvsFileSet (inherited from AbstractCvsTask) | Used to specify the version control system (VCS) files that are going to be acted on.
CvsFullPath (inherited from AbstractCvsTask) | The full path to the cvs binary used. The cvs tasks will attempt to "guess" the location of your cvs binary based on your path. If the task is unable to resolve the location, or resolves it incorrectly this can be used to manually specify the path.
Date | Specify the revision date to checkout. The date specified is validated and then passed to the cvs binary in a standard format recognized by cvs.
DestinationDirectory (inherited from AbstractSourceControlTask) | Destination directory for the local sandbox. If destination is not specified then the current directory is used.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from AbstractCvsTask) | The name of the cvs executable.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
GlobalOptions (inherited from AbstractSourceControlTask) | Holds a collection of globally available options.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Module (inherited from AbstractCvsTask) | The module to perform an operation on.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
OverrideDir | Specify a directory name to replace the module name. Valid names include any valid filename, excluding path information.
OverrideDirectory | Specify a directory name to replace the module name. Valid names include any valid filename, excluding path information.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile (inherited from AbstractSourceControlTask) | The full path to the cached password file. If not specified then the environment variables are used to try and locate the file.
Password (inherited from AbstractSourceControlTask) | Obsolete. The password for logging in to the repository.
ProgramArguments (inherited from AbstractSourceControlTask) | Get the command line arguments for the task.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Quiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be supressed. The default is false.
ReadOnly (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read only mode. The default is false.
ReadWrite (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read/write mode. The default is true.
ReallyQuiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be stopped. The default is false.
Revision | Specify the revision to checkout. This corresponds to the "sticky-tag" of the file.
Root (inherited from AbstractCvsTask) The cvs root variable has the following components:
[protocol]:[username]@[servername]:[server path]
  • protocol: ext, pserver, ssh (sharpcvslib); if you are not using sharpcvslib consult your cvs documentation.
  • username: [username]
  • servername: cvs.sourceforge.net
  • server path: /cvsroot/nant
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Ssh (inherited from AbstractCvsTask) | The executable to use for ssh communication.
StickyTag | Sticky tag or revision to checkout.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
UseSharpCvsLib (inherited from AbstractCvsTask) | true if the SharpCvsLib binaries that come bundled with NAnt should be used to perform the cvs commands, false otherwise. You may also specify an override value for all cvs tasks instead of specifying a value for each. To do this set the property sourcecontrol.usesharpcvslib to false. If you choose not to use SharpCvsLib to checkout from cvs you will need to include a cvs.exe binary in your path.
VcsFileSet (inherited from AbstractCvsTask) | Get the cvs file set.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
IsModuleNeeded (inherited from AbstractCvsTask) | Specify if the module is needed for this cvs command. It is only needed if there is no module information on the local file system.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
PassFileName (inherited from AbstractCvsTask) | The name of the pass file, or .cvspass at the time of this writing.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
SshEnv (inherited from AbstractCvsTask) | The environment name for the ssh variable.
VcsExeName (inherited from AbstractCvsTask) | The name of the cvs binary, or cvs.exe at the time this was written.
VcsHome (inherited from AbstractSourceControlTask) | The path to the specific home directory of the version control system, this can be where the binary files are kept, or other app information.
VcsHomeEnv (inherited from AbstractCvsTask) | The name of the version control system specific home environment variable.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

AddArg (inherited from AbstractCvsTask) | Add the given argument to the command line options. Note that are not explicitly quoted are split into seperate arguments. This is to resolve a recent issue with quoting command line arguments.
AppendFiles (inherited from AbstractSourceControlTask) | Append the files specified in the fileset to the command line argument. Files are changed to use a relative path from the working directory that the task is spawned in.
AppendSubCommandArgs (inherited from AbstractCvsTask) | Override to append any commands before the modele and files.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
DeriveVcsFromEnvironment (inherited from AbstractSourceControlTask) Derive the location of the version control system from the environment variable
PATH
.
ExecuteTask (inherited from ExternalProgramBase) | Starts the external process and captures its output.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from AbstractCvsTask) | Build up the command line arguments, determine which executable is being used and find the path to that executable and set the working directory.
SetCommandOption (inherited from AbstractSourceControlTask) | Adds a new command option if none exists. If one does exist then the use switch is toggled on or of.
SetEnvironment (inherited from AbstractSourceControlTask) | Set up the environment variables for a process.
SetGlobalOption (inherited from AbstractSourceControlTask) | Adds a new global option if none exists. If one does exist then the use switch is toggled on or of.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
ToCvsDateTimeString (inherited from AbstractCvsTask) | Converts a DateTime value to a String representation that can be interpreted by cvs.

See Also

CheckoutTask Class | NAnt.SourceControl.Tasks Namespace


CheckoutTask Constructor

Initializes a new instance of the CheckoutTask class.

[Visual Basic]
Public Sub New()
[C#]
public CheckoutTask();

See Also

CheckoutTask Class | NAnt.SourceControl.Tasks Namespace


CheckoutTask Properties

The properties of the CheckoutTask class are listed below. For a complete list of CheckoutTask class members, see the CheckoutTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments (inherited from AbstractSourceControlTask) | Command-line arguments for the program. The command line arguments are used to specify any cvs command options that are not available as attributes. These are appended after the command itself and are additive to whatever attributes are currently specified.
CommandName | The name of the cvs command that is going to be executed.
CommandOptions (inherited from AbstractSourceControlTask) | A collection of options that can be used to modify the default behavoir of the version control commands. See the sub-tasks for implementation specifics.
CompressionLevel (inherited from AbstractCvsTask) Compression level to use for all net traffic. This should be a value from 1-9.

NOTE: This is not available on sharpcvslib.
CvsFileSet (inherited from AbstractCvsTask) | Used to specify the version control system (VCS) files that are going to be acted on.
CvsFullPath (inherited from AbstractCvsTask) | The full path to the cvs binary used. The cvs tasks will attempt to "guess" the location of your cvs binary based on your path. If the task is unable to resolve the location, or resolves it incorrectly this can be used to manually specify the path.
Date | Specify the revision date to checkout. The date specified is validated and then passed to the cvs binary in a standard format recognized by cvs.
DestinationDirectory (inherited from AbstractSourceControlTask) | Destination directory for the local sandbox. If destination is not specified then the current directory is used.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from AbstractCvsTask) | The name of the cvs executable.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
GlobalOptions (inherited from AbstractSourceControlTask) | Holds a collection of globally available options.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Module (inherited from AbstractCvsTask) | The module to perform an operation on.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
OverrideDir | Specify a directory name to replace the module name. Valid names include any valid filename, excluding path information.
OverrideDirectory | Specify a directory name to replace the module name. Valid names include any valid filename, excluding path information.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile (inherited from AbstractSourceControlTask) | The full path to the cached password file. If not specified then the environment variables are used to try and locate the file.
Password (inherited from AbstractSourceControlTask) | Obsolete. The password for logging in to the repository.
ProgramArguments (inherited from AbstractSourceControlTask) | Get the command line arguments for the task.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Quiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be supressed. The default is false.
ReadOnly (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read only mode. The default is false.
ReadWrite (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read/write mode. The default is true.
ReallyQuiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be stopped. The default is false.
Revision | Specify the revision to checkout. This corresponds to the "sticky-tag" of the file.
Root (inherited from AbstractCvsTask) The cvs root variable has the following components:
[protocol]:[username]@[servername]:[server path]
  • protocol: ext, pserver, ssh (sharpcvslib); if you are not using sharpcvslib consult your cvs documentation.
  • username: [username]
  • servername: cvs.sourceforge.net
  • server path: /cvsroot/nant
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Ssh (inherited from AbstractCvsTask) | The executable to use for ssh communication.
StickyTag | Sticky tag or revision to checkout.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
UseSharpCvsLib (inherited from AbstractCvsTask) | true if the SharpCvsLib binaries that come bundled with NAnt should be used to perform the cvs commands, false otherwise. You may also specify an override value for all cvs tasks instead of specifying a value for each. To do this set the property sourcecontrol.usesharpcvslib to false. If you choose not to use SharpCvsLib to checkout from cvs you will need to include a cvs.exe binary in your path.
VcsFileSet (inherited from AbstractCvsTask) | Get the cvs file set.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
IsModuleNeeded (inherited from AbstractCvsTask) | Specify if the module is needed for this cvs command. It is only needed if there is no module information on the local file system.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
PassFileName (inherited from AbstractCvsTask) | The name of the pass file, or .cvspass at the time of this writing.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
SshEnv (inherited from AbstractCvsTask) | The environment name for the ssh variable.
VcsExeName (inherited from AbstractCvsTask) | The name of the cvs binary, or cvs.exe at the time this was written.
VcsHome (inherited from AbstractSourceControlTask) | The path to the specific home directory of the version control system, this can be where the binary files are kept, or other app information.
VcsHomeEnv (inherited from AbstractCvsTask) | The name of the version control system specific home environment variable.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

CheckoutTask Class | NAnt.SourceControl.Tasks Namespace


CommandName Property

NAnt SDK Documentation - v0.91

CheckoutTask.CommandName Property

The name of the cvs command that is going to be executed.

[Visual Basic]
Overrides Public ReadOnly Property CommandName As String
[C#]
public override string CommandName {get;}

See Also

CheckoutTask Class | NAnt.SourceControl.Tasks Namespace


Date Property

NAnt SDK Documentation - v0.91

CheckoutTask.Date Property

Specify the revision date to checkout. The date specified is validated and then passed to the cvs binary in a standard format recognized by cvs.

[Visual Basic]
<DateTimeValidator, _ TaskAttribute(Name:="date", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Date As Date
[C#]
[DateTimeValidator]
[TaskAttribute(Name="date", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.DateTime Date {get; set;}

See Also

CheckoutTask Class | NAnt.SourceControl.Tasks Namespace


OverrideDir Property

NAnt SDK Documentation - v0.91

CheckoutTask.OverrideDir Property

Specify a directory name to replace the module name. Valid names include any valid filename, excluding path information.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="overridedir", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property OverrideDir As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="overridedir", Required=False, ExpandProperties=True, ProcessXml=True)]
public string OverrideDir {get; set;}

See Also

CheckoutTask Class | NAnt.SourceControl.Tasks Namespace


OverrideDirectory Property

NAnt SDK Documentation - v0.91

CheckoutTask.OverrideDirectory Property

Specify a directory name to replace the module name. Valid names include any valid filename, excluding path information.

[Visual Basic]
<TaskAttribute(Name:="override-directory", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property OverrideDirectory As String
[C#]
[TaskAttribute(Name="override-directory", Required=False, ExpandProperties=True, ProcessXml=True)]
public string OverrideDirectory {get; set;}

See Also

CheckoutTask Class | NAnt.SourceControl.Tasks Namespace


Revision Property

NAnt SDK Documentation - v0.91

CheckoutTask.Revision Property

Specify the revision to checkout. This corresponds to the "sticky-tag" of the file.

[Visual Basic]
<TaskAttribute(Name:="revision", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=True, Expression:="^[A-Za-z0-9][A-Za-z0-9._\-]*$", ExpressionErrorMessage:="null")>
Public Property Revision As String
[C#]
[TaskAttribute(Name="revision", Required=False, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=True, Expression="^[A-Za-z0-9][A-Za-z0-9._\-]*$", ExpressionErrorMessage="null")]
public string Revision {get; set;}

See Also

CheckoutTask Class | NAnt.SourceControl.Tasks Namespace


StickyTag Property

NAnt SDK Documentation - v0.91

CheckoutTask.StickyTag Property

Sticky tag or revision to checkout.

[Visual Basic]
<StringValidator(AllowEmpty:=True, Expression:="^[A-Za-z0-9][A-Za-z0-9._\-]*$", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="sticky-tag", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property StickyTag As String
[C#]
[StringValidator(AllowEmpty=True, Expression="^[A-Za-z0-9][A-Za-z0-9._\-]*$", ExpressionErrorMessage="null")]
[TaskAttribute(Name="sticky-tag", Required=False, ExpandProperties=True, ProcessXml=True)]
public string StickyTag {get; set;}

See Also

CheckoutTask Class | NAnt.SourceControl.Tasks Namespace


CvsPass Class

Executes the cvs login command which appends or updates an entry to the specified .cvspass file.

For a list of all members of this type, see CvsPass Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.SourceControl.Tasks.CvsPass

[Visual Basic]
<TaskName(Name:="cvs-pass")>
Public Class CvsPass
Inherits Task
[C#]
[TaskName(Name="cvs-pass")]
public class CvsPass : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Update .cvspass file to include the NAnt anonymous login.

            <cvs-pass cvsroot=":pserver:anonymous@cvs.sourceforge.net:/cvsroot/nant"
                 password="anonymous"
                 passfile="C:\.cvspass" />

Requirements

Namespace: NAnt.SourceControl.Tasks

Assembly: NAnt.SourceControlTasks (in NAnt.SourceControlTasks.dll)

See Also

CvsPass Members | NAnt.SourceControl.Tasks Namespace


CvsPass Members

CvsPass overview

Public Instance Constructors

CvsPass Constructor Initializes a new instance of the CvsPass class.

Public Instance Properties

DestinationDirectory | The current working directory.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile | The full path to the .cvspass file. The default is ~/.cvspass.
Password | Password to append or update to the .cvspass file.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Root | The repository root string.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Update the .cvspass file with the given password. If the passfile is not specified then the default search locations are used: CVS_PASSFILE/.cvspass HOME/.cvspass USERPROFILE/.cvspass TODO: Confirm that this is valid behavior or if it is going to give problems with the cvsnt implementation.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Ensures all information is available to execute the Task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CvsPass Class | NAnt.SourceControl.Tasks Namespace


CvsPass Constructor

Initializes a new instance of the CvsPass class.

[Visual Basic]
Public Sub New()
[C#]
public CvsPass();

See Also

CvsPass Class | NAnt.SourceControl.Tasks Namespace


CvsPass Properties

The properties of the CvsPass class are listed below. For a complete list of CvsPass class members, see the CvsPass Members topic.

Public Instance Properties

DestinationDirectory | The current working directory.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile | The full path to the .cvspass file. The default is ~/.cvspass.
Password | Password to append or update to the .cvspass file.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Root | The repository root string.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

CvsPass Class | NAnt.SourceControl.Tasks Namespace


DestinationDirectory Property

NAnt SDK Documentation - v0.91

CvsPass.DestinationDirectory Property

The current working directory.

[Visual Basic]
Overridable Public ReadOnly Property DestinationDirectory As DirectoryInfo
[C#]
public virtual System.IO.DirectoryInfo DestinationDirectory {get;}

See Also

CvsPass Class | NAnt.SourceControl.Tasks Namespace


PassFile Property

NAnt SDK Documentation - v0.91

CvsPass.PassFile Property

The full path to the .cvspass file. The default is ~/.cvspass.

[Visual Basic]
<TaskAttribute(Name:="passfile", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property PassFile As FileInfo
[C#]
[TaskAttribute(Name="passfile", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo PassFile {get; set;}

Property Value

See Also

CvsPass Class | NAnt.SourceControl.Tasks Namespace


Password Property

NAnt SDK Documentation - v0.91

CvsPass.Password Property

Password to append or update to the .cvspass file.

[Visual Basic]
<TaskAttribute(Name:="password", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property Password As String
[C#]
[TaskAttribute(Name="password", Required=True, ExpandProperties=True, ProcessXml=True)]
public string Password {get; set;}

See Also

CvsPass Class | NAnt.SourceControl.Tasks Namespace


Root Property

NAnt SDK Documentation - v0.91

CvsPass.Root Property

The repository root string.

[Visual Basic]
<TaskAttribute(Name:="cvsroot", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property Root As String
[C#]
[TaskAttribute(Name="cvsroot", Required=False, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string Root {get; set;}

See Also

CvsPass Class | NAnt.SourceControl.Tasks Namespace


CvsPass Methods

The methods of the CvsPass class are listed below. For a complete list of CvsPass class members, see the CvsPass Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Update the .cvspass file with the given password. If the passfile is not specified then the default search locations are used: CVS_PASSFILE/.cvspass HOME/.cvspass USERPROFILE/.cvspass TODO: Confirm that this is valid behavior or if it is going to give problems with the cvsnt implementation.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Ensures all information is available to execute the Task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CvsPass Class | NAnt.SourceControl.Tasks Namespace


CvsPass.ExecuteTask Method

Update the .cvspass file with the given password. If the passfile is not specified then the default search locations are used: CVS_PASSFILE/.cvspass HOME/.cvspass USERPROFILE/.cvspass TODO: Confirm that this is valid behavior or if it is going to give problems with the cvsnt implementation.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

CvsPass Class | NAnt.SourceControl.Tasks Namespace


Initialize Method

NAnt SDK Documentation - v0.91

CvsPass.Initialize Method

Ensures all information is available to execute the Task.

Overload List

Ensures all information is available to execute the Task.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

CvsPass Class | NAnt.SourceControl.Tasks Namespace


CvsPass.Initialize Method ()

Ensures all information is available to execute the Task.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

CvsPass Class | NAnt.SourceControl.Tasks Namespace | CvsPass.Initialize Overload List


CvsTask Class

Executes the cvs command specified by the command attribute.

For a list of all members of this type, see CvsTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.SourceControl.Tasks.AbstractSourceControlTask
NAnt.SourceControl.Tasks.AbstractCvsTask
NAnt.SourceControl.Tasks.CvsTask

[Visual Basic]
<TaskName(Name:="cvs")>
Public Class CvsTask
Inherits AbstractCvsTask
[C#]
[TaskName(Name="cvs")]
public class CvsTask : AbstractCvsTask

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Checkout NAnt.

            <cvs command="checkout"
                 destination="c:\src\nant\"
                 cvsroot=":pserver:anonymous@cvs.sourceforge.net:/cvsroot/nant"
                 module="nant" />

Requirements

Namespace: NAnt.SourceControl.Tasks

Assembly: NAnt.SourceControlTasks (in NAnt.SourceControlTasks.dll)

See Also

CvsTask Members | NAnt.SourceControl.Tasks Namespace


CvsTask Members

CvsTask overview

Public Instance Constructors

CvsTask Constructor Initializes a new instance of the CvsTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments (inherited from AbstractSourceControlTask) | Command-line arguments for the program. The command line arguments are used to specify any cvs command options that are not available as attributes. These are appended after the command itself and are additive to whatever attributes are currently specified.
CommandName | The cvs command to execute.
CommandOptions (inherited from AbstractSourceControlTask) | A collection of options that can be used to modify the default behavoir of the version control commands. See the sub-tasks for implementation specifics.
CompressionLevel (inherited from AbstractCvsTask) Compression level to use for all net traffic. This should be a value from 1-9.

NOTE: This is not available on sharpcvslib.
CvsFileSet (inherited from AbstractCvsTask) | Used to specify the version control system (VCS) files that are going to be acted on.
CvsFullPath (inherited from AbstractCvsTask) | The full path to the cvs binary used. The cvs tasks will attempt to "guess" the location of your cvs binary based on your path. If the task is unable to resolve the location, or resolves it incorrectly this can be used to manually specify the path.
DestinationDirectory (inherited from AbstractSourceControlTask) | Destination directory for the local sandbox. If destination is not specified then the current directory is used.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from AbstractCvsTask) | The name of the cvs executable.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
GlobalOptions (inherited from AbstractSourceControlTask) | Holds a collection of globally available options.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Module (inherited from AbstractCvsTask) | The module to perform an operation on.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile (inherited from AbstractSourceControlTask) | The full path to the cached password file. If not specified then the environment variables are used to try and locate the file.
Password (inherited from AbstractSourceControlTask) | Obsolete. The password for logging in to the repository.
ProgramArguments (inherited from AbstractSourceControlTask) | Get the command line arguments for the task.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Quiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be supressed. The default is false.
ReadOnly (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read only mode. The default is false.
ReadWrite (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read/write mode. The default is true.
ReallyQuiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be stopped. The default is false.
Root (inherited from AbstractCvsTask) The cvs root variable has the following components:
[protocol]:[username]@[servername]:[server path]
  • protocol: ext, pserver, ssh (sharpcvslib); if you are not using sharpcvslib consult your cvs documentation.
  • username: [username]
  • servername: cvs.sourceforge.net
  • server path: /cvsroot/nant
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Ssh (inherited from AbstractCvsTask) | The executable to use for ssh communication.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
UseSharpCvsLib (inherited from AbstractCvsTask) | true if the SharpCvsLib binaries that come bundled with NAnt should be used to perform the cvs commands, false otherwise. You may also specify an override value for all cvs tasks instead of specifying a value for each. To do this set the property sourcecontrol.usesharpcvslib to false. If you choose not to use SharpCvsLib to checkout from cvs you will need to include a cvs.exe binary in your path.
VcsFileSet (inherited from AbstractCvsTask) | Get the cvs file set.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
IsModuleNeeded | Specify if the module is needed for this cvs command.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
PassFileName (inherited from AbstractCvsTask) | The name of the pass file, or .cvspass at the time of this writing.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
SshEnv (inherited from AbstractCvsTask) | The environment name for the ssh variable.
VcsExeName (inherited from AbstractCvsTask) | The name of the cvs binary, or cvs.exe at the time this was written.
VcsHome (inherited from AbstractSourceControlTask) | The path to the specific home directory of the version control system, this can be where the binary files are kept, or other app information.
VcsHomeEnv (inherited from AbstractCvsTask) | The name of the version control system specific home environment variable.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

AddArg (inherited from AbstractCvsTask) | Add the given argument to the command line options. Note that are not explicitly quoted are split into seperate arguments. This is to resolve a recent issue with quoting command line arguments.
AppendFiles (inherited from AbstractSourceControlTask) | Append the files specified in the fileset to the command line argument. Files are changed to use a relative path from the working directory that the task is spawned in.
AppendSubCommandArgs (inherited from AbstractCvsTask) | Override to append any commands before the modele and files.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
DeriveVcsFromEnvironment (inherited from AbstractSourceControlTask) Derive the location of the version control system from the environment variable
PATH
.
ExecuteTask (inherited from ExternalProgramBase) | Starts the external process and captures its output.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from AbstractCvsTask) | Build up the command line arguments, determine which executable is being used and find the path to that executable and set the working directory.
SetCommandOption (inherited from AbstractSourceControlTask) | Adds a new command option if none exists. If one does exist then the use switch is toggled on or of.
SetEnvironment (inherited from AbstractSourceControlTask) | Set up the environment variables for a process.
SetGlobalOption (inherited from AbstractSourceControlTask) | Adds a new global option if none exists. If one does exist then the use switch is toggled on or of.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
ToCvsDateTimeString (inherited from AbstractCvsTask) | Converts a DateTime value to a String representation that can be interpreted by cvs.

See Also

CvsTask Class | NAnt.SourceControl.Tasks Namespace


CvsTask Constructor

Initializes a new instance of the CvsTask class.

[Visual Basic]
Public Sub New()
[C#]
public CvsTask();

See Also

CvsTask Class | NAnt.SourceControl.Tasks Namespace


CvsTask Properties

The properties of the CvsTask class are listed below. For a complete list of CvsTask class members, see the CvsTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments (inherited from AbstractSourceControlTask) | Command-line arguments for the program. The command line arguments are used to specify any cvs command options that are not available as attributes. These are appended after the command itself and are additive to whatever attributes are currently specified.
CommandName | The cvs command to execute.
CommandOptions (inherited from AbstractSourceControlTask) | A collection of options that can be used to modify the default behavoir of the version control commands. See the sub-tasks for implementation specifics.
CompressionLevel (inherited from AbstractCvsTask) Compression level to use for all net traffic. This should be a value from 1-9.

NOTE: This is not available on sharpcvslib.
CvsFileSet (inherited from AbstractCvsTask) | Used to specify the version control system (VCS) files that are going to be acted on.
CvsFullPath (inherited from AbstractCvsTask) | The full path to the cvs binary used. The cvs tasks will attempt to "guess" the location of your cvs binary based on your path. If the task is unable to resolve the location, or resolves it incorrectly this can be used to manually specify the path.
DestinationDirectory (inherited from AbstractSourceControlTask) | Destination directory for the local sandbox. If destination is not specified then the current directory is used.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from AbstractCvsTask) | The name of the cvs executable.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
GlobalOptions (inherited from AbstractSourceControlTask) | Holds a collection of globally available options.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Module (inherited from AbstractCvsTask) | The module to perform an operation on.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile (inherited from AbstractSourceControlTask) | The full path to the cached password file. If not specified then the environment variables are used to try and locate the file.
Password (inherited from AbstractSourceControlTask) | Obsolete. The password for logging in to the repository.
ProgramArguments (inherited from AbstractSourceControlTask) | Get the command line arguments for the task.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Quiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be supressed. The default is false.
ReadOnly (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read only mode. The default is false.
ReadWrite (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read/write mode. The default is true.
ReallyQuiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be stopped. The default is false.
Root (inherited from AbstractCvsTask) The cvs root variable has the following components:
[protocol]:[username]@[servername]:[server path]
  • protocol: ext, pserver, ssh (sharpcvslib); if you are not using sharpcvslib consult your cvs documentation.
  • username: [username]
  • servername: cvs.sourceforge.net
  • server path: /cvsroot/nant
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Ssh (inherited from AbstractCvsTask) | The executable to use for ssh communication.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
UseSharpCvsLib (inherited from AbstractCvsTask) | true if the SharpCvsLib binaries that come bundled with NAnt should be used to perform the cvs commands, false otherwise. You may also specify an override value for all cvs tasks instead of specifying a value for each. To do this set the property sourcecontrol.usesharpcvslib to false. If you choose not to use SharpCvsLib to checkout from cvs you will need to include a cvs.exe binary in your path.
VcsFileSet (inherited from AbstractCvsTask) | Get the cvs file set.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
IsModuleNeeded | Specify if the module is needed for this cvs command.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
PassFileName (inherited from AbstractCvsTask) | The name of the pass file, or .cvspass at the time of this writing.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
SshEnv (inherited from AbstractCvsTask) | The environment name for the ssh variable.
VcsExeName (inherited from AbstractCvsTask) | The name of the cvs binary, or cvs.exe at the time this was written.
VcsHome (inherited from AbstractSourceControlTask) | The path to the specific home directory of the version control system, this can be where the binary files are kept, or other app information.
VcsHomeEnv (inherited from AbstractCvsTask) | The name of the version control system specific home environment variable.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

CvsTask Class | NAnt.SourceControl.Tasks Namespace


CommandName Property

NAnt SDK Documentation - v0.91

CvsTask.CommandName Property

The cvs command to execute.

[Visual Basic]
<TaskAttribute(Name:="command", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Overrides Public Property CommandName As String
[C#]
[TaskAttribute(Name="command", Required=True, ExpandProperties=True, ProcessXml=True)]
public override string CommandName {get; set;}

See Also

CvsTask Class | NAnt.SourceControl.Tasks Namespace


IsModuleNeeded Property

NAnt SDK Documentation - v0.91

CvsTask.IsModuleNeeded Property

Specify if the module is needed for this cvs command.

[Visual Basic]
Overrides Protected ReadOnly Property IsModuleNeeded As Boolean
[C#]
protected override bool IsModuleNeeded {get;}

See Also

CvsTask Class | NAnt.SourceControl.Tasks Namespace


ExportTask Class

Exports a cvs module in preperation for a release (i.e. the CVS version folders are not exported).

For a list of all members of this type, see ExportTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.SourceControl.Tasks.AbstractSourceControlTask
NAnt.SourceControl.Tasks.AbstractCvsTask
NAnt.SourceControl.Tasks.ExportTask

[Visual Basic]
<TaskName(Name:="cvs-export")>
Public Class ExportTask
Inherits AbstractCvsTask
[C#]
[TaskName(Name="cvs-export")]
public class ExportTask : AbstractCvsTask

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Export the most recent NAnt sources from cvs.

            <cvs-export
                destination="c:\src\nant\"
                cvsroot=":pserver:anonymous@cvs.sourceforge.net:/cvsroot/nant"
                module="nant" />

Export NAnt revision named your_favorite_revision_here to the folder c:\src\nant\replacement_for_module_directory_name. **NOTE**: filesets names for the export task must be prefixed with the module name. This is different than other tasks.

            <cvs-export
                destination="c:\src\nant\"
                cvsroot=":pserver:anonymous@cvs.sourceforge.net:/cvsroot/nant"
                module="nant"
                revision="your_favorite_revision_here"
                overridedir="replacement_for_module_directory_name"
                recursive="false">
                <fileset>
                    <include name="nant/bin/NAnt.exe"/>
                    <include name="nant/bin/NAnt.exe.config"/>
                </fileset>
            </cvs-export>

Requirements

Namespace: NAnt.SourceControl.Tasks

Assembly: NAnt.SourceControlTasks (in NAnt.SourceControlTasks.dll)

See Also

ExportTask Members | NAnt.SourceControl.Tasks Namespace


ExportTask Members

ExportTask overview

Public Instance Constructors

ExportTask Constructor Create a new instance of the ExportTask.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments (inherited from AbstractSourceControlTask) | Command-line arguments for the program. The command line arguments are used to specify any cvs command options that are not available as attributes. These are appended after the command itself and are additive to whatever attributes are currently specified.
CommandName | The export command name for the cvs client.
CommandOptions (inherited from AbstractSourceControlTask) | A collection of options that can be used to modify the default behavoir of the version control commands. See the sub-tasks for implementation specifics.
CompressionLevel (inherited from AbstractCvsTask) Compression level to use for all net traffic. This should be a value from 1-9.

NOTE: This is not available on sharpcvslib.
CvsFileSet (inherited from AbstractCvsTask) | Used to specify the version control system (VCS) files that are going to be acted on.
CvsFullPath (inherited from AbstractCvsTask) | The full path to the cvs binary used. The cvs tasks will attempt to "guess" the location of your cvs binary based on your path. If the task is unable to resolve the location, or resolves it incorrectly this can be used to manually specify the path.
Date | Specify the revision date to update to. The version of the file that existed at the date specified is retrieved.
DestinationDirectory (inherited from AbstractSourceControlTask) | Destination directory for the local sandbox. If destination is not specified then the current directory is used.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from AbstractCvsTask) | The name of the cvs executable.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForceHead | Indicates whether the head revision should be used if the revison specified by Revision or the Date tags are not found. The default is false.
GlobalOptions (inherited from AbstractSourceControlTask) | Holds a collection of globally available options.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Module (inherited from AbstractCvsTask) | The module to perform an operation on.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NoShortening | No shortening. Do not shorten module paths if -d specified.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
OverrideDir | Specify a directory name to replace the module name. Valid names include any valid filename, excluding path information.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile (inherited from AbstractSourceControlTask) | The full path to the cached password file. If not specified then the environment variables are used to try and locate the file.
Password (inherited from AbstractSourceControlTask) | Obsolete. The password for logging in to the repository.
ProgramArguments (inherited from AbstractSourceControlTask) | Get the command line arguments for the task.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Quiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be supressed. The default is false.
ReadOnly (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read only mode. The default is false.
ReadWrite (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read/write mode. The default is true.
ReallyQuiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be stopped. The default is false.
Recursive | If a directory is specified indicates whether sub-directories should also be processed.
Revision | Specify the revision to update the file to. This corresponds to the "sticky-tag" of the file.
Root (inherited from AbstractCvsTask) The cvs root variable has the following components:
[protocol]:[username]@[servername]:[server path]
  • protocol: ext, pserver, ssh (sharpcvslib); if you are not using sharpcvslib consult your cvs documentation.
  • username: [username]
  • servername: cvs.sourceforge.net
  • server path: /cvsroot/nant
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Ssh (inherited from AbstractCvsTask) | The executable to use for ssh communication.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
UseSharpCvsLib (inherited from AbstractCvsTask) | true if the SharpCvsLib binaries that come bundled with NAnt should be used to perform the cvs commands, false otherwise. You may also specify an override value for all cvs tasks instead of specifying a value for each. To do this set the property sourcecontrol.usesharpcvslib to false. If you choose not to use SharpCvsLib to checkout from cvs you will need to include a cvs.exe binary in your path.
VcsFileSet (inherited from AbstractCvsTask) | Get the cvs file set.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
IsModuleNeeded (inherited from AbstractCvsTask) | Specify if the module is needed for this cvs command. It is only needed if there is no module information on the local file system.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
PassFileName (inherited from AbstractCvsTask) | The name of the pass file, or .cvspass at the time of this writing.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
SshEnv (inherited from AbstractCvsTask) | The environment name for the ssh variable.
VcsExeName (inherited from AbstractCvsTask) | The name of the cvs binary, or cvs.exe at the time this was written.
VcsHome (inherited from AbstractSourceControlTask) | The path to the specific home directory of the version control system, this can be where the binary files are kept, or other app information.
VcsHomeEnv (inherited from AbstractCvsTask) | The name of the version control system specific home environment variable.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

AddArg (inherited from AbstractCvsTask) | Add the given argument to the command line options. Note that are not explicitly quoted are split into seperate arguments. This is to resolve a recent issue with quoting command line arguments.
AppendFiles (inherited from AbstractSourceControlTask) | Append the files specified in the fileset to the command line argument. Files are changed to use a relative path from the working directory that the task is spawned in.
AppendSubCommandArgs (inherited from AbstractCvsTask) | Override to append any commands before the modele and files.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
DeriveVcsFromEnvironment (inherited from AbstractSourceControlTask) Derive the location of the version control system from the environment variable
PATH
.
ExecuteTask (inherited from ExternalProgramBase) | Starts the external process and captures its output.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from AbstractCvsTask) | Build up the command line arguments, determine which executable is being used and find the path to that executable and set the working directory.
SetCommandOption (inherited from AbstractSourceControlTask) | Adds a new command option if none exists. If one does exist then the use switch is toggled on or of.
SetEnvironment (inherited from AbstractSourceControlTask) | Set up the environment variables for a process.
SetGlobalOption (inherited from AbstractSourceControlTask) | Adds a new global option if none exists. If one does exist then the use switch is toggled on or of.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
ToCvsDateTimeString (inherited from AbstractCvsTask) | Converts a DateTime value to a String representation that can be interpreted by cvs.

See Also

ExportTask Class | NAnt.SourceControl.Tasks Namespace


ExportTask Constructor

Create a new instance of the ExportTask.

[Visual Basic]
Public Sub New()
[C#]
public ExportTask();

See Also

ExportTask Class | NAnt.SourceControl.Tasks Namespace


ExportTask Properties

The properties of the ExportTask class are listed below. For a complete list of ExportTask class members, see the ExportTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments (inherited from AbstractSourceControlTask) | Command-line arguments for the program. The command line arguments are used to specify any cvs command options that are not available as attributes. These are appended after the command itself and are additive to whatever attributes are currently specified.
CommandName | The export command name for the cvs client.
CommandOptions (inherited from AbstractSourceControlTask) | A collection of options that can be used to modify the default behavoir of the version control commands. See the sub-tasks for implementation specifics.
CompressionLevel (inherited from AbstractCvsTask) Compression level to use for all net traffic. This should be a value from 1-9.

NOTE: This is not available on sharpcvslib.
CvsFileSet (inherited from AbstractCvsTask) | Used to specify the version control system (VCS) files that are going to be acted on.
CvsFullPath (inherited from AbstractCvsTask) | The full path to the cvs binary used. The cvs tasks will attempt to "guess" the location of your cvs binary based on your path. If the task is unable to resolve the location, or resolves it incorrectly this can be used to manually specify the path.
Date | Specify the revision date to update to. The version of the file that existed at the date specified is retrieved.
DestinationDirectory (inherited from AbstractSourceControlTask) | Destination directory for the local sandbox. If destination is not specified then the current directory is used.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from AbstractCvsTask) | The name of the cvs executable.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForceHead | Indicates whether the head revision should be used if the revison specified by Revision or the Date tags are not found. The default is false.
GlobalOptions (inherited from AbstractSourceControlTask) | Holds a collection of globally available options.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Module (inherited from AbstractCvsTask) | The module to perform an operation on.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
NoShortening | No shortening. Do not shorten module paths if -d specified.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
OverrideDir | Specify a directory name to replace the module name. Valid names include any valid filename, excluding path information.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile (inherited from AbstractSourceControlTask) | The full path to the cached password file. If not specified then the environment variables are used to try and locate the file.
Password (inherited from AbstractSourceControlTask) | Obsolete. The password for logging in to the repository.
ProgramArguments (inherited from AbstractSourceControlTask) | Get the command line arguments for the task.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Quiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be supressed. The default is false.
ReadOnly (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read only mode. The default is false.
ReadWrite (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read/write mode. The default is true.
ReallyQuiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be stopped. The default is false.
Recursive | If a directory is specified indicates whether sub-directories should also be processed.
Revision | Specify the revision to update the file to. This corresponds to the "sticky-tag" of the file.
Root (inherited from AbstractCvsTask) The cvs root variable has the following components:
[protocol]:[username]@[servername]:[server path]
  • protocol: ext, pserver, ssh (sharpcvslib); if you are not using sharpcvslib consult your cvs documentation.
  • username: [username]
  • servername: cvs.sourceforge.net
  • server path: /cvsroot/nant
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Ssh (inherited from AbstractCvsTask) | The executable to use for ssh communication.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
UseSharpCvsLib (inherited from AbstractCvsTask) | true if the SharpCvsLib binaries that come bundled with NAnt should be used to perform the cvs commands, false otherwise. You may also specify an override value for all cvs tasks instead of specifying a value for each. To do this set the property sourcecontrol.usesharpcvslib to false. If you choose not to use SharpCvsLib to checkout from cvs you will need to include a cvs.exe binary in your path.
VcsFileSet (inherited from AbstractCvsTask) | Get the cvs file set.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
IsModuleNeeded (inherited from AbstractCvsTask) | Specify if the module is needed for this cvs command. It is only needed if there is no module information on the local file system.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
PassFileName (inherited from AbstractCvsTask) | The name of the pass file, or .cvspass at the time of this writing.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
SshEnv (inherited from AbstractCvsTask) | The environment name for the ssh variable.
VcsExeName (inherited from AbstractCvsTask) | The name of the cvs binary, or cvs.exe at the time this was written.
VcsHome (inherited from AbstractSourceControlTask) | The path to the specific home directory of the version control system, this can be where the binary files are kept, or other app information.
VcsHomeEnv (inherited from AbstractCvsTask) | The name of the version control system specific home environment variable.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

ExportTask Class | NAnt.SourceControl.Tasks Namespace


CommandName Property

NAnt SDK Documentation - v0.91

ExportTask.CommandName Property

The export command name for the cvs client.

[Visual Basic]
Overrides Public ReadOnly Property CommandName As String
[C#]
public override string CommandName {get;}

See Also

ExportTask Class | NAnt.SourceControl.Tasks Namespace


Date Property

NAnt SDK Documentation - v0.91

ExportTask.Date Property

Specify the revision date to update to. The version of the file that existed at the date specified is retrieved.

[Visual Basic]
<DateTimeValidator, _ TaskAttribute(Name:="date", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Date As Date
[C#]
[DateTimeValidator]
[TaskAttribute(Name="date", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.DateTime Date {get; set;}

Property Value

A valid date time value, which is then converted to a format that cvs can parse.

See Also

ExportTask Class | NAnt.SourceControl.Tasks Namespace


ForceHead Property

NAnt SDK Documentation - v0.91

ExportTask.ForceHead Property

Indicates whether the head revision should be used if the revison specified by Revision or the Date tags are not found. The default is false.

[Visual Basic]
<TaskAttribute(Name:="force-head", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property ForceHead As Boolean
[C#]
[TaskAttribute(Name="force-head", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool ForceHead {get; set;}

Property Value

true if the specified tag should be moved; otherwise, false. The default is false.

See Also

ExportTask Class | NAnt.SourceControl.Tasks Namespace


NoShortening Property

NAnt SDK Documentation - v0.91

ExportTask.NoShortening Property

No shortening. Do not shorten module paths if -d specified.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="no-shortening", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property NoShortening As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="no-shortening", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool NoShortening {get; set;}

See Also

ExportTask Class | NAnt.SourceControl.Tasks Namespace


OverrideDir Property

NAnt SDK Documentation - v0.91

ExportTask.OverrideDir Property

Specify a directory name to replace the module name. Valid names include any valid filename, excluding path information.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="^[A-Za-z0-9][A-Za-z0-9._\-]*$", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="overridedir", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property OverrideDir As String
[C#]
[StringValidator(AllowEmpty=False, Expression="^[A-Za-z0-9][A-Za-z0-9._\-]*$", ExpressionErrorMessage="null")]
[TaskAttribute(Name="overridedir", Required=False, ExpandProperties=True, ProcessXml=True)]
public string OverrideDir {get; set;}

See Also

ExportTask Class | NAnt.SourceControl.Tasks Namespace


Recursive Property

NAnt SDK Documentation - v0.91

ExportTask.Recursive Property

If a directory is specified indicates whether sub-directories should also be processed.

[Visual Basic]
<TaskAttribute(Name:="recursive", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property Recursive As Boolean
[C#]
[TaskAttribute(Name="recursive", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool Recursive {get; set;}

Property Value

true if the sub-directories should be tagged; otherwise, false. The default is true.

See Also

ExportTask Class | NAnt.SourceControl.Tasks Namespace


Revision Property

NAnt SDK Documentation - v0.91

ExportTask.Revision Property

Specify the revision to update the file to. This corresponds to the "sticky-tag" of the file.

[Visual Basic]
<StringValidator(AllowEmpty:=True, Expression:="^[A-Za-z0-9][A-Za-z0-9._\-]*$", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="revision", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Revision As String
[C#]
[StringValidator(AllowEmpty=True, Expression="^[A-Za-z0-9][A-Za-z0-9._\-]*$", ExpressionErrorMessage="null")]
[TaskAttribute(Name="revision", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Revision {get; set;}

See Also

ExportTask Class | NAnt.SourceControl.Tasks Namespace


RTagTask Class

Tags all sources in the remote repository with a given tag.

For a list of all members of this type, see RTagTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.SourceControl.Tasks.AbstractSourceControlTask
NAnt.SourceControl.Tasks.AbstractCvsTask
NAnt.SourceControl.Tasks.RTagTask

[Visual Basic]
<TaskName(Name:="cvs-rtag")>
Public Class RTagTask
Inherits AbstractCvsTask
[C#]
[TaskName(Name="cvs-rtag")]
public class RTagTask : AbstractCvsTask

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Unlike tag, the rtag command acts only on sources that are in the repository. Any modified sources on the local file system will NOT be tagged with this command, so a commit should be performed before an rtag is done.

NOTE: Although a working directory is not necessary to perform the command one must be specified in order to remain in compliance with the cvs library.

Example

Tag NAnt sources remotely.

            <cvs-rtag
                cvsroot=":pserver:anonymous@cvs.sourceforge.net:/cvsroot/nant"
                destination="."
                tag="v0_8_4"
                 />

Remove a tag from the remote repository.

            <cvs-rtag
                cvsroot=":pserver:anonymous@cvs.sourceforge.net:/cvsroot/nant"
                destination="."
                tag="v0_8_4"
                remove="true"
                 />

Requirements

Namespace: NAnt.SourceControl.Tasks

Assembly: NAnt.SourceControlTasks (in NAnt.SourceControlTasks.dll)

See Also

RTagTask Members | NAnt.SourceControl.Tasks Namespace


RTagTask Members

RTagTask overview

Public Instance Constructors

RTagTask Constructor Initializes a new instance of the RTagTask class.

Public Instance Properties

ActOnDate | Indicates the revision date of the file that the tag should be applied to.
ActOnTag | Indicates the repository Tag that is acted on for the tag command. Note if MoveIfExists is true then the tag specified is moved to the revision of the file on the HEAD of the branch specified.
Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments (inherited from AbstractSourceControlTask) | Command-line arguments for the program. The command line arguments are used to specify any cvs command options that are not available as attributes. These are appended after the command itself and are additive to whatever attributes are currently specified.
CommandName | The name of the cvs command that is going to be executed.
CommandOptions (inherited from AbstractSourceControlTask) | A collection of options that can be used to modify the default behavoir of the version control commands. See the sub-tasks for implementation specifics.
CompressionLevel (inherited from AbstractCvsTask) Compression level to use for all net traffic. This should be a value from 1-9.

NOTE: This is not available on sharpcvslib.
CvsFileSet (inherited from AbstractCvsTask) | Used to specify the version control system (VCS) files that are going to be acted on.
CvsFullPath (inherited from AbstractCvsTask) | The full path to the cvs binary used. The cvs tasks will attempt to "guess" the location of your cvs binary based on your path. If the task is unable to resolve the location, or resolves it incorrectly this can be used to manually specify the path.
DestinationDirectory (inherited from AbstractSourceControlTask) | Destination directory for the local sandbox. If destination is not specified then the current directory is used.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from AbstractCvsTask) | The name of the cvs executable.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForceHead | Indicates whether the head revision should be used if the ActOnTag or the ActOnDate tags are not found.
GlobalOptions (inherited from AbstractSourceControlTask) | Holds a collection of globally available options.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Module (inherited from AbstractCvsTask) | The module to perform an operation on.
MoveIfExists | Indicates whether the tag specified in Tag should be moved to the current file revision. If the tag does not exist then it is created.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile (inherited from AbstractSourceControlTask) | The full path to the cached password file. If not specified then the environment variables are used to try and locate the file.
Password (inherited from AbstractSourceControlTask) | Obsolete. The password for logging in to the repository.
ProgramArguments (inherited from AbstractSourceControlTask) | Get the command line arguments for the task.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Quiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be supressed. The default is false.
ReadOnly (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read only mode. The default is false.
ReadWrite (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read/write mode. The default is true.
ReallyQuiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be stopped. The default is false.
Recursive | If a directory is specified indicates whether sub-directories should also be processed.
Remove | Indicates whether the tag specified in Tag should be removed or not.
Root (inherited from AbstractCvsTask) The cvs root variable has the following components:
[protocol]:[username]@[servername]:[server path]
  • protocol: ext, pserver, ssh (sharpcvslib); if you are not using sharpcvslib consult your cvs documentation.
  • username: [username]
  • servername: cvs.sourceforge.net
  • server path: /cvsroot/nant
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Ssh (inherited from AbstractCvsTask) | The executable to use for ssh communication.
Tag | The name of the tag to assign or remove.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
UseSharpCvsLib (inherited from AbstractCvsTask) | true if the SharpCvsLib binaries that come bundled with NAnt should be used to perform the cvs commands, false otherwise. You may also specify an override value for all cvs tasks instead of specifying a value for each. To do this set the property sourcecontrol.usesharpcvslib to false. If you choose not to use SharpCvsLib to checkout from cvs you will need to include a cvs.exe binary in your path.
VcsFileSet (inherited from AbstractCvsTask) | Get the cvs file set.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
IsModuleNeeded (inherited from AbstractCvsTask) | Specify if the module is needed for this cvs command. It is only needed if there is no module information on the local file system.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
PassFileName (inherited from AbstractCvsTask) | The name of the pass file, or .cvspass at the time of this writing.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
SshEnv (inherited from AbstractCvsTask) | The environment name for the ssh variable.
VcsExeName (inherited from AbstractCvsTask) | The name of the cvs binary, or cvs.exe at the time this was written.
VcsHome (inherited from AbstractSourceControlTask) | The path to the specific home directory of the version control system, this can be where the binary files are kept, or other app information.
VcsHomeEnv (inherited from AbstractCvsTask) | The name of the version control system specific home environment variable.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

AddArg (inherited from AbstractCvsTask) | Add the given argument to the command line options. Note that are not explicitly quoted are split into seperate arguments. This is to resolve a recent issue with quoting command line arguments.
AppendFiles (inherited from AbstractSourceControlTask) | Append the files specified in the fileset to the command line argument. Files are changed to use a relative path from the working directory that the task is spawned in.
AppendSubCommandArgs | Append the tag information to the commandline.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
DeriveVcsFromEnvironment (inherited from AbstractSourceControlTask) Derive the location of the version control system from the environment variable
PATH
.
ExecuteTask (inherited from ExternalProgramBase) | Starts the external process and captures its output.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from AbstractCvsTask) | Build up the command line arguments, determine which executable is being used and find the path to that executable and set the working directory.
SetCommandOption (inherited from AbstractSourceControlTask) | Adds a new command option if none exists. If one does exist then the use switch is toggled on or of.
SetEnvironment (inherited from AbstractSourceControlTask) | Set up the environment variables for a process.
SetGlobalOption (inherited from AbstractSourceControlTask) | Adds a new global option if none exists. If one does exist then the use switch is toggled on or of.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
ToCvsDateTimeString (inherited from AbstractCvsTask) | Converts a DateTime value to a String representation that can be interpreted by cvs.

See Also

RTagTask Class | NAnt.SourceControl.Tasks Namespace


RTagTask Constructor

Initializes a new instance of the RTagTask class.

[Visual Basic]
Public Sub New()
[C#]
public RTagTask();

See Also

RTagTask Class | NAnt.SourceControl.Tasks Namespace


RTagTask Properties

The properties of the RTagTask class are listed below. For a complete list of RTagTask class members, see the RTagTask Members topic.

Public Instance Properties

ActOnDate | Indicates the revision date of the file that the tag should be applied to.
ActOnTag | Indicates the repository Tag that is acted on for the tag command. Note if MoveIfExists is true then the tag specified is moved to the revision of the file on the HEAD of the branch specified.
Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments (inherited from AbstractSourceControlTask) | Command-line arguments for the program. The command line arguments are used to specify any cvs command options that are not available as attributes. These are appended after the command itself and are additive to whatever attributes are currently specified.
CommandName | The name of the cvs command that is going to be executed.
CommandOptions (inherited from AbstractSourceControlTask) | A collection of options that can be used to modify the default behavoir of the version control commands. See the sub-tasks for implementation specifics.
CompressionLevel (inherited from AbstractCvsTask) Compression level to use for all net traffic. This should be a value from 1-9.

NOTE: This is not available on sharpcvslib.
CvsFileSet (inherited from AbstractCvsTask) | Used to specify the version control system (VCS) files that are going to be acted on.
CvsFullPath (inherited from AbstractCvsTask) | The full path to the cvs binary used. The cvs tasks will attempt to "guess" the location of your cvs binary based on your path. If the task is unable to resolve the location, or resolves it incorrectly this can be used to manually specify the path.
DestinationDirectory (inherited from AbstractSourceControlTask) | Destination directory for the local sandbox. If destination is not specified then the current directory is used.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from AbstractCvsTask) | The name of the cvs executable.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForceHead | Indicates whether the head revision should be used if the ActOnTag or the ActOnDate tags are not found.
GlobalOptions (inherited from AbstractSourceControlTask) | Holds a collection of globally available options.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Module (inherited from AbstractCvsTask) | The module to perform an operation on.
MoveIfExists | Indicates whether the tag specified in Tag should be moved to the current file revision. If the tag does not exist then it is created.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile (inherited from AbstractSourceControlTask) | The full path to the cached password file. If not specified then the environment variables are used to try and locate the file.
Password (inherited from AbstractSourceControlTask) | Obsolete. The password for logging in to the repository.
ProgramArguments (inherited from AbstractSourceControlTask) | Get the command line arguments for the task.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Quiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be supressed. The default is false.
ReadOnly (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read only mode. The default is false.
ReadWrite (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read/write mode. The default is true.
ReallyQuiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be stopped. The default is false.
Recursive | If a directory is specified indicates whether sub-directories should also be processed.
Remove | Indicates whether the tag specified in Tag should be removed or not.
Root (inherited from AbstractCvsTask) The cvs root variable has the following components:
[protocol]:[username]@[servername]:[server path]
  • protocol: ext, pserver, ssh (sharpcvslib); if you are not using sharpcvslib consult your cvs documentation.
  • username: [username]
  • servername: cvs.sourceforge.net
  • server path: /cvsroot/nant
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Ssh (inherited from AbstractCvsTask) | The executable to use for ssh communication.
Tag | The name of the tag to assign or remove.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
UseSharpCvsLib (inherited from AbstractCvsTask) | true if the SharpCvsLib binaries that come bundled with NAnt should be used to perform the cvs commands, false otherwise. You may also specify an override value for all cvs tasks instead of specifying a value for each. To do this set the property sourcecontrol.usesharpcvslib to false. If you choose not to use SharpCvsLib to checkout from cvs you will need to include a cvs.exe binary in your path.
VcsFileSet (inherited from AbstractCvsTask) | Get the cvs file set.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
IsModuleNeeded (inherited from AbstractCvsTask) | Specify if the module is needed for this cvs command. It is only needed if there is no module information on the local file system.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
PassFileName (inherited from AbstractCvsTask) | The name of the pass file, or .cvspass at the time of this writing.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
SshEnv (inherited from AbstractCvsTask) | The environment name for the ssh variable.
VcsExeName (inherited from AbstractCvsTask) | The name of the cvs binary, or cvs.exe at the time this was written.
VcsHome (inherited from AbstractSourceControlTask) | The path to the specific home directory of the version control system, this can be where the binary files are kept, or other app information.
VcsHomeEnv (inherited from AbstractCvsTask) | The name of the version control system specific home environment variable.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

RTagTask Class | NAnt.SourceControl.Tasks Namespace


ActOnDate Property

NAnt SDK Documentation - v0.91

RTagTask.ActOnDate Property

Indicates the revision date of the file that the tag should be applied to.

[Visual Basic]
<DateTimeValidator, _ TaskAttribute(Name:="act-on-date", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property ActOnDate As Date
[C#]
[DateTimeValidator]
[TaskAttribute(Name="act-on-date", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.DateTime ActOnDate {get; set;}

Property Value

A valid date which specifies the revision point that the tag will be applied to.

See Also

RTagTask Class | NAnt.SourceControl.Tasks Namespace


ActOnTag Property

NAnt SDK Documentation - v0.91

RTagTask.ActOnTag Property

Indicates the repository Tag that is acted on for the tag command. Note if MoveIfExists is true then the tag specified is moved to the revision of the file on the HEAD of the branch specified.

[Visual Basic]
<TaskAttribute(Name:="act-on-tag", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="^[A-Za-z0-9][A-Za-z0-9._\-]*$", ExpressionErrorMessage:="null")>
Public Property ActOnTag As String
[C#]
[TaskAttribute(Name="act-on-tag", Required=False, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="^[A-Za-z0-9][A-Za-z0-9._\-]*$", ExpressionErrorMessage="null")]
public string ActOnTag {get; set;}

Property Value

The tag (or more likely) branch that should be used to apply the new tag.

See Also

RTagTask Class | NAnt.SourceControl.Tasks Namespace


CommandName Property

NAnt SDK Documentation - v0.91

RTagTask.CommandName Property

The name of the cvs command that is going to be executed.

[Visual Basic]
Overrides Public ReadOnly Property CommandName As String
[C#]
public override string CommandName {get;}

See Also

RTagTask Class | NAnt.SourceControl.Tasks Namespace


ForceHead Property

NAnt SDK Documentation - v0.91

RTagTask.ForceHead Property

Indicates whether the head revision should be used if the ActOnTag or the ActOnDate tags are not found.

[Visual Basic]
<TaskAttribute(Name:="force-head", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property ForceHead As Boolean
[C#]
[TaskAttribute(Name="force-head", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool ForceHead {get; set;}

Property Value

true if the specified tag should be moved; otherwise, false. The default is false.

See Also

RTagTask Class | NAnt.SourceControl.Tasks Namespace


MoveIfExists Property

NAnt SDK Documentation - v0.91

RTagTask.MoveIfExists Property

Indicates whether the tag specified in Tag should be moved to the current file revision. If the tag does not exist then it is created.

[Visual Basic]
<TaskAttribute(Name:="move-if-exists", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property MoveIfExists As Boolean
[C#]
[TaskAttribute(Name="move-if-exists", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool MoveIfExists {get; set;}

Property Value

true if the specified tag should be moved; otherwise, false. The default is false.

See Also

RTagTask Class | NAnt.SourceControl.Tasks Namespace


Recursive Property

NAnt SDK Documentation - v0.91

RTagTask.Recursive Property

If a directory is specified indicates whether sub-directories should also be processed.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="recursive", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Recursive As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="recursive", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool Recursive {get; set;}

Property Value

true if the sub-directories should be tagged; otherwise, false. The default is true.

See Also

RTagTask Class | NAnt.SourceControl.Tasks Namespace


Remove Property

NAnt SDK Documentation - v0.91

RTagTask.Remove Property

Indicates whether the tag specified in Tag should be removed or not.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="remove", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Remove As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="remove", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool Remove {get; set;}

Property Value

true if the specified tag should be removed; otherwise, false. The default is false.

See Also

RTagTask Class | NAnt.SourceControl.Tasks Namespace


Tag Property

NAnt SDK Documentation - v0.91

RTagTask.Tag Property

The name of the tag to assign or remove.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="^[A-Za-z0-9][A-Za-z0-9._\-]*$", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="tag", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property Tag As String
[C#]
[StringValidator(AllowEmpty=False, Expression="^[A-Za-z0-9][A-Za-z0-9._\-]*$", ExpressionErrorMessage="null")]
[TaskAttribute(Name="tag", Required=True, ExpandProperties=True, ProcessXml=True)]
public string Tag {get; set;}

Property Value

The name of the tag to assign or remove.

See Also

RTagTask Class | NAnt.SourceControl.Tasks Namespace


RTagTask Methods

The methods of the RTagTask class are listed below. For a complete list of RTagTask class members, see the RTagTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddArg (inherited from AbstractCvsTask) | Add the given argument to the command line options. Note that are not explicitly quoted are split into seperate arguments. This is to resolve a recent issue with quoting command line arguments.
AppendFiles (inherited from AbstractSourceControlTask) | Append the files specified in the fileset to the command line argument. Files are changed to use a relative path from the working directory that the task is spawned in.
AppendSubCommandArgs | Append the tag information to the commandline.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
DeriveVcsFromEnvironment (inherited from AbstractSourceControlTask) Derive the location of the version control system from the environment variable
PATH
.
ExecuteTask (inherited from ExternalProgramBase) | Starts the external process and captures its output.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from AbstractCvsTask) | Build up the command line arguments, determine which executable is being used and find the path to that executable and set the working directory.
SetCommandOption (inherited from AbstractSourceControlTask) | Adds a new command option if none exists. If one does exist then the use switch is toggled on or of.
SetEnvironment (inherited from AbstractSourceControlTask) | Set up the environment variables for a process.
SetGlobalOption (inherited from AbstractSourceControlTask) | Adds a new global option if none exists. If one does exist then the use switch is toggled on or of.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
ToCvsDateTimeString (inherited from AbstractCvsTask) | Converts a DateTime value to a String representation that can be interpreted by cvs.

See Also

RTagTask Class | NAnt.SourceControl.Tasks Namespace


RTagTask.AppendSubCommandArgs Method

Append the tag information to the commandline.

[Visual Basic]
Overrides Protected Sub AppendSubCommandArgs()
[C#]
protected override void AppendSubCommandArgs();

See Also

RTagTask Class | NAnt.SourceControl.Tasks Namespace


TagTask Class

Tags all local sources with the specified tag.

For a list of all members of this type, see TagTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.SourceControl.Tasks.AbstractSourceControlTask
NAnt.SourceControl.Tasks.AbstractCvsTask
NAnt.SourceControl.Tasks.TagTask

[Visual Basic]
<TaskName(Name:="cvs-tag")>
Public Class TagTask
Inherits AbstractCvsTask
[C#]
[TaskName(Name="cvs-tag")]
public class TagTask : AbstractCvsTask

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This differs from the RTagTask in that it acts on references to the cvs files contained in your local filesystem. As such the sticky tags and local revisions can be considered in commits. It also allows you to verify that all local files have been checked in before a tag is performed.

Example

Tag NAnt sources remotely.

<cvs-tag
    cvsroot=":pserver:anonymous@cvs.sourceforge.net:/cvsroot/nant"
    destination="."
    tag="v0_8_4"
     />

Remove a tag from the remote repository.

<cvs-tag
    cvsroot=":pserver:anonymous@cvs.sourceforge.net:/cvsroot/nant"
    destination="."
    tag="v0_8_4"
    remove="true"
    fail-if-modified="true"
     />

Requirements

Namespace: NAnt.SourceControl.Tasks

Assembly: NAnt.SourceControlTasks (in NAnt.SourceControlTasks.dll)

See Also

TagTask Members | NAnt.SourceControl.Tasks Namespace


TagTask Members

TagTask overview

Public Instance Constructors

TagTask Constructor Initializes a new instance of the TagTask class.

Public Instance Properties

ActOnDate | Indicates the revision date of the file that the tag should be applied to.
ActOnTag | Indicates the repository Tag that is acted on for the tag command. Note if MoveIfExists is true then the tag specified is moved to the revision of the file on the HEAD of the branch specified.
Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments (inherited from AbstractSourceControlTask) | Command-line arguments for the program. The command line arguments are used to specify any cvs command options that are not available as attributes. These are appended after the command itself and are additive to whatever attributes are currently specified.
CommandName | The name of the cvs command that is going to be executed.
CommandOptions (inherited from AbstractSourceControlTask) | A collection of options that can be used to modify the default behavoir of the version control commands. See the sub-tasks for implementation specifics.
CompressionLevel (inherited from AbstractCvsTask) Compression level to use for all net traffic. This should be a value from 1-9.

NOTE: This is not available on sharpcvslib.
CvsFileSet (inherited from AbstractCvsTask) | Used to specify the version control system (VCS) files that are going to be acted on.
CvsFullPath (inherited from AbstractCvsTask) | The full path to the cvs binary used. The cvs tasks will attempt to "guess" the location of your cvs binary based on your path. If the task is unable to resolve the location, or resolves it incorrectly this can be used to manually specify the path.
DestinationDirectory (inherited from AbstractSourceControlTask) | Destination directory for the local sandbox. If destination is not specified then the current directory is used.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from AbstractCvsTask) | The name of the cvs executable.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailIfModified | Indicates whether the head revision should be used if the ActOnTag or the ActOnDate tags are not found.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForceHead | Indicates whether the head revision should be used if the revision specified by ActOnTag or the ActOnDate tags are not found.
GlobalOptions (inherited from AbstractSourceControlTask) | Holds a collection of globally available options.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Module | Not used
MoveIfExists | Indicates whether the tag specified in Tag should be moved to the current file revision. If the tag does not exist then it is created.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile (inherited from AbstractSourceControlTask) | The full path to the cached password file. If not specified then the environment variables are used to try and locate the file.
Password (inherited from AbstractSourceControlTask) | Obsolete. The password for logging in to the repository.
ProgramArguments (inherited from AbstractSourceControlTask) | Get the command line arguments for the task.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Quiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be supressed. The default is false.
ReadOnly (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read only mode. The default is false.
ReadWrite (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read/write mode. The default is true.
ReallyQuiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be stopped. The default is false.
Recursive | If a directory is specified indicates whether sub-directories should also be processed.
Remove | Indicates whether the tag specified in Tag should be removed or not.
Root (inherited from AbstractCvsTask) The cvs root variable has the following components:
[protocol]:[username]@[servername]:[server path]
  • protocol: ext, pserver, ssh (sharpcvslib); if you are not using sharpcvslib consult your cvs documentation.
  • username: [username]
  • servername: cvs.sourceforge.net
  • server path: /cvsroot/nant
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Ssh (inherited from AbstractCvsTask) | The executable to use for ssh communication.
Tag | The name of the tag to assign or remove.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
UseSharpCvsLib (inherited from AbstractCvsTask) | true if the SharpCvsLib binaries that come bundled with NAnt should be used to perform the cvs commands, false otherwise. You may also specify an override value for all cvs tasks instead of specifying a value for each. To do this set the property sourcecontrol.usesharpcvslib to false. If you choose not to use SharpCvsLib to checkout from cvs you will need to include a cvs.exe binary in your path.
VcsFileSet (inherited from AbstractCvsTask) | Get the cvs file set.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
IsModuleNeeded | Specify if the module is needed for this cvs command. It is only needed if there is no module information on the local file system.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
PassFileName (inherited from AbstractCvsTask) | The name of the pass file, or .cvspass at the time of this writing.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
SshEnv (inherited from AbstractCvsTask) | The environment name for the ssh variable.
VcsExeName (inherited from AbstractCvsTask) | The name of the cvs binary, or cvs.exe at the time this was written.
VcsHome (inherited from AbstractSourceControlTask) | The path to the specific home directory of the version control system, this can be where the binary files are kept, or other app information.
VcsHomeEnv (inherited from AbstractCvsTask) | The name of the version control system specific home environment variable.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

AddArg (inherited from AbstractCvsTask) | Add the given argument to the command line options. Note that are not explicitly quoted are split into seperate arguments. This is to resolve a recent issue with quoting command line arguments.
AppendFiles (inherited from AbstractSourceControlTask) | Append the files specified in the fileset to the command line argument. Files are changed to use a relative path from the working directory that the task is spawned in.
AppendSubCommandArgs | Append the tag information to the commandline.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
DeriveVcsFromEnvironment (inherited from AbstractSourceControlTask) Derive the location of the version control system from the environment variable
PATH
.
ExecuteTask (inherited from ExternalProgramBase) | Starts the external process and captures its output.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from AbstractCvsTask) | Build up the command line arguments, determine which executable is being used and find the path to that executable and set the working directory.
SetCommandOption (inherited from AbstractSourceControlTask) | Adds a new command option if none exists. If one does exist then the use switch is toggled on or of.
SetEnvironment (inherited from AbstractSourceControlTask) | Set up the environment variables for a process.
SetGlobalOption (inherited from AbstractSourceControlTask) | Adds a new global option if none exists. If one does exist then the use switch is toggled on or of.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
ToCvsDateTimeString (inherited from AbstractCvsTask) | Converts a DateTime value to a String representation that can be interpreted by cvs.

See Also

TagTask Class | NAnt.SourceControl.Tasks Namespace


TagTask Constructor

Initializes a new instance of the TagTask class.

[Visual Basic]
Public Sub New()
[C#]
public TagTask();

See Also

TagTask Class | NAnt.SourceControl.Tasks Namespace


TagTask Properties

The properties of the TagTask class are listed below. For a complete list of TagTask class members, see the TagTask Members topic.

Public Instance Properties

ActOnDate | Indicates the revision date of the file that the tag should be applied to.
ActOnTag | Indicates the repository Tag that is acted on for the tag command. Note if MoveIfExists is true then the tag specified is moved to the revision of the file on the HEAD of the branch specified.
Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments (inherited from AbstractSourceControlTask) | Command-line arguments for the program. The command line arguments are used to specify any cvs command options that are not available as attributes. These are appended after the command itself and are additive to whatever attributes are currently specified.
CommandName | The name of the cvs command that is going to be executed.
CommandOptions (inherited from AbstractSourceControlTask) | A collection of options that can be used to modify the default behavoir of the version control commands. See the sub-tasks for implementation specifics.
CompressionLevel (inherited from AbstractCvsTask) Compression level to use for all net traffic. This should be a value from 1-9.

NOTE: This is not available on sharpcvslib.
CvsFileSet (inherited from AbstractCvsTask) | Used to specify the version control system (VCS) files that are going to be acted on.
CvsFullPath (inherited from AbstractCvsTask) | The full path to the cvs binary used. The cvs tasks will attempt to "guess" the location of your cvs binary based on your path. If the task is unable to resolve the location, or resolves it incorrectly this can be used to manually specify the path.
DestinationDirectory (inherited from AbstractSourceControlTask) | Destination directory for the local sandbox. If destination is not specified then the current directory is used.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from AbstractCvsTask) | The name of the cvs executable.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailIfModified | Indicates whether the head revision should be used if the ActOnTag or the ActOnDate tags are not found.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForceHead | Indicates whether the head revision should be used if the revision specified by ActOnTag or the ActOnDate tags are not found.
GlobalOptions (inherited from AbstractSourceControlTask) | Holds a collection of globally available options.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Module | Not used
MoveIfExists | Indicates whether the tag specified in Tag should be moved to the current file revision. If the tag does not exist then it is created.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile (inherited from AbstractSourceControlTask) | The full path to the cached password file. If not specified then the environment variables are used to try and locate the file.
Password (inherited from AbstractSourceControlTask) | Obsolete. The password for logging in to the repository.
ProgramArguments (inherited from AbstractSourceControlTask) | Get the command line arguments for the task.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Quiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be supressed. The default is false.
ReadOnly (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read only mode. The default is false.
ReadWrite (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read/write mode. The default is true.
ReallyQuiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be stopped. The default is false.
Recursive | If a directory is specified indicates whether sub-directories should also be processed.
Remove | Indicates whether the tag specified in Tag should be removed or not.
Root (inherited from AbstractCvsTask) The cvs root variable has the following components:
[protocol]:[username]@[servername]:[server path]
  • protocol: ext, pserver, ssh (sharpcvslib); if you are not using sharpcvslib consult your cvs documentation.
  • username: [username]
  • servername: cvs.sourceforge.net
  • server path: /cvsroot/nant
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Ssh (inherited from AbstractCvsTask) | The executable to use for ssh communication.
Tag | The name of the tag to assign or remove.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
UseSharpCvsLib (inherited from AbstractCvsTask) | true if the SharpCvsLib binaries that come bundled with NAnt should be used to perform the cvs commands, false otherwise. You may also specify an override value for all cvs tasks instead of specifying a value for each. To do this set the property sourcecontrol.usesharpcvslib to false. If you choose not to use SharpCvsLib to checkout from cvs you will need to include a cvs.exe binary in your path.
VcsFileSet (inherited from AbstractCvsTask) | Get the cvs file set.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
IsModuleNeeded | Specify if the module is needed for this cvs command. It is only needed if there is no module information on the local file system.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
PassFileName (inherited from AbstractCvsTask) | The name of the pass file, or .cvspass at the time of this writing.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
SshEnv (inherited from AbstractCvsTask) | The environment name for the ssh variable.
VcsExeName (inherited from AbstractCvsTask) | The name of the cvs binary, or cvs.exe at the time this was written.
VcsHome (inherited from AbstractSourceControlTask) | The path to the specific home directory of the version control system, this can be where the binary files are kept, or other app information.
VcsHomeEnv (inherited from AbstractCvsTask) | The name of the version control system specific home environment variable.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

TagTask Class | NAnt.SourceControl.Tasks Namespace


ActOnDate Property

NAnt SDK Documentation - v0.91

TagTask.ActOnDate Property

Indicates the revision date of the file that the tag should be applied to.

[Visual Basic]
<TaskAttribute(Name:="act-on-date", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ DateTimeValidator>
Public Property ActOnDate As Date
[C#]
[TaskAttribute(Name="act-on-date", Required=False, ExpandProperties=True, ProcessXml=True)]
[DateTimeValidator]
public System.DateTime ActOnDate {get; set;}

Property Value

A valid date which specifies the revision point that the tag will be applied to.

See Also

TagTask Class | NAnt.SourceControl.Tasks Namespace


ActOnTag Property

NAnt SDK Documentation - v0.91

TagTask.ActOnTag Property

Indicates the repository Tag that is acted on for the tag command. Note if MoveIfExists is true then the tag specified is moved to the revision of the file on the HEAD of the branch specified.

[Visual Basic]
<TaskAttribute(Name:="act-on-tag", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="^[A-Za-z0-9][A-Za-z0-9._\-]*$", ExpressionErrorMessage:="null")>
Public Property ActOnTag As String
[C#]
[TaskAttribute(Name="act-on-tag", Required=False, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="^[A-Za-z0-9][A-Za-z0-9._\-]*$", ExpressionErrorMessage="null")]
public string ActOnTag {get; set;}

Property Value

The tag (or more likely) branch that should be used to apply the new tag.

See Also

TagTask Class | NAnt.SourceControl.Tasks Namespace


CommandName Property

NAnt SDK Documentation - v0.91

TagTask.CommandName Property

The name of the cvs command that is going to be executed.

[Visual Basic]
Overrides Public ReadOnly Property CommandName As String
[C#]
public override string CommandName {get;}

See Also

TagTask Class | NAnt.SourceControl.Tasks Namespace


FailIfModified Property

NAnt SDK Documentation - v0.91

TagTask.FailIfModified Property

Indicates whether the head revision should be used if the ActOnTag or the ActOnDate tags are not found.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="fail-if-modified", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property FailIfModified As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="fail-if-modified", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool FailIfModified {get; set;}

Property Value

true if the specified tag should be moved; otherwise, false. The default is false.

See Also

TagTask Class | NAnt.SourceControl.Tasks Namespace


ForceHead Property

NAnt SDK Documentation - v0.91

TagTask.ForceHead Property

Indicates whether the head revision should be used if the revision specified by ActOnTag or the ActOnDate tags are not found.

[Visual Basic]
<TaskAttribute(Name:="force-head", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property ForceHead As Boolean
[C#]
[TaskAttribute(Name="force-head", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool ForceHead {get; set;}

Property Value

true if the specified tag should be moved; otherwise, false. The default is false.

See Also

TagTask Class | NAnt.SourceControl.Tasks Namespace


IsModuleNeeded Property

NAnt SDK Documentation - v0.91

TagTask.IsModuleNeeded Property

Specify if the module is needed for this cvs command. It is only needed if there is no module information on the local file system.

[Visual Basic]
Overrides Protected ReadOnly Property IsModuleNeeded As Boolean
[C#]
protected override bool IsModuleNeeded {get;}

See Also

TagTask Class | NAnt.SourceControl.Tasks Namespace


Module Property

NAnt SDK Documentation - v0.91

TagTask.Module Property

Not used

[Visual Basic]
Overrides Public Property Module As String
[C#]
public override string Module {get; set;}

See Also

TagTask Class | NAnt.SourceControl.Tasks Namespace


MoveIfExists Property

NAnt SDK Documentation - v0.91

TagTask.MoveIfExists Property

Indicates whether the tag specified in Tag should be moved to the current file revision. If the tag does not exist then it is created.

[Visual Basic]
<TaskAttribute(Name:="move-if-exists", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property MoveIfExists As Boolean
[C#]
[TaskAttribute(Name="move-if-exists", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool MoveIfExists {get; set;}

Property Value

true if the specified tag should be moved; otherwise, false. The default is false.

See Also

TagTask Class | NAnt.SourceControl.Tasks Namespace


Recursive Property

NAnt SDK Documentation - v0.91

TagTask.Recursive Property

If a directory is specified indicates whether sub-directories should also be processed.

[Visual Basic]
<TaskAttribute(Name:="recursive", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property Recursive As Boolean
[C#]
[TaskAttribute(Name="recursive", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool Recursive {get; set;}

Property Value

true if the sub-directories should be tagged; otherwise, false. The default is true.

See Also

TagTask Class | NAnt.SourceControl.Tasks Namespace


Remove Property

NAnt SDK Documentation - v0.91

TagTask.Remove Property

Indicates whether the tag specified in Tag should be removed or not.

[Visual Basic]
<TaskAttribute(Name:="remove", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property Remove As Boolean
[C#]
[TaskAttribute(Name="remove", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool Remove {get; set;}

Property Value

true if the specified tag should be removed; otherwise, false. The default is false.

See Also

TagTask Class | NAnt.SourceControl.Tasks Namespace


Tag Property

NAnt SDK Documentation - v0.91

TagTask.Tag Property

The name of the tag to assign or remove.

[Visual Basic]
<TaskAttribute(Name:="tag", Required:=True, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="^[A-Za-z0-9][A-Za-z0-9._\-]*$", ExpressionErrorMessage:="null")>
Public Property Tag As String
[C#]
[TaskAttribute(Name="tag", Required=True, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="^[A-Za-z0-9][A-Za-z0-9._\-]*$", ExpressionErrorMessage="null")]
public string Tag {get; set;}

Property Value

The name of the tag to assign or remove.

See Also

TagTask Class | NAnt.SourceControl.Tasks Namespace


TagTask Methods

The methods of the TagTask class are listed below. For a complete list of TagTask class members, see the TagTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddArg (inherited from AbstractCvsTask) | Add the given argument to the command line options. Note that are not explicitly quoted are split into seperate arguments. This is to resolve a recent issue with quoting command line arguments.
AppendFiles (inherited from AbstractSourceControlTask) | Append the files specified in the fileset to the command line argument. Files are changed to use a relative path from the working directory that the task is spawned in.
AppendSubCommandArgs | Append the tag information to the commandline.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
DeriveVcsFromEnvironment (inherited from AbstractSourceControlTask) Derive the location of the version control system from the environment variable
PATH
.
ExecuteTask (inherited from ExternalProgramBase) | Starts the external process and captures its output.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from AbstractCvsTask) | Build up the command line arguments, determine which executable is being used and find the path to that executable and set the working directory.
SetCommandOption (inherited from AbstractSourceControlTask) | Adds a new command option if none exists. If one does exist then the use switch is toggled on or of.
SetEnvironment (inherited from AbstractSourceControlTask) | Set up the environment variables for a process.
SetGlobalOption (inherited from AbstractSourceControlTask) | Adds a new global option if none exists. If one does exist then the use switch is toggled on or of.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
ToCvsDateTimeString (inherited from AbstractCvsTask) | Converts a DateTime value to a String representation that can be interpreted by cvs.

See Also

TagTask Class | NAnt.SourceControl.Tasks Namespace


TagTask.AppendSubCommandArgs Method

Append the tag information to the commandline.

[Visual Basic]
Overrides Protected Sub AppendSubCommandArgs()
[C#]
protected override void AppendSubCommandArgs();

See Also

TagTask Class | NAnt.SourceControl.Tasks Namespace


UpdateTask Class

Updates a CVS module in a local working directory.

For a list of all members of this type, see UpdateTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.SourceControl.Tasks.AbstractSourceControlTask
NAnt.SourceControl.Tasks.AbstractCvsTask
NAnt.SourceControl.Tasks.UpdateTask

[Visual Basic]
<TaskName(Name:="cvs-update")>
Public Class UpdateTask
Inherits AbstractCvsTask
[C#]
[TaskName(Name="cvs-update")]
public class UpdateTask : AbstractCvsTask

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Update nant.

            <cvs-update
                destination="c:\src\nant\"
                cvsroot=":pserver:anonymous@cvs.sourceforge.net:/cvsroot/nant"
                password=""
                module="nant" />

Update your NAnt revision named your_favorite_revision_here in the folder c:\src\nant\replacement_for_module_directory_name.

            <cvs-update
                destination="c:\src\nant\"
                cvsroot=":pserver:anonymous@cvs.sourceforge.net:/cvsroot/nant"
                module="nant"
                revision="your_favorite_revision_here"
                overridedir="replacement_for_module_directory_name"
                usesharpcvslib="false">
                <fileset>
                    <include name="build.number"/>
                </fileset>
            </cvs-update>

Requirements

Namespace: NAnt.SourceControl.Tasks

Assembly: NAnt.SourceControlTasks (in NAnt.SourceControlTasks.dll)

See Also

UpdateTask Members | NAnt.SourceControl.Tasks Namespace


UpdateTask Members

UpdateTask overview

Public Instance Constructors

UpdateTask Constructor Initializes a new instance of the UpdateTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
BuildDirs | If true. new directories will be created on the local sandbox. The default is true.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments (inherited from AbstractSourceControlTask) | Command-line arguments for the program. The command line arguments are used to specify any cvs command options that are not available as attributes. These are appended after the command itself and are additive to whatever attributes are currently specified.
CommandName | The name of the cvs command that is going to be executed.
CommandOptions (inherited from AbstractSourceControlTask) | A collection of options that can be used to modify the default behavoir of the version control commands. See the sub-tasks for implementation specifics.
CompressionLevel (inherited from AbstractCvsTask) Compression level to use for all net traffic. This should be a value from 1-9.

NOTE: This is not available on sharpcvslib.
CvsFileSet (inherited from AbstractCvsTask) | Used to specify the version control system (VCS) files that are going to be acted on.
CvsFullPath (inherited from AbstractCvsTask) | The full path to the cvs binary used. The cvs tasks will attempt to "guess" the location of your cvs binary based on your path. If the task is unable to resolve the location, or resolves it incorrectly this can be used to manually specify the path.
Date | Specify the revision date to update to. The version of the file that existed at the date specified is retrieved.
DestinationDirectory (inherited from AbstractSourceControlTask) | Destination directory for the local sandbox. If destination is not specified then the current directory is used.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from AbstractCvsTask) | The name of the cvs executable.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
GlobalOptions (inherited from AbstractSourceControlTask) | Holds a collection of globally available options.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Module (inherited from AbstractCvsTask) | The module to perform an operation on.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
OverwriteLocal | If true the local copy of the file will be overwritten with the copy from the remote repository. The default is false.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile (inherited from AbstractSourceControlTask) | The full path to the cached password file. If not specified then the environment variables are used to try and locate the file.
Password (inherited from AbstractSourceControlTask) | Obsolete. The password for logging in to the repository.
ProgramArguments (inherited from AbstractSourceControlTask) | Get the command line arguments for the task.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PruneEmpty | If true empty directories copied down from the remote repository will be removed from the local sandbox. The default is true.
Quiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be supressed. The default is false.
ReadOnly (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read only mode. The default is false.
ReadWrite (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read/write mode. The default is true.
ReallyQuiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be stopped. The default is false.
Recursive | Specifies if the command should be executed recursively. The default is true.
Revision | Specify the revision to update the file to. This corresponds to the "sticky-tag" of the file.
Root (inherited from AbstractCvsTask) The cvs root variable has the following components:
[protocol]:[username]@[servername]:[server path]
  • protocol: ext, pserver, ssh (sharpcvslib); if you are not using sharpcvslib consult your cvs documentation.
  • username: [username]
  • servername: cvs.sourceforge.net
  • server path: /cvsroot/nant
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Ssh (inherited from AbstractCvsTask) | The executable to use for ssh communication.
StickyTag | Sticky tag or revision to update the local file to.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
UseSharpCvsLib (inherited from AbstractCvsTask) | true if the SharpCvsLib binaries that come bundled with NAnt should be used to perform the cvs commands, false otherwise. You may also specify an override value for all cvs tasks instead of specifying a value for each. To do this set the property sourcecontrol.usesharpcvslib to false. If you choose not to use SharpCvsLib to checkout from cvs you will need to include a cvs.exe binary in your path.
VcsFileSet (inherited from AbstractCvsTask) | Get the cvs file set.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
IsModuleNeeded | Specify if the module is needed for this cvs command. It is only needed if there is no module information on the local file system.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
PassFileName (inherited from AbstractCvsTask) | The name of the pass file, or .cvspass at the time of this writing.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
SshEnv (inherited from AbstractCvsTask) | The environment name for the ssh variable.
VcsExeName (inherited from AbstractCvsTask) | The name of the cvs binary, or cvs.exe at the time this was written.
VcsHome (inherited from AbstractSourceControlTask) | The path to the specific home directory of the version control system, this can be where the binary files are kept, or other app information.
VcsHomeEnv (inherited from AbstractCvsTask) | The name of the version control system specific home environment variable.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

AddArg (inherited from AbstractCvsTask) | Add the given argument to the command line options. Note that are not explicitly quoted are split into seperate arguments. This is to resolve a recent issue with quoting command line arguments.
AppendFiles (inherited from AbstractSourceControlTask) | Append the files specified in the fileset to the command line argument. Files are changed to use a relative path from the working directory that the task is spawned in.
AppendSubCommandArgs (inherited from AbstractCvsTask) | Override to append any commands before the modele and files.
CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
DeriveVcsFromEnvironment (inherited from AbstractSourceControlTask) Derive the location of the version control system from the environment variable
PATH
.
ExecuteTask (inherited from ExternalProgramBase) | Starts the external process and captures its output.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from AbstractCvsTask) | Build up the command line arguments, determine which executable is being used and find the path to that executable and set the working directory.
SetCommandOption (inherited from AbstractSourceControlTask) | Adds a new command option if none exists. If one does exist then the use switch is toggled on or of.
SetEnvironment (inherited from AbstractSourceControlTask) | Set up the environment variables for a process.
SetGlobalOption (inherited from AbstractSourceControlTask) | Adds a new global option if none exists. If one does exist then the use switch is toggled on or of.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.
ToCvsDateTimeString (inherited from AbstractCvsTask) | Converts a DateTime value to a String representation that can be interpreted by cvs.

See Also

UpdateTask Class | NAnt.SourceControl.Tasks Namespace


UpdateTask Constructor

Initializes a new instance of the UpdateTask class.

[Visual Basic]
Public Sub New()
[C#]
public UpdateTask();

Remarks

Sets the build directory and prune empty directory properties to true.

See Also

UpdateTask Class | NAnt.SourceControl.Tasks Namespace


UpdateTask Properties

The properties of the UpdateTask class are listed below. For a complete list of UpdateTask class members, see the UpdateTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
BuildDirs | If true. new directories will be created on the local sandbox. The default is true.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CommandLineArguments (inherited from AbstractSourceControlTask) | Command-line arguments for the program. The command line arguments are used to specify any cvs command options that are not available as attributes. These are appended after the command itself and are additive to whatever attributes are currently specified.
CommandName | The name of the cvs command that is going to be executed.
CommandOptions (inherited from AbstractSourceControlTask) | A collection of options that can be used to modify the default behavoir of the version control commands. See the sub-tasks for implementation specifics.
CompressionLevel (inherited from AbstractCvsTask) Compression level to use for all net traffic. This should be a value from 1-9.

NOTE: This is not available on sharpcvslib.
CvsFileSet (inherited from AbstractCvsTask) | Used to specify the version control system (VCS) files that are going to be acted on.
CvsFullPath (inherited from AbstractCvsTask) | The full path to the cvs binary used. The cvs tasks will attempt to "guess" the location of your cvs binary based on your path. If the task is unable to resolve the location, or resolves it incorrectly this can be used to manually specify the path.
Date | Specify the revision date to update to. The version of the file that existed at the date specified is retrieved.
DestinationDirectory (inherited from AbstractSourceControlTask) | Destination directory for the local sandbox. If destination is not specified then the current directory is used.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from AbstractCvsTask) | The name of the cvs executable.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
GlobalOptions (inherited from AbstractSourceControlTask) | Holds a collection of globally available options.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Module (inherited from AbstractCvsTask) | The module to perform an operation on.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
OverwriteLocal | If true the local copy of the file will be overwritten with the copy from the remote repository. The default is false.
Parent (inherited from Element) | Gets or sets the parent of the element.
PassFile (inherited from AbstractSourceControlTask) | The full path to the cached password file. If not specified then the environment variables are used to try and locate the file.
Password (inherited from AbstractSourceControlTask) | Obsolete. The password for logging in to the repository.
ProgramArguments (inherited from AbstractSourceControlTask) | Get the command line arguments for the task.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PruneEmpty | If true empty directories copied down from the remote repository will be removed from the local sandbox. The default is true.
Quiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be supressed. The default is false.
ReadOnly (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read only mode. The default is false.
ReadWrite (inherited from AbstractCvsTask) | true if the sandbox files should be checked out in read/write mode. The default is true.
ReallyQuiet (inherited from AbstractCvsTask) | Indicates if the output from the cvs command should be stopped. The default is false.
Recursive | Specifies if the command should be executed recursively. The default is true.
Revision | Specify the revision to update the file to. This corresponds to the "sticky-tag" of the file.
Root (inherited from AbstractCvsTask) The cvs root variable has the following components:
[protocol]:[username]@[servername]:[server path]
  • protocol: ext, pserver, ssh (sharpcvslib); if you are not using sharpcvslib consult your cvs documentation.
  • username: [username]
  • servername: cvs.sourceforge.net
  • server path: /cvsroot/nant
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Ssh (inherited from AbstractCvsTask) | The executable to use for ssh communication.
StickyTag | Sticky tag or revision to update the local file to.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
UseSharpCvsLib (inherited from AbstractCvsTask) | true if the SharpCvsLib binaries that come bundled with NAnt should be used to perform the cvs commands, false otherwise. You may also specify an override value for all cvs tasks instead of specifying a value for each. To do this set the property sourcecontrol.usesharpcvslib to false. If you choose not to use SharpCvsLib to checkout from cvs you will need to include a cvs.exe binary in your path.
VcsFileSet (inherited from AbstractCvsTask) | Get the cvs file set.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
IsModuleNeeded | Specify if the module is needed for this cvs command. It is only needed if there is no module information on the local file system.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
PassFileName (inherited from AbstractCvsTask) | The name of the pass file, or .cvspass at the time of this writing.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
SshEnv (inherited from AbstractCvsTask) | The environment name for the ssh variable.
VcsExeName (inherited from AbstractCvsTask) | The name of the cvs binary, or cvs.exe at the time this was written.
VcsHome (inherited from AbstractSourceControlTask) | The path to the specific home directory of the version control system, this can be where the binary files are kept, or other app information.
VcsHomeEnv (inherited from AbstractCvsTask) | The name of the version control system specific home environment variable.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

UpdateTask Class | NAnt.SourceControl.Tasks Namespace


BuildDirs Property

NAnt SDK Documentation - v0.91

UpdateTask.BuildDirs Property

If true. new directories will be created on the local sandbox. The default is true.

[Visual Basic]
<TaskAttribute(Name:="builddirs", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property BuildDirs As Boolean
[C#]
[TaskAttribute(Name="builddirs", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool BuildDirs {get; set;}

See Also

UpdateTask Class | NAnt.SourceControl.Tasks Namespace


CommandName Property

NAnt SDK Documentation - v0.91

UpdateTask.CommandName Property

The name of the cvs command that is going to be executed.

[Visual Basic]
Overrides Public ReadOnly Property CommandName As String
[C#]
public override string CommandName {get;}

See Also

UpdateTask Class | NAnt.SourceControl.Tasks Namespace


Date Property

NAnt SDK Documentation - v0.91

UpdateTask.Date Property

Specify the revision date to update to. The version of the file that existed at the date specified is retrieved.

[Visual Basic]
<TaskAttribute(Name:="date", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ DateTimeValidator>
Public Property Date As Date
[C#]
[TaskAttribute(Name="date", Required=False, ExpandProperties=True, ProcessXml=True)]
[DateTimeValidator]
public System.DateTime Date {get; set;}

Property Value

A valid date time value, which is then converted to a format that cvs can parse.

See Also

UpdateTask Class | NAnt.SourceControl.Tasks Namespace


IsModuleNeeded Property

NAnt SDK Documentation - v0.91

UpdateTask.IsModuleNeeded Property

Specify if the module is needed for this cvs command. It is only needed if there is no module information on the local file system.

[Visual Basic]
Overrides Protected ReadOnly Property IsModuleNeeded As Boolean
[C#]
protected override bool IsModuleNeeded {get;}

See Also

UpdateTask Class | NAnt.SourceControl.Tasks Namespace


OverwriteLocal Property

NAnt SDK Documentation - v0.91

UpdateTask.OverwriteLocal Property

If true the local copy of the file will be overwritten with the copy from the remote repository. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="overwritelocal", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property OverwriteLocal As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="overwritelocal", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool OverwriteLocal {get; set;}

See Also

UpdateTask Class | NAnt.SourceControl.Tasks Namespace


PruneEmpty Property

NAnt SDK Documentation - v0.91

UpdateTask.PruneEmpty Property

If true empty directories copied down from the remote repository will be removed from the local sandbox. The default is true.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="pruneempty", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property PruneEmpty As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="pruneempty", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool PruneEmpty {get; set;}

See Also

UpdateTask Class | NAnt.SourceControl.Tasks Namespace


Recursive Property

NAnt SDK Documentation - v0.91

UpdateTask.Recursive Property

Specifies if the command should be executed recursively. The default is true.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="recursive", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Recursive As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="recursive", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool Recursive {get; set;}

Remarks

The -R option is on by default in cvs.

See Also

UpdateTask Class | NAnt.SourceControl.Tasks Namespace


Revision Property

NAnt SDK Documentation - v0.91

UpdateTask.Revision Property

Specify the revision to update the file to. This corresponds to the "sticky-tag" of the file.

[Visual Basic]
<TaskAttribute(Name:="revision", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=True, Expression:="^[A-Za-z0-9][A-Za-z0-9._\-]*$", ExpressionErrorMessage:="null")>
Public Property Revision As String
[C#]
[TaskAttribute(Name="revision", Required=False, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=True, Expression="^[A-Za-z0-9][A-Za-z0-9._\-]*$", ExpressionErrorMessage="null")]
public string Revision {get; set;}

See Also

UpdateTask Class | NAnt.SourceControl.Tasks Namespace


StickyTag Property

NAnt SDK Documentation - v0.91

UpdateTask.StickyTag Property

Sticky tag or revision to update the local file to.

[Visual Basic]
<TaskAttribute(Name:="sticky-tag", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property StickyTag As String
[C#]
[TaskAttribute(Name="sticky-tag", Required=False, ExpandProperties=True, ProcessXml=True)]
public string StickyTag {get; set;}

Property Value

A valid cvs tag.

See Also

UpdateTask Class | NAnt.SourceControl.Tasks Namespace


NAnt.SourceControl.Types

NAnt SDK Documentation - v0.91

NAnt.SourceControl.Types Namespace

Namespace hierarchy

Classes

Class | Description
CvsFileSet | A CvsFileSet is a FileSet with extra attributes useful in the context of the CvsTask.


CvsFileSet Class

A CvsFileSet is a FileSet with extra attributes useful in the context of the CvsTask.

For a list of all members of this type, see CvsFileSet Members.

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.Core.Types.FileSet
NAnt.SourceControl.Types.CvsFileSet

[Visual Basic]
<ElementName(Name:="cvsfileset")>
Public Class CvsFileSet
Inherits FileSet
[C#]
[ElementName(Name="cvsfileset")]
public class CvsFileSet : FileSet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.SourceControl.Types

Assembly: NAnt.SourceControlTasks (in NAnt.SourceControlTasks.dll)

See Also

CvsFileSet Members | NAnt.SourceControl.Types Namespace


CvsFileSet Members

CvsFileSet overview

Public Instance Constructors

CvsFileSet Constructor Initializes a new instance of the CvsFileSet class.

Public Instance Properties

AsIs (inherited from FileSet) | Gets the collection of files that will be added to the FileSet without pattern matching or checking if the file exists.
BaseDirectory (inherited from FileSet) | The base of the directory of this fileset. The default is the project base directory.
CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
CaseSensitive (inherited from FileSet) | Indicates whether include and exclude patterns must be treated in a case-sensitive way. The default is true on Unix; otherwise, false.
DefaultExcludes (inherited from FileSet) | Indicates whether default excludes should be used or not. The default is true.
DirectoryNames (inherited from FileSet) | Gets the collection of directory names that match the fileset.
ExcludeElements (inherited from FileSet) | The items to exclude from the fileset.
Excludes (inherited from FileSet) | Gets the collection of exclude patterns.
ExcludesFiles (inherited from FileSet) | The files from which a list of patterns or files to exclude should be obtained.
FailOnEmpty (inherited from FileSet) | When set to true, causes the fileset element to throw a ValidationException when no files match the includes and excludes criteria. The default is false.
FileNames (inherited from FileSet) | Gets the collection of file names that match the fileset.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IncludeElements (inherited from FileSet) | The items to include in the fileset.
Includes (inherited from FileSet) | Gets the collection of include patterns.
IncludesFiles (inherited from FileSet) | The files from which a list of patterns or files to include should be obtained.
MostRecentLastWriteTimeFile (inherited from FileSet) | Determines the most recently modified file in the fileset (by LastWriteTime of the FileInfo).
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PathFiles (inherited from FileSet) |
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.
ScannedDirectories (inherited from FileSet) | Gets the collection of directory names that were scanned for files.
SetExcludes (inherited from FileSet) | Obsolete. The items to exclude from the fileset.
SetIncludes (inherited from FileSet) | Obsolete. The items to include in the fileset.
SetIncludesList (inherited from FileSet) | Obsolete. The files from which a list of patterns or files to include should be obtained.
UseCvsIgnore | Indicates whether the entires in the .cvsignore should be used to limit the file list; true to exclude files in .cvsignore, otherwise false. The default is true.

Public Instance Methods

AddPatternSet (inherited from FileSet) | Adds a nested set of patterns, or references a standalone patternset.
Clone (inherited from FileSet) | Creates a shallow copy of the FileSet.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from FileSet) |
Scan (inherited from FileSet) |
ToString (inherited from FileSet) |

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from FileSet) | Overloaded. Copies all instance data of the FileSet to a given FileSet.
CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Initialize the CvsFileSet object and locate the .cvsignore files to add to the exclude list.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CvsFileSet Class | NAnt.SourceControl.Types Namespace


CvsFileSet Constructor

Initializes a new instance of the CvsFileSet class.

[Visual Basic]
Public Sub New()
[C#]
public CvsFileSet();

See Also

CvsFileSet Class | NAnt.SourceControl.Types Namespace


CvsFileSet Properties

The properties of the CvsFileSet class are listed below. For a complete list of CvsFileSet class members, see the CvsFileSet Members topic.

Public Instance Properties

AsIs (inherited from FileSet) | Gets the collection of files that will be added to the FileSet without pattern matching or checking if the file exists.
BaseDirectory (inherited from FileSet) | The base of the directory of this fileset. The default is the project base directory.
CanBeReferenced (inherited from DataTypeBase) | Gets a value indicating whether a reference to the type can be defined.
CaseSensitive (inherited from FileSet) | Indicates whether include and exclude patterns must be treated in a case-sensitive way. The default is true on Unix; otherwise, false.
DefaultExcludes (inherited from FileSet) | Indicates whether default excludes should be used or not. The default is true.
DirectoryNames (inherited from FileSet) | Gets the collection of directory names that match the fileset.
ExcludeElements (inherited from FileSet) | The items to exclude from the fileset.
Excludes (inherited from FileSet) | Gets the collection of exclude patterns.
ExcludesFiles (inherited from FileSet) | The files from which a list of patterns or files to exclude should be obtained.
FailOnEmpty (inherited from FileSet) | When set to true, causes the fileset element to throw a ValidationException when no files match the includes and excludes criteria. The default is false.
FileNames (inherited from FileSet) | Gets the collection of file names that match the fileset.
ID (inherited from DataTypeBase) | The ID used to be referenced later.
IncludeElements (inherited from FileSet) | The items to include in the fileset.
Includes (inherited from FileSet) | Gets the collection of include patterns.
IncludesFiles (inherited from FileSet) | The files from which a list of patterns or files to include should be obtained.
MostRecentLastWriteTimeFile (inherited from FileSet) | Determines the most recently modified file in the fileset (by LastWriteTime of the FileInfo).
Name (inherited from DataTypeBase) | Gets the name of the datatype.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
PathFiles (inherited from FileSet) |
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RefID (inherited from DataTypeBase) | The ID to use as the reference.
ScannedDirectories (inherited from FileSet) | Gets the collection of directory names that were scanned for files.
SetExcludes (inherited from FileSet) | Obsolete. The items to exclude from the fileset.
SetIncludes (inherited from FileSet) | Obsolete. The items to include in the fileset.
SetIncludesList (inherited from FileSet) | Obsolete. The files from which a list of patterns or files to include should be obtained.
UseCvsIgnore | Indicates whether the entires in the .cvsignore should be used to limit the file list; true to exclude files in .cvsignore, otherwise false. The default is true.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

CvsFileSet Class | NAnt.SourceControl.Types Namespace


UseCvsIgnore Property

NAnt SDK Documentation - v0.91

CvsFileSet.UseCvsIgnore Property

Indicates whether the entires in the .cvsignore should be used to limit the file list; true to exclude files in .cvsignore, otherwise false. The default is true.

[Visual Basic]
<TaskAttribute(Name:="usecvsignore", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property UseCvsIgnore As Boolean
[C#]
[TaskAttribute(Name="usecvsignore", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool UseCvsIgnore {get; set;}

See Also

CvsFileSet Class | NAnt.SourceControl.Types Namespace


CvsFileSet Methods

The methods of the CvsFileSet class are listed below. For a complete list of CvsFileSet class members, see the CvsFileSet Members topic.

Public Instance Methods

AddPatternSet (inherited from FileSet) | Adds a nested set of patterns, or references a standalone patternset.
Clone (inherited from FileSet) | Creates a shallow copy of the FileSet.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
Reset (inherited from FileSet) |
Scan (inherited from FileSet) |
ToString (inherited from FileSet) |

Protected Instance Methods

CopyTo (inherited from FileSet) | Overloaded. Copies all instance data of the FileSet to a given FileSet.
CopyTo (inherited from DataTypeBase) | Overloaded. Copies all instance data of the DataTypeBase to a given DataTypeBase.
CopyTo (inherited from Element) | Overloaded. Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize | Overloaded. Initialize the CvsFileSet object and locate the .cvsignore files to add to the exclude list.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CvsFileSet Class | NAnt.SourceControl.Types Namespace


Initialize Method

NAnt SDK Documentation - v0.91

CvsFileSet.Initialize Method

Initialize the CvsFileSet object and locate the .cvsignore files to add to the exclude list.

Overload List

Initialize the CvsFileSet object and locate the .cvsignore files to add to the exclude list.

protected override void Initialize();

Inherited from Element.

public void Initialize(XmlNode);

See Also

CvsFileSet Class | NAnt.SourceControl.Types Namespace


CvsFileSet.Initialize Method ()

Initialize the CvsFileSet object and locate the .cvsignore files to add to the exclude list.

[Visual Basic]
Overrides Overloads Protected Sub Initialize()
[C#]
protected override void Initialize();

See Also

CvsFileSet Class | NAnt.SourceControl.Types Namespace | CvsFileSet.Initialize Overload List


NAnt.VisualCpp.Tasks

NAnt SDK Documentation - v0.91

NAnt.VisualCpp.Tasks Namespace

Namespace hierarchy

Classes

Class | Description
ClTask | Compiles C/C++ programs using cl.exe, Microsoft's C/C++ compiler.
LibTask | Run lib.exe, Microsoft's Library Manager.
LinkTask | Links files using link.exe, Microsoft's Incremental Linker.
McTask | Compiles messages using mc.exe, Microsoft's Win32 message compiler.
MidlTask | This tasks allows you to run MIDL.exe.
RcTask | Compiles resources using rc.exe, Microsoft's Win32 resource compiler.

Enumerations

Enumeration | Description
ClTask.PrecompiledHeaderMode | Defines the supported modes for the use of precompiled header files.


ClTask Class

Compiles C/C++ programs using cl.exe, Microsoft's C/C++ compiler.

For a list of all members of this type, see ClTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.VisualCpp.Tasks.ClTask

[Visual Basic]
<TaskName(Name:="cl")>
Public Class ClTask
Inherits ExternalProgramBase
[C#]
[TaskName(Name="cl")]
public class ClTask : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This task is intended for version 13.00.9466 of cl.exe.

Example

Compiles helloworld.cpp for the Common Language Runtime.

            <cl outputdir="build" options="/clr">
                <sources>
                    <include name="helloworld.cpp" />
                </sources>
            </cl>

Requirements

Namespace: NAnt.VisualCpp.Tasks

Assembly: NAnt.VisualCppTasks (in NAnt.VisualCppTasks.dll)

See Also

ClTask Members | NAnt.VisualCpp.Tasks Namespace


ClTask Members

ClTask overview

Public Static (Shared) Methods

GetObjOutputFile | Determines the file name of the OBJ file for the specified source file.
QuoteArgumentValue | Quotes an argument value and duplicates trailing backslahes.

Public Instance Constructors

ClTask Constructor Initializes a new instance of the ClTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CharacterSet | Tells the compiler to use the specified character set.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Defines | Macro definitions to pass to cl.exe. Each entry will generate a /D
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForcedUsingFiles | Specifies metadata files to reference in this compilation as an alternative to passing a file name to #using in source code.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IncludeDirs | The list of directories in which to search for include files.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
ManagedExtensions | Specifies whether Managed Extensions for C++ should be enabled. The default is false.
MetaDataIncludeDirs | Directories that the compiler will search to resolve file references passed to the #using directive.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
ObjectFile | A name to override the default object file name; can be either a file or directory name. The default is the output directory.
Options | Options to pass to the compiler.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputDir | Directory where all output files are placed.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
PchFile | Specifies the path and/or name of the generated precompiled header file - given either relative to OutputDir or as an absolute path.
PchMode | The mode in which the specified PchFile (if any) is used. The default is Use.
PchThroughFile | The path of the boundary file when generating/using the specified PchFile. If a precompiled header file is not specified then this attribute is ignored.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramDatabaseFile | A name for the compiler-generated PDB file; can be either a file or directory name. The default is the output directory.
ProgramFileName | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Sources | The list of files to compile.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
Undefines | Macro undefines (/U) to pass to cl.exe.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Compiles the sources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines if the sources need to be compiled.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


ClTask Constructor

Initializes a new instance of the ClTask class.

[Visual Basic]
Public Sub New()
[C#]
public ClTask();

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


ClTask Properties

The properties of the ClTask class are listed below. For a complete list of ClTask class members, see the ClTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CharacterSet | Tells the compiler to use the specified character set.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Defines | Macro definitions to pass to cl.exe. Each entry will generate a /D
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
ForcedUsingFiles | Specifies metadata files to reference in this compilation as an alternative to passing a file name to #using in source code.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IncludeDirs | The list of directories in which to search for include files.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
ManagedExtensions | Specifies whether Managed Extensions for C++ should be enabled. The default is false.
MetaDataIncludeDirs | Directories that the compiler will search to resolve file references passed to the #using directive.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
ObjectFile | A name to override the default object file name; can be either a file or directory name. The default is the output directory.
Options | Options to pass to the compiler.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputDir | Directory where all output files are placed.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
PchFile | Specifies the path and/or name of the generated precompiled header file - given either relative to OutputDir or as an absolute path.
PchMode | The mode in which the specified PchFile (if any) is used. The default is Use.
PchThroughFile | The path of the boundary file when generating/using the specified PchFile. If a precompiled header file is not specified then this attribute is ignored.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramDatabaseFile | A name for the compiler-generated PDB file; can be either a file or directory name. The default is the output directory.
ProgramFileName | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Sources | The list of files to compile.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
Undefines | Macro undefines (/U) to pass to cl.exe.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


CharacterSet Property

NAnt SDK Documentation - v0.91

ClTask.CharacterSet Property

Tells the compiler to use the specified character set.

[Visual Basic]
<TaskAttribute(Name:="characterset", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property CharacterSet As CharacterSet
[C#]
[TaskAttribute(Name="characterset", Required=False, ExpandProperties=True, ProcessXml=True)]
public NAnt.VisualCpp.Types.CharacterSet CharacterSet {get; set;}

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


Defines Property

NAnt SDK Documentation - v0.91

ClTask.Defines Property

Macro definitions to pass to cl.exe. Each entry will generate a /D

[Visual Basic]
<BuildElementCollection(ChildElementName:="define", ElementType:=null, Name:="defines", Required:=False, ProcessXml:=True)>
Public ReadOnly Property Defines As OptionCollection
[C#]
[BuildElementCollection(ChildElementName="define", ElementType=null, Name="defines", Required=False, ProcessXml=True)]
public NAnt.Core.Types.OptionCollection Defines {get;}

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


ForcedUsingFiles Property

NAnt SDK Documentation - v0.91

ClTask.ForcedUsingFiles Property

Specifies metadata files to reference in this compilation as an alternative to passing a file name to #using in source code.

[Visual Basic]
<BuildElement(Name:="forcedusingfiles", Required:=False, ProcessXml:=True)>
Public Property ForcedUsingFiles As FileSet
[C#]
[BuildElement(Name="forcedusingfiles", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet ForcedUsingFiles {get; set;}

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


IncludeDirs Property

NAnt SDK Documentation - v0.91

ClTask.IncludeDirs Property

The list of directories in which to search for include files.

[Visual Basic]
<BuildElement(Name:="includedirs", Required:=False, ProcessXml:=True)>
Public Property IncludeDirs As FileSet
[C#]
[BuildElement(Name="includedirs", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet IncludeDirs {get; set;}

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


ManagedExtensions Property

NAnt SDK Documentation - v0.91

ClTask.ManagedExtensions Property

Specifies whether Managed Extensions for C++ should be enabled. The default is false.

[Visual Basic]
<TaskAttribute(Name:="managedextensions", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property ManagedExtensions As Boolean
[C#]
[TaskAttribute(Name="managedextensions", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool ManagedExtensions {get; set;}

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


MetaDataIncludeDirs Property

NAnt SDK Documentation - v0.91

ClTask.MetaDataIncludeDirs Property

Directories that the compiler will search to resolve file references passed to the #using directive.

[Visual Basic]
<BuildElement(Name:="metadataincludedirs", Required:=False, ProcessXml:=True)>
Public Property MetaDataIncludeDirs As FileSet
[C#]
[BuildElement(Name="metadataincludedirs", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet MetaDataIncludeDirs {get; set;}

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


ObjectFile Property

NAnt SDK Documentation - v0.91

ClTask.ObjectFile Property

A name to override the default object file name; can be either a file or directory name. The default is the output directory.

[Visual Basic]
<TaskAttribute(Name:="objectfile", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property ObjectFile As String
[C#]
[TaskAttribute(Name="objectfile", Required=False, ExpandProperties=True, ProcessXml=True)]
public string ObjectFile {get; set;}

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


Options Property

NAnt SDK Documentation - v0.91

ClTask.Options Property

Options to pass to the compiler.

[Visual Basic]
<TaskAttribute(Name:="options", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Options As String
[C#]
[TaskAttribute(Name="options", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Options {get; set;}

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


OutputDir Property

NAnt SDK Documentation - v0.91

ClTask.OutputDir Property

Directory where all output files are placed.

[Visual Basic]
<TaskAttribute(Name:="outputdir", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property OutputDir As DirectoryInfo
[C#]
[TaskAttribute(Name="outputdir", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.DirectoryInfo OutputDir {get; set;}

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


PchFile Property

NAnt SDK Documentation - v0.91

ClTask.PchFile Property

Specifies the path and/or name of the generated precompiled header file - given either relative to OutputDir or as an absolute path.

[Visual Basic]
<TaskAttribute(Name:="pchfile", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property PchFile As String
[C#]
[TaskAttribute(Name="pchfile", Required=False, ExpandProperties=True, ProcessXml=True)]
public string PchFile {get; set;}

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


PchMode Property

NAnt SDK Documentation - v0.91

ClTask.PchMode Property

The mode in which the specified PchFile (if any) is used. The default is Use.

[Visual Basic]
<TaskAttribute(Name:="pchmode", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property PchMode As PrecompiledHeaderMode
[C#]
[TaskAttribute(Name="pchmode", Required=False, ExpandProperties=True, ProcessXml=True)]
public ClTask.PrecompiledHeaderMode PchMode {get; set;}

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


PchThroughFile Property

NAnt SDK Documentation - v0.91

ClTask.PchThroughFile Property

The path of the boundary file when generating/using the specified PchFile. If a precompiled header file is not specified then this attribute is ignored.

[Visual Basic]
<TaskAttribute(Name:="pchthroughfile", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property PchThroughFile As String
[C#]
[TaskAttribute(Name="pchthroughfile", Required=False, ExpandProperties=True, ProcessXml=True)]
public string PchThroughFile {get; set;}

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

ClTask.ProgramArguments Property

Gets the command-line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

Property Value

The command-line arguments for the external program.

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


ProgramDatabaseFile Property

NAnt SDK Documentation - v0.91

ClTask.ProgramDatabaseFile Property

A name for the compiler-generated PDB file; can be either a file or directory name. The default is the output directory.

[Visual Basic]
<TaskAttribute(Name:="pdbfile", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property ProgramDatabaseFile As String
[C#]
[TaskAttribute(Name="pdbfile", Required=False, ExpandProperties=True, ProcessXml=True)]
public string ProgramDatabaseFile {get; set;}

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


ProgramFileName Property

NAnt SDK Documentation - v0.91

ClTask.ProgramFileName Property

Gets the filename of the external program to start.

[Visual Basic]
Overrides Public ReadOnly Property ProgramFileName As String
[C#]
public override string ProgramFileName {get;}

Property Value

The filename of the external program.

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


Sources Property

NAnt SDK Documentation - v0.91

ClTask.Sources Property

The list of files to compile.

[Visual Basic]
<BuildElement(Name:="sources", Required:=False, ProcessXml:=True)>
Public Property Sources As FileSet
[C#]
[BuildElement(Name="sources", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet Sources {get; set;}

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


Undefines Property

NAnt SDK Documentation - v0.91

ClTask.Undefines Property

Macro undefines (/U) to pass to cl.exe.

[Visual Basic]
<BuildElementCollection(ChildElementName:="undefine", ElementType:=null, Name:="undefines", Required:=False, ProcessXml:=True)>
Public ReadOnly Property Undefines As OptionCollection
[C#]
[BuildElementCollection(ChildElementName="undefine", ElementType=null, Name="undefines", Required=False, ProcessXml=True)]
public NAnt.Core.Types.OptionCollection Undefines {get;}

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


ClTask Methods

The methods of the ClTask class are listed below. For a complete list of ClTask class members, see the ClTask Members topic.

Public Static (Shared) Methods

GetObjOutputFile | Determines the file name of the OBJ file for the specified source file.
QuoteArgumentValue | Quotes an argument value and duplicates trailing backslahes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Compiles the sources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines if the sources need to be compiled.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


ClTask.ExecuteTask Method

Compiles the sources.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


ClTask.GetObjOutputFile Method

Determines the file name of the OBJ file for the specified source file.

[Visual Basic]
Public Shared Function GetObjOutputFile( _
ByVal srcFile As String, _
ByVal objectPath As String _
) As String
[C#]
public static string GetObjOutputFile(
string srcFile,
string objectPath
);

Parameters

srcFile
The source file for which the OBJ file should be determined.
objectPath
The path of the object file.

Return Value

The file name of the OBJ file for the specified source file.

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


ClTask.NeedsCompiling Method

Determines if the sources need to be compiled.

[Visual Basic]
Overridable Protected Function NeedsCompiling() As Boolean
[C#]
protected virtual bool NeedsCompiling();

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


ClTask.QuoteArgumentValue Method

Quotes an argument value and duplicates trailing backslahes.

[Visual Basic]
Public Shared Function QuoteArgumentValue( _
ByVal value As String _
) As String
[C#]
public static string QuoteArgumentValue(
string value
);

Parameters

value
The argument value to quote.

Return Value

The quotes argument value.

See Also

ClTask Class | NAnt.VisualCpp.Tasks Namespace


ClTask.PrecompiledHeaderMode Enumeration

Defines the supported modes for the use of precompiled header files.

[Visual Basic]
<Serializable>
Public Enum ClTask.PrecompiledHeaderMode
[C#]
[Serializable]
public enum ClTask.PrecompiledHeaderMode

Members

Member Name | Description
Create | Create a precompiled header file.
AutoCreate | Automatically create a precompiled header file if necessary.
Use | Use a (previously generated) precompiled header file.

Requirements

Namespace: NAnt.VisualCpp.Tasks

Assembly: NAnt.VisualCppTasks (in NAnt.VisualCppTasks.dll)

See Also

NAnt.VisualCpp.Tasks Namespace


LibTask Class

Run lib.exe, Microsoft's Library Manager.

For a list of all members of this type, see LibTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.VisualCpp.Tasks.LibTask

[Visual Basic]
<TaskName(Name:="lib")>
Public Class LibTask
Inherits ExternalProgramBase
[C#]
[TaskName(Name="lib")]
public class LibTask : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Create a library.

            <lib output="library.lib">
                <sources>
                    <include name="library.obj" />
                </sources>
            </lib>

Requirements

Namespace: NAnt.VisualCpp.Tasks

Assembly: NAnt.VisualCppTasks (in NAnt.VisualCppTasks.dll)

See Also

LibTask Members | NAnt.VisualCpp.Tasks Namespace


LibTask Members

LibTask overview

Public Instance Constructors

LibTask Constructor Initializes a new instance of the LibTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IgnoreLibraries | Names of default libraries to ignore.
LibDirs | The list of additional library directories to search.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
ModuleDefinitionFile | The module definition file.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Options | Options to pass to the compiler.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | The output file.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Sources | The list of files to combine into the output file.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Symbols | Symbols to add to the symbol table.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Creates the library.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines if the sources need to be linked.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

LibTask Class | NAnt.VisualCpp.Tasks Namespace


LibTask Constructor

Initializes a new instance of the LibTask class.

[Visual Basic]
Public Sub New()
[C#]
public LibTask();

See Also

LibTask Class | NAnt.VisualCpp.Tasks Namespace


LibTask Properties

The properties of the LibTask class are listed below. For a complete list of LibTask class members, see the LibTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IgnoreLibraries | Names of default libraries to ignore.
LibDirs | The list of additional library directories to search.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
ModuleDefinitionFile | The module definition file.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Options | Options to pass to the compiler.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | The output file.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Sources | The list of files to combine into the output file.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Symbols | Symbols to add to the symbol table.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

LibTask Class | NAnt.VisualCpp.Tasks Namespace


IgnoreLibraries Property

NAnt SDK Documentation - v0.91

LibTask.IgnoreLibraries Property

Names of default libraries to ignore.

[Visual Basic]
<BuildElementCollection(ChildElementName:="library", ElementType:=null, Name:="ignorelibraries", Required:=False, ProcessXml:=True)>
Public Property IgnoreLibraries As LibraryCollection
[C#]
[BuildElementCollection(ChildElementName="library", ElementType=null, Name="ignorelibraries", Required=False, ProcessXml=True)]
public NAnt.VisualCpp.Types.LibraryCollection IgnoreLibraries {get; set;}

See Also

LibTask Class | NAnt.VisualCpp.Tasks Namespace


LibDirs Property

NAnt SDK Documentation - v0.91

LibTask.LibDirs Property

The list of additional library directories to search.

[Visual Basic]
<BuildElement(Name:="libdirs", Required:=False, ProcessXml:=True)>
Public Property LibDirs As FileSet
[C#]
[BuildElement(Name="libdirs", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet LibDirs {get; set;}

See Also

LibTask Class | NAnt.VisualCpp.Tasks Namespace


ModuleDefinitionFile Property

NAnt SDK Documentation - v0.91

LibTask.ModuleDefinitionFile Property

The module definition file.

[Visual Basic]
<TaskAttribute(Name:="moduledefinition", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property ModuleDefinitionFile As FileInfo
[C#]
[TaskAttribute(Name="moduledefinition", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo ModuleDefinitionFile {get; set;}

See Also

LibTask Class | NAnt.VisualCpp.Tasks Namespace


Options Property

NAnt SDK Documentation - v0.91

LibTask.Options Property

Options to pass to the compiler.

[Visual Basic]
<TaskAttribute(Name:="options", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Options As String
[C#]
[TaskAttribute(Name="options", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Options {get; set;}

See Also

LibTask Class | NAnt.VisualCpp.Tasks Namespace


OutputFile Property

NAnt SDK Documentation - v0.91

LibTask.OutputFile Property

The output file.

[Visual Basic]
<TaskAttribute(Name:="output", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property OutputFile As FileInfo
[C#]
[TaskAttribute(Name="output", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo OutputFile {get; set;}

See Also

LibTask Class | NAnt.VisualCpp.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

LibTask.ProgramArguments Property

Gets the command-line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

Property Value

The command-line arguments for the external program.

See Also

LibTask Class | NAnt.VisualCpp.Tasks Namespace


ProgramFileName Property

NAnt SDK Documentation - v0.91

LibTask.ProgramFileName Property

Gets the filename of the external program to start.

[Visual Basic]
Overrides Public ReadOnly Property ProgramFileName As String
[C#]
public override string ProgramFileName {get;}

Property Value

The filename of the external program.

See Also

LibTask Class | NAnt.VisualCpp.Tasks Namespace


Sources Property

NAnt SDK Documentation - v0.91

LibTask.Sources Property

The list of files to combine into the output file.

[Visual Basic]
<BuildElement(Name:="sources", Required:=False, ProcessXml:=True)>
Public Property Sources As FileSet
[C#]
[BuildElement(Name="sources", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet Sources {get; set;}

See Also

LibTask Class | NAnt.VisualCpp.Tasks Namespace


Symbols Property

NAnt SDK Documentation - v0.91

LibTask.Symbols Property

Symbols to add to the symbol table.

[Visual Basic]
<BuildElementCollection(ChildElementName:="symbol", ElementType:=null, Name:="symbols", Required:=False, ProcessXml:=True)>
Public Property Symbols As SymbolCollection
[C#]
[BuildElementCollection(ChildElementName="symbol", ElementType=null, Name="symbols", Required=False, ProcessXml=True)]
public NAnt.VisualCpp.Types.SymbolCollection Symbols {get; set;}

See Also

LibTask Class | NAnt.VisualCpp.Tasks Namespace


LibTask Methods

The methods of the LibTask class are listed below. For a complete list of LibTask class members, see the LibTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Creates the library.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines if the sources need to be linked.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

LibTask Class | NAnt.VisualCpp.Tasks Namespace


LibTask.ExecuteTask Method

Creates the library.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

LibTask Class | NAnt.VisualCpp.Tasks Namespace


LibTask.NeedsCompiling Method

Determines if the sources need to be linked.

[Visual Basic]
Overridable Protected Function NeedsCompiling() As Boolean
[C#]
protected virtual bool NeedsCompiling();

See Also

LibTask Class | NAnt.VisualCpp.Tasks Namespace


LinkTask Class

Links files using link.exe, Microsoft's Incremental Linker.

For a list of all members of this type, see LinkTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.VisualCpp.Tasks.LinkTask

[Visual Basic]
<TaskName(Name:="link")>
Public Class LinkTask
Inherits ExternalProgramBase
[C#]
[TaskName(Name="link")]
public class LinkTask : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This task is intended for version 7.00.9466 of link.exe.

Example

Combine all object files in the current directory into helloworld.exe.

            <link output="helloworld.exe">
                <sources>
                    <include name="*.obj" />
                </sources>
            </link>

Requirements

Namespace: NAnt.VisualCpp.Tasks

Assembly: NAnt.VisualCppTasks (in NAnt.VisualCppTasks.dll)

See Also

LinkTask Members | NAnt.VisualCpp.Tasks Namespace


LinkTask Members

LinkTask overview

Public Static (Shared) Methods

QuoteArgumentValue Quotes an argument value and duplicates trailing backslahes.

Public Instance Constructors

LinkTask Constructor Initializes a new instance of the LinkTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Debug | Create debugging information for the .exe file or DLL. The default is false.
DelayLoadedDlls | Specified DLLs for delay loading.
EmbeddedResources | Embed the specified resources into this assembly.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IgnoreLibraries | Names of libraries that you want the linker to ignore when it resolves external references.
LibDirs | The list of additional library directories to search.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
ModuleDefinition | The name of a module-definition file (.def) to be passed to the linker.
Modules | Link the specified modules into this assembly.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Options | Options to pass to the compiler.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | The output file.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramDatabaseFile | A user-specified name for the program database (PDB) that the linker creates. The default file name for the PDB has the base name of the OutputFile and the extension .pdb.
ProgramFileName | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Sources | The list of files to combine into the output file.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Symbols | Symbols to add to the symbol table.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Links the sources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsLinking | Determines if the output needs linking.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


LinkTask Constructor

Initializes a new instance of the LinkTask class.

[Visual Basic]
Public Sub New()
[C#]
public LinkTask();

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


LinkTask Properties

The properties of the LinkTask class are listed below. For a complete list of LinkTask class members, see the LinkTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Debug | Create debugging information for the .exe file or DLL. The default is false.
DelayLoadedDlls | Specified DLLs for delay loading.
EmbeddedResources | Embed the specified resources into this assembly.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IgnoreLibraries | Names of libraries that you want the linker to ignore when it resolves external references.
LibDirs | The list of additional library directories to search.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
ModuleDefinition | The name of a module-definition file (.def) to be passed to the linker.
Modules | Link the specified modules into this assembly.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Options | Options to pass to the compiler.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | The output file.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramDatabaseFile | A user-specified name for the program database (PDB) that the linker creates. The default file name for the PDB has the base name of the OutputFile and the extension .pdb.
ProgramFileName | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Sources | The list of files to combine into the output file.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Symbols | Symbols to add to the symbol table.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


Debug Property

NAnt SDK Documentation - v0.91

LinkTask.Debug Property

Create debugging information for the .exe file or DLL. The default is false.

[Visual Basic]
Public Property Debug As Boolean
[C#]
public bool Debug {get; set;}

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


DelayLoadedDlls Property

NAnt SDK Documentation - v0.91

LinkTask.DelayLoadedDlls Property

Specified DLLs for delay loading.

[Visual Basic]
<BuildElement(Name:="delayloaded", Required:=False, ProcessXml:=True)>
Public Property DelayLoadedDlls As FileSet
[C#]
[BuildElement(Name="delayloaded", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet DelayLoadedDlls {get; set;}

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


EmbeddedResources Property

NAnt SDK Documentation - v0.91

LinkTask.EmbeddedResources Property

Embed the specified resources into this assembly.

[Visual Basic]
<BuildElement(Name:="embeddedresources", Required:=False, ProcessXml:=True)>
Public Property EmbeddedResources As FileSet
[C#]
[BuildElement(Name="embeddedresources", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet EmbeddedResources {get; set;}

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


IgnoreLibraries Property

NAnt SDK Documentation - v0.91

LinkTask.IgnoreLibraries Property

Names of libraries that you want the linker to ignore when it resolves external references.

[Visual Basic]
<BuildElementCollection(ChildElementName:="library", ElementType:=null, Name:="ignorelibraries", Required:=False, ProcessXml:=True)>
Public Property IgnoreLibraries As LibraryCollection
[C#]
[BuildElementCollection(ChildElementName="library", ElementType=null, Name="ignorelibraries", Required=False, ProcessXml=True)]
public NAnt.VisualCpp.Types.LibraryCollection IgnoreLibraries {get; set;}

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


LibDirs Property

NAnt SDK Documentation - v0.91

LinkTask.LibDirs Property

The list of additional library directories to search.

[Visual Basic]
<BuildElement(Name:="libdirs", Required:=False, ProcessXml:=True)>
Public Property LibDirs As FileSet
[C#]
[BuildElement(Name="libdirs", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet LibDirs {get; set;}

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


ModuleDefinition Property

NAnt SDK Documentation - v0.91

LinkTask.ModuleDefinition Property

The name of a module-definition file (.def) to be passed to the linker.

[Visual Basic]
<TaskAttribute(Name:="moduledefinition", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property ModuleDefinition As FileInfo
[C#]
[TaskAttribute(Name="moduledefinition", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo ModuleDefinition {get; set;}

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


Modules Property

NAnt SDK Documentation - v0.91

LinkTask.Modules Property

Link the specified modules into this assembly.

[Visual Basic]
<BuildElement(Name:="modules", Required:=False, ProcessXml:=True)>
Public Property Modules As FileSet
[C#]
[BuildElement(Name="modules", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet Modules {get; set;}

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


Options Property

NAnt SDK Documentation - v0.91

LinkTask.Options Property

Options to pass to the compiler.

[Visual Basic]
<TaskAttribute(Name:="options", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Options As String
[C#]
[TaskAttribute(Name="options", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Options {get; set;}

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


OutputFile Property

NAnt SDK Documentation - v0.91

LinkTask.OutputFile Property

The output file.

[Visual Basic]
<TaskAttribute(Name:="output", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property OutputFile As FileInfo
[C#]
[TaskAttribute(Name="output", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo OutputFile {get; set;}

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

LinkTask.ProgramArguments Property

Gets the command-line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

Property Value

The command-line arguments for the external program.

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


ProgramDatabaseFile Property

NAnt SDK Documentation - v0.91

LinkTask.ProgramDatabaseFile Property

A user-specified name for the program database (PDB) that the linker creates. The default file name for the PDB has the base name of the OutputFile and the extension .pdb.

[Visual Basic]
<TaskAttribute(Name:="pdbfile", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property ProgramDatabaseFile As FileInfo
[C#]
[TaskAttribute(Name="pdbfile", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo ProgramDatabaseFile {get; set;}

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


ProgramFileName Property

NAnt SDK Documentation - v0.91

LinkTask.ProgramFileName Property

Gets the filename of the external program to start.

[Visual Basic]
Overrides Public ReadOnly Property ProgramFileName As String
[C#]
public override string ProgramFileName {get;}

Property Value

The filename of the external program.

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


Sources Property

NAnt SDK Documentation - v0.91

LinkTask.Sources Property

The list of files to combine into the output file.

[Visual Basic]
<BuildElement(Name:="sources", Required:=False, ProcessXml:=True)>
Public Property Sources As FileSet
[C#]
[BuildElement(Name="sources", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet Sources {get; set;}

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


Symbols Property

NAnt SDK Documentation - v0.91

LinkTask.Symbols Property

Symbols to add to the symbol table.

[Visual Basic]
<BuildElementCollection(ChildElementName:="symbol", ElementType:=null, Name:="symbols", Required:=False, ProcessXml:=True)>
Public Property Symbols As SymbolCollection
[C#]
[BuildElementCollection(ChildElementName="symbol", ElementType=null, Name="symbols", Required=False, ProcessXml=True)]
public NAnt.VisualCpp.Types.SymbolCollection Symbols {get; set;}

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


LinkTask Methods

The methods of the LinkTask class are listed below. For a complete list of LinkTask class members, see the LinkTask Members topic.

Public Static (Shared) Methods

QuoteArgumentValue Quotes an argument value and duplicates trailing backslahes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Links the sources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsLinking | Determines if the output needs linking.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


LinkTask.ExecuteTask Method

Links the sources.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


LinkTask.NeedsLinking Method

Determines if the output needs linking.

[Visual Basic]
Overridable Protected Function NeedsLinking() As Boolean
[C#]
protected virtual bool NeedsLinking();

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


LinkTask.QuoteArgumentValue Method

Quotes an argument value and duplicates trailing backslahes.

[Visual Basic]
Public Shared Function QuoteArgumentValue( _
ByVal value As String _
) As String
[C#]
public static string QuoteArgumentValue(
string value
);

Parameters

value
The argument value to quote.

Return Value

The quotes argument value.

See Also

LinkTask Class | NAnt.VisualCpp.Tasks Namespace


McTask Class

Compiles messages using mc.exe, Microsoft's Win32 message compiler.

For a list of all members of this type, see McTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.VisualCpp.Tasks.McTask

[Visual Basic]
<TaskName(Name:="mc")>
Public Class McTask
Inherits ExternalProgramBase
[C#]
[TaskName(Name="mc")]
public class McTask : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Compile text.mc using the default options.

            <mc mcfile="text.mc"/>

Compile text.mc, passing a path to store the header, the rc file and some additonal options.

            <mc mcfile="text.mc" headerpath=".\build" rcpath=".\build" options="-v -c -u"/>

Requirements

Namespace: NAnt.VisualCpp.Tasks

Assembly: NAnt.VisualCppTasks (in NAnt.VisualCppTasks.dll)

See Also

McTask Members | NAnt.VisualCpp.Tasks Namespace


McTask Members

McTask overview

Public Instance Constructors

McTask Constructor Initializes a new instance of the McTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
HeaderPath | Path to store header file. The default is the project base directory.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
McFile | Input filename.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Options | Options to pass to the compiler.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RCPath | Path to store RC file. The default is the project base directory.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Compiles the sources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

McTask Class | NAnt.VisualCpp.Tasks Namespace


McTask Constructor

Initializes a new instance of the McTask class.

[Visual Basic]
Public Sub New()
[C#]
public McTask();

See Also

McTask Class | NAnt.VisualCpp.Tasks Namespace


McTask Properties

The properties of the McTask class are listed below. For a complete list of McTask class members, see the McTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
HeaderPath | Path to store header file. The default is the project base directory.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
McFile | Input filename.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Options | Options to pass to the compiler.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RCPath | Path to store RC file. The default is the project base directory.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

McTask Class | NAnt.VisualCpp.Tasks Namespace


HeaderPath Property

NAnt SDK Documentation - v0.91

McTask.HeaderPath Property

Path to store header file. The default is the project base directory.

[Visual Basic]
<TaskAttribute(Name:="headerpath", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property HeaderPath As DirectoryInfo
[C#]
[TaskAttribute(Name="headerpath", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.DirectoryInfo HeaderPath {get; set;}

See Also

McTask Class | NAnt.VisualCpp.Tasks Namespace


McFile Property

NAnt SDK Documentation - v0.91

McTask.McFile Property

Input filename.

[Visual Basic]
<TaskAttribute(Name:="mcfile", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property McFile As FileInfo
[C#]
[TaskAttribute(Name="mcfile", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo McFile {get; set;}

See Also

McTask Class | NAnt.VisualCpp.Tasks Namespace


Options Property

NAnt SDK Documentation - v0.91

McTask.Options Property

Options to pass to the compiler.

[Visual Basic]
<TaskAttribute(Name:="options", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Options As String
[C#]
[TaskAttribute(Name="options", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Options {get; set;}

See Also

McTask Class | NAnt.VisualCpp.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

McTask.ProgramArguments Property

Gets the command-line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

Property Value

The command-line arguments for the external program.

See Also

McTask Class | NAnt.VisualCpp.Tasks Namespace


ProgramFileName Property

NAnt SDK Documentation - v0.91

McTask.ProgramFileName Property

Gets the filename of the external program to start.

[Visual Basic]
Overrides Public ReadOnly Property ProgramFileName As String
[C#]
public override string ProgramFileName {get;}

Property Value

The filename of the external program.

See Also

McTask Class | NAnt.VisualCpp.Tasks Namespace


RCPath Property

NAnt SDK Documentation - v0.91

McTask.RCPath Property

Path to store RC file. The default is the project base directory.

[Visual Basic]
<TaskAttribute(Name:="rcpath", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property RCPath As DirectoryInfo
[C#]
[TaskAttribute(Name="rcpath", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.DirectoryInfo RCPath {get; set;}

See Also

McTask Class | NAnt.VisualCpp.Tasks Namespace


McTask Methods

The methods of the McTask class are listed below. For a complete list of McTask class members, see the McTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Compiles the sources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

McTask Class | NAnt.VisualCpp.Tasks Namespace


McTask.ExecuteTask Method

Compiles the sources.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

McTask Class | NAnt.VisualCpp.Tasks Namespace


MidlTask Class

This tasks allows you to run MIDL.exe.

For a list of all members of this type, see MidlTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.VisualCpp.Tasks.MidlTask

[Visual Basic]
<TaskName(Name:="midl")>
Public Class MidlTask
Inherits ExternalProgramBase
[C#]
[TaskName(Name="midl")]
public class MidlTask : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This task only supports a small subset of the MIDL.EXE command line switches, but you can use the options element to specify any other unsupported commands you want to specify.

Example

            <midl
                env="win32"
                Oi="cf"
                tlb="${outputdir}\TempAtl.tlb"
                header="${outputdir}\TempAtl.h"
                iid="${outputdir}\TempAtl_i.c"
                proxy="${outputdir}\TempAtl_p.c"
                filename="TempAtl.idl"
            >
                <defines>
                    <define name="_DEBUG"/>
                    <define name="WIN32" value="1"/>
                </defines>
                <options>
                    <option name="/mktyplib203"/>
                    <option name="/error" value="allocation"/>
                </options>
            </midl>

Requirements

Namespace: NAnt.VisualCpp.Tasks

Assembly: NAnt.VisualCppTasks (in NAnt.VisualCppTasks.dll)

See Also

MidlTask Members | NAnt.VisualCpp.Tasks Namespace


MidlTask Members

MidlTask overview

Public Instance Constructors

MidlTask Constructor Initializes a new instance of the MidlTask class.

Public Instance Properties

Acf | The /acf switch allows the user to supply an explicit ACF file name. The switch also allows the use of different interface names in the IDL and ACF files.
Align | The /align switch is functionally the same as the MIDL /Zp option and is recognized by the MIDL compiler solely for backward compatibility with MkTypLib.
AppConfig | The /app_config switch selects application-configuration mode, which allows you to use some ACF keywords in the IDL file. With this MIDL compiler switch, you can omit the ACF and specify an interface in a single IDL file.
Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
Char | The /char switch helps to ensure that the MIDL compiler and C compiler operate together correctly for all char and small types.
Client | The /client switch directs the MIDL compiler to generate client-side C source files for an RPC interface
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CStub | The /cstub switch specifies the name of the client stub file for an RPC interface.
Defines | Macro definitions to pass to mdil.exe. Each entry will generate a /D
DllData | Specifies the file name for the generated dlldata file for a proxy DLL. The default file name Dlldata.c is used if DllData is not specified.
Env | The /env switch selects the environment in which the application runs.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
Filename | Name of .IDL file to process.
Header | Specifies the name of the header file.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
Iid | Specifies the name of the interface identifier file for a COM interface, overriding the default name obtained by adding _i.c to the IDL file name.
IncludeDirs | The list of directories in which to search for include files.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Oi | The /Oi switch directs the MIDL compiler to use a fully-interpreted marshaling method. The /Oic and /Oicf switches provide additional performance enhancements.
Options | Additional options to pass to midl.exe.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName | Filename of program to execute
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Proxy | Specifies the name of the interface proxy file for a COM interface.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
Tlb | Specifies a file name for the type library generated by the MIDL compiler.
Undefines | Macro undefines (/U) to pass to mdil.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | This is where the work is done.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


MidlTask Constructor

Initializes a new instance of the MidlTask class.

[Visual Basic]
Public Sub New()
[C#]
public MidlTask();

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


MidlTask Properties

The properties of the MidlTask class are listed below. For a complete list of MidlTask class members, see the MidlTask Members topic.

Public Instance Properties

Acf | The /acf switch allows the user to supply an explicit ACF file name. The switch also allows the use of different interface names in the IDL and ACF files.
Align | The /align switch is functionally the same as the MIDL /Zp option and is recognized by the MIDL compiler solely for backward compatibility with MkTypLib.
AppConfig | The /app_config switch selects application-configuration mode, which allows you to use some ACF keywords in the IDL file. With this MIDL compiler switch, you can omit the ACF and specify an interface in a single IDL file.
Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
Char | The /char switch helps to ensure that the MIDL compiler and C compiler operate together correctly for all char and small types.
Client | The /client switch directs the MIDL compiler to generate client-side C source files for an RPC interface
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
CStub | The /cstub switch specifies the name of the client stub file for an RPC interface.
Defines | Macro definitions to pass to mdil.exe. Each entry will generate a /D
DllData | Specifies the file name for the generated dlldata file for a proxy DLL. The default file name Dlldata.c is used if DllData is not specified.
Env | The /env switch selects the environment in which the application runs.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
Filename | Name of .IDL file to process.
Header | Specifies the name of the header file.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
Iid | Specifies the name of the interface identifier file for a COM interface, overriding the default name obtained by adding _i.c to the IDL file name.
IncludeDirs | The list of directories in which to search for include files.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Oi | The /Oi switch directs the MIDL compiler to use a fully-interpreted marshaling method. The /Oic and /Oicf switches provide additional performance enhancements.
Options | Additional options to pass to midl.exe.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName | Filename of program to execute
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Proxy | Specifies the name of the interface proxy file for a COM interface.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
Tlb | Specifies a file name for the type library generated by the MIDL compiler.
Undefines | Macro undefines (/U) to pass to mdil.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


Acf Property

NAnt SDK Documentation - v0.91

MidlTask.Acf Property

The /acf switch allows the user to supply an explicit ACF file name. The switch also allows the use of different interface names in the IDL and ACF files.

[Visual Basic]
<TaskAttribute(Name:="acf", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Acf As String
[C#]
[TaskAttribute(Name="acf", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Acf {get; set;}

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


Align Property

NAnt SDK Documentation - v0.91

MidlTask.Align Property

The /align switch is functionally the same as the MIDL /Zp option and is recognized by the MIDL compiler solely for backward compatibility with MkTypLib.

[Visual Basic]
<TaskAttribute(Name:="align", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Align As String
[C#]
[TaskAttribute(Name="align", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Align {get; set;}

Remarks

The alignment value can be 1, 2, 4, or 8.

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


AppConfig Property

NAnt SDK Documentation - v0.91

MidlTask.AppConfig Property

The /app_config switch selects application-configuration mode, which allows you to use some ACF keywords in the IDL file. With this MIDL compiler switch, you can omit the ACF and specify an interface in a single IDL file.

[Visual Basic]
<TaskAttribute(Name:="app_config", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property AppConfig As Boolean
[C#]
[TaskAttribute(Name="app_config", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool AppConfig {get; set;}

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


Char Property

NAnt SDK Documentation - v0.91

MidlTask.Char Property

The /char switch helps to ensure that the MIDL compiler and C compiler operate together correctly for all char and small types.

[Visual Basic]
<TaskAttribute(Name:="char", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Char As String
[C#]
[TaskAttribute(Name="char", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Char {get; set;}

Remarks

Can be one of signed | unsigned | ascii7

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


Client Property

NAnt SDK Documentation - v0.91

MidlTask.Client Property

The /client switch directs the MIDL compiler to generate client-side C source files for an RPC interface

[Visual Basic]
<TaskAttribute(Name:="client", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Client As String
[C#]
[TaskAttribute(Name="client", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Client {get; set;}

Remarks

can be one of stub | none

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


CStub Property

NAnt SDK Documentation - v0.91

MidlTask.CStub Property

The /cstub switch specifies the name of the client stub file for an RPC interface.

[Visual Basic]
<TaskAttribute(Name:="cstub", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property CStub As String
[C#]
[TaskAttribute(Name="cstub", Required=False, ExpandProperties=True, ProcessXml=True)]
public string CStub {get; set;}

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


Defines Property

NAnt SDK Documentation - v0.91

MidlTask.Defines Property

Macro definitions to pass to mdil.exe. Each entry will generate a /D

[Visual Basic]
<BuildElementCollection(ChildElementName:="define", ElementType:=null, Name:="defines", Required:=False, ProcessXml:=True)>
Public ReadOnly Property Defines As OptionCollection
[C#]
[BuildElementCollection(ChildElementName="define", ElementType=null, Name="defines", Required=False, ProcessXml=True)]
public NAnt.Core.Types.OptionCollection Defines {get;}

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


DllData Property

NAnt SDK Documentation - v0.91

MidlTask.DllData Property

Specifies the file name for the generated dlldata file for a proxy DLL. The default file name Dlldata.c is used if DllData is not specified.

[Visual Basic]
<TaskAttribute(Name:="dlldata", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property DllData As FileInfo
[C#]
[TaskAttribute(Name="dlldata", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo DllData {get; set;}

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


Env Property

NAnt SDK Documentation - v0.91

MidlTask.Env Property

The /env switch selects the environment in which the application runs.

[Visual Basic]
<TaskAttribute(Name:="env", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Env As String
[C#]
[TaskAttribute(Name="env", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Env {get; set;}

Remarks

It can take the values win32 and win64

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


Filename Property

NAnt SDK Documentation - v0.91

MidlTask.Filename Property

Name of .IDL file to process.

[Visual Basic]
<TaskAttribute(Name:="filename", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property Filename As FileInfo
[C#]
[TaskAttribute(Name="filename", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo Filename {get; set;}

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


Header Property

NAnt SDK Documentation - v0.91

MidlTask.Header Property

Specifies the name of the header file.

[Visual Basic]
<TaskAttribute(Name:="header", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Header As FileInfo
[C#]
[TaskAttribute(Name="header", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo Header {get; set;}

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


Iid Property

NAnt SDK Documentation - v0.91

MidlTask.Iid Property

Specifies the name of the interface identifier file for a COM interface, overriding the default name obtained by adding _i.c to the IDL file name.

[Visual Basic]
<TaskAttribute(Name:="iid", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Iid As FileInfo
[C#]
[TaskAttribute(Name="iid", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo Iid {get; set;}

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


IncludeDirs Property

NAnt SDK Documentation - v0.91

MidlTask.IncludeDirs Property

The list of directories in which to search for include files.

[Visual Basic]
<BuildElement(Name:="includedirs", Required:=False, ProcessXml:=True)>
Public Property IncludeDirs As FileSet
[C#]
[BuildElement(Name="includedirs", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet IncludeDirs {get; set;}

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


Oi Property

NAnt SDK Documentation - v0.91

MidlTask.Oi Property

The /Oi switch directs the MIDL compiler to use a fully-interpreted marshaling method. The /Oic and /Oicf switches provide additional performance enhancements.

[Visual Basic]
<TaskAttribute(Name:="Oi", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Oi As String
[C#]
[TaskAttribute(Name="Oi", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Oi {get; set;}

Remarks

If you specify the Oi attribute, you must set it to one of the values: - Oi="" - Oi="c" - Oi="f" - Oi="cf"

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


Options Property

NAnt SDK Documentation - v0.91

MidlTask.Options Property

Additional options to pass to midl.exe.

[Visual Basic]
<BuildElementCollection(ChildElementName:="option", ElementType:=null, Name:="options", Required:=False, ProcessXml:=True)>
Public ReadOnly Property Options As OptionCollection
[C#]
[BuildElementCollection(ChildElementName="option", ElementType=null, Name="options", Required=False, ProcessXml=True)]
public NAnt.Core.Types.OptionCollection Options {get;}

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

MidlTask.ProgramArguments Property

Gets the command-line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

Property Value

The command-line arguments for the external program.

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


ProgramFileName Property

NAnt SDK Documentation - v0.91

MidlTask.ProgramFileName Property

Filename of program to execute

[Visual Basic]
Overrides Public ReadOnly Property ProgramFileName As String
[C#]
public override string ProgramFileName {get;}

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


Proxy Property

NAnt SDK Documentation - v0.91

MidlTask.Proxy Property

Specifies the name of the interface proxy file for a COM interface.

[Visual Basic]
<TaskAttribute(Name:="proxy", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Proxy As FileInfo
[C#]
[TaskAttribute(Name="proxy", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo Proxy {get; set;}

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


Tlb Property

NAnt SDK Documentation - v0.91

MidlTask.Tlb Property

Specifies a file name for the type library generated by the MIDL compiler.

[Visual Basic]
<TaskAttribute(Name:="tlb", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Tlb As FileInfo
[C#]
[TaskAttribute(Name="tlb", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo Tlb {get; set;}

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


Undefines Property

NAnt SDK Documentation - v0.91

MidlTask.Undefines Property

Macro undefines (/U) to pass to mdil.

[Visual Basic]
<BuildElementCollection(ChildElementName:="undefine", ElementType:=null, Name:="undefines", Required:=False, ProcessXml:=True)>
Public ReadOnly Property Undefines As OptionCollection
[C#]
[BuildElementCollection(ChildElementName="undefine", ElementType=null, Name="undefines", Required=False, ProcessXml=True)]
public NAnt.Core.Types.OptionCollection Undefines {get;}

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


MidlTask Methods

The methods of the MidlTask class are listed below. For a complete list of MidlTask class members, see the MidlTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | This is where the work is done.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


MidlTask.ExecuteTask Method

This is where the work is done.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

MidlTask Class | NAnt.VisualCpp.Tasks Namespace


RcTask Class

Compiles resources using rc.exe, Microsoft's Win32 resource compiler.

For a list of all members of this type, see RcTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.VisualCpp.Tasks.RcTask

[Visual Basic]
<TaskName(Name:="rc")>
Public Class RcTask
Inherits ExternalProgramBase
[C#]
[TaskName(Name="rc")]
public class RcTask : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Compile text.rc to text.res using the default options.

            <rc rcfile="text.rc" output="text.res" />

Compile text.rc, passing an additional option.

            <rc rcfile="text.rc" options="/r"/>

Requirements

Namespace: NAnt.VisualCpp.Tasks

Assembly: NAnt.VisualCppTasks (in NAnt.VisualCppTasks.dll)

See Also

RcTask Members | NAnt.VisualCpp.Tasks Namespace


RcTask Members

RcTask overview

Public Instance Constructors

RcTask Constructor Initializes a new instance of the RcTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Defines | Macro definitions to pass to rc.exe. Each entry will generate a /d
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IncludeDirs | The list of directories in which to search for include files.
LangId | Default language ID.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Options | Options to pass to the compiler.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | Output file.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Arguments of program to execute
ProgramFileName | Filename of program to execute
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RcFile | The resource file to compile.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Compile the resource file
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines if the resource need compiling.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

RcTask Class | NAnt.VisualCpp.Tasks Namespace


RcTask Constructor

Initializes a new instance of the RcTask class.

[Visual Basic]
Public Sub New()
[C#]
public RcTask();

See Also

RcTask Class | NAnt.VisualCpp.Tasks Namespace


RcTask Properties

The properties of the RcTask class are listed below. For a complete list of RcTask class members, see the RcTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
Defines | Macro definitions to pass to rc.exe. Each entry will generate a /d
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IncludeDirs | The list of directories in which to search for include files.
LangId | Default language ID.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Options | Options to pass to the compiler.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | Output file.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Arguments of program to execute
ProgramFileName | Filename of program to execute
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
RcFile | The resource file to compile.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

RcTask Class | NAnt.VisualCpp.Tasks Namespace


Defines Property

NAnt SDK Documentation - v0.91

RcTask.Defines Property

Macro definitions to pass to rc.exe. Each entry will generate a /d

[Visual Basic]
<BuildElementCollection(ChildElementName:="define", ElementType:=null, Name:="defines", Required:=False, ProcessXml:=True)>
Public ReadOnly Property Defines As OptionCollection
[C#]
[BuildElementCollection(ChildElementName="define", ElementType=null, Name="defines", Required=False, ProcessXml=True)]
public NAnt.Core.Types.OptionCollection Defines {get;}

See Also

RcTask Class | NAnt.VisualCpp.Tasks Namespace


IncludeDirs Property

NAnt SDK Documentation - v0.91

RcTask.IncludeDirs Property

The list of directories in which to search for include files.

[Visual Basic]
<BuildElement(Name:="includedirs", Required:=False, ProcessXml:=True)>
Public Property IncludeDirs As FileSet
[C#]
[BuildElement(Name="includedirs", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet IncludeDirs {get; set;}

See Also

RcTask Class | NAnt.VisualCpp.Tasks Namespace


LangId Property

NAnt SDK Documentation - v0.91

RcTask.LangId Property

Default language ID.

[Visual Basic]
<TaskAttribute(Name:="langid", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property LangId As Integer
[C#]
[TaskAttribute(Name="langid", Required=False, ExpandProperties=True, ProcessXml=True)]
public int LangId {get; set;}

See Also

RcTask Class | NAnt.VisualCpp.Tasks Namespace


Options Property

NAnt SDK Documentation - v0.91

RcTask.Options Property

Options to pass to the compiler.

[Visual Basic]
<TaskAttribute(Name:="options", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Options As String
[C#]
[TaskAttribute(Name="options", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Options {get; set;}

See Also

RcTask Class | NAnt.VisualCpp.Tasks Namespace


OutputFile Property

NAnt SDK Documentation - v0.91

RcTask.OutputFile Property

Output file.

[Visual Basic]
<TaskAttribute(Name:="output", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property OutputFile As FileInfo
[C#]
[TaskAttribute(Name="output", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo OutputFile {get; set;}

See Also

RcTask Class | NAnt.VisualCpp.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

RcTask.ProgramArguments Property

Arguments of program to execute

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

See Also

RcTask Class | NAnt.VisualCpp.Tasks Namespace


ProgramFileName Property

NAnt SDK Documentation - v0.91

RcTask.ProgramFileName Property

Filename of program to execute

[Visual Basic]
Overrides Public ReadOnly Property ProgramFileName As String
[C#]
public override string ProgramFileName {get;}

See Also

RcTask Class | NAnt.VisualCpp.Tasks Namespace


RcFile Property

NAnt SDK Documentation - v0.91

RcTask.RcFile Property

The resource file to compile.

[Visual Basic]
<TaskAttribute(Name:="rcfile", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property RcFile As FileInfo
[C#]
[TaskAttribute(Name="rcfile", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo RcFile {get; set;}

See Also

RcTask Class | NAnt.VisualCpp.Tasks Namespace


RcTask Methods

The methods of the RcTask class are listed below. For a complete list of RcTask class members, see the RcTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Compile the resource file
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines if the resource need compiling.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

RcTask Class | NAnt.VisualCpp.Tasks Namespace


RcTask.ExecuteTask Method

Compile the resource file

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

RcTask Class | NAnt.VisualCpp.Tasks Namespace


RcTask.NeedsCompiling Method

Determines if the resource need compiling.

[Visual Basic]
Overridable Protected Function NeedsCompiling() As Boolean
[C#]
protected virtual bool NeedsCompiling();

See Also

RcTask Class | NAnt.VisualCpp.Tasks Namespace


NAnt.VisualCpp.Types

NAnt SDK Documentation - v0.91

NAnt.VisualCpp.Types Namespace

Namespace hierarchy

Classes

Class | Description
Library | Represents a library.
LibraryCollection | Contains a collection of Library elements.
LibraryEnumerator | Enumerates the Library elements of a LibraryCollection.
Symbol | Represents a symbol.
SymbolCollection | Contains a collection of Symbol elements.
SymbolEnumerator | Enumerates the Symbol elements of a SymbolCollection.

Enumerations

Enumeration | Description
CharacterSet | Defines the character sets that can be used by the C++ compiler.


CharacterSet Enumeration

Defines the character sets that can be used by the C++ compiler.

[Visual Basic]
<Serializable>
Public Enum CharacterSet
[C#]
[Serializable]
public enum CharacterSet

Members

Member Name | Description
NotSet | Have the compiler determine the character set.
Unicode | Unicode character set.
MultiByte | Multi-byte character set.

Requirements

Namespace: NAnt.VisualCpp.Types

Assembly: NAnt.VisualCppTasks (in NAnt.VisualCppTasks.dll)

See Also

NAnt.VisualCpp.Types Namespace


Library Class

Represents a library.

For a list of all members of this type, see Library Members.

System.Object
NAnt.Core.Element
NAnt.VisualCpp.Types.Library

[Visual Basic]
Public Class Library
Inherits Element
[C#]
public class Library : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VisualCpp.Types

Assembly: NAnt.VisualCppTasks (in NAnt.VisualCppTasks.dll)

See Also

Library Members | NAnt.VisualCpp.Types Namespace


Library Members

Library overview

Public Instance Constructors

Library Overloaded. Initializes a new instance of the Library class.

Public Instance Properties

IfDefined | If true then the element will be processed; otherwise, skipped. The default is true.
LibraryName | The name of the library.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | If true then the element will be skipped; otherwise, processed. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Library Class | NAnt.VisualCpp.Types Namespace


Library Constructor

Initializes a new instance of the Library class.

Overload List

Initializes a new instance of the Library class.

public Library();

Initializes a new instance of the Library class with the specified name.

public Library(string);

See Also

Library Class | NAnt.VisualCpp.Types Namespace


Library Constructor ()

Initializes a new instance of the Library class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Library();

See Also

Library Class | NAnt.VisualCpp.Types Namespace | Library Constructor Overload List


Library Constructor (String)

Initializes a new instance of the Library class with the specified name.

[Visual Basic]
Overloads Public Sub New( _
ByVal name As String _
)
[C#]
public Library(
string name
);

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing in Visual Basic).

See Also

Library Class | NAnt.VisualCpp.Types Namespace | Library Constructor Overload List


Library Properties

The properties of the Library class are listed below. For a complete list of Library class members, see the Library Members topic.

Public Instance Properties

IfDefined | If true then the element will be processed; otherwise, skipped. The default is true.
LibraryName | The name of the library.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | If true then the element will be skipped; otherwise, processed. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

Library Class | NAnt.VisualCpp.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

Library.IfDefined Property

If true then the element will be processed; otherwise, skipped. The default is true.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="if", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property IfDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="if", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool IfDefined {get; set;}

See Also

Library Class | NAnt.VisualCpp.Types Namespace


LibraryName Property

NAnt SDK Documentation - v0.91

Library.LibraryName Property

The name of the library.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="name", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property LibraryName As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="name", Required=True, ExpandProperties=True, ProcessXml=True)]
public string LibraryName {get; set;}

See Also

Library Class | NAnt.VisualCpp.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

Library.UnlessDefined Property

If true then the element will be skipped; otherwise, processed. The default is false.

[Visual Basic]
<TaskAttribute(Name:="unless", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property UnlessDefined As Boolean
[C#]
[TaskAttribute(Name="unless", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool UnlessDefined {get; set;}

See Also

Library Class | NAnt.VisualCpp.Types Namespace


LibraryCollection Class

Contains a collection of Library elements.

For a list of all members of this type, see LibraryCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.VisualCpp.Types.LibraryCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class LibraryCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class LibraryCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VisualCpp.Types

Assembly: NAnt.VisualCppTasks (in NAnt.VisualCppTasks.dll)

See Also

LibraryCollection Members | NAnt.VisualCpp.Types Namespace


LibraryCollection Members

LibraryCollection overview

Public Instance Constructors

LibraryCollection Overloaded. Initializes a new instance of the LibraryCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a Library to the end of the collection.
AddRange | Overloaded. Adds the elements of a Library array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a Library is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified Library object in the collection.
Insert | Inserts a Library into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

LibraryCollection Class | NAnt.VisualCpp.Types Namespace


LibraryCollection Constructor

Initializes a new instance of the LibraryCollection class.

Overload List

Initializes a new instance of the LibraryCollection class.

public LibraryCollection();

Initializes a new instance of the LibraryCollection class with the specified array of Library instances.

public LibraryCollection(Library[]);

Initializes a new instance of the LibraryCollection class with the specified LibraryCollection instance.

public LibraryCollection(LibraryCollection);

See Also

LibraryCollection Class | NAnt.VisualCpp.Types Namespace


LibraryCollection Constructor ()

Initializes a new instance of the LibraryCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public LibraryCollection();

See Also

LibraryCollection Class | NAnt.VisualCpp.Types Namespace | LibraryCollection Constructor Overload List


LibraryCollection Constructor (LibraryCollection)

Initializes a new instance of the LibraryCollection class with the specified LibraryCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As LibraryCollection _
)
[C#]
public LibraryCollection(
LibraryCollection value
);

See Also

LibraryCollection Class | NAnt.VisualCpp.Types Namespace | LibraryCollection Constructor Overload List


LibraryCollection Constructor (Library[])

Initializes a new instance of the LibraryCollection class with the specified array of Library instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As Library() _
)
[C#]
public LibraryCollection(
Library[] value
);

See Also

LibraryCollection Class | NAnt.VisualCpp.Types Namespace | LibraryCollection Constructor Overload List


LibraryCollection Properties

The properties of the LibraryCollection class are listed below. For a complete list of LibraryCollection class members, see the LibraryCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

LibraryCollection Class | NAnt.VisualCpp.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

LibraryCollection.Item Property

Gets or sets the element at the specified index.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As Library
[C#]
public Library this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

LibraryCollection Class | NAnt.VisualCpp.Types Namespace


LibraryCollection Methods

The methods of the LibraryCollection class are listed below. For a complete list of LibraryCollection class members, see the LibraryCollection Members topic.

Public Instance Methods

Add | Adds a Library to the end of the collection.
AddRange | Overloaded. Adds the elements of a Library array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a Library is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified Library object in the collection.
Insert | Inserts a Library into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

LibraryCollection Class | NAnt.VisualCpp.Types Namespace


LibraryCollection.Add Method

Adds a Library to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As Library _
) As Integer
[C#]
public int Add(
Library item
);

Parameters

item
The Library to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

LibraryCollection Class | NAnt.VisualCpp.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

LibraryCollection.AddRange Method

Adds the elements of a Library array to the end of the collection.

Overload List

Adds the elements of a Library array to the end of the collection.

public void AddRange(Library[]);

Adds the elements of a LibraryCollection to the end of the collection.

public void AddRange(LibraryCollection);

See Also

LibraryCollection Class | NAnt.VisualCpp.Types Namespace


LibraryCollection.AddRange Method (Library[])

Adds the elements of a Library array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As Library() _
)
[C#]
public void AddRange(
Library[] items
);

Parameters

items
The array of Library elements to be added to the end of the collection.

See Also

LibraryCollection Class | NAnt.VisualCpp.Types Namespace | LibraryCollection.AddRange Overload List


LibraryCollection.AddRange Method (LibraryCollection)

Adds the elements of a LibraryCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As LibraryCollection _
)
[C#]
public void AddRange(
LibraryCollection items
);

Parameters

items
The LibraryCollection to be added to the end of the collection.

See Also

LibraryCollection Class | NAnt.VisualCpp.Types Namespace | LibraryCollection.AddRange Overload List


LibraryCollection.Contains Method

Determines whether a Library is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal item As Library _
) As Boolean
[C#]
public bool Contains(
Library item
);

Parameters

item
The Library to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

LibraryCollection Class | NAnt.VisualCpp.Types Namespace


LibraryCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As Library(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
Library[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

LibraryCollection Class | NAnt.VisualCpp.Types Namespace


LibraryCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As LibraryEnumerator
[C#]
new public LibraryEnumerator GetEnumerator();

Return Value

A LibraryEnumerator for the entire collection.

See Also

LibraryCollection Class | NAnt.VisualCpp.Types Namespace


LibraryCollection.IndexOf Method

Retrieves the index of a specified Library object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As Library _
) As Integer
[C#]
public int IndexOf(
Library item
);

Parameters

item
The Library object for which the index is returned.

Return Value

The index of the specified Library. If the Library is not currently a member of the collection, it returns -1.

See Also

LibraryCollection Class | NAnt.VisualCpp.Types Namespace


LibraryCollection.Insert Method

Inserts a Library into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As Library _
)
[C#]
public void Insert(
int index,
Library item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The Library to insert.

See Also

LibraryCollection Class | NAnt.VisualCpp.Types Namespace


LibraryCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As Library _
)
[C#]
public void Remove(
Library item
);

Parameters

item
The Library to remove from the collection.

See Also

LibraryCollection Class | NAnt.VisualCpp.Types Namespace


LibraryEnumerator Class

Enumerates the Library elements of a LibraryCollection.

For a list of all members of this type, see LibraryEnumerator Members.

System.Object
NAnt.VisualCpp.Types.LibraryEnumerator

[Visual Basic]
Public Class LibraryEnumerator
Implements IEnumerator
[C#]
public class LibraryEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VisualCpp.Types

Assembly: NAnt.VisualCppTasks (in NAnt.VisualCppTasks.dll)

See Also

LibraryEnumerator Members | NAnt.VisualCpp.Types Namespace


LibraryEnumerator Members

LibraryEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LibraryEnumerator Class | NAnt.VisualCpp.Types Namespace


LibraryEnumerator Properties

The properties of the LibraryEnumerator class are listed below. For a complete list of LibraryEnumerator class members, see the LibraryEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

LibraryEnumerator Class | NAnt.VisualCpp.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

LibraryEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As Library
[C#]
public Library Current {get;}

See Also

LibraryEnumerator Class | NAnt.VisualCpp.Types Namespace


LibraryEnumerator Methods

The methods of the LibraryEnumerator class are listed below. For a complete list of LibraryEnumerator class members, see the LibraryEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LibraryEnumerator Class | NAnt.VisualCpp.Types Namespace


LibraryEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

LibraryEnumerator Class | NAnt.VisualCpp.Types Namespace


LibraryEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

LibraryEnumerator Class | NAnt.VisualCpp.Types Namespace


Symbol Class

Represents a symbol.

For a list of all members of this type, see Symbol Members.

System.Object
NAnt.Core.Element
NAnt.VisualCpp.Types.Symbol

[Visual Basic]
Public Class Symbol
Inherits Element
[C#]
public class Symbol : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VisualCpp.Types

Assembly: NAnt.VisualCppTasks (in NAnt.VisualCppTasks.dll)

See Also

Symbol Members | NAnt.VisualCpp.Types Namespace


Symbol Members

Symbol overview

Public Instance Constructors

Symbol Overloaded. Initializes a new instance of the Symbol class.

Public Instance Properties

IfDefined | If true then the element will be processed; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
SymbolName | The name of the symbol.
UnlessDefined | If true then the element will be skipped; otherwise, processed. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Symbol Class | NAnt.VisualCpp.Types Namespace


Symbol Constructor

Initializes a new instance of the Symbol class.

Overload List

Initializes a new instance of the Symbol class.

public Symbol();

Initializes a new instance of the Symbol class with the specified name.

public Symbol(string);

See Also

Symbol Class | NAnt.VisualCpp.Types Namespace


Symbol Constructor ()

Initializes a new instance of the Symbol class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Symbol();

See Also

Symbol Class | NAnt.VisualCpp.Types Namespace | Symbol Constructor Overload List


Symbol Constructor (String)

Initializes a new instance of the Symbol class with the specified name.

[Visual Basic]
Overloads Public Sub New( _
ByVal name As String _
)
[C#]
public Symbol(
string name
);

Exceptions

Exception Type | Condition
ArgumentNullException | name is a null reference (Nothing in Visual Basic).

See Also

Symbol Class | NAnt.VisualCpp.Types Namespace | Symbol Constructor Overload List


Symbol Properties

The properties of the Symbol class are listed below. For a complete list of Symbol class members, see the Symbol Members topic.

Public Instance Properties

IfDefined | If true then the element will be processed; otherwise, skipped. The default is true.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
SymbolName | The name of the symbol.
UnlessDefined | If true then the element will be skipped; otherwise, processed. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

Symbol Class | NAnt.VisualCpp.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

Symbol.IfDefined Property

If true then the element will be processed; otherwise, skipped. The default is true.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="if", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property IfDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="if", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool IfDefined {get; set;}

See Also

Symbol Class | NAnt.VisualCpp.Types Namespace


SymbolName Property

NAnt SDK Documentation - v0.91

Symbol.SymbolName Property

The name of the symbol.

[Visual Basic]
<StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null"), _ TaskAttribute(Name:="name", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property SymbolName As String
[C#]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
[TaskAttribute(Name="name", Required=True, ExpandProperties=True, ProcessXml=True)]
public string SymbolName {get; set;}

See Also

Symbol Class | NAnt.VisualCpp.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

Symbol.UnlessDefined Property

If true then the element will be skipped; otherwise, processed. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="unless", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property UnlessDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="unless", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool UnlessDefined {get; set;}

See Also

Symbol Class | NAnt.VisualCpp.Types Namespace


SymbolCollection Class

Contains a collection of Symbol elements.

For a list of all members of this type, see SymbolCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.VisualCpp.Types.SymbolCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class SymbolCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class SymbolCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VisualCpp.Types

Assembly: NAnt.VisualCppTasks (in NAnt.VisualCppTasks.dll)

See Also

SymbolCollection Members | NAnt.VisualCpp.Types Namespace


SymbolCollection Members

SymbolCollection overview

Public Instance Constructors

SymbolCollection Overloaded. Initializes a new instance of the SymbolCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a Symbol to the end of the collection.
AddRange | Overloaded. Adds the elements of a Symbol array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a Symbol is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified Symbol object in the collection.
Insert | Inserts a Symbol into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

SymbolCollection Class | NAnt.VisualCpp.Types Namespace


SymbolCollection Constructor

Initializes a new instance of the SymbolCollection class.

Overload List

Initializes a new instance of the SymbolCollection class.

public SymbolCollection();

Initializes a new instance of the SymbolCollection class with the specified array of Symbol instances.

public SymbolCollection(Symbol[]);

Initializes a new instance of the SymbolCollection class with the specified SymbolCollection instance.

public SymbolCollection(SymbolCollection);

See Also

SymbolCollection Class | NAnt.VisualCpp.Types Namespace


SymbolCollection Constructor ()

Initializes a new instance of the SymbolCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public SymbolCollection();

See Also

SymbolCollection Class | NAnt.VisualCpp.Types Namespace | SymbolCollection Constructor Overload List


SymbolCollection Constructor (SymbolCollection)

Initializes a new instance of the SymbolCollection class with the specified SymbolCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As SymbolCollection _
)
[C#]
public SymbolCollection(
SymbolCollection value
);

See Also

SymbolCollection Class | NAnt.VisualCpp.Types Namespace | SymbolCollection Constructor Overload List


SymbolCollection Constructor (Symbol[])

Initializes a new instance of the SymbolCollection class with the specified array of Symbol instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As Symbol() _
)
[C#]
public SymbolCollection(
Symbol[] value
);

See Also

SymbolCollection Class | NAnt.VisualCpp.Types Namespace | SymbolCollection Constructor Overload List


SymbolCollection Properties

The properties of the SymbolCollection class are listed below. For a complete list of SymbolCollection class members, see the SymbolCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

SymbolCollection Class | NAnt.VisualCpp.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

SymbolCollection.Item Property

Gets or sets the element at the specified index.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As Symbol
[C#]
public Symbol this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

SymbolCollection Class | NAnt.VisualCpp.Types Namespace


SymbolCollection Methods

The methods of the SymbolCollection class are listed below. For a complete list of SymbolCollection class members, see the SymbolCollection Members topic.

Public Instance Methods

Add | Adds a Symbol to the end of the collection.
AddRange | Overloaded. Adds the elements of a Symbol array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Determines whether a Symbol is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified Symbol object in the collection.
Insert | Inserts a Symbol into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

SymbolCollection Class | NAnt.VisualCpp.Types Namespace


SymbolCollection.Add Method

Adds a Symbol to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As Symbol _
) As Integer
[C#]
public int Add(
Symbol item
);

Parameters

item
The Symbol to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

SymbolCollection Class | NAnt.VisualCpp.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

SymbolCollection.AddRange Method

Adds the elements of a Symbol array to the end of the collection.

Overload List

Adds the elements of a Symbol array to the end of the collection.

public void AddRange(Symbol[]);

Adds the elements of a SymbolCollection to the end of the collection.

public void AddRange(SymbolCollection);

See Also

SymbolCollection Class | NAnt.VisualCpp.Types Namespace


SymbolCollection.AddRange Method (Symbol[])

Adds the elements of a Symbol array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As Symbol() _
)
[C#]
public void AddRange(
Symbol[] items
);

Parameters

items
The array of Symbol elements to be added to the end of the collection.

See Also

SymbolCollection Class | NAnt.VisualCpp.Types Namespace | SymbolCollection.AddRange Overload List


SymbolCollection.AddRange Method (SymbolCollection)

Adds the elements of a SymbolCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As SymbolCollection _
)
[C#]
public void AddRange(
SymbolCollection items
);

Parameters

items
The SymbolCollection to be added to the end of the collection.

See Also

SymbolCollection Class | NAnt.VisualCpp.Types Namespace | SymbolCollection.AddRange Overload List


SymbolCollection.Contains Method

Determines whether a Symbol is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal item As Symbol _
) As Boolean
[C#]
public bool Contains(
Symbol item
);

Parameters

item
The Symbol to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

SymbolCollection Class | NAnt.VisualCpp.Types Namespace


SymbolCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As Symbol(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
Symbol[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

SymbolCollection Class | NAnt.VisualCpp.Types Namespace


SymbolCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As SymbolEnumerator
[C#]
new public SymbolEnumerator GetEnumerator();

Return Value

A SymbolEnumerator for the entire collection.

See Also

SymbolCollection Class | NAnt.VisualCpp.Types Namespace


SymbolCollection.IndexOf Method

Retrieves the index of a specified Symbol object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As Symbol _
) As Integer
[C#]
public int IndexOf(
Symbol item
);

Parameters

item
The Symbol object for which the index is returned.

Return Value

The index of the specified Symbol. If the Symbol is not currently a member of the collection, it returns -1.

See Also

SymbolCollection Class | NAnt.VisualCpp.Types Namespace


SymbolCollection.Insert Method

Inserts a Symbol into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As Symbol _
)
[C#]
public void Insert(
int index,
Symbol item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The Symbol to insert.

See Also

SymbolCollection Class | NAnt.VisualCpp.Types Namespace


SymbolCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As Symbol _
)
[C#]
public void Remove(
Symbol item
);

Parameters

item
The Symbol to remove from the collection.

See Also

SymbolCollection Class | NAnt.VisualCpp.Types Namespace


SymbolEnumerator Class

Enumerates the Symbol elements of a SymbolCollection.

For a list of all members of this type, see SymbolEnumerator Members.

System.Object
NAnt.VisualCpp.Types.SymbolEnumerator

[Visual Basic]
Public Class SymbolEnumerator
Implements IEnumerator
[C#]
public class SymbolEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VisualCpp.Types

Assembly: NAnt.VisualCppTasks (in NAnt.VisualCppTasks.dll)

See Also

SymbolEnumerator Members | NAnt.VisualCpp.Types Namespace


SymbolEnumerator Members

SymbolEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SymbolEnumerator Class | NAnt.VisualCpp.Types Namespace


SymbolEnumerator Properties

The properties of the SymbolEnumerator class are listed below. For a complete list of SymbolEnumerator class members, see the SymbolEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

SymbolEnumerator Class | NAnt.VisualCpp.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

SymbolEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As Symbol
[C#]
public Symbol Current {get;}

See Also

SymbolEnumerator Class | NAnt.VisualCpp.Types Namespace


SymbolEnumerator Methods

The methods of the SymbolEnumerator class are listed below. For a complete list of SymbolEnumerator class members, see the SymbolEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SymbolEnumerator Class | NAnt.VisualCpp.Types Namespace


SymbolEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

SymbolEnumerator Class | NAnt.VisualCpp.Types Namespace


SymbolEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

SymbolEnumerator Class | NAnt.VisualCpp.Types Namespace


NAnt.VisualCpp.Util

NAnt SDK Documentation - v0.91

NAnt.VisualCpp.Util Namespace

Namespace hierarchy

Classes

Class | Description
ArgumentUtils | Groups a set of useful String manipulation methods for command-line arguments.

Enumerations

Enumeration | Description
BackslashProcessingMethod | Defines how to deal with backslashes in values of command line arguments.


ArgumentUtils Class

Groups a set of useful String manipulation methods for command-line arguments.

For a list of all members of this type, see ArgumentUtils Members.

System.Object
NAnt.VisualCpp.Util.ArgumentUtils

[Visual Basic]
Public Class ArgumentUtils
[C#]
public class ArgumentUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VisualCpp.Util

Assembly: NAnt.VisualCppTasks (in NAnt.VisualCppTasks.dll)

See Also

ArgumentUtils Members | NAnt.VisualCpp.Util Namespace


ArgumentUtils Members

ArgumentUtils overview

Public Static (Shared) Methods

CleanTrailingBackslash | Removes all the trailing backslashes from the input.
DuplicateTrailingBackslash | Duplicates the trailing backslash.
FixTrailingBackslash | Fixes the trailing backslash. This function replaces the trailing double backslashes with only one backslash. It also, removes the single trailing backslash.
ProcessTrailingBackslash | Performs backslash processing on the specified value using a given method.
QuoteArgumentValue | Quotes an argument value and processes backslashes using a given BackslashProcessingMethod.

Public Instance Constructors

ArgumentUtils Constructor Initializes a new instance of the ArgumentUtils class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArgumentUtils Class | NAnt.VisualCpp.Util Namespace


ArgumentUtils Constructor

Initializes a new instance of the ArgumentUtils class.

[Visual Basic]
Public Sub New()
[C#]
public ArgumentUtils();

See Also

ArgumentUtils Class | NAnt.VisualCpp.Util Namespace


ArgumentUtils Methods

The methods of the ArgumentUtils class are listed below. For a complete list of ArgumentUtils class members, see the ArgumentUtils Members topic.

Public Static (Shared) Methods

CleanTrailingBackslash | Removes all the trailing backslashes from the input.
DuplicateTrailingBackslash | Duplicates the trailing backslash.
FixTrailingBackslash | Fixes the trailing backslash. This function replaces the trailing double backslashes with only one backslash. It also, removes the single trailing backslash.
ProcessTrailingBackslash | Performs backslash processing on the specified value using a given method.
QuoteArgumentValue | Quotes an argument value and processes backslashes using a given BackslashProcessingMethod.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArgumentUtils Class | NAnt.VisualCpp.Util Namespace


ArgumentUtils.CleanTrailingBackslash Method

Removes all the trailing backslashes from the input.

[Visual Basic]
Public Shared Function CleanTrailingBackslash( _
ByVal value As String _
) As String
[C#]
public static string CleanTrailingBackslash(
string value
);

Parameters

value
The input string.

Return Value

The result string without trailing backslashes.

See Also

ArgumentUtils Class | NAnt.VisualCpp.Util Namespace


ArgumentUtils.DuplicateTrailingBackslash Method

Duplicates the trailing backslash.

[Visual Basic]
Public Shared Function DuplicateTrailingBackslash( _
ByVal value As String _
) As String
[C#]
public static string DuplicateTrailingBackslash(
string value
);

Parameters

value
The input string to check and duplicate the trailing backslash if necessary.

Return Value

The result string after being processed.

Remarks

Also duplicates trailing backslash in quoted value.

See Also

ArgumentUtils Class | NAnt.VisualCpp.Util Namespace


ArgumentUtils.FixTrailingBackslash Method

Fixes the trailing backslash. This function replaces the trailing double backslashes with only one backslash. It also, removes the single trailing backslash.

[Visual Basic]
Public Shared Function FixTrailingBackslash( _
ByVal value As String _
) As String
[C#]
public static string FixTrailingBackslash(
string value
);

Parameters

value
The input string.

Return Value

The result string after being processed.

See Also

ArgumentUtils Class | NAnt.VisualCpp.Util Namespace


ArgumentUtils.ProcessTrailingBackslash Method

Performs backslash processing on the specified value using a given method.

[Visual Basic]
Public Shared Function ProcessTrailingBackslash( _
ByVal value As String, _
ByVal processingMethod As BackslashProcessingMethod _
) As String
[C#]
public static string ProcessTrailingBackslash(
string value,
BackslashProcessingMethod processingMethod
);

Parameters

value
The String to process.
processingMethod
The BackslashProcessingMethod to use.

Return Value

value with backslashes processed using the given BackslashProcessingMethod.

See Also

ArgumentUtils Class | NAnt.VisualCpp.Util Namespace


ArgumentUtils.QuoteArgumentValue Method

Quotes an argument value and processes backslashes using a given BackslashProcessingMethod.

[Visual Basic]
Public Shared Function QuoteArgumentValue( _
ByVal value As String, _
ByVal processingMethod As BackslashProcessingMethod _
) As String
[C#]
public static string QuoteArgumentValue(
string value,
BackslashProcessingMethod processingMethod
);

Parameters

value
The argument value to quote.
processingMethod
The BackslashProcessingMethod to use.

Return Value

The quoted argument value.

See Also

ArgumentUtils Class | NAnt.VisualCpp.Util Namespace


BackslashProcessingMethod Enumeration

Defines how to deal with backslashes in values of command line arguments.

[Visual Basic]
<Serializable>
Public Enum BackslashProcessingMethod
[C#]
[Serializable]
public enum BackslashProcessingMethod

Members

Member Name | Description
None | Does not perform any processing on backslashes.
Duplicate | Duplicates the trailing backslash.
Fix | Fixes the trailing backslash by replaces trailing double backslashes with only one backslash and removing single trailing backslashes.
Clean | Removes all the trailing backslashes.

Requirements

Namespace: NAnt.VisualCpp.Util

Assembly: NAnt.VisualCppTasks (in NAnt.VisualCppTasks.dll)

See Also

NAnt.VisualCpp.Util Namespace


NAnt.VSNet

NAnt SDK Documentation - v0.91

NAnt.VSNet Namespace

Namespace hierarchy

Classes

Class | Description
AssemblyReferenceBase |
Configuration |
ConfigurationBase |
ConfigurationDictionary |
ConfigurationDictionaryEntry |
ConfigurationDictionaryEnumerator |
ConfigurationMap |
ConfigurationMapEntry |
ConfigurationMapEnumerator |
ConfigurationSettings |
CSharpProject |
FileReferenceBase |
GenericSolution | Supports grouping of individual projects, and treating them as a solution.
JSharpProject |
ManagedAssemblyReference |
ManagedProjectBase |
ManagedProjectReference |
ManagedWrapperReference |
ProjectBase | Base class for all project classes.
ProjectBaseCollection | Contains a collection of ProjectBase elements.
ProjectBaseEnumerator | Enumerates the ProjectBase elements of a ProjectBaseCollection.
ProjectEntry |
ProjectEntryCollection | Contains a collection of ProjectEntry elements.
ProjectEntryEnumerator | Enumerates the ProjectEntry elements of a ProjectEntryCollection.
ProjectReferenceBase |
ProjectSettings |
ReferenceBase |
ReferencesResolver |
Resource |
SolutionBase |
VBProject |
VcArgumentMap | A mapping from properties in the .vcproj file to command line arguments.
VcAssemblyReference |
VcConfigurationBase | A single build configuration for a Visual C++ project or for a specific file in the project.
VcFileConfiguration | Represents the configuration of a file.
VcProject | Visual C++ project.
VcProjectConfiguration | Represents a Visual C++ project configuration.
VcProjectReference |
VcWrapperReference |
WebDavClient |
WrapperReferenceBase |

Delegates

Delegate | Description
VcConfigurationBase.ExpansionHandler |

Enumerations

Enumeration | Description
BuildResult | Specifies the result of the build.
ManagedOutputType | Indentifies the different output types of a managed project.
ProductVersion |
ProjectLocation | Indentifies the physical location of a managed project.
ProjectType | Specifies the type of the project.
VcArgumentMap.ArgGroup | Allow us to assign an argument to a specific group.
VcProjectConfiguration.ConfigurationType | The type of output for a given configuration.


AssemblyReferenceBase Class

For a list of all members of this type, see AssemblyReferenceBase Members.

System.Object
NAnt.VSNet.ReferenceBase
NAnt.VSNet.FileReferenceBase
NAnt.VSNet.AssemblyReferenceBase
NAnt.VSNet.ManagedAssemblyReference
NAnt.VSNet.VcAssemblyReference

[Visual Basic]
MustInherit Public Class AssemblyReferenceBase
Inherits FileReferenceBase
[C#]
public abstract class AssemblyReferenceBase : FileReferenceBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

AssemblyReferenceBase Members | NAnt.VSNet Namespace


AssemblyReferenceBase Members

AssemblyReferenceBase overview

Public Instance Properties

CopyLocal | Gets a value indicating whether the output file(s) of this reference should be copied locally.
Name (inherited from ReferenceBase) |

Public Instance Methods

CreateProjectReference |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences | Gets the complete set of assemblies that need to be referenced when a project references this component.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles | Gets the complete set of output files for the referenced project.
GetPrimaryOutputFile | Gets the path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from FileReferenceBase) | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

AssemblyReferenceBase Constructor

Protected Instance Properties

GacCache (inherited from FileReferenceBase) |
IsPrivate |
IsPrivateSpecified |
IsSystem | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |
XmlDefinition (inherited from FileReferenceBase) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAssemblyOutputFiles (inherited from FileReferenceBase) | Gets the complete set of output files for the specified assembly and adds them to collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ResolveAssemblyReference | Resolves an assembly reference.
ResolveFromAssemblyFolders |
ResolveFromFolderList | Searches for the given file in all paths in folderList.
ResolveFromFramework | Resolves an assembly reference in the framework assembly directory of the target framework.
ResolveFromRelativePath | Resolves an assembly reference using a path relative to the project directory.

See Also

AssemblyReferenceBase Class | NAnt.VSNet Namespace


AssemblyReferenceBase Constructor

[Visual Basic]
Protected Sub New( _
ByVal xmlDefinition As XmlElement, _
ByVal referencesResolver As ReferencesResolver, _
ByVal parent As ProjectBase, _
ByVal gacCache As GacCache _
)
[C#]
protected AssemblyReferenceBase(
XmlElement xmlDefinition,
ReferencesResolver referencesResolver,
ProjectBase parent,
GacCache gacCache
);

See Also

AssemblyReferenceBase Class | NAnt.VSNet Namespace


AssemblyReferenceBase Properties

The properties of the AssemblyReferenceBase class are listed below. For a complete list of AssemblyReferenceBase class members, see the AssemblyReferenceBase Members topic.

Public Instance Properties

CopyLocal | Gets a value indicating whether the output file(s) of this reference should be copied locally.
Name (inherited from ReferenceBase) |

Protected Instance Properties

GacCache (inherited from FileReferenceBase) |
IsPrivate |
IsPrivateSpecified |
IsSystem | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |
XmlDefinition (inherited from FileReferenceBase) |

See Also

AssemblyReferenceBase Class | NAnt.VSNet Namespace


CopyLocal Property

NAnt SDK Documentation - v0.91

AssemblyReferenceBase.CopyLocal Property

Gets a value indicating whether the output file(s) of this reference should be copied locally.

[Visual Basic]
Overrides Public ReadOnly Property CopyLocal As Boolean
[C#]
public override bool CopyLocal {get;}

Property Value

true if the output file(s) of this reference should be copied locally; otherwise, false.

See Also

AssemblyReferenceBase Class | NAnt.VSNet Namespace


IsPrivate Property

NAnt SDK Documentation - v0.91

AssemblyReferenceBase.IsPrivate Property

[Visual Basic]
MustOverride Protected ReadOnly Property IsPrivate As Boolean
[C#]
protected abstract bool IsPrivate {get;}

See Also

AssemblyReferenceBase Class | NAnt.VSNet Namespace


IsPrivateSpecified Property

NAnt SDK Documentation - v0.91

AssemblyReferenceBase.IsPrivateSpecified Property

[Visual Basic]
MustOverride Protected ReadOnly Property IsPrivateSpecified As Boolean
[C#]
protected abstract bool IsPrivateSpecified {get;}

See Also

AssemblyReferenceBase Class | NAnt.VSNet Namespace


IsSystem Property

NAnt SDK Documentation - v0.91

AssemblyReferenceBase.IsSystem Property

Gets a value indicating whether this reference represents a system assembly.

[Visual Basic]
Overrides Protected ReadOnly Property IsSystem As Boolean
[C#]
protected override bool IsSystem {get;}

Property Value

true if this reference represents a system assembly; otherwise, false.

See Also

AssemblyReferenceBase Class | NAnt.VSNet Namespace


AssemblyReferenceBase Methods

The methods of the AssemblyReferenceBase class are listed below. For a complete list of AssemblyReferenceBase class members, see the AssemblyReferenceBase Members topic.

Public Instance Methods

CreateProjectReference |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences | Gets the complete set of assemblies that need to be referenced when a project references this component.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles | Gets the complete set of output files for the referenced project.
GetPrimaryOutputFile | Gets the path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from FileReferenceBase) | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAssemblyOutputFiles (inherited from FileReferenceBase) | Gets the complete set of output files for the specified assembly and adds them to collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ResolveAssemblyReference | Resolves an assembly reference.
ResolveFromAssemblyFolders |
ResolveFromFolderList | Searches for the given file in all paths in folderList.
ResolveFromFramework | Resolves an assembly reference in the framework assembly directory of the target framework.
ResolveFromRelativePath | Resolves an assembly reference using a path relative to the project directory.

See Also

AssemblyReferenceBase Class | NAnt.VSNet Namespace


AssemblyReferenceBase.CreateProjectReference Method

[Visual Basic]
Public Function CreateProjectReference( _
ByVal project As ProjectBase _
) As ProjectReferenceBase
[C#]
public ProjectReferenceBase CreateProjectReference(
ProjectBase project
);

See Also

AssemblyReferenceBase Class | NAnt.VSNet Namespace


AssemblyReferenceBase.GetAssemblyReferences Method

Gets the complete set of assemblies that need to be referenced when a project references this component.

[Visual Basic]
Overrides Public Function GetAssemblyReferences( _
ByVal solutionConfiguration As Configuration _
) As StringCollection
[C#]
public override StringCollection GetAssemblyReferences(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Return Value

The complete set of assemblies that need to be referenced when a project references this component.

See Also

AssemblyReferenceBase Class | NAnt.VSNet Namespace


AssemblyReferenceBase.GetOutputFiles Method

Gets the complete set of output files for the referenced project.

[Visual Basic]
Overrides Public Sub GetOutputFiles( _
ByVal solutionConfiguration As Configuration, _
ByVal outputFiles As Hashtable _
)
[C#]
public override void GetOutputFiles(
Configuration solutionConfiguration,
Hashtable outputFiles
);

Parameters

solutionConfiguration
The solution configuration that is built.
outputFiles
The set of output files to be updated.

Remarks

The key of the case-insensitive Hashtable is the full path of the output file and the value is the path relative to the output directory.

See Also

AssemblyReferenceBase Class | NAnt.VSNet Namespace


AssemblyReferenceBase.GetPrimaryOutputFile Method

Gets the path of the reference, without taking the "copy local" setting into consideration.

[Visual Basic]
Overrides Public Function GetPrimaryOutputFile( _
ByVal solutionConfiguration As Configuration _
) As String
[C#]
public override string GetPrimaryOutputFile(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Return Value

The output path of the reference.

See Also

AssemblyReferenceBase Class | NAnt.VSNet Namespace


AssemblyReferenceBase.GetTimestamp Method

Gets the timestamp of the reference.

[Visual Basic]
Overrides Public Function GetTimestamp( _
ByVal solutionConfiguration As Configuration _
) As Date
[C#]
public override DateTime GetTimestamp(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Return Value

The timestamp of the reference.

See Also

AssemblyReferenceBase Class | NAnt.VSNet Namespace


AssemblyReferenceBase.ResolveAssemblyReference Method

Resolves an assembly reference.

[Visual Basic]
MustOverride Protected Function ResolveAssemblyReference() As String
[C#]
protected abstract string ResolveAssemblyReference();

Return Value

The full path to the resolved assembly, or a null reference (Nothing in Visual Basic) if the assembly reference could not be resolved.

See Also

AssemblyReferenceBase Class | NAnt.VSNet Namespace


AssemblyReferenceBase.ResolveFromAssemblyFolders Method

[Visual Basic]
Overridable Protected Function ResolveFromAssemblyFolders( _
ByVal referenceElement As XmlElement, _
ByVal fileName As String _
) As String
[C#]
protected virtual string ResolveFromAssemblyFolders(
XmlElement referenceElement,
string fileName
);

See Also

AssemblyReferenceBase Class | NAnt.VSNet Namespace


AssemblyReferenceBase.ResolveFromFolderList Method

Searches for the given file in all paths in folderList.

[Visual Basic]
Protected Function ResolveFromFolderList( _
ByVal folderList As StringCollection, _
ByVal fileName As String _
) As String
[C#]
protected string ResolveFromFolderList(
StringCollection folderList,
string fileName
);

Parameters

folderList
The folders to search.
fileName
The file to search for.

Return Value

The path of the assembly if fileName was found in folderList; otherwise, a null reference (Nothing in Visual Basic).

See Also

AssemblyReferenceBase Class | NAnt.VSNet Namespace


AssemblyReferenceBase.ResolveFromFramework Method

Resolves an assembly reference in the framework assembly directory of the target framework.

[Visual Basic]
Protected Function ResolveFromFramework( _
ByVal fileName As String _
) As String
[C#]
protected string ResolveFromFramework(
string fileName
);

Parameters

fileName
The file to search for.

Return Value

The full path of the assembly file if the assembly could be located in the framework assembly directory; otherwise, a null reference (Nothing in Visual Basic).

See Also

AssemblyReferenceBase Class | NAnt.VSNet Namespace


AssemblyReferenceBase.ResolveFromRelativePath Method

Resolves an assembly reference using a path relative to the project directory.

[Visual Basic]
Protected Function ResolveFromRelativePath( _
ByVal relativePath As String _
) As String
[C#]
protected string ResolveFromRelativePath(
string relativePath
);

Return Value

The full path of the assembly, or a null reference (Nothing in Visual Basic) if relativePath is a null reference (Nothing in Visual Basic) or an empty String.

See Also

AssemblyReferenceBase Class | NAnt.VSNet Namespace


BuildResult Enumeration

Specifies the result of the build.

[Visual Basic]
<Serializable>
Public Enum BuildResult
[C#]
[Serializable]
public enum BuildResult

Members

Member Name | Description
Failed | The build failed.
Success | The build succeeded.
SuccessOutputUpdated | The build succeeded and the output was updated.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

NAnt.VSNet Namespace


Configuration Class

For a list of all members of this type, see Configuration Members.

System.Object
NAnt.VSNet.Configuration

[Visual Basic]
Public Class Configuration
Implements IComparable
[C#]
public class Configuration : IComparable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

Configuration Members | NAnt.VSNet Namespace


Configuration Members

Configuration overview

Public Static (Shared) Methods

Parse

Public Static (Shared) Operators

Equality Operator
Inequality Operator

Public Instance Constructors

Configuration Overloaded. Initializes a new instance of the Configuration class.

Public Instance Properties

Name
Platform

Public Instance Methods

CompareTo |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Configuration Class | NAnt.VSNet Namespace


Configuration Constructor

Initializes a new instance of the Configuration class.

Overload List

Initializes a new instance of the Configuration class.

public Configuration();

public Configuration(string,string);

See Also

Configuration Class | NAnt.VSNet Namespace


Configuration Constructor ()

Initializes a new instance of the Configuration class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Configuration();

See Also

Configuration Class | NAnt.VSNet Namespace | Configuration Constructor Overload List


Configuration Constructor (String, String)

[Visual Basic]
Overloads Public Sub New( _
ByVal name As String, _
ByVal platform As String _
)
[C#]
public Configuration(
string name,
string platform
);

See Also

Configuration Class | NAnt.VSNet Namespace | Configuration Constructor Overload List


Configuration Properties

The properties of the Configuration class are listed below. For a complete list of Configuration class members, see the Configuration Members topic.

Public Instance Properties

Name
Platform

See Also

Configuration Class | NAnt.VSNet Namespace


Name Property

NAnt SDK Documentation - v0.91

Configuration.Name Property

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}

See Also

Configuration Class | NAnt.VSNet Namespace


Platform Property

NAnt SDK Documentation - v0.91

Configuration.Platform Property

[Visual Basic]
Public Property Platform As String
[C#]
public string Platform {get; set;}

See Also

Configuration Class | NAnt.VSNet Namespace


Configuration Methods

The methods of the Configuration class are listed below. For a complete list of Configuration class members, see the Configuration Members topic.

Public Static (Shared) Methods

Parse

Public Instance Methods

CompareTo |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Configuration Class | NAnt.VSNet Namespace


Configuration.CompareTo Method

[Visual Basic]
NotOverridable Public Function CompareTo( _
ByVal obj As Object _
) As Integer _
Implements IComparable.CompareTo
[C#]
public int CompareTo(
object obj
);

Implements

IComparable.CompareTo

See Also

Configuration Class | NAnt.VSNet Namespace


Configuration.Equals Method

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

See Also

Configuration Class | NAnt.VSNet Namespace


Configuration.GetHashCode Method

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

See Also

Configuration Class | NAnt.VSNet Namespace


Configuration.Parse Method

[Visual Basic]
Public Shared Function Parse( _
ByVal config As String _
) As Configuration
[C#]
public static Configuration Parse(
string config
);

See Also

Configuration Class | NAnt.VSNet Namespace


Configuration.ToString Method

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

Configuration Class | NAnt.VSNet Namespace


Configuration Operators

The operators of the Configuration class are listed below. For a complete list of Configuration class members, see the Configuration Members topic.

Public Static (Shared) Operators

Equality Operator
Inequality Operator

See Also

Configuration Class | Configuration Members | NAnt.VSNet Namespace


Configuration Equality Operator

[Visual Basic]
returnValue = Configuration.op_Equality(c1, c2)
[C#]
public static bool operator ==(
Configuration c1,
Configuration c2
);

See Also

Configuration Class | NAnt.VSNet Namespace


Configuration Inequality Operator

[Visual Basic]
returnValue = Configuration.op_Inequality(c1, c2)
[C#]
public static bool operator !=(
Configuration c1,
Configuration c2
);

See Also

Configuration Class | NAnt.VSNet Namespace


ConfigurationBase Class

For a list of all members of this type, see ConfigurationBase Members.

System.Object
NAnt.VSNet.ConfigurationBase
NAnt.VSNet.ConfigurationSettings
NAnt.VSNet.VcConfigurationBase

[Visual Basic]
MustInherit Public Class ConfigurationBase
[C#]
public abstract class ConfigurationBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ConfigurationBase Members | NAnt.VSNet Namespace


ConfigurationBase Members

ConfigurationBase overview

Public Instance Properties

BuildPath | Gets the path in which the output file will be created before its copied to the actual output path.
ExtraOutputFiles | Gets the set of output files that is specific to the project configuration.
Name | Gets the name of the configuration.
ObjectDir | Get the directory in which intermediate build output will be stored for this configuration.
OutputDir | Gets the output directory.
OutputPath | Gets the path for the output file.
PlatformName | Gets the platform that the configuration targets.
Project | Gets the project.
RelativeOutputDir | Get the path of the output directory relative to the project directory.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandMacros |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ConfigurationBase Constructor Initializes a new instance of the ConfigurationBase class with the given ProjectBase.

Protected Instance Properties

SolutionTask

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

ExpandMacro Expands the given macro.

See Also

ConfigurationBase Class | NAnt.VSNet Namespace


ConfigurationBase Constructor

Initializes a new instance of the ConfigurationBase class with the given ProjectBase.

[Visual Basic]
Protected Sub New( _
ByVal project As ProjectBase _
)
[C#]
protected ConfigurationBase(
ProjectBase project
);

Parameters

project
The project of the configuration.

See Also

ConfigurationBase Class | NAnt.VSNet Namespace


ConfigurationBase Properties

The properties of the ConfigurationBase class are listed below. For a complete list of ConfigurationBase class members, see the ConfigurationBase Members topic.

Public Instance Properties

BuildPath | Gets the path in which the output file will be created before its copied to the actual output path.
ExtraOutputFiles | Gets the set of output files that is specific to the project configuration.
Name | Gets the name of the configuration.
ObjectDir | Get the directory in which intermediate build output will be stored for this configuration.
OutputDir | Gets the output directory.
OutputPath | Gets the path for the output file.
PlatformName | Gets the platform that the configuration targets.
Project | Gets the project.
RelativeOutputDir | Get the path of the output directory relative to the project directory.

Protected Instance Properties

SolutionTask

See Also

ConfigurationBase Class | NAnt.VSNet Namespace


BuildPath Property

NAnt SDK Documentation - v0.91

ConfigurationBase.BuildPath Property

Gets the path in which the output file will be created before its copied to the actual output path.

[Visual Basic]
MustOverride Public ReadOnly Property BuildPath As String
[C#]
public abstract string BuildPath {get;}

See Also

ConfigurationBase Class | NAnt.VSNet Namespace


ExtraOutputFiles Property

NAnt SDK Documentation - v0.91

ConfigurationBase.ExtraOutputFiles Property

Gets the set of output files that is specific to the project configuration.

[Visual Basic]
Public ReadOnly Property ExtraOutputFiles As Hashtable
[C#]
public System.Collections.Hashtable ExtraOutputFiles {get;}

Property Value

The set of output files that is specific to the project configuration.

Remarks

The key of the case-insensitive Hashtable is the full path of the output file and the value is the path relative to the output directory.

See Also

ConfigurationBase Class | NAnt.VSNet Namespace


Name Property

NAnt SDK Documentation - v0.91

ConfigurationBase.Name Property

Gets the name of the configuration.

[Visual Basic]
MustOverride Public ReadOnly Property Name As String
[C#]
public abstract string Name {get;}

See Also

ConfigurationBase Class | NAnt.VSNet Namespace


ObjectDir Property

NAnt SDK Documentation - v0.91

ConfigurationBase.ObjectDir Property

Get the directory in which intermediate build output will be stored for this configuration.

[Visual Basic]
Overridable Public ReadOnly Property ObjectDir As DirectoryInfo
[C#]
public virtual System.IO.DirectoryInfo ObjectDir {get;}

Remarks

This is a directory relative to the project directory named obj\<configuration name>.

.resx and .licx files will only be recompiled if the compiled resource files in the ObjectDir are not uptodate.

See Also

ConfigurationBase Class | NAnt.VSNet Namespace


OutputDir Property

NAnt SDK Documentation - v0.91

ConfigurationBase.OutputDir Property

Gets the output directory.

[Visual Basic]
MustOverride Public ReadOnly Property OutputDir As DirectoryInfo
[C#]
public abstract System.IO.DirectoryInfo OutputDir {get;}

See Also

ConfigurationBase Class | NAnt.VSNet Namespace


OutputPath Property

NAnt SDK Documentation - v0.91

ConfigurationBase.OutputPath Property

Gets the path for the output file.

[Visual Basic]
MustOverride Public ReadOnly Property OutputPath As String
[C#]
public abstract string OutputPath {get;}

See Also

ConfigurationBase Class | NAnt.VSNet Namespace


PlatformName Property

NAnt SDK Documentation - v0.91

ConfigurationBase.PlatformName Property

Gets the platform that the configuration targets.

[Visual Basic]
MustOverride Public ReadOnly Property PlatformName As String
[C#]
public abstract string PlatformName {get;}

Property Value

The platform targeted by the configuration.

See Also

ConfigurationBase Class | NAnt.VSNet Namespace


Project Property

NAnt SDK Documentation - v0.91

ConfigurationBase.Project Property

Gets the project.

[Visual Basic]
Public ReadOnly Property Project As ProjectBase
[C#]
public ProjectBase Project {get;}

See Also

ConfigurationBase Class | NAnt.VSNet Namespace


RelativeOutputDir Property

NAnt SDK Documentation - v0.91

ConfigurationBase.RelativeOutputDir Property

Get the path of the output directory relative to the project directory.

[Visual Basic]
MustOverride Public ReadOnly Property RelativeOutputDir As String
[C#]
public abstract string RelativeOutputDir {get;}

See Also

ConfigurationBase Class | NAnt.VSNet Namespace


SolutionTask Property

NAnt SDK Documentation - v0.91

ConfigurationBase.SolutionTask Property

[Visual Basic]
Protected ReadOnly Property SolutionTask As SolutionTask
[C#]
protected Tasks.SolutionTask SolutionTask {get;}

See Also

ConfigurationBase Class | NAnt.VSNet Namespace


ConfigurationBase Methods

The methods of the ConfigurationBase class are listed below. For a complete list of ConfigurationBase class members, see the ConfigurationBase Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandMacros |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

ExpandMacro Expands the given macro.

See Also

ConfigurationBase Class | NAnt.VSNet Namespace


ConfigurationBase.ExpandMacro Method

Expands the given macro.

[Visual Basic]
Overridable Protected Friend Function ExpandMacro( _
ByVal macro As String _
) As String
[C#]
protected internal virtual string ExpandMacro(
string macro
);

Parameters

macro
The macro to expand.

Return Value

The expanded macro.

Exceptions

Exception Type | Condition
BuildException | The macro is not supported. -or- The macro is not implemented. -or- The macro cannot be expanded.
NotImplementedException | Expansion of a given macro is not yet implemented.

See Also

ConfigurationBase Class | NAnt.VSNet Namespace


ConfigurationBase.ExpandMacros Method

[Visual Basic]
Public Function ExpandMacros( _
ByVal s As String _
) As String
[C#]
public string ExpandMacros(
string s
);

See Also

ConfigurationBase Class | NAnt.VSNet Namespace


ConfigurationDictionary Class

For a list of all members of this type, see ConfigurationDictionary Members.

System.Object
NAnt.VSNet.ConfigurationDictionary

[Visual Basic]
<DefaultMember(MemberName:="Item")>
NotInheritable Public Class ConfigurationDictionary
Implements IDictionary, ICollection, IEnumerable
[C#]
[DefaultMember(MemberName="Item")]
public sealed class ConfigurationDictionary : IDictionary, ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ConfigurationDictionary Members | NAnt.VSNet Namespace


ConfigurationDictionary Members

ConfigurationDictionary overview

Public Instance Constructors

ConfigurationDictionary Constructor Initializes a new instance of the ConfigurationDictionary class.

Public Instance Properties

Count
IsFixedSize
IsReadOnly
IsSynchronized
Item
Keys
SyncRoot
Values

Public Instance Methods

Add |
Clear |
Contains |
ContainsKey |
ContainsValue |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ConfigurationDictionary Class | NAnt.VSNet Namespace


ConfigurationDictionary Constructor

Initializes a new instance of the ConfigurationDictionary class.

[Visual Basic]
Public Sub New()
[C#]
public ConfigurationDictionary();

See Also

ConfigurationDictionary Class | NAnt.VSNet Namespace


ConfigurationDictionary Properties

The properties of the ConfigurationDictionary class are listed below. For a complete list of ConfigurationDictionary class members, see the ConfigurationDictionary Members topic.

Public Instance Properties

Count
IsFixedSize
IsReadOnly
IsSynchronized
Item
Keys
SyncRoot
Values

See Also

ConfigurationDictionary Class | NAnt.VSNet Namespace


Count Property

NAnt SDK Documentation - v0.91

ConfigurationDictionary.Count Property

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

ConfigurationDictionary Class | NAnt.VSNet Namespace


IsFixedSize Property

NAnt SDK Documentation - v0.91

ConfigurationDictionary.IsFixedSize Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsFixedSize As Boolean _
Implements IDictionary.IsFixedSize
[C#]
public bool IsFixedSize {get;}

Implements

IDictionary.IsFixedSize

See Also

ConfigurationDictionary Class | NAnt.VSNet Namespace


IsReadOnly Property

NAnt SDK Documentation - v0.91

ConfigurationDictionary.IsReadOnly Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsReadOnly As Boolean _
Implements IDictionary.IsReadOnly
[C#]
public bool IsReadOnly {get;}

Implements

IDictionary.IsReadOnly

See Also

ConfigurationDictionary Class | NAnt.VSNet Namespace


IsSynchronized Property

NAnt SDK Documentation - v0.91

ConfigurationDictionary.IsSynchronized Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ConfigurationDictionary Class | NAnt.VSNet Namespace


Item Property

NAnt SDK Documentation - v0.91

ConfigurationDictionary.Item Property

[Visual Basic]
Public Default Property Item( _
ByVal key As Configuration _
) As ConfigurationBase
[C#]
public ConfigurationBase this[
NAnt.VSNet.Configuration key
] {get; set;}

See Also

ConfigurationDictionary Class | NAnt.VSNet Namespace


Keys Property

NAnt SDK Documentation - v0.91

ConfigurationDictionary.Keys Property

[Visual Basic]
NotOverridable Public ReadOnly Property Keys As ICollection _
Implements IDictionary.Keys
[C#]
public System.Collections.ICollection Keys {get;}

Implements

IDictionary.Keys

See Also

ConfigurationDictionary Class | NAnt.VSNet Namespace


SyncRoot Property

NAnt SDK Documentation - v0.91

ConfigurationDictionary.SyncRoot Property

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ConfigurationDictionary Class | NAnt.VSNet Namespace


Values Property

NAnt SDK Documentation - v0.91

ConfigurationDictionary.Values Property

[Visual Basic]
NotOverridable Public ReadOnly Property Values As ICollection _
Implements IDictionary.Values
[C#]
public System.Collections.ICollection Values {get;}

Implements

IDictionary.Values

See Also

ConfigurationDictionary Class | NAnt.VSNet Namespace


ConfigurationDictionary Methods

The methods of the ConfigurationDictionary class are listed below. For a complete list of ConfigurationDictionary class members, see the ConfigurationDictionary Members topic.

Public Instance Methods

Add |
Clear |
Contains |
ContainsKey |
ContainsValue |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ConfigurationDictionary Class | NAnt.VSNet Namespace


ConfigurationDictionary.Add Method

[Visual Basic]
Public Sub Add( _
ByVal key As Configuration, _
ByVal value As ConfigurationBase _
)
[C#]
public void Add(
Configuration key,
ConfigurationBase value
);

See Also

ConfigurationDictionary Class | NAnt.VSNet Namespace


ConfigurationDictionary.Clear Method

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements IDictionary.Clear
[C#]
public void Clear();

Implements

IDictionary.Clear

See Also

ConfigurationDictionary Class | NAnt.VSNet Namespace


ConfigurationDictionary.Contains Method

[Visual Basic]
Public Function Contains( _
ByVal key As Configuration _
) As Boolean
[C#]
public bool Contains(
Configuration key
);

See Also

ConfigurationDictionary Class | NAnt.VSNet Namespace


ConfigurationDictionary.ContainsKey Method

[Visual Basic]
Public Function ContainsKey( _
ByVal key As Configuration _
) As Boolean
[C#]
public bool ContainsKey(
Configuration key
);

See Also

ConfigurationDictionary Class | NAnt.VSNet Namespace


ConfigurationDictionary.ContainsValue Method

[Visual Basic]
Public Function ContainsValue( _
ByVal value As ConfigurationBase _
) As Boolean
[C#]
public bool ContainsValue(
ConfigurationBase value
);

See Also

ConfigurationDictionary Class | NAnt.VSNet Namespace


ConfigurationDictionary.GetEnumerator Method

[Visual Basic]
Public Function GetEnumerator() As ConfigurationDictionaryEnumerator
[C#]
public ConfigurationDictionaryEnumerator GetEnumerator();

See Also

ConfigurationDictionary Class | NAnt.VSNet Namespace


ConfigurationDictionary.Remove Method

[Visual Basic]
Public Sub Remove( _
ByVal configuration As Configuration _
)
[C#]
public void Remove(
Configuration configuration
);

See Also

ConfigurationDictionary Class | NAnt.VSNet Namespace


ConfigurationDictionaryEntry Class

For a list of all members of this type, see ConfigurationDictionaryEntry Members.

System.Object
NAnt.VSNet.ConfigurationDictionaryEntry

[Visual Basic]
NotInheritable Public Class ConfigurationDictionaryEntry
[C#]
public sealed class ConfigurationDictionaryEntry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ConfigurationDictionaryEntry Members | NAnt.VSNet Namespace


ConfigurationDictionaryEntry Members

ConfigurationDictionaryEntry overview

Public Instance Properties

Config
Name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ConfigurationDictionaryEntry Class | NAnt.VSNet Namespace


ConfigurationDictionaryEntry Properties

The properties of the ConfigurationDictionaryEntry class are listed below. For a complete list of ConfigurationDictionaryEntry class members, see the ConfigurationDictionaryEntry Members topic.

Public Instance Properties

Config
Name

See Also

ConfigurationDictionaryEntry Class | NAnt.VSNet Namespace


Config Property

NAnt SDK Documentation - v0.91

ConfigurationDictionaryEntry.Config Property

[Visual Basic]
Public ReadOnly Property Config As ConfigurationBase
[C#]
public ConfigurationBase Config {get;}

See Also

ConfigurationDictionaryEntry Class | NAnt.VSNet Namespace


Name Property

NAnt SDK Documentation - v0.91

ConfigurationDictionaryEntry.Name Property

[Visual Basic]
Public ReadOnly Property Name As Configuration
[C#]
public Configuration Name {get;}

See Also

ConfigurationDictionaryEntry Class | NAnt.VSNet Namespace


ConfigurationDictionaryEnumerator Class

For a list of all members of this type, see ConfigurationDictionaryEnumerator Members.

System.Object
NAnt.VSNet.ConfigurationDictionaryEnumerator

[Visual Basic]
Public Class ConfigurationDictionaryEnumerator
Implements IDictionaryEnumerator, IEnumerator
[C#]
public class ConfigurationDictionaryEnumerator : IDictionaryEnumerator, IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ConfigurationDictionaryEnumerator Members | NAnt.VSNet Namespace


ConfigurationDictionaryEnumerator Members

ConfigurationDictionaryEnumerator overview

Public Instance Properties

Current
Entry
Key
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConfigurationDictionaryEnumerator Class | NAnt.VSNet Namespace


ConfigurationDictionaryEnumerator Properties

The properties of the ConfigurationDictionaryEnumerator class are listed below. For a complete list of ConfigurationDictionaryEnumerator class members, see the ConfigurationDictionaryEnumerator Members topic.

Public Instance Properties

Current
Entry
Key
Value

See Also

ConfigurationDictionaryEnumerator Class | NAnt.VSNet Namespace


Current Property

NAnt SDK Documentation - v0.91

ConfigurationDictionaryEnumerator.Current Property

[Visual Basic]
Public ReadOnly Property Current As ConfigurationDictionaryEntry
[C#]
public ConfigurationDictionaryEntry Current {get;}

See Also

ConfigurationDictionaryEnumerator Class | NAnt.VSNet Namespace


Entry Property

NAnt SDK Documentation - v0.91

ConfigurationDictionaryEnumerator.Entry Property

[Visual Basic]
NotOverridable Public ReadOnly Property Entry As DictionaryEntry _
Implements IDictionaryEnumerator.Entry
[C#]
public System.Collections.DictionaryEntry Entry {get;}

Implements

IDictionaryEnumerator.Entry

See Also

ConfigurationDictionaryEnumerator Class | NAnt.VSNet Namespace


Key Property

NAnt SDK Documentation - v0.91

ConfigurationDictionaryEnumerator.Key Property

[Visual Basic]
Public ReadOnly Property Key As Configuration
[C#]
public Configuration Key {get;}

See Also

ConfigurationDictionaryEnumerator Class | NAnt.VSNet Namespace


Value Property

NAnt SDK Documentation - v0.91

ConfigurationDictionaryEnumerator.Value Property

[Visual Basic]
Public ReadOnly Property Value As ConfigurationBase
[C#]
public ConfigurationBase Value {get;}

See Also

ConfigurationDictionaryEnumerator Class | NAnt.VSNet Namespace


ConfigurationDictionaryEnumerator Methods

The methods of the ConfigurationDictionaryEnumerator class are listed below. For a complete list of ConfigurationDictionaryEnumerator class members, see the ConfigurationDictionaryEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConfigurationDictionaryEnumerator Class | NAnt.VSNet Namespace


ConfigurationDictionaryEnumerator.MoveNext Method

[Visual Basic]
NotOverridable Public Function MoveNext() As Boolean _
Implements IEnumerator.MoveNext
[C#]
public bool MoveNext();

Implements

IEnumerator.MoveNext

See Also

ConfigurationDictionaryEnumerator Class | NAnt.VSNet Namespace


ConfigurationDictionaryEnumerator.Reset Method

[Visual Basic]
NotOverridable Public Sub Reset() _
Implements IEnumerator.Reset
[C#]
public void Reset();

Implements

IEnumerator.Reset

See Also

ConfigurationDictionaryEnumerator Class | NAnt.VSNet Namespace


ConfigurationMap Class

For a list of all members of this type, see ConfigurationMap Members.

System.Object
NAnt.VSNet.ConfigurationMap

[Visual Basic]
<DefaultMember(MemberName:="Item")>
NotInheritable Public Class ConfigurationMap
Implements IDictionary, ICollection, IEnumerable
[C#]
[DefaultMember(MemberName="Item")]
public sealed class ConfigurationMap : IDictionary, ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ConfigurationMap Members | NAnt.VSNet Namespace


ConfigurationMap Members

ConfigurationMap overview

Public Instance Constructors

ConfigurationMap Overloaded. Initializes a new instance of the ConfigurationMap class.

Public Instance Properties

Count
IsFixedSize
IsReadOnly
IsSynchronized
Item
Keys
SyncRoot
Values

Public Instance Methods

Add |
Clear |
Contains |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ConfigurationMap Class | NAnt.VSNet Namespace


ConfigurationMap Constructor

Initializes a new instance of the ConfigurationMap class.

Overload List

Initializes a new instance of the ConfigurationMap class.

public ConfigurationMap();

Initializes a new instance of the ConfigurationMap class with the specified initial capacity.

public ConfigurationMap(int);

See Also

ConfigurationMap Class | NAnt.VSNet Namespace


ConfigurationMap Constructor ()

Initializes a new instance of the ConfigurationMap class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ConfigurationMap();

See Also

ConfigurationMap Class | NAnt.VSNet Namespace | ConfigurationMap Constructor Overload List


ConfigurationMap Constructor (Int32)

Initializes a new instance of the ConfigurationMap class with the specified initial capacity.

[Visual Basic]
Overloads Public Sub New( _
ByVal capacity As Integer _
)
[C#]
public ConfigurationMap(
int capacity
);

Parameters

capacity
The appropriate number of entries that the ConfigurationMap can initially contain.

See Also

ConfigurationMap Class | NAnt.VSNet Namespace | ConfigurationMap Constructor Overload List


ConfigurationMap Properties

The properties of the ConfigurationMap class are listed below. For a complete list of ConfigurationMap class members, see the ConfigurationMap Members topic.

Public Instance Properties

Count
IsFixedSize
IsReadOnly
IsSynchronized
Item
Keys
SyncRoot
Values

See Also

ConfigurationMap Class | NAnt.VSNet Namespace


Count Property

NAnt SDK Documentation - v0.91

ConfigurationMap.Count Property

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

ConfigurationMap Class | NAnt.VSNet Namespace


IsFixedSize Property

NAnt SDK Documentation - v0.91

ConfigurationMap.IsFixedSize Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsFixedSize As Boolean _
Implements IDictionary.IsFixedSize
[C#]
public bool IsFixedSize {get;}

Implements

IDictionary.IsFixedSize

See Also

ConfigurationMap Class | NAnt.VSNet Namespace


IsReadOnly Property

NAnt SDK Documentation - v0.91

ConfigurationMap.IsReadOnly Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsReadOnly As Boolean _
Implements IDictionary.IsReadOnly
[C#]
public bool IsReadOnly {get;}

Implements

IDictionary.IsReadOnly

See Also

ConfigurationMap Class | NAnt.VSNet Namespace


IsSynchronized Property

NAnt SDK Documentation - v0.91

ConfigurationMap.IsSynchronized Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ConfigurationMap Class | NAnt.VSNet Namespace


Item Property

NAnt SDK Documentation - v0.91

ConfigurationMap.Item Property

[Visual Basic]
Public Default Property Item( _
ByVal key As Configuration _
) As Configuration
[C#]
public Configuration this[
NAnt.VSNet.Configuration key
] {get; set;}

See Also

ConfigurationMap Class | NAnt.VSNet Namespace


Keys Property

NAnt SDK Documentation - v0.91

ConfigurationMap.Keys Property

[Visual Basic]
NotOverridable Public ReadOnly Property Keys As ICollection _
Implements IDictionary.Keys
[C#]
public System.Collections.ICollection Keys {get;}

Implements

IDictionary.Keys

See Also

ConfigurationMap Class | NAnt.VSNet Namespace


SyncRoot Property

NAnt SDK Documentation - v0.91

ConfigurationMap.SyncRoot Property

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ConfigurationMap Class | NAnt.VSNet Namespace


Values Property

NAnt SDK Documentation - v0.91

ConfigurationMap.Values Property

[Visual Basic]
NotOverridable Public ReadOnly Property Values As ICollection _
Implements IDictionary.Values
[C#]
public System.Collections.ICollection Values {get;}

Implements

IDictionary.Values

See Also

ConfigurationMap Class | NAnt.VSNet Namespace


ConfigurationMap Methods

The methods of the ConfigurationMap class are listed below. For a complete list of ConfigurationMap class members, see the ConfigurationMap Members topic.

Public Instance Methods

Add |
Clear |
Contains |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ConfigurationMap Class | NAnt.VSNet Namespace


ConfigurationMap.Add Method

[Visual Basic]
Public Sub Add( _
ByVal key As Configuration, _
ByVal value As Configuration _
)
[C#]
public void Add(
Configuration key,
Configuration value
);

See Also

ConfigurationMap Class | NAnt.VSNet Namespace


ConfigurationMap.Clear Method

[Visual Basic]
NotOverridable Public Sub Clear() _
Implements IDictionary.Clear
[C#]
public void Clear();

Implements

IDictionary.Clear

See Also

ConfigurationMap Class | NAnt.VSNet Namespace


ConfigurationMap.Contains Method

[Visual Basic]
Public Function Contains( _
ByVal key As Configuration _
) As Boolean
[C#]
public bool Contains(
Configuration key
);

See Also

ConfigurationMap Class | NAnt.VSNet Namespace


ConfigurationMap.GetEnumerator Method

[Visual Basic]
Public Function GetEnumerator() As ConfigurationMapEnumerator
[C#]
public ConfigurationMapEnumerator GetEnumerator();

See Also

ConfigurationMap Class | NAnt.VSNet Namespace


ConfigurationMap.Remove Method

[Visual Basic]
Public Sub Remove( _
ByVal configuration As Configuration _
)
[C#]
public void Remove(
Configuration configuration
);

See Also

ConfigurationMap Class | NAnt.VSNet Namespace


ConfigurationMapEntry Class

For a list of all members of this type, see ConfigurationMapEntry Members.

System.Object
NAnt.VSNet.ConfigurationMapEntry

[Visual Basic]
NotInheritable Public Class ConfigurationMapEntry
[C#]
public sealed class ConfigurationMapEntry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ConfigurationMapEntry Members | NAnt.VSNet Namespace


ConfigurationMapEntry Members

ConfigurationMapEntry overview

Public Instance Properties

Key
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ConfigurationMapEntry Class | NAnt.VSNet Namespace


ConfigurationMapEntry Properties

The properties of the ConfigurationMapEntry class are listed below. For a complete list of ConfigurationMapEntry class members, see the ConfigurationMapEntry Members topic.

Public Instance Properties

Key
Value

See Also

ConfigurationMapEntry Class | NAnt.VSNet Namespace


Key Property

NAnt SDK Documentation - v0.91

ConfigurationMapEntry.Key Property

[Visual Basic]
Public ReadOnly Property Key As Configuration
[C#]
public Configuration Key {get;}

See Also

ConfigurationMapEntry Class | NAnt.VSNet Namespace


Value Property

NAnt SDK Documentation - v0.91

ConfigurationMapEntry.Value Property

[Visual Basic]
Public ReadOnly Property Value As Configuration
[C#]
public Configuration Value {get;}

See Also

ConfigurationMapEntry Class | NAnt.VSNet Namespace


ConfigurationMapEnumerator Class

For a list of all members of this type, see ConfigurationMapEnumerator Members.

System.Object
NAnt.VSNet.ConfigurationMapEnumerator

[Visual Basic]
Public Class ConfigurationMapEnumerator
Implements IDictionaryEnumerator, IEnumerator
[C#]
public class ConfigurationMapEnumerator : IDictionaryEnumerator, IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ConfigurationMapEnumerator Members | NAnt.VSNet Namespace


ConfigurationMapEnumerator Members

ConfigurationMapEnumerator overview

Public Instance Properties

Current
Entry
Key
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConfigurationMapEnumerator Class | NAnt.VSNet Namespace


ConfigurationMapEnumerator Properties

The properties of the ConfigurationMapEnumerator class are listed below. For a complete list of ConfigurationMapEnumerator class members, see the ConfigurationMapEnumerator Members topic.

Public Instance Properties

Current
Entry
Key
Value

See Also

ConfigurationMapEnumerator Class | NAnt.VSNet Namespace


Current Property

NAnt SDK Documentation - v0.91

ConfigurationMapEnumerator.Current Property

[Visual Basic]
Public ReadOnly Property Current As ConfigurationMapEntry
[C#]
public ConfigurationMapEntry Current {get;}

See Also

ConfigurationMapEnumerator Class | NAnt.VSNet Namespace


Entry Property

NAnt SDK Documentation - v0.91

ConfigurationMapEnumerator.Entry Property

[Visual Basic]
NotOverridable Public ReadOnly Property Entry As DictionaryEntry _
Implements IDictionaryEnumerator.Entry
[C#]
public System.Collections.DictionaryEntry Entry {get;}

Implements

IDictionaryEnumerator.Entry

See Also

ConfigurationMapEnumerator Class | NAnt.VSNet Namespace


Key Property

NAnt SDK Documentation - v0.91

ConfigurationMapEnumerator.Key Property

[Visual Basic]
Public ReadOnly Property Key As Configuration
[C#]
public Configuration Key {get;}

See Also

ConfigurationMapEnumerator Class | NAnt.VSNet Namespace


Value Property

NAnt SDK Documentation - v0.91

ConfigurationMapEnumerator.Value Property

[Visual Basic]
Public ReadOnly Property Value As Configuration
[C#]
public Configuration Value {get;}

See Also

ConfigurationMapEnumerator Class | NAnt.VSNet Namespace


ConfigurationMapEnumerator Methods

The methods of the ConfigurationMapEnumerator class are listed below. For a complete list of ConfigurationMapEnumerator class members, see the ConfigurationMapEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConfigurationMapEnumerator Class | NAnt.VSNet Namespace


ConfigurationMapEnumerator.MoveNext Method

[Visual Basic]
NotOverridable Public Function MoveNext() As Boolean _
Implements IEnumerator.MoveNext
[C#]
public bool MoveNext();

Implements

IEnumerator.MoveNext

See Also

ConfigurationMapEnumerator Class | NAnt.VSNet Namespace


ConfigurationMapEnumerator.Reset Method

[Visual Basic]
NotOverridable Public Sub Reset() _
Implements IEnumerator.Reset
[C#]
public void Reset();

Implements

IEnumerator.Reset

See Also

ConfigurationMapEnumerator Class | NAnt.VSNet Namespace


ConfigurationSettings Class

For a list of all members of this type, see ConfigurationSettings Members.

System.Object
NAnt.VSNet.ConfigurationBase
NAnt.VSNet.ConfigurationSettings

[Visual Basic]
Public Class ConfigurationSettings
Inherits ConfigurationBase
[C#]
public class ConfigurationSettings : ConfigurationBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ConfigurationSettings Members | NAnt.VSNet Namespace


ConfigurationSettings Members

ConfigurationSettings overview

Public Instance Constructors

ConfigurationSettings Constructor

Public Instance Properties

BuildPath | Gets the path in which the output file will be created before its copied to the actual output path.
ExtraOutputFiles (inherited from ConfigurationBase) | Gets the set of output files that is specific to the project configuration.
Name |
ObjectDir (inherited from ConfigurationBase) | Get the directory in which intermediate build output will be stored for this configuration.
OutputDir |
OutputPath |
PlatformName | Gets the platform that the configuration targets.
Project (inherited from ConfigurationBase) | Gets the project.
RegisterForComInterop | Gets a value indicating whether to register the project output for use with COM components.
RelativeOutputDir |
Settings |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandMacros (inherited from ConfigurationBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

SolutionTask (inherited from ConfigurationBase)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

ExpandMacro (inherited from ConfigurationBase) Expands the given macro.

See Also

ConfigurationSettings Class | NAnt.VSNet Namespace


ConfigurationSettings Constructor

[Visual Basic]
Public Sub New( _
ByVal project As ManagedProjectBase, _
ByVal elemConfig As XmlElement, _
ByVal outputDir As DirectoryInfo _
)
[C#]
public ConfigurationSettings(
ManagedProjectBase project,
XmlElement elemConfig,
DirectoryInfo outputDir
);

See Also

ConfigurationSettings Class | NAnt.VSNet Namespace


ConfigurationSettings Properties

The properties of the ConfigurationSettings class are listed below. For a complete list of ConfigurationSettings class members, see the ConfigurationSettings Members topic.

Public Instance Properties

BuildPath | Gets the path in which the output file will be created before its copied to the actual output path.
ExtraOutputFiles (inherited from ConfigurationBase) | Gets the set of output files that is specific to the project configuration.
Name |
ObjectDir (inherited from ConfigurationBase) | Get the directory in which intermediate build output will be stored for this configuration.
OutputDir |
OutputPath |
PlatformName | Gets the platform that the configuration targets.
Project (inherited from ConfigurationBase) | Gets the project.
RegisterForComInterop | Gets a value indicating whether to register the project output for use with COM components.
RelativeOutputDir |
Settings |

Protected Instance Properties

SolutionTask (inherited from ConfigurationBase)

See Also

ConfigurationSettings Class | NAnt.VSNet Namespace


BuildPath Property

NAnt SDK Documentation - v0.91

ConfigurationSettings.BuildPath Property

Gets the path in which the output file will be created before its copied to the actual output path.

[Visual Basic]
Overrides Public ReadOnly Property BuildPath As String
[C#]
public override string BuildPath {get;}

See Also

ConfigurationSettings Class | NAnt.VSNet Namespace


Name Property

NAnt SDK Documentation - v0.91

ConfigurationSettings.Name Property

[Visual Basic]
Overrides Public ReadOnly Property Name As String
[C#]
public override string Name {get;}

See Also

ConfigurationSettings Class | NAnt.VSNet Namespace


OutputDir Property

NAnt SDK Documentation - v0.91

ConfigurationSettings.OutputDir Property

[Visual Basic]
Overrides Public ReadOnly Property OutputDir As DirectoryInfo
[C#]
public override System.IO.DirectoryInfo OutputDir {get;}

See Also

ConfigurationSettings Class | NAnt.VSNet Namespace


OutputPath Property

NAnt SDK Documentation - v0.91

ConfigurationSettings.OutputPath Property

[Visual Basic]
Overrides Public ReadOnly Property OutputPath As String
[C#]
public override string OutputPath {get;}

See Also

ConfigurationSettings Class | NAnt.VSNet Namespace


PlatformName Property

NAnt SDK Documentation - v0.91

ConfigurationSettings.PlatformName Property

Gets the platform that the configuration targets.

[Visual Basic]
Overrides Public ReadOnly Property PlatformName As String
[C#]
public override string PlatformName {get;}

Property Value

The platform targeted by the configuration.

See Also

ConfigurationSettings Class | NAnt.VSNet Namespace


RegisterForComInterop Property

NAnt SDK Documentation - v0.91

ConfigurationSettings.RegisterForComInterop Property

Gets a value indicating whether to register the project output for use with COM components.

[Visual Basic]
Public ReadOnly Property RegisterForComInterop As Boolean
[C#]
public bool RegisterForComInterop {get;}

Property Value

true if the project output should be registered for use with COM components; otherwise, false.

See Also

ConfigurationSettings Class | NAnt.VSNet Namespace


RelativeOutputDir Property

NAnt SDK Documentation - v0.91

ConfigurationSettings.RelativeOutputDir Property

[Visual Basic]
Overrides Public ReadOnly Property RelativeOutputDir As String
[C#]
public override string RelativeOutputDir {get;}

See Also

ConfigurationSettings Class | NAnt.VSNet Namespace


Settings Property

NAnt SDK Documentation - v0.91

ConfigurationSettings.Settings Property

[Visual Basic]
Public ReadOnly Property Settings As String()
[C#]
public string[] Settings {get;}

See Also

ConfigurationSettings Class | NAnt.VSNet Namespace


CSharpProject Class

For a list of all members of this type, see CSharpProject Members.

System.Object
NAnt.VSNet.ProjectBase
NAnt.VSNet.ManagedProjectBase
NAnt.VSNet.CSharpProject

[Visual Basic]
Public Class CSharpProject
Inherits ManagedProjectBase
[C#]
public class CSharpProject : ManagedProjectBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

CSharpProject Members | NAnt.VSNet Namespace


CSharpProject Members

CSharpProject overview

Public Static (Shared) Methods

IsSupported Returns a value indicating whether the project represented by the specified XML fragment is supported by CSharpProject.

Public Instance Constructors

CSharpProject Constructor

Public Instance Properties

BuildConfigurations (inherited from ProjectBase) | Gets a list of project configurations that can be build.
ExtraOutputFiles (inherited from ProjectBase) | Gets the extra set of output files for the project.
Guid (inherited from ManagedProjectBase) | Gets or sets the unique identifier of the VS.NET project.
Name (inherited from ManagedProjectBase) | Gets the name of the VS.NET project.
ObjectDir (inherited from ProjectBase) | Get the directory in which intermediate build output that is not specific to the build configuration will be stored.
ProductVersion (inherited from ProjectBase) | Gets the Visual Studio product version of the project.
ProjectConfigurations (inherited from ProjectBase) | Gets a list of all configurations defined in the project.
ProjectDependencies (inherited from ProjectBase) | Gets the set of projects that the project depends on.
ProjectDirectory (inherited from ManagedProjectBase) | Gets the directory containing the VS.NET project.
ProjectLocation (inherited from ManagedProjectBase) | Get the location of the project.
ProjectPath (inherited from ManagedProjectBase) | Gets the path of the VS.NET project.
ProjectSettings (inherited from ManagedProjectBase) |
References (inherited from ManagedProjectBase) |
ReferencesResolver (inherited from ProjectBase) |
SolutionTask (inherited from ProjectBase) |
TemporaryFiles (inherited from ProjectBase) |
Type | Gets the type of the project.

Public Instance Methods

Compile (inherited from ProjectBase) |
CreateProjectReference (inherited from ManagedProjectBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from ProjectBase) |
GetConfiguration (inherited from ProjectBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from ManagedProjectBase) | Gets the complete set of output files for the project configuration matching the specified solution configuration.
GetOutputPath (inherited from ProjectBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from ManagedProjectBase) | Gets a value indicating whether building the project for the specified build configuration results in managed output.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

DevEnvDir (inherited from ProjectBase) |
FileExtension | Gets the default file extension of sources for this project.
GacCache (inherited from ProjectBase) |
OutputDir (inherited from ProjectBase) |

Protected Instance Methods

Build (inherited from ManagedProjectBase) |
CopyFile (inherited from ProjectBase) | Copies the specified file if the destination file does not exist, or the source file has been modified since it was previously copied.
CreateReference (inherited from ManagedProjectBase) |
DetermineProductVersion | Returns the Visual Studio product version of the specified project XML fragment.
DetermineProjectLocation | Returns the project location from the specified project XML fragment.
ExecuteBuildEvent (inherited from ProjectBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetProcessStartInfo | Returns a ProcessStartInfo for launching the compiler for this project.
Log (inherited from ProjectBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Prepare (inherited from ManagedProjectBase) | Prepares the project for being built.
VerifyProjectXml | Verifies whether the specified XML fragment represents a valid project that is supported by this ProjectBase.
WriteCompilerOptions (inherited from ManagedProjectBase) |
WriteProjectOptions (inherited from ManagedProjectBase) |

Protected Internal Instance Methods

ExpandMacro (inherited from ProjectBase) Expands the given macro.

See Also

CSharpProject Class | NAnt.VSNet Namespace


CSharpProject Constructor

[Visual Basic]
Public Sub New( _
ByVal solution As SolutionBase, _
ByVal projectPath As String, _
ByVal xmlDefinition As XmlElement, _
ByVal solutionTask As SolutionTask, _
ByVal tfc As TempFileCollection, _
ByVal gacCache As GacCache, _
ByVal refResolver As ReferencesResolver, _
ByVal outputDir As DirectoryInfo _
)
[C#]
public CSharpProject(
SolutionBase solution,
string projectPath,
XmlElement xmlDefinition,
SolutionTask solutionTask,
TempFileCollection tfc,
GacCache gacCache,
ReferencesResolver refResolver,
DirectoryInfo outputDir
);

See Also

CSharpProject Class | NAnt.VSNet Namespace


CSharpProject Properties

The properties of the CSharpProject class are listed below. For a complete list of CSharpProject class members, see the CSharpProject Members topic.

Public Instance Properties

BuildConfigurations (inherited from ProjectBase) | Gets a list of project configurations that can be build.
ExtraOutputFiles (inherited from ProjectBase) | Gets the extra set of output files for the project.
Guid (inherited from ManagedProjectBase) | Gets or sets the unique identifier of the VS.NET project.
Name (inherited from ManagedProjectBase) | Gets the name of the VS.NET project.
ObjectDir (inherited from ProjectBase) | Get the directory in which intermediate build output that is not specific to the build configuration will be stored.
ProductVersion (inherited from ProjectBase) | Gets the Visual Studio product version of the project.
ProjectConfigurations (inherited from ProjectBase) | Gets a list of all configurations defined in the project.
ProjectDependencies (inherited from ProjectBase) | Gets the set of projects that the project depends on.
ProjectDirectory (inherited from ManagedProjectBase) | Gets the directory containing the VS.NET project.
ProjectLocation (inherited from ManagedProjectBase) | Get the location of the project.
ProjectPath (inherited from ManagedProjectBase) | Gets the path of the VS.NET project.
ProjectSettings (inherited from ManagedProjectBase) |
References (inherited from ManagedProjectBase) |
ReferencesResolver (inherited from ProjectBase) |
SolutionTask (inherited from ProjectBase) |
TemporaryFiles (inherited from ProjectBase) |
Type | Gets the type of the project.

Protected Instance Properties

DevEnvDir (inherited from ProjectBase) |
FileExtension | Gets the default file extension of sources for this project.
GacCache (inherited from ProjectBase) |
OutputDir (inherited from ProjectBase) |

See Also

CSharpProject Class | NAnt.VSNet Namespace


FileExtension Property

NAnt SDK Documentation - v0.91

CSharpProject.FileExtension Property

Gets the default file extension of sources for this project.

[Visual Basic]
Overrides Protected ReadOnly Property FileExtension As String
[C#]
protected override string FileExtension {get;}

Property Value

For C# projects, the default file extension is ".cs".

See Also

CSharpProject Class | NAnt.VSNet Namespace


Type Property

NAnt SDK Documentation - v0.91

CSharpProject.Type Property

Gets the type of the project.

[Visual Basic]
Overrides Public ReadOnly Property Type As ProjectType
[C#]
public override ProjectType Type {get;}

Property Value

The type of the project.

See Also

CSharpProject Class | NAnt.VSNet Namespace


CSharpProject Methods

The methods of the CSharpProject class are listed below. For a complete list of CSharpProject class members, see the CSharpProject Members topic.

Public Static (Shared) Methods

IsSupported Returns a value indicating whether the project represented by the specified XML fragment is supported by CSharpProject.

Public Instance Methods

Compile (inherited from ProjectBase) |
CreateProjectReference (inherited from ManagedProjectBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from ProjectBase) |
GetConfiguration (inherited from ProjectBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from ManagedProjectBase) | Gets the complete set of output files for the project configuration matching the specified solution configuration.
GetOutputPath (inherited from ProjectBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from ManagedProjectBase) | Gets a value indicating whether building the project for the specified build configuration results in managed output.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Build (inherited from ManagedProjectBase) |
CopyFile (inherited from ProjectBase) | Copies the specified file if the destination file does not exist, or the source file has been modified since it was previously copied.
CreateReference (inherited from ManagedProjectBase) |
DetermineProductVersion | Returns the Visual Studio product version of the specified project XML fragment.
DetermineProjectLocation | Returns the project location from the specified project XML fragment.
ExecuteBuildEvent (inherited from ProjectBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetProcessStartInfo | Returns a ProcessStartInfo for launching the compiler for this project.
Log (inherited from ProjectBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Prepare (inherited from ManagedProjectBase) | Prepares the project for being built.
VerifyProjectXml | Verifies whether the specified XML fragment represents a valid project that is supported by this ProjectBase.
WriteCompilerOptions (inherited from ManagedProjectBase) |
WriteProjectOptions (inherited from ManagedProjectBase) |

Protected Internal Instance Methods

ExpandMacro (inherited from ProjectBase) Expands the given macro.

See Also

CSharpProject Class | NAnt.VSNet Namespace


CSharpProject.DetermineProductVersion Method

Returns the Visual Studio product version of the specified project XML fragment.

[Visual Basic]
Overrides Protected Function DetermineProductVersion( _
ByVal docElement As XmlElement _
) As ProductVersion
[C#]
protected override ProductVersion DetermineProductVersion(
XmlElement docElement
);

Parameters

docElement
The document element of the project.

Return Value

The Visual Studio product version of the specified project XML fragment.

Exceptions

Exception Type | Condition
BuildException | The product version could not be determined. -or- The product version is not supported.

See Also

CSharpProject Class | NAnt.VSNet Namespace


CSharpProject.DetermineProjectLocation Method

Returns the project location from the specified project XML fragment.

[Visual Basic]
Overrides Protected Function DetermineProjectLocation( _
ByVal docElement As XmlElement _
) As ProjectLocation
[C#]
protected override ProjectLocation DetermineProjectLocation(
XmlElement docElement
);

Parameters

docElement
XML fragment representing the project file.

Return Value

The project location of the specified project XML file.

Exceptions

Exception Type | Condition
BuildException | The project location could not be determined. -or- The project location is invalid.

See Also

CSharpProject Class | NAnt.VSNet Namespace


CSharpProject.GetProcessStartInfo Method

Returns a ProcessStartInfo for launching the compiler for this project.

[Visual Basic]
Overrides Protected Function GetProcessStartInfo( _
ByVal config As ConfigurationBase, _
ByVal responseFile As String _
) As ProcessStartInfo
[C#]
protected override ProcessStartInfo GetProcessStartInfo(
ConfigurationBase config,
string responseFile
);

Parameters

config
The configuration to build.
responseFile
The response file for the compiler.

Return Value

A ProcessStartInfo for launching the compiler for this project.

See Also

CSharpProject Class | NAnt.VSNet Namespace


CSharpProject.IsSupported Method

Returns a value indicating whether the project represented by the specified XML fragment is supported by CSharpProject.

[Visual Basic]
Public Shared Function IsSupported( _
ByVal docElement As XmlElement _
) As Boolean
[C#]
public static bool IsSupported(
XmlElement docElement
);

Parameters

docElement
XML fragment representing the project to check.

Return Value

true if CSharpProject supports the specified project; otherwise, false.

Remarks

A project is identified as as C# project, if the XML fragment at least has the following information:

<VisualStudioProject>
    <CSHARP
        ProductVersion="..."
        ....
    >
        ...
    </CSHARP>
</VisualStudioProject>

See Also

CSharpProject Class | NAnt.VSNet Namespace


CSharpProject.VerifyProjectXml Method

Verifies whether the specified XML fragment represents a valid project that is supported by this ProjectBase.

[Visual Basic]
Overrides Protected Sub VerifyProjectXml( _
ByVal docElement As XmlElement _
)
[C#]
protected override void VerifyProjectXml(
XmlElement docElement
);

Parameters

docElement
XML fragment representing the project file.

Exceptions

Exception Type | Condition
BuildException | The XML fragment is not supported by this ProjectBase. -or- The XML fragment does not represent a valid project (for this ProjectBase).

See Also

CSharpProject Class | NAnt.VSNet Namespace


FileReferenceBase Class

For a list of all members of this type, see FileReferenceBase Members.

System.Object
NAnt.VSNet.ReferenceBase
NAnt.VSNet.FileReferenceBase
NAnt.VSNet.AssemblyReferenceBase
NAnt.VSNet.WrapperReferenceBase

[Visual Basic]
MustInherit Public Class FileReferenceBase
Inherits ReferenceBase
[C#]
public abstract class FileReferenceBase : ReferenceBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

FileReferenceBase Members | NAnt.VSNet Namespace


FileReferenceBase Members

FileReferenceBase overview

Public Instance Properties

CopyLocal (inherited from ReferenceBase) | Gets a value indicating whether the output file(s) of this reference should be copied locally.
Name (inherited from ReferenceBase) |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from ReferenceBase) | Gets the complete set of assemblies that need to be referenced when a project references this component.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from ReferenceBase) | Gets the complete set of output files of the reference for the specified configuration.
GetPrimaryOutputFile (inherited from ReferenceBase) | Gets the output path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp (inherited from ReferenceBase) | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

FileReferenceBase Constructor

Protected Instance Properties

GacCache |
IsSystem (inherited from ReferenceBase) | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |
XmlDefinition |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAssemblyOutputFiles | Gets the complete set of output files for the specified assembly and adds them to collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileReferenceBase Class | NAnt.VSNet Namespace


FileReferenceBase Constructor

[Visual Basic]
Protected Sub New( _
ByVal xmlDefinition As XmlElement, _
ByVal referencesResolver As ReferencesResolver, _
ByVal parent As ProjectBase, _
ByVal gacCache As GacCache _
)
[C#]
protected FileReferenceBase(
XmlElement xmlDefinition,
ReferencesResolver referencesResolver,
ProjectBase parent,
GacCache gacCache
);

See Also

FileReferenceBase Class | NAnt.VSNet Namespace


FileReferenceBase Properties

The properties of the FileReferenceBase class are listed below. For a complete list of FileReferenceBase class members, see the FileReferenceBase Members topic.

Public Instance Properties

CopyLocal (inherited from ReferenceBase) | Gets a value indicating whether the output file(s) of this reference should be copied locally.
Name (inherited from ReferenceBase) |

Protected Instance Properties

GacCache |
IsSystem (inherited from ReferenceBase) | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |
XmlDefinition |

See Also

FileReferenceBase Class | NAnt.VSNet Namespace


GacCache Property

NAnt SDK Documentation - v0.91

FileReferenceBase.GacCache Property

[Visual Basic]
Protected ReadOnly Property GacCache As GacCache
[C#]
protected NAnt.Core.Util.GacCache GacCache {get;}

See Also

FileReferenceBase Class | NAnt.VSNet Namespace


XmlDefinition Property

NAnt SDK Documentation - v0.91

FileReferenceBase.XmlDefinition Property

[Visual Basic]
Protected ReadOnly Property XmlDefinition As XmlElement
[C#]
protected System.Xml.XmlElement XmlDefinition {get;}

See Also

FileReferenceBase Class | NAnt.VSNet Namespace


FileReferenceBase Methods

The methods of the FileReferenceBase class are listed below. For a complete list of FileReferenceBase class members, see the FileReferenceBase Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from ReferenceBase) | Gets the complete set of assemblies that need to be referenced when a project references this component.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from ReferenceBase) | Gets the complete set of output files of the reference for the specified configuration.
GetPrimaryOutputFile (inherited from ReferenceBase) | Gets the output path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp (inherited from ReferenceBase) | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAssemblyOutputFiles | Gets the complete set of output files for the specified assembly and adds them to collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileReferenceBase Class | NAnt.VSNet Namespace


FileReferenceBase.GetAssemblyOutputFiles Method

Gets the complete set of output files for the specified assembly and adds them to collection.

[Visual Basic]
Protected Sub GetAssemblyOutputFiles( _
ByVal assemblyFile As String, _
ByVal outputFiles As Hashtable _
)
[C#]
protected void GetAssemblyOutputFiles(
string assemblyFile,
Hashtable outputFiles
);

Parameters

assemblyFile
The path of the assembly to get the output files for.
outputFiles
The set of output files to be updated.

Remarks

The key of the case-insensitive Hashtable is the full path of the output file and the value is the path relative to the output directory.

See Also

FileReferenceBase Class | NAnt.VSNet Namespace


FileReferenceBase.IsManaged Method

Gets a value indicating whether the reference is managed for the specified configuration.

[Visual Basic]
Overrides Public Function IsManaged( _
ByVal config As Configuration _
) As Boolean
[C#]
public override bool IsManaged(
Configuration config
);

Parameters

config
The build configuration of the reference.

Return Value

true.

See Also

FileReferenceBase Class | NAnt.VSNet Namespace


GenericSolution Class

Supports grouping of individual projects, and treating them as a solution.

For a list of all members of this type, see GenericSolution Members.

System.Object
NAnt.VSNet.SolutionBase
NAnt.VSNet.GenericSolution

[Visual Basic]
Public Class GenericSolution
Inherits SolutionBase
[C#]
public class GenericSolution : SolutionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

GenericSolution Members | NAnt.VSNet Namespace


GenericSolution Members

GenericSolution overview

Public Instance Constructors

GenericSolution Constructor

Public Instance Properties

File (inherited from SolutionBase)
ProjectEntries (inherited from SolutionBase)
TemporaryFiles (inherited from SolutionBase)

Public Instance Methods

Compile (inherited from SolutionBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetProjectFileFromGuid (inherited from SolutionBase) | Gets the project file of the project with the given unique identifier.
GetProjectFromGuid (inherited from SolutionBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
RecursiveLoadTemplateProject (inherited from SolutionBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

WebMaps (inherited from SolutionBase)

Protected Instance Methods

CreateProjectDoesNotExistException (inherited from SolutionBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FixProjectReferences (inherited from SolutionBase) | Converts assembly references to projects to project references, adding a build dependency.c
GetDependenciesFromProjects (inherited from SolutionBase) |
LoadProjectGuids (inherited from SolutionBase) |
LoadProjects (inherited from SolutionBase) | Loads the projects from the file system and stores them in an instance variable.
Log (inherited from SolutionBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetProjectBuildConfiguration (inherited from SolutionBase) |
TranslateProjectPath (inherited from SolutionBase) | Translates a project path, in the form of a relative file path or a URL, to an absolute file path.

See Also

GenericSolution Class | NAnt.VSNet Namespace


GenericSolution Constructor

[Visual Basic]
Public Sub New( _
ByVal solutionTask As SolutionTask, _
ByVal tfc As TempFileCollection, _
ByVal gacCache As GacCache, _
ByVal refResolver As ReferencesResolver _
)
[C#]
public GenericSolution(
SolutionTask solutionTask,
TempFileCollection tfc,
GacCache gacCache,
ReferencesResolver refResolver
);

See Also

GenericSolution Class | NAnt.VSNet Namespace


JSharpProject Class

For a list of all members of this type, see JSharpProject Members.

System.Object
NAnt.VSNet.ProjectBase
NAnt.VSNet.ManagedProjectBase
NAnt.VSNet.JSharpProject

[Visual Basic]
Public Class JSharpProject
Inherits ManagedProjectBase
[C#]
public class JSharpProject : ManagedProjectBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

JSharpProject Members | NAnt.VSNet Namespace


JSharpProject Members

JSharpProject overview

Public Static (Shared) Methods

IsSupported Returns a value indicating whether the project represented by the specified XML fragment is supported by JSharpProject.

Public Instance Constructors

JSharpProject Constructor

Public Instance Properties

BuildConfigurations (inherited from ProjectBase) | Gets a list of project configurations that can be build.
ExtraOutputFiles (inherited from ProjectBase) | Gets the extra set of output files for the project.
Guid (inherited from ManagedProjectBase) | Gets or sets the unique identifier of the VS.NET project.
Name (inherited from ManagedProjectBase) | Gets the name of the VS.NET project.
ObjectDir (inherited from ProjectBase) | Get the directory in which intermediate build output that is not specific to the build configuration will be stored.
ProductVersion (inherited from ProjectBase) | Gets the Visual Studio product version of the project.
ProjectConfigurations (inherited from ProjectBase) | Gets a list of all configurations defined in the project.
ProjectDependencies (inherited from ProjectBase) | Gets the set of projects that the project depends on.
ProjectDirectory (inherited from ManagedProjectBase) | Gets the directory containing the VS.NET project.
ProjectLocation (inherited from ManagedProjectBase) | Get the location of the project.
ProjectPath (inherited from ManagedProjectBase) | Gets the path of the VS.NET project.
ProjectSettings (inherited from ManagedProjectBase) |
References (inherited from ManagedProjectBase) |
ReferencesResolver (inherited from ProjectBase) |
SolutionTask (inherited from ProjectBase) |
TemporaryFiles (inherited from ProjectBase) |
Type | Gets the type of the project.

Public Instance Methods

Compile (inherited from ProjectBase) |
CreateProjectReference (inherited from ManagedProjectBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from ProjectBase) |
GetConfiguration (inherited from ProjectBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from ManagedProjectBase) | Gets the complete set of output files for the project configuration matching the specified solution configuration.
GetOutputPath (inherited from ProjectBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from ManagedProjectBase) | Gets a value indicating whether building the project for the specified build configuration results in managed output.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

DevEnvDir (inherited from ProjectBase) |
FileExtension | Gets the default file extension of sources for this project.
GacCache (inherited from ProjectBase) |
OutputDir (inherited from ProjectBase) |

Protected Instance Methods

Build (inherited from ManagedProjectBase) |
CopyFile (inherited from ProjectBase) | Copies the specified file if the destination file does not exist, or the source file has been modified since it was previously copied.
CreateReference (inherited from ManagedProjectBase) |
DetermineProductVersion | Returns the Visual Studio product version of the specified project XML fragment.
DetermineProjectLocation | Returns the project location from the specified project XML fragment.
ExecuteBuildEvent (inherited from ProjectBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetProcessStartInfo | Returns a ProcessStartInfo for launching the compiler for this project.
Log (inherited from ProjectBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Prepare | Prepares the project for being built.
VerifyProjectXml | Verifies whether the specified XML fragment represents a valid project that is supported by this ProjectBase.
WriteCompilerOptions (inherited from ManagedProjectBase) |
WriteProjectOptions (inherited from ManagedProjectBase) |

Protected Internal Instance Methods

ExpandMacro (inherited from ProjectBase) Expands the given macro.

See Also

JSharpProject Class | NAnt.VSNet Namespace


JSharpProject Constructor

[Visual Basic]
Public Sub New( _
ByVal solution As SolutionBase, _
ByVal projectPath As String, _
ByVal xmlDefinition As XmlElement, _
ByVal solutionTask As SolutionTask, _
ByVal tfc As TempFileCollection, _
ByVal gacCache As GacCache, _
ByVal refResolver As ReferencesResolver, _
ByVal outputDir As DirectoryInfo _
)
[C#]
public JSharpProject(
SolutionBase solution,
string projectPath,
XmlElement xmlDefinition,
SolutionTask solutionTask,
TempFileCollection tfc,
GacCache gacCache,
ReferencesResolver refResolver,
DirectoryInfo outputDir
);

See Also

JSharpProject Class | NAnt.VSNet Namespace


JSharpProject Properties

The properties of the JSharpProject class are listed below. For a complete list of JSharpProject class members, see the JSharpProject Members topic.

Public Instance Properties

BuildConfigurations (inherited from ProjectBase) | Gets a list of project configurations that can be build.
ExtraOutputFiles (inherited from ProjectBase) | Gets the extra set of output files for the project.
Guid (inherited from ManagedProjectBase) | Gets or sets the unique identifier of the VS.NET project.
Name (inherited from ManagedProjectBase) | Gets the name of the VS.NET project.
ObjectDir (inherited from ProjectBase) | Get the directory in which intermediate build output that is not specific to the build configuration will be stored.
ProductVersion (inherited from ProjectBase) | Gets the Visual Studio product version of the project.
ProjectConfigurations (inherited from ProjectBase) | Gets a list of all configurations defined in the project.
ProjectDependencies (inherited from ProjectBase) | Gets the set of projects that the project depends on.
ProjectDirectory (inherited from ManagedProjectBase) | Gets the directory containing the VS.NET project.
ProjectLocation (inherited from ManagedProjectBase) | Get the location of the project.
ProjectPath (inherited from ManagedProjectBase) | Gets the path of the VS.NET project.
ProjectSettings (inherited from ManagedProjectBase) |
References (inherited from ManagedProjectBase) |
ReferencesResolver (inherited from ProjectBase) |
SolutionTask (inherited from ProjectBase) |
TemporaryFiles (inherited from ProjectBase) |
Type | Gets the type of the project.

Protected Instance Properties

DevEnvDir (inherited from ProjectBase) |
FileExtension | Gets the default file extension of sources for this project.
GacCache (inherited from ProjectBase) |
OutputDir (inherited from ProjectBase) |

See Also

JSharpProject Class | NAnt.VSNet Namespace


FileExtension Property

NAnt SDK Documentation - v0.91

JSharpProject.FileExtension Property

Gets the default file extension of sources for this project.

[Visual Basic]
Overrides Protected ReadOnly Property FileExtension As String
[C#]
protected override string FileExtension {get;}

Property Value

For J# projects, the default file extension is ".jsl".

See Also

JSharpProject Class | NAnt.VSNet Namespace


Type Property

NAnt SDK Documentation - v0.91

JSharpProject.Type Property

Gets the type of the project.

[Visual Basic]
Overrides Public ReadOnly Property Type As ProjectType
[C#]
public override ProjectType Type {get;}

Property Value

The type of the project.

See Also

JSharpProject Class | NAnt.VSNet Namespace


JSharpProject Methods

The methods of the JSharpProject class are listed below. For a complete list of JSharpProject class members, see the JSharpProject Members topic.

Public Static (Shared) Methods

IsSupported Returns a value indicating whether the project represented by the specified XML fragment is supported by JSharpProject.

Public Instance Methods

Compile (inherited from ProjectBase) |
CreateProjectReference (inherited from ManagedProjectBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from ProjectBase) |
GetConfiguration (inherited from ProjectBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from ManagedProjectBase) | Gets the complete set of output files for the project configuration matching the specified solution configuration.
GetOutputPath (inherited from ProjectBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from ManagedProjectBase) | Gets a value indicating whether building the project for the specified build configuration results in managed output.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Build (inherited from ManagedProjectBase) |
CopyFile (inherited from ProjectBase) | Copies the specified file if the destination file does not exist, or the source file has been modified since it was previously copied.
CreateReference (inherited from ManagedProjectBase) |
DetermineProductVersion | Returns the Visual Studio product version of the specified project XML fragment.
DetermineProjectLocation | Returns the project location from the specified project XML fragment.
ExecuteBuildEvent (inherited from ProjectBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetProcessStartInfo | Returns a ProcessStartInfo for launching the compiler for this project.
Log (inherited from ProjectBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Prepare | Prepares the project for being built.
VerifyProjectXml | Verifies whether the specified XML fragment represents a valid project that is supported by this ProjectBase.
WriteCompilerOptions (inherited from ManagedProjectBase) |
WriteProjectOptions (inherited from ManagedProjectBase) |

Protected Internal Instance Methods

ExpandMacro (inherited from ProjectBase) Expands the given macro.

See Also

JSharpProject Class | NAnt.VSNet Namespace


JSharpProject.DetermineProductVersion Method

Returns the Visual Studio product version of the specified project XML fragment.

[Visual Basic]
Overrides Protected Function DetermineProductVersion( _
ByVal docElement As XmlElement _
) As ProductVersion
[C#]
protected override ProductVersion DetermineProductVersion(
XmlElement docElement
);

Parameters

docElement
The document element of the project.

Return Value

The Visual Studio product version of the specified project XML fragment.

Exceptions

Exception Type | Condition
BuildException | The product version could not be determined. -or- The product version is not supported.

See Also

JSharpProject Class | NAnt.VSNet Namespace


JSharpProject.DetermineProjectLocation Method

Returns the project location from the specified project XML fragment.

[Visual Basic]
Overrides Protected Function DetermineProjectLocation( _
ByVal docElement As XmlElement _
) As ProjectLocation
[C#]
protected override ProjectLocation DetermineProjectLocation(
XmlElement docElement
);

Parameters

docElement
XML fragment representing the project file.

Return Value

The project location of the specified project XML file.

Exceptions

Exception Type | Condition
BuildException | The project location could not be determined. -or- The project location is invalid.

See Also

JSharpProject Class | NAnt.VSNet Namespace


JSharpProject.GetProcessStartInfo Method

Returns a ProcessStartInfo for launching the compiler for this project.

[Visual Basic]
Overrides Protected Function GetProcessStartInfo( _
ByVal config As ConfigurationBase, _
ByVal responseFile As String _
) As ProcessStartInfo
[C#]
protected override ProcessStartInfo GetProcessStartInfo(
ConfigurationBase config,
string responseFile
);

Parameters

config
The configuration to build.
responseFile
The response file for the compiler.

Return Value

A ProcessStartInfo for launching the compiler for this project.

See Also

JSharpProject Class | NAnt.VSNet Namespace


JSharpProject.IsSupported Method

Returns a value indicating whether the project represented by the specified XML fragment is supported by JSharpProject.

[Visual Basic]
Public Shared Function IsSupported( _
ByVal docElement As XmlElement _
) As Boolean
[C#]
public static bool IsSupported(
XmlElement docElement
);

Parameters

docElement
XML fragment representing the project to check.

Return Value

true if CSharpProject supports the specified project; otherwise, false.

Remarks

A project is identified as as J# project, if the XML fragment at least has the following information:

<VisualStudioProject>
    <JSHARP
        ProductVersion="..."
        ....
    >
        ...
    </JSHARP>
</VisualStudioProject>

See Also

JSharpProject Class | NAnt.VSNet Namespace


JSharpProject.Prepare Method

Prepares the project for being built.

[Visual Basic]
Overrides Protected Sub Prepare( _
ByVal solutionConfiguration As Configuration _
)
[C#]
protected override void Prepare(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Remarks

Ensures the configuration-level object directory exists and ensures that none of the output files are marked read-only.

See Also

JSharpProject Class | NAnt.VSNet Namespace


JSharpProject.VerifyProjectXml Method

Verifies whether the specified XML fragment represents a valid project that is supported by this ProjectBase.

[Visual Basic]
Overrides Protected Sub VerifyProjectXml( _
ByVal docElement As XmlElement _
)
[C#]
protected override void VerifyProjectXml(
XmlElement docElement
);

Parameters

docElement
XML fragment representing the project file.

Exceptions

Exception Type | Condition
BuildException | The XML fragment is not supported by this ProjectBase. -or- The XML fragment does not represent a valid project (for this ProjectBase).

See Also

JSharpProject Class | NAnt.VSNet Namespace


ManagedAssemblyReference Class

For a list of all members of this type, see ManagedAssemblyReference Members.

System.Object
NAnt.VSNet.ReferenceBase
NAnt.VSNet.FileReferenceBase
NAnt.VSNet.AssemblyReferenceBase
NAnt.VSNet.ManagedAssemblyReference

[Visual Basic]
Public Class ManagedAssemblyReference
Inherits AssemblyReferenceBase
[C#]
public class ManagedAssemblyReference : AssemblyReferenceBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ManagedAssemblyReference Members | NAnt.VSNet Namespace


ManagedAssemblyReference Members

ManagedAssemblyReference overview

Public Instance Constructors

ManagedAssemblyReference Constructor

Public Instance Properties

CopyLocal (inherited from AssemblyReferenceBase) | Gets a value indicating whether the output file(s) of this reference should be copied locally.
Name | Gets the name of the referenced assembly.

Public Instance Methods

CreateProjectReference (inherited from AssemblyReferenceBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from AssemblyReferenceBase) | Gets the complete set of assemblies that need to be referenced when a project references this component.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from AssemblyReferenceBase) | Gets the complete set of output files for the referenced project.
GetPrimaryOutputFile (inherited from AssemblyReferenceBase) | Gets the path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp (inherited from AssemblyReferenceBase) | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from FileReferenceBase) | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

GacCache (inherited from FileReferenceBase) |
IsPrivate |
IsPrivateSpecified |
IsSystem (inherited from AssemblyReferenceBase) | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |
XmlDefinition (inherited from FileReferenceBase) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAssemblyOutputFiles (inherited from FileReferenceBase) | Gets the complete set of output files for the specified assembly and adds them to collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ResolveAssemblyReference | Resolves an assembly reference.
ResolveFromAssemblyFolders |
ResolveFromFolderList (inherited from AssemblyReferenceBase) | Searches for the given file in all paths in folderList.
ResolveFromFramework (inherited from AssemblyReferenceBase) | Resolves an assembly reference in the framework assembly directory of the target framework.
ResolveFromRelativePath (inherited from AssemblyReferenceBase) | Resolves an assembly reference using a path relative to the project directory.

See Also

ManagedAssemblyReference Class | NAnt.VSNet Namespace


ManagedAssemblyReference Constructor

[Visual Basic]
Public Sub New( _
ByVal xmlDefinition As XmlElement, _
ByVal referencesResolver As ReferencesResolver, _
ByVal parent As ProjectBase, _
ByVal gacCache As GacCache _
)
[C#]
public ManagedAssemblyReference(
XmlElement xmlDefinition,
ReferencesResolver referencesResolver,
ProjectBase parent,
GacCache gacCache
);

See Also

ManagedAssemblyReference Class | NAnt.VSNet Namespace


ManagedAssemblyReference Properties

The properties of the ManagedAssemblyReference class are listed below. For a complete list of ManagedAssemblyReference class members, see the ManagedAssemblyReference Members topic.

Public Instance Properties

CopyLocal (inherited from AssemblyReferenceBase) | Gets a value indicating whether the output file(s) of this reference should be copied locally.
Name | Gets the name of the referenced assembly.

Protected Instance Properties

GacCache (inherited from FileReferenceBase) |
IsPrivate |
IsPrivateSpecified |
IsSystem (inherited from AssemblyReferenceBase) | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |
XmlDefinition (inherited from FileReferenceBase) |

See Also

ManagedAssemblyReference Class | NAnt.VSNet Namespace


IsPrivate Property

NAnt SDK Documentation - v0.91

ManagedAssemblyReference.IsPrivate Property

[Visual Basic]
Overrides Protected ReadOnly Property IsPrivate As Boolean
[C#]
protected override bool IsPrivate {get;}

See Also

ManagedAssemblyReference Class | NAnt.VSNet Namespace


IsPrivateSpecified Property

NAnt SDK Documentation - v0.91

ManagedAssemblyReference.IsPrivateSpecified Property

[Visual Basic]
Overrides Protected ReadOnly Property IsPrivateSpecified As Boolean
[C#]
protected override bool IsPrivateSpecified {get;}

See Also

ManagedAssemblyReference Class | NAnt.VSNet Namespace


Name Property

NAnt SDK Documentation - v0.91

ManagedAssemblyReference.Name Property

Gets the name of the referenced assembly.

[Visual Basic]
Overrides Public ReadOnly Property Name As String
[C#]
public override string Name {get;}

Property Value

The name of the referenced assembly, or a null reference (Nothing in Visual Basic) if the name could not be determined.

See Also

ManagedAssemblyReference Class | NAnt.VSNet Namespace


ManagedAssemblyReference Methods

The methods of the ManagedAssemblyReference class are listed below. For a complete list of ManagedAssemblyReference class members, see the ManagedAssemblyReference Members topic.

Public Instance Methods

CreateProjectReference (inherited from AssemblyReferenceBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from AssemblyReferenceBase) | Gets the complete set of assemblies that need to be referenced when a project references this component.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from AssemblyReferenceBase) | Gets the complete set of output files for the referenced project.
GetPrimaryOutputFile (inherited from AssemblyReferenceBase) | Gets the path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp (inherited from AssemblyReferenceBase) | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from FileReferenceBase) | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAssemblyOutputFiles (inherited from FileReferenceBase) | Gets the complete set of output files for the specified assembly and adds them to collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ResolveAssemblyReference | Resolves an assembly reference.
ResolveFromAssemblyFolders |
ResolveFromFolderList (inherited from AssemblyReferenceBase) | Searches for the given file in all paths in folderList.
ResolveFromFramework (inherited from AssemblyReferenceBase) | Resolves an assembly reference in the framework assembly directory of the target framework.
ResolveFromRelativePath (inherited from AssemblyReferenceBase) | Resolves an assembly reference using a path relative to the project directory.

See Also

ManagedAssemblyReference Class | NAnt.VSNet Namespace


ManagedAssemblyReference.ResolveAssemblyReference Method

Resolves an assembly reference.

[Visual Basic]
Overrides Protected Function ResolveAssemblyReference() As String
[C#]
protected override string ResolveAssemblyReference();

Return Value

The full path to the resolved assembly, or a null reference (Nothing in Visual Basic) if the assembly reference could not be resolved.

Remarks

Visual Studio .NET uses the following search mechanism :

  1. The project directory.
  2. The directories specified in the "ReferencePath" property, which is stored in the .USER file.
  3. The .NET Framework directory (see KB306149)

  4. The directories specified under the following registry keys:

    • HKLM\SOFTWARE\Microsoft\.NETFramework\AssemblyFolders
    • HKCU\SOFTWARE\Microsoft\.NETFramework\AssemblyFolders
    • HKLM\SOFTWARE\Microsoft\VisualStudio\<major version>.<minor version>\AssemblyFolders
    • HKCU\SOFTWARE\Microsoft\VisualStudio\<major version>.<minor version>\AssemblyFolders

    Future versions of Visual Studio .NET will also check in:

    • HKLM\SOFTWARE\Microsoft\.NETFramework\AssemblyFoldersEx
    • HKCU\SOFTWARE\Microsoft\.NETFramework\AssemblyFoldersEx
  5. The HintPath.

See Also

ManagedAssemblyReference Class | NAnt.VSNet Namespace


ManagedAssemblyReference.ResolveFromAssemblyFolders Method

[Visual Basic]
Overrides Protected Function ResolveFromAssemblyFolders( _
ByVal referenceElement As XmlElement, _
ByVal fileName As String _
) As String
[C#]
protected override string ResolveFromAssemblyFolders(
XmlElement referenceElement,
string fileName
);

See Also

ManagedAssemblyReference Class | NAnt.VSNet Namespace


ManagedOutputType Enumeration

Indentifies the different output types of a managed project.

[Visual Basic]
<Serializable>
Public Enum ManagedOutputType
[C#]
[Serializable]
public enum ManagedOutputType

Remarks

Visual Studio .NET does not support modules.

Members

Member Name | Description
Library | A class library.
Executable | A console application.
WindowsExecutable | A Windows program.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

NAnt.VSNet Namespace


ManagedProjectBase Class

For a list of all members of this type, see ManagedProjectBase Members.

System.Object
NAnt.VSNet.ProjectBase
NAnt.VSNet.ManagedProjectBase
NAnt.VSNet.CSharpProject
NAnt.VSNet.JSharpProject
NAnt.VSNet.VBProject

[Visual Basic]
MustInherit Public Class ManagedProjectBase
Inherits ProjectBase
[C#]
public abstract class ManagedProjectBase : ProjectBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ManagedProjectBase Members | NAnt.VSNet Namespace


ManagedProjectBase Members

ManagedProjectBase overview

Public Static (Shared) Methods

IsEnterpriseTemplateProject
LoadGuid

Protected Static (Shared) Methods

GetProductVersion | Returns the Visual Studio product version of the specified project XML fragment.
GetProjectLocation | Returns the ProjectLocation of the specified project XML fragment.

Public Instance Properties

BuildConfigurations (inherited from ProjectBase) | Gets a list of project configurations that can be build.
ExtraOutputFiles (inherited from ProjectBase) | Gets the extra set of output files for the project.
Guid | Gets or sets the unique identifier of the VS.NET project.
Name | Gets the name of the VS.NET project.
ObjectDir (inherited from ProjectBase) | Get the directory in which intermediate build output that is not specific to the build configuration will be stored.
ProductVersion (inherited from ProjectBase) | Gets the Visual Studio product version of the project.
ProjectConfigurations (inherited from ProjectBase) | Gets a list of all configurations defined in the project.
ProjectDependencies (inherited from ProjectBase) | Gets the set of projects that the project depends on.
ProjectDirectory | Gets the directory containing the VS.NET project.
ProjectLocation | Get the location of the project.
ProjectPath | Gets the path of the VS.NET project.
ProjectSettings |
References |
ReferencesResolver (inherited from ProjectBase) |
SolutionTask (inherited from ProjectBase) |
TemporaryFiles (inherited from ProjectBase) |
Type (inherited from ProjectBase) | Gets the type of the project.

Public Instance Methods

Compile (inherited from ProjectBase) |
CreateProjectReference |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from ProjectBase) |
GetConfiguration (inherited from ProjectBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles | Gets the complete set of output files for the project configuration matching the specified solution configuration.
GetOutputPath (inherited from ProjectBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged | Gets a value indicating whether building the project for the specified build configuration results in managed output.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ManagedProjectBase Constructor

Protected Instance Properties

DevEnvDir (inherited from ProjectBase) |
FileExtension | Gets the default file extension of sources for this project.
GacCache (inherited from ProjectBase) |
OutputDir (inherited from ProjectBase) |

Protected Instance Methods

Build |
CopyFile (inherited from ProjectBase) | Copies the specified file if the destination file does not exist, or the source file has been modified since it was previously copied.
CreateReference |
DetermineProductVersion (inherited from ProjectBase) | Returns the Visual Studio product version of the specified project XML fragment.
DetermineProjectLocation | Returns the project location from the specified project XML fragment.
ExecuteBuildEvent (inherited from ProjectBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetProcessStartInfo | Returns a ProcessStartInfo for launching the compiler for this project.
Log (inherited from ProjectBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Prepare | Prepares the project for being built.
VerifyProjectXml (inherited from ProjectBase) | Verifies whether the specified XML fragment represents a valid project that is supported by this ProjectBase.
WriteCompilerOptions |
WriteProjectOptions |

Protected Internal Instance Methods

ExpandMacro (inherited from ProjectBase) Expands the given macro.

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ManagedProjectBase Constructor

[Visual Basic]
Protected Sub New( _
ByVal solution As SolutionBase, _
ByVal projectPath As String, _
ByVal xmlDefinition As XmlElement, _
ByVal solutionTask As SolutionTask, _
ByVal tfc As TempFileCollection, _
ByVal gacCache As GacCache, _
ByVal refResolver As ReferencesResolver, _
ByVal outputDir As DirectoryInfo _
)
[C#]
protected ManagedProjectBase(
SolutionBase solution,
string projectPath,
XmlElement xmlDefinition,
SolutionTask solutionTask,
TempFileCollection tfc,
GacCache gacCache,
ReferencesResolver refResolver,
DirectoryInfo outputDir
);

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ManagedProjectBase Properties

The properties of the ManagedProjectBase class are listed below. For a complete list of ManagedProjectBase class members, see the ManagedProjectBase Members topic.

Public Instance Properties

BuildConfigurations (inherited from ProjectBase) | Gets a list of project configurations that can be build.
ExtraOutputFiles (inherited from ProjectBase) | Gets the extra set of output files for the project.
Guid | Gets or sets the unique identifier of the VS.NET project.
Name | Gets the name of the VS.NET project.
ObjectDir (inherited from ProjectBase) | Get the directory in which intermediate build output that is not specific to the build configuration will be stored.
ProductVersion (inherited from ProjectBase) | Gets the Visual Studio product version of the project.
ProjectConfigurations (inherited from ProjectBase) | Gets a list of all configurations defined in the project.
ProjectDependencies (inherited from ProjectBase) | Gets the set of projects that the project depends on.
ProjectDirectory | Gets the directory containing the VS.NET project.
ProjectLocation | Get the location of the project.
ProjectPath | Gets the path of the VS.NET project.
ProjectSettings |
References |
ReferencesResolver (inherited from ProjectBase) |
SolutionTask (inherited from ProjectBase) |
TemporaryFiles (inherited from ProjectBase) |
Type (inherited from ProjectBase) | Gets the type of the project.

Protected Instance Properties

DevEnvDir (inherited from ProjectBase) |
FileExtension | Gets the default file extension of sources for this project.
GacCache (inherited from ProjectBase) |
OutputDir (inherited from ProjectBase) |

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


FileExtension Property

NAnt SDK Documentation - v0.91

ManagedProjectBase.FileExtension Property

Gets the default file extension of sources for this project.

[Visual Basic]
MustOverride Protected ReadOnly Property FileExtension As String
[C#]
protected abstract string FileExtension {get;}

Property Value

The default file extension of sources for this project.

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


Guid Property

NAnt SDK Documentation - v0.91

ManagedProjectBase.Guid Property

Gets or sets the unique identifier of the VS.NET project.

[Visual Basic]
Overrides Public Property Guid As String
[C#]
public override string Guid {get; set;}

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


Name Property

NAnt SDK Documentation - v0.91

ManagedProjectBase.Name Property

Gets the name of the VS.NET project.

[Visual Basic]
Overrides Public ReadOnly Property Name As String
[C#]
public override string Name {get;}

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ProjectDirectory Property

NAnt SDK Documentation - v0.91

ManagedProjectBase.ProjectDirectory Property

Gets the directory containing the VS.NET project.

[Visual Basic]
Overrides Public ReadOnly Property ProjectDirectory As DirectoryInfo
[C#]
public override System.IO.DirectoryInfo ProjectDirectory {get;}

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ProjectLocation Property

NAnt SDK Documentation - v0.91

ManagedProjectBase.ProjectLocation Property

Get the location of the project.

[Visual Basic]
Overrides Public ReadOnly Property ProjectLocation As ProjectLocation
[C#]
public override ProjectLocation ProjectLocation {get;}

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ProjectPath Property

NAnt SDK Documentation - v0.91

ManagedProjectBase.ProjectPath Property

Gets the path of the VS.NET project.

[Visual Basic]
Overrides Public ReadOnly Property ProjectPath As String
[C#]
public override string ProjectPath {get;}

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ProjectSettings Property

NAnt SDK Documentation - v0.91

ManagedProjectBase.ProjectSettings Property

[Visual Basic]
Public ReadOnly Property ProjectSettings As ProjectSettings
[C#]
public ProjectSettings ProjectSettings {get;}

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


References Property

NAnt SDK Documentation - v0.91

ManagedProjectBase.References Property

[Visual Basic]
Overrides Public ReadOnly Property References As ArrayList
[C#]
public override System.Collections.ArrayList References {get;}

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ManagedProjectBase Methods

The methods of the ManagedProjectBase class are listed below. For a complete list of ManagedProjectBase class members, see the ManagedProjectBase Members topic.

Public Static (Shared) Methods

IsEnterpriseTemplateProject
LoadGuid

Protected Static (Shared) Methods

GetProductVersion | Returns the Visual Studio product version of the specified project XML fragment.
GetProjectLocation | Returns the ProjectLocation of the specified project XML fragment.

Public Instance Methods

Compile (inherited from ProjectBase) |
CreateProjectReference |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from ProjectBase) |
GetConfiguration (inherited from ProjectBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles | Gets the complete set of output files for the project configuration matching the specified solution configuration.
GetOutputPath (inherited from ProjectBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged | Gets a value indicating whether building the project for the specified build configuration results in managed output.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Build |
CopyFile (inherited from ProjectBase) | Copies the specified file if the destination file does not exist, or the source file has been modified since it was previously copied.
CreateReference |
DetermineProductVersion (inherited from ProjectBase) | Returns the Visual Studio product version of the specified project XML fragment.
DetermineProjectLocation | Returns the project location from the specified project XML fragment.
ExecuteBuildEvent (inherited from ProjectBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetProcessStartInfo | Returns a ProcessStartInfo for launching the compiler for this project.
Log (inherited from ProjectBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Prepare | Prepares the project for being built.
VerifyProjectXml (inherited from ProjectBase) | Verifies whether the specified XML fragment represents a valid project that is supported by this ProjectBase.
WriteCompilerOptions |
WriteProjectOptions |

Protected Internal Instance Methods

ExpandMacro (inherited from ProjectBase) Expands the given macro.

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ManagedProjectBase.Build Method

[Visual Basic]
Overrides Protected Function Build( _
ByVal solutionConfiguration As Configuration _
) As BuildResult
[C#]
protected override BuildResult Build(
Configuration solutionConfiguration
);

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ManagedProjectBase.CreateProjectReference Method

[Visual Basic]
Overrides Public Function CreateProjectReference( _
ByVal project As ProjectBase, _
ByVal isPrivateSpecified As Boolean, _
ByVal isPrivate As Boolean _
) As ProjectReferenceBase
[C#]
public override ProjectReferenceBase CreateProjectReference(
ProjectBase project,
bool isPrivateSpecified,
bool isPrivate
);

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ManagedProjectBase.CreateReference Method

[Visual Basic]
Overridable Protected Function CreateReference( _
ByVal solution As SolutionBase, _
ByVal xmlDefinition As XmlElement _
) As ReferenceBase
[C#]
protected virtual ReferenceBase CreateReference(
SolutionBase solution,
XmlElement xmlDefinition
);

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ManagedProjectBase.DetermineProjectLocation Method

Returns the project location from the specified project XML fragment.

[Visual Basic]
MustOverride Protected Function DetermineProjectLocation( _
ByVal docElement As XmlElement _
) As ProjectLocation
[C#]
protected abstract ProjectLocation DetermineProjectLocation(
XmlElement docElement
);

Parameters

docElement
XML fragment representing the project file.

Return Value

The project location of the specified project XML file.

Exceptions

Exception Type | Condition
BuildException | The project location could not be determined. -or- The project location is invalid.

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ManagedProjectBase.GetOutputFiles Method

Gets the complete set of output files for the project configuration matching the specified solution configuration.

[Visual Basic]
Overrides Public Sub GetOutputFiles( _
ByVal solutionConfiguration As Configuration, _
ByVal outputFiles As Hashtable _
)
[C#]
public override void GetOutputFiles(
Configuration solutionConfiguration,
Hashtable outputFiles
);

Parameters

solutionConfiguration
The solution configuration that is built.
outputFiles
The set of output files to be updated.

Remarks

The key of the case-insensitive Hashtable is the full path of the output file and the value is the path relative to the output directory.

If the project is not configured to be built for the specified solution configuration, then no output files are added.

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ManagedProjectBase.GetProcessStartInfo Method

Returns a ProcessStartInfo for launching the compiler for this project.

[Visual Basic]
MustOverride Protected Function GetProcessStartInfo( _
ByVal config As ConfigurationBase, _
ByVal responseFile As String _
) As ProcessStartInfo
[C#]
protected abstract ProcessStartInfo GetProcessStartInfo(
ConfigurationBase config,
string responseFile
);

Parameters

config
The configuration to build.
responseFile
The response file for the compiler.

Return Value

A ProcessStartInfo for launching the compiler for this project.

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ManagedProjectBase.GetProductVersion Method

Returns the Visual Studio product version of the specified project XML fragment.

[Visual Basic]
Protected Shared Function GetProductVersion( _
ByVal projectNode As XmlNode _
) As ProductVersion
[C#]
protected static ProductVersion GetProductVersion(
XmlNode projectNode
);

Parameters

projectNode
XML fragment representing the project to check.

Return Value

The Visual Studio product version of the specified project XML fragment.

Exceptions

Exception Type | Condition
BuildException | The product version could not be determined. -or- The product version is not supported.

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ManagedProjectBase.GetProjectLocation Method

Returns the ProjectLocation of the specified project XML fragment.

[Visual Basic]
Protected Shared Function GetProjectLocation( _
ByVal projectNode As XmlNode _
) As ProjectLocation
[C#]
protected static ProjectLocation GetProjectLocation(
XmlNode projectNode
);

Parameters

projectNode
XML fragment representing the project to check.

Return Value

The ProjectLocation of the specified project XML fragment.

Exceptions

Exception Type | Condition
BuildException | The project location could not be determined. -or- The project location is invalid.

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ManagedProjectBase.IsEnterpriseTemplateProject Method

[Visual Basic]
Public Shared Function IsEnterpriseTemplateProject( _
ByVal fileName As String _
) As Boolean
[C#]
public static bool IsEnterpriseTemplateProject(
string fileName
);

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ManagedProjectBase.IsManaged Method

Gets a value indicating whether building the project for the specified build configuration results in managed output.

[Visual Basic]
Overrides Public Function IsManaged( _
ByVal solutionConfiguration As Configuration _
) As Boolean
[C#]
public override bool IsManaged(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Return Value

true.

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ManagedProjectBase.LoadGuid Method

[Visual Basic]
Public Shared Function LoadGuid( _
ByVal xmlDefinition As XmlElement _
) As String
[C#]
public static string LoadGuid(
XmlElement xmlDefinition
);

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ManagedProjectBase.Prepare Method

Prepares the project for being built.

[Visual Basic]
Overrides Protected Sub Prepare( _
ByVal solutionConfiguration As Configuration _
)
[C#]
protected override void Prepare(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Remarks

Ensures the configuration-level object directory exists and ensures that none of the output files are marked read-only.

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ManagedProjectBase.WriteCompilerOptions Method

[Visual Basic]
Overridable Protected Sub WriteCompilerOptions( _
ByVal sw As StreamWriter, _
ByVal solutionConfiguration As Configuration _
)
[C#]
protected virtual void WriteCompilerOptions(
StreamWriter sw,
Configuration solutionConfiguration
);

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ManagedProjectBase.WriteProjectOptions Method

[Visual Basic]
Overridable Protected Sub WriteProjectOptions( _
ByVal sw As StreamWriter _
)
[C#]
protected virtual void WriteProjectOptions(
StreamWriter sw
);

See Also

ManagedProjectBase Class | NAnt.VSNet Namespace


ManagedProjectReference Class

For a list of all members of this type, see ManagedProjectReference Members.

System.Object
NAnt.VSNet.ReferenceBase
NAnt.VSNet.ProjectReferenceBase
NAnt.VSNet.ManagedProjectReference

[Visual Basic]
Public Class ManagedProjectReference
Inherits ProjectReferenceBase
[C#]
public class ManagedProjectReference : ProjectReferenceBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ManagedProjectReference Members | NAnt.VSNet Namespace


ManagedProjectReference Members

ManagedProjectReference overview

Public Instance Constructors

ManagedProjectReference Overloaded. Initializes a new instance of the ManagedProjectReference class.

Public Instance Properties

CopyLocal (inherited from ProjectReferenceBase) | Gets a value indicating whether the output file(s) of this reference should be copied locally.
Name (inherited from ProjectReferenceBase) |
Project |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from ProjectReferenceBase) | Gets the complete set of assemblies that need to be referenced when a project references this project.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from ProjectReferenceBase) | Gets the complete set of output files for the referenced project.
GetPrimaryOutputFile (inherited from ProjectReferenceBase) | Gets the output path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp (inherited from ProjectReferenceBase) | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsPrivate |
IsPrivateSpecified |
IsSystem (inherited from ProjectReferenceBase) | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
LoadProject (inherited from ProjectReferenceBase) |
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ManagedProjectReference Class | NAnt.VSNet Namespace


ManagedProjectReference Constructor

Overload List

public ManagedProjectReference(ProjectBase,ProjectBase,bool,bool);

public ManagedProjectReference(XmlElement,ReferencesResolver,ProjectBase,SolutionBase,TempFileCollection,GacCache,DirectoryInfo);

See Also

ManagedProjectReference Class | NAnt.VSNet Namespace


ManagedProjectReference Constructor (XmlElement, ReferencesResolver, ProjectBase, SolutionBase, TempFileCollection, GacCache, DirectoryInfo)

[Visual Basic]
Overloads Public Sub New( _
ByVal xmlDefinition As XmlElement, _
ByVal referencesResolver As ReferencesResolver, _
ByVal parent As ProjectBase, _
ByVal solution As SolutionBase, _
ByVal tfc As TempFileCollection, _
ByVal gacCache As GacCache, _
ByVal outputDir As DirectoryInfo _
)
[C#]
public ManagedProjectReference(
XmlElement xmlDefinition,
ReferencesResolver referencesResolver,
ProjectBase parent,
SolutionBase solution,
TempFileCollection tfc,
GacCache gacCache,
DirectoryInfo outputDir
);

See Also

ManagedProjectReference Class | NAnt.VSNet Namespace | ManagedProjectReference Constructor Overload List


ManagedProjectReference Constructor (ProjectBase, ProjectBase, Boolean, Boolean)

[Visual Basic]
Overloads Public Sub New( _
ByVal project As ProjectBase, _
ByVal parent As ProjectBase, _
ByVal isPrivateSpecified As Boolean, _
ByVal isPrivate As Boolean _
)
[C#]
public ManagedProjectReference(
ProjectBase project,
ProjectBase parent,
bool isPrivateSpecified,
bool isPrivate
);

See Also

ManagedProjectReference Class | NAnt.VSNet Namespace | ManagedProjectReference Constructor Overload List


ManagedProjectReference Properties

The properties of the ManagedProjectReference class are listed below. For a complete list of ManagedProjectReference class members, see the ManagedProjectReference Members topic.

Public Instance Properties

CopyLocal (inherited from ProjectReferenceBase) | Gets a value indicating whether the output file(s) of this reference should be copied locally.
Name (inherited from ProjectReferenceBase) |
Project |

Protected Instance Properties

IsPrivate |
IsPrivateSpecified |
IsSystem (inherited from ProjectReferenceBase) | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |

See Also

ManagedProjectReference Class | NAnt.VSNet Namespace


IsPrivate Property

NAnt SDK Documentation - v0.91

ManagedProjectReference.IsPrivate Property

[Visual Basic]
Overrides Protected ReadOnly Property IsPrivate As Boolean
[C#]
protected override bool IsPrivate {get;}

See Also

ManagedProjectReference Class | NAnt.VSNet Namespace


IsPrivateSpecified Property

NAnt SDK Documentation - v0.91

ManagedProjectReference.IsPrivateSpecified Property

[Visual Basic]
Overrides Protected ReadOnly Property IsPrivateSpecified As Boolean
[C#]
protected override bool IsPrivateSpecified {get;}

See Also

ManagedProjectReference Class | NAnt.VSNet Namespace


Project Property

NAnt SDK Documentation - v0.91

ManagedProjectReference.Project Property

[Visual Basic]
Overrides Public ReadOnly Property Project As ProjectBase
[C#]
public override ProjectBase Project {get;}

See Also

ManagedProjectReference Class | NAnt.VSNet Namespace


ManagedProjectReference Methods

The methods of the ManagedProjectReference class are listed below. For a complete list of ManagedProjectReference class members, see the ManagedProjectReference Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from ProjectReferenceBase) | Gets the complete set of assemblies that need to be referenced when a project references this project.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from ProjectReferenceBase) | Gets the complete set of output files for the referenced project.
GetPrimaryOutputFile (inherited from ProjectReferenceBase) | Gets the output path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp (inherited from ProjectReferenceBase) | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
LoadProject (inherited from ProjectReferenceBase) |
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ManagedProjectReference Class | NAnt.VSNet Namespace


ManagedProjectReference.IsManaged Method

Gets a value indicating whether the reference is managed for the specified configuration.

[Visual Basic]
Overrides Public Function IsManaged( _
ByVal solutionConfiguration As Configuration _
) As Boolean
[C#]
public override bool IsManaged(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Return Value

true.

See Also

ManagedProjectReference Class | NAnt.VSNet Namespace


ManagedWrapperReference Class

For a list of all members of this type, see ManagedWrapperReference Members.

System.Object
NAnt.VSNet.ReferenceBase
NAnt.VSNet.FileReferenceBase
NAnt.VSNet.WrapperReferenceBase
NAnt.VSNet.ManagedWrapperReference

[Visual Basic]
Public Class ManagedWrapperReference
Inherits WrapperReferenceBase
[C#]
public class ManagedWrapperReference : WrapperReferenceBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ManagedWrapperReference Members | NAnt.VSNet Namespace


ManagedWrapperReference Members

ManagedWrapperReference overview

Public Instance Constructors

ManagedWrapperReference Constructor

Public Instance Properties

CopyLocal (inherited from WrapperReferenceBase) | Gets a value indicating whether the output file(s) of this reference should be copied locally.
IsCreated (inherited from WrapperReferenceBase) | Gets a value indicating whether the wrapper assembly has already been created.
Name | Gets the name of the referenced assembly.
WrapperAssembly | Gets the path of the wrapper assembly.
WrapperTool | Gets the name of the tool that should be used to create the WrapperAssembly.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from WrapperReferenceBase) | Gets the complete set of assemblies that need to be referenced when a project references this component.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from WrapperReferenceBase) | Gets the complete set of output files for the referenced project.
GetPrimaryOutputFile (inherited from WrapperReferenceBase) | Gets the path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp (inherited from WrapperReferenceBase) | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from FileReferenceBase) | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

GacCache (inherited from FileReferenceBase) |
IsSystem (inherited from WrapperReferenceBase) | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
PrimaryInteropAssembly | Gets the path of the Primary Interop Assembly.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |
TypeLibGuid | Gets the GUID of the type library as defined in the definition of the reference.
TypeLibLocale | Gets the locale of the type library in hex notation.
TypeLibraryName (inherited from WrapperReferenceBase) | Gets the name of the type library.
TypeLibVersion | Gets the hex version of the type library as defined in the definition of the reference.
XmlDefinition (inherited from FileReferenceBase) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAssemblyOutputFiles (inherited from FileReferenceBase) | Gets the complete set of output files for the specified assembly and adds them to collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
GetPrimaryInteropAssembly (inherited from WrapperReferenceBase) |
GetTypeLibrary (inherited from WrapperReferenceBase) |
GetTypeLibraryName (inherited from WrapperReferenceBase) |
ImportActiveXLibrary |
ImportTypeLibrary |
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ResolveWrapperAssembly (inherited from WrapperReferenceBase) |

See Also

ManagedWrapperReference Class | NAnt.VSNet Namespace


ManagedWrapperReference Constructor

[Visual Basic]
Public Sub New( _
ByVal xmlDefinition As XmlElement, _
ByVal referencesResolver As ReferencesResolver, _
ByVal parent As ProjectBase, _
ByVal gacCache As GacCache, _
ByVal projectSettings As ProjectSettings _
)
[C#]
public ManagedWrapperReference(
XmlElement xmlDefinition,
ReferencesResolver referencesResolver,
ProjectBase parent,
GacCache gacCache,
ProjectSettings projectSettings
);

See Also

ManagedWrapperReference Class | NAnt.VSNet Namespace


ManagedWrapperReference Properties

The properties of the ManagedWrapperReference class are listed below. For a complete list of ManagedWrapperReference class members, see the ManagedWrapperReference Members topic.

Public Instance Properties

CopyLocal (inherited from WrapperReferenceBase) | Gets a value indicating whether the output file(s) of this reference should be copied locally.
IsCreated (inherited from WrapperReferenceBase) | Gets a value indicating whether the wrapper assembly has already been created.
Name | Gets the name of the referenced assembly.
WrapperAssembly | Gets the path of the wrapper assembly.
WrapperTool | Gets the name of the tool that should be used to create the WrapperAssembly.

Protected Instance Properties

GacCache (inherited from FileReferenceBase) |
IsSystem (inherited from WrapperReferenceBase) | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
PrimaryInteropAssembly | Gets the path of the Primary Interop Assembly.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |
TypeLibGuid | Gets the GUID of the type library as defined in the definition of the reference.
TypeLibLocale | Gets the locale of the type library in hex notation.
TypeLibraryName (inherited from WrapperReferenceBase) | Gets the name of the type library.
TypeLibVersion | Gets the hex version of the type library as defined in the definition of the reference.
XmlDefinition (inherited from FileReferenceBase) |

See Also

ManagedWrapperReference Class | NAnt.VSNet Namespace


Name Property

NAnt SDK Documentation - v0.91

ManagedWrapperReference.Name Property

Gets the name of the referenced assembly.

[Visual Basic]
Overrides Public ReadOnly Property Name As String
[C#]
public override string Name {get;}

Property Value

The name of the referenced assembly, or a null reference (Nothing in Visual Basic) if the name could not be determined.

See Also

ManagedWrapperReference Class | NAnt.VSNet Namespace


PrimaryInteropAssembly Property

NAnt SDK Documentation - v0.91

ManagedWrapperReference.PrimaryInteropAssembly Property

Gets the path of the Primary Interop Assembly.

[Visual Basic]
Overrides Protected ReadOnly Property PrimaryInteropAssembly As String
[C#]
protected override string PrimaryInteropAssembly {get;}

Property Value

The path of the Primary Interop Assembly, or a null reference (Nothing in Visual Basic) if not available.

See Also

ManagedWrapperReference Class | NAnt.VSNet Namespace


TypeLibGuid Property

NAnt SDK Documentation - v0.91

ManagedWrapperReference.TypeLibGuid Property

Gets the GUID of the type library as defined in the definition of the reference.

[Visual Basic]
Overrides Protected ReadOnly Property TypeLibGuid As String
[C#]
protected override string TypeLibGuid {get;}

Property Value

The GUID of the type library.

See Also

ManagedWrapperReference Class | NAnt.VSNet Namespace


TypeLibLocale Property

NAnt SDK Documentation - v0.91

ManagedWrapperReference.TypeLibLocale Property

Gets the locale of the type library in hex notation.

[Visual Basic]
Overrides Protected ReadOnly Property TypeLibLocale As String
[C#]
protected override string TypeLibLocale {get;}

Property Value

The locale of the type library.

See Also

ManagedWrapperReference Class | NAnt.VSNet Namespace


TypeLibVersion Property

NAnt SDK Documentation - v0.91

ManagedWrapperReference.TypeLibVersion Property

Gets the hex version of the type library as defined in the definition of the reference.

[Visual Basic]
Overrides Protected ReadOnly Property TypeLibVersion As String
[C#]
protected override string TypeLibVersion {get;}

Property Value

The hex version of the type library.

Exceptions

Exception Type | Condition
BuildException | The definition of the reference does not contain a "VersionMajor" attribute. -or The definition of the reference does not contain a "VersionMinor" attribute.

See Also

ManagedWrapperReference Class | NAnt.VSNet Namespace


WrapperAssembly Property

NAnt SDK Documentation - v0.91

ManagedWrapperReference.WrapperAssembly Property

Gets the path of the wrapper assembly.

[Visual Basic]
Overrides Public ReadOnly Property WrapperAssembly As String
[C#]
public override string WrapperAssembly {get;}

Property Value

The path of the wrapper assembly.

Remarks

The wrapper assembly is stored in the object directory of the project.

See Also

ManagedWrapperReference Class | NAnt.VSNet Namespace


WrapperTool Property

NAnt SDK Documentation - v0.91

ManagedWrapperReference.WrapperTool Property

Gets the name of the tool that should be used to create the WrapperAssembly.

[Visual Basic]
Overrides Public ReadOnly Property WrapperTool As String
[C#]
public override string WrapperTool {get;}

Property Value

The name of the tool that should be used to create the WrapperAssembly.

See Also

ManagedWrapperReference Class | NAnt.VSNet Namespace


ManagedWrapperReference Methods

The methods of the ManagedWrapperReference class are listed below. For a complete list of ManagedWrapperReference class members, see the ManagedWrapperReference Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from WrapperReferenceBase) | Gets the complete set of assemblies that need to be referenced when a project references this component.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from WrapperReferenceBase) | Gets the complete set of output files for the referenced project.
GetPrimaryOutputFile (inherited from WrapperReferenceBase) | Gets the path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp (inherited from WrapperReferenceBase) | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from FileReferenceBase) | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAssemblyOutputFiles (inherited from FileReferenceBase) | Gets the complete set of output files for the specified assembly and adds them to collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
GetPrimaryInteropAssembly (inherited from WrapperReferenceBase) |
GetTypeLibrary (inherited from WrapperReferenceBase) |
GetTypeLibraryName (inherited from WrapperReferenceBase) |
ImportActiveXLibrary |
ImportTypeLibrary |
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ResolveWrapperAssembly (inherited from WrapperReferenceBase) |

See Also

ManagedWrapperReference Class | NAnt.VSNet Namespace


ManagedWrapperReference.ImportActiveXLibrary Method

[Visual Basic]
Overrides Protected Sub ImportActiveXLibrary()
[C#]
protected override void ImportActiveXLibrary();

See Also

ManagedWrapperReference Class | NAnt.VSNet Namespace


ManagedWrapperReference.ImportTypeLibrary Method

[Visual Basic]
Overrides Protected Sub ImportTypeLibrary()
[C#]
protected override void ImportTypeLibrary();

See Also

ManagedWrapperReference Class | NAnt.VSNet Namespace


ProductVersion Enumeration

[Visual Basic]
<Serializable>
Public Enum ProductVersion
[C#]
[Serializable]
public enum ProductVersion

Members

Member Name | Description
Rainier | Visual Studio.NET 2002
Everett | Visual Studio.NET 2003
Whidbey | Visual Studio 2005
Orcas | Visual Studio 2008
Rosario | Visual Studio 2010

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

NAnt.VSNet Namespace


ProjectBase Class

Base class for all project classes.

For a list of all members of this type, see ProjectBase Members.

System.Object
NAnt.VSNet.ProjectBase
NAnt.VSNet.ManagedProjectBase
NAnt.VSNet.VcProject

[Visual Basic]
MustInherit Public Class ProjectBase
[C#]
public abstract class ProjectBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ProjectBase Members | NAnt.VSNet Namespace


ProjectBase Members

ProjectBase overview

Public Instance Properties

BuildConfigurations | Gets a list of project configurations that can be build.
ExtraOutputFiles | Gets the extra set of output files for the project.
Guid | Gets or sets the unique identifier of the VS.NET project.
Name | Gets the name of the VS.NET project.
ObjectDir | Get the directory in which intermediate build output that is not specific to the build configuration will be stored.
ProductVersion | Gets the Visual Studio product version of the project.
ProjectConfigurations | Gets a list of all configurations defined in the project.
ProjectDependencies | Gets the set of projects that the project depends on.
ProjectDirectory | Gets the directory containing the VS.NET project.
ProjectLocation | Get the location of the project.
ProjectPath | Gets the path of the VS.NET project.
References |
ReferencesResolver |
SolutionTask |
TemporaryFiles |
Type | Gets the type of the project.

Public Instance Methods

Compile |
CreateProjectReference |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences |
GetConfiguration |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles | Gets the complete set of output files for the project configuration matching the specified solution configuration.
GetOutputPath |
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged | Gets a value indicating whether building the project for the specified build configuration results in managed output.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ProjectBase Constructor Initializes a new instance of the ProjectBase class.

Protected Instance Properties

DevEnvDir
GacCache
OutputDir

Protected Instance Methods

Build |
CopyFile | Copies the specified file if the destination file does not exist, or the source file has been modified since it was previously copied.
DetermineProductVersion | Returns the Visual Studio product version of the specified project XML fragment.
ExecuteBuildEvent |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
Log | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Prepare | Prepares the project for being built.
VerifyProjectXml | Verifies whether the specified XML fragment represents a valid project that is supported by this ProjectBase.

Protected Internal Instance Methods

ExpandMacro Expands the given macro.

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectBase Constructor

Initializes a new instance of the ProjectBase class.

[Visual Basic]
Protected Sub New( _
ByVal xmlDefinition As XmlElement, _
ByVal solutionTask As SolutionTask, _
ByVal temporaryFiles As TempFileCollection, _
ByVal gacCache As GacCache, _
ByVal referencesResolver As ReferencesResolver, _
ByVal outputDir As DirectoryInfo _
)
[C#]
protected ProjectBase(
XmlElement xmlDefinition,
SolutionTask solutionTask,
TempFileCollection temporaryFiles,
GacCache gacCache,
ReferencesResolver referencesResolver,
DirectoryInfo outputDir
);

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectBase Properties

The properties of the ProjectBase class are listed below. For a complete list of ProjectBase class members, see the ProjectBase Members topic.

Public Instance Properties

BuildConfigurations | Gets a list of project configurations that can be build.
ExtraOutputFiles | Gets the extra set of output files for the project.
Guid | Gets or sets the unique identifier of the VS.NET project.
Name | Gets the name of the VS.NET project.
ObjectDir | Get the directory in which intermediate build output that is not specific to the build configuration will be stored.
ProductVersion | Gets the Visual Studio product version of the project.
ProjectConfigurations | Gets a list of all configurations defined in the project.
ProjectDependencies | Gets the set of projects that the project depends on.
ProjectDirectory | Gets the directory containing the VS.NET project.
ProjectLocation | Get the location of the project.
ProjectPath | Gets the path of the VS.NET project.
References |
ReferencesResolver |
SolutionTask |
TemporaryFiles |
Type | Gets the type of the project.

Protected Instance Properties

DevEnvDir
GacCache
OutputDir

See Also

ProjectBase Class | NAnt.VSNet Namespace


BuildConfigurations Property

NAnt SDK Documentation - v0.91

ProjectBase.BuildConfigurations Property

Gets a list of project configurations that can be build.

[Visual Basic]
Public ReadOnly Property BuildConfigurations As ConfigurationDictionary
[C#]
public ConfigurationDictionary BuildConfigurations {get;}

Remarks

Project configurations that are not in this list do not need to be compiled.

See Also

ProjectBase Class | NAnt.VSNet Namespace


DevEnvDir Property

NAnt SDK Documentation - v0.91

ProjectBase.DevEnvDir Property

[Visual Basic]
Overridable Protected ReadOnly Property DevEnvDir As String
[C#]
protected virtual string DevEnvDir {get;}

See Also

ProjectBase Class | NAnt.VSNet Namespace


ExtraOutputFiles Property

NAnt SDK Documentation - v0.91

ProjectBase.ExtraOutputFiles Property

Gets the extra set of output files for the project.

[Visual Basic]
Public ReadOnly Property ExtraOutputFiles As Hashtable
[C#]
public System.Collections.Hashtable ExtraOutputFiles {get;}

Property Value

The extra set of output files for the project.

Remarks

The key of the case-insensitive Hashtable is the full path of the output file and the value is the path relative to the output directory.

See Also

ProjectBase Class | NAnt.VSNet Namespace


GacCache Property

NAnt SDK Documentation - v0.91

ProjectBase.GacCache Property

[Visual Basic]
Protected ReadOnly Property GacCache As GacCache
[C#]
protected NAnt.Core.Util.GacCache GacCache {get;}

See Also

ProjectBase Class | NAnt.VSNet Namespace


Guid Property

NAnt SDK Documentation - v0.91

ProjectBase.Guid Property

Gets or sets the unique identifier of the VS.NET project.

[Visual Basic]
MustOverride Public Property Guid As String
[C#]
public abstract string Guid {get; set;}

See Also

ProjectBase Class | NAnt.VSNet Namespace


Name Property

NAnt SDK Documentation - v0.91

ProjectBase.Name Property

Gets the name of the VS.NET project.

[Visual Basic]
MustOverride Public ReadOnly Property Name As String
[C#]
public abstract string Name {get;}

See Also

ProjectBase Class | NAnt.VSNet Namespace


ObjectDir Property

NAnt SDK Documentation - v0.91

ProjectBase.ObjectDir Property

Get the directory in which intermediate build output that is not specific to the build configuration will be stored.

[Visual Basic]
Overridable Public ReadOnly Property ObjectDir As DirectoryInfo
[C#]
public virtual System.IO.DirectoryInfo ObjectDir {get;}

Remarks

For Local projects, this is defined as <Project Directory<\obj.

For Web projects, this is defined as %HOMEPATH%\VSWebCache\<Machine Name>\<Project Directory>\obj.

See Also

ProjectBase Class | NAnt.VSNet Namespace


OutputDir Property

NAnt SDK Documentation - v0.91

ProjectBase.OutputDir Property

[Visual Basic]
Protected ReadOnly Property OutputDir As DirectoryInfo
[C#]
protected System.IO.DirectoryInfo OutputDir {get;}

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProductVersion Property

NAnt SDK Documentation - v0.91

ProjectBase.ProductVersion Property

Gets the Visual Studio product version of the project.

[Visual Basic]
Public ReadOnly Property ProductVersion As ProductVersion
[C#]
public ProductVersion ProductVersion {get;}

Property Value

The Visual Studio product version of the project.

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectConfigurations Property

NAnt SDK Documentation - v0.91

ProjectBase.ProjectConfigurations Property

Gets a list of all configurations defined in the project.

[Visual Basic]
Public ReadOnly Property ProjectConfigurations As ConfigurationDictionary
[C#]
public ConfigurationDictionary ProjectConfigurations {get;}

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectDependencies Property

NAnt SDK Documentation - v0.91

ProjectBase.ProjectDependencies Property

Gets the set of projects that the project depends on.

[Visual Basic]
Public ReadOnly Property ProjectDependencies As ProjectBaseCollection
[C#]
public ProjectBaseCollection ProjectDependencies {get;}

Property Value

The set of projects that the project depends on.

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectDirectory Property

NAnt SDK Documentation - v0.91

ProjectBase.ProjectDirectory Property

Gets the directory containing the VS.NET project.

[Visual Basic]
MustOverride Public ReadOnly Property ProjectDirectory As DirectoryInfo
[C#]
public abstract System.IO.DirectoryInfo ProjectDirectory {get;}

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectLocation Property

NAnt SDK Documentation - v0.91

ProjectBase.ProjectLocation Property

Get the location of the project.

[Visual Basic]
MustOverride Public ReadOnly Property ProjectLocation As ProjectLocation
[C#]
public abstract ProjectLocation ProjectLocation {get;}

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectPath Property

NAnt SDK Documentation - v0.91

ProjectBase.ProjectPath Property

Gets the path of the VS.NET project.

[Visual Basic]
MustOverride Public ReadOnly Property ProjectPath As String
[C#]
public abstract string ProjectPath {get;}

See Also

ProjectBase Class | NAnt.VSNet Namespace


References Property

NAnt SDK Documentation - v0.91

ProjectBase.References Property

[Visual Basic]
MustOverride Public ReadOnly Property References As ArrayList
[C#]
public abstract System.Collections.ArrayList References {get;}

See Also

ProjectBase Class | NAnt.VSNet Namespace


ReferencesResolver Property

NAnt SDK Documentation - v0.91

ProjectBase.ReferencesResolver Property

[Visual Basic]
Public ReadOnly Property ReferencesResolver As ReferencesResolver
[C#]
public ReferencesResolver ReferencesResolver {get;}

See Also

ProjectBase Class | NAnt.VSNet Namespace


SolutionTask Property

NAnt SDK Documentation - v0.91

ProjectBase.SolutionTask Property

[Visual Basic]
Public ReadOnly Property SolutionTask As SolutionTask
[C#]
public Tasks.SolutionTask SolutionTask {get;}

See Also

ProjectBase Class | NAnt.VSNet Namespace


TemporaryFiles Property

NAnt SDK Documentation - v0.91

ProjectBase.TemporaryFiles Property

[Visual Basic]
Public ReadOnly Property TemporaryFiles As TempFileCollection
[C#]
public System.CodeDom.Compiler.TempFileCollection TemporaryFiles {get;}

See Also

ProjectBase Class | NAnt.VSNet Namespace


Type Property

NAnt SDK Documentation - v0.91

ProjectBase.Type Property

Gets the type of the project.

[Visual Basic]
MustOverride Public ReadOnly Property Type As ProjectType
[C#]
public abstract ProjectType Type {get;}

Property Value

The type of the project.

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectBase Methods

The methods of the ProjectBase class are listed below. For a complete list of ProjectBase class members, see the ProjectBase Members topic.

Public Instance Methods

Compile |
CreateProjectReference |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences |
GetConfiguration |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles | Gets the complete set of output files for the project configuration matching the specified solution configuration.
GetOutputPath |
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged | Gets a value indicating whether building the project for the specified build configuration results in managed output.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Build |
CopyFile | Copies the specified file if the destination file does not exist, or the source file has been modified since it was previously copied.
DetermineProductVersion | Returns the Visual Studio product version of the specified project XML fragment.
ExecuteBuildEvent |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
Log | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Prepare | Prepares the project for being built.
VerifyProjectXml | Verifies whether the specified XML fragment represents a valid project that is supported by this ProjectBase.

Protected Internal Instance Methods

ExpandMacro Expands the given macro.

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectBase.Build Method

[Visual Basic]
MustOverride Protected Function Build( _
ByVal solutionConfiguration As Configuration _
) As BuildResult
[C#]
protected abstract BuildResult Build(
Configuration solutionConfiguration
);

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectBase.Compile Method

[Visual Basic]
Public Function Compile( _
ByVal solutionConfiguration As Configuration _
) As Boolean
[C#]
public bool Compile(
Configuration solutionConfiguration
);

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectBase.CopyFile Method

Copies the specified file if the destination file does not exist, or the source file has been modified since it was previously copied.

[Visual Basic]
Protected Sub CopyFile( _
ByVal srcFile As FileInfo, _
ByVal destFile As FileInfo, _
ByVal parent As Task _
)
[C#]
protected void CopyFile(
FileInfo srcFile,
FileInfo destFile,
Task parent
);

Parameters

srcFile
The file to copy.
destFile
The destination file.
parent
The Task in which context the operation will be performed.

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectBase.CreateProjectReference Method

[Visual Basic]
MustOverride Public Function CreateProjectReference( _
ByVal project As ProjectBase, _
ByVal isPrivateSpecified As Boolean, _
ByVal isPrivate As Boolean _
) As ProjectReferenceBase
[C#]
public abstract ProjectReferenceBase CreateProjectReference(
ProjectBase project,
bool isPrivateSpecified,
bool isPrivate
);

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectBase.DetermineProductVersion Method

Returns the Visual Studio product version of the specified project XML fragment.

[Visual Basic]
MustOverride Protected Function DetermineProductVersion( _
ByVal docElement As XmlElement _
) As ProductVersion
[C#]
protected abstract ProductVersion DetermineProductVersion(
XmlElement docElement
);

Parameters

docElement
XML fragment representing the project file.

Return Value

The Visual Studio product version of the specified project XML file.

Exceptions

Exception Type | Condition
BuildException | The product version could not be determined. -or- The product version is not supported.

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectBase.ExecuteBuildEvent Method

[Visual Basic]
Protected Function ExecuteBuildEvent( _
ByVal buildEvent As String, _
ByVal buildCommandLine As String, _
ByVal batchFile As String, _
ByVal workingDirectory As String, _
ByVal config As ConfigurationBase _
) As Boolean
[C#]
protected bool ExecuteBuildEvent(
string buildEvent,
string buildCommandLine,
string batchFile,
string workingDirectory,
ConfigurationBase config
);

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectBase.ExpandMacro Method

Expands the given macro.

[Visual Basic]
Overridable Protected Friend Function ExpandMacro( _
ByVal macro As String _
) As String
[C#]
protected internal virtual string ExpandMacro(
string macro
);

Parameters

macro
The macro to expand.

Return Value

The expanded macro or a null reference (Nothing in Visual Basic) if the macro is not supported.

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectBase.GetAssemblyReferences Method

[Visual Basic]
Public Function GetAssemblyReferences( _
ByVal solutionConfiguration As Configuration _
) As StringCollection
[C#]
public StringCollection GetAssemblyReferences(
Configuration solutionConfiguration
);

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectBase.GetConfiguration Method

[Visual Basic]
Public Function GetConfiguration( _
ByVal solutionConfiguration As Configuration _
) As ConfigurationBase
[C#]
public ConfigurationBase GetConfiguration(
Configuration solutionConfiguration
);

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectBase.GetOutputFiles Method

Gets the complete set of output files for the project configuration matching the specified solution configuration.

[Visual Basic]
Overridable Public Sub GetOutputFiles( _
ByVal solutionConfiguration As Configuration, _
ByVal outputFiles As Hashtable _
)
[C#]
public virtual void GetOutputFiles(
Configuration solutionConfiguration,
Hashtable outputFiles
);

Parameters

solutionConfiguration
The solution configuration that is built.
outputFiles
The set of output files to be updated.

Remarks

The key of the case-insensitive Hashtable is the full path of the output file and the value is the path relative to the output directory.

If the project is not configured to be built for the specified solution configuration, then no output files are added.

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectBase.GetOutputPath Method

[Visual Basic]
Public Function GetOutputPath( _
ByVal solutionConfiguration As Configuration _
) As String
[C#]
public string GetOutputPath(
Configuration solutionConfiguration
);

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectBase.IsManaged Method

Gets a value indicating whether building the project for the specified build configuration results in managed output.

[Visual Basic]
MustOverride Public Function IsManaged( _
ByVal configuration As Configuration _
) As Boolean
[C#]
public abstract bool IsManaged(
Configuration configuration
);

Parameters

configuration
The build configuration.

Return Value

true if the project output for the given build configuration is managed; otherwise, false.

See Also

ProjectBase Class | NAnt.VSNet Namespace


Log Method

NAnt SDK Documentation - v0.91

ProjectBase.Log Method

Logs a message with the given priority.

Overload List

Logs a message with the given priority.

protected void Log(Level,string);

Logs a message with the given priority.

protected void Log(Level,string,params object[]);

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectBase.Log Method (Level, String)

Logs a message with the given priority.

[Visual Basic]
Overloads Protected Sub Log( _
ByVal messageLevel As Level, _
ByVal message As String _
)
[C#]
protected void Log(
Level messageLevel,
string message
);

Parameters

messageLevel
The message priority at which the specified message is to be logged.
message
The message to be logged.

Remarks

The actual logging is delegated to the underlying task.

See Also

ProjectBase Class | NAnt.VSNet Namespace | ProjectBase.Log Overload List


ProjectBase.Log Method (Level, String, Object[])

Logs a message with the given priority.

[Visual Basic]
Overloads Protected Sub Log( _
ByVal messageLevel As Level, _
ByVal message As String, _
ParamArray args As Object() _
)
[C#]
protected void Log(
Level messageLevel,
string message,
params object[] args
);

Parameters

messageLevel
The message priority at which the specified message is to be logged.
message
The message to log, containing zero or more format items.
args
An Object array containing zero or more objects to format.

Remarks

The actual logging is delegated to the underlying task.

See Also

ProjectBase Class | NAnt.VSNet Namespace | ProjectBase.Log Overload List


ProjectBase.Prepare Method

Prepares the project for being built.

[Visual Basic]
Overridable Protected Sub Prepare( _
ByVal solutionConfiguration As Configuration _
)
[C#]
protected virtual void Prepare(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Remarks

The default implementation will ensure that none of the output files are marked read-only.

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectBase.VerifyProjectXml Method

Verifies whether the specified XML fragment represents a valid project that is supported by this ProjectBase.

[Visual Basic]
MustOverride Protected Sub VerifyProjectXml( _
ByVal docElement As XmlElement _
)
[C#]
protected abstract void VerifyProjectXml(
XmlElement docElement
);

Parameters

docElement
XML fragment representing the project file.

Exceptions

Exception Type | Condition
BuildException | The XML fragment is not supported by this ProjectBase. -or- The XML fragment does not represent a valid project (for this ProjectBase).

See Also

ProjectBase Class | NAnt.VSNet Namespace


ProjectBaseCollection Class

Contains a collection of ProjectBase elements.

For a list of all members of this type, see ProjectBaseCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.VSNet.ProjectBaseCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class ProjectBaseCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class ProjectBaseCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ProjectBaseCollection Members | NAnt.VSNet Namespace


ProjectBaseCollection Members

ProjectBaseCollection overview

Public Instance Constructors

ProjectBaseCollection Overloaded. Initializes a new instance of the ProjectBaseCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a ProjectBase to the end of the collection.
AddRange | Overloaded. Adds the elements of a ProjectBase array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a ProjectBase is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified ProjectBase object in the collection.
Insert | Inserts a ProjectBase into the collection at the specified index.
Remove | Overloaded. Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace


ProjectBaseCollection Constructor

Initializes a new instance of the ProjectBaseCollection class.

Overload List

Initializes a new instance of the ProjectBaseCollection class.

public ProjectBaseCollection();

Initializes a new instance of the ProjectBaseCollection class with the specified array of ProjectBase instances.

public ProjectBaseCollection(ProjectBase[]);

Initializes a new instance of the ProjectBaseCollection class with the specified ProjectBaseCollection instance.

public ProjectBaseCollection(ProjectBaseCollection);

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace


ProjectBaseCollection Constructor ()

Initializes a new instance of the ProjectBaseCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ProjectBaseCollection();

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace | ProjectBaseCollection Constructor Overload List


ProjectBaseCollection Constructor (ProjectBaseCollection)

Initializes a new instance of the ProjectBaseCollection class with the specified ProjectBaseCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As ProjectBaseCollection _
)
[C#]
public ProjectBaseCollection(
ProjectBaseCollection value
);

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace | ProjectBaseCollection Constructor Overload List


ProjectBaseCollection Constructor (ProjectBase[])

Initializes a new instance of the ProjectBaseCollection class with the specified array of ProjectBase instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As ProjectBase() _
)
[C#]
public ProjectBaseCollection(
ProjectBase[] value
);

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace | ProjectBaseCollection Constructor Overload List


ProjectBaseCollection Properties

The properties of the ProjectBaseCollection class are listed below. For a complete list of ProjectBaseCollection class members, see the ProjectBaseCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace


Item Property

NAnt SDK Documentation - v0.91

ProjectBaseCollection.Item Property

Gets or sets the element at the specified index.

Overload List

Gets or sets the element at the specified index.

public ProjectBase this[int] {get; set;}

Gets the ProjectBase with the specified GUID.

public ProjectBase this[string] {get;}

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace


Item Property (Int32)

NAnt SDK Documentation - v0.91

ProjectBaseCollection.Item Property (Int32)

Gets or sets the element at the specified index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As ProjectBase
[C#]
public ProjectBase this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace | ProjectBaseCollection.Item Overload List


Item Property (String)

NAnt SDK Documentation - v0.91

ProjectBaseCollection.Item Property (String)

Gets the ProjectBase with the specified GUID.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal guid As String _
) As ProjectBase
[C#]
public ProjectBase this[
string guid
] {get;}

Parameters

guid
The GUID of the ProjectBase to get.

Remarks

Performs a case-insensitive lookup.

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace | ProjectBaseCollection.Item Overload List


ProjectBaseCollection Methods

The methods of the ProjectBaseCollection class are listed below. For a complete list of ProjectBaseCollection class members, see the ProjectBaseCollection Members topic.

Public Instance Methods

Add | Adds a ProjectBase to the end of the collection.
AddRange | Overloaded. Adds the elements of a ProjectBase array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a ProjectBase is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified ProjectBase object in the collection.
Insert | Inserts a ProjectBase into the collection at the specified index.
Remove | Overloaded. Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace


ProjectBaseCollection.Add Method

Adds a ProjectBase to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As ProjectBase _
) As Integer
[C#]
public int Add(
ProjectBase item
);

Parameters

item
The ProjectBase to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace


AddRange Method

NAnt SDK Documentation - v0.91

ProjectBaseCollection.AddRange Method

Adds the elements of a ProjectBase array to the end of the collection.

Overload List

Adds the elements of a ProjectBase array to the end of the collection.

public void AddRange(ProjectBase[]);

Adds the elements of a ProjectBaseCollection to the end of the collection.

public void AddRange(ProjectBaseCollection);

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace


ProjectBaseCollection.AddRange Method (ProjectBase[])

Adds the elements of a ProjectBase array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As ProjectBase() _
)
[C#]
public void AddRange(
ProjectBase[] items
);

Parameters

items
The array of ProjectBase elements to be added to the end of the collection.

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace | ProjectBaseCollection.AddRange Overload List


ProjectBaseCollection.AddRange Method (ProjectBaseCollection)

Adds the elements of a ProjectBaseCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As ProjectBaseCollection _
)
[C#]
public void AddRange(
ProjectBaseCollection items
);

Parameters

items
The ProjectBaseCollection to be added to the end of the collection.

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace | ProjectBaseCollection.AddRange Overload List


Contains Method

NAnt SDK Documentation - v0.91

ProjectBaseCollection.Contains Method

Determines whether a ProjectBase is in the collection.

Overload List

Determines whether a ProjectBase is in the collection.

public bool Contains(ProjectBase);

Determines whether a ProjectBase with the specified GUID is in the collection, using a case-insensitive lookup.

public bool Contains(string);

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace


ProjectBaseCollection.Contains Method (ProjectBase)

Determines whether a ProjectBase is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal item As ProjectBase _
) As Boolean
[C#]
public bool Contains(
ProjectBase item
);

Parameters

item
The ProjectBase to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace | ProjectBaseCollection.Contains Overload List


ProjectBaseCollection.Contains Method (String)

Determines whether a ProjectBase with the specified GUID is in the collection, using a case-insensitive lookup.

[Visual Basic]
Overloads Public Function Contains( _
ByVal value As String _
) As Boolean
[C#]
public bool Contains(
string value
);

Parameters

value
The GUID to locate in the collection.

Return Value

true if a ProjectBase with GUID value is found in the collection; otherwise, false.

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace | ProjectBaseCollection.Contains Overload List


ProjectBaseCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As ProjectBase(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
ProjectBase[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace


ProjectBaseCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As ProjectBaseEnumerator
[C#]
new public ProjectBaseEnumerator GetEnumerator();

Return Value

A ProjectBaseEnumerator for the entire collection.

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace


ProjectBaseCollection.IndexOf Method

Retrieves the index of a specified ProjectBase object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As ProjectBase _
) As Integer
[C#]
public int IndexOf(
ProjectBase item
);

Parameters

item
The ProjectBase object for which the index is returned.

Return Value

The index of the specified ProjectBase. If the ProjectBase is not currently a member of the collection, it returns -1.

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace


ProjectBaseCollection.Insert Method

Inserts a ProjectBase into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As ProjectBase _
)
[C#]
public void Insert(
int index,
ProjectBase item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The ProjectBase to insert.

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace


Remove Method

NAnt SDK Documentation - v0.91

ProjectBaseCollection.Remove Method

Removes a member from the collection.

Overload List

Removes a member from the collection.

public void Remove(ProjectBase);

Remove items with the specified guid from the collection.

public void Remove(string);

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace


ProjectBaseCollection.Remove Method (ProjectBase)

Removes a member from the collection.

[Visual Basic]
Overloads Public Sub Remove( _
ByVal item As ProjectBase _
)
[C#]
public void Remove(
ProjectBase item
);

Parameters

item
The ProjectBase to remove from the collection.

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace | ProjectBaseCollection.Remove Overload List


ProjectBaseCollection.Remove Method (String)

Remove items with the specified guid from the collection.

[Visual Basic]
Overloads Public Sub Remove( _
ByVal guid As String _
)
[C#]
public void Remove(
string guid
);

Parameters

guid
The guid of the project to remove from the collection.

See Also

ProjectBaseCollection Class | NAnt.VSNet Namespace | ProjectBaseCollection.Remove Overload List


ProjectBaseEnumerator Class

Enumerates the ProjectBase elements of a ProjectBaseCollection.

For a list of all members of this type, see ProjectBaseEnumerator Members.

System.Object
NAnt.VSNet.ProjectBaseEnumerator

[Visual Basic]
Public Class ProjectBaseEnumerator
Implements IEnumerator
[C#]
public class ProjectBaseEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ProjectBaseEnumerator Members | NAnt.VSNet Namespace


ProjectBaseEnumerator Members

ProjectBaseEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProjectBaseEnumerator Class | NAnt.VSNet Namespace


ProjectBaseEnumerator Properties

The properties of the ProjectBaseEnumerator class are listed below. For a complete list of ProjectBaseEnumerator class members, see the ProjectBaseEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

ProjectBaseEnumerator Class | NAnt.VSNet Namespace


Current Property

NAnt SDK Documentation - v0.91

ProjectBaseEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As ProjectBase
[C#]
public ProjectBase Current {get;}

See Also

ProjectBaseEnumerator Class | NAnt.VSNet Namespace


ProjectBaseEnumerator Methods

The methods of the ProjectBaseEnumerator class are listed below. For a complete list of ProjectBaseEnumerator class members, see the ProjectBaseEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProjectBaseEnumerator Class | NAnt.VSNet Namespace


ProjectBaseEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

ProjectBaseEnumerator Class | NAnt.VSNet Namespace


ProjectBaseEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

ProjectBaseEnumerator Class | NAnt.VSNet Namespace


ProjectEntry Class

For a list of all members of this type, see ProjectEntry Members.

System.Object
NAnt.VSNet.ProjectEntry

[Visual Basic]
Public Class ProjectEntry
[C#]
public class ProjectEntry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ProjectEntry Members | NAnt.VSNet Namespace


ProjectEntry Members

ProjectEntry overview

Public Instance Constructors

ProjectEntry Constructor

Public Instance Properties

BuildConfigurations | Return a mapping between the configurations defined in the solution file and the project build configurations.
Guid |
Path |
Project | Gets or sets the in memory representation of the project.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProjectEntry Class | NAnt.VSNet Namespace


ProjectEntry Constructor

[Visual Basic]
Public Sub New( _
ByVal guid As String, _
ByVal path As String _
)
[C#]
public ProjectEntry(
string guid,
string path
);

See Also

ProjectEntry Class | NAnt.VSNet Namespace


ProjectEntry Properties

The properties of the ProjectEntry class are listed below. For a complete list of ProjectEntry class members, see the ProjectEntry Members topic.

Public Instance Properties

BuildConfigurations | Return a mapping between the configurations defined in the solution file and the project build configurations.
Guid |
Path |
Project | Gets or sets the in memory representation of the project.

See Also

ProjectEntry Class | NAnt.VSNet Namespace


BuildConfigurations Property

NAnt SDK Documentation - v0.91

ProjectEntry.BuildConfigurations Property

Return a mapping between the configurations defined in the solution file and the project build configurations.

[Visual Basic]
Public Property BuildConfigurations As ConfigurationMap
[C#]
public ConfigurationMap BuildConfigurations {get; set;}

Property Value

Mapping between configurations defined in the solution file and the project build configurations, or a null reference (Nothing in Visual Basic) if the project is not defined in a solution file.

Remarks

This mapping only includes project build configurations that are configured to be built for a given solution configuration.

See Also

ProjectEntry Class | NAnt.VSNet Namespace


Guid Property

NAnt SDK Documentation - v0.91

ProjectEntry.Guid Property

[Visual Basic]
Public ReadOnly Property Guid As String
[C#]
public string Guid {get;}

See Also

ProjectEntry Class | NAnt.VSNet Namespace


Path Property

NAnt SDK Documentation - v0.91

ProjectEntry.Path Property

[Visual Basic]
Public ReadOnly Property Path As String
[C#]
public string Path {get;}

See Also

ProjectEntry Class | NAnt.VSNet Namespace


Project Property

NAnt SDK Documentation - v0.91

ProjectEntry.Project Property

Gets or sets the in memory representation of the project.

[Visual Basic]
Public Property Project As ProjectBase
[C#]
public ProjectBase Project {get; set;}

Property Value

The in memory representation of the project, or a null reference (Nothing in Visual Basic) if the project is not (yet) loaded.

Remarks

This property will always be a null reference (Nothing in Visual Basic) for projects that are not supported.

See Also

ProjectEntry Class | NAnt.VSNet Namespace


ProjectEntryCollection Class

Contains a collection of ProjectEntry elements.

For a list of all members of this type, see ProjectEntryCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.VSNet.ProjectEntryCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class ProjectEntryCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class ProjectEntryCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ProjectEntryCollection Members | NAnt.VSNet Namespace


ProjectEntryCollection Members

ProjectEntryCollection overview

Public Instance Constructors

ProjectEntryCollection Overloaded. Initializes a new instance of the ProjectEntryCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a ProjectEntry to the end of the collection.
AddRange | Overloaded. Adds the elements of a ProjectEntry array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a ProjectEntry is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified ProjectEntry object in the collection.
Insert | Inserts a ProjectEntry into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace


ProjectEntryCollection Constructor

Initializes a new instance of the ProjectEntryCollection class.

Overload List

Initializes a new instance of the ProjectEntryCollection class.

public ProjectEntryCollection();

Initializes a new instance of the ProjectEntryCollection class with the specified array of ProjectEntry instances.

public ProjectEntryCollection(ProjectEntry[]);

Initializes a new instance of the ProjectEntryCollection class with the specified ProjectEntryCollection instance.

public ProjectEntryCollection(ProjectEntryCollection);

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace


ProjectEntryCollection Constructor ()

Initializes a new instance of the ProjectEntryCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ProjectEntryCollection();

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace | ProjectEntryCollection Constructor Overload List


ProjectEntryCollection Constructor (ProjectEntryCollection)

Initializes a new instance of the ProjectEntryCollection class with the specified ProjectEntryCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As ProjectEntryCollection _
)
[C#]
public ProjectEntryCollection(
ProjectEntryCollection value
);

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace | ProjectEntryCollection Constructor Overload List


ProjectEntryCollection Constructor (ProjectEntry[])

Initializes a new instance of the ProjectEntryCollection class with the specified array of ProjectEntry instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As ProjectEntry() _
)
[C#]
public ProjectEntryCollection(
ProjectEntry[] value
);

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace | ProjectEntryCollection Constructor Overload List


ProjectEntryCollection Properties

The properties of the ProjectEntryCollection class are listed below. For a complete list of ProjectEntryCollection class members, see the ProjectEntryCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace


Item Property

NAnt SDK Documentation - v0.91

ProjectEntryCollection.Item Property

Gets or sets the element at the specified index.

Overload List

Gets or sets the element at the specified index.

public ProjectEntry this[int] {get; set;}

Gets the ProjectEntry with the specified GUID.

public ProjectEntry this[string] {get; set;}

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace


Item Property (Int32)

NAnt SDK Documentation - v0.91

ProjectEntryCollection.Item Property (Int32)

Gets or sets the element at the specified index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As ProjectEntry
[C#]
public ProjectEntry this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace | ProjectEntryCollection.Item Overload List


Item Property (String)

NAnt SDK Documentation - v0.91

ProjectEntryCollection.Item Property (String)

Gets the ProjectEntry with the specified GUID.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal guid As String _
) As ProjectEntry
[C#]
public ProjectEntry this[
string guid
] {get; set;}

Parameters

guid
The GUID of the ProjectEntry to get.

Remarks

Performs a case-insensitive lookup.

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace | ProjectEntryCollection.Item Overload List


ProjectEntryCollection Methods

The methods of the ProjectEntryCollection class are listed below. For a complete list of ProjectEntryCollection class members, see the ProjectEntryCollection Members topic.

Public Instance Methods

Add | Adds a ProjectEntry to the end of the collection.
AddRange | Overloaded. Adds the elements of a ProjectEntry array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a ProjectEntry is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified ProjectEntry object in the collection.
Insert | Inserts a ProjectEntry into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace


ProjectEntryCollection.Add Method

Adds a ProjectEntry to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As ProjectEntry _
) As Integer
[C#]
public int Add(
ProjectEntry item
);

Parameters

item
The ProjectEntry to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace


AddRange Method

NAnt SDK Documentation - v0.91

ProjectEntryCollection.AddRange Method

Adds the elements of a ProjectEntry array to the end of the collection.

Overload List

Adds the elements of a ProjectEntry array to the end of the collection.

public void AddRange(ProjectEntry[]);

Adds the elements of a ProjectEntryCollection to the end of the collection.

public void AddRange(ProjectEntryCollection);

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace


ProjectEntryCollection.AddRange Method (ProjectEntry[])

Adds the elements of a ProjectEntry array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As ProjectEntry() _
)
[C#]
public void AddRange(
ProjectEntry[] items
);

Parameters

items
The array of ProjectEntry elements to be added to the end of the collection.

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace | ProjectEntryCollection.AddRange Overload List


ProjectEntryCollection.AddRange Method (ProjectEntryCollection)

Adds the elements of a ProjectEntryCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As ProjectEntryCollection _
)
[C#]
public void AddRange(
ProjectEntryCollection items
);

Parameters

items
The ProjectEntryCollection to be added to the end of the collection.

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace | ProjectEntryCollection.AddRange Overload List


Contains Method

NAnt SDK Documentation - v0.91

ProjectEntryCollection.Contains Method

Determines whether a ProjectEntry is in the collection.

Overload List

Determines whether a ProjectEntry is in the collection.

public bool Contains(ProjectEntry);

Determines whether a ProjectEntry with the specified GUID is in the collection, using a case-insensitive lookup.

public bool Contains(string);

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace


ProjectEntryCollection.Contains Method (ProjectEntry)

Determines whether a ProjectEntry is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal item As ProjectEntry _
) As Boolean
[C#]
public bool Contains(
ProjectEntry item
);

Parameters

item
The ProjectEntry to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace | ProjectEntryCollection.Contains Overload List


ProjectEntryCollection.Contains Method (String)

Determines whether a ProjectEntry with the specified GUID is in the collection, using a case-insensitive lookup.

[Visual Basic]
Overloads Public Function Contains( _
ByVal value As String _
) As Boolean
[C#]
public bool Contains(
string value
);

Parameters

value
The GUID to locate in the collection.

Return Value

true if a ProjectEntry with GUID value is found in the collection; otherwise, false.

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace | ProjectEntryCollection.Contains Overload List


ProjectEntryCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As ProjectEntry(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
ProjectEntry[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace


ProjectEntryCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As ProjectEntryEnumerator
[C#]
new public ProjectEntryEnumerator GetEnumerator();

Return Value

A ProjectEntryEnumerator for the entire collection.

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace


ProjectEntryCollection.IndexOf Method

Retrieves the index of a specified ProjectEntry object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As ProjectEntry _
) As Integer
[C#]
public int IndexOf(
ProjectEntry item
);

Parameters

item
The ProjectEntry object for which the index is returned.

Return Value

The index of the specified ProjectEntry. If the ProjectEntry is not currently a member of the collection, it returns -1.

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace


ProjectEntryCollection.Insert Method

Inserts a ProjectEntry into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As ProjectEntry _
)
[C#]
public void Insert(
int index,
ProjectEntry item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The ProjectEntry to insert.

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace


ProjectEntryCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As ProjectEntry _
)
[C#]
public void Remove(
ProjectEntry item
);

Parameters

item
The ProjectEntry to remove from the collection.

See Also

ProjectEntryCollection Class | NAnt.VSNet Namespace


ProjectEntryEnumerator Class

Enumerates the ProjectEntry elements of a ProjectEntryCollection.

For a list of all members of this type, see ProjectEntryEnumerator Members.

System.Object
NAnt.VSNet.ProjectEntryEnumerator

[Visual Basic]
Public Class ProjectEntryEnumerator
Implements IEnumerator
[C#]
public class ProjectEntryEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ProjectEntryEnumerator Members | NAnt.VSNet Namespace


ProjectEntryEnumerator Members

ProjectEntryEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProjectEntryEnumerator Class | NAnt.VSNet Namespace


ProjectEntryEnumerator Properties

The properties of the ProjectEntryEnumerator class are listed below. For a complete list of ProjectEntryEnumerator class members, see the ProjectEntryEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

ProjectEntryEnumerator Class | NAnt.VSNet Namespace


Current Property

NAnt SDK Documentation - v0.91

ProjectEntryEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As ProjectEntry
[C#]
public ProjectEntry Current {get;}

See Also

ProjectEntryEnumerator Class | NAnt.VSNet Namespace


ProjectEntryEnumerator Methods

The methods of the ProjectEntryEnumerator class are listed below. For a complete list of ProjectEntryEnumerator class members, see the ProjectEntryEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProjectEntryEnumerator Class | NAnt.VSNet Namespace


ProjectEntryEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

ProjectEntryEnumerator Class | NAnt.VSNet Namespace


ProjectEntryEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

ProjectEntryEnumerator Class | NAnt.VSNet Namespace


ProjectLocation Enumeration

Indentifies the physical location of a managed project.

[Visual Basic]
<Serializable>
Public Enum ProjectLocation
[C#]
[Serializable]
public enum ProjectLocation

Members

Member Name | Description
Local | A local project.
Web | A web project.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

NAnt.VSNet Namespace


ProjectReferenceBase Class

For a list of all members of this type, see ProjectReferenceBase Members.

System.Object
NAnt.VSNet.ReferenceBase
NAnt.VSNet.ProjectReferenceBase
NAnt.VSNet.ManagedProjectReference
NAnt.VSNet.VcProjectReference

[Visual Basic]
MustInherit Public Class ProjectReferenceBase
Inherits ReferenceBase
[C#]
public abstract class ProjectReferenceBase : ReferenceBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ProjectReferenceBase Members | NAnt.VSNet Namespace


ProjectReferenceBase Members

ProjectReferenceBase overview

Public Instance Properties

CopyLocal | Gets a value indicating whether the output file(s) of this reference should be copied locally.
Name |
Project |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences | Gets the complete set of assemblies that need to be referenced when a project references this project.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles | Gets the complete set of output files for the referenced project.
GetPrimaryOutputFile | Gets the output path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from ReferenceBase) | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ProjectReferenceBase Constructor

Protected Instance Properties

IsPrivate |
IsPrivateSpecified |
IsSystem | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
LoadProject |
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProjectReferenceBase Class | NAnt.VSNet Namespace


ProjectReferenceBase Constructor

[Visual Basic]
Protected Sub New( _
ByVal referencesResolver As ReferencesResolver, _
ByVal parent As ProjectBase _
)
[C#]
protected ProjectReferenceBase(
ReferencesResolver referencesResolver,
ProjectBase parent
);

See Also

ProjectReferenceBase Class | NAnt.VSNet Namespace


ProjectReferenceBase Properties

The properties of the ProjectReferenceBase class are listed below. For a complete list of ProjectReferenceBase class members, see the ProjectReferenceBase Members topic.

Public Instance Properties

CopyLocal | Gets a value indicating whether the output file(s) of this reference should be copied locally.
Name |
Project |

Protected Instance Properties

IsPrivate |
IsPrivateSpecified |
IsSystem | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |

See Also

ProjectReferenceBase Class | NAnt.VSNet Namespace


CopyLocal Property

NAnt SDK Documentation - v0.91

ProjectReferenceBase.CopyLocal Property

Gets a value indicating whether the output file(s) of this reference should be copied locally.

[Visual Basic]
Overrides Public ReadOnly Property CopyLocal As Boolean
[C#]
public override bool CopyLocal {get;}

Property Value

true if the output file(s) of this reference should be copied locally; otherwise, false.

See Also

ProjectReferenceBase Class | NAnt.VSNet Namespace


IsPrivate Property

NAnt SDK Documentation - v0.91

ProjectReferenceBase.IsPrivate Property

[Visual Basic]
MustOverride Protected ReadOnly Property IsPrivate As Boolean
[C#]
protected abstract bool IsPrivate {get;}

See Also

ProjectReferenceBase Class | NAnt.VSNet Namespace


IsPrivateSpecified Property

NAnt SDK Documentation - v0.91

ProjectReferenceBase.IsPrivateSpecified Property

[Visual Basic]
MustOverride Protected ReadOnly Property IsPrivateSpecified As Boolean
[C#]
protected abstract bool IsPrivateSpecified {get;}

See Also

ProjectReferenceBase Class | NAnt.VSNet Namespace


IsSystem Property

NAnt SDK Documentation - v0.91

ProjectReferenceBase.IsSystem Property

Gets a value indicating whether this reference represents a system assembly.

[Visual Basic]
Overrides Protected ReadOnly Property IsSystem As Boolean
[C#]
protected override bool IsSystem {get;}

Property Value

false as a project by itself can never be a system assembly.

See Also

ProjectReferenceBase Class | NAnt.VSNet Namespace


Name Property

NAnt SDK Documentation - v0.91

ProjectReferenceBase.Name Property

[Visual Basic]
Overrides Public ReadOnly Property Name As String
[C#]
public override string Name {get;}

See Also

ProjectReferenceBase Class | NAnt.VSNet Namespace


Project Property

NAnt SDK Documentation - v0.91

ProjectReferenceBase.Project Property

[Visual Basic]
MustOverride Public ReadOnly Property Project As ProjectBase
[C#]
public abstract ProjectBase Project {get;}

See Also

ProjectReferenceBase Class | NAnt.VSNet Namespace


ProjectReferenceBase Methods

The methods of the ProjectReferenceBase class are listed below. For a complete list of ProjectReferenceBase class members, see the ProjectReferenceBase Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences | Gets the complete set of assemblies that need to be referenced when a project references this project.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles | Gets the complete set of output files for the referenced project.
GetPrimaryOutputFile | Gets the output path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from ReferenceBase) | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
LoadProject |
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProjectReferenceBase Class | NAnt.VSNet Namespace


ProjectReferenceBase.GetAssemblyReferences Method

Gets the complete set of assemblies that need to be referenced when a project references this project.

[Visual Basic]
Overrides Public Function GetAssemblyReferences( _
ByVal solutionConfiguration As Configuration _
) As StringCollection
[C#]
public override StringCollection GetAssemblyReferences(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Return Value

The complete set of assemblies that need to be referenced when a project references this project.

Remarks

Apparently, there's some hack in VB.NET that allows a type to be used that derives from a type in an assembly that is not referenced by the project.

When building from the command line (using vbc), the following error is reported "error BC30007: Reference required to assembly 'X' containing the base class 'X'. Add one to your project".

Somehow VB.NET can workaround this issue, without actually adding a reference to that assembly. I verified this with both VS.NET 2003 and VS.NET 2005.

For now, we have no other option than to return all assembly references of the referenced project if the parent is a VB.NET project.

See Also

ProjectReferenceBase Class | NAnt.VSNet Namespace


ProjectReferenceBase.GetOutputFiles Method

Gets the complete set of output files for the referenced project.

[Visual Basic]
Overrides Public Sub GetOutputFiles( _
ByVal solutionConfiguration As Configuration, _
ByVal outputFiles As Hashtable _
)
[C#]
public override void GetOutputFiles(
Configuration solutionConfiguration,
Hashtable outputFiles
);

Parameters

solutionConfiguration
The solution configuration that is built.
outputFiles
The set of output files to be updated.

Return Value

The complete set of output files for the referenced project.

Remarks

The key of the case-insensitive Hashtable is the full path of the output file and the value is the path relative to the output directory.

See Also

ProjectReferenceBase Class | NAnt.VSNet Namespace


ProjectReferenceBase.GetPrimaryOutputFile Method

Gets the output path of the reference, without taking the "copy local" setting into consideration.

[Visual Basic]
Overrides Public Function GetPrimaryOutputFile( _
ByVal solutionConfiguration As Configuration _
) As String
[C#]
public override string GetPrimaryOutputFile(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Return Value

The output path of the reference.

See Also

ProjectReferenceBase Class | NAnt.VSNet Namespace


ProjectReferenceBase.GetTimestamp Method

Gets the timestamp of the reference.

[Visual Basic]
Overrides Public Function GetTimestamp( _
ByVal solutionConfiguration As Configuration _
) As Date
[C#]
public override DateTime GetTimestamp(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Return Value

The timestamp of the reference.

See Also

ProjectReferenceBase Class | NAnt.VSNet Namespace


ProjectReferenceBase.LoadProject Method

[Visual Basic]
Protected Function LoadProject( _
ByVal solution As SolutionBase, _
ByVal tfc As TempFileCollection, _
ByVal gacCache As GacCache, _
ByVal outputDir As DirectoryInfo, _
ByVal projectFile As String _
) As ProjectBase
[C#]
protected ProjectBase LoadProject(
SolutionBase solution,
TempFileCollection tfc,
GacCache gacCache,
DirectoryInfo outputDir,
string projectFile
);

See Also

ProjectReferenceBase Class | NAnt.VSNet Namespace


ProjectSettings Class

For a list of all members of this type, see ProjectSettings Members.

System.Object
NAnt.VSNet.ProjectSettings

[Visual Basic]
Public Class ProjectSettings
[C#]
public class ProjectSettings

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ProjectSettings Members | NAnt.VSNet Namespace


ProjectSettings Members

ProjectSettings overview

Public Static (Shared) Methods

GetProjectGuid Gets the project GUID from the given XmlElement holding a <VisualStudioProject> node.

Public Instance Constructors

ProjectSettings Constructor

Public Instance Properties

ApplicationIcon | Gets the .ico file to use as application icon.
AssemblyKeyContainerName | Gets the key name to use to sign ActiveX/COM wrappers.
AssemblyName |
AssemblyOriginatorKeyFile | Gets the key file to use to sign ActiveX/COM wrappers.
Guid |
OutputExtension |
OutputFileName |
OutputType | Gets the output type of this project.
PostBuildEvent | Contains commands to be ran after a build has taken place.
PreBuildEvent | Contains commands to be run before a build takes place.
RootNamespace |
RunPostBuildEvent | Designates when the PostBuildEvent command line should be run. Possible values are "OnBuildSuccess", "Always" or "OnOutputUpdated".
Settings |
TemporaryFiles |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetTemporaryFilename |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOutputType | Determines the output type of the project from its XML definition.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProjectSettings Class | NAnt.VSNet Namespace


ProjectSettings Constructor

[Visual Basic]
Public Sub New( _
ByVal elemRoot As XmlElement, _
ByVal elemSettings As XmlElement, _
ByVal project As ManagedProjectBase _
)
[C#]
public ProjectSettings(
XmlElement elemRoot,
XmlElement elemSettings,
ManagedProjectBase project
);

See Also

ProjectSettings Class | NAnt.VSNet Namespace


ProjectSettings Properties

The properties of the ProjectSettings class are listed below. For a complete list of ProjectSettings class members, see the ProjectSettings Members topic.

Public Instance Properties

ApplicationIcon | Gets the .ico file to use as application icon.
AssemblyKeyContainerName | Gets the key name to use to sign ActiveX/COM wrappers.
AssemblyName |
AssemblyOriginatorKeyFile | Gets the key file to use to sign ActiveX/COM wrappers.
Guid |
OutputExtension |
OutputFileName |
OutputType | Gets the output type of this project.
PostBuildEvent | Contains commands to be ran after a build has taken place.
PreBuildEvent | Contains commands to be run before a build takes place.
RootNamespace |
RunPostBuildEvent | Designates when the PostBuildEvent command line should be run. Possible values are "OnBuildSuccess", "Always" or "OnOutputUpdated".
Settings |
TemporaryFiles |

See Also

ProjectSettings Class | NAnt.VSNet Namespace


ApplicationIcon Property

NAnt SDK Documentation - v0.91

ProjectSettings.ApplicationIcon Property

Gets the .ico file to use as application icon.

[Visual Basic]
Public ReadOnly Property ApplicationIcon As FileInfo
[C#]
public System.IO.FileInfo ApplicationIcon {get;}

Property Value

The .ico file to use as application icon, or a null reference (Nothing in Visual Basic) if no application icon should be used.

See Also

ProjectSettings Class | NAnt.VSNet Namespace


AssemblyKeyContainerName Property

NAnt SDK Documentation - v0.91

ProjectSettings.AssemblyKeyContainerName Property

Gets the key name to use to sign ActiveX/COM wrappers.

[Visual Basic]
Public ReadOnly Property AssemblyKeyContainerName As String
[C#]
public string AssemblyKeyContainerName {get;}

Property Value

The name of the key container to use to sign ActiveX/COM wrappers, or a null reference (Nothing in Visual Basic) if the wrapper assembly should not be signed using a key container.

See Also

ProjectSettings Class | NAnt.VSNet Namespace


AssemblyName Property

NAnt SDK Documentation - v0.91

ProjectSettings.AssemblyName Property

[Visual Basic]
Public ReadOnly Property AssemblyName As String
[C#]
public string AssemblyName {get;}

See Also

ProjectSettings Class | NAnt.VSNet Namespace


AssemblyOriginatorKeyFile Property

NAnt SDK Documentation - v0.91

ProjectSettings.AssemblyOriginatorKeyFile Property

Gets the key file to use to sign ActiveX/COM wrappers.

[Visual Basic]
Public ReadOnly Property AssemblyOriginatorKeyFile As String
[C#]
public string AssemblyOriginatorKeyFile {get;}

Property Value

The path of the key file to use to sign ActiveX/COM wrappers, relative to the project root directory, or a null reference (Nothing in Visual Basic) if the wrapper assembly should not be signed using a key file.

See Also

ProjectSettings Class | NAnt.VSNet Namespace


Guid Property

NAnt SDK Documentation - v0.91

ProjectSettings.Guid Property

[Visual Basic]
Public ReadOnly Property Guid As String
[C#]
public string Guid {get;}

See Also

ProjectSettings Class | NAnt.VSNet Namespace


OutputExtension Property

NAnt SDK Documentation - v0.91

ProjectSettings.OutputExtension Property

[Visual Basic]
Public ReadOnly Property OutputExtension As String
[C#]
public string OutputExtension {get;}

See Also

ProjectSettings Class | NAnt.VSNet Namespace


OutputFileName Property

NAnt SDK Documentation - v0.91

ProjectSettings.OutputFileName Property

[Visual Basic]
Public ReadOnly Property OutputFileName As String
[C#]
public string OutputFileName {get;}

See Also

ProjectSettings Class | NAnt.VSNet Namespace


OutputType Property

NAnt SDK Documentation - v0.91

ProjectSettings.OutputType Property

Gets the output type of this project.

[Visual Basic]
Public ReadOnly Property OutputType As ManagedOutputType
[C#]
public ManagedOutputType OutputType {get;}

See Also

ProjectSettings Class | NAnt.VSNet Namespace


PostBuildEvent Property

NAnt SDK Documentation - v0.91

ProjectSettings.PostBuildEvent Property

Contains commands to be ran after a build has taken place.

[Visual Basic]
Public ReadOnly Property PostBuildEvent As String
[C#]
public string PostBuildEvent {get;}

Remarks

Valid commands are those in a .bat file. For more info see MSDN.

See Also

ProjectSettings Class | NAnt.VSNet Namespace


PreBuildEvent Property

NAnt SDK Documentation - v0.91

ProjectSettings.PreBuildEvent Property

Contains commands to be run before a build takes place.

[Visual Basic]
Public ReadOnly Property PreBuildEvent As String
[C#]
public string PreBuildEvent {get;}

Remarks

Valid commands are those in a .bat file. For more info see MSDN.

See Also

ProjectSettings Class | NAnt.VSNet Namespace


RootNamespace Property

NAnt SDK Documentation - v0.91

ProjectSettings.RootNamespace Property

[Visual Basic]
Public ReadOnly Property RootNamespace As String
[C#]
public string RootNamespace {get;}

See Also

ProjectSettings Class | NAnt.VSNet Namespace


RunPostBuildEvent Property

NAnt SDK Documentation - v0.91

ProjectSettings.RunPostBuildEvent Property

Designates when the PostBuildEvent command line should be run. Possible values are "OnBuildSuccess", "Always" or "OnOutputUpdated".

[Visual Basic]
Public ReadOnly Property RunPostBuildEvent As String
[C#]
public string RunPostBuildEvent {get;}

See Also

ProjectSettings Class | NAnt.VSNet Namespace


Settings Property

NAnt SDK Documentation - v0.91

ProjectSettings.Settings Property

[Visual Basic]
Public ReadOnly Property Settings As String()
[C#]
public string[] Settings {get;}

See Also

ProjectSettings Class | NAnt.VSNet Namespace


TemporaryFiles Property

NAnt SDK Documentation - v0.91

ProjectSettings.TemporaryFiles Property

[Visual Basic]
Public ReadOnly Property TemporaryFiles As TempFileCollection
[C#]
public System.CodeDom.Compiler.TempFileCollection TemporaryFiles {get;}

See Also

ProjectSettings Class | NAnt.VSNet Namespace


ProjectSettings Methods

The methods of the ProjectSettings class are listed below. For a complete list of ProjectSettings class members, see the ProjectSettings Members topic.

Public Static (Shared) Methods

GetProjectGuid Gets the project GUID from the given XmlElement holding a <VisualStudioProject> node.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetTemporaryFilename |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOutputType | Determines the output type of the project from its XML definition.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProjectSettings Class | NAnt.VSNet Namespace


ProjectSettings.GetOutputType Method

Determines the output type of the project from its XML definition.

[Visual Basic]
Overridable Protected Function GetOutputType( _
ByVal settingsXml As XmlElement _
) As ManagedOutputType
[C#]
protected virtual ManagedOutputType GetOutputType(
XmlElement settingsXml
);

Parameters

settingsXml
The XML definition of the project settings.

Return Value

The output type of the project.

Exceptions

Exception Type | Condition
BuildException | The output type of the project is not set in the specified XML definition. -or- The output type of the project is not supported.

See Also

ProjectSettings Class | NAnt.VSNet Namespace


ProjectSettings.GetProjectGuid Method

Gets the project GUID from the given XmlElement holding a <VisualStudioProject> node.

[Visual Basic]
Public Shared Function GetProjectGuid( _
ByVal projectFile As String, _
ByVal elemRoot As XmlElement _
) As String
[C#]
public static string GetProjectGuid(
string projectFile,
XmlElement elemRoot
);

Parameters

projectFile
The path of the project file.
elemRoot
The <VisualStudioProject> node from which the project GUID should be retrieved.

Return Value

The project GUID from specified <VisualStudioProject> node.

See Also

ProjectSettings Class | NAnt.VSNet Namespace


ProjectSettings.GetTemporaryFilename Method

[Visual Basic]
Public Function GetTemporaryFilename( _
ByVal fileName As String _
) As String
[C#]
public string GetTemporaryFilename(
string fileName
);

See Also

ProjectSettings Class | NAnt.VSNet Namespace


ProjectType Enumeration

Specifies the type of the project.

[Visual Basic]
<Serializable>
Public Enum ProjectType
[C#]
[Serializable]
public enum ProjectType

Members

Member Name | Description
VB | A Visual Basic.NET project.
CSharp | A Visual C# project.
VisualC | A Visual C++ project.
JSharp | A Visual J# project.
MSBuild | MSBuild project.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

NAnt.VSNet Namespace


ReferenceBase Class

For a list of all members of this type, see ReferenceBase Members.

System.Object
NAnt.VSNet.ReferenceBase
NAnt.VSNet.FileReferenceBase
NAnt.VSNet.ProjectReferenceBase

[Visual Basic]
MustInherit Public Class ReferenceBase
[C#]
public abstract class ReferenceBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ReferenceBase Members | NAnt.VSNet Namespace


ReferenceBase Members

ReferenceBase overview

Public Static (Shared) Methods

GetRelatedFiles

Public Instance Properties

CopyLocal | Gets a value indicating whether the output file(s) of this reference should be copied locally.
Name |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences | Gets the complete set of assemblies that need to be referenced when a project references this component.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles | Gets the complete set of output files of the reference for the specified configuration.
GetPrimaryOutputFile | Gets the output path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ReferenceBase Constructor

Protected Instance Properties

IsSystem | Gets a value indicating whether this reference represents a system assembly.
Parent | Gets the project in which the reference is defined.
ReferencesResolver |
SolutionTask |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFileTimestamp | Returns the date and time the specified file was last written to.
Log | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReferenceBase Class | NAnt.VSNet Namespace


ReferenceBase Constructor

[Visual Basic]
Protected Sub New( _
ByVal referencesResolver As ReferencesResolver, _
ByVal parent As ProjectBase _
)
[C#]
protected ReferenceBase(
ReferencesResolver referencesResolver,
ProjectBase parent
);

See Also

ReferenceBase Class | NAnt.VSNet Namespace


ReferenceBase Properties

The properties of the ReferenceBase class are listed below. For a complete list of ReferenceBase class members, see the ReferenceBase Members topic.

Public Instance Properties

CopyLocal | Gets a value indicating whether the output file(s) of this reference should be copied locally.
Name |

Protected Instance Properties

IsSystem | Gets a value indicating whether this reference represents a system assembly.
Parent | Gets the project in which the reference is defined.
ReferencesResolver |
SolutionTask |

See Also

ReferenceBase Class | NAnt.VSNet Namespace


CopyLocal Property

NAnt SDK Documentation - v0.91

ReferenceBase.CopyLocal Property

Gets a value indicating whether the output file(s) of this reference should be copied locally.

[Visual Basic]
MustOverride Public ReadOnly Property CopyLocal As Boolean
[C#]
public abstract bool CopyLocal {get;}

Property Value

true if the output file(s) of this reference should be copied locally; otherwise, false.

See Also

ReferenceBase Class | NAnt.VSNet Namespace


IsSystem Property

NAnt SDK Documentation - v0.91

ReferenceBase.IsSystem Property

Gets a value indicating whether this reference represents a system assembly.

[Visual Basic]
MustOverride Protected ReadOnly Property IsSystem As Boolean
[C#]
protected abstract bool IsSystem {get;}

Property Value

true if this reference represents a system assembly; otherwise, false.

See Also

ReferenceBase Class | NAnt.VSNet Namespace


Name Property

NAnt SDK Documentation - v0.91

ReferenceBase.Name Property

[Visual Basic]
MustOverride Public ReadOnly Property Name As String
[C#]
public abstract string Name {get;}

See Also

ReferenceBase Class | NAnt.VSNet Namespace


Parent Property

NAnt SDK Documentation - v0.91

ReferenceBase.Parent Property

Gets the project in which the reference is defined.

[Visual Basic]
Protected ReadOnly Property Parent As ProjectBase
[C#]
protected ProjectBase Parent {get;}

See Also

ReferenceBase Class | NAnt.VSNet Namespace


ReferencesResolver Property

NAnt SDK Documentation - v0.91

ReferenceBase.ReferencesResolver Property

[Visual Basic]
Protected ReadOnly Property ReferencesResolver As ReferencesResolver
[C#]
protected ReferencesResolver ReferencesResolver {get;}

See Also

ReferenceBase Class | NAnt.VSNet Namespace


SolutionTask Property

NAnt SDK Documentation - v0.91

ReferenceBase.SolutionTask Property

[Visual Basic]
Protected ReadOnly Property SolutionTask As SolutionTask
[C#]
protected Tasks.SolutionTask SolutionTask {get;}

See Also

ReferenceBase Class | NAnt.VSNet Namespace


ReferenceBase Methods

The methods of the ReferenceBase class are listed below. For a complete list of ReferenceBase class members, see the ReferenceBase Members topic.

Public Static (Shared) Methods

GetRelatedFiles

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences | Gets the complete set of assemblies that need to be referenced when a project references this component.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles | Gets the complete set of output files of the reference for the specified configuration.
GetPrimaryOutputFile | Gets the output path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFileTimestamp | Returns the date and time the specified file was last written to.
Log | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReferenceBase Class | NAnt.VSNet Namespace


ReferenceBase.GetAssemblyReferences Method

Gets the complete set of assemblies that need to be referenced when a project references this component.

[Visual Basic]
MustOverride Public Function GetAssemblyReferences( _
ByVal solutionConfiguration As Configuration _
) As StringCollection
[C#]
public abstract StringCollection GetAssemblyReferences(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Return Value

The complete set of assemblies that need to be referenced when a project references this component.

See Also

ReferenceBase Class | NAnt.VSNet Namespace


ReferenceBase.GetFileTimestamp Method

Returns the date and time the specified file was last written to.

[Visual Basic]
Protected Function GetFileTimestamp( _
ByVal fileName As String _
) As Date
[C#]
protected DateTime GetFileTimestamp(
string fileName
);

Parameters

fileName
The file for which to obtain write date and time information.

Return Value

A DateTime structure set to the date and time that the specified file was last written to, or MaxValue if the specified file does not exist.

See Also

ReferenceBase Class | NAnt.VSNet Namespace


ReferenceBase.GetOutputFiles Method

Gets the complete set of output files of the reference for the specified configuration.

[Visual Basic]
MustOverride Public Sub GetOutputFiles( _
ByVal solutionConfiguration As Configuration, _
ByVal outputFiles As Hashtable _
)
[C#]
public abstract void GetOutputFiles(
Configuration solutionConfiguration,
Hashtable outputFiles
);

Parameters

solutionConfiguration
The solution configuration that is built.
outputFiles
The set of output files to be updated.

Remarks

The key of the case-insensitive Hashtable is the full path of the output file and the value is the path relative to the output directory.

See Also

ReferenceBase Class | NAnt.VSNet Namespace


ReferenceBase.GetPrimaryOutputFile Method

Gets the output path of the reference, without taking the "copy local" setting into consideration.

[Visual Basic]
MustOverride Public Function GetPrimaryOutputFile( _
ByVal solutionConfiguration As Configuration _
) As String
[C#]
public abstract string GetPrimaryOutputFile(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Return Value

The full output path of the reference.

See Also

ReferenceBase Class | NAnt.VSNet Namespace


ReferenceBase.GetRelatedFiles Method

[Visual Basic]
Public Shared Sub GetRelatedFiles( _
ByVal file As String, _
ByVal relatedFiles As Hashtable _
)
[C#]
public static void GetRelatedFiles(
string file,
Hashtable relatedFiles
);

See Also

ReferenceBase Class | NAnt.VSNet Namespace


ReferenceBase.GetTimestamp Method

Gets the timestamp of the reference.

[Visual Basic]
MustOverride Public Function GetTimestamp( _
ByVal solutionConfiguration As Configuration _
) As Date
[C#]
public abstract DateTime GetTimestamp(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Return Value

The timestamp of the reference.

See Also

ReferenceBase Class | NAnt.VSNet Namespace


ReferenceBase.IsManaged Method

Gets a value indicating whether the reference is managed for the specified configuration.

[Visual Basic]
MustOverride Public Function IsManaged( _
ByVal solutionConfiguration As Configuration _
) As Boolean
[C#]
public abstract bool IsManaged(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Return Value

true if the reference is managed for the specified configuration; otherwise, false.

See Also

ReferenceBase Class | NAnt.VSNet Namespace


Log Method

NAnt SDK Documentation - v0.91

ReferenceBase.Log Method

Logs a message with the given priority.

Overload List

Logs a message with the given priority.

protected void Log(Level,string);

Logs a message with the given priority.

protected void Log(Level,string,params object[]);

See Also

ReferenceBase Class | NAnt.VSNet Namespace


ReferenceBase.Log Method (Level, String)

Logs a message with the given priority.

[Visual Basic]
Overloads Protected Sub Log( _
ByVal messageLevel As Level, _
ByVal message As String _
)
[C#]
protected void Log(
Level messageLevel,
string message
);

Parameters

messageLevel
The message priority at which the specified message is to be logged.
message
The message to be logged.

Remarks

The actual logging is delegated to the underlying task.

See Also

ReferenceBase Class | NAnt.VSNet Namespace | ReferenceBase.Log Overload List


ReferenceBase.Log Method (Level, String, Object[])

Logs a message with the given priority.

[Visual Basic]
Overloads Protected Sub Log( _
ByVal messageLevel As Level, _
ByVal message As String, _
ParamArray args As Object() _
)
[C#]
protected void Log(
Level messageLevel,
string message,
params object[] args
);

Parameters

messageLevel
The message priority at which the specified message is to be logged.
message
The message to log, containing zero or more format items.
args
An Object array containing zero or more objects to format.

Remarks

The actual logging is delegated to the underlying task.

See Also

ReferenceBase Class | NAnt.VSNet Namespace | ReferenceBase.Log Overload List


ReferencesResolver Class

For a list of all members of this type, see ReferencesResolver Members.

System.Object
System.MarshalByRefObject
NAnt.VSNet.ReferencesResolver

[Visual Basic]
Public Class ReferencesResolver
Inherits MarshalByRefObject
[C#]
public class ReferencesResolver : MarshalByRefObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ReferencesResolver Members | NAnt.VSNet Namespace


ReferencesResolver Members

ReferencesResolver overview

Public Instance Constructors

ReferencesResolver Constructor Initializes a new instance of the ReferencesResolver class.

Public Instance Methods

AppendReferencedModulesLocatedInGivenDirectory |
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyFileName | Gets the file name of the assembly with the given assembly name.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.

See Also

ReferencesResolver Class | NAnt.VSNet Namespace


ReferencesResolver Constructor

Initializes a new instance of the ReferencesResolver class.

[Visual Basic]
Public Sub New()
[C#]
public ReferencesResolver();

See Also

ReferencesResolver Class | NAnt.VSNet Namespace


ReferencesResolver Methods

The methods of the ReferencesResolver class are listed below. For a complete list of ReferencesResolver class members, see the ReferencesResolver Members topic.

Public Instance Methods

AppendReferencedModulesLocatedInGivenDirectory |
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyFileName | Gets the file name of the assembly with the given assembly name.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.

See Also

ReferencesResolver Class | NAnt.VSNet Namespace


ReferencesResolver.AppendReferencedModulesLocatedInGivenDirectory Method

[Visual Basic]
Public Sub AppendReferencedModulesLocatedInGivenDirectory( _
ByVal moduleDirectory As String, _
ByVal moduleName As String, _
ByRef allReferences As Hashtable, _
ByRef unresolvedReferences As Hashtable _
)
[C#]
public void AppendReferencedModulesLocatedInGivenDirectory(
string moduleDirectory,
string moduleName,
ref Hashtable allReferences,
ref Hashtable unresolvedReferences
);

See Also

ReferencesResolver Class | NAnt.VSNet Namespace


ReferencesResolver.GetAssemblyFileName Method

Gets the file name of the assembly with the given assembly name.

[Visual Basic]
Public Function GetAssemblyFileName( _
ByVal assemblyName As String _
) As String
[C#]
public string GetAssemblyFileName(
string assemblyName
);

Parameters

assemblyName
The assembly name of the assembly of which the file name should be returned.

Return Value

The file name of the assembly with the given assembly name.

See Also

ReferencesResolver Class | NAnt.VSNet Namespace


ReferencesResolver.InitializeLifetimeService Method

Obtains a lifetime service object to control the lifetime policy for this instance.

[Visual Basic]
Overrides Public Function InitializeLifetimeService() As Object
[C#]
public override object InitializeLifetimeService();

Return Value

An object of type ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized with a lease that will never time out.

See Also

ReferencesResolver Class | NAnt.VSNet Namespace


Resource Class

For a list of all members of this type, see Resource Members.

System.Object
NAnt.VSNet.Resource

[Visual Basic]
Public Class Resource
[C#]
public class Resource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

Resource Members | NAnt.VSNet Namespace


Resource Members

Resource overview

Public Instance Constructors

Resource Constructor

Public Instance Properties

Culture |
InputFile | Gets a FileInfo representing the physical location of the resource file.
IsResX | Gets a value indicating whether the resource is in fact a ResX file.
LogicalFile | Gets a FileInfo representing the logical location of the resource file in the project.
Project |

Public Instance Methods

Compile | Compiles the resource file.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCompiledResourceFile | Returns a FileInfo representing the compiled resource file.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetManifestResourceName |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Resource Class | NAnt.VSNet Namespace


Resource Constructor

[Visual Basic]
Public Sub New( _
ByVal project As ManagedProjectBase, _
ByVal resourceSourceFile As FileInfo, _
ByVal resourceSourceFileRelativePath As String, _
ByVal dependentFile As String, _
ByVal solutionTask As SolutionTask, _
ByVal gacCache As GacCache _
)
[C#]
public Resource(
ManagedProjectBase project,
FileInfo resourceSourceFile,
string resourceSourceFileRelativePath,
string dependentFile,
SolutionTask solutionTask,
GacCache gacCache
);

See Also

Resource Class | NAnt.VSNet Namespace


Resource Properties

The properties of the Resource class are listed below. For a complete list of Resource class members, see the Resource Members topic.

Public Instance Properties

Culture |
InputFile | Gets a FileInfo representing the physical location of the resource file.
IsResX | Gets a value indicating whether the resource is in fact a ResX file.
LogicalFile | Gets a FileInfo representing the logical location of the resource file in the project.
Project |

See Also

Resource Class | NAnt.VSNet Namespace


Culture Property

NAnt SDK Documentation - v0.91

Resource.Culture Property

[Visual Basic]
Public ReadOnly Property Culture As CultureInfo
[C#]
public System.Globalization.CultureInfo Culture {get;}

See Also

Resource Class | NAnt.VSNet Namespace


InputFile Property

NAnt SDK Documentation - v0.91

Resource.InputFile Property

Gets a FileInfo representing the physical location of the resource file.

[Visual Basic]
Public ReadOnly Property InputFile As FileInfo
[C#]
public System.IO.FileInfo InputFile {get;}

See Also

Resource Class | NAnt.VSNet Namespace


IsResX Property

NAnt SDK Documentation - v0.91

Resource.IsResX Property

Gets a value indicating whether the resource is in fact a ResX file.

[Visual Basic]
Public ReadOnly Property IsResX As Boolean
[C#]
public bool IsResX {get;}

Property Value

true if the resource is a ResX file; otherwise, false.

See Also

Resource Class | NAnt.VSNet Namespace


LogicalFile Property

NAnt SDK Documentation - v0.91

Resource.LogicalFile Property

Gets a FileInfo representing the logical location of the resource file in the project.

[Visual Basic]
Public ReadOnly Property LogicalFile As FileInfo
[C#]
public System.IO.FileInfo LogicalFile {get;}

Remarks

When the resource file is not linked, this matches the InputFile.

See Also

Resource Class | NAnt.VSNet Namespace


Project Property

NAnt SDK Documentation - v0.91

Resource.Project Property

[Visual Basic]
Public ReadOnly Property Project As ManagedProjectBase
[C#]
public ManagedProjectBase Project {get;}

See Also

Resource Class | NAnt.VSNet Namespace


Resource Methods

The methods of the Resource class are listed below. For a complete list of Resource class members, see the Resource Members topic.

Public Instance Methods

Compile | Compiles the resource file.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCompiledResourceFile | Returns a FileInfo representing the compiled resource file.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetManifestResourceName |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Resource Class | NAnt.VSNet Namespace


Resource.Compile Method

Compiles the resource file.

[Visual Basic]
Public Function Compile( _
ByVal solutionConfiguration As Configuration _
) As FileInfo
[C#]
public FileInfo Compile(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Return Value

A FileInfo representing the compiled resource file.

See Also

Resource Class | NAnt.VSNet Namespace


Resource.GetCompiledResourceFile Method

Returns a FileInfo representing the compiled resource file.

[Visual Basic]
Public Function GetCompiledResourceFile( _
ByVal solutionConfiguration As Configuration _
) As FileInfo
[C#]
public FileInfo GetCompiledResourceFile(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Return Value

A FileInfo representing the compiled resource file.

Remarks

Calling this method does not force compilation of the resource file.

See Also

Resource Class | NAnt.VSNet Namespace


Resource.GetManifestResourceName Method

[Visual Basic]
Public Function GetManifestResourceName( _
ByVal solutionConfiguration As Configuration _
) As String
[C#]
public string GetManifestResourceName(
Configuration solutionConfiguration
);

See Also

Resource Class | NAnt.VSNet Namespace


SolutionBase Class

For a list of all members of this type, see SolutionBase Members.

System.Object
NAnt.VSNet.SolutionBase
NAnt.VSNet.GenericSolution

[Visual Basic]
MustInherit Public Class SolutionBase
[C#]
public abstract class SolutionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

SolutionBase Members | NAnt.VSNet Namespace


SolutionBase Members

SolutionBase overview

Public Instance Properties

File
ProjectEntries
TemporaryFiles

Public Instance Methods

Compile |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetProjectFileFromGuid | Gets the project file of the project with the given unique identifier.
GetProjectFromGuid |
GetType (inherited from Object) | Gets the Type of the current instance.
RecursiveLoadTemplateProject |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

SolutionBase Constructor

Protected Instance Properties

WebMaps

Protected Instance Methods

CreateProjectDoesNotExistException |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FixProjectReferences | Converts assembly references to projects to project references, adding a build dependency.c
GetDependenciesFromProjects |
LoadProjectGuids |
LoadProjects | Loads the projects from the file system and stores them in an instance variable.
Log | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetProjectBuildConfiguration |
TranslateProjectPath | Translates a project path, in the form of a relative file path or a URL, to an absolute file path.

See Also

SolutionBase Class | NAnt.VSNet Namespace


SolutionBase Constructor

[Visual Basic]
Overloads Protected Sub New( _
ByVal solutionTask As SolutionTask, _
ByVal tfc As TempFileCollection, _
ByVal gacCache As GacCache, _
ByVal refResolver As ReferencesResolver _
)
[C#]
protected SolutionBase(
SolutionTask solutionTask,
TempFileCollection tfc,
GacCache gacCache,
ReferencesResolver refResolver
);

See Also

SolutionBase Class | NAnt.VSNet Namespace


SolutionBase Properties

The properties of the SolutionBase class are listed below. For a complete list of SolutionBase class members, see the SolutionBase Members topic.

Public Instance Properties

File
ProjectEntries
TemporaryFiles

Protected Instance Properties

WebMaps

See Also

SolutionBase Class | NAnt.VSNet Namespace


File Property

NAnt SDK Documentation - v0.91

SolutionBase.File Property

[Visual Basic]
Public ReadOnly Property File As FileInfo
[C#]
public System.IO.FileInfo File {get;}

See Also

SolutionBase Class | NAnt.VSNet Namespace


ProjectEntries Property

NAnt SDK Documentation - v0.91

SolutionBase.ProjectEntries Property

[Visual Basic]
Public ReadOnly Property ProjectEntries As ProjectEntryCollection
[C#]
public ProjectEntryCollection ProjectEntries {get;}

See Also

SolutionBase Class | NAnt.VSNet Namespace


TemporaryFiles Property

NAnt SDK Documentation - v0.91

SolutionBase.TemporaryFiles Property

[Visual Basic]
Public ReadOnly Property TemporaryFiles As TempFileCollection
[C#]
public System.CodeDom.Compiler.TempFileCollection TemporaryFiles {get;}

See Also

SolutionBase Class | NAnt.VSNet Namespace


WebMaps Property

NAnt SDK Documentation - v0.91

SolutionBase.WebMaps Property

[Visual Basic]
Protected ReadOnly Property WebMaps As WebMapCollection
[C#]
protected Types.WebMapCollection WebMaps {get;}

See Also

SolutionBase Class | NAnt.VSNet Namespace


SolutionBase Methods

The methods of the SolutionBase class are listed below. For a complete list of SolutionBase class members, see the SolutionBase Members topic.

Public Instance Methods

Compile |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetProjectFileFromGuid | Gets the project file of the project with the given unique identifier.
GetProjectFromGuid |
GetType (inherited from Object) | Gets the Type of the current instance.
RecursiveLoadTemplateProject |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CreateProjectDoesNotExistException |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FixProjectReferences | Converts assembly references to projects to project references, adding a build dependency.c
GetDependenciesFromProjects |
LoadProjectGuids |
LoadProjects | Loads the projects from the file system and stores them in an instance variable.
Log | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetProjectBuildConfiguration |
TranslateProjectPath | Translates a project path, in the form of a relative file path or a URL, to an absolute file path.

See Also

SolutionBase Class | NAnt.VSNet Namespace


SolutionBase.Compile Method

[Visual Basic]
Public Function Compile( _
ByVal solutionConfiguration As Configuration _
) As Boolean
[C#]
public bool Compile(
Configuration solutionConfiguration
);

See Also

SolutionBase Class | NAnt.VSNet Namespace


SolutionBase.CreateProjectDoesNotExistException Method

[Visual Basic]
Protected Function CreateProjectDoesNotExistException( _
ByVal projectPath As String _
) As BuildException
[C#]
protected BuildException CreateProjectDoesNotExistException(
string projectPath
);

See Also

SolutionBase Class | NAnt.VSNet Namespace


SolutionBase.FixProjectReferences Method

Converts assembly references to projects to project references, adding a build dependency.c

[Visual Basic]
Protected Function FixProjectReferences( _
ByVal project As ProjectBase, _
ByVal solutionConfiguration As Configuration, _
ByVal builtProjects As Hashtable, _
ByVal failedProjects As Hashtable _
) As Boolean
[C#]
protected bool FixProjectReferences(
ProjectBase project,
Configuration solutionConfiguration,
Hashtable builtProjects,
Hashtable failedProjects
);

Parameters

project
The ProjectBase to analyze.
solutionConfiguration
The solution configuration that is built.
builtProjects
Hashtable containing list of projects that have been built.
failedProjects
Hashtable containing list of projects that failed to build.

See Also

SolutionBase Class | NAnt.VSNet Namespace


SolutionBase.GetDependenciesFromProjects Method

[Visual Basic]
Protected Sub GetDependenciesFromProjects( _
ByVal solutionConfiguration As Configuration _
)
[C#]
protected void GetDependenciesFromProjects(
Configuration solutionConfiguration
);

See Also

SolutionBase Class | NAnt.VSNet Namespace


SolutionBase.GetProjectFileFromGuid Method

Gets the project file of the project with the given unique identifier.

[Visual Basic]
Public Function GetProjectFileFromGuid( _
ByVal projectGuid As String _
) As String
[C#]
public string GetProjectFileFromGuid(
string projectGuid
);

Parameters

projectGuid
The unique identifier of the project for which the project file should be retrieves.

Return Value

The project file of the project with the given unique identifier.

Exceptions

Exception Type | Condition
BuildException | No project with unique identifier projectGuid could be located.

See Also

SolutionBase Class | NAnt.VSNet Namespace


SolutionBase.GetProjectFromGuid Method

[Visual Basic]
Public Function GetProjectFromGuid( _
ByVal projectGuid As String _
) As ProjectBase
[C#]
public ProjectBase GetProjectFromGuid(
string projectGuid
);

See Also

SolutionBase Class | NAnt.VSNet Namespace


SolutionBase.LoadProjectGuids Method

[Visual Basic]
Protected Sub LoadProjectGuids( _
ByVal projects As ArrayList, _
ByVal isReferenceProject As Boolean _
)
[C#]
protected void LoadProjectGuids(
ArrayList projects,
bool isReferenceProject
);

See Also

SolutionBase Class | NAnt.VSNet Namespace


SolutionBase.LoadProjects Method

Loads the projects from the file system and stores them in an instance variable.

[Visual Basic]
Protected Sub LoadProjects( _
ByVal gacCache As GacCache, _
ByVal refResolver As ReferencesResolver, _
ByVal explicitProjectDependencies As Hashtable _
)
[C#]
protected void LoadProjects(
GacCache gacCache,
ReferencesResolver refResolver,
Hashtable explicitProjectDependencies
);

Parameters

gacCache
GacCache instance to use to determine whether an assembly is located in the Global Assembly Cache.
refResolver
ReferencesResolver instance to use to determine location and references of assemblies.
explicitProjectDependencies
TODO

Exceptions

Exception Type | Condition
BuildException | A project GUID in the solution file does not match the actual GUID of the project in the project file.

See Also

SolutionBase Class | NAnt.VSNet Namespace


Log Method

NAnt SDK Documentation - v0.91

SolutionBase.Log Method

Logs a message with the given priority.

Overload List

Logs a message with the given priority.

protected void Log(Level,string);

Logs a message with the given priority.

protected void Log(Level,string,params object[]);

See Also

SolutionBase Class | NAnt.VSNet Namespace


SolutionBase.Log Method (Level, String)

Logs a message with the given priority.

[Visual Basic]
Overloads Protected Sub Log( _
ByVal messageLevel As Level, _
ByVal message As String _
)
[C#]
protected void Log(
Level messageLevel,
string message
);

Parameters

messageLevel
The message priority at which the specified message is to be logged.
message
The message to be logged.

Remarks

The actual logging is delegated to the underlying task.

See Also

SolutionBase Class | NAnt.VSNet Namespace | SolutionBase.Log Overload List


SolutionBase.Log Method (Level, String, Object[])

Logs a message with the given priority.

[Visual Basic]
Overloads Protected Sub Log( _
ByVal messageLevel As Level, _
ByVal message As String, _
ParamArray args As Object() _
)
[C#]
protected void Log(
Level messageLevel,
string message,
params object[] args
);

Parameters

messageLevel
The message priority at which the specified message is to be logged.
message
The message to log, containing zero or more format items.
args
An Object array containing zero or more objects to format.

Remarks

The actual logging is delegated to the underlying task.

See Also

SolutionBase Class | NAnt.VSNet Namespace | SolutionBase.Log Overload List


SolutionBase.RecursiveLoadTemplateProject Method

[Visual Basic]
Public Sub RecursiveLoadTemplateProject( _
ByVal fileName As String _
)
[C#]
public void RecursiveLoadTemplateProject(
string fileName
);

See Also

SolutionBase Class | NAnt.VSNet Namespace


SolutionBase.SetProjectBuildConfiguration Method

[Visual Basic]
Overridable Protected Sub SetProjectBuildConfiguration( _
ByVal projectEntry As ProjectEntry _
)
[C#]
protected virtual void SetProjectBuildConfiguration(
ProjectEntry projectEntry
);

See Also

SolutionBase Class | NAnt.VSNet Namespace


SolutionBase.TranslateProjectPath Method

Translates a project path, in the form of a relative file path or a URL, to an absolute file path.

[Visual Basic]
Protected Function TranslateProjectPath( _
ByVal solutionDir As String, _
ByVal projectPath As String _
) As String
[C#]
protected string TranslateProjectPath(
string solutionDir,
string projectPath
);

Parameters

solutionDir
The directory of the solution.
projectPath
The project path to translate to an absolute file path.

Return Value

The project path translated to an absolute file path.

See Also

SolutionBase Class | NAnt.VSNet Namespace


VBProject Class

For a list of all members of this type, see VBProject Members.

System.Object
NAnt.VSNet.ProjectBase
NAnt.VSNet.ManagedProjectBase
NAnt.VSNet.VBProject

[Visual Basic]
Public Class VBProject
Inherits ManagedProjectBase
[C#]
public class VBProject : ManagedProjectBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

VBProject Members | NAnt.VSNet Namespace


VBProject Members

VBProject overview

Public Static (Shared) Methods

IsSupported Returns a value indicating whether the project represented by the specified XML fragment is supported by VBProject.

Public Instance Constructors

VBProject Constructor

Public Instance Properties

BuildConfigurations (inherited from ProjectBase) | Gets a list of project configurations that can be build.
ExtraOutputFiles (inherited from ProjectBase) | Gets the extra set of output files for the project.
Guid (inherited from ManagedProjectBase) | Gets or sets the unique identifier of the VS.NET project.
Name (inherited from ManagedProjectBase) | Gets the name of the VS.NET project.
ObjectDir (inherited from ProjectBase) | Get the directory in which intermediate build output that is not specific to the build configuration will be stored.
ProductVersion (inherited from ProjectBase) | Gets the Visual Studio product version of the project.
ProjectConfigurations (inherited from ProjectBase) | Gets a list of all configurations defined in the project.
ProjectDependencies (inherited from ProjectBase) | Gets the set of projects that the project depends on.
ProjectDirectory (inherited from ManagedProjectBase) | Gets the directory containing the VS.NET project.
ProjectLocation (inherited from ManagedProjectBase) | Get the location of the project.
ProjectPath (inherited from ManagedProjectBase) | Gets the path of the VS.NET project.
ProjectSettings (inherited from ManagedProjectBase) |
References (inherited from ManagedProjectBase) |
ReferencesResolver (inherited from ProjectBase) |
SolutionTask (inherited from ProjectBase) |
TemporaryFiles (inherited from ProjectBase) |
Type | Gets the type of the project.

Public Instance Methods

Compile (inherited from ProjectBase) |
CreateProjectReference (inherited from ManagedProjectBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from ProjectBase) |
GetConfiguration (inherited from ProjectBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from ManagedProjectBase) | Gets the complete set of output files for the project configuration matching the specified solution configuration.
GetOutputPath (inherited from ProjectBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from ManagedProjectBase) | Gets a value indicating whether building the project for the specified build configuration results in managed output.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

DevEnvDir (inherited from ProjectBase) |
FileExtension | Gets the default file extension of sources for this project.
GacCache (inherited from ProjectBase) |
OutputDir (inherited from ProjectBase) |

Protected Instance Methods

Build (inherited from ManagedProjectBase) |
CopyFile (inherited from ProjectBase) | Copies the specified file if the destination file does not exist, or the source file has been modified since it was previously copied.
CreateReference (inherited from ManagedProjectBase) |
DetermineProductVersion | Returns the Visual Studio product version of the specified project XML fragment.
DetermineProjectLocation | Returns the project location from the specified project XML fragment.
ExecuteBuildEvent (inherited from ProjectBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetProcessStartInfo | Returns a ProcessStartInfo for launching the compiler for this project.
Log (inherited from ProjectBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Prepare (inherited from ManagedProjectBase) | Prepares the project for being built.
VerifyProjectXml | Verifies whether the specified XML fragment represents a valid project that is supported by this ProjectBase.
WriteCompilerOptions (inherited from ManagedProjectBase) |
WriteProjectOptions |

Protected Internal Instance Methods

ExpandMacro (inherited from ProjectBase) Expands the given macro.

See Also

VBProject Class | NAnt.VSNet Namespace


VBProject Constructor

[Visual Basic]
Public Sub New( _
ByVal solution As SolutionBase, _
ByVal projectPath As String, _
ByVal xmlDefinition As XmlElement, _
ByVal solutionTask As SolutionTask, _
ByVal tfc As TempFileCollection, _
ByVal gacCache As GacCache, _
ByVal refResolver As ReferencesResolver, _
ByVal outputDir As DirectoryInfo _
)
[C#]
public VBProject(
SolutionBase solution,
string projectPath,
XmlElement xmlDefinition,
SolutionTask solutionTask,
TempFileCollection tfc,
GacCache gacCache,
ReferencesResolver refResolver,
DirectoryInfo outputDir
);

See Also

VBProject Class | NAnt.VSNet Namespace


VBProject Properties

The properties of the VBProject class are listed below. For a complete list of VBProject class members, see the VBProject Members topic.

Public Instance Properties

BuildConfigurations (inherited from ProjectBase) | Gets a list of project configurations that can be build.
ExtraOutputFiles (inherited from ProjectBase) | Gets the extra set of output files for the project.
Guid (inherited from ManagedProjectBase) | Gets or sets the unique identifier of the VS.NET project.
Name (inherited from ManagedProjectBase) | Gets the name of the VS.NET project.
ObjectDir (inherited from ProjectBase) | Get the directory in which intermediate build output that is not specific to the build configuration will be stored.
ProductVersion (inherited from ProjectBase) | Gets the Visual Studio product version of the project.
ProjectConfigurations (inherited from ProjectBase) | Gets a list of all configurations defined in the project.
ProjectDependencies (inherited from ProjectBase) | Gets the set of projects that the project depends on.
ProjectDirectory (inherited from ManagedProjectBase) | Gets the directory containing the VS.NET project.
ProjectLocation (inherited from ManagedProjectBase) | Get the location of the project.
ProjectPath (inherited from ManagedProjectBase) | Gets the path of the VS.NET project.
ProjectSettings (inherited from ManagedProjectBase) |
References (inherited from ManagedProjectBase) |
ReferencesResolver (inherited from ProjectBase) |
SolutionTask (inherited from ProjectBase) |
TemporaryFiles (inherited from ProjectBase) |
Type | Gets the type of the project.

Protected Instance Properties

DevEnvDir (inherited from ProjectBase) |
FileExtension | Gets the default file extension of sources for this project.
GacCache (inherited from ProjectBase) |
OutputDir (inherited from ProjectBase) |

See Also

VBProject Class | NAnt.VSNet Namespace


FileExtension Property

NAnt SDK Documentation - v0.91

VBProject.FileExtension Property

Gets the default file extension of sources for this project.

[Visual Basic]
Overrides Protected ReadOnly Property FileExtension As String
[C#]
protected override string FileExtension {get;}

Property Value

For VB projects, the default file extension is ".vb".

See Also

VBProject Class | NAnt.VSNet Namespace


Type Property

NAnt SDK Documentation - v0.91

VBProject.Type Property

Gets the type of the project.

[Visual Basic]
Overrides Public ReadOnly Property Type As ProjectType
[C#]
public override ProjectType Type {get;}

Property Value

The type of the project.

See Also

VBProject Class | NAnt.VSNet Namespace


VBProject Methods

The methods of the VBProject class are listed below. For a complete list of VBProject class members, see the VBProject Members topic.

Public Static (Shared) Methods

IsSupported Returns a value indicating whether the project represented by the specified XML fragment is supported by VBProject.

Public Instance Methods

Compile (inherited from ProjectBase) |
CreateProjectReference (inherited from ManagedProjectBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from ProjectBase) |
GetConfiguration (inherited from ProjectBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from ManagedProjectBase) | Gets the complete set of output files for the project configuration matching the specified solution configuration.
GetOutputPath (inherited from ProjectBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from ManagedProjectBase) | Gets a value indicating whether building the project for the specified build configuration results in managed output.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Build (inherited from ManagedProjectBase) |
CopyFile (inherited from ProjectBase) | Copies the specified file if the destination file does not exist, or the source file has been modified since it was previously copied.
CreateReference (inherited from ManagedProjectBase) |
DetermineProductVersion | Returns the Visual Studio product version of the specified project XML fragment.
DetermineProjectLocation | Returns the project location from the specified project XML fragment.
ExecuteBuildEvent (inherited from ProjectBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetProcessStartInfo | Returns a ProcessStartInfo for launching the compiler for this project.
Log (inherited from ProjectBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Prepare (inherited from ManagedProjectBase) | Prepares the project for being built.
VerifyProjectXml | Verifies whether the specified XML fragment represents a valid project that is supported by this ProjectBase.
WriteCompilerOptions (inherited from ManagedProjectBase) |
WriteProjectOptions |

Protected Internal Instance Methods

ExpandMacro (inherited from ProjectBase) Expands the given macro.

See Also

VBProject Class | NAnt.VSNet Namespace


VBProject.DetermineProductVersion Method

Returns the Visual Studio product version of the specified project XML fragment.

[Visual Basic]
Overrides Protected Function DetermineProductVersion( _
ByVal docElement As XmlElement _
) As ProductVersion
[C#]
protected override ProductVersion DetermineProductVersion(
XmlElement docElement
);

Parameters

docElement
The document element of the project.

Return Value

The Visual Studio product version of the specified project XML fragment.

Remarks

This method is called from the ProjectBase ctor, and at that time we're not sure the XML that is passed in, is indeed a valid Visual Basic project.

Exceptions

Exception Type | Condition
BuildException | The product version could not be determined. -or- The product version is not supported.

See Also

VBProject Class | NAnt.VSNet Namespace


VBProject.DetermineProjectLocation Method

Returns the project location from the specified project XML fragment.

[Visual Basic]
Overrides Protected Function DetermineProjectLocation( _
ByVal docElement As XmlElement _
) As ProjectLocation
[C#]
protected override ProjectLocation DetermineProjectLocation(
XmlElement docElement
);

Parameters

docElement
XML fragment representing the project file.

Return Value

The project location of the specified project XML file.

Exceptions

Exception Type | Condition
BuildException | The project location could not be determined. -or- The project location is invalid.

See Also

VBProject Class | NAnt.VSNet Namespace


VBProject.GetProcessStartInfo Method

Returns a ProcessStartInfo for launching the compiler for this project.

[Visual Basic]
Overrides Protected Function GetProcessStartInfo( _
ByVal config As ConfigurationBase, _
ByVal responseFile As String _
) As ProcessStartInfo
[C#]
protected override ProcessStartInfo GetProcessStartInfo(
ConfigurationBase config,
string responseFile
);

Parameters

config
The configuration to build.
responseFile
The response file for the compiler.

Return Value

A ProcessStartInfo for launching the compiler for this project.

See Also

VBProject Class | NAnt.VSNet Namespace


VBProject.IsSupported Method

Returns a value indicating whether the project represented by the specified XML fragment is supported by VBProject.

[Visual Basic]
Public Shared Function IsSupported( _
ByVal docElement As XmlElement _
) As Boolean
[C#]
public static bool IsSupported(
XmlElement docElement
);

Parameters

docElement
XML fragment representing the project to check.

Return Value

true if VBProject supports the specified project; otherwise, false.

Remarks

A project is identified as as Visual Basic project, if the XML fragment at least has the following information:

<VisualStudioProject>
    <VisualBasic
        ProductVersion="..."
        ....
    >
        ...
    </VisualBasic>
</VisualStudioProject>

See Also

VBProject Class | NAnt.VSNet Namespace


VBProject.VerifyProjectXml Method

Verifies whether the specified XML fragment represents a valid project that is supported by this ProjectBase.

[Visual Basic]
Overrides Protected Sub VerifyProjectXml( _
ByVal docElement As XmlElement _
)
[C#]
protected override void VerifyProjectXml(
XmlElement docElement
);

Parameters

docElement
XML fragment representing the project file.

Exceptions

Exception Type | Condition
BuildException | The XML fragment is not supported by this ProjectBase. -or- The XML fragment does not represent a valid project (for this ProjectBase).

See Also

VBProject Class | NAnt.VSNet Namespace


VBProject.WriteProjectOptions Method

[Visual Basic]
Overrides Protected Sub WriteProjectOptions( _
ByVal sw As StreamWriter _
)
[C#]
protected override void WriteProjectOptions(
StreamWriter sw
);

See Also

VBProject Class | NAnt.VSNet Namespace


VcArgumentMap Class

A mapping from properties in the .vcproj file to command line arguments.

For a list of all members of this type, see VcArgumentMap Members.

System.Object
NAnt.VSNet.VcArgumentMap

[Visual Basic]
Public Class VcArgumentMap
[C#]
public class VcArgumentMap

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

VcArgumentMap Members | NAnt.VSNet Namespace


VcArgumentMap Members

VcArgumentMap overview

Public Static (Shared) Methods

CreateCLArgumentMap | Creates a mapping between configuration properties for the Visual C++ compiler and corresponding command-line arguments.
CreateLinkerArgumentMap | Creates a mapping between configuration properties for the Visual C++ linker and corresponding command-line arguments.
CreateMidlArgumentMap |

Public Instance Constructors

VcArgumentMap Constructor Initializes a new instance of the VcArgumentMap class.

Public Instance Methods

AddBool | Overloaded.
AddEnum | Overloaded.
AddLinkerString | Overloaded.
AddQuotedLinkerString | Overloaded.
AddString | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetArgument | Gets the argument string corresponding with a configuration property named propName with value propValue. An ignore mask can be used to eliminate some arguments from the search.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VcArgumentMap Class | NAnt.VSNet Namespace


VcArgumentMap Constructor

Initializes a new instance of the VcArgumentMap class.

[Visual Basic]
Public Sub New()
[C#]
public VcArgumentMap();

See Also

VcArgumentMap Class | NAnt.VSNet Namespace


VcArgumentMap Methods

The methods of the VcArgumentMap class are listed below. For a complete list of VcArgumentMap class members, see the VcArgumentMap Members topic.

Public Static (Shared) Methods

CreateCLArgumentMap | Creates a mapping between configuration properties for the Visual C++ compiler and corresponding command-line arguments.
CreateLinkerArgumentMap | Creates a mapping between configuration properties for the Visual C++ linker and corresponding command-line arguments.
CreateMidlArgumentMap |

Public Instance Methods

AddBool | Overloaded.
AddEnum | Overloaded.
AddLinkerString | Overloaded.
AddQuotedLinkerString | Overloaded.
AddString | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetArgument | Gets the argument string corresponding with a configuration property named propName with value propValue. An ignore mask can be used to eliminate some arguments from the search.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VcArgumentMap Class | NAnt.VSNet Namespace


AddBool Method

NAnt SDK Documentation - v0.91

VcArgumentMap.AddBool Method

Overload List

public void AddBool(ArgGroup,string,string);

public void AddBool(ArgGroup,string,string,string);

public void AddBool(string,string);

public void AddBool(string,string,string);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace


VcArgumentMap.AddBool Method (ArgGroup, String, String)

[Visual Basic]
Overloads Public Sub AddBool( _
ByVal group As ArgGroup, _
ByVal propName As String, _
ByVal argName As String _
)
[C#]
public void AddBool(
ArgGroup group,
string propName,
string argName
);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace | VcArgumentMap.AddBool Overload List


VcArgumentMap.AddBool Method (ArgGroup, String, String, String)

[Visual Basic]
Overloads Public Sub AddBool( _
ByVal group As ArgGroup, _
ByVal propName As String, _
ByVal argName As String, _
ByVal match As String _
)
[C#]
public void AddBool(
ArgGroup group,
string propName,
string argName,
string match
);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace | VcArgumentMap.AddBool Overload List


VcArgumentMap.AddBool Method (String, String)

[Visual Basic]
Overloads Public Sub AddBool( _
ByVal propName As String, _
ByVal argName As String _
)
[C#]
public void AddBool(
string propName,
string argName
);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace | VcArgumentMap.AddBool Overload List


VcArgumentMap.AddBool Method (String, String, String)

[Visual Basic]
Overloads Public Sub AddBool( _
ByVal propName As String, _
ByVal argName As String, _
ByVal match As String _
)
[C#]
public void AddBool(
string propName,
string argName,
string match
);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace | VcArgumentMap.AddBool Overload List


AddEnum Method

NAnt SDK Documentation - v0.91

VcArgumentMap.AddEnum Method

Overload List

public void AddEnum(ArgGroup,string,string,params string[]);

public void AddEnum(string,string,params string[]);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace


VcArgumentMap.AddEnum Method (ArgGroup, String, String, String[])

[Visual Basic]
Overloads Public Sub AddEnum( _
ByVal group As ArgGroup, _
ByVal propName As String, _
ByVal argName As String, _
ParamArray values As String() _
)
[C#]
public void AddEnum(
ArgGroup group,
string propName,
string argName,
params string[] values
);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace | VcArgumentMap.AddEnum Overload List


VcArgumentMap.AddEnum Method (String, String, String[])

[Visual Basic]
Overloads Public Sub AddEnum( _
ByVal propName As String, _
ByVal argName As String, _
ParamArray values As String() _
)
[C#]
public void AddEnum(
string propName,
string argName,
params string[] values
);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace | VcArgumentMap.AddEnum Overload List


AddLinkerString Method

NAnt SDK Documentation - v0.91

VcArgumentMap.AddLinkerString Method

Overload List

public void AddLinkerString(ArgGroup,string,string);

public void AddLinkerString(ArgGroup,string,string,bool);

public void AddLinkerString(string,string);

public void AddLinkerString(string,string,bool);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace


VcArgumentMap.AddLinkerString Method (ArgGroup, String, String)

[Visual Basic]
Overloads Public Sub AddLinkerString( _
ByVal group As ArgGroup, _
ByVal propName As String, _
ByVal argName As String _
)
[C#]
public void AddLinkerString(
ArgGroup group,
string propName,
string argName
);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace | VcArgumentMap.AddLinkerString Overload List


VcArgumentMap.AddLinkerString Method (ArgGroup, String, String, Boolean)

[Visual Basic]
Overloads Public Sub AddLinkerString( _
ByVal group As ArgGroup, _
ByVal propName As String, _
ByVal argName As String, _
ByVal ignoreEmptyValue As Boolean _
)
[C#]
public void AddLinkerString(
ArgGroup group,
string propName,
string argName,
bool ignoreEmptyValue
);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace | VcArgumentMap.AddLinkerString Overload List


VcArgumentMap.AddLinkerString Method (String, String)

[Visual Basic]
Overloads Public Sub AddLinkerString( _
ByVal propName As String, _
ByVal argName As String _
)
[C#]
public void AddLinkerString(
string propName,
string argName
);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace | VcArgumentMap.AddLinkerString Overload List


VcArgumentMap.AddLinkerString Method (String, String, Boolean)

[Visual Basic]
Overloads Public Sub AddLinkerString( _
ByVal propName As String, _
ByVal argName As String, _
ByVal ignoreEmptyValue As Boolean _
)
[C#]
public void AddLinkerString(
string propName,
string argName,
bool ignoreEmptyValue
);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace | VcArgumentMap.AddLinkerString Overload List


AddQuotedLinkerString Method

NAnt SDK Documentation - v0.91

VcArgumentMap.AddQuotedLinkerString Method

Overload List

public void AddQuotedLinkerString(ArgGroup,string,string);

public void AddQuotedLinkerString(ArgGroup,string,string,bool);

public void AddQuotedLinkerString(string,string);

public void AddQuotedLinkerString(string,string,bool);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace


VcArgumentMap.AddQuotedLinkerString Method (ArgGroup, String, String)

[Visual Basic]
Overloads Public Sub AddQuotedLinkerString( _
ByVal group As ArgGroup, _
ByVal propName As String, _
ByVal argName As String _
)
[C#]
public void AddQuotedLinkerString(
ArgGroup group,
string propName,
string argName
);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace | VcArgumentMap.AddQuotedLinkerString Overload List


VcArgumentMap.AddQuotedLinkerString Method (ArgGroup, String, String, Boolean)

[Visual Basic]
Overloads Public Sub AddQuotedLinkerString( _
ByVal group As ArgGroup, _
ByVal propName As String, _
ByVal argName As String, _
ByVal ignoreEmptyValue As Boolean _
)
[C#]
public void AddQuotedLinkerString(
ArgGroup group,
string propName,
string argName,
bool ignoreEmptyValue
);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace | VcArgumentMap.AddQuotedLinkerString Overload List


VcArgumentMap.AddQuotedLinkerString Method (String, String)

[Visual Basic]
Overloads Public Sub AddQuotedLinkerString( _
ByVal propName As String, _
ByVal argName As String _
)
[C#]
public void AddQuotedLinkerString(
string propName,
string argName
);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace | VcArgumentMap.AddQuotedLinkerString Overload List


VcArgumentMap.AddQuotedLinkerString Method (String, String, Boolean)

[Visual Basic]
Overloads Public Sub AddQuotedLinkerString( _
ByVal propName As String, _
ByVal argName As String, _
ByVal ignoreEmptyValue As Boolean _
)
[C#]
public void AddQuotedLinkerString(
string propName,
string argName,
bool ignoreEmptyValue
);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace | VcArgumentMap.AddQuotedLinkerString Overload List


AddString Method

NAnt SDK Documentation - v0.91

VcArgumentMap.AddString Method

Overload List

public void AddString(ArgGroup,string,string);

public void AddString(ArgGroup,string,string,bool);

public void AddString(string,string);

public void AddString(string,string,bool);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace


VcArgumentMap.AddString Method (ArgGroup, String, String)

[Visual Basic]
Overloads Public Sub AddString( _
ByVal group As ArgGroup, _
ByVal propName As String, _
ByVal argName As String _
)
[C#]
public void AddString(
ArgGroup group,
string propName,
string argName
);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace | VcArgumentMap.AddString Overload List


VcArgumentMap.AddString Method (ArgGroup, String, String, Boolean)

[Visual Basic]
Overloads Public Sub AddString( _
ByVal group As ArgGroup, _
ByVal propName As String, _
ByVal argName As String, _
ByVal ignoreEmptyValue As Boolean _
)
[C#]
public void AddString(
ArgGroup group,
string propName,
string argName,
bool ignoreEmptyValue
);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace | VcArgumentMap.AddString Overload List


VcArgumentMap.AddString Method (String, String)

[Visual Basic]
Overloads Public Sub AddString( _
ByVal propName As String, _
ByVal argName As String _
)
[C#]
public void AddString(
string propName,
string argName
);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace | VcArgumentMap.AddString Overload List


VcArgumentMap.AddString Method (String, String, Boolean)

[Visual Basic]
Overloads Public Sub AddString( _
ByVal propName As String, _
ByVal argName As String, _
ByVal ignoreEmptyValue As Boolean _
)
[C#]
public void AddString(
string propName,
string argName,
bool ignoreEmptyValue
);

See Also

VcArgumentMap Class | NAnt.VSNet Namespace | VcArgumentMap.AddString Overload List


VcArgumentMap.CreateCLArgumentMap Method

Creates a mapping between configuration properties for the Visual C++ compiler and corresponding command-line arguments.

[Visual Basic]
Public Shared Function CreateCLArgumentMap() As VcArgumentMap
[C#]
public static VcArgumentMap CreateCLArgumentMap();

Return Value

A mapping between configuration properties for the Visual C++ compiler and corresponding command-line arguments.

Remarks

The following configuration properties are processed by VcProject:

Category | Property
General | Addtional Include Directories (/I[path])
General | Resolve #using References (/AI[path])
Preprocessor | Preprocessor Definitions (/D[macro])
Code Generation | Enable C++ Exceptions (/EHsc)
Precompiled Headers | Create/Use Precompiled Header
Precompiled Headers | Create/Use PCH Through File
Precompiled Headers | Precompiled Header File
Output Files | Assembler Output
Output Files | ASM List Location
Browse Information | Enable Browse Information
Browse Information | Browse File
Advanced | Force Includes (/FI[name])
Advanced | Force #using (/FU[name])
Advanced | Undefine Preprocessor Definitions (/U[macro])

See Also

VcArgumentMap Class | NAnt.VSNet Namespace


VcArgumentMap.CreateLinkerArgumentMap Method

Creates a mapping between configuration properties for the Visual C++ linker and corresponding command-line arguments.

[Visual Basic]
Public Shared Function CreateLinkerArgumentMap() As VcArgumentMap
[C#]
public static VcArgumentMap CreateLinkerArgumentMap();

Return Value

A mapping between configuration properties for the Visual C++ linker and corresponding command-line arguments.

Remarks

The following configuration properties are processed by VcProject:

Category | Property
General | Output File (/OUT:[file])
General | Additional Library Directories (/LIBPATH:[dir])
Input | Additional Dependencies
Input | Add Module to Assembly (/ASSEMBLYMODULE:file)
Input | Embed Managed Resource File (/ASSEMBLYRESOURCE:file)
Debugging | Generate Debug Info (/DEBUG)
Debugging | Generate Program Database File (/PDB:name)
Debugging | Generate Map File (/MAP)
Debugging | Map File Name (/MAP:[filename])
System | Heap Reserve Size (/HEAP:reserve)
System | Heap Commit Size (/HEAP:reserve, commit)
System | Stack Reserve Size (/STACK:reserve)
System | Stack Commit Size (/STACK:reserve, commit)

The following configuration properties are ignored:

Category | Property
General | Show Progress (/VERBOSE, /VERBOSE:LIB)
General | Suppress Startup Banner (/NOLOGO)

Support for the following configuration properties still needs to be implemented:

Category | Property
General | Ignore Import Library
General | Register Output
Input | Delay Loaded DLLs (/DELAYLOAD:[dll_name])
Embedded IDL | MIDL Commands (/MIDL:[file])

See Also

VcArgumentMap Class | NAnt.VSNet Namespace


VcArgumentMap.CreateMidlArgumentMap Method

[Visual Basic]
Public Shared Function CreateMidlArgumentMap() As VcArgumentMap
[C#]
public static VcArgumentMap CreateMidlArgumentMap();

See Also

VcArgumentMap Class | NAnt.VSNet Namespace


VcArgumentMap.GetArgument Method

Gets the argument string corresponding with a configuration property named propName with value propValue. An ignore mask can be used to eliminate some arguments from the search.

[Visual Basic]
Public Function GetArgument( _
ByVal propName As String, _
ByVal propValue As String, _
ByVal useIgnoreGroup As ArgGroup _
) As String
[C#]
public string GetArgument(
string propName,
string propValue,
ArgGroup useIgnoreGroup
);

Parameters

propName
The name of the configuration property.
propValue
The value of the configuration property.
useIgnoreGroup
Specify any groups that needs to be ignored.

Return Value

The argument string corresponding with a configuration property named propName with value propValue, or a null reference (Nothing in Visual Basic) if no corresponding argument exists.

See Also

VcArgumentMap Class | NAnt.VSNet Namespace


VcArgumentMap.ArgGroup Enumeration

Allow us to assign an argument to a specific group.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Serializable, _ Flags>
Public Enum VcArgumentMap.ArgGroup
[C#]
[Serializable]
[Flags]
public enum VcArgumentMap.ArgGroup

Members

Member Name | Description | Value
Unassigned | The argument is not assigned to any group. | 0
OptiIgnoreGroup | The argument is ignored when the optimization level is set to Minimum Size (1) or Maximum Size (2). | 1

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

NAnt.VSNet Namespace


VcAssemblyReference Class

For a list of all members of this type, see VcAssemblyReference Members.

System.Object
NAnt.VSNet.ReferenceBase
NAnt.VSNet.FileReferenceBase
NAnt.VSNet.AssemblyReferenceBase
NAnt.VSNet.VcAssemblyReference

[Visual Basic]
Public Class VcAssemblyReference
Inherits AssemblyReferenceBase
[C#]
public class VcAssemblyReference : AssemblyReferenceBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

VcAssemblyReference Members | NAnt.VSNet Namespace


VcAssemblyReference Members

VcAssemblyReference overview

Public Instance Constructors

VcAssemblyReference Constructor

Public Instance Properties

CopyLocal (inherited from AssemblyReferenceBase) | Gets a value indicating whether the output file(s) of this reference should be copied locally.
Name | Gets the name of the referenced assembly.

Public Instance Methods

CreateProjectReference (inherited from AssemblyReferenceBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from AssemblyReferenceBase) | Gets the complete set of assemblies that need to be referenced when a project references this component.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from AssemblyReferenceBase) | Gets the complete set of output files for the referenced project.
GetPrimaryOutputFile (inherited from AssemblyReferenceBase) | Gets the path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp (inherited from AssemblyReferenceBase) | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from FileReferenceBase) | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

GacCache (inherited from FileReferenceBase) |
IsPrivate |
IsPrivateSpecified |
IsSystem (inherited from AssemblyReferenceBase) | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |
XmlDefinition (inherited from FileReferenceBase) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAssemblyOutputFiles (inherited from FileReferenceBase) | Gets the complete set of output files for the specified assembly and adds them to collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ResolveAssemblyReference | Resolves an assembly reference.
ResolveFromAssemblyFolders (inherited from AssemblyReferenceBase) |
ResolveFromFolderList (inherited from AssemblyReferenceBase) | Searches for the given file in all paths in folderList.
ResolveFromFramework (inherited from AssemblyReferenceBase) | Resolves an assembly reference in the framework assembly directory of the target framework.
ResolveFromRelativePath (inherited from AssemblyReferenceBase) | Resolves an assembly reference using a path relative to the project directory.

See Also

VcAssemblyReference Class | NAnt.VSNet Namespace


VcAssemblyReference Constructor

[Visual Basic]
Public Sub New( _
ByVal xmlDefinition As XmlElement, _
ByVal referencesResolver As ReferencesResolver, _
ByVal parent As ProjectBase, _
ByVal gacCache As GacCache _
)
[C#]
public VcAssemblyReference(
XmlElement xmlDefinition,
ReferencesResolver referencesResolver,
ProjectBase parent,
GacCache gacCache
);

See Also

VcAssemblyReference Class | NAnt.VSNet Namespace


VcAssemblyReference Properties

The properties of the VcAssemblyReference class are listed below. For a complete list of VcAssemblyReference class members, see the VcAssemblyReference Members topic.

Public Instance Properties

CopyLocal (inherited from AssemblyReferenceBase) | Gets a value indicating whether the output file(s) of this reference should be copied locally.
Name | Gets the name of the referenced assembly.

Protected Instance Properties

GacCache (inherited from FileReferenceBase) |
IsPrivate |
IsPrivateSpecified |
IsSystem (inherited from AssemblyReferenceBase) | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |
XmlDefinition (inherited from FileReferenceBase) |

See Also

VcAssemblyReference Class | NAnt.VSNet Namespace


IsPrivate Property

NAnt SDK Documentation - v0.91

VcAssemblyReference.IsPrivate Property

[Visual Basic]
Overrides Protected ReadOnly Property IsPrivate As Boolean
[C#]
protected override bool IsPrivate {get;}

See Also

VcAssemblyReference Class | NAnt.VSNet Namespace


IsPrivateSpecified Property

NAnt SDK Documentation - v0.91

VcAssemblyReference.IsPrivateSpecified Property

[Visual Basic]
Overrides Protected ReadOnly Property IsPrivateSpecified As Boolean
[C#]
protected override bool IsPrivateSpecified {get;}

See Also

VcAssemblyReference Class | NAnt.VSNet Namespace


Name Property

NAnt SDK Documentation - v0.91

VcAssemblyReference.Name Property

Gets the name of the referenced assembly.

[Visual Basic]
Overrides Public ReadOnly Property Name As String
[C#]
public override string Name {get;}

Property Value

The name of the referenced assembly, or a null reference (Nothing in Visual Basic) if the name could not be determined.

See Also

VcAssemblyReference Class | NAnt.VSNet Namespace


VcAssemblyReference Methods

The methods of the VcAssemblyReference class are listed below. For a complete list of VcAssemblyReference class members, see the VcAssemblyReference Members topic.

Public Instance Methods

CreateProjectReference (inherited from AssemblyReferenceBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from AssemblyReferenceBase) | Gets the complete set of assemblies that need to be referenced when a project references this component.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from AssemblyReferenceBase) | Gets the complete set of output files for the referenced project.
GetPrimaryOutputFile (inherited from AssemblyReferenceBase) | Gets the path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp (inherited from AssemblyReferenceBase) | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from FileReferenceBase) | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAssemblyOutputFiles (inherited from FileReferenceBase) | Gets the complete set of output files for the specified assembly and adds them to collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ResolveAssemblyReference | Resolves an assembly reference.
ResolveFromAssemblyFolders (inherited from AssemblyReferenceBase) |
ResolveFromFolderList (inherited from AssemblyReferenceBase) | Searches for the given file in all paths in folderList.
ResolveFromFramework (inherited from AssemblyReferenceBase) | Resolves an assembly reference in the framework assembly directory of the target framework.
ResolveFromRelativePath (inherited from AssemblyReferenceBase) | Resolves an assembly reference using a path relative to the project directory.

See Also

VcAssemblyReference Class | NAnt.VSNet Namespace


VcAssemblyReference.ResolveAssemblyReference Method

Resolves an assembly reference.

[Visual Basic]
Overrides Protected Function ResolveAssemblyReference() As String
[C#]
protected override string ResolveAssemblyReference();

Return Value

The full path to the resolved assembly, or a null reference (Nothing in Visual Basic) if the assembly reference could not be resolved.

See Also

VcAssemblyReference Class | NAnt.VSNet Namespace


VcConfigurationBase Class

A single build configuration for a Visual C++ project or for a specific file in the project.

For a list of all members of this type, see VcConfigurationBase Members.

System.Object
NAnt.VSNet.ConfigurationBase
NAnt.VSNet.VcConfigurationBase
NAnt.VSNet.VcFileConfiguration
NAnt.VSNet.VcProjectConfiguration

[Visual Basic]
MustInherit Public Class VcConfigurationBase
Inherits ConfigurationBase
[C#]
public abstract class VcConfigurationBase : ConfigurationBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

VcConfigurationBase Members | NAnt.VSNet Namespace


VcConfigurationBase Members

VcConfigurationBase overview

Public Instance Properties

BuildPath | Gets the path in which the output file will be created before its copied to the actual output path.
ExtraOutputFiles (inherited from ConfigurationBase) | Gets the set of output files that is specific to the project configuration.
IntermediateDir | Gets the intermediate directory, specified relative to project directory.
Name | Gets the name of the configuration.
ObjectDir (inherited from ConfigurationBase) | Get the directory in which intermediate build output will be stored for this configuration.
OutputDir | Gets the output directory.
OutputPath (inherited from ConfigurationBase) | Gets the path for the output file.
PlatformName | Gets the platform that the configuration targets.
Project (inherited from ConfigurationBase) | Gets the project.
ReferencesPath | Gets a comma-separated list of directories to scan for assembly references.
RelativeOutputDir (inherited from ConfigurationBase) | Get the path of the output directory relative to the project directory.
UsePrecompiledHeader |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandMacros (inherited from ConfigurationBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetToolArguments | Overloaded.
GetToolSetting | Overloaded. Gets the value of a given setting for a specified tool.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

VcConfigurationBase Overloaded. Initializes a new instance of the VcConfigurationBase class.

Protected Instance Fields

Tools

Protected Instance Properties

SolutionTask (inherited from ConfigurationBase)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

ExpandMacro Expands the given macro.

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace


VcConfigurationBase Constructor

Overload List

protected VcConfigurationBase(string,ProjectBase,DirectoryInfo);

protected VcConfigurationBase(XmlElement,ProjectBase,DirectoryInfo);

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace


VcConfigurationBase Constructor (XmlElement, ProjectBase, DirectoryInfo)

[Visual Basic]
Overloads Protected Sub New( _
ByVal elem As XmlElement, _
ByVal parentProject As ProjectBase, _
ByVal outputDir As DirectoryInfo _
)
[C#]
protected VcConfigurationBase(
XmlElement elem,
ProjectBase parentProject,
DirectoryInfo outputDir
);

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace | VcConfigurationBase Constructor Overload List


VcConfigurationBase Constructor (String, ProjectBase, DirectoryInfo)

[Visual Basic]
Overloads Protected Sub New( _
ByVal configName As String, _
ByVal parentProject As ProjectBase, _
ByVal outputDir As DirectoryInfo _
)
[C#]
protected VcConfigurationBase(
string configName,
ProjectBase parentProject,
DirectoryInfo outputDir
);

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace | VcConfigurationBase Constructor Overload List


VcConfigurationBase Fields

The fields of the VcConfigurationBase class are listed below. For a complete list of VcConfigurationBase class members, see the VcConfigurationBase Members topic.

Protected Instance Fields

Tools

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace


VcConfigurationBase.Tools Field

[Visual Basic]
Protected ReadOnly Tools As Hashtable
[C#]
protected readonly Hashtable Tools;

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace


VcConfigurationBase Properties

The properties of the VcConfigurationBase class are listed below. For a complete list of VcConfigurationBase class members, see the VcConfigurationBase Members topic.

Public Instance Properties

BuildPath | Gets the path in which the output file will be created before its copied to the actual output path.
ExtraOutputFiles (inherited from ConfigurationBase) | Gets the set of output files that is specific to the project configuration.
IntermediateDir | Gets the intermediate directory, specified relative to project directory.
Name | Gets the name of the configuration.
ObjectDir (inherited from ConfigurationBase) | Get the directory in which intermediate build output will be stored for this configuration.
OutputDir | Gets the output directory.
OutputPath (inherited from ConfigurationBase) | Gets the path for the output file.
PlatformName | Gets the platform that the configuration targets.
Project (inherited from ConfigurationBase) | Gets the project.
ReferencesPath | Gets a comma-separated list of directories to scan for assembly references.
RelativeOutputDir (inherited from ConfigurationBase) | Get the path of the output directory relative to the project directory.
UsePrecompiledHeader |

Protected Instance Properties

SolutionTask (inherited from ConfigurationBase)

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace


BuildPath Property

NAnt SDK Documentation - v0.91

VcConfigurationBase.BuildPath Property

Gets the path in which the output file will be created before its copied to the actual output path.

[Visual Basic]
Overrides Public ReadOnly Property BuildPath As String
[C#]
public override string BuildPath {get;}

Remarks

For Visual C++ projects, the output file will be immediately created in the output path.

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace


IntermediateDir Property

NAnt SDK Documentation - v0.91

VcConfigurationBase.IntermediateDir Property

Gets the intermediate directory, specified relative to project directory.

[Visual Basic]
MustOverride Public ReadOnly Property IntermediateDir As String
[C#]
public abstract string IntermediateDir {get;}

Property Value

The intermediate directory, specified relative to project directory.

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace


Name Property

NAnt SDK Documentation - v0.91

VcConfigurationBase.Name Property

Gets the name of the configuration.

[Visual Basic]
Overrides Public ReadOnly Property Name As String
[C#]
public override string Name {get;}

Property Value

The name of the configuration.

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace


OutputDir Property

NAnt SDK Documentation - v0.91

VcConfigurationBase.OutputDir Property

Gets the output directory.

[Visual Basic]
Overrides Public ReadOnly Property OutputDir As DirectoryInfo
[C#]
public override System.IO.DirectoryInfo OutputDir {get;}

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace


PlatformName Property

NAnt SDK Documentation - v0.91

VcConfigurationBase.PlatformName Property

Gets the platform that the configuration targets.

[Visual Basic]
Overrides Public ReadOnly Property PlatformName As String
[C#]
public override string PlatformName {get;}

Property Value

The platform targeted by the configuration.

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace


ReferencesPath Property

NAnt SDK Documentation - v0.91

VcConfigurationBase.ReferencesPath Property

Gets a comma-separated list of directories to scan for assembly references.

[Visual Basic]
MustOverride Public ReadOnly Property ReferencesPath As String
[C#]
public abstract string ReferencesPath {get;}

Property Value

A comma-separated list of directories to scan for assembly references, or a null reference (Nothing in Visual Basic) if no additional directories should scanned.

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace


UsePrecompiledHeader Property

NAnt SDK Documentation - v0.91

VcConfigurationBase.UsePrecompiledHeader Property

[Visual Basic]
Public ReadOnly Property UsePrecompiledHeader As UsePrecompiledHeader
[C#]
public Types.UsePrecompiledHeader UsePrecompiledHeader {get;}

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace


VcConfigurationBase Methods

The methods of the VcConfigurationBase class are listed below. For a complete list of VcConfigurationBase class members, see the VcConfigurationBase Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandMacros (inherited from ConfigurationBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetToolArguments | Overloaded.
GetToolSetting | Overloaded. Gets the value of a given setting for a specified tool.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

ExpandMacro Expands the given macro.

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace


VcConfigurationBase.ExpandMacro Method

Expands the given macro.

[Visual Basic]
Overrides Protected Friend Function ExpandMacro( _
ByVal macro As String _
) As String
[C#]
protected internal override string ExpandMacro(
string macro
);

Parameters

macro
The macro to expand.

Return Value

The expanded macro.

Exceptions

Exception Type | Condition
BuildException | The macro is not supported. -or- The macro is not implemented. -or- The macro cannot be expanded.

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace


GetToolArguments Method

NAnt SDK Documentation - v0.91

VcConfigurationBase.GetToolArguments Method

Overload List

public Hashtable GetToolArguments(string,VcArgumentMap);

public abstract Hashtable GetToolArguments(string,VcArgumentMap,ArgGroup);

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace


VcConfigurationBase.GetToolArguments Method (String, VcArgumentMap)

[Visual Basic]
Overloads Public Function GetToolArguments( _
ByVal toolName As String, _
ByVal argMap As VcArgumentMap _
) As Hashtable
[C#]
public Hashtable GetToolArguments(
string toolName,
VcArgumentMap argMap
);

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace | VcConfigurationBase.GetToolArguments Overload List


VcConfigurationBase.GetToolArguments Method (String, VcArgumentMap, ArgGroup)

[Visual Basic]
MustOverride Overloads Public Function GetToolArguments( _
ByVal toolName As String, _
ByVal argMap As VcArgumentMap, _
ByVal ignoreGroup As ArgGroup _
) As Hashtable
[C#]
public abstract Hashtable GetToolArguments(
string toolName,
VcArgumentMap argMap,
ArgGroup ignoreGroup
);

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace | VcConfigurationBase.GetToolArguments Overload List


GetToolSetting Method

NAnt SDK Documentation - v0.91

VcConfigurationBase.GetToolSetting Method

Gets the value of a given setting for a specified tool.

Overload List

Gets the value of a given setting for a specified tool.

public string GetToolSetting(string,string);

Gets the value of a given setting for a specified tool.

public abstract string GetToolSetting(string,string,string);

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace


VcConfigurationBase.GetToolSetting Method (String, String)

Gets the value of a given setting for a specified tool.

[Visual Basic]
Overloads Public Function GetToolSetting( _
ByVal toolName As String, _
ByVal settingName As String _
) As String
[C#]
public string GetToolSetting(
string toolName,
string settingName
);

Parameters

toolName
The name of the tool.
settingName
The name of the setting.

Return Value

The value of a setting for the specified tool, or a null reference (Nothing in Visual Basic) if the setting is not defined for the specified tool.

Remarks

An empty setting value, which is used as a means to override the project default, will be returned as a empty String.

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace | VcConfigurationBase.GetToolSetting Overload List


VcConfigurationBase.GetToolSetting Method (String, String, String)

Gets the value of a given setting for a specified tool.

[Visual Basic]
MustOverride Overloads Public Function GetToolSetting( _
ByVal toolName As String, _
ByVal settingName As String, _
ByVal defaultValue As String _
) As String
[C#]
public abstract string GetToolSetting(
string toolName,
string settingName,
string defaultValue
);

Parameters

toolName
The name of the tool.
settingName
The name of the setting.
defaultValue
The value to return if setting is not defined.

Return Value

The value of a setting for the specified tool, or defaultValue if the setting is not defined for the specified tool.

Remarks

An empty setting value, which is used as a means to override the project default, will be returned as a empty String.

See Also

VcConfigurationBase Class | NAnt.VSNet Namespace | VcConfigurationBase.GetToolSetting Overload List


VcConfigurationBase.ExpansionHandler Delegate

[Visual Basic]
<Serializable>
Public Delegate Function VcConfigurationBase.ExpansionHandler( _
ByVal value As String _
) As String
[C#]
[Serializable]
public delegate string VcConfigurationBase.ExpansionHandler(
string value
);

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

NAnt.VSNet Namespace


VcFileConfiguration Class

Represents the configuration of a file.

For a list of all members of this type, see VcFileConfiguration Members.

System.Object
NAnt.VSNet.ConfigurationBase
NAnt.VSNet.VcConfigurationBase
NAnt.VSNet.VcFileConfiguration

[Visual Basic]
Public Class VcFileConfiguration
Inherits VcConfigurationBase
[C#]
public class VcFileConfiguration : VcConfigurationBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

VcFileConfiguration Members | NAnt.VSNet Namespace


VcFileConfiguration Members

VcFileConfiguration overview

Public Instance Properties

BuildPath (inherited from VcConfigurationBase) | Gets the path in which the output file will be created before its copied to the actual output path.
ExcludeFromBuild | Gets a value indication whether the file should be excluded from the build for this configuration.
ExtraOutputFiles (inherited from ConfigurationBase) | Gets the set of output files that is specific to the project configuration.
IntermediateDir | Gets the intermediate directory, specified relative to project directory.
Name (inherited from VcConfigurationBase) | Gets the name of the configuration.
ObjectDir (inherited from ConfigurationBase) | Get the directory in which intermediate build output will be stored for this configuration.
OutputDir (inherited from VcConfigurationBase) | Gets the output directory.
OutputPath | Gets the path for the output file.
PlatformName (inherited from VcConfigurationBase) | Gets the platform that the configuration targets.
Project (inherited from ConfigurationBase) | Gets the project.
ReferencesPath | Gets a comma-separated list of directories to scan for assembly references.
RelativeOutputDir | Get the path of the output directory relative to the project directory.
RelativePath | Gets the relative path of the file.
UsePrecompiledHeader (inherited from VcConfigurationBase) |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandMacros (inherited from ConfigurationBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetToolArguments | Overloaded.
GetToolArguments (inherited from VcConfigurationBase) | Overloaded.
GetToolSetting | Overloaded. Gets the value of a given setting for a specified tool.
GetToolSetting (inherited from VcConfigurationBase) | Overloaded. Gets the value of a given setting for a specified tool.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

Tools (inherited from VcConfigurationBase)

Protected Instance Properties

SolutionTask (inherited from ConfigurationBase)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

ExpandMacro Expands the given macro.

See Also

VcFileConfiguration Class | NAnt.VSNet Namespace


VcFileConfiguration Properties

The properties of the VcFileConfiguration class are listed below. For a complete list of VcFileConfiguration class members, see the VcFileConfiguration Members topic.

Public Instance Properties

BuildPath (inherited from VcConfigurationBase) | Gets the path in which the output file will be created before its copied to the actual output path.
ExcludeFromBuild | Gets a value indication whether the file should be excluded from the build for this configuration.
ExtraOutputFiles (inherited from ConfigurationBase) | Gets the set of output files that is specific to the project configuration.
IntermediateDir | Gets the intermediate directory, specified relative to project directory.
Name (inherited from VcConfigurationBase) | Gets the name of the configuration.
ObjectDir (inherited from ConfigurationBase) | Get the directory in which intermediate build output will be stored for this configuration.
OutputDir (inherited from VcConfigurationBase) | Gets the output directory.
OutputPath | Gets the path for the output file.
PlatformName (inherited from VcConfigurationBase) | Gets the platform that the configuration targets.
Project (inherited from ConfigurationBase) | Gets the project.
ReferencesPath | Gets a comma-separated list of directories to scan for assembly references.
RelativeOutputDir | Get the path of the output directory relative to the project directory.
RelativePath | Gets the relative path of the file.
UsePrecompiledHeader (inherited from VcConfigurationBase) |

Protected Instance Properties

SolutionTask (inherited from ConfigurationBase)

See Also

VcFileConfiguration Class | NAnt.VSNet Namespace


ExcludeFromBuild Property

NAnt SDK Documentation - v0.91

VcFileConfiguration.ExcludeFromBuild Property

Gets a value indication whether the file should be excluded from the build for this configuration.

[Visual Basic]
Public ReadOnly Property ExcludeFromBuild As Boolean
[C#]
public bool ExcludeFromBuild {get;}

Property Value

true if the file should be excluded from the build for this configuration; otherwise, false.

See Also

VcFileConfiguration Class | NAnt.VSNet Namespace


IntermediateDir Property

NAnt SDK Documentation - v0.91

VcFileConfiguration.IntermediateDir Property

Gets the intermediate directory, specified relative to project directory.

[Visual Basic]
Overrides Public ReadOnly Property IntermediateDir As String
[C#]
public override string IntermediateDir {get;}

Property Value

The intermediate directory, specified relative to project directory.

See Also

VcFileConfiguration Class | NAnt.VSNet Namespace


OutputPath Property

NAnt SDK Documentation - v0.91

VcFileConfiguration.OutputPath Property

Gets the path for the output file.

[Visual Basic]
Overrides Public ReadOnly Property OutputPath As String
[C#]
public override string OutputPath {get;}

Property Value

The path for the output file, or a null reference (Nothing in Visual Basic) if there's no output file for this configuration.

See Also

VcFileConfiguration Class | NAnt.VSNet Namespace


ReferencesPath Property

NAnt SDK Documentation - v0.91

VcFileConfiguration.ReferencesPath Property

Gets a comma-separated list of directories to scan for assembly references.

[Visual Basic]
Overrides Public ReadOnly Property ReferencesPath As String
[C#]
public override string ReferencesPath {get;}

Property Value

A comma-separated list of directories to scan for assembly references, or a null reference (Nothing in Visual Basic) if no additional directories should scanned.

See Also

VcFileConfiguration Class | NAnt.VSNet Namespace


RelativeOutputDir Property

NAnt SDK Documentation - v0.91

VcFileConfiguration.RelativeOutputDir Property

Get the path of the output directory relative to the project directory.

[Visual Basic]
Overrides Public ReadOnly Property RelativeOutputDir As String
[C#]
public override string RelativeOutputDir {get;}

See Also

VcFileConfiguration Class | NAnt.VSNet Namespace


RelativePath Property

NAnt SDK Documentation - v0.91

VcFileConfiguration.RelativePath Property

Gets the relative path of the file.

[Visual Basic]
Public ReadOnly Property RelativePath As String
[C#]
public string RelativePath {get;}

Property Value

The path of the file relative to the project directory.

See Also

VcFileConfiguration Class | NAnt.VSNet Namespace


VcFileConfiguration Methods

The methods of the VcFileConfiguration class are listed below. For a complete list of VcFileConfiguration class members, see the VcFileConfiguration Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandMacros (inherited from ConfigurationBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetToolArguments | Overloaded.
GetToolArguments (inherited from VcConfigurationBase) | Overloaded.
GetToolSetting | Overloaded. Gets the value of a given setting for a specified tool.
GetToolSetting (inherited from VcConfigurationBase) | Overloaded. Gets the value of a given setting for a specified tool.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

ExpandMacro Expands the given macro.

See Also

VcFileConfiguration Class | NAnt.VSNet Namespace


VcFileConfiguration.ExpandMacro Method

Expands the given macro.

[Visual Basic]
Overrides Protected Friend Function ExpandMacro( _
ByVal macro As String _
) As String
[C#]
protected internal override string ExpandMacro(
string macro
);

Parameters

macro
The macro to expand.

Return Value

The expanded macro.

Exceptions

Exception Type | Condition
BuildException | The macro is not supported. -or- The macro is not implemented. -or- The macro cannot be expanded.

See Also

VcFileConfiguration Class | NAnt.VSNet Namespace


GetToolArguments Method

NAnt SDK Documentation - v0.91

VcFileConfiguration.GetToolArguments Method

Overload List

Inherited from VcConfigurationBase.

public Hashtable GetToolArguments(string,VcArgumentMap);

public override Hashtable GetToolArguments(string,VcArgumentMap,ArgGroup);

See Also

VcFileConfiguration Class | NAnt.VSNet Namespace


VcFileConfiguration.GetToolArguments Method (String, VcArgumentMap, ArgGroup)

[Visual Basic]
Overrides Overloads Public Function GetToolArguments( _
ByVal toolName As String, _
ByVal argMap As VcArgumentMap, _
ByVal ignoreGroup As ArgGroup _
) As Hashtable
[C#]
public override Hashtable GetToolArguments(
string toolName,
VcArgumentMap argMap,
ArgGroup ignoreGroup
);

See Also

VcFileConfiguration Class | NAnt.VSNet Namespace | VcFileConfiguration.GetToolArguments Overload List


GetToolSetting Method

NAnt SDK Documentation - v0.91

VcFileConfiguration.GetToolSetting Method

Gets the value of a given setting for a specified tool.

Overload List

Inherited from VcConfigurationBase.

public string GetToolSetting(string,string);

Gets the value of a given setting for a specified tool.

public override string GetToolSetting(string,string,string);

See Also

VcFileConfiguration Class | NAnt.VSNet Namespace


VcFileConfiguration.GetToolSetting Method (String, String, String)

Gets the value of a given setting for a specified tool.

[Visual Basic]
Overrides Overloads Public Function GetToolSetting( _
ByVal toolName As String, _
ByVal settingName As String, _
ByVal projectDefault As String _
) As String
[C#]
public override string GetToolSetting(
string toolName,
string settingName,
string projectDefault
);

Parameters

toolName
The name of the tool.
settingName
The name of the setting.
projectDefault
The value to return if setting is not defined in both the file and project configuration.

Return Value

The value of a setting for the specified tool, or settingName if the setting is not defined in both the file and project configuration.

Remarks

If the setting is not defined in the file configuration, then the project level setting will be used.

An empty setting value, which is used as a means to override the project default, will be returned as a empty String.

See Also

VcFileConfiguration Class | NAnt.VSNet Namespace | VcFileConfiguration.GetToolSetting Overload List


VcProject Class

Visual C++ project.

For a list of all members of this type, see VcProject Members.

System.Object
NAnt.VSNet.ProjectBase
NAnt.VSNet.VcProject

[Visual Basic]
Public Class VcProject
Inherits ProjectBase
[C#]
public class VcProject : ProjectBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

VcProject Members | NAnt.VSNet Namespace


VcProject Members

VcProject overview

Public Static (Shared) Methods

IsSupported | Returns a value indicating whether the project represented by the specified XML fragment is supported by VcProject.
LoadGuid |

Public Instance Constructors

VcProject Constructor

Public Instance Properties

BuildConfigurations (inherited from ProjectBase) | Gets a list of project configurations that can be build.
ExtraOutputFiles (inherited from ProjectBase) | Gets the extra set of output files for the project.
Guid | Gets or sets the unique identifier of the Visual C++ project.
Name | Gets the name of the Visual C++ project.
ObjectDir | Get the directory in which intermediate build output that is not specific to the build configuration will be stored.
ProductVersion (inherited from ProjectBase) | Gets the Visual Studio product version of the project.
ProjectConfigurations (inherited from ProjectBase) | Gets a list of all configurations defined in the project.
ProjectDependencies (inherited from ProjectBase) | Gets the set of projects that the project depends on.
ProjectDirectory | Gets the directory containing the VS.NET project.
ProjectLocation | Get the location of the project.
ProjectPath | Gets the path of the Visual C++ project.
References |
ReferencesResolver (inherited from ProjectBase) |
SolutionTask (inherited from ProjectBase) |
TemporaryFiles (inherited from ProjectBase) |
Type | Gets the type of the project.

Public Instance Methods

Compile (inherited from ProjectBase) |
CreateProjectReference |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from ProjectBase) |
GetConfiguration (inherited from ProjectBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from ProjectBase) | Gets the complete set of output files for the project configuration matching the specified solution configuration.
GetOutputPath (inherited from ProjectBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged | Gets a value indicating whether building the project for the specified build configuration results in managed output.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

DevEnvDir (inherited from ProjectBase)
GacCache (inherited from ProjectBase)
OutputDir (inherited from ProjectBase)

Protected Instance Methods

Build |
CopyFile (inherited from ProjectBase) | Copies the specified file if the destination file does not exist, or the source file has been modified since it was previously copied.
CreateReference |
DetermineProductVersion | Returns the Visual Studio product version of the specified project XML fragment.
ExecuteBuildEvent (inherited from ProjectBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
Log (inherited from ProjectBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Prepare (inherited from ProjectBase) | Prepares the project for being built.
VerifyProjectXml | Verifies whether the specified XML fragment represents a valid project that is supported by this ProjectBase.

Protected Internal Instance Methods

ExpandMacro Expands the given macro.

See Also

VcProject Class | NAnt.VSNet Namespace


VcProject Constructor

[Visual Basic]
Public Sub New( _
ByVal solution As SolutionBase, _
ByVal projectPath As String, _
ByVal xmlDefinition As XmlElement, _
ByVal solutionTask As SolutionTask, _
ByVal tfc As TempFileCollection, _
ByVal gacCache As GacCache, _
ByVal refResolver As ReferencesResolver, _
ByVal outputDir As DirectoryInfo _
)
[C#]
public VcProject(
SolutionBase solution,
string projectPath,
XmlElement xmlDefinition,
SolutionTask solutionTask,
TempFileCollection tfc,
GacCache gacCache,
ReferencesResolver refResolver,
DirectoryInfo outputDir
);

See Also

VcProject Class | NAnt.VSNet Namespace


VcProject Properties

The properties of the VcProject class are listed below. For a complete list of VcProject class members, see the VcProject Members topic.

Public Instance Properties

BuildConfigurations (inherited from ProjectBase) | Gets a list of project configurations that can be build.
ExtraOutputFiles (inherited from ProjectBase) | Gets the extra set of output files for the project.
Guid | Gets or sets the unique identifier of the Visual C++ project.
Name | Gets the name of the Visual C++ project.
ObjectDir | Get the directory in which intermediate build output that is not specific to the build configuration will be stored.
ProductVersion (inherited from ProjectBase) | Gets the Visual Studio product version of the project.
ProjectConfigurations (inherited from ProjectBase) | Gets a list of all configurations defined in the project.
ProjectDependencies (inherited from ProjectBase) | Gets the set of projects that the project depends on.
ProjectDirectory | Gets the directory containing the VS.NET project.
ProjectLocation | Get the location of the project.
ProjectPath | Gets the path of the Visual C++ project.
References |
ReferencesResolver (inherited from ProjectBase) |
SolutionTask (inherited from ProjectBase) |
TemporaryFiles (inherited from ProjectBase) |
Type | Gets the type of the project.

Protected Instance Properties

DevEnvDir (inherited from ProjectBase)
GacCache (inherited from ProjectBase)
OutputDir (inherited from ProjectBase)

See Also

VcProject Class | NAnt.VSNet Namespace


Guid Property

NAnt SDK Documentation - v0.91

VcProject.Guid Property

Gets or sets the unique identifier of the Visual C++ project.

[Visual Basic]
Overrides Public Property Guid As String
[C#]
public override string Guid {get; set;}

See Also

VcProject Class | NAnt.VSNet Namespace


Name Property

NAnt SDK Documentation - v0.91

VcProject.Name Property

Gets the name of the Visual C++ project.

[Visual Basic]
Overrides Public ReadOnly Property Name As String
[C#]
public override string Name {get;}

See Also

VcProject Class | NAnt.VSNet Namespace


ObjectDir Property

NAnt SDK Documentation - v0.91

VcProject.ObjectDir Property

Get the directory in which intermediate build output that is not specific to the build configuration will be stored.

[Visual Basic]
Overrides Public ReadOnly Property ObjectDir As DirectoryInfo
[C#]
public override System.IO.DirectoryInfo ObjectDir {get;}

Remarks

This is a directory relative to the project directory, named temp\.

See Also

VcProject Class | NAnt.VSNet Namespace


ProjectDirectory Property

NAnt SDK Documentation - v0.91

VcProject.ProjectDirectory Property

Gets the directory containing the VS.NET project.

[Visual Basic]
Overrides Public ReadOnly Property ProjectDirectory As DirectoryInfo
[C#]
public override System.IO.DirectoryInfo ProjectDirectory {get;}

See Also

VcProject Class | NAnt.VSNet Namespace


ProjectLocation Property

NAnt SDK Documentation - v0.91

VcProject.ProjectLocation Property

Get the location of the project.

[Visual Basic]
Overrides Public ReadOnly Property ProjectLocation As ProjectLocation
[C#]
public override ProjectLocation ProjectLocation {get;}

Property Value

Local.

Remarks

For now, we only support local Visual C++ projects.

See Also

VcProject Class | NAnt.VSNet Namespace


ProjectPath Property

NAnt SDK Documentation - v0.91

VcProject.ProjectPath Property

Gets the path of the Visual C++ project.

[Visual Basic]
Overrides Public ReadOnly Property ProjectPath As String
[C#]
public override string ProjectPath {get;}

See Also

VcProject Class | NAnt.VSNet Namespace


References Property

NAnt SDK Documentation - v0.91

VcProject.References Property

[Visual Basic]
Overrides Public ReadOnly Property References As ArrayList
[C#]
public override System.Collections.ArrayList References {get;}

See Also

VcProject Class | NAnt.VSNet Namespace


Type Property

NAnt SDK Documentation - v0.91

VcProject.Type Property

Gets the type of the project.

[Visual Basic]
Overrides Public ReadOnly Property Type As ProjectType
[C#]
public override ProjectType Type {get;}

Property Value

The type of the project.

See Also

VcProject Class | NAnt.VSNet Namespace


VcProject Methods

The methods of the VcProject class are listed below. For a complete list of VcProject class members, see the VcProject Members topic.

Public Static (Shared) Methods

IsSupported | Returns a value indicating whether the project represented by the specified XML fragment is supported by VcProject.
LoadGuid |

Public Instance Methods

Compile (inherited from ProjectBase) |
CreateProjectReference |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from ProjectBase) |
GetConfiguration (inherited from ProjectBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from ProjectBase) | Gets the complete set of output files for the project configuration matching the specified solution configuration.
GetOutputPath (inherited from ProjectBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged | Gets a value indicating whether building the project for the specified build configuration results in managed output.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Build |
CopyFile (inherited from ProjectBase) | Copies the specified file if the destination file does not exist, or the source file has been modified since it was previously copied.
CreateReference |
DetermineProductVersion | Returns the Visual Studio product version of the specified project XML fragment.
ExecuteBuildEvent (inherited from ProjectBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
Log (inherited from ProjectBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
Prepare (inherited from ProjectBase) | Prepares the project for being built.
VerifyProjectXml | Verifies whether the specified XML fragment represents a valid project that is supported by this ProjectBase.

Protected Internal Instance Methods

ExpandMacro Expands the given macro.

See Also

VcProject Class | NAnt.VSNet Namespace


VcProject.Build Method

[Visual Basic]
Overrides Protected Function Build( _
ByVal solutionConfiguration As Configuration _
) As BuildResult
[C#]
protected override BuildResult Build(
Configuration solutionConfiguration
);

See Also

VcProject Class | NAnt.VSNet Namespace


VcProject.CreateProjectReference Method

[Visual Basic]
Overrides Public Function CreateProjectReference( _
ByVal project As ProjectBase, _
ByVal isPrivateSpecified As Boolean, _
ByVal isPrivate As Boolean _
) As ProjectReferenceBase
[C#]
public override ProjectReferenceBase CreateProjectReference(
ProjectBase project,
bool isPrivateSpecified,
bool isPrivate
);

See Also

VcProject Class | NAnt.VSNet Namespace


VcProject.CreateReference Method

[Visual Basic]
Overridable Protected Function CreateReference( _
ByVal solution As SolutionBase, _
ByVal xmlDefinition As XmlElement _
) As ReferenceBase
[C#]
protected virtual ReferenceBase CreateReference(
SolutionBase solution,
XmlElement xmlDefinition
);

See Also

VcProject Class | NAnt.VSNet Namespace


VcProject.DetermineProductVersion Method

Returns the Visual Studio product version of the specified project XML fragment.

[Visual Basic]
Overrides Protected Function DetermineProductVersion( _
ByVal docElement As XmlElement _
) As ProductVersion
[C#]
protected override ProductVersion DetermineProductVersion(
XmlElement docElement
);

Parameters

docElement
The document element of the project.

Return Value

The Visual Studio product version of the specified project XML fragment.

Exceptions

Exception Type | Condition
BuildException | The product version could not be determined. -or- The product version is not supported.

See Also

VcProject Class | NAnt.VSNet Namespace


VcProject.ExpandMacro Method

Expands the given macro.

[Visual Basic]
Overrides Protected Friend Function ExpandMacro( _
ByVal macro As String _
) As String
[C#]
protected internal override string ExpandMacro(
string macro
);

Parameters

macro
The macro to expand.

Return Value

The expanded macro or a null reference (Nothing in Visual Basic) if the macro is not supported.

See Also

VcProject Class | NAnt.VSNet Namespace


VcProject.IsManaged Method

Gets a value indicating whether building the project for the specified build configuration results in managed output.

[Visual Basic]
Overrides Public Function IsManaged( _
ByVal solutionConfiguration As Configuration _
) As Boolean
[C#]
public override bool IsManaged(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Return Value

true if the project output for the specified build configuration is either a Dynamic Library (dll) or an Application (exe), and Managed Extensions are enabled; otherwise, false.

See Also

VcProject Class | NAnt.VSNet Namespace


VcProject.IsSupported Method

Returns a value indicating whether the project represented by the specified XML fragment is supported by VcProject.

[Visual Basic]
Public Shared Function IsSupported( _
ByVal docElement As XmlElement _
) As Boolean
[C#]
public static bool IsSupported(
XmlElement docElement
);

Parameters

docElement
XML fragment representing the project to check.

Return Value

true if VcProject supports the specified project; otherwise, false.

Remarks

A project is identified as as Visual C++ project, if the XML fragment at least has the following information:

<VisualStudioProject
    ProjectType="Visual C++"
    Version="..."
    ...
    >
</VisualStudioProject>

See Also

VcProject Class | NAnt.VSNet Namespace


VcProject.LoadGuid Method

[Visual Basic]
Public Shared Function LoadGuid( _
ByVal xmlDefinition As XmlElement _
) As String
[C#]
public static string LoadGuid(
XmlElement xmlDefinition
);

See Also

VcProject Class | NAnt.VSNet Namespace


VcProject.VerifyProjectXml Method

Verifies whether the specified XML fragment represents a valid project that is supported by this ProjectBase.

[Visual Basic]
Overrides Protected Sub VerifyProjectXml( _
ByVal docElement As XmlElement _
)
[C#]
protected override void VerifyProjectXml(
XmlElement docElement
);

Parameters

docElement
XML fragment representing the project file.

Exceptions

Exception Type | Condition
BuildException | The XML fragment is not supported by this ProjectBase. -or- The XML fragment does not represent a valid project (for this ProjectBase).

See Also

VcProject Class | NAnt.VSNet Namespace


VcProjectConfiguration Class

Represents a Visual C++ project configuration.

For a list of all members of this type, see VcProjectConfiguration Members.

System.Object
NAnt.VSNet.ConfigurationBase
NAnt.VSNet.VcConfigurationBase
NAnt.VSNet.VcProjectConfiguration

[Visual Basic]
Public Class VcProjectConfiguration
Inherits VcConfigurationBase
[C#]
public class VcProjectConfiguration : VcConfigurationBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

VcProjectConfiguration Members | NAnt.VSNet Namespace


VcProjectConfiguration Members

VcProjectConfiguration overview

Public Instance Properties

BuildPath (inherited from VcConfigurationBase) | Gets the path in which the output file will be created before its copied to the actual output path.
CharacterSet | Tells the compiler which character set to use.
ExtraOutputFiles (inherited from ConfigurationBase) | Gets the set of output files that is specific to the project configuration.
IntermediateDir | Gets the intermediate directory, specified relative to project directory.
ManagedExtensions | Gets a value indicating whether Managed Extensions for C++ are enabled.
Name (inherited from VcConfigurationBase) | Gets the name of the configuration.
ObjectDir | Get the directory in which intermediate build output will be stored for this configuration.
OutputDir (inherited from VcConfigurationBase) | Gets the output directory.
OutputPath | Gets the absolute path for the output file.
PlatformName (inherited from VcConfigurationBase) | Gets the platform that the configuration targets.
Project (inherited from ConfigurationBase) | Gets the project.
ReferencesPath | Gets a comma-separated list of directories to scan for assembly references.
RelativeOutputDir | Get the path of the output directory relative to the project directory.
Type |
UseOfATL | Gets a value indicating how ATL is used by the configuration.
UseOfMFC | Gets a value indicating how MFC is used by the configuration.
UsePrecompiledHeader (inherited from VcConfigurationBase) |
WholeProgramOptimization |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandMacros (inherited from ConfigurationBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetToolArguments | Overloaded.
GetToolArguments (inherited from VcConfigurationBase) | Overloaded.
GetToolSetting | Overloaded.
GetToolSetting (inherited from VcConfigurationBase) | Overloaded. Gets the value of a given setting for a specified tool.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

Tools (inherited from VcConfigurationBase)

Protected Instance Properties

SolutionTask (inherited from ConfigurationBase)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

ExpandMacro Expands the given macro.

See Also

VcProjectConfiguration Class | NAnt.VSNet Namespace


VcProjectConfiguration Properties

The properties of the VcProjectConfiguration class are listed below. For a complete list of VcProjectConfiguration class members, see the VcProjectConfiguration Members topic.

Public Instance Properties

BuildPath (inherited from VcConfigurationBase) | Gets the path in which the output file will be created before its copied to the actual output path.
CharacterSet | Tells the compiler which character set to use.
ExtraOutputFiles (inherited from ConfigurationBase) | Gets the set of output files that is specific to the project configuration.
IntermediateDir | Gets the intermediate directory, specified relative to project directory.
ManagedExtensions | Gets a value indicating whether Managed Extensions for C++ are enabled.
Name (inherited from VcConfigurationBase) | Gets the name of the configuration.
ObjectDir | Get the directory in which intermediate build output will be stored for this configuration.
OutputDir (inherited from VcConfigurationBase) | Gets the output directory.
OutputPath | Gets the absolute path for the output file.
PlatformName (inherited from VcConfigurationBase) | Gets the platform that the configuration targets.
Project (inherited from ConfigurationBase) | Gets the project.
ReferencesPath | Gets a comma-separated list of directories to scan for assembly references.
RelativeOutputDir | Get the path of the output directory relative to the project directory.
Type |
UseOfATL | Gets a value indicating how ATL is used by the configuration.
UseOfMFC | Gets a value indicating how MFC is used by the configuration.
UsePrecompiledHeader (inherited from VcConfigurationBase) |
WholeProgramOptimization |

Protected Instance Properties

SolutionTask (inherited from ConfigurationBase)

See Also

VcProjectConfiguration Class | NAnt.VSNet Namespace


CharacterSet Property

NAnt SDK Documentation - v0.91

VcProjectConfiguration.CharacterSet Property

Tells the compiler which character set to use.

[Visual Basic]
Public ReadOnly Property CharacterSet As CharacterSet
[C#]
public NAnt.VisualCpp.Types.CharacterSet CharacterSet {get;}

See Also

VcProjectConfiguration Class | NAnt.VSNet Namespace


IntermediateDir Property

NAnt SDK Documentation - v0.91

VcProjectConfiguration.IntermediateDir Property

Gets the intermediate directory, specified relative to project directory.

[Visual Basic]
Overrides Public ReadOnly Property IntermediateDir As String
[C#]
public override string IntermediateDir {get;}

Property Value

The intermediate directory, specified relative to project directory.

See Also

VcProjectConfiguration Class | NAnt.VSNet Namespace


ManagedExtensions Property

NAnt SDK Documentation - v0.91

VcProjectConfiguration.ManagedExtensions Property

Gets a value indicating whether Managed Extensions for C++ are enabled.

[Visual Basic]
Public ReadOnly Property ManagedExtensions As Boolean
[C#]
public bool ManagedExtensions {get;}

See Also

VcProjectConfiguration Class | NAnt.VSNet Namespace


ObjectDir Property

NAnt SDK Documentation - v0.91

VcProjectConfiguration.ObjectDir Property

Get the directory in which intermediate build output will be stored for this configuration.

[Visual Basic]
Overrides Public ReadOnly Property ObjectDir As DirectoryInfo
[C#]
public override System.IO.DirectoryInfo ObjectDir {get;}

Remarks

This is a directory relative to the project directory named obj\<configuration name>.

.resx and .licx files will only be recompiled if the compiled resource files in the ObjectDir are not uptodate.

See Also

VcProjectConfiguration Class | NAnt.VSNet Namespace


OutputPath Property

NAnt SDK Documentation - v0.91

VcProjectConfiguration.OutputPath Property

Gets the absolute path for the output file.

[Visual Basic]
Overrides Public ReadOnly Property OutputPath As String
[C#]
public override string OutputPath {get;}

Property Value

The absolute path for the output file, or a null reference (Nothing in Visual Basic) if there's no output file for this configuration.

See Also

VcProjectConfiguration Class | NAnt.VSNet Namespace


ReferencesPath Property

NAnt SDK Documentation - v0.91

VcProjectConfiguration.ReferencesPath Property

Gets a comma-separated list of directories to scan for assembly references.

[Visual Basic]
Overrides Public ReadOnly Property ReferencesPath As String
[C#]
public override string ReferencesPath {get;}

Property Value

A comma-separated list of directories to scan for assembly references, or a null reference (Nothing in Visual Basic) if no additional directories should scanned.

See Also

VcProjectConfiguration Class | NAnt.VSNet Namespace


RelativeOutputDir Property

NAnt SDK Documentation - v0.91

VcProjectConfiguration.RelativeOutputDir Property

Get the path of the output directory relative to the project directory.

[Visual Basic]
Overrides Public ReadOnly Property RelativeOutputDir As String
[C#]
public override string RelativeOutputDir {get;}

See Also

VcProjectConfiguration Class | NAnt.VSNet Namespace


Type Property

NAnt SDK Documentation - v0.91

VcProjectConfiguration.Type Property

[Visual Basic]
Public ReadOnly Property Type As ConfigurationType
[C#]
public VcProjectConfiguration.ConfigurationType Type {get;}

See Also

VcProjectConfiguration Class | NAnt.VSNet Namespace


UseOfATL Property

NAnt SDK Documentation - v0.91

VcProjectConfiguration.UseOfATL Property

Gets a value indicating how ATL is used by the configuration.

[Visual Basic]
Public ReadOnly Property UseOfATL As UseOfATL
[C#]
public Types.UseOfATL UseOfATL {get;}

See Also

VcProjectConfiguration Class | NAnt.VSNet Namespace


UseOfMFC Property

NAnt SDK Documentation - v0.91

VcProjectConfiguration.UseOfMFC Property

Gets a value indicating how MFC is used by the configuration.

[Visual Basic]
Public ReadOnly Property UseOfMFC As UseOfMFC
[C#]
public Types.UseOfMFC UseOfMFC {get;}

See Also

VcProjectConfiguration Class | NAnt.VSNet Namespace


WholeProgramOptimization Property

NAnt SDK Documentation - v0.91

VcProjectConfiguration.WholeProgramOptimization Property

[Visual Basic]
Public ReadOnly Property WholeProgramOptimization As Boolean
[C#]
public bool WholeProgramOptimization {get;}

See Also

VcProjectConfiguration Class | NAnt.VSNet Namespace


VcProjectConfiguration Methods

The methods of the VcProjectConfiguration class are listed below. For a complete list of VcProjectConfiguration class members, see the VcProjectConfiguration Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandMacros (inherited from ConfigurationBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetToolArguments | Overloaded.
GetToolArguments (inherited from VcConfigurationBase) | Overloaded.
GetToolSetting | Overloaded.
GetToolSetting (inherited from VcConfigurationBase) | Overloaded. Gets the value of a given setting for a specified tool.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

ExpandMacro Expands the given macro.

See Also

VcProjectConfiguration Class | NAnt.VSNet Namespace


VcProjectConfiguration.ExpandMacro Method

Expands the given macro.

[Visual Basic]
Overrides Protected Friend Function ExpandMacro( _
ByVal macro As String _
) As String
[C#]
protected internal override string ExpandMacro(
string macro
);

Parameters

macro
The macro to expand.

Return Value

The expanded macro.

Exceptions

Exception Type | Condition
BuildException | The macro is not supported. -or- The macro is not implemented. -or- The macro cannot be expanded.
NotImplementedException | Expansion of a given macro is not yet implemented.

See Also

VcProjectConfiguration Class | NAnt.VSNet Namespace


GetToolArguments Method

NAnt SDK Documentation - v0.91

VcProjectConfiguration.GetToolArguments Method

Overload List

Inherited from VcConfigurationBase.

public Hashtable GetToolArguments(string,VcArgumentMap);

public override Hashtable GetToolArguments(string,VcArgumentMap,ArgGroup);

See Also

VcProjectConfiguration Class | NAnt.VSNet Namespace


VcProjectConfiguration.GetToolArguments Method (String, VcArgumentMap, ArgGroup)

[Visual Basic]
Overrides Overloads Public Function GetToolArguments( _
ByVal toolName As String, _
ByVal argMap As VcArgumentMap, _
ByVal ignoreGroup As ArgGroup _
) As Hashtable
[C#]
public override Hashtable GetToolArguments(
string toolName,
VcArgumentMap argMap,
ArgGroup ignoreGroup
);

See Also

VcProjectConfiguration Class | NAnt.VSNet Namespace | VcProjectConfiguration.GetToolArguments Overload List


GetToolSetting Method

NAnt SDK Documentation - v0.91

VcProjectConfiguration.GetToolSetting Method

Overload List

Inherited from VcConfigurationBase.

public string GetToolSetting(string,string);

public override string GetToolSetting(string,string,string);

See Also

VcProjectConfiguration Class | NAnt.VSNet Namespace


VcProjectConfiguration.GetToolSetting Method (String, String, String)

[Visual Basic]
Overrides Overloads Public Function GetToolSetting( _
ByVal toolName As String, _
ByVal settingName As String, _
ByVal defaultValue As String _
) As String
[C#]
public override string GetToolSetting(
string toolName,
string settingName,
string defaultValue
);

See Also

VcProjectConfiguration Class | NAnt.VSNet Namespace | VcProjectConfiguration.GetToolSetting Overload List


VcProjectConfiguration.ConfigurationType Enumeration

The type of output for a given configuration.

[Visual Basic]
<Serializable>
Public Enum VcProjectConfiguration.ConfigurationType
[C#]
[Serializable]
public enum VcProjectConfiguration.ConfigurationType

Members

Member Name | Description
Makefile | A Makefile.
Application | Application (.exe).
DynamicLibrary | Dynamic Library (.dll).
StaticLibrary | Static Library (.lib).
Utility | Utility.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

NAnt.VSNet Namespace


VcProjectReference Class

For a list of all members of this type, see VcProjectReference Members.

System.Object
NAnt.VSNet.ReferenceBase
NAnt.VSNet.ProjectReferenceBase
NAnt.VSNet.VcProjectReference

[Visual Basic]
Public Class VcProjectReference
Inherits ProjectReferenceBase
[C#]
public class VcProjectReference : ProjectReferenceBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

VcProjectReference Members | NAnt.VSNet Namespace


VcProjectReference Members

VcProjectReference overview

Public Instance Constructors

VcProjectReference Overloaded. Initializes a new instance of the VcProjectReference class.

Public Instance Properties

CopyLocal (inherited from ProjectReferenceBase) | Gets a value indicating whether the output file(s) of this reference should be copied locally.
Name (inherited from ProjectReferenceBase) |
Project |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from ProjectReferenceBase) | Gets the complete set of assemblies that need to be referenced when a project references this project.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from ProjectReferenceBase) | Gets the complete set of output files for the referenced project.
GetPrimaryOutputFile (inherited from ProjectReferenceBase) | Gets the output path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp (inherited from ProjectReferenceBase) | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsPrivate |
IsPrivateSpecified |
IsSystem (inherited from ProjectReferenceBase) | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
LoadProject (inherited from ProjectReferenceBase) |
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VcProjectReference Class | NAnt.VSNet Namespace


VcProjectReference Constructor

Overload List

public VcProjectReference(ProjectBase,ProjectBase,bool,bool);

public VcProjectReference(XmlElement,ReferencesResolver,ProjectBase,SolutionBase,TempFileCollection,GacCache,DirectoryInfo);

See Also

VcProjectReference Class | NAnt.VSNet Namespace


VcProjectReference Constructor (XmlElement, ReferencesResolver, ProjectBase, SolutionBase, TempFileCollection, GacCache, DirectoryInfo)

[Visual Basic]
Overloads Public Sub New( _
ByVal xmlDefinition As XmlElement, _
ByVal referencesResolver As ReferencesResolver, _
ByVal parent As ProjectBase, _
ByVal solution As SolutionBase, _
ByVal tfc As TempFileCollection, _
ByVal gacCache As GacCache, _
ByVal outputDir As DirectoryInfo _
)
[C#]
public VcProjectReference(
XmlElement xmlDefinition,
ReferencesResolver referencesResolver,
ProjectBase parent,
SolutionBase solution,
TempFileCollection tfc,
GacCache gacCache,
DirectoryInfo outputDir
);

See Also

VcProjectReference Class | NAnt.VSNet Namespace | VcProjectReference Constructor Overload List


VcProjectReference Constructor (ProjectBase, ProjectBase, Boolean, Boolean)

[Visual Basic]
Overloads Public Sub New( _
ByVal project As ProjectBase, _
ByVal parent As ProjectBase, _
ByVal isPrivateSpecified As Boolean, _
ByVal isPrivate As Boolean _
)
[C#]
public VcProjectReference(
ProjectBase project,
ProjectBase parent,
bool isPrivateSpecified,
bool isPrivate
);

See Also

VcProjectReference Class | NAnt.VSNet Namespace | VcProjectReference Constructor Overload List


VcProjectReference Properties

The properties of the VcProjectReference class are listed below. For a complete list of VcProjectReference class members, see the VcProjectReference Members topic.

Public Instance Properties

CopyLocal (inherited from ProjectReferenceBase) | Gets a value indicating whether the output file(s) of this reference should be copied locally.
Name (inherited from ProjectReferenceBase) |
Project |

Protected Instance Properties

IsPrivate |
IsPrivateSpecified |
IsSystem (inherited from ProjectReferenceBase) | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |

See Also

VcProjectReference Class | NAnt.VSNet Namespace


IsPrivate Property

NAnt SDK Documentation - v0.91

VcProjectReference.IsPrivate Property

[Visual Basic]
Overrides Protected ReadOnly Property IsPrivate As Boolean
[C#]
protected override bool IsPrivate {get;}

See Also

VcProjectReference Class | NAnt.VSNet Namespace


IsPrivateSpecified Property

NAnt SDK Documentation - v0.91

VcProjectReference.IsPrivateSpecified Property

[Visual Basic]
Overrides Protected ReadOnly Property IsPrivateSpecified As Boolean
[C#]
protected override bool IsPrivateSpecified {get;}

See Also

VcProjectReference Class | NAnt.VSNet Namespace


Project Property

NAnt SDK Documentation - v0.91

VcProjectReference.Project Property

[Visual Basic]
Overrides Public ReadOnly Property Project As ProjectBase
[C#]
public override ProjectBase Project {get;}

See Also

VcProjectReference Class | NAnt.VSNet Namespace


VcProjectReference Methods

The methods of the VcProjectReference class are listed below. For a complete list of VcProjectReference class members, see the VcProjectReference Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from ProjectReferenceBase) | Gets the complete set of assemblies that need to be referenced when a project references this project.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from ProjectReferenceBase) | Gets the complete set of output files for the referenced project.
GetPrimaryOutputFile (inherited from ProjectReferenceBase) | Gets the output path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp (inherited from ProjectReferenceBase) | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
LoadProject (inherited from ProjectReferenceBase) |
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VcProjectReference Class | NAnt.VSNet Namespace


VcProjectReference.IsManaged Method

Gets a value indicating whether the reference is managed for the specified configuration.

[Visual Basic]
Overrides Public Function IsManaged( _
ByVal config As Configuration _
) As Boolean
[C#]
public override bool IsManaged(
Configuration config
);

Parameters

config
The build configuration of the reference.

Return Value

true if the reference is managed for the specified configuration; otherwise, false.

See Also

VcProjectReference Class | NAnt.VSNet Namespace


VcWrapperReference Class

For a list of all members of this type, see VcWrapperReference Members.

System.Object
NAnt.VSNet.ReferenceBase
NAnt.VSNet.FileReferenceBase
NAnt.VSNet.WrapperReferenceBase
NAnt.VSNet.VcWrapperReference

[Visual Basic]
Public Class VcWrapperReference
Inherits WrapperReferenceBase
[C#]
public class VcWrapperReference : WrapperReferenceBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

VcWrapperReference Members | NAnt.VSNet Namespace


VcWrapperReference Members

VcWrapperReference overview

Public Instance Constructors

VcWrapperReference Constructor

Public Instance Properties

CopyLocal (inherited from WrapperReferenceBase) | Gets a value indicating whether the output file(s) of this reference should be copied locally.
IsCreated (inherited from WrapperReferenceBase) | Gets a value indicating whether the wrapper assembly has already been created.
Name | Gets the name of the referenced assembly.
WrapperAssembly | Gets the path of the wrapper assembly.
WrapperTool | Gets the name of the tool that should be used to create the WrapperAssembly.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from WrapperReferenceBase) | Gets the complete set of assemblies that need to be referenced when a project references this component.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from WrapperReferenceBase) | Gets the complete set of output files for the referenced project.
GetPrimaryOutputFile (inherited from WrapperReferenceBase) | Gets the path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp (inherited from WrapperReferenceBase) | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from FileReferenceBase) | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

GacCache (inherited from FileReferenceBase) |
IsSystem (inherited from WrapperReferenceBase) | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
PrimaryInteropAssembly | Gets the path of the Primary Interop Assembly.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |
TypeLibGuid | Gets the GUID of the type library as defined in the definition of the reference.
TypeLibLocale | Gets the locale of the type library in hex notation.
TypeLibraryName (inherited from WrapperReferenceBase) | Gets the name of the type library.
TypeLibVersion | Gets the hex version of the type library as defined in the definition of the reference.
XmlDefinition (inherited from FileReferenceBase) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAssemblyOutputFiles (inherited from FileReferenceBase) | Gets the complete set of output files for the specified assembly and adds them to collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
GetPrimaryInteropAssembly (inherited from WrapperReferenceBase) |
GetTypeLibrary (inherited from WrapperReferenceBase) |
GetTypeLibraryName (inherited from WrapperReferenceBase) |
ImportActiveXLibrary |
ImportTypeLibrary |
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ResolveWrapperAssembly (inherited from WrapperReferenceBase) |

See Also

VcWrapperReference Class | NAnt.VSNet Namespace


VcWrapperReference Constructor

[Visual Basic]
Public Sub New( _
ByVal xmlDefinition As XmlElement, _
ByVal referencesResolver As ReferencesResolver, _
ByVal parent As ProjectBase, _
ByVal gacCache As GacCache _
)
[C#]
public VcWrapperReference(
XmlElement xmlDefinition,
ReferencesResolver referencesResolver,
ProjectBase parent,
GacCache gacCache
);

See Also

VcWrapperReference Class | NAnt.VSNet Namespace


VcWrapperReference Properties

The properties of the VcWrapperReference class are listed below. For a complete list of VcWrapperReference class members, see the VcWrapperReference Members topic.

Public Instance Properties

CopyLocal (inherited from WrapperReferenceBase) | Gets a value indicating whether the output file(s) of this reference should be copied locally.
IsCreated (inherited from WrapperReferenceBase) | Gets a value indicating whether the wrapper assembly has already been created.
Name | Gets the name of the referenced assembly.
WrapperAssembly | Gets the path of the wrapper assembly.
WrapperTool | Gets the name of the tool that should be used to create the WrapperAssembly.

Protected Instance Properties

GacCache (inherited from FileReferenceBase) |
IsSystem (inherited from WrapperReferenceBase) | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
PrimaryInteropAssembly | Gets the path of the Primary Interop Assembly.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |
TypeLibGuid | Gets the GUID of the type library as defined in the definition of the reference.
TypeLibLocale | Gets the locale of the type library in hex notation.
TypeLibraryName (inherited from WrapperReferenceBase) | Gets the name of the type library.
TypeLibVersion | Gets the hex version of the type library as defined in the definition of the reference.
XmlDefinition (inherited from FileReferenceBase) |

See Also

VcWrapperReference Class | NAnt.VSNet Namespace


Name Property

NAnt SDK Documentation - v0.91

VcWrapperReference.Name Property

Gets the name of the referenced assembly.

[Visual Basic]
Overrides Public ReadOnly Property Name As String
[C#]
public override string Name {get;}

Property Value

The name of the referenced assembly.

See Also

VcWrapperReference Class | NAnt.VSNet Namespace


PrimaryInteropAssembly Property

NAnt SDK Documentation - v0.91

VcWrapperReference.PrimaryInteropAssembly Property

Gets the path of the Primary Interop Assembly.

[Visual Basic]
Overrides Protected ReadOnly Property PrimaryInteropAssembly As String
[C#]
protected override string PrimaryInteropAssembly {get;}

Property Value

The path of the Primary Interop Assembly, or a null reference (Nothing in Visual Basic) if not available.

See Also

VcWrapperReference Class | NAnt.VSNet Namespace


TypeLibGuid Property

NAnt SDK Documentation - v0.91

VcWrapperReference.TypeLibGuid Property

Gets the GUID of the type library as defined in the definition of the reference.

[Visual Basic]
Overrides Protected ReadOnly Property TypeLibGuid As String
[C#]
protected override string TypeLibGuid {get;}

Property Value

The GUID of the type library.

See Also

VcWrapperReference Class | NAnt.VSNet Namespace


TypeLibLocale Property

NAnt SDK Documentation - v0.91

VcWrapperReference.TypeLibLocale Property

Gets the locale of the type library in hex notation.

[Visual Basic]
Overrides Protected ReadOnly Property TypeLibLocale As String
[C#]
protected override string TypeLibLocale {get;}

Property Value

The locale of the type library.

See Also

VcWrapperReference Class | NAnt.VSNet Namespace


TypeLibVersion Property

NAnt SDK Documentation - v0.91

VcWrapperReference.TypeLibVersion Property

Gets the hex version of the type library as defined in the definition of the reference.

[Visual Basic]
Overrides Protected ReadOnly Property TypeLibVersion As String
[C#]
protected override string TypeLibVersion {get;}

Property Value

The hex version of the type library.

Exceptions

Exception Type | Condition
BuildException | The definition of the reference does not contain a "ControlVersion" attribute.

See Also

VcWrapperReference Class | NAnt.VSNet Namespace


WrapperAssembly Property

NAnt SDK Documentation - v0.91

VcWrapperReference.WrapperAssembly Property

Gets the path of the wrapper assembly.

[Visual Basic]
Overrides Public ReadOnly Property WrapperAssembly As String
[C#]
public override string WrapperAssembly {get;}

Property Value

The path of the wrapper assembly.

Remarks

The wrapper assembly is stored in the object directory of the project.

See Also

VcWrapperReference Class | NAnt.VSNet Namespace


WrapperTool Property

NAnt SDK Documentation - v0.91

VcWrapperReference.WrapperTool Property

Gets the name of the tool that should be used to create the WrapperAssembly.

[Visual Basic]
Overrides Public ReadOnly Property WrapperTool As String
[C#]
public override string WrapperTool {get;}

Property Value

The name of the tool that should be used to create the WrapperAssembly.

See Also

VcWrapperReference Class | NAnt.VSNet Namespace


VcWrapperReference Methods

The methods of the VcWrapperReference class are listed below. For a complete list of VcWrapperReference class members, see the VcWrapperReference Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences (inherited from WrapperReferenceBase) | Gets the complete set of assemblies that need to be referenced when a project references this component.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles (inherited from WrapperReferenceBase) | Gets the complete set of output files for the referenced project.
GetPrimaryOutputFile (inherited from WrapperReferenceBase) | Gets the path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp (inherited from WrapperReferenceBase) | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from FileReferenceBase) | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAssemblyOutputFiles (inherited from FileReferenceBase) | Gets the complete set of output files for the specified assembly and adds them to collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
GetPrimaryInteropAssembly (inherited from WrapperReferenceBase) |
GetTypeLibrary (inherited from WrapperReferenceBase) |
GetTypeLibraryName (inherited from WrapperReferenceBase) |
ImportActiveXLibrary |
ImportTypeLibrary |
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ResolveWrapperAssembly (inherited from WrapperReferenceBase) |

See Also

VcWrapperReference Class | NAnt.VSNet Namespace


VcWrapperReference.ImportActiveXLibrary Method

[Visual Basic]
Overrides Protected Sub ImportActiveXLibrary()
[C#]
protected override void ImportActiveXLibrary();

See Also

VcWrapperReference Class | NAnt.VSNet Namespace


VcWrapperReference.ImportTypeLibrary Method

[Visual Basic]
Overrides Protected Sub ImportTypeLibrary()
[C#]
protected override void ImportTypeLibrary();

See Also

VcWrapperReference Class | NAnt.VSNet Namespace


WebDavClient Class

For a list of all members of this type, see WebDavClient Members.

System.Object
NAnt.VSNet.WebDavClient

[Visual Basic]
Public Class WebDavClient
[C#]
public class WebDavClient

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

WebDavClient Members | NAnt.VSNet Namespace


WebDavClient Members

WebDavClient overview

Public Static (Shared) Methods

GetFileContentsStatic

Public Instance Constructors

WebDavClient Constructor

Public Instance Methods

DeleteFile |
DownloadFile |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFileContents |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UploadFile |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebDavClient Class | NAnt.VSNet Namespace


WebDavClient Constructor

[Visual Basic]
Public Sub New( _
ByVal uriBase As Uri _
)
[C#]
public WebDavClient(
Uri uriBase
);

See Also

WebDavClient Class | NAnt.VSNet Namespace


WebDavClient Methods

The methods of the WebDavClient class are listed below. For a complete list of WebDavClient class members, see the WebDavClient Members topic.

Public Static (Shared) Methods

GetFileContentsStatic

Public Instance Methods

DeleteFile |
DownloadFile |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFileContents |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UploadFile |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebDavClient Class | NAnt.VSNet Namespace


WebDavClient.DeleteFile Method

[Visual Basic]
Public Sub DeleteFile( _
ByVal localFileName As String, _
ByVal remoteFileName As String _
)
[C#]
public void DeleteFile(
string localFileName,
string remoteFileName
);

See Also

WebDavClient Class | NAnt.VSNet Namespace


WebDavClient.DownloadFile Method

[Visual Basic]
Public Sub DownloadFile( _
ByVal localFileName As String, _
ByVal remoteFileName As String _
)
[C#]
public void DownloadFile(
string localFileName,
string remoteFileName
);

See Also

WebDavClient Class | NAnt.VSNet Namespace


WebDavClient.GetFileContents Method

[Visual Basic]
Public Function GetFileContents( _
ByVal remoteFileName As String _
) As String
[C#]
public string GetFileContents(
string remoteFileName
);

See Also

WebDavClient Class | NAnt.VSNet Namespace


WebDavClient.GetFileContentsStatic Method

[Visual Basic]
Public Shared Function GetFileContentsStatic( _
ByVal remoteFileName As String _
) As String
[C#]
public static string GetFileContentsStatic(
string remoteFileName
);

See Also

WebDavClient Class | NAnt.VSNet Namespace


WebDavClient.UploadFile Method

[Visual Basic]
Public Sub UploadFile( _
ByVal localFileName As String, _
ByVal remoteFileName As String _
)
[C#]
public void UploadFile(
string localFileName,
string remoteFileName
);

See Also

WebDavClient Class | NAnt.VSNet Namespace


WrapperReferenceBase Class

For a list of all members of this type, see WrapperReferenceBase Members.

System.Object
NAnt.VSNet.ReferenceBase
NAnt.VSNet.FileReferenceBase
NAnt.VSNet.WrapperReferenceBase
NAnt.VSNet.ManagedWrapperReference
NAnt.VSNet.VcWrapperReference

[Visual Basic]
MustInherit Public Class WrapperReferenceBase
Inherits FileReferenceBase
[C#]
public abstract class WrapperReferenceBase : FileReferenceBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

WrapperReferenceBase Members | NAnt.VSNet Namespace


WrapperReferenceBase Members

WrapperReferenceBase overview

Public Instance Properties

CopyLocal | Gets a value indicating whether the output file(s) of this reference should be copied locally.
IsCreated | Gets a value indicating whether the wrapper assembly has already been created.
Name (inherited from ReferenceBase) |
WrapperAssembly | Gets the path of the wrapper assembly.
WrapperTool | Gets the name of the tool that should be used to create the WrapperAssembly.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences | Gets the complete set of assemblies that need to be referenced when a project references this component.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles | Gets the complete set of output files for the referenced project.
GetPrimaryOutputFile | Gets the path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from FileReferenceBase) | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

WrapperReferenceBase Constructor

Protected Instance Properties

GacCache (inherited from FileReferenceBase) |
IsSystem | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
PrimaryInteropAssembly | Gets the path of the Primary Interop Assembly.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |
TypeLibGuid | Gets the GUID of the type library as defined in the definition of the reference.
TypeLibLocale | Gets the locale of the type library in hex notation.
TypeLibraryName | Gets the name of the type library.
TypeLibVersion | Gets the hex version of the type library as defined in the definition of the reference.
XmlDefinition (inherited from FileReferenceBase) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAssemblyOutputFiles (inherited from FileReferenceBase) | Gets the complete set of output files for the specified assembly and adds them to collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
GetPrimaryInteropAssembly |
GetTypeLibrary |
GetTypeLibraryName |
ImportActiveXLibrary |
ImportTypeLibrary |
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ResolveWrapperAssembly |

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


WrapperReferenceBase Constructor

[Visual Basic]
Protected Sub New( _
ByVal xmlDefinition As XmlElement, _
ByVal referencesResolver As ReferencesResolver, _
ByVal parent As ProjectBase, _
ByVal gacCache As GacCache _
)
[C#]
protected WrapperReferenceBase(
XmlElement xmlDefinition,
ReferencesResolver referencesResolver,
ProjectBase parent,
GacCache gacCache
);

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


WrapperReferenceBase Properties

The properties of the WrapperReferenceBase class are listed below. For a complete list of WrapperReferenceBase class members, see the WrapperReferenceBase Members topic.

Public Instance Properties

CopyLocal | Gets a value indicating whether the output file(s) of this reference should be copied locally.
IsCreated | Gets a value indicating whether the wrapper assembly has already been created.
Name (inherited from ReferenceBase) |
WrapperAssembly | Gets the path of the wrapper assembly.
WrapperTool | Gets the name of the tool that should be used to create the WrapperAssembly.

Protected Instance Properties

GacCache (inherited from FileReferenceBase) |
IsSystem | Gets a value indicating whether this reference represents a system assembly.
Parent (inherited from ReferenceBase) | Gets the project in which the reference is defined.
PrimaryInteropAssembly | Gets the path of the Primary Interop Assembly.
ReferencesResolver (inherited from ReferenceBase) |
SolutionTask (inherited from ReferenceBase) |
TypeLibGuid | Gets the GUID of the type library as defined in the definition of the reference.
TypeLibLocale | Gets the locale of the type library in hex notation.
TypeLibraryName | Gets the name of the type library.
TypeLibVersion | Gets the hex version of the type library as defined in the definition of the reference.
XmlDefinition (inherited from FileReferenceBase) |

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


CopyLocal Property

NAnt SDK Documentation - v0.91

WrapperReferenceBase.CopyLocal Property

Gets a value indicating whether the output file(s) of this reference should be copied locally.

[Visual Basic]
Overrides Public ReadOnly Property CopyLocal As Boolean
[C#]
public override bool CopyLocal {get;}

Property Value

false if the reference wraps a Primary Interop Assembly; otherwise, true.

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


IsCreated Property

NAnt SDK Documentation - v0.91

WrapperReferenceBase.IsCreated Property

Gets a value indicating whether the wrapper assembly has already been created.

[Visual Basic]
Public ReadOnly Property IsCreated As Boolean
[C#]
public bool IsCreated {get;}

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


IsSystem Property

NAnt SDK Documentation - v0.91

WrapperReferenceBase.IsSystem Property

Gets a value indicating whether this reference represents a system assembly.

[Visual Basic]
Overrides Protected ReadOnly Property IsSystem As Boolean
[C#]
protected override bool IsSystem {get;}

Property Value

false as none of the system assemblies are wrappers or Primary Interop Assemblies anyway.

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


PrimaryInteropAssembly Property

NAnt SDK Documentation - v0.91

WrapperReferenceBase.PrimaryInteropAssembly Property

Gets the path of the Primary Interop Assembly.

[Visual Basic]
MustOverride Protected ReadOnly Property PrimaryInteropAssembly As String
[C#]
protected abstract string PrimaryInteropAssembly {get;}

Property Value

The path of the Primary Interop Assembly, or a null reference (Nothing in Visual Basic) if not available.

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


TypeLibGuid Property

NAnt SDK Documentation - v0.91

WrapperReferenceBase.TypeLibGuid Property

Gets the GUID of the type library as defined in the definition of the reference.

[Visual Basic]
MustOverride Protected ReadOnly Property TypeLibGuid As String
[C#]
protected abstract string TypeLibGuid {get;}

Property Value

The GUID of the type library.

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


TypeLibLocale Property

NAnt SDK Documentation - v0.91

WrapperReferenceBase.TypeLibLocale Property

Gets the locale of the type library in hex notation.

[Visual Basic]
MustOverride Protected ReadOnly Property TypeLibLocale As String
[C#]
protected abstract string TypeLibLocale {get;}

Property Value

The locale of the type library.

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


TypeLibraryName Property

NAnt SDK Documentation - v0.91

WrapperReferenceBase.TypeLibraryName Property

Gets the name of the type library.

[Visual Basic]
Overridable Protected ReadOnly Property TypeLibraryName As String
[C#]
protected virtual string TypeLibraryName {get;}

Property Value

The name of the type library.

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


TypeLibVersion Property

NAnt SDK Documentation - v0.91

WrapperReferenceBase.TypeLibVersion Property

Gets the hex version of the type library as defined in the definition of the reference.

[Visual Basic]
MustOverride Protected ReadOnly Property TypeLibVersion As String
[C#]
protected abstract string TypeLibVersion {get;}

Property Value

The hex version of the type library.

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


WrapperAssembly Property

NAnt SDK Documentation - v0.91

WrapperReferenceBase.WrapperAssembly Property

Gets the path of the wrapper assembly.

[Visual Basic]
MustOverride Public ReadOnly Property WrapperAssembly As String
[C#]
public abstract string WrapperAssembly {get;}

Property Value

The path of the wrapper assembly.

Remarks

The wrapper assembly is stored in the object directory of the project.

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


WrapperTool Property

NAnt SDK Documentation - v0.91

WrapperReferenceBase.WrapperTool Property

Gets the name of the tool that should be used to create the WrapperAssembly.

[Visual Basic]
MustOverride Public ReadOnly Property WrapperTool As String
[C#]
public abstract string WrapperTool {get;}

Property Value

The name of the tool that should be used to create the WrapperAssembly.

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


WrapperReferenceBase Methods

The methods of the WrapperReferenceBase class are listed below. For a complete list of WrapperReferenceBase class members, see the WrapperReferenceBase Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyReferences | Gets the complete set of assemblies that need to be referenced when a project references this component.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetOutputFiles | Gets the complete set of output files for the referenced project.
GetPrimaryOutputFile | Gets the path of the reference, without taking the "copy local" setting into consideration.
GetTimestamp | Gets the timestamp of the reference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsManaged (inherited from FileReferenceBase) | Gets a value indicating whether the reference is managed for the specified configuration.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAssemblyOutputFiles (inherited from FileReferenceBase) | Gets the complete set of output files for the specified assembly and adds them to collection.
GetFileTimestamp (inherited from ReferenceBase) | Returns the date and time the specified file was last written to.
GetPrimaryInteropAssembly |
GetTypeLibrary |
GetTypeLibraryName |
ImportActiveXLibrary |
ImportTypeLibrary |
Log (inherited from ReferenceBase) | Overloaded. Logs a message with the given priority.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ResolveWrapperAssembly |

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


WrapperReferenceBase.GetAssemblyReferences Method

Gets the complete set of assemblies that need to be referenced when a project references this component.

[Visual Basic]
Overrides Public Function GetAssemblyReferences( _
ByVal solutionConfiguration As Configuration _
) As StringCollection
[C#]
public override StringCollection GetAssemblyReferences(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Return Value

The complete set of assemblies that need to be referenced when a project references this component.

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


WrapperReferenceBase.GetOutputFiles Method

Gets the complete set of output files for the referenced project.

[Visual Basic]
Overrides Public Sub GetOutputFiles( _
ByVal solutionConfiguration As Configuration, _
ByVal outputFiles As Hashtable _
)
[C#]
public override void GetOutputFiles(
Configuration solutionConfiguration,
Hashtable outputFiles
);

Parameters

solutionConfiguration
The solution configuration that is built.
outputFiles
The set of output files to be updated.

Remarks

The key of the case-insensitive Hashtable is the full path of the output file and the value is the path relative to the output directory.

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


WrapperReferenceBase.GetPrimaryInteropAssembly Method

[Visual Basic]
Protected Function GetPrimaryInteropAssembly() As String
[C#]
protected string GetPrimaryInteropAssembly();

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


WrapperReferenceBase.GetPrimaryOutputFile Method

Gets the path of the reference, without taking the "copy local" setting into consideration.

[Visual Basic]
Overrides Public Function GetPrimaryOutputFile( _
ByVal solutionConfiguration As Configuration _
) As String
[C#]
public override string GetPrimaryOutputFile(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Return Value

The output path of the reference.

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


WrapperReferenceBase.GetTimestamp Method

Gets the timestamp of the reference.

[Visual Basic]
Overrides Public Function GetTimestamp( _
ByVal solutionConfiguration As Configuration _
) As Date
[C#]
public override DateTime GetTimestamp(
Configuration solutionConfiguration
);

Parameters

solutionConfiguration
The solution configuration that is built.

Return Value

The timestamp of the reference.

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


WrapperReferenceBase.GetTypeLibrary Method

[Visual Basic]
Protected Function GetTypeLibrary() As String
[C#]
protected string GetTypeLibrary();

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


WrapperReferenceBase.GetTypeLibraryName Method

[Visual Basic]
Protected Function GetTypeLibraryName( _
ByVal typeLibraryPath As String _
) As String
[C#]
protected string GetTypeLibraryName(
string typeLibraryPath
);

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


WrapperReferenceBase.ImportActiveXLibrary Method

[Visual Basic]
MustOverride Protected Sub ImportActiveXLibrary()
[C#]
protected abstract void ImportActiveXLibrary();

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


WrapperReferenceBase.ImportTypeLibrary Method

[Visual Basic]
MustOverride Protected Sub ImportTypeLibrary()
[C#]
protected abstract void ImportTypeLibrary();

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


WrapperReferenceBase.ResolveWrapperAssembly Method

[Visual Basic]
Protected Function ResolveWrapperAssembly() As String
[C#]
protected string ResolveWrapperAssembly();

See Also

WrapperReferenceBase Class | NAnt.VSNet Namespace


NAnt.VSNet.Extensibility

NAnt SDK Documentation - v0.91

NAnt.VSNet.Extensibility Namespace

Namespace hierarchy

Interfaces

Interface | Description
IProjectBuildProvider |
ISolutionBuildProvider |


IProjectBuildProvider Interface

For a list of all members of this type, see IProjectBuildProvider Members.

[Visual Basic]
Public Interface IProjectBuildProvider
Implements IPlugin
[C#]
public interface IProjectBuildProvider : IPlugin

Requirements

Namespace: NAnt.VSNet.Extensibility

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

IProjectBuildProvider Members | NAnt.VSNet.Extensibility Namespace


IProjectBuildProvider Members

IProjectBuildProvider overview

Public Instance Methods

GetInstance |
IsSupported | Returns a number representing how much this file fits this project type.
LoadGuid |

See Also

IProjectBuildProvider Interface | NAnt.VSNet.Extensibility Namespace


IProjectBuildProvider Methods

The methods of the IProjectBuildProvider interface are listed below. For a complete list of IProjectBuildProvider interface members, see the IProjectBuildProvider Members topic.

Public Instance Methods

GetInstance |
IsSupported | Returns a number representing how much this file fits this project type.
LoadGuid |

See Also

IProjectBuildProvider Interface | NAnt.VSNet.Extensibility Namespace


IProjectBuildProvider.GetInstance Method

[Visual Basic]
Function GetInstance( _
ByVal solution As SolutionBase, _
ByVal projectPath As String, _
ByVal xmlDefinition As XmlElement, _
ByVal solutionTask As SolutionTask, _
ByVal tfc As TempFileCollection, _
ByVal gacCache As GacCache, _
ByVal refResolver As ReferencesResolver, _
ByVal outputDir As DirectoryInfo _
) As ProjectBase
[C#]
ProjectBase GetInstance(
SolutionBase solution,
string projectPath,
XmlElement xmlDefinition,
SolutionTask solutionTask,
TempFileCollection tfc,
GacCache gacCache,
ReferencesResolver refResolver,
DirectoryInfo outputDir
);

See Also

IProjectBuildProvider Interface | NAnt.VSNet.Extensibility Namespace


IProjectBuildProvider.IsSupported Method

Returns a number representing how much this file fits this project type.

[Visual Basic]
Function IsSupported( _
ByVal projectExt As String, _
ByVal xmlDefinition As XmlElement _
) As Integer
[C#]
int IsSupported(
string projectExt,
XmlElement xmlDefinition
);

Parameters

projectExt
xmlDefinition

Return Value

Remarks

This enables the override in other providers. Do not return big numbers, mainly when compring only on filename.

See Also

IProjectBuildProvider Interface | NAnt.VSNet.Extensibility Namespace


IProjectBuildProvider.LoadGuid Method

[Visual Basic]
Function LoadGuid( _
ByVal xmlDefinition As XmlElement _
) As String
[C#]
string LoadGuid(
XmlElement xmlDefinition
);

See Also

IProjectBuildProvider Interface | NAnt.VSNet.Extensibility Namespace


ISolutionBuildProvider Interface

For a list of all members of this type, see ISolutionBuildProvider Members.

[Visual Basic]
Public Interface ISolutionBuildProvider
Implements IPlugin
[C#]
public interface ISolutionBuildProvider : IPlugin

Requirements

Namespace: NAnt.VSNet.Extensibility

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

ISolutionBuildProvider Members | NAnt.VSNet.Extensibility Namespace


ISolutionBuildProvider Members

ISolutionBuildProvider overview

Public Instance Methods

GetInstance
IsSupported

See Also

ISolutionBuildProvider Interface | NAnt.VSNet.Extensibility Namespace


ISolutionBuildProvider Methods

The methods of the ISolutionBuildProvider interface are listed below. For a complete list of ISolutionBuildProvider interface members, see the ISolutionBuildProvider Members topic.

Public Instance Methods

GetInstance
IsSupported

See Also

ISolutionBuildProvider Interface | NAnt.VSNet.Extensibility Namespace


ISolutionBuildProvider.GetInstance Method

[Visual Basic]
Function GetInstance( _
ByVal solutionContent As String, _
ByVal solutionTask As SolutionTask, _
ByVal tfc As TempFileCollection, _
ByVal gacCache As GacCache, _
ByVal refResolver As ReferencesResolver _
) As SolutionBase
[C#]
SolutionBase GetInstance(
string solutionContent,
SolutionTask solutionTask,
TempFileCollection tfc,
GacCache gacCache,
ReferencesResolver refResolver
);

See Also

ISolutionBuildProvider Interface | NAnt.VSNet.Extensibility Namespace


ISolutionBuildProvider.IsSupported Method

[Visual Basic]
Function IsSupported( _
ByVal fileContents As String _
) As Integer
[C#]
int IsSupported(
string fileContents
);

See Also

ISolutionBuildProvider Interface | NAnt.VSNet.Extensibility Namespace


NAnt.VSNet.Tasks

NAnt SDK Documentation - v0.91

NAnt.VSNet.Tasks Namespace

Namespace hierarchy

Classes

Class | Description
SolutionTask | Compiles VS.NET solutions (or sets of projects), automatically determining project dependencies from inter-project references.


SolutionTask Class

Compiles VS.NET solutions (or sets of projects), automatically determining project dependencies from inter-project references.

For a list of all members of this type, see SolutionTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.VSNet.Tasks.SolutionTask

[Visual Basic]
<Serializable, _
 Serializable, _
 PluginConsumer(PluginType:=NAnt.VSNet.Extensibility.ISolutionBuildProvider), _
 TaskName(Name:="solution"), _
 PluginConsumer(PluginType:=NAnt.VSNet.Extensibility.IProjectBuildProvider)>
Public Class SolutionTask
Inherits Task
Implements IPluginConsumer
[C#]
[Serializable]
[Serializable]
[PluginConsumer(PluginType=NAnt.VSNet.Extensibility.ISolutionBuildProvider)]
[TaskName(Name="solution")]
[PluginConsumer(PluginType=NAnt.VSNet.Extensibility.IProjectBuildProvider)]
public class SolutionTask : Task, IPluginConsumer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This task support the following projects:

  • Visual Basic .NET
  • Visual C# .NET
  • Visual J# .NET
  • Visual C++ .NET
Note Right now, only Microsoft Visual Studio .NET 2002 and 2003 solutions and projects are supported. Support for .NET Compact Framework projects is also not available at this time.

The SolutionTask also supports the model of referencing projects by their output filenames, rather than referencing them inside the solution. It will automatically detect the existance of a file reference and convert it to a project reference. For example, if project "A" references the file in the release output directory of project "B", the SolutionTask will automatically convert this to a project dependency on project "B" and will reference the appropriate configuration output directory at the final build time (ie: reference the debug version of "B" if the solution is built as debug).

Note The SolutionTask expects all project files to be valid XML files.

Resx Files

When building a project for a down-level target framework, special care should be given to resx files. Resx files (can) contain references to a specific version of CLR types, and as such are only upward compatible.

For example: if you want to be able to build a project both as a .NET 1.0 and .NET 1.1 assembly, the resx files should only contain references to .NET 1.0 CLR types. Failure to do this may result in a InvalidCastException failure at runtime on machines with only the .NET Framework 1.0 installed.

Example

Compiles all of the projects in test.sln, in release mode, in the proper order.

<solution configuration="release" solutionfile="test.sln" />

Compiles all of the projects in projects.txt, in the proper order.

<solution configuration="release">
    <projects>
        <includesfile name="projects.txt" />
   </projects>
</solution>

Compiles projects A, B and C, using the output of project X as a reference.

<solution configuration="release">
    <projects>
        <include name="A\A.csproj" />
        <include name="B\b.vbproj" />
        <include name="C\c.csproj" />
    </projects>
    <referenceprojects>
        <include name="X\x.csproj" />
    </referenceprojects>
</solution>

Compiles all of the projects in the solution except for project A.

<solution solutionfile="test.sln" configuration="release">
    <excludeprojects>
        <include name="A\A.csproj" />
    </excludeprojects>
</solution>

Compiles all of the projects in the solution mapping the specific project at http://localhost/A/A.csproj to c:\inetpub\wwwroot\A\A.csproj and any URLs under http://localhost/B/[remainder] to c:\other\B\[remainder]. This allows the build to work without WebDAV.

<solution solutionfile="test.sln" configuration="release">
    <webmap>
        <map url="http://localhost/A/A.csproj" path="c:\inetpub\wwwroot\A\A.csproj" />
        <map url="http://localhost/B" path="c:\other\B" />
    </webmap>
</solution>

Compiles all of the projects in the solution placing compiled outputs in c:\temp.

<solution solutionfile="test.sln" configuration="release" outputdir="c:\temp" />

Requirements

Namespace: NAnt.VSNet.Tasks

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

SolutionTask Members | NAnt.VSNet.Tasks Namespace


SolutionTask Members

SolutionTask overview

Public Instance Constructors

SolutionTask Constructor Initializes a new instance of the SolutionTask class.

Public Instance Properties

AssemblyFolderList | Gets the list of folders to scan for assembly references.
AssemblyFolders | Set of folders where references are searched when not found in path from project file (HintPath).
Configuration | The name of the solution configuration to build.
CustomProperties | Set of properties set at solution level. Builders for projects in solution may or may not use them.
EnableWebDav | Allow the task to use WebDAV for retrieving/compiling the projects within solution. Use of WebMap is preferred over WebDAV. The default is false.
ExcludeProjects | Fileset of projects to exclude.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IncludeVSFolders | Includes Visual Studio search folders in reference search path. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OutputDir | The directory where compiled targets will be placed. This overrides path settings contained in the solution/project.
Parent (inherited from Element) | Gets or sets the parent of the element.
Platform | The name of platform to build the solution for.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Projects | The projects to build.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
ReferenceProjects | The projects to scan, but not build.
SolutionConfig | Gets the solution configuration to build.
SolutionFile | The name of the VS.NET solution file to build.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
WebMaps | WebMap of URL's to project references.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SolutionTask Class | NAnt.VSNet.Tasks Namespace


SolutionTask Constructor

Initializes a new instance of the SolutionTask class.

[Visual Basic]
Public Sub New()
[C#]
public SolutionTask();

See Also

SolutionTask Class | NAnt.VSNet.Tasks Namespace


SolutionTask Properties

The properties of the SolutionTask class are listed below. For a complete list of SolutionTask class members, see the SolutionTask Members topic.

Public Instance Properties

AssemblyFolderList | Gets the list of folders to scan for assembly references.
AssemblyFolders | Set of folders where references are searched when not found in path from project file (HintPath).
Configuration | The name of the solution configuration to build.
CustomProperties | Set of properties set at solution level. Builders for projects in solution may or may not use them.
EnableWebDav | Allow the task to use WebDAV for retrieving/compiling the projects within solution. Use of WebMap is preferred over WebDAV. The default is false.
ExcludeProjects | Fileset of projects to exclude.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
IncludeVSFolders | Includes Visual Studio search folders in reference search path. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OutputDir | The directory where compiled targets will be placed. This overrides path settings contained in the solution/project.
Parent (inherited from Element) | Gets or sets the parent of the element.
Platform | The name of platform to build the solution for.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Projects | The projects to build.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
ReferenceProjects | The projects to scan, but not build.
SolutionConfig | Gets the solution configuration to build.
SolutionFile | The name of the VS.NET solution file to build.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.
WebMaps | WebMap of URL's to project references.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

SolutionTask Class | NAnt.VSNet.Tasks Namespace


AssemblyFolderList Property

NAnt SDK Documentation - v0.91

SolutionTask.AssemblyFolderList Property

Gets the list of folders to scan for assembly references.

[Visual Basic]
Public ReadOnly Property AssemblyFolderList As StringCollection
[C#]
public System.Collections.Specialized.StringCollection AssemblyFolderList {get;}

Property Value

The list of folders to scan for assembly references.

See Also

SolutionTask Class | NAnt.VSNet.Tasks Namespace


AssemblyFolders Property

NAnt SDK Documentation - v0.91

SolutionTask.AssemblyFolders Property

Set of folders where references are searched when not found in path from project file (HintPath).

[Visual Basic]
<BuildElement(Required:=False, Name:="assemblyfolders", ProcessXml:=True)>
Public Property AssemblyFolders As FileSet
[C#]
[BuildElement(Required=False, Name="assemblyfolders", ProcessXml=True)]
public NAnt.Core.Types.FileSet AssemblyFolders {get; set;}

See Also

SolutionTask Class | NAnt.VSNet.Tasks Namespace


Configuration Property

NAnt SDK Documentation - v0.91

SolutionTask.Configuration Property

The name of the solution configuration to build.

[Visual Basic]
<TaskAttribute(Name:="configuration", Required:=True, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property Configuration As String
[C#]
[TaskAttribute(Name="configuration", Required=True, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string Configuration {get; set;}

Remarks

Generally release or debug. Not case-sensitive.

See Also

SolutionTask Class | NAnt.VSNet.Tasks Namespace


CustomProperties Property

NAnt SDK Documentation - v0.91

SolutionTask.CustomProperties Property

Set of properties set at solution level. Builders for projects in solution may or may not use them.

[Visual Basic]
<BuildElementArray(ElementType:=NAnt.Core.Tasks.PropertyTask, Name:="property", Required:=False, ProcessXml:=True)>
Public ReadOnly Property CustomProperties As ArrayList
[C#]
[BuildElementArray(ElementType=NAnt.Core.Tasks.PropertyTask, Name="property", Required=False, ProcessXml=True)]
public System.Collections.ArrayList CustomProperties {get;}

Remarks

TODO: some documentataion which properties could be defined here.

See Also

SolutionTask Class | NAnt.VSNet.Tasks Namespace


EnableWebDav Property

NAnt SDK Documentation - v0.91

SolutionTask.EnableWebDav Property

Allow the task to use WebDAV for retrieving/compiling the projects within solution. Use of WebMap is preferred over WebDAV. The default is false.

[Visual Basic]
<TaskAttribute(Name:="enablewebdav", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property EnableWebDav As Boolean
[C#]
[TaskAttribute(Name="enablewebdav", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool EnableWebDav {get; set;}

Remarks

WebDAV support requires permission changes to be made on your project server. These changes may affect the security of the server and should not be applied to a public installation.

Consult your web server or the NAnt Wiki documentation for more information.

See Also

SolutionTask Class | NAnt.VSNet.Tasks Namespace


ExcludeProjects Property

NAnt SDK Documentation - v0.91

SolutionTask.ExcludeProjects Property

Fileset of projects to exclude.

[Visual Basic]
<BuildElement(Required:=False, Name:="excludeprojects", ProcessXml:=True)>
Public Property ExcludeProjects As FileSet
[C#]
[BuildElement(Required=False, Name="excludeprojects", ProcessXml=True)]
public NAnt.Core.Types.FileSet ExcludeProjects {get; set;}

See Also

SolutionTask Class | NAnt.VSNet.Tasks Namespace


IncludeVSFolders Property

NAnt SDK Documentation - v0.91

SolutionTask.IncludeVSFolders Property

Includes Visual Studio search folders in reference search path. The default is true.

[Visual Basic]
<TaskAttribute(Name:="includevsfolders", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property IncludeVSFolders As Boolean
[C#]
[TaskAttribute(Name="includevsfolders", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool IncludeVSFolders {get; set;}

See Also

SolutionTask Class | NAnt.VSNet.Tasks Namespace


OutputDir Property

NAnt SDK Documentation - v0.91

SolutionTask.OutputDir Property

The directory where compiled targets will be placed. This overrides path settings contained in the solution/project.

[Visual Basic]
<TaskAttribute(Name:="outputdir", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property OutputDir As DirectoryInfo
[C#]
[TaskAttribute(Name="outputdir", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.DirectoryInfo OutputDir {get; set;}

See Also

SolutionTask Class | NAnt.VSNet.Tasks Namespace


Platform Property

NAnt SDK Documentation - v0.91

SolutionTask.Platform Property

The name of platform to build the solution for.

[Visual Basic]
<TaskAttribute(Name:="platform", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=True, Expression:="null", ExpressionErrorMessage:="null")>
Public Property Platform As String
[C#]
[TaskAttribute(Name="platform", Required=False, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=True, Expression="null", ExpressionErrorMessage="null")]
public string Platform {get; set;}

See Also

SolutionTask Class | NAnt.VSNet.Tasks Namespace


Projects Property

NAnt SDK Documentation - v0.91

SolutionTask.Projects Property

The projects to build.

[Visual Basic]
<BuildElement(Name:="projects", Required:=False, ProcessXml:=True)>
Public Property Projects As FileSet
[C#]
[BuildElement(Name="projects", Required=False, ProcessXml=True)]
public NAnt.Core.Types.FileSet Projects {get; set;}

See Also

SolutionTask Class | NAnt.VSNet.Tasks Namespace


ReferenceProjects Property

NAnt SDK Documentation - v0.91

SolutionTask.ReferenceProjects Property

The projects to scan, but not build.

[Visual Basic]
<BuildElement(Required:=False, Name:="referenceprojects", ProcessXml:=True)>
Public Property ReferenceProjects As FileSet
[C#]
[BuildElement(Required=False, Name="referenceprojects", ProcessXml=True)]
public NAnt.Core.Types.FileSet ReferenceProjects {get; set;}

Remarks

These projects are used to resolve project references and are generally external to the solution being built. References to these project's output files are converted to use the appropriate solution configuration at build time.

See Also

SolutionTask Class | NAnt.VSNet.Tasks Namespace


SolutionConfig Property

NAnt SDK Documentation - v0.91

SolutionTask.SolutionConfig Property

Gets the solution configuration to build.

[Visual Basic]
Public ReadOnly Property SolutionConfig As Configuration
[C#]
public NAnt.VSNet.Configuration SolutionConfig {get;}

See Also

SolutionTask Class | NAnt.VSNet.Tasks Namespace


SolutionFile Property

NAnt SDK Documentation - v0.91

SolutionTask.SolutionFile Property

The name of the VS.NET solution file to build.

[Visual Basic]
<TaskAttribute(Name:="solutionfile", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property SolutionFile As FileInfo
[C#]
[TaskAttribute(Name="solutionfile", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo SolutionFile {get; set;}

Remarks

The Projects can be used instead to supply a list of Visual Studio.NET projects that should be built.

See Also

SolutionTask Class | NAnt.VSNet.Tasks Namespace


WebMaps Property

NAnt SDK Documentation - v0.91

SolutionTask.WebMaps Property

WebMap of URL's to project references.

[Visual Basic]
<BuildElementCollection(ChildElementName:="map", ElementType:=null, Name:="webmap", Required:=False, ProcessXml:=True)>
Public ReadOnly Property WebMaps As WebMapCollection
[C#]
[BuildElementCollection(ChildElementName="map", ElementType=null, Name="webmap", Required=False, ProcessXml=True)]
public NAnt.VSNet.Types.WebMapCollection WebMaps {get;}

See Also

SolutionTask Class | NAnt.VSNet.Tasks Namespace


SolutionTask Methods

The methods of the SolutionTask class are listed below. For a complete list of SolutionTask class members, see the SolutionTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SolutionTask Class | NAnt.VSNet.Tasks Namespace


SolutionTask.ExecuteTask Method

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

SolutionTask Class | NAnt.VSNet.Tasks Namespace


NAnt.VSNet.Types

NAnt SDK Documentation - v0.91

NAnt.VSNet.Types Namespace

Namespace hierarchy

Classes

Class | Description
WebMap | Represents a single mapping from URL project path to physical project path.
WebMapCollection | Contains a strongly typed collection of WebMap objects.
WebMapEnumerator | Enumerates the WebMap elements of a WebMapCollection.

Enumerations

Enumeration | Description
UseOfATL | Defines how the project is using the ATL library.
UseOfMFC | Defines how the project is using the MFC library.
UsePrecompiledHeader | Indicates the possible ways in which precompiled header file use is specified in a Visual C++ project.


UseOfATL Enumeration

Defines how the project is using the ATL library.

[Visual Basic]
<Serializable>
Public Enum UseOfATL
[C#]
[Serializable]
public enum UseOfATL

Members

Member Name | Description
NotUsing | Don't use ATL.
Static | Use ATL in a Static Library.
Shared | Use ATL in a Shared DLL.

Requirements

Namespace: NAnt.VSNet.Types

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

NAnt.VSNet.Types Namespace


UseOfMFC Enumeration

Defines how the project is using the MFC library.

[Visual Basic]
<Serializable>
Public Enum UseOfMFC
[C#]
[Serializable]
public enum UseOfMFC

Members

Member Name | Description
NotUsing | Don't use MFC.
Static | Use MFC in a Static Library.
Shared | Use MFC in a Shared DLL.

Requirements

Namespace: NAnt.VSNet.Types

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

NAnt.VSNet.Types Namespace


UsePrecompiledHeader Enumeration

Indicates the possible ways in which precompiled header file use is specified in a Visual C++ project.

[Visual Basic]
<Serializable>
Public Enum UsePrecompiledHeader
[C#]
[Serializable]
public enum UsePrecompiledHeader

Remarks

The integer values assigned match those specified in the Visual C++ project file for each setting.

Members

Member Name | Description
Unspecified | Precompiled header file use not specified.
No | Don't use a precompiled header file.
Create | Create precompiled header file.
AutoCreate | Automatically create precompiled header file if necessary.
Use | Use a precompiled header file.

Requirements

Namespace: NAnt.VSNet.Types

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

NAnt.VSNet.Types Namespace


WebMap Class

Represents a single mapping from URL project path to physical project path.

For a list of all members of this type, see WebMap Members.

System.Object
NAnt.Core.Element
NAnt.VSNet.Types.WebMap

[Visual Basic]
<Serializable, _ Serializable>
Public Class WebMap
Inherits Element
[C#]
[Serializable]
[Serializable]
public class WebMap : Element

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet.Types

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

WebMap Members | NAnt.VSNet.Types Namespace


WebMap Members

WebMap overview

Public Instance Constructors

WebMap Constructor Initializes a new instance of the WebMap class.

Public Instance Properties

CaseSensitive | Specifies whether the mapping is case-sensitive or not.
IfDefined | Indicates if the URL of the project file should be mapped.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Path | Specifies the actual path to the project file, or the path fragment to replace.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Indicates if the URL of the project file should not be mapped.
Url | Specifies the URL of the project file, or a URL fragment to match.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
Log (inherited from Element) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebMap Class | NAnt.VSNet.Types Namespace


WebMap Constructor

Initializes a new instance of the WebMap class.

[Visual Basic]
Public Sub New()
[C#]
public WebMap();

See Also

WebMap Class | NAnt.VSNet.Types Namespace


WebMap Properties

The properties of the WebMap class are listed below. For a complete list of WebMap class members, see the WebMap Members topic.

Public Instance Properties

CaseSensitive | Specifies whether the mapping is case-sensitive or not.
IfDefined | Indicates if the URL of the project file should be mapped.
Name (inherited from Element) | Gets the name of the XML element used to initialize this element.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Path | Specifies the actual path to the project file, or the path fragment to replace.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
UnlessDefined | Indicates if the URL of the project file should not be mapped.
Url | Specifies the URL of the project file, or a URL fragment to match.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

WebMap Class | NAnt.VSNet.Types Namespace


CaseSensitive Property

NAnt SDK Documentation - v0.91

WebMap.CaseSensitive Property

Specifies whether the mapping is case-sensitive or not.

[Visual Basic]
<TaskAttribute(Name:="casesensitive", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property CaseSensitive As Boolean
[C#]
[TaskAttribute(Name="casesensitive", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool CaseSensitive {get; set;}

Property Value

A boolean flag representing the case-sensitivity of the mapping. Default is true.

See Also

WebMap Class | NAnt.VSNet.Types Namespace


IfDefined Property

NAnt SDK Documentation - v0.91

WebMap.IfDefined Property

Indicates if the URL of the project file should be mapped.

[Visual Basic]
<TaskAttribute(Name:="if", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property IfDefined As Boolean
[C#]
[TaskAttribute(Name="if", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool IfDefined {get; set;}

Property Value

true if the URL of the project file should be mapped; otherwise, false.

See Also

WebMap Class | NAnt.VSNet.Types Namespace


Path Property

NAnt SDK Documentation - v0.91

WebMap.Path Property

Specifies the actual path to the project file, or the path fragment to replace.

[Visual Basic]
<TaskAttribute(Name:="path", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property Path As FileInfo
[C#]
[TaskAttribute(Name="path", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo Path {get; set;}

Property Value

The actual path to the project file or the path fragment to replace the URL fragment with.

See Also

WebMap Class | NAnt.VSNet.Types Namespace


UnlessDefined Property

NAnt SDK Documentation - v0.91

WebMap.UnlessDefined Property

Indicates if the URL of the project file should not be mapped.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="unless", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property UnlessDefined As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="unless", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool UnlessDefined {get; set;}

Property Value

true if the URL of the project file should not be mapped; otherwise, false.

See Also

WebMap Class | NAnt.VSNet.Types Namespace


Url Property

NAnt SDK Documentation - v0.91

WebMap.Url Property

Specifies the URL of the project file, or a URL fragment to match.

[Visual Basic]
<TaskAttribute(Name:="url", Required:=True, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Public Property Url As String
[C#]
[TaskAttribute(Name="url", Required=True, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public string Url {get; set;}

Property Value

The URL of the project file or the URL fragment to match.

See Also

WebMap Class | NAnt.VSNet.Types Namespace


WebMapCollection Class

Contains a strongly typed collection of WebMap objects.

For a list of all members of this type, see WebMapCollection Members.

System.Object
System.Collections.CollectionBase
NAnt.VSNet.Types.WebMapCollection

[Visual Basic]
<Serializable, _ Serializable, _ DefaultMember(MemberName:="Item")>
Public Class WebMapCollection
Inherits CollectionBase
[C#]
[Serializable]
[Serializable]
[DefaultMember(MemberName="Item")]
public class WebMapCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet.Types

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

WebMapCollection Members | NAnt.VSNet.Types Namespace


WebMapCollection Members

WebMapCollection overview

Public Instance Constructors

WebMapCollection Overloaded. Initializes a new instance of the WebMapCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds a WebMap to the end of the collection.
AddRange | Overloaded. Adds the elements of a WebMap array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a WebMap is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindBestMatch | Find the best matching WebMap for the given Uri.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified WebMap object in the collection.
Insert | Inserts a WebMap into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace


WebMapCollection Constructor

Initializes a new instance of the WebMapCollection class.

Overload List

Initializes a new instance of the WebMapCollection class.

public WebMapCollection();

Initializes a new instance of the WebMapCollection class with the specified array of WebMap instances.

public WebMapCollection(WebMap[]);

Initializes a new instance of the WebMapCollection class with the specified WebMapCollection instance.

public WebMapCollection(WebMapCollection);

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace


WebMapCollection Constructor ()

Initializes a new instance of the WebMapCollection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public WebMapCollection();

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace | WebMapCollection Constructor Overload List


WebMapCollection Constructor (WebMapCollection)

Initializes a new instance of the WebMapCollection class with the specified WebMapCollection instance.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As WebMapCollection _
)
[C#]
public WebMapCollection(
WebMapCollection value
);

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace | WebMapCollection Constructor Overload List


WebMapCollection Constructor (WebMap[])

Initializes a new instance of the WebMapCollection class with the specified array of WebMap instances.

[Visual Basic]
Overloads Public Sub New( _
ByVal value As WebMap() _
)
[C#]
public WebMapCollection(
WebMap[] value
);

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace | WebMapCollection Constructor Overload List


WebMapCollection Properties

The properties of the WebMapCollection class are listed below. For a complete list of WebMapCollection class members, see the WebMapCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden.
Item | Overloaded. Gets or sets the element at the specified index.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace


Item Property

NAnt SDK Documentation - v0.91

WebMapCollection.Item Property

Gets or sets the element at the specified index.

Overload List

Gets or sets the element at the specified index.

public WebMap this[int] {get; set;}

Gets the WebMap with the specified value.

public WebMap this[string] {get;}

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace


Item Property (Int32)

NAnt SDK Documentation - v0.91

WebMapCollection.Item Property (Int32)

Gets or sets the element at the specified index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As WebMap
[C#]
public WebMap this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace | WebMapCollection.Item Overload List


Item Property (String)

NAnt SDK Documentation - v0.91

WebMapCollection.Item Property (String)

Gets the WebMap with the specified value.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal value As String _
) As WebMap
[C#]
public WebMap this[
string value
] {get;}

Parameters

value
The value of the WebMap to get.

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace | WebMapCollection.Item Overload List


WebMapCollection Methods

The methods of the WebMapCollection class are listed below. For a complete list of WebMapCollection class members, see the WebMapCollection Members topic.

Public Instance Methods

Add | Adds a WebMap to the end of the collection.
AddRange | Overloaded. Adds the elements of a WebMap array to the end of the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance. This method cannot be overridden.
Contains | Overloaded. Determines whether a WebMap is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindBestMatch | Find the best matching WebMap for the given Uri.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Retrieves the index of a specified WebMap object in the collection.
Insert | Inserts a WebMap into the collection at the specified index.
Remove | Removes a member from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace


WebMapCollection.Add Method

Adds a WebMap to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As WebMap _
) As Integer
[C#]
public int Add(
WebMap item
);

Parameters

item
The WebMap to be added to the end of the collection.

Return Value

The position into which the new element was inserted.

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace


AddRange Method

NAnt SDK Documentation - v0.91

WebMapCollection.AddRange Method

Adds the elements of a WebMap array to the end of the collection.

Overload List

Adds the elements of a WebMap array to the end of the collection.

public void AddRange(WebMap[]);

Adds the elements of a WebMapCollection to the end of the collection.

public void AddRange(WebMapCollection);

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace


WebMapCollection.AddRange Method (WebMap[])

Adds the elements of a WebMap array to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As WebMap() _
)
[C#]
public void AddRange(
WebMap[] items
);

Parameters

items
The array of WebMap elements to be added to the end of the collection.

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace | WebMapCollection.AddRange Overload List


WebMapCollection.AddRange Method (WebMapCollection)

Adds the elements of a WebMapCollection to the end of the collection.

[Visual Basic]
Overloads Public Sub AddRange( _
ByVal items As WebMapCollection _
)
[C#]
public void AddRange(
WebMapCollection items
);

Parameters

items
The WebMapCollection to be added to the end of the collection.

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace | WebMapCollection.AddRange Overload List


Contains Method

NAnt SDK Documentation - v0.91

WebMapCollection.Contains Method

Determines whether a WebMap is in the collection.

Overload List

Determines whether a WebMap is in the collection.

public bool Contains(WebMap);

Determines whether a WebMap with the specified value is in the collection.

public bool Contains(string);

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace


WebMapCollection.Contains Method (WebMap)

Determines whether a WebMap is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal item As WebMap _
) As Boolean
[C#]
public bool Contains(
WebMap item
);

Parameters

item
The WebMap to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace | WebMapCollection.Contains Overload List


WebMapCollection.Contains Method (String)

Determines whether a WebMap with the specified value is in the collection.

[Visual Basic]
Overloads Public Function Contains( _
ByVal value As String _
) As Boolean
[C#]
public bool Contains(
string value
);

Parameters

value
The argument value to locate in the collection.

Return Value

true if a WebMap with value value is found in the collection; otherwise, false.

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace | WebMapCollection.Contains Overload List


WebMapCollection.CopyTo Method

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

[Visual Basic]
Public Sub CopyTo( _
ByVal array As WebMap(), _
ByVal index As Integer _
)
[C#]
public void CopyTo(
WebMap[] array,
int index
);

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace


WebMapCollection.FindBestMatch Method

Find the best matching WebMap for the given Uri.

[Visual Basic]
Public Function FindBestMatch( _
ByVal uri As String _
) As String
[C#]
public string FindBestMatch(
string uri
);

Parameters

uri
The value to match against the WebMap objects in the collection.

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace


WebMapCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

[Visual Basic]
Public Function GetEnumerator() As WebMapEnumerator
[C#]
new public WebMapEnumerator GetEnumerator();

Return Value

A WebMapEnumerator for the entire collection.

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace


WebMapCollection.IndexOf Method

Retrieves the index of a specified WebMap object in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As WebMap _
) As Integer
[C#]
public int IndexOf(
WebMap item
);

Parameters

item
The WebMap object for which the index is returned.

Return Value

The index of the specified WebMap. If the WebMap is not currently a member of the collection, it returns -1.

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace


WebMapCollection.Insert Method

Inserts a WebMap into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
ByVal index As Integer, _
ByVal item As WebMap _
)
[C#]
public void Insert(
int index,
WebMap item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The WebMap to insert.

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace


WebMapCollection.Remove Method

Removes a member from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As WebMap _
)
[C#]
public void Remove(
WebMap item
);

Parameters

item
The WebMap to remove from the collection.

See Also

WebMapCollection Class | NAnt.VSNet.Types Namespace


WebMapEnumerator Class

Enumerates the WebMap elements of a WebMapCollection.

For a list of all members of this type, see WebMapEnumerator Members.

System.Object
NAnt.VSNet.Types.WebMapEnumerator

[Visual Basic]
Public Class WebMapEnumerator
Implements IEnumerator
[C#]
public class WebMapEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: NAnt.VSNet.Types

Assembly: NAnt.VSNetTasks (in NAnt.VSNetTasks.dll)

See Also

WebMapEnumerator Members | NAnt.VSNet.Types Namespace


WebMapEnumerator Members

WebMapEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebMapEnumerator Class | NAnt.VSNet.Types Namespace


WebMapEnumerator Properties

The properties of the WebMapEnumerator class are listed below. For a complete list of WebMapEnumerator class members, see the WebMapEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

WebMapEnumerator Class | NAnt.VSNet.Types Namespace


Current Property

NAnt SDK Documentation - v0.91

WebMapEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Public ReadOnly Property Current As WebMap
[C#]
public WebMap Current {get;}

See Also

WebMapEnumerator Class | NAnt.VSNet.Types Namespace


WebMapEnumerator Methods

The methods of the WebMapEnumerator class are listed below. For a complete list of WebMapEnumerator class members, see the WebMapEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebMapEnumerator Class | NAnt.VSNet.Types Namespace


WebMapEnumerator.MoveNext Method

Advances the enumerator to the next element of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

See Also

WebMapEnumerator Class | NAnt.VSNet.Types Namespace


WebMapEnumerator.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

WebMapEnumerator Class | NAnt.VSNet.Types Namespace


NAnt.Win32.Functions

NAnt SDK Documentation - v0.91

NAnt.Win32.Functions Namespace

Namespace hierarchy

Classes

Class | Description
CygpathFunctions | Groups a set of functions that convert Windows native filenames to Cygwin POSIX-style pathnames and vice versa.


CygpathFunctions Class

Groups a set of functions that convert Windows native filenames to Cygwin POSIX-style pathnames and vice versa.

For a list of all members of this type, see CygpathFunctions Members.

System.Object
NAnt.Core.FunctionSetBase
NAnt.Win32.Functions.CygpathFunctions

[Visual Basic]
<FunctionSet(Category:="Unix/Cygwin", Prefix:="cygpath")>
Public Class CygpathFunctions
Inherits FunctionSetBase
[C#]
[FunctionSet(Category="Unix/Cygwin", Prefix="cygpath")]
public class CygpathFunctions : FunctionSetBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

It can be used when a Cygwin program needs to pass a file name to a native Windows program, or expects to get a file name from a native Windows program.

Requirements

Namespace: NAnt.Win32.Functions

Assembly: NAnt.Win32Tasks (in NAnt.Win32Tasks.dll)

See Also

CygpathFunctions Members | NAnt.Win32.Functions Namespace


CygpathFunctions Members

CygpathFunctions overview

Public Instance Constructors

CygpathFunctions Constructor Initializes a new instance of the CygpathFunctions class with the specified Project and properties.

Public Instance Properties

Project (inherited from FunctionSetBase) Gets or sets the Project that this functionset will reference.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDosPath | Gets the DOS (short) form of the specified path.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUnixPath | Gets the Unix form of the specified path.
GetWindowsPath | Gets the Windows form of the specified path.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CygpathFunctions Class | NAnt.Win32.Functions Namespace


CygpathFunctions Constructor

Initializes a new instance of the CygpathFunctions class with the specified Project and properties.

[Visual Basic]
Public Sub New( _
ByVal project As Project, _
ByVal properties As PropertyDictionary _
)
[C#]
public CygpathFunctions(
Project project,
PropertyDictionary properties
);

Parameters

project
The Project in which the class is used.
properties
The set of properties to use for macro expansion.

See Also

CygpathFunctions Class | NAnt.Win32.Functions Namespace


CygpathFunctions Methods

The methods of the CygpathFunctions class are listed below. For a complete list of CygpathFunctions class members, see the CygpathFunctions Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDosPath | Gets the DOS (short) form of the specified path.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUnixPath | Gets the Unix form of the specified path.
GetWindowsPath | Gets the Windows form of the specified path.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CygpathFunctions Class | NAnt.Win32.Functions Namespace


CygpathFunctions.GetDosPath Method

Gets the DOS (short) form of the specified path.

[Visual Basic]
<Function(Name:="get-dos-path")>
Public Function GetDosPath( _
ByVal path As String _
) As String
[C#]
[Function(Name="get-dos-path")]
public string GetDosPath(
string path
);

Parameters

path
The path to convert.

Return Value

The DOS (short) form of the specified path.

Exceptions

Exception Type | Condition
Win32Exception | cygpath could not be started.
ArgumentException | path could not be converted to a short form.

See Also

CygpathFunctions Class | NAnt.Win32.Functions Namespace


CygpathFunctions.GetUnixPath Method

Gets the Unix form of the specified path.

[Visual Basic]
<Function(Name:="get-unix-path")>
Public Function GetUnixPath( _
ByVal path As String _
) As String
[C#]
[Function(Name="get-unix-path")]
public string GetUnixPath(
string path
);

Parameters

path
The path to convert.

Return Value

The Unix form of the specified path.

Exceptions

Exception Type | Condition
Win32Exception | cygpath could not be started.
ArgumentException | path could not be converted to a Unix form.

See Also

CygpathFunctions Class | NAnt.Win32.Functions Namespace


CygpathFunctions.GetWindowsPath Method

Gets the Windows form of the specified path.

[Visual Basic]
<Function(Name:="get-windows-path")>
Public Function GetWindowsPath( _
ByVal path As String _
) As String
[C#]
[Function(Name="get-windows-path")]
public string GetWindowsPath(
string path
);

Parameters

path
The path to convert.

Return Value

The Windows form of the specified path.

Exceptions

Exception Type | Condition
Win32Exception | cygpath could not be started.
ArgumentException | path could not be converted to a Windows form.

See Also

CygpathFunctions Class | NAnt.Win32.Functions Namespace


NAnt.Win32.Tasks

NAnt SDK Documentation - v0.91

NAnt.Win32.Tasks Namespace

Namespace hierarchy

Classes

Class | Description
AxImpTask | Generates a Windows Forms Control that wraps ActiveX Controls defined in an OCX.
ReadRegistryTask | Reads a value or set of values from the Windows Registry into one or more NAnt properties.
RegAsmTask | Registers an assembly, or set of assemblies for use from COM clients.
TlbExpTask | Exports a .NET assembly to a type library that can be used from unmanaged code (wraps Microsoft's tlbexp.exe).
TlbImpTask | Imports a type library to a .NET assembly (wraps Microsoft's tlbimp.exe).


AxImpTask Class

Generates a Windows Forms Control that wraps ActiveX Controls defined in an OCX.

For a list of all members of this type, see AxImpTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.Win32.Tasks.AxImpTask

[Visual Basic]
<ProgramLocation(LocationType:=LocationType.FrameworkSdkDir), _ TaskName(Name:="aximp")>
Public Class AxImpTask
Inherits ExternalProgramBase
[C#]
[ProgramLocation(LocationType=LocationType.FrameworkSdkDir)]
[TaskName(Name="aximp")]
public class AxImpTask : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

            <aximp ocx="MyControl.ocx" output="MyFormsControl.dll" />

Requirements

Namespace: NAnt.Win32.Tasks

Assembly: NAnt.Win32Tasks (in NAnt.Win32Tasks.dll)

See Also

AxImpTask Members | NAnt.Win32.Tasks Namespace


AxImpTask Members

AxImpTask overview

Public Instance Constructors

AxImpTask Constructor Initializes a new instance of the AxImpTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
DelaySign | Specifies to sign the resulting control using delayed signing.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
GenerateSource | Determines whether C# source code for the Windows Form wrapper should be generated. The default is false.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
KeyContainer | Specifies the key container in which the public/private key pair should be found that should be used to sign the resulting assembly with a strong name.
KeyFile | Specifies the publisher's official public/private key pair with which the resulting assembly should be signed with a strong name.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OcxFile | Filename of the .ocx file.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | Filename of the generated assembly.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PublicKeyFile | Specifies the file containing the public key to use to sign the resulting assembly.
RcwFile | Assembly to use for Runtime Callable Wrapper rather than generating new one [.NET 1.1 or higher].
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
SupportsRcw | Indicates whether aximp supports using an existing Runtime Callable Wrapper for a given target framework. The default is true.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Import the ActiveX control.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines whether the assembly needs to be created again.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

AxImpTask Class | NAnt.Win32.Tasks Namespace


AxImpTask Constructor

Initializes a new instance of the AxImpTask class.

[Visual Basic]
Public Sub New()
[C#]
public AxImpTask();

See Also

AxImpTask Class | NAnt.Win32.Tasks Namespace


AxImpTask Properties

The properties of the AxImpTask class are listed below. For a complete list of AxImpTask class members, see the AxImpTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
DelaySign | Specifies to sign the resulting control using delayed signing.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
GenerateSource | Determines whether C# source code for the Windows Form wrapper should be generated. The default is false.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
KeyContainer | Specifies the key container in which the public/private key pair should be found that should be used to sign the resulting assembly with a strong name.
KeyFile | Specifies the publisher's official public/private key pair with which the resulting assembly should be signed with a strong name.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
OcxFile | Filename of the .ocx file.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | Filename of the generated assembly.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command-line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PublicKeyFile | Specifies the file containing the public key to use to sign the resulting assembly.
RcwFile | Assembly to use for Runtime Callable Wrapper rather than generating new one [.NET 1.1 or higher].
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
SupportsRcw | Indicates whether aximp supports using an existing Runtime Callable Wrapper for a given target framework. The default is true.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

AxImpTask Class | NAnt.Win32.Tasks Namespace


DelaySign Property

NAnt SDK Documentation - v0.91

AxImpTask.DelaySign Property

Specifies to sign the resulting control using delayed signing.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="delaysign", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property DelaySign As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="delaysign", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool DelaySign {get; set;}

See Also

AxImpTask Class | NAnt.Win32.Tasks Namespace


GenerateSource Property

NAnt SDK Documentation - v0.91

AxImpTask.GenerateSource Property

Determines whether C# source code for the Windows Form wrapper should be generated. The default is false.

[Visual Basic]
<TaskAttribute(Name:="generatesource", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property GenerateSource As Boolean
[C#]
[TaskAttribute(Name="generatesource", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool GenerateSource {get; set;}

See Also

AxImpTask Class | NAnt.Win32.Tasks Namespace


KeyContainer Property

NAnt SDK Documentation - v0.91

AxImpTask.KeyContainer Property

Specifies the key container in which the public/private key pair should be found that should be used to sign the resulting assembly with a strong name.

[Visual Basic]
<TaskAttribute(Name:="keycontainer", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property KeyContainer As String
[C#]
[TaskAttribute(Name="keycontainer", Required=False, ExpandProperties=True, ProcessXml=True)]
public string KeyContainer {get; set;}

Property Value

The key container containing a public/private key pair that should be used to sign the resulting assembly.

See Also

AxImpTask Class | NAnt.Win32.Tasks Namespace


KeyFile Property

NAnt SDK Documentation - v0.91

AxImpTask.KeyFile Property

Specifies the publisher's official public/private key pair with which the resulting assembly should be signed with a strong name.

[Visual Basic]
<TaskAttribute(Name:="keyfile", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property KeyFile As FileInfo
[C#]
[TaskAttribute(Name="keyfile", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo KeyFile {get; set;}

Property Value

The keyfile to use to sign the resulting assembly with a strong name.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

AxImpTask Class | NAnt.Win32.Tasks Namespace


OcxFile Property

NAnt SDK Documentation - v0.91

AxImpTask.OcxFile Property

Filename of the .ocx file.

[Visual Basic]
<TaskAttribute(Name:="ocx", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property OcxFile As FileInfo
[C#]
[TaskAttribute(Name="ocx", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo OcxFile {get; set;}

See Also

AxImpTask Class | NAnt.Win32.Tasks Namespace


OutputFile Property

NAnt SDK Documentation - v0.91

AxImpTask.OutputFile Property

Filename of the generated assembly.

[Visual Basic]
<TaskAttribute(Name:="output", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property OutputFile As FileInfo
[C#]
[TaskAttribute(Name="output", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo OutputFile {get; set;}

See Also

AxImpTask Class | NAnt.Win32.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

AxImpTask.ProgramArguments Property

Gets the command-line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

Property Value

The command-line arguments for the external program.

See Also

AxImpTask Class | NAnt.Win32.Tasks Namespace


PublicKeyFile Property

NAnt SDK Documentation - v0.91

AxImpTask.PublicKeyFile Property

Specifies the file containing the public key to use to sign the resulting assembly.

[Visual Basic]
<TaskAttribute(Name:="publickey", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property PublicKeyFile As FileInfo
[C#]
[TaskAttribute(Name="publickey", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo PublicKeyFile {get; set;}

Property Value

The file containing the public key to use to sign the resulting assembly.

See Also

AxImpTask Class | NAnt.Win32.Tasks Namespace


RcwFile Property

NAnt SDK Documentation - v0.91

AxImpTask.RcwFile Property

Assembly to use for Runtime Callable Wrapper rather than generating new one [.NET 1.1 or higher].

[Visual Basic]
<TaskAttribute(Name:="rcw", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property RcwFile As FileInfo
[C#]
[TaskAttribute(Name="rcw", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo RcwFile {get; set;}

See Also

AxImpTask Class | NAnt.Win32.Tasks Namespace


SupportsRcw Property

NAnt SDK Documentation - v0.91

AxImpTask.SupportsRcw Property

Indicates whether aximp supports using an existing Runtime Callable Wrapper for a given target framework. The default is true.

[Visual Basic]
<FrameworkConfigurable(Name:="supportsrcw", Required:=False, ExpandProperties:=True)>
Public Property SupportsRcw As Boolean
[C#]
[FrameworkConfigurable(Name="supportsrcw", Required=False, ExpandProperties=True)]
public bool SupportsRcw {get; set;}

See Also

AxImpTask Class | NAnt.Win32.Tasks Namespace


AxImpTask Methods

The methods of the AxImpTask class are listed below. For a complete list of AxImpTask class members, see the AxImpTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Import the ActiveX control.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines whether the assembly needs to be created again.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

AxImpTask Class | NAnt.Win32.Tasks Namespace


AxImpTask.ExecuteTask Method

Import the ActiveX control.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

AxImpTask Class | NAnt.Win32.Tasks Namespace


AxImpTask.NeedsCompiling Method

Determines whether the assembly needs to be created again.

[Visual Basic]
Overridable Protected Function NeedsCompiling() As Boolean
[C#]
protected virtual bool NeedsCompiling();

Return Value

true if the assembly needs to be created again; otherwise, false.

See Also

AxImpTask Class | NAnt.Win32.Tasks Namespace


ReadRegistryTask Class

Reads a value or set of values from the Windows Registry into one or more NAnt properties.

For a list of all members of this type, see ReadRegistryTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Win32.Tasks.ReadRegistryTask

[Visual Basic]
<TaskName(Name:="readregistry")>
Public Class ReadRegistryTask
Inherits Task
[C#]
[TaskName(Name="readregistry")]
public class ReadRegistryTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Read a single value from the registry.

            <readregistry property="sdkRoot" key="SOFTWARE\Microsoft\.NETFramework\sdkInstallRoot" hive="LocalMachine" />

Read all the registry values in a key.

            <readregistry prefix="dotNetFX" key="SOFTWARE\Microsoft\.NETFramework\sdkInstallRoot" hive="LocalMachine" />

Requirements

Namespace: NAnt.Win32.Tasks

Assembly: NAnt.Win32Tasks (in NAnt.Win32Tasks.dll)

See Also

ReadRegistryTask Members | NAnt.Win32.Tasks Namespace


ReadRegistryTask Members

ReadRegistryTask overview

Public Instance Constructors

ReadRegistryTask Constructor Initializes a new instance of the ReadRegistryTask class.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PropertyName | The property to set to the specified registry key value. If this attribute is used then a single value will be read.
PropertyPrefix | The prefix to use for the specified registry key values. If this attribute is used then all registry values will be read and stored as properties with this prefix.
RegistryHiveName | Space separated list of registry hives to search for RegistryKey. For a list of possible values, see RegistryHive. The default is LocalMachine.
RegistryKey | The registry key to read, including the path.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | read the specified registry value
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
GetHiveKey | Returns the key for a given registry hive.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
LookupRegKey | Returns the hive for a given key.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReadRegistryTask Class | NAnt.Win32.Tasks Namespace


ReadRegistryTask Constructor

Initializes a new instance of the ReadRegistryTask class.

[Visual Basic]
Public Sub New()
[C#]
public ReadRegistryTask();

See Also

ReadRegistryTask Class | NAnt.Win32.Tasks Namespace


ReadRegistryTask Properties

The properties of the ReadRegistryTask class are listed below. For a complete list of ReadRegistryTask class members, see the ReadRegistryTask Members topic.

Public Instance Properties

FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Parent (inherited from Element) | Gets or sets the parent of the element.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PropertyName | The property to set to the specified registry key value. If this attribute is used then a single value will be read.
PropertyPrefix | The prefix to use for the specified registry key values. If this attribute is used then all registry values will be read and stored as properties with this prefix.
RegistryHiveName | Space separated list of registry hives to search for RegistryKey. For a list of possible values, see RegistryHive. The default is LocalMachine.
RegistryKey | The registry key to read, including the path.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

ReadRegistryTask Class | NAnt.Win32.Tasks Namespace


PropertyName Property

NAnt SDK Documentation - v0.91

ReadRegistryTask.PropertyName Property

The property to set to the specified registry key value.

If this attribute is used then a single value will be read.

[Visual Basic]
<TaskAttribute(Name:="property", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property PropertyName As String
[C#]
[TaskAttribute(Name="property", Required=False, ExpandProperties=True, ProcessXml=True)]
public virtual string PropertyName {get; set;}

See Also

ReadRegistryTask Class | NAnt.Win32.Tasks Namespace


PropertyPrefix Property

NAnt SDK Documentation - v0.91

ReadRegistryTask.PropertyPrefix Property

The prefix to use for the specified registry key values.

If this attribute is used then all registry values will be read and stored as properties with this prefix.

[Visual Basic]
<TaskAttribute(Name:="prefix", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property PropertyPrefix As String
[C#]
[TaskAttribute(Name="prefix", Required=False, ExpandProperties=True, ProcessXml=True)]
public virtual string PropertyPrefix {get; set;}

Example

Registry values a, b, c will be turned into prefixa, prefixb, prefixc named properties

See Also

ReadRegistryTask Class | NAnt.Win32.Tasks Namespace


RegistryHiveName Property

NAnt SDK Documentation - v0.91

ReadRegistryTask.RegistryHiveName Property

Space separated list of registry hives to search for RegistryKey. For a list of possible values, see RegistryHive. The default is LocalMachine.

[Visual Basic]
<TaskAttribute(Name:="hive", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Overridable Public Property RegistryHiveName As String
[C#]
[TaskAttribute(Name="hive", Required=False, ExpandProperties=True, ProcessXml=True)]
public virtual string RegistryHiveName {get; set;}

Remarks

See Also

ReadRegistryTask Class | NAnt.Win32.Tasks Namespace | RegistryHive


RegistryKey Property

NAnt SDK Documentation - v0.91

ReadRegistryTask.RegistryKey Property

The registry key to read, including the path.

[Visual Basic]
<TaskAttribute(Name:="key", Required:=True, ExpandProperties:=True, ProcessXml:=True), _ StringValidator(AllowEmpty:=False, Expression:="null", ExpressionErrorMessage:="null")>
Overridable Public Property RegistryKey As String
[C#]
[TaskAttribute(Name="key", Required=True, ExpandProperties=True, ProcessXml=True)]
[StringValidator(AllowEmpty=False, Expression="null", ExpressionErrorMessage="null")]
public virtual string RegistryKey {get; set;}

Example

SOFTWARE\Microsoft\.NETFramework\sdkInstallRoot

See Also

ReadRegistryTask Class | NAnt.Win32.Tasks Namespace


ReadRegistryTask Methods

The methods of the ReadRegistryTask class are listed below. For a complete list of ReadRegistryTask class members, see the ReadRegistryTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | read the specified registry value
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
GetHiveKey | Returns the key for a given registry hive.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
LookupRegKey | Returns the hive for a given key.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReadRegistryTask Class | NAnt.Win32.Tasks Namespace


ReadRegistryTask.ExecuteTask Method

read the specified registry value

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

ReadRegistryTask Class | NAnt.Win32.Tasks Namespace


ReadRegistryTask.GetHiveKey Method

Returns the key for a given registry hive.

[Visual Basic]
Protected Function GetHiveKey( _
ByVal hive As RegistryHive _
) As RegistryKey
[C#]
protected RegistryKey GetHiveKey(
RegistryHive hive
);

Parameters

hive
The registry hive to return the key for.

Return Value

The key for a given registry hive.

See Also

ReadRegistryTask Class | NAnt.Win32.Tasks Namespace


ReadRegistryTask.LookupRegKey Method

Returns the hive for a given key.

[Visual Basic]
Protected Function LookupRegKey( _
ByVal key As String, _
ByVal registries As RegistryHive() _
) As RegistryKey
[C#]
protected RegistryKey LookupRegKey(
string key,
RegistryHive[] registries
);

Parameters

key
registries

Return Value

The hive for a given key.

See Also

ReadRegistryTask Class | NAnt.Win32.Tasks Namespace


RegAsmTask Class

Registers an assembly, or set of assemblies for use from COM clients.

For a list of all members of this type, see RegAsmTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.Win32.Tasks.RegAsmTask

[Visual Basic]
<TaskName(Name:="regasm"), _ ProgramLocation(LocationType:=LocationType.FrameworkDir)>
Public Class RegAsmTask
Inherits ExternalProgramBase
[C#]
[TaskName(Name="regasm")]
[ProgramLocation(LocationType=LocationType.FrameworkDir)]
public class RegAsmTask : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Refer to the Regasm documentation for more information on the regasm tool.

Example

Register types in a single assembly.

            <regasm assembly="myAssembly.dll" />

Register types of an assembly and generate a type library containing definitions of accessible types defined within the assembly.

            <regasm assembly="myAssembly.dll" typelib="myAssembly.tlb" />

Register types of set of assemblies at once, while specifying a set of reference assemblies.

            <regasm codebase="true">
                <assemblies>
                    <include name="OutlookAddin.dll" />
                    <include name="OfficeCoreAddin.dll" />
                </assemblies>
                <references>
                    <include name="CommonTypes.dll" />
                </references>
            </regasm>

Requirements

Namespace: NAnt.Win32.Tasks

Assembly: NAnt.Win32Tasks (in NAnt.Win32Tasks.dll)

See Also

RegAsmTask Members | NAnt.Win32.Tasks Namespace


RegAsmTask Members

RegAsmTask overview

Public Instance Constructors

RegAsmTask Constructor Initializes a new instance of the RegAsmTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
Assemblies | The set of assemblies to register, or unregister.
AssemblyFile | The name of the file to register. This is provided as an alternate to using the task's Assemblies.
BaseDirectory | Gets the working directory for the application.
CodeBase | Set the code base registry setting.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command line arguments for the external program.
ProgramFileName | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
References | The set of assembly references.
Registered | Only refer to already registered type libraries.
RegistryFile | Registry file to export to instead of entering the types directly into the registry.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
TypeLib | Export the assemblies to the specified type library and register it.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Unregister | Unregister the assembly. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Registers or unregisters a single assembly, or a group of assemblies.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

RegAsmTask Class | NAnt.Win32.Tasks Namespace


RegAsmTask Constructor

Initializes a new instance of the RegAsmTask class.

[Visual Basic]
Public Sub New()
[C#]
public RegAsmTask();

See Also

RegAsmTask Class | NAnt.Win32.Tasks Namespace


RegAsmTask Properties

The properties of the RegAsmTask class are listed below. For a complete list of RegAsmTask class members, see the RegAsmTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
Assemblies | The set of assemblies to register, or unregister.
AssemblyFile | The name of the file to register. This is provided as an alternate to using the task's Assemblies.
BaseDirectory | Gets the working directory for the application.
CodeBase | Set the code base registry setting.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command line arguments for the external program.
ProgramFileName | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
References | The set of assembly references.
Registered | Only refer to already registered type libraries.
RegistryFile | Registry file to export to instead of entering the types directly into the registry.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
TypeLib | Export the assemblies to the specified type library and register it.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Unregister | Unregister the assembly. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

RegAsmTask Class | NAnt.Win32.Tasks Namespace


Assemblies Property

NAnt SDK Documentation - v0.91

RegAsmTask.Assemblies Property

The set of assemblies to register, or unregister.

[Visual Basic]
<BuildElement(Required:=False, Name:="assemblies", ProcessXml:=True)>
Public Property Assemblies As AssemblyFileSet
[C#]
[BuildElement(Required=False, Name="assemblies", ProcessXml=True)]
public NAnt.DotNet.Types.AssemblyFileSet Assemblies {get; set;}

See Also

RegAsmTask Class | NAnt.Win32.Tasks Namespace


AssemblyFile Property

NAnt SDK Documentation - v0.91

RegAsmTask.AssemblyFile Property

The name of the file to register. This is provided as an alternate to using the task's Assemblies.

[Visual Basic]
<TaskAttribute(Name:="assembly", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property AssemblyFile As FileInfo
[C#]
[TaskAttribute(Name="assembly", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo AssemblyFile {get; set;}

See Also

RegAsmTask Class | NAnt.Win32.Tasks Namespace


BaseDirectory Property

NAnt SDK Documentation - v0.91

RegAsmTask.BaseDirectory Property

Gets the working directory for the application.

[Visual Basic]
Overrides Public Property BaseDirectory As DirectoryInfo
[C#]
public override System.IO.DirectoryInfo BaseDirectory {get; set;}

Property Value

The working directory for the application.

See Also

RegAsmTask Class | NAnt.Win32.Tasks Namespace


CodeBase Property

NAnt SDK Documentation - v0.91

RegAsmTask.CodeBase Property

Set the code base registry setting.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="codebase", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property CodeBase As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="codebase", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool CodeBase {get; set;}

See Also

RegAsmTask Class | NAnt.Win32.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

RegAsmTask.ProgramArguments Property

Gets the command line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

Property Value

The command line arguments for the external program.

See Also

RegAsmTask Class | NAnt.Win32.Tasks Namespace


ProgramFileName Property

NAnt SDK Documentation - v0.91

RegAsmTask.ProgramFileName Property

Gets the filename of the external program to start.

[Visual Basic]
Overrides Public ReadOnly Property ProgramFileName As String
[C#]
public override string ProgramFileName {get;}

Property Value

The filename of the external program.

Remarks

Override in derived classes to explicitly set the location of the external tool.

See Also

RegAsmTask Class | NAnt.Win32.Tasks Namespace


References Property

NAnt SDK Documentation - v0.91

RegAsmTask.References Property

The set of assembly references.

[Visual Basic]
<BuildElement(Required:=False, Name:="references", ProcessXml:=True)>
Public Property References As AssemblyFileSet
[C#]
[BuildElement(Required=False, Name="references", ProcessXml=True)]
public NAnt.DotNet.Types.AssemblyFileSet References {get; set;}

See Also

RegAsmTask Class | NAnt.Win32.Tasks Namespace


Registered Property

NAnt SDK Documentation - v0.91

RegAsmTask.Registered Property

Only refer to already registered type libraries.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="registered", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Registered As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="registered", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool Registered {get; set;}

See Also

RegAsmTask Class | NAnt.Win32.Tasks Namespace


RegistryFile Property

NAnt SDK Documentation - v0.91

RegAsmTask.RegistryFile Property

Registry file to export to instead of entering the types directly into the registry.

[Visual Basic]
<TaskAttribute(Name:="regfile", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property RegistryFile As FileInfo
[C#]
[TaskAttribute(Name="regfile", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo RegistryFile {get; set;}

See Also

RegAsmTask Class | NAnt.Win32.Tasks Namespace


TypeLib Property

NAnt SDK Documentation - v0.91

RegAsmTask.TypeLib Property

Export the assemblies to the specified type library and register it.

[Visual Basic]
<TaskAttribute(Name:="typelib", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property TypeLib As FileInfo
[C#]
[TaskAttribute(Name="typelib", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo TypeLib {get; set;}

See Also

RegAsmTask Class | NAnt.Win32.Tasks Namespace


Unregister Property

NAnt SDK Documentation - v0.91

RegAsmTask.Unregister Property

Unregister the assembly. The default is false.

[Visual Basic]
<TaskAttribute(Name:="unregister", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property Unregister As Boolean
[C#]
[TaskAttribute(Name="unregister", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool Unregister {get; set;}

See Also

RegAsmTask Class | NAnt.Win32.Tasks Namespace


RegAsmTask Methods

The methods of the RegAsmTask class are listed below. For a complete list of RegAsmTask class members, see the RegAsmTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Registers or unregisters a single assembly, or a group of assemblies.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareProcess | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

RegAsmTask Class | NAnt.Win32.Tasks Namespace


RegAsmTask.ExecuteTask Method

Registers or unregisters a single assembly, or a group of assemblies.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

RegAsmTask Class | NAnt.Win32.Tasks Namespace


RegAsmTask.PrepareProcess Method

Updates the ProcessStartInfo of the specified Process.

[Visual Basic]
Overrides Protected Sub PrepareProcess( _
ByVal process As Process _
)
[C#]
protected override void PrepareProcess(
Process process
);

Parameters

process
The Process of which the ProcessStartInfo should be updated.

See Also

RegAsmTask Class | NAnt.Win32.Tasks Namespace


TlbExpTask Class

Exports a .NET assembly to a type library that can be used from unmanaged code (wraps Microsoft's tlbexp.exe).

For a list of all members of this type, see TlbExpTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.Win32.Tasks.TlbExpTask

[Visual Basic]
<TaskName(Name:="tlbexp"), _ ProgramLocation(LocationType:=LocationType.FrameworkSdkDir)>
Public Class TlbExpTask
Inherits ExternalProgramBase
[C#]
[TaskName(Name="tlbexp")]
[ProgramLocation(LocationType=LocationType.FrameworkSdkDir)]
public class TlbExpTask : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

Example

Export DotNetAssembly.dll to LegacyCOM.dll.

            <tlbexp assembly="DotNetAssembly.dll" output="LegacyCOM.dll" />

Requirements

Namespace: NAnt.Win32.Tasks

Assembly: NAnt.Win32Tasks (in NAnt.Win32Tasks.dll)

See Also

TlbExpTask Members | NAnt.Win32.Tasks Namespace


TlbExpTask Members

TlbExpTask overview

Public Instance Constructors

TlbExpTask Constructor Initializes a new instance of the TlbExpTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
AssemblyFile | Specifies the assembly for which to export a type library.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamesFile | Specifies the file used to determine capitalization of names in a type library.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | Specifies the name of the type library file to generate.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Exports the type library.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines whether the assembly needs to be exported to a type library again.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

TlbExpTask Class | NAnt.Win32.Tasks Namespace


TlbExpTask Constructor

Initializes a new instance of the TlbExpTask class.

[Visual Basic]
Public Sub New()
[C#]
public TlbExpTask();

See Also

TlbExpTask Class | NAnt.Win32.Tasks Namespace


TlbExpTask Properties

The properties of the TlbExpTask class are listed below. For a complete list of TlbExpTask class members, see the TlbExpTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
AssemblyFile | Specifies the assembly for which to export a type library.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
NamesFile | Specifies the file used to determine capitalization of names in a type library.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | Specifies the name of the type library file to generate.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
ProgramArguments | Gets the command line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

TlbExpTask Class | NAnt.Win32.Tasks Namespace


AssemblyFile Property

NAnt SDK Documentation - v0.91

TlbExpTask.AssemblyFile Property

Specifies the assembly for which to export a type library.

[Visual Basic]
<TaskAttribute(Name:="assembly", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property AssemblyFile As FileInfo
[C#]
[TaskAttribute(Name="assembly", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo AssemblyFile {get; set;}

Property Value

The assembly for which to export a type library.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

TlbExpTask Class | NAnt.Win32.Tasks Namespace


NamesFile Property

NAnt SDK Documentation - v0.91

TlbExpTask.NamesFile Property

Specifies the file used to determine capitalization of names in a type library.

[Visual Basic]
<TaskAttribute(Name:="names", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property NamesFile As FileInfo
[C#]
[TaskAttribute(Name="names", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo NamesFile {get; set;}

Property Value

The file used to determine capitalization of names in a type library.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

TlbExpTask Class | NAnt.Win32.Tasks Namespace


OutputFile Property

NAnt SDK Documentation - v0.91

TlbExpTask.OutputFile Property

Specifies the name of the type library file to generate.

[Visual Basic]
<TaskAttribute(Name:="output", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property OutputFile As FileInfo
[C#]
[TaskAttribute(Name="output", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo OutputFile {get; set;}

Property Value

The name of the type library file to generate.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

TlbExpTask Class | NAnt.Win32.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

TlbExpTask.ProgramArguments Property

Gets the command line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

Property Value

The command line arguments for the external program.

See Also

TlbExpTask Class | NAnt.Win32.Tasks Namespace


TlbExpTask Methods

The methods of the TlbExpTask class are listed below. For a complete list of TlbExpTask class members, see the TlbExpTask Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Exports the type library.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines whether the assembly needs to be exported to a type library again.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

TlbExpTask Class | NAnt.Win32.Tasks Namespace


TlbExpTask.ExecuteTask Method

Exports the type library.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

TlbExpTask Class | NAnt.Win32.Tasks Namespace


TlbExpTask.NeedsCompiling Method

Determines whether the assembly needs to be exported to a type library again.

[Visual Basic]
Overridable Protected Function NeedsCompiling() As Boolean
[C#]
protected virtual bool NeedsCompiling();

Return Value

true if the assembly needs to be exported to a type library; otherwise, false.

See Also

TlbExpTask Class | NAnt.Win32.Tasks Namespace


TlbImpTask Class

Imports a type library to a .NET assembly (wraps Microsoft's tlbimp.exe).

For a list of all members of this type, see TlbImpTask Members.

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.Win32.Tasks.TlbImpTask

[Visual Basic]
<ProgramLocation(LocationType:=LocationType.FrameworkSdkDir), _ TaskName(Name:="tlbimp")>
Public Class TlbImpTask
Inherits ExternalProgramBase
[C#]
[ProgramLocation(LocationType=LocationType.FrameworkSdkDir)]
[TaskName(Name="tlbimp")]
public class TlbImpTask : ExternalProgramBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This task lets you easily create interop assemblies. By default, it will not reimport if the underlying COM TypeLib or reference has not changed.

See the Microsoft.NET Framework SDK documentation for details.

Example

Import LegacyCOM.dll to DotNetAssembly.dll.

            <tlbimp typelib="LegacyCOM.dll" output="DotNetAssembly.dll" />

Generate an assembly named "Interop.MSVidCtlLib.dll" for the MS Video Control 1.0 Type Library, transforming any [out, retval] parameters of methods on dispinterfaces in the type library into return values in the managed library.

            <tlbimp typelib="msvidctl.dll" output="Interop.MSVidCtlLib.dll" transform="dispret">
                <references basedir="Interop">
                    <include name="Interop.TunerLib.dll" />
                </references>
            </tlbimp>

Requirements

Namespace: NAnt.Win32.Tasks

Assembly: NAnt.Win32Tasks (in NAnt.Win32Tasks.dll)

See Also

TlbImpTask Members | NAnt.Win32.Tasks Namespace


TlbImpTask Members

TlbImpTask overview

Public Static (Shared) Methods

ExtractTypeLibPath Returns the path of the type library, removing the identifier of the type library from the specified string.

Public Instance Constructors

TlbImpTask Constructor Initializes a new instance of the TlbImpTask class.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
AsmVersion | Specifies the version number of the assembly to produce.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
DelaySign | Specifies whether the resulting assembly should be signed with a strong name using delayed signing. The default is false.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
KeyContainer | Specifies the key container in which the public/private key pair should be found that should be used to sign the resulting assembly with a strong name.
KeyFile | Specifies the publisher's official public/private key pair with which the resulting assembly should be signed with a strong name.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
Namespace | Specifies the namespace in which to produce the assembly.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | Specifies the name of the output file.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
Primary | Specifies whether a primary interop assembly should be produced for the specified type library. The default is false.
ProgramArguments | Gets the command line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PublicKeyFile | Specifies the file containing the public key to use to sign the resulting assembly.
References | Specifies the assembly files to use to resolve references to types defined outside the current type library.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
StrictRef | Specifies whether a type library should not be imported if all references within the current assembly or the reference assemblies cannot be resolved. The default is false.
SupportsTransform | Indicates whether tlbimp supports transforming metadata for a given target framework. The default is true.
SysArray | Specifies whether to import a COM style SafeArray as a managed Array class type. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
Transform | Specifies how to transform the metadata [.NET 1.1 or higher].
TypeLib | Specifies the source type library that gets passed to the type library importer.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Unsafe | Specifies whether interfaces should be produced without .NET Framework security checks. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Imports the type library to a .NET assembly.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines whether the type library needs to be imported again.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


TlbImpTask Constructor

Initializes a new instance of the TlbImpTask class.

[Visual Basic]
Public Sub New()
[C#]
public TlbImpTask();

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


TlbImpTask Properties

The properties of the TlbImpTask class are listed below. For a complete list of TlbImpTask class members, see the TlbImpTask Members topic.

Public Instance Properties

Arguments (inherited from ExternalProgramBase) | The command-line arguments for the external program.
AsmVersion | Specifies the version number of the assembly to produce.
BaseDirectory (inherited from ExternalProgramBase) | Gets the working directory for the application.
CommandLine (inherited from ExternalProgramBase) | Gets the command-line arguments, separated by spaces.
DelaySign | Specifies whether the resulting assembly should be signed with a strong name using delayed signing. The default is false.
ErrorWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which error output of the external program will be written.
ExeName (inherited from ExternalProgramBase) | The name of the executable that should be used to launch the external program.
ExitCode (inherited from ExternalProgramBase) | Gets the value that the process specified when it terminated.
FailOnError (inherited from Task) | Determines if task failure stops the build, or is just reported. The default is true.
IfDefined (inherited from Task) | If true then the task will be executed; otherwise, skipped. The default is true.
KeyContainer | Specifies the key container in which the public/private key pair should be found that should be used to sign the resulting assembly with a strong name.
KeyFile | Specifies the publisher's official public/private key pair with which the resulting assembly should be signed with a strong name.
LogPrefix (inherited from Task) | Obsolete. The prefix used when sending messages to the log.
Managed (inherited from ExternalProgramBase) | Specifies whether the external program should be treated as a managed application, possibly forcing it to be executed under the currently targeted version of the CLR.
Name (inherited from Task) | The name of the task.
Namespace | Specifies the namespace in which to produce the assembly.
NamespaceManager (inherited from Element) | Gets or sets the XmlNamespaceManager.
Output (inherited from ExternalProgramBase) | Gets the file to which the standard output should be redirected.
OutputAppend (inherited from ExternalProgramBase) | Gets a value indicating whether output will be appended to the Output.
OutputFile | Specifies the name of the output file.
OutputWriter (inherited from ExternalProgramBase) | Gets or sets the TextWriter to which standard output messages of the external program will be written.
Parent (inherited from Element) | Gets or sets the parent of the element.
Primary | Specifies whether a primary interop assembly should be produced for the specified type library. The default is false.
ProgramArguments | Gets the command line arguments for the external program.
ProgramFileName (inherited from ExternalProgramBase) | Gets the filename of the external program to start.
Project (inherited from Element) | Gets or sets the Project to which this element belongs.
Properties (inherited from Element) | Gets the properties local to this Element and the Project.
PublicKeyFile | Specifies the file containing the public key to use to sign the resulting assembly.
References | Specifies the assembly files to use to resolve references to types defined outside the current type library.
Spawn (inherited from ExternalProgramBase) | Gets or sets a value indicating whether the application should be spawned. If you spawn an application, its output will not be logged by NAnt. The default is false.
StrictRef | Specifies whether a type library should not be imported if all references within the current assembly or the reference assemblies cannot be resolved. The default is false.
SupportsTransform | Indicates whether tlbimp supports transforming metadata for a given target framework. The default is true.
SysArray | Specifies whether to import a COM style SafeArray as a managed Array class type. The default is false.
Threshold (inherited from Task) | Gets or sets the log threshold for this Task. By default the threshold of a task is Debug, causing no messages to be filtered in the task itself.
TimeOut (inherited from ExternalProgramBase) | The maximum amount of time the application is allowed to execute, expressed in milliseconds. Defaults to no time-out.
Transform | Specifies how to transform the metadata [.NET 1.1 or higher].
TypeLib | Specifies the source type library that gets passed to the type library importer.
UnlessDefined (inherited from Task) | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false.
Unsafe | Specifies whether interfaces should be produced without .NET Framework security checks. The default is false.
UseRuntimeEngine (inherited from ExternalProgramBase) | Obsolete. Specifies whether the external program is a managed application which should be executed using a runtime engine, if configured. The default is false.
Verbose (inherited from Task) | Determines whether the task should report detailed build log messages. The default is false.

Protected Instance Properties

CustomXmlProcessing (inherited from Element) | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element.
Location (inherited from Element) | Gets or sets the location in the build file where the element is defined.
ProcessId (inherited from ExternalProgramBase) | Gets the unique identifier for the spawned application.
XmlNode (inherited from Element) | Gets or sets the XML node of the element.

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


AsmVersion Property

NAnt SDK Documentation - v0.91

TlbImpTask.AsmVersion Property

Specifies the version number of the assembly to produce.

[Visual Basic]
<TaskAttribute(Name:="asmversion", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property AsmVersion As String
[C#]
[TaskAttribute(Name="asmversion", Required=False, ExpandProperties=True, ProcessXml=True)]
public string AsmVersion {get; set;}

Remarks

The version number of the assembly to produce.

The version number should be in the format major.minor.build.revision.

See the Microsoft.NET Framework SDK documentation for details.

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


DelaySign Property

NAnt SDK Documentation - v0.91

TlbImpTask.DelaySign Property

Specifies whether the resulting assembly should be signed with a strong name using delayed signing. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="delaysign", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property DelaySign As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="delaysign", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool DelaySign {get; set;}

Property Value

true if the resulting assembly should be signed with a strong name using delayed signing; otherwise, false.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


KeyContainer Property

NAnt SDK Documentation - v0.91

TlbImpTask.KeyContainer Property

Specifies the key container in which the public/private key pair should be found that should be used to sign the resulting assembly with a strong name.

[Visual Basic]
<TaskAttribute(Name:="keycontainer", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property KeyContainer As String
[C#]
[TaskAttribute(Name="keycontainer", Required=False, ExpandProperties=True, ProcessXml=True)]
public string KeyContainer {get; set;}

Property Value

The key container containing a public/private key pair that should be used to sign the resulting assembly.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


KeyFile Property

NAnt SDK Documentation - v0.91

TlbImpTask.KeyFile Property

Specifies the publisher's official public/private key pair with which the resulting assembly should be signed with a strong name.

[Visual Basic]
<TaskAttribute(Name:="keyfile", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property KeyFile As FileInfo
[C#]
[TaskAttribute(Name="keyfile", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo KeyFile {get; set;}

Property Value

The keyfile to use to sign the resulting assembly with a strong name.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


Namespace Property

NAnt SDK Documentation - v0.91

TlbImpTask.Namespace Property

Specifies the namespace in which to produce the assembly.

[Visual Basic]
<TaskAttribute(Name:="namespace", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Namespace As String
[C#]
[TaskAttribute(Name="namespace", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Namespace {get; set;}

Property Value

The namespace in which to produce the assembly.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


OutputFile Property

NAnt SDK Documentation - v0.91

TlbImpTask.OutputFile Property

Specifies the name of the output file.

[Visual Basic]
<TaskAttribute(Name:="output", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property OutputFile As FileInfo
[C#]
[TaskAttribute(Name="output", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo OutputFile {get; set;}

Property Value

The name of the output file.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


Primary Property

NAnt SDK Documentation - v0.91

TlbImpTask.Primary Property

Specifies whether a primary interop assembly should be produced for the specified type library. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="primary", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Primary As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="primary", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool Primary {get; set;}

Property Value

true if a primary interop assembly should be produced; otherwise, false.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


ProgramArguments Property

NAnt SDK Documentation - v0.91

TlbImpTask.ProgramArguments Property

Gets the command line arguments for the external program.

[Visual Basic]
Overrides Public ReadOnly Property ProgramArguments As String
[C#]
public override string ProgramArguments {get;}

Property Value

The command line arguments for the external program.

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


PublicKeyFile Property

NAnt SDK Documentation - v0.91

TlbImpTask.PublicKeyFile Property

Specifies the file containing the public key to use to sign the resulting assembly.

[Visual Basic]
<TaskAttribute(Name:="publickey", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property PublicKeyFile As FileInfo
[C#]
[TaskAttribute(Name="publickey", Required=False, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo PublicKeyFile {get; set;}

Property Value

The file containing the public key to use to sign the resulting assembly.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


References Property

NAnt SDK Documentation - v0.91

TlbImpTask.References Property

Specifies the assembly files to use to resolve references to types defined outside the current type library.

[Visual Basic]
<BuildElement(Required:=False, Name:="references", ProcessXml:=True)>
Public Property References As AssemblyFileSet
[C#]
[BuildElement(Required=False, Name="references", ProcessXml=True)]
public NAnt.DotNet.Types.AssemblyFileSet References {get; set;}

Property Value

The assembly files to use to resolve references to types defined outside the current type library.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


StrictRef Property

NAnt SDK Documentation - v0.91

TlbImpTask.StrictRef Property

Specifies whether a type library should not be imported if all references within the current assembly or the reference assemblies cannot be resolved. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="strictref", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property StrictRef As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="strictref", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool StrictRef {get; set;}

Property Value

true if a type library should not be imported if all references cannot be resolved; otherwise, false.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


SupportsTransform Property

NAnt SDK Documentation - v0.91

TlbImpTask.SupportsTransform Property

Indicates whether tlbimp supports transforming metadata for a given target framework. The default is true.

[Visual Basic]
<FrameworkConfigurable(Name:="supportstransform", Required:=False, ExpandProperties:=True)>
Public Property SupportsTransform As Boolean
[C#]
[FrameworkConfigurable(Name="supportstransform", Required=False, ExpandProperties=True)]
public bool SupportsTransform {get; set;}

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


SysArray Property

NAnt SDK Documentation - v0.91

TlbImpTask.SysArray Property

Specifies whether to import a COM style SafeArray as a managed Array class type. The default is false.

[Visual Basic]
<TaskAttribute(Name:="sysarray", Required:=False, ExpandProperties:=True, ProcessXml:=True), _ BooleanValidator>
Public Property SysArray As Boolean
[C#]
[TaskAttribute(Name="sysarray", Required=False, ExpandProperties=True, ProcessXml=True)]
[BooleanValidator]
public bool SysArray {get; set;}

Property Value

true if a COM style SafeArray should be imported as a managed Array class type; otherwise, false.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


Transform Property

NAnt SDK Documentation - v0.91

TlbImpTask.Transform Property

Specifies how to transform the metadata [.NET 1.1 or higher].

[Visual Basic]
<TaskAttribute(Name:="transform", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Transform As String
[C#]
[TaskAttribute(Name="transform", Required=False, ExpandProperties=True, ProcessXml=True)]
public string Transform {get; set;}

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


TypeLib Property

NAnt SDK Documentation - v0.91

TlbImpTask.TypeLib Property

Specifies the source type library that gets passed to the type library importer.

[Visual Basic]
<TaskAttribute(Name:="typelib", Required:=True, ExpandProperties:=True, ProcessXml:=True)>
Public Property TypeLib As FileInfo
[C#]
[TaskAttribute(Name="typelib", Required=True, ExpandProperties=True, ProcessXml=True)]
public System.IO.FileInfo TypeLib {get; set;}

Property Value

The source type library that gets passed to the type library importer.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


Unsafe Property

NAnt SDK Documentation - v0.91

TlbImpTask.Unsafe Property

Specifies whether interfaces should be produced without .NET Framework security checks. The default is false.

[Visual Basic]
<BooleanValidator, _ TaskAttribute(Name:="unsafe", Required:=False, ExpandProperties:=True, ProcessXml:=True)>
Public Property Unsafe As Boolean
[C#]
[BooleanValidator]
[TaskAttribute(Name="unsafe", Required=False, ExpandProperties=True, ProcessXml=True)]
public bool Unsafe {get; set;}

Property Value

true if interfaces without .NET Framework security checks should be produced; otherwise, false.

Remarks

See the Microsoft.NET Framework SDK documentation for details.

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


TlbImpTask Methods

The methods of the TlbImpTask class are listed below. For a complete list of TlbImpTask class members, see the TlbImpTask Members topic.

Public Static (Shared) Methods

ExtractTypeLibPath Returns the path of the type library, removing the identifier of the type library from the specified string.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from Task) | Executes the task unless it is skipped.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetLocation (inherited from Element) | Retrieves the location in the build file where the element is defined.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Element) | Overloaded. Performs default initialization.
InitializeTaskConfiguration (inherited from Task) | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file.
IsLogEnabledFor (inherited from Task) | Determines whether build output is enabled for the given Level.
Log (inherited from Task) | Overloaded. Logs a message with the given priority.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo (inherited from Element) | Copies all instance data of the Element to a given Element.
ExecuteTask | Imports the type library to a .NET assembly.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAttributeConfigurationNode (inherited from Task) | Overloaded. Locates the XML node for the specified attribute in either the configuration section of the extension assembly or the.project.
GetAttributeConfigurationNode (inherited from Element) | Overloaded. Locates the XML node for the specified attribute in the project configuration node.
Initialize (inherited from Task) | Overloaded. Initializes the task.
InitializeElement (inherited from Element) | Obsolete. Derived classes should override to this method to provide extra initialization and validation not covered by the base class.
InitializeTask (inherited from Task) | Obsolete. Initializes the task.
InitializeXml (inherited from Element) | Initializes all build attributes and child elements.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedsCompiling | Determines whether the type library needs to be imported again.
PrepareProcess (inherited from ExternalProgramBase) | Updates the ProcessStartInfo of the specified Process.
StartProcess (inherited from ExternalProgramBase) | Starts the process and handles errors.

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


TlbImpTask.ExecuteTask Method

Imports the type library to a .NET assembly.

[Visual Basic]
Overrides Protected Sub ExecuteTask()
[C#]
protected override void ExecuteTask();

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


TlbImpTask.ExtractTypeLibPath Method

Returns the path of the type library, removing the identifier of the type library from the specified string.

[Visual Basic]
Public Shared Function ExtractTypeLibPath( _
ByVal path As String _
) As String
[C#]
public static string ExtractTypeLibPath(
string path
);

Parameters

path
The path from which to extract the path of the type library.

Return Value

The path of the type library without the type library identifier.

Remarks

An example of a path which includes the identifier of the type library (in this case "2") is C:\WINDOWS\system32\msvidctl.dll\2.

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


TlbImpTask.NeedsCompiling Method

Determines whether the type library needs to be imported again.

[Visual Basic]
Overridable Protected Function NeedsCompiling() As Boolean
[C#]
protected virtual bool NeedsCompiling();

Return Value

true if the type library needs to be imported; otherwise, false.

See Also

TlbImpTask Class | NAnt.Win32.Tasks Namespace


NAnt.Compression.TasksHierarchy

NAnt SDK Documentation - v0.91

NAnt.Compression.Tasks Hierarchy

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Compression.Tasks.ExpandBaseTask
NAnt.Compression.Tasks.UnTarTask
NAnt.Compression.Tasks.UnZipTask
NAnt.Compression.Tasks.GUnzip
NAnt.Compression.Tasks.TarTask
NAnt.Compression.Tasks.ZipTask

See Also

NAnt.Compression.Tasks Namespace


NAnt.Compression.TypesHierarchy

NAnt SDK Documentation - v0.91

NAnt.Compression.Types Hierarchy

System.Object
NAnt.Compression.Types.TarFileSetEnumerator ---- System.Collections.IEnumerator
NAnt.Compression.Types.ZipFileSetEnumerator ---- System.Collections.IEnumerator
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.Core.Types.FileSet
NAnt.Compression.Types.TarFileSet
NAnt.Compression.Types.ZipFileSet
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
NAnt.Compression.Types.TarFileSetCollection
NAnt.Compression.Types.ZipFileSetCollection
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
NAnt.Compression.Types.DuplicateHandling
NAnt.Compression.Types.TarCompressionMethod

See Also

NAnt.Compression.Types Namespace


NAnt.Core.AttributesHierarchy

NAnt SDK Documentation - v0.91

NAnt.Core.Attributes Hierarchy

System.Object
System.Attribute
NAnt.Core.Attributes.BuildAttributeAttribute
NAnt.Core.Attributes.TaskAttributeAttribute
NAnt.Core.Attributes.BuildElementAttribute
NAnt.Core.Attributes.BuildElementArrayAttribute
NAnt.Core.Attributes.BuildElementCollectionAttribute
NAnt.Core.Attributes.FileSetAttribute
NAnt.Core.Attributes.ElementNameAttribute
NAnt.Core.Attributes.TaskNameAttribute
NAnt.Core.Attributes.FrameworkConfigurableAttribute
NAnt.Core.Attributes.FunctionAttribute
NAnt.Core.Attributes.FunctionSetAttribute
NAnt.Core.Attributes.ProgramLocationAttribute
NAnt.Core.Attributes.ValidatorAttribute
NAnt.Core.Attributes.BooleanValidatorAttribute
NAnt.Core.Attributes.DateTimeValidatorAttribute
NAnt.Core.Attributes.Int32ValidatorAttribute
NAnt.Core.Attributes.StringValidatorAttribute
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
NAnt.Core.Attributes.LocationType

See Also

NAnt.Core.Attributes Namespace


DataTypeBase Hierarchy

System.Object
Element
DataTypeBase
FilterChain
Credential
FileSet
PathSet
PatternSet
Proxy
DataTypeCollectionBase
ModuleSet
WarningAsError
Categories

See Also

DataTypeBase Class | DataTypeBase Members | NAnt.Core Namespace


Element Hierarchy

System.Object
Element
DataTypeBase
ChainableReader
Target
Task
InElement
Argument
EnvironmentSet
EnvironmentVariable
Exclude
ExcludesFile
Formatter
Option
PathElement
Pattern
RawXml
Token
XmlNamespace
XsltExtensionObject
XsltParameter
AssemblyAttribute
CompilerWarning
Module
NamespaceImport
Package
FormatterElement
NUnitTest
Category
NUnit2Test
Library
Symbol
WebMap

See Also

Element Class | Element Members | NAnt.Core Namespace


NAnt.Core.ExtensibilityHierarchy

NAnt SDK Documentation - v0.91

NAnt.Core.Extensibility Hierarchy

System.Object
NAnt.Core.Extensibility.ExtensionBuilder
NAnt.Core.Extensibility.IPlugin
NAnt.Core.Extensibility.IPluginConsumer
System.Attribute
NAnt.Core.Extensibility.PluginConsumerAttribute

See Also

NAnt.Core.Extensibility Namespace


NAnt.Core.FiltersHierarchy

NAnt SDK Documentation - v0.91

NAnt.Core.Filters Hierarchy

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.Core.Filters.FilterChain
NAnt.Core.Filters.ChainableReader ---- System.IDisposable
NAnt.Core.Filters.Filter
NAnt.Core.Filters.ExpandProperties
NAnt.Core.Filters.ReplaceString
NAnt.Core.Filters.ReplaceTokens
NAnt.Core.Filters.TabsToSpaces
NAnt.Core.Element.AttributeConfigurator
NAnt.Core.Filters.FilterChain.FilterChainConfigurator
NAnt.Core.Extensibility.ExtensionBuilder
NAnt.Core.Filters.FilterBuilder
NAnt.Core.Filters.FilterBuilderEnumerator ---- System.Collections.IEnumerator
NAnt.Core.Filters.FilterEnumerator ---- System.Collections.IEnumerator
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
NAnt.Core.Filters.FilterBuilderCollection
NAnt.Core.Filters.FilterCollection

See Also

NAnt.Core.Filters Namespace


FunctionSetBase Hierarchy

System.Object
FunctionSetBase
AssemblyFunctions
AssemblyNameFunctions
BooleanConversionFunctions
ConversionFunctions
DateTimeConversionFunctions
DateTimeFunctions
DirectoryFunctions
DnsFunctions
DoubleConversionFunctions
EnvironmentFunctions
FileFunctions
FileVersionInfoFunctions
FrameworkFunctions
Int32ConversionFunctions
Int64ConversionFunctions
MathFunctions
NAntFunctions
OperatingSystemFunctions
PathFunctions
PkgConfigFunctions
PlatformFunctions
ProjectFunctions
PropertyFunctions
StringFunctions
TargetFunctions
TaskFunctions
TimeSpanConversionFunctions
TimeSpanFunctions
VersionConversionFunctions
VersionFunctions
CygpathFunctions

See Also

FunctionSetBase Class | FunctionSetBase Members | NAnt.Core Namespace


NAnt.Core.FunctionsHierarchy

NAnt SDK Documentation - v0.91

NAnt.Core.Functions Hierarchy

System.Object
NAnt.Core.FunctionSetBase
NAnt.Core.Functions.AssemblyFunctions
NAnt.Core.Functions.AssemblyNameFunctions
NAnt.Core.Functions.BooleanConversionFunctions
NAnt.Core.Functions.ConversionFunctions
NAnt.Core.Functions.DateTimeConversionFunctions
NAnt.Core.Functions.DateTimeFunctions
NAnt.Core.Functions.DirectoryFunctions
NAnt.Core.Functions.DnsFunctions
NAnt.Core.Functions.DoubleConversionFunctions
NAnt.Core.Functions.EnvironmentFunctions
NAnt.Core.Functions.FileFunctions
NAnt.Core.Functions.FileVersionInfoFunctions
NAnt.Core.Functions.FrameworkFunctions
NAnt.Core.Functions.Int32ConversionFunctions
NAnt.Core.Functions.Int64ConversionFunctions
NAnt.Core.Functions.MathFunctions
NAnt.Core.Functions.NAntFunctions
NAnt.Core.Functions.OperatingSystemFunctions
NAnt.Core.Functions.PathFunctions
NAnt.Core.Functions.PkgConfigFunctions
NAnt.Core.Functions.PlatformFunctions
NAnt.Core.Functions.ProjectFunctions
NAnt.Core.Functions.PropertyFunctions
NAnt.Core.Functions.StringFunctions
NAnt.Core.Functions.TargetFunctions
NAnt.Core.Functions.TaskFunctions
NAnt.Core.Functions.TimeSpanConversionFunctions
NAnt.Core.Functions.TimeSpanFunctions
NAnt.Core.Functions.VersionConversionFunctions
NAnt.Core.Functions.VersionFunctions

See Also

NAnt.Core.Functions Namespace


Task Hierarchy

System.Object
Element
Task
ExpandBaseTask
GUnzip
TarTask
ZipTask
TaskContainer
AttribTask
AvailableTask
CallTask
CopyTask
DeleteTask
DescriptionTask
EchoTask
ExternalProgramBase
FailTask
GetTask
IncludeTask
LoadFileTask
LoadTasksTask
MailTask
MkDirTask
NAntSchemaTask
NAntTask
PropertyTask
RegexTask
SetEnvTask
SleepTask
StyleTask
SysInfoTask
TouchTask
TStampTask
UpToDateTask
XmlPeekTask
XmlPokeTask
AssemblyInfoTask
NDocTask
ScriptTask
ServiceControllerTask
NUnitTask
NUnit2Task
CvsPass
SolutionTask
ReadRegistryTask

See Also

Task Class | Task Members | NAnt.Core Namespace


ExternalProgramBase Hierarchy

System.Object
Element
Task
ExternalProgramBase
ExecTask
AssemblyLinkerTask
CompilerBase
DelaySignTask
IlasmTask
LicenseTask
RegsvcsTask
ResGenTask
IldasmTask
AbstractSourceControlTask
ClTask
LibTask
LinkTask
McTask
MidlTask
RcTask
AxImpTask
RegAsmTask
TlbExpTask
TlbImpTask

See Also

ExternalProgramBase Class | ExternalProgramBase Members | NAnt.Core.Tasks Namespace


NAnt.Core.TasksHierarchy

NAnt SDK Documentation - v0.91

NAnt.Core.Tasks Hierarchy

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.TaskContainer
NAnt.Core.Tasks.IfTask
NAnt.Core.Tasks.IfNotTask
NAnt.Core.Tasks.LoopTask
NAnt.Core.Tasks.AttribTask
NAnt.Core.Tasks.AvailableTask
NAnt.Core.Tasks.CallTask
NAnt.Core.Tasks.CopyTask
NAnt.Core.Tasks.MoveTask
NAnt.Core.Tasks.DeleteTask
NAnt.Core.Tasks.DescriptionTask
NAnt.Core.Tasks.EchoTask
NAnt.Core.Tasks.ExternalProgramBase
NAnt.Core.Tasks.ExecTask
NAnt.Core.Tasks.FailTask
NAnt.Core.Tasks.GetTask
NAnt.Core.Tasks.IncludeTask
NAnt.Core.Tasks.LoadFileTask
NAnt.Core.Tasks.LoadTasksTask
NAnt.Core.Tasks.MailTask
NAnt.Core.Tasks.MkDirTask
NAnt.Core.Tasks.NAntSchemaTask
NAnt.Core.Tasks.NAntTask
NAnt.Core.Tasks.PropertyTask
NAnt.Core.Tasks.RegexTask
NAnt.Core.Tasks.SetEnvTask
NAnt.Core.Tasks.SleepTask
NAnt.Core.Tasks.StyleTask
NAnt.Core.Tasks.SysInfoTask
NAnt.Core.Tasks.TouchTask
NAnt.Core.Tasks.TStampTask
NAnt.Core.Tasks.UpToDateTask
NAnt.Core.Tasks.XmlPeekTask
NAnt.Core.Tasks.XmlPokeTask
NAnt.Core.Tasks.InElement
NAnt.Core.Tasks.CopyTask.FileDateInfo
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
NAnt.Core.Tasks.AvailableTask.ResourceType
NAnt.Core.Tasks.LoopTask.LoopItem
NAnt.Core.Tasks.LoopTask.LoopTrim

See Also

NAnt.Core.Tasks Namespace


FileSet Hierarchy

System.Object
Element
DataTypeBase
FileSet
TarFileSet
ZipFileSet
DirSet
AssemblyFileSet
LibDirectorySet
ResourceFileSet
CvsFileSet

See Also

FileSet Class | FileSet Members | NAnt.Core.Types Namespace | PatternSet


NAnt.Core.TypesHierarchy

NAnt SDK Documentation - v0.91

NAnt.Core.Types Hierarchy

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.Core.Types.Credential
NAnt.Core.Types.FileSet
NAnt.Core.Types.DirSet ---- System.ICloneable
NAnt.Core.Types.PathSet
NAnt.Core.Types.PatternSet
NAnt.Core.Types.Proxy
NAnt.Core.Types.Argument
NAnt.Core.Types.EnvironmentSet
NAnt.Core.Types.EnvironmentVariable
NAnt.Core.Types.FileSet.Exclude
NAnt.Core.Types.FileSet.Include
NAnt.Core.Types.FileSet.ExcludesFile
NAnt.Core.Types.FileSet.IncludesFile
NAnt.Core.Types.Formatter
NAnt.Core.Types.Option
NAnt.Core.Types.PathElement
NAnt.Core.Types.Pattern
NAnt.Core.Types.RawXml
NAnt.Core.Types.Token
NAnt.Core.Types.XmlNamespace
NAnt.Core.Types.XsltExtensionObject
NAnt.Core.Types.XsltParameter
NAnt.Core.Types.ArgumentEnumerator ---- System.Collections.IEnumerator
NAnt.Core.Types.EnvironmentVariableEnumerator ---- System.Collections.IEnumerator
NAnt.Core.Types.FormatterEnumerator ---- System.Collections.IEnumerator
NAnt.Core.Types.OptionEnumerator ---- System.Collections.IEnumerator
NAnt.Core.Types.PatternCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
NAnt.Core.Types.PatternEnumerator ---- System.Collections.IEnumerator
NAnt.Core.Types.XmlNamespaceEnumerator ---- System.Collections.IEnumerator
NAnt.Core.Types.XsltExtensionObjectEnumerator ---- System.Collections.IEnumerator
NAnt.Core.Types.XsltParameterEnumerator ---- System.Collections.IEnumerator
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
NAnt.Core.Types.ArgumentCollection
NAnt.Core.Types.EnvironmentVariableCollection
NAnt.Core.Types.FormatterCollection
NAnt.Core.Types.OptionCollection
NAnt.Core.Types.XmlNamespaceCollection
NAnt.Core.Types.XsltExtensionObjectCollection
NAnt.Core.Types.XsltParameterCollection
System.ComponentModel.TypeConverter
System.ComponentModel.EnumConverter
NAnt.Core.Types.ManagedExecutionConverter
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
NAnt.Core.Types.ManagedExecution

See Also

NAnt.Core.Types Namespace


NAnt.Core.UtilHierarchy

NAnt SDK Documentation - v0.91

NAnt.Core.Util Hierarchy

System.Object
NAnt.Core.Util.AssemblyResolver
NAnt.Core.Util.CommandLineArgument
NAnt.Core.Util.CommandLineArgumentEnumerator ---- System.Collections.IEnumerator
NAnt.Core.Util.CommandLineParser
NAnt.Core.Util.DateTimeProvider
NAnt.Core.Util.FileUtils
NAnt.Core.Util.GacCache ---- System.IDisposable
NAnt.Core.Util.ReflectionUtils
NAnt.Core.Util.ResourceUtils
NAnt.Core.Util.StopWatchStack
NAnt.Core.Util.StringUtils
System.Attribute
NAnt.Core.Util.CommandLineArgumentAttribute
NAnt.Core.Util.DefaultCommandLineArgumentAttribute
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
NAnt.Core.Util.CommandLineArgumentCollection
System.Exception ---- System.Runtime.Serialization.ISerializable
System.SystemException
System.ArgumentException
NAnt.Core.Util.CommandLineArgumentException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
NAnt.Core.Util.CommandLineArgumentTypes

See Also

NAnt.Core.Util Namespace


NAnt.CoreHierarchy

NAnt SDK Documentation - v0.91

NAnt.Core Hierarchy

System.Object
NAnt.Core.BuildListenerEnumerator ---- System.Collections.IEnumerator
NAnt.Core.BuildReport
NAnt.Core.CommandLineOptions
NAnt.Core.ConfigurationSection ---- System.Configuration.IConfigurationSectionHandler
NAnt.Core.ConsoleDriver
NAnt.Core.DataTypeBaseBuilderEnumerator ---- System.Collections.IEnumerator
NAnt.Core.DataTypeBaseDictionary ---- System.Collections.ICollection, System.Collections.IDictionary, System.Collections.IEnumerable, System.ICloneable
NAnt.Core.DataTypeBaseDictionaryEnumerator ---- System.Collections.IDictionaryEnumerator, System.Collections.IEnumerator
NAnt.Core.DefaultLogger ---- NAnt.Core.IBuildListener, NAnt.Core.IBuildLogger
NAnt.Core.MailLogger
NAnt.Core.DirectoryScanner ---- System.ICloneable
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.Core.Target ---- System.ICloneable
NAnt.Core.Task
NAnt.Core.TaskContainer
NAnt.Core.Element.AttributeConfigurator
NAnt.Core.ExpressionEvalBase
NAnt.Core.ExpressionEvaluator
NAnt.Core.ExpressionTokenizer
NAnt.Core.Extensibility.ExtensionBuilder
NAnt.Core.DataTypeBaseBuilder
NAnt.Core.TaskBuilder
NAnt.Core.FrameworkInfo ---- System.Runtime.Serialization.ISerializable
NAnt.Core.FrameworkInfoDictionary ---- System.Collections.ICollection, System.Collections.IDictionary, System.Collections.IEnumerable, System.ICloneable
NAnt.Core.FrameworkInfoDictionaryEnumerator ---- System.Collections.IDictionaryEnumerator, System.Collections.IEnumerator
NAnt.Core.FunctionSetBase
NAnt.Core.IBuildListener
NAnt.Core.IBuildLogger ---- NAnt.Core.IBuildListener
NAnt.Core.Location
NAnt.Core.PathScanner ---- System.ICloneable
NAnt.Core.PlatformHelper
NAnt.Core.Project
NAnt.Core.TaskBuilderEnumerator ---- System.Collections.IEnumerator
NAnt.Core.TypeFactory
NAnt.Core.XmlLogger ---- NAnt.Core.IBuildListener, NAnt.Core.IBuildLogger, System.Runtime.Serialization.ISerializable
System.Collections.ArrayList ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
NAnt.Core.TargetCollection
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
NAnt.Core.BuildListenerCollection
NAnt.Core.DataTypeBaseBuilderCollection
NAnt.Core.TaskBuilderCollection
System.Collections.DictionaryBase ---- System.Collections.ICollection, System.Collections.IDictionary, System.Collections.IEnumerable
NAnt.Core.PropertyDictionary
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
NAnt.Core.BuildEventHandler
System.EventArgs
NAnt.Core.BuildEventArgs
System.Exception ---- System.Runtime.Serialization.ISerializable
NAnt.Core.ExpressionParseException
System.ApplicationException
NAnt.Core.BuildException
NAnt.Core.ValidationException
System.MarshalByRefObject
System.IO.TextWriter ---- System.IDisposable
NAnt.Core.LogWriter
System.ValueType
NAnt.Core.ExpressionTokenizer.Position
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
NAnt.Core.ClrType
NAnt.Core.ExpressionTokenizer.TokenType
NAnt.Core.FrameworkTypes
NAnt.Core.Level
NAnt.Core.VendorType

See Also

NAnt.Core Namespace


NAnt.DotNet.TasksHierarchy

NAnt SDK Documentation - v0.91

NAnt.DotNet.Tasks Hierarchy

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.DotNet.Tasks.AssemblyLinkerTask
NAnt.DotNet.Tasks.CompilerBase
NAnt.DotNet.Tasks.CscTask
NAnt.DotNet.Tasks.JscTask
NAnt.DotNet.Tasks.VbcTask
NAnt.DotNet.Tasks.VjcTask
NAnt.DotNet.Tasks.DelaySignTask
NAnt.DotNet.Tasks.IlasmTask
NAnt.DotNet.Tasks.LicenseTask
NAnt.DotNet.Tasks.RegsvcsTask
NAnt.DotNet.Tasks.ResGenTask
NAnt.DotNet.Tasks.AssemblyInfoTask
NAnt.DotNet.Tasks.NDocTask
NAnt.DotNet.Tasks.ScriptTask
NAnt.DotNet.Tasks.CompilerBase.ResourceLinkage
NAnt.DotNet.Tasks.QualifiedResource
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
NAnt.DotNet.Tasks.AssemblyInfoTask.CodeLanguage
NAnt.DotNet.Tasks.RegsvcsTask.ActionType

See Also

NAnt.DotNet.Tasks Namespace


NAnt.DotNet.TypesHierarchy

NAnt SDK Documentation - v0.91

NAnt.DotNet.Types Hierarchy

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.Core.Types.FileSet
NAnt.DotNet.Types.AssemblyFileSet ---- System.ICloneable
NAnt.DotNet.Types.LibDirectorySet
NAnt.DotNet.Types.ResourceFileSet ---- System.ICloneable
NAnt.DotNet.Types.DataTypeCollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable
NAnt.DotNet.Types.EmbeddedResourceCollection ---- System.Collections.IList
NAnt.DotNet.Types.NamespaceImportCollection ---- System.Collections.IList
NAnt.DotNet.Types.ModuleSet
NAnt.DotNet.Types.WarningAsError
NAnt.DotNet.Types.AssemblyAttribute
NAnt.DotNet.Types.CompilerWarning
NAnt.DotNet.Types.Module
NAnt.DotNet.Types.NamespaceImport
NAnt.DotNet.Types.Package
NAnt.DotNet.Types.AssemblyAttributeEnumerator ---- System.Collections.IEnumerator
NAnt.DotNet.Types.CompilerWarningEnumerator ---- System.Collections.IEnumerator
NAnt.DotNet.Types.EmbeddedResource
NAnt.DotNet.Types.EmbeddedResourceEnumerator ---- System.Collections.IEnumerator
NAnt.DotNet.Types.ModuleCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
NAnt.DotNet.Types.ModuleEnumerator ---- System.Collections.IEnumerator
NAnt.DotNet.Types.NamespaceImportEnumerator ---- System.Collections.IEnumerator
NAnt.DotNet.Types.PackageEnumerator ---- System.Collections.IEnumerator
NAnt.DotNet.Types.ResourceFileSetEnumerator ---- System.Collections.IEnumerator
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
NAnt.DotNet.Types.AssemblyAttributeCollection
NAnt.DotNet.Types.CompilerWarningCollection
NAnt.DotNet.Types.PackageCollection
NAnt.DotNet.Types.ResourceFileSetCollection
System.ComponentModel.TypeConverter
System.ComponentModel.EnumConverter
NAnt.DotNet.Types.DebugOutputConverter
NAnt.DotNet.Types.DelaySignConverter
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
NAnt.DotNet.Types.DebugOutput
NAnt.DotNet.Types.DelaySign

See Also

NAnt.DotNet.Types Namespace


NAnt.MSNet.TasksHierarchy

NAnt SDK Documentation - v0.91

NAnt.MSNet.Tasks Hierarchy

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.MSNet.Tasks.IldasmTask
NAnt.MSNet.Tasks.ServiceControllerTask
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
NAnt.MSNet.Tasks.ServiceControllerTask.ActionType

See Also

NAnt.MSNet.Tasks Namespace


NAnt.NUnit1.TasksHierarchy

NAnt SDK Documentation - v0.91

NAnt.NUnit1.Tasks Hierarchy

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.NUnit1.Tasks.NUnitTask
System.MarshalByRefObject
NAnt.NUnit1.Tasks.RemoteNUnitTestRunner
NUnit.Runner.BaseTestRunner ---- NUnit.Framework.ITestListener
NAnt.NUnit1.Tasks.NUnitTestRunner
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
NAnt.NUnit1.Tasks.RunnerResult

See Also

NAnt.NUnit1.Tasks Namespace


NAnt.NUnit1.TypesHierarchy

NAnt SDK Documentation - v0.91

NAnt.NUnit1.Types Hierarchy

System.Object
NAnt.Core.Element
NAnt.NUnit1.Types.NUnitTest
NAnt.NUnit1.Types.IResultFormatter ---- NUnit.Framework.ITestListener
NAnt.NUnit1.Types.IResultFormatterEnumerator ---- System.Collections.IEnumerator
NAnt.NUnit1.Types.LogFormatter ---- NAnt.NUnit1.Types.IResultFormatter, NUnit.Framework.ITestListener
NAnt.NUnit1.Types.NUnitTestData
NAnt.NUnit1.Types.NUnitTestEnumerator ---- System.Collections.IEnumerator
NAnt.NUnit1.Types.PlainTextFormatter ---- NAnt.NUnit1.Types.IResultFormatter, NUnit.Framework.ITestListener
NAnt.NUnit1.Types.XmlResultFormatter ---- NAnt.NUnit1.Types.IResultFormatter, NUnit.Framework.ITestListener
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
NAnt.NUnit1.Types.IResultFormatterCollection
NAnt.NUnit1.Types.NUnitTestCollection
System.MarshalByRefObject
NUnit.Framework.TestResult
NAnt.NUnit1.Types.TestResultExtra

See Also

NAnt.NUnit1.Types Namespace


NAnt.NUnit2.TasksHierarchy

NAnt SDK Documentation - v0.91

NAnt.NUnit2.Tasks Hierarchy

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.NUnit2.Tasks.NUnit2Task

See Also

NAnt.NUnit2.Tasks Namespace


NAnt.NUnit2.TypesHierarchy

NAnt SDK Documentation - v0.91

NAnt.NUnit2.Types Hierarchy

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.NUnit2.Types.Categories
NAnt.NUnit2.Types.Category
NAnt.NUnit2.Types.NUnit2Test
NAnt.NUnit2.Types.CategoryEnumerator ---- System.Collections.IEnumerator
NAnt.NUnit2.Types.NUnit2TestEnumerator ---- System.Collections.IEnumerator
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
NAnt.NUnit2.Types.CategoryCollection
NAnt.NUnit2.Types.NUnit2TestCollection

See Also

NAnt.NUnit2.Types Namespace


NAnt.NUnit.TypesHierarchy

NAnt SDK Documentation - v0.91

NAnt.NUnit.Types Hierarchy

System.Object
NAnt.Core.Element
NAnt.NUnit.Types.FormatterElement
NAnt.NUnit.Types.FormatterData
NAnt.NUnit.Types.FormatterDataEnumerator ---- System.Collections.IEnumerator
NAnt.NUnit.Types.FormatterElementEnumerator ---- System.Collections.IEnumerator
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
NAnt.NUnit.Types.FormatterDataCollection
NAnt.NUnit.Types.FormatterElementCollection
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
NAnt.NUnit.Types.FormatterType

See Also

NAnt.NUnit.Types Namespace


AbstractCvsTask Hierarchy

System.Object
Element
Task
ExternalProgramBase
AbstractSourceControlTask
AbstractCvsTask
ChangeLogTask
CheckoutTask
CvsTask
ExportTask
RTagTask
TagTask
UpdateTask

See Also

AbstractCvsTask Class | AbstractCvsTask Members | NAnt.SourceControl.Tasks Namespace


NAnt.SourceControl.TasksHierarchy

NAnt SDK Documentation - v0.91

NAnt.SourceControl.Tasks Hierarchy

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.SourceControl.Tasks.AbstractSourceControlTask
NAnt.SourceControl.Tasks.AbstractCvsTask
NAnt.SourceControl.Tasks.ChangeLogTask
NAnt.SourceControl.Tasks.CheckoutTask
NAnt.SourceControl.Tasks.CvsTask
NAnt.SourceControl.Tasks.ExportTask
NAnt.SourceControl.Tasks.RTagTask
NAnt.SourceControl.Tasks.TagTask
NAnt.SourceControl.Tasks.UpdateTask
NAnt.SourceControl.Tasks.CvsPass

See Also

NAnt.SourceControl.Tasks Namespace


NAnt.SourceControl.TypesHierarchy

NAnt SDK Documentation - v0.91

NAnt.SourceControl.Types Hierarchy

System.Object
NAnt.Core.Element
NAnt.Core.DataTypeBase
NAnt.Core.Types.FileSet
NAnt.SourceControl.Types.CvsFileSet

See Also

NAnt.SourceControl.Types Namespace


NAnt.VisualCpp.TasksHierarchy

NAnt SDK Documentation - v0.91

NAnt.VisualCpp.Tasks Hierarchy

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.VisualCpp.Tasks.ClTask
NAnt.VisualCpp.Tasks.LibTask
NAnt.VisualCpp.Tasks.LinkTask
NAnt.VisualCpp.Tasks.McTask
NAnt.VisualCpp.Tasks.MidlTask
NAnt.VisualCpp.Tasks.RcTask
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
NAnt.VisualCpp.Tasks.ClTask.PrecompiledHeaderMode

See Also

NAnt.VisualCpp.Tasks Namespace


NAnt.VisualCpp.TypesHierarchy

NAnt SDK Documentation - v0.91

NAnt.VisualCpp.Types Hierarchy

System.Object
NAnt.Core.Element
NAnt.VisualCpp.Types.Library
NAnt.VisualCpp.Types.Symbol
NAnt.VisualCpp.Types.LibraryEnumerator ---- System.Collections.IEnumerator
NAnt.VisualCpp.Types.SymbolEnumerator ---- System.Collections.IEnumerator
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
NAnt.VisualCpp.Types.LibraryCollection
NAnt.VisualCpp.Types.SymbolCollection
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
NAnt.VisualCpp.Types.CharacterSet

See Also

NAnt.VisualCpp.Types Namespace


NAnt.VisualCpp.UtilHierarchy

NAnt SDK Documentation - v0.91

NAnt.VisualCpp.Util Hierarchy

System.Object
NAnt.VisualCpp.Util.ArgumentUtils
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
NAnt.VisualCpp.Util.BackslashProcessingMethod

See Also

NAnt.VisualCpp.Util Namespace


NAnt.VSNet.ExtensibilityHierarchy

NAnt SDK Documentation - v0.91

NAnt.VSNet.Extensibility Hierarchy

System.Object
NAnt.VSNet.Extensibility.IProjectBuildProvider ---- NAnt.Core.Extensibility.IPlugin
NAnt.VSNet.Extensibility.ISolutionBuildProvider ---- NAnt.Core.Extensibility.IPlugin

See Also

NAnt.VSNet.Extensibility Namespace


NAnt.VSNet.TasksHierarchy

NAnt SDK Documentation - v0.91

NAnt.VSNet.Tasks Hierarchy

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.VSNet.Tasks.SolutionTask ---- NAnt.Core.Extensibility.IPluginConsumer

See Also

NAnt.VSNet.Tasks Namespace


NAnt.VSNet.TypesHierarchy

NAnt SDK Documentation - v0.91

NAnt.VSNet.Types Hierarchy

System.Object
NAnt.Core.Element
NAnt.VSNet.Types.WebMap
NAnt.VSNet.Types.WebMapEnumerator ---- System.Collections.IEnumerator
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
NAnt.VSNet.Types.WebMapCollection
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
NAnt.VSNet.Types.UseOfATL
NAnt.VSNet.Types.UseOfMFC
NAnt.VSNet.Types.UsePrecompiledHeader

See Also

NAnt.VSNet.Types Namespace


NAnt.VSNetHierarchy

NAnt SDK Documentation - v0.91

NAnt.VSNet Hierarchy

System.Object
NAnt.VSNet.Configuration ---- System.IComparable
NAnt.VSNet.ConfigurationBase
NAnt.VSNet.ConfigurationSettings
NAnt.VSNet.VcConfigurationBase
NAnt.VSNet.VcFileConfiguration
NAnt.VSNet.VcProjectConfiguration
NAnt.VSNet.ConfigurationDictionary ---- System.Collections.ICollection, System.Collections.IDictionary, System.Collections.IEnumerable
NAnt.VSNet.ConfigurationDictionaryEntry
NAnt.VSNet.ConfigurationDictionaryEnumerator ---- System.Collections.IDictionaryEnumerator, System.Collections.IEnumerator
NAnt.VSNet.ConfigurationMap ---- System.Collections.ICollection, System.Collections.IDictionary, System.Collections.IEnumerable
NAnt.VSNet.ConfigurationMapEntry
NAnt.VSNet.ConfigurationMapEnumerator ---- System.Collections.IDictionaryEnumerator, System.Collections.IEnumerator
NAnt.VSNet.ProjectBase
NAnt.VSNet.ManagedProjectBase
NAnt.VSNet.CSharpProject
NAnt.VSNet.JSharpProject
NAnt.VSNet.VBProject
NAnt.VSNet.VcProject
NAnt.VSNet.ProjectBaseEnumerator ---- System.Collections.IEnumerator
NAnt.VSNet.ProjectEntry
NAnt.VSNet.ProjectEntryEnumerator ---- System.Collections.IEnumerator
NAnt.VSNet.ProjectSettings
NAnt.VSNet.ReferenceBase
NAnt.VSNet.FileReferenceBase
NAnt.VSNet.AssemblyReferenceBase
NAnt.VSNet.ManagedAssemblyReference
NAnt.VSNet.VcAssemblyReference
NAnt.VSNet.WrapperReferenceBase
NAnt.VSNet.ManagedWrapperReference
NAnt.VSNet.VcWrapperReference
NAnt.VSNet.ProjectReferenceBase
NAnt.VSNet.ManagedProjectReference
NAnt.VSNet.VcProjectReference
NAnt.VSNet.Resource
NAnt.VSNet.SolutionBase
NAnt.VSNet.GenericSolution
NAnt.VSNet.VcArgumentMap
NAnt.VSNet.WebDavClient
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
NAnt.VSNet.ProjectBaseCollection
NAnt.VSNet.ProjectEntryCollection
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
NAnt.VSNet.VcConfigurationBase.ExpansionHandler
System.MarshalByRefObject
NAnt.VSNet.ReferencesResolver
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
NAnt.VSNet.BuildResult
NAnt.VSNet.ManagedOutputType
NAnt.VSNet.ProductVersion
NAnt.VSNet.ProjectLocation
NAnt.VSNet.ProjectType
NAnt.VSNet.VcArgumentMap.ArgGroup
NAnt.VSNet.VcProjectConfiguration.ConfigurationType

See Also

NAnt.VSNet Namespace


NAnt.Win32.FunctionsHierarchy

NAnt SDK Documentation - v0.91

NAnt.Win32.Functions Hierarchy

System.Object
NAnt.Core.FunctionSetBase
NAnt.Win32.Functions.CygpathFunctions

See Also

NAnt.Win32.Functions Namespace


NAnt.Win32.TasksHierarchy

NAnt SDK Documentation - v0.91

NAnt.Win32.Tasks Hierarchy

System.Object
NAnt.Core.Element
NAnt.Core.Task
NAnt.Core.Tasks.ExternalProgramBase
NAnt.Win32.Tasks.AxImpTask
NAnt.Win32.Tasks.RegAsmTask
NAnt.Win32.Tasks.TlbExpTask
NAnt.Win32.Tasks.TlbImpTask
NAnt.Win32.Tasks.ReadRegistryTask

See Also

NAnt.Win32.Tasks Namespace